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Licensing Agreement and Warrantee Disclaimer 

Read carefully before registering this software. By registering this software, you indicate your acceptance of the 
following license agreement and warranty disclaimer. If you do not choose to accept this license agreement and warranty
disclaimer, simply remove this software from your computer. 

ANDOVER ADVANCED TECHNOLOGIES LICENSE

1. GRANT OF LICENSE.  Andover Advanced Technologies, Inc. grants you the right to use one copy of the enclosed 
Andover Advanced Technologies product (the “SOFTWARE”) on a single terminal connected to a single computer (i.e., 
with a single CPU). You may not network the SOFTWARE or otherwise use it on more than one computer or computer 
terminal at the same time.

2. COPYRIGHT.  The SOFTWARE is owned by Andover Advanced Technologies, Inc. and is protected by United States
copyright laws and international treaty provisions. Therefore, you must treat the SOFTWARE like any other copyrighted 
material (e.g., a book or musical recording) except that you may either (a) make one copy of the SOFTWARE solely for 
backup or archival purposes, or (b) transfer the SOFTWARE to a single hard disk provided you keep the original solely 
for backup or archival purposes. You may not copy the written materials accompanying the SOFTWARE.

3. OTHER RESTRICTIONS.  You may not rent or lease the SOFTWARE. You may not reverse engineer, decompile, or 
disassemble the SOFTWARE. The registration fee for the SOFTWARE is non-refundable.

DISCLAIMER OF WARRANTY

THIS SOFTWARE AND MANUAL ARE SOLD “AS IS” AND WITHOUT WARRANTIES AS TO PERFORMANCE 
OR MERCHANTABILITY. THE SELLER’S SALESPERSONS OR EMPLOYEES MAY HAVE MADE STATEMENTS
ABOUT THIS SOFTWARE. ANY SUCH STATEMENTS DO NOT CONSTITUTE WARRANTIES AND SHALL NOT 
BE RELIED ON BY THE BUYER IN DECIDING WHETHER TO PURCHASE THIS PROGRAM.

THIS PROGRAM IS SOLD WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES WHATSOEVER. BECAUSE 
OF THE DIVERSITY OF CONDITIONS AND HARDWARE UNDER WHICH THIS PROGRAM MAY BE USED, NO 
WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. THE USER IS ADVISED TO TEST THE 
PROGRAM THOROUGHLY BEFORE RELYING ON IT. THE USER MUST ASSUME THE ENTIRE RISK OF 
USING THIS PROGRAM. ANY LIABILITY OF SELLER OR MANUFACTURER WILL BE LIMITED 
EXCLUSIVELY TO PRODUCT REPLACEMENT.
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Welcome to VideoCraft! 
The magic of Hollywood never ceases. Spectacular aquatic worlds have been brought to life, long lost starlets have been 
resurrected, and incredible transmogrifications bring everyday objects to life. Big budget studios spend millions to make 
the impossible happen. From the fluid transformations of "morphing", to Hollywood's long time friend, "blue screening",
to advanced texture mapping and compositing effects, a complete palette of amazement makers can be found in 
VideoCraft. Contained in VideoCraft are millions of special effects that are waiting to be discovered.

In this manual
This printed manual contains information on getting started with VideoCraft. Following a brief overview, we’ll go 
through most of VideoCraft's functions. Then you'll be ready to create stunning special effects on your PC.

Windows 95 versus Windows 3.1
There are two versions of the VideoCraft GIF Animator available. One is a 32-Bit application that is designed for use on 
the Windows 95 operating system. The second version is a 16-Bit application that is optimized for use under Windows 
3.1. We do not recommend running the 16-Bit version of VideoCraft on Windows 95. Besides, you’ll want to take 
advantage of the speed of the 32-Bit version of VideoCraft.

The screen shots used in this manual were taken using the Windows 95 version of VideoCraft. The appearance of these 
screens in Windows 3.1 will appear slightly different.

General Overview
VideoCraft creates special effects from various types of source material. Images stored in many popular formats, as well 
as video clips stored in the AVI file format can be used in VideoCraft. If VideoCraft does not directly support the format 
you need, its screen capture utility can be used to import any image you want.

Once the source materials have been loaded, they can be edited. VideoCraft has many image editing functions built into 
it, including: cropping, scaling, framing, and rotating. Color correction tools including Contrast and Brightness as well as
basic filter effects are provided. Video files are edited by setting in and out points and sampling options.

After basic editing, the special effects are created. The Project Editor is the command center of VideoCraft. There are 
areas for the start and end source materials. The seven effects, Colorize, Distort, Morph, Overlay, Stylize, Transition and 
Warp, are chosen from a drop down list. Up to three effects can be applied simultaneously. The effect's Editor, Options, 
and  Preview window are only a mouse click away.

THE VIDEOCRAFT PROJECT EDITOR

Sequential effects can be chained together using the Storyboard. Used in combination with the video editing options, the 
Storyboard can be used to perform basic non-linear digital video editing.

With the editing complete, the finished project can be saved and rendered. VideoCraft saves its projects as VPR files 
which can be reloaded and edited at a later time. GIF Animation files need to be rendered. Following their creation, they 
can be viewed in an internet browser, or embedded in HTML or JAVA code. 
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Tutorial 1 - Loading and Rendering an Existing VideoCraft Project
The purpose of this tutorial is to introduce you to VideoCraft Project and GIF Animations. VideoCraft Project files, 
which take up relatively little disk space, can be loaded, edited, and saved again. 

To load a pre-existing VideoCraft Project and create a GIF Animation:
1. Open VideoCraft. The Project Editor will be on your screen.

2. Notice the row of buttons on the top of the Project Editor. The first button, the Open Project button, allows you to 
open VideoCraft Project (VPR) files. It is important to note that VPR files are the only files that can be loaded with 
this button. Image and video files are loaded elsewhere. Click on the Open Project button in the Project Editor 
Toolbar.

THE OPEN PROJECT BUTTON

3. Select a VideoCraft project from the Open dialog box that appears. VideoCraft Projects have the extension VPR. If 
no VideoCraft Projects are showing, use the ‘Look In’ feature of the Open dialog box to change to the folder that 
VideoCraft has been installed in -- typically C:\VidCraft.

Please note that during the opening of a project, all source materials for that project (images and video clips) are 
loaded into the main work area of VideoCraft. Also notice that each window in the work area has a title bar. The 
current window, whether it is an image, video clip, or the Project Editor, has a different color title bar (usually dark 
blue). The menu items at the top of the screen change depending on the window that is current. For example, 
because the Filter menu can only be applied to image windows, it is not shown when the Project Editor is current.

By default, the Project Editor “floats” above all source materials. This setting can be changed in the Preferences 
section (Second from the right on the Project Editor tool bar) of the Project Editor.

4. Click on the Create Video button of the Project Editor, which by default creates a GIF Animation. Give the video a 
filename, press OK, and wait as the video is generated, based on the information contained in the VPR file.

THE CREATE VIDEO BUTTON

5. Once the GIF Animation has been created, it can be loaded and played in an Internet Browser that supports the 
playback of GIF Animations. Netscape’s Navigator and Microsoft’s Internet Explorer are two popular browsers that 
support GIF Animations.
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Tutorial 2 - Creating a Morph Movie
Morphing is the easiest way to create compelling digital video from still images; let's go through the process. Suppose 
you are creating a web page for an automobile manufacturer. The concept is to show the power of a sports car, combined 
with the space of a minivan. Morphing is a great way to send this message, so we'll morph the sports car into a minivan.

1. Open VideoCraft. If you are already in VideoCraft, select New... VideoCraft Project  from the File menu in the 
upper left hand corner of your VideoCraft Window.

2. When morphing, start and an end materials are required. Notice in the Project Editor the two blank Windows, 
labeled Start and End. Under each Window, you will see a drop down list. Once an image is chosen for the start and 
end images, <<No Image>> will be replaced with the file name of the image that you are working with. To the right 
of both drop down lists, you will find a small file folder button. Click on the one under Start Image.

THE OPEN IMAGE BUTTON

3. Now you will be opening a start image. In the Open Image dialog box, you will see where it indicates "Files of 
Type". Select "JPG - JPEG JFIF". This will allow you to load images stored with the extension .JPG into 
VideoCraft. You may want to take a moment to note the other formats that can be loaded.

4. Locate the file SMLCAR2.JPG in your VideoCraft directory. Click on it and press OK to load it as your start image
in the Project Editor. SMLCAR2 is an image of a sports car.

5. Next, we need to load an end image. Click on the Open End Image button underneath the End Image window. 
Choose BIGCAR2.JPG and press OK.

6. The Project Editor now appears with a sports car in the Start window and a minivan in the End window. Note that 
Morph has been chosen as the default in the Effect Type List. VideoCraft contains seven effects: Colorize, Distort, 
Morph, Overlay, Stylize, Transition, and Warp. For now, we'll stick to Morphing.

7. Click on the Edit button. This will open the Morph/Warp Editor. Again, the start image is located on the left and the
end image is located on the right.

8. Notice the tool bar located to the left of both images. Each Button has a specific purpose:

a. The top button places points onto the images. What points do will be explained below.
b. The second button moves points. The currently selected point can be moved by clicking and dragging, pointing 

and clicking with the right mouse button, or with the cursor keys.
c. The third button erases points.
d. The fourth button allows you to zoom in and out upon the image. When this button is selected, click on the 

image to zoom in, shift-click (hold down the shift key while clicking with the left mouse button) on the image 
to zoom out.

e. The bottom button is for customizing the color scheme of the points.
9. Note that this Window can be re-sized and “maximized” - just like most windows. By expanding the window, more 

of each image is shown.

10. Using your mouse, point to a spot on the bottom of the rear bumper of the sports car in the start image. Click with 
the left mouse button. A point will appear on the image and a corresponding point appears on the end image.

11. Now move the cursor over to the end image and position it over the active (red) point you just placed. Click and 
drag the point to the bottom of the rear bumper of the minivan.

12. Place and move points in a similar manner in the following locations:

a. Center of rear tire
b. Center of front tire



c. Bottom of front bumper
d. Top of front bumper
e. Front of hood
f. Bottom of windshield
g. Top of windshield
h. Top of back of car
i. Top of rear bumper
Your finished morph point placements should look like this:

THE COMPLETED MORPH POINTS

13. Now you've placed all your 'Married Point Pairs'. We call them Married because they are linked together. Each point
on the start image has a representation on the end image. By placing Married Points, you link the similar features of 
the two objects together. Once you are satisfied with your point selections, press OK.

14. Preview the video by using the Preview button on the Project Editor, seventh from the left, that resembles a 
Magnifying Glass. Click on it now.

THE  PREVIEW BUTTON

15. The Preview window appears. Use the percentage slider to look through your video's frames. Notice the other 
buttons in the Preview window. The Up Arrow updates the image, which is useful when editing a morph. The 
second button saves the image shown to a file; this is handy for using still VideoCraft images with other software 
packages. The third button saves the image to a new VideoCraft Window, which allows you to reuse or print the 
image in VideoCraft.
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THE PREVIEW WINDOW

16. If you want to save your VideoCraft Project, which consists of the points and images you have selected, click on the
Save Project button in the Project Editor. It is the second button from the left. Save the file with the extension VPR. 
Note that you are not creating the finished video in this step, you are merely saving the points you have placed, so 
you can edit the points (or further refine this project) sometime later.

17. When you are satisfied with your preview and point placement, click on the  Create Video button as we did in the 
previous tutorial. Give the GIF Animation a filename with the extension GIF.

THE CREATE VIDEO BUTTON

18. Once the video is created, open the GIF animation in your browser to play your video!

Although there are a number of steps involved, morphing is very easy. In fact, all of VideoCraft's features are powerful, 
yet intuitive and easy to use. As you dig into VideoCraft, you'll see just how easy it is to create incredible digital video 
with your PC. Welcome to the world of digital video special effects!



The Next Step... More Special Effects
We've started with Morphing, now we’ll explore the other effects in VideoCraft.

The Colorize Effects
The Colorize features in VideoCraft allow you to apply 19 special effects directly to images and video clips. You can use
the Old Movie effect to make any video clip look like an old black and white movie. You can use the Contrast effect to 
add or decrease the contrast of a video clip as you would with a TV set.

 
THE COLORIZE EDITOR

Tutorial 3 - Using the Colorize Editor
Let's apply the old time movie effect to a video clip. We also want the effect to fade in linearly, as the video progresses. 
This is very easy to do with the Colorize effect.

1. Start VideoCraft. If you already have VideoCraft running, choose File / New... Project. This will clear VideoCraft of
any existing Projects.

2. Locate the Open Start Image button in the Project Editor. This button, a small file folder, is located under the start 
image window. Press it to access the Open Image dialog box.

3. In the Open Image dialog box, you will see where it indicates "Files of Type". Select "AVI - Video for Windows". 
This will allow you to load video clips into VideoCraft. In VideoCraft, video clips are treated exactly the same as 
images, except that video clips change over time.

4. Locate the file CHRIS26.AVI in your VideoCraft directory. Click on it and press OK to load it as your start image 
in the Project Editor. CHRIS26 is a video clip of Chris spinning on a stool in front of a Blue Screen. The Colorize 
Effect does not require an End image. 

5. In the Project Editor, choose Colorize from the Effect Type drop-down list. Press Edit to enter the Colorize Editor.

6. On the left of the editor there are 19 different Colorize effects. Since we want to apply the Old Movie effect, choose 
it from the list.

7. Notice that the preview built into the Colorize Editor will indicate how the effect will transpire. Adjust the slider 
from left to right, to see how the effect will change over time. In this case, the Old Movie effect will fade in as 
Chris spins. Press OK.

8. Now lets make this into a movie. Press Create Video to save this movie as an GIF Animation. Give it the filename 
OLDMOVIE.GIF and press OK. Once the video is finished rendering, access it through your Internet browser. 
Chris will spin while the Old Movie effect fades in.

Holding an Effect At a Constant Rate
Suppose we wanted to have the Old Movie effect be applied evenly throughout the whole clip , instead of faded in. We 
can do this using the Effect Options. 
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(Continued from the above tutorial)
9. In the Project Editor, press Options. In the lower right hand corner of this screen, you will notice where it says 

Effect Percentage. This control is used to indicate how the effect changes over time. When set to variable, the effect
changes over a period of time. If set to constant, the effect will remain at a constant level. Since we want to have the
Old Movie effect applied evenly, set this control to Constant, 100%. This will apply Old Movie at full strength 
(100%) through the entire clip. Press OK.

THE EFFECT OPTIONS DIALOG BOX

10. Repeat Step 8 to render the new version of this movie. 

You will notice that some of the Colorize effects, such as Contrast, Noise, and Trace Edges have slider controls in them, 
allowing precise adjustment of the effect.

The Colorize effects can be used in combination with other Effect Types to create truly beautiful results. All Colorize 
effects work with alpha channels, allowing you to selectively colorize only certain parts of the source material. An 
example of this can be found in Tutorial 11 - Using the Image/Mask Menu to Construct Basic Alpha Channels.  It is 
also useful to know that you can use several Colorize effects in a single clip. You can boost the contrast of a clip with the
Contrast effect, you can then use the Blur effect, and finally you can apply the Old Movie effect. You can do all this in a 
single clip using the multiple effects. Check out Tutorial 9 - A Simple Example of Multiple Effect Layers for more 
details.

The Stylize Effects
The 30 Stylize effects are similar to the Colorize effects and are used in the same way. However, controls are added to 
reverse and cycle each effect. The 30 Stylize effects are best described by the following chart:

Natural Media Textures Blur Altering Shapes
Charcoal Bricks Center Blur Frazzle Pointillize
Color Pencil Bumps Glass Kaleidoscope Solarize
Contours Crosshair Motion Blur Mosaic Rain
Dark Strokes Sampler Radial Blur Reflection Smudge
Find Edges Steel Plate Shake Stamp Triangles
Fresco Tiles
Posterize Weave
Solarize
WaterColor

Tutorial 4 - Using the Stylize Effects
This tutorial will introduce you to the Stylize effects the Storyboard.

1. From the Project Editor in VideoCraft, load the WEASEL.JPG file into the Start window. Do this by clicking on the 
small white folder button at the bottom right side of the Start window.  Select JPG as the type of file to be opened 
and load WEASEL.JPG.



2. Open your Storyboard by clicking on the fifth button in the Project Editor, it looks like a film strip.  When you have
done this you should see the Storyboard with one clip, and that clip should have a picture of Weasel the cat 
displayed. More information about using the options in the Storyboard and another tutorial can be found in the 
section of this manual titled, Using the Storyboard.

THE STORYBOARD BUTTON

3. Change the Effect Type to Stylize. It is in the Type list located just below the Start window.

4. Duplicate this clip by clicking on the New Clip button, it is located between the Start and End windows and looks 
like a tilted film strip with an arrow.  Click on this twice to add two more clips.  These clips will be displayed in the 
Storyboard.

THE CREATE NEW CLIP BUTTON

5. Double click on the first clip in the Storyboard to select this clip. When you select a clip a red box will highlight it. 
Click on the Edit button to bring up the list of Stylize filters, choose Charcoal from the list of effects.  Use the 
slider bar under the Preview window in Charcoal to preview how the effect changes over time. 

6. There are four choices for applying the Direction of Stylize effects in a clip: Forward, Backward, Cycle, and 
Reverse Cycle. Forward starts an effect at 0% and gradually increases it over a clip until getting to 100%. Backward
does the opposite, it starts at 100% and decreases to 0%. Cycle starts with an effect at 0%, reaches 100% in the 
middle of a clip, and decreases to 0% by the end of the clip. Reverse Cycle is Cycle’s opposite, it starts with an 
effect at 100%, decreases to 0% in the middle of a clip, and goes back to 100% by the end of the clip. You can 
override these settings by using the Color Shift and Effect Percentage options located in the Effect Options box on 
the Project Editor. For instance you can set a Stylize filter to be constant across a clip by setting the Constant value 
to a desired percentage. 

Press OK to exit the Stylize Editor.

7. Double click on the second clip to select it, click Edit and select Triangles. Notice that there are three parameters 
that you can adjust in Triangles: Color, Number, and Randomness. The Color parameter adjusts the background 
color of the triangles used in the effect. You can select any of 16 Million colors. Number refers to the number of 
triangles used in the effect. Move the slider bar all the way to the right and notice what this looks like with 
maximum triangles used. Now move the slider all the way to the left and view the picture with fewer triangles.  
Now adjust the Randomness slider and  see what this picture looks like with more and less randomness in the 
placement of the triangles. When finished, Press OK.

8. Double click on the third clip to select it, click on Edit and select Kaleidoscope. Select Backward for the Direction. 
Notice that the Kaleidoscope effect starts at 100% and decreases to 0% in the Preview window. Press OK.

9. You can now render this project by clicking on the Create Video button in the Project Editor and see what a Stylize 
effect looks like in motion.  Remember that not only can you apply Stylize effects to AVI video clips, but also to 
still images to create other still images. Use the Save image to file button in the Project Editor's Preview window to 
create still images.

The Transition Effects
The VideoCraft Transition Editor provides more than 256,000 combinations of video transitions. Besides providing a list 
of popular presets, its WYSIWYG interface allows you to create stunning scene changes with ease. 
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THE TRANSITION EDITOR

To access the Transition Editor:
1. Load a start image or video clip into the Project Editor.

2. Load an end image or video clip of the same dimensions as the start material. When transitioning to a solid color 
(such as a fade to black), an end image / video is not required.

3. Select Transition from the list of Effect Types in the Project Editor.

4. Press Edit.

Direction Arrows
The heart of the Transition Editor lies in the Direction Arrow buttons. The Direction Arrows specify the direction that the
image or video clip will move as time passes. The left set of arrows control the transition direction for the Start image, 
the right set of arrows control the direction of the End image. For example, if only the 'up' arrow is specified for the Start
image, the Start image will move up, revealing the End image. If both the up and down arrow are specified, it will break 
into two pieces; the top half will transition up and the bottom half will transition down. This is the general method for all
of the Direction Arrows. If you specify all eight direction arrows for a video clip, the clip will break into eight pieces and
each will transition off of the screen in a radial direction outward. The arrows work the same for the End clip on the right
hand side except that clips move from outwards to inwards.

The Faders
Faders are additional effects that can be added to the incoming and outgoing images. The Faders are Solid, Fade, Reverse
Fade, Melt, Random, and Alpha.

Choosing Solid is the same as not choosing any fader.

The Fade fader causes a gradual and continuous color change to occur during the transition. It is commonly known as a 
dissolve.

The Reverse Fade causes the fade to operate backwards. This is usually used with one image to fade from a solid color. 
See Background Color, below.

Melt causes a fade based on the luminance values of the image or video clip. This causes the lighter parts of the source 
material to fade in first followed by the darker portions.

Random adds speckles of color that will either be the selected background color, or the color of the image beneath it, 
depending on the transition.



The Alpha fader is a very powerful feature and can produce wonderful transitions. The Alpha fader is used on 32-bit start
images to cause the opaque part of the image to fade before the transparent part. Using this technique you can design 
your own transitions (checkerboards, gradient, circular, etc.). To use the Alpha channel fader it is necessary to select 
Alpha for both the Start and End image faders. The Start image must be a 32-bit image. For a discussion and explanation 
of Alpha channel images refer to tutorials 10-15, paying close attention to Tutorial 12 - Making Custom Faders Using 
32-Bit Images.

The Background Color
The Background Color option allows you to choose background colors for transitions. These colors will also modulate 
some of the Faders. For instance, if you choose a background color of green and choose Random as a fader for a 
transition, the random speckles of color will appear green. If you only specify a start image and choose Reverse Fade, the
image will fade from a shade of green into the start image.

The Transition List
The Transition List on the leftmost side of the Transition Editor lists the names of the most commonly used transitions. 
To use a particular transition that is listed, simply select a transition from the list.

The Overlay Effects
The Overlay Effect is used when one image or video clip is to be superimposed onto another. VideoCraft provides six 
different ways to create overlays: Blue Screening, Chroma Keying, Luminance Keying, Alpha Channel Compositing, 
Texturizing, and Text overlays.

THE OVERLAY EDITOR

When using the Overlay Effect, the Start and End materials must be the same size.

Color Keying
The Chroma Key, Blue Screen, and Luminance Key effects are a family of similar effects. Each effect allows you to 
select a range of colors or brightness values and make those colors transparent to a background image. In other words, 
those colors in the Start image become transparent and the End image shows through. Blue Screen is the most commonly
used effect - widely used in television and films. Typically, an actor is filmed against a blue background. The film 
editing process removes the blue background and substitutes an exciting picture like a view over a cliff. The actor wasn't 
filmed hanging over a cliff, the editing process made it look that way. VideoCraft can do exactly the same effect using 
the three color keying effects. The differences in the effects are listed:

Blue Screen allows you to key on a range of only blue colors and pass through shadows.

Chroma Key allows you to 'key' on, or select any color.

Luminance Key allows you to key on a range of luminance values, or brightness values instead of colors.
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The color key features in VideoCraft are extremely powerful and very flexible. It is possible to blue screen an AVI clip 
onto another AVI clip. This means that you could have a moving actor blue screened onto a moving background. You 
can also mix still bitmaps with video clips. Don't forget that by using multiple layers  of effects in a single clip you can 
composite four scenes with any three effects. It is possible to use all three color key effects in the same clip. For the 
exciting details, refer to Tutorial 9 - A Simple Example of Multiple Effect Layers.

Blue Screening 
The Blue Screen effect works only with blue colors. Three controls are available to adjust the key values of the blue 
color. That is, which shades of blue become transparent. The Lightness control allows you to set the lightest value of 
blue to become transparent and the Darkness control allows you to set the darkest value to become transparent. These 
controls allow you to set a light point and a dark point. Any shades of blue between these points become invisible. Any 
shades outside these values will remain visible in the resulting image of the Start and End images. The Shadow control 
allows a shadow in the blue screen to pass through and become a shadow in the resulting overlay. There must be a 
shadow in the blue color on the blue screen for this to function properly.

A common trick to producing high quality morphs is to film the objects to be morphed against a blue screen. After the 
morph is constructed, it is superimposed against a new background. This way, the background does not interfere with the
morphing process. This effect can be duplicated exactly by combining morphing and blue screening with multiple layers 
of effects. 

Tutorial 5 - Creating a Blue Screen Overlay
Suppose you had a picture of a car that was filmed against a blue backdrop that you wanted to place against an image of 
a setting sun. This is easy to do with VideoCraft.

1. Start VideoCraft. If you already have VideoCraft running, choose New... Project  from the File menu.

2. In the Project Editor, open BLUECAR1.JPG as your start image. For your end image, load SUNSET.JPG.

3. Please note that we've already defined the blue screen for this image, BLUECAR1.JPG. Ideally, one would take the
picture of the object against a blue screen. However, you can get acceptable results by painting the background blue 
on the image. When compositing video, it is highly recommended that the object be filmed against a blue screen, 
since it is very time consuming to hand paint every frame with a blue background. 

4. Select Overlay as your Effect Type and press Edit.

5. You will notice that Blue Screen has defaulted in the Overlay Editor. A preview shows the output that will be 
generated - in this case, the car against the sunset. Lightness, Darkness and Shadow controls allow you to adjust the 
effect. When finished, press OK.

6. Lastly, create the video and play it.

Chroma Keying
The Chroma Key effect is more powerful than the Blue Screen effect because it can key on any color. It is a more general
purpose tool and can do anything the Blue Screen effect can except transfer a shadow. Because it can do more things the 
controls are a little different. The biggest difference is the addition of the Eyedropper tool. This tool allows you to 
sample a key color in either the Start or End image. To use the eyedropper to select a color key you simply click on a 
part of the image. Once you have sampled this color you can adjust it further with the other controls. The Chroma tool 
allows you to select the key color manually. The Tolerance control allows you to adjust the range of the colors to key on.
If the tolerance is set to very small, or all the way left, only a single color value can become transparent. If the tolerance 
level is very large, or all the way to the right, all colors can pass through and the complete Starting image will be 
transparent. The Darkness tool will also adjust the range of colors that are key colors. 

Luminance Keying



The Luminance Key effect allows you to key on a range of luminance values, or brightness, instead of actual colors. This
is especially useful for keying on white, black, and shades of gray. It is also good for keying on pictures that have several
colors of the same luminance. The Eyedropper tool will allow you to automatically select a starting luminance directly 
from an image. The Minimum control will set the darkest luminance value. The Maximum control will set the brightest 
luminance value. When using the eyedropper, the left mouse button selects the minimum value and the right mouse 
button selects the maximum value.

Note that blue screening, chroma keying, and luminance keying depend on chroma and luminance of the source material.
Certain lossy compression algorithms reduce or remove this data from the images or videos being compressed. Thus, it 
may be difficult to get good results from materials that have been heavily compressed. For example, JPEG compression 
(including Motion JPEG) can cause these sorts of problems. To reduce this phenomenon, be sure to keep your 
compression quality settings as high as possible.

Alpha Channel
Alpha channel images can be used to create very interesting see-through and semitransparent effects. An alpha channel 
image is simply a 24-bit image with extra information, called a channel. Since an alpha channel uses 8 bits of 
information, an alpha channel image is also called a 32-bit image. The Alpha channel determines the transparency of the 
image with respect to other images, specifying 256 levels of transparency varying from completely transparent to 
completely opaque. An alpha channel image with the alpha channel set completely off would look exactly like a normal 
image. An alpha channel set completely on would be completely transparent to any background image. The trick to using
alpha channels is deciding what becomes transparent. 

Alpha channel images can be created in VideoCraft using the Colors/32-bit tool with the Image/Mask tool or specified in
the Effect Options of the Project Editor.

A complete discussion of Alpha Channels can be found in tutorials 10-15.

Texturize
The Texturize overlay takes the texture of the start image and applies it to the end image. This can be useful for creating 
imprints and other nifty effects. 

Text Overlay
The Text Overlay feature in VideoCraft allows titling of both video clips and images with TrueType and PostScript fonts.
When using 24-bit source material, the font’s color can be any of 16 Million colors. The interface allows real-time color 
changing, and font adjustment on the screen. 

To access the Text Overlay tool, place a video clip or bitmap in the Start image of the Project Editor, remove any image 
in the End position. Select the Overlay effect and click on Edit. The Text effect appears with the Style, Alignment, Color 
and Text box options. The Style option allows you to choose from any installed font styles and sizes. The Alignment 
option allows you to position your text at one of several preset areas on the image. It also allows you to choose between 
right justification, centered, or left justification. The Color option allows you to select the color of your text. The Text 
box is where you type in the text that you wish to appear on the image. The text overlay will update the image with each 
keystroke. Text length is limited to one line of text.

The start image can be shown through the text by checking off the "Invert Text" option. When Alpha Channels are being 
used, additional options for applying text to the alpha channel are provided.

Text overlay can be used to create some very interesting clips when used with other VideoCraft effects. For instance, you
can overlay blue text onto a video clip or bitmap and use the Blue Screen effect to make each letter invisible to a video 
clip that plays behind each letter. You can get very fancy with this effect by using the Distortion effects such as Zoom In,
Zoom Out, and Rotate on the text. You can also create a tilted text effect by first rotating the bitmap, overlaying the text, 
and rotating it back. Always use high quality to preserve the image and text quality.
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The Text Overlay tool is only available when one image is selected in the Project Editor.



The Distortion Effects

Video Distortions
The VideoCraft Distortions provide a great way to add truly unique effects to any video clip or bitmap. There are 31 
distortions to choose from, each can be rendered in low, medium, and high quality. Low quality renders very quickly and
is good for previewing the effects. High quality is recommended for studio and broadcast videos. Click on the Video 
Parameters button to access the Quality setting in the Project Editor.

THE DISTORTION EDITOR

Several distortions can be combined in a single clip to create some really unbelievable effects. For example, the Rotation
and Zoom In effects can be combined to create a spinning and growing effect. Rotation can be combined with Ripple on 
an Alpha Channel to make some really mind blowing pictures. 

Tutorial 6 - Using the Distortion Effects
Let's create a simple distortion effect on an image. While we're at it, we'll take a look at the Quality Settings in Video 
Parameters.

1. Start VideoCraft. If you already have VideoCraft running, choose Project, New from the File menu.

2. In the Project Editor, load OBOE.JPG as your start image.

3. Choose Distort as your Effect Type and press Edit.

4. A list of 31 pre-defined distortion effects is shown on the left hand side of the Distortion Editor. A number of 
settings appear on the right. Choose the Wave distortion effect and press OK.

5. Rather than creating a Video, let's use the Preview window to examine the Wave distortion. Open the Preview 
window by pressing its button in the Project Editor (or choose it from the View Menu.)

6. Use the Percentage slider to see how the effect occurs. The image starts undistorted, then ends at full distortion. 
Close or minimize the Preview window.

7. Suppose we wanted to start with a distorted image, and then end up with the original image. Press Edit in the Project
Editor. Engage Reverse Start Effect and press OK. Now access the Preview window again. The desired effect has 
been achieved, the image starts at full distortion, then undistorts into the original image.

8. Now let's use the distortion effect on two images to create a cross fade while the distortion occurs. Open 
GRLBRN.JPG as the end image. Press Edit to access the Distortion Editor. 
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9. Notice the three new percentage controls on the right: Source, Merge, and Destination. These settings control cross 
fading during the distortion. Set Source to 33%, Merge to 34%, and Destination to 33%. Disengage Reverse Start 
Effect and turn on Reverse End Effect. Press OK and Preview.

10. As you slide the Percentage from left to right you will notice that the effect starts with OBOE.JPG, ends with 
GRLBRN.JPG, and waves in the middle. Why? We specified the Source (In this case, Oboe) to distort for 33%. 
Then a cross fade (or merge) occurs for the next 34%. Finally the last 33% is GRLBRN undistorting itself. Thus, the
percentage settings control how the fade will occur. The Reverse Start and Reverse End settings control the direction
the effect is going to occur.

11. Go back to the Project Editor. Access the Video Parameters button; it's the fourth from the left and resembles a 
movie camera with two arrows pointing right. Once pressed, the right hand side of the Project Editor will open.

THE VIDEO PARAMETERS BUTTON

12. On the bottom right of the Video Parameters section you will notice a Quality setting. This setting controls the 
quality of VideoCraft's output. Low quality renders quickly but may yield pixelated results. Rendering at medium 
quality takes longer, but yields better results. High quality rendering takes the longest, and is best suited for final 
production. Set Quality to high and update the Preview window (using the arrow button). Notice how much better 
the images appear. 

Some things to know about distortion effects:
1. The Distort effect can be used with either one image (load only a Start image) or two images (load Start and End 

images).

2. The Start and End percentages control when the Distort clip will begin and end recording to the output file.

3. If two images are being used, controls are provided for specifying different phases of the video: Source, Merge, and 
Destination. These controls allow sophisticated transition effects to be achieved.

4. Controls are also available for dictating the direction of the distortion:

Forward (undistorted image => distorted image) 

or Reverse (distorted image => undistorted image).

5. Distortion effect names followed by a [F] are particularly computationally intensive and will be slow on machines 
without a floating point co-processor.

6. All distortion effects can be rendered at each of three speed and quality settings: Low, Medium, and High. Low 
quality renders four times faster than Medium, and 16 times faster than High quality. Low quality is best suited to 
idea testing. High quality gives substantially better image detail and is best suited for a final render. The quality 
settings can be found in the Project Editor’s Video Parameters.

The Warp Effect
Imagine placing an image on a sheet of rubber and having the ability to stretch that image in any way. Warping allows 
you to do this, to stretch an image (or video clip).

Warps begin and end with different versions of the same image, therefore, only a Start image needs to be loaded. 
However, an End image may be loaded for use as a reference image (see below, Tips on Positioning Warp Point Pairs).



Tutorial 7 - Creating a Warp
Performing a warp is very similar to morphing; points are placed on an image and adjusted. Suppose we wanted to 
illustrate a smart child. All we need to do is warp the child's head into an unnaturally large size. Let's try this with 
VideoCraft. 

1. Open VideoCraft. If you are already in VideoCraft, select File / New... Project.

2. When warping, only a start image is required. In the Project Editor you will see two blank windows, labeled Start 
and End. Under each Window, you will see a drop down list. Once an image is chosen for the start and end images, 
<<No Image>> will be replaced with the file name of the image that you are working with. To the right of both drop
down lists, you will find a small file folder button. Click on the one under the Start image.

3. Now you will be opening a start image. Change the 'Files of Type', to JPG -JPEG JFIF. Click on LITLGIRL.JPG 
and press OK.

4. The Project Editor now should appear with a young girl in the Start window. Choose Warp as the Effect Type. 

5. Click on the Edit button. This will open the Morph/Warp Editor. As opposed to a morph, where both start and end 
images are used, a warp only stretches a single image. Thus, the End window in the Morph/Warp Editor is also 
filled with the image to be warped. Points are placed on the start image. As each point is placed, a second point is 
placed automatically on the end image. The placement of the point on the start image indicates the feature you want 
to stretch. By moving the point on the end image, you indicate the spot where the image is to be stretched to.

6. Notice the tool bar located to the left of both images. Each Button has a specific purpose:

a. The top button places points onto the images as explained below.
b. The second button moves points. The currently selected point can be moved with the mouse or with the cursor 

keys.
c. The third button erases points.
d. The bottom button allows you to zoom in and out upon the image. Click on the image to zoom in, shift-click on

the image to zoom out.
7. Note that this Window can be re-sized and “maximized” - just like most windows. By expanding the window, more 

of each image is shown.

8. The first feature we will stretch will be the forehead. Starting with a point directly under the left ear, place some 
points on the start image along the forehead. The last point should be directly underneath the right ear. With the 
exception of the two points under the ears, move the points along the forehead of the end image outward. The result 
should look like this:

This will cause the forehead to stretch outward.
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9. Next, we'll tackle the hair line. Place points along the girl hair on the start image. Move those points outward on the 
end image, ensuring they are further outward than the points we've placed previously. The result should look like 
this:

10. Finally, we want to 'anchor' the eyebrows in place so that they do not stretch out unnaturally. Place a few points just 
above the eyebrows of the start image. Do not move them on the end image. This anchors each point in place. The 
result should look like this:  

11. Press OK and check your work using Preview. You'll find the Preview button on the Project Editor, seventh from the
left, that looks like a magnifying glass.

12. The Preview window appears. Use the slider to look through your video's frames. 

13. Once satisfied with your warp point placement, press Create Video. A Save As... dialog box will appear. Name the 
GIF Animation and Press OK.

14. After the rendering is finished, load and view your finished GIF Animation.

Tips on Positioning Warp Point Pairs
As in creating morph clips, a good rule of thumb to follow for a warp clip is to place points on features in the image or 
images.



Since the Warp effect begins and ends with different version of the same image, only a Start image needs to be loaded. 
However, an End image may be loaded to use as a reference. 

For example, imagine that you wanted to warp an image of your face into another version which has the geometry of 
Arnold Schwarzenegger's face. Load the image of your face as the Start image, and load Arnold's face into the End image
window. Then use the Warp Effect Editor to place points on the features of the faces, such as:

Edges/outline of eyes

Edges/outline of mouth

Along the hairline

Edges of the nose and ears

Along the outside edge of the head

... and any other specific features that are to be changed over the course of the warp.

When you create the warp video, your original face will warp into another version which has the same configuration as 
Arnold's face. Note, though, that Arnold's face (since it was loaded in the End image window) never actually appears in 
the finished warp.
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Using the Storyboard
The Storyboard is used to chain together clips of effects to create sequences of special effects. In fact, whole movies can 
be created using the Storyboard feature of VideoCraft. The Storyboard in the “GIF Animator” version is limited to five 
clips.

THE PROJECT EDITOR, SHOWING THE OPEN STORYBOARD

Tutorial 8 - Using the Storyboard to Create a Sequence of Effects
Suppose we wanted to create a video that does the following: morphs one car into a second, pauses for a moment, then 
has the second car transition back into the first. This sequence can be made using the Storyboard.

1. Start VideoCraft. If you already have VideoCraft running, choose New... Project from the File menu.

2. Follow the steps in Tutorial 2 - Creating a Morph Movie, to create a clip of a car morphing into a second. 
However, you do not need to create the finished video.

3. Nestled between the Start and End image windows of the Project Editor is the Create New Clip button. This button 
resembles a film strip with an arrow pointing at it from an angle. Press it to create the second clip in this sequence. 
It will also open the Storyboard section of the Project Editor.

THE CREATE NEW CLIP BUTTON

Please Note:
If your computer is currently in 640x480 display mode, the Storyboard may not be completely visible. If this is the 
case, ensure the VideoCraft Window is Maximized. To automatically maximize VideoCraft on startup, choose that 
option from the settings button in the Project Editor. To gain additional screen real estate, turn off ‘Toolbar’, 
‘Help/Status Bar’ and ‘Info/Status Bar’ from the View menu. 

4. The second clip will start with the end image (BIGCAR2.JPG) from the previous clip. Our desired effect for this 
clip is simply to pause for two seconds. First we'll create the pause. Select Transition as the Effect Type and press 
Edit. Choose "Hold Constant" from the list of pre-defined transitions and press OK. This will hold the start image 
constant for the duration of the clip.

5. Now we'll set this to pause for two seconds. Open the Video Parameters (see Tutorial 6 - Using the Distortion 
Effects for more details). Notice the Frames Per Second (FPS) setting. This parameter allows you to specify the 
number of frames that should appear in every second of video. This setting applies to the entire video. Now notice 
the Frames setting next to the Edit button in the Project Editor. This parameter specifies the number of frames that 
is going to take place over the duration of the clip. This setting can be different for each clip in the Storyboard. By 
adjusting these two parameters, the length of the clip is determined.



For example, suppose you desired to create a clip with a duration of two seconds. First, check the Video Parameters 
section to determine the FPS setting. If this is set to 20 FPS, you need 40 frames to create two seconds of video. If 
this the FPS is set to 15, you need 30 frames to create two seconds of video. 

6. Determine the amount needed to create two seconds of video, and enter it into the Frames parameter in the Project 
Editor. Now the video will pause for two seconds.

7. Our final clip transitions from the second car back to the first. Press  Create New Clip. The second car will remain as
the start image. Using the drop down list under the End Image window, load the first car (SMLCAR2.JPG) as the 
End image.

8. Ensure that Transition is your Effect Type and press Edit. Choose a transition from the list (or make up your own) 
and press OK.

9. Change the Frames setting so that the transition will take one second. For example, if you are running at 20 FPS, set
Frames to 20.

10. Press Create Video to render and view your finished movie! 

More features of the Storyboard
The clip which is currently loaded in the Project Editor is outlined in red. The clip which has been clicked on (selected) 
in the Storyboard is outlined in blue. A tool bar is used to manipulate the position of a clip in the Storyboard.

THE STORYBOARD TOOL BAR

(FROM LEFT TO RIGHT: BEGIN, LEFT, LOAD CLIP, RIGHT, END, CUT, COPY, PASTE)

Begin
The Begin button moves the selected clip (blue outline) to the beginning position in the Storyboard. This clip will now 
begin the video.

Left
The Left button moves the selected clip (blue outline) one position to the left.

Load Clip
The Load button reloads the selected clip (blue outline) back into the Project Editor. The clip will now be outlined in red,
as the currently-loaded clip. You may also double-click on a clip to reload it into the Project Editor.

Right
The Right button moves the selected clip (blue outline) one position to the right.

End
The End button moves the selected clip (blue outline) to the ending position in the Storyboard. This clip will now end the
video.

Cut
The Cut button removes the selected clip (blue outline) from the sequence of clips on the Storyboard and puts it on the 
Windows Clipboard. It may then be pasted into a different position in the current video, or into another video.

Copy
The Copy button puts a copy of the selected clip (blue outline) on the Clipboard. This clip may now be pasted into a 
different position in the current video, or into another video.
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Paste
The Paste button inserts a clip from the Windows Clipboard. The clip will be inserted into the currently-selected position
(blue outline), and the other clips will be shifted to the right.

Toggling the Storyboard Display
One can show and hide the Storyboard by pressing the Toggle Storyboard display button in the Project Editor. Note that 
this does not delete the contents of Storyboard, it merely hides them from view. Use the Cut button to delete items from 
the Storyboard.

THE TOGGLE STORYBOARD DISPLAY BUTTON



Advanced Topics I: Multiple Effect Layers and Alpha Channel Compositing
This section is devoted to some of the advanced features of VideoCraft. Although these features may appear intimidating
at first, we have attempted to make each feature extremely powerful, while maintaining a straightforward, easy-to-use 
interface.

Multiple Effects

What are Effect Layers?
Imagine a composer working on a piece of music for three very talented musicians. Although each musician can play 
only one instrument at a time, each musician can play any of seven different instruments. Because each musician is an 
accomplished soloist, there will be portions of the piece of music that the composer will want only one musician to play. 
There will be other sections, however, in which the composer may wish to have a duet, or even all three musicians 
playing at once. 

Remember that each musician can play any of seven instruments. Thus, the composer could have a section of music 
during which three trumpets play, then have another section in which the orchestration calls for flute, tuba, and bagpipe. 
Or he could have an electric guitar solo. This composer has many possibilities. 

Think of each VideoCraft effect (Colorize, Distort, Morph, Overlay, Stylize, Transition and Warp) as one of the seven 
instruments, the three effect layers as the three musicians, and yourself as the composer. Just as the composer would use 
different instrument combinations to create various musical textures, you can use different effect combinations to create 
various special effects. You have many possibilities.

Changing Effects
Switching between effect layers is very easy. Next to the Effect Type in the Project Editor is a button labeled [123]. This 
button acts as a toggle between the three layers. The currently-selected effect is highlighted in red. The second and third 
effects default to <<No Effect>>.

Tutorial 9 - A Simple Example of Multiple Effect Layers
1. Load a Start image. Set the Effect Type for the first layer to Colorize and click on Edit. Emboss will be the default 

effect. Slide the preview slider in the Colorize Editor to see how the resulting video will appear. The clip will start 
with the original image, and change to an embossed image. Since this is the desired result for our example, press 
OK.

2. Press [123] to advance to the second effect. The Start image will default to <<Effect 1>>. Remember that the first 
layer is creating a dynamic emboss. Suppose we want to slide the image left as it embosses. Select Transition as the 
Effect Type and press Edit. Select Slide Left from the transition list and press OK. 

3. Now open the Preview window and slide the Percentage slider. You will see that the clip starts with the original 
image, and as the image is being embossed, it slides to the left. If you click on Create Video, you can see the 
finished video clip.

This simple combination illustrates multi-layered effects very clearly. The second effect is layered atop the first. We can 
go another step and layer a third effect atop the first and second. We leave this as an exercise to the reader. (Hint: Try 
setting effect layer 3 in the above example to a Rotate distortion.)

It is important to note that although the result of the previous effect defaults to being the Start image, it can be used as 
the End image, as both the Start and End images, or not at all. In most cases the Start image default will be the most 
useful. Not using it at all may not appear terribly exciting, but as you'll see below, in the section on Effect Options, 
previous effects can be used to create dynamic Alpha Channel Masks.
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Alpha Channels and Masking

What are Alpha Channels?
Imagine looking through a stained glass window. Light shines through some areas of the window, yet no light shines 
though other areas. One could say that certain portions of the window are transparent, where light clearly shines through. 
Other portions are opaque, and no light shines through.

With VideoCraft, one can construct a stained glass window atop any image or video clip. This window is known as an 
Alpha Channel. With an alpha channel one can control exactly which areas of an image become transparent when a 
second image is superimposed upon it.

When alpha channels are used, the fully transparent areas of the finished output can be used to set the transparent area of 
a GIF Animation. Thus, the transparency setting for a GIF Animation can be dynamic and independent of the colors 
used. Use the setup button for the GIF Animation output type in Video Parameters to enable the transparency output.

Tutorial 10 - Increase to 32-Bit, The Difference Between Opaque and Transparent
Close any open Editor window. Load an image from the File menu, then choose the Colors menu. Under 32-Bit there are 
two options: Increase to 32-Bit (Opaque) and Increase to 32-Bit (Transparent). Choosing one of these options adds an 
alpha channel to the image. An Opaque Alpha Channel has no transparency, and therefore nothing will shine through the 
image. With a Transparent Alpha Channel, the image becomes completely clear, and when a second image is overlaid, 
the first image will disappear.

By default, VideoCraft displays "stripes" in the areas that are transparent. Thus, by selecting Increase to 32-Bit 
(Transparent) the entire image becomes striped. When Increase to 32-Bit (Opaque) is chosen, the image does not become
striped because no area of the image is transparent. The way alpha channels are displayed on images can be specified 
under the File/Settings menu.

32-bit images are said to contain alpha channel information. Only a few file formats can save this 
information: .BMP, .DIB, .TGA, and .TIF.

Tutorial 11 - Using the Image / Mask Menu to Construct Basic Alpha Channels
Once an image has been designated as a 32-bit image, the Mask option under the Image menu can be used to create basic
transparencies on an image. Note that using mask menu is only one way to create an alpha channel. See Tutorial 14 - 
Dynamic Masks for more details.

1. Using the steps outlined above, load an image and increase it to be  32-Bit Transparent. This should result in the 
image's becoming completely transparent, which is indicated by the striping. Next, select Mask from the Image 
menu. 

THE MASK IMAGE DIALOG BOX



2. On the left is a list of preset masks. On the right, the currently-selected mask appears. There are three options that 
can be selected: Invert Mask, Mask Alpha Channel, and Mask Color Channel. For our example, select the Star 
mask. Ensure that Invert Mask is de-selected, Mask Alpha Channel is selected, and Mask Color Channel is de-
selected. Click OK and look at the resulting image.

3. You will notice that the transparency, indicated by the striping, now takes the shape of the star. If you had selected 
Invert Mask, the opaque area of the image would be the interior of the star, and the exterior of the star would be 
transparent. Masking the Color Channel applies the mask to the image itself.

Now the part you've been waiting for; how to use alpha channels. We'll start with the Colorize effect.

4. Take the image created above, in which the star mask was used to create an image with some transparent portions 
and some opaque portions. Load this image as the Start image in the Project Editor. For your effect, choose Colorize
and click Edit.

5. You will notice that Emboss is the default effect. In the Preview window, you will note that the effect is only being 
applied to the opaque areas of the image. The transparent areas (the areas that are striped) are not affected by the 
Emboss effect.

Even with this simple example, the power of alpha channels is illustrated. Portions of images can be masked out, so that 
specific areas of an image can be left unchanged.

Tutorial 12 - Making Custom Faders Using 32-Bit Images
1. With an alpha channel, one can create one's own transition fader. Use the same star image in the above examples as 

the Start image. Load an image that is of the same dimensions as the End image. Select Transition as your effect 
and click Edit.

2. The Transition Editor knows that the Start image contains an alpha channel and thus provides a fader under both 
images labeled Alpha. Select the Alpha fader under both images. Click OK and preview the video. As you slide the 
preview Percentage, you will see that the transparent areas fade between images first, then the opaque areas fade.

As you'll see below, VideoCraft can use any image or AVI file as an alpha channel mask. This means that you can create 
an infinite variety of faders. For a fun project in the meanwhile, try doing the same effect but instead of using the star to 
generate the Alpha Mask, use checkers. 

Alpha Channel Overlays
When using the Overlay Editor with a Start image containing an alpha channel, two more overlay types appear; Alpha 
and Inv. (Inverse) Alpha. These are used to provide control over the areas to be overlaid. 

Tutorial 13 - Making an Overlay With a 32-Bit Image
1. Load the star alpha channel image used previously into the Start image window of the Project Editor. Load a second 

image of the same size into the End image window. Select Overlay as your Effect Type and click Edit. Choose 
Alpha from the Type list.

2. You will see that the End image shines through the Start image in the shaded, transparent area. In the opaque area, 
the Start image shows. To reverse this, choose Inv. Alpha. This way, the area that is transparent become opaque, and
the opaque areas become transparent.

Slider Explanation
You will notice two (or three as explained below) sliders for alpha channel control. The first is labeled Pre-Alpha Fader. 
This slider controls the fade of areas that are not controlled by the Start image's alpha channel. Sliding the control to the 
left increases the Start image's transparency; all the way left is equivalent to 100% transparency.
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The second and third sliders control the alpha channel of the resulting clip - this Overlay's output. These two sliders are 
useful when alpha channels need to be reused in multi-layer clips. Precise control of the resulting alpha channel is 
possible.

The second slider, labeled Post-Start Fader, controls the amount of transparency applied to the resultant clip, based upon 
the Start image's alpha channel. When the slider is placed all the way to the left, the resultant image is 100% transparent.
With the slider set to the right, the resultant image will have the alpha channel from the Start image applied. Varying 
degrees of resultant transparencies can thus be achieved by adjusting the slider.

When the End image has an alpha channel, a third slider appears: Post-End Fader. This slider controls the amount of 
transparency applied to the resultant clip, based upon the End image's alpha channel. When the slider is placed all the 
way to the left, the resultant image's alpha channel is that of the Start image. With the slider set to the right, the resultant 
image has the alpha channel from the End image combined with that of the Start image such that the opaque areas of 
both alpha channels are combined. Varying degrees of resultant transparencies can be achieved by adjusting the slider. 
To use the alpha channel of the End image alone, set the Post-Start Fader slider to the left, and the Post-End Fader slider 
to the right.

Varying the Transparency levels
Up to this point, we have only used basic alpha channels; the area is opaque, or its transparent - there is no "middle 
ground". Well, there can be! As there are shades of gray between black and white, there is a gradient between 
transparency and opacity. Since VideoCraft reads and uses 32-bit images created with PhotoShop, PhotoStyler, and 3D-
Studio, users of those programs can already reap the benefits of alpha channels without further instruction; simply load 
those images and use them as you did the images in the above examples. Some of us, however, aren't so fortunate. That's 
why VideoCraft allows anyone to use any image as a dynamic mask. Read on...

Tutorial 14 - Dynamic Masks
Through the use of the Effect Options, any image, any AVI file, and even the previous effect can be used to create alpha 
channels.

1. Load Start and End images that are the same size but do not contain alpha channel information. Select Overlay as 
your Effect Type. Press Options. 

2. Under Alpha Masks (lower left hand corner of the window) you will notice places for Start and End images. 
Familiar Open Image file buttons appear next to each name. In a nutshell, one can specify another image, a video 
clip, or a previous effect to provide the alpha channel in varying degrees of transparency.

3. Let's continue this example, and then explain what's going on. Under Start choose any image (if need be, load an 
image using the Open Image button next to Start). Click on OK then click Edit in the Project Editor. The Overlay 
Editor should appear. Select Alpha from the list.

4. The resulting preview might surprise you. The Start and End images are superimposed upon each other; the amount 
of transparency being determined by the colors of the image used as the mask. You may wish to turn off Stripe 
Alpha Channel in the File / Settings menu to get the whole idea here.

Suppose we had used a monochrome (black and white) image as our Alpha Mask. If we had, the black areas in the image
would indicate transparent spots, and the white areas would indicate opaque spots. If the masking image had been a 
grayscale image, the black areas would be used to make transparent areas. The white portions would be used to create 
opaque areas. The shades of gray would be used to create varying transparency levels (the darker the gray level, the more
transparent the area, and vice versa). 

VideoCraft treated our color image as if it were a grayscale image. Thus, you will notice that where the masking image is
dark in color, the End image shines through. Where the masking image is light in color, the Start image shines through. 
Remember, black or dark makes for a transparent area, and white or light makes for an opaque area.



Realize that any image can be used as a mask. For example, if we wanted to take one object in an image, and place it on 
a different background, we would do the following: take a copy of the image into an image editor such as Paint. Next, 
paint black where you want the background to show. Paint white where you want the original image to show. After 
saving this image with a different filename (such as My Mask.BMP), start VideoCraft. Then, load the original object as 
your start image. Load the background as the end image. Press Options and load your mask as the start mask. This will 
specify the transparent (black) areas and the opaque (white) areas. Finally choose Overlay as the effect type, press  Edit, 
and choose Alpha as the Overlay type. The preview will indicate the desired result, an object in an image on a different 
background.  

Using AVI files as Alpha Channels
Because VideoCraft can treat AVI video clips in the same way it treats still images, one can create moving alpha 
channels. When a video clip is loaded into the Start or End mask section of the Effect Options, the Video Editing Options
dialog is enabled for the masking AVI. Just like in the Project Editor, in and out points as well as sampling options can 
be specified. Consult the section on Video Editing Options elsewhere in this manual.

When a video clip is used as a mask, it is similar to using a color image, except the image changes over time. Where the 
video clip is dark in color, the End image shines through. Where the video clip is light in color, the Start image shines 
through. As with images, black or dark makes for a transparent area and white or light makes for an opaque area.

Tutorial 15 - Using Other Effects as Alpha Channels
If you use the multiple effect layers, you will see that the previous effect can be used as a mask for a subsequent effect. 
As with images in the Project Editor, <<Effect 1>> and <<Effect 2>> can be used as input into the masks of, 
respectively, effect layer 2 and effect layer 3.

1. From the File menu, choose New... Project to clear out the Project Editor. Then close the Project Editor as well as 
any open image windows.

2. From the File menu, choose Open and load the image (not video clip) of your choice. From the Edit menu choose 
Copy, which will copy the image you just loaded onto the Windows Clipboard.

3. From the File menu, choose New... Image. This will create a new, blank image.

4. From the Edit menu, choose Paste, and the image from the clipboard will be pasted into the new image window.

5. From the Image menu, choose Mask. From the list, choose Star. Ensure that Invert Mask is de-selected. Click on 
Mask Color, select Black, and click OK. Click OK to apply the mask.

6. A second time, from the Image menu, choose Mask. From the list, choose Star. This time, select Invert Mask. Click 
on Mask Color, select White, and click OK. Click OK to apply the mask. The resulting image should be a white star 
surrounded by a black border. All we’ve done is create a black and white image to be used as a mask. Realize that 
we could have used any image editor to make this mask and that we can use any image as a mask. 

7. From the View Menu, choose Project Editor. In the drop-down image list under the Start image of the Project 
Editor, choose Image1 - the image that we just made. 

8. Set your effect to Distort and click Edit. Choose Rotate from the distortion list and click OK.

9. Open the Preview window and use the Percentage slider to verify that what is occurring in the first effect is a 
rotating, black and white, star.

10. Press [123] to advance to the second effect layer.

11. Under Start image, <<Effect 1>> is selected by default. Instead, use the drop-down list to select the image that you 
originally loaded in step 2.

12. Choose Colorize from the effect list and click Edit. From the list of effects, choose Emboss and click OK.

13. Click Options to open the Effect Options. 

14. Under Effect Percentage, choose Constant, 100%. This will apply the Emboss evenly throughout the video clip.



Advanced Topics I: Multiple Effect Layers and Alpha Channel Compositing 27

15. Under Alpha Masks, choose <<Effect 1>> as your Start Alpha Mask. This will use the rotating star that we created 
in the first effect layer as the alpha channel. Remember, the black areas will be transparent and the white areas will 
be opaque. Click OK.

16. Click Create Video and give the GIF Animation file any filename. Be sure that the Transparent GIF option has not 
been enabled in the GIF Animation Setup.

17. Once the file is created, use your internet browser to load and play.

Although there were a number of steps involved, the resulting video clip is impressive. Dynamic masks can be used to 
create unbelievable effects. Some more things to experiment with:

In the above example, use the same effect layer 1, but change the second layer to be a Reverse Zoom Out distortion 
effect applied to the first layer, <<Effect 1>>. In the third effect layer, use <<Effect 2>> as the mask against a static 
emboss. This way the star will zoom in from nowhere, as it is rotating.

Start with a completely white image as your Start image. Use the first effect layer to construct an Explode transition. Use
the second effect layer to perform a Shear distortion onto <<Effect 1>>. For the third effect layer, use two images, Start 
and End, of the same size. Under Options, set the start mask to be <<Effect 2>>. Set the third effect layer to be Overlay 
on Alpha Channel. Render this one for a truly amazing transition. 



Advanced Topics II: Motion Morphing and Warping

Motion Morphing
Motion Morphing is a feature that works with video clips. It is the same effect as single-frame morphing except that you 
can morph between two AVI video clips. For example, you can morph a running tiger into a moving automobile. Motion 
Morphing is automatically selected if either the Start or End image is an AVI file. To perform a motion morph load two 
AVI files into the Project Editor, select Morph in the list of Effect Types, and click Edit. Motion morphing is different 
from single-frame morphing. If you are morphing an AVI with 30 frames then there are 30 frames that need morph 
points. With single frame morphing there is only one frame. If you are new to morphing we recommend that you attempt
some single-frame morphs before trying a motion morph. 

The Basic Process
Place points on the important features in the first frame of the Start and End AVI clips. Use the bottom slider to advance 
to the final frame of the clip. Adjust the points to match the movement of the AVI files on the last frame of the Start and 
End AVI clips. Go back and adjust frames at infrequent intervals such as every 10 frames. Then start at the beginning 
and perform fine adjustments. When you are finished with point placement, you can adjust the color  movement within a 
morph using the Project Editor/Options/ Color Shift tool. You can also adjust the morph movement speed using the 
Options/ Movement Speed tool. You can also create a morph which is a constant  blend of the Start and End image 
instead of a dynamic transition from Start to End image. This is also found in the Option/Effect Percentage tool. Simply 
choose between Variable and Constant. Variable is the default and is most common for morphing.

Smart Points
The points that you add by hand are called Real Points and can be identified by their default color of light blue and light 
green. You can add a Real point anywhere in an AVI clip. VideoCraft will duplicate that point by creating Smart Points 
on all following frames. Smart Points have a default color of dark blue if they have not been moved or adjusted, and are 
dark green if they have been moved. By creating Smart Points, VideoCraft saves you the work of creating new points for 
each frame, letting you concentrate on the important task of fine tuning the placement of points. By doing adjustments 
every 10 frames or so you can make use of the automatic adjustments of the Smart Points. The Smart Points between the 
Real points will always adjust to the Real Points.

When deleting a Real Point or a Smart Point, all corresponding points after that point will be deleted but no points before
it will be deleted. If you have a sequence in a motion morph that has a lot of movement, extra points may be needed just 
for that section. You can add Real Points, adjust the Smart Points for several frames, and delete the remaining points that
are not needed.

Helpful Advice
To help you achieve best placement of morph points you should use the zoom tool to zoom in on a clip when placing 
points. Also, because motion morphing takes more time than single frame morphing you may wish to create a test morph
with just a few points before spending a lot of time on a project. This process of gradual refinement is very good for 
starting with a rough idea and gradually perfecting it.

Motion Warping
Motion Warping is the same effect as single-frame warping except that you can warp all or some of the frames of a 
moving video clip. Motion Warping is automatically selected if you place an AVI clip in the Start image of the Project 
Editor and choose Warp from the list of Effect types. 

Smart Points
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The amount of effort to create a motion warp is a bit more than is needed to create a single-frame warp. If you are 
warping a clip with 30 frames, there are 30 frames that need warping points. Rather than make you recreate 30 frames of 
warping points, we have added Smart Points to help you get the job done. The process to create a motion warp is the 
same as creating a single-frame warp but with one additional step. First, click on Edit in the Project Editor to bring up 
the Morph/Warp Editor. Set your starting warp points in the first frame of your warp clip. These points that you create by
hand are called Real Points. VideoCraft will create Smart Points on all following frames automatically, saving you a lot 
of work. You can add Real Points to any frame anywhere in a video clip, and Smart Points will be created automatically. 

Helpful Advice
If you delete a Real Point or a Smart Point, only the points on following frames will be deleted. You will find that most 
of the effort of a motion warp is in adjusting the Smart Points so that a smooth motion is created. This is very important 
since video images tend to move on each frame. In order for a motion warp to look good, the points should be moving on
each frame. Again, VideoCraft has several features to make your work easier. All points are color coded to help you 
organize your work. Colors can be assigned to the following kinds of points: Active Real Point, Active Smart Point, 
Moved Real Point, Moved Smart Point, Unmoved Real Point, and Unmoved Smart Point. For images that have a color 
that conflicts or obscures the points you can easily change the color of that point type to be something else using the 
point color tool.

By specifying a constant setting in Effect Options, Smart Points can be used to create very exact warps. The motion of 
the points will determine the exact shape the warp will take over time.



Image Editing within VideoCraft

Opening Image Files
Opening an image file reads in an image from your disk and displays it. Go to the File menu and choose Open. A dialog 
box will appear.

To see a list of available file formats, click on the down-arrow button next to the Files of Type list. Scroll the list by 
clicking on the up and down scroll arrows. Click on the file format PCX - PC Paintbrush Format. VideoCraft will display
all of the files in the current directory that are in the PCX format. If you want to see a list of all files in the directory, go 
to the top of the file formats list and choose * - List all files.

To open a file, double-click on its name in the file list. Try opening some of the sample images that are provided with 
your copy of VideoCraft. They can be found in the VidCraft folder.

Converting, Compressing, and Saving Images
After loading an image, you can use Save As... in the File menu to convert the image to other formats and save it in 
compressed or decompressed form. Open the file COLORS1.TGA from your VideoCraft directory. Now choose Save 
As... from the File menu. A dialog box will appear.

If you wish to save the image to a new drive or directory, move to the new one by double-clicking with the mouse in the 
directories list box. Choose a new file format for the image by clicking on the new format's name in the formats list box. 
Try choosing the format TIF - Tagged Image File Format from the formats list box. Note that the output filename in the 
Filename edit box has been changed to COLORS1.TIF. You can use this edit box to change the output filename if you 
wish. Those using the Windows 95 version of VideoCraft can take advantage of Windows 95’s support for long file 
names.

Instead of using the mouse to make changes, you may change the output filename and format by simply typing the new 
name in the Filename edit box. For example, to change the file COLORS1.TGA to a PCX file, type COLORS1.PCX in 
the Filename box.

You can also change the file's compression state when saving. Click on the Format>> button. Choose the Compressed 
radio button at the bottom to save your file in a compressed form. De-select the radio button to save the file in an 
uncompressed form. Note: There are some formats that cannot have their compression state changed by the user. For 
these formats, the Compressed radio button will be grayed out (disabled).

To save the file with your chosen parameters, click on the Save button. To cancel saving and exit the Save As... dialog 
box, click on the Cancel button.

In addition to being able to change filenames and compression states, the Save As... option in the File menu can change 
color configurations.

Color Reduction and Optimization - The Colors Menu
VideoCraft has sophisticated options for performing optimized color reductions on your images. There are two different 
ways to change color formats: 

Use the main Colors menu or the pop-up (right click) Colors menu.

Use the Image/Save As... option in the File menu.

With both of these methods, you may choose between two color reduction algorithms, Flat Cut and Optimized Cut, and 
you may choose whether or not to dither the image when reducing colors.

Using the colors menu, you may quickly choose a color configuration for your current image. 
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Open the sample file, COLORS1.TGA. Now open the Colors menu and note that 24-Bit Color is checked. Click on 
another color configuration; for example, 16 Colors. Now you may choose between Flat Cut, Optimized Cut, Flat Cut 
with Dither, and Optimized Cut with Dither. Try choosing one of these options, then use the Undo option under the Edit 
menu to get the original image back. Then choose another method, then Undo, etc. This will give you an idea of the 
results each of the four methods will give you.

You can also try choosing Gray at the top of the Colors list to convert the image to grayscale.

For a shortcut to the Colors menu, right click on an image.

Screen Capture
The VideoCraft screen capture utility will prove very useful to you in creating screen images to use in videos.

The following sequence will capture an image of your entire screen and automatically paste it into a new VideoCraft 
window.

Go to the Capture menu and choose Entire Screen. Now click on Set Options... in the Capture menu. In the Capture 
group, choose To Window. Click OK.

Now simply hit the F11 key. VideoCraft captures an image of your screen, opens a new window, and pastes the image 
into it (all in one step!)

Feel free to explore the Capture menu to realize all of VideoCraft's screen capture possibilities.

Printing
To print an image, simply open an image file and choose Print from the File menu. You can use the Print dialog box to 
scale, set print quality, and set up the printer. VideoCraft can print to any Windows-supported printing device. A preview
is also provided, to access it, choose Print Preview from the File menu.

If you wish to print a frame of a VideoCraft sequence, use the Save image to new window button in the Preview window. 
This will create a new image in the VideoCraft work area. Then, select the new image by clicking on it (close the Project
Editor and Preview window if necessary) and chose Print from the File Menu.

The Edit Menu
Options for Cutting, Copying, and Pasting to the current image window are provided. Each menu item is detailed below.

Mistakes and Experiments: Undo
The Undo function under the Edit menu can be a lifesaver. It reverses the most recent operation performed on an image. 
Note that the Undo operation only applies to image windows, not to project windows!

Undo works on an image-by-image basis. In other words, if you have two images open, you can make a change to Image 
#1, then make a change to Image #2, then go back to Image #1, choose Undo, and get the original unchanged Image #1 
back.

You can use Undo as a toggle between two versions of an image. Load an image, make a change, then use Undo to 
switch back to the original image. Use Undo again to see the change again, and so forth.

Undo is a great tool for trying out various operations on an image. Try loading an image and performing the different 
color reduction options on it (Flat Cut, Optimized Cut, and the same two with dither), using the Colors menu.

Cut



This option clears the current image window and places that image on the Windows clipboard.

Copy
This option copies image from the current image window and places that image on the Windows clipboard.

Paste
This option takes the image that has been cut or copied to the clipboard (from VideoCraft or any other image editor) and 
places that image into the current image window. To paste an image into a new window, choose New... Image from the 
file menu before pasting. 

Paste Palette
This handy feature pastes the palette from the image stored on the clipboard into the current image in VideoCraft. This is
extremely useful for ensuring that images share the same palette on 256 color displays.

The Image Menu - Instant Image Editing
With the Image menu, you can re-orient your image by rotating, change its size by cropping or scaling, and perform a 
variety of other operations such as inverting colors, mirroring, framing, tiling, captioning, and masking. Controls for 
contrast/brightness, hue/saturation provide a means of color correction for images. By combining these operations, you 
can achieve great-looking special effects, too.

The items in the Image menu can also be used when the Windows 95 version of VideoCraft is serving image formats to 
an OLE client. See Using VideoCraft as an OLE image server, below, for more details.

Digital re-sampling methods are used to create very high-quality rotated and scaled images.

Invert Image
Use this menu item to invert the colors in your image. Invert Image creates a color negative by taking each of the 
original image colors, computing their opposite in the color spectrum, and changing each original color to its opposite. 

Flip Image
Use this menu item to flip your image along the horizontal axis.

Mirror Image
Use this menu item to flip your image along the vertical axis, creating a mirror-image of the original.

Crop
Use this option to cut off portions from the sides of your image. The Crop dialog box lets you specify portions of the 
image you want to cut from top, bottom, left, and/or right. A thumbnail version of the image is included in a previewing 
box at left. Use this to monitor your crop-line locations as you crop the image.

The Crop group in the dialog box has fields in which you can enter pixel values to crop off of the Top, Bottom, Left, 
and/or Right of your image. As you enter pixel values, crop lines will appear at the specified locations in the thumbnail 
previewing box.

Another way you can crop your image is to point with the mouse to a crop line in the previewing box (the cursor will 
change to a double-sided arrow), hold down the left mouse button, and drag the line to the new location. When you first 
open the Crop dialog, the crop lines are located at the edges of the image in the previewing box. As you drag, the pixel 
values in the Top, Bottom, Left, and Right fields will change dynamically. You can also point to a corner (a four-sided 
cursor appears) and drag the corner, to move two crop lines simultaneously. To move the entire crop-line box around the 
image, just point anywhere inside the box (the cursor will change to a hand), click, and drag the box to its new location.
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The new dimensions (in pixels) of the image will be displayed in the Dimensions group. The Dimensions group allows 
you to enter new pixel dimensions for the image in the Width and Height edit boxes. By default, the crop lines will be 
centered on the image. For example, if you enter a Width value that is 20 pixels less than your original image's width, 
crop lines will appear 10 pixels in from the left and right edges of the image.

The Dimensions group is quite useful if you want your final cropped image to be of a specific size. Just enter the final 
dimensions in the Width and Height boxes. Then, if the crop lines are not where you'd like them to be, you can use the 
hand cursor to move the crop box around.

The Display group allows you to choose whether or not to preview your image at actual size. If your image is small 
enough that it fits entirely within the previewing box, the Show Real Size radio button will be permanently selected 
(since your image will automatically be previewed at full size).

Scale
The Scale Image dialog box allows you to: set a new width and/or height for the image; scale by percentage; choose 
high-quality or high-speed scaling; choose different units of measurement; specify dots-per-inch for different devices 
(allowing you to create predictable image sizes for particular devices, such as printers); and correct aspect ratio and 
resolution problems.

You may specify a new image size by typing values into the Width and/or Height fields. Use the Maintain Aspect check-
box to choose whether or not to maintain the image's original aspect ratio (in this instance, aspect ratio means the ratio of
image height to image width). If you select the Maintain Aspect check-box and then change either the Width or the 
Height value, the other value will change automatically, to preserve the same aspect ratio. If you de-select the Maintain 
Aspect check- box, and you enter Width and Height values that do not preserve the original aspect ratio, the result will 
generally be an image that looks squashed or elongated.

The Measure list box allows you to change the resolution by which the scaled image is measured, enabling you to create 
images which are of a predictable size for a particular device. There are three choices: Screen (x, y), Printer (x, y), and 
Custom. The values in parentheses represent dots-per-inch (horizontal, vertical) for the chosen device.

The Quality list box lets you choose between High or Low quality for your scaled image. If you choose Low quality, the 
scaling operation will be fast, and the resulting image will not be as good as it could be. With Low quality, the scaled 
image will be created in the same color configuration (bits-per-pixel) as the original image. In a High quality scaling 
operation, the scaled image will be created in 24-bit color (for color images) or in 8-bit grayscale (for gray or 
monochrome images).

Rotate
Use this menu item to rotate your image by any number of degrees, positive or negative, and to choose a background 
color for the rotated image.

Choose Custom, 90, 180, or 270 for degrees of rotation. If you choose Custom, you may enter any integer in the Amount 
edit box, and your image will be rotated by that number of degrees. Rotation is to the right (clockwise) if the integer is 
positive, to the left (counterclockwise) if the integer is negative. You may use the Quality list box to choose between 
High and Low quality for the final rotated image.

If you are rotating the image by 90, 180, or 270 degrees, the quality will always be High (in other words, there will be no
difference in appearance of the image or in speed of the operation, whether you choose High or Low quality). If you 
choose 90, 180, or 270 for degrees of rotation, the rotated image will be created in the same color configuration (bits-per-
pixel) as the original image. For instance, if your original image was a 4-bit (16-color) image and you rotate it by 180 
degrees, the rotated image will be created as a 4-bit (16-color) image.



If you are rotating the image by any other number of degrees, you will be performing a Custom rotation. If you choose 
Low quality for a Custom rotation, the rotation operation will be fast, and the resulting image will not be as good as it 
can be. With Low quality, the resulting image will be stored in the same color configuration (bits-per-pixel) as the 
original image. If you choose High quality for a Custom rotation, the rotation operation will be slower, but the resulting 
image will look much better. In a High quality rotation, the rotated image will be created in 24-bit color (for color 
images) or in 8-bit grayscale (for gray or monochrome images).

The final quality of the rotated image is dependent on the image's resolution. One way to increase an image's resolution 
is to first use the Scale... operation to enlarge your image (say to 300%, or 3 times original size), then perform the 
Rotate... operation, and finally scale the image back down to its original size. Working with the image at a higher 
resolution (larger size) will increase the quality of the image when it is shrunk back to its original size.

In a Custom rotation, the rotated image's dimensions will be larger than the original image's dimensions. (Rotate... draws
a rectangle around the rotated image, with edges tangent to the rotated image's corners. You will thus have portions of 
"background" showing behind the rotated image.) You may choose a background color for the rotated image by clicking 
on the Color button. The background color may be chosen from a palette corresponding to your original image's color 
configuration (for monochrome images, choose black or white; for 4-bit images, choose among 16 colors; etc.). If your 
original image was in 24-bit color, you may choose any color for the background.

When you click on the Color button, a color-chooser dialog box for the present color configuration appears (except for 
monochrome, where the color toggles between black and white). For 4-bit and 8-bit files, the color palette will have 16 
colors and 256 colors to choose from, respectively. For 24-bit files, the standard Windows color-chooser dialog box 
appears. Note: If you are choosing a color for a 24-bit image, remember to check the luminance value in the color-
chooser dialog (this can be adjusted with the slider on the far right). If luminance is set to 0, your color will always come
out black, and if it is set to 240 (the highest value), your color will always come out white.

Frame/Caption
Use this menu item to create a custom frame and to add a caption to an image. 

In the Frame/Caption Image dialog box, you will find options for choosing a frame style; specifying a framed image's 
final dimensions; specifying and previewing frame margin measurements; adding caption text; and choosing colors for 
frame fill, frame outline, and text.

From the Style list box, you may choose Filled or Outline as the frame style. Filled creates a frame filled with a specified
color. Outline creates a frame with a one-pixel outline of a different color from the fill color. (Use the Color button to 
name a color for frame fill and frame outlines.)

In the Final Dimensions group, you may enter the dimensions, in pixels, of the finished image (picture plus frame). As 
you enter the picture's final dimensions, the Frame Margin values (see Frame Margins below) will change dynamically, 
centering the image within the frame. Please note: The Final Dimensions width and height values cannot be smaller than 
the width and height of the image you wish to frame. In other words, the frame cannot cover any part of the image but 
must only wrap around the outside of the image. If you want the finished dimensions to be smaller, you should first use 
Crop... or Scale... to cut down the size of the image before framing it.

In the Frame Margins group, you may specify the width of the frame, in pixels, at the Top, Bottom, Left, and Right of 
the image. As you alter these values, the Final Dimensions values will change dynamically to show you the final height 
and width of the framed image. A previewing box at the top right also changes dynamically as the Frame Margins values 
change. (The frame you've specified appears in black, while the hatch-marked area represents the framed image.)

Use the Colors group to choose colors for frame fill, frame outline, and caption text. In the drop-down list box, choose 
the area for which you want to pick a color (Fill Color, Outline Color, or Text Color), then choose the color with the 
Color button. Colors may be chosen from a palette corresponding to the original image's color configuration (except for 
24-bit images, for which any color may be chosen).
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When you click on the Color button, a color-chooser dialog box for the present color configuration appears (except for 
monochrome, where the color toggles between black and white). For 4-bit and 8-bit files, the color palette will have 16 
colors and 256 colors to choose from, respectively. For 24-bit files, the standard Windows color-chooser dialog box 
appears. Note: If you are choosing a color for a 24-bit image, check the luminance value in this dialog (adjust with the 
slider on the far right). If luminance is set to 0, your color will always be black, and if it is set to 240 (the highest value), 
your color will always come out white.

In the Caption (x, y) group, you may enter any text you wish to overlay upon the image. (You are not required to create a
frame in order to place text upon your image.) The x and y values that are displayed next to the word Caption represent 
the width and height (in pixels) of the caption that you create. This allows you to create a frame in which your caption 
will fit. If your caption does not fit in your frame or on your picture, the text will be truncated, not wrapped.

Click the Style button to select your font, font style (bold, italic, etc.), size, and effects. Choose a text color with the 
drop-down list box in the Colors group, click on Text Color, then pick a color with the Color button. (See above for 
information on the Color button.)

Click the Align button to position your text along the horizontal and vertical axes. Choose Left, Center, or Right align in 
the Horizontal group, and Top, Center, or Bottom align in the Vertical group.

You should also consider the special effects you can achieve by combining various operations in the Image menu. For 
instance, to run a caption diagonally across your image, first rotate the image by 45 degrees, caption it, then rotate back 
to its original orientation.

The final appearance and quality of the framed image and caption text is dependent on the image's resolution. One way 
to increase an image's resolution is to use the Scale... operation to enlarge the image (say to 300%, or 3 times original 
size), then frame and/or caption it, and finally scale the image back down to its original size. Working with the image at 
a higher resolution (larger size) will increase the quality of the image when it returns to its original size.

Tile
Use this menu item to create multiple copies (tiles) of your original image and organize them in an array (as though the 
images were tiles being laid).

The Tile Image dialog box provides you with a Width and a Height field. Use these fields to specify how many tiles of 
the image you want along the horizontal (Width) and vertical (Height) dimensions.

Select the Mirror Tiles option to create mirror effects. This option will mirror tiles both along the horizontal and along 
the vertical axes. If you wish to mirror only along one axis, first tile along the mirrored axis with Mirror Tiles selected; 
then tile along the non-mirrored axis with Mirror Tiles de-selected.

Mask
Use this menu item to create special effects by masking out (hiding) parts of your image with the figures and patterns 
provided.

In the Mask Image dialog box, you can choose from an assortment of shapes for your mask. The Shape box at right will 
display the shape you choose from the Name list at left. By default, the black areas in the Shape box will be the areas 
through which your original image will show, and the white areas will be masked. If you select the Invert Mask option, 
however, the white areas in the preview box will be the areas through which your image will show, and the black areas 
will be masked. Selecting Mask Alpha Channel will apply the mask only to the channel of a 32-bit image. Selecting 
Color Channel masks only the color part of a 32-bit image.



Use the Mask Color... button to choose a color for the masked parts of the final image. Colors may be chosen from a 
palette corresponding to your image's color configuration (i.e., black or white for a monochrome image, 256 colors for an
8-bit image, etc.). If the original image is in 24-bit color, any color may be chosen for the mask color.

When you click on the Color button, a color-chooser dialog box for the present color configuration appears (except for 
monochrome, where the color toggles between black and white). For 4-bit and 8-bit files, the color palette will have 16 
colors and 256 colors to choose from, respectively. For 24-bit files, the standard Windows color-chooser dialog box 
appears. Note: If you are choosing a color for a 24-bit image, remember to check the luminance value in the color-
chooser dialog (this can be adjusted with the slider on the far right). If luminance is set to 0, your color will always come
out black, and if it is set to 240 (the highest value), your color will always come out white.

The final quality of the masked image is dependent on the image's resolution. One way to increase an image's resolution 
is to first use the Scale... operation to enlarge your image (say to 300%, or 3 times original size), then mask the image, 
and finally scale the image back down to its original size. Working with the image at a higher resolution (larger size) will
increase the quality of the image when it is reduced to its original size.

Contrast/Brightness
Use these menu items to increase the contrast and brightness of the selected image. Contrast will make dark parts of an 
image darker and will make light colors lighter. Brightness will make the entire image lighter. Use the slider controls to 
change the contrast and brightness on the preview image which is displayed. Then select OK to apply those changes to 
the image. You can use Channel to select the specific color plane you wish to modify or you can select RGB and change 
all colors with a single operation.

Hue/Saturation
Use the Hue and Saturation controls to change to overall Hue and Saturation of an image. 

The Filter Menu
VideoCraft comes with 11 filter effects which can give an image additional distinction and flair. A filter is applied to the 
image in the active window. This process can be repeated several times to give more of an effect. All filters work with 
images having 16 or more colors. If an image is only black and white, or monochrome, the filter menus will appear 
grayed out and will not be applicable. If you really need to apply a filter to a black-and-white image you can promote the
image to color using the Colors menu. The filter menu does not apply to AVI files. Use the Colorize effect to filter AVI 
files.

The effects in the Filter menu can also be used when the Windows 95 version of VideoCraft is serving image formats to 
an OLE client. See Using VideoCraft as an OLE image server, below, for more details. 

The Filter menu’s effects appear in the following order:

Sharpen
The Sharpen filter will make a blurred image look more crisp. The opposite of Sharpen is Blur.

Sharpen Lines
The Sharpen Lines filter will accentuate lines and finer detail in an image.

Despeckle
The Despeckle filter will remove stray points of very different colors. This has a subtle smoothing effects.

Emboss
The Emboss is a very interesting effect which can make an image look like a three-dimensional relief, or sculpture. 

Blur
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The Blur effect gives an image a blurry appearance. It is especially noticeable on very detailed images. As with all 
filters, it can be used repeatedly on an image to make it very blurry or a little blurry.

Median
The Median filter can be used to create a Posterize effect where a few colors dominate an image.

Trace Edges
The Trace Edges filter will remove all features from an image accept its edges. Because of the nature of the filter, the 
colors it creates are very bright. These colors can be toned down or simply converted to gray using the 
Contrast/Brightness or Hue/Saturation controls in the Image menu.

Noise
The Noise filter will add an amount of randomly colored pixels or 'visual noise' evenly over an image. If more noise is 
desired, the filter can be repeatedly applied as needed.

Maximum
The Maximum filter will increase bright or light colored areas in an image. Repeatedly applying this filter will spread the
bright colors over an image much like water colors or finger paints.

Minimum
The Minimum filter is much like the Maximum filter except that it spreads dark colors. 

Old Movie
The Old Movie filter makes the image look like it was taken using and old style movie camera. This is also known as 
‘Sepia Tone’.

Using VideoCraft as an OLE image server
In the Windows 95 version, all of VideoCraft’s supported image formats can be used in any OLE 2.0 compatible 
application. This allows you to use a multitude of image formats in any client application. For example, you can embed 
TGA images into a WordPad document. Also, all of VideoCraft’s image editing and filter functionality (as described 
above) can be accessed by the client application. 

There are four ways to embed a VideoCraft image into a client application:
1. Copy the image to the clipboard in VideoCraft with the Edit menu. Then paste (or paste special) in the client 

application.

2. Click and drag on the image from VideoCraft and drop it into the client application.

3. Click and drag on the image from Explorer and drop it into the client application.

4. From the client application’s Insert menu, choose Object. Once in VideoCraft, choose Image from the Insert menu 
to open the image you would like to insert into the client application.

Please note for images to be properly served by VideoCraft, they should be registered to VideoCraft. Also note that 
VideoCraft only serves image formats, not its own native VPR format. For more information about OLE 2.0 and file 
registration, please consult your Windows 95 documentation.



Video Editing, Effect, and Output Options

Video Editing Options
The Video Editing Options tool allows you to specify a segment of frames to use within the current AVI file. The tool is 
located under the start and end image in the Project Editor and will become automatically enabled when an AVI video 
clip is loaded in that window. By setting the In Point and the Out Point, the portion of the clip to be used is specified, 
providing a means of performing simple editing, thus eliminating the need to use a separate editing program for anything
but advanced editing. Also included in the Video Editing Options is the ability to specify how the source video is to be 
sampled. There are 3 options for sampling: By Time, By Frames and Whole Clip.

THE VIDEO EDITING OPTIONS BUTTON

Sampling by Time means that VideoCraft should attempt to use the same amount of source video (in seconds) that is 
going to be created in the clip. If the clip contains 30 frames and is going to be written at 20 frames-per-second, 
VideoCraft would try to take 1.5 seconds of video from the input AVI starting at the in-point. If there are not enough 
frames between the in-point and the out-point to sample the proper amount of time, VideoCraft will switch over the 
Whole Clip sampling.

Sampling by Frames means that VideoCraft should attempt to match the input with the output frame-for-frame. If the 
output is going to be 30 frames, VideoCraft should use 30 frames of the input video starting at the in-point. If there are 
not enough frames between the in-point and the out-point to sample the proper amount of time, VideoCraft will switch 
over the Whole Clip sampling.

Sampling Whole Clip means that VideoCraft will resample the frames between the in-point and the out-point to match 
the number of frames that is going to be created by the clip. For example, if there are 10 frames between the in-point and
the out-point and the clip is going to output 30 frames, each frame of the input video will be used 3 times.

Effect Options
The Effect Options dialog box has several features which can provide for greater control of the effects. 

THE EFFECT OPTIONS DIALOG BOX
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Color Shift
The Color Shift control will adjust the speed that colors shift from the Start image to the End image. This is normally a 
linear transition but this too can be speed up or slowed down. A setting of 100 starts slowly and ends quickly. A setting 
of -100 starts quickly and ends slowly.

Movement Speed
Movement Speed is used to add acceleration or deceleration to a clip and for creating natural movements. A setting of 
100 starts slowly and ends quickly; -100 starts quickly and ends slowly.

Effect Percentage
The Effect Percentage control determines how much of an effect will be applied. With the Variable setting, the effect 
will gradually increase from 0% to 100% across a clip. The Constant setting will fix a effect at a set percentage for the 
duration of the clip. This is useful for situations where you wish to hold a effect level constant over the duration of an 
entire clip (like embossing and entire AVI file at 100%). Even though the effect level is kept constant the AVI file will 
still be sampled normally.

Alpha Masks
Alpha Masks allow you to use any image or AVI file as a temporary alpha channel without having to keep the alpha 
channel merged inside the source materials. Start allows you to specify an Alpha channel for the Start image, End allows 
you to specify an Alpha channel for the End image. When AVI’s are used to provide alpha channel information, the 
Video Editing Options for that AVI will be enabled.

Output Options
To access the output options, click on the Video Parameters button on the Project Editor toolbar. Choose one of the four 
output types and use the Setup button to set its configuration. The Compression section of Video Parameters will change 
to reflect the current output type.

THE VIDEO PARAMETERS BUTTON

Please note that the settings for each output type are not saved with each project (.VPR) file. Thus, if you change your 
output settings often, be sure to check them before starting a long render. Also, additional output formats (AVI and FLC)
can be found in the standard version of VideoCraft.

Frames Output
When using VideoCraft with professional editing equipment, the best and most versatile video format is sequentially 
numbered frames.

The compression for frames can either be on or off. However, some formats ignore this setting. For example, JPG files 
are always compressed - therefore, setting compression to Off when outputting JPG files will have no effect. BMP files 
are always uncompressed - therefore, turning compression On when outputting BMP files will have no effect. A TGA 
(Targa) file is an example of a format that can be compressed or uncompressed.



GIF89a Animation Output
One of the promises of the Internet in the 21st century involves video on demand. While waiting for the fulfillment of this
promise, we have to settle to for low-bandwidth solutions. The GIF89a Animation format has quickly become the 
standard delivery mechanism for Internet animations. VideoCraft gives you flexible controls to create the perfect 
animation for your web page.

There are a plethora of options for GIF Animation output. Looping controls the number of times the GIF Animation 
should play. The Palette options define how the colors used in the animation should be determined. To determine the 
number of colors in the palette, choose the Colors option. As with FLC, Dithering can also be specified. Should you wish
to create a Transparent GIF (based on the Alpha Channel that you have defined) check off that option. The Speed of the 
Animation’s playback can be determined by the Frames Per Second (FPS) rating in the Video Parameters, or can be set 
to play back as quickly as possible. 

Because of the nature of GIF89a Animation files, they are always compressed. Thus, the Compression setting for GIF 
Animations is always ON.
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A Guide to the Tutorials
Here is a list of the tutorials contained in this manual. More tutorials and comprehensive information about VideoCraft 
can be found throughout the Online Manual on the CD-ROM.

Tutorial 1 - Loading and Rendering an Existing VideoCraft Project
Primary Topic:

Loading and using VideoCraft Project (VPR) files
Other Topics Covered: 

Create Video

Tutorial 2 - Creating a Morph Movie
Primary Topic: 

The Morph Editor
Other Topics Covered:

Loading Start and End images
Morph Points
The Preview window
Saving VideoCraft Project (VPR) files
Create Video

Tutorial 3 - Using the Colorize Editor
Primary Topic:

The Colorize Editor
Other Topics Covered:

Loading Video Clips into the Project Editor
Effect Options, Holding an effect at a constant percentage

Tutorial 4 - Using the Stylize Effects
Primary Topic:

The Stylize Editor
Other Topics Covered:

Using the Storyboard

Tutorial 5 - Creating a Blue Screen Overlay
Primary Topic:

The Overlay Editor
Other Topics Covered:

Acquiring objects on a blue background.

Tutorial 6 - Using the Distortion Effects
Primary Topic:

The Distortion Editor
Other Topics Covered:

Video Parameters - Quality Setting

Tutorial 7- Creating a Warp
Primary Topic:

The Warp Editor
Other Topics Covered:

The Preview window

Tutorial 8 - Using the Storyboard to Create a Sequence of Effects
Primary Topic: 

The Storyboard
Other Topics Covered:

Morphing
Creating Pauses in the Movie



Frames verses Frames Per Second
Transition Effects

Tutorial 9 - A Simple Example of Multiple Effect Layers
Primary Topic: 

Multiple Effect Layers
Other Topics Covered:

Colorize & Transition Effects

Tutorial 10 - Increase to 32-Bit, The Difference Between Opaque and Transparent
Primary Topic: 

The Colors Menu and Alpha Channels

Tutorial 11 - Using the Image / Mask Menu to Construct Basic Alpha Channels
Primary Topic: 

The Mask Menu Item and 32-Bit images
Other Topics Covered:

Colorizing 32-Bit Images

Tutorial 12 - Making Custom Faders Using 32-Bit Images
Primary Topic:

Alpha Faders in the Transition Effects

Tutorial 13 - Making an Overlay With a 32-Bit Image
Primary Topic:

Alpha & Inv. Alpha in the Overlay Editor

Tutorial 14 - Dynamic Masks
Primary Topic:

Using Effect Options to Specify the Alpha Channel

Tutorial 15 - Using Other Effects as Alpha Channels
Primary Topic:

Multiple Effects as Alpha Channels
Other Topics:

Image / Mask Menu
Distortion  and Colorize Effects


	Welcome to VideoCraft!
	In this manual
	Windows 95 versus Windows 3.1

	General Overview
	Getting Started with VideoCraft
	Tutorial 1 - Loading and Rendering an Existing VideoCraft Project
	Tutorial 2 - Creating a Morph Movie

	The Next Step... More Special Effects
	The Colorize Effects
	Tutorial 3 - Using the Colorize Editor
	Holding an Effect At a Constant Rate

	The Stylize Effects
	Tutorial 4 - Using the Stylize Effects
	The Transition Effects
	Direction Arrows
	The Faders
	The Background Color
	The Transition List

	The Overlay Effects
	Color Keying
	Blue Screening

	Tutorial 5 - Creating a Blue Screen Overlay
	Chroma Keying
	Luminance Keying
	Alpha Channel
	Texturize
	Text Overlay

	The Distortion Effects
	Video Distortions

	Tutorial 6 - Using the Distortion Effects
	Some things to know about distortion effects:

	The Warp Effect
	Tutorial 7 - Creating a Warp
	Tips on Positioning Warp Point Pairs


	Using the Storyboard
	Tutorial 8 - Using the Storyboard to Create a Sequence of Effects
	More features of the Storyboard
	Begin
	Left
	Load Clip
	Right
	End
	Cut
	Copy
	Paste
	Toggling the Storyboard Display


	Advanced Topics I: Multiple Effect Layers and Alpha Channel Compositing
	Multiple Effects
	What are Effect Layers?
	Changing Effects

	Tutorial 9 - A Simple Example of Multiple Effect Layers
	Alpha Channels and Masking
	What are Alpha Channels?

	Tutorial 10 - Increase to 32-Bit, The Difference Between Opaque and Transparent
	Tutorial 11 - Using the Image / Mask Menu to Construct Basic Alpha Channels
	Tutorial 12 - Making Custom Faders Using 32-Bit Images
	Alpha Channel Overlays

	Tutorial 13 - Making an Overlay With a 32-Bit Image
	Slider Explanation
	Varying the Transparency levels

	Tutorial 14 - Dynamic Masks
	Using AVI files as Alpha Channels
	Tutorial 15 - Using Other Effects as Alpha Channels

	Advanced Topics II: Motion Morphing and Warping
	Motion Morphing
	The Basic Process
	Smart Points
	Helpful Advice

	Motion Warping
	Smart Points
	Helpful Advice


	Image Editing within VideoCraft
	Opening Image Files
	Converting, Compressing, and Saving Images
	Color Reduction and Optimization - The Colors Menu
	Screen Capture
	Printing
	The Edit Menu
	Mistakes and Experiments: Undo
	Cut
	Copy
	Paste
	Paste Palette

	The Image Menu - Instant Image Editing
	Invert Image
	Flip Image
	Mirror Image
	Crop
	Scale
	Rotate
	Frame/Caption
	Tile
	Mask
	Contrast/Brightness
	Hue/Saturation

	The Filter Menu
	Sharpen
	Sharpen Lines
	Despeckle
	Emboss
	Blur
	Median
	Trace Edges
	Noise
	Maximum
	Minimum
	Old Movie

	Using VideoCraft as an OLE image server

	Video Editing, Effect, and Output Options
	Video Editing Options
	Effect Options
	Color Shift
	Movement Speed
	Effect Percentage
	Alpha Masks

	Output Options
	Frames Output
	GIF89a Animation Output


	A Guide to the Tutorials

