
Microangelo™ Quickstart User Guide

ATTENTION!
Icons can contain MULTIPLE IMAGES that support a SINGLE ICON. If you
only read some of this document, be SURE to read the next few sentences
before proceeding, to insure enjoying Microangelo as much as possible.

Windows 95 uses multiple-image icons. Windows 95 applications normally contain
several sizes and color formats for every icon image. These formats are used by
Windows 95 to provide different sizes of the icon in the best color format for your video
display. Windows 95 will choose the image format that will appear best on your desktop
or in a control when it is time for the icon to be displayed.

Microangelo provides complete access to all image formats within an icon. When an icon
library is opened with Microangelo Librarian for viewing or managing, and when an icon
resource is opened with Microangelo Studio for editing, be aware that there may be more
image formats that support the icon than the one that you are looking at. Both the
Librarian and the Studio have drop-down combo list controls towards the right on their
tool bars. Open the combo box and you will see a complete list of all of the image
formats available. Click on any image format to select it for use.

The remainder of this document will tell you the most important things to know about
Microangelo. It will take only a few minutes to read, and will provide you with valuable
information that is guaranteed to help you get the most out of Microangelo.

Another important source of information is Microangelo's online Help. This document will
provide a good foundation to begin with - the online Help will provide you with much more
information and tips to make your work easier. You are encouraged to refer to (or even
browse) the online Help index for specific tips and step-by-step instructions as you work.

More on Multiple-image Icons
Windows 95 can automatically select the best looking image for your display from
multiple image formats within an icon. The term image format refers to the size of the
icon and how many colors can be included in the image. A Windows 95 program should
contain icons that have image formats using 16 colors in 16x16, 32x32, and 48x48 in
size. Some of the best icons also include 256 color image formats. Windows 95 selects
the best appearing image format for your display from those that are available.

To see this first hand, open the Application Extension "Shell32" found in your Windows
95 "System" folder. Users who have the Microsoft Plus! package installed on their
system can get an even better example by looking at the "Cool" Application extension.

What's an Application Extension?
Windows 95 introduces long filenames and moves towards eliminating the three
character file extension that we are used to. Files are no longer referred to by cryptic
three character types, but by descriptive names. For example, program files, or "EXE"
files, are now referred to as "Application" files. Here are a few important file types and
their new names under Windows 95.

Old File Type New Type Name
EXE Application
DLL Application Extension
CUR Cursor
ICO Icon
ICL Icon Library



Microangelo uses the new type names when referring to files. Also, the term
"icons" is frequently used when referring to Icon Resource files, and "libraries" is
used to refer to Application, Application Extension, and Icon Library file types.

With that behind us, let's move on to the fun!

Where to start?
This Microangelo package contains five components: the Browser, Engineer,
Librarian, Studio, and the Animator. Here's a quick description of each
component - more hot tips for each one appear below.

The Browser Use it to assist you whenever you use Microangelo.
The Browser provides access to icons and files that contain them, such as Icon
Libraries, Applications, and Application Extensions. You can open these files
types to work with them, and be returned to the Browser when your work is
complete.

The Browser has intelligent tabs in its main window
that you can set to any drive and folder. The tabs are labelled to indicate the type
of file(s) that each one will access. Each tab seeks out files of its type and
displays only those that contain icons. What a time saver!

The Engineer Use it to change the system icons on your Windows
desktop, Start Menu, and other areas. The Engineer contains a System Settings
tab where you can choose among several options for your Windows 95 system
configuration. Select normal or high-color icons, choose to display or hide
shortcut arrows on Shortcut and DOS icons, and set other system options.

The Librarian Use it to view, create, and manage libraries of icons.
The Librarian can open Icon Library, Application, and Application Extension files.
You can create new library files and then drag and drop icons or other libraries
into the Librarian from Windows Explorer or from Microangelo's Browser.

Double-click on any icon to edit the images that it
contains. All image formats that support the icon will be passed to the Studio for
your edit session.

The Studio Use it to create or edit icons and cursors. Microangelo
Studio provides a rich set of editing tools and controls that will help you edit icon
and cursor images in all sizes and color formats. It is the only editor that we are
aware of outside of development tools used by programmers that provides this
level of performance.

The Studio can also import and scale 256 color bitmap
images to create stunning images with just a few clicks of the mouse.

The Animator Use it to create or edit animated cursors. Microangelo
Animator includes the rich feature set of the Studio component together with
options specifically designed for animating cursors.

More on the Browser
Although Microangelo Librarian and Studio can be launched by simply double-
clicking on an Icon Resource or Icon Library from Windows Explorer, many users
will find that the Browser can make their work even easier. Also, Windows 95
hides Application Extension files from its own pre-defined list of file types by
default when you install it. The Browser will display and allow access to all Icon



Resource, Icon Library, Application, and Application Extension files that contain
icons.

Double-click on any image in a tab and the Browser will open the file for work.
Icon files are opened with the Studio for editing and library files (files with more
than one icon) are opened with the Librarian.

The Browser's tabs have three display modes controlled by the tool buttons
directly above the Welcome tab. Select Report Mode to view details on icon files.
Click on a column heading to sort the items according to the information
contained in the column (clicking on Date or Time will sort on both Date and then
Time). Sort by "Icons" to find files with many icons, or by "Date" to easily work on
recent projects.

The tabs will stay positioned to the drive and folder that you set each of them to
until you move them to a new location. Each tab will also remember the last
viewing mode it was set to - set the view that you prefer for the different tabs.

More on the Engineer
The most recent addition to Microangelo is the Engineer. This component
provides a "one stop" location to change many of the system icons and cursors in
Windows 95. The Engineer allows updates to be selected manually one at a time
and can also read "motif" file sets or Plus! "theme" file sets for to quickly update
multiple icon and cursor images.

The Engineer opens in "Local" mode. This mode is the most common - it is used
to update icon settings on your system. You can change to "Motif" mode from the
main menu. Motif mode is used to create and edit motif file sets that allow
multiple icon and cursor updates to be collected and written into motif file format.
Icons and cursors are not updated on your system when the Engineer is in Motif
mode.

Local mode includes a System Settings tab where you can change icon related
settings on your system. Select whether you would like to use normal (16 color)
or hi-color (256 color) icon images. Choose normal (32x32) or Large (48x48)
icons and whether Windows will display shortcut arrows on your shortcut and PIF
linked icons. You can also change the spacing that Windows uses when it
arranges your icons and the icon font face and size it uses for descriptions.

Multiple tabs on the Engineer's display organize the various icons and pointers
(cursors) into related groups. A corresponding checkbox to the right of the tabbed
area is enabled whenever a new graphic has been selected for updating within a
tab. Checking or un-checking this box determines whether or not the tab's
updates will be applied to your system when you select the "Apply" pushbutton.
These check boxes are handy ways to help you select which updates will be
applied to your system if you open a motif or theme file set.

Microangelo Motif file sets can be opened in Local mode as well as Microsoft
Plus! theme file sets. The Engineer will stage the icon and pointer updates in the
tab controls for your inspection before you choose to Apply the changes to your
system.

More on the Librarian
Microangelo Librarian can update icon images within Application and Application
Extension files. These file types usually contain program code and other
resources in addition to icons. Microangelo only allows copying or editing of the



existing image types. Adding or deleting icons or icon images could very likely
cause undesirable results or failures within the components that rely on the
contents of these files.

The Librarian supports the creation and maintenance of custom Icon Library files.
These file types are 100% compatible with Windows 95 and other applications
that normally read icons from Application and Application Extension files.

The Librarian can open and operate on many file formats that contain icons. It
can even scan your computer, opening many files into one workspace. Use the
"Open All As Library" and "Include Subfolders" controls on the Librarian's Open
File dialog to determine what files you would like to include.

A small "traffic light" at the left of the Librarian's status bar will indicate yellow
when and Application or Application Extension has been opened to remind you
that the icons or images cannot be added or removed. The traffic light will display
green when an Icon Library is open and full updating is allowed.

If you see any icons in the Librarian window that you would like to collect into a
new custom library, select New Window on the File menu. Then drag the icons
into the new Librarian window. You can add as many icons you want before
saving the new library. Please refer to Microangelo's online Help for more
information and tips on selecting and dragging icons.

Select an icon with a right button click to access a pop up menu of commands
related to the icon, including a Properties page that displays information on the
current image and other available images. Right click on any area not occupied
by an icon to access the Property page for the Librarian's current workspace.

More on the Studio
Microangelo Studio provides equal or better editing features and access to icon
images than most commercial and professional icon editors. The Studio allows
you to work on all images contained in an icon in the same edit session. You can
copy and paste images from of one size and color format to another, making it
easier to create multiple-image icons. Separate "Undo" and "Redo" buffers are
used for each image being edited, and each 256 color image uses a separate
color palette that can be edited as required.

All editing Is performed in the grid area of the main window. The status panel to
the left of the grid displays an actual size view of the image currently being edited,
and the current A and B colors associated with the left and right mouse buttons by
many of Studio's drawing tools. The B color can also used as a background color
when dragging a selection or pasting. On the Tools menu, click Drag and Paste
to select opaqueness or transparency of Color B for these operations.

The View menu contains toggle selections for displaying or hiding Studio's
accessories. The color box contains color wells for every color used in the
current image. The tool box contains tool button access to all of the drawing
tools. The main window, color box, and tool box remember their last position on
your desktop and initialize to the same places when used later.

Click on the New Image Format tool button on the far right of the tool bar to add a
new image to the current icon. You can select the size and color format of the
new image. The Studio will open a new image filled with "screen". Use the
Image Format drop-down combo box to the left of the New Image Format button
to move to any image format in the current icon.



Use the Color Eraser tool to easily change one color to another. Select the old
color as Color A and the new color as Color B, then click and drag in the grid area
to selectively change pixels of one color to another.

Use Undo and Redo generously to experiment. The Studio can Undo many
changes, and Redo them back again. You cannot Redo changes that have been
undone after deciding to continue with more drawing.

On the Edit menu, Paste Special increases the power of standard paste
operations. You can paste directly from a 16 or 256 color bitmap on disk, and
paste into a currently selected area of your image for controlled sizing and
scaling.

Also on the Edit menu, Open Bitmap As New Image provides a better alternative
for using 16 and 256 color bitmaps than Paste Special when you are creating a
new image and would like to preserve the colors from the source bitmap. Using
the Open Bitmap As Image command causes the color of the bitmap file to be
read in and used for the image. This contrasts with using Paste Special to paste
a bitmap image, because the Studio will always keep the current color palette and
translate the incoming information when a Paste operation is performed.

More on the Animator
Microangelo Animator adds a well-balanced set of animation features to the solid
foundation already found in the Studio component. This self-contained utility
provides all of the tools required to create, edit, and preview animated cursors in
action.

For more information, please refer to Microangelo's online Help, available on the
Help menu or Help button of any Microangelo component.

We hope that you find Microangelo useful enough to decide to register it and
continue to enjoy using it on your computer. We believe that you will see that
Microangelo does much more than any other icon or cursor utility, and offers you
a higher return in value for your investment.

Thank you for taking the time to evaluate Microangelo. We hope to hear from you
soon!

The Impact Team


