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Introduction
Maintenance is an activity which aims at minimizing the incidence of production stops caused by the 
need for repair of broken equipment.    It also extends the economic life of the equipment maintained 
through this activity.

Maintenance is NOT a repair activity - it takes place before the need for repair arises.    However, 
whenever repair of broken down equipment must be carried out, carefully    kept maintenance and 
repair records serve to improve the activites of maintenance.

Keeping of appropriate maintenance and repair records therefore serve to enhance the productivity 
of the industrial plant.    Combining the information in these records with equipment inventory data 
facilitate making of decisions as to when equipment should be replaced and new items purchased.



What MPM is
MPM is short for Maintenance Planning and Management.    It is a tool for planning and management
of    the maintenance activities of an industry of any kind that uses equipment to produce its output.    
It can be applied to industry of any size, although it was essentially designed with medium sized 
industry in mind.



How MPM works
The principle of MPM is very simple:    First you assign inventory areas to your system, based on the 
location of the equipment.    Then you fill in on-screen 'cards' for inventory, maintenance and repair 
data.    This will be your database for your maintenance planning and management activities.    MPM 
will then provide a daily listing of what maintenance activites need to be carried out and display, print 
or file records for the maintenance and repair work done,    including downtime,    for future reference.

You may also run the companion programs SPARES and SUPPLY from within MPM.    SPARES is a 
program for management of the spare parts inventory and SUPPLY provides a database for supliers 
of equipment and spare parts. 

Inventory areas
Data cards
Daily maintenance listing
Reports and records
Data files





Data cards

Three cards
MPM uses three 'data cards' for each item of equipment. All three display the inventory area where 
the equipment is located, the inventory code and the name of the item of equipment.    In addition, the
cards    contain

n Inventory data,    that is,    the serial number of the equipment,    the year when it was purchased,   
its purchase price, the amount of annual depreciation and the present value ot the item;

n Maintenance data,    that is,    up to five maintenance activities, how frequently (in days) they 
should be carried out, the date of the last maintenance and the date when maintenance is due 
again;

n Repair and downtime data, with up to five records of repair or downtime.    For each of them it 
displays the date when it was done, what the problem was, how it was fixed and the downtime in 
working hours.

Note:
If the number of maintenance activities or repairs exceeds five, it may be necessary to create a 
second entry for the item of equipment.    Since the inventory code is used for sorting of data and 
must be unique for each set of cards, the second set would have to have a unique inventory code, as
well.    

To indicate that it is the same item of equipment, use the same title with an indication that the data is 
provided in two or more separate sets.    For instance,

                    Front end loader (a)
                    Front end loader (b) 

and so on.    This must be distinguished from the case in which there are several items of the same 
make and the same type.    In that case,    use Roman numerals, for instance,

                  Front end loader (1)
                  Front end loader (2)

and so on.





Reports and records

Principle
MPM provides listings of inventory, maintenance and repair data for each selected inventory area.    
These can be displayed on the screen, printed or saved to a file.

Display on the screen obviously serves the purpose of allowing a quick look at the status of the 
inventory, maintenance or repair data.    Printouts or filed data, however, are more meaningful as a 
means for future reference.

Establishing maintenance records
Records of maintenance or repairs can be established by printing or filing the corresponding listing at
regular intervals.    For instance, if    the maintenance listing is filed once every two weeks in a new 
file, there will be a record of all maintenance activities carried out between the dates of two 
consecutive files.

The period between two sets of records depends on how often the most frequent activity is 
undertaken and how important it is that records of such activities are kept.    It may even be 
necessary to file or print records every day or week.    Nevertheless, a likley frequency of recording 
data in this way is once a month.

Establishing repair and downtime records
The repair/downtime card includes five records of repairs or downtime.    In the long term this will not 
be sufficient.    Saving repair and downtime record listings from time to time in a file or as a printout 
accordingly provides a means of expanding the historical repair and downtime data.

By saving the repair and downtime records, say once every six months or once a year, the cards can
be updated to include only the most recent records.    How often records need to be saved in this way
depends mainly on how often the    cards get full.



Data files
MPM automatically stores the data you have entered in four files with the same name but different 
extensions.    For instance, if you have named the file for your data 'MYDATA',    the data will be 
stored in 

                    MYDATA.MP1
                    MYDATA.MP2
                    MYDATA.MP3
                    MYDATA.MP4.

The first time you save your data, you will be prompted for a name for the file.    The dialog box will 
display the extension '*.mp1'.    There is no need to add an extension to the filename.    MPM will do it
automatically for all four files.

Similarly, to load data, simply load the file MYDATA.MP1, and all the other files will be loaded, as 
well.



System requirements

Hardware requirements
n Personal computer using 286 type microprocessor or higher (386 type or higher recommended).
n 2 MB of memory (5 MB recommened).
n EGA, VGA, Super-VGA, XGA, 8514/A or compatible video card with corresponding monitor.
n Mouse

Software requirements
n Microsoft DOS version 3.1 or higher.
n Microsoft Windows version 3.0 or higher (Version 3.1 or higher recommened).



Help on Help
You have access to Help in three ways:    As    a specifc menu item in the Help menu, by pressing the 
[F1] key or from the Help button in the dialog boxes.

Help as a menu item
The Help menu has two options for calling Help.    First, 'Help on MPM' which gives you the Contents 
screen of Help.      From this you can access all the other screens and read them as a manual for 
MPM.

Second, there is the 'Help on Help' option, which calls this screen.

Help from F1
Help obtainable by pressing the [F1] key is context-sensitive, that is, the Help screen displayed 
depends on what menu option has been selected before [F1] was pressed.

If no menu selection has been made,    Help displays its Contents screen.    Please note that Help 
cannot be accessed by pressing [F1] when a dialog box is displayed.    

Help for dialog boxes
The only way to access Help when a dialog box is displayed is by clicking on the Help button of the 
box.    This displays the Help listing for dialog boxes



Getting started
Closing the logo
Opening a new file
Changing inventory areas
Setting date format
Creating new data
Saving your work
Loading data



Logo
The logo is displayed continuously on the screen.    If you want to remove it, point the mouse at it and
press the right mouse button.    Alternatively, press any key, except the [Alt] key.



Opening a new file
To start a new maintenance management system for your industry, you need to create the set of files
needed for the database.    You may also want to change the default field areas according to your 
specific requirements.

To start this, simply click on 'New' in the File Menu.    This clears the memory of any previous work 
and sets the default inventory areas.    You are now ready to create your database.





Setting    date format
The international date format (dd/mm/yy) is the default of the program.    To change this to the US 
format, mm-dd-yy, or ISO, yy.mm.dd, click on 'Preferences' in the File Menu.

Click on the down arrow in the dialog box and select the date format of your preference.    Your 
choice will be retained in your system when you save the data.

Please note that    in addition to accepting three different orders of entry of day, month and year, the 
program also accepts three different separators, a slash (/), a dash (-) and a dot (.). 

 An important point on entering the date in your maintenance card is that if there are les than two 
digits in the entries for day and month, you must enter leading zeros.    For instance, enter 05/08/93,   
NOT 5/8/93.    The program will not accept the latter.

If you wish to use a format diferent from the default, you must make your selection of format at the 
beginning of establishing the database.    If the format is changed later, all date entries in you cards 
must be revised.



Creating new data

New data cards
To create new data cards, click on 'New' in the Inventory Menu.    This displays and empty 'Inventory 
card'.    Click on the down arrow for 'Area' and select the inventory area under which the data will be 
entered.

Press the [TAB] key which brings the vertical cursor to the window for entry of an inventory code.    
Please note that    the inventory code is used by the program for sorting of data.    Accordingly the 
code must be unique to that particular item of equipment.    

Enter an inventory code.    If the code entered is already in use, the program will alert you to this and 
ask you to correct the code.    Press the [TAB] key again and enter the information requested until the
inventory card is completed.    Click on 'OK' or press [ENTER].

A 'Maintenance card' will be displayed.    The top half has already been completed by MPM, based on
the information in the inventory card.    Again, use the [TAB] key to move around between the entries 
and enter the data requested.    Please note that you do not need to enter the date of the next 
maintenance due in each case.    This will be added by the program afterwards. Click on 'OK' or 
press [ENTER] when finished.

On entering dates, use consistently the date format selected from the menu item 'Preferences'.    Be 
especially careful to enter dates with leading zeros if there are less that two digits in the date.    For 
instance, enter '05/08/93 NOT 5/8/93.    Otherwise the program will not accept the input.

Since the database is being established, it is unlikely that there would be any repair or downtime 
records to add to the 'Repair card' at this stage.    Otherwise the procedure is the same as for the 
inventory and maintenance cards.    Press [ENTER] or click on 'OK'.    One set of data has now been 
added to your database.

Related topics
Data cards



Saving your work

Save as...
Use this option in the File Menu when you have started a new database or if you want to save your 
work in a file separate from the work included in the file you originally loaded into the program.

A dialog box will display the default directory of files with the extension '*.mp1'.    If you want to store 
the file in a different directory, double-click on the symbol for the root directory (shown as[..]) until the 
directory of your choice is displayed. 

Double-click on the name of your choice for the file, if it is an existing file, or type a name for your file,
without extension.    MPM will add the extension for the set of files stored under the name or your 
choice.

Related topics
Data files



Loading data

Loading the data
To load existing data already saved in a file, click on 'Open' in the File Menu.    If the dialog box does 
not display the directory in which you have stored the data, double-click on the root directory symbol 
until the directory is displayed and select it by double-clicking.

Select your data file from the list of files and click on 'OK' to load the data.    This will load four files 
with the same name and the extensions *.mp1, *.mp2, *.mp3 and *.mp4.

Related topics
Data files



Menu commands
File menu
Area menu
Inventory menu
Maintenance menu
Repair menu
To do... menu
More menu
Help menu



File menu
The File menu has seven commands:
n New - to start a new maintenance file.
Opening a new file

n Open - to load and existing maintenance file.
Loading data

n Save as - to save a new file or to save a file under a new name.
n Save - to save your work on an existing file.
Saving your work

n Preferences - to select your preferred date format.
Setting date format

n Printer setup - to select printer or change its setup.

n Exit - to exit from MPM.













More menu
The 'More' menu has two options:
n 'Spare parts inventory' which calls SPARES for spare parts inventory    management.
n 'Supplier's database' which calls SUPPLY for the database on suppliers.

NOTE:    If you have been working and changing data under MPM, you must    save your work before 
switching to these two programs.    Otherwise you may lose you new data on loading data for 
SPARES or SUPPLY.



Help menu
This menu has three options:

n Help on MPM - this file.
n Print registration form - to make it easy for you.
n About... - some information on MPM



Procedures
Changing inventory areas
Setting date format
Viewing /Editing data
Deleting data cards
Adding new data cards
Maintenance due
Display lists
Print lists
File lists
Spare parts inventory and supplier's database





Edit data cards
To edit or view data cards proceed as follows:
n Click on Select/Edit in the Inventory menu and select the area where the equipment is located.
n From the listing of items, select the item of interest.    This will display the inventory card for the 

item.
n If some data need to be modified in the inventory card, move the cursor to the entry windows by 

pressing the [TAB] key.    Modify the data as required.    Click on 'OK'` when you are finished.
n Click on 'Card' in the Maintenance menu.    This will display the maintenance card for the item 

selected.    Edit it as required in the same way as for the inventory card and click on 'OK' when 
finished.

n Click on 'Card' in the Repair Menu.    This will display the repair data card for the item.    Edit it as 
required in the same way as for the inventory card and click 'OK' when finished.

Note:
This is the procedure used to change the maintenance date settings in the maintenance card.



Delete data cards
To delete a set of data cards, the procedure is as follows:

n Click on Select/Edit in the Inventory menu and select the inventory area in which the equipment 
is located;

n From the display that follows, select the item which corresponds to the set of cards to be deleted.
The inventory card will be displayed.

n Click on the 'Delete' button.    A warning will be displayed.    Click on the 'Yes' button and the data 
on that item of equipment is deleted.

Please note that this deletes the whole set, that is, the inventory, maintenance and repair data cards.





Display lists
Lists can be displayed on the screen for the main inventory, maintenance and repair/downtime data,  
as well as for maintenance work due.

All these lists are displayed in two windows;    one at the top with the headings of the list and the 
second underneath with the actual data.

When you have finished scrolling/viewing such a list, point at each of the two windows and press the 
right mouse button to close them.    Failure to do this, will cause interference in the display of 
subsequent lists.



Print lists
Lists can be printed for the main inventory, maintenance and repair data of an area,    as well as for 
maintenance work due.

Selection of this option under the Inventory, Maintenance, Repair or To do... menus displays a dialog 
box which allows selection of printer and changing of printer setup, if needed.



File lists
Lists can be saved to a file for the main inventory, maintenance and repair data,    as well as for 
maintenance work due for the area selected

Enter a name and the path for the file, as prompted in the dialog box..



Spare parts inventory and suppliers database
MPM has two companion programs, SPARES and SUPPLY.    The former is for management of the 
spare parts inventory and the latter for a database on suppliers of equipment and spare parts.    Both 
can be accessed through MPM or run separately.    To access these programs within MPM, click on 
the choices in the 'More' menu.



Dialog boxes
A number of commands or activities are controlled by dialog boxes, the most important of which are:

New inventory card
Inventory area select box
Inventory list
Inventory card
Maintenance card
Repair record card















Copyright
Copyright © 1993
Borje Kyrklund
All rights reserved



Registration
It is in your interest to register your copy of MPM as soon as possible.    As a registered user, you will 
be notified of future upgrades and you will also have access to technical support.

Registration by mail or fax
Registration by E-mail



Registration by mail or fax
In the Help menu, click on 'Print registration form' to obtain a copy of the form.    Complete the form 
and either

n send it by mail to:
          
                    Borje Kyrklund
                    Via dei Radiotelegrafisti 28 B 3
                    00143 - Rome, Italy

n or fax it to +(39-6) 592-0773.

Note that 39-6 is the IDC for Rome, Italy



Registration by E mail
Click on 'Print registration form' in the Help menu and send the information requested in the form by 
E-mail on Compuserve to Borje Kyrklund, CIS 100013,375.



Technical support
Technical support is available by mail, fax and E-mail by stating the serial number of your copy of 
MPM.
n By mail:              Borje Kyrklund

                                      Via dei Radiotelegrafisti 28 B 3
                                      00143 - Rome, Italy

n By fax:              +(39-6) 592-0773

Please note that (39-6) is the IDC for Rome, Italy
n By E-mail:      Borje Kyrklund

                                    Compuserve ID 100013,375



Support by mail or fax



downtime
The time in working hours, during which the equipment is idle, either because of repair or because of 
scheduling or other problems.



inventory areas
The inventory areas group the equipment according to in what department/division it is or its general 
location.






