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What Is WiZ ?

WiZ stands for Windows Info-ZIP. WiZ is a Microsoft Windows application which extracts, 
tests, and displays files archived in ZIP archive format, as well as creating archives in the 
same format.

WiZ is derived from a cooperative effort by a number of developers collectively known as 
Info-ZIP. (See Who is Info-ZIP ?). Info-ZIP's goal is to provide widely-available, non-
commercial archiving tools compatible with Phil Katz's popular DOS application products, 
pkzip and pkunzip. Info-ZIP's counterpart products are called zip and unzip respectively. WiZ 
4.0 is Info-ZIPs Windows GUI implementation of both zip and unzip and can extract, or 
update files from archives created using pkzip 2.04 or earlier, as well as create archives 
compatible with pkzip 2.04 or earlier.

The unzip logic of WiZ is based on Info-ZIP's product unzip, which has been ported to a 
number of platforms. Likewise, the zip logic is based on Info-ZIPs product zip. WiZ is 
essentially zip and unzip with a Microsoft Windows interface and a little extra logic to 
archive, display and extract files. 

The bitmap displayed as a splash screen in the 32 bit version was created using POV-Ray for 
Windows 3.0. An excellent program for those of you interested in ray-traced graphics.

WiZ has its origins in WizUnzip created by Johnny Lee and Robert Heath. Although it has 
been extensively re-written for one reason or another, WiZ would not be what it is today 
without their work. A tip of the virtual hat to them both.

In keeping with Info-ZIP's goals, WiZ is available on a not-for-profit basis. (See Copyright and 
Distribution.) 



Installing WiZ from

Install the WiZ executable file, WIZ.EXE, its DLLs (ZIPxx.DLL and UNZIPxx.DLL, where xx is 
either 16 or 32 depending on whether you are installing the 16 bit or 32 bit version), its help 
file, WIZxx.HLP, (where xx is either 16 or 32 depending on whether you are installing the 16 
bit or 32 bit version) and the associated data files, SFX*.DAT, by copying them into any 
directory listed in your system's PATH environment variable. Although it is not required, it is 
possible to put the dlls into a different directory than WiZ itself, as long as that directory is 
listed is your systems PATH environment variable.

If you are installing the 32 bit version, you will also need wiz32.cnt copied into the same 
directory as your executables.

Though not necessary for proper operation, the WiZ unzipping sound file, WIZUNZIP.WAV, 
may be installed on any directory listed in your system's PATH environment variable. Your 
WINDOWS directory is usually such a directory.



Archives Menu

The Archives menu includes commands that let you select or de-select all of the 
ArchiveDirectoryListbox entries as well as commands which operate on the archive (ZIP file) 
itself.

For more information, select an Archives menu command from below.

Select All Files
Deselect All Files
Select Files by Pattern
Delete Entries in Archive
Update Archive Entries
Extract
Display
Test
Get Complete Archive Info
Show .ZIP Comment
Archive Statistics

Note that these commands are also available by clicking the right mouse button while the 
cursor is in the ArchiveDirectoryListbox 



Archive Statistics

This option will provide you with the following information about the archive in a message 
box:

Size
Compressed Size
Compression Ratio
Number of Files in the archive



Selecting An Archive Name

You need to select an archive name (and directory.) You select the directory as you would 
any other directory under Windows with a file open dialog box. You may then choose either 
an existing archive, or create a new archive. Press OK to continue on to the file selection 
dialog box.



Selecting Files For An Archive

In the file selection dialog box, you have the option of setting a reference directory. This 
directory should be the highest level directory for all the files in the archive. Your selection 
will be shown at the bottom of the dialog box.

For example: If you have (or want to have) an archive that contains files from the directory \
foo, and you want to retain the directory names, then you should select the root directory of 
that drive. If you have an archive that contains files from the directory \foo and the 
directory \foo\bar you should also select the root directory as above. If not, then you should 
set the reference directory to be the same as the directory you are in.

What setting a reference directory does is save a string with the drive and path of the 
reference directory. Just prior to archiving, this reference directory string is compared to the 
drive and path name of each file. If a portion of the path is the same as the reference 
directorys, that portion is stripped off.

You should then select the files you wish to add to the archive. The file names you select will
be added to the listbox at the right of the dialog box when you press the >>Add>> button. 
If, for some reason, you decide you dont want to add particular files, simply highlight the 
files you dont wish to have put into the archive, and press the <<delete<< button.

If you want to include all the files shown in the file selection listbox, you may do so by 
pressing the Select All button, then pressing the >>Add>> button. Alternatively, you can 
simply press the Include button.

To select all the files (e.g. *.c) in the current directory, and in all the subdirectories below the
current directory, press the Recurse button. Note that this search is done immediately upon 
pressing the Recurse button, rather than when the archive is actually created.

If you wish to change any of the zip options, pressing the options key will take you to a 
temporary options dialog box which allows you to change the zip options only for this 
particular archive. Upon the completion of creating this archive, the options will be set back 
to their previous state.

When you are ready to create (or update) the archive, press the OK button. The dialog box 
will disappear, and an hourglass cursor will appear. Nothing will appear to happen for a 
second or two as a list of the files to be archived is created, then you will see messages 
begin to appear in the Edit/Status window informing you of which files have been archived.

There are numerous buttons in this dialog box. The following is a brief description of each 
button, and what it does.

Select All - This button selects all the files shown in the file selection list box. Once 
selected, you must still add them to the selected files list box.

Deselect All - This button de-selects any selected files shown in the file selection list box.

Set Root - The button sets the root (reference) directory for all archiving done for this 
particular archive. What setting a reference directory does is saves a string with the drive 
and path of the reference directory. Just prior to archiving, this reference directory string is 
compared to the drive and path name of each file. If a portion of the path is the same as the 
reference directorys, that portion is stripped off. It is not required that a root directory be 
selected. In that case, each file archived will be archived with a fully qualified path name.



Deselect Root - This button removes the root (reference) directory, assuming one is set.

>>Add>> - This button adds any files that have been selected to the selected files list box.

<<Delete<< - This button only is active when you highlight a file or files in the selected 
files list box. When pressed, it will remove the selected files from the selected files list box.

OK - This button will make an archive containing the files you have selected for inclusion.

Cancel - This button will cancel the creating archive function entirely.

Options - This button will allow you to temporarily set the zip options for this archive only. 
These options will not be saved.

Recurse - This button will allow you to recurse the current directory, and any sub-directories
below it. This acts on whatever file selection(s) you have entered in the Recurse/Include edit 
window.

Include - This button will allow you to simply include (with wild cards) the file selection(s) in 
the Recurse/Include edit window. Assuming that you have typed in *.txt, then pressing the 
include button will result in the selected files list box showing <path>\*.txt rather than each 
individual file.

Help - This button brings you to this help screen.

Network - If present, added by the system to allow you to map a network drive.



Update Archive Entries

This menu item updates the selected entries in the Archive Directory Listbox according to 
the zip options selected. You will be asked for confirmation that you really want to do this. 
Assuming that you do, you will then be asked to set a reference directory. This directory 
should be the highest level directory for all the files in the archive.

For example: If you have an archive that contains files from the directory \foo, and you wish 
to include the directory name foo, then you should select the root directory of that drive. If 
you have an archive that contains files from the directory \foo and the directory \foo\bar you 
should also select the root directory as above. However, if you have files listed in the archive
as bar\myfiles.c, and the directory bar is a subdirectory of \foo, and you do not want to 
include the directory name foo, then you should select \foo as the reference directory.



Delete Entries in Archive

This menu item deletes the selected entries in the Archive Directory Listbox from the 
archive, and then redisplays the remaining entries in the Archive Directory Listbox.

You will be asked for confirmation that you wish to delete these entries. After the entries are 
deleted, the Archive Directory Listbox will be updated with the current entries in the archive.



Adding Comments to an Archive

To add your comment to the archive, or change an existing comment, simply type in the text
you wish to add in the edit box. The edit box acts just like notepad does, without the find, 
replace etc. capabilities.



File Menu Create Zip Archive…

This menu item allows you to create or update an existing archive, according to the zip 
options selected. the selected entries in the Archive Directory Listbox according to the zip 
options selected. Assuming that you do, you will then be asked to select an archive name 
(and directory.) You may choose either an existing archive, or create a new archive. Press OK
to continue on to the file selection dialog box.

In the file selection dialog box, you have the option of setting a reference directory. This 
directory should be the reference for all the files in the archive. Your selection will be shown 
at the bottom of the dialog box.

For example: If you have (or want to have) an archive that contains files from the directory \
foo, and want to retain the directory name foo, then you should select the root directory of 
that drive. If you have an archive that contains files from the directory \foo and the 
directory \foo\bar you should also select the root directory as above. This is true if you wish 
to retain the directory names with the file names. If not, then you should set the reference 
directory to be the same as the directory your files are in.

What setting a reference directory does is saves a string with the drive and path of the 
reference directory. Just prior to archiving, this reference directory string is compared to the 
drive and path name of each file. If a portion of the path is the same as the reference 
directorys, that portion is stripped off.

You should then select the files you wish to add to the archive. The file names you select will
be added to the listbox at the right of the dialog box when you press the >>Add>> button. 
If, for some reason, you decide you dont want to add particular files, simply highlight the 
files you dont wish to have put into the archive, and press the <<delete<< button.

If you want to include all the files shown in the file selection listbox, you may do so by 
pressing the Select All button, then pressing the >>Add>> button. Alternatively, you can 
simply press the Include button.

To select all the files (e.g. *.c) in the current directory, and in all the subdirectories below the
current directory, press the Recurse button. Note that this search is done immediately upon 
pressing the Recurse button, rather than when the archive is actually created.

If you wish to change any of the zip options, pressing the options key will take you to a 
temporary options dialog box which allows you to change the zip options only for this 
particular archive. Upon the completion of creating this archive, the options will be set back 
to their previous state.

When you are ready to create (or update) the archive, press the OK button. The dialog box 
will disappear, and an hourglass cursor will appear. Nothing will appear to happen for a 
second or two as a list of the files to be archived is created, then you will see messages 
begin to appear in the Edit/Status window informing you of which files have been archived.



De-select All Files

This menu item de-selects and unhighlights all entries in the ArchiveDirectoryListbox. 

WiZ dims all the buttons associated with selected    files, as well as greying out the 
appropriate menu items.

You may then select one or more entries in the listbox using the pointer or the keyboard. 

Selecting one or more entries in the ArchiveDirectoryListbox causes the buttons and menu 
items to become active again. 

Select any of the buttons to operate on the selected entries.

Pressing the F3 key or clicking on the  button is a short-cut to de-selecting all 
ArchiveDirectoryListbox entries.



Select All Files

This menu item selects and highlights all entries in the ArchiveDirectoryListbox. 

WiZ activates (if not already activated) the buttons and menu items that relate to operations
regarding files contained within the archive.

Select any of these buttons (or menu items) to operate on all selected entries in the archive.

Pressing the F2 key or clicking on the  button is a short-cut to selecting all 
ArchiveDirectoryListbox entries.



Select Files By Pattern

When archives contain a large number of files, you can choose the files to be selected by 
specifying patterns in the filenames. Note that you may specific a path as well as the file 
names if paths are included in the archive file names.

This menu item opens the Select Files by Pattern dialog box. It prompts you to enter a 
pattern by which files in the ArchiveDirectoryListbox are selected. 
Your pattern may contain wild card characters such as *, ?, and character lists surrounded by
square brackets. For example *.[ch] will list all files with a file extension of .c or ch.

Note that if directory names are included in the archive, the directory will be separated from 
the file name by a slash ( / ), rather than a backslash ( \ ).

You may enter multiple patterns, separated by white space, in the edit field.
Choose the Select button to highlight your choices in the ArchiveDirectoryListbox. The files 
can then be extracted, displayed, or tested using any of the three push buttons. 

You may alternately deselect files in the Archive Directory Listbox by first specifying a 
pattern then choosing the Deselect button.

After making all your selections and deselections, you may close the dialog box by selecting 
the Done button. 

Pressing the F4 key or clicking on the     button is a short-cut to the Select Files by 
Pattern dialog box.



Edit Menu

The Edit menu includes commands that let you control the Edit/Status Window.    The actual 
edit controls such as cut, copy, paste etc., are controlled by the right mouse button when 
clicked in the Edit/Status Window.

Clear Edit Window  Clear all text from edit window



Clear Edit/Status Window

This menu item clears the Edit/Status Window. 

WiZ automatically clears your Edit/Status Window if its contents would either exceed the 
amount of memory available (to WiZ) in your system or reach 65535 characters. If you have 
prompting turned on, you will be notified each time this happens, and will have the option of
not clearing the window.

Pressing the Del key is a short-cut to clearing the Edit/Status Window as is the  button.



Menu Bar

WiZ's Menu Bar contains the following menus:

File Menu Operates on files and directories
Edit Menu Clipboard functions.
Archives Menu Operates on files within an archive
Search Menu Search archives for file names
View Menu Controls general appearance
Options Menu Sets and remembers preferences
Help On-line documentation



Search Menu

This menu selection has one menu item, Search Archive. Search archive will allow you to 
search through all archives in a directory for files of a given pattern. Search archive will also 
search through all archives in any sub-directories under the selected directory.

The results of this search will be displayed in the Edit/Status window.



File Menu

The File menu includes the following commands:

Create Zip Archive Creates an archive
Open Archive Opens an archive and lists its directory.
Unzip Archive To Changes the directory into which WiZ extracts files.
Copy Archive Copies the archive to a different filename and/or directory.
Move Archive Moves the archive to a different filename and/or directory.
Delete Archive Deletes the archive.
Rename Archive Renames the archive.
Make Directory Creates a directory.
Exit Exits WiZ.

Note that the Copy, Move, Rename, and Delete archive commands are also available when 
you click the right mouse button in the ArchiveDirectoryListbox 



File Menu Open Archive Command

If you select the File menu's Open command or click on the button bar's  button, WiZ 
brings up the Open Archive dialog box.

Open Archive Dialog Box

This dialog box lets you select the ZIP archive on which you may perform further operations.
Select the directory in which the ZIP archive is found.
When you select a directory,    WiZ lists all of the Zip archives, files with suffix .ZIP, in the file 
listbox.
The File Name field starts out as a template of all the ZIP archives in the directory.

You may select archives with other suffixes using the Files of Type combo box. 
You may select self-extracting .ZIP files, which have the .EXE suffix. However, not every file 
with a .EXE suffix is a self-extracting .ZIP file. WiZ lets you safely attempt to open the file to 
find out.

Select an archive either by clicking on its filename from the file listbox or by typing its name 
in the File Name edit box.
Select the OK button to put your choice into effect.

Select the Cancel button if you don't wish to open a new ZIP archive.

When you open a ZIP archive, WiZ displays the archive contents in the Archive Directory 
Listbox of its main window. 
WiZ does not automatically extract the contents.    See Extracting Files from the Archive to 
find out how to extract files.

You may unzip the archive contents either into the directory where the .ZIP file lives or into a
separate directory.
See the File Menu Unzip To Command and the Unzip to Same Directory as .ZIP item under 
the Options Menu for more information.



File Menu Unzip To... Command

Selecting this command or clicking on the  button lets you change the directory into 
which WiZ extracts entries from the current ZIP archive.
You may extract files into a directory other than the one in which the ZIP archive file resides.

If the    command or button is grayed, you may enable it by toggling the Unzip to Same 
Directory as .ZIP item under the Options Menu. 

If you don't select a destination directory, WiZ assumes you wish to extract files into the 
same directory as the ZIP archive 
The Unzip To... command produces the Unzip To Dialog Box.

Unzip To Dialog Box

This dialog box lets you browse and select a destination directory for unzipped archive 
entries.

The Directories listbox shows where WiZ places extracted files.

You may browse the directory tree by repeatedly selecting directories from the Directories 
listbox.

To automatically change to the selected directory the next time you start WiZ, select the 
Save as Default checkbox.

Select the OK button to save the new directory as the one to which WiZ extracts files.    
The new destination directory appears on the title bar.

Select the Cancel button to return to the directory displayed on entry.

NOTE:
The Drives listbox shows all drives in the system. 
However, you won't be able to select write-protected drives such as CD-ROM drives and 
certain network drives.



File Menu Copy Archive Command

Once you have opened an archive, this command lets you make a copy of it. See Opening an
Archive. 

Copy Archive Dialog Box
Selecting this command opens the Copy Archive dialog box in which you enter the name to 
be given to the copy.

You may also select a different directory for the copy of your archive file.    The destination 
directory must be writable (i.e. not on a CD-ROM or write-protected network drive.)



File Menu Move Archive Command

Once you have opened an archive, this command lets you move the archive file.

Move Archive Dialog Box
Selecting this command opens the Move Archive dialog box in which you enter the new 
name to be given to the archive file.

You may also select a new directory for your archive file. The destination directory must be 
writable (i.e. not on a CD-ROM or write-protected network drive.)



File Menu Delete Archive Command

Once you have opened an archive, this command lets you delete the archive file.

The command opens a dialog box which offers you a chance to change your mind.

If you decide to continue, WiZ closes the current archive and deletes the file from your disk.

The  button is a shortcut to this operation.



File Menu Rename Archive Command

Once you have opened an archive, this command lets you rename the archive file.

Rename Archive Dialog Box
Selecting this command opens the Rename Archive dialog box in which you enter the new 
name to be given to the archive file.

You may also select a new directory for your archive file. The destination directory must be 
writable (i.e. not on a CD-ROM or write-protected network drive.)



File Menu Make Directory Command

This command lets you create a new directory.

You may wish to create a new directory before extracting the contents of a ZIP archive.

This menu command takes you to the Make Directory Dialog Box. 

After creating a new directory, you may wish to extract files to it using the Unzip Archive To 
command.



Make Directory Dialog Box

This dialog box allows you the create a new directory or subdirectory on your system.

You may wish to create a subdirectory into which you can extract files from an archive.

The dialog box lists the current directory in which the files will be extracted.    

In the field entitled Enter path for new directory you may specify any of:

1) a subdirectory under the current directory, e.g.

mynewdir

2) an absolute path on the current drive, e.g.

\mynewdir

3) or, a full pathname, including drive, e.g.

c:\mynewdir

Select the OK button or just hit the Enter key to apply your selection.



File Menu Exit Command

This command takes you out of WiZ. 
To find out other ways to exit WiZ, see Exiting WiZ.



Exiting WiZ

You may exit WiZ by any of the following methods:
1) typing Alt-F4, 
2) selecting Exit from the File Menu, or 
3) selecting Close from WiZ's system menu, or

4) by clicking on the  button.

You may safely exit WiZ at any time without fear of losing data.



Options Menu

The Options menu lets you specify how WiZ handles directories as well as where WiZ puts 
files extracted from the archive. The options menu also lets you set the various unzip and zip
options which will be stored in the wiz.ini file.

For more information, select any of the following items:

Always Save Unzip To Dir
Always Save Unzip From Dir
Always Save Zip To Dir
Unzip to Same Directory as .ZIP
Unzip Options
Zip Options
Sound Options

WiZ saves your option selection(s) permanently until you replace it with another.



Save Zip To Dir

When checked, this option directs WiZ to save the last directory an archive was created or 
updated in, to be used as the archive creation directory the next time you run WiZ, or create
another archive.



Unzip Options

During extraction, WiZ may encounter files in the destination directory which have the same
names as those WiZ would extract from the archive.    
The following three options help WiZ handle conflicts:

Always Overwrite Existing Files 
Extract Only Newer Files 
Prompt to Overwrite Existing Files 

Recreate Directory Structure Lets you retain directory structure or not.
Translate LF to CR-LF Translates LF character to CR/LF character pair.
Translate Filename Spaces to Underscore maps space characters in filename to underscore

The following three items let you define the action taken when you double-click on a file in 
the ArchiveDirectoryListbox: 

Listbox Selection Extracts File Double click extracts entry.
Listbox Selection Tests File Double click tests entry.
Listbox Selection Displays File Double click displays text file.



Recreate Directory Structure

During file extraction this option specifies whether or not WiZ re-creates subdirectories 
saved within the archive. 

When this option is active, a checkmark appears beside its menu item.

When this option is active, WiZ extracts, preserving the directory structure present in the 
archive.

When this option is not active, WiZ extracts the files from subdirectories listed in the archive 
into the parent directory.

WiZ saves the setting of this option in your WIZZIP.INI file until you change it again through 
the menu.



Always Save Unzip To Dir

When checked, this option directs WiZ to save the last Unzip To directory selected, to be 
used as the initial Unzip To directory the next time you run WiZ.



Always Save Unzip From Dir

When checked, this option directs WiZ to save the last directory in which an archive file was 
opened, to be used as the initial directory in which to search for an archive the next time 
you run WiZ.



Extract Options

During extraction, WiZ may encounter files in the destination directory which have the same
names as those WiZ would extract from the archive.    
The following options help WiZ handle conflicts:

Always Overwrite Existing Files
Extract Only Newer Files
Prompt to Overwrite Existing Files



Always Overwrite Existing Files Option

When you choose this option, WiZ automatically overwrites each existing file that it finds 
during extraction. 

WiZ saves the setting of this option in your WIZ.INI file until you change it again through the 
menus.

Overwrite Existing File Dialog Box

When you don't choose the Overwrite Existing Files option, WiZ prompts you with a dialog 
box for each existing file that it would replace during extraction. The dialog box prompt gives
you five alternatives.    You may:

(1) skip the file without extracting it (the default),
(2) overwrite the file,
(3) overwrite the file and all others in this operation,
(4) overwrite none of the files in this operation,
(5) rename the conflicting file.

If you select (3) or (4), the Overwrite Existing Files Dialog Box won't appear for the rest of 
the operation if any more files should conflict with existing files.
The Overwrite Existing Files Dialog Box has no effect on the more permanent Overwrite 
Existing Files Option. 



Encrypted Files

WiZ can extract files from an encrypted archive, but you must first know the password.

Encrypted File Dialog Box

When you first attempt to extract, display, or test a file from an encrypted archive, WiZ 
displays the Encrypted File dialog box, prompting you for the password with which the 
archive was encrypted.    

As you type the password in the Password field, WiZ echoes the password as a series of 
asterisks. 

If you enter the correct password, WiZ proceeds with the operation.    

If you enter the wrong password, WiZ gives you two more chances to enter the right 
password then cancels the operation.

If you forget the password or do not know the password of an encrypted archive, there is no 
way to extract, display, or test the archived files using WiZ.



Extract Only Newer Files

This option directs WiZ to automatically overwrite a file in the destination directory with a 
newer file from the ZIP archive if their names match. 

WiZ saves the value of this option until you change it again. 



Prompt to Overwrite Existing Files

When active, this option directs WiZ to prompt you about overwriting a file in the destination
directory with a file from the ZIP archive if their names match. 

Selecting this option disables both the Always Overwrite Existing Files option and the Extract
Only Newer Files option. 

WiZ saves the value of this option until you change it again.



Translate LF to CR-LF

Choose this option only if you are extracting text files from a UNIX or similar computer and 
wish to translate them into the format used by DOS.    

In UNIX text file format, lines of text are separated by a linefeed character. Lines of text 
within DOS files are typically separated by the two characters: carriage return, linefeed.

This is a very DANGEROUS option, as it can cause files to be corrupted. Do not choose this 
option unless you are extracting a text file.    If you do, you will almost certainly cause 
problems with binary files, and probably with database files as well.

Since WiZ can't tell the difference between text and other files, you have to decide when to 
use it.    In general, don't choose this option unless you're sure you need it.

The setting you choose stays in effect until you toggle it.



Translate Filename Spaces to Underscore

Choose this option if you want WiZ to translate space characters in a filename to 
underscores during extraction.

Space characters in filenames are typically not used in 16-bit versions of Windows.

The setting you choose stays in effect until you toggle it.



Unzip to Same Directory as .ZIP

Choose this option only if you want WiZ to always extract the contents of the ZIP archive in 
the same directory as the ZIP archive.    
This option saves having to set the extraction directory separately. 

When WiZ is set to unzip in the same directory as the ZIP archive, WiZ disables and grays 
the File Menu Unzip To... Command. 

When you do not select this option, WiZ enables the File Menu Unzip To... Command, and 
you may select the destination directory.

WiZ places a check mark beside the menu item to show that the option is in force.    
The setting you choose stays in effect until you toggle it.

WiZ's title bar always shows the name of the directory into which it extracts regardless of 
the option's setting.



Listbox Selection Extracts File

When this option is active, double-clicking on a ArchiveDirectoryListbox entry extracts the 
selected entry from the archive and logs the outcome in the Edit/Status Window. 



Listbox Selection Displays File

When this option is active, double-clicking on a ArchiveDirectoryListbox entry displays the 
entry in the Edit/Status Window. 



Listbox Selection Tests File

When this option is active, double-clicking on a ArchiveDirectoryListbox entry tests the entry
and displays the results in the Edit/Status Window. 



Sound Options

This entry leads to a dialog box in which you choose the sound that WiZ emits either before 
or after the action (i.e. extract, test or display entries) completes. 
If WiZ detects that the system can play a wave, you may specify the name of a wave file 
which WiZ plays either before or after the operation. 
WiZ includes a default wave file, WIZUNZIP.WAV, which contains an unzipping sound 
(complements of Robert Heaths old gym bag.) 

Regardless of whether your system can play wave files, you can configure WiZ to emit a 
beep on completion.

The Browse option lets you search for .WAV files on your system.

The Play option plays whichever .WAV file is shown in the Sound Name or File edit field.



Show Toolbar Help

This option from the view menu controls whether to display Toolbar Help. 

The choice toggles each time this entry is selected.

When a checkmark appears beside the entry, toolbar help is active.

Your choice stays in effect until you change it.



Zip Options

For more information, select any of the following items:

Freshen Files
Update Files
Set Zip file time to latest file time
Move Files into Archive
Encrypt
LF to CR/LF 
CR/LF to LF 
Compression Level
Quiet Operation
Verbose Operation
Files After Date 
No Directory Entries 
Ignore Directory Names 
Exclude Extra Files Attributes 
Include Volume Label 
Include System and Hidden Files 
Remove SFX prefix from archive 
Add Comment to Archive 
Make xx bit Self Extracting Archive
Adjust Archive Entry SFX Offsets

WiZ saves your option selections permanently until you replace them with new selections.



Update archive with changed files only.



Update archive with changed or new files.



Set archive time to time of newest file.



Delete files after archiving



Password protect files in archive. Use this option with care. If you forget your password, 
there is no way for WiZ to extract the file in that archive again. Note that you must be using 
the version of WiZ that has encryption enabled.



Convert LF character into CR/LF character pair when archiving.



Convert CR/LF character pair into LF character when archiving



Set the amount of compression to be used. This can be from 0 (no compression, store only) 
to 9 (maximum compression.) The default compression level is 6.



Send minimal status messages to the Edit/Status window



Send full, complete status messages to the Edit/Status window



Archive files with file dates after the given date only.



Do not include directory entries in the archive



Do not include directory names as part of the file name in the archive



Exclude the extra file attributes available under Windows 95 or Windows NT when archiving.



Include the volume label in the archive



Include system and hidden files when archiving.



Delete the self-extracting prefix to the archive.



Add a comment to the archive.



This selection is useful only when you have manually created a self-extracting archive 
without adjusting the archive entries. This will adjust the offsets to account for the self-
extracting prefix when you update the archive.



When creating or updating an archive, you may make it self-extracting . If you do so with an 
existing archive, the archive file extension will be changed to .exe, and the original archive 
will be deleted. The archive entries will also automatically be adjusted for the self-extracting 
prefix. The 16 bit version of WiZ will only allow you to create DOS executables. The 32 bit 
version of WiZ will allow you to create either DOS or Windows (console) executables. Note 
that the 32 bit version self-extracting version is over three times as large. As a result, the 32 
bit executable should only be used when you need long file names, and it is expected that 
the resulting executable will be run under Windows 95 or Windows NT.



View Menu

You may also hide the Edit/Status Window by selecting Hide/Show Edit/Status Window.

Show Toolbar Help  If checked, this causes Toolbar Help to be displayed.



Hide/Show Edit/Status Window

This menu item hides or shows the Edit/Status Window. This makes it easier for you to 
browse a file displayed from the archive, and to use a full screen display of the archive.

You can restore the Edit/Status Window by selecting the Restore entry from its system menu,
or by double-clicking its maximize/minimize icon in its upper right-hand corner.



Glossary

DOS
FTP
Internet
Toolbar Help
UNIX
Win32s
ZIP archive



DOS

The DOS operating system popular on IBM-compatible personal computers.
It's either running or emulated on your PC right now.
DOS usually is short for MS-DOS, a trademark of Microsoft.



FTP

File Transfer Protocol. A protocol for transferring files through the Internet.



Internet

A data network connecting many universities, corporations, and government institutions.



Toolbar Help

A type of on-screen help which appears when your mouse cursor passes over one of the 
buttons of the toolbar. 
A summary of the functions of the button appears in a rectangle below the button bar.
The help message disappears as soon as your mouse cursor is moved away from the button.
Also called balloon help.



Win32s

Extensions to Windows 3.1 and Windows 3.11 which allow some 32-bit applications to run in 
a 16-bit environment.
The Win32s extensions are not installed by WiZ and must be obtained separately.



UNIX

The UNIX operating system is popular on multi-user open computer systems.    Unix is a 
trademark of X/Open.



ZIP archive

A ZIP archive is a collection of files stored within a single file in the format implemented by 
Phil Katz's products pkzip and pkunzip as well as Info-ZIP's products WiZ, zip and unzip.

ZIP archive files typically have the suffix .ZIP. 

WiZ is compatible with archives created by pkzip version 2.04 and earlier.



Browsing Text in the Archive

To browse one or more files within the archive, do the following:

First open the archive, see Opening an Archive File,

Next select the files you wish to view, using the ArchiveDirectoryListbox. 

Finally display the contents by doing of the following:

1) clicking on the Display Button ,
2) typing Control-D, or
3) selecting the Display option under the Archives Menu.

The selected entries will be displayed in the Edit/Status Window which can be scrolled using 
the horizontal and vertical scroll bars.

Alternately, you may use the Options menu to let you automatically display a file whenever 
you select its entry in the ArchiveDirectoryListbox.    
To do so, select the Listbox Selection Displays File. from the Options menu.    
Whenever you double-click on a entry in the ArchiveDirectoryListbox, WiZ displays the 
entry's contents in the Edit/Status Window. 
WiZ saves this setting in your WIZZIP.INI file until you change it.

WiZ cannot distinguish between text and binary data files, so it is possible to display a 
binary data file into the Edit/Status Window. 
WiZ assumes that the files it displays in the Edit/Status Window are in the PC manufacturer's
OEM codepage, which WiZ translates to the ANSI character set. 



Extracting Files from the Archive

To extract files from an archive, do the following:

First open the archive, see Opening an Archive File,

Next select the files you wish to extract, using the Archive Directory Listbox . 

Finally start the extraction by doing any one of the following:

a) clicking on the Extract button 
b) typing Control-X, or by
c) selecting the Extract item under the Archives Menu.

WiZ extracts the files, placing them in the directory shown on the title bar. 
The Edit/Status Window lists the names of the files as they are extracted.

A successful extraction displays status messages similar to these:

inflating: FILE1.DAT
inflating: FILE2.DOC
inflating: FILE3.EXE
inflating: FILE4.TXT

Alternately, you may use the Options menu to let you automatically extract a file whenever 
you double-click on an entry in the ArchiveDirectoryListbox.    To do so, select the Listbox 
SelectionExtracts File. from the Options menu.    
Now when you double-click on an entry in the Archive Directory Listbox, WiZ extracts it. WiZ 
saves this setting in your WIZ.INI file until you change it.



Testing Files in the Archive

To test files in the archive for integrity, do the following:

First open the archive, see Opening an Archive File,

Next select the files you wish to test, using the Archive Directory Listbox.

Finally start the test by selecting the Test option under the Archives Menu.

Alternately, you may use the Options menu to let you automatically test a file whenever you 
double-click on an entry in the ArchiveDirectoryListbox.    To do so, select Listbox Selection 
Tests File  from the Options menu.    Afterwards, when you double-click on an entry in the 
Archive Directory Listbox, WiZ will test it. WiZ saves this setting in your WIZ.INI file until you 
change it.

WiZ tests the files, listing the file names and results as they are tested in the Edit/Status 
Window. 

A successful test displays messages similar to these:

testing: FILE1.DAT OK
testing: FILE2.DOC OK
testing: FILE3.EXE OK

No errors detected in compressed data of C:\MYARCHVE.ZIP.



Archives Menu Get Zip Info Command

The Get Zip Info command provides you with the information of the type indicated below (a 
sample is provided).

Archive:    C:\zips\Unzip52.zip      806171 bytes      257 files

End-of-central-directory record:
-------------------------------

    Actual offset of end-of-central-dir record:            805897 (000C4C09h)
    Expected offset of end-of-central-dir record:        805897 (000C4C09h)
    (based on the length of the central directory and its expected offset)

    This zipfile constitutes the sole disk of a single-part archive; its
    central directory contains 257 entries.    The central directory is 18574
    (0000488Eh) bytes long, and its (expected) offset in bytes from the
    beginning of the zipfile is 787323 (000C037Bh).

    The zipfile comment is 252 bytes long and contains the following text:

======================== zipfile comment begins 
==========================
Info-ZIP's portable UnZip, version 5.2.
      Go forth and multiply this software freely.    Also check out our megaspiffy
      web site at http://quest.jpl.nasa.gov/Info-ZIP/ and our principal ftp site
      at ftp://ftp.uu.net/pub/archiving/zip/ .    Rock on.

========================= zipfile comment ends 
===========================

Central directory entry #0:
---------------------------

    Contents

    file system or operating system of origin:                Unix
    version of encoding software:                                          2.1
    minimum file system compatibility required:              MS-DOS, OS/2 or NT FAT
    minimum software version required to extract:          2.0
    compression method:                                                              deflated
    compression sub-type (deflation):                                  maximum
    file security status:                                                          not encrypted
    extended local header:                                                        no
    file last modified on (DOS date/time):                        1996 Apr 27 13:53:00
    file last modified on (UX extra field modtime):      1996 Apr 27 11:53:00 local
    file last modified on (UX extra field modtime):      1996 Apr 27 18:53:00 UTC
    32-bit CRC value (hex):                                                      5e6b88b2
    compressed size:                                                                    1594 bytes
    uncompressed size:                                                                4049 bytes
    length of filename:                                                              8 characters
    length of extra field:                                                        12 bytes
    length of file comment:                                                      0 characters
    disk number on which file begins:                                  disk 0
    apparent file type:                                                              text



    Unix file attributes (100644 octal):                            -rw-r--r--
    MS-DOS file attributes (00 hex):                                    none
    offset of local header from start of archive:          0 (00000000h) bytes

    The central-directory extra field contains:
    - A subfield with ID 0x5855 (Info-ZIP Unix/OS2/NT) and 8 data bytes:
            e8 6c 82 31 0c 6d 82 31

    There is no file comment.



Opening an Archive File

Before you can operate on a ZIP archive, you must open it. 
WiZ only operates on archive files in .ZIP format. .ZIP files are created either by Phil Katz's 
PKZIP program, by Info-ZIP's ZIP program, or by WiZ itself. 
ZIP files are identified by their .ZIP suffix.

You may open a .ZIP file by any of the following methods:

1) passing its name to WiZ when you start WiZ or,

2) using WiZ's File Menu Open Command or,

3) dragging the filename and dropping it onto the WiZ window, or 

4) clicking on the Open an Archive (.ZIP) File button

For easy browsing and extraction of .ZIP files, you may find it useful to associate the 
suffix .ZIP with WiZ in the Windows' Registry.

When the archive file has been successfully opened, its name appears in WiZ's title bar. 
From that point forward, WiZ's ArchiveDirectoryListbox and button operations apply to the 
open file. 
WiZ can open only one .ZIP file at a time. 
It is not necessary to close or save the file before exiting WiZ.



Creating or Updating an Archive

You can create or update an archive in one of two ways. First by using the Archive Menus 

Create Zip Archive selection, or by pressing the  button on the toolbar.

You will then see an open file selection dialog box where you can either enter the name of an
existing archive, or put in the name of a new archive. It is not necessary to enter the file 
extension .zip, or .exe as these will be added automatically for you. If you do enter a file 
extension that extension will be retained.

After selecting the file name for the archive, press the Open button, you will now be taken to
another dialog box that lets you select the files you wish to include in the archive. Select as 
many files as you want to be added to or updated in the archive. After you have selected all 
the necessary files in the selected directory, press the >>Add>> button to put them in the 
selected files list box. 

Alternatively, you may enter the file selection criteria (e.g. *.exe) in the Recurse/Include edit 
window, then you may press the Include button. You will see that instead of individual file 
names for each of the files selected, you will now see only a fully qualified path name with 
the wildcard criteria included (e.g. C:\FOO\BAR\*.EXE)

You may also include files recursively. Select your criteria as above for including files, but 
press the Recurse button instead. WiZ will search in the current directory, and all 
subdirectories below the current directory for files that meet your search criteria and will 
place them in the selected files list box. Note that this search is done immediately upon 
pressing the Recurse button.

If you have inadvertently placed a file (or files) in the selected files listbox that you dont 
want to include in the archive, highlight that file by clicking on it with the mouse, then press 
the Delete button. To select multiple files, hold down the Control key while clicking with the 
mouse.

When you have selected all the files you want to put in the archive, press the OK button. WiZ
will now search for all the files, which may take a few seconds if you are including a lot of 
files in the archive, then you will see messages appearing in the Edit/Status window 
indicating each file as it is being added.

If you do not have another archive being displayed in the archive listbox, then WiZ will 
automatically load the archive you have created or displayed in the archive listbox.



Showing the Archive Comment

Some ZIP archive files contain a readable comment.
 
 
If the archive has no comment, then the Show .ZIP Comment Button will be grayed.    

You may display the comment by any of the following:

1) selecting the Show .ZIP Comment button with the mouse,
2) typing Control-S, or 
3) selecting the Show .ZIP Comment item under the Archives Menu.

The comment will be copied into the Edit/Status Window where it may be scrolled using the 
scroll bars or the standard Windows navigation keys.

To add a comment to an archive see Adding Comments to an Archive 



Archive Directory Listbox

When you open a ZIP archive, WiZ displays the archive's directory in the Archive Directory 
Listbox at the top of WiZ's main window. The format of the listbox entries will be familiar to 
users of Phil Katz's PKUNZIP program or Info-ZIP's UNZIP program.

The Archive Directory Listbox is an extended, multiple-selection listbox.
This means you may select multiple files by clicking the mouse on a given item and 
dragging the mouse downward through the listbox.
You may also press the Control key and click on listbox individual items to make a 
cumulative list.
To select or de-select all files in the listbox at once, use the Edit Menu.

After selecting the files on which you wish to operate, you can Browse Text in the Archive, 
Extract Files from the Archive, or Test Files in the Archive.

You may extract, display, or test files directly from the listbox by double-clicking on the 
entries in the listbox. To define which action WiZ takes when you double-click on an entry, 
use the Options Menu. The push-button which corresponds to the listbox double-click action 
is surrounded by a thicker frame.

Background Color

The background color of the Archive Directory Listbox heading and total area is the Windows
Disabled Text color.
You can change your system's Disabled Text color using the Windows Control Panel.
Be careful! If you set your system's Disabled Text color to the same color as regular text 
(e.g. black), you won't be able to see the headings and totals above and below the Archive 
Directory Listbox.



Toolbar Buttons

Just below WiZ's menu bar lies its button bar, containing the bitmaps shown below. 
To see what function one of WiZ's buttons performs, click on the corresponding button below:

Create Zip Archive

Open an Archive (.ZIP) File

Extract a File from the Archive

Delete the Archive

Select All Files in Archive

Deselect All Files in Archive

Select Files by Pattern in Archive

Clear Edit/Status Window

Change Unzip To Directory

Hide/Show Edit/Status Window

Exit WiZ

WiZ Help



Edit/Status Window

At the bottom of WiZ's main window is the Edit/Status window, in which WiZ displays three 
types of information from the archive:

1) a record of file extraction and file testing (see Extracting Files from the Archive),
2) text files to browse (see Browsing Text in the Archive),
3) comments (see Showing the Archive Comment).

The Edit/Status window may be scrolled horizontally or vertically using either the mouse or 
standard Windows navigation keys.

You can maximize the Edit/Status window within WiZ's main window by clicking on the 
Edit/Status window's maximize box.

You can restore the maximized Edit/Status window to its normal size by selecting the 
Minimize entry from the Edit/Status window's system menu.

You can hide the Edit/Status window by selecting Hide/Show Edit/Status Window from the 
View Menu.

You can clear the Edit/Status window using the Clear Edit/Status Window menu item 
from the Edit Menu or by typing the Del key.    The Edit/Status window 
automatically clears itself to make room for more information when either of the 
following happens:

1) the number of characters in the buffer reaches 32767 (16384 in the 16 bit 
version), or

2) your system does not have enough global memory to store more data.

The menu bar in the Edit/Status Window has two drop down menus, File and Edit:

The File Menu has two items:

File Open
Save As

The Edit Menu has seven items:

Undo - undo last operation
Cut - cut selected text to the clipboard
Copy - copy selected text to the clipboard
Paste - paste text from the clipboard into the Edit/Status Window
Delete - delete selected text
Select All - select all text in the Edit/Status Window
Clear Edit Window - delete all text in the Edit/Status Window



File Open

This allows you to open and edit text files on your disk. However, you should note that this 
provides only very limited safety features, in particular, it does not warn you that the file has
been modified prior to exiting WiZ.

If you are editing a file, and in the middle of editing you do something with WiZ that causes 
WiZ to send messages to the Edit/Status Window, it will add those messages to the bottom 
of the file you are trying to edit.



Save As…

Selecting this menu item will allow you to save whatever is in the Edit/Status Window to 
disk. This can be any text in the Edit/Status Window.

Please note that this is the only way to save any text in the Edit/Status Window, no matter 
how it got there. If you read a file from disk, spend hours modifying it, then exit WiZ, none of
your changes will be saved. You must save them yourself.

Morale - If you are doing any significant editing, use something else to do the work.



Title Bar

The title bar shows which ZIP archive is currently open and into which directory WiZ extracts 
archive entries.

If no ZIP archive is open, the title bar contains the message (No ZIP File) in the file name 
field.



Icon
The WiZ icon's title includes the name of the current archive file name. 
If no ZIP archive is open, the title contains the text (No ZIP File).

The WiZ icon starts out as a fully zipped zipper.

After extracting the first file, the WiZ icon changes into an unzipped zipper.

That's as close as WiZ comes to snappy graphics and animation.

The zipped and unzipped zipper icon artwork is by Becky Cobb.



Becky Cobb

No one can do
      What Becky can do
In just thirty-two
      By thirty-two.



Error Messages in the Edit/Status Window

This section describes some of the error messages which can appear in the Edit/Status 
Window.

End-of-central-directory signature not found.    Either this file is not
          a zipfile, or it constitutes one disk of a multi-part archive.    In the
          latter case the central directory and zipfile comment will be found on
          the last disk(s) of this archive.
This error means that the opened file is either not in ZIP archive format or is a corrupted ZIP 
file.    Check the suffix of the file. This error might occur if you transferred the archive across 
a network as an ASCII file rather than as a binary file. At any rate, WiZ can't decipher it.

error: can't open zipfile [ filename ]
This message appears if the archive file has been moved or deleted after having been 
opened in WiZ.

error:    expected central file header signature not found (file #n).
This error means that the opened file is either not in ZIP archive format or is a corrupted ZIP 
file.    Check the suffix of the file. This error might occur if you transferred the archive across 
a network as an ASCII file rather than as binary file. At any rate, WiZ can't decipher it.

Expanding: filename    status
Exploding: filename    status
Extracting: filename    status
Inflating: filename    status
Testing: filename    status
UnShrinking: filename    status
These messages occur during extraction or testing. During extraction they indicate which 
compression technique was employed to archive the file named filename.    The status value 
can be either 

OK,    which means success, 

or

Bad CRC xxxxxxxx    (should be xxxxxxxx), which means the file is corrupted in the 
archive,

where xxxxxxxx is a hexadecimal number.

Fatal write error
This message might appear if the disk had filled up while extracting a file.

filename    unknown compression method
This indicates that WiZ cannot extract the given file. The cause is possibly due to a 
corrupted archive or the file was stored using a technique designed after this version of WiZ.

warning:    didn't find end-of-central-dir signature at end of central dir.
This error indicates that the opened file is either not in ZIP archive format or is a corrupted 
ZIP file.    Check the suffix of the file. This error might occur if you transferred the archive 
across a network as an ASCII file rather than as a binary file. 

warning:    filename too long--truncating
This error might appear when extracting a file generated on a system other than DOS. The 



name exceeds DOS's 8.3 format. You should not see this message when using the 32 bit 
version of WiZ



Error Messages in Dialog Boxes

This section describes error messages which may appear in a Windows message box.

A write error has occurred. Perhaps the disk is full. Continue ?
Appears during extraction. It typically occurs if the disk to which you are extracting runs out 
of free space. Files may erroneously appear to have CRC errors during extraction in this 
case.    It typically does no good to continue.

Cannot open filename
Appears in the Open a ZIP File dialog box if you specify a file that doesn't exist.
Can also appear if you specify a file which does not exist when starting up WiZ with a 
filename argument.

Can't change directory to <directory name>!
Appears before or after extraction if WiZ has been configured to change to or return to a 
non-existent directory.

Clearing Messages window to make room for more information.
Appears if the Edit/Status Window buffer becomes full or otherwise cannot grow.

johnny__.yuu. Cannot access this file. Please verify security privileges on the 
network drive.
This message box appears if you try to select a write-protected drive, such as a CD-ROM 
drive, from the Unzip To... dialog box.
(See File Menu Unzip To... Command.)

This archive contains too many files for WiZ to list them all! 
This appears if the archive contains many files and the data required to list those files and 
their attributes exceeds a Windows internal limit of 65K characters.



System Requirements

WiZ is released as both a 16-bit version and a 32-bit version.    You can tell which version you
are running by opening WiZs About Box.

Feature WiZ-16 WiZ-32
Windows 3.1 supported unsupported
Windows 3.11 supported unsupported
Windows 3.X + Win32s supported supported
Windows 95 supported supported
Windows NT 3.X supported supported
Sound optional optional*
Disk space required 600K bytes 800K bytes
Memory required minimum** minimum**

*WiZ-32 running under Windows 3.X + Win32s does not support sound. In all other 
combinations WiZ supports sound as long as a sound card and an appropriate driver are 
installed.

**WiZ has no memory requirements above the minimum required to run your version of 
Windows.



Who is Info-ZIP ?

Info-ZIP is a diverse, Internet-based workgroup of about 20 primary authors and over one 
hundred beta-testers, formed in 1990 as a mailing list hosted by Keith Petersen on the 
original SimTel site at the White Sands Missile Range in New Mexico.

Info-ZIPs purpose is to provide free, portable high-quality versions of the Zip and UnZip 
compressor-archiver that are compatible with the DOS-based PKZIP by PKWARE, Inc.

Info-ZIP supports hardware from microcomputers all the way up to Cray supercomputers, 
running on almost all versions of Unix, VMS, OS/2, MS-DOS, Windows NT/95, AmigaDOS, 
Atari TOS, MacOS, BeOS, Acorn RICS OS, SMS/QDOS, VM/CMS, MVS and Human68K 
(Japanese.) There is also some support for TOPS-20, AOS/VS and Novell NLMs as well as a full
graphical interface for Windows.

Info-ZIP code is incorporated into a number of third-party products as well, both commercial 
and freeware. Some of the more interesting ones are the use of UnZip code in the unzip.dll 
distributed with IBMs OS/2 Warp BonusPak and WebExplorer, and as part of the reinstallation
code for the IBM Aptivas preloaded with OS/2 Warp. Sun is (or was) using Info-ZIPs self-
extractor to distribute the NT version of their HotJava browser. Various Windows products 
such as WinZip and the DynaZIP DLLs incorporate Info-ZIP code also. And let us not forget 
Pretty Good Privacy (PGP), an excellent encryption program that uses Info-ZIPs code as a 
first step in encrypting files.

Info-ZIP can be reached by e-mail at Zip-Bugs@LISTS.WKU.EDU. Our primary web and ftp 
site is hosted by the fine folks at Walnut Creek CD-ROM. Our secondary distribution sites are 
hosted by UUNET Technologies and Swiss SunSITE.

For a partial list of contributors, please see the accompanying Contribs file.



Copyright and Distribution

There are currently at least four explicit copyrights on portions of the UnZip code (at least of 
which Info-ZIP is aware.) For specific information on the copyrights, answers to frequently 
asked questions and information on whether you may incorporate the Zip and UnZip code 
(including dlls) in your applications, please see the Copying file that accompanied this 
distribution.



Where to Find Info-ZIP Products

The latest versions of Info-ZIP products can be found online at 
http://www.cdrom.com/pub/infozip/ For locations and specific information regarding the 
location(s) of Info-ZIP products, please see the Where file that accompanied this distribution,
or see it online at http://www.cdrom.com/pub/infozip/doc/Where



Warranty or Lack Thereof

WiZ's (and WizUnZips) authors make no promises express or implied on the suitability of this
software product for any purpose at all. 

All responsibility for use of WiZ lies with the user.

What this means is that if WiZ somehow formats your hard-drive(s), deletes all your work for
the last five years, causes your computer to have to be sent to the computer hospital (or 
cemetery), or anything else that could in any way be construed as an unpleasant or bad 
thing to happen, we take no responsibility whatsoever for any of your problems whether 
caused by WiZ or not.

Mike White



History

Non-WiZ Versions

Please see the History.* files in the unzip and zip source distributions for a complete listing of
changes.

WizUnZip versions
Date Version Description
Jan. 27, 1992 1.0 Original Release.
Apr. 26, 1992 1.1 Fixes problem in LF to CR,LF 

mapping. Renamed Translate LF 
to CR,LF option to Translate 
CR,LF to LF. 
Release of source.

June 30, 1992 1.2 Updated to Unzip 5.0 source and MS Windows 3.1
Added drag-drop, sped up zip operations, and
hiding status window.

August, 1992 1.3 Tidied up bugs in 1.2 version.

May 21, 1993 2.0 Release of WizUnZip 2.0 Beta 1.
Aligned with unzip 5.0p1,
for pkzip 2.04 compatibility.
Fixed many bugs in Windows interface.
Changed Translate CR,LF to LF feature
back to Translate LF to CR,LF..
New features: configurable unzip to 
directory, select files by pattern, 
play wave on completion, copy status
window to clipboard, offers self-
extracting archives as a choice when
opening a file. Moved initialization 
data to WIZZIP.INI. 
Thanks to Richard Hartman for some good ideas!

July 4, 1993 2.0 General release of WizUnZip 2.0.

April 27, 1996 3.0 General release of WizUnZip 3.0
- Modified to compile under Borland C compiler.
- Allow compilation for either Win-16 or Win-32.
- Added support for encryption.
- Added toolbar help.
- Added various display options.
- Added ability to copy, move, rename, delete archive files,
    and create directories.
- Added DLL support for unzip.

WiZ Versions

Nov 3, 1997      4.0 General release of WiZ 4.0, based on Unzip 5.32 and Zip 2.2.

July 12, 1996 4.0 Release of WiZ 4.0 beta. Several bug fixes pertaining to
pre-existing bugs in WizUnZip. Addition of a zip DLL and 
related options. No longer a stand-alone application, requires
the use of DLLs for both zip and unzip functions.



April 27, 1996 3.0 General release of WizUnZip 3.0. With the release of    WizUnZip,
3.0 WizUnZip as a separate application will no longer be 
supported. WiZ is based on WizUnZip 3.0



Help Overview

WiZ offers three varieties of help:

WiZ Help Help specific to WiZ
Using Windows Help How to Use Windows Help in General
About WiZ... Version and Author



WiZ Help

Standard Help
WiZ has standard Windows help, accessed by typing the F1 key.    This method takes you to 
WiZ's top help index. You may use the mouse or keyboard to select lower-level topics or to 
simply browse.

Context Help
WiZ also has context help by which you can hit Shift-F1, producing the question-mark/arrow 
cursor. You may then select any of WiZ's menu items using the mouse or the keyboard.    
Context help takes you directly to the help screen associated with the desired menu item.

Toolbar Help
WiZ provides Toolbar Help when you pause the mouse cursor over one of the buttons on 
WiZs toolbar.    Toolbar help can be enabled or disabled, using the Show Toolbar Help option 
under the Options Menu 



Using Windows Help

This menu entry takes you to the standard introduction on using Windows help.



About WiZ...

The about box tells:

1) whether you are running the 16-bit or the 32-bit version,

2) the program release number, and 

3) information about the authors.



Bugs and Restrictions

Here are a few bugs and restrictions in WiZ, along with some workarounds.

Archive Directory Listbox holds up to 64K bytes of data.
This problem is signaled by a Message Box which signals that the listbox has run out of 
space.    This occurs in both WiZ-16 and WiZ-32. 

Open Dialog Box Can't Distinguish Between Self-extracting .EXE's and 
Ordinary .EXE's
When listing self-extracting files, the Open dialog box lists all .EXE files regardless of whether
they are self-extracting .ZIP files.    
If you open the file and receive the End-of-central-directory signature not found message, 
you may assume the file is not a self-extracting .ZIP.

Edit/Status Window Displays Windows ANSI Character Set
When displaying a .ZIP file comment in the Edit/Status Window, WiZ maps the data into the 
ANSI Character Set.




