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The Index contains a list of all Help topics available for Multimedia Sound Recorder. For 
information on how to use Help, press F1 or choose Using Help from the Help menu.



Summary

Sound Recorder is a VOC, WAV, and SND file player, editor and recorder for multimedia 
Windows.

Multimedia Sound Recorder 3.1 represents all sound files internally as .VOC files. All sound 
files are recorded/edited in memory - playing from or recording directly to disk is not 
currently supported.

VOC files consist of individual data blocks that are grouped together to form a complete 
sound data file. There are currently eight different types of data blocks:

End Block - This is the terminating block in all VOC files. It indicates the end of the VOC file.

New Voice Data Block - This block contains sampling rate and packing information as well as 
digitized sound data. All VOC files will contain at least one of these blocks.

Continuation Data Block - This block contains only digitized sound data. It uses the same
sampling rate and packing format as the preceding block.

Silence Block - This block represents a silence period of the voice data.

Marker Block - This type of block marks a position in a VOC file. It is often used to 
synchronize the sound with some other event.

Message Block - This block can be used to store text information in a file.

Repeat Start Block - This block marks the begining of a repeated sequence in a VOC file. It 
also contains the number of times the sequence is repeated.

Repeat End Block - This block marks the end of a repeated sequence.

When a file is first loaded into memory, its block structure is displayed using the above icons
to represent the different block types. Clicking on an icon will display information about the 
block.

Double-clicking on New Data Blocks or Continuation Data Blocks will draw a graphical 
display of the sound data.



File Menu

The File menu includes commands that enable you to open and save files, establish a new 
workspace, and to exit the program.

For more information, select the File menu command name.

Open Retrieve a file.
Save Save the current file to disk.
Save As Save the current file with a different name or format.
New Clear memory of all data.
Exit Quit the program.



Edit Menu

The Edit menu includes commands that enable you to move sound data to and from the 
clipboard, to insert and delete data blocks, to play and clear the contents of the clipboard, 
and to merge the contents of the clipboard with other sound data.

For more information, select the Edit menu command name.

Cut Deletes sound data and moves it to the clipboard.
Copy Copies sound data to the clipboard.
Paste Moves sound data from the clipboard to the edit window.
Insert New Block Insert a new data block.
Delete Block Delete a data block.
Merge Combine the contents of the clipboard with the current file.
Play Clipboard Plays the contents of the clipboard.
Clear Clipboard Deletes the contents of the clipboard.



Settings Menu

The Settings menu includes commands that allow you to select the input and output wave 
devices, as well as altering wave file parameters.

For more information, select the Settings menu command.

Hardware Change the input or output wave device.
Data FIle Change the sampling rate or packing format.



Effects Menu

The Effects menu includes commands that allow you to add special effects to sound files, 
such as echoes, digital filtering, and amplification.

For more information, select the Effects menu command.

Invert Reverse the sound.
Echo Add an echo effect.
Amplify Increase or decrease the volume.
Filter Remove background noise and hiss.
Fade In Add a fade-in effect.
Fade Out Add a fade-out effect.



Compression Menu

The Compression menu includes commands that allow you to compress sound data using 
ADPCM, effectively cutting the file size in half. These compression schemes will operate 
correctly only when the file is saved as a .VOC file.

For more information, select the Compression menu command.

4-Bit ADPCM Compress the file by half.
8-Bit ADPCM Expand the file back to normal.
Silence Packing Reduce file size by compressing silent sections.



Help Menu

This menu item contains coomands for online help and information.

For more information, select the Help menu command.

Help Get online help.
About Display information about Multimedia Sound Recorder.



Play Button

This button causes the current voice data in memory to be played through the current sound
output device starting at the selected block. 

The file is played starting from the currently selected block. If no block has been selected, 
the sound is played from the begining of the file. If a new data block or continuation data 
block are open when this button is selected, only the current block will be played. 

While a sound is playing, a message will be displayed at the top center of the main window 
indicating the elapsed time in milliseconds. The Stop and Pause buttons are also enabled.



Stop Button

Press this button to discontinue playing or recording a sound file.



Record Button

To record your own sounds, press this button. When it is pressed, another button labeled 
Start appears. At this point, you may change the sampling rate, if desired, by selecting 
Settings-Data File from the main menu. 

When you are ready to record, press the Start button. A message will be displayed at the 
bottom center of the main window indicating the elapsed time. 

When you are finished recording, press the Stop button.



Pause Button

Press this button while a sound is playing to suspend output of the sound. Press the button 
again to continue playing the sound.



Glossary

ADPCM
clipboard
data block
packing format
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.SND files
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.WAV files



Selecting Data Blocks

To select a data block, position the mouse over the block to be selected and click once. The 
block will be inverted and bars will be displayed above and below the block. Information 
about the block will be displayed in the lower center area of the main window.



Opening Data Blocks

To open a New Voice Data Block or a Continuation Data block, move the mouse pointer over 
the block to be opened. Double-clicking on the block causes a graphical representation of 
the data to be displayed.

To close the block, double-click the mouse while the pointer is anywhere on the graphed 
data.



Selecting Sound Data

To select data contained in New Data Blocks or Continuation Data Blocks, first open the data 
block by double-clicking on the block.

To select data within the block, position the mouse over the start of the area to be selected. 
Click and hold the mouse button and drag either left or right until the data of interest is 
within the inverted rectangle.



Editing Sound Files

Data blocks may be inserted or deleted by selecting the Edit-Insert Block command or Edit-
Delete Block command from the main menu.

If a block is inserted with no file loaded, an End Data Block will be appended to the inserted 
block.

NOTE: DO NOT ATTEMPT TO PLAY A FILE THAT DOES NOT HAVE AN END DATA BLOCK. THIS 
MAY RESULT IN ABNORMAL TERMINATION OF THE PROGRAM.

When a data block is selected, information about the block is displayed in the lower center 
area of the main window. In the case of Repeat, Silence, Marker, and Message Data Blocks, 
this information can be edited.

To edit the information, click in the edit window where the information is displayed. After 
changes have been made, click on the data block to activate the change.



File - Open

Select this to load a voice file into memory. Click the ".VOC" button to load a file that is in 
the "Creative Voice File" format, ".SND" to load a raw voice data file, or ".WAV" to load a 
Windows sound file.



File - Save

Choose this to save the current file to disk. The current file name will be used and the file 
will be overwritten automatically.



File - Save As

This option allows you to save the current file under a different name or in a
different format. Click ".VOC" to save in the "Creative Voice File" format, ".SND" to save as 
raw voice data, or ".WAV" to save in Windows sound format.



File - New

Choose this to erase the current file in memory. If the file has not yet been saved, a box will 
appear asking if you would like to save the file. Answer yes to save the file or no to lose any 
changes you have made.



File - Exit

Select this to end Multimedia Sound Recorder. If the file has not yet been saved, a box will 
appear asking if you would like to save the file. Answer yes to save the file or no to lose any 
changes you have made.



Edit - Cut

This allows "cutting" or removal of the selected section of the sound. The selection is saved 
in Window's clipboard.



Edit - Copy

This allows the selected portion of wave data to be copied into the clipboard. The contents of
the clipboard prior to this command will be overwritten.



Edit - Paste

Select this to insert the contents of the clipboard into the sound file. The data is inserted 
starting at the current cursor postion.



Edit - Insert Block

This option allows you to insert a .VOC file data block. Select the block type from the list and
click OK. The block will be inserted BEFORE the currently selected block.



Edit - Delete Block

This option allows you to remove the current .VOC data block. The currently selected block 
will be deleted.

NOTE: Use caution when deleting End Data Blocks. One of these blocks must be present in 
order for the file to play correctly.



Edit - Merge

Select this to combine the contents of the clipboard with the data file. The clipboard 
contents will be combined with the data starting at the current cursor position. The file will 
be lengthened if needed.



Edit - Play Clipboard

This will play the sound data stored in the clipboard. The Stop and Pause buttons are 
enabled during playback.



Edit - Clear Clipboard

This will remove all data from the clipboard.



Settings - Hardware

This option allows you to change the sound input and output devices. Select the devices 
from the list of available sound devices. If the device of interest is not displayed in the list, 
check the Drivers in Windows' Control Panel for the device. 



Settings - Data

Select this option to change the data file's sampling rate and packing format. Information 
about the file length and data blocks is also displayed.

NOTE: Use caution when changing the packing format by this method. An incorrect value 
could cause the file to play incorrectly if stored as a .VOC file.



Effects... - Invert

This will reverse the data in the selected block, allowing it to be played backwards. Selecting
this a second time returns the sound to normal.



Effects... - Amplify

This option allows the volume to be changed in the selected block by a user-defined amount.
Click Increase to raise the volume or Decrease to lower it. An amount to raise or lower the 
volume can also be entered.

NOTE: Because clipping of the data can occur if the volume is raised too high, it is best to 
raise the volume in small increments ( for example, 25% ) until the desired level is reached.



Effects... - Echo

Select this to add an echo effect. You can control three different parameters to produce the 
desired echo. The first is the delay in milliseconds between the original sound and the first 
echo. The second is the number of echoes. The last is the volume of each echo in relation to 
the previous one.



Effects... - Filter

This will cause all data below a user-defined threshold to be removed. This can be used to 
clean up data with high background noise. A threshold of 0 causes no filtering, while a value 
of 128 will filter all data.



Effects... - Fade In

The volume of the sound data is increased linearly from zero to maximum volume starting at
the begining of the data block and ending at the insertion point.



Effects... - Fade Out

The volume of the sound data is decreased linearly from maximum volume to zero starting 
at the insertion point and ending at the end of the data block.



Compression - 4-Bit ADPCM

The selected sound data block is compressed 2:1 using adaptive differential pulse code 
modulation.

NOTE: Windows does not yet support ADPCM, therefore this command should be used only if
the file is to be saved in .VOC format and is to be played by a program that supports this 
format.



Compression - 8-Bit Uncompressed

Choose this to uncompress data blocks that were compressed by 4-bit ADPCM. Files 
compressed using 2.5- or 2-bit ADPCM CANNOT be decompressed by this command.

NOTE: WINDOWS 3.1 DOES NOT CURRENTLY SUPPORT ADPCM. ALL FILES MUST BE IN 
DECOMPRESSED FORMAT TO PLAY PROPERLY.



Compression - Silence Packing

This option allows long periods of silence in a data block to be replaced by silence blocks, 
decreasing the size of the data file.

NOTE: This type of packing must be done before any other type is performed.



Help - Help

This option displays the information you are seeing here.



Help - About

This option displays information about Multimedia Sound Recorder.



ADPCM

Adaptive Differential Pulse Code Modulation, or ADPCM, is a tecnique used to compress data.
It allows data to compressed with little loss of quality.



Clipboard

The clipboard is a temporary storage area for cut or copied data. It allows data to be 
transferred to other Windows aplications.



Data Blocks

Data blocks are the basic units of .VOC files and contain information such as sampling rate, 
packing format, repeat information, silence information, and other data.



Packing Formats

Packing formats are used by .VOC files to indicate whether the data is compressed or not.



Sampling Rate

The sampling rate is a measure of how fast a file is to be played or recorded and is 
measured in bytes per second. The higher the rate, usually the better the quality.



.SND Files

These files contain only raw digitized sound data. No information header is included with this
type of sound file.



.VOC Files

These are files based on the "Creative Labs File Format" and contain blocks of information, 
such as sampling rate, repeat information, silence information, etc.



.WAV Files

These are sound files that can be used by Multimeia Windows.




