
Personal Web Server Overview

Since so many people have handy Web browsers and there are so many ways of creating HTML 
documents, it’s time that people had a simple way to make information easily available on the World 
Wide Web. Corel Personal Web Server allows you to create your own Web server for providing 
information on the Web.

Related topics {button ,AL(`Getting Started;How Personal Web Server Works;How to')}



How Personal Web Server Works

Personal Web Server can be configured to start up when you start Windows 95 and the Personal 
Web Server icon shows up on your task bar. If you click this icon, a window appears which displays 
the files you're making available on the Web and the name that each file is referred to by the outside 
world. For example, you may have the file C:\Docs\car.HTML on your hard disk and make it available 
to the outside world as Car.html. Anyone with a Web browser and the name of your machine can then
access this file. Personal Web Server keeps track of how many people visit your Web server, how 
often people visit, and so on. If you want to stop sharing a file at any time, you can just delete it from 
the list in the Personal Web Server window.

Example: Typically you would create an initial HTML document (or home page), with another 
application (i.e. Corel Home Page Author), which you would then drag to the Personal Web Server 
window. Next, you would drag all of the files (i.e. text files, bitmaps, WAV files, etc...) that make up 
your initial HTML document to the Personal Web Server window. Finally, you would drag all of the files
on your machine (i.e. text files, other HTML documents, etc...) that you want to make available 
through your home page, to the Personal Web Server window. Then anyone with a Web browser, an 
Internet connection, and the name of your machine, could access all of the files on your Personal 
Web Server through your home page.

Note: If your entire HTML structure is in a single directory, you can drag this directory to your 
Personal Web Server. Your initial HTML document (or home page) and all of the other files within that
directory will then be automatically accessible through your Personal Web Server.
Create as many of these HTML structures as you want and drag them all to your Personal Web 
Server.
Web Server is most beneficial if you have a full time Internet connection, but even if you don't, you 
can still enter the world of Internet providers on a temporary basis.

{button ,AL(`Getting Started;Personal Web Server Overview')}



Getting Started

Your computer must be properly configured to act as a Web server. Click {button ,AL(`Congifuring 
your system as a Server',1,`',`second')} for help configuring your system.

Add files or directories of files to your Personal Web Server
You must first add files or directories of files to your Personal Web Server by either dragging and 
dropping them to your Personal Web Server or by clicking the Add File command from the Edit menu.

Example: Typically you would create an initial HTML document (or home page), with another 
application (i.e. Corel Home Page Author), which you would then drag to your Personal Web Server. 
Next, you would drag all of the files (i.e. text files, bitmaps, WAV files, etc...) that make up your initial 
HTML document to your Personal Web Server. Finally, you would drag all of the files on your machine
(i.e. text files, other HTML documents, etc...) that you want to make available through your home 
page, to your Personal Web Server. Then anyone with a Web browser, an Internet connection, and 
the name of your machine, could access all of the files on your Personal Web Server through your 
home page.

The Public name for all pages must start with a "/" character. If it doesn't, Personal Web Server 
won't be able to display that page.

If your entire HTML structure is in a single directory, you can drag this directory to your Personal 
Web Server. Your initial HTML document (or home page) and all of the other files within that directory will 
then be automatically accessible through your Personal Web Server.

Create as many of these HTML structures as you want and drag them all to your Personal Web 
Server.

Set program options for your Personal Web Server
Set program options for your Personal Web Server by clicking the Options command from the Tools 
menu.

On the Options dialog box, click the Browser tab to configure how Personal Web Server launches 
your Web browser whenever you open an HTML document (or a Web page) from within the Personal 
Web Server window.

Click the Logging tab on the Options dialog box to configure your initial Usage and Error Logs. These 
Logs keep track of all of the activity on your Personal Web Server. 

Leave your computer on with Personal Web Server running
Now leave your computer on and your Personal Web Server running to provide information on the 
World Wide Web. Minimize your Personal Web Server by clicking the Minimize command from the 
System menu if you have other tasks to perform. The minimized Personal Web Server will then be 
represented by an icon on your task bar.

Periodically bring your Personal Web Server to the foreground by clicking the Personal Web Server 
icon on your task bar and check your Usage Log for activity by selecting the Usage Log command 
from the View menu. 

{button ,AL(`How Personal Web Server Works;How to;Keyboard Short-cuts;Personal Web 
Server Overview')} Related topics 



Print command (File menu)

Commands: Print...

Shortcuts: Ctrl+P

You can print the list of files and directories that are currently available on your Personal Web Server.

To print the list of files and directories:
1. From the File menu, choose the Print command.
2. Set the print options, including any changes to the printer setup, and then click the OK button.

{button ,AL(`Print Setup command (File menu)')} Related topics 



Print Setup command (File menu)

Commands: Print Setup...

Shortcuts: N/A

Most printers include options for choosing a default printer, paper orientation, and paper selections. 
However, the options provided when you choose the Print Setup... command depend on the 
capabilities of your printer. For information about these options and settings, see the documentation 
provided with your printer.

Printer setup options usually identify the printer that's used by default and list other printers which are 
available for temporary selection.

Typically, printer setup options also let you choose the paper orientation: landscape or portrait. The 
landscape setting prints information horizontally on the page. The portrait setting prints information 
vertically on the page.

The paper settings let you choose the paper size and the source, which is typically the print tray in 
which the selected paper size is located.

To set print options:
1. From the File menu, choose the Print Setup... command.
2. Select the printer setup options and click the OK button.

{button ,AL(`Print command (File menu)')} Related topics 



Exit command (File menu)

Commands: Exit

Shortcuts: N/A

If you want to stop Personal Web Server from running on your system, you can exit the application. 
When Personal Web Server isn't running, no activity can take place on it. You may also run other 
applications with Personal Web Server minimized, leaving it running in the background. While 
Personal Web Server is running in the background, all files and directories available on it can 
constantly be accessed.

When Personal Web Server is minimized, it appears next to the clock on the task bar.

To exit Personal Web Server:
1. From the File menu, choose the Exit command.

To minimize Personal Web Server and leave it running in the background:
1. From the System menu, choose the Minimize command.



Add File command (Edit menu)

Commands: Add File

Shortcuts: Insert

Adding files or directories of files to your Personal Web Server is the first step in creating your own 
Web server.

To add a file or directory of files to your Personal Web Server:
1. From the Edit menu, choose the Add File command.
2. Type the filename and path, the public name, and a description of the file, and then click the OK 

button.

{button ,AL(`Delete command (Edit menu)')} Related topics 



Delete command (Edit menu)

Commands: Delete

Shortcuts: Del

Files or directories of files that you no longer want to make available can be deleted from your 
Personal Web Server.

To delete a file or directory of files from your Personal Web Server:
1. Highlight the file or directory of files on your Personal Web Server.
2. From the Edit menu, choose the Delete command.

{button ,AL(`Add File command (Edit menu)')} Related topics 



Properties command (Edit menu)

Commands: Properties

Shortcuts: N/A

The properties of each file or directory available on your Personal Web Server can be configured to 
your own specifications.

Four tabs are located on the File Properties dialog box which will assist you in configuring these 
properties.

The General tab enables you to change the filename and path, the public name, and the description 
of the highlighted file. The General tab also informs you how many times the highlighted file has been 
accessed and enables you to reset this number to zero.

The Advanced tab enables you to define the MIME content type of the highlighted file and to instruct 
Personal Web Server to parse the Web page, corresponding to the highlighted file, for Personal Web 
Server’s HTML tags. The latter will default to the appropriate setting.

The Security tab enables you to specify which computers can access the highlighted file. You may 
want to make a specific file accessible to only certain computers.

The Links tab enables you to see how many hits the highlighted file has received and from which links
(URLs). A hit only shows up in the links list if it’s from another page which contains a link to the hit 
page (or highlighted file). 

To access the File Properties dialog box:
1. Highlight a file or directory of files in your Personal Web Server.
2. From the Edit menu, choose the Properties command.

{button ,AL(`Advanced tab (File Properties dialog box);General tab (File Properties dialog 
box);Links tab (File Properties dialog box);Security tab (File Properties dialog box)')} Related 
topics



Usage Log command (View menu)

Commands: Usage Log

Shortcuts: N/A

All activity on your Personal Web Server is recorded in a Usage Log.

To see a record of the current Usage Log:
1. From the View menu, choose the Usage Log command.

{button ,AL(`Clear Usage Log command (Tools menu);Error Log command (View menu)')} 
Related topics 



Error Log command (View menu)

Commands: Error Log

Shortcuts: N/A

All errors that occur during the use of the files on your Personal Web Server are recorded in an Error 
Log.

To see a record of the current Error Log:
1. From the View menu, choose the Error Log command.

{button ,AL(`Clear Error Log command (Tools menu);Usage Log command (View menu)')} 
Related topics 



Status Bar command (View menu)

Commands: Status Bar

Shortcuts: N/A

You can choose to disable the Status Bar on the Personal Web Server screen.

To disable the Status Bar:
1. From the View menu, choose the Status Bar command.



Clear Usage Log command (Tools menu)

Commands: Clear Usage Log

Shortcuts: N/A

The current Usage Log can be cleared of entries if desired.

To clear the Usage Log:
1. From the Tools menu, choose the Clear Usage Log command.

{button ,AL(`Usage Log command (View menu)')} Related topics 



Clear Error Log command (Tools menu)

Commands: Clear Error Log

Shortcuts: N/A

The current Error Log can be cleared of entries if desired.

To clear the Error Log:
1. From the Tools menu, choose the Clear Error Log command.

{button ,AL(`Error Log command (View menu)')} Related topics 



Options command (Tools menu)

Commands: Options...

Shortcuts: N/A

The Options command brings up a dialog box with two tabs that enable you to configure program 
options.

The Browser tab enables you to configure how Personal Web Server launches your Web browser 
whenever you open an HTML document (or a Web Page) from within the Personal Web Server 
window.

The Logging tab enables you to configure your Usage and Error Logs.

To access the Options dialog box:
1. From the Tools menu, choose the Options... command.

{button ,AL(`Options dialog box')} Related topics



Contents command (Help menu)

Commands: Contents

Shortcuts: N/A

Choosing the Contents command displays a list of topics available in this Help file.



About command (Help menu)

Commands: About

Shortcuts: N/A

The About command displays version information about Personal Web Server.

To display the version of Personal Web Server that you’re using:
1. From the Help menu, choose the About command.



Using Help command (Help menu)

Commands: Using Help

Shortcuts: N/A

If you require    help performing any function in Personal Web Server, extensive on-line help is 
included in the software. If you're unsure of the operation of any menu command or the procedure for 
a specific function, the on-line Help in Personal Web Server can probably help you.

Method of 
accessing Help

Type of information provided

Help menu Choosing Contents from the Help menu 
displays the Help file's table of contents 
and allows you to access the Help file's 
Index and full text search. Use the Help 
menu for overviews and explanations of 
procedures.

F1 Key Provides help on the currently selected 
object. For example, if you select a menu
command and press F1, information on 
the use of the selected command is 
displayed.

Shift+F1 Keys Provides a context-sensitive help cursor 
(Show cursor). For example, you can press 
Shift+F1 and click a list box to view an 
explanation of that list box.

Right mouse click Provides information on the selected 
object. For example: right click the 
mouse on a check box and choose 
What's This? from the menu to view an 
explanation of that check box.

Help button Provides an overview of the current 
dialog box or window.

Status bar Provides a short description of the menu 
command you have currently selected.

You can browse through this Help file to become familiar with the help features available in Personal 
Web Server.

To open the online Personal Web Server Help files:
1. From the Help menu, choose the Contents command or press the F1 key.

To display Help for a specific command:
1. Highlight the command.
2. Press the F1 key.

To display Help for a specific dialog box:



1. Press the Help button on the dialog box.

To display Help for window elements such as buttons and list boxes:
1. Press the Shift and F1 keys at the same time and then click the element.



Applies any changes you've made in the File Properties dialog box to the current session. The File Properties dialog box 
remains open.



Activates on-line Help for Personal Web Server.



Enables you to configure the Usage Log.



Enables you specify a location to store your Usage Log.



Enables you to search for a specific location to store your Log file.



Enables the Usage Log to include the host names with all entries.



Enables the Usage Log to have multi-line entries with full headers.



Enables the Usage Log to display all access denied messages.



Enables you to specify a location to store your Error Log.



Enables to specify a location to store your Error Log.



Enables you to search for a location to store your Log file.



Keyboard Short-cuts

Function Keyboard 
Short-cut

Delete Page 
{button ,AL(`Del
ete command 
(Edit menu)')}

Del

Print 
{button ,AL(`Prin
t command (File 
menu)')}

Ctrl+P

Add Page 
{button ,AL(`Add
File command 
(Edit menu)')} 

Insert

Help 
{button ,AL(`Usi
ng Help 
command (Help 
menu)')}

Context 
Sensitive Help 

F1

Shift+F1

Minimize reduces the window to an icon beside the clock on the task bar. This action occurs when 
you either choose the Minimize command from the System menu or click the button that’s furthest to 
the left in the upper right corner of the window.



Maximize increases the window to the size of your screen. This action occurs when you either 
choose the Maximize command from the System menu or click the middle button in the upper right 
corner of the window.



Size allows you to drag a border on the window to resize it.



Close shuts down the window.



Restore returns the window to its original size.



Move allows you to drag the window to a new location.



Switch To displays the Task List from which you can activate another application.



Caption bar displays the name of the current directory contents and pane.



Scroll bars advance the information in the current panel.



System menu is activated by clicking the Personal Web Server icon in the upper left corner of the 
Personal Web Server window. It contains commands which enable you to restore, move, size, 
minimize, maximize, and close the Personal Web Server window.



About

The About Personal Web Server dialog box displays version information about Personal Web Server.



Add Document dialog box

Enables you to add a file or directory of files to your Personal Web Server. 

File name text box enables you to type the file name and path of the file that you’re adding to your 
Personal Web Server.

Public name text box enables you to type the name you want your file to be referred to by the 
outside world.

Description text box enables you to type a description of the file you're adding.

OK button exits from the Add Document dialog box and adds the file to your Web server. Click here 
after you’ve provided a filename and path, a public name, and a description of the file.

Cancel button cancels any changes you’ve made and closes the Add Document dialog box.



Enables you to add a file or a directory of files to your Personal Web Server.



Type the file name and path of the file that you’re adding to your Personal Web Server.



Type the name you want your file to be referred to by the outside world.



Type a description of the file you're adding.



Click here once you’ve provided a filename and path, a public name, and a description of the file.



Cancels any changes that you’ve made and closes the dialog box.



Options dialog box

The Options dialog box allows you to configure Personal Web Server's application options.

Browser tab enables you to configure how Personal Web Server launches your Web browser 
whenever you open an HTML document (or a Web page) from within the Personal Web Server 
window.

Logging tab enables you to configure your Usage and Error Logs.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.

{button ,AL(`Browser tab (Options dialog box);Logging tab (Options dialog box)')} Related 
topics



Enables you to configure program options.



Applies any changes you’ve made in the Options dialog box to the current session. The Options dialog box remains open.



Displays the Options dialog box Help page.



Accepts your changes to the Options dialog box and returns to the Personal Web Server main window.



Cancels any changes you’ve made, exits the dialog box, and returns to the Personal Web Server main window.



Browser tab (Options dialog box)

Enables you to configure how Personal Web Server launches your Web browser whenever you open 
an HTML document (or a Web page) from within the Personal Web Server window.

Launch URL button sends the URL of the Web page directly to the Windows 95 operating system. 
Windows 95 then launches your Web browser and locates the selected Web page.

Launch Program button instructs Personal Web Server to launch your Web browser whenever you 
open an HTML document (or a Web page) from within the Personal Web Server window.

Path text box specifies the path to your Web browser application.

Browse button enables you to view the folders on any drives that are available to your system to 
make it easier to locate your Web browser.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.



Enables you to configure how Personal Web Server launches your Web browser whenever you open a Web page from within 
the Personal Web Server window.



Sends the URL of the Web page directly to the Windows 95 operating system. Windows 95 then launches your Web browser 
and locates the selected Web page.



Instructs Personal Web Server to launch your Web browser whenever you open a Web page from within the Personal Web 
Server window.



Specifies the path and executable name of your Web browser application.



Enables you to view the folders on any drives that are available to your system to make it easier to locate your Web browser.



Logging tab (Options dialog box)

Enables you to configure the Usage and Error Logs.

Usage Log group enables you to configure your Usage Log.

Log File name text box enables you to specify a location to store your Usage Log.

Browse button enables you to search for a location to store your Log file.

Include host names in log check box enables the Usage Log to include the host names with all 
entries.

Multi-line log entries with full headers check box enables the Usage Log to have multi-line entries 
with full headers.

Log access denied messages check box enables the Usage Log to display all access denied 
messages.

Error Log group enables you to specify a location to store your Error Log.

Error log name text box enables you to specify a location to store your Error Log.

Browse button enables you to search for a location to store your Log file.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.



Enables you to configure the Usage and Error Logs.



Enables you to configure your Usage Log.



Enables you to specify a location to store your Usage Log.



Enables you to view the folders on your system to help you search for a specific location for your Log file.



Specifies whether you want the names of the active hosts to be included in the log file. Including the host names may slow 
down performance significantly.



Enables the Usage Log to have multi-line entries with full headers. Allowing multi-line entries with full headers may slow down 
performance significantly.



Enables the Usage Log to display all access denied messages. Enabling the display of all access denied messages may slow 
down performance significantly.



Enables you to specify the location of your Error Log.



Enables you to specify the location of your Error Log.



Enables you to view the folders on your system to help you search for a specific location for your Log file.



File Properties dialog box

Enables you to configure the properties of any file or directory on your Personal Web Server.

General tab enables you to change the filename and path, the public name, and the description of 
the highlighted file. The General tab also informs you how many times the highlighted file has been 
accessed and enables you to reset this number to zero.

Advanced tab enables you to define the MIME content type of the highlighted file and to instruct 
Personal Web Server to parse the Web page, corresponding to the highlighted file, for Personal Web 
Server’s HTML tags. The latter will default to the appropriate setting.

Security tab enables you to specify which computers can access the highlighted file. You may want 
to make a specific file accessible to only certain computers.

Links tab enables you to see how many hits the highlighted file has received and from which links 
(URLs). A hit only shows up in the links list if it’s from another page which contains a link to the hit 
page (or highlighted file).

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.

{button ,AL(`Advanced tab (File Properties dialog box);General tab (File Properties dialog 
box);Links tab (File Properties dialog box);Security tab (File Properties dialog box)')} Related 
topics



Enables you to configure the properties of any file or directory on your Personal Web Server.



Applies any changes you’ve made in the File Properties dialog box to the current session. The File Properties dialog box 
remains open.



Displays the File Properties dialog box Help page.



Accepts your changes to the File Properties dialog box and returns to the Personal Web Server main window.



Cancels any changes you’ve made, exits the dialog box, and returns to the Personal Web Server main window.



General tab (File Properties dialog box)

The General tab enables you to change the filename and path, the public name, and the description 
of the highlighted file. It also informs you how many times the highlighted file has been accessed and 
enables you to reset this number to zero.

File name text box enables you to specify the file name and path of the file you want to make 
available to the outside world.

Public name text box enables you to specify the name that you want your file to be referred to by the
outside world.

Description text box enables you to provide a more detailed description of the file you identified in 
the File name text box. 

Access counter keeps track of the number of times a file on your Personal Web Server has been 
accessed by the outside world. 

Reset button resets the Access counter to zero.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.



Enables you to change the file name and path, the public name, and the description of the highlighted file. It also informs you 
how many times the highlighted file has been accessed and enables you to reset this number to zero.



Specifies the path and file name of the file you want to make available to the outside world.



Specifies the name that you want your file to be referred to by the outside world.



Provides a more detailed description of the file you identified in the File name text box.



Keeps track of the number of times a file on your Personal Web Server has been accessed by the outside world.



Resets the Access counter to zero.



Advanced tab (File Properties dialog box)

Enables you to define the MIME content type of the highlighted file and to instruct Personal Web 
Server to parse the Web page, corresponding to the highlighted file, for Personal Web Server’s HTML
tags. The latter will default to the appropriate setting.

MIME Content Type text box enables you to define the MIME content type of the highlighted file. You
only need to specify the MIME type if it isn't automatically detected by Personal Web Server.

Parse page for <counter> and <include> tags check box enables you to instruct Personal Web 
Server to parse the Web page, corresponding to the highlighted file, for Personal Web Server’s HTML
tags.

The <counter> tag in an HTML document will be replaced with a number representing the page’s hit 
count. For example, if you had in one of your document’s “This page has been visited <counter> 
times.” the user might see “This page has been visited 452 times.”

The <include> tag lets the user insert a separate file into an HTML document. For example:
Here is your autoexec.bat file:
<samp><pre><include c:\autoexec.bat></pre></samp>
And here is your config.sys file:
<samp><pre><include c:\config.sys></pre></samp>

The filename in the include tag will be sent with no processing done on it’s contents (ie. it cannot 
include another <include> tag or a counter).

By default this Parse page for <counter> and <include> tags check box will be on for HTML or HTM 
documents and off for all other files. Therefore, it should rarely have to be adjusted.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.



Enables you to define the MIME content type of the highlighted file and to instruct Personal Web Server to parse the Web 
page, corresponding to the highlighted file, for Personal Web Server’s HTML tags. The latter will default to the appropriate 
setting.



Enables you to define the MIME content type of the highlighted file. You only need to specify the MIME type if it isn't 
automatically detected by Personal Web Server.



Enables you to instruct Personal Web Server to parse the Web page, corresponding to the highlighted file, for Personal Web 
Server’s HTML tags.
The <counter> tag in an HTML document will be replaced with a number representing the page’s hit count. For example, if you
had in one of your document’s “This page has been visited <counter> times.” the user might see “This page has been visited 
452 times.”
The <include> tag lets the user insert a separate file into an HTML document. For example:

Here is your autoexec.bat file:
<samp><pre><include c:\autoexec.bat></pre></samp>
And here is your config.sys file:
<samp><pre><include c:\config.sys></pre></samp>

The filename in the include tag will be sent with no processing done on it’s contents (ie. it cannot include another <include> tag
or a counter).
By default this setting will be on for HTML or HTM documents and off for all other files. Therefore, it should rarely have to be 
adjusted.



Security tab (File Properties dialog box)

Enables you to specify which computers can access the highlighted file. You may want to make a 
specific file accessible to only certain computers.

No Security button enables you to allow access by all machines to the highlighted file.

Restrict Access button enables you to specify which machines can have access to the highlighted 
file.

Access list box enables you to view the names of the specific machines that have access to the 
highlighted file.

Add button enables you to add the name of a machine to the Access list box.

Remove button enables you to remove the name of a machine from the Access list box.

Alternate page text box enables you to designate an alternate Web page to display to those 
machines that are denied access to the Web page that's represented by the highlighted file. i.e. You 
could designate an alternate Web page that you’ve created that displays the message “You can’t 
access this file!”.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.



Enables you to specify which computers can access the highlighted file. You may want to make a specific file accessible to 
only certain computers.



Enables you to allow access by all machines to the highlighted file. 



Enables you to specify which machines can have access to the highlighted file. 



Enables you to view the names of the specific machines that have access to the highlighted file.



Enables you to add the name of a machine to the Access list box.



Enables you to remove the name of a machine from the Access list box.



Enables you to designate an alternate page to display to those machines that are denied access to the page that's represented
by the highlighted file. i.e. You could designate an alternate Web page that you’ve created that displays the message “You 
can’t access this file!”.



Links tab (File Properties dialog box)

Enables you to see how many hits the highlighted file has received and from which links (URLs). A hit 
only shows up in the links list if it’s from another page which contains a link to the hit page (or 
highlighted file).

Pages with links to this page list box enables you to see how many hits the highlighted file has 
received and from which links (URLs). A hit only shows up in the links list if it’s from another page 
which contains a link to the hit page (or highlighted file).

Clear List button enables you to clear the Pages with links to this page list box.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Personal Web Server main 
window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Personal 
Web Server main window.



Enables you to see how many hits the highlighted file has received and from which links (URLs). A hit only shows up in the 
links list if it’s from another page which contains a link to the hit page (or highlighted file).



Enables you to see how many hits the highlighted file has received and from which links (URLs). A hit only shows up in the 
links list if it’s from another page which contains a link to the hit page (or highlighted file). 



Enables you to clear the Pages with links to this page list box.



Add new site to access list dialog box

Enables you to add the name of a machine to the Access list box to give it access to the highlighted 
file.

Name or address of machine text box enables you to enter the name or address of the machine 
that you would like to add to the Access list.

OK button accepts your changes to this dialog box and returns to the File Properties dialog box.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the File 
Properties dialog box.



Enables you to add the name of a machine to the Access list box to give it access to the highlighted file. 



Enables you to enter the name or address of the machine that you would like to add to the Access list.



Accepts your changes to this dialog box and returns to the File Properties dialog box.



Cancels any changes you’ve made, exits the dialog box, and returns to the File Properties dialog box.



Congifuring your system as a Server

You may need to make some changes to your operating system configuration for your system to be 
able to operate as a Web Server. Your server can operate on two scales: as a server that's only 
available across a local area network but not to the World Wide Web and as a full server on the World
Wide Web. If you get access to the World Wide Web through a network, your Network Administrator 
may have to make significant changes to the system to allow outside users on the Web to access 
your server.

To configure your TCP/IP configuration for an internal server:
1. Click the Start button and choose the Settings menu.
2. Choose Control Panel from the submenu.
3. Double click the Network icon.
4. Click the Configuration tab.
5. Double click TCP/IP in the list.
6. Click the WINS Configuration tab.
7. Click Enable WINS Resolution.
8. Check with your System Administrator to make sure that you have the proper Primary and 

Secondary WINS Server addresses. Typically, these addresses take the form of four numbers 
separated by periods. For example, 120.1.20.100.

9. Click the DNS Configuration tab.
10. Click the Enable DNS button
11. In the Host text box, type your computer name. You can find your computer's name by clicking on 

the Identification tab of the first Network configuration dialog box.
12. In the Domain text box, type the network domain that you access. Check with your System 

Administrator if you're unsure of your system's domain.
13. Click the OK button on the TCP/IP Properties dialog box.
14. Click the OK button on the Network dialog box.

To configure your server for access from the World Wide Web:
If you're on a local area network, you will likely need assistance and cooperation from your system 
administrator to make your server available outside your local area network.

1. Click the Start button and choose the Settings menu.
2. Choose Control Panel from the submenu.
3. Double click the Network icon.
4. Click the Configuration tab.
5. Double click TCP/IP in the list.
6. Click the WINS Configuration tab.
7. Click the DNS Configuration tab.
8. Click the Enable DNS button
9. In the Host text box, type your computer name. You can find your computer's name by clicking on 

the Identification tab of the first Network configuration dialog box.
10. In the Domain text box, type the network domain that you access. Check with your Internet service 



provider if you're unsure of your system's domain.
11. Click the OK button on the TCP/IP Properties dialog box.
12. Click the OK button on the Network dialog box.

Accessing your server

Before users can access your server, they need to know the address of your server. 

To find your address:
1. Click the Start button.
2. Choose Run from the menu.
3. In the Run dialog box, type WINIPCFG.
4. The IP Address box contains the address that users need to use to access your server.

To confirm your IP address:
1. Click the Start button.
2. Choose the Programs menu.
3. From the Programs menu, choose the MS DOS prompt.
4. At the DOS prompt, type PING followed by a space and your IP Address. For example, PING 

120.100.6.51. If your IP address is found, you'll receive replies from the network. If it isn't found, 
you'll receive an error.



How users access your server

After you've configured your computer and added some pages to Personal Web Server, users can 
now access your server.

Users can access your Personal Web Server by one of two methods:
1.If your machine is accessible by name they type http://[machine name].[domain]/[filename] in their 
Web browser’s location text box. Machine name and domain are set in the DNS page of the network 
control panel’s TCP/IP page.
2.Otherwise, they type http://[ip address]/[filename] in their Web browser’s location text box. 

You can test access yourself to make sure your server looks the way you want it to. Start a web 
browser and type your IP address followed by your home page name. For example, 
120.100.6.51/HOME.HTM.



Multimedia Internet Mail Extensions (MIME)
MIME is a naming convention for data file types that you're going to provide access to over the 
Internet. Whenever you send data other than text, you must specify its MIME type so the data is 
managed properly during transmission and when its received. MIME types are stored in the Windows 
95 registry.



 How to...

System configuration
To configure your server for access from the World Wide Web
To configure your TCP/IP configuration for an internal Server
To confirm your IP address
To find your IP address

Using Personal Web Server
access the File Properties dialog box
access the Options dialog box
add a file or directory of files to your Personal Web Server
delete a file or directory of files from your Personal Web Server
disable the Status Bar
exit Personal Web Server
minimize Personal Web Server and leave it running in the background
print the list of files and directories
set print options

Error logging
clear the Error Log
clear the Usage Log
see a record of the current Error Log
see a record of the current Usage Log

Help
display Help for a specific command
display Help for a specific dialog box
display Help for window elements such as buttons and list boxes
display the version of Personal Web Server that you  ’  re using  
open the online Personal Web Server Help files




