
About This Manual

About This Manual

This manual provides a description as well as step-by-step instructions on using 
the features contained in Multimedia Studio. It is recommended that you 
reference the Getting Started section in this manual for information on the 
installation of Multimedia Studio, background information on Multimedia Studio
and some tutorial lessons that get you off to a quick start. For information on the 
Sound Editor, Image Editor, Video Editor, Video Capture, Morphing Editor, 
Album, CD ROM Browser and Screen Capture tools, refer to the Multimedia 
Production Tools manual.

The process of creating a self-running or interactive multimedia application with 
Multimedia Studio can be broken down into four general steps. These steps are:

1. Creating the individual screens of your application.

2. Linking the individual screens of your application together.

3. Previewing your application. This allows you to test your application to 
ensure that it is linking correctly, that the multimedia elements are 
properly incorporated, the screens look the way you want, etc.

4. Mastering your application. This process copies all of the application 
files to the same directory, with the appropriate sub-directories, on your 
hard drive. You can then copy these files to floppy disks, tape backups, 
CD ROMs, etc. to distribute them.
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After you gain an understanding of these four concepts, you can begin creating 
brilliant, high quality, interactive applications. 

This manual is divided into six main sections:

· Getting Started

· Screen Creation

· Linking Screens

· Database Features

· Application Creation

· Appendices

Additionally, there is a brief glossary of terms.
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Section1
Getting Started
In order to get off to a quick start with Multimedia Studio, you need to learn basics. The Getting 
Started section provides the information you need to get off to a quick start with Multimedia 
Studio.

The following sections tell you:

What is Multimedia Studio.............................4

What you need to know before installation...6

How to install Multimedia Studio..................12

How to setup your hardware..........................14

About the main window.................................16

How to use the tutorials.................................22



Multimedia Studio

What is Multimedia Studio?

Welcome to the world of multimedia, the newest and most exciting technology 
to hit the field of computing! In its simplest form, multimedia is the integration 
of text with sound, still images, animation, and motion video on a computer 
system. With its cross-industry and cross-presentation appeal, multimedia 
represents the merging of the computer, entertainment, consumer electronics, and
educational industries. Never before has a single technology had such potential 
to fundamentally impact nearly every aspect our lives, in ways never before 
imagined.

Multimedia is bringing power to computer users that they never imagined having
in the past. For years, multimedia has been implemented for many presentations, 
including corporate training, business presentations, informational kiosks, 
electronic publishing, and educational/instructional presentations. Companies 
everywhere, from small "mom and pop" businesses to Fortune 100 corporations 
are beginning to utilize the power of multimedia in everyday applications. 

In the past, working with multimedia was out of reach of the average computer 
user, because many of the software packages required the use of various forms of
programming and scripting languages, as well as dozens of supplementary 
products to create even the most simple multimedia presentations. Multimedia 
Studio is the first software product designed specifically to give mainstream PC 
users all of the tools required to create and distribute professional quality 
multimedia presentations that combine text with photo quality images, digital 
quality sound, and motion picture quality video and animation. Pull down menus
and unique "HyperButton" Authoring TechnologyTM make Multimedia Studio 
extremely simple and easy to use for even novice users.

Ease of use, however, is only the beginning. Multimedia Studio provides you 
with powerful features that go beyond the basic definition of multimedia. Screen 
editing tools give you the flexibility to create screen layouts tailored to your own
needs. Multimedia Studio also enables you to capture directly from live video or 
import images from popular paint and graphics packages, which gives you 
maximum flexibility in designing your screens. After your multimedia 
presentation is created, Multimedia Studio allows you to create application 
runtimes that you distribute royalty free.
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Because multimedia applications can often consist of hundreds of application 
screens and hundreds of still image, sound, animation, and live video files, 
screen management is an integral part of any presentation software package. That
is why Multimedia Studio was designed with an integrated database management
system. In other words, Multimedia Studio is both a powerful presentation 
package and database management system in one. 

Multimedia Studio is designed to be as easy to use and as powerful as possible. 
In no time at all, you will have the basics mastered and be well on your way to 
creating presentations never before imagined. You now have the tools needed to 
unlock the true potential of your PC, with Multimedia Studio Multimedia 
Software!



Before You Install

System Requirements

There are a few minimum system requirements to run Multimedia Studio 
successfully.

System Requirements
· 386 or Higher Intel compatible PC
· Hard Drive
· CD ROM (for installation and content, disks are available upon request)
· VGA Monitor 
· VGA Display Card
· 4 or more megabytes of RAM 
· Microsoft Compatible Mouse
· Windows 3.1 

Licensing Agreement

You should install your copy of Multimedia Studio only after you have read and 
accepted the terms of the license agreement as printed on the envelop containing 
the program diskettes. Opening the license envelop and installing Multimedia 
Studio acknowledges your acceptance of the license agreement and all of the 
terms and conditions specified therein.

Registering Multimedia Studio

The Multimedia Studio registration card is enclosed in the package. Please fill 
out this card and mail it to register your product to be eligible for product 
support and updates.
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Multimedia Studio and Windows

Multimedia Studio runs under Microsoft Windows, version 3.1. See your 
Windows documentation for details and procedures for using Windows.

Many Multimedia Studio actions are the same as Windows actions. If you 
understand how to control Windows, choose commands and control dialog 
boxes, then you already know most of the techniques you need to use 
Multimedia Studio. The following sections describe some of the terminology 
used in this manual and the Multimedia Studio User's Guide:

Pointing
The mouse controls a pointer on your screen. The pointer can have a 
number of shapes. Typically it takes the form of an arrow. The pointer 
takes the shape of an I-beam (a stylized letter I) when you are in an edit 
box in order to enter text. The pointer takes the form of an hourglass 
whenever the Multimedia Studio is processing a command you have 
selected. If the hourglass is visible, you cannot select any other 
command until the process is finished. Moving the mouse on a flat 
surface moves the pointer in a corresponding fashion on the screen.

Mouse Buttons
Unless otherwise specified, clicking a mouse button refers to the left 
button of the mouse.



Clicking
Clicking means pressing and quickly releasing a mouse button. By 
pointing to something on your screen and then clicking a mouse button, 
you select what is underneath the pointer. Double Clicking means 
pointing to an object on the screen and quickly clicking the mouse 
button twice. 

Dragging
Dragging is used to mark an area on the screen, or to move an object on 
the screen. By positioning the pointer on the object to be selected, 
pressing and holding a mouse button, dragging the pointer to the new 
position for the object, then releasing the mouse button, you move the 
object to the new location.

Highlighting
Highlighting refers to marking an object in order to perform a function 
on that object. If the pointer is an arrow, simply point to the object you 
want to highlight and click the left mouse button. If the pointer is the I-
beam, point to the object, then click and drag the pointer to the end of 
the object to highlight it.

Choosing Menu Items

Multimedia Studio uses a standard Windows menu bar for executing certain 
commands. See the Microsoft Windows User's Guide for information on using 
the menu bar.

Active menu items appear in black, inactive choices in gray. When you point to 
an active item on the menu bar, the option is highlighted. See the User’s Guide 
for information on the specific menu commands.

�To select a menu item with the mouse:
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1. Point to the name of the menu on the menu bar and click on the name to 
open the menu.

2. Click on the menu item you want.

�To select a menu item with the keyboard:

1. Menus have underlined letters. To open a menu with the keyboard, press
ALT and simultaneously press the key that corresponds to the 
underlined letter. 

2. Menu items also have underlined letters. When the menu is displayed, 
press the key that corresponds to the underlined letter of a menu item to 
activate it.

�To cancel a selected menu:

1. Click on the menu name or anywhere outside the menu, or

2. Press the Esc key.



Activating a HyperButton

HyperButtons are areas on the screen, which when selected, execute 
predetermined operations such as linking screens, activating sound and 
animation files, performing search functions, activating live video, etc. 
HyperButtons can be displayed as plain buttons, buttons with images on them, or
even invisible hot spots on graphics. When HyperButtons are created, they can 
be activated in different ways:

· Clicking on them with the mouse.

· Typing the first letter of the name on the button using a keyboard or 
keypad.

· Touching the button when using a touch screen.

Making Backup Copies

You can make backup copies of the original release disks of Multimedia Studio 
using the DOS diskcopy command or the disk copy feature in the File Manager 
of Windows. This is always a good idea when initially installing a software 
package. For detailed information, see your DOS or Windows manual. 

We recommend that the original Multimedia Studio disks are write protected 
prior to making a copy. Also be sure to transcribe the information from the 
original disk labels to the labels on the new copies.

When you finish making the backup copies, store the original disks in a safe 
place and use the backup copies to run the installation program.
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Technical Support

Upon receipt of your registration card, Advanced Media provides you with 
technical support. If you are having technical problems, and you cannot solve 
your problem using the Troubleshooting section in the Appendix of this manual, 
technical support is available by calling 714-957-1616. 



Installation

The Setup program for the Multimedia Studio makes installing the software easy 
and straightforward. Setup decompresses and copies the essential files onto your 
hard disk and asks you to verify critical information and make changes if 
necessary. The setup procedure installs Multimedia Studio and the additional 
programs that are described in the Multimedia Production Tools manual. The 
following installation must be done from within Windows.

Important: Do not try to install Multimedia Studio by copying files directly 
from the CD ROM. The files are converted into usable files during the setup 
process.

�To install Multimedia Studio for Windows:

1. Insert the Multimedia Studio CD ROM into your CD ROM drive.

2. Open the Program Manager window, if it is not already open.

3. From the File menu, choose Run.

4. In the Command Line box, type D:\SETUP (where D is the CD ROM 
drive containing the Multimedia Studio CD ROM) and press ENTER.

5. When the installation procedure begins, an initial screen appears along 
with an hour glass icon. The installation routine must scan the contents 
of your system to set itself up to offer you the appropriate options. When
the installation begins, read the options carefully and select the ones you 
want.
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Installing Video for Windows
The Multimedia Studio CD ROM includes a copy of Video for Windows. If you 
do not already have a copy installed, you must install Video for Windows to use 
video in your applications. This includes running the Video Editor and Video 
Capture programs.

„To install Video for Windows:

1. Insert the Multimedia Studio CD ROM into your CD ROM drive.

2. Open the Program Manager window, if it is not already open.

3. From the File menu, choose Run.

4. In the Command Line box, type D:\VFW\SETUP (where D is the CD 
ROM drive containing the Multimedia Studio CD ROM) and press 
ENTER.

5. When the installation procedure begins, an initial screen appears along 
with an hour glass icon. When the installation begins, read the options 
carefully and select the ones you want.



Setting up Drivers

When creating multimedia presentations with Multimedia Studio, you can use 
sound, video and animation. Most of the devices and drivers that you will be 
using with your multimedia application can be setup using the options in the 
Control Panel within Windows. Some of the drivers that you are using may not 
be available from within the Control Panel. We have provided you with an 
additional setup program which allows you to setup additional drivers that are 
not available with Windows. These drivers are for Capture/Overlay boards, 
Digital Video boards and Video devices.

„To setup a specific driver for use with Multimedia Studio:

1. In the Program Manager, double click on the Hardware Setup icon in 
the Multimedia Studio group.

2. Click on the down arrow next to the category you are interested and 
select the driver you want from the list that appears.

3. Click on the Setup button and select the appropriate options.



Getting Started

Starting Multimedia Studio

�To start Multimedia Studio:

1. If it is not already open, open the Program Manager window.

2. Open the Multimedia Studio group window.

3. Double click on the Multimedia Studio icon.

4. The Multimedia Studio program appears and you can begin using 
Multimedia Studio.



The Main Window

How Multimedia Studio Works

Multimedia Studio is very easy to learn and use, because all of the commands are
easy to access and understand. Furthermore, all functions can be accessed with a 
simple mouse click, or even quicker for the skilled user by the use of convenient 
hot keys.

In designing Multimedia Studio, we have tried to enforce rules of operation that 
are consistent throughout Multimedia Studio and consistent with the operation of
other "point and click" Windows applications; especially those that run under 
Windows on IBM-compatible computers. We did this in order to make it as easy 
as possible for the largest number of users already familiar with Windows 
programs to get up and running with Multimedia Studio as quickly as possible.



Getting Started

The Multimedia Studio Work Space

In Multimedia Studio there are a variety of tools. These tools are used to create 
your interactive applications. The following section shows you where the 
Multimedia Studio tools are located and how they can be used to create an 
application.

Tool Locations

Take a close look at the diagram below. This diagram lets you become familiar 
with the location of the tools and some of the terms that are used in this manual.

Title Bar

Toolbox

Minimize/Maximize ButtonsWindow Control Box

Menu Bar

Toolbar

File Name Folder Status Quick Jump
Hot Spot

Folder Name

Folder Scroll
Button

Screen Scroll
Button

Screen Status

Work Area

A brief description of each tool follows.



Menu Bar

When you select an item in the Menu bar a box drops down with a list of 
commands. To select one of these commands, select the desired command name 
with the left mouse button. These commands can also be activated by using the 
keyboard. To activate a command with the keyboard, hold the Alt key on your 
keyboard and simultaneously press the underlined letter from the menu you 
want. When the menu drops down, type the underlined letter of the command 
you want.

Window Control Box

The Window Control Box allows you to perform a variety of standard Windows 
functions. For more information on the Window Control Box, refer to your 
Window’s manual.

Title Bar

The Title Bar displays the name of the current program and file currently being 
run.

Minimize/Maximize Buttons

These buttons are used to resize the main Multimedia Studio window or to 
minimize the window down to an icon.
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Toolbox

The toolbox contains a variety of tools that can be used to create presentations. 
There are three different groups of tool boxes, with each containing different 
icons (Editing, Objects and HyperButtons). To use a tool in the toolbox, click on
the icon that represents the tool you want to use. The following diagrams 
describe each of the icons in the different toolboxes. For more specific 
information on a particular icon, reference the appropriate section on that item.

Move

Copy
Attributes

Resize

Delete

Try It
Grid

Menu On\Off

HyperButtons
Objects

Color

Fade Effect

Repaint    

Text

Box
Circle

Data Field

Animation WindowImage Field

Live Video
Window

MPEG/AVI Window

GoTo

Sound

Video

Animation

Quit



Screen Status

The Screen Status area tells you which screen you are currently viewing in the 
current folder.

Screen Scroll Button

Clicking on the Screen Scroll button either takes you to the next screen, or the 
previous screen, depending on which button you click on.

Folder Scroll Button

Clicking on the Folder Scroll button either takes you to the next folder, or the 
previous folder, depending on which button you click on.

Folder Name

This area tells you the name of the current folder you are in. Double clicking on 
the folder name allows you to change the folder name.

Quick Jump Hot Spot

Double clicking on this area of the screen displays a dialog box that allows you 
to go to a particular screen or folder in your presentation.

Folder Status

The Folder Status area tells you which folder you are currently in.

File Name

This area of the screen displays the name of the current file you are working on.
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Work Area

The work area is where you create your application (images, HyperButtons, etc.).

Toolbar

The Toolbar contains buttons that launch the programs and utilities that are 
integrated with the Multimedia Studio. To launch a program, click on the 
appropriate button in the toolbar. The following diagram shows the button and 
its associated program. For more information on each program, see the 
Multimedia Production Tools manual that comes with Multimedia Studio.

Album

Video Editor

Image Editor

Morph Editor

Sound Editor

Video Capture

Screen Capture

CD Browser

Viewer



Tutorials

Lesson One

The following tutorial is designed to teach the basic concepts and use of 
Multimedia Studio. It contains a series of steps which take you through the 
process of developing a simple application. This application demonstrates how 
to use most of the basic features and capabilities within Multimedia Studio. This 
tutorial assumes that you have a basic familiarity with Microsoft Windows and 
its operation. The tutorial should take approximately one hour to two hours to 
complete. It can be completed in several sessions if you save your work when 
you want to stop, and then open your file when you resume. 

An example of the finished application resulting from this tutorial has been 
included so that you can get an idea of what you are going to be developing 
during this tutorial.  

A Quick Tour

Let’s start by reviewing the tutorial example. When you install Multimedia 
Studio a file containing this tutorial is installed on your hard disk (called 
TUTOR.STU). An icon is also added to your Multimedia Studio group called 
“Tutorial Example”. Double clicking on this icon opens the file containing the 
completed tutorial. The following steps take you through a tour of this file so 
that you can see what you are going to create.

„To view the completed tutorial file:

1. From the Program Manager, double click on the ‘Tutorial Example’ icon
in the Multimedia Studio program group to start Multimedia Studio 
with the tutorial example loaded. You should see a blue screen titled 
‘Main Menu’ with an image in the middle and two buttons near the 
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bottom. There should also be a toolbox in the upper right hand part 
of the screen.

2. From the Screen menu, select Update Icons.

3. Select the All Screens option and the click on the OK button. This 
builds an iconic representation of each screen that are used in the 
‘Screen Overview’ mode.

4. From the Screen menu, select Overview. This view shows an iconic 
representation of all the screens within the current application. 
Multimedia Studio applications are made up of a set of screens and 
folders. In this application there are three screens and two folders 
defined, with screen three being the only screen used in the second 
folder.

5. Click on the OK button to return to the single screen view. Notice that 
the screen and folder indicators in the status bars on the right and bottom
of the screen tell you that you are currently on Screen 1 of 3 and Folder 
1 of 2. The folder name is shown on the right side of the bottom status 
bar. In this case the folder is named ‘FOLDER1’. 



Previewing the Application

In order to view the application the way it will operate in a ‘runtime’ 
mode, you can place Multimedia Studio in the ‘preview’ mode. This 
allows you to see your application as a user would when they run the 
application. When an application is run in “runtime” mode it does not 
display the menus, title bar, toolbox and other parts of the screen that 
you see when you are developing the application. 

„To preview the tutorial:

1. From the File menu, select Preview. At this point you can try 
out this simple example. Click on the ‘Interactive’ button to go 
to the interactive example screen. From here you can click on 
the ‘Play Video’ button or the ‘Play Sound’ button. When you 
are done here, click on the ‘Main Menu’ button to return to the 
main menu screen. Start the self running portion of the example 
by clicking on the ‘Self Running’ button. This is an example of 
a non-interactive segment of an application which plays 
repeatedly by itself through the use of button linking (more on 
this later). Select the ‘Main’ button to return to the Main Menu 
screen when you are ready.

Note: If the sound is not playing, check to make sure that your 
sound hardware is installed properly. If the video is not playing, 
make sure that you have Video for Windows installed. If you are
still having problems, contact technical support.

2. When you are done viewing the application, press the Escape 
key on the keyboard to change from ‘preview’ mode back to 
‘authoring’ mode.

The up and down arrow keys on the right status bar or the 
keyboard can be used to go to the next or previous screen. The 
left and right buttons on the bottom status bar or the keyboard 
can be used to go to the next or previous folder.
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3. Click on the down arrow button at the bottom of the right status 
bar. This takes you to screen 2, which in this case is the 
interactive screen. Notice that the screen status indicator on 
the right status bar shows that you are on screen 2 of 3. If 
you click rapidly on the arrow buttons you bypass the 
intermediate screens and go directly to the selected screens 
(for example if you are on screen 1 and click twice on the 
down arrow you move directly from screen 1 to screen 3).

4. From the File menu, select Exit. This closes the tutorial example
and exits you from Multimedia Studio.

Building the Application

You will now be taken through the steps required to recreate the tutorial example
application that you just viewed. The first thing we need to do is to start up 
Multimedia Studio and open a new file.

„To start a new application:

1. Start up Multimedia Studio by double clicking on the ‘Multimedia Studio’
icon in the Multimedia Studio group in the Program Manager.

2. From the File menu, select New. At this point Multimedia Studio opens a
new file with the default name of FILE1. The default background color 
replaces the white Multimedia Studio background.



Creating the Main Menu Screen

Changing the Background

When creating applications, screen backgrounds tend to make your applications 
more visually appealing and professional looking. When creating applications in 
Multimedia Studio, you can choose from a variety of backgrounds that come 
with Multimedia Studio, or you can import your own images and use them as 
backgrounds. For this application, you are going to use one of the backgrounds 
that comes with Multimedia Studio.

„To choose a screen background:

1. From the Screen menu, select Background. This displays the 
background selection screen which consists of 16 standard solid color
backgrounds as well as a set of image backgrounds. The images 
background only appear if you chose them during installation. If there
are more backgrounds than fit on the screen, a scroll bar is present at 
the bottom of the screen which allows you to view the entire set of 
backgrounds. 

2. Select a background from the available selection. The background used 
for the sample is ‘Bluegrad’. To select a background you can click on
it, which highlights it in red, and then select the OK button, or you 
can just double click on the background you want. You may select a 
different background for a screen at any time.
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Creating Text

Using the Text tool , you can add text to your screen. This text can be simple
static text that just remains on the screen, or you can use the Fade Effect tool to 
fade the text on and off the screen. For this example, the text is going to be 
static. To fade text on and off the screen, see the section on the Fade Effect tool 
later in this manual.

„To add text to a screen:

1. From the Objects menu select Text. This brings up the Text Object 
dialog box where you define the ‘Main Menu’ text object.

2. Enter the text ‘MAIN MENU’ into the Text field of the dialog box. 

3. Select a font by either typing the font name or clicking on the ‘...’ button 
which brings up a standard font selection dialog box. The font used in
the example is Arial with a size of 36. The font size can be set 
directly in the text object dialog box, or from within the font 
selection dialog box.

4. Select a shadow value of 4 by clicking on the up arrow to the right of the 
shadow value box. The shadow value is the number of pixels on the 
screen that the shadow is offset by.

5. Click on the Bold check box to set the font to bold. This can also be been
done in the font selection dialog box.



6. Click on OK. The text object is placed in the upper left hand corner of 
the screen.

Moving Objects

If you look at the toolbox, you notice that the ‘Move’ tool  is the currently 
active tool. The move tool is activated automatically after creating a new object. 
The move tool is used to position objects on the screen. All objects are initially 
positioned near the upper left corner of the screen. You can use the move tool to 
position them wherever you want on the screen.

„To move the text:

1. Click on the text object with the left mouse button and drag it to a new 
location near the top center of the screen.

Changing Colors

After an object is created (in this case text), you can change its color. Changing 
an object’s color is simple and is done with the color tool.

„To change the color of the text:

1. From the Edit menu, select Color. Notice that the Color tool  on the 
toolbox is now active. All of the tools can be selected from either the 
edit menu or the ‘Tools’ toolbox.

2. Now that the Color tool is active, click on the text object. This brings up 
the color selection dialog box. Select a color for the text object (the 
example uses red).
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3. Click on the OK button to complete the color selection.

Changing Attributes

You can use the Attributes tool to edit or change the attributes or properties of 
objects or HyperButtons after they are created. Different objects have different 
attributes. For example, the attributes of text are different from those of a circle. 
Therefore, the dialog box that appears when you change an object’s attributes 
depends on the object.

„To change the attributes of the text:

1. From the Edit menu, select Attributes. Notice that the Attributes tool
 is selected in the toolbox.

2. Click on the ‘MAIN MENU’ text object. This displays the same dialog 
box that you used to define the object initially. At this point you 
could change any of the values in the dialog box. If you like you can 
change the font or size of the font.



3. If you make any changes to the text, click on OK. If you decide that you 
don’t want to make any changes to the text, click on Cancel.

Adding Additional Screens

When a new Multimedia Studio application is created, it consists of a single 
screen. Additional screens and folders are manually added to the application as 
needed. When creating applications you can add as many screens as you need. 
Since the tutorial example requires a total of three screens, you can add the other 
two screens now.

„To add a screen to an application:

1. From the Screen menu, select Add Screen. This adds a new screen and 
positions you on the new screen.

2. Repeat step 1. This adds another screen and takes you to this new screen 
so you are on screen 3 of 3.

3. Position yourself back to screen 1 by clicking twice on the up arrow 
button on the status bar located on the right of the screen, or using the up 
arrow key on the keyboard.

Creating the Goto Buttons

You are now going to create two Goto HyperButtons, one called ‘Interactive’ 
and one called ‘Self Running’. These buttons are going to be placed at the 
bottom of Screen 1. Goto HyperButtons are used to jump from one screen to 
another. When the user clicks on a Goto HyperButton, they are taken to the 
appropriate screen as determined by the Goto HyperButton.

„To create a Goto HyperButton:

1. From the HyperButtons menu, select Goto. This displays the Goto 
button dialog box.
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2. Enter ‘Interactive’ in the Button Name field. This is the name that 
appears on the button when it is created.

3. Select a font and size for the button name (the example uses Arial size 
12).

4. In the Destination box, click on the down arrow to the right of the Screen
field. This displays a list of all the screens in your application. Select 
‘2’ as the destination screen and leave ‘FOLDER1’ as the destination 
folder. This defines the screen that is jumped to when the Goto button
is pressed.

5. Click on the down arrow button to the right of the Transition Effect field
and select a transition. The example uses Top to Bottom Thick 
Shutter. This determines how the new screen is displayed when the 
Goto button is clicked on.

6. Click on the OK button to complete the creation of the Goto button. The 
button appears in the upper left corner of the screen.

7. From the Edit menu, select Copy. Notice that the Copy tool  is now 
active in the toolbox. The copy tool is used to make a copy of an 
object.

8. Click on the Goto button you just created (‘Interactive’) to create a 
second Goto button. Another Goto button called ‘Interactive’ appears.



This button has the same attributes as the first button you created. 
Using the Attributes tool, you are going to change the attributes of 
this new button.

„To change the attributes of the new button:

1. From the Edit menu, select Attributes.

2. Click on the second ‘Interactive’ button to bring up the dialog box and 
edit the following parameters:

Button Name: Self Running
Destination Folder: FOLDER1
Destination Screen: 3

 Transition Effect: None

3. Click OK when you are done.

Moving, Sizing and Aligning the Buttons

You now need to move the Goto HyperButtons to position them on the screen 
where you want. 

„To position the new Goto HyperButtons:

1. From the Edit menu, select Grids. This is used to give you better 
control of the positioning of objects on the screen. With the grids 
turned on, objects ‘snap to’ the grid lines when you move or resize 
them.  

2. Click on OK in the grid information dialog box. The gridlines should 
now be visible. Notice that the Grids button  on the toolbox is 
now depressed. Grids can be turned on and off at any time by 
selecting the grids button on the toolbox.
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3. From the Edit menu, select Move, or select the move tool  on the 
toolbox.

4. Click and drag the two Goto HyperButtons to position them near the 
bottom of the screen.

5. From the Edit menu, select Resize. Notice that the Resize tool  is 
now active on the toolbox.

6. Resize the buttons to the desired size by clicking and dragging near a 
corner of the button. Notice that as you resize the buttons, they snap 
to the grid lines. This is because you turned the snap to grid option on
earlier.

7. From the Edit menu, select Color or select the color tool on the toolbox.
The colors of the buttons and the text on the buttons can now be changed
by clicking on a button or the text within a button.

Deleting an Object

In case you make a mistake during the tutorial and need to delete an object, the 
delete tool can be used to delete an object. Be careful when deleting objects, 
because objects cannot be undeleted. The following steps show you how to 
delete an unwanted object.

„To copy an object and then delete it:

1. Use the copy tool to create a copy of one of the Goto buttons.

2. From the Edit menu, select Delete.

3. Click on the extra Goto button that you just created. A confirmation box 
appears to make sure that you really want to delete the object.

4. Click on the OK button. The object is deleted.



Importing the Image

Images in Media Master Professional are imported into objects called ‘Image 
Fields’. Image fields define the position and size of the image objects. This 
method assures optimal performance in displaying images when the application 
is run.

„To import an image:

1. From the Object menu, select Image Field.

2. In the Name field enter a name for the image field. The example uses the
name ‘Image Field’

3. Click on the OK button to create the image field. The field appears 
‘hashed out’ since it has not yet been saved.

4. Using the Move tool  , click and drag the image field to the center of 
the screen.

5. From the File menu, select Save As.

6. Enter ‘myfile’ as the name to save the file as and select the OK button..

7. Select OK in the Update Screen Icons dialog box.

8. From the Image menu, select Import. Multimedia Studio verifies which 
image field you want to import an image into. Select the Yes button 
in the dialog box.
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9. Click on the ‘...’ button to the right of the Image Name field in the 
Import Image dialog box. This displays the standard file selection 
dialog box.

10. Select ‘vitest.tga’ as the image to import and click on OK.

11. Select OK in the Import Image dialog box. Multimedia Studio 
automatically scales the image being imported to the size of the 
image field and saves this resized copy as a separate file. At this 
point, you are prompted to enter the filename and location to save 
this copy to.

12. Enter ‘myimage’ in the File Name field of the Save Image File dialog 
box and click on OK. 

13. You can click on the Grid tool to turn the grid off.

Congratulations! The main menu screen is now complete.



Building the Interactive Screen

The interactive screen will have a Text Object, a Sound HyperButton, a Video 
HyperButton, a Framed Box object with a Video Window on top of it, and a 
Goto HyperButton. This is the screen that is displayed when you click on the 
Goto HyperButton called ‘Interactive’. The Interactive screen is Screen 2 
Folder1 of your application. You must first go to that screen and then begin 
creating it.

„To begin creating the Interactive screen:

1. Double click on the Quick Jump hotspot.

D ouble  C lick Here

2. From the dialog box that appears, enter ‘Screen 2’ in the Screen field and
click OK. This takes you to screen 2 of your application. The screen 
is currently blank, but this will change quickly as you create the 
screen.

3. From the Screen menu, select Background. Select any background you 
like and click OK.

4. From the Objects menu, select Text and add the text object ‘Interactive’
in the same way you added the ‘Main Menu’ text object to the first 
screen. Use a 30pt Arial font. When the text appears, move it to the 
right side of the screen using the Move tool.

5. From the Objects menu, select Box.
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6. Leave the default settings and select the OK button to create the framed 
box. Use the Move tool and drag the box to the right about one inch.

7. Use the Color tool  to change the color of the frame or the 
background of the box. If you click on the frame of the box, you can 
change the color of the box’s frame, if you click on the inside of the 
box, you can change its background color.

Adding the AVI Video Clip

An .AVI file is a file format for video. To play .AVI video files in Multimedia 
Studio, you must have Video for Windows installed. If you do not have Video 
for Windows installed, see the Installation section of this manual. 

To play an AVI video file you need to create a Video Window and a Video 
HyperButton. The Video Window determines where the video file is going to be 
played on the screen and the size of the video when it is played. The Video 
HyperButton is a button that when clicked on, plays the selected .AVI file in the 
appropriate window. 

Note: When adding video clips to your application, you should create the Video 
Window first because you have to enter the name of the Video Window when 
you create the Video button. This is not necessary because you can always go 
back and change the attributes of objects, but it is recommended.

„To create a window for the video to play in:

1. From the Objects menu, select MPEG/AVI Video Window.



2. Give the window a name such as ‘AVI Win’ and select AVI as the 
Video Format. You can use any name for a Video Window, but you 
should make note of the name that use because you have to enter this
name when you create the Video button later. Click OK to create the
Video Window object.

3. Move and size the video window so that it is positioned inside the 
framed box that you created earlier.

Note: This video window does not appear when you run your application. It is 
only used when you are creating your application to determine where the video is
going to play when the Video HyperButton is clicked on.

„To create the Video HyperButton:

1. From the HyperButtons menu, select Video.
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2. In the Name box, enter ‘Play Video’ for the name of the Video 
HyperButton. 

3. Under the MPEG/AVI Information section, leave the File radio button 
selected and click on the ‘...’ button to the right of the File field to 
select the file ‘skiers.avi’ from the tutorial\video subdirectory.

4. In the MPEG/AVI Window field, enter the ‘AVI Win’ or whatever 
name you assigned to the MPEG/AVI Video Window.

5. Select OK to create the Video HyperButton.

6. Use the Move tool and move the Play Video button you just created so 
that it is below the framed box.

Testing the Video HyperButton

HyperButtons can be executed in the authoring mode by using the ‘Try It’ tool. 
The ‘Try It’ tool lets you test the buttons you create in your application as you 
create them. This allows you to detect errors in your application. If something is 
not working how you expected, you can quickly make the appropriate 
adjustment. For example, if the video is not playing where you want, you can 
easily move the Video Window.

„To test the Video HyperButton:

1. From the Edit menu, select Try It. Notice that the Try It tool  is now
depressed on the toolbox.

2. Click on the Video HyperButton that you just created. The video should 
play in the MPEG/AVI Video Window.



Adding the Sound HyperButton

Adding sound to a Multimedia Studio application is done with a Sound 
HyperButton. You can play either .WAV files or MIDI files from within your 
applications. To play a sound file, you must make sure that your sound board is 
installed properly. If you cannot play a sound file as documented in the 
following steps, check your sound hardware to make sure that it is installed 
properly. If you are still having problems playing a sound file, contact technical 
support. 

„To create a Sound HyperButton:

1. From the HyperButtons menu, select Sound. The Sound Button dialog 
box appears.

2. In the Button Name box, enter a name for the button such as ‘Play 
Sound’ and select a font and size if you wish.

3. Leave the File radio button selected and click on the browse button to 
the right of the File field to bring up the file selection dialog box and 
select ‘boing.wav’ from the tutorial\sound subdirectory.

4. Select OK to create the Sound Button and then use the Move tool and 
the new button to the right of the screen.

5. You may test the sound button using the ‘Try It’ tool  in the same 
way that you tested the Video Button.
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Adding the Goto HyperButton

The last thing you need to do on the interactive screen is to create the Goto 
HyperButton which is used to return to the main menu. When creating 
applications with a main menu, you should be sure to put a Goto HyperButton 
on different screens so the user can always get back to the Main Menu.

„To create a Goto HyperButton that goes to the main menu:

1. From the HyperButtons menu, select Goto and create a Goto 
HyperButton with the following parameters:

Button Name: Main Menu
Destination Folder: <First>
Destination Screen: <First>
Transition Effect: Top to Bottom

2. When the new Goto HyperButton is created, use the Move tool and 
position the new button on the lower right part of the screen.

3. From the File menu, select Save. It is always a good idea to save your 
work on a regular basis.



Previewing Your Work so Far

At this point, you can test your application to see what you have done so far. 
Applications can be previewed using the Preview command in the File menu. 
Previewing applications lets you see your application as a user of the application 
would (no menus, toolboxes, etc.). An application can be previewed at any time 
during its development.

„To preview an application:

1. Position yourself at screen 1.

2. From the File menu, select Preview.

3. Click on the ‘Interactive’ button. This should take you to your 
interactive screen where you can try out your sound and video 
buttons.

4. Click on the Video button and then click on the Sound button.

5. Click on the ‘Main Menu’ button to make sure it takes you back to the 
main menu.

6. Exit the ‘preview’ mode by pressing the Escape key on the keyboard.
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Building the Self Running Screens

You can now build the self running portion of the example. This involves two 
screens which automatically execute Goto, Sound and Animation buttons 
through the process of linking HyperButtons together. Self Running applications 
can be useful when you want to create applications that are not going to have any
human interaction. For example, you may want to create an application that 
demonstrates a product at a trade show and continually runs. The following steps
take you through the process of creating a simple self running application.

Adding the Second Folder

The self running portion of the application will be located in a separate folder 
from the interactive portion of the application. It is not necessary to create this 
portion in a separate folder, but it helps better organize your application and is a 
good lesson in the use of Folders.

„To create another folder:

1. From the Screen menu, select Add Folder.

2. Select OK in the Enter Folder Name dialog box. This creates a new 
folder with the default name of ‘FOLDER2’.

3. Use the arrow keys or the scroll buttons to position yourself at Screen 3, 
Folder 1.



Adding Display Effects to Objects

Display effects are used to cause objects to fade on and off of the screen at 
predefined times. In this case you will cause the text ‘Self Running’ to fade onto 
the screen immediately in a left to right direction.

„To create text and fade it onto the screen:

1. From the Objects menu, select Text and create a text object called ‘Self 
Running’ and then use the Move tool to position it in the top middle 
of the screen.

2. From the Edit menu, select Display Effect. Notice that the Display 
Effect button  is now depressed on the toolbox.

3. Click on the text ‘Self Running’. This causes the Object Display Effect 
dialog box to appear.

4. Select Left to Right as the Effect in the appear section.

Note: The Animation Path option is only used if you select Animate as 
the Effect.



Getting Started

5. Set the Speed to 4. The Speed determines how fast (or slow) the object 
fades to the screen. The higher the number, the slower the fade takes 
place.

6. Select OK to set the display effect for the text object.

7. From the File menu, select Preview. You now see how the objects are 
displayed on the screen with the new fade effect. 

8. Press the Escape key on the keyboard to exit the Preview mode.

Adding the Global Goto HyperButton

You will now create a Goto HyperButton that returns to the Main Menu screen 
from either of the two screens in the self running portion of the example. This is 
accomplished by creating a ‘global’ button which appears on screen 3 in both 
folders.

„To create a global Goto HyperButton:

1. From the HyperButtons menu, select Goto and set the following 
parameters:

Button Name: Main
Destination Folder: FOLDER1
Destination Screen: 1

2. Click on the Options button in the Goto Button dialog box. This 
displays the options portion of the dialog box. This section is the same 
for all HyperButtons and is used to set properties of texture (solid, clear 
or invisible), position (local or global), button level (this determine 
which object is on top when objects overlap), whether or not the button 
is clickable by the user, and several other parameters which are described
later.

3. Select Global in the position section.



4. Click OK to create the button and then move it to the bottom of the 
screen and make any size or color changes you wish.

5. Click on the right arrow button or key to move to folder 2. Notice that 
the Goto button is present on both screens. This is because the Goto 
button is global. The text is not global and therefore is not on both 
folders. Click on the left arrow button or key to go back to folder 1.

Adding the Invisible Sound and Goto HyperButtons

Invisible buttons are used to cause events to happen, but are not visible on the 
screen during preview or runtime mode. In authoring mode, invisible buttons are 
shown as outlines. Invisible buttons can be used in many ways to create different
types of effects. For example, you can create an invisible Goto HyperButton and 
put it on top of an image. The user does not see the invisible button, but when 
they click on the image, they are taken to the screen that is determined by the 
Goto HyperButton. Invisible HyperButtons are also useful when they are linked 
to other HyperButtons that are visible. The following steps show how to create 
the invisible HyperButtons and the steps later in this lesson show how to link 
these invisible HyperButtons.

„To create invisible HyperButtons:

1. From the HyperButtons menu, select Sound and set the following 
parameters:

Button Name: Sound 1
File Name: tutorial\sound\zap.wav

2. Click on the Options button in the Sound Button dialog box.
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3. Select Invisible in the texture portion of the dialog box.

4. Click on OK to create the sound button. Invisible buttons show up as an 
outline in the authoring mode but are invisible in the preview and 
runtime modes.

5. From the HyperButtons menu select Goto and create an invisible Goto 
HyperButton with the following parameters:

Button Name: Goto 3/2
Destination Folder: FOLDER2
Destination Screen: 3
Texture Invisible

6. Position yourself on screen 3, folder 2.

7. From the HyperButtons menu, select Sound and create another 
invisible Sound Button with the following attributes:

Button Name: Sound 2
File Name: tutorial\sound\exit_snd.wav
Texture Invisible



8. From the HyperButtons menu, select Goto and create another invisible 
Goto Button with the following attributes:

Button Name: Loop
Destination Folder: FOLDER1
Destination Screen: 3
Texture Invisible

9. Notice that the buttons are overlapping. Because they are invisible and 
will be linked to other buttons, there location does not matter. If you 
like you can use the Move tool to re-position them, but this is not 
necessary.

Adding the Animation Window and Animation HyperButton

Multimedia Studio allows you to play .FLI and .FLC animation files. Playing 
animation files works in basically the same way as playing video files. You 
create an animation window which determines where the animation is going to 
be played, and then you create an Animation HyperButton which defines which 
animation to play in the window.

„To create an Animation Window:

1. From the Objects menu, select Animation Window.

2. In the Name box enter ‘Anim Win’. 

3. Click on OK to create the animation window. The Animation Window 
only appears when you are creating the application. It does not 
appear when you run the application. It only serves as a locator for 
where the animation file plays.
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„To create an Animation HyperButton:

1. From the HyperButtons menu, select Animation.

2. Assign the following values to the animation button:

Button Name: Play Anim
File Name: tutorial\animate\ami_ball.fli
# of Loops: 5
Speed: 5
Ani Window: Anim Win (or whatever name you gave 

the animation window)
Texture: Invisible

3. Click on OK to create the animation button and then move it as you 
wish.

4. You can test the Animation Button by selecting the ‘Try It’ tool and 
clicking on the Animation HyperButton.



Linking the Buttons Together

Now that you have created your invisible HyperButtons, you need to link the 
buttons together so that they execute automatically. In the Options section of the 
HyperButton dialog boxes there are fields called ‘Link Button’ and ‘Link Delay’.
These fields are used to define the button to be executed next in the sequence 
after the button is selected, and how long the delay should be before it is 
executed.

„To link the HyperButtons:

1. From the Edit menu, select Attributes, or select the Attributes tool  
from the toolbox.

2. Click on the ‘Sound 2’ button to bring up the Sound Button dialog box

3. Click on the Options button to open the options section of the dialog 
box.

4. Click on the down arrow next to the Link Button field to bring up a list 
of available buttons to link to.

5. Select the ‘Play Anim’ button. Leave the Link Delay at 0.0 seconds so 
that the animation starts playing as soon as the sound starts.

6. Click on OK to effect these changes.

7. Using the same technique, make the link button assignments as shown in 
the following table:

This Button: On Screen: Folder: Links to this Button: With Link Delay:
Play Anim 3 2 Loop 0.0
Loop 3 2 Sound 1 0.0
Sound 1 3 1 Goto 3/2 2.0
Goto 3/2 3 1 Sound 2 0.0
Self Running 1 1 Sound 1 0.0
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The application should now be complete. You can use the preview mode to test 
the application and make sure all of the buttons and links are working correctly. 
Once you are done with that step you can ‘Master’ the application to create a 
standalone runtime version. You should also save your work at this point.

Mastering the Application

After an application is complete, you can master the application. Mastering an 
application takes all of the files associated with an application and put them in 
one directory. This gives you the ability to copy all of the files associated with 
the application to a the media you are going to be distributing your application 
on (i.e. CD ROM, tapes, floppy disks, etc.).

„To master your application:

1. From the File menu, select Master. Click on the OK button on the 
dialog box that appears.

2. Select a directory to master the application into. The directory must be 
empty or not yet exist. For this example you can use the default 
directory. 

3. From the dialog that appears, you can select the files you want to use for 
your application. This is only necessary if you are using multiple files in 
your application. For this example you are only using a single file, 
therefore you can simply click on the Master button to complete the 
process.

The entire application along with all content and support files are copied into the 
new directory structure. You may then create a program manager item which 
runs the application by setting the command line to ‘viwin.exe myfile’ and the 
working directory to the appropriate directory.

 

Congratulations! You have completed the tutorial!!



Additional Information

For additional information on using Multimedia Studio, you can consult the rest 
of this User’s Guide or the Help file. You can also look at the amidemo.stu file 
in the /Tutorial directory that was installed during installation for some ideas and
examples on how the different tools in Multimedia Studio are used.



Section2
Screen Creation
After Multimedia Studio is installed you can begin creating an interactive application. When 
creating an application you must design the screens in your application. A screen consists of 
objects created using the drawing tools in Multimedia Studio, images imported from other 
applications, different types of HyperButtons (i.e. animation, video) and other features that make 
your application look the way you want. The features needed to create and manage screens are 
documented in the following sections.

The following sections show you how to:

Create and manage files.................................54

Edit objects on your screen............................68

Create and manage screens and folders.........91

Create Objects................................................104

Create and Import Images..............................124

Create HyperButtons......................................134



File Menu

Files are used to store and organize the screens of your application, which allows
screens to be easily retrieved and managed. The File option in the menu bar 
contains important features which help you manage your files. The commands in
the File menu as well as other information about creating, opening, saving and 
deleting files are discussed in the following sections.
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File Layout

Depending upon your application, the layout of a file can be very simple or it can
be somewhat sophisticated.

Simple Case For many applications, the database capabilities of Multimedia Studio are not 
needed. In these cases, the layout of a file is very simple. Such a file would 
contain one folder (column) and many screens. When a screen is added, it is 
automatically added at the bottom of the folder (remember, it does not matter in 
what order you add screens, order is given later when you link the screens).



Complex Case For more sophisticated applications which take advantage of 
database functions, screens must be created in more than one folder. A good 
example would be the real-estate example, where each house and the information
about the house is in its own folder.

To help you stick with this structure, Multimedia Studio automatically copies 
any image field and data field on a given screen onto every screen within that 
row. In this example, when you add a new folder, a template for screen 5 would 
automatically exist, so you merely need to add data into the data fields and 
capture images into the image fields. 

In many cases, you might want several screens of information for each record. In
this case, for each astronaut, you might want screens containing more images 
and information on the astronauts. These screens might be screens 6 and 7, and 
each of these screens would be in the same folder as the astronaut they are 
associated with (in Multimedia Studio terms, these are "associated" screens).

The reason that Multimedia Studio requires such a structure is due to the way in 
which the database search is carried out. Lets say that the data field that you 
want to search upon is a data field which contains the name of the university that
an astronaut attended, and that you want to search for any astronauts that went to
the University of California. The way in which Multimedia Studio works is that 
it looks in the University data field on screen 5 of every folder, and look for any 
matches. If your file has 100 folders (i.e. 100 astronauts), Multimedia Studio 
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would search the "University" data field on screen 5 of each folder. For each 
match that is found, you want to see not only screen 5 for that house, but also the
associated screens (i.e. screens 6 and 7). Therefore, after performing a search, 
Multimedia Studio allows you to view the entire folder for each astronaut (i.e. 
Multimedia Studio sets a filter to view only the folders that meet your search 
criteria). For this reason, screens associated with the same astronaut need to be in
the same folder. Screens of different astronauts need to be in different folders, 
but at the same screen number.

Now that you understand the way in which files are laid out in Multimedia 
Studio, you are ready to begin creating a new file.



Creating a New File

The first step to creating an application with Multimedia Studio is the creation of
a file that contains the screens of your application. You must select the New 
command to create a new file. When you first start Multimedia Studio, you see a 
blank white screen. Selecting New from the File menu starts a new file with one 
screen. As your application becomes more complex, you can begin adding new 
screens and folders to your application. See the section on adding new screens 
and folders for more information.

�To create a new file:

1. From the File menu, select New. A blank screen appears with the 
toolbox in the upper right corner. 

2. A blank teal colored screen appears, labeled FOLDER 1 of 1, SCREEN 
1 of 1 with the toolbox in the upper right corner. This indicates that 
you are on the first screen of the first folder of your new file. 

3. You can now begin designing the first screen of your application. This 
screen can consist of any thing you like, including HyperButtons, 
Graphics, Images, etc. You can then begin adding new screens and 
folders as you need them.

Hint: Many interactive multimedia applications have a main menu which 
allows the user to click on different buttons that take them to different 
sections of the application. If your application is going to have a main menu,
you may want to create this menu on the first screen.
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Opening a File

After a file is created, you can open it at any time. You can then edit, preview, or
master this file.

�To open a previously created file: 

1. From the File menu, select Open.

2. This dialog box contains a list of previously saved files. From the list 
that appears, select the file you want to open and then choose OK to 
open the file or select Cancel if you want to cancel the operation (double
clicking on the filename also opens the file).

Note: To open an application created in the DOS version of Multimedia 
Studio, run the “DOS2WIN” utility.

Closing a File

The Close command closes the current file. This does not completely exit 
Multimedia Studio. You can continue to open another file.

�To close the file that you are currently in:

1. From the File menu, select Close.



2. The file that is currently open closes and you see the blank screen that 
you see when you first enter Multimedia Studio. 

Note: The Close command does not exit you from Multimedia Studio. If you
want to exit, you must select the Exit command in the File menu.

Saving a File

It is important that you frequently save any changes that you make to your 
application. The Save command saves your file and any changes made to it with 
its current name. If you have not yet saved your file, you are prompted with the 
Save As dialog box to enter a name for the file.

�To save your changes:

1. From the File menu, select Save.

2. The file and its changes are saved using the file’s current name.

Saving a File With a New Name

The Save As command allows you to save your file with another name, other 
than its current name.

�To save a file with another name:

1. From the File menu, select Save As. The Save As dialog box appears.
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2. Select the drive and directory where you want the file saved to. Type in a
new name for the file and click OK.

Deleting a File 

It may at times become necessary to delete some of your files, in order to save 
disk space, simplify management of your files, etc. 

�To delete a file:

1. Open the file you want to delete with the Open command.

2. From the File menu, select Delete. A dialog box appears with a 
confirmation message.

3. Choose Yes to delete the file or Select No if you do not want to delete 
the file.

** WARNING** Deleting a file permanently deletes all of the folders and 
screens within that file including Images, HyperButtons and Text data.



Print

The Print command allows you to print either a Report, Screen, or an Image on 
the screen. When you select the Print option from the File menu, you can select 
any of these options. The Report option lets you print a report based on the data 
fields on the current screen. The Screen option prints the entire screen including 
all objects and HyperButtons on the screen. The Image option prints a specified 
image on the current screen.

„To print a report:

1. From the File menu, select Print.

2. Select the Report option and click OK.

3. Select a report and click OK. If a report doesn’t exist, click on the Add 
button and create your own report.

4. If you want any text to appear in the Header or Footer, enter the text you 
want.

5. If you want specific margins, enter the margin amount you want to use. 
Click OK when the appropriate options are entered.
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„To print a screen:

1. From the File menu, select Print.

2. Select the Screen option and click OK.

3. Select the size of the output you want and click OK. If you want to 
change your printer or printer settings, click on the Setup button.

„To print an image:

1. From the File menu, select Print.

2. Select the Image option and click OK.

Note: If you have more than one image on the screen, you must click on 
the image you want to print. 

3. Select the size of the output you want and click OK. If you want to 
change your printer or printer settings, click on the Setup button.



Setup 

The Setup option under the File menu allows you to select the start-up screen 
when you are mastering the current application. The setup screen can be any 
screen from any Multimedia Studio file. The Opening screen serves as the first, 
or main, application screen from which all other screens of your application are 
linked. 

�To select the setup screen for an application:

1. Open the desired application.

2. From the File menu, select Setup. The Application Setup dialog box 
appears.

3. Enter the Starting file name, Starting folder name and Starting screen #. 
This is the screen that appears first, each time the current application is 
opened.

4. To open the application with the new start-up screen, re-open the 
application by pressing enter, select open from the application menu and 
re-select the application you just modified.
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Preview

To test the flow and function of your application, select Preview from the File 
menu. Notice that the Multimedia Studio menu and status bars disappear. You 
can navigate through your selected screens of your application as the users of 
your application can, namely, by selecting defined HyperButtons. If you discover
a problem or dead end in your application, simply press the ESC key to return to 
the authoring mode and make the necessary corrections. After you finish 
checking the application, you can master your application to generate your 
application runtime.



Master

The Master option in the File menu is used to Master your application so that it 
can be distributed to your audience. Mastering an application is similar to 
mastering a record album or CD disk. After the application is mastered, changes 
can only be made by changing the original application and re-mastering it. The 
Master command puts all of the files (including executables) into a single 
directory with the appropriate sub-directories. You can now easily take this 
single directory and copy it to a CD ROM, Tape backup, Network drive, or any 
other media you like.

�When you are ready to distribute an application:

1. Open the desired Application.
 

2. From the File menu, select Master.

3. A dialog box appears requesting the directory name you want to master 
your application into. 

4. The selected directory must be empty. You can now select the new 
directory and proceed with the mastering of your application, select OK 
to `master the application or select Cancel to end the operation.

5. Multimedia Studio copies all information and associated files for all the 
screens of your application including sound, video, and animation files 
to your selected directory. 

6. To run your mastered application from Windows, go to the Program 
Manager and select Run from the File menu. In the Run box, type 
VIWIN followed by the name of your application and click OK. Your 
application starts.

7. You may now distribute your application via floppy disks, hard drive, 
optical drive, etc., by copying the entire contents of the application 
directory onto your distribution media (i.e. Floppy disk, CD ROM).
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8. A file called HWSETUP.EXE is included in the mastered directory 
which allows users to setup their Applications to run with their particular
hardware configuration.

Exiting Multimedia Studio

When you want to exit Multimedia Studio, you can use the exit command.

�To exit Multimedia Studio:

1. From the File menu, select Exit.

2. If you have an unsaved file open, you are prompted to save them. Click 
Yes to save the file and exit, click No to exit without saving the file and 
click Cancel to return back to Multimedia Studio without exiting or 
saving.



Edit Menu

The Edit menu provides you with important editing tools that you need when 
designing a screen. To activate a tool in the Edit menu, click on Edit in the menu
bar and select the tool you want from the menu that appears. A check mark
appears next to the selected option, indicating that the chosen tool is now active. 
The following sections give you detailed information on using the commands in 
the Edit menu as well as some other editing information.
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Data

The first option that appears in the Edit menu is the Data option. This option 
allows you to enter or change the data contained within data fields. Data Fields 
are created with the Data Fields options in the Objects menu. Data Fields are 
very useful when you are displaying information in your application. If there are 
no Data Fields on the current screen, the Edit Data option will not do anything. 
If you want the user of your runtime application to edit or enter data, you need to
use the Data button command in the HyperButton/Extension menu (see the 
Extensions section). 

�To edit data within Data Fields:

1. From the Edit menu, select Data so there is a check mark next to it.

2. Select the Try-It tool from the toolbox or select Try-It from the Edit 
menu.

3. Click on the Data Field that you want to enter data into.

4. A blinking cursor appears in the Data Field. Type the data you want in 
the Data box. Select as many Data Fields as you like, and enter data into 
them.

5. To turn the Edit Data function off, Select Data from the Edit menu 
again so there is no check mark. 



Toolbox

After you open a file, you notice that a "toolbox" of icons appears in the upper 
right corner of the screen. These icons provide powerful editing tools and 
increased flexibility in screen design. The toolbox is moveable, which allows 
you to move it if it gets in the way during screen design. You can move the 
toolbox by clicking and dragging it where you want. You can also make the 
toolbox drop down to a small icon by "double-clicking" on the top bar of the 
toolbox. To make the toolbox reappear, "double-click" on the icon. The toolbox 
option in the Edit menu, allows you to select if you want to display the toolbox. 
A check mark next to the toolbox command displays the toolbox, remove the 
check mark by selecting the toolbox option to remove the toolbox from the 
screen. The toolbox is very useful when you are working in the Menu Off mode. 
This gives you the ability select different tools while viewing your application as
a runtime user would.

Move

Copy
Attributes

Resize

Delete

Try It
Grid

Menu On\Off

HyperButtons
Objects

Color

Fade Effect

Repaint

The icons in the toolbox in the above diagram are editing tools. These tools 
correspond to the options that are available under the Edit Menu.

Multimedia Studio is an object oriented software program that treats fields, text, 
boxes, circles, lines, etc., as objects. The editing tools listed below operate the 
same on all types of screen objects. When you select a given editing tool, the 
tool icon becomes depressed, indicating it is selected. The command in the Edit 
menu that corresponds to the selected icon gets a check put next to it, also 
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indicating it is the currently active tool. The selected tool remains active until 
another tool icon is selected. 

The following sections discuss these editing tools in detail. As you read about 
these editing tools, take this opportunity to open the Tutorial files that come with
Multimedia Studio, and practice editing some of the objects on the screens.

Important: Keep in mind that when you use the editing tools to change a global 
object, the changes that you make are also made to the selected object on the 
current screen in all of the folders for the current file. 

Move The Move tool is the default active tool in the toolbox, therefore it is 
automatically active whenever you enter a file. The move tool is the 
most common of all tools, and is used to move an object on the screen 
from one location to another. The move tool can be used to move any 
object, window, data field, text, or HyperButton to the desired location. 
You must select the move tool before you move any of the objects on 
the screen.

�To move an object:

1. Select the Move icon from the toolbox, or choose Move from the Edit 
menu.

2. Click on the object you want to move with the left mouse button, and 
while holding down the left mouse button, drag the object to the new 
location. 

3. Release the mouse button to place the object in its new location.

Copy The Copy tool allows you to copy any object to any other screen within
your file. This makes the creation of multiple objects extremely easy. 
This command can be used to copy a single object or a group of 
objects. When copying a single object, you can only copy to the 
existing screen. When copying multiple objects, you can copy these 
objects to another screen or the existing screen. 



Note: If you are creating a lot of objects with similar characteristics, 
you can copy the object and then change the attributes of the copied 
objects. For example, you may want five Goto buttons that are the same
size, but go to different screens. You can create one Goto button and 
then copy it four times. You can then change the attributes of the new 
Goto buttons so each one goes to a different screen.

�To copy a single object:

1. Select the Copy icon or choose Copy from the Edit menu.

2. Click on the object you want to copy. A copy of the selected object 
appears that has the same attributes as the object you selected.

3. You can now move, resize, change, or add color to the newly copied 
object by selecting the appropriate tool icon.

„To copy multiple objects:

1. Select the Copy icon or choose Copy from the Edit menu.

2. Click and drag your cursor so that the box you draw encompasses the 
objects you want to copy.

3. A dialog box appears telling you how many objects have been selected. 
Click OK to continue.

4. Another screen appears that contains small icons that represent the 
screens in your application. Double click on the icon that represents 
the screen you want to copy the selected objects to. If you want to 
copy an object to multiple screens, you can select multiple icons and
then click on the OK button. This is very useful when you want the 
same object to appear on more than one screen. For example, you 
may want a button that returns to the main menu to appear on many 
different screens.
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5. You can now go to the screen that you copied the objects to and move or
edit the copied objects.

Note: When you copy objects to other screens, your screen icons are not 
updated until you either move to those screens within the editing mode, or 
until you select "Update Icons" from the Screen Menu.

Attribute The Attribute tool allows you to redefine or review the attributes of a 
specific screen object. An objects attribute varies depending on the 
object you select. For example, the attributes of text is different from 
that of a Sound HyperButton. The dialog box that appears when you 
edit an object’s attributes is the same as when you create the object, 
except the options in the dialog box are already entered. For specific 
information on an individual objects attributes, see the section on that 
object. 

The Attribute command can be useful when you want to copy multiple 
objects and change their attributes slightly without recreating the 
object. For example, if you want to create multiple lines of text all with
the same font and color, you can create the first line and then copy the 
text. You can then select the attribute tool and select the copied text. 
Next, you can change the text you want to appear on the screen and 
click OK.

�To redefine or review the attributes of an image or data 
field, such as its name or data type:

1. Select the Attribute icon from the toolbox, or choose Attribute from 
the Edit menu.

2. Position the cursor over the desired object and click the left mouse 
button. 

3. A dialog box containing the selected object’s attributes appears. You can
change the attributes by typing the desired information into the dialog 
box and clicking OK. A different dialog box appears depending on the 



object you select. For example, if you select a data field, the data field 
dialog box appears. If you select an image field, the image field dialog 
box appears.

Note: Because fields are automatically defined as global, redefining a field 
changes that field for every folder of the current file (i.e. on every screen in 
that row).

�To redefine the attributes of objects such as windows, text, circles
and boxes:

1. Select the Attribute Icon from the toolbox.

2. Select the object you want to redefine by placing the mouse cursor over 
the object and clicking the left mouse button.

3. A dialog box containing the object's current attributes appears. A 
different dialog box appears depending on the object you select. For 
example, if you select text, the text dialog box appears. If you select a 
circle, the circle dialog box appears.

4. To save the object with its new attributes, make the appropriate changes 
and select OK.

HELPFUL HINT
When you are creating a screen with many objects that are similar (i.e. several Goto 
HyperButtons), it is often easy to create the first object, then copy it multiple times and make 
changes to the copies. Experiment with this method a little bit and you will find that in many 
cases it will save you time. 
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Resize The Resize tool allows you to shrink or enlarge the size of any object, 
such as increasing a data field from 10 characters to 25 or shrinking a 
full-screen image field to a quarter-screen image field. The only object 
that cannot be resized with this tool is text (see the section on Text). To 
resize text, you must change the font size of the text. The resize 
command is very useful when you want to make buttons of different 
sizes. You must select the Resize tool before you resize any object.

Note: If you resize a HyperButton that has a button image, you are 
asked if you want the image to be resized. If you select Yes, the actual 
bitmap that is applied to the button is resized to fit the button, but be 
careful, all buttons that use this bitmap are updated with the newly 
sized bitmap. If you select No, the bitmap is not resized and if the 
bitmap is smaller than the button the whole button may not be covered. 
For example, you may be applying images of different animals on a 
button and you want the image to cover the whole button.

�To resize a data field:

1. Select the Resize icon from the toolbox, or choose Resize from Edit 
menu.

2. Place the mouse cursor over the desired data field and click the left 
mouse button. 

3. While holding the left mouse button down, slide the mouse cursor from 
the left to the right to expand or shrink the field accordingly. The field's 
length is displayed inside the data field. 

4. When the desired field length is reached, release the left mouse button to
save the new field length.



Different sized data fields

�To resize image fields and other objects: 

1. Select the Resize Icon from the toolbox.

2. Position and click the left mouse button inside (or on) the outer edge of 
the object you want to resize. 

3. While holding the left mouse button down, drag the mouse button up 
and down or left and right until the desired size is reached.

4. When the desired size is reached, release the mouse button to save the 
new object size. This process can be repeated as many times as you like 
until the object is the desired size.

Note: Resizing image fields requires the software to resize all images in the 
current field for every folder in your file. This process may take several 
minutes, depending on the number and size of the images you have in your 
files. 

Delete After you create an object, you can remove it from the screen with the 
Delete command. You can delete any object from the screen, but be 
careful, you cannot undelete an object.

�To delete an object:

1. Select the Delete icon from the toolbox, or choose Delete from 
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the Edit menu.

2. Click on the object you want to delete.

3. A warning box appears requesting confirmation of your desire to delete 
the object. To continue with deleting, select Proceed or to cancel an 
operation, select Cancel.

Color The color tool allows you to choose the color of any screen object. 
Multimedia Studio provides many powerful features that make it 
possible to create professional quality colors. It is important to choose 
the right color for your presentation, that is why Multimedia Studio 
gives you the ability to create almost any color you desire.

�To change the color of a specific screen object:

1. Select the Color Tool from the toolbox, or choose Color from the Edit 
menu.

2. Click on the object whose color you want to change. The Color dialog 
box appears.



3. Select the desired color from the color palette box and click OK. The 
object that you selected appears in the color that you selected.

4. If you do not see a color you like on the initial color palette, you can 
create your own color. 

�To create your own color:

1. From the Color dialog box, click on the Define Custom Colors button. 
The Color dialog box expands with a place for you to create your custom
color.
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2. Multimedia Studio gives you two sets of options for creating a custom 
color: Red, Green, Blue or Hue, Saturation, Lumination. You should use
the appropriate options to create the color you desire.

Red, Green, Blue Options

The Red, Green, Blue options allow you to select the amount of red, green 
and blue to create the color you want. Each color can range between 0 and 
255. If you mix 0 of all the colors you get black. If you mix 255 of all the 
colors you get white. 

The easiest way to select a color is to drag the marker in the two color boxes 
and visually select the color you want. The marker in the large box, controls 
the amount of red, green and blue. The marker in the narrow box to the right,
controls the amount of black, which controls how light or dark your color is.

If you know the specific color you want, type in the appropriate amount to 
create your color. When you have created the appropriate color, click on the 
Add to Custom Colors button and the color you created appears in a box in 
the Custom Colors palette below the set colors to the left. This new color can
be selected any time you want to change the color of an object.

Hue, Saturation, Lumination Options

A color can be created by changing the hue, saturation and lumination of the 
color. Saturation refers to the purity or intensity of the color. Hue refers to 



the quality that makes colors different from another. Lumination refers to 
how much black is in a color.
 
These options are input automatically if you drag the markers to a specific 
color or you can input the specific number to create the color. All options 
can have a number between 0 and 240. For brightness, 0 is no brightness or 
black and 240 is full brightness or white. For saturation, 0 is very low purity 
and 240 represents maximum purity of the color. For Hue, 0 corresponds to 
red, 40 to yellow, 80 to green, 120 to cyan and 160 to blue.
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Display 
Effect 

The Display Effect tool is an exciting tool that can add a lot of flare to 
your application. The display effect tool allows you to fade any object 
onto a screen. This determines how and when an object is displayed on 
the screen. If you do not choose a display effect for an object, the object
will be on the screen when you change screens. This should not be 
confused with transitional fade effects (used with Go to HyperButtons),
where one entire screen fades into another. 

The display effect tool can also be used to animate objects on the 
screen. There is a Fade Effect option called Animate which allows you 
to do this. This is especially useful when you want to have bullets of 
text appear on the screen. It can also be useful to animate other objects 
on the screen (i.e. buttons, graphics, etc.).

With the display effect tool, the only thing that fades in or out is the 
individual object that is selected. This tool can be used not only for 
objects, but also for text. This allows you to fade in bullet points for 
applications. A fade effect can be used to make objects appear and 
disappear on the screen without any type of fade. For example, to make
text appear on the screen and then disappear after a certain length of 
time, just enter the amount of time you want the object to appear and 
disappear in and select none for the fade effect.

When using a display effect, timing is very important, especially when 
using text. When displaying and removing bullet points onto the 
screen, make sure that the text remains on the screen long enough for 
people that read slow. This varies depending on the target audience of 
your application.

�To fade an object onto the screen:

1. Select the Display Effect icon, or choose Display Effect from the Edit 
menu.

2. Click on the object you want to fade in or out. The Display Effect dialog
box appears.



3. You are prompted to enter a Appear in (Object Appear) and a Disappear 
in (Object Disappear) time. The time that you enter is in seconds, and 
represents how many seconds after you are on a screen should the object 
either appear or disappear. In other words, when you first jump to a 
given screen, that point is time=0, much like a timeline and if you typed 
5 in the Appear in box, the image will appear five seconds after you 
enter the screen. You can enter the time at which the various objects fade
in and out. You can have an object fade in, fade out, both, or none. If 
you type 5 in the Disappear in box, the object will be removed in five 
seconds.

4. Next, you are prompted to select an Effect. Click on the down arrow and
select the fade you want from the list that appears. There are many 
different effects you can chose from. Try the different effects until 
you get one that you like. You can select a different fade effect for 
an object to fade in and fade out. 

5. Next you can select how fast you want the fade to take place. Enter a 
number in the Speed box. The lower the speed number the faster the 
fade effect takes place. For example, if you select a Left to Right 
fade effect and a fade speed of 1, the object appears very quickly. If 
you select the Left to Right fade effect and a fade speed of 8, the 
object appears very slowly left to right, similar to a curtain opening.
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Animating Objects

Using the Animate option in the Effect drop down box, you can animate objects 
on the screen. The Animate option moves an object on to, or off the screen from 
the direction you select. This command animates objects from a 45 degree angle 
from the direction you select.

„To animate an object:

1. Select the Display Effect icon, or choose Display Effect from the Edit 
menu.

2. Click on the object you want to animate. The Display Effect dialog box 
appears.

3. You are prompted to enter a Appear in (Object Appear) and a Disappear 
in (Object Disappear) time. The time that you enter is in seconds, 
and represents how many seconds after you are on a screen should 
the object begin to animate. In other words, when you first jump to a
given screen, that point is time=0, much like a timeline and if you 
typed 5 in the Appear in box, the image will appear five seconds 



after you enter the screen. You can enter the time at which the 
various objects fade in and out. You can have an object fade in, fade 
out, both, or none. If you type 5 in the Disappear in box, the object 
will be removed in five seconds.

4. Next, you need to select a fade effect and fade speed. Click on the down 
arrow to the right of the Effect box and select the Animate option 
from the list that appears. You can now enter a number for the speed 
of the animation. The lower the speed number the faster the 
animation takes place. For example, if you select a fade speed of 1, 
the object appears very quickly. If you select a fade speed of 8, the 
object appears very slowly.

5. You can now select the direction you want the object to appear or 
disappear from. After you select the Animate option from the Effect 
box, the Animation Path option is no longer gray. Click on the 
radio button whose arrow represents the direction you want the 
object to appear or disappear in. The object will move across the 
screen in a 45 degree angle based on the direction you select (either 
appearing or disappearing).

6. Click OK when you are complete. Select Preview from the Application
menu and watch your object move. Sometimes it takes a few tries to get 
an object to animate exactly the speed and way you want. If you want to 
make any changes, select the display effects tool and select the object 
again. You can then make the necessary changes.
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Repaint Occasionally, when moving, resizing, and deleting screen objects, you 
may temporarily overwrite another screen objects or the menu and 
status bars. The Repaint tool allows you to "re-paint" the screen so that
all of the screen objects reappear. 

�To repaint the screen:

1. Select the Repaint Tool from the toolbox, or choose Repaint from the 
Edit menu.

2. The screen should be re-painted and all objects should reappear.

Grids
The Grids tool overlays grids on the screen to make lining up screen 
objects easier. This tool is very useful when you are designing complex 
screens and you want to be very accurate. You can display the grid while
you are creating your screen layout, so that objects are drawn exactly 
where you want them with respect to other objects on your screen. You 
can control the density of these grids and control whether or not objects 
snap to the grid lines. Using the grid can also be useful when you want 
to resize objects to the same size.

When you move objects with the snap to grid active, the object is forced 
to the nearest grid line. You determine which grid line the object is 
snapped to by where you move the object.

�To put a grid on the screen:

1. Select the Grids tool from either the toolbox or the Edit menu. The Grid
dialog box appears.



2. Enter the width and height in pixels that separates the individual 
gridlines (the lower the number the denser the grid lines).

3. If you want to activate the "snap to" feature, click on the Snap to 
Column or Snap to Row toggle boxes until "X"s appear. When an 
object is moved with these options selected, it automatically snaps to the
closest grid line.

4. To turn the Grid off, reselect the Grid option. 
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Grid set 40x40

Grid set 10x10

Try It
The Try It tool allows you to test a HyperButton or other parts of your 
application and make sure that they are working in the way that you 
would like it to. It is recommended that you test your HyperButtons 
after you create them. You can also test your application by using the 
Preview command in the Application menu. The Try It tool, unlike the 
Preview command, does not remove the menus and toolbox.

�To test a HyperButton:

1. Select Try It from the Edit menu, or select the Try It tool from the 
toolbox.



2. Click on the HyperButton that you want to test.

3. The HyperButton you select will do what it is designed to do. If the 
button does not perform as you expected, select the Attributes tool and 
click and the button. This will display the attributes of the button. You 
can now check and see what went wrong and make the appropriate 
changes.

Toolbox The toolbox option in the Edit menu allows you to turn the toolbox off during 
the creation of your screens. To remove the toolbox, select toolbox from the 
Edit menu.

The toolbox option works as a toggle switch. When the toolbox is active, the 
toolbox option has a check mark next to it. If you turn the toolbox off, the check 
mark disappears. To bring the toolbox back, select toolbox from the Edit menu 
again. The toolbox re-appears, and a check mark returns next to the toolbox 
option.
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Shortcut Icons

The toolbox also contains two icons which open up new icon boxes. These icons 
provide shortcuts to some of the most commonly used functions in Multimedia 
Studio, and also allow you to turn off the menus and still access these 
capabilities (you might want to turn off the menus in order to use the entire 
screen during your screen design, this will be discussed later in this section).

HyperButton If you select the HyperButtons icon, a new toolbox appears with the 
various HyperButton icons. These icons serve as a shortcut to the 
objects available within the HyperButtons menu. After you click on a 
HyperButton Icon, the procedure to add a HyperButton is the same as 
if you defined the button starting from the HyperButton menu (see the
HyperButtons section for detailed information).



Objects If you select the Objects icon, the Objects icons appear. These icons 
serve as a shortcut to adding the objects available under the Objects 
menu. When you select any of the Objects icons, a dialog box appears, 
and the procedure to define the object is the same as described in the 
Objects section.

Menu On/Off

All of the icon boxes mentioned above also have a Menu On/Off 
Icon. If you click on this icon, the menu and status bars are 
removed. This is a very important feature because it allows you to 
view the entire work area. Remember, runtime versions of your 
application have no menus, so you should create your screens so 
they use up the entire work area. The Tool boxes allow you to turn 
the menus off, and still have access to the editing and objects 
functions. As a result, you can now create and place objects on the 
entire screen.
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Screen Menu

The Screen menu contains options pertaining to the individual screens and 
folders of your application. When you first enter Multimedia Studio, you initially
have only one screen within one folder. The Screen menu provides you with the 
means to increase the size of your application, by adding additional screens and 
folders. Additionally, the Screen menu provides powerful screen management 
features. The following sections provide detailed information about the 
commands in the Screen menu.



Navigating Files

Quick Jump Multimedia Studio provides the user with several methods of
by Icon navigating within a file. The way to jump from screen to screen is using the 

"Screen Overview" (also called "view by icon") capabilities in Multimedia 
Studio. 

„To quickly jump to any given screen within Multimedia Studio:

1. From the Screen menu, select Overview.

2. A grid appears which shows small TGA images of the screens within 
your application. To scroll through your screens, you can click on the 
navigation arrows, or click-and-drag the scroll box.

3. "Double-click" on the icon of the screen that you want to jump to or 
highlight the screen and select the OK button. You are taken to the 
chosen screen.
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Screen Up The screen status is  located  at  the upper
and Down       right hand corner of the screen. To flip to the next screen of 

a folder within a file, click on the down arrow at the lower 
right corner of the screen. To flip to a previous screen of a 
folder, click on the up arrow at the upper right corner of the 
screen.

Next and For simplifying file navigation,  Media Master
Previous Professional  has  a folder status line at the bottom of  the screen.
Folder To advance to the next folder of an open file, click on the right arrow at the 

lower left corner of the screen. To go to the previous folder, click on the left 
arrow at the lower left corner of the screen.

Quick Jump If you want to jump to a screen in a different file, or the current file, you can use 
the Quick Jump feature. This method is the quickest and easiest way to move 
between screens.

�To quickly jump to a particular screen:  

1. Double click on the bottom status line. 

D ouble C lick H ere

2. The Quick Jump dialog box appears.



3. You are first prompted to enter a File name. This allows you to jump to 
a particular screen of a file other than the file currently open by 
specifying a file name. Click on the down arrow to the right of the File 
box and select the file you want to go to. If you do not want to jump to 
another file, leave the default folder.

4. After entering the file name, enter the folder name and the screen 
number you want to jump to in that folder.

5. Select OK and you are taken to the selected screen.

The default settings are to the current screen location, as defined by the current 
file name, folder name, and screen number. As a result, many times you only 
need to enter one of the criteria. For example, if you are in a file called Demo, on
Folder 1, Screen 2, and you want to jump to Folder1, Screen 8 of the same file, 
all that you would need to enter into the Quick Jump dialog box is Screen 8.
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HELPFUL HINT
For different file navigation needs, different approaches are appropriate. If you are only jumping 
to the next or previous screen or folder, the navigation arrows are quickest. If you are jumping to 
a screen in the same file, and also either on the same folder or screen, the Quick Jump (using the 
default settings) is the quickest. If you want to jump to a screen that in within the first 5 folders 
and screens (i.e. within the first 5 x 5 grid of view by icon screens), or if you are sure of the 
location of the screen, you should use the Screen Overview jump.

Adding a Screen

When you add a screen in Multimedia Studio, a new screen is automatically 
added to the end of each folder of your file. For example, if you have five 
screens and you add another screen, the new screen becomes screen number six. 
You can manipulate between screens in your application by creating 
HyperButtons that when clicked on go to a specified screen. For example, if you 
have an application with a main menu that takes the user to different topics, you 
can have multiple Goto HyperButtons that take the user to different screens in 
your application. For example, one button can be labeled Elephant that when 
clicked on goes to a screen containing information about elephants, another 
button can be called Lions, that when clicked on takes the user to a screen with 
information about lions, etc.

Hint: If you are using a main menu it is useful to have Goto buttons on the 
individual screens that take you back to the main menu.

�To add a screen to your file:

1. From the Screen menu, select Add Screen.

2. A blank screen is added. After the screen is added, Multimedia Studio 
brings you to the newly added screen. You can now begin creating your 
screen layouts by adding and editing objects on the new screen. 



Deleting a Screen

Multimedia Studio allows you to delete the last screen in your file. If your 
application contains more than one folder, deleting a screen removes that screen 
from all folders within your file (i.e. it removes all screens in that row). All 
objects on the screens in that row must be deleted before a screen can be deleted.

�To delete a screen:

1. Go to the screen you want to delete.

2. From the Screen menu, select Delete Screen.

3. You are prompted that all of your objects on all folders for the current 
screen number will be deleted. Click OK to proceed with the screen 
deletion, or click Cancel to exit the dialog box without deleting the 
screen.
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Adding a Folder

The Add Folder option allows you to add new folders (i.e., an entire group of 
screens) to your file. Adding a folder, can be used to do more than simply add 
another group of screens to an application. When global objects are used 
correctly, adding a folder can, in essence, add a new set of template screens. For 
example, if global objects are used to create the screens of folder 1 in a real-
estate example, each time a new folder is added, a template will already exist as 
defined in folder 1.

�To add a Folder:

1. From the Screen menu, select Add Folder.

2. The Add Folder dialog box appears. Type in the name of your new 
folder and choose OK to create the new folder or select Cancel if you 
want to cancel the operation.

3. Your new folder appears, and the folder name appears at the corner of 
the lower right of the status bar. 

4. When the new folder appears, it automatically contains the same number
of screens that the existing folders have. In addition, any globally 
defined objects automatically appear on the screens in the new folder.

HELPFUL HINT
Properly naming folders can be an important part of organizing an application. If you plan to 
create an application with a lot of folders, it is helpful to enter names that represent the 
information contained within the folders.



Renaming a Folder

Naming your folders can be an important part of organizing the screens within 
your files. By default Multimedia Studio names folders in ascending numeric 
order (i.e. Folder 1, Folder 2, Folder 3, etc.) Multimedia Studio gives you the 
ability to change a folder's name. When renaming folders be careful, you may 
have Goto buttons that reference the folder’s original name before it was 
renamed. The Goto button still references the folder’s original name until you 
change it. For example, you may have a Goto button that jumps to Folder 2 
Screen 1, if you rename Folder 2 to Information, you must go to the Goto button 
and change Folder 2 to Information. 

�To rename a folder:

1. Double click the left mouse button on the current folder name at the 
bottom of the screen. 

Double Click Here

2. A dialog box appears with the current folder name. To change the name, 
type a new unique folder name and select OK. If the folder name you 
enter is not unique, Multimedia Studio prompts you to re-enter a new 
name. 
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Deleting a Folder

Deleting a Folder removes a folder from your file, and deletes all the objects on 
all of the screens in the folder. After a folder is deleted, you cannot undelete it.

�To delete a folder:

1. Go to any screen within the folder you want to delete.

2. From the Screen menu, select Delete Folder.

3. You are warned with the message, "All Objects on Every Screen in This 
Folder Will Be Deleted?"

4. Select Yes to delete the folder or No to cancel the operation.

** WARNING** Deleting a folder will permanently delete all of the screens 
within that folder, including Images, HyperButtons and text data.



Overview

One of the most powerful screen management features within Multimedia Studio 
is the Screen Overview feature (also called "View by Icon") which allows you to 
see small images of all the screens within your file. The Screen Overview feature
is particularly useful for viewing the overall layout of your file, locating specific 
screens, or "jumping" to screens within your file.

�To view your screens:

1. From the Screen menu, select the Overview option.

2. A dialog box appears containing all of the screens of your file organized 
by screen number and folder name.

3. You may navigate through the screens by selecting the scroll bars at the 
right of the screen, or through the folders by selecting the scroll bars at 
the bottom of the screen.

4. To "Jump" to a particular screen, double click the left mouse button over
the desired image, or single click until a red border appears, and select 
the OK button. Select Cancel to return to the screen you were on before 
entering the View by Icon screen.
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Update Icons

Multimedia Studio has built-in functions which updates the images used in the 
Screen Overview feature. However, at times you will find that all of the screens 
are not updated. If you want to manually update the icons, Multimedia Studio 
provides you with a way to do this using the Update Icons option in the Screen 
Menu.

�To update your screen icons:

1. From the Screen menu, select Update Icons.

2. A dialog box appears, asking you if you want to update the TGA icon 
images of your screens. You have several options regarding updating 
these icons.

� The first selection allows you to continue without updating any 
icons. If you select the Cancel button, you continue on without 
updating any icons.

� The second selection, the default setting, is to update only the 
screens that have been changed in some way, but have not been 
updated.

� The third option available is "Manually Selected Only". This option 
allows you to manually select which screens icons are updated. If 
you choose this option, the Screen Overview screen appears. Click 
on the icons that you want to update and select OK.

� The final selection is to update all of your screens. Updating all of 
your screens may require a lot of time, so you should avoid using 
this option unless you need to have all of the icons updated.

3. After your changes have been saved, your screens are updated with the 
new changes. 



Background

Multimedia Studio gives you the ability to assign images to be the background of
individual screens. Each screen can be given its own unique screen background, 
to add as much variety to the application as desired. This exciting feature helps 
you easily create innovative and spectacular screen designs.

Multimedia Studio comes with backgrounds that you can use. If you find 
yourself wanting more background screens, more are available through 
Advanced Media, Inc., or you can create and import your own.

�To assign an image as a screen background:

1. Move to the screen that you want to assign an image background to.

2. From the Screen menu, select Background.

3. Small images of the available backgrounds appear. Click on the color or 
image you want to use for a background and click OK.

4. The image or color appears as a background on that screen.
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Creating Your Own Backgrounds

If you do not like any of the backgrounds that come with Multimedia Studio, you
can easily import an image of your own and use it as a background. Multimedia 
Studio supports most of the popular image formats. Backgrounds can be screen 
shots, textures, corporate logo, or almost any image you like.

�To make your own images into backgrounds:

1. From the Screen menu, select Background. The Select Background 
dialog box appears.

2. Select Add. A dialog box appears with a list of the available .TGA files.

3. Select the .TGA image that you want to add and click OK.

�To delete background images:

1. From the Screen menu, select Background. The Select Background 
dialog box appears.

2. Select the background you want to delete and click on the Delete button.



Objects Menu

After you open a file, you are ready to begin adding objects to your screens. The 
Objects menu provides you with some of the necessary options to design the 
layout of your screen, including adding data and image fields, live video and 
animation windows, text, boxes and circles (keep in mind that you can also add 
these Objects by using the Objects toolbox). The following sections describe 
how to use these tools.

Text

Box
Circle

Data Field

Animation WindowImage Field

Live Video
Window

MPEG/AVI Window
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Levels

Whenever you create an object in Multimedia Studio (this includes special 
objects covered in other chapters such as HyperButtons), you have the ability to 
specify the "level" on which that object is painted onto the screen. Objects can 
be placed on up to nine levels. For example, you may want to display a line of 
text on top of a circle, which is on top of a box. 

The number (1) indicates that you want the object to appear on the first or lowest
level. The number (9) indicates that you want the object to appear on the last or 
highest level. All objects defined with the same level number appear on the same
screen level. The level option provides extraordinary power in designing three 
dimensional effects with screen objects as well as other attractive screen designs.
For example, you might specify level 1 for the circle, level 2 for the box, and 
level 3 for the text to get the layering effect you want. See the following diagram
for an example of levels.

Hint: Objects with higher numbers appear on top of objects with lower numbers.

Circle=Level 1, Box=Level 2, Text=Level 3



Local and Global

When you are creating an application with more than one folder, you have the 
ability to define an object as either local or global. Local objects appear on the 
specified screen only within that folder. A global object, on the other hand, 
appears on the specified screen in every folder that is added (i.e. every screen 
within that row). For example, if you want to add text over the top of an image, 
and you want the text to appear only on that image and no others, you would 
define the text as local. To add a box object that you want to appear on every 
screen in that folder, you would define the box as global. 
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Text Objects

Standard 
Text

The process of adding text to a screen design is very simple. The text tool allows
you to add non-interactive text to a screen. Which means, if you click on the text
nothing happens. The text added to a screen with the text tool is for design 
purposes only. For example, in the Tutorial demo, the text on the opening screen
that says, “Main Menu” was created with the text tool. 

If you want to allow a user to click on text and have something happen (i.e. go to
a new screen or play sound or video file), you can use an invisible HyperButton 
and place it on top of the text. When the user clicks on the text it will be the 
same as clicking on the invisible HyperButton. Because the user does not see the
HyperButton, they will think the text is the hot spot. For example, you may have
an image of a house and you want the user to click on that area of the house and 
then go to a screen that contains more information about the house. You can add 
text on top of the image that says CLICK HERE and then put an invisible Goto 
HyperButton on top of the house that goes to a screen with a more detailed 
picture of the house.

�To add standard text to a screen:

1. From the Objects menu, select Text, or click on the Text icon.

2. After Text has been selected, a dialog box appears with the available text
options. In the Text box, enter the desired text.



3. Select the font and size for the text by clicking on the browse button at 
the right side of the Name box in the Font Attributes section. The Font 
dialog box appears. Click OK when you select the font, font style and 
size you want.

4. If you want to apply a drop shadow to the text, select an offset value 
between 1 and 25 (the number indicates the number of pixels that the 
drop shadow is offset from the text).

5. Select the level on which you want the text to be painted, by clicking on 
the circle corresponding to that level.

6. To add the text, select OK or select Cancel to exit the dialog box 
without adding the text. 

7. The text appears in the upper left portion of the screen. You can now 
move, copy, color, change, or delete your text object using the tool 
icons. 

Important: There is a difference between this type of text and the text 
within a data field. The text designed with the Text tool is used to design a 
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screen's layout and is not interactive. The text within a data field can be used
with the database functions such as searching and sorting. See the following 
diagram for an example of text created with the Text tool and text within a 
data field. The word SOLD was created with the Text tool and the text in the
fields on the right is from a data field.

Importing If you want to incorporate text into Multimedia Studio, you can do so
Text Images by importing an image of text created in another software package. To import 

text into Multimedia Studio, save the image of the text into a TGA, PCX, GIF, or
TIFF file format. Next, import the image into Multimedia Studio (see the section 
on Import).



Box Objects

You can use the box tool to draw rectangles or boxes on the screen. Boxes 
can be used to design the look of your screen. There are different attributes to 
choose from when drawing a box. Each option draws a different type of box. 
You can use a Framed, Clear box to draw an outline around a particular area 
of your screen. For example, you have a screen that contains an image, some 
data fields and some HyperButtons. You can use Framed boxes to separate 
the different areas of the screen. This will make your screen appear more 
organized and easier to understand for a user. After a box is drawn it can be 
resized to outline the area you want.

�To add a box to your screen layout:

1. From the Objects menu, select Box, or click on the Box icon.

2. A dialog box appears prompting you for information about the box. 
Choose whether you want the box to be solid or clear; 2D, 3D or framed,
and what level you want the box to appear on.

3. To add the box, select OK, or select Cancel to exit the dialog box 
without adding the box. 

4. The box appears in the upper left portion of the screen. You can now 
move, copy, resize, change, color, or delete your box object using the 
tool icons. 
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Different box types

Circle Objects

You can use the circle tool to draw circles or ovals on the screen. Boxes 
can be used to design the look of your screen. There are different options 
to choose from when drawing a circle. Each option draws a circle with 
different attributes. Circles can be drawn on anywhere on a screen or 
image to highlight a specific area of your application. For example, you 
may want to circle an area on an image and put some text that says CLICK
HERE. You can then put an invisible HyperButton on the circle so when 
the user clicks there something happens (i.e. a video or sound file plays).

�To add a circle to your screen layout:

1. From the Objects menu, select Circle, or click on the Circle icon.

2. A dialog box appears prompting you for information about the circle. 
Choose whether you want the circle to be solid or clear, and what level 
you want the circle to appear on.



3. To add the circle, select OK or select Cancel to exit the dialog box 
without adding the circle. 

4. The circle appears in the upper left portion of the screen. You can now 
move, copy, resize, change, color, or delete your circle object using the 
tool icons. 

Solid and Clear Circles

Field Objects

There are two types of fields within Multimedia Studio, Data Fields and Image 
Fields. Each field type is used to display or store different types of information. 
Image fields are used to display image files (i.e. .TGA, .PCX, .TIF, etc.) and 
Data fields are used to display numeric, alphanumeric and date information like a
database (i.e. names, numbers and dates).

Once again, it is important to note that Data and Image Fields are special types 
of objects - they are automatically defined as global objects. After you have 
created a field, that field will appear on every screen in that row (i.e. screen #3 of
folder1, screen #3 of folder2, screen #3 of folder3, etc.). 
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Data Field

Data Fields are used to incorporate the database features of Multimedia Studio. 
Data Fields are place holders for data that helps describe screens, and can be 
used with the database functions such as searching and sorting.

For example, in a real-estate application you may create the following Data 
Fields: Price, City, # of Bedrooms, etc.

Data fields have the following attributes: Field Name and Data Type. The Field 
Name is a name given to the information contained in that field. For example 
"Price", "ID #", "Name", etc. The Data Type determines the type of information 
which is to be contained in the field such as character, date or numerical 
information. See the table below for information on the specific field types.

This data type: Stores:
Character Field contents as text (i.e. Names).
Numeric Field contents as positive and 

negative numbers (i.e. Product 
Prices)

Date Field contents as a date expression 
(i.e. 12/31/94).

�To add a new Data Field object to your screen layout:

1. From the Objects menu, select Data Field, or click on the Data Field 
icon.

2. A dialog box appears prompting you for information about the data field.
Enter the name of the new field. The name can be any alphabetic or 
numeric name under 21 characters.



3. Select a font you want the Data Field name to appear in.

4. Select whether you want the Data Field to be beveled (sunken, 3D) or 
not (flat 2D).

5. Select the field type of your data field by choosing "Character", 
"Numeric", or "Date". It is important to select the proper data type if you
want to properly search or sort on your data fields. 

6. Select the level on which you want the data field to appear.

7. To add the data field, select OK, or select Cancel to cancel the 
operation. 

8. The data field appears in the upper left portion of the screen. You can 
now move, resize, change, color, or delete your data field object using 
the tool icons. The new data field appears on the current screen number 
for all of the folders in your file. 

Data Fields
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Formatting Date Data Fields

If you select Date for your Data Type, you can select the format you want the 
date to appear in. Click on the down arrow to the right of the Format box and 
select the date format you want your data to appear in. The following table 
shows how the different date formats display the date July 2, 1994: 

Format Result
m/d/yy 7/2/94
d-mmm-yy 2-Jul-94
mmm-yy Jul-94
mm/dd/yy 07/02/94
mm-dd-yy 07-02-94
mm-dd-yyyy 07-02-1994
mm/dd/yyyy 07/02/1994
mmmm/dd/yy July/02/94
mmmm-dd-yyyy July-02-1994

Formatting Numeric Data Fields

If you select Numeric for your Data Type, you can select a format for you data to
appear in. Click on the down arrow next to the Format box and select a format 
from the list that appears. The following table shows how the different formats 
display the number 3655.85:

Format Result
0 3656
0.00 3655.85
#,##0 3,656
#,##0.00 3,655.85
$#,##0 $3,656
$#,##0.00 $3,655.85
0% 3656%
0.00% 3655.85%



Image Field Incorporating images into your application is a two step process. The first step is 
to create an image field, which simply defines a window where you can later 
import or capture an image into. The second step is to either capture, or import 
an image into the image field. 

Important: An image field must be defined AND SAVED on your screen before 
you can capture or import an image to that screen.

�To add an image field to your screen layout:

1. From the Objects menu, select Image Field, or click on the Image Field
icon.

2. A dialog box appears prompting you for information about the image 
field. In the Name box, enter the name that you want to give the new 
field, and the level on which you want the image field to appear.

3. Select the image format you want to save the image to - either Targa 
(TGA), JPEG, or PCX.

4. If you want a 3D frame to automatically frame the image field, click on 
the Framed toggle box.

5. Enter the level at which you want the image field to appear on.

6. To add the image field, select OK, or select Cancel to exit the dialog 
box without adding the image. 
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7. The image field appears in the upper left portion of the screen. You can 
now move, resize, change, or delete your image field object using the 
editing tool icons. The new image field appears on the current screen 
number for all of the folders in your file. 

Note: When you first create an image field it has hash marks through it. This
means that the image field has not yet been saved. Before an image can be 
brought into an image field, it must first be saved. Select Save from the File 
menu.

8. After an image field is saved, you may begin putting images into your 
image fields by saving your changes, and selecting Capture or Import 
from the Image menu (see the section on Images).



Image Fields

Live Video Window

If your computer has a Video Overlay Card installed, you can integrate live 
video into your application screens. This live video can come from a variety of 
sources, including laser disc players, PC-VCRs, hardware assisted MPEG, using 
Optibase’s PC Motion board and video cameras. This can be very useful when 
you are creating an application that needs to display live video. For example, you
may design a security application that displays video from a camera, or you may 
be at a trade show and have a camera hooked up to your computer and you want 
to display video as people walk by. You may even be creating a training 
application where video is being displayed in your application from a remote 
location. 

A Live Video Window differs from an MPEG/AVI Video Window in that an 
MPEG/AVI Video Window plays a video file (i.e. .AVI and MPEG files). Video
is only played in the MPEG/AVI Video Window when a Video Button is clicked
on by the user. Clicking on Video buttons tells Multimedia Studio to play the 
appropriate file in the MPEG/AVI Video Window. With a Live Video Window, 
the user does not have to click on a button to display the video. The video is 
automatically played from the attached source (VCR, video camera) when the 
screen containing the Live Video Window appears.
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�To define a live video window:

1. From the Objects menu, select Live Video Window. The Live Video 
dialog box appears prompting you for information about the video 
window.

2. Depending upon the brand of video board that is installed, you will see a
different dialog box. All boxes prompt you to enter a level, and whether 
the video window is local or global. Some boards allow you to size the 
video window just like any other object within Multimedia Studio, while
others restrict you to only a few possible sizes. Make your selections, 
and choose OK.

3. The video window appears in the upper left hand corner of your screen. 
If you have a video source hooked up, you should see video on your 
computer screen. You may now move the Video Window to any location
on the screen. When the user goes to this screen, the video from the 
camera is displayed in the video window. For example, if you have a 
main menu with a Goto button called Camera 1, clicking on this button 
would take the user to a screen that contains a Live Video Window of 
what camera 1 is seeing.



MPEG/AVI Video Window

An MPEG/AVI Video Window determines where on the screen your video files 
are played. This command allows you to create a Video Window for either 
MPEG (Motion Pictures Expert Group) or AVI files. Multimedia Studio 
includes the decompression player software needed to play MPEG compressed 
video files. This revolutionary software allows you to incorporate compressed 
video into your applications without requiring any additional software!  This is 
very important when you are creating runtimes, because it is important to reduce 
the hardware requirements of the systems that will be running the runtimes. This 
means that more people can view your application. Limiting the hardware 
requirements of your application greatly increases your target audience.

Note: In order to convert video into MPEG files, you need an MPEG encoder 
device such as a Sigma Designs Reel Magic board. For more information on 
MPEG encoding, contact Advanced Media, Inc.

Integrating an MPEG or .AVI video clip into an application is a two step 
process. The first step is to create an MPEG/AVI Video Window. The second 
step is to create a Video HyperButton. When a Video HyperButton is clicked on,
the associated MPEG or .AVI file is played in the MPEG/AVI Video Window. 
You should create the MPEG/AVI Video Window first because you have to tell 
the Video button the name of the Video Window the video is going to play in.

You can have as many MPEG/AVI Video Windows as you like. For example, 
you may want to play video in different areas on the screen. In this case you can 
have three Video buttons that each play video in a different Video Window that 
is a different size and located at a different area of the screen. You can also have 
multiple Video buttons that play video in the same Video Window.

�To create an MPEG/AVI Video Window:

1. From the Objects menu, select MPEG/AVI Video Window.
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2. The MPEG/AVI Video Window dialog box appears.

3. In the Name box, enter the name you want to assign to the MPEG/AVI 
Video Window (this name is only a reference name for your own 
use). Make a note of this name because when you create the Video 
HyperButton, you must enter the name of the MPEG/AVI Video 
Window you want the video to play in.

4. In the Video Format, select the type of video file that is going to be 
played in the window. Select MPEG if you are going to play an 
MPEG file, or select AVI if you are going to play an .AVI file. The 
file that is played is selected when you create your Video 
HyperButton later on.

5. Select whether you want the MPEG/AVI Window to be local or global. 
Local means that the window only appears on the current screen. 
Global means that the window appears on the current screen for 
every Folder (i.e. if you are on screen 2, every screen 2 of every 
folder will have the video window on it).

6. Select the level on which you want the window to appear on (i.e., the 
level on which you want the video to appear).

7. You can now move the MPEG/AVI Window to any location on the 
screen using the Move tool. You can now create a Video HyperButton to
play an MPEG file within this window.



Animation Window

Multimedia Studio has the ability to play animations either as full screen 
animations (640 x 480 resolution) or as an animation inside of a window (320x 
200 resolution). If you want to play an animation inside of a window, the first 
step is to create an Animation Window. An animation window defines the area 
where the animation will play when the Animation HyperButton is clicked on, 
and is therefore much like a Video Window (except animation files are played 
instead of video files). 

To play an animation file in a specified window in Multimedia Studio is a two 
step process. First, you must create an Animation Window and then you must 
create an Animation HyperButton. When the Animation HyperButton is clicked 
on, the animation file is played in the associated Animation Window.

�To create an Animation Window:  

1. From the Objects menu, select Animation Window.

2. In the Name box, enter the name you want to assign to that Animation 
Window (this name is only a reference name for your own use). Make a 
note of this name because you must enter this name when you create the 
Animation HyperButton.

3. Select whether you want the Animation Window to be local or global. 
Local means that the window only appears on the current screen. Global 
means that the window appears on the current screen for every Folder 
(i.e. if you are on screen 2, every screen 2 of every folder will have the 
animation window on it).
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4. Select the level you want the window to be on (i.e., the level on which 
you want the animation to appear).

5. You may now move the Animation Window to any location on the 
screen (Note that an Animation Window always displays at 320 x 200, 
and therefore cannot be resized). You can now create an Animation 
HyperButton to play an animation file within this window.



Image Menu

The Image menu in the menu bar is where all operations concerning the 
displaying, acquiring, importing, naming, and converting of images exist. After 
you select the appropriate video source or video capture you can begin capturing,
and importing images directly into defined image fields. These features and other
features about images are described in the following sections.
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Image Colors

Multimedia Studio has the ability to display images in 16, 256, 32,768, 65,535, 
or 16.7 million colors. The number of colors that you should use depends upon 
your individual application. Obviously the more colors you use to create the 
image, the more impressive the image is. However, you must consider what 
hardware is used on the runtime stations to determine how many colors you want
to save the images to.

What happens if you find yourself in a situation where 95% of your audience 
has, for example, 256 color capabilities, but the other 5% only has 16 color 
capabilities? Multimedia Studio has the ability to convert images on the fly. That
is, Multimedia Studio can convert a 256 color image to 16 colors if the user is in 
the 16 color mode. 



Auto Show

To make pictures appear automatically each time a screen containing an image or
picture is displayed, select Auto Show from the Image Option. A check mark 
signifies that the Auto Show feature is active. The absence of a check mark 
signifies that Auto Show is not active. 

HELPFUL HINT    
When the Auto Show feature is turned off, screen navigation is quicker, because images are not 
displayed each time you flip to new screens or folders. So, if you are authoring an application 
with a lot of images, turn the Auto Show feature off until you are ready to test the application. 
This will save you time in the creation of your application. 

If you activate the Image menu, you notice that there is a check mark next to the 
Auto Show option. This means that the Auto Show option is currently turned on.
The default setting is for the Auto Show feature to be turned on. 

Show Image Name

The Show Name feature is handy for many reasons, which include the capability 
to provide you with valuable information about an image you might want to 
bring into a common paint program or desktop publishing package. It can also be
useful if you want to edit a particular image and you do not remember the name 
of the image or where it is located on your hard disk.

�To display the name of the image(s) for the current screen:

1. From the Image menu, select Show Name.

2. The names of all the Image Fields on the current screen, and the names 
of the images within these Image Fields is displayed.
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3. The Show Name feature also provides you with other information on an 
image, such as its file format, coordinate position, and width and height. 
You can access this information using the horizontal scroll buttons at the
bottom of the dialog box.   

Delete Image

Multimedia Studio makes it easy to delete any unwanted images from your files. 

�To delete an image:

1. From the Image menu, select Delete.

2. A message appears directing you to click on the image that you want to 
delete.

3. Click on the image that you want to delete.

4. A dialog box appears, asking you to confirm that you want to delete the 
selected image. 



5. Select Yes to delete the image, or No to exit the dialog box without 
deleting the image.

6. Continue selecting the images you want to delete or press the ESC key 
to stop deleting images.

Auto Naming

Images that are captured or imported are automatically saved on your hard drive 
as a TGA, JPEG or PCX file. These files need to be given their own unique file 
names. You have the option to manually enter these file names, or to have names
automatically assigned to them using the Auto Naming feature. The default 
setting is set so that you must manually enter the file names. If you want to have 
names automatically assigned to your files, you can change this default setting. 

�To change to Auto Naming:

1. Select Options from the Image menu. 

2. Click on the browse button and select the directory you want the images 
saved to. At the bottom of the dialog box, you see a prompt, 
"Automatically Generate Image Names?". Click on the box to change the
setting to automatically name your images. The names that are assigned 
to the images are in the following format: "PIC_0001", with the numbers
beginning at 0001 and incrementing upward. Select the Universal Palette
option is you want the image to use a universal palette.
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Capture Image

The Capture Image option allows you to capture images from a video source
directly into pre-defined image fields. Therefore, you must have an image field 
on that screen before you can capture an image. An image field is created using 
the Image Field command in the Objects menu

In order to use the capture command, you need to have a video capture card and 
a video source (i.e. video camera, VCR, still video camera) properly installed.

Image

Fields
�To capture an image an image field of the current screen of the 
current folder:

1. Go to the screen you want to capture images into. 

2. From the Image menu, select Capture.

3. After selected, you are prompted to proceed with capturing an image into
the Image field on the current screen. Select Proceed to continue, or 
Cancel to end the operation. Depending upon the type of capture card 
you have installed, you either see the incoming video signal on your 
computer monitor or on your video display monitor. 

4. After you see the desired image you want to capture simply press the 
Enter key or click the left mouse button. 

5. You are prompted with a question, "Maintain aspect ratio?" This is 
simply asking whether or not you want Multimedia Studio to "stretch" 
your image to fit the size of the image field exactly. If you do not want 
for your original image to be stretched, select Yes. If you don't mind if 
your original image is distorted by stretching, select No. 
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Import Image

The Import Image option under the Image Menu allows you to import .BMP, 
TGA, PCX, TIFF, JPEG, or GIF images into defined image fields. This allows 
you to incorporate images created with popular paint and graphic packages into 
your application. 

Note: You must create and save an Image Field with the Image Field command 
in the Objects menu, before importing an image.

�To import images into a screen that contains an image field:

1. From the Image menu, select Import.

2. A dialog box appears with the question, "Import image for (image field 
name)? Select Yes to continue or Cancel to abort the process.

3. A second dialog box appears requesting the name of the image you want 
to import. To import an image file, click on the browse button and select
the image you want to import. If you know the name and path of the 
image, you can just type it in.

4. At the bottom of the dialog there is a Maintain Aspect Ratio check box.
This option allows you to select if you want an image to be resized to fit 
the image field, or if you want an image to stay the same size and be 
cropped to fit in the image field. If you do not want for your original 
image to be stretched to fit in the image field, select click on this option. 
Clicking the Maintain Aspect Ratio option crops your image so that only
part of it is displayed. If you don't mind if your original image is resized 
so that it fits in the image field, you can select leave this option 
unselected. 



5. Select OK to import the image. The first dialog box disappears, and the 
file begins to be imported. 

6. After you import your image, you can use the editing tools to resize and 
move your image.

HELPFUL HINT
 When capturing, or importing images into pre-defined image fields, if you choose "No", be sure 
that the dimensions of the defined image field closely approximates the dimensions of the 
captured image. Otherwise, captured images may appear to be distorted. For example, importing 
an image with a rectangular area into a square image field would cause the image to appear 
squeezed on the left and right sides.
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Options

The Options selection allows you to set up the Drive and Directory to store your 
captured images. Images can be stored in the current directory, or across multiple
drives. This can be useful when you want to keep track of your images and 
where they are located.

�To set your capture path:

1. From the Image menu, select Options. The Options dialog box appears.

2. Click on the browse button and select the path you want your images 
captured to. If you know the path you want your images captured to just 
type in the path you want to use. 

3. In addition to setting the capture path for your image, you may also 
select whether you want captured images named automatically or 
manually. The default setting is for images to be named manually. 
Each time you capture a new image, you will be prompted to enter 
its name. Alternatively, you may choose to automatically name each 
new image that is captured. To select automatic naming, click on the
Automatic Naming option so there is an X in the box. 

4. You can also select whether or not you want to use a Universal Palette 
for your images. The Universal Palette option forces all images to 
use the same color palette when they are displayed in Multimedia 
Studio. If you choose to use a universal palette, your images will not
fade to black when using screen transitions in 256 color mode, but 
the quality of the image is reduced. To use a universal palette, click 
on the Universal Palette option so there is an X in the box.
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HyperButtons are mouse sensitive areas on the screen which execute 
predetermined operations which include linking screens, activating sound and
animation files, playing live video, etc. HyperButtons are Multimedia Studio's 
unique approach to introducing interactivity into an application. 

Each HyperButton can also be linked to another HyperButton, allowing one 
HyperButton to automatically activate another one after a specified time delay. 
The HyperButton features of Multimedia Studio allow extraordinary power in 
designing your multimedia applications. 
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The HyperButton options can be accessed from the HyperButton menu or the 
HyperButton Tool Box as shown in the following diagram. The following 
sections describe these functions as well as other information about 
HyperButtons.

GoTo

Sound

Video

Animation

Quit



Options Dialog Box

When you are in a HyperButton dialog box, notice that in addition to OK and 
Cancel buttons, there is also an Options button. The Options button displays 
additional options for your HyperButtons in the dialog box. Unlike other 
buttons, this button displays the same options for all HyperButtons. 

This section drops down whenever you click on the Options button

Linking One of the more powerful options available in the Options
HyperButtons section of a HyperButton dialog box is the ability to link HyperButtons together.

When you are creating a new HyperButton, this button can automatically trigger 
a second button by entering the name of this second button in the "Link Button" 
box. As a result, when you activate the new HyperButton, it performs its 
function, and then links to the second HyperButton which then performs its 
function. 

For example, if you want to link a Sound HyperButton to a Goto HyperButton 
(i.e. so that when you click on a Goto HyperButton you Goto the destination 
screen and then automatically activate a sound file), you would do the following:
When defining the Goto HyperButton, select the Options button to activate the 
additional options. Select the name of the sound HyperButton at the Link Button
prompt. You can also use linked Sound HyperButtons to make a button make a 
noise when it is clicked on. For example, if you are designing a kiosk, you may 
want to make your button make a noise each time they are selected.

When creating an application you may want a button to make a noise when it is 
clicked on, but you do not want to actually see the sound button. For example, 
you may have an application that has a multiple choice question with three 
buttons representing the different answer choices. When the user clicks on the 
correct answer, you want to display an image and play a sound file that applauds 
the correct answer. In this case you would create a Place Image button and link 
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the Place Image button to a Sound button that plays a sound clip of applause. 
Because you do not want the user to actually see the Sound button, you would 
make the Sound button invisible by checking the Invisible option. 

It is important that the linked HyperButton is on the same screen that you are on 
when the link function occurs. In other words, if a button is linked to a Goto 
button, the linked button must be on the destination screen of the Goto function. 
If a HyperButtons is linked to any other type of button, it must be on the same 
screen as the first button.

When linking HyperButtons, you have the ability to add a delay to the link. For 
example, you may want an Animation HyperButton to be activated automatically
if a particular Sound HyperButton is selected. You can have the animation play 
immediately (no delay), or you can define a delay period (i.e. 10 seconds). To 
add a delay to a HyperButton link, simply type in the delay period, in seconds. 
See the Linking HyperButtons section for more information on linking buttons.

Button Image Perhaps the most powerful screen design feature within Multimedia Studio is the 
ability to wrap an image around a 3D HyperButton. You can assign most image 
formats to a HyperButton, making it possible to turn any image into a three 
dimensional HyperButton! As a result, runtime users are able to click on an 
image to activate any of the interactive HyperButton features within Multimedia 
Studio. And images can be more than just pictures, they can be textures, color 
fades - anything that can be saved as an image! For example, you may want an 
image to have a marble appearance. In this case you would select a marble image
for the button image.

When you apply images to a button, you may not want the button name text to 
appear on the button. In this case, you would deselect the Show Name option. 
For example, you have created a Sound button called Elephant and applied an 
image of an Elephant on the button. You do not want the name of the button (in 
this case Elephant) on the button. If you deselect the Show Name option, the 
button will have the elephant image and the button name will not be on the 
button.



�To apply an image on to a HyperButton: 

1. Enter an image name and path into the Button Image box, or click on the
browse button. If you clicked on the Browse button, select the file type 
you want to use for the button image and then switch to the directory 
that contains the image you want to use. When the image is selected, 
click OK.

2. By default, Multimedia Studio does not scale the image to fit the 
HyperButton. Instead, it keeps the image at its original size, and applies 
the portion of the image beginning at the upper left corner, and 
extending downward and to the right to the exact dimensions of the 
HyperButton.

3. In some cases, particularly when you are applying a texture image to a 
button, it is ideal that the image is not resized. This way, the texture does
not become distorted by scaling and you can use the same image 
throughout an application to create multiple buttons of various sizes. 
After resizing the HyperButton to the desired size, you are prompted 
with a question asking if you would like the image to be scaled to fit the 
new dimensions of the HyperButton. In this case, select No.

4. In other cases, particularly when you are applying a picture to a button, 
you want the image to be resized to the exact size of the button. To do 
this, use the resize tool to resize the button to its final size. You are 
prompted with a dialog box asking whether you want to resize the image
to fit the button. Select Yes.

Note: If you resize an image, the image will be resized for all of the buttons 
using that image. For example, if you are using a marble texture for all of 
your images and you resize the image to be very small, the image may not be
large enough to cover some of the larger buttons. In this case, you should 
resize the button image so that it covers the largest button.
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HELPFUL HINT
If you are going to put a full picture onto a HyperButton, try to avoid resizing the image more 
than you have to, as resizing an image takes time. In other words, resize the button to the size 
that you want before responding "Yes" to the resize image prompt. 

Solid, Clear, If you choose not to assign an image to a HyperButton, 
and Invisible the Options dialog box allows you to define whether you want the HyperButton 

to be solid, clear, or invisible. This provides you with further flexibility in screen
design. For example, invisible HyperButtons allow you to place HyperButtons 
on top of live video, text, etc., and still remain unseen by the end user. As a 
result, you can have a user activate HyperButton capabilities by clicking on 
images, live video, text, etc. Clear HyperButtons are similar to invisible 
HyperButtons, but clear buttons show an outline of the HyperButton. Finally, 
solid HyperButtons are the standard 3D buttons, which can be changed to any 
color, resized, etc., to create the desired look. For example, if you want to go to a
specific screen when an image is clicked on, you can put an invisible Goto 
HyperButton on the image.

Button Styles

Clickable When you link HyperButtons together to create a chain of self-running events, 
you often use invisible HyperButtons that you would not want someone to 
accidentally trigger. For example, you may create a Sound HyperButton that 
begins playing a sound file 10 seconds into a slide show of screen images. You 
would not want a user to be able to accidentally select the button after only 5 
seconds. The "Clickable" toggle box gives you the option to make a button "un-



clickable" or "unselectable". To make a button un-clickable, click on the 
Clickable toggle box to remove the "X". Un-clickable buttons are usually 
invisible HyperButtons that are linked to other HyperButtons. Making an 
invisible HyperButton un-clickable makes sure that a user does not randomly 
click on the screen and activate the HyperButton.

Note: HyperButtons can be selected with a mouse, or by typing the first letter of 
the HyperButton.

Display NameWhen creating a HyperButton, you have the choice of whether or not you want 
to display the name of the HyperButton. While at first, it may seem as if you 
would always want to display the name of the HyperButton, there are many 
occasions when you might not. For example, when you assign a picture to a 
button, you might not want a name displayed on top of the image (however, you 
still want to assign a name to the button for your own reference, and for linking 
HyperButtons, etc.).

Levels In the Objects section you were introduced to levels, and using levels to "layer" 
objects and create 3-D effects. The Options button displays an option of level, 
which is where you assign a HyperButton a level on which it is painted. Levels 
of HyperButtons work the same as levels of objects.

Goto HyperButton

The Goto HyperButton is the most commonly used HyperButton, and is the 
method by which you can incorporate interactive branching into an application. 
In other words, Goto HyperButtons link screens together. This button is 
therefore described in detail in the Linking your Application Screens section.
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Multimedia HyperButtons

Multimedia Studio has multimedia HyperButtons which provide you with the 
ability to easily incorporate Sound, Animation, and Live Video into your 
multimedia Applications.

Note: In order for these HyperButtons to operate properly, you must first install 
the required hardware according to the manufacturer's instructions and load any 
necessary device drivers and programs.

Sound
HyperButtons

Sound can be an important part of your multimedia application. Sound (and 
video) is one of the main components of your multimedia application that truly 
differentiates it from standard printed material. With Multimedia Studio, 
incorporating sound into an application is easy.

Sound buttons, when selected, play a specified sound file. To play a sound file, 
you must have a sound board on your computer. Multimedia Studio 
supports .WAV and MIDI files and these sound files can be used in many 
different ways. They can be used to activate background music when a screen 
appears, they can be used to activate a sound when the user selects a button that 
takes them to another screen (this is done with linking a sound file to a Goto 
button), or they can be used to simple play a sound file when a button is clicked 
on. For example, you may have a screen that contains information (i.e. video, 
images) about elephants. On that screen you can have a button that when clicked 
on plays the sound that an elephant makes.

�To create a sound button:

1. From the HyperButton menu, select Sound. The Sound Button dialog 
box appears.



2. In the Button Name box, type the name you want to appear on the sound
button. Typically you can type the name of the sound file on this button 
or just simply Sound or any name that you feel appropriate. 

3. Leave the File radio button selected and click on the browse button and 
select the font style and size for the button name.

4. Because we are creating a button that plays a sound file leave the “Stop 
Sound” toggle unselected. Selecting this option creates a button that 
stops the sound file from playing. This provides the user the ability to 
stop a sound file from playing. Creating a stop sound button can be very 
important and is discussed in the next section.

5. Click on the browse button next to the File Name box. In the File Type 
box, select the type of sound file you want to select (MIDI, .WAV). 
Browse through your directories and select the sound file you want to 
use and click OK.

6. If you want to make any changes to the attributes in the Options dialog 
box, click on the Options button and make any changes that you would 
like.

7. After the sound button appears, you can move, resize, or change its color
by selecting the appropriate editing tool. To test the new Sound 
HyperButton, select the "Try-it" tool. You can now click on your new 
button, and the sound file plays.
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Stopping a Sound File

When a sound file is playing, you can give the user the option of stopping the 
sound file. This can be important because someone might get a phone call (or 
other distraction) while using your application and they want to stop the sound. 
When creating a multimedia application with sound, you may want to keep this 
in mind. A Stop sound button is created in the same way as a regular sound file, 
except you now select the stop sound option when creating the button. This type 
of button can be called Stop Sound or anything else you like.

�To create a button that stops a sound file from playing:

1. From the HyperButton menu, select Sound. The Sound Button dialog 
box appears.

2. In the Button Name box, type the name which you want to appear on the
sound button. Usually something like Stop Sound is appropriate.

3. Select a font by clicking on the browse button in the Font Attributes 
section.

4. Select the “Stop Sound” toggle so there is an X in the box.

5. Leave the Sound file blank.



6. If you want to make any changes to the attributes in the Options dialog 
box, click on the Options button and make any changes that you would 
like.

7. After the stop sound button appears, you can move, resize, or change its 
color by selecting the appropriate editing tool. To use the new 
HyperButton, select the "Try-it" tool. Click on a Sound HyperButton 
that plays a sound file. While the sound file is playing, you can click on 
your new button, and the sound file stops playing.

Video
HyperButtons

The Video HyperButton is used to play a segment of video from analog video 
devices such as laser disc players and computer controllable VCRs, or to play 
digital files saved to an MPEG (Motion Pictures Expert Group) or .AVI format. 
If you want to display analog video from an external source or a hardware 
assisted MPEG file on you VGA monitor, you need to be sure that you have a 
Video Windowing Board installed. If you want to play a software only .AVI file,
a Video Windowing Board is not required.

Before creating a Video HyperButton to play analog video or a hardware assisted
MPEG file, you need to define a Video Window, as explained in the section on 
Live Video Window. You also need to be sure that you have setup Multimedia 
Studio to work with the video device. If you haven’t, double click on the 
Hardware Setup icon in the Multimedia Studio group in the Program Manager 
and select the proper video device.

Note: Using the Video Editor program that comes with Multimedia Studio, you 
can edit your video clips. You can also use the video editor to incorporate sound 
into your video clips and you can even combine multiple sound clips using 
different transitions. For more information on the Video Editor, see the 
Multimedia Production Tools documentation.
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Before creating a Video HyperButton to play a digital MPEG or .AVI file, you 
need to create an MPEG\AVI Video Window (see section on MPEG/AVI Video 
Window). This window determines the size of the video when it is played on the 
screen and where the video file is going to be played on the screen.

�To create a Video HyperButton:

1. From the HyperButton menu, select Video. 

2. In the Button Name box, type the name you want to appear on the Video
button (i.e. Play Video, Video, etc.).

3. Select a font by clicking on the browse button in the Font Attributes 
section.

4. The middle section of the Video HyperButton dialog box is designed for 
creating video buttons to control external analog video devices such as 
laser disc players, video cameras and PC-VCRs. To create such a button:

 Select a command by clicking on the down arrow. The list of 
available commands depends upon the video device that you have 
installed, but will always at least include the command to play a 
range of video.



 If the command that you select requires a starting and stopping 
address (i.e. if you select “Play Range”), type the starting and 
stopping “address” for the video sequence you want to play (you 
may need to consult your video devices’ manual to determine how to
enter an starting and stopping address). Disregard the lower portion 
of the dialog box, which is used only for MPEG video.

5. If you are creating a button to activate an MPEG or .AVI video clip, 
disregard the upper potion of the dialog box used to control external live 
video devices. The lower portion of the Video dialog box is used when 
creating a button to play a MPEG video clip.

· Click on the down arrow to the right of the Command option and 
select Play. Certain video boards display additional options here.

· Leave the File option selected and click on the browse button to the 
right of the File option. Browse through your directories and 
select the MPEG or .AVI file that you want to play and click 
OK.

· Enter the name of the MPEG/AVI Video Window that the video clip
will play within. This window should be created prior to creating the
Video button with the MPEG/AVI Video Window command in the 
Objects menu.

6. If you want to make any changes to the attributes in the Options dialog 
box, click on the Options button and make the changes you want.

7. Click OK when the appropriate options are entered.

8. After the Video button appears, you can move, resize, or change its color
by selecting the appropriate editing tool. To test the new HyperButton, 
select the Try-it tool and click on the button. The video you selected will
play in the selected window.
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Animation HyperButton

Animation Buttons give you the ability to define buttons that when selected, play
an animation file from any supported animation programs. Animations can be 
played as full screen animations (640 x 480 resolution) or they can be played 
within an animation window (320x200 resolution). When playing animations in 
an animation window, you can control where the animation is going to be played
on the screen. Multimedia Studio support .FLI and .FLC animation files. 
Animation can give your application the pizzazz it needs to be a real attention 
getter. You can even link Animation HyperButtons with Sound HyperButtons to 
create even more stunning applications.

�To create a full screen animation button:

1. From the HyperButtons menu, select Animation.

2. In the Button Name box, enter the name of the Animation HyperButton 
(i.e. Animation, Play, etc.).

3. Select a font by clicking on the browse button in the Font Attributes 
section.

4. Enter the number of loops, or times, that you would like for the 
animation file to play each time that the HyperButton is selected.



5. Enter the speed at which you would like for the animation file to be 
played at. The lower the number you enter for speed, the faster the 
animation will play.

6. Type the file name (including the path) of the animation file that you 
want to play, or click on the down arrow and select a file from the list 
that appears. For example, to play an Autodesk Animator "Fli" file 
called FISH.FLI which exists in the ANIMATE directory, you would 
type C:\ANIMATE\FISH.FLI in the Animation File Name field. You 
can also click on the browse button and choose the file you want.

7. After selecting an animation file name, you can preview the animation 
by clicking on the Play button.

8. For full screen animations, leave the Animation Window and Leave 
Last Frame fields empty.

9. If you are happy with the default settings for the remaining attributes, 
select OK. Otherwise, select the Options button, and make any changes 
that you like.

10. After the animation button appears, you can move, resize, or change its 
color by selecting the appropriate editing tool. To use the Animation
HyperButton, select the "Try-it" tool. You can now click on your new 
button, and the animation file plays.
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�To create a button that plays an animation in a specified window:

1. Create an Animation Window as described in the Animation Window 
section. This window defines the location on the screen where the 
animation going to play when the animation button is clicked on. 

2. Follow steps 1 through 8 of  "Creating a full screen Animation Button" 
outlined above.

3. In the Ani Window box, enter the name of the Animation Window that 
you want to play the animation within.

4. When playing an animation in a window, you have the option of leaving 
the last frame of the animation on the screen after the animation has 
finished playing. If you would like to leave the last frame of the 
animation on the screen, click on the Leave Last Frame box until an 
"X" appears. To refresh the original screen after the animation has 
played, leave this box empty.

5. If you are happy with the default settings for the remaining attributes, 
select OK and you are done. Otherwise, select the Options button and 
make the necessary changes.

6. After the button appears, you can move, resize, or change its color by 
selecting the appropriate editing tool. To use the new HyperButton, 
select the "Try-it" tool. You can now click on the button, and the 
animation plays.



Quit
HyperButtons

The Quit HyperButton is one of the authoring buttons that is essential to 
incorporate if you are planning to distribute runtimes. The Quit HyperButton, 
when selected, enables the end-user to exit a runtime application and return to 
the Windows. If you want the user to exit the application, you should create a 
Quit button. If you do not want a user to exit the application (i.e. self running 
kiosks), you should not create a Quit button. In many cases you would put a Quit
HyperButton on the screen that is easily accessible to the user of the application. 
For example, you may want to put the Quit button on the main menu screen 
because most applications always provide the user a way to get to the main 
menu. You can create as many quit buttons as you like. You can even put one on
every screen, although this may make the screens of the application appear 
cluttered. This would though give the user the ability quit the application at any 
time from any screen.

�To create a Quit HyperButton:

1. From the HyperButton menu, select Quit.

2. In the Button Name box, type the name you want to appear on the Quit 
button. A typical name for this type of button would be Quit or Exit.

3. If you want to make any changes to the attributes in the Options dialog 
box, click on the Options button and make any changes that you like.

4. After the appropriate options are input, click on the OK button.
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5. After the exit button appears, you can move, resize, or change its colors 
by selecting the appropriate editing tool. To use the new HyperButton, 
select the "Try-it" tool. You can now click on the button, and you will 
exit the software.
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Section3
Linking Screens
After you create your screens, you can link your screens together. Linking screens determines 
which screen appears and how it appears when a HyperButton is selected.

The following sections show you how to:

Create a Goto HyperButton...........................153

Link HyperButtons........................................158
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Goto HyperButton

The Goto HyperButton allows you to jump from one screen to another in your 
application. This allows you to determine where you are taken when a 
HyperButton is selected. The main function of the Goto button is to link the 
screens of your application together. For this reason, the Goto HyperButton is 
the most important HyperButton within Multimedia Studio, and the most 
commonly used.  For example, Goto HyperButtons can be used to create a main 
menu that begins an application and contains a variety of buttons that allow the 
user to select the topic in the application they want to go to.

The Goto HyperButton also allows you to incorporate transitional fade and wipe 
effects into your application. You can also link Goto buttons to different buttons 
which can perform different functions when the user goes to a new screen. For 
example, you can link a Goto button to a sound button which would cause a 
sound file to be played when a user clicks on a button. The following diagram is 
an example of an application with a Main Menu which contains Goto buttons to 
take the user to different parts of the application. Each of the buttons goes to a 
screen that contains more detailed information on each of the topics. Each screen
in return has a Goto button called Main Menu, which takes the user back to this 
main menu so they can select another topic. The only button that is not a Goto 
button is the Quit button which when clicked on exits the application.
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�To create a Goto HyperButton: 

1. From the HyperButton menu, select Goto.

2. In the Button Name box, enter the name you want to appear on the 
button.

3. Choose the font in which you want the button name to appear.
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4. If you want to enter the destination screen using the View by Icon 
screen, select the Icons button. The View by Icon screen appears. You 
can select the destination screen by clicking on that screen's icon and 
selecting OK, or by double-clicking on the screen's icon. After you do 
this, you return to the dialog box, and the destination screen's 
information is automatically entered into the folder and screen # fields.

5. If you want to enter the screen location manually, enter the folder name 
and screen # that you want to link the current screen to when the button 
is pressed. You can either type these names or select from a list clicking 
on the down arrow. In addition to establishing absolute jumps between 
two screens, you may also want to have a Goto button jump to the Next, 
Previous, First or Last folder or screen of a particular file. Multimedia 
Studio makes this easy. Enter the word Next, Previous, First, or Last in
the Goto Folder Name, or Goto Screen # fields to create this kind of 
Goto button.

6. If you want to incorporate a transitional fade or wipe effect, click on the 
down arrow next to the Effect box and select one from the list that 
appears. 

Note: Transitional effects only work in the Preview and Runtime modes. 
They will not work when you are using the Try-It tool.

7. If you want to create a bookmark, check the Bookmark option. A 
bookmark can be used to create a Goto HyperButton that returns to 
the original screen. For example, if you have Goto HyperButtons on 
a Main Menu, you can check the Bookmark options for these 
HyperButtons. You can then put Goto HyperButtons on the other 
screens that automatically return to the Main Menu. These Goto 
HyperButtons do not need to have the Bookmark option selected and
you can leave the Folder and Screen blank.

8. If you want to make any changes to the attributes in the Options dialog 
box, click on the Options button and make any changes that you 
like.



9. Click on the OK button.

10. After the button appears, you may move, resize, or change its color by 
selecting the appropriate tool from the toolbox. You can test the Goto 
HyperButton by selecting the Try It tool, and then clicking on the Goto 
button.

Self Running Applications

Using Goto HyperButtons, you can create self running applications and 
presentations. With the Time Out option, located at the bottom of the Goto 
HyperButton dialog box, you can automatically activate Goto buttons after a 
specified time period, without having to click on them. 

When creating self running applications it is best to use invisible Goto 
HyperButtons that Time Out (activate) after a specified time. This way the user 
does not see the button and the screen changes automatically. For example, your 
application starts out by putting some bullet points on the screen. After the 
person finishes reading the bullet points (about 15 seconds), you want the 
application to automatically continue and display another screen with more 
information. To do this, all you have to do is create an invisible Goto 
HyperButton on the screen that has a Time Out of 15 seconds. After 15 seconds 
the Goto button will activate and the desired screen automatically appears. 

Note: When using Goto HyperButtons that time out after a specified time period,
make sure the user has ample time to read the on screen information. Changing 
screens too quickly can be irritating for the person attempting read the 
information. For best results, let people of different reading speeds test your 
application and then make the appropriate adjustments to the timing.

„To create a Goto HyperButton that automatically activates:

1. Create a Goto HyperButton as described in the previous section.

2. In the Time Out option of the Goto HyperButton dialog box, enter the 
time you want to elapse before the Goto HyperButton activates.
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3. Click on the Options button and select the Invisible option in the 
Textures section.

4. Deselect the Clickable option. This makes sure that no one randomly 
clicks on the screen and activates the invisible HyperButton.

5. Click OK and the button appears in the upper left corner of the screen. 
The screen location of this button does not matter because this 
button is invisible and is not clickable. Whenever the current screen 
appears and is in active for the time specified in the Time Out 
option, the Goto HyperButton activates as if it was clicked on.
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Another important linking feature is the ability to link one HyperButton to 
another (which, in turn, can be linked to another, etc.). This can be used to link 
various combinations of HyperButtons together, giving the user unprecedented 
power. HyperButtons can be linked to one another by clicking on the Option 
button in the dialog box of the HyperButton you are creating and selecting the 
name of the button you want to link to in the Link Button box.

As a result, this linking feature can be used to link screens together, and create a 
self-running application. This is done by linking a series of Goto HyperButtons 
together. You can also create a Sound HyperButton that is linked to a Goto 
HyperButton. When this button is clicked on, a sound file plays and then the new
screen appears. For example, you may want a short sound file to play (i.e. a beep
or gong sound) every time a button is pushed. 

To view a good example of how linking HyperButtons can work, open the 
AMIDEMO file and go to Folder1 Screen 4. Use the attributes tool and click on 
the Applications button and click on the Options button. This displays the 
attributes of the Applications button. Notice that the Applications button is 
linked to the GotoAppAreas button, which is linked to the Play Music button. 
When the application is previewed, the only button that is visible is the 
Application button, but when the user clicks on the Applications button, a sound 
file plays, you go to another screen and then another sound file plays. Because 
the buttons are all linked together, this all happens automatically by clicking on 
one button.

Note: In many cases you may want to link to invisible button. This way the user 
does not see the linked button. This gives the effect that multiple things are 
happening when the user clicks on a single button. In reality, multiple buttons 
are being activated, but the user only notices the one button that they click on.
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„To link HyperButtons:

1. Create your HyperButton as you normally would.

2. Click on the Options button.

3. Click on the down arrow to the right of the Link Button option and 
select the button you want to link to.
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Incorporating Database Features
Multimedia Studio provides you with the ability to incorporate powerful database features into 
your applications. These features are accessed from the View menu and give you the ability to 
sort and search through your files.

The following section shows you how to:

Use the commands in the View menu...........161
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View Menu

The View menu is where you have access to the database features within 
Multimedia Studio. These features provide you with the ability to "view" your 
files by customizable Search, Sort, and Table Criterion. The options within the 
View menu allow you to create, save, and execute these multiple custom Search, 
Sort, and Table criteria. 



Chapter Example

In order to better understand the database features within Multimedia Studio, 
throughout this chapter we refer to a real world example that most of us can 
relate to - a multimedia real-estate database. An overview of the application is 
shown below. Each folder represents an individual house, and contains three 
associated screens of information pertaining to the house. Further details about 
the application is discussed as you proceed through the chapter. 
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Database Overview

About the Unlike other authoring products that merely interface 
Database with external databases, the database within Multimedia Studio is actually an 

integrated database engine. The database is dBASE III+ compatible, so its files 
are saved to a standard .dbf file format that is compatible with many of the 
popular databases in use today. The database is flat, not relational. 

Size When incorporating database features into your multimedia application, there
Constraints are size limitations that you may want to consider (although it is very unlikely 

that any of these limits will affect your application). 

First, you can have an unlimited number of folders (i.e. database records) within 
an application. Many complex applications can have up to tens or hundreds of 
thousands of folders. It is important to note, however, that the speed of the 
database is proportional to the number of folders within the application.

Within a folder (i.e., your database "record"), you may want to have more than 
one screen associated with that folder. For example, in our real-estate example, 
you would want to create a new folder for each house. For each house, however, 
you may want to be able to access a total of 10 screens with information, 
pictures, and video pertaining to that house. These 10 screens are the screens 
"associated" with that folder. In Multimedia Studio, you can have up to 99 
associated screens within a folder.



Integrating Database Features

In order to incorporate database features into your application, you need to use 
data fields. Data fields are used to store database searchable text and numeric 
information such as names, part numbers, dates, prices, etc. Therefore, when you
create a database, the first step is to create data fields for every type of 
information that you want to search on, sort by, or create a table with. To create 
a data field, select Data Field from the Objects menu.

In our real-estate application, you may want to create several data fields, such as 
"Price", "City", "# of Bedrooms", "# of Baths", and more. The result may be the 
screen shown below.
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Keep in mind that data fields are automatically global objects. As such, they 
automatically appear on the same screen in every folder of your application. This
is very helpful, in that it automatically creates a template for your database. You 
don't need to manually add these data fields for each new folder.

In order to effectively use data fields, you only need to create them on one screen
within a given folder, because Multimedia Studio searches for entire folders 
rather than individual screens (however, if you like, you can create data fields on 
multiple screens). 



Dialog Box

The functions found in the View menu utilize a common dialog box during the 
creation or selection of search, sort, and table criteria. The dialog box has the 
following buttons: OK, Cancel, Add, Modify, Delete and Rename. 

OK The OK option automatically executes the highlighted selection, whether it is a 
search, sort, or table criteria. The selection can also be started by double clicking 
the left mouse button.

Cancel The Cancel button cancels the operation and return you back to the current 
screen of the current folder. 

Add The Add button allows you to add a new table, search, or sort criteria. 

Modify The Modify button allows you to make changes to saved criteria. To modify 
criteria, highlight the desired selection and click on the Modify button. The 
saved criteria appears. Make your desired changes and select the Save button to 
save the new changes.
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Delete To Delete a saved criteria, highlight the desired criteria and select the Delete key.
A warning message appears prompting you to Proceed with deleting the criteria 
or to Cancel the operation.

Rename To Rename a saved criteria, select the Rename button and enter the new criteria 
name. Press the Enter key or select the Save button.

By Search 

Sometimes you may want to retrieve only certain folders with fields that contain 
specific text information in data fields. For example, you may want to select only
folders from a real-estate application which includes houses with four bedrooms, 
three baths, and a pool. The searching function within Multimedia Studio is 
much like that within a standard database. After you perform a search, you have 
set a filter so that only those folders that meet the search criteria are available. 
All folders can again become available by using the Clear Search option.

„To search for records using the By Search command:

1. After creating your data fields, select By Search from the View menu.

2. Click on the Add button. 

3. In the dialog box that appears type a name for the search and click OK. 
When entering name, it is useful to use a name that is descriptive of 
the search criteria. For example, if you are going to be searching for 
all records that have a number less than 175,000 in the amount field, 
you may want to call your search “Less than 175k”.



4. In the appropriate field, type the record you want to search for. For 
example, if you want to search for all houses that have 4 Bedrooms, 
you would enter a 4 in the Bedrooms field. You can also use 
operators (i.e. <, >, =) to create your search criteria. These operators 
are described in detail later in these chapter. If you want to search for
all houses that have less than 4 bedrooms, you would enter <4 in the 
Bedrooms field. If you want to search for all houses that have 4 
bedrooms and 3 baths, you would enter 4 in the Bedrooms field and 
3 in the Baths field.

5. Click on the OK button after you enter all of the search criteria you want
to use. A message appears telling you how many records meet your 
search criteria. Click OK. 

6. The screen containing the first record that matched your criteria is 
displayed. You can now browse through all of the records that match 
your criteria using the Next Folder arrow. To clear the search criteria you
just made, select Clear Search from the View menu. 

Selecting a Saved Search Criteria

�To search for records using an existing search criteria:

1. From the View menu, select By Search.
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2. To execute a saved criteria, highlight the desired search criteria and 
double click the mouse button, or press the OK button. 

3. You are prompted with the number of matches that meet your criteria 
and are asked to proceed with viewing the matched folders. 

By Table

Multimedia Studio lets you view the records in your application in a table. When
using a table to view your records, your records are displayed in rows, and the 
fields are displayed in columns. After your records are displayed in a table, you 
can scroll through your records and then double click on the record of your 
choice. This displays the screen that contains the data on that record. Creating a 
table is similar to creating the criteria when using the By Search option. The only
difference is that the By Search option allows you to specify a specific search 
criteria for the records you want to display and the By Table option displays all 
of the records in your application.

Note: When creating a table, you can specify the order of the columns and which
fields are in the table. If you do not 

„To display your records in a table:

1. After creating your data fields, select By Table from the View menu.



2. Click on the Add button. 

3. In the dialog box that appears type a name for the search and click OK. 
When entering name, it is useful to use a name that is descriptive of 
the search criteria.

4. From this screen, you can determine which fields are going to be in your
table and in which order they are going to appear. This is done by 
entering a number in the field you want to include in your table. The 
order of the number determines how the fields are displayed in the 
table. For example, if you have 5 fields called “First Name”, “Last 
Name”, “Amount”, “Address” and “Date” on each screen, but only 
want to display “Last Name” and “Date” in the table, you would 
enter a 1 in the “Last Name” field and a 2 in the “Date” field. This 
would create a table with two columns, the first being “Last Name” 
and the second being “Date”. If you wanted “Date” to be the first 
column, you would enter a 1 in the “Date” field and a 2 in the “Last 
Name” field. You can have as many columns as you like in your 



Application Menu

table. The numbering determines the order of the columns in the 
table. If you do not enter a number in a field, it is not included in the
table.

Note: If a column in your table is too long, you can determine the width of the 
column when you enter the criteria. This is done by adding a comma and then 
the width of the column. For example, if you have a field that contains 35 
characters, you can enter 4,10 in the field and only the column for that field will 
only be 10 characters wide.

5. After you enter all of the numbers in the fields you want to use, click on 
the OK button.

6. A table appears containing all of the records that meet your criteria. 

7. Double click on the record your want to display. The screen containing 
the record you double clicked on is displayed. 

„To view records in a table using an pre-existing table format:

1. From the View menu, select By Table. Highlight the desired table 
criteria and select OK. The table appears with only those folders which 
meet the defined search criteria.



2. To directly go to a specific folder, highlight the folder and double click 
the left mouse button or click on the OK button.
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Boolean Multimedia Studio also provides the following
Search Boolean search operators to expand the power of your 
Operators searching capabilities. The following shows examples of the use of Boolean 

operators in a real-estate Application.

                                                            Examples

Operator         Description                 Numeric Character              

      <            Less than <$150,000 <Irvine
      <=  Less than or equal to <=$150,000 <=Anaheim
      > Greater than >$100,000 >Anaheim
      >= Greater than or equal to >=$150,000 >=Mesa
     <> Not equal to <>$250,000 <>Tustin
      ; OR $1,000;$2,000 Tustin;Irvine
      : Range (low to high) $1,000:$2,000 Mesa:Reed 
       .. Sub-String Search ..25 or 34.. New..

* Operator must always proceed search value.

(<,<=,>,>=) Operators

To find all folders with price values less than $150,000, you would enter 
<$150,000 in the Price field and select Proceed to begin your search. 

When used with character data, the "less than" operator, for example, can be 
used to retrieve all the houses located in cities that are "less than" Los Angeles, 
in alphabetical order, such as La Palma or Buena Park. To use this search, you 
would enter <Los Angeles in the City field and press Proceed to begin the 
search. The other four operators {=, >, >=, <>} work similarly.



"OR" Operator

If, for example, you want to find all the homes located in the city of Tustin or 
Irvine, you would use the "OR" (";") operator. For the above example, you 
would type “Tustin;Irvine” into the City field and select Proceed to begin your 
search. You may also expand your search to include Anaheim by typing 
“Tustin;Irvine;Anaheim” into the City field.

For numeric data fields, the "OR" (";" ) operator acts similarly. To find folders 
with numeric values for a price field of $150,000, $125,000 or $75,000, you 
would enter $150,000;$125,000;$75,000 in the price field and select Proceed. 
Multimedia Studio would then find all file folders which meet this search 
criteria.

Range Operator

The range operator (":") is used to find a subset of folders within your file that is 
defined by a lower limit and a sequentially higher upper limit.

For example, to find the homes with a price range between $140,000 and 
$250,000 you would type $140,000:$250,000 into the price field and select 
Proceed to begin your search. To find all cities within the range of Apple Valley
and Indigo, enter Apple Valley:Indigo in the City field and select Proceed to 
begin the search.

The Subset Operator

To search for data that is a subset of your data field, you would use the "Subset" 
operator (".."). For example, to find all the cities with York in their name, enter
..York in the City field and select Proceed to begin your search. Multimedia 
Studio finds all folders which include the character string York in the City field. 
The Subset operator can also proceed a string. For example, to search for a field's
value which starts with the letters New, you would enter New.. into the field. 
The Subset operator acts similarly with numeric data. 
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By Sort

In addition to retrieving only certain records, you may also want to sort your 
records based on specific criteria. For example, you may want to sort all your file
folders alphabetically by first name, or listed alphabetically by city.

�To set a new sort criteria:

1. From the View menu, select By Sort. 

2. Click on the Add button and enter the name of your new sort criteria.

3. The current screen repaints, leaving all of the Data Fields empty. You 
can enter the sorting order by entering number into the Data Fields. For 
example, if you want to sort first by price, then by # of bedrooms, and 
the # of baths, you would enter a "1" in the price Data Field, a "2" in the 
# of bedrooms Data Field, and a "3" in the # of baths Data Field.

4. To begin your new sort criteria, click Proceed on the bottom of the 
screen.



�To select a saved Sort Criteria:

1. From the View menu, select By Sort. The Sort Order dialog box 
appears.

2. Highlight the desired sort criteria and double click the left mouse button 
or press the OK button to begin the sort.

Note: The selected sort criteria works in conjunction with a search criteria if 
one is selected, allowing you to also sort your matched folders.
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Viewing Sort Criteria by Table Format

To view your newly sorted folders in a table format, select By Table from the 
View menu and select the desired saved Table Format or select Add to create a 
new one.

Table The Table option allows you to create and save customized table criterion which 
change folder viewing from one folder at a time to viewing multiple folders in a 
customizable columnar format based upon specified data field values. 

�To view your data in a table format:

1. From the View menu, select By Table.

2. Highlight the saved table criteria you want, and double click the left 
mouse button, or press the OK button to execute the table format.

3. The folders specified by your table criteria appear. To select a particular 
folder, highlight the desired folder and double click the mouse button, or
select the OK button to immediately go to that folder. 

Note: If a sort or search criteria is active, the table only displays folders 
meeting the active search criteria, sorted by the current sort criteria. To reset 
the view of file folders to all folders, select Clear Search and Clear Sort 
from the View menu and reselect the table criteria.



 �To define a new table criteria:

1. From the View menu, select By Table.

2. Click on the Add button and enter a Table name.

3. To define the column headings for your new table criteria, highlight the 
desired fields and enter the appropriate column numbers you want the 
fields to be displayed in. 

4. To display a table criteria, highlight the desired criteria and double click 
the left mouse button, or press OK. 

5. After the table is displayed, you may go to a specific folder by 
highlighting the desired folder and double clicking the left mouse button 
or by selecting the OK button. To exit the table and return to the current 
folder, select the Cancel button.
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Shortening Field Lengths

When setting a table criteria you may shorten the length of the table columns to 
display more fields on the screen simultaneously. To shorten a field length and 
maximize the number of fields you can view in your table, enter the number of 
the column you want the field to display followed by a comma (,) and the 
number of spaces you want to display. 

For example, a field which is in the second column of the table and has a length 
of 20 characters, can be shortened to say 15 characters by typing 2,15 in the 
field. When viewed, the field displays the first 15 characters of the field. 

Clear Search

The Clear Search option under the View menu is used to end the current search 
criteria and resets the viewing of the file folders to include all folders.

Clear Sort

The Clear Sort option allows you to clear the current sort criteria back to its 
default.

Clear All

The Clear All option allows you to simultaneously clear both a Sort and Search 
criteria, resetting the viewing to all folders in your file.
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Troubleshooting
The following section gives some solutions to problems you might encounter while using 
Multimedia Studio:

Message "Invalid Personal.vi" appears

 Check that your Multimedia Studio disks are not write protected. Multimedia 
Studio needs to write to your disks during the installation procedure.

Fade and Wipe effects are not working

 You are not in the preview or runtime modes. Select the Application Preview 
section.

Software locks up
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  You do not have sufficient conventional memory for Multimedia Studio to 
run. Remove various device drivers to free up at least 520k for Multimedia 
Studio

 You are almost out of hard disk space. In this case, simply free up space on 
your hard drive.



CD-ROM Setup Program

Menus and/or Dialog Boxes do not erase when they should

 Check hard disk space. Multimedia Studio requires at least 2 MegaBytes free 
space on your hard drive.

 Check the number of files in your CONFIG.SYS file. Multimedia Studio 
requires at least 30 files. 

Sound Problems:

When you test a sound button, you hear no sound

 Check the Control Panel to see if your sound drivers are properly setup. 

When you try to record, "recording" does not appear on the status bar

 You need to enter the name of a sound file, complete with a  .WAV,  
extension.

Sound stops playing or recording in the middle of a file

 You may be recording at too high of a sampling rate for your computer to 
keep up. Try recording at a lower sampling rate.

 Your files may be fragmented. Try running a disk optimization program (i.e. 
Norton Utilities, Optune, etc.)

 Record your files to a RAM drive. 



Video Capture Problems:

When you select Image Capture, the screen goes black or blue

 You are not getting a video signal. Check all of the connections,. and make 
sure that you have a "Video in" signal going into your video capture board. 

 If you are in the hi color mode, make sure that your Video Overlay board is 
compatible with your hi color board.

"Capture" is not a selectable option under the Image Menu

 The proper device has not been selected in the setup.

 The hardware is not functioning correctly. Test the capture board using the 
software that came with the video board.

After selecting <Enter>, the capture process does not complete successfully

 Make sure that you have at least 2 MegaBytes of hard disk space free.
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Import Image Problems:

After selecting an image to import, the importation process does not complete 
successfully

 Make sure that you have at least 2 MegaBytes of hard disk space free.

Images come in with a slight blur

 You may be scaling your images up in size, which tends to reduce the quality.
Check that the original image size is equal to or smaller than the size of the 
Image Field. You can determine the information on a particular Image Field 
by selecting "Show Name" from the Image Menu, and then using the <right 
arrow> to pan over to the image height and width information. 



Database Problems

After selecting Edit Data, you cannot enter data into Data Fields

 Select the "Try It" tool from the toolbox. 
 

When search or sorting based on numeric criteria, result is incorrect

 Make sure that defined the Data Fields as "numeric" rather than "character". 
To do this check, select the "Change Attributes" tool from the toolbox, and 
then click on the Data Field.
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Presentations

Corporate presentations can vary tremendously among different customers.  A 
presentation may be used by a sales person on the road, as a product demo to be 
sent to potential customers, or in a standard boardroom setting.  In each case, 
multimedia has a great deal of promise - if used correctly.

Don't Forget With all of the excitement and pizzazz that comes with 
the multimedia, it is easy to get so caught up in the flash, that the substance of the 
Substance presentation gets lost behind an "overdose" of multimedia.  Be careful with your 

use of multimedia in applications.  Use it as it has been shown to be most 
productive, to help retain key points, peak interest in the subject matter, and 
leave the audience with the impression that the presenter and his/her company is 
on the cutting edge.

Use Hi Color In an application, you want the final product to have a clean, professional, 
polished look.  After all, the application is going to be a reflection of the 
product(s), service(s), and/or company that it presents.  The benefits of 
incorporating hi color into an application easily outweigh the costs involved with
the extra hardware.  Not only will a hi color board allow you to display still 
images in over 32,000 colors, it will also allow you to display hi color 
background images and 3D image HyperButtons.  The result of this alone will be
screens that attract and retain the attention of even the most discriminating of 
audiences.



Fade in Make sure to use the fade object tool, which allows you to fade in any 
Objects individual object on a screen after an elapsed period of time. With this tool, you 

can fade in bullet points, charts, etc. As a result, the application can better follow
the flow of a traditional application, where bits of information can be given in a 
timed, linear manner.  In addition, by continuously having objects fade in and 
out of a screen, the audience's attention will be retained as moving objects will 
constantly grab their attention.

Distribute or Before you create an application, it is important to 
not? consider whether you will be creating an application which will reside on only a 

few internal hard drives, or if you want to distribute the application on floppy 
disc.  Obviously, if you are going to distribute on floppy discs, you will face 
many limitations.

First, you want to minimize the size of the application, thus reducing the number
of floppy discs distributed, and reducing the amount of hard disk space required 
by the user to load the application.  To reduce the size, save your images to PCX
or JPEG format, make your images less that full screen, and minimize the 
number of total screens within the application.

Next, it is essential that you consider the minimal hardware that the audience that
you will distribute the application to have, and plan the development of the 
application accordingly.  In particular, there are typically three hardware areas 
where you may face limitations: VGA display, video capabilities, and sound 
hardware.  In each case, you face tradeoffs - you want to be able to reach the 
widest possible audience, but at the same time you want to utilize as much of the
power of multimedia as possible.

VGA display  In order to reach the widest possible audience, you  
should develop your application in 16 colors, in order to reach anyone 
with a VGA monitor.    Developing an application in more than 16 
colors (4 bit) is risky, unless you have a very specialized audience that 
you know will have higher than 4 bit display capabilities.

Video capabilities  If you are considering incorporating video into your 
application, it is important that you consider that almost all of your 
audience will not have access to analog video sources or digital video 
decompression boards.  As a result, you should use software only video 
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clips, that do not require any additional hardware by the end user 
(i.e. .AVI and the Intel Smart Video Recorder.  Video can truly add 
excitement to any application, so if you get the opportunity, incorporate 
as much video as possible!

Sound hardware  Sound can really add excitement to an application, 
but not all of your audience will have sound boards. An ideal solution is 
to incorporate sound that enhances an application, but is not necessary 
for a user to get the substance of the application.  For example, you may 
incorporate a lot of background music, sound effects, etc., but not 
necessarily dialog which is key to the application.

 



Interactive Education and Computer Based Training

The terms Interactive Education and CBT can refer to a wide variety of 
multimedia applications, each having very specific requirements.  However, 
there are tips that can help make any Interactive Education or CBT application 
more successful.

Use Maximum The main reason to use multimedia in educational and 
Multimedia andtraining applications is to improve attention span and 
Interactivity retention rates.  When a person is taught something in a verbal manner, retention 

rates are less than 25%.  When visuals are added, this number is 45%.  When 
video, animation, photographic images, and sound are added, attention and 
retention rates increase by 70%.  Finally, when interactivity is introduced,  
retention and attention approach 100%.

What does this mean?  It means that interactivity and multimedia are key to the 
success of the application, so you need to ensure that both are heavily integrated 
into the application.  Avoid the temptation to have purely self-running 
applications.  Use a little creativity to incorporate as much interactivity as 
possible - it will ensure that you have the user's attention!
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Multimedia Databases

Multimedia databases are typically more straightforward and less flashy than 
most multimedia applications.  However, there still are a couple of tips that you 
may want to consider in the creation of your multimedia database.

Minimize The natural instinct when creating any database is to create as many
Data Fields possible searchable data fields to include both information that you want to 

search upon, and also to contain information associated with that record.  If you 
overload Multimedia Studio's database with Data Fields, you must keep in mind 
that this will severely slow down the speed at which an individual screen will be 
painted.

Therefore, you should limit the number of Data Fields that you create on a screen
to the number of characteristics that you would actually want to search or sort 
on.  Add supplementary information in the form of text objects, windows, and 
even images.



Use Do not limit yourself to the idea of one screen per 
Associated database record.  Within Multimedia Studio, you can have up to 99 
Screens associated screens for a give record (i.e., within a given folder).  This means that 

you do not need to force all of the information for a record onto one screen.  By 
using multiple screens for each record, you can create cleaner, less cluttered 
screen designs, and often times convey much more information.

Report-ready Often, database applications incorporate report generating capabilities.
Screen Even though Multimedia Studio has report generating capabilities, 
Design forethought in the design of your database screen can eliminate the need to 

generate reports in the traditional, textual manner.

In particular, the easiest way to create a report is to design your screen so that it 
looks like a report that you would want to print out.  Typically, this means that 
you would place Data Fields on the screen that contain the information desired 
on the report.  You can then also add an associated image to the screen, etc.

With the screen laid out as you like it and you have completed a search or a sort, 
you can then simply print the screen to the printer - no need to use the report 
generating features.
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Multimedia Clipart
Your Multimedia Studio CD ROM contains over 500 megabytes of multimedia 
clipart files. These files can be used royalty free in any of the applications you 
create with the Multimedia Studio and they can be edited or used with any of 
your other graphics tools. The files on the CD can be opened directly off the CD 
or they can be copied to your hard disk and accessed from there. The following 
table details the directories containing the clipart files.

This directory: Contains:
F:\SAMPLES\ALBUM Catalogs which contain thumbnails of 

different groups of files. These files 
can be opened in the ALBUM 
program.

F:\SAMPLES\AVI Video files in .AVI format.

F:\SAMPLES\BMP Graphics in .BMP format.

F:\SAMPLES\MID Sound files in MIDI format.

F:\SAMPLES\MORPH Morph files that can be opened in the 
Morph Editor.

F:\SAMPLES\TIF Graphics in .TIF format.

F:\SAMPLES\WAV Sound files in .WAV format.

F:\SAMPLES\WMF Vector graphics in .WMF format.
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Glossary

Analog Video Video requiring hardware for playback (i.e. VCR). Stored in a linear
format on tape.

Applications A collection of screens from a file that have been organized into 
specific order which, when mastered, can be distributed to your 
audience. After the screens have been created, you may "Preview" 
the application to test its operation. After you are satisfied with the 
application, you can now "Master" it for distribution. 

Browse Button

Digital Video Video requiring software for playback. Can be stored in a binary 
format on a hard disk. This type of video uses some type of video 
compression.

Fields In Multimedia Studio, there are two types of Object fields: Data 
fields and Image Fields. Data fields store text information such as 
names, prices, dates, and numbers. Image fields are used to define 
the area on the screen where you want an image or graphic to be 
displayed. Image fields can be any size and placed anywhere within 
a screen work area. Up to 16 image fields can be placed on a single 
screen allowing for multiple images per screen. 

File Layout The structure in which Multimedia Studio screens are organized 
within a file can be summarized in terms of columns (up and down) 
and rows (left and right). When a new screen is added in Multimedia
Studio, it will be added to the bottom of the first column (in 
Multimedia Studio terms, the new screen will be added at the 
bottom of the first "folder"). For most applications, each new screen
will typically be added to the end of the first folder. 

Files Files organize and store the individual screens of your Applications.
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In Multimedia Studio, you can create an unlimited number of files 
which can contain an unlimited number of screens.

Folders The "columns" within a file are called Folders, and are used to 
organize associated screens together for database applications. For 
applications emphasizing database capabilities, each folder is 
designed to be a unique record. For example, in a real-estate 
application, each house might have its own folder consisting of 
several screens per house. Or, in a product catalog, each part might 
have its own folder.

Global Refers to objects that appear on the same screen, in every folder 
throughout a file.

HyperButtons HyperButtons are Multimedia Studio's unique approach to 
incorporating interactivity into an application. Through the use of 
HyperButtons, even the most novice computer user can design 
sophisticated multimedia applications. Experienced computer users 
will find that HyperButtons provide unprecedented flexibility and 
speed for incorporating laborious programming tasks with simple to 
define HyperButtons.

Master The Master option allows you to copy or "master" your applications 
so that they can be distributed to your audience. Mastering an 
application is similar to mastering a record album. After the 
application has been mastered, changes can be made only by 
changing the original application and re-mastering it.

Objects In Multimedia Studio, there are several types of Objects which can 
be used to design the Layout of your application screens. These 
Objects include Data and Image Fields, Video Windows, Text, 
Circles, Boxes, Animation Windows and HyperButtons. 

Preview The Preview function allows you to see the application as the user 
of a runtime would. In other words, the menus are taken away, the 
opening screen appears, and you can then only interact with the 
program by selecting the HyperButtons that are on your screens. 
Previewing an application is very important, because it allows you 
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to test the links that make up your application before mastering and 
distributing your application.

Runtime The mastered copy of an application is called a runtime. A runtime 
contains the files needed to allow a person who does not have their 
own copy of Multimedia Studio to load the application that you 
created on their computer. The user of a runtime version will 
interact with an application in the same way that you would during 
the application preview mode.

Screen Layout Within Multimedia Studio, a Screen's Layout refers to the design of 
a particular screen, i.e. the placement of all objects on that screen. A
Screen's Layout can be changed by adding objects and using various
editing tools.

Screens Screens are the individual "slides" that make up an application. A 
screen is defined as the area between the menu and status bars, and 
is also referred to as the "work area". 

Variable Text Database searchable data within a data field.

Windows Windows are user-definable boxes that specify an area of the screen 
in which certain types of information will be displayed. There are 
three types of Windows available within Multimedia Studio, 
including Animation Windows, AVI/MPEG Windows and Live 
Video Windows.
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Index

—3—
3-D effects, 105

—A—
Add

Color, 79
Folder, 43
Screens, 30

Add Folder, 97
Add Screen, 30
Album, 21
Album Files, 192
All Screens, 23
AMI Demo, 52
Ani Window, 49
Animate

Objects, 83
Speed, 84

Animation. see HyperButtons - Animation
full screen, 146
Last Frame, 148
Loops, 49
Resolution, 123
Testing, 147
Within a window, 122

Animation Button, 48
Create, 146

Animation Window, 48, 147, 148
Create, 122

Animator
Autodesk, 147

Answer, 135
Application

Building, 25
Exit, 149

linking screens, 152
Master, 51, 193
New, 25
Overview, 193
Preview, 24, 65, 193
self-running, 157

arrow, 7, 8
Buttons, 24

Attribute, 73
Attributes, 29, 50
Auto Naming, 128

Changing To, 128
Auto Show, 126
Autodesk Animator, 147
Automated

HyperButtons, 155
Kiosks, 155

AVI, 37

—B—
Background, 26

Changing, 26
Create, 102
Default, 25

Backgrounds
TGA, 103

Backup Copies, 10
Bitmap Files, 192
Bitmaps

On buttons, 75
Blue, 79
Bluegrad, 26
BMP Files, 192
Bookmark, 154
Box, 36, 110

Add, 110
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Change Color, 79
Icon, 110

Boxes
Edit, 74

Branching, 152
Brightness

Color, 79
Bullet points, 81
Bullets, 155

Animate, 83
Button

Scaling Image For, 137
Button Image, 75, 136
Button Name, 31, 41
Buttons, 133

Aligning, 32
Animate, 83
Invisible, 46, 155
Linking, 50
Move, 32
Sizing, 32

—C—
Capture

Not Working, 183
Path, 132

Capture Board, 14
Capture Image, 129
CBT, 189
CD Browser, 21
CD ROM, 51, 192
Change. see Attribute
Check Mark, 68
Circle

Change Color, 79
Circle Icon, 111
Circles, 111

Edit, 74
Clear

Box, 110

Button, 138
Circle, 111

Clear All, 178
Clear HyperButtons, 138
Clear Sort, 178
Clickable, 138
Clicking, 8
Clipart, 192
Close, 60

File, 59
Color, 37

Add, 79
Create, 78, 79
Customize, 79

Color Palette
Create, 79

Color Tool, 77
Colors

Change, 28
Image, 125
Number, 125
Universal Palette, 132

Column
Snap to, 86

Command Line, 12, 13
compression

video. see MPEG
Conditional Branching, 152
Content, 192
Control Box, 18
Control Panel, 14
Converting

DOS to Windows, 59
Coordinate Position

image, 127
Copy, 72

Objects, 31, 73
CPU, 6
Create

Color, 79
Crop, 130
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Customize
Color, 79

—D—
Data

Editing Data, 69
Search, 173

Data Field, 56
Add, 113
Change Color, 79
Edit, 73
Font, 114

Data Fields, 69, 113, 163, 190, 193
Database, 160, 190

Overview, 162
Problems, 185
Reports, 191
Search

see Search, 166
Size Constraints, 162
structure of, 56, 162
Template, 164
Using Data Fields, 163

Database Features
Integrating, 163

dBASE, 162
Default Settings, 126
Delete, 77

File, 61
Folder, 99
Image, 127
Object, 33
Screen, 96

Destination Folder, 41
Destination Screen, 41
Device Drivers, 140
Devices, 14
digital video. see MPEG
Digital Video boards, 14
Directory

Images, 132

Display Card, 6
Display Effect

Animate, 83
Display Effect tool, 81
Display Effects, 44
Display Name, 139
Distribute, 4, 187
Document Window, 195
DOS Version, 59
DOS2WIN, 59
Double Clicking, 8
Dragging, 8
Drivers, 14

—E—
Edit

Attribute. see Attribute
Change. see Attribute
Copy. see Copy
Delete. see Delete
Display Effect, 81
Move. see Move
Objects, 29
Resize. see Resize

Edit Data
Turning Off, 69

Edit Menu, 68
Education, 4, 189

Interactive, 189
Effect

Animate, 83
Effects, 44
Exit, 25, 60, 67

Runtime, 149
External

Data Fields, 114

—F—
Fade
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Effect, 82, 84
Screens, 31, 153
Time, 82, 83

Fade Effect, 27
Fade to Black, 132
Fading

Objects, 44
Fading Objects, 81, 187
Field Lengths

Shorten, 178
Fields, 112

Data, 113
File, 54

Exit, 67
navigation within, 100
New, 58
Open, 59
Save, 60

File Layout, 55
File Menu, 54
File Name, 20
FILE1, 25
FLC, 48
FLI, 48, 147
Folder, 20, 55, 154

Adding, 43
Folder Indicators, 23
Folder Name, 20
Folder Status, 20
Folders, 162
Font, 27, 108
Framed

Box, 110
Image Field, 116

—G—
GIF, 109, 130
Global, 45, 74, 106, 112. see Objects: 

Global. see Objects: Global
Goto, 93

HyperButton, 139
Goto Buttons, 30
Goto HyperButton, 41, 152
GoTo Jump

Absolute, 154
Relative, 154

Graphic Files, 192
Graphics

Palette, 132
Green, 79
Grid, 85
Grids, 32
Guides, 85

Off, 86

—H—
Highlighting, 8
Hot keys, 16
Hot Spot

Invisible, 107
Hotspot, 36
hourglass, 7
Hue, 79
HyperButton

3D, 136
Animation, 123
Clear, 138
GoTo, 152
Invisible, 138
Resize, 75
Scaling Image For, 137
Solid, 138
Test, 87
TGA, 136

HyperButtons, 89, 133
Animate, 83
Animation, 146
assigning an image to, 136
Clickable, 138
Display Name, 139
Exit, 133, 149
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GoTo, 139, 152
Invisible, 138, 155
linking, 133, 135, 157
Multimedia, 140
overview, 133
Print, 133
Selecting, 10, 139
Sound, 133
Un-Clickable, 139
Video, 133
View, 133

HyperButtons Icon, 89

—I—
I-beam, 7, 8
Icons, 21

Objects, 90
Toolbox, 70
Update, 23, 101

Image
16 Color, 125
256 Color, 125
Auto Show, 126
Capture, 124, 128, 129
Colors, 125
Coordinates of, 127
Cutting Down, 125
Delete, 127
Dimensions of, 127
Hi Color, 125, 186
Import, 34, 124, 128, 130
Options, 132
Print, 62
Scaling for Button, 137
scan, 124, 128
Show name, 126

Image Editor, 21
Image Field, 116, 193

Edit, 73
Framed, 116
Save, 116

Image Fields

Resize, 76
Image Menu, 124
Image Name, 35
Images

Animate, 83
Blurred, 184
Directory, 132
On buttons, 75
Pale XE "Fade to Black"  XE 

"Graphics:Palette" tte, 132
Import

File Types, 130
Image, 34

Import Image, 130
Problems, 184

Importing. see Image: Import
Text, 109

Installation, 12
Interactive. see HyperButtons
Interactive Screen

Building, 36
Interactivity

Importance of, 189
Invalid Personal.vi, 180
Invisible

Button, 138
Buttons, 46
Hot Spot, 107
HyperButton, 107
HyperButtons, 155

Invisible HyperButtons, 138

—J—
JPEG, 128, 130
Jump, 100

Between Screens, 20, 92
Jumps

On images, 107
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—K—
Keys

Arrows, 24
kiosk, 149
Kiosks, 4

Self Running, 155

—L—
laser disc, 118
Layering

Objects, 105
Leave Last Frame, 147, 148
Lesson One, 22
Levels, 105, 139
Licensing Agreement, 6
Link Button, 50
Link Delay

Buttons, 50
Linking, 157

Buttons, 50
HyperButtons, 135
Screens, 1

Linking Screens, 152
Live Video Window, 119
Local, 106. see Objects: Local
Loops

Animation, 49
Lumination, 79

—M—
Maintain Aspect Ratio, 130
Manual

How to Use, 1
Manually Selected Only, 101
Master

Application, 51
Mastering, 1
Maximize, 18

Memory, 6
menu

cancel, 9
Menu Bar, 18
Menu On/Off Icon, 90
Menus

Removing, 24
Microsoft Windows, 22
MIDI Files, 192
Minimize, 18
Morph Editor, 21
Morph Files, 192
Motion board

Optibase, 118
Mouse, 6, 8
Mouse Buttons, 7
Move, 28, 71

Animate, 83
Moving

Objects, 8
MPEG, 120
MPEG/AVI Information

Section, 39
MPEG/AVI Video Window, 37
Multimedia

Definition, 4
Multimedia HyperButtons, 140
Multiple Choice, 135

—N—
Name

File, 20
Show, 126

Naming
Auto, 128

New
Application, 25
File, 58

Norton Utilities, 182
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—O—
Object

Change Color, 77
Delete, 33
Fade, 81
Move, 71

Objects, 104
Animate, 83
Box, 36
Circles. see Circles
Copy, 31, 73
DocumentWindow. see Document Window
Fields, 112
global, 106
HyperButtons. see HyperButtons
levels of, 105
local, 106
Move, 28
Text, 107. see Text
VideoWindows. see Video Windows

Objects Icons, 90
Objects Menu, 104
Open

File, 59
Optibase

Motion Board, 118
Optibase’s PC Motion board, 118
Options, 50, 132
Options Button, 135
Optune, 182
OR

Operator, 173
Order

Screens, 55
Overlay boards, 14
Overview, 92, 100

Screen, 23

—P—
Paint

Screen, 85
Palette

Color, 79
Universal, 132

Patterns
Background, 102

PC Motion board
Optibase, 118

PC-VCR, 118
PCX, 109, 130
Personal.vi

Invalid, 180
PIC, 128
Picture. see Image
Pixels, 86
Play

Button, 147
Pointer, 7
Pointing, 7
Position

Coordinate, 127
Preview, 24, 42, 154
Previewing, 1
Print, 62
Program Manager, 12, 13, 15, 22
Publishing, 4
Purity

Color, 80

—Q—
Quick Jump, 20, 36, 92, 93, 94
Quick Tour, 22
Quit, 67
Quit HyperButton, 149

—R—
Range

Color, 79
Range Operator, 173
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Red, 79
Registering, 6
Registration Card, 6
Relational Databases, 162
Remove

File, 61
Rename

Folder, 98
Repaint

Screen, 85
Repaint Tool, 85
Report

Print, 62
Requirements

System, 6
Resize, 75, 76
Resolution

Animation, 146
Retention

Multimedia's Impact on, 189
ROM, 51
Row

Snap to, 86
Royalty, 4
Run, 12, 13
Runtime, 24, 154

Exit, 149

—S—
Samples, 192
Saturation, 79
save, 60
Scan. see Image: Scan
Screen, 55, 91, 154

Deleting a screen, 96
Fades, 31
Jumping Between, 30
Layout. see Edit - Screen Layout
Overview, 92, 100, 154
Print, 62

Transition effects, 153
Screen Capture, 21
Screen Icons

Update, 34
Screen Menu, 91
Screen Overview, 23
Screen Status, 20
Screens

Add, 30
Moving Between, 36
Order, 55

Scroll Button, 20
Search, 160, 166

adding a new search criteria, 165
Boolean Operators, 172
changing a search criteria, 165
Clear, 178
Clear search, 178
Data, 173
data fields, 113
deleting a search criteria, 165
renaming a search criteria, 166
selecting a search criteria, 167
Viewing by table format, 168

Self Running, 43, 155
Self-Running, 157
Set Sort Criteria, 174
Setup, 12, 13

Drivers, 14
Shadow

Text, 27, 108
Shortcut Icons, 89
Shorten

Field Lengths, 178
Show Image Name, 126
Sigma Designs Reel Magic, 120
Size

Image, 76
Text, 108

Size Constraints, 162
Snap
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To Column, 86
To Row, 86

Snap to Grid, 32
Solid

Box, 110
Button, 138
Circle, 111

Solid HyperButtons, 138
Sort, 160, 174

adding a new sort criteria, 165, 174
changing a sort criteria, 165
Clear sort, 178
data fields, 113
deleting a sort criteria, 165, 166
selecting a sort criteria, 175
Viewing by table format, 176

Sound, 40. see HyperButtons - Sound
playing a sound file, 141, 143
Problems, 182

Sound Editor, 21
Sound Files, 192
Sound HyperButton, 40
Speed

Animation, 49
Starting

Media Master Professional, 15
Startup

Icons, 21
Status

Folder, 20
Screen, 20

Subset Operator, 173
Support, 11
System Requirements, 6

—T—
Table, 160, 168, 176

adding a new table criteria, 165
changing a table criteria, 165
deleting a table criteria, 165, 166
New, 177

Table Format, 176
Technical Support, 11
Test

HyperButton, 87
Testing

Buttons, 39
Text, 36, 107

Add, 107
Animate, 83
Change Color, 79
Creating, 27
Edit, 74
Font, 108
Importing, 109
Multiple Lines, 73
Shadow, 108
Size, 108

Text Field
Resize, 75

Textures, 136
On buttons, 75

TGA, 109, 130
Background, 102

TGA Images
Backgrounds, 103

Thumbnails, 192
TIFF, 109, 130
Time Out, 155
Timing, 155
Title Bar, 18

Removing, 24
Tool Locations, 17
Toolbar, 21
Toolbox, 88

main, 70
Tools Box, 19
Touch Screen, 10
Tour, 22
Training, 189
Transition Effect, 31, 41
Transitional Effects, 154
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Troubleshooting, 11
Try It, 39, 49
Try It tool, 87
TUTOR.STU, 22
Tutorial Example, 22

—U—
Universal Palette, 132
Update Icons, 23, 73, 101
Update Screen Icons, 34
User

Exit, 149
Utilities, 21

—V—
Vector Files, 192
Version

DOS, 59
Video, 37, 38, 118, 120, 143

Live, 119
Video Capture, 21

Problems, 183
Video devices, 14
Video Editor, 21

Video Files, 192
Video for Windows, 13, 37
Video HyperButton, 37
Video Source, 129
Video Window, 37
Video Windows, 195

Live Video Window, 118
MPEG, 120

View
Dialog Box, 162, 165
Screens, 100

View by Icon, 100, 154
View menu, 160
Viewer, 21

—W—
WAV Files, 192
Window Control Box, 18
Windows, 6, 22

Edit, 74
version, 7

Wipes, 153
WMF Files, 192
Work Area, 21
Work Space, 17
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