
Multimedia Studio Tutorial

Introduction

The following tutorial is designed to teach basic Multimedia Studio concepts and use.  It contains 
a series of steps which you will use to build a simple application which demonstrates most of the 
basic objects and capabilities within Multimedia Studio.  This tutorial assumes that you have a 
basic familiarity with Microsoft Windows and it’s operation.  The tutorial should take 1 to 2 hours 
to complete.  It can be completed in several sessions if you save your work when you want to 
stop, and open your file when you resume.  

An example of the finished application resulting from this tutorial has been included so that you 
can get an idea of what you are going to be developing during this tutorial.   

A Quick Tour
Let’s start by reviewing the tutorial example.

1.  From the Program Manager, double click on the ‘Tutorial Example’ icon in the Multimedia 
Studio program group to start Multimedia Studio with the example application loaded.  You 
should see a blue screen titled ‘Main Menu’ with an image in the middle and two buttons near 
the bottom.  There should also be a toolbox in the upper right hand part of the screen.

2.  From the Screen menu, select Update Icons.

3.  Select the All Screens option and the click on the OK button.  This will build an iconic 
representation of each screen that will be used in the ‘Screen Overview’ mode.

 
4.  From the Screen menu, select Overview.  This view shows an iconic representation of all the 

screens within an application.  Multimedia Studio applications are made up of a set of screens 
and folders.  In this case there are three screens and two folders defined, with screen three 
being the only one being used in the second folder.

5.  Click on the OK button to return to the single screen view.  You will notice that the screen and 
folder indicators in the status bars on the right and bottom of the screen tell you that you are 
currently on Screen 1 of 3 and Folder 1 of 2.  The folder name is shown on the right side of the
bottom status bar.  In this case the folder is named ‘FOLDER1’.  

In order to view the application the way it will operate in a ‘runtime’ mode, you can place 
Multimedia Studio in the ‘preview’ mode.    

6.  From the File menu, select Preview.  At this point you can try out this simple example.  Click 
on the ‘Interactive’ button to go to the interactive example screen.  From here you can click on 
the ‘Play Video’ button or the ‘Play Sound’ button.  When you are done here, click on the ‘Main
Menu’ button to return to the main menu screen.  Start the self running portion of the example 
by clicking on the ‘Self Running’ button.  This is an example of a non-interactive segment of an
application which plays repeatedly by itself through the use of button linking (more on this 



later).  Select the ‘Main Menu’ button to return to the Main Menu screen when you are ready.

7.  Hit the Escape key on the keyboard to change from ‘preview’ mode back to ‘authoring’ mode.

The up and down arrow keys on the right status bar or the keyboard can be used to go to the 
next or previous screen.  The left and right buttons on the bottom status bar or the keyboard can 
be used to go to the next or previous folder.

8.  Click on the down arrow button at the bottom of the right status bar.  This will take you to 
screen 2 which in this case is the interactive screen.  Notice that the screen status indicator on
the right status bar shows that you are on screen 2 of 3.  If you click rapidly on the arrow 
buttons you will bypass the intermediate screens and go directly to the selected screens (for 
example if you are on screen 1 and click twice on the down arrow you will move directly from 
screen 1 to screen 3).

9.  From the File menu, select Exit.  This will close the tutorial example and exit you from 
Multimedia Studio.

Building the Application

You will now be taken through the steps required to recreate the tutorial example application.  The
first thing we need to do is to start up Multimedia Studio and open a new file.

1.  Start up Multimedia Studio by double clicking on the ‘Multimedia Studio’ icon in the Multimedia
Studio program group.

2.  From the File menu, select New.  At this point Multimedia Studio will open a new file with the 
default name of FILE1.  The default background color will replace the white Multimedia Studio 
background.

Creating the Main Menu Screen

Changing the Background

1.  From the Screen menu, select Background.  This will bring up the background selection 
screen which consists of 16 standard solid color backgrounds as well as a set of image 
backgrounds if you chose to install them.  If there are more backgrounds than will fit on the 
screen, a scroll bar will be present at the bottom of the screen which will allow you to view the 
entire set of backgrounds.  

2.  Select a background from the available selection.  The background used for the sample is 
‘Bluegrad’.  To select a background you can click on it, which will highlight it in red, and then 
select the OK button, or you can just double click on the background you want.  You may 
select a different background for a screen at any time.

Creating the Text Object

1.  From the Objects menu select Text.  This will bring up the Text Object dialog box where you 
will define the ‘Main Menu’ text object.



2.  Enter the text ‘MAIN MENU’ into the Text field of the dialog box.  

3.  Select a font by either typing the font name or clicking on the ‘...’ button which will bring up a 
standard font selection dialog box.  The font used in the example is Arial with a size of 36.  
The font size can be set directly in the text object dialog box, or from within the font selection 
dialog box.

4.  Select a shadow value of 4 by clicking on the up arrow to the right of the shadow value box.  
The shadow value is the number of pixels on the screen that the shadow is offset by.

5.  Click on the Bold check box to set the font to bold.  This can also be been done in the font 
selection dialog box.

6.  Click on OK.  The text object will be placed in the upper left hand corner of the screen.

Moving Objects

If you look at the toolbox, you will notice that the ‘move’ tool is the currently active tool.  The move
tool is activated automatically after creating a new object.  The move tool is used to position 
objects on the screen.  All objects will initially be positioned near the upper left corner of the 
screen.  

1. Click on the text object with the left mouse button and drag it to a new location near the top 
center of the screen.

Changing Colors

1.  From the Edit menu, select Color.  Notice that the Color tool on the toolbox is now active.  All 
of the tools can be selected from either the edit menu or the ‘Tools’ toolbox.

2.  Now that the color tool is active, click on the text object.  This will bring up the color selection 
dialog box.  Select a color for the text object (the example uses red).

3.  Click on the OK button to complete the color selection.

Changing Attributes

You can use the Attributes tool to edit or change the attributes or properties of objects or 
HyperButtons after they are created.

1.  From the Edit menu, select Attributes.  Notice that the Attributes tool is selected in the 
toolbox.

2.  Click on the ‘MAIN MENU’ text object.  This will bring up the same dialog box that you used to 
define the object initially.  At this point you could change any of the values in the dialog box.

3.  Click on OK or Cancel to close the dialog box.

Adding Additional Screens



When a new Multimedia Studio application is created, it consists of a single screen.  Additional 
screens and folders are manually added to the application as needed.  Since the tutorial example 
requires a total of three screens, you can add the other two screens now.

1.  From the Screen menu, select Add Screen.  This will add a new screen and position you on 
the new screen.

2.  Add another screen so you are on screen 3 of 3.

3.  Position yourself back to screen 1 by clicking twice on the up arrow button on the status bar on
the right of the screen, or using the up arrow key on the keyboard.

Creating the Goto Buttons

You will now create two Goto HyperButtons (‘Interactive’ and ‘Self Running’), and place them near
the bottom of the screen.  Goto HyperButtons are used to jump from one screen to another.

1.  From the HyperButtons menu, select Goto.  This will bring up the goto button dialog box.

2.  Enter ‘Interactive’ in the Button Name field.  This is the name that will appear on the button 
when it is created.

3.  Select a font and size for the button name (the example uses Arial size 12).

4.  In the destination box, click on the down arrow to the right of the screen field.  This will show a
list of the current screens.  Select ‘2’ as the destination screen and leave ‘FOLDER1’ as the 
destination folder.  This defines the destination screen that will be jumped to when the goto 
button is pressed.

5.  Click on the down arrow button to the right of the Transition Effect field and select a 
transition.  The example uses Top to Bottom Thick Shutter. 

6.  Click on the OK button to complete the creation of the goto button.  The button will appear in 
the upper left corner of the screen.

7.  From the Edit menu, select Copy.  Notice that the copy tool is now active in the toolbox.  The 
copy tool is used to make a copy of an object.

8.  Click on the goto button you just created (‘Interactive’) to create a second goto button.

9.  From the Edit menu, select Attributes.

10.  Click on the second ‘Interactive’ button to bring up the dialog box and edit the following 
parameters:

Button Name: Self Running
Destination Folder: FOLDER1
Destination Screen: 3

Transition Effect: None

Moving, Sizing and Aligning the Buttons

You now need to move the Goto HyperButtons to the position on the screen where you want 



them.

1.  From the Edit menu, select Grids.  This is used to control the object alignment grid on the 
screen.  With the grids turned on, objects will ‘snap to’ the grid lines when you move or resize 
them.   

2.  Click on OK in the grid information dialog box.  The gridlines should now be visible.  Notice 
that the grids button on the toolbox is now depressed.  Grids can be turned on and off at any 
time by selecting the grids button on the toolbox..

3.  From the Edit menu, select Move, or select the move tool on the toolbox.

4.  Click and drag the two Goto HyperButtons to position them near the bottom of the screen.

5.  From the Edit menu, select Resize.  Notice that the resize tool is now active on the toolbox.

6.  Resize the buttons to the desired size by clicking and dragging near a corner of the button.

7.  From the Edit menu, select Color or select the color tool on the toolbox. The colors of the 
buttons and the text on the buttons can now be changed by clicking on a button or the text 
within a button.

Deleting an Object

In case you make a mistake during the tutorial and need to delete an object, the delete tool can 
be used to accomplish this.

1.  Use the copy tool to create a copy of one of the goto buttons.

2.  From the Edit menu, select Delete.

3.  Click on the extra goto button that you just created.  A confirmation box will appear to make 
sure that you really want to delete the object.

4.  Click on the OK button.  The object will be deleted.

Importing the Image

Images in Multimedia Studio are imported into objects called ‘Image Fields’.  Image fields define 
the position and size of the image objects.  This method assures optimal performance in 
displaying the images when the application is run.

1.  From the Object menu, select Image Field.

2.  In the Name field enter a name for the image field.  The example uses the name ‘Image Field’

3.  Click on the OK button to create the image field.  The field will appear ‘hashed out’ since it has
not yet been saved.

4.  Move the image field to the center of the screen.

5.  From the File menu, select Save As.



6.  Enter ‘myfile’ as the name to save the file as and select the OK button..

7.  Select OK in the Update Screen Icons dialog box.

8.  From the Image menu, select Import.  Multimedia Studio will verify which image field you 
want to import an image into.  Select the Yes button in the dialog box.

9.  Click on the ‘...’ button to the right of the Image Name field in the Import Image dialog box.  
This will bring up a standard file selection dialog box.

10.  Select ‘vitest.tga’ as the image to import and click on OK.

11.  Select OK in the Import Image dialog box.

Multimedia Studio will scale the image being imported to the size of the image field and save this 
resized copy as a separate file.  At this point, you will be prompted to enter the filename and 
location to save this copy to.

11.  Enter ‘myimage’ in the File Name field of the Save Image File dialog box and click on OK. 

Congratulations!  The main menu screen is now complete.

Building the Interactive Screen

The interactive screen will have a Text Object, a Sound HyperButton,  a Video HyperButton, a 
Framed Box object with a Video Window on top of it, and a Goto HyperButton.  

1.  Position yourself at screen 2.

2.  Select a background for this screen if desired.

3.  Add the text object ‘Interactive’ in the same way you added the ‘Main Menu’ text object to the 
first screen.

4.  From the Objects menu, select Box.

5.  Select the OK button to create the framed box.  This is the default setting for the box object.

6.  Use the color tool to change the color of the frame or the background.

Adding the AVI Video Clip

To play an AVI video file you must create a Video Window to play it in (which defines the position 
and size of the video display), and a Video HyperButton to control the playing of the file.

1.  From the Objects menu, select MPEG/AVI Video Window.

2.  Give the window a name such as ‘AVI Win’ and select AVI as the Video Format.  Click OK to 
create the Video Window object.

3.  Move and size the video window so that it is positioned inside the framed box.



4.  From the HyperButtons menu, select Video.

5.  Give the video button a name such as ‘Play Video’ and assign the font and size you desire.  

6.  Under the MPEG/AVI Information section, use the ‘...’ button to the right of the Source field to
select the file ‘skiers.avi’ from the tutorial\video subdirectory.

7.  In the MPEG/AVI Window field, enter the name you assigned to the MPEG/AVI Video 
Window.

8.  Select OK to create the Video HyperButton.

Testing the AVI Video Clip

HyperButtons can be executed in the authoring mode by using the ‘Try It’ tool.

1.  From the Edit menu, select Try It.  Notice that the Try It tool is now depressed on the toolbox.

2.  Click on the Video HyperButton that you just created.  The video should play in the MPEG/AVI 
Video Window.

Adding the Sound HyperButton

1.  From the HyperButtons menu, select Sound.  The Sound Button dialog box will appear.

2.  Give the Sound Button a name such as ‘Play Sound’ and select a font and size if you wish.

3.  Use the ‘...’ button to the right of the Source field to bring up the file selection dialog box and 
select ‘boing.wav’ from the tutorial\sound subdirectory.

4.  Select OK to create the Sound Button and then move it to the position you want.

5.  You may test the sound button using the ‘Try It’ tool in the same way that you tested the Video 
Button.

Adding the Goto HyperButton

The last thing we need to do on the interactive screen is to add the goto button which will be used
to return to the main menu. 

1.  Create a Goto HyperButton with the following parameters:

Button Name: Main Menu
Destination Folder: <First>
Destination Screen: <First>
Transition Effect: Top to Bottom

2.  From the File menu, select Save.  It is always a good idea to save your work on a regular 



basis.

Previewing Your Work so Far

At this point, you can try out what you have done so far.

1.  Position yourself at screen 1.

2.  From the File menu, select Preview.

3.  Click on the ‘Interactive’ button.  This should take you to your interactive screen where you can
try out your sound and video buttons.

4.  Click on the ‘Main Menu’ button to make sure it takes you back to the main menu.

5.  Exit the ‘preview’ mode by hitting the Escape key on the keyboard.

Building the Self Running Screens

You will now build the self running portion of the example.  This involves two screens which 
execute Goto, Sound and Animation buttons automatically through the process of linking 
HyperButtons together.

Adding the Second Folder

1.  From the Screen menu, select Add Folder.

2.  Select OK in the Enter Folder Name dialog box.  This will create a new folder with the default 
name of ‘FOLDER2’.

3.  Use the arrow keys or buttons to position yourself at Screen 3, Folder 1.

Adding Display Effects to Objects

Display effects are used to cause objects to fade on and off of the screen at predefined times.  In 
this case you will cause the text ‘Self Running’ to fade onto the screen immediately in a left to 
right direction.

1.  Create a text object ‘Self Running’ and place it in the top middle of the screen.

2.  From the Edit menu, select Display Effect.  Notice that the display effect button is now 
depressed on the toolbox.

3.  Click on the ‘Self Running’ text object.  This will cause the Object Display Effect dialog box to 
appear.

4.  Select Left to Right as the fade effect in the appear section.



5.  Set the Fade Speed to 4.

6.  Select OK to set the display effect for the text object.

7.  You may go into preview mode at this point to see how the effect will look.

Adding the Global Goto HyperButton

You will now create a Goto HyperButton that will return to the Main Menu screen from either of 
the two screens in the self running portion of the example.  This will be accomplished by creating 
a ‘global’ button which will appear on screen 3 in both folders.

1.  From the HyperButtons menu, select Goto and set the following parameters:

Button Name: Main
Destination Folder: FOLDER1
Destination Screen: 1

2.  Click on the Options button in the Goto Button dialog box.  This will bring down the options 
portion of the dialog box.  This section is the same for all HyperButtons and is used to set 
properties of texture (solid, clear or invisible), position (local or global), button level (this 
determine which object is on top when objects overlap), whether or not the button is clickable 
by the user, and several other parameters which will be described later.

3.  Select Global in the position section.

4.  Click OK to create the button and then move it to the bottom of the screen and make any size 
or color changes you wish.

5.  Click on the right arrow button or key to move to folder 2.  Notice that the goto button is 
present on both screens.  Click on the left arrow button or key to go back to folder 1.

Adding the Invisible Sound and Goto HyperButtons

Invisible buttons are used to cause events to happen but are not visible on the screen during 
preview or runtime mode.  In authoring mode, invisible buttons are shown as outlines.

1.  From the HyperButtons menu, select Sound and set the following parameters:

Button Name: Sound 1
Source: tutorial\sound\zap.wav

2.  Click on the Options button in the Sound Button dialog box.

3.  Select Invisible in the texture portion of the dialog box.

4.  Click on OK to create the sound button.  Invisible buttons will show up as an outline in the 
authoring mode but will be invisible in the preview and runtime modes.

5.  Create an invisible Goto HyperButton with the following parameters:

Button Name: Goto 3/2
Destination Folder: FOLDER2



Destination Screen: 3

6.  Position yourself on screen 3, folder 2

7.  Create an invisible Sound Button with the following attributes:

Button Name: Sound 2
Source: tutorial\sound\exit_snd.wav

8.  Create an invisible Goto Button with the following attributes:

Button Name: Loop
Destination Folder: FOLDER1
Destination Screen: 3

Adding the Animation Window and Animation HyperButton

Animation buttons work in basically the same way as video buttons.  You create an animation 
window, and then an animation HyperButton which defines which animation to play in the window.

1.  From the Objects menu, select Animation Window.

2.  Give the animation window a name such as ‘Anim Win’

3.  Click on OK to create the animation window.

4.  From the HyperButtons menu, select Animation.

5.  Assign the following values to the animation button:

Button Name: Play Anim
File Name: tutorial\animate\ami_ball.fli
# of Loops: 5
Speed: 5
Ani Window: Anim Win (or whatever name you gave the animation window)
Texture: Invisible

6.  Click on OK to create the animation button and then move, resize and color it as you wish.

7.  You can test the Animation Button by using the ‘Try It’ tool.

Linking the Buttons Together

Now you need to link the buttons together so that they will execute automatically.  In the Options 
section of the HyperButton dialog boxes there are fields called ‘Link Button’ and ‘Link Delay’.  
These fields are used to define the button to be executed next in the sequence, and how long the 
delay should be before it is executed.

1.  From the Edit menu, select Attributes, or select the Attributes tool from the toolbox.

2.  Click on the ‘Sound 2’ button to bring up the Sound Button dialog box



3.  Click on the Options button to open the options section of the dialog box.

4.  Click on the down arrow next to the Link Button field to bring up a list of available buttons to 
link to.

5.  Select the ‘Play Anim’ button.  Leave the Link Delay at 0.0 seconds so that the animation will 
start playing as soon as the sound starts.

6.  Click on OK to effect these changes.

7.  Using the same technique, make the following link button assignments:

Screen Folder Button Link Button Link Delay
3 2 Play Anim Loop 0.0
3 2 Loop Sound 1 0.0
3 1 Sound 1 Goto 3/2 2.0
3 1 Goto 3/2 Sound 2 0.0
1 1 Self Running Sound 1 0.0

The application should now be complete.  You can use the preview mode to test the application 
and make sure all of the buttons and links are working correctly.  Once you are done with that 
step you can ‘Master’ the application to create a standalone runtime version.  You should also 
save your work at this point.

Mastering the Application

1.  From the File menu, select Setup.

2.  Select FOLDER1 and Screen 1 as the starting screen and folder.

3.  Click on OK to complete the setup process.

4.  From the File menu, select Master.  Click on the OK button on the information box which 
appears.

5.  Select a directory to master the application into.  The directory must be empty or not yet exist. 
For this example you can use the default directory.  

The entire application along with all content and support files will be copied into the new directory 
structure.  You may then create a program manager item which runs the application by setting the
command line to ‘viwin.exe myfile’ and the working directory to the appropriate directory.

Congratulations!  You have completed the tutorial!!

Additional Information

For additional information on using Multimedia Studio, you can consult the User’s Manual, the 
Help file and the AMI Demo application.


