
Contents for WinTel-FTP Help
To use this help, click the left mouse button on the colored underlined text or use the tab key to highlight the text 
and press enter. Help is available on following topics: 

FTP connection
FTP Commands
FTP Dialogbox
Viewing GIF/JPEG File
Printing
Session Capture
Disconnecting



Color
You can select color settings for the text and the window background by selecting color command from the settings 
menu    Select the element and then choose the desired color from 16 predefined VGA colors. If these colors do not 
suit your needs then create your own colors with the help of three RGB scroll bars. By changing the red, green and 
the blue component    of a color, any desired color can be achieved. Once you have made your choice, save them by 
clicking the OK button. You may revert back to your original window colors by clicking on the default button. 

Summary of Color controls:

Color Element Listbox:
Here you specify the element whose color you want to modify.
Default
When you click on this button, the window text and the background color would revert back to default colors of the 
window.
Color Boxes
You click here to choose one of the 16 colors for your background and text.
Red, Green and Blue scrollbars
These three scrollbar controls would enable you to customize your color. You change the red, green and blue 
component of a color to obtain a desired color. The color thus obtained is displayed in a rectangle. The RGB values 
are shown to the left of the scrollbars.



Fonts
You can select font command from the settings menu or from communication settings dialog box. A list of all the 
fixed size fonts are shown in listbox. A font is selected by clicking on the desired entry in the listbox. Font size is not
shown as this program adjusts the size of the font based on your window size.



Default Directory
This command can be invoked either from the settings menu or from the communication settings dialog box. Here 
you specify the default directory for the file transfer and your session logs. If    the session log option is enabled then 
the log file would be stored in the directory you specify in the session log edit box. Check the top check box if you 
want your downloaded files to go the current local directory otherwise your downloaded files from the remote 
system will go to the directory specified in the default download directory edit box.



Viewing GIF/JPEG File
 
If you want to view a JPEG file while downloading it, enable the view JPEG realtime option from the utilities menu.
Any file of type JPEG would be displayed on a separate window while being downloaded. 

You can also view stored GIF/JPEG files by selecting view GIF/JPEG offline command from the utilities menu or 
from the toolbar. This would activate a    GIF/JPEG viewer task. By choosing "Open" from the file menu in JPEG 
viewer and selecting file of type JPG, the file can be viewed.    You can resize the picture by selecting stretch/shrink 
command in the File menu. You exit the GIF/JPEG viewer by choosing "Exit" command from the file menu.



Copy to Clipboard
If you want to send the text from the clipboard, first copy the text to the clipboard. This can be done either from 
some other application or from your own screen. You select the text to be copied to the clipboard by pressing on the 
left mouse button and dragging over the text you want copied. Once the text is selected, choose copy command from
the edit menu. Your text will be copied to the clipboard.



Clearing Scroll Buffer
When you receive text from the remote computer, this text is placed in a buffer which can be viewed by using 
vertical scroll bar. If you want to clear this buffer, use the clear buffer command from the Edit menu.



Printing
You can print your session log file by selecting print logfile command from the File menu. You will be asked for the 
file name to be printed. Select the desired file and your file would be printed. You can also print the saved scroll 
back    buffer by selecting print buffer command from the File menu.

Related topic:

Session Capture



Session Capture
Select session capture command from the session menu. You can direct all your incoming data from the remote 
system onto to a file for later viewing and printing. Your session log file name would be the name of the online 
service you are    connected to with log extension. You can stop capturing the session by reselecting the capture 
session command from the session menu.

Related topic:

Printing



Disconnecting
If you want to disconnect from a session, select"Disconnect" command from the session menu or the toolbar 
disconnect button. You may then either exit from the program or ftp to another service. You exit the program by 
selecting Exit command from the File menu or exit button in the toolbar.



FTP Commands
You type in the FTP commands at the ftp prompt after the connection is established. Following is a list of commands
available to you:

dir
This command causes the server to send a detailed file list. You can press control-c to abort this command.
ls
This command causes the server to send a file list and no other information. You can press control-c to abort the list.
pwd                 
This command causes the server to send the current working directory.
cd                       
This command causes the server to change the working directory . The argument to this command specifies the new 
working directory.
mkdir            
Creates a new directory specified by argument to this command
rmdir            
Deletes a directory on the host. The argument specifies the directory.
delete          
Deletes a file. The argument specifies the filename.
cdup               
Changes the default working directory one level up.
rename        
Renames the file specified by the first argument to the name specified by the second argument.
get                       
Downloads the file from the remote. The file name is specified as the first argument. The files are downloaded to the
current local directory if you have enabled this option in def dir dialog box.
put                        
Uploads the file to remote. The file name is specified by the first argument.
ascii                    
Sets the file transfer mode to ASCII.
binary             
Sets the file transfer mode to binary
system           
Causes the server to send information about itself.
user                     
Sends username to remote. The name is specified as the first argument
pass                      
Sends the password to the remote. The password is specified as the first argument.
quit                         
Logs off from the remote

remotehelp 
The server sends the list of available commands.
lcd
Change the local working directory. The local directory is specified as the first argument. 



Related topic
FTP Dialogbox



FTP Client Connection to Remote Host using TCP/IP (SLIP/PPP)

File transfer protocol(FTP) allows you to transfer files from one system to another. It provides you with a list of 
commands to view file listings, make and remove directory, renaming of files and uploading and downloading of 
files. This program (client)allows your computer to talk to the remotehost using TCP/IP protocol. Before you can 
FTP to your host computer, you would require a TCP/IP stack and if you are using your modem to dailin to your 
remote computer, you would need an internet dialer talking SLIP/PPP protocol. If you are running under Windows 
3.1 environment, you would need to get the shareware program Trumpet Winsock. However if you are running 
under Windows 95, it already has a built in TCP/IP stack and an internet dialer. Once you have established a 
connection to internet either using Trumpet Winsock or Windows 95 dialup networking, you are ready to FTP to the 
remote host. 
There are two ways to invoke WinTel-FTP. You can use command line option with the following format:

winftp(32) [Address] [Port]

where winftp(32) is the name of the telnet executable file and the optional fields are the internet address
and the port to which you want to connect.

In the second method, you double click on the FTP icon in WinTel    program group. A FTPbook would open up. You
can create entries to the FTPbook by clicking on the new button. A communication dialog box would appear. You 
type in the FTPbook entry name in the name field and in the address field you type in the internet address of the 
remote host. If for example, you wish to FTP to CompuServe, then the name field, you would enter Compuserve and
in the address field,ftp.compuserve.com.
Once an entry has been made, you can click on the connect button in the FTPbook dialog box. This program would 
then attempt to connect. Make sure your SLIP/PPP connection has already been established. 

Related topic
FTP Dialogbox
FTP Commands 



FTPbook
You open FTPbook either from toolbar or by selecting FTPbook command in the File menu. A list of all    internet 
entries would be shown in the listbox. Here is a summary of all the buttons in the FTPbook:

Cancel
Removes the FTPbook from the display.
Connect
Connects to the selected internet site
New
Adds a new internet site in the FTPbook.
Edit
Edits a selected entry
Delete
Deletes a selected entry from the FTPbook.
Copy
Copies an existing entry to a new entry with a new name and a new internet address 



Copy FTPbook entry to a new entry
This dialog box is invoked from the copy button of the FTP FTPbook settings dialog box. Once you have created an 
entry in the FTPbook, you can copy all the settings to a new entry. Following controls are provided:
Service name
Here you type in your new service name.
Internet Address
Here you specify a new internet site address. 



FTP Setting
 
FTP setting dialog box can be invoked from the FTPbook's edit button. This command allows you to define your 
username, password, internet host address    parameters. Here is a list of options available to you:

Cancel
Removes the box from display
Name
Enter the name of the internet host. Text after the first space or first eight characters is treated as a comment to the 
host name. NOTE:This is not an internet address.
Address
Enter your host internet address.
Username
You type in your username. If you are connecting to anonymous site. Type in anonymous here.
Password
You type in your password for the FTP server only if you wish your password to be saved.    For anonymous FTP 
server, enable the save password option and then enter your email address here. 
Port
You type in the FTP servers port number. If this field is left blank, then the system would figure out the port for you. 
This is usually port 21.
Save Password
If you want your password to be saved for later connection, enable this check box.
Binary
Make sure this checkbox is checked when transferring binary files 



FTP Dialogbox

This dialog box is invoked from the file menu after the connection is established. It allows you to list directories, 
change directory download files in batch mode. If you want to change directory then double click on the directory 
shown in the listbox. Following buttons are available:

Binary
Enable this option when you are downloading or uploading a binary file.
Recover
Enable this option if you want to crash recover the partial file. 
List
Requests the host to send a list of files in the working directory. The file list is shown in the listbox. Click on the 
Abort button to cancel this operation.
Directory
Request the host to send a detailed list of files in the current working directory. The full list is shown in the listbox. 
Click on the Abort button to cancel this operation.
Dir Up
Request the host to move one directory up in the directory tree.
Chg Dir
Request the host to change the directory to directory selected in the file listbox. This command is also executed 
when you double click on the directory name in the filelist box.
Receive
Downloads selected file(s) from the host.    If you are downloading a single file, then first make a selection of file in 
the listbox and then click on the receive button. If you are batch downloading files then you must add files to the 
batch list and click on the receive button. The files are downloaded to the current local directory if you have enabled
this option in the Def Dir dialog box otherwise they are downloaded to default download directory.
Add
Add button on the right/left hand side adds selected file to the batch list    for later downloading/uploading.
Delete
Deletes from the batch list.
Send
Uploads selected file to the remote or batch uploads batchlist files.
View
View text file using the nottepad editor after the file is downloaded.
Close/Abort
Close removes the dialogbox from the screen. Abort cancels the file list operation.




