
Introduction to Microangelo

Microangelo consists of three major components: the Browser, Librarian, and Studio. 
The Browser will help you locate the files on your system that contain icons.    It provides you a 
place to start whenever you want to open a file, and can easily be accessed from the File menus of 
the Librarian and Studio.    
The Librarian has been developed to facilitate managing and editing icons that are contained inside
Icon Resource, Icon Library, Application, and Application Extension files.    These file types are the 
Windows 95 equivalents of the ICO, ICL, EXE, and DLL file extensions used in the old DOS file 
naming convention.
The Studio will create and edit icon images contained in Icon Resource files.    It also acts as a server
application for the Librarian to allow editing of icons contained inside other file types.

Microangelo Browser
When you click on these Tabs and navigate through different folders on your machine, the Browser 
will only display the files that contain icons. If you double click on a file in the Icons tab, the file will
be opened in a Studio edit session.    Selecting a file in the Libraries tab will open the file in the 
Librarian.
After a Librarian window has been opened, the Browser can be used to drag and drop files onto the 
Librarian.    Using the right mouse button to drag and drop will provide a choice of either opening 
the file or adding the icons in the file(s) to the current Librarian workspace.

Microangelo Librarian
The Microangelo Librarian provides you with the capability to extract, edit, organize, and store icons
on your system.    You can open a file in Librarian from the Libraries tab in the Browser or from 
Windows Explorer.    Double click on the file or simply drag and drop it into an open Librarian 
window.
Individual icons can be moved or copied by dragging and dropping between Librarian windows to 
create customized icon libraries.    Icons contained in icon libraries and application files can be 
modified in the Studio by double-clicking on the icon in the Librarian window.

Microangelo Studio
Microangelo Studio supports the editing of various sizes and formats of icon images contained in 
icons.    It will create, open, and save icon resource files (*.ICO format) or support the Librarian 
directly.    Select a file from the Browser Icons tab to open the file in an edit session with the Studio.  
Double click on any icon in the Librarian to establish an edit session with the Studio.    Microangelo 
Studio will create or edit any size icon image from 8x8 to 64x64 pixels in monochrome,16 , or 256 
color formats.
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Opening Icon Libraries 

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_opening_icl_and_dll_files_browse')}      Open an icon library
from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_opening_icl_and_dll_files_librarian')}      Open an icon library from
the Librarian?



Opening Icon Resource Files

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_opening_ico_files_browse')}      Open an icon resource from
the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_opening_ico_files_librarian')}      Open an icon resource from the 
Librarian?



Opening Application Files

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_opening_exe_files_browse')}      Open an application file 
from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_opening_exe_files_librarian')}      Open an application file from 
the Librarian?



Create Icon Image

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_create_new_icon_browse')}      Create a new icon from the 
Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_create_new_icon_librarian')}      Create a new icon from the 
Librarian?
{button ,JI(`Muedit.hlp>Proc1',`stu_create_new_icon_studio')}      Create a new icon from the 
Studio?



Creating a ‘Custom” Size Icon Image

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_create_custom_icon_browse')}      Create a ‘custom’ size 
and color icon from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_creating_custom_size_librarian')}      Create a ‘custom’ size and 
color icon from the Librarian?
{button ,JI(`Muedit.hlp>Proc1',`stu_creating_custom_size_studio')}      Create a ‘custom’ size and 
color icon from the Studio?



Edit Icon Resource Image

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_edit_an_icon_browse')}      Edit an existing icon resource 
from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_edit_an_icon_librarian')}      Edit an existing icon resource from 
the Librarian?
{button ,JI(`Muedit.hlp>Proc1',`stu_edit_an_icon_studio')}      Edit an existing icon resource from the 
Studio?



Create an Icon Image From a Bitmap

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_converting_bmp_file_browse')}      Creating an icon 
resource from a bitmap from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_converting_bmp_file_librarian')}      Creating an icon resource 
from a bitmap from the Librarian?
{button ,JI(`Muedit.hlp>Proc1',`stu_converting_bmp_file')}      Creating an icon resource from a 
bitmap from the Studio?



Copying/Moving an Icon Image to a New Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_ moving_from_saved_to_new_browse')}      Copying/Moving
an icon from a library, and create a new library from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_multiple_saved_to_new')}      Copying/Moving an icon from a 
library, and create a library from the Librarian?



Copying/Moving an Icon Image to a Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_ moving_into_existing_browse')}      Copying/Moving from a
library, to a library from Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_multiple_into_existing_file')}      Copying/Moving from a library, to
a library from Librarian?



Copying/Moving Multiple Icons Into a New Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_ multiple_saved_to_new_browse')}      Copying/Moving 
multiple icons and create a new library from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_multiple_saved_to_new')}      Copying/Moving multiple icons and 
create a new library from the Librarian?



Copying/Moving Multiple Icons Into a Library

There can be different procedures to follow, to help you accomplish a task the most efficient way 
possible.

What do you want to do?

{button ,JI(`Muangelo.hlp>Proc28',`mua_ multiple_into_existing_file_browse')}      Copying/Moving 
multiple icons into a library from the Browser?
{button ,JI(`Mumgr.hlp>Proc1',`lib_multiple_into_existing_file')}      Copying/Moving multiple icons 
into a library from the Librarian?



Opening Icon Resource Files

1    Click the Icons Tab.
2    Browse to the folder which contains the icon file.
3    Double click on file.
4    Studio will open the image, and place it in the grid area, ready to be edited.



Opening Icon Libraries

1    Click the Libraries Tab.
2    Browse to the folder which contains the file.
3    Double click to open in the Librarian.

Tip:
· Once the Icon Library is open, you may double click on any icon to start editing the image with the

Studio component.
· When working with an icon image in a Application file or an Application Extension, the Librarian is 

unable to delete images from the file. These file types can include program code and/or other 
types of resources.    Making any changes to these types of files other than editing the existing 
images could result in the loss of important information. 



Opening Application Files 

1    Click the Libraries Tab.
2    Browse to the folder which contains the file.
3    Double click on the file to open.

Tip:
· Once the Application file is open, you may double click on any icon to start editing with the Studio 

component
· When working with an icon image in an Application file or Application Extension, the Librarian is 

unable to delete images from the file. These file types can include program code and/or other 
types of resources.    Making any changes to these types of files other than editing the existing 
images could result in the loss of important information. 



Creating a New Icon

1    Click the New Tab.
2    Double click New Icon.
3    Microangelo Studio will open with a blank grid area to start creating a new icon.
4    Once drawing has been completed, click Save As from the File menu.
Tip
· When you click Save As from the File menu, it    will update the image in the file, but leave the 

Studio open, so that you may edit the image with different color schemes, or shapes, etc.



Creating a ‘Custom’ Size Icon Resource

1    Click the New Tab.
2    Double click on New Icon.
3    Microangelo Studio will open with a blank grid area to start creating a new icon.
4    Click the New Image Format button (far right of toolbar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
5    Once editing has been completed, click Save As from the File menu.



Editing an Existing Icon Resource

1    Click the Icons Tab.
2    Browse to the folder, that contains the image to be edited.
3    Select the file, and double click to open.
4    This will invoke an edit session with the Studio.
5    Make any desired changes to the image.
6    Click Save from the File menu.
Tip
· When you click Save from the File menu, it    will update the image in the file, but leave the Studio 

open, so that you may edit the image with different color schemes, or shapes, etc.    



Creating an Icon Resource From a Bitmap

1    Click the New Tab.
2    Double click New Icon, this will start the Studio component.
3    Click the New Image Format button (far right of toolbar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
4    Click Open Bitmap File from the Edit menu.
5    Browse to the folder which contains the bitmap file.
6    Select the file, and click Open, the bitmap will be pasted into the grid area.
7    Click Save As from the File menu to save image as an icon.
Tip:
· You may also convert a BMP file into an icon, by pasting it to the Clipboard, and using the Paste 

Special option on the Edit menu.    However, if your bitmap uses colors that are not available in the
currently active palette, the Studio will substitute the closest color available from the currently 
active palette.    To ensure color integrity, always use the Open Bitmap File, on the Edit menu.



Copying/Moving an Icon From Library to New Library

1    Click the Libraries Tab.
2    Browse to the folder where the file of the image is saved.
3    Double click on file to open it in the Librarian.
4    Click New Window from the File menu.
5    Click on image with the right mouse button, then drag and drop it into the new library.    A pop 

up menu will appear with available options.
6    Click Save As from the File menu.
Note:
· While the icon is being dragged, the cursor will display an image of the icon whenever it is 

positioned over a legal drop area. 
· You may select multiple icons from the saved file, and move them to a new file.



Copying/Moving an Icon From Library to Library

1    Click the Libraries Tab.
2    Browse to the folder where the library is saved.
3    Double click on the file to open, the file will be opened in the Librarian.
4    Click New Window from the File menu.
5    Click Open from the File menu, in the new window.
6    Browse to the folder where the icon library is located.
7    Select the file, and click Open.
8    Click on image with the right mouse button, then drag and drop it into the new library.    A pop 

up menu will appear with available options.
9    Click Save from the File menu.
Note:
· While the icon is being dragged, the cursor will display an image of the icon whenever it is 

positioned over a legal drop area. 
· You may select multiple icons from the saved file, and move them to a new file.



Copying/Moving Multiple Icons Into a New Library

1    Click the Libraries Tab.
2    Browse to the folder where the library is saved.
3    Double click on file to open, it will open in the Librarian.
4    Click New Window from the File menu.
5    Select the icons, by holding the CTRL key down, and clicking once on each image.
6    Drag and drop one image into the new window, all the images will be pasted in to the new 

window (using left button=Move, using right button=Copy).
7    Click Save As from the File menu.
Note:
· While dragging the icons, the cursor will display an image of a paper clip attached to a sheet of 

icons, whenever it is positioned on top of a legal drop area.    
· A circle with a slash is displayed when the cursor is over any area that the icons cannot be 

dropped on.    Any open window inside the Microangelo Librarian is a valid drop area.    



Copying/Moving Icon Images Into Libraries

1    Click the Libraries Tab.
2    Browse to the folder where the library is saved.
3    Double click on file to open, it will open in the Librarian.
4    Click New Window from the File menu.
5    Click Open from the File menu, of the new window.
6    Browse to the folder where the library is saved.
7    Select file, and click open.
8    Select the icons, by holding down the CTRL key, and clicking once on each image to be moved.
9    Drag and drop one image into the exisitng file window, all the images will be pasted into that 

window (using left button=Move, using right button=Copy).
10    Click Save from the File menu.

Note:
· While dragging the icon, the cursor will display an image of a paper clip attached to a sheet of 

icons, whenever it is positioned on top of a legal drop area.    
· A circle with a slash is displayed when the cursor is over any area that the icon cannot be dropped

on.    Any open window inside the Microangelo Librarian is a valid drop area.    



Using the Windows Explorer

Librarian
Windows Explorer can be a useful tool to navigate through the drives and folders on your machine.   
Double click on any Icon Library file to open it in a new Librarian window.    Drag and drop any file 
that contains icons into any open Librarian window to open the file.    Using the right mouse button 
to drag and drop provides access to a pop up menu where you can select to add the icons to the 
current Librarian workspace.

Studio
Double click on any Icon Resource file to start a standalone edit session with the Studio where you 
can edit the icon.    When your updates have been completed, select Save from the File menu; and 
then Exit. 
_________________________________________________
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Add Icon Resource Files to a Library

1    From the Explorer, move to the folder that contains the icon library.
2    Double click on the file.    It will open in the Librarian.
3    In Explorer, move to the folder that contains the icon resource files.
4    Click on the file with the right mouse button, then drag and drop it into the open library.    A 

pop up menu will appear with available options.

Note:
· If you drag and drop with the left mouse button the Librarian will open the file in the current 

window.    It will not add to the current library.



Opening Icon Library Files

1    Move to the folder where the library is located.
2    Double click the library file.    The file will be opened in the Librarian.

Tip:
· You can add to icons to the library by dragging and dropping files into the window with the right 

mouse button.    A pop up menu will appear with options. 
· Once the Icon Library is open you can double click on any icon to start editing with the Studio 

component.    
· When working with an icon image in an Application or an Application Extension file, the Librarian 

will not allow adding or deleting of images.    These file types can include program code and/or 
other types of resources.    Making any changes to these types of files other than editing the 
existing images could result in the loss of important information.    If you want to create a custom 
library file you should drag the icons into a “New” Librarian workspace and save them in an icon 
library.



Editing an Existing Icon Resource

1    Move to the folder that contains the icon to be edited.
2    Double click the file to open.    This will invoke an edit session with the Studio.
3    Make any desired changes to the image.
4    On the File menu, click Save.
Tip
· When you perform a Save from the File menu you will save the image to disk and be able to 

continue your edit session, experimenting with changes, different color schemes or shapes, etc.    



Merging Libraries From Explorer

1    From the Explorer, move to a folder that contains an icon library.
2    Double click on the file.    It will open in the Librarian.
3    In Explorer, move to the folder that contains other icon libraries.
4    Click on the file with right mouse button, then drag and drop it into the open library.    A pop 

up menu will appear with available options.

Note:
· If you drag and drop with the left mouse button, the Librarian will close any current file that is 

open before opening the dropped file.    It will not add to the current library.



The New Image Format option, is located to the far right of the tool bar, and gives you the ability to 
determine the size, and number of colors to be used in creating a new image for an icon.



The grid area is a zoomed view of the icon image being edited, and the area where all drawing 
takes place.



Open an existing image format by selecting it using the Image Format drop down combo control, 
above the grid area.    A new image format can be added to the current icon by pressing the New 
Image Format button located at the far right of the tool bar.



Multiple icons can be selected by clicking in an area outside of an icon and then dragging the 
mouse cursor to surround the desired icons, or by holding down the CTRL key and clicking once on 
each icon to be selected.



The Blend Color dialog is activated by double clicking on any color inside the 256 color Palette 
window.    



An Application file, in Windows 95, is the equivalent to an (*.EXE) file, under the old DOS based 
naming convention.



An Application Extension, in Windows 95, is the equivalent to a (*.DLL) file, under the old DOS 
naming convention.



An Icon Library, in Windows 95, is the equivalent to an (*.ICL) file, under the old DOS naming 
convention.



An Icon Resource, in Windows 95, is the equivalent to an (*.ICO) file, under the old DOS naming 
convention 



What is a server edit session?
Server mode is when one program furnishes its services to another program.    In Microangelo, the 
Studio can operate as a server to the Librarian.    The File menu of the Studio is modified when it is 
acting as an edit server for the Librarian.    The standard New, Open, Save and Save As selections 
are replaced with the following options:

· Update (to update the image in Librarian and continue the edit session), and 
· Update and Exit (to update Librarian and end the edit session).

The New, Open, and Save buttons on the tool bar are disabled when the Studio is operating as a 
server to the Librarian.

Tip:
· When the cursor is positioned over a button that has been disabled for server operation, the tool 

tip window for the button will display the added reminder: (not available in Server mode).



What is a standalone edit session?
A standalone edit session is when any file is opened directly by the Studio component.    This can be
accomplished by any of the following procedures:

1    When selecting New Icon from the New tab in the Browser and clicking Open.
2    When selecting an icon file from the Icons tab in the Browser and clicking Open; 
3    When selecting any icon file in Windows Explorer and pressing Enter from the keyboard.
4    When opening an ICO resource file in the Studio by clicking Open from the File menu; or
5    When creating a new icon in the Studio by clicking New from the File menu.




