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Curve Fit Synopsis
The Curve Fit application allows you fit data pairs to a curve you select.    The supported curve types are 
polynomial, log-log polynomial, and semi-log in both X and Y.    You are allowed to select a curve order of from 1 
through 10 for the polynomial curve types.    The fit method used is least squares.    To help determine how good the 
fit is for the curve selected, the sum of the absolute differences and the coefficient of fit performance are reported.    
The best fits usually have the smallest sum of absolute differences and a coefficient of performance near 1.000.    
The curve is automatically refitted anytime a change in data or curve type occurs.    Two views of the data are 
supported which are a listing (List View) and a plot (Plot View) view.

Starting a New Data Set
To fit a curve to a new data set, select New Data when asked to select a data file in the opening dialog.    You 
immediately get a tabbed dialog that has the following three pages.
o The Curve Page allows you to define a data set title, title the X & Y axes, select a curve type, and set the 
curve order.
o The Data Page allows you to enter, import, edit, delete, and rearrange data pairs.
o The Resolution Page allows you to set the data precision and display-entry format.
You can also start a new data set by selecting the New Fit Button        on the tool bar.    Enter a data title and the 
axes titles; pick the curve type and order; select the data resolution and display format; and enter or import the data 
pairs.    Click OK when you are satisfied with the data set.

Plotting the Current Data Set
Once you have entered a data set and fitted a curve, you may select the Plot Button        on tool bar to display 
your data set in graphical form or select the New Plot Window option of the Window menu..    Each entered data 
pair is plotted as an asterisk and the fitted equation is plotted between the minimum and maximum data pairs as a 
solid green line.    To get a better view you can double the plot dimensions by selecting the Zoom Button    

    on the tool bar or by selecting the Zoom Plot option of the Options menu.    To restore the plot select the Zoom
Button again.

Modifying the Current Data Set
You may modify the data title, axes labels, curve type and order, precision, display style, and the data at any time by 
selecting the Data Button        on the tool bar or by selecting the Data option of the Options menu..

Saving a Data Set
Once you have entered a data set, select the Save… or Save As… option of File menu or the Save Button        on 
the tool bar to save the data.    Enter a file name appropriate for your data, and click the OK button.    This 
application automatically recognizes data files having a dat extension.

Loading an Existing Data Set
To load a previously saved data set, use the opening file dialog to find the file on your system.    When you have 
found the file, double click it or click it and then click the Open Existing button to load it.    The application reads 
the file and displays pertinent information in the List View.    You may reload a previously saved data set at any time
by selecting the Open Button        on the tool bar or by selecting Open from the File menu.

Printing
You may print the data set by selecting the Print Button        on the tool bar or by selecting the Print option from 
the File menu.    The hard copy will have the same format as the List View.

Importing Data
You may import data from a text file by selecting the Import button on the Data page.    The X-Y data pairs may be 
delimited with a space, tab, comma, semicolon, double quote, and single quote or any combination of these 
characters.    If the file contains more than two columns of data, only the first two are used and the remaining 
columns are ignored.    If you have data in an Excel file, you can export it to a text file and then import it into this 
application.



Limitations
Until the application is licensed, you are limited to only 7 data points.

The application is easy to use.    It has been tested with a data set in excess of 100,000 pairs and although slow with a
data set that large it ran just fine.    Select a previously saved file you wish to read from any drive/directory on your 
system and your off and running.

Windows 95 Customers
With Windows 95, I had hoped that the display limitations for list boxes et. al. would no longer be a concern.    In 
fact, only 32,767 lines can be displayed in a list box.    As a result, only 32,000 lines/data pairs are displayed per 
display/data page.    To overcome this limitation, you may switch display pages using the Next Page     , Previous 
Page    

, and GoTo Page    
    Buttons on the tool bar or selecting the Next/Previous Display Page or GoTo Display Page option from the 

View Menu.    When entering data, the same arrows are available in the upper right corner of the Data Page.    For 
those of you who are running NT, forget this paragraph, you get it all in a single list.

Data precision is limited to 14 decimal places maximum and 0 decimal places minimum.



Tool Bar

        

The tool bar provides a quick means to perform a task.    Simply select the appropriate button and click on it.    From 
left to right the buttons are:

Start a new curve fit session.

Open a previously saved curve fit file.

Save the current curve fit to file.

Plot the data and fitted curve.

Double or restore the plot.

Display next page.

Display previous page.

Go to a Display/Data page.

Print the list view display.

Get HELP!!



Compute X

        

This page is only active when you have elected to fit your data to the X = Ae^BY semi-log curve.    You may enter a 
Y value in the edit control and X will be computed using the fitted curve coefficients when you click the Compute 
X button.



Compute Y

        

This page is active when you have elected to fit your data to the Y = Ae^BX semi-log curve or any polynomial.    
You may enter an X value in the edit control and Y will be computed using the fitted curve coefficients when you 
click the Compute Y button.



Registration Form

Your Name: _____________________________________________

Note: Type/print your name and company below EXACTLY as it appears in the Registration
dialog in the Help Menu of the Application.

Registration Dialog Name: _____________________________________________

Registration Dialog Company:__________________________________________

Please type or print clearly the following information:

Address: __________________________________________________________

City: _________________________________            State: _____            Zip: __________

E-Mail Address: _______________________________

Check the programs you wish to Register.

Curve Fit: _____    $20.00
Find String: _____    $15.00
HTML Merge: _____    $20.00
Search/Replace String: _____    $15.00
Set Text File Line Break: _____    $10.00
Touch File Date/Time: _____    $10.00
Both Search/Replace & Find String: _____    $25.00
Both Search/Replace & HTML Merge: _____    $30.00

I have enclosed a 
___ Check ___Money Order ___Cash (Check One)

Preferred Registration Code delivery:
___ Mail ___ E-mail (Check One)

Please include a self addressed envelope for mail delivery to speed up the response.
__________________________________________________________________________
Please make checks payable to Richard Floersch.
Mail this form and your check or money order to:

Richard Floersch
7307 W 89th Terr
Overland Park, Ks 66212
__________________________________________________________________________



Curve Page

        

The Curve page allows you to enter a title that describes your data, assign labels to the X & Y axes, and select a 
curve type.    You may select a polynomial, log-log polynomial, or one of two semi-log curves.    For the polynomial 
curves you may set the fit order of the curve from a 1st (straight line) to a 10th order curve.    You must enter at least 
one more data pair than the order of the curve you select (e.g., for a 3rd order curve you must enter at least 4 data 
pairs).    You may change the curve type or order at any time and the application will refit the data to the new choice. 



Data Page

        

The Data page allows you to add, import, modify, delete, and rearrange data pairs.

Large Data Sets and Windows 95
With Windows 95, I had hoped that the display limitations for list boxes et. al. would no longer be a concern.    In 
fact, I found out that I can only display 32,767 data pairs in the data list box.    As a result, only 32,000 data pairs are 
displayed per data page.    You may switch between data pages using the Next Page     , Previous Page    

, and GoTo Page    
    Buttons in the upper right hand corner of the dialog page.    For those of you who are running NT, you get it all 

in one list.

Adding/Inserting/Editing
Enter data pairs in the fields you titled on the Curve page and click the Add button to add a new data pair to the data
set.    Double clicking on a data pair loads their values in your titled fields where either may be modified.    Click the 
Edit button to replace the highlighted pair, click the Insert button to insert the data above the highlighted pair, or 
click the Add button to add the new pair to the data set.    If multiple pages are required to display your data, you 
may add/insert up to 700 more data pairs to an existing full display page.    When you reach the 700 limit, a message 
box will be displayed telling you that the list will be rebuilt.    If the page isn't full, you will be able to add the 
difference between 32,000 and the existing displayed pairs plus the additional 700.

Deleting Data Pairs
To delete one or more pairs, highlight the data pairs in the data list you want to eliminate then click the Delete 
button.    If multiple pages are required to display your data, the delete operation will not automatically bring the data
from ensuing pages into the current page.    Rebuilding the list box is time consuming, therefore, I chose to NOT 
automatically rebuild.    You will need to switch pages before the data pairs are rearranged for display.



Moving Data
You may rearrange the data pairs by highlighting a pair and clicking the move Up or Down buttons to exchange the 
pair with the pair above or below it respectively.    If multiple pages are required to display your data, you will not be
allowed to move a data pair to the previous or ensuing display page.    You may only move it within the current page.

Importing Data
To import data pairs from a text file, click the Import button.    The data file may contain multiple columns of data 
but only the first two columns are used.    The data pairs must be separated by a comma, a semicolon, a space, a tab, 
a single quote, or a double quote in any combination.    The first column will be interpreted as the X value.    
Importing will stop when the end-of-file is reached, an error occurs, or seven data pairs have been read if the 
application is not licensed.    Imported data is always added to the end of any existing data.    If the imported data 
exceeds 32,000 pairs, all pairs will all be imported but you will have to switch data pages to display the pairs that 
exceed the 32,000 limitation. 



Resolution Page

        

The Resolution page allows you to specify the data entry/display format and number of precision digits you want 
your data to have.    The two formats supported are standard (e.g., 13400.) or exponential (e.g., 1.34e+04).    Each 
data point can be 16 digits, a sign, and a decimal point.    The data precision is set to five by default and is restricted 
to from 0 (no decimal point) to 14 decimal positions.    If you want fewer or more digits to the right of the decimal, 
enter the number you want in the appropriate decimal places control.



List View
       

The List View displayed above is a scroll window that allows you to view or print your data set and the pertinent 
information about the fitted curve.    The List View is the primary display window.    If you pop up the Plot View and
kill the List View window, select New List Window option from the Window menu to redisplay it.

Windows 95 Customers
With Windows 95, I had hoped that the display limitations for list boxes et. al. would no longer be a concern.    In 
fact, I assumed that, only to find out that I can only display 32767 lines in a list box.    As a result, only 32,000 lines 
are displayed per display page.    To overcome this limitation, you may switch display pages using the Next Page   

 , Previous Page    
, and GoTo Page    
    Buttons on the tool bar or selecting the Next/Previous Display Page or GoTo Display Page option from the 

View Menu.    For those of you who are running NT, you get all the data displayed in one display page.



Plot View
       

You can get a plot of the data pairs and the fitted curve by selecting the New Plot Window option from the Window
menu or by clicking the Plot Button        on the tool bar.    Click the Zoom Button    

    to double the size of the plot.    Click the Zoom Button again to restore the plot to its original size.    Each data 
pair is represented by a red asterisk.    The green line is a plot generated by evaluating the fitted equation between the
minimum and maximum data pairs.

Note: The plot displayed above is a perfect straight line with 100,000 data pairs plotted, consequently, the green 
line doesn't show up because it is overpowered by the red asterisks.




