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How to Customize: Overview
You can customize various settings to your own preferences, and these settings are preserved between 
sessions (except as explained below).    All user-configurable settings are accessible from the Configure 
menu, except for the Print Setup command, which is on the File menu. You can also configure properties
for the active document by choosing the Properties command from the popup menu that is displayed 
when you right click in its window.
Some of the configuration dialogs (eg. Font) give you the option to have the settings apply to the active 
document only, or to all documents.    Only settings that are applied to all documents are preserved 
between sessions.
Click the Contents button to see the various options that can be customized, or the next item button (>>)
to step through them one at a time.



How to Customize General Preferences
You can customize these general settings by choosing Preferences from the Configure menu:

Set this Option: To Do This:
Save settings on exit Save all settings between sessions.
Save the workspace Save the state of open documents between 

sessions, so that you can continue from 
where you left off.

Allow multiple instances 
to run

Allow more than one instance of the program
to run at a time.    This is not possible for the 
16-bit edition.

Use multiple selection 
Open File dialog box

Allow multiple files to be selected in the 
Open File dialog.

Working directory 
follows active document

Automatically change working directory, to 
match that of the active document.

Display startup logo Suppress the "splash" logo window that is 
displayed whilst TextPad starts up.

Use OLE drag and drop Enable the drag and drop capabilities.    This 
setting can only be changed when no 
document windows are open, and OLE2 has
been installed.    16-bit edition only: uses 
non-OLE drag and drop when not set.

Display full path names 
on Window Selector

Display as much of the path as can be fitted 
in the Window Selector, otherwise omit the 
path and just display the file name.

Start with a new 
document

Open a new document, if no files are opened
when TextPad is started..



How to Customize Binary Extensions
TextPad has a built-in list of file extensions that it associates with binary files, such as ".EXE".    If you 
open one of these files, it will be displayed in hexadecimal.    To modify the list:
1. Choose the Preferences command from the Configure menu.
2. Select the Binaries tab.
3. To delete an entry, select it from the list, and click Delete.
4. To add a new entry, type it in the New Extension box, and click Add.
5. To reinstate the defaults, click Set Defaults.
6. Click OK.



How to Customize Colors
The screen colors used for normal and selected text, bookmarks, and the left margin can be modified as
follows:
1. Choose the Preferences command from the Configure menu.
2. Select the Colors tab on the Preferences dialog box.
3. Choose the item that you want to change the color of.
4. Select the required foreground and background colors.
5. Click OK or Apply.

Notes:
The colors are initially "automatic".    This means that they automatically change to match the 

colors set for your Windows desktop.
The background color of bookmarks is not used.
The foreground and background colors of the left margin are used to differentiate the active and 

inactive parts of a split view.



How to Customize Document Preferences
You can customize these document settings by choosing Preferences from the Configure menu to 
change all documents, or by choosing Document Properties to change them for the active document:

Set this Option: To Do This:
Word wrap long lines Word-wrap lines that are wider than the view,

or than the column specified for hard breaks.
Constrain the caret to 
the text

Restrict the position of the caret to the 
existing text.    Otherwise it can be placed 
anywhere in the document window.    In 
word-wrap mode, the caret is always 
constrained.

Maintain indentation Automatically indent each new line by the 
same amount as the preceding line.

Automatically indent 
blocks

Indent a new line following a line ending with 
{, and unindent a } on a line on its own.    
Maintain Indentation must also be set.

Remove trailing spaces 
when saving

To strip trailing spaces and tabs from each 
line as the file is saved.

Clear undo buffer when 
saving.

Prevent edits from being undone, after a file 
has been saved.    Also reduces the risk of 
memory overflows after a lot of edits.

Read only Prevent the document from being edited.    
This cannot be set if the document has 
already been modified.

No breaks in lines Save word-wrapped documents without 
actually breaking the lines as wrapped.

Hard breaks at column # Insert new line characters at the specified 
column position, when saving word-wrapped
documents.



How to Customize File Associations
Most applications are entirely responsible for the files that they manage (e.g. MS Word and its .DOC 
files), so they can register all file associations during the installation process, and guarantee that the 
associations are made correctly.    Text editors don't have that luxury.    They can be associated with all 
sorts of files, with scope for all sorts of problems (and support calls to us) if it's not done right.    It was 
easy on Windows 3.1: by adding an entry for TextPad to the registry, you could use File Manager's 
Associate command to correctly associate an extension with that entry.    If you do the same thing on 
Windows 95, you lose the correct description for the file, and any additional functionality that the original 
association may have had (e.g. with .BAT files, you can either edit or run them).    Hence TextPad 
provides its own way to make associations.
By associating TextPad with file extensions, Explorer or File Manager will know to start TextPad when 
you want to edit such a file.    Change the associations as follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Choose the Associations tab.
3. Type an extension in the New Extension box, or choose one from the drop-down list.
4. Type the description of such files in the Description box.
5. Click the Add button.
6. Repeat steps 3-5 for each new extension.
7. Click OK or Apply.

To revert an association back to its default:
1. Select the extension from the list box.
2. Click Delete.
3. Repeat steps 1-2 for each extension to delete.
4. Click OK or Apply.

Notes:
Clicking Cancel will leave your current associations intact.
If you have associated extensions with releases of TextPad earlier than 1.31, they will not show 

up in the list initially.    You must remake the associations to get them in the list.    The uninstall program 
uses this list to reinstate the default associations.



How to Customize File Backups
When you save a file, you can keep a backup copy of the original.    To customize the settings, choose 
Preferences from the Configure menu and select the Backup tab on the Preferences dialog box:

Set this Option: To Do This:
Preserve original file 
creator when saving 
changes

For safety, TextPad (32-bit only) normally 
saves changes to a temporary file, before 
deleting the original.    This loses the original 
file creator.    By checking this option, the 
original file is overwritten, which preserves 
the creator, at the risk of losing the original 
file if the save operation fails.    This setting is
ignored for FAT file systems, which have no 
concept of a file creator.

Backup files before 
saving changes

Copy the original file to a backup with one of 
the following names, before saving changes.

FILE.BAK Backup FILE.EXT as FILE.BAK
FILE.BAK.EXT Backup FILE.EXT as FILE.BAK.EXT
FILE.EXT.BAK Backup FILE.EXT as FILE.EXT.BAK
FILE.EXT in folder Backup FILE.EXT with the same name in the

specified folder.

Notes:
On file systems that do not support long file names, FILE.EXT will always be backed up as 

FILE.BAK (unless a backup folder is given).
Only a single backup copy is kept, which is overwritten on each file save.



How to Customize File Filters
File filters are the list of wild cards in the List Files of Type box on the File Open dialog box.    You can 
add to the default list as follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Select the Filters tab and Click New.    The word New is displayed in the Filters and Descriptions 

boxes.
3. Replace this word in the Description box with the text that you would like to describe the filter.    eg. 

Assembler Files (*.asm, *.inc).
4. In the Wild Cards box, type the corresponding list of wild cards, separated by semicolons.    eg. 

*.asm;*.inc.
5. Click Move Up or Move Down to change the position of this filter in the list.    The first entry in the list 

will normally be used as the default each time TextPad starts up.    However, if TextPad loaded a 
workspace when it started, the initial filter will be set to the last one used.

6. Click OK.



How to Customize File Preferences
You can customize these file settings by choosing Preferences from the Configure menu:

Set this Option: To Do This:
Number of recent files 
on File menu

Set the number of most recently used files 
on the File menu to between 1 and 16.

Default file extension If you open or save a file using the File Open
or Save As dialog boxes, and do not specify 
a file extension, this string will be used.    It 
must not include spaces or dots.

Treat Ctrl+Z as end of 
file marker.

Prevent TextPad from reading any 
characters after a Ctrl+Z (hex 1A) in a file. 

Work on DOS files in the
ANSI code set.

Files that you open as DOS will be 
converted to ANSI when opened, and back 
to DOS when saved if you check this box.

When files are modified 
by another process:
Prompt, Auto-Reload or 
Ignore

If an open file is modified by another 
process: Prompt will ask if it's OK to reload 
it; Auto-Reload will reload it automatically, 
unless it's been modified; Ignore will ignore 
the change.

Default code set:
ANSI or DOS

Set the default code set used.    Click DOS if 
you want to use most of your text files with 
DOS applications, otherwise click ANSI.    
This setting is used for dropped files, and 
files opened by double clicking, but can be 
overridden for individual files on the Open 
File dialog box.

Create new files as:
PC, UNIX or MAC

Choose the option for the default end of line 
characters saved with new files.

Use simple file I/O 32-bit only: If you have problems editing 
files on a file server, try checking this box.



How to Customize Hypertext Expressions
You can change the regular expression used in hypertext jumps from the Command Output window as 
follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Choose the Jumps tab.
3. Clear the Use Defaults check box.
4. In the Regular Expression box, type the regular expression that matches the text in the Command 

Output window.    This must include at least two tagged expressions for the filename and line number,
and optionally a third for the column number.    It must also match the start of the line.    Up to 10 such
expressions are saved in the drop-down list.

5. In the Register boxes, set the indexes corresponding to the tagged expressions defined in the last 
step.

6. Check Use Defaults, if you want to revert to the default expression.
7. Click OK.

More Information:
The Command Output window is used to capture the output from the Run command, or from tools 
added to the Tools menu.    If the output is from a compiler, or Grep type of program, it can be used to 
jump directly to the corresponding source line using left double-click.    Built-in support is provided for 
output from Microsoft and Symantec (Zortech) compilers, in the form:

filename(line): message
If this default is not suitable, it will be necessary to specify an alternative hypertext jump regular 
expression.    For example:
1. Microsoft and Symantec (Zortech) C/C++

Expression = ^\([^(]+\)(\([0-9]+\))
File Register = 1
Line Register = 2

2. Borland C/C++
Expression = ^[WE][a-z]+ \([^ ]+\) \([0-9]+\):
File Register = 1
Line Register = 2

3. Java
Expression = ^\([^:]+\):\([0-9]+\)
File Register = 1
Line Register = 2

4. Keil C51
Expression = ^.+ IN LINE \([0-9]+\) OF \([^:]+\):
File Register = 2
Line Register = 1

5. IAR Assembler
Expression = "\([^"]+\)",\([0-9]+\)
File Register = 1
Line Register = 2

6. PowerBASIC
Expression = ^Error [0-9]+ in \([^(]+\)(\([0-9]+\):\([0-9]+\)
File Register = 1
Line Register = 2
Column Register = 3

7. Perl for Windows 95
Expression = ^.+at \(.+\) line \([0-9]+\),
File Register = 1
Line Register = 2

8. Generic filename(line,column)
Expression = ^\([^(]+\)(\([0-9]+\),\([0-9]+\))



File Register = 1
Line Register = 2
Column Register = 3



How to Customize the Language
To choose a language for the user interface:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Choose the Language tab.
3. Select a language from the list box.
4. Click OK.

Notes:
This effects the language used for menus, dialog boxes, etc, but not the on-line help.
You have to restart TextPad after changing the language, before the change takes effect.
English is always available, but other languages are stored in DLL's with names of the form 

"TXP32???.DLL" and "TXP16???.DLL".    Initially, only German is available, where "???" is "DEU".



How to Customize the Printer
To choose a particular printer, or to set up the printed page layout and font:
1. From the File menu, choose Print Setup.    The Configure Printing dialog appears.
2. To change the printer, click the Printer button and the standard Print Setup dialog is displayed.    Click

its OK button when you have made your selection.
3. To change the font, click the Font button and the standard Font dialog is displayed.    Click its OK 

button when you have made your selection.    Note that this selection only applies to the printer, not 
the screen font.

4. To add a header and/or footer to each printed page, type the required text in the Header and Footer 
boxes.    You can also use header macros to get the file name, date and time:

5. If you want the times in the header and footer to correspond to the creation time of the file being 
printed, click File Time, else click Print Time.

6. To set the page margins, fill in the Left, Right, Top and Bottom boxes.    Note that if you set these to 
less than the minimum that the printer allows, the settings are ignored.

7. If you want lines that are too long for the page width to be wrapped on to the next line, click the Word
Wrap Long Lines box.    Otherwise lines that are too long will be truncated.

8. Click OK when you have completed your changes.

Tip:
To save on paper, use the Print Preview command on the File menu to check that your printer settings 
are satisfactory.



How to Customize the Screen Font
Only fixed width fonts are allowed on the screen, so the screen font is set independently of the printer 
font.
1. From the Configure menu, choose Screen Font.    The Font dialog is displayed.
2. In the Font box, choose from the list of fixed width fonts.
3. In the Font Style box, choose from the list of styles.
4. In the Size box, choose from the list of font point sizes.
5. In the Scope box, select Make Default, if you want these settings to be applied to all documents, 

otherwise select Active Document to make a temporary change to the active document only.
6. Check Use on Printer if you want to print with this font as well.
7. Verify that the text displayed in the Sample box is satisfactory.
8. Click OK.



How to Customize Tab Stops
Tab stops and indentation can be set at regular intervals as follows:
1. To change the default settings for all documents, choose Preferences from the Configure menu, and 

the Preferences dialog box will be displayed.    To make changes for the active document only, 
choose Document Properties from the Configure menu, and the Properties For ... dialog box will be 
displayed.

2. Select the Tabs tab.
3. In the Tab Size box, type the character spacing between tab stops.
4. In the Indent Size box, type the character spacing for each line indentation.    This is best set to the 

same value as tab stops, otherwise indentation will be made up of a mixture of spaces and tabs.
5. Check Convert New tabs to Spaces, if you want tabs converted to the equivalent number of spaces.
6. Check Convert Existing Tabs to Spaces When Saving Files, if you want existing tabs converted to 

the equivalent number of spaces.    This does not make any changes, until a document is saved.
7. Click OK.



How to Customize the Tools Menu
You can add up to 10 of your own commands to the tools menu as follows:
1. From the Configure menu, choose Preferences.    The Preferences dialog box is displayed.
2. Select the Tools tab.
3. Click New, and choose Command.    The Select File dialog is displayed.
4. Either use the Select File dialog to select an executable file and click OK, or click Cancel if you want 

to add a DOS internal command, such as DIR.
5. Make any necessary changes to the command in the Command box.    If you clicked Cancel in the 

previous step, this will have been initialized to User Tool, which must be changed.    Note that the 
command must include its full path name, unless it is on your search path.

6. Make any necessary changes to the text that will appear on the Tools menu in the Menu Text box.    
This box is initialized from the text in the Command box.

7. In the Parameters box, type any parameters required to run this tool.    You can include any tool 
macros here.

8. In the Initial Directory box, type the startup directory for the command.    This defaults to the directory 
containing the tool. You can include directory tool macros here.

9. Check Prompt for Parameters, if you want to supply different parameters each time you choose this 
tool.    The parameters you type in the Tool Parameters dialog at run time will be appended to those 
in the Parameters box.

10. Check Run Minimized, if you want the tool to run displayed as an icon.
11. Check Capture Output, if you want to see the output from the tool in the Command window.    This 

only applies to DOS or console commands.
12. Check DOS Command, if the tool is an internal DOS command, such as DIR or TYPE.
13. Click Move Up or Move Down to set the order of this tool on the Tools menu.
14. Click OK.

Examples:
1. Compiling the active file with the JAVA compiler:

Menu text: Compile JAVA
Command: JAVAC.EXE
Parameters: $File
Initial directory: $FileDir
Capture Output: (x)

2. Viewing the active HTML document with Internet Explorer:
Menu text: View HTML
Command: IEXPLORE.EXE
Parameters: -nohome file:$File



How to Customize View Preferences
You can customize these view settings by choosing Preferences from the Configure menu:

Set this Option: To Do This:
Tool Bar Display the tool bar at the top of the main 

window.
Status Bar Display the status bar at the bottom of the main

window.
Clock Display the digital clock on the status bar.
Tool Bar popup tips Display tool bar help by holding the cursor over 

a button.
Visible alerts Flash the window whenever the beeper is 

sounded.
Stay on top of other 
windows

Keep the main window on top of all others, 
even when another application is active.

Visible spaces and 
tabs

In visible mode, spaces are shown as ( ) , tabs 
as (»), and line ends as (¶).

Block caret Display the caret as a block, instead of a 
vertical bar.    The caret is temporarily changed 
to the alternate form in overtype mode.

Vertical Splitter Allow each view to be split vertically into two 
using the Split Window command on the 
Window menu.    The default is for views to be 
split horizontally.    This option is disabled if any 
windows are open.

Horizontal scroll bar Display a horizontal scroll bar in each view.    
This option is checked and disabled if Vertical 
Splitter is checked.



How to Configure Document Properties
To configure properties for the active document, choose Document Properties from the Configure menu, 
then choose one of the following tabs from the dialog box:
Document for word-wrap and indentation settings.
View for scroll bars and visible spaces.
Tabs for tab settings.
Statistics for information about the document, such as its word count.



How to Configure View Properties
You can change these settings for the active view by choosing Document Properties from the Configure 
menu, and selecting the View tab:

Set this Option: To Do This:
Horizontal scroll bar Display a horizontal scroll bar in each view.    

This option is checked and disabled if Vertical 
Splitter is checked on the View tab of the 
Preferences dialog box.

Visible spaces and 
tabs

In visible mode, spaces are shown as ( ) , tabs 
as (»), and line ends as (¶).



How to View Document Statistics
You can view these properties of the active document by choosing Document Properties from the 
Configure menu, and selecting the Statistics tab:

Property: Notes:
Full name Shows the fully qualified file name.    You may 

need to scroll to the end if the name is longer 
than the available display space.

Last saved at Shows the date and time that the document 
was last written to its disk file.

Character count Shows the number of characters in the 
document.

Line count Shows the number of lines in the document.    
Note that a word-wrapped line is counted as a 
single line.

Word count Shows the number of words in the document.    
A word is composed of letters, numbers, 
hyphens, underscores and apostrophes.

Code set This can be ANSI or DOS (OEM)
File type This can be PC, UNIX or MAC.



Page Header/Footer Macros
The following macros can be used in the Header and Footer boxes in the Configure Printing 
dialog:

Use To Get
&d The current date in Windows short form.
&D The current date in Windows long form.
&t The current time in Windows format.
&f The filename, excluding its path.
&F The full filename, including its path.
&p The page number.
&l Text that follows this code is to be left justified.
&c Text that follows this code is to be centred (this is the

default).
&r Text that follows this code is to be right justified.

For example: to get a page header that looks like:

Left Center Right
readme.txt Page 1 10/11/96

Set the header to "&l&f&cPage &p&r&d



Quick Open File Dialog Box
This dialog box allows you to open a file, when you do not need the browsing capabilities of the standard
Open File dialog box, and you are willing to type the file name.
Use Ctrl+Shift+O to bring up this dialog box.    There is no menu or toolbar equivalent command.
Click the Browse button to get the standard Open File dialog box.



Fill Selected Block Dialog Box
This dialog box appears when you choose the Fill Block command from the Edit menu.
Type in the character or characters that you want to fill the current block selection with.    You can fill with
tabs by entering ‘\t’ as the fill character.    If you actually want to fill with ‘\t’, enter it as ‘\\t’.



Manage Files Dialog Box
Use the manage Files dialog to:
 Copy Files
 Delete Files
 Rename Files
 Update Timestamps of Files
The Browse button brings up the standard Open File dialog box, so that you can select the file or files 
you want to manage.



Copy/Rename/Move Dialog Box
This dialog box appears when you click Copy or Rename on the Manage Files dialog box.
Confirm that the files in the From box are what you want, and edit them if necessary, then type the 
destination file name, wild card or directory name in the To box.
The Browse button brings up the standard Open File dialog box, so that you can select the destination 
file name.



Delete/Touch Dialog Box
This dialog box appears when you click Delete or Touch on the Manage Files dialog box.
Confirm that the files in the edit box are what you want, and edit them if necessary.    Then click OK.



Tool Parameters Dialog Box
This dialog appears when you choose a user tool from the Tools menu and you checked the Prompt for 
Parameters box when you configured this tool.
Type any parameters that the program requires in the Parameters box, and click OK.



Go To Line dialog box
This dialog box is displayed when you choose the Go To Line command from the Search menu (Ctrl+G).
Type the required line number in the Go To Line box, and click Go To.
If you want to select everything between the current position and the start of the given line, check the 
Extend Selection box.



Go To Address dialog box
This dialog box is displayed when you choose the Go To Address command from the Search menu 
(Ctrl+G) in Hex views.
Type the required hexadecimal offset in the file in the Go To Address box, and click Go To.



How to Edit: Overview

TextPad loads an entire file into memory when you edit it, so the original file is not changed until you 
save the changes.    You can opt to keep the original file as a backup when saving changes.
UNIX, Mac and PC files use different end of line characters, which TextPad automatically recognizes.    
These will be preserved when you save the file, unless you choose to save with a different format, using 
the Save As command.
If a file has long lines, you can choose to scroll horizontally when the line extends beyond the right 
margin, or have words wrapped at the right margin, or at a specified column position.    If you specify a 
column position, hard line breaks will be inserted where words are wrapped, when you save the 
changes.    Otherwise, the file is saved with long lines, which you can think of as paragraphs.    You can 
configure these settings using the Preferences command and selecting the Document tab of the 
Preferences dialog box.
The basic functions for moving around in the text, and making simple edits follow the conventions of 
other Windows applications, so you can get started immediately.    The more powerful editing commands
are all on the menus, with their shortcuts shown against them, so you should be able to get up to speed 
quickly.
Any changes you make (except converting the code set between DOS and ANSI) can be undone, and 
you can redo changes you undo.    You can opt to undo even after saving the changes, using the 
Preferences command and selecting the Document tab of the Preferences dialog box.
You can record the commands to make repetitive edits as keystroke macros, which you can playback on
different parts of the text.



How to Move Around in Text
To Move the Caret: Press This Key:
To a specified line, column or page 
number

Ctrl+G and fill in the number

To the mouse cursor position Left button
To the beginning of the file Ctrl+Home
To the end of the file Ctrl+End
To first non-space character on a line Home
To the start of a line Home twice
To the end of a line End
To the start of the first visible line Alt+Home
To the start of the last visible line Alt+End
Forward one character Right arrow
Back one character Left arrow
Down one line Down arrow
Up one line Up arrow
Forward one word Ctrl+W or Ctrl+Right arrow
Back one word Ctrl+B or Ctrl+Left arrow
Forward to end of current word Ctrl+E
Back to end of previous word Ctrl+D
Scroll down one line Ctrl+Down arrow
Scroll up one line Ctrl+Up arrow

Caret Mode:
The caret can be constrained to positions within the existing text only, or can be free to be placed 
anywhere in the document window.    This setting is changed with the Constrain Caret command on the 
Configure menu.
When the caret is constrained, the left and right arrows wrap around to the previous or next line at the 
beginning and end of a line respectively.
In block selection mode, the Constrain Caret command is disabled.



How to Select Text
Text can be selected in block (column) or normal mode.    Use the Block Select Mode command on the 
configure menu to switch between modes.

To select any text with the mouse:
1. Press and hold the left button down at the start of the text you want to select.
2. Drag the cursor to the end of the selection, and release the button.

or
1. Click the left button at the start of the selection.
2. Hold the Shift key down and click the left button at the end of the selection.

To select any text using the keyboard:
1. Use any of the caret motion keys to move the caret to the start of the text you want to select.
2. Press and hold the shift key down whilst using the motion keys to move the caret to the end of the 

selection.

To select a word:
Move the cursor over the word and double click the left button.

To select a whole line:
Double click the left button in the left margin, next to the line.

To select a block of text:
1. Make sure that word-wrapping is turned off.
2. Choose Block Select Mode from the Configure menu.
Shortcut: Alt+Left click toggles block select mode on and off.
3. Use the keyboard or mouse to mark the selection as normal.

To select the whole file:
Choose Select All from the Edit menu.
or
Click Ctrl+Left button anywhere in the left margin.

To cancel a selection:
Press ESC.



How to Use the Clipboard
To insert text from the clipboard:

Position the caret and choose the Paste (Ctrl+V) command from the Edit menu.
Toolbar: 

To copy selected text to the clipboard:
Choose the Copy (Ctrl+C) command from the Edit menu.

Toolbar: 

To move selected text to the clipboard:
Choose the Cut (Ctrl+X) command from the Edit menu.

Toolbar: 

To move the line containing the caret to the clipboard:
Cancel any selection (ESC) and choose the Cut Line (Ctrl+Y) command from the Edit menu.

To move the word containing the caret to the clipboard:
Cancel any selection (ESC) and choose the Cut Word (Ctrl+Q) command from the Edit menu.

To copy all bookmarked lines to the clipboard:
Choose the Copy Bookmarked Lines command from the Edit menu.

To move all bookmarked lines to the clipboard:
Choose the Cut Bookmarked Lines command from the Edit menu.

To append text to the existing contents of the clipboard:
Choose one of the Cut Append or Copy Append commands from the Edit menu.



How to Drag and Drop
You can use the mouse to move or copy text within a document, or to another document, as follows:

To move selected text:
1. Hold the left button down in the selection.
2. Drag the caret to the new location.
3. Release the left button.

To copy selected text:
1. Hold Ctrl+Left button down in the selection.
2. Drag the caret to the new location.
3. Release the left button.

To cancel a drag-drop:
Press ESC, or
Click the right button, or
Release the left button in the selection.

Notes:
1. The Ctrl key can be pressed or released at any time before releasing the left button, to make the 

drag a copy or a move.
2. If the new location is not visible, hold the cursor at the edge of the window nearest to the destination,

and it will scroll through the file until the cursor is moved away.



How to Delete Text
You can delete different amounts of text as follows:

To Delete This: Do This:
Selected text Delete or Backspace
The next character Delete
The previous character Backspace
To the start of the next word Ctrl+Delete
Back to the last start of word Ctrl+Backspace
To the end of the line Ctrl+Shift+Delete
The current line Ctrl+Y (note that this moves it to 

the clipboard)
The whole document Alt+Delete
Lines with bookmarks Choose the Delete Bookmarked 

Lines command from the Edit 
menu.

See Also:
How to Use the Clipboard for commands to save deleted text on the clipboard.



How to Change Case
Select the text to be changed, and then:

To Do This: Use this Edit Menu Command:
Change all to lower case Lower Case (Ctrl+L)
Change all to upper case Upper Case (Ctrl+U)
Invert the case of each character Invert Case (Ctrl+K)
Make the first character of each word 
upper case and the rest lower case

Capitalize (Ctrl+Shift+U)

How to Indent Lines
To increase the indentation of multiple lines:

1. Select the lines to be indented.
2. Choose Indent (Tab) from the Edit menu.

Toolbar: 

To reduce the indentation of multiple lines:
1. Select the lines to be unindented.
2. Choose Unindent (Shift+Tab) from the Edit menu.

Toolbar: 

To change the indentation level of a single line:
Either use the toolbar commands, or delete or insert tabs at the beginning of the line.

Note:
The indentation level of lines changes by increments of the indent size, which can be changed on the 
Tab Settings property sheet.



How to Join Lines
You can join single or multiple lines, such that each line in turn is appended to the first, separated by a 
single space.

To join a single line to the current line:
1. Cancel any selection (ESC).
2. Choose Join Lines (Ctrl+J) from the Edit menu.

To join multiple lines to the current line:
1. Select all the lines to be joined.
2. Choose Join Lines (Ctrl+J) from the Edit menu.

Word-Wrap Joins
When multiple lines are joined in word-wrapping mode, empty lines are treated as paragraph marks.    
So a new sequence of joined lines is started after each blank line, preserving the original paragraphs.



How to Split Long Lines
In word-wrapping mode, you can split long lines into separate lines where they are wrapped, as follows:
1. Select the lines to split.    (Note: Ctrl+Left mouse in the margin selects all.)
2. Choose Split Wrapped Lines (Ctrl+Shift+J) from the Edit menu.



How to Reformat Paragraphs
When not in word-wrapping mode, you can adjust the lengths of currently selected lines to the word-
wrap margin.    Words are moved between the lines as necessary, and blank lines are preserved as 
paragraph separators.
To reformat paragraphs:
1. Select the lines to reformat.    (Note: Ctrl+Left mouse in the margin selects all.)
2. Choose Reformat (Ctrl+Shift+J) from the Edit menu.



How to Insert New Lines
To Create a New Line: Press This Key:
After the current line Ctrl+I or End Enter
Before the current line Ctrl+Shift+I or Home Enter
By splitting the current line Enter

How to Insert the Date or Time
You can insert the current date and time, using the formats defined with the International applet on 
Control Panel, as follows:

To Insert this: Choose this Edit Command:
The current time Insert Time
Today's date in short format Insert Short Date
Today's date in long format Insert Long Date

Shortcuts:
Mouse: Ctrl+Right click at the insertion point.
Keys: Ctrl+F10.



How to Insert a Page Break 
1. Move the caret to the first line to be printed on a new page.
2. Choose Insert Page Break (Ctrl+Shift+L) from the Edit menu.

More Information:
This actually inserts the ASCII 0x0C (Ctrl+L) character in the text, but displays it on the screen as «, and 
draws a line at the point where the page break would occur on a printer.
The Page Break character is only recognised when it is the first character of a line.



How to Insert a File
1. Move the caret to the insertion point.
2. Choose Paste File from the Edit menu.    The File Open dialog appears.
3. Select the file you want to insert.
4. Click OK.



How to Insert Line Numbers
To insert consecutive line numbers at the start of each line:
1. From the Search menu, choose Replace;
2. In the Find What box type "^" (without the quotes);
3. In the Replace With box, type "\i " (without the quotes), if the line numbers start at 1, or "\

i(100) ", if they start at 100, etc.;
4. Check the Regular Expression box;
5. Click Replace All.

More Information:
See How to Generate Sequence Numbers.



How to Transpose Text
To transpose adjacent characters:
1. Move the caret between the two characters to be transposed.
2. Choose Transpose Characters (Ctrl+T) from the Edit menu.    The characters will be swapped 

around.

To transpose adjacent lines:
1. Move the caret to the end of the first line, or start of the second line.
2. Choose Transpose Lines (Ctrl+T) from the Edit menu.    The lines will be swapped around.

To transpose adjacent words:
1. Move the caret between the two words to be transposed.    This may be on a space, or intervening 

punctuation, or the beginning or end of a line.
2. Choose Transpose Words (Ctrl+Shift+T) from the Edit menu.    The words will be swapped around.



How to Fill Blocks
Block filling is only enabled when block select mode has been set from the Configure menu, and a block 
of text has been selected.

To fill with Characters:
1. Choose the Fill Block command from the Edit menu.
2. In the Fill Selected Block dialog box, enter the characters you want to fill with.
3. Choose the format of the fill characters within the selected block.    They can be aligned left or right, 

or repeated to fill the block.
4. Click OK.

To fill with Numbers:
1. Choose the Fill Block command from the Edit menu.
2. In the Fill Selected Block dialog box, enter the starting number, and the amount to increment it by.    

These must be integers, and may be positive or negative.
3. Choose the format of the numbers within the selected block.    They can be aligned left or right, or 

with leading zeros to fill the block.
4. Click OK.

Notes:
To fill with a tab, enter "\t" (without the quotes).    If you actually want to fill with the characters "\t", enter it

as "\\t".



How to Display Spaces and Tabs

Displays spaces tabs and paragraph marks 
as visible characters. Spaces are shown as (
) , tabs as (»), and line ends as (¶).

Click the button a second time to hide visible spaces.
You can also turn them on and off from the View tab of the Preferences and Properties dialog boxes.



How to Cancel the Last Action
To cancel the last edit:

Choose Undo (Ctrl+Z) from the Edit Menu
Toolbar: 

To cancel the last undo:
Choose Redo (Ctrl+A) from the Edit Menu.

Toolbar: 

To cancel all edits:
Type Ctrl+Shift+Z.

To redo all edits:
Type Ctrl+Shift+A.

Note:
The Undo command can be repeated until all changes made since the file was opened, or last saved, 
have been undone.



Frequently Asked Questions
Before reporting any problems, please check this list to see if there is a known solution:

Why can't TextPad open files with spaces in their names, using Explorer?
Why can't TextPad open files with spaces in their names, using the Open File dialog box?
When I save a file as NAME.EXT, why is it saved as NAME.EXT.TXT?
Why do I get an error message from CTL3DV2.DLL or CTL3D32.DLL?
Why did drag and drop stop working after I upgraded TextPad?
Why doesn't TextPad preserve the original file's creator (and UNIX access modes) when it saves 

changes?



Why can't TextPad open files with spaces in their names, using Explorer?
TextPad can open more than one file at a time using the command line:

txtpad32.exe file1 file2 file3
So, if any of the names contain spaces, they must be quoted, as in:

txtpad32.exe "My File 1" "My File 2"
As a special case, a single filename, containing spaces, can be used without quotes, if the parameter -u 
is also used, as in:

txtpad32.exe -u My File
This problem generally only arises if you have set up TextPad's file associations manually, using a 
command of the form "txtpad32.exe %1", without quoting the "%1".    If you use the Associations tab on 
the Preferences dialog box to do it, File Manager and Explorer will communicate with TextPad using 
DDE, rather than command line parameters, so spaces are not significant.
Note that there is a bug in Explorer which causes it to add an invisible "%1" (without the essential 
quotes) to the command line when you use it to edit any associations.    This overrides any DDE 
configuration, and causes problems if filenames contain spaces.    This "%1" can only be seen and 
removed using Regedit.



Why can't TextPad open files with spaces in their names, using the Open File 
dialog box?

TextPad uses the common Open File dialog box, which has a design fault in Windows versions prior to 
95 and NT 4.    When it is enabled for multiple selection, it uses a space to separate each file name, so 
gets confused if a name includes spaces.    The workaround is to clear the "Use multiple selection Open 
File dialog box" field on the General tab of the Preferences dialog box (or get the latest version of 
Windows!).



When I save a file as NAME.EXT, why is it saved as NAME.EXT.TXT?
This is a feature of the Save As dialog box in Windows 95 and NT 4.    If you specify an unknown 
extension, the first extension in the currently selected "Save as type" box is used.    The solution is either
to set the Save as type to "*.*", or to quote the filename.



Why do I get an error message from CTL3DV2.DLL or CTL3D32.DLL?
These dynamic link libraries must be installed in your Windows system directory only.    If you also have 
a copy in the TextPad installation directory, or anywhere on your search path, it will notify you that it has 
failed to load.    The effect is that you will not get 3-D dialogs on Windows 3.1 or NT 3.51.    (Windows 95 
and NT 4 do not use the DLL's.)    The solution is to delete all other copies of these DLL's.



Why did drag and drop stop working after I upgraded TextPad?
Editions of TextPad prior to 2.0 had a fallback implementation of drag and drop that didn't use OLE.    It 
used an anchor cursor, instead of the conventional OLE one.    If you were using that when you 
upgraded, drag and drop will have been disabled.    To enable it again:
1) Close all documents (in TextPad).
2) From the Configure menu, choose Preferences.
3) On the General tab, check "Use OLE drag and drop".
4) Click OK.
Note that you must have the OLE 2 system installed for this to work.    It's standard with Windows 95 and
NT, and you can get it for Windows 3.1 from:

http://www.microsoft.com/kb/faq/devtools/winsdk/win32s/faq3474.htm
and

CompuServe forum WINSHARE as WN32SOLE.ZIP.



Why doesn't TextPad preserve the original file's creator (and UNIX access modes)
when it saves changes?

For safety, TextPad (32-bit only) normally saves changes to a temporary file, before deleting the original. 
This loses the original file's creator on file systems (such as NTFS) that maintain such information.    
There is an option on the Backup tab of the Preferences dialog box to change this behaviour.    When 
selected, the original file is overwritten, which preserves the creator, at the risk of losing the original file if
the save operation fails.





How to Create a New File
To create a new unnamed document:
From the File menu, choose New.

Toolbar: 

The new document may be given a name using the Save As command on the File menu.

To create a new named file:
1. From the File menu, choose Open (Ctrl+O).    The File Open dialog appears.
Toolbar: 

2. In the Directories box, double-click a directory where you want to store the source file (or move up or
down a path to the appropriate directory).

3. Type the file name in the File Name box, and click OK. The default extension given to a file is .TXT, 
unless you specify something else.

4. Click Yes on the message box that appears, asking if you want to create the file.
5. Use the editor to type the contents of the file.



How to Open an Existing File
1. From the File menu, choose Open (Ctrl+O).    The File Open dialog appears.
Toolbar: 

2. Select the drive and directory where the file is stored.    The default is the current drive and directory.
3. Set the types of files to display in the List Files of Type box.    Files with the chosen extension are 

displayed in the File Name box.    This box serves as a filter to display all files with a given extension. 
For example, Source (*.cpp,*.c,*.h) displays all files with the given extensions. The drop-down box 
initially lists commonly-used file extensions.    Alternatively, you can specify wildcard patterns in the 
File Name box to display file types.    The new wildcard pattern is retained until the dialog box is 
closed.    You can also use any combination of wildcard patterns, delimited by semicolons.    For 
example, entering "*.TXT; *.INI" displays all files withthose extensions.

4. If you want to override the automatically determined file format, choose from the drop-down list as 
follows:

File 
Type:

Definition:

Auto A file with an extension matching the internal list 
of binary extensions will be viewed in 
hexadecimal, otherwise it will be opened as a 
text file.

Text The file is read as text in the selected character 
set.

Binary The file is binary and will be viewed in 
hexadecimal.

5. If you want to disable edits to the file, check the Read Only box.
6. In the File Name box, click a filename, then click OK.
Shortcut: Double-click a filename.

Tips:
You can select multiple files to open at once, by using Ctrl+Left button to select each in turn, or 

Shift+Left button to select a range of files.
The use of spaces for multiple file opening conflicts with long file names (except on Windows 95),

so to see long file names in the File Open Dialog, uncheck “Use multiple selection Open File dialog box” 
on the General tab of the Preferences dialog box.



How to Open a Hex View of a File
1. From the File menu, choose Open (Ctrl+O).    The File Open dialog appears.

Toolbar: 

2. Select the file to open.
3. Click the down arrow next to the File Format box.
4. Choose "Binary" from the drop-down list.
5. Click OK.

Tips:
You can select multiple files to open at once, by using Ctrl+Left button to select each in turn, or 

Shift+Left button to select a range of files.
The use of spaces for multiple file opening conflicts with long file names (except on Windows 95),

so to see long file names in the File Open Dialog, uncheck “Use Multiple File Open Dialog Box” on the 
General tab of the Preferences dialog box.



Binary File Extensions
The following file extensions are assumed to be associated with files containing binary, or non-textual 
data:

COM .EXE .DLL .SYS .DRV .386 .DOS
LIB .OBJ .PIF .RES .SYM .BIN .ZIP
FON .FOT .TTF .MID .WAV .GRP .VBX
WMF .TIF .PCX .BMP .CUR .ICO .TWS
HLP .PPT .DOT .WRI .MDB .DBF .FRX
XLS .IMP .WK1 .WK2 .WK3 .WK4

You can customize this list from the Binaries tab of the Preferences dialog box.



How to Save a File
1. Switch to the source window.
2. From the File menu, choose Save (Ctrl+S).

Toolbar: 

3. If your file is unnamed, the Save As dialog box is displayed.    In the File Name box, type the 
filename.

4. In the Drives and Directories boxes, select a drive and directory.
5. Click OK.



How to Save a File with a Different Name
1. From the File menu, choose Save As.    The Save As dialog box appears.
2. Select the drive and directory where the file is to be stored.    The default is the current drive and 

directory.
3. Choose the File Format if you want to convert from the original.
4. In the File Name box, type the filename.
5. Click OK.



How to Save the Workspace
You can arrange for TextPad to "warm start" - that is, start up exactly where you left off when you last 
shut it down.    To enable this feature:
1. Choose Preferences from the Configure menu.    This brings up the Preferences dialog box.
2. On the General tab, check "Save the Workspace".
3. Click OK.

Notes:
The workspace is preserved in a file called TEXTPAD0.TWS in your Windows directory.
If more than one instance of TextPad is running, only the workspace of the first one to be started 

will be preserved.
If TextPad is started up with the command line parameter "-s" (which is how DDE starts it), the 

workspace is not restored, nor saved when you exit.
On Windows 95, if this option is enabled and you shut down Windows whilst TextPad is still 

running, it will be automatically restarted when Windows starts up again.



How to Close a File
1. Switch to the file's window.
2. From the File menu, choose Close. This action closes the active window and any additional views of 

the window.

Tip:
When the Window Selector has the input focus, pressing the Delete key closes the highlighted file.



How to Convert a File for PC, Unix or Mac
1. From the File menu, choose Save As.    The File Save As dialog appears.
2. Select the drive and directory where the file is to be stored.    The default is the current drive and 

directory.
3. In the File Name box, type the filename.
4. Choose the file format from the drop-down list as follows:

Charact
er Set:

Definition:

PC The file is saved in DOS PC format with a 
carriage return/line feed at the end of each 
line.

Unix The file is saved in the Unix format with a 
line feed at the end of each line.

Mac The file is saved in the Apple MAC format 
with a carriage return at the end of each line.

5. Click OK.



How to Work with DOS Files
Overview:
Windows applications normally use the ANSI code set, whilst DOS applications use the DOS code set 
(also known as OEM and IBM).    The numeric codes that are assigned to the English alphabet, numbers
and various other common characters are the same in both sets, but characters with codes above 
decimal 127 (hex 7F), such as the line drawing set, use different codes, and some are unique.
Text on the clipboard presents an additional complication.    If it's been cut or copied from a DOS box, 
TextPad will convert to the ANSI code set before pasting, unless you work in the DOS code set as 
described in option 3 below.
Windows has one TrueType font that uses the DOS code set, called MS LineDraw.    It also has a raster 
font, called Terminal on Windows 95 and NT, and 8514OEM on Windows 3.1.

Options for working with DOS files:
1. There is a Convert command on the Tools menu to convert between the character sets. TextPad 

selects the MS LineDraw font, after converting to DOS, and the default font after converting to ANSI.
Disadvantage: the process is not reversible for the unique characters.

2. You can choose to edit DOS files in ANSI, by checking the "Work in ANSI" option on the File tab of 
the Preferences dialog box.    In this case, if you check the "DOS Code Set" box when you open a file
(or set it as the default on the File tab of the Preferences dialog box), files are automatically 
converted to ANSI as they are read in, and back to DOS as they are saved.
Disadvantage: the process is not reversible for the unique characters.

3. You can edit a DOS file without converting the characters, by unchecking the "Work in ANSI" option 
on the File tab of the Preferences dialog box. In this case, if you check the "DOS Code Set" box 
when you open a file (or set it as the default on the File tab of the Preferences dialog box), the MS 
LineDraw font is automatically selected for that file (overriding the default font).
Disadvantage:  edit controls in dialog boxes, such as Find and Replace, continue to use the ANSI 
code set, so they will display some characters differently.



How to Set the Default File Folder
You can change the default file folder (or working directory) for TextPad, by changing the way TextPad is 
started.    See under the appropriate heading below for how to do this with the version of Windows that 
you have.

From a Windows 3.1/NT 3.51 Program Manager Icon:
1. Click the Program Manager icon for TextPad.
2. Type Alt+Enter to get its properties dialog box.
3. Fill in the Default Directory field with the required directory, and click OK.

From a Windows 95/NT 4 Desktop Icon:
1. Right click the desktop icon for TextPad.
2. Choose Properties to get the properties dialog box.
3. Fill in the Start In field on the Shortcut tab with the required folder name, and click OK.

From the Windows 95/NT 4 Taskbar Start Menu:
1. Right click the Taskbar.
2. Choose Properties to get the Taskbar Properties dialog box.
3. Click the Advanced button on the Start Menu Programs tab.
4. Select "Programs" on the Explorer view.
5. Right click TextPad on the right hand pane, and choose Properties.
6. Select the Shortcut tab, and fill in the "Start In" field with the required folder name.
7. Click OK to close all the dialog boxes.

Tip:
To keep TextPad's current working directory in the chosen folder, uncheck "Directory follows Active 
Document" on the General tab of its Preferences dialog box.



How to Switch to a File's Window
Do one of the following:
Click anywhere in the window.
Choose the window name from the Window menu.
Double click the window name in the Window Selector.
Press Ctrl+F6 or Ctrl+TAB to cycle through the active source windows one at a time.



How to Create a Second View
Using the Keyboard:
1. From the Window menu, choose Split.
2. Use the up and down arrows to move the horizontal bar to where you want to split the window.
3. Press Enter to create the second view, or Escape to cancel.

Using the Mouse:
Drag  from the top of the scroll bar to where you want to split the window.

To Close the Second View:
Drag the splitter bar to the top or bottom of the view.



How to Use the Window Selector
The Window Selector is a list box showing the each of the files you are editing.    You can display it by 
choosing Use Selector (F11) from the Window menu.
The Window Selector displays the files in alphabetical order, and it can be resized to fit the file names it 
lists.    Its size and position are remembered between sessions.
You can use the following keys when the Window Selector is active:

Use this Key: To Do This:
Esc Close the Window Selector.
Left Click Select the file window.    If not already 

the active window, activate it.
Left Double Click Select and activate the file window.
Enter Activate the file window.
Delete Close the selected file window.
Up Arrow Select the previous window in the list.
Down Arrow Select the next window in the list.
Home Select the first window in the list.
End Select the last window in the list.



How to Print a File
1. Switch to the file’s window.
2. From the File Menu, choose Print.    The Print dialog box appears.
3. Click "All" for the print range.
4. Click OK.

Shortcuts:
Keys: Ctrl+P
Toolbar:

(Prints to the default printer, unless you hold Shift down at the same time)



How to Display a Page Before Printing
1. From the File Menu, choose Print Preview.
2. Click OK.    The print preview mode will be set, starting at the page containing the caret.
3. Click Next Page or Prev Page to see each page in turn.
4. Click Close to return to normal viewing mode.

Notes:
When you choose this command, the main window will be replaced with a print preview window in which
one or two pages will be displayed in their printed format.    The print preview toolbar offers you options 
to view either one or two pages at a time; move back and forth through the document; zoom in and out 
of pages; and initiate a print job.

Shortcuts:
Toolbar:

Keys: Ctrl+Shift+P



How to Copy a File
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to copy.    This may include a path if it is not in the current 
working directory.    The filename may be a wildcard pattern if you want to copy multiple files.

3. Click Copy.    The Copy dialog appears.
4. Type the name that you want to give the copy.    If this is just a pathname, the file is copied to that 

directory, keeping its original file name.
5. Click OK.



How to Rename a File
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to rename.    This may include a path if it is not in the current 
working directory.    The filename may be a wildcard pattern if you want to rename multiple files.

3. Click Rename.    The Rename dialog appears.
4. Type the new name that you want to give the file.    If this is just a pathname, the file is moved to that 

directory, keeping its original file name.
5. Click OK.



How to Delete a File
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to delete.    This may include a path if it is not in the current 
working directory.    The filename may be a wildcard pattern if you want to delete multiple files.

3. Click Delete.    The Delete dialog appears.
4. Click OK to confirm that you really want to delete the file.



How to Update a File's Time Stamp
1. From the File Menu, choose Manage Files (F3).    The Manage Files dialog appears.

Toolbar: 

2. Type the name of the file that you want to update its last modified date to the current time.    This may
include a path if it is not in the current working directory.    The filename may be a wildcard pattern if 
you want to update multiple files.

3. Click Touch.    The Touch dialog appears.
4. Click OK to confirm that you really want to update the file.



How to Compare Text Files
1. From the Tools menu, choose the Compare Files command.    The Compare Files dialog box 

appears.
2. In the First File box, type the name of the first file to be compared.    This is initialised with the 

filename of the active document, if appropriate.
3. In the Second File box, type the name of the second file to be compared.    If it has the same name in

another directory, just type the path name.
4. Choose if you want to ignore differences due to upper and lower case letters.
5. Choose if you want to ignore differences due to the number of spaces or tabs.    Note that tabs or 

spaces, where there are none in the other file, will still be flagged as a difference, unless they are 
leading or trailing.

6. Click OK to start the comparison.

The differences are written to the Command Output window using the following conventions:
Symbol: Meaning:
< Precedes each different line from the first file.
> Precedes each different line from the second file.
a Means that the lines following were added.
d Means that the lines following were deleted.
c Means that the lines following were changed.
--- Separates changed lines in the first file from the 

second.



The ANSI Code Set
This table displays the full ANSI code set using the Courier font:

0 1 2 3 4 5 6 7 8 9 A B C D E F
00: NUL SOH STX ETX EOT ENQ ACK BEL BS HT LF VT FF CR SO SI
10: DLE DC1 DC2 DC3 DC4 NAK SYN ETB CAN EM SUB ESC FS GS RS US
20: ! " # $ % & ' ( ) * + , - . /
30: 0 1 2 3 4 5 6 7 8 9 : ; < = > ?
40: @ A B C D E F G H I J K L M N O
50: P Q R S T U V W X Y Z [ \ ] ^ _
60: ` a b c d e f g h i j k l m n o
70: p q r s t u v w x y z { | } ~ DEL
80: €  ‚ ƒ „ … † ‡ ˆ ‰ Š ‹ Œ  Ž 
90:  ‘ ’ “ ” • – — ˜ ™ š › œ  ž Ÿ
A0:   ¡ ¢ £ ¤ ¥ ¦ § ¨ © ª « ¬ ® ¯
B0: ° ± ² ³ ´ µ ¶ · ¸ ¹ º » ¼ ½ ¾ ¿
C0: À Á Â Ã Ä Å Æ Ç È É Ê Ë Ì Í Î Ï
D0: Ð Ñ Ò Ó Ô Õ Ö × Ø Ù Ú Û Ü Ý Þ ß
E0: à á â ã ä å æ ç è é ê ë ì í î ï
F0: ð ñ ò ó ô õ ö ÷ ø ù ú û ü ý þ ÿ

See also: DOS code set



The DOS Code Set
This table displays the full DOS code set using the MS LineDraw font:

See also: ANSI code set



How to Find Text
You can find each occurrence of a combination of any characters, including uppercase and lowercase 
characters, whole words, or parts of words, or regular expression.

To find text:
1. From the Search menu, choose Find (F5).    This starts a modeless dialog box which remains on the 

screen until you close it.

Toolbar: 

2. In the Find What box, type in the search string, or choose a previous string from the drop-down list.
3. Set the options you want to control the search.

Select: To:
Text Specify a text search 

string.
Hex Specify a search string 

in hexadecimal.
Match Whole
Word

Find occurrences of the 
text as a whole word.

Match Case Find text having the 
given pattern of 
uppercase and 
lowercase letters.

Regular 
Expression

Specify that the search 
string is a regular 
expression.

Backwards Search the document 
above the insertion 
point.

Forwards Search the document 
below the insertion 
point.

4. Choose Find Next. If the search string is found, the screen scrolls so you can see the text in context.
 or
Choose Mark All to place a bookmark on each line containing the search string.

5. Either close the dialog by clicking the Cancel button, or continue editing as normal.

Tips
1. The Find What box will be initialised with the current selection, if any (as long as it is on a single 

line), or the last search pattern entered.
2. The Find Next command (Ctrl+F) will copy the current selection to the Find What box.
3. To do a forward search after closing the dialog box, press Ctrl+F.
4. To do a backwards search after closing the dialog box, press Ctrl+Shift+F.
5. Match Whole Word is equivalent to the regular expression \<RE\>.

 Examples



How to Replace Text
You can find and replace each or every occurrence of a text pattern, in the current file, or all loaded files.

To Replace Text:
1. From the Search menu, choose Replace (F8).    This starts a modeless dialog box which remains on 

the screen until you close it.

Toolbar: 

2. Specify the text to replace as described in Finding Text.
3. Type the Replacement Expression in the Replace With box, or choose a previous string from the 

drop-down list.
4. Set the scope of the search:

Select: To:
Active 
Document

Search in current 
document only.

Selected 
Text

Search in currently 
selected text in current 
document.

All 
Documents

Search in all text in all 
open documents.

5. Choose one of the following actions:
a) Click Find Next to select the next occurrence.
b) Click Replace to replace the current selection.
c) Click Replace Next to replace the current selection, and find the next occurrence.
d) Click Replace All to replace all occurrences of the search text, in the specified scope.

Note that Find Next, Replace and Replace Next are only enabled when the scope is Active Document.
6. Either close the dialog by clicking Cancel, or continue editing as normal.

Tips:
The Replace button will replace the current selection, so make sure you press Find Next first.
Because edit controls do not allow tabs to be input, '\t' is used (without the quotes) to represent a 

tab.    If you want to replace text with literal '\' and 't' characters, specify '\\t' in the Replace With box.
 Examples



How to Use Regular Expressions
A regular expression (RE) is a search string that uses special characters to match patterns of text. 
You can use them with the Find, and Find in Files commands, and with the Replace command in 
conjunction with replacement expressions.

To use a regular expression:
1. From the Search menu, choose Find, Replace, or Find in Files.
2. In the Find What box, type a regular expression.
3. Check the "Regular expression" box.

Summary of regular expressions:
Expression Description
. Any single character. Example: h.t 

matches hat, hit, hot and hut.
[ ] Any one of the characters in the brackets, or

any of an ANSI range of characters 
separated by a hyphen (-). Examples: 
h[aeiou][a-z] matches hat, hip, hit, hop, 
and hut; [A-Za-z] matches any single 
letter; x[0-9] matches x0, x1, …, x9.

[^] Any characters except for those after the 
caret "^".    Example: h[^u]t matches hat, 
hit, and hot, but not hut.

^ The start of a line (column 1).
$ The end of a line.
\< The start of a word.
\> The end of a word.
\n A new line character, for matching 

expressions that span line boundaries.    This
cannot be followed by '*' or '+'.

\( \) Brackets a tagged expression to use in 
replacement expressions.    An RE can have 
up to 9 tagged expressions, numbered 
according to their order in the RE.    The 
corresponding replacement expression is \x, 
for x in the range 1-9.    Example: If \([a-
z]+\) \([a-z]+\) matches "way wrong",
\2 \1 would replace it with "wrong way".

* Zero or more of the preceding characters or 
expressions.    Example: ho*p matches hp, 
hop and hoop.

+ One or more of the preceding characters or 
expressions.    Example: ho+p matches hop,
and hoop, but not hp.

\ "Escapes" the special meaning of the above 
expressions, so that they can be matched as
literal characters.    Hence, to match a literal 
"\", you must use "\\".    Example: \< 
matches the start of a word, but \\< 
matches "\<".

Example:
HTML tags are in matched pairs of <…>, such as <FONT SIZE=+1>.    To match any tag that begins and
ends on the same line, use the regular expression:



<[^>]*>
This matches a "<", followed by zero or more characters, excluding ">", followed by a ">".    Note that "*" 
finds the longest matching sequence on a line, so the regular expression:

<.*>
would be incorrect, because it would not stop at the first ">".

For more information and examples, see regular expressions, and replacement expressions in the 
Reference section.



How to Generate Sequence Numbers
You can update or insert sequence numbers in a file, using replacement expressions.    This is achieved 
using the Replace dialog box, with the Regular Expression box checked.
The syntax of the replacement expression is:

Expression: Effect:
\i Replace with numbers starting from 1, in steps of 1.
\i(10) Replace with numbers starting from 10, in steps of 1.
\i(0,10) Replace with numbers starting from 0, in steps of 10.
\i(100,-10) Replace with numbers starting from 100, reducing in 

steps of -10.

Examples:
1. To insert line numbers at the start of each line:

Search for: ^
Replace with: \i 

2. To update sequence numbers of the form Axxx, Bxxx, … ,Zxxx where "xxx" is any number >= 100, 
independent of the letters, which are to be preserved:
Search for: \([A-Z]\)[1-9][0-9][0-9]+
Replace with: \1\i(100)



How to Find in Multiple Files
You can search for strings in either text (excluding Unicode) or binary files, as follows:
1. From the Search menu, choose the Find in Files command (Ctrl+F5).    This starts a modeless dialog

box which remains on the screen until you close it.

Toolbar: 

2. In the Find What box, either type the search string, or choose a previous string from the drop-down 
list.    (Check that Text or Hex is correctly set for the type of string in the Conditions box.)

3. In the In Files box, either type a list of files using wild cards, or choose a previous list from the drop-
down list.

4. In the In Directory box, either type the pathname to the directory containing the files, or select a 
previous directory from the drop-down list, or click Defaults to set it to the current working directory.

5. In the Conditions box, specify the search criteria as follows:
Select: To:
Text Specify a text search 

string.
Hex Specify a search string 

in hexadecimal.
Match Whole
Word

Find occurrences of the 
text as a whole word.

Match Case Find text having the 
given pattern of 
uppercase and 
lowercase letters.

Regular 
Expression

Specify that the search 
string is a regular 
expression.

6. In the File Type box, choose Text if the files contain text, or Binary if they contain any NULL 
characters.

7. In the Report Detail box, choose All Matching Lines if you want each matching line printed out, or File
Counts Only if you simply want to know how many occurrences there are in each file.

8. Click Search Subdirectories if you want to search through all files in the subdirectories of the 
directory specified in step (4) as well.    (This feature is only enabled in registered copies.)

9. Click Find.

Hypertext Jumps:
Matching strings are listed in the Search Output window.    You can use this to jump to a line in its file by 
double clicking the line.
To jump to the next occurrence, choose the Jump Next (F4) command from the Search menu.

Toolbar: 

To jump to the previous occurrence, choose the Jump Previous (Ctrl+F4) command from the Search 
menu.

Toolbar: 



How to Find a Matching Bracket
To Find a Matching Bracket:
1. Place the caret to the left of the bracket to be matched:    ([{< or >}])
2. From the Search menu, choose the Match Brace command (Ctrl+M).    If there is a matching brace, it

will be selected.

To Select Text Between Brackets:
1. Place the caret to the left of the bracket to be matched.
2. Type Ctrl+Shift+M.    If there is a matching brace, all intervening text will be selected.    When 

matching forwards, both brackets are selected as well.    When matching backwards, neither bracket 
is selected.



How to Use Bookmarks
To Set a Bookmark:
Lines can have bookmarks placed on them either by choosing the Toggle Bookmark command (Ctrl+F2)
from the Search menu, or by clicking Mark All on the Find dialog.

To Go to the Next Bookmark:
From the Search menu, choose the Next Bookmark command (F2).

To Go to the Previous Bookmark:
From the Search menu, choose the Previous Bookmark command (Shift+F2).

To Clear a Single Bookmark:
From the Search menu, choose the Toggle Bookmark command (Ctrl +F2).

To Clear all Bookmarks:
From the Search menu, choose the Clear All Bookmarks command (Ctrl+Shift+F2).

To Delete all Bookmarked Lines:
From the Edit menu, choose the Delete Bookmarked Lines command.

To Copy all Bookmarked Lines to the Clipboard:
From the Edit menu, choose the Copy Bookmarked Lines command.

To Cut all Bookmarked Lines to the Clipboard:
From the Edit menu, choose the Cut Bookmarked Lines command.



Examples - Finding Text
See Also: Replacing Text
1.    Find all trailing spaces:

[ \t]+$
finds one or more spaces or tabs followed by the end of line.

2.    Find an empty line:

^$
finds the beginning of a line immediately followed by its end.

3.    Find everything on a line:

^.*
finds the beginning of a line, followed by zero or more of any characters, up to the end of the line.

4.    Find "$12.34":

\$12\.34
Note that '.' and '$' have been escaped using the backslash to hide their regular expression 
meanings.

5.    Find any valid C language variable name:

\<[ a-zA-Z][ a-zA-Z0-9]*
finds a word starting with an underscore or alphabetic character, followed by zero or more 
underscores or alphanumeric characters.

6.    Find an inner-most bracketed expression:

([^()]*)
finds a left bracket, followed by zero or more characters excluding left and right brackets, followed by
a right bracket.

7.    Find a repeated expression:

\([0-9]+\)-\1
This uses a tagged expression "\(...\)" to find one or more digits, followed by a hyphen, followed by 
the string matched by the tagged expression.    So this regular expression will find 12-12, but not 12-
34.



Examples:    Replacing Text
See Also: Finding Text
1.    Find any alphabetic word starting with an upper case letter:

[A-Z][a-z]+
and replace with the same word all in upper case:

\U&
2.    Find a C language variable name starting with a lower case letter:

\<[a-z][ a-zA-Z0-9]*
and make the first letter upper case:

\u&
3.    Find two numeric strings separated by one or more spaces:

\([0-9]+\) +\([0-9]+\)
and swap them around, using a tab to separate them:

\2\t\1
4.    Find "paste":

paste
and replace with the contents of the clipboard:

\p
5.    To change:

X100000 to X100.000
Y100123 Y100.123
Z600 Z.600

Find: \([XYZ]\)\([0-9]*\)\([0-9][0-9][0-9]\)
Replace: \1\2.\3



Regular Expressions
Examples
A regular expression (RE) is a mechanism for describing patterns in text when executing the Find, the 
Replace, and the Find in Files commands.    An RE is made up of ordinary characters from the ANSI 
character set, some of which take on the special meanings described below.

Ordinary Characters
An ordinary character is an RE that matches itself.    It can be any character in the ANSI character set 
except <newline> and the special characters listed below.    An ordinary character preceded by a 
backslash is treated as the ordinary character itself, except when the character is (, ), <, >, or the letters 
f, n, t and x, or the digits 1 through 9.

Hex Characters
Any character can be represented by its hex value.    This is specified with the pattern \xdd, where dd 
is any 2-digit hexadecimal number, excluding zero.

New Lines
A new line character is represented by the pattern \n.    Note that these cannot be combined with 
repetition expressions (see below), so you can only match an exact number of them (e.g. \n\n will 
match a single blank line.)

Page Breaks
A page break (form feed) character is represented by the pattern \f.

Special Characters
These special characters, can be rendered ordinary by preceding them with a backslash (\), if they are 
single special characters, or removing the preceding backslash if they are compound special characters.

Character Context
. [ \ The period, left square bracket, and backslash are special 

except when used in a Class Expression.
* + Asterisk and plus are special except when used in a class 

expression, as the first character of an RE, or as the first 
character of a Tagged Expression.

- The hyphen is special in a Class Expression, except as the 
first or last character of that expression.

^ The circumflex is special when used as the first character of an
entire RE (see Expression Anchoring), or as the first character 
of a Class Expression.

$ The dollar sign is special when used as the last character of an
entire RE (see Expression Anchoring).

Wildcard Character
The period (.), or question mark (?), when used outside of a class expression, matches any character 
except newline.

Repetition Expressions
The asterisk (*) matches zero or more occurrences of the preceding regular expression, whilst the plus 
sign (+) matches at least one occurrence.    For example, A*b+ matches zero or more A's followed by 
one or more b's.

Class Expressions
A class expression is an RE, enclosed in square brackets ([ ]), that matches any one of the elements 
contained in the brackets.    The permitted elements of a class expression are:

Simple Characters
These are single characters that match themselves.    To match a right square bracket (]), it must be 
the first character of the class expression, after any initial circumflex (see Negated Class 
Expressions).    To match a hyphen, it must be either the first or the last character of the class 
expression.    For example [AaBb] matches upper or lower case A or B.



Negated Class Expressions
If the first character of a class expression is the circumflex (^), the expression matches any character
not in the class.    For example [^AB^] matches any character except A, B and the circumflex itself.

Range Expressions
A range expression is two characters separated by a hyphen (-).    It matches any of the characters in
the ANSI collating sequence, between the two characters.    For example, [A-Za-z0-9-] matches any
upper or lower case letter or digit, or the hyphen itself.

Expression Anchoring
An RE can be restricted to matching strings that begin or end a line or word, as follows:

^ A circumflex as the first character of an RE anchors
the expression to the beginning of the line.

$ A dollar sign as the last character of an RE anchors
the expression to the end of the line.

\< The character pair \< anchors the next RE to the 
start of a word.

\> The character pair \> anchors the previous RE to 
the end of a word.

Tagged Expressions
A tagged expression is an RE that starts with the pair \( and ends with the pair \).    There can be up to 
nine such expressions in a complete RE.    Such an expression matches the same as the expression 
without the surrounding \( and \).    The first expression defined in this way can be referenced as \1 later 
in the RE, and so on up to \9 for the ninth tagged expression.    Each such reference matches the same 
string as its original tagged expression.    For example \(tu\) \1 matches the string "tu tu".
References to tagged expressions can also be used in Replacement Expressions.



Replacement Expressions
Replacement expressions are used to substitute text in conjunction with Tagged Regular Expressions, 
when using the Replace command.

Expression Definition
& Substitute the text matching the entire 

search pattern.
\0 to \9 Substitute the text matching tagged 

expression 0 through 9.    \0 is 
equivalent to &.

\f Substitute a page break (form feed).
\i<expression> Substitute a sequence number.
\n Substitute a newline.
\p Substitute the contents of the clipboard.
\t Substitute a tab.
\xdd Substitute the character with hex code 

dd (must be 2 hex digits, excluding 00).
\u Force the next substituted character to 

be in upper case.
\l Force the next substituted character to 

be in lower case.
\U Force all subsequent substituted 

characters to be in upper case.
\L Force all subsequent substituted 

characters to be in lower case.
\E or \e Turns off previous \U or \L.

To substitute a literal \ or &, use \\ and \&.



The Status Bar

The status bar is displayed at the bottom of the main window.    To display or hide the status bar, use the 
Preferences command in the Configure menu.
The left pane of the status bar describes the actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of toolbar 
buttons as you depress them, before releasing them.    (If after viewing the description of the toolbar 
button command you wish not to execute the command, then release the mouse button while the pointer
is off the toolbar button.)
The right hand panes of the status bar indicate the following information:
Indicator Description
1 The line number of the caret.
2 The column number of the caret.
Read The file is read-only, otherwise Edit is shown.
Ovr The Insert key is latched down, otherwise Ins is shown.
Block Block or Normal selection mode, or Wrap for word wrap mode.
Sync Synchronized scrolling of all views is enabled.
Rec A keystroke macro is being recorded.
Caps The Caps Lock key is latched down.
3.50pm The current time.

The status bar is active.    This means that you can double left click any of its panes (except for Time) to 
change the indicated state.



The Toolbar

The toolbar is displayed across the top of the main window, below the menu bar.    The toolbar provides 
quick mouse access to many commands.
To display or hide the toolbar, use the Preferences command in the Configure menu.
The effect of some buttons can be modified by holding the Shift or Ctrl Key down when they are clicked, 
as shown in this table:

Click Normal Operation With Shift With Ctrl
Opens a new document.
Opens an existing document 
using the Open File dialog 
box, in which you can locate 
and open the desired file.

Displays the 
Quick File 
Open dialog 
box.

Saves the active document 
with its current name.    If you 
have not modified or named 
the document, the Save As 
dialog box is displayed.

Saves all 
modified files

Displays the
Save As 
dialog box.

Displays the Manage Files 
dialog box.
Prints the active document, 
using the default printer.

Displays the 
Print dialog 
box.

Displays the
Configure 
Printing 
dialog box.

Previews the printed layout of 
the active document.
Checks spelling.

Cuts the selection from the 
document and save it on the 
clipboard.

Cuts the 
selection and 
appends it to 
existing text 
on the 
clipboard.

Copies the selection to the 
clipboard.

Appends the 
selection to 
existing text 
on the 
clipboard.

Inserts what's on the 
clipboard.

Inserts a file.

Cancels (undo) the last edit 
command.

Undo all edits
back to the 
last save 
checkpoint.

Cancels (redo) the last Undo 
command

Redo all edits
up to the last 
save 
checkpoint.

Reduces indentation of 
selected text.
Increases indentation of 
selected text.
Enables word wrapping.



Displays spaces tabs and 
paragraph marks as visible 
characters.
Displays the Find dialog box.

Displays the Replace dialog 
box.
Displays the Find in Files 
dialog box.
Starts the keystroke macro 
recorder.
Temporarily pauses the 
keystroke macro recorder.
Plays back the scratch 
keystroke macro.

Displays the 
Playback 
Macro dialog 
box.

Jumps to the previous item in 
the search or command 
window.
Jumps to the next item in the 
search or command window.
Displays a cursor to click on 
an item you require help on.



Open File Button (Toolbar)

Normal Operation With Shift With Ctrl
Opens an existing document 
using the Open File dialog 
box, in which you can locate 
and open the desired file.

Displays the 
Quick File 
Open dialog 
box.



Save File Button (Toolbar)

Normal Operation With Shift With Ctrl
Saves the active document 
with its current name.    If you 
have not modified or named 
the document, the Save As 
dialog box is displayed.

Saves all 
modified files

Displays the
Save As 
dialog box.



Print Button (Toolbar)

Normal Operation With Shift With Ctrl
Prints the active document, 
using the default printer.

Displays the 
Print dialog 
box.

Displays the
Configure 
Printing 
dialog box.



Copy Button (Toolbar)

Normal Operation With Shift With Ctrl
Copies the selection to the 
clipboard.

Appends the 
selection to 
existing text 
on the 
clipboard.



Cut Button (Toolbar)

Normal Operation With Shift With Ctrl
Cuts the selection from the 
document and save it on the 
clipboard.

Cuts the 
selection and 
appends it to 
existing text 
on the 
clipboard.



Paste Button (Toolbar)

Normal Operation With Shift With Ctrl
Inserts what's on the 
clipboard.

Inserts a file.



Undo Button (Toolbar)

Normal Operation With Shift With Ctrl
Cancels (undo) the last edit 
command.

Undo all edits
back to the 
last save 
checkpoint.



Redo Button (Toolbar)

Normal Operation With Shift With Ctrl
Cancels (redo) the last Undo 
command

Redo all edits
up to the last 
save 
checkpoint.



Record Button (Toolbar)

Normal Operation With Shift With Ctrl
Starts the keystroke macro 
recorder.



Pause Button (Toolbar)

Normal Operation With Shift With Ctrl
Temporarily pauses the 
keystroke macro recorder.



Playback Button (Toolbar)

Normal Operation With Shift With Ctrl
Plays back the scratch 
keystroke macro.

Displays the 
Playback 
Macro dialog 
box.



The Keyboard
Key Modifier Command
A Ctrl Redo last Undo
A Ctrl+Shift Redo All Undos
B Ctrl Move the caret back to start of word
B Ctrl+Shift Select back to start of word
C Ctrl Copy selection to clipboard
C Ctrl+Shift Append selection to clipboard
D Ctrl Move caret back to end of word
D Ctrl+Shift Select back to end of word
E Ctrl Move caret forward to end of word
E Ctrl+Shift Select forward to end of word
F Ctrl Find next instance of search pattern
F Ctrl+Shift Find previous instance of search pattern
G Ctrl Go to line
I Ctrl Insert new line after current line
I Ctrl+Shift Insert new line before current line
J Ctrl Join selected lines
J Ctrl+Shift Split word-wrapped lines
K Ctrl Invert case of selection
L Ctrl Convert selection to lower case
L Ctrl+Shift Insert a page break
M Ctrl Find matching { [ (< or >) ] }
M Ctrl+Shift Select to matching { [ (< or >) ] }
N Ctrl Create a new document
O Ctrl Open a document using common File Open dialog box
O Ctrl+Shift Open a document by typing its name
P Ctrl Print active document
P Ctrl+Shift Preview the active document as it will print.
R Ctrl Playback the scratch macro.
R Ctrl+Shift Record a new macro.
Q Ctrl Cut the word containing the caret to the clipboard
Q Ctrl+Shift Cut and append the word containing the caret to the 

clipboard
S Ctrl Save the active document
S Ctrl+Shift Save all documents
T Ctrl Transpose the lines or characters either side of the caret
T Ctrl+Shift Transpose the words either side of the caret
U Ctrl Convert selection to upper case
U Ctrl+Shift Convert first character of selection to uppercase and the 

rest to lower case
V Ctrl Paste text from the clipboard
V Ctrl+Shift Paste the contents of a file at the caret position.
W Ctrl Move caret forward to start of word
W Ctrl+Shift Select forward to start of word
X Ctrl Cut the selection to the clipboard
X Ctrl+Shift Cut and append the selection to the clipboard
Y Ctrl Cut the line containing the caret to the clipboard



Y Ctrl+Shift Cut and append the line containing the caret to the 
clipboard

Z Ctrl Undo last edit
Z Ctrl+Shift Undo all edits
0-9 Alt Run user tool 0,1,...,9
0-5 Alt+Shift Run user tool 10,11,...,15
Numpad
0-9

Ctrl Run keystroke macro 0-9

Break Ctrl Stop the tool running in the command window (only under
32-bit versions of Windows)

Backspace Delete selection, or character before the caret.
Backspace Ctrl Delete back to the last start of word.
Delete Delete selection, or character after the caret.
Delete Ctrl Delete forward to the next start of word.
Delete Ctrl+Shift Delete to the end of the line.
Delete Alt Delete all lines in the document.
End Caret to end of line.
End Shift Select to end of line.
End Ctrl Caret to end of document.
End Ctrl+Shift Select to end of document.
End Alt Caret to start of last visible line.
Enter Start a new line in an edit document, or do a hypertext 

jump in a log document.
Enter Alt Display in-context properties dialog box
Escape Cancel any existing selection
Home Caret to start of line.    Press twice to go to column 1.
Home Shift Select to start of line.
Home Ctrl Caret to start of document.
Home Ctrl+Shift Select to start of document.
Home Alt Caret to start of first visible line.
Scroll Lock Locks caret position when scrolling with page up/down 

keys.
Tab  Indent selected lines, or move caret to next tab stop
Tab Ctrl Next window (same as Ctrl+F6)
Tab Ctrl+Shift Previous window (same as Ctrl+Shift+F6)
Tab Shift Un-indent selected lines, or move caret to previous tab 

stop
F1  In-context help
F1 Ctrl Display document statistics on status bar
F1 Shift Invoke in-context help cursor
F2  Go to next bookmark
F2 Ctrl Set or clear a bookmark on the current line
F2 Shift Go to previous bookmark
F2 Ctrl+Shift Clear all bookmarks
F3  Invoke the Manage Files dialog box
F3 Alt Invoke Windows File Manager or Explorer
F4  Hypertext jump to next item in Search or Command 

Output window
F4 Shift Hypertext jump to previous item in Search or Command 



Output window
F5  Invoke the Find dialog box
F5 Ctrl Invoke Find in Files dialog box
F6  Activate next view
F6 Ctrl Activate previous view
F7 Check the spelling of the active document.
F7 Ctrl Invoke the Playback Macro dialog box.
F8  Invoke Replace dialog
F8 Ctrl Replace next instance of search pattern
F9  Find matching { [ ( or ) ] }
F9 Shift Select to matching { [ ( or ) ] }
F10 Invoke the main menu
F10 Shift Popup the in-context document menu
F10 Ctrl Popup the insert date/time menu
F11 Invoke the Window Selector
F11 Ctrl Activate the Command Output window
F11 Shift Activate the Search Output window
F12 Shift Switch in and out of word-wrap mode



The Mouse
Cursor Positioning:
To set the insertion position with the mouse, click the left mouse button when the mouse cursor is at the 
required character position.    You can set it to the start of a line by clicking in the left margin next to the 
line.

Text Selection:
To: Do this with the left mouse button:
Select any text Click on the first character and drag to 

the last.
Select a single word Double click on the word.
Select an entire line Double click in the left margin next to 

the line.
Select the entire file Press Ctrl and click in the left margin.
Extend the current selection Press Shift and click or drag to the new

last character position.

In-context Menus:
Right click a document to pop up the in-context menu.
Ctrl+Right click an edit document to pop up the insert date/time menu.



The caret is the blinking vertical line or block, which indicates the insertion position for text.    Contrast 
this with the cursor, which tracks the mouse position.



The cursor is a pointer on the screen which tracks the mouse position.    Contrast this with the caret, 
which is the blinking vertical line or block indicating the insertion position for text.





Introducing TextPad
Winner - 1996 Shareware Industry Awards
Winner - 1995 Ziff-Davis Shareware Awards
TextPad™ 2.1    is designed to provide the power and functionality to satisfy the most demanding text 
editing requirements.    It is Windows™ hosted, and comes in 16 and 32-bit editions.    Huge files can be 
edited by either - just choose the edition that works best with your PC.    The 32-bit edition can edit files 
up to the limits of virtual memory, and it will work with Windows 95, Windows NT and Windows 3.1 with 
Win32s extensions.

TextPad has been implemented according to the Windows 95 user interface guidelines, so great 
attention has been paid to making it easy for both beginners and experienced users.    In-context help is 
available for all commands, and in-context menus pop-up with the right mouse button.    The Windows 
multiple document interface allows many files to be edited simultaneously, with up to 2 views on each 
file.    Text can be dragged and dropped between files.
In addition to the usual cut and paste capabilities, you can correct the most common typing errors with 
commands to change case, and transpose words, characters and lines.    Other commands let you 
indent blocks of text, split or join lines, and insert whole files.    Any change can be undone or redone, 
right back to the first one made.    Visible bookmarks can be put on lines, and edit commands can be 
applied to lines with bookmarks.
Frequently used combinations of commands can be saved as keystroke macros, and the spelling 
checker has dictionaries for 10 languages.
It also has a customizable tools menu, and integral file compare and search commands, with hypertext 
jumps from the matched text to the corresponding line in the source file (ideal for integrating compilers).

Summary of Features:
Huge files can be edited (up to the limits of virtual memory for the 32-bit edition).    See 

Specifications for the actual limits.
Supports Universal Naming Convention (UNC) style names, and long file names with spaces.
CUA compliant keyboard commands.
Multiple files can be simultaneously edited, with up to 2 views per file.
Warm Start feature lets you restart exactly where you left off.
In addition to the usual cut, copy and paste capabilities, selected text can be case shifted and 

block indented, and characters, words and lines can be transposed.    Cut and copied text can be 
appended to the clipboard, as well as replacing its contents.

Text can be automatically word-wrapped at the margin, or at a specified column, if it does not fit 
on a line.    In this mode, text can be split into separate lines where wrapping occurs, or lines can be 
intelligently joined, preserving paragraphs.

OLE2 drag and drop editing for copying and moving text between documents.
Unlimited undo/redo capability.    The undo buffer can be optionally cleared when a file is saved, 

or by using the Mark Clean command.
Block (column) selection mode, and visible display of tabs and spaces.
A spelling checker with dictionaries in 10 languages.
A keystroke macro recorder, with up to 16 active macros.
Sorting, using up to 3 keys.
Text can be automatically aligned and indented, relative to the previous line, to aid block 

indentation.
The right mouse button pops up an in-context menu.
The caret can be constrained to the text, or can be positioned freely in the document view.
Toolbar with fly-by usage hints, and an active status bar.
A powerful search/replace engine using UNIX-style regular expressions.    Sets of files in a 

directory tree can be searched, and text can be replaced in all open documents at once.



Visible bookmarks can be placed on individual lines, and on all occurrences of a search pattern.    
Bookmarked lines can be cut, copied or deleted.

A built in file manager for fast file copying, renaming, deleting etc.
Print previewing, and printing with customizable headers/footers and page breaks.
Viewer for binary files using a hexadecimal display format.
Built in file comparison utility, and up to 16 user-defined tools with parameter macros.
Hypertext links from file search and user tool output to the relevant source line.
DDE interface to other tools, such as VC++.    The editor detects when an open file has been 

modified by another tool, and prompts you to reopen it.

Copyright © 1992-1996 Helios Software Solutions
All Rights Reserved.



Specifications
Conforms to MS Windows User Interface Design Guide 4 recommendations.
The editor can handle files with up to 32,500 lines in the 16-bit edition, and up to the limits of 

virtual memory in the 32-bit edition, except that in word-wrapped mode it is also limited to 32,500 lines.
The maximum line length is 4095 characters.
The number of concurrent edits is limited by available memory.    In the 16-bit edition, the 64KB 

local heap restricts this to a maximum of 28.
Supports Universal Naming Convention (UNC) style, and long file names with spaces.
8-bit text files with DOS, UNIX and Macintosh end of line characters are supported.
Text can be in either the ANSI (Windows) or OEM (DOS) character sets.
Each document has a single MDI window with up to 2 views.
Fonts and tab stops are user selectable (fixed width font for editing).
Up to 16 (user settable)    most    recently used files are listed on the File menu.
Up to 16 user-defined commands can be added to the Tools menu.
Up to 16 keystroke macros can be added to the Macros menu. This is restricted to 2 macros in 

unregistered copies.
Limitations:

The 16-bit edition cannot cut or paste more than 64KB at a time.
Non-OLE drag and drop does not support scrolling.
The 16-bit edition, and the 32-bit edition under Win32s, can only display the output of a user tool 

command in a window after the command has completed.
The 32-bit edition cannot mail files under 16-bit Windows.
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Helios Software Solutions
Mail Address:

Helios Software Solutions
Carr Brook House
Chorley Old Road
Brindle
CHORLEY    PR6 7QZ
England
Tel/Fax: +44 (01772) 324353

E-Mail Addresses:
Internet: textpad@heliosof.demon.co.uk
CompuServe: >internet:textpad@heliosof.demon.co.uk

WWW URL:
http://www.textpad.com/



Registration Benefits
This product makes use of the most advanced software technology available today.    As the technology 
improves, so does our software.    Your registration fee enables us to keep it at the forefront of 
technology, so that you continue to benefit from the productivity gains it gives you.
As a registered user, you will receive:

A copy of the latest release of both 16 and 32-bit editions on 3.5" diskette, unless you opt for the 
download only price, which includes a license for both editions.

A license to use all future *maintenance releases (which will be made available for downloading 
from our Internet web site, CompuServe, AOL and MSN).    This license file will be e-mailed to you, if you 
quote your e-mail address with your order.

The display of your name, company and registration number on the About dialog box.
Technical support via e-mail, by FAX, or through the mail, at no charge, for at least 101 days.

* We reserve the right to introduce an upgrade charge for major new releases.



How to Order
Registration Instructions:

The registration fee can be paid by cheque, Visa or MasterCard direct to Helios Software Solutions in 
UK Pounds, or to PsL in US dollars, using a credit card, or it can be debited from your CompuServe 
account using the shareware registration service (GO SWREG).
We always send an invoice if you specify a company name.    Private users can request one by stating 
"invoice required" in the place of the company name.
If you have already downloaded the latest release, there is no point in paying extra to have the software 
on diskettes.    Just order it at the no disk price.
Paying in UK Pounds
Paying in US Dollars by Check
Paying in US Dollars by Credit Card
CompuServe Registration
Purchase Orders



Paying in UK Pounds
We accept payment by MasterCard, Visa, or cheques in UK pounds.
Cheques must be in UK pound denominated drafts drawn on a UK bank, or by EuroCheque, or by 
Pound Sterling International Money Order.    Sorry, but banking fees for payments in other denominations
are prohibitively expensive.
See the Price List for current pricing, and return the completed Order Form.



Paying in US Dollars by Check
For non-European users, we accept direct payment with a check made out in US dollars.    European 
users must pay in UK Pounds, to keep our VAT records in order.
See the Price List for current pricing, and return the completed Order Form.



Paying in US Dollars by Credit Card
Note: This option for payment is only available for single user licenses.    Payment for site licenses 
must be made directly to us in UK Pounds or by a check in US Dollars.
MasterCard, Visa, American Express, and Discover orders can be placed through PsL, a credit card 
order taking service.    You can reach PsL 24 hours a day 7 days a week by fax at 1-713-524-6398 or by 
CompuServe mail to 71355,470 or Internet mail to 71355.470@compuserve.com.    You can also call 
PsL at 1-800-242-4PsL(4775) or 1-713-524-6394 between the hours of 7:00 am and 6:00 pm CST 
Monday-Thursday and 7:00 am and 12:30 pm CST on Fridays, except holidays.    You can also mail 
orders to PsL at P.O. Box 35705, Houston, TX 77235, USA.

THESE NUMBERS ARE FOR ORDERING ONLY.    Any other queries, including the status of the 
shipment of the order, must be addressed to Helios Software Solutions.    PsL will charge us $2.50 for 
any queries you make, then pass them on for us to answer anyway, so please ask us directly!

PsL requires the following information:
Number of Copies: ___
Diskettes Required (Y/N): ___
E-mail Address: _____________________________________

Credit Card [    ] MasterCard [    ] VISA [    ] AMEX [    ] Discover
Credit Card Number: _____________________________________
Expiry Date: _____________________________________
Name On Card: _____________________________________
Company: _____________________________________
Billing Address: _____________________________________

_____________________________________
_____________________________________

The registration fee for orders through PsL is $35 US Dollars if you want a copy of the software on 3.5in 
diskettes, or $27 if you download the software yourself.    You must specify an e-mail address, unless 
you order diskettes.

We will automatically send an invoice if you specify your company name.    Private users who want one 
should state "Invoice Required" in place of the company name.

PsL will notify us within one working day of you placing your order, and we will e-mail a license file to you
if you specify your e-mail address.    If you opt for having the software sent on diskettes, we will mail 
them directly to you.

Note: e-mail addresses can be quite complicated, and occasionally get written down incorrectly by the 
telephone operators.    If you have not received your license file within a couple of days, please send an 
e-mail message to: orders@heliosof.demon.co.uk



CompuServe Shareware Registration Service
Note: This option for payment is only available for single user licenses.    Payment for site licenses 
must be made directly to us in UK Pounds or by a check in US Dollars.
If you have a CompuServe account you can have the registration fee charged to your account.    Simply 
GO SWREG and follow the online instructions.
The registration ID numbers are:

ID Number Includes Disks Price
3938 No $27
794 Yes $35

We will automatically send an invoice if you specify your company name.    Private users who want one 
should state "Invoice Required" in place of the company name.
CompuServe will notify us on the day of your order and we will e-mail a license file to you.    If you opt for
having the software sent on diskettes, we will mail them directly to you.



Purchase Orders
Purchase orders (net 30 days) are accepted only from government and accredited educational 
institutions and major corporations, provided that they are submitted on purchase order forms with a 
purchase order number.    Please be sure to include the European or World wide order form with a 
purchase order.
See the Price List for current pricing.



Price List
Valid from 1st August, 1996

Single User Prices:
Currency Without Diskettes With Diskettes
US Dollars $27.00 $35.00
UK Pounds (ex. VAT) £17.00 £20.00
UK Pounds (inc. VAT*) £19.98 £23.50

Site License Prices:
Users US Dollars UK Pounds (ex. VAT) UK Pounds (inc. VAT*)

5 $120.00 £80.00 £94.00
10 $210.00 £140.00 £164.50
15 $300.00 £200.00 £235.00
20 $360.00 £240.00 £282.00
50 $750.00 £500.00 £587.50

Unlimited $1000.00 £680.00 £799.00

Notes:
If you have already downloaded the latest release, there is no point in paying extra to have the 

software on diskettes.    Order it without diskettes.
When purchasing without diskettes, you must download the software yourself, and must provide 

an e-mail address for us to send your license file to.
*VAT at 17.5% is payable by UK residents, and European residents who are not VAT registered.    

You must pay in UK Pounds if VAT is applicable.
TextPad can be purchased in US Dollars or UK pounds only.    The prices are as shown in the 

tables above, and are not subject to exchange rate fluctuations.    They are inclusive of shipping and 
handling.

A site license is for a single physical site.
Site licenses always include one set of diskettes.
Additional educational discounts for site licenses are available on request.



TextPad Order Form for Payment in UK Pounds
Please register me as a licensed TextPad user, and send me a copy of the latest release.
Name:___________________________________________
Company:________________________________________
Address:________________________________________
________________________________________________
________________________________________________
Phone:__________________________________________
Fax:____________________________________________
E-mail:_________________________________________

Payment Due (see price list):
Users: 1__ 5__ 10__ 20__ 50__ Unlimited__
Registration Price: £_____

Price  x  __ copies = £_____
VAT at 17.5% (**Europe only): £_____
Total paid: £_____
 (**No VAT to pay if non-UK European, and VAT number is filled in below.)

VAT Registration No.____________________
Payment by: MasterCard__ VISA__ Cheque__
Cheque/Draft No.________________________ (To "Helios Software Solutions")
Credit Card Details:

Number:____________________________
Expiry:____________________________

Signed:_________________________________
Date:___________________________________

How did you hear about TextPad?__________________________
_________________________________________________________

Any Comments:____________________________________________
_________________________________________________________
_________________________________________________________
When you have filled in the above details, mail this to:

Helios Software Solutions
Carr Brook House
Chorley Old Road, Brindle
CHORLEY    PR6 7QZ
England
(FAX: +44 (01772) 324353)

Thank you for your interest in this product.



TextPad Order Form for Payment by Check in US Dollars
Please register me as a licensed TextPad user, and send me a copy of the latest release.

Name:___________________________________________
Company:________________________________________
Address:________________________________________
________________________________________________
________________________________________________
Phone:__________________________________________
Fax:____________________________________________
E-mail:_________________________________________

Payment Due (see price list):
Users: 1__ 5__ 10__ 20__ 50__ Unlimited__
Registration Price: $_______

Price  x  __ copies = £_______
Total paid: $_______
Check/Draft No._________________________
Signed:_________________________________
Date:___________________________________
Do you require an invoice to be sent?___

How did you hear about TextPad?__________________________
_________________________________________________________

Any Comments:____________________________________________
_________________________________________________________
_________________________________________________________
_________________________________________________________

Make checks payable to "Helios Software Solutions".
When you have filled in the above details, mail this with your check to:

Helios Software Solutions
Carr Brook House
Chorley Old Road, Brindle
CHORLEY    PR6 7QZ
England

Thank you for your interest in this product.



Registered User License Agreement

This is a legal agreement between you (either an individual or an entity) and Helios Software Solutions.   
By opening the sealed software packages and/or by using the SOFTWARE, you agree to be bound by 
the terms of this Agreement.    If you do not agree to the terms of this Agreement, promptly return the 
disk package and accompanying items for a full refund.

SOFTWARE LICENSE

1. GRANT OF LICENSE.    This License Agreement (“License”) permits you to use one copy of the software product identified 
above, which may include user documentation provided in “on-line” or electronic form (“SOFTWARE”).    The SOFTWARE is 
licensed as a single product.    Its component parts may not be separated for use on more than one computer or by more than 
one user at any time.    The SOFTWARE is “in use” on a computer when it is loaded into the temporary memory (i.e. RAM) or 
installed into the permanent memory (e.g. hard disk) of that computer.    If the SOFTWARE is permanently installed on the hard 
disk or other storage device of a computer and one person uses that computer more than 80% of the time, then that person may
also use the SOFTWARE on a portable or home computer.

2. COPYRIGHT.    The SOFTWARE is owned by Helios Software Solutions and is protected by United Kingdom copyright laws and
international treaty provisions.    Therefore you must treat the SOFTWARE like any other copyrighted material (e.g. a book or 
musical recording) except that you may either (a) make one copy of the SOFTWARE solely for backup or archival purposes, or 
(b) transfer the SOFTWARE to a single hard disk provided you keep the original solely for backup or archival purposes.    You 
may not copy the printed materials accompanying the SOFTWARE, nor print copies of any user documentation provided in “on-
line” or electronic form.    You must not redistribute the file TEXTPAD.LIC, which licenses your copy of the software.

3. OTHER RESTRICTIONS.    This License is your proof of license to exercise the rights granted herein and must be retained by 
you.    You may not rent or lease the SOFTWARE, but you may transfer your rights under this License on a permanent basis, 
provided you transfer this License, the SOFTWARE and all accompanying printed materials, retain no copies, and the recipient 
agrees to the terms of this License.    You may not reverse engineer, decompile, or disassemble the SOFTWARE, except to the 
extent the foregoing restriction is expressly prohibited by applicable law.

LIMITED WARRANTY

LIMITED WARRANTY.    Helios Software Solutions warrants that the SOFTWARE will perform substantially in accordance with the 
accompanying printed material and on-line documentation for a period of 101 days from the date of receipt.

CUSTOMER REMEDIES.    Helios Software Solutions’ entire liability and your exclusive remedy shall be, at Helios Software 
Solutions’ option, either (a) return of the price paid or (b) repair or replacement of the SOFTWARE that does not meet this Limited 
Warranty and that is returned to Helios Software Solutions with a copy of your receipt.    This Limited Warranty is void if failure of 
the SOFTWARE has resulted from accident, abuse, or misapplication.    Any replacement SOFTWARE will be warranted for the 
remainder of the original warranty period or thirty (30) days, whichever is longer.

NO OTHER WARRANTIES.    To the maximum extent permitted by applicable law, Helios Software Solutions disclaims all other 
warranties, either express or implied, including but not limited to implied warranties of merchantability and fitness for a particular 
purpose, with respect to the SOFTWARE and any accompanying written materials.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES. To the maximum extent permitted by applicable law, in no event shall Helios 
Software Solutions be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, 
business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use the 
SOFTWARE, even if Helios Software Solutions has been advised of the possibility of such damages.



Unregistered User License Agreement
LIMITED WARRANTY AND REMEDIES

THE PROGRAM IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE.    IN NO EVENT WILL THE AUTHOR BE LIABLE TO 
YOU FOR ANY DAMAGES, INCLUDING INCIDENTAL OR CONSEQUENTIAL DAMAGES, 
ARISING OUT OF THE USE OF THE PROGRAM, EVEN IF ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGES.
YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE, UNDERSTAND IT AND AGREE 
TO BE BOUND BY ITS TERMS AS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE 
AGREEMENT BETWEEN US, SUPERSEDING ANY PROPOSAL OR PRIOR AGREEMENT, ORAL 
OR WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN US RELATING TO THE 
SUBJECT MATTER OF THIS LICENSE.

TextPad is a shareware program and is provided at no charge to the user for evaluation.    Feel free to 
share unlicensed copies with your friends, but please do not give it away altered or as part of another 
system.    The essence of shareware software is to provide personal computer users with quality 
software without high prices, and yet to provide incentive for programmers to continue to develop new 
products.
If you find this program useful and find that you continue to use it after a reasonable trial period, you 
must make a registration payment (see the registration instructions for details).    This registration fee will
license one copy for use on any one computer at any one time.    All users will receive a copy of the 
latest release when they register, and free technical support for a limited period.
Commercial users must register and pay for their copies within 30 days of first use or their license is 
withdrawn.    Site License arrangements may be made by contacting Helios Software Solutions.
Anyone distributing this product for any kind of remuneration must first contact Helios Software Solutions
for authorization.
You must treat this software just like a book.    For example, this software may be used by any number of
people and may be freely moved from one computer location to another, as long as there is no 
possibility of it being used at more than one location at a time.    Just as a book cannot be read by two 
people at the same time.
You are encouraged to pass a copy of this software along to your friends for evaluation, but you must 
include all files in the original distribution.    Please encourage them to register their copy if they find that 
they make use of it.



Distributor License Agreement
Anyone wishing to charge people a fee for giving them a copy of this software must have the written 
authorization of the author, without which, the distributor is guilty of copyright violation.    To receive such 
authorization, send this completed application, along with a copy of your software library's order form to 
Helios Software Solutions.    Include £5.00 to cover the cost of processing the application and of sending 
you the latest version of the software.    For distributors already recognized by the Association of 
Shareware Professionals, this application is not necessary.

Name of Organization: ____________________________________
Your Name: _______________________________________________
Address:   _______________________________________________

_______________________________________________
_______________________________________________

Terms of Distribution of TextPad:
1.    The fee charged may not exceed $10, including postage, mailer and any other charges.
2.    Your library's catalog or listing must state that this program is not free, but is copyrighted software 
that is provided to allow the user to evaluate it before paying.
3.    The offering and sale of the software will be stopped at any time the author so requests.
4.    Copies must be made from the copy of the software sent to you with this agreement. This is required
for control purposes.
5.    Problems or complaints about the program will be reported to the author for investigation.    In return 
for a license to charge a fee for the distribution of TextPad, I agree to comply with the above terms of 
distribution.

Signed, ____________________________________  ______________
your signature                        date

__________________________   _________   ______________
Keith MacDonald         control #         date



Definition of Shareware
Shareware distribution gives users a chance to try software before buying it.    If you try a shareware 
program and continue using it, you are expected to register.    Individual programs differ on details -- 
some request registration while others require it, some specify a maximum trial period.    With 
registration, you get anything from the simple right to continue using the software to an updated program
with printed manual.
Copyright laws apply to both shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below.    Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality.    (In both 
cases, there are good programs and bad ones!)    The main difference is in the method of distribution.    
The author specifically grants the right to copy and distribute the software, either to all and sundry or to a
specific group.    For example, some authors require written permission before a commercial disk vendor
may copy their shareware.
Shareware is a distribution method, not a type of software.    You should find software that suits your 
needs and pocketbook, whether it's commercial or shareware.    The shareware system makes fitting 
your needs easier, because you can try before you buy.    And because the overhead is low, prices are 
low also.    Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't 
pay for it.



Association of Shareware Professionals

Helios Software Solutions is an approved vendor and associate member of the Association of 
Shareware Professionals (ASP).
The primary goals of the ASP include:

o    To inform users about shareware programs and about shareware as a method of distributing and 
marketing software.
o    To foster a high degree of professionalism among shareware authors by setting programming, 
marketing, and support standards for ASP members to follow.
o    To encourage broader distribution of shareware through user groups and disk dealers who agree 
to identify and explain the nature of shareware.
o    To assist members in marketing their software.
o    To provide a forum through which ASP members may communicate, share ideas, and learn from 
each other.

The Association of Shareware Professionals have drafted a code of ethics for all present and future 
members.    This code of ethics includes the following requirements:

o    A member's program (evaluation version) must not be limited (crippled) in any way.    In the true 
spirit of Try-Before-You-Buy, users must be able to evaluate all the features in a program before 
paying the registration fee.
o    Members must respond to every registration.    At the very least they must send a receipt for the 
payment. 
o    Members must provide technical support for their products for at least 90 days from the date of 
registration.

The ASP has put in place a system to help ensure that users are treated fairly and professionally.    If a 
user is unable to resolve a problem with a member author then the user can contact the ASP 
Ombudsman with their complaint.    The Ombudsman will then try to help resolve the dispute.

ASP Ombudsman Statement:
Helios Software Solutions is a member of the Association of Shareware Professionals (ASP).    ASP 
wants to make sure that the shareware principle works for you.    If you are unable to resolve a 
shareware-related problem with an ASP member by contacting the member directly, ASP may be able to
help.    The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does 
not provide technical support for members' products.
Please write to the ASP Ombudsman at:

ASP Ombudsman
545 Grover Road
Muskegon, MI    49442-9427
U.S.A.

or send a message via e-mail to ASP Ombudsman, 70007.3536@compuserve.com.



How to Use Keystroke Macros: Overview
Keystroke macros are useful whenever you have the same sequence of editing commands to repeat, or 
a block of text to insert.    You can record one unnamed (scratch) macro, and up to 16 named ones, 
which are added to the Macro menu.    Each macro has a default play mode (once only, repeat through 
selected text, or repeat to the end of the document), which can be overridden when you play it back.

Recordable Commands:
Normal typing.
Selection and cursor positioning using keystrokes.
All commands on the Edit menu, except for Undo and Redo.
All commands on the Search menu, except for Find in Files.
The Convert to DOS/ANSI command on the Tools menu.
All commands on the File and Windows menus.
Next Window and Previous Window commands.
Previously recorded, named macros.
Mouse double clicks.    Not mouse motion or drag and drop.

Points to Bear in Mind:
You should normally position the caret before starting the recorder, since the macro will play back 

from the current position.    The Find/replace commands are exceptions to this rule.
All of the parameters that you set on the Find or Replace dialog box are recorded.
The file name for the Insert File command is recorded.
You can pause the recorder, if you don't want to record some commands in the middle of a 

recording.
If you want to be able to play back a macro to the end of the document, it is important that you 

record at least one command to move the caret down a line.
You can cancel a macro, whilst it is being played back by, releasing the playback button on the 

toolbar, or with the Stop Playing command on the Macro menu.
After a macro has finished playing, the Undo command will cancel any changes it made.
The unnamed (scratch) macro is only saved if the option to save the workspace is enabled on the

General tab of the Preferences dialog box.
See also: Recording, Playing, Saving, Example.



How to Record Keystroke Macros
To record a keystroke macro:
1. If the caret position is significant, move it to where you want first.
2. Start the macro recorder with the Record command on the Macro menu.
3. If you have previously recorded a macro, and not yet saved it, you will be asked if you want to erase 

it.
4. Type as usual, or invoke any of the recordable commands.
5. When you have finished, select the Stop Recording command on the Macros menu, or click the 

record button again on the toolbar.
6. The first time, you will be prompted to save the macro.    You can choose to just use it as an unsaved 

(scratch) macro, or to save it with a name, and whether you want to be prompted in future.
Shortcuts:
Toolbar:

Keys: Ctrl+Shift+R
See also: Overview, Playing, Saving, Example.



How to Save a Keystroke Macro
To save the unnamed (scratch) keystroke macro:
1. Choose the Save command from the Macros menu.    The Save Macro dialog box will be displayed.
2. Choose a file name.    The default will be MACROxx.TPM, where xx is a number.    The file will be 

stored in the folder configured on the Macros tab of the Preferences dialog box.
3. In the Display Name box, type text that you want to appear on the Macros menu.    If you insert an '&'

before any character, it will be underlined on the menu, and can be used as the menu accelerator.
4. Optionally fill in the Author and Comment fields.    These can be modified later by clicking the 

Properties button on the Macros tab of the Preferences dialog box.
5. Choose the default play mode.    This can later be overridden when playing the macro, or modified as

for the Author and Comment fields.
6. Click OK.

See also: Overview, Recording, Playing, Example.



How to Playback a Keystroke Macro 
To play back the unnamed (scratch) keystroke macro:

Choose the Playback command from the Macros menu.
Shortcuts:
Toolbar:

Keys: Ctrl+R
To play back a named macro:

Select it by name from the Macros menu.

To play back a macro differently from its default mode:
1. Choose the Multi-play command from the Macros menu.    The Playback Macro dialog box will be 

displayed.
Shortcut:
Toolbar: Shift+

2. Select a named macro, or the scratch macro to play.
3. Choose to play it a specified number of times, or through the current selection, or to the end of file.
4. Click OK.

See also: Overview, Recording, Saving, Example.



Macro Example
HTML tags are in matched pairs of <…>'s, which may extend over several lines.    You can create a 
macro to select a whole tag as follows:
1. Select any "<" at the beginning of the file;
2. Start the recorder, using Ctrl+Shift+R, or the toolbar button;
3. Search for the next "<", using Ctrl+F;
4. Select up to the matching ">", using Ctrl+Shift+M;
5. Stop the recorder, using Ctrl+Shift+R, or the toolbar button;
6. Save the macro with a suitable name.

If you want to delete the tag, hit the Delete key before stopping the recorder.    Then you can play it to the
end of the file to strip all tags.



How to Change Macro Properties
You can change the properties of a macro by choosing Preferences from the Configure menu, and 
selecting the Macros tab.    If you select a macro, and click the Properties button, you can view or modify
the following properties:

Property: Description:
       File Name The name of the disk file containing this macro.
Display Name A name of up to 40 characters that will appear on 

the Macros menu.    You can insert an '&' to 
indicate the character to use as the menu 
accelerator.

Author This is automatically set to the name of the 
registered user.    It can be up to 40 characters 
long.

Description Up to 128 characters to remind you what the 
macro does.

Default Play 
Mode

Choose from "Play Once", "Repeat through 
Selection", and "Repeat to End of File".



How to Customize Macro Preferences
You can customize these macro settings by choosing Preferences from the Configure menu, and 
selecting the Macros tab:
Macro Folder: Macros will be stored in the specified folder.    The default is the TextPad installation 
folder.
Macros Available: lists the macros available in the specified folder, which have not already been 
selected.
Macros on menu: lists the macros which have been selected.

Click this button: To do this:
Add Add the selected macro from the Available list 

to the menu.
Remove Removes the selected macro from the menu, 

and puts it on the Available list.
Move Up Moves the selected macro up the menu list.
Move Down Moves the selected macro down the menu list.
Properties View or change the macro properties.



New command (File menu)
Use this command to create a new, unnamed document.
You can open a new document, and give it a name at the same time, with the Open command.

Shortcuts:
Toolbar:

Keys: Ctrl+N
More information



Open command (File menu)
Use this command to open an existing document.
Select the file (or multiple files) from the Open File dialog box which appears.

Shortcuts:
Toolbar:

Keys: Ctrl+O
More information



Close command (File menu)
Use this command to close all views containing the active document.
You get prompted to save changes to your document before you close it.    If you close a document 
without saving, you lose all changes made since the last time you saved it.    Before closing an untitled 
document, the Save As dialog box appears to suggest that you name and save the document.
More information



Close All command (File menu)
Use this command to close all your documents.    If any document has been modified, you will be 
prompted to save it before its window is closed.



Save command (File menu)
Use this command to save an open document.
When you save an unnamed document for the first time, the Save As dialog box appears, so that you 
can give it a name.

Shortcuts:
Toolbar:

Keys: Ctrl+S
More information



Save As command (File menu)
Use this command to save the active document with another name.
The Save As dialog box appears, so that you can supply the new name.
More information



Save All command (File menu)
Use this command to save all modified documents.
When you save an unnamed document for the first time, the Save As dialog box appears, so that you 
can give it a name.

Shortcuts:
Keys: Ctrl+Shift+S



Manage Files command (File menu)
Use this command to open copy, rename, delete or update the timestamps of files.

Shortcuts:
Toolbar:

Keys: F3
More information



Print command (File menu)
Use this command to print the active document.
This command presents a Print dialog box, where you may specify the range of pages to be printed, the 
number of copies, the destination printer, and other printer setup options.

Shortcuts:
Toolbar:

Keys: Ctrl+P
More information



Print Preview command (File menu)
Use this command to display the active document as it would appear when printed.
When you choose this command, the main window will be replaced with a print preview window in which
one or two pages will be displayed in their printed format.    The print preview toolbar offers you options 
to view either one or two pages at a time; move back and forth through the document; zoom in and out 
of pages; and initiate a print job.

Shortcuts:
Toolbar:

Keys: Ctrl+Shift+P



Print Setup command (File menu)
Use this command to select the printer and setup the appearance of the printed page.
You can set margins and headers and footers on the Configure Printing dialog box which appears.
More information



Send command (File menu)
Use this command to send the active document to another person via electronic mail.    You must have a
MAPI compatible e-mail system installed to enable this command.



1, 2, 3, 4 ... command (File menu)
Use the numbers and filenames listed at the bottom of the File menu to open the last several documents
you closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)
Use this command to end your session.    You can also use the Close command on the application 
Control menu.    You are prompted to save any documents with unsaved changes.

Shortcuts:
Mouse: Double-click the application's Control menu button.
Keys: Alt+F4



Undo command (Edit menu)
Use this command to undo the last edit command, including Redo.    It is unavailable when there is 
nothing to undo.
You can undo each edit you made since the file was last saved by repeated use of this command, or you
can undo all edits at once using Ctrl+Shift+Z.

Shortcuts:
Toolbar:

Keys: Ctrl+Z    or    Alt+Backspace
More information



Redo command (Edit menu)
Use this command to cancel the last Undo command.    It is unavailable when there is nothing to redo.
You can redo each undo you cancelled by repeated use of this command, or you can redo all undos at 
once using Ctrl+Shift+A.

Shortcuts:
Toolbar:

Keys: Ctrl+A
More information



Cut command (Edit menu)
Use this command to remove the currently selected text from the document and put it on the clipboard.   
It is unavailable if no text is currently selected.
Cutting text to the clipboard replaces the contents previously stored there.

Shortcuts:
Toolbar:

Keys: Ctrl+X    or    Shift+Delete
More information



Copy command (Edit menu)
Use this command to copy the selected text from the document to the clipboard.    It is unavailable if no 
text is currently selected.
Copying text to the clipboard replaces the contents previously stored there.

Shortcuts:
Toolbar:

Keys: Ctrl+C    or    Ctrl+Insert
More information



Paste command (Edit menu)
Use this command to insert the contents of the clipboard at the caret position, or to replace the current 
selection.    It is unavailable if there is no text on the clipboard.

Shortcuts:
Toolbar:

Keys: Ctrl+V    or    Shift+Insert
More information



Cut Selection Append command (Edit menu)
Use this command to remove the currently selected text from the document and append it to any text 
already on the clipboard.    It is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+X

More information



Copy Selection Append command (Edit menu)
Use this command to copy the currently selected text from the document and append it to any text 
already on the clipboard.    It is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+C

More information



Invert Case command (Edit menu)
Use this command to change selected characters from upper to lower case, and vice versa.
If no text is currently selected, the case of the character after the caret is changed, and the caret is 
moved one position to the right.

Shortcuts:
Keys: Ctrl+K

More information



Upper Case command (Edit menu)
Use this command to change selected characters from lower to upper case.
If no text is currently selected, the case of the character after the caret is changed, and the caret is 
moved one position to the right.

Shortcuts:
Keys: Ctrl+U

More information



Lower Case command (Edit menu)
Use this command to change selected characters from upper to lower case.
If no text is currently selected, the case of the character after the caret is changed, and the caret is 
moved one position to the right.

Shortcuts:
Keys: Ctrl+L

More information



Capitalize command (Edit menu)
Use this command to make the first character of each word in the current selection upper case, and the 
rest lower case.
This command is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+U

More information



Transpose command (Edit menu)
Use this command to transpose lines or characters.    If the caret is at the beginning or end of a line, the 
adjacent lines are swapped, otherwise the adjacent characters are swapped.
This command is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+T



Transpose Words command (Edit menu)
Use this command to transpose the words either side of the caret. Any punctuation between the words is
left in place.    If the caret is in the middle of a word, its two halves are transposed.
This command is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Shift+T



Unindent command (Edit menu)
Use this command to reduce the indentation of currently selected lines.

Shortcuts:
Toolbar:

Keys: Shift+Tab
More information



Indent command (Edit menu)
Use this command to increase the indentation of currently selected lines.

Shortcuts:
Toolbar:

Keys: Tab
More information



Insert File command (Edit menu)
Use this command to insert the contents of a file at the caret position, or to replace the current selection. 
The File Open dialog box appears to allow you to select the file to insert.

Shortcuts:
Keys: Ctrl+Shift+V

More information



Join Lines command (Edit menu)
Use this command to join currently selected lines.    Each line in turn is appended to the first, separated 
by a single space.    Paragraphs are preserved in word-wrapping mode.

Shortcuts:
Keys: Ctrl+J

More information



Reformat/Split Lines command (Edit menu)
Reformat:
Use this command when not in word-wrapping mode to adjust the lengths of currently selected lines to 
the word-wrap margin.    Words are moved between the lines as necessary, and blank lines are 
preserved as paragraph separators.

Split Lines:
Use this command when in word-wrapping mode to split currently selected lines at the point where they 
are wrapped, by inserting new line characters.

Shortcuts:
Keys: Ctrl+Shift+J



Insert Line After command (Edit menu)
Use this command to open up a new line after the line containing the caret.    It is unavailable if the 
current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+I

More information



Insert Line Before command (Edit menu)
Use this command to open up a new line before the line containing the caret.    It is unavailable if the 
current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Shift+I

More information



Insert Page Break command (Edit menu)
Use this command to insert a page break at the start of the line containing the caret.    It is unavailable if 
any text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+L

More information



Insert Time command (Edit menu)
Use this command to insert the current time at the caret position.    The format used is as specified with 
Control Panel's International applet.

Shortcuts:
Keys: Ctrl+F10



Insert Short Date command (Edit menu)
Use this command to insert the current date at the caret position.    The format used is as specified for 
short dates with Control Panel's International applet.

Shortcuts:
Keys: Ctrl+F10



Insert Long Date command (Edit menu)
Use this command to insert the current date at the caret position.    The format used is as specified for 
long dates with Control Panel's International applet.

Shortcuts:
Keys: Ctrl+F10



Cut Line command (Edit menu)
Use this command to remove the line containing the caret from the document and put it on the clipboard.
It is unavailable if the current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Y

More information



Cut Line Append command (Edit menu)
Use this command to remove the line containing the caret from the document and append it to any text 
already on the clipboard.    It is unavailable if the current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Shift+Y

More information



Cut Word command (Edit menu)
Use this command to remove the word containing the caret from the document and put it on the 
clipboard.    It is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Q

More information



Cut Word Append command (Edit menu)
Use this command to remove the word containing the caret from the document and append it to any text
already on the clipboard.    It is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Shift+Q

More information



Mark Clean command (Edit menu)
Use this command to cancel, without undoing, any changes that have been made to the active 
document.    The changes remain, but you will not be prompted to save the document when you close it.
This command also clears the undo buffer for the document.



Delete command (Edit menu)
Use this command to delete the currently selected text, or the character after the caret if nothing is 
selected.

Shortcuts:
Keys: Delete



Delete Bookmarked Lines command (Edit menu)
Use this command to delete all lines that have bookmarks on them.



Cut Bookmarked Lines command (Edit menu)
Use this command to delete all lines that have bookmarks on them, and place them on the clipboard.



Copy Bookmarked Lines command (Edit menu)
Use this command to copy all lines that have bookmarks on them to the clipboard.



Fill Block command (Edit menu)
Use this command to fill the selected block of text with a specified character or characters.    A dialog box
is displayed for you to enter the characters to fill with.    These are repeated if the block to be filled is 
wider than the fill characters.
You can fill with tabs by entering ‘\t’ as the fill character.    If you actually want to fill with ‘\t’, enter it as ‘\\t’.
This option is disabled until a selection has been made in block mode.



Clear All command (Edit menu)
Use this command to delete the whole contents of the Command Output window.

Shortcuts:
Keys: Ctrl+Del



Select All command (Edit menu)
Use this command to select the whole document.

Shortcuts:
Mouse: Crl+Left click in the left margin.
Keys: Ctrl+Home, followed by Ctrl+Shift+End

More information



Find command (Search menu)
Use this command to specify a search string and the search criteria, such as whether or not to match 
case.    It brings up the Find dialog box, which can remain permanently on screen.

Shortcuts:
Toolbar:

Keys: F5
More information



Find Next command (Search menu)
Use this command to find the next occurrence of the selected text.    If nothing is selected, or the 
selection extends over one line, the last search string, if any, is used.
If one of the Find, Replace, or Find in Files dialog boxes is on the screen, the new search string is 
copied to its Find What box.

Shortcuts:
Keys: Ctrl+F

More information



Find Previous command (Search menu)
Use this command to find the previous occurrence of the selected text.    If nothing is selected, or the 
selection extends over one line, the last search string, if any, is used.
If one of the Find, Replace, or Find in Files dialog boxes is on the screen, the new search string is 
copied to its Find What box.

Shortcuts:
Keys: Ctrl+Shift+F

More information



Find in Files command (Search menu)
Use this command to specify a search string, the search criteria, such as whether or not to match case, 
and the list of files to search.    It brings up the Find in Files dialog box, which can remain permanently on
screen.

Shortcuts:
Toolbar:

Keys: Ctrl+F5
More information



Replace command (Search menu)
Use this command to specify search and replace strings and the search criteria, such as whether or not 
to match case.    It brings up the Replace dialog box, which can remain permanently on screen.

Shortcuts:
Toolbar:

Keys: Ctrl+F8
More information



Replace Next command (Search menu)
Use this command to replace the current selection with the last defined replacement string.

Shortcuts:
Keys: Ctrl+F8

More information



Go To command (Search menu)
For text files, this command moves the caret to the beginning of a specified line.    It brings up the Go To 
Line dialog box, in which you type the line number.
For binary files, this command moves the caret to a specified offset in the file.    It    brings up the Go To 
Address dialog box, in which you type the address in hexadecimal.

Shortcuts:
Keys: Ctrl+G



Jump Next command (Search menu)
Use this command to do a hypertext jump to the next item in the Search or Command output windows.
Which of the Search or Command output windows is used by this command is set according to the last 
one accessed.    This is shown with a bullet ( ) against it on the Window menu.

Shortcuts:
Toolbar:

Keys: F4



Jump Previous command (Search menu)
Use this command to do a hypertext jump to the previous item in the Search or Command output 
windows.
Which of the Search or Command output windows is used by this command is set according to the last 
one accessed.    This is shown with a bullet ( ) against it on the Window menu.

Shortcuts:
Toolbar:

Keys: Shift+F4



Toggle Bookmark command (Search menu)
Use this command to set or clear a bookmark on the current line.

Shortcuts:
Keys: Ctrl+F2

More information



Next Bookmark command (Search menu)
Use this command to go to the next line containing a bookmark.

Shortcuts:
Keys: F2

More information



Previous Bookmark command (Search menu)
Use this command to go to the previous line containing a bookmark.

Shortcuts:
Keys: Shift+F2

More information



Clear All Bookmarks command (Search menu)
Use this command to remove all the bookmarks from the active document.

Shortcuts:
Keys: Ctrl+Shift+F2

More information



Match Bracket command (Search menu)
Use this command to go to the closing bracket matching the opening bracket after the caret (or vice 
versa).

Shortcuts:
Keys: Ctrl+M

More information



Compare Files command (Tools menu)
Use this command to look for differences between two text files.    It brings up the Compare Text Files 
dialog box, in which you can specify the file names.
More information



Spelling command (Tools menu)
Use this command to check the spelling of the active document.

Shortcuts:
Toolbar:

Keys: F7
More information



Sort command (Tools menu)
Use this command to sort selected lines.
More information



Convert command (Tools menu)
Use this command to convert the character set in the active document between ANSI and DOS (also 
known as OEM or IBM).
Note that the conversion is not reversible for characters that are unique to the current character set 
(such as line drawing characters), and the command cannot be undone.
TextPad selects the MS LineDraw font, after converting to DOS, and the default font after converting to 
ANSI.
More information



Explorer/File Manager command (Tools menu)
Use this command start Windows own File Manager, or Explorer.

Shortcuts:
Keys: Alt+F3



Stop command (Tools menu)
Use this command to terminate the user tool whose output is being redirected to the Command Output 
window.

Shortcuts:
Keys: Ctrl+Break

More information



Run command (Tools menu)
Use this command to start another application, and optionally redirect its output to the Command Output
window.    It brings up the Run dialog box for you to fill in the details.
More information



User Tool command (Tools menu)
Use this command to start the application that has been added to the Tools menu.
More information



Record command (Macros menu)
Use this command to start and stop the macro recorder.

Shortcuts:
Toolbar:

Keys: Ctrl+Shift+R
More information



Pause command (Macros menu)
Use this command to temporarily suspend and resume the macro recorder.

Shortcuts:
Toolbar:

More information



Playback command (Macros menu)
Use this command to play back the unnamed (scratch) macro.

Shortcuts:
Toolbar:

Keys: Ctrl +R
More information



Multi-play command (Macros menu)
Use this command to play back a chosen macro macro more than once.

Shortcuts:
Toolbar: Shift+

Keys: Ctrl+F7
More information



Save command (Macros menu)
Use this command to save the unnamed (scratch) macro.
More information



User Macro command (Macros menu)
Use this command to play back the selected macro in its default play mode.

Shortcuts:
Keys: Ctrl+Numpad <number>

More information



Block Select Mode command (Configure menu)
Use this command to alternate between block (column) and normal selection modes.    A check mark is 
shown against this menu item when block selection mode is enabled.    The current state is also 
displayed on the status bar.
This command is not available in word-wrapping mode.

Shortcuts:
Mouse: Alt+Left button

More information



Word Wrap command (Configure menu)
Use this command to switch in and out of word-wrapping mode.

Shortcuts:
Toolbar:

Keys: Shift+F12
More information



Visible Spaces button

Displays spaces tabs and paragraph marks 
as visible characters. Spaces are shown as (

) , tabs as (»), and line ends as (¶).

Click the button a second time to hide visible spaces.



Synchronize Scrolling command (Configure menu)
Use this command to switch in and out of synchronized scrolling mode.    When enabled, "Sync" is 
shown on the status bar, and scrolling one view causes all views of all other documents to scroll by the 
same amount.



Preferences command (Configure menu)
Use this command to bring up the Preferences dialog box.    This lets you configure various settings.
More information



Screen Font command (Configure menu)
Use this command to bring up the standard Font dialog box.    This lets you select the font to be used on 
the screen.
More information



Document Properties command (Configure menu)
Use this command to bring up the Document Properties dialog box.    This lets you change various 
properties of the active document, and view its statistics.
More information



Split Window command (Window menu)
Use this command to split the active window into 2 panes.    You may then use the mouse or the 
keyboard arrows to move the splitter bar.    When you are finished, press the left button, or Enter to leave
the splitter bar in its new location.
Pressing escape cancels this command.
More information



Tile Across command (Window menu)
Use this command to arrange your windows side by side across the screen.



Tile Down command (Window menu)
Use this command to arrange your windows one above another, in a non-overlapped fashion, down the 
screen.



Cascade command (Window menu)
Use this command to arrange your windows in an overlapped fashion, from top left to bottom right of the 
screen.



Arrange Icons command (Window menu)
Use this command to arrange neatly the icons for minimized windows at the bottom of the main window. 
If there is an open document window at the bottom of the main window, then some or all of the icons 
may not be visible because they will be underneath this document window.



Use Selector command (Window menu)
Use this command to bring up the Window Selector.    This is a list of your open documents that remains 
permanently on the screen.    You can move and resize this to your requirements, and use it to switch 
between document windows.

Shortcuts:
Keys: F11

More information



Search Output command (Window menu)
Use this command to switch to the window showing the results of the last Find in Files command.    This 
command is unavailable if you close the window, until you do another Find in Files.
After you have used this command, a bullet mark ( ) is shown against it on the Window menu, to show 
that the Jump Next/Previous commands on the Search menu apply to this window.

Shortcuts:
Keys: Shift+F11

More information



Command Output command (Window menu)
Use this command to switch to the window showing the output of the last tool from the tools menu.    This
command is unavailable if you close the window, until you run another tool.
After you have used this command, a bullet mark ( ) is shown against it on the Window menu, to show 
that the Jump Next/Previous commands on the Search menu apply to this window.

Shortcuts:
Keys: Ctrl+F11

More information



1,2,... command (Window menu)
A list of currently open document windows is displayed at the bottom of the Window menu.    A check 
mark appears in front of the document name of the active window.    Choose a document from this list to 
make its window active.



Contents command (Help menu)
Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions, and various types of reference information.
Once you open Help, you can click its Contents button whenever you want to return to the opening 
screen.



Search for Help command (Help menu)
Use this command to display the Search dialog box.    This displays the index of help topics for you to 
select from.    It is equivalent to clicking the Search button when you are already running the help 
system.



File Statistics command (Help menu)
Use this command to display the size and number of lines in the active document, on the status bar.

Shortcuts:
Keys: Ctrl+F1



About TextPad command (Help menu)
Use this command to display the About dialog box.    This displays various license details, and system 
resource information.



Context Help command

Use the Context Help command to obtain help on some portion of the graphical interface.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.
Then click somewhere in the application window, such as another Toolbar button.    The Help topic will be
shown for the item you clicked.
Pressing escape cancels this command.

Shortcuts:
Keys: Shift+F1



Open Include File
Clicking with the right button on a line beginning #include ..., adds a command to open the included
file to the popup menu.    If you choose that command, the file will be opened in a new window.



How to Sort by Selected Column
To sort lines in your document, using the text in the selected column as a key:
1. Uncheck word-wrapping and check block select mode on the Configure menu.
2. Click the mouse at the top left of the column, and drag it to the bottom right to select the lines to sort.
3. From the Tools menu, choose the Sort command to display the Sort Selected Column dialog box.
4. Choose to sort in ascending or descending order.
5. Set the comparison to be by character, with capital letters being significant or not, or by numeric 

value.
6. Click OK.

Notes:
Character comparisons use the collating sequence conventions for the regional settings selected 

with Windows Control Panel.
Numeric comparisons use signed integral values.    Floating point values are not supported.    If 

the key field does not contain a number, the value used for comparison is the ANSI code of the first 
character.

See also: Sorting by Keys



How to Sort by Specified Key Positions
To sort selected lines in your document, using up to 3 keys:
1. Uncheck block select mode on the Configure menu.
2. Click the mouse on the first line, and drag it to the last line to sort.
3. From the Tools menu, choose the Sort command to display the Sort Selected Lines dialog box.
4. For each of up to 3 keys:

Specify the start display column position and length.    Omit the length if the key extends to the end of
the line.
Choose to sort in ascending or descending order.
Set the comparison to be by character, with capital letters being significant or not, or by numeric 
value.

5. Click OK.

Notes:
Lines are sorted first by key 1, then key 2, then key 3.
Keys may overlap.
Character comparisons use the collating sequence conventions for the locale selected using 

Windows Control Panel.
Numeric comparisons use signed integral values.    Floating point values are not supported.    If 

the key field does not contain a number, the value used for comparison is the ANSI code of the first 
character.

See also: Sorting by Column



How to Check Spelling: Overview
TextPad has licensed spelling checking technology from LexSaurus Software, Inc.    This gives you the 
ability to verify words, correct spelling errors, check capitalization, create your own dictionaries, and 
extend the standard ones.    Dictionaries are available in the following languages:

bokmål italiano
dansk Nederlands
Deutsch svenska
español UK English
français US English

See Obtaining Standard Dictionaries if you don't already have the dictionary you require.
Standard dictionaries must all be installed in the same folder as TextPad, but you can specify an 
alternative folder for custom dictionaries, and personal extensions to standard dictionaries.    (You will 
want these folders to be different if TextPad is installed on a file server.)    Personal extensions are added
to a user dictionary corresponding to the currently selected language or custom dictionary, so the 
standard dictionaries can be write protected.
By default, if the corresponding dictionary is available, TextPad will use the one corresponding to the 
language you have set for Windows (using Control Panel).    You can choose a particular language using
the Preferences command, and selecting the Spelling tab on the Preferences dialog box.
Spelling is checked for the entire document, unless you select the text to be checked first.    Text in 
HTML tags will be ignored for documents with standard HTML file extensions, and LaTex commands will 
be ignored in documents with extension .TEX.
When a word is not recognized, you can add it to the dictionary.    If you know in advance of words you 
use that are unlikely to be in the dictionary, you can add them all at once from a simple text file.    
Normally, such additions are used in conjunction with the corresponding standard dictionary, but you can
have up to two stand-alone custom dictionaries.
In case you are wondering why you can't just use the spelling checker of your favorite word processor with TextPad, it's because of
licensing restrictions.    You've already paid for the spelling checker, but TextPad cannot use it without a license, and Inso Corp. 
were not interested in selling one for use with shareware.



How to Check Spelling
To check the spelling of a whole document, first clear any selection, otherwise select the text to check, 
then choose the Spelling command from the Tools menu.    You will be presented with the following 
dialog box for each word that is not recognized:

The spelling checker will list suggestions for the correction, if it has any, and place the most likely of 
them in the Change To box.    If you want to edit the original word, you can copy it to the Change To box 
by clicking it.
The actions available are:

Ignore this occurrence of the word, and continue checking.
Ignore All occurrences of the word, and continue checking.
Change the original to the word in the Change To box, and continue checking.
Auto-correct all occurrences of the word to the word in the Change To box, and continue 

checking.
Add the original to the dictionary, and continue checking.    Note that Shift+Add will add all unique 

words in the document to the dictionary.
Suggest other words similar to the one in the Change To box.    This button is disabled until you 

modify the Change To word.
Undo Last change, and continue checking.
Close the spelling checker.

The Options button allows you to select the language and configure various other settings.    You can 
also do this using the Preferences command and selecting the Spelling tab on the Preferences dialog 
box.



How to Edit User Dictionaries
There is one user dictionary corresponding to each of the available languages.    When you edit a 
dictionary, no changes are made to the base dictionary.
To edit a user dictionary:
1. Choose the Preferences command on the Configure menu.    The Preferences dialog box will be 

displayed.
2. Select the Spelling tab.
3. Choose the language to edit.
4. Click the Edit button to display the following dialog box.

The words currently in the dictionary will be listed.    Choose from the following actions (none of which 
can be undone):

Add the word in the Entries box.    If you want an automatic replacement for all occurrences of 
this word (e.g. one you frequently mistype, or an abbreviation you want to expand), type it in the 
Automatic Replacement box before clicking Add.

Delete the selected word.
Change the selected word to the one in the Entries box.    You can change the Automatic 

Replacement at the same time.
Add File of words.    Prepare the file with one word per line, optionally separated by a space or 

tab from its automatic replacement.    The automatic replacement may contain spaces, but neither the 
word nor its replacement may contain more than 50 characters.

Delete All words in the dictionary.
Close the editor.



How to Obtain Standard Dictionaries
Standard dictionaries for the spelling checker are available for downloading from our web site at 
http://www.textpad.com/, and from CompuServe forum WINUTIL, amongst other sources.    The following
table shows the name of the file to download for each language.    To install a language file, simply unzip 
it into your TextPad installation folder.

Language: File Name:
bokmål txpadbok.zip
dansk txpaddan.zip
Deutsch txpaddeu.zip
español txpadesp.zip
français txpadfra.zip
italiano txpadita.zip
Nederlands txpadned.zip
svenska txpadsve.zip
UK English txpaduk.zip
US English txpadus.zip



How to Configure the Spelling Checker
To configure the spelling checker:
1. Choose the Preferences command on the Configure menu.    The Preferences dialog box will be 

displayed.
2. Select the Spelling tab.

This tab can also be displayed by clicking the Options button on the Spelling dialog box.
The parameters you can configure are:
Folder for user dictionaries:  This defaults to the installation directory.    You will want to change this if 
TextPad is installed on a file server.
Language: choose from the drop-down list of available languages.    Automatic selects the language 
configured by Control Panel.
Ignore words containing.  These settings are on a per language basis:
All CAPITALS - prevent acronyms (e.g. HTML) being checked;
Numbers - prevent paragraph numbers, such as A10, being checked
Single letters - prevent one letter words being checked.
Remember which words to correct automatically.  When checked, words corrected using the Auto-
Correct button on the Spelling dialog box are permanently saved in the user dictionary.    Otherwise, they
are discarded when you close TextPad.
Prompt for proper nouns and abbreviations.  When not checked, unrecognized words that start with 
a capital letter, or end with a period are added to the user dictionary exactly as typed.    This means that 
if they are later encountered without an initial capital letter or trailing period, they will not be recognized, 
and will have to be added as separate words.    When this option is checked, you will be asked if a word 
starting with a capital letter is a proper noun.    If not, it will be added with the first letter in lower case.    
Similarly, if a word ends in a period, you will be asked if it is an abbreviation.    If not, it will be added 
without the trailing period.
Edit the selected user dictionary.



Getting Assistance While You Work
You can use the on-line help system in various ways to help you as you work:

Press F1 in any context to display help information.    For example, highlight a menu command 
and press F1 to find out what it does.

Click 
 on the toolbar, then click 
 where you want help.

Hold the cursor over a toolbar button to find out what it does.
Use the Contents command on the Help menu to display all help topics.



Technical Support
Important: Please read How to Report Problems before submitting any problem reports.
CompuServe members can get support from forum WINUTIL..    Post questions in the Disk Mgt/Editors 
section and the sysops, who are Windows User Group (WUGNET) members will reply.    This can also 
be used for peer group support, so if you can help another user, please do so.
Technical support can also be obtained by sending electronic mail to:

textpad@heliosof.demon.co.uk
You can also fax queries to +44-(0)1772-324353, or post them to:

Helios Software Solutions
Carr Brook House
Chorley Old Road
Brindle
CHORLEY    PR6 7QZ
England



How to Report Problems
Have you checked the frequently asked questions and known problems first?
Please provide at least the following information with any problem report:
1. The version number and edition (16/32-bit) of TextPad.
2. The version of Windows (and Win32s if appropriate) that you're using.
3. Driver manufacturer and version numbers for printer problems.
4. Display driver and screen resolution for GPF's, along with any error messages.
5. How to reproduce the problem.

E-mail your completed report to:
textpad@heliosof.demon.co.uk

or FAX it to:
+44-(0)1772-324353

or post it to:
Helios Software Solutions
Carr Brook House
Chorley Old Road
Brindle
CHORLEY    PR6 7QZ
England



Obtaining Updates
New releases of TextPad will be made available for downloading from various sites, including:
Our Internet Web site at URL: http://www.textpad.com/
Our FTP server at: ftp.textpad.com

Log in as "anonymous", use your e-mail address as the password, and change directory to 
/public_html/download.

CompuServe forum WINUTIL, as:
TPAD16.ZIP (16-bit edition)
TPAD32.ZIP (32-bit edition)

The Coast to Coast WWW and FTP servers at:
http://www.coast.net/SimTel/, and ftp.coast.net as:
/simtel/win3/editor/txp16???.zip (16-bit edition)
/simtel/win95/editor/txp32???.zip (32-bit edition)

Note: To maintain full TextPad access rights, registered users must keep their original license file with 
each new release.



Here are some tips you may find useful:
Remember to make use of the right mouse button.
Double left click in the left margin selects the line.
Ctrl+left click in the left margin selects all lines.
When you right click a "#include" line in a C/C++ source file, a command to open the included file 

is added to the pop up menu.
You can use Explorer's Send To command to open selected files with TextPad.    Right click the 

selection, choose Send To, and pick TextPad from the cascading menu.
When using the Save As dialog box, Windows 95 will not let you specify a name without an 

extension, or an arbitrary extension that it does not recognize, unless you select "All Files (*.*)" as the 
Save as type, or enclose the name in quotes.

When the File Open dialog box is enabled for multiple file opening, it does not show long file 
names (except on Windows 95 & NT 4).    This setting can be changed on the General tab of the 
Preferences dialog box.

On Windows 95, you can create directories, and rename and delete files using the Open File 
dialog box, just like in Explorer.

Ctrl+Shift+O brings up a simple dialog box for file opening.
In the Replace dialog box, you can use '\t' as a tab in the search and replace strings, if you check 

the Regular Expression check box.
After you have saved the Search or Command output results as an ordinary file, it loses its 

hypertext jump property, but you can always load an ordinary file into the Command output window by 
capturing the output from the DOS TYPE command.



Known Problems
The following problems have been identified with this release:
1. Various printer drivers do not work with Win32s (eg. HP DeskJet and Citizen Swift).    The symptoms 

are that TextPad 32 goes through the motions of printing a file, but it never gets printed.    Try using a 
compatible driver from the standard list of Windows printer drivers, instead of the one that comes 
with the printer, or contact your supplier for an updated driver.    You can get PCL driver 6.1d, to fix 
the problemwith HP DeskJets, from CompuServe forum HPPERIPHERALS.

2. If you use TextPad 16 and you have an HP LaserJet 4M with the Adobe printer driver, you must use 
version 3.01 or later.    This can also be downloaded from CompuServe forum HPPERIPHERALS.

3. WinFax Pro 4 does not work with 32-bit applications that use Win32s to run on 16-bit Windows.    
Therefore you must use the 16-bit edition of TextPad if you want to use it to send faxes on Windows 
3.1x.

4. The 32-bit edition will not save files from NT 4 to a UNIX server, if connected using Samba, unless 
the direct overwrite option is set on the Backup tab of the Preferences dialog box.



How to Uninstall TextPad
From Windows 95:
1. Click the Start menu and select Settings/Control Panel.
2. Double click Add/Remove Programs.
3. Select TextPad from the list and click Add/Remove.
4. Confirm that you want to uninstall TextPad.
5. When Uninstall has finished, use Explorer to manually delete the installation directory, and the 

uninstall program.

From Other Versions of Windows:
1. Run UNINSTAL.EXE (or UNINST16.EXE) from your installation directory.
2. Confirm that you want to uninstall TextPad.
3. When Uninstall has finished, use File Manager to manually delete the installation directory, and the 

uninstall program.
4. Manually delete any Program Manager icons and groups for TextPad.

A Note About File Associations:
Any file associations that you have made with TextPad 1.31 or later will revert back to their defaults 
when you uninstall TextPad.    If you have previously associated any file extensions with TextPad, and 
you want to set them back to their default associations at any time:
1. Run File Manager (WINFILE.EXE)
2. Select any file with the given extension.
3. From the File menu, choose the Associate command.
4. Make the corresponding association from the following table:

.BAT MS-DOS Batch File

.INF Setup Information

.INI Configuration Settings

.REG Registration Extries

.TXT Text Document



The Command Output Window
The Command Output Window is used to capture the output from the Run command, or from tools 
added to the Tools menu.    If the output is from a compiler, or Grep type program, it can be used to 
hypertext jump directly to the corresponding source line using left double-click.    Built-in support is 
provided for output from Microsoft and Symantec compilers, in the form:

filename(line): message
If this default is not suitable, it will be necessary to specify an alternative hypertext jump regular 
expression,.    This is set from the Hypertext Expression command on the Configure menu for the 
Commmand Output window.

Loading a File into the Command Output Window:
If the command output to be used for hypertext jumps is written to a file, rather than stdout, it cannot be 
automatically captured.    However, any file can subsequently be loaded into the Command Output 
window by adding the following command to the Tools menu:

Command: TYPE
Menu Text: Load Command Output
Parameters:
Initial Directory: (something suitable)
Prompt for Parameters X
Run Minimised: X
Capture Output: X
DOS Command: X

If the file needs post-processing in any way, use your own filter program, instead of the DOS TYPE 
command, to write the processed data to stdout.



Tool Parameter Macros
Programs that you add to the Tools Menu can be started with context dependent information using 
parameter macros.    These can be specified in the "Parameters" and "Initial Directory" fields of the Tools 
dialog box, and in the Run and Tool Parameters dialog boxes.    The following macros are defined:

Macro Name Expanded String
$File The fully qualified filename of the current

document.
$DOSFile Same as $File, except that DOS aliases 

are substituted for any long names in the
path.

$FileName The simple filename of the current 
document.

$BaseName $FileName, stripped of any extension.
$FileDir The drive and directory of the current 

document.
$FilePath The directory of the current document, 

stripped of the drive.
$Dir The current working drive and directory.
$Line The caret line within the current 

document
$Col The caret column within the current 

document
$Sel Selected text in the active document.    

This is limited to the first line in a 
multiple-line selection.

Notes:
Any macro that is inappropriate in the current context is replaced by an empty string.
Macros can be in any case (eg. $File = = $file = = $FILE).
The macro name can be bracketed to delimit it from subsequent text.    (eg. $(Sel)ection).
If a filename macro contains spaces when expanded, it will automatically be quoted.
Fully qualified is defined to mean drive + path from the root of that drive (eg. C:\WINDOWS\

WIN.INI).
In any expression using macros, each macro must be terminated by a non-alphabetic character, 

or the end of line.



Command Line Parameters
The command line parameters listed below can be used to start TextPad.    They are not case sensitive, 
but must appear before any file names.    Surround any parameters containing spaces with quotation 
marks (").    Because some of the parameters are mutually exclusive, conflicts are resolved by using the 
last option specified.    Any other parameters are silently ignored.    The switch character can be '/' or '-' 
as shown:

Parameter Description
-av Arrange windows vertically tiled.
-ah Arrange windows horizontally tiled.
-ac Arrange windows cascaded.
-am Arrange windows maximized.
-p "file" Print the specified file using default printer.
-q Don’t display startup "splash" message.
-r Open any files in the command line as read

only.
-s Started by a DDE shell command.
-t "title" Append "title" to the main window title bar.
-u file Open the file, whose name can contain 

spaces, but does not need to be quoted.

Notes:
Except when using the -p option, these command parameters can be followed by multiple 

filenames and/or wildcards, but they must be quoted to allow for filenames containing spaces.
An empty, quoted filename (i.e. "") causes a new document to be created.
If the filename to be edited (not printed) is followed by "(<line>[,<col>])", with no intervening 

spaces, the file will be opened with the caret at that position.    If <line> is a hex number (eg. 0x1a22), a 
hex view of the file will be created, with the caret at that address.

eg.    TXTPAD32.EXE -ac "Read me.txt(51,20)"
In this example TextPad will start up and open "Read me.txt" at line 51, column 20 and display it in a 
cascaded window.



How to Run Other Programs
1. From the Tools menu, choose the Run command.    The Run dialog box appears.
2. In the Command box, either type the name of the program or command, or choose a previous entry 

from the drop-down list.    If the program cannot be found in your search path, you will need to supply
its full path name.

3. In the Parameters box, type any parameters required by the program.    You can use any tool macros
such as $File here, to specify the active file.

4. In the Initial Directory box, type the initial working directory for the program.    If this box is blank, it 
defaults to the installation directory of the particular program.    You can use directory tool macros 
here.

5. If the command is a DOS internal, such as DIR or TYPE, check the DOS Command box.
6. If you want the program to run in a minimized window, check the Run Minimized box.
7. If you want to redirect the output from the program to the Command window, check the Capture 

Output box.    This has no effect for Windows applications.
8. Click OK.

Note:
If you capture the output of another program in 32-bit versions of Windows, the output is displayed in the
Command window immediately.    In 16-bit versions of Windows, the output is displayed when the 
program finishes.



How to Use with Compilers
You can configure TextPad to compile the file in the active window, and output any compiler error 
messages to the Command Output window.    By double clicking an error message, you can go straight 
to the corresponding source line.
The first step is to add the command line for your compiler to the Tools menu using the Tools tab of the 
Preferences dialog box.
Then you may have to define a regular expression that matches compiler error messages, using the 
hypertext Jumps tab.    TextPad uses that to extract the file name, and line and column numbers to open 
the file at the right spot, when you double click the error message.

For example, to configure TextPad to use Java, add it to the Tools menu as follows:
Menu text: Compile JAVA
Command: JAVAC.EXE
Parameters: $File
Initial directory: $FileDir
Capture Output: (x)

Then set its hypertext jump as follows:
Expression: ^\([^:]+\):\([0-9]+\)
File Register: 1
Line Register: 2



How to Use as the Editor for Other Applications
TextPad can easily be used as the editor for other applications.    By using its dynamic data exchange 
(DDE) capabilities, each file to be edited can be opened in a new window, rather than starting another 
copy of TextPad.
The installation directory contains a programs called DDEOPN16.EXE and DDEOPN32.EXE.    These 
translate command line requests to open files into the appropriate DDE commands for the 16 and 32-bit 
editions of TextPad respectively.    The first parameter must be the registered server name TextPad, 
and the second parameter is the file to open, with an optional line and column position immediately 
following in brackets.
Example 1:
To use TextPad as the editor for WinCIM, add the following line to the [General Preferences] section of 
WINCIM.INI:
Text-Editor=C:\TEXTPAD\DDEOPN16.EXE TextPad

Example 2:
To use TextPad as the editor for WinGrep, add the following line as the editor command on its Configure
dialog box:
C:\TEXTPAD\DDEOPN16.EXE TextPad $f($l)

Example 3:
To use TextPad with Visual C++ 1.52, so that it edits the same active file as MSVC, customize the Tools 

menu of MSVC.EXE with the following command:
Command Line: C:\TEXTPAD\DDEOPN16.EXE
Menu Text: &TextPad
Parameters: TextPad $File($Line,$Col)

Example 4:
To use TextPad with Visual C++ 4.1, so that it edits the same active file as MSVC, customize the Tools 
menu of MSVC.EXE with the following command:
Command Line: C:\TEXTPAD\DDEOPN32.EXE
Menu Text: &TextPad
Parameters: $(FilePath)($(CurLine),$(CurCol))

Notes:
For best performance, you should use DDEOPN32.EXE with 32-bit versions of Windows, and 

DDEOPN16.EXE with 16-bit versions.
Whenever TextPad is reactivated, it checks the last modified date of each file that you are editing,

and asks if it should reload any that have been changed by another application.



DDE Commands
The following DDE commands are recognized.    They are all part of the "system" topic.

Command: Function:
[open("filename")] Opens the specified file.
[command(Append,"string ")] Appends the string to the active 

document.
[command(SaveAs,"filename")] Saves the active document with 

the given name.
[command(Save)] Saves the active document.

These commands must be passed exactly as shown, with no embedded spaces, except in the quotes.

Note that the topic is not used to specify the document, so Append, Save and SaveAs all apply to the 
active document.



What's New
See also: History of Changes
TextPad 2.1
Changes and Enhancements:

German user interface (not on-line help) is now available.    This can be selected on the Language
tab of the Preferences dialog box.

Faster memory management in 32-bit edition.
The destination of the Go To command can now be a column or page, as well as a line.
Views can now be split vertically instead of horizontally.    This is configured on the View tab of the

Preferences dialog box.
Synchronized scrolling can be temporarily disabled by holding the Ctrl key whilst using the scroll 

bar.
All lines will be sorted if none are selected.
When text is selected, caret left goes to the start of the selection and caret right to the end.
The spelling checker ignores LaTex commands in documents with the .TEX extension.
New tool parameter macros: $FilePath returns the directory of the active document, stripped of 

the drive letter; and $DOSFile returns the full file name substituting DOS aliases for long name 
components of the path.

The configuration setting for externally modified files has been moved from the General to the File
tab of the Preferences dialog box.    It has a new option to disable checks for modified files.

Command line parameter -r opens any files in the command line as read only.
There is now an option to create a new document on startup, on the General tab of the 

Preferences dialog box.
Fixes:

The ordering of files in the Search Output window now matches those in the Window Selector.
16-bit edition could crash doing Find in Files on files containing Ctrl+Z.
File filters > 255 bytes stopped registry saves.
Filename was not quoted when setting up Associations for printing.
When loading from a file, the spell checker should not have prompted for proper nouns and 

abbreviations.
The status bar message was not cleared when all documents were closed.
Modified indicator (*) on window selector was only updated when a document was active.
Running some DOS tools with invalid file headers could cause the 32-bit edition to crash.
Insert Line Before an indented line, followed by backspace, deleted too much text.
Incorrect caret position after splitting word wrapped lines.
The caret seemed to disappear after indenting a selected block.
If the Search or Command Output windows were saved using the Save button on the toolbar, 

they continued to be used as output windows.
Files containing bracketed numbers in their paths, such as c:\data(1)\file.ext, could not be opened

by double clicking them in Explorer.
Pasting lines longer than 4K resulted in the split lines being inserted in reverse order.
Cancelling a "play once" macro with Ctrl+R disabled the Playback command on the Macro menu.
Failure to find a search pattern didn't cancel macro playback.
A macro that deleted, but didn't move the caret, wasn't allowed to run to end of file.
Move caret by word didn't change the preferred caret position.
The range of the selection was not updated on the status bar, if it was extended with Shift+Left 

click.



File filter customizations could be lost by using the command line to pass a filename to an already
running instance, rather than using DDE, when double clicking an associated file.

Multi-file open only honoured the OEM codeset setting for the first file.
User dictionaries for the spelling checker didn't work on NT 3.51.

TextPad 2.0
Changes and Enhancements:

Up to 16 keystroke macros can be created and assigned to a menu.
A spelling checker with dictionaries in 10 languages.
Sorting by the selected column, or up to 3 specified keys.
Configurable color scheme.
Cut, Copy and Paste are back on the top level of the Edit menu.    Some menu mnemonics have 

had to be changed in consequence.
Visible spaces in word-wrap mode, and a visible end of line character.
A Load All command on the context menu for the Search output window.
Ansi/Dos conversion of the active document, and editing in the DOS code set.
Ctrl+Shift+Del deletes to the end of the current line.
Move by word follows programmer's editor semantics for program source files.
The Explorer Send To command now works for multiple files, but this has changed the 

requirement for quoting file names in command line parameters.
Toolbar buttons for spell checking, keystroke macros, and displaying visible spaces.
Extra shortcuts using toolbar buttons in conjunction with the Shift and Ctrl keys.
Modified files are indicated with an asterisk.
The status bar shows the number of characters or lines selected.
Synchronized scrolling of all views.
Configurable list of extensions recognized as binary files.
The settings for hard line breaks can be set on a per document basis.
New options to:

Strip trailing spaces.
Not treat Ctrl+Z as marking the end of file.
Automatically reload externally modified files.
Disable drag and drop editing in the 32-bit edition.
Store backup files in a specified directory, or with alternative extensions.
Suppress the startup splash message.
Set the default format for new files to PC, UNIX or MAC.
Convert new tabs to spaces, whilst leaving existing ones alone.
Not clear the undo buffer when files are saved.

Conventional file reads and writes can now optionally be used by the 32-bit edition for accessing 
remote files.    This should provide better compatibility with Lantastic, PC-NFS and other network systems 
that don't fully support memory mapping.

Files that are opened for writing by another process can now be loaded into the editor.
The 32-bit edition now detects changes to file modification dates and read-only status, without 

needing to lose and regain active status.
A Replace Next button on the Replace dialog box to replace then find the next occurrence.
Numeric variable in replacement expressions for generating or updating sequence numbers.
Hex character codes (\xdd), newlines (\n), and page breaks (\f) in find/replace regular 

expressions.
If current selection extends over one line, the scope is initialised to Selection on the Replace 

dialog box.



The current selection can be substituted as a parameter to a user tool using tool macro "$Sel".
The Statistics tab now shows a file's format and character set.
Goto Line can now extend the selection in block mode.
Alt+Home/End moves the caret to the start of the first/last visible line.
The page break character is now recognized at the end of lines, as well as at the start.
Paste and drop now replace characters in overtype mode, unless the paste or drop is onto 

selected text.
After a column of text has been inserted, the insert position is moved to the end of the first, rather 

than last line.
Switching to the Search or Command Output window does not change the working directory.
New DDE commands to write to documents and save them.



Changes Made in Previous Releases
Changes and Enhancements in Release 1.32a:
Changes and Enhancements:

Multiple files can now be supplied as command line parameters, provided each name is quoted 
(e.g. txtpad32.exe "File1" "File2").    This is to avoid confusion with file names containing spaces.    If any 
of the files don't exist, TextPad asks if you want to create them.

The commands to insert the date and time now have their own popup menu.    This can be 
popped up using Ctrl+F10, or Ctrl+Right click.

The Block Fill command can now fill with a sequence of numbers.
File comparison can now optionally ignore differences due to case of letters, and numbers of 

spaces and tabs.
The match brackets command now matches < with >.
If the current selection extends over one line, the scope is initialised to Selection on the Print 

dialog box.
When a window is iconised, any file path is stripped from its title.
The combobox has been changed to a listbox on the Filters tabs of the Preferences dialog box.

Bug Fixes in Release 1.32:
When the 32-bit edition is restricted to running as a single instance, file names in command line 

parameters are now made absolute before passing them over to the previous instance.
Warnings due to unterminated last line are no longer given.
The default tab setting on the Preferences dialog box was wrongly initialised to that of the active 

document.
The document width was not recalculated when the tab size was changed.

Additional Fixes in Release 1.32a:
Crash when saving word-wrapped files with hard line breaks.
Command names could not have spaces in user tools.
Parameters to user tools could not be quoted.

Changes and Enhancements in Release 1.31:
User settable default for the ANSI or DOS character set.
"Options" on the Configure menu has been renamed "Preferences".
Changes to configuration settings are saved immediately.
Associating file extensions with TextPad must now be done from the Associations tab of the 

Preferences dialog box.    The setup program no longer has that as an option.
Dates and times are displayed according to the Windows regional setting (32-bit only).
Uninstallation now follows the Windows 95 guidelines.
Paths can be omitted from the file names displayed in the Window Selector.    This is set from the 

General tab of the Preferences dialog box.
The startup "splash" message can be disabled using the command line parameter "-q".
A different caret is used in overtype mode.
When auto-indent mode is enabled, a "}" is always unindented on an empty line, regardless of 

whether or not the caret is constrained to the text.
The Find Next button on the Replace dialog box stops searching at the end of file, rather than 

wrapping around to the beginning, as happens with the Find dialog box.
When run on NT with the 2nd new shell preview, TextPad now uses the new File Open dialog 

box.
The environment variable COMSPEC is now used to determine which command interpreter to run



for user tools.
Bug Fixes in 1.31:

On Windows 95, file extensions are now always displayed, regardless of the setting in Explorer.
Scroll bars now operate correctly on NT 3.5.
When switching from word-wrap mode, horizontal scroll bars are now displayed if set on in View 

Preferences.
Double clicking in the margin in word-wrap mode now selects the line as displayed, instead of the

paragraph.
Splitting lines longer than 4095 characters sometimes inserted garbage into a file.
The 32-bit edition could not open some files with particular accented characters in their names.
Starting with parameter "-s" cleared the "Save Workspace" flag on exit.
Command line parameters are no longer case sensitive.
CreateProcess error -1 in Run command on NT with the new shell preview.

Changes and Enhancements in Release 1.30:
The state of the workspace can be saved between editing sessions, including open documents, 

window positions, bookmarks & fonts.
The Command and Search windows can now be edited, by turning off the read-only property.    

(Double-click Read on the status bar.)
Lines with bookmarks can be cut, copied or deleted.    The Edit menu has been slightly 

rearranged to accomodate the new commands.
A selected block can be filled with a character or string.
The left margin of word-wrapped paragraphs is now aligned with the first line of the paragraph, 

when the Maintain Indentation property is set on the Document tab of the Properties dialog box.
Paragraphs can be reformatted when not in word-wrap mode.
The Close All command has been moved from the Window to the File menu.
The Stay on Top command has been added to the System menu.
A word-wrap button has been added to the toolbar.
A file can be printed without bringing up the Print dialog box, by clicking the print button on the 

toolbar.    The Print command on the File menu still displays the dialog box.
Dragging and dropping files on to a printer icon is now supported on Windows 95.
Text can be converted between the ANSI and DOS (OEM) character sets when opening and 

saving files.
The caret can be set to a flashing block, or a vertical bar from the View tab of the Preferences 

dialog box.
If a document is opened read-only because its file has the read-only attribute set, it is 

automatically made editable when the state of the file changes. (Useful for source control systems.)
To avoid problems with file names containing spaces, TextPad now only allows a single file name 

as a command line parameter.
The pre-release version of the new shell for NT is supported.

Changes and Enhancements in Release 1.29:
On Windows 95 and NT, the 32-bit edition uses the Windows Registry, instead of TEXTPAD.INI to

save its settings.
New commands to insert the current date and time were added to the Edit menu.
The installation program automatically registers TextPad's DDE commands.



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive containing the file that you want to open.

Directories
Select the directory containing the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Title Bar

The title bar is located along the top of a window.    It contains the name of the application and 
document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title 
bars.

A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside the scroll 
bars indicate your vertical and horizontal location in the document.    You can use the mouse to scroll to 
other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow 
keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 

border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with
the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: Ctrl+F7



Minimize command (application Control menu)

Use this command to reduce the window to an icon.

Shortcut
Mouse: Click the minimize icon  on the title bar.

Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse: Click the maximize icon  on the title bar; or double-click the title bar.

Keys: Ctrl+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    This corresponds to the order in which
you opened the windows.

Shortcut
Keys: Ctrl+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window. This corresponds to the order in 
which you opened the windows.

Shortcut
Keys: SHIFT+Ctrl+F6



Close command (Control menus)

Use this command to close the active window or dialog box.
Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: Ctrl+F4 closes a document window

ALT+F4 closes the main window or a dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: Ctrl+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the printer and 
printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selection Prints the currently selected text.
Pages Prints the range of pages you specify in the From and To boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing.    Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the printer.    The 
page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific Printer option 
and select one of the current installed printers shown in the box.    You install printers and configure 
ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of 
printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.




