
Welcome
MicroChart/32 for Windows 95™ and Windows NT™ 3.51 was originally developed as a DOS graphics 
program in 1983 during my teaching assignment at University of Hawaii and from the very beginning till 
present has been used to design and chart the halftime shows of the University of Hawaii "Rainbow" 
Marching Band and the Hula Bowl All-Star Halftime Pageantry. Since most other early marching band 
drill design programs were for the Apple™ (then IIe) computers, MicroChart was one of the first program
of it's kind for the DOS IBM PC platform. A Windows™ version was released in 1991 which included 
several major enhancements that took advantage of the new graphical environment. Now in it's third 
major revision for the new 32-bit Windows 95 and Windows NT, MicroChart/32 supports the newer 
functions, controls, and interface improvements of these environments.

Some of the features of MicroChart/32 include:

Drawing Tools: point, line, block, parallelogram, arc, circle, freeform curves
Edit Functions: copy, delete, move, scale, rotate, mirror, join, center, alter symbol & color, and 

zoom
Multiple zoom magnifications for precision placement of objects
True perspective view for press or visitors with adjustable height & distance settings
Selectable colors for positions and grid
Multiple document support - load and work with several drills at a time
Floatable tool bar and edit bar
Support for high school, NCAA, and professional league hash and yardline markings
Batch printing of chart files
Batch Builder dialog for creating batch print files
Support for most Windows compatible printer including laser and color inkjets
Selectable printer fonts and font attributes
Online help via Windows™ compatible help file
Support for the Windows 95 / Windows NT registry

Thank you for using MicroChart/32!

MicroChart/32 was developed and tested on Windows NT Workstation 3.51 & 4.0 Beta 2 and Windows 95 with Microsoft Visual C+
+ 4.2 on a Cyrix 6x86-P166 system with 64 MB RAM, 2.2 GB hard disk, Matrox Millennium PCI accelerated video running at 
1024x768x64K and large fonts.

Copyright © 1996 by Keith Y. Higaki, H&H Enterprises
All Rights Reserved.



Legal Information

COPYRIGHT 
Copyright © 1996 by H&H Enterprises. All Rights Reserved. This documentation may not, in whole or part, be copied, 
photocopied, translated, or reduced to any electronic medium or machine readable form, without prior consent, in writing, from 
Keith Y. Higaki and H&H Enterprises. All software described in this documentation is Copyright © 1996 by H&H Enterprises. All 
Rights Reserved. The distribution and sale of these products are intended for the use of the original purchaser only. Lawful users 
of these programs are hereby licensed only to read the programs, from their media into memory of a computer, solely for the 
purpose of executing the programs on one machine at a time. Duplicating or copying for other than backup purposes, or selling or 
otherwise distributing these products is a violation of the law and this agreement.

DISCLAIMER 
THIS SOFTWARE AND DOCUMENTATION IS PROVIDED "AS IS" WITHOUT REPRESENTATION OR WARRANTY OF ANY 
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY REPRESENTATIONS OR ENDORSEMENTS
REGARDING THE USE OF, THE RESULTS OF, OR PERFORMANCE OF THE INFORMATION, ITS APPROPRIATENESS, 
ACCURACY, RELIABILITY, OR CURRENTNESS.
THE ENTIRE RISK AS TO THE USE OF THIS PROGRAM IS ASSUMED BY THE USER. IN NO EVENT WILL KEITH Y. HIGAKI, 
H&H ENTERPRISES, OR IT'S EMPLOYEES BE LIABLE FOR ANY DAMAGES, DIRECT, INDIRECT, INCIDENTAL OR 
CONSEQUENTIAL, RESULTING FROM ANY DEFECT IN THE INFORMATION, EVEN IF KEITH Y. HIGAKI OR H&H 
ENTERPRISES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
THIS DISCLAIMER SHALL SUPERSEDE ANY VERBAL OR WRITTEN STATEMENT TO THE CONTRARY. IF YOU DO NOT 
ACCEPT THESE TERMS YOU MUST CEASE AND DESIST USING THIS PRODUCT.

LICENSE AGREEMENT 
Your use of this package indicates your acceptance of the following terms and conditions:
1. Copyright: These programs and the related documentation are copyright. The sole owner is Keith Y. Higaki and H&H 
Enterprises. You may not use, copy, modify, or transfer the programs, documentation, or any copy except as expressly provided in
this agreement.
2. License: You have the non-exclusive right to use any enclosed program only on a single computer at a time. You may load the 
program into your computers temporary memory (RAM). You may physically transfer the program from one computer to another, 
provided that the program is used on only one computer at a time. You may not distribute copies of the registered package, the 
accompanying documentation, or your registration number to others. You may not de-compile, disassemble, reverse engineer, 
modify, or translate the program or the documentation. You may not attempt to unlock or bypass any copy protection utilized with 
the program. All other rights and uses not specifically granted in this license are reserved by H&H Enterprises and/or its owner 
Keith Y. Higaki.
3. Back-up and Transfer: You may make one (1) copy of the registered program solely for back-up purposes. You must 
reproduce and include the copyright notice on the back-up copy. You may transfer the registered product to another party only if 
the other party agrees to the terms and conditions of this agreement and completes and returns a registration form to H&H 
Enterprises. If you transfer the program you must at the same time transfer the documentation and back-up copy or transfer the 
documentation and destroy the back-up copy.
4. Terms: This license is effective until terminated. You may terminate it by destroying the program, the documentation and copies
thereof. This license will also terminate if you fail to comply with any terms or conditions of this agreement. You agree upon such 
termination to destroy all copies of the program and of the documentation.

H&H Enterprises
45-1133 Makamae Street
Kaneohe, Hawaii 96744-3122
U.S.A.

CompuServe: 75021,3701
Internet: khigaki@aloha.net
WWW: http://hookomo.aloha.net/~khigaki/

Windows, Windows 95, and Windows NT are trademarks of Microsoft Corporation.



What Is Shareware
Shareware is a distribution method, not a type of software. You should find software that suits your 
needs and pocketbook, whether it's commercial or Shareware. The Shareware system makes fitting 
your needs easier, because you can try before you buy. And because the overhead is low, prices are 
also low. Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't 
pay for it.

Shareware distribution gives users a chance to try software before buying it. If you try a Shareware 
program and continue using it, you are expected to register. Individual programs differ on details -- some
request registration while others require it, some specify a maximum trial period. With registration, you 
get anything from the simple right to continue using the software to an updated program with printed 
manual.

Copyright Laws apply to both Shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below. Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality. (In both cases, 
there are good programs and bad ones!) The main difference is in the method of distribution. The author
specifically grants the right to copy and distribute the software, either to all and sundry or to a specific 
group.

See Also: Registration Information
Registration Form
Legal Information



Registering MicroChart/32
MicroChart/32 is Shareware and may be freely distributed. You may use and evaluate MicroChart/32 
for a 15 day free trial period. The software will, however, continue to function after 15 days. If you decide
to register your copy of MicroChart/32, you will get:

1. A serial number that will provide full printing features and disable the registration reminders. This 
registration number will be valid for all future minor updates of MicroChart/32.

2. Free upgrades. Simply download the new shareware version from CompuServe or selected 
Internet depositories and use your registration number to convert it to a registered version. Your 
name and organization will appear in the about box after you enter your registration number.

3. Notification by e-mail (if provided) when future versions of MicroChart/32 become available.
4. Free support for MicroChart/32 directly from the author via e-mail.

PAYMENT:
1. If you have a CompuServe account, you can use the convenient on-line software registration 

service. This service will charge your account the $99 fee for a single-user license and will 
automatically send an e-mail message notifying me that you have registered. To use this service 
type GO SWREG, select Register Shareware, and use ID #10067 to register MicroChart/32. I will 
respond by e-mail with your MicroChart/32 serial number. There is no additional charge for using 
the SWREG service.

2. If you would prefer to register by surface mail, please print the Single License Order Form and 
send the completed form with the $99 single-user license fee to:

H&H Enterprises
45-1133 Makamae Street
Kaneohe, Hawaii 96744-3122
U.S.A.

If you include your e-mail address with your payment, I will send you your MicroChart/32 serial number 
by e-mail. Otherwise, I will send it by surface mail.

Note that you will not receive a diskette or a manual in the mail when you register, since you already 
have the complete MicroChart/32 program, including the available documentation (this help file). This 
allows me to not charge anything for upgrades, since you can download them at your convenience.

This registration number will be valid for all future minor updates of MicroChart/32. To upgrade, simply 
download the new shareware version and use the registration number to convert it to a registered 
version.

Thank you for using MicroChart/32!

See Also: Registration Form



Registration Form
MicroChart/32 version 7.01
To print this form, click on the Print button above, or press <Alt> + <P>. If you are unable to print this form, then you can send the 
information requested below, with payment, to the address given.

NAME:              __________________________________________________
ORGANIZATION:      __________________________________________________
ADDRESS:           __________________________________________________
CITY, STATE:       __________________________________________________
POSTAL/ZIP CODE:   __________________________________________________
COUNTRY:           __________________________________________________

TELEPHONE (Voice): _____________________  (FAX): ____________________
E-MAIL:            __________________________________________________
COMMENTS:          __________________________________________________
                   __________________________________________________

WHERE DID YOU OBTAIN YOUR COPY OF MICROCHART/32?
     CD-ROM: _______________________  CIS Forum: ____________________
     Internet: _____________________  BBS: __________________________
     Other: _________________________________________________________

                   QUANTITY: __________  X $99.00         ___________
                   TOTAL ENCLOSED (US Dollars):           ___________

Payments must be in US dollars drawn on a US bank, or you can send international postal money 
orders in US dollars.

Make checks payable to: H&H Enterprises
Mail to: H&H Enterprises

45-1133 Makamae Street
Kaneohe, Hawaii 96744-3122
U.S.A.

Thank you for purchasing MicroChart/32!



System Requirements

MINIMUM

CPU: 80386

Memory: 4 MB

Video: VGA 640x480

Windows: Windows 95 or Windows NT 3.51

Disk: Approximately 700 KB

PREFERRED

CPU: 80486 or Pentium

Memory: 8 MB or more (depending on Windows version)

Video: SVGA 1024x768

Windows: Windows 95 or Windows NT 3.51

Disk: Approximately 700 KB



Charting Tools

MicroChart/32 includes a powerful array of tools to meet your most demanding charting requirements. To 
set the active charting tool, open the Tools menu and click on your selection or click on the desired tool 
button on the Tool toolbar.

The active tool will have a check mark next to it in the Tools menu and is always displayed in the Tool Box
on the Status Bar. Each tool requires from one to three input points to define the object being drawn, and 
uses from one to seven control points with which the overall shape and position of the object can be 
adjusted.

See Also: Adding Objects
Edit Tools



Edit Tools

The edit tools allow you to make all necessary adjustments to your chart before printing. Much like words 
and paragraphs of a word processor, the positions and objects of MicroChart/32 can be cut, moved, 
copied, centered, etc. with control over various aspects of its appearance. To choose an edit tool, open 
the Edit menu and click on your selection.

Each edit tool (except Redefine and Copy) presents one or more dialog box requesting some information 
specific to the edit function. It is usually followed by another request for input either by pointing to an 
object or by enclosing positions in an area within which the tool is to modify. An edit tool cannot be 
selected if there are no positions on the active chart.

See Also: Charting Tools



Screen Layout

The MicroChart/32 screen is a simple and clean workspace that allows for maximum viewing and editing 
of chart objects. In addition to the standard title bar and menu bar common to most Windows applications,
most information is displayed on the status bar at the bottom of the screen. The status bar is divided into 
smaller boxes that display information in the following order from left to right:

Status Bar Displays various information including object length, ruler length, object 
information, input instructions, and menu item descriptions.

Distance Box Displays the distance in steps (22.5 inches) of the current line or curve. Also used
by the Tape Measure Tool to find the length in steps between two points.

Tool Box Displays the current charting tool. Clicking on this box will cycle either forward 
(left mouse button) or backwards (right mouse button) through the available tools.

Symbol Box Displays the current screen symbol and color. Clicking on this box will cycle 
either forward (left mouse button) or backwards (right mouse button) through the 
available symbols.

Mirror Box Displays the current mirror mode. Clicking on this box will cycle either forward 
(left mouse button) or backwards (right mouse button) through the available 
modes (off, horizontal, vertical, and center).

Count Box Displays the total position count for the current chart.

Horizontal Step Displays the step distance of the current cursor position relative to the 50 
yardline.



Vertical Step Displays the step distance of the current cursor position relative to the grid origin.



Screen Resolution

One of MicroChart/32's many strengths is the accurate control and placement of objects on the charting 
grid. This is mainly due to the careful use of the current screen resolution to the best advantage. By 
using a proportionate amount of screen pixels to represent grid measurements, MicroChart/32 allows 
the placement of objects to the fraction of a step. This accuracy, though, can be further enhanced by 
using the greatest screen resolution possible on the system.

Although standard VGA resolution (640 x 480) is adequate for most charting applications, it is highly 
recommended that the Super VGA resolution (800 x 600 or higher) be used.



Batch Print
To start the batch print feature, do one of the following:

From the File menu, choose Batch Print (Alt+F, B)
Type Ctrl+B

If you have made any changes to the current chart since you last saved, MicroChart/32 asks whether or 
not you want to save these changes. All existing positions are cleared and the chart will be unnamed.

The Open Batch Print File dialog box will prompt for the batch file name and location. Select the disk 
drive and directory of the batch file. Type the name of the batch file in the File Name box. Press the 
Open button or simply scroll through the files and double click on the batch file.

The Print dialog box will then prompt for print configuration selections. Press the Print button to begin or 
the Cancel button to abandon batch printing. During batch printing, another dialog box indicating the file,
print device, and port will be displayed. You may cancel printing the current chart by pressing the Abort 
button.

See Also: Creating Batch Print Files
Printing
Print Options
Printer Fonts



Creating Batch Print Files
To create a batch print file, do one of the following:

Select the 

 icon on the Edit toolbar
From the File menu, choose Batch File Builder… (Alt+F, T)
Select from the main menu: File / Batch File Builder…

A batch print file includes the names and (optionally) chart titles to be printed as a batch print job. Using 
the Batch Builder dialog, select the directory where your charts are saved in with the listbox on the left 
half of the dialog. Select charts individually by double clicking on the filenames or by highlighting the 
filename and pressing the Add button. Press the Add All button to select all chart files in the current 
directory.

To print a title other than the one saved with the chart, select the file in the listbox on the right half of the 
dialog and press the Alt. Title… button, or you can simply click the file with the right mouse button and 
type the alternate title.

Creating Batch Files Manually
Batch print files can be created manually by any pure ASCII text editor such as Windows Notepad. The 
format of the file is flexible but must adhere to the following specifications:

1. Each line in the file must contain a valid chart file path and name with extension. MicroChart/32 
does not check for illegal file name or path specifications. The case of the file names do not matter 
(a:\big opener.mcc = A:\BIG Opener.MCC).



2. MicroChart/32 uses the default title stored in the Summary Information with the chart. If a title is 
included in the batch file, it will override the default title. The title must be preceded by a TAB (ASCII
9) to separate it from the file name. Note that in some editors spaces (ASCII 32) are inserted to 
represent tabs. This is NOT acceptable and will result in truncated or absent titles. The case of the 
characters in the chart title is important. Titles will be printed exactly as it appears in the batch file.

3. The batch file must be saved with the extension .MCB and can be located anywhere on any disk as 
long as the file names in the batch file include the full path to their location. The Batch Print File 
Open dialog box will search and list files with only his extension.

4. If an error should occur during printing, edit your batch file to include only those files that you want 
printed or reprinted.

5. Comments are allowed in the batch file as long as the first character of each comment line is a 
semicolon. Blank lines can be inserted to separate groups of files.

6. The following is a sample MicroChart/32 batch print file:

; SAMPLE MICROCHART/32 BATCH FILE

; Opener charts with alternate titles:
C:\MyCharts\Opener_1.MCC Opening Move
C:\MyCharts\Opener_2.MCC Multigait Drill
C:\MyCharts\Opener_3.MCC Bursting Arcs
C:\MyCharts\Opener_4.MCC Final Set

; The default titles will be printed for these charts:
D:\MyCharts\DrumlineFeature_1.MCC
D:\MyCharts\DrumlineFeature_2.MCC
D:\MyCharts\DrumlineFeature_3.MCC
D:\MyCharts\DrumlineFeature_4.MCC

See Also: Batch Print
Printing
Print Options



Alter Objects
To start the Alter feature do one of the following:

From the Edit menu, choose Alter (Alt+E, A)
Press Ctrl+A

The Select Method dialog box will prompt you to identify the method of selection you desire. Your choices 
include object, area, or all positions. If the object or area methods are selected, the cursor will change to a
hollow crosshair and you will be prompted to either click on an object, or to surround an area by dragging 
a rectangle around the positions you want altered.

The Alter Symbol dialog box will then appear and prompt for symbol color, screen symbol, and print 



symbol. The Enable checkboxes next to each listbox allows you to selectively enable or disable the 
various attributes of the selected positions. For example, by enabling only the Screen Symbol listbox, one
could change the screen symbol used of all the selected positions, but not the print symbol or the symbol 
color.

See Also: Setting the Current Symbol Shape and Color
Display Object Information



Adding Objects
The input method is consistent throughout all charting tools and involves three stages: entering control 
points, adjusting the final position of the object, and defining the object's positions. These stages are 
described below:

STAGE I All necessary control points are created for defining the object. These controls define the 
key points of the object such as endpoints, corners, and centers. To enter control points, 
move the cursor with the mouse or the keyboard arrow keys to the desired location. Then
click on the left mouse button or press the ENTER key.

STAGE II Control points are adjusted to size and shape the object before actual positions are 
plotted. As adjustments are made, dotted lines serve as visual feedback to display the 
size and shape of the object to be plotted.

The controls perform different functions or react differently to adjustments depending on 
their appearance. The large solid square control drags the entire object to a new location.
The large hollow square control in the Parallelogram tool indicates the second input point 
and the term row for this object defines the length between the 1st and the 2nd input 
points. The small solid square controls modify the object locally.

This stage is completed by clicking the RIGHT mouse button or by holding down the 
SHIFT key while pressing the ENTER key. The tool can also be aborted at this point by 
pressing the Ctrl key while clicking the RIGHT mouse button, or simply by pressing the 
ESC key.

STAGE III The Chart Object Definition dialog box is filled in to define specific information for the 
object including the number of positions, screen symbol, print symbol, and color. After all 
information is entered the object is plotted on the grid using the selected screen symbol 
and color. If the object is not exactly what was intended you may select Redefine Object 
under the Edit menu to re-edit the control points and change object data.

Chart Object Definition dialog box.



See Also: Input Table
Charting Tools
Edit Tools



Input Table

Object
Input

Points
Control
Points Input Order

Point 1 1 Point

Line 2 2 Endpoint 1, Endpoint 2

Block 2 2 Corner, Opposite Corner

Hollow Block 2 2 Corner, Opposite Corner

Parallelogram 3 3 Corner 1, Corner 2, Corner 3

Hollow Parallelogram 3 3 Corner 1, Corner 2, Corner 3

Arc 3 3 Endpoint 1, Endpoint 2, Arc Intersect Point

Circle by Radius 2 2 Center Point, Circle Intersect Point

Circle by Step 2 2 Center Point, Vector Point for 1st Position

Bezier Curve - Simple 2 4 Endpoint 1, Endpoint 2

Bezier Curve - Complex 2 7 Endpoint 1, Endpoint 2



Mirror Modes

Designing symmetrical drills with MicroChart is easily accomplished using one of the three mirroring 
modes: horizontal, vertical and center. These modes take effect when objects are plotted on the grid. As 
each position is plotted, another position is plotted with respect to the current mirror mode. The following
describes the available mirror modes:

OFF Mirroring is not active.

HOR Mirror the left and right sides of the field with respect to the 50 yardline.

VER Mirror the top and bottom halves of the field with respect to the imaginary line that divides
the grid vertically in half.

CTR Mirror to the point at the center of the grid.

The active mirror mode can be changed by cycling through and selecting the mode of your choice using 
one of the following actions:

Press on the desired mirror button on the Edit toolbar.
Click on the Mirror BoxScreenLayout on the Status Bar with the left mouse button to cycle 

forward or the right mouse button to cycle backward through the mirror modes.
Press “M” to cycle forward through the mirror modes.



Printing
To open the Print dialog box, do one of the following:

Press the 

 button on the Edit toolbar
From the File menu, choose Print (Alt+F, P)
Press Ctrl+P

The standard Windows Print dialog box will be presented. Make any necessary adjustments, such as 
paper orientation and number of copies, and press the OK button.

During printing, another dialog box indicating the file, print device, and port will be displayed. You may 
cancel the print job by pressing the Abort button.

See Also: Print Options
Batch Print
Creating Batch Print Files



Print Options
To open the Print Options dialog box, do one of the following:

From the File menu, choose Print Options (Alt+F, O)

The selections in the Print Options dialog box are described below:

Printer Lists the installed printer devices of your current Windows setup. Select the 
device you want to print your charts on.

Printer Setup Configure your printer options including page size, source, orientation, and print 
resolution. The printer setup varies with individual printer drivers. For best results 
select landscape orientation with the highest resolution possible for your printer.

Grid Size Select the preferred step size of the dotted grid. Select None if a grid is not 
desired.

Range Select the outer range of the printed chart. For best results select the narrowest 
grid that is necessary to include all your chart positions.

Yardlines Print yardlines.

Yardline Numbers Print yardline numbers.

Hash Marks Print hash marks.

Nine-Yard Marks Print NCAA nine-yard markings.

Center X on 35 Print center X on both 35 yardlines.

Center X on 40 Print center X on both 40 yardlines.

Fine Grid Dots Use a fine dot size to print the grid. For best results, experiment which each 
mode to determine the best output for your printer.

Bold Symbols Print bold symbols. For best results, experiment which each mode to determine 
the best output for your printer.



Print Colors Print using colors. For best results, this option should be OFF for monochrome 
printers which would otherwise attempt to print colors as shades of gray. In this 
situation white and light colored symbols would not be clearly visible.

Enter the following information to be printed on the chart:

Page Title A title containing any alpha-numeric and punctuation characters. MicroChart/32 
inserts the default title as entered in the Summary Information which may be 
overridden by typing another title.

Copies The number of copies to print.

Press the Print button to print the chart or the Cancel button to abandon the print job. Press the Save 
Options button to save your print configuration to be loaded as the default the next time you start 
MicroChart/32.

During printing, another dialog box indicating the file, print device, and port will be displayed. You may 
cancel printing the current chart by pressing the Abort button.

See Also: Printing
Batch Print



Printer Fonts
To select or change the current font:

1. Open the File menu and select Printer Fonts (Alt+F, F).

2. Scroll through and highlight your selections in the Font and Font Style boxes.

3. Confirm your selection by checking the Sample box.

4. To accept your selection or change click the OK button.

5. To abandon your selection or change click the Cancel button.

MicroChart/32 can use any printer font installed for your Windows configuration. The selected font will be 
used to print the chart title, yardline numbers, file name, and copyright notice. The default font that is used
is the standard Windows Arial font. Depending on your preference though, you may select an alternate 
font and style that best serves your charting needs.

See Also: Printing
Print Options
Batch Print



Redefine Object
The Redefine Object feature is a time saving tool for making minor adjustments on objects such as a 
change in the number of positions, or maybe tweaking the curvature of an arc or bezier.

Redefine Object allows only the most recently drawn object to be retraced back into Input Stage II to 
allow the readjustment of control points and handles. All positions in the object are deleted and the 
control points are redrawn in their last position before the Chart Object dialog box was called. Once 
again, this stage is completed by clicking the Right mouse button or by holding down the Shift key while 
pressing the Enter key. The previous information such as object positions, rows, columns, etc. will be 
pre-entered wherever appropriate. Change or leave whatever information as necessary then press the 
OK button. The object will be redrawn reflecting your changes.

NOTE: If the tool is aborted (by pressing the Ctrl key while clicking the Right mouse button, or by 
pressing the Esc key), or if the Chart Object dialog box is aborted (by pressing the Cancel button), all 
information for the last object is discarded, disabling any further redefinition.

See Also: Adding Objects
Input Table



Copy Object
The Copy tool makes duplication of objects quick, easy and flexible. To start the Copy feature do one of 
the following:

Press the 

 on the Edit toolbar
From the Edit menu, choose Copy (Alt+E, C)
Press Ctrl+C

The cursor will change to an hollow crosshair and you will be prompted to click on a position in the 
object you want copied. The position you choose is very important because it will be that same relative 
position in the copy that will be plotted at the next point you select, the destination point. The cursor will 
change to a crosshair and you will then be prompted to click on a destination point, on which the same 
relative position will be plotted, and all the other points in the copy will be plotted relative to that point.

See Also: Delete Object
Mirror Modes



Join Object
There are times when combining positions into a single object would make editing simpler and more 
efficient. The joined positions can then be treated as a single object when moving, copying, rotating, 
scaling, etc. To start the Join feature do one of the following:

Press the 

 button on the Edit toolbar
From the Edit menu, choose Join (Alt+E, N)
Press Ctrl+N

The Select Method dialog box will prompt you to identify the method of joining you desire. Your 
selections include joining by object, area, or all positions.

If the object or area methods are selected, the cursor will change to an hollow crosshair and you will be 
prompted to either click on any position in two objects, or to surround an area by dragging a rectangle 
around the positions you want joined. The selected positions will flash to indicate their joining.

See Also: Display Object Information



Delete Object
To start the Delete feature do one of the following:

Press the 

 button on the Edit toolbar
From the Edit menu, choose Delete (Alt+E, D)
Press Ctrl+D

The Select Method dialog box will prompt you to identify the method of selection you desire. Your 
choices include deleting an object, area, the last object drawn, or all positions. If last object drawn is 
selected MicroChart/32 automatically deletes the object and no other input is required.

If the object or area methods are selected, the cursor will change to an hollow crosshair and you will be 
prompted to either click on an object, or to surround an area by dragging a rectangle around the 
positions you want deleted.

See Also: Redefine Object



Move Object
To start the Move feature do one of the following:

Press the 

 button on the Edit toolbar
From the Edit menu, choose Move (Alt+E, M)
Press Ctrl+F

The Select Method dialog box will prompt you to identify the method of selection you desire. Your choices 
include moving an object, area, or all positions. Enter the horizontal and vertical steps to move in the 
Move group of the dialog box..

If the object or area methods are selected, the cursor will change to an hollow crosshair and you will be 
prompted to either click on an object, or to surround an area by dragging a rectangle around the positions 
you want moved. If the Leave Original checkbox is enabled and checked, the original positions selected 
to move will remain and a copy of those positions will be plotted in the new location.

See Also: Rotate Object
Center Object
Scale Object



Center Object
To start the Center feature do one of the following:

Press the 

 button on the Edit toolbar
From the Edit menu, choose Center (Alt+E, T)
Press Ctrl+T

The Select Method dialog box will prompt you to identify the method of selection you desire. Your choices 
include centering an object, area, or all positions.

If the object or area methods are selected, the cursor will change to an hollow crosshair and you will be 
prompted to either click on an object, or to surround an area by dragging a rectangle around the positions 
you want centered. If the Leave Original checkbox is enabled and checked, the original positions selected
to center will remain and a copy of those positions will be plotted in the new location.

See Also: Move Object
Rotate Object
Scale Object



Rotate Object
To start the Rotate feature do one of the following:

Press the 

 button on the Edit toolbar
From the Edit menu, choose Rotate (Alt+E, R)
Press Ctrl+R

The Rotate dialog box will prompt you for a degree of rotation and a pivot point selection. To rotate 
positions in a clockwise direction, enter a positive number in the Degrees box. To rotate positions in a 
counterclockwise direction, enter a negative number.

The Select Method dialog box will then prompt you to identify the method of selection you desire. Your 
choices include rotating an object, area, or all positions.

If the object or area methods are selected, the cursor will change to an hollow crosshair and you will be 
prompted to either click on an object, or to surround an area by dragging a rectangle around the positions 
you want to rotate. If the Leave Original checkbox is enabled and checked, the original positions selected 
to rotate will remain and a copy of those positions will be plotted in the new location.

See Also: Move Object
Center Object
Scale Object



Scale Object
To start the Scale feature do one of the following:

Press the 

 button on the Edit toolbar
From the Edit menu, choose Scale (Alt+E, L)
Press Ctrl+L

The Select Method dialog box will then prompt you to identify the method of selection you desire. Your 
choices include scaling an object, area, or all positions. Enter the horizontal and vertical scaling 
percentages in the Scaling group of the dialog box.

If the object or area methods are selected, the cursor will change to an hollow crosshair and you will be 
prompted to either click on an object, or to surround an area by dragging a rectangle around the positions 
you want scaled. If the Leave Original checkbox is enabled and checked, the original positions selected to
scale will remain and a copy of those positions will be plotted in the new location.

See Also: Move Object
Center Object
Rotate Object



Tape Measure Tool

Use the Tape Measure Tool to measure the distance between two points in step units (22.5 inches). To 
select the Tape Measure Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Tape Measure Tool.
From the Tools menu, choose Tape Measure (Alt+T, T).
Press F3.

Input Points

1. Endpoint #1.

2. Endpoint #2.



Point Tool
Use the Point Tool to plot a single point on the chart. To select the Point Tool do one of the following:

Press the 

 button on the Tool toolbar
From the Tools menu, choose Point (Alt+T, P).
Click on the Tool Box on the Status Bar and select the Point Tool.
Press F4.

Input Point

1. Point.

See Also: Adding Objects



Line Tool

The Line Tool plots a straight line between two endpoints, evenly spacing the desired positions between 
them. To select the Line Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Line Tool.
From the Tools menu, choose Line (Alt+T, L).
Press F5.

Input Points

1. Endpoint #1.

2. Endpoint #2.

See Also: Adding Objects



Block Tool

The Block Tool plots a rectangular block as defined by two opposite corner points, evenly spacing the 
positions within the rows and columns of the block. To select the Block Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Block Tool.
From the Tools menu, choose Block (Alt+T, B).
Press F6.

Input Points

1. Corner point.

2. Opposite corner point.

See Also: Hollow Block Tool
Adding Objects



Hollow Block Tool
The Hollow Block Tool plots a rectangular block outline as defined by two opposite corner points, evenly 
spacing the positions between the outer rows and columns of the block. To select the Hollow Block Tool 
do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the H-Block Tool.
From the Tools menu, choose Hollow Block (Alt+T, O).
Press SHIFT+F6.

Input Points

1. Corner point.

2. Opposite corner point.

See Also: Block Tool
Adding Objects



Parallelogram Tool

The Parallelogram Tool plots a parallelogram as defined by three adjacent corner points, evenly spacing 
the positions within the rows and columns of the Parallelogram. To select the Parallelogram Tool do one 
of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Parallelogram Tool.
From the Tools menu, choose Parallelogram (Alt+T, H).
Press ALT+F6.

Input Points

1. Corner point #1.

2. Adjacent corner point #2. The distance between the 1st and the 2nd corner points will be 
considered the row regardless of orientation.

3. Adjacent corner point #3. The distance between the 2nd and the 3rd corner points will be 
considered the column regardless of orientation.

See Also: Hollow Parallelogram Tool
Adding Objects



Hollow Parallelogram Tool
The Hollow Parallelogram Tool plots a parallelogram as defined by three adjacent corner points, evenly 
spacing the positions within the outer rows and columns of the Parallelogram. To select the Hollow 
Parallelogram Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the H-Parallelogram Tool.
From the Tools menu, choose Hollow Parallelogram (Alt+T, W).
Press ALT+SHIFT+F6.

Input Points

1. Corner point #1.

2. Adjacent corner point #2. The distance between the 1st and the 2nd corner points will be 
considered the row regardless of orientation.

3. Adjacent corner point #3. The distance between the 2nd and the 3rd corner points will be 
considered the column regardless of orientation.

See Also: Parallelogram Tool
Adding Objects



Arc Tool

The Arc Tool plots a circular arc as defined by two end points and a third intersection point, evenly 
spacing the positions within the arc. To select the Arc Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Arc Tool.
From the Tools menu, choose Arc (Alt+T, A).
Press F7.

Input Points

1. Endpoint #1.

2. Endpoint #2.

3. A point of intersection to define the depth or curvature of the arc. A position may not necessarily 
be plotted at this point, depending on the number of positions, position spacing, and the size of 
the arc.

See Also: Simple Bezier Tool
Complex Bezier Tool
Adding Objects



Circle by Radius Tool

The Circle by Radius Tool plots a circle as defined by a center point and a point on the circle (radius) 
indicating the starting position, evenly spacing the positions on the circle. To select the Circle by Radius 
Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Circle-R Tool.
From the Tools menu, choose Circle by Radius (Alt+T, R).
Press F8.

Input Points

1. Center of circle.

2. A point on the circle where the first position will be plotted.

See Also: Circle by Step Tool
Adding Objects



Circle by Step Tool
The Circle by Step Tool plots a circle as defined by a center point and a point on a vector angle to 
indicate the starting position, evenly spacing the positions on the circle. To select the Circle by Step Tool
do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Circle-S Tool.
From the Tools menu, choose Circle by Step (Alt+T, S).
Press ALT+F8.

Input Points

1. Center point of circle.

2. A point defining an angle with the center on which the first position will be plotted.

See Also: Circle by Radius Tool
Adding Objects



Simple Bezier Curve Tool

The Simple Bezier Curve Tool plots a freeform curve as defined by two endpoints and two handle points, 
evenly spacing the positions on the curve. Use the handle points to adjust the curvature or bend of this 
tool. To select the Simple Bezier Curve Tool do one of the following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Bezier-S Tool.
From the Tools menu, choose Bezier-Simple (Alt+T, Z).
Press F9.

Input Points

1. Endpoint #1.

2. Endpoint #2. Two handle points will be automatically be drawn by MicroChart/32.

See Also: Complex Bezier Curve Tool
Adding Objects



Complex Bezier Curve Tool

The Complex Bezier Curve Tool plots a freeform curve as defined by two endpoints, a central control 
point, and four handle points, evenly spacing the positions on the curve. Use the control and handle 
points to adjust the curvature or bend of this tool. To select the Complex Bezier Curve Tool do one of the 
following:

Press the 

 button on the Tool toolbar
Click on the Tool Box on the Status Bar and select the Bezier-C Tool.
From the Tools menu, choose Bezier-Complex (Alt+T, X).
Press ALT+F9.

Input Points

1. Endpoint #1.

2. Endpoint #2. A third control point and four handle points will be automatically be drawn by 
MicroChart/32.

See Also: Simple Bezier Curve Tool
Adding Objects



Cursor Movement
Cursor movement can be accomplished by either the mouse or keyboard by pressing the arrow keys. By
holding down the Ctrl key and pressing the arrow keys the cursor will move in approximately two step 
intervals. Other movement keys include the HOME key which moves the cursor to the center of the grid,
PgUp and PgDn key which moves the cursor approximately two steps up or down respectively, and Ctrl-
Home and Ctrl-End which moves the cursor to the top or bottom of the grid respectively.

As the cursor is moved, the distance from the grid origin is displayed in the horizontal and vertical 
position boxes at the bottom right of the screen. These measurement represents step units on the 
selected grid style and can be used to accurately position objects on the grid. 

See Also: Keyboard Commands



Keyboard Commands
CURSOR MOVEMENT

Ctrl-Down Down Two Steps
Ctrl-Right Right Two Steps
Ctrl-Left Left Steps
Ctrl-Up Up Two Steps
Down Down One Screen Pixel
End Grid Center
Home Grid Center
Left Left One Screen Pixel
PgDn Down Two Steps
PgUp Up Two Steps
Right Right One Screen Pixel
Up Up One Screen Pixel

WORK ENVIRONMENT
+ Screen Symbol - Cycle Forward
- Screen Symbol - Cycle Backward
M Mirror - Cycle Forward
S Screen Symbol - Cycle Forward
Shift-S Symbol Color - Cycle Forward
T Tool - Cycle Forward
Shift-T Tool - Cycle Backward
F1 Help Contents
F3 Tape Measure
F4 Point Tool
Alt-F4 Exit
F5 Line Tool
F6 Block Tool
Shift-F6 Hollow Block
Alt-F6 Parallelogram Tool
Alt-Shift-F6 Hollow Parallelogram Tool
F7 Arc Tool
F8 Circle - Radius Tool
Alt-F8 Circle - Step Tool
F9 Bezier Simple Tool
Alt-F9 Bezier Complex Tool

COMMANDS
Ctrl-A Alter Dialog Box
Ctrl-B Batch Print Dialog Box
Ctrl-C Copy Object or Area
Ctrl-D Delete Object, Area, or All
Ctrl-F Move Object, Area, or All
Ctrl-G Merge
Ctrl-I Summary Information
Ctrl-L Scale Object, Area, or All
Ctrl-N Join Object, Area or All
Ctrl-O Open Dialog Box
Ctrl-P Print Dialog Box
Ctrl-R Rotate Object, Area or All
Ctrl-S Save Object, Area or All
Ctrl-T Center Object, Area or All
Ctrl-V Perspective View





Display Object Information
Information about a specific point or object can be displayed in a dialog by pointing the cursor over any 
position in the chart and clicking the right mouse button. The information that is displayed is described in
the following example:

Chart Object: 3 of 8
The selected position is the 3rd third object of eight total objects in the current chart.

Object Positions: 32
The selected position belongs to an object with 32 positions.

Print Symbol: Circle-Small
The selected position will be printed using the Circle-Small symbol.

Symbol Color: Green
The selected position will be printed in the color Green (if Print Colors option is enabled).

NOTE: Because both the screen and print symbols of any position(s) within a single object can be 
modified by the Alter Symbol function, the print symbol displayed applies only to the specific position 
pointed to.

See Also: Setting the Current Symbol Shape and Color
Altering Object Symbols and Colors



Symbol Shape and Color
The current screen symbol shape and color is displayed in the Symbol Box on the Status Bar at the 
bottom the MicroChart/32 screen. The symbol shape can be changed by pressing the '+' or '-' key or by 
clicking with either the left or right mouse button to cycle either forward or backwards through the 
available symbols.

To change the current symbol color, hold down the Control key while clicking either the left or right 
mouse button to cycle either forward or backwards through the available colors.

If a new symbol shape and/or color is selected when completing the Chart Object dialog box during 
Input Stage III, the new selections become the current symbol shape and color.

See Also: Display Object Information
Altering Object Symbols and Colors



Perspective View

MicroChart/32 features a true perspective view to envision the presentation of your chart from your 
audiences' point of view. Selecting from one of three height levels, three distances, and two sides, you 
can design your drills to accommodate for specific stadium configurations. Perspective View will display 
each chart position as an upright standing figure to simulate the field performer.

To view the current chart in perspective view, do one of the following:
Clicking on the 

 button on the Edit toolbar.
Click the right mouse button on a blank part of the grid.
From the View menu, choose Perspective, View (Alt+V, P, V).
Press Ctrl+V.

See Also: Perspective Options



MicroChart Options

MicroChart/32 options can be selected by either:
Clicking on the 

 button on the toolbar.
Selecting View / Options... from the menu bar.

The Options pages include:

General These options allows for the customization of the MicroChart/32 visual 
workspace and charting style.

Field Grid Customization of the MicroChart/32 work grid and all appropriate markings 
including grid origin, number style, hash style, zoom factor, and yardline 
markings.

Perspective The Perspective View function displays a true perspective view of your chart. You
can select the height, side, and distance of your viewpoint in the Perspective 
Settings dialog box. As an added dimension to simulate realism, the Show Torso 
option draws a more human looking figure at each position. Colors for the legs 
and the torso portion can be assigned separately.

Colors Support for color to both the displayed and printed figures help visually separate 
and identify chart objects. Color selection is made when completing the Chart 
Object dialog box during input Stage III or when making changes with the Alter 
Symbol dialog box. The eight total colors include Black, Blue, Green, Cyan, Red, 
Magenta, Yellow, and White.



General Options

These options allows for the customization of the MicroChart/32 visual workspace and charting style. 
The following describes the function of each option:

Cursor Size
MicroChart/32 provides three crosshair cursor sizes. Select the preferred size by selecting the 
appropriate radio button. (Default: Medium)

Proximity Check
MicroChart/32 can check the proximity or closeness of the positions before they are plotted to avoid 
collisions in the design. To enable this feature check the Enable box under the Proximity Check option 
and select a minimum plotting distance of 1, 2, or 4 steps (in standard step units of 22.5 inches). A 
check will be made before each new position is plotted to see if it is equal to or farther than the minimum
charting distance. This will insure that no position will be plotted closer to another by that distance. 
(Default: Off)

Bezier Handles
In the Complex Bezier Tool a third central control point appears after entering the first two endpoints. 
This control point is accompanied by two additional handles that have slightly different responses 
depending on the Bezier Handles setting. In the Smooth setting, the two handles may be at different 
distances from the control point. In the Symmetrical setting, the two handles are always equidistant from
the control point. (Default: Smooth)



Arc Dots
Select the desired amount of dots to represent the arc in edit mode. The visual feedback provided by 
these dots provides for greater accuracy in the design of drills. During input, the arc is represented by 
these dots that adjust to the movements of its control points. The size and visibility of these dots will 
depend on the Large Dot selection as set in MicroChart/32 Options. (Default: 24)

NOTE: Depending on the speed of your computer, an increase in the amount and size of dots used to 
represent the arc may slow down the response of the tool.

Show Large Dots
Display large dots for better visibility. On high resolution monitors individual pixels can be extremely 
small and difficult to see. Enabling this option will represent the dot symbol approximately three times 
the normal dot width. (Default: On)

Show Rubber Lines
Display dotted lines to represent objects. During Input Stage I & II dotted outlines are normally used to 
display the object's size and shape as they are sized and shaped to their desired position. If this option 
is disabled only the control points will be visible while editing the object. (Default: On)

Show Step Position
Display cursor position in steps relative to the grid origin. These numbers represent the step distance of 
the crosshair cursor from the origin. This information can aid in the accurate placement of chart objects. 
(Default: On)

Show Object Length
Display length of current line or curve. During Input Stage II the status box will display the length of the 
line or curve currently being edited. This information can be used to calculate position count and 
spacing. Use the Tape Measure Tool position to find the length in steps between two points. (Default: 
On)

Large Toolbar Buttons
Display the toolbars using larger buttons for greater visibility. (Default: Off)

Use Control Key
Select this option to force the use of the Control key when entering objects with the mouse. This is 
provided for backwards compatibility for users of previous versions of MicroChart. (Default: Off)

Default Button
Revert all settings to default MicroChart/32 settings.



Field Grid Options

The Configuration dialog box allows for the customization of the MicroChart/32 visual workspace and 
charting style. The following describes the function of each option:

Origin
The grid origin affects the orientation of both the on-screen grid dots and the printed grid. The steps 
displayed in the step boxes on the Status Bar represent the distance from this origin. The grid origin is 
saved with the chart information and is automatically set when loading a chart file.

Top Step coordinate system based on the top of the 50 yardline on the far sideline. 
(default)

Bottom Step coordinate system based on the bottom of the 50 on the near sideline.

Number Style
Select the desired setting to display the yardline numbers every 5 or 10 yards.

Every 5 Display yardline numbers every 5 yards.

Every 10 Display yardline numbers every 10 yards. (default)

Zoom Factor
Select the appropriate amount of magnification for most of your charting needs. This will be the default 
magnification for all new charts. Zoom magnification for the current chart can be changed on the fly by 



pressing the appropriate zoom button on the edit toolbar.

Hash Style
The numbers in parenthesis at the end of each hash style represent the distance in steps for that style 
from sideline to hash, hash to hash, and hash to sideline. The hash style is saved with the other chart 
information and is automatically set when loading a chart file.

High School Hash mark placed to divide the field width evenly in three, spaced 53 
feet, 4 inches from each sideline and from each other. (28, 28, 28)

NCAA True Steps Hash mark placed at 60 feet from the sideline with 40 feet between each 
hash mark. (32, 21.33, 32)

NCAA Proportional Hash mark placed at 60 feet from the sideline with 40 feet between each 
hash mark. (31.5, 21, 31.5)

NCAA: Adjusted Hash mark placed at 60 feet from the sideline with 40 feet between each 
hash mark. (32, 20, 32)

NFL: Proportional Hash mark placed at 70¾ feet (849 inches) from the sideline with 18½ 
feet (222 inches) between each hash mark. (37.144, 9.712, 37.144)

NFL: Adjusted Hash mark placed at 70¾ feet (849 inches) from the sideline with 18½ 
feet (222 inches) between each hash mark. (37, 10, 37)

35 yardline X's
Display X marks centered on both 35 yardlines. (Default: Off)

40 yardline X's
Display X marks centered on both 40 yardlines. (Default: Off)

Yardline dots
Display dot marks on yardlines for . (Default: On)

Show grid dots
Display a 4-step dotted grid on the charting as a background to aid in the accurate placement of objects.
To set the printed grid size see Printing a Chart. (Default: On)

Nine yard marks
Display the NCAA nine-yard markings on each yardline. (Default: Off)



Perspective Options

Height
Select the most appropriate distance setting to approximate the site of performance. Generally, the 
Medium setting should accommodate for most viewing distances.

Low Low viewing height

Medium Medium viewing height (default)

High High viewing height

Distance
Select the most appropriate distance setting to approximate the site of performance. Generally, the 
Normal setting should accommodate for most viewing distances.

Near Near viewing distance.

Normal Average viewing distance. (default)

Far Far viewing distance.

Side
Normally set to the Press Box side the designer may choose to observe the view from the visitors side 
of the field.

Press Box View from the press box side of the field. (default)



Visitors View from the visitors side of the field (opposite the press box).

Show Position Torso
Setting this option draws a thicker torso on each position in perspective view to give a more human 
looking figure. Furthermore, colors for the legs and the torso portion can be assigned independently. 
(Default: On)



Colors Options

Color Sliders
Depending on the Windows color configuration of your system you may need to adjust the default color 
settings used by MicroChart/32 by adjusting the color sliders to match the corresponding colors to their 
descriptions.

Synchronize color sliders
Select this option to synchronize the movement or all color sliders. To adjust the sliders independently 
de-select this option. (Default: On)

Base Color
Generally this setting will not need to be adjusted unless the color sliders above it cannot be adjusted to 
match the corresponding color.

Perspective
These settings allow the customization of the perspective view to closely represent your uniform and 
grid color.

Position Press this button to select the color used to display all positions.

Torso Press this button to select the color used to display the torso portion of all positions.

Grid Press this button to select the color used to display the field grid.





Future Enhancements

Your comments, questions and suggestions are always appreciated and in fact help mold the future 
design of MicroChart/32. Some of the enhancements suggested for possible future releases include:

Polygon shape tool
Zoom print areas
Animation feature

Please feel free to send your comments to me at:

CompuServe: 75021,3701
Internet: khigaki@aloha.net

Please visit the MicroChart/32 Web home page at:

http://hookomo.aloha.net/~khigaki/



European Registration Service

European registrations can be done easily in cooperation with KELLY Data - KDL Registrierungsservice. 
Simply contact them by fax or phone and they will handle your registration. You can also contact them 
directly to place an order.

KDL-Registrierungsservice - KELLY Data GmbH
Lena-Christ-Str.: 50
82152 Martinsried/Munich
Germany
phone: ++49-89-895626-50
fax:   ++49-89-895626-99

The KDL-Registrierungsservice will notify me (the author) of your order, and I will forward your 
registration number to you ASAP. Contact KELLY Data for orders only. Please direct all other questions 
to me.






