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File menu commands
The File menu offers the following commands:

New Create a new FoneBook or Schedule.
Open Opens an existing FoneBook or Schedule.
Close Closes an opened FoneBook or Schedule.
Save Saves an opened FoneBook or Schedule using the same file name.
Save As Saves an opened FoneBook or Schedule to a specified file name.
Print Preview Displays the document on the screen as it would appear printed.
Exit Exits FoneBook.



Edit menu commands
The Edit menu offers the following commands:

Undo Undo the last undoable command
Add Add a new record to the database
Delete Delete selected records from the database
Update Update an existing record within the database
Cut Deletes data from the database and moves it to the clipboard.
Copy Copies data from the database to the clipboard.
Paste Pastes data from the clipboard into the database.



View menu commands
The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Font Change the default font used for displaying data.
Fields Set the index order for fields and search for records.
Dial Dial a phone number or place a batch fax.



Window menu commands
The Window menu offers the following commands, which enable you to arrange multiple views of 
multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 2, ... Goes to specified window.



Help menu commands
The Help menu offers the following commands, which provide you assistance with this application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)
Use this command to create a new document in FoneBook.    Select the type of new file you want to 
create in the File New dialog box.
You can open an existing document with the Open command.
Shortcuts
Toolbar:

Keys: CTRL+N



File New dialog box
Specify the type of document you wish to create:
PB FoneBook - lists of contacts
PBS Schedule - Scheduled events



Open command (File menu)
Use this command to open an existing document in a new window.    You can open multiple documents 
at once.    Use the Window menu to switch among the multiple open documents.    See Window 1, 2, ... 
command.
You can create new documents with the New command.
The product keeps track of the last directory that you opened a file in, so when you navigate the 
directories, the working directory will change to the place that you last visit. FoneBooks are the 
databases used and have to have an extension of PB. The schedules have extensions of PBS. You can 
open both styles of files from this dialog, making the selection by clicking of “List files of type.”

Shortcuts
Toolbar:

Keys: CTRL+O



File Open dialog box
The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive in which FoneBook stores the file that you want to open. 

Directories
Select the directory in which FoneBook stores the file that you want to open.
Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)
Use this command to close all windows containing the active document.    FoneBook suggests that you 
save changes to your document before you close it.    If you close a document without saving, you lose 
all changes made since the last time you saved it.    Before closing an untitled document, FoneBook 
displays the Save As dialog box and suggests that you name and save the document.
You can also close a document by using the Close icon on the document’s window, as shown below:



Save command (File menu)
Use this command to save the active document to its current name and directory.    When you save a 
document for the first time, FoneBook displays the Save As dialog box so you can name your document.
If you want to change the name and directory of an existing document before you save it, choose the 
Save As command.

Shortcuts
Toolbar:

Keys: CTRL+S



Save As command (File menu)
Use this command to save and name the active document.    FoneBook displays the Save As dialog box 
so you can name your document.    
To save a document with its existing name and directory, use the Save command.



File Save As dialog box
The following options allow you to specify the name and location of the file you’re about to save:

File Name
Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    FoneBook adds the extension you specify in the
Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.
Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)
Use the numbers and filenames listed at the bottom of the File menu to open the last four documents 
you closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)
Use this command to end your FoneBook session.    You can also use the Close command on the 
application Control menu.    FoneBook prompts you to save documents with unsaved changes.
Shortcuts
Mouse: Double-click the application’s Control menu button.

Keys: ALT+F4



Cut command (Edit menu)
Use this command to remove the currently selected data from the document and put it on the clipboard.  
This command is unavailable if there is no data currently selected.
Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar:

Keys: CTRL+X



Copy command (Edit menu)
Use this command to copy selected data onto the clipboard.    This command is unavailable if there is no
data currently selected.
Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar:

Keys: CTRL+C



Paste command (Edit menu)
Use this command to insert a copy of the clipboard contents at the insertion point.    This command is 
unavailable if the clipboard is empty.

Shortcuts
Toolbar:

Keys: CTRL+V



Toolbar command (View menu)
Use this command to display and hide the Toolbar, which includes buttons for some of the most common
commands in FoneBook, such as File Open.    A check mark appears next to the menu item when the 
Toolbar is displayed.
See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The toolbar 
provides quick mouse access to many tools used in FoneBook,
To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).



Status Bar command (View menu)
Use this command to display and hide the Status Bar, which describes the action to be executed by the 
selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next 
to the menu item when the Status Bar is displayed.
See Status Bar for help on using the status bar.



Status Bar
The status bar is displayed at the bottom of the FoneBook window.    To display or hide the status bar, 
use the Status Bar command in the View menu.
The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 
through menus.    This area similarly shows messages that describe the actions of toolbar buttons as you
depress them, before releasing them.    If after viewing the description of the toolbar button command 
you wish not to execute the command, then release the mouse button while the pointer is off the toolbar 
button.



New command (Window menu)
Use this command to open a new window with the same contents as the active window.    You can open 
multiple document windows to display different parts or views of a document at the same time.    When 
you open a new window, it becomes the active window and is displayed on top of all other open 
windows.



Cascade command (Window menu)



Tile command (Window menu)
Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)
Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.



Tile Vertical command (Window menu)
Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command
Use this command to arrange the icons for minimized windows at the bottom of the main window.    If 
there is an open document window at the bottom of the main window, then some or all of the icons may 
not be visible because they will be underneath this document window.



1, 2, ... command (Window menu)
FoneBook displays a list of currently open document windows at the bottom of the Window menu.    A 
check mark appears in front of the document name of the active window.    Choose a document from this
list to make its window active.    



Index command (Help menu)
Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using FoneBook and various types of reference information.    
Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help command (Help menu)
Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of FoneBook.



Context Help command 

Use the Context Help command to obtain help on some portion of FoneBook.    When you choose the 
Toolbar’s Context Help button, the mouse pointer will change to an arrow and question mark.    Then 
click somewhere in the FoneBook window, such as another Toolbar button.    The Help topic will be 
shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar
The title bar is located along the top of a window.    It contains the name of the application and document.
To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars
Displayed at the right and bottom edges of the document window.    The scroll boxes inside the scroll 
bars indicate your vertical and horizontal location in the document.    You can use the mouse to scroll to 
other parts of the document.



Size command (System menu)
Use this command to display a four-headed arrow so you can size the active window with the arrow 
keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 

border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)
Use this command to display a four-headed arrow so you can move the active window or dialog box with
the arrow keys.

Note:    This command is unavailable if you maximize the window.
Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)
Use this command to reduce the FoneBook window to an icon.

Shortcut
Mouse: Click the minimize icon  on the title bar.

Keys: ALT+F9



Maximize command (System menu)
Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse: Click the maximize icon  on the title bar; or double-click the title bar.

Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)
Use this command to switch to the next open document window.    FoneBook determines which window 
is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)
Use this command to switch to the previous open document window.    FoneBook determines which 
window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)
Use this command to close the active window or dialog box.
Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the document 
Control menu closes only one window at a time.    You can close all windows at once with the Close 
command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the FoneBook or Schedule window.



Restore command (Control menu)
Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)
Use this command to display a list of all open applications.    Use this “Task List” to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)



Choose Font dialog box
Use the font selection dialog box to chance the font use in the display data within the index. Any screen 
font installed upon the system can be used, in any style.



No Help Available
No help is available for this area of the window.



No Help Available
No help is available for this message box.



Selecting records
The search window allows you to include or exclude sets of records by matching fields against your 
selection criteria. The text is matched when it occurs anywhere within the field(s) that are selected to be 
searched. You can search any one or all the fields. You can:
    include records into the index.
    exclude records from the index.
    can clear the index before any index.

    Leave all records in from any prior filtering actions.

    specify which fields to search within.

    search all open files or just the active one.
This allows for filtering records for printing operations or fax broadcasting. You can have a record within 
the index more than once by performing matches repeatedly. This can be useful in a case where you 
want to print multiple labels for yourself.



Configuring fields
This command brings up the fields and search pages.
The FIELDS page allow you to rearrange the order that fields are ordered within the main index. It also 
allows for changing the field name  as well as it characteristics.
The SEARCH page is used to filter the records, to exclude or include entries form printing reports or 
labels, or when placing a fax.



Dial voice page
The numbers that appear in the list on the voice page, are those in which the fields have been identified 
on the configuration as voice numbers.
Other pages within the property sheet allow for the configuration of your location, hardware configuration
as well as perform voice dialing and fax broadcast.
Options include:
Access numbers used in dialing 
Identification of location .
Hardware options .
Fax broadcast using the MAPI interface .



Dial access page
This page allows formatting access specifics:

outside line

international

access number

long distance carrier

credit card number

number to dial to access credit card dialing
Some of these fields are used in the formatting the number to dial depending the location you are dialing 
from. For instance if dialing to a different area code it would automatically place the distance numeral’s in 
front of the number to be dialed before sending the dialing string to the modem for dialing. 



Dial location page
This page contains the specifics for where the computer is being executed from; 

The country

area code

local toll prefixes

symbolic name used for identifying profiled location.
Country code and area code are used both in determining the format of the number to dial. As well as in 
determining the time at the location of the dial process.



Dial hardware page
This page is used to specify hardware configuration; 

The Com port the modem is located on

Attempt to perform a fast dial

Tone or pulse dialing



Dial fax page
This dialog is used to identify all the options for sending faxes through the Microsoft Mail and At Work 
Fax within Windows. 
The options include: 

The target numbers within the index to fax to. 

What MAPI interface to use (Fax or Email). 

The document or file to sent. 

The ID it is to be identified as coming from. 
The symbolic field names in the list identify all numbers that are validly configured as Fax or Email type 
numbers. To identify any numbers as Fax or Email see the configuration page.



Edit record
This sheet contains multiple pages for editing the selected record. All of the fields titles can be 
configured from the configuration page, where any dialable attributes can be set also. Each field can be 
set individually as to the characters that are allowed to be entered.
The page has buttons on the right that allow for updating after changing any of the fields or for adding a 
new records as well as deleting the current record.    
If you want to perform mass deletions you need to return to the main index and select the records you 
want to delete then press the minus button on the button bar.



Edit schedule record

These pages allow for the editing of schedule records after making the necessary changes or additions 
you press the add button to add a new record, update to change an existing record or delete to delete 
the current record. 
On the action page there is a test button to test the current scheduled event before actually adding the 
record. 



Config page
The configuration page is used for setting which fields will be placed in the index and the order they shall
appear. 
Also configurable from this page are the characteristics or style of each of the fields. This allows for a 
strict conformity of style, which is needed for fields used in communications.
The style of fields available are:

 Text
255 bytes of non filtered characteristics

 Phone
3 digits for area code followed by 7 digits for the alpha number digit

 Phone 4
3 digits for area code followed by 7 digits for the number with 4 digit extension

 Phone 5
3 digits for area code followed by 7 digits for the number with 5 digit extension

 Fax
3 digits for area code followed by 7 digits for the number used for fax targets

 Zipcode
U.S.A. 5 digit postal code

 Zipcode 4
U.S.A. 5 digit postal - 4 digit extension

 Zipcode 6
U.S.A. 5 digit postal - 6 digit extension

 Lastcall
Used to record the last date and time a call was made to this destination

 Updated
 

Used to record the date and time the record was last updated

 Date
typical 6 digit date field separated by /’s

 Time
typical 6 digit time field separated by /’s

 Date 
Time

typical 6 digit date field and time fields separated by /’s

 Other
For future expansion in connecting to various BBS’s



Delete selected records
This menu item is used to delete all selected records in the main index.



Update selected record
This menu item is used to place the first selected record in the edit window for updating. After making 
the necessary changes within that window you will have to press the update button for the changes to 
occur within the database.



Add new record
This menu item is used to bring up the record edit box for adding a new record to the database.



Undo last undoable command
This command undoes the last undoable command.

Keys: CTRL+Z 



Print Preview
The print preview dialog allows for the previewing of reports before printing them.
On the canvas there are other commands not available off of the menu. 

You can select a field or a group of fields to work with by dragging the cursor around the fields you 
want to work with, using the left mouse button. 

You can bring up a configuration dialog for these fields with the right mouse button. 

You can change the position of the fields on the canvas by dragging them around the canvas with the
left mouse button. 

On bitmaps or static text fields you can edit them by double clicking on them with the left mouse 
button. 

To delete a fields off of the canvas just drag it off of the canvas, and it will be added to the available 
fields control.
The horizontal and vertical lines identifies the extents that will be used for printing out records, giving you 
the ability print more than one record per line. This allows for configuring the reports to fit on almost any 
standard label or non standard label.

If choosing to print on labels turn of printing headers. To see the number of columns and row that will be 
printed look at the lower left corner. The first number contains the number of columns the second contains
the number of rows that will be printed.



Print preview options
Loading current record fields instead of showing the field names.
Snap to column and row alignment.
Allowing overlapping fields
Turning off or on printing headers.
Start printing labels on the first or any subsequent position.
Invoking the print setup dialog.



Main FoneBook window
The main window for contacts allow for sorting by any of the columns, just by pressing the left mouse 
button in the header bar on the column you wish to sort. You can add any of the fields to the main index 
using the configuration  pages. Any and all fields can be in the index at the same time in any given order.
If you wish to change the field in column one you will need to make the change then save the file and 
reopen the file, for the change to take place.
You can edit a record from this window by double clicking the left mouse button on the record of choice.
This window also supports multiple selections by either dragging the left mouse button over the records 
of choice or by holding the CTRL button down on the records you want to add to the selection list.



Main schedule
This screen allows for changing the calendars years months or day. It also allows for listing events for a 
given day of all events.

    To list the event  for a given day press the right mouse button on that day. 

    To list all events  , right mouse button click on the header of the window.



Schedule events
This window display either all events or only the events for a specific period of time, depending upon 
how it was invoked. The methods of invocation are:

    right mouse on the days header portion of the calendar - all events

    right mouse click on any given day - only those events for that day



Setting the font
You can use the change font dialog to change the font in two places;
for displaying and printing fields in print preview.
for display the data in the contact list and the schedule list.

Besides being able to change the font you can also change the size and the style of the font.



Print setup
The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use.    Choose the Default Printer; or choose the Specific Printer option 
and select one of the current installed printers shown in the box.    You install printers and configure ports
using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of 
printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Duplicate field
The duplicate field was specifically designed for use with a true type bar-code font and the zip 
code/postal code, for printing a bar-code on a label or the outside of envelopes.



Field attributes
Setting the field display characteristics occur from this dialog. Including the font the size of the font, 
whether to show the field label and its alignment within its designated area.



Setting a static field
Setting the characteristics of any static text is performed for this dialog, including setting the font, its size
and other characteristics. You also set the static text that will be printed on every field from this dialog.



Bar Codes
There are many True Type fonts available. They can be used to print the zip code in barcodes on labels. 
To do so on the report you design, you need to drag the field called Duplicate out on the report, when 
you are done dragging it out it will prompt you for which field you want duplicated, chose the zip code 
field or postal code field, depending on what you have labeled that field. The click the font button and 
select the ZipBarCode font. 
This is useful when doing mass mailings because the postal department in the US gives you a discount 
if you mail has the bar codes printed correctly, and is delivered sorted.



Import
The import dialog is used for import external files into an internal FoneBook format. It allows a formatting
ability that specifies which field each field will be placed within as well as the delimiters for the field. You 
can save the format for later usage both in importing and exporting, if you need to take the fields back 
out to the external file format. 
The Import File in field identifies the file that will be imported, the field under it allows previewing the file 
before actually importing it.
After identifying the fields , the order they come in the file and the delimiter that shall be used you need 
to save the format in an format file (they have an extension of .CFG.



Export
The export dialog is used for exporting a FoneBook to an external fill. It allows a formatting ability that 
specifies the order the fields will be placed in the external file as well as the delimiters that shall be 
placed after the fields. You can save the format for later usage both in importing and exporting, if you 
need to bring the fields back into an internal format. 
After identifying the fields , the order they come in the file and the delimiter that shall be used you need 
to save the format in a file (they have an extension of .CFG.



Fax Broadcast
The fax broadcast relies upon using Microsoft Exchange as it carrier. After selecting the index entries 
that you want the broadcast sent to, you indicate who the fax is coming from, and which document you 
want the broadcast to send. After selecting the send button the broadcast shall transfer the faxes one at 
a time to MSMail to perform the task. The destinations for the fax can only be sent to a style of number 
that has been configuration  asa fax.



EMail Broadcast
The EMail broadcast relies upon using Microsoft Exchange as it carrier. After selecting the index entries 
that you want the broadcast sent to, you indicate who the EMAil is coming from, and which document 
you want the broadcast to send. After selecting the send button the broadcast shall transfer the mail one
at a time to the exchangel to perform the task. The destinations for the EMail can only be sent to a style 
of number that has been configuration  asa fax.



Threads
FoneBook takes advantage of threads many places internally. Including when opening files and 
searching for records. This has certain advantages for the end user in that it allows them on long drawn 
out processes to perform other tasks within FoneBook, instead of haveing the whole application locked 
up while this occurs.
Opening files is enhanced, in that they can be opened simultaneously at startup, by    specifying    it on 
the command line when initiating the product.
An example of starting the product would be if FoneBook lived in the directory “C:\FoneBook” you could 
specify to execute FoneBook thus:
“C:\FB\FoneBook.Exe Work.PB|Home.PB|Schedule.PBS|DoubleWord.phone”.
This would automatically open the two FoneBooks and one schedule, plus one phone monitor    
simultaneously. If one of the files had a couple of hundred thousand entries, you could interface with the 
file even while it was being opened, or work in one of the other windows. 



Copyright Liscense Warranty
FoneBook Copyright © 1992 - 1996 by DoubleWord 
All rights reserved.

License Agreement
You should read the following terms and conditions before using this software.    Unless you have a 
different license agreement signed by DoubleWord your use of this software indicates your acceptance 
of this license agreement and warranty.

Registered Version
One registered copy of FoneBook may be used by a single person who uses the software personally on 
one or more computers, or installed on a single workstation used nonsimultaneously by multiple people, 
but not both.
You may access the registered version of FoneBook through a network, provided that you have obtained
individual licenses for the software covering all workstations that will access the software through the 
network.    For instance, if 5 different workstations will access FoneBook on the network, each 
workstation must have its own FoneBook license, regardless of whether they use FoneBook at different 
times or concurrently.

Governing Law
This agreement shall be governed by the laws of the State of California.
Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE DISTRIBUTED "AS IS" WITHOUT 
WARRANTIES AS TO PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES 
WHETHER EXPRESSED OR IMPLIED. Because of the various hardware and software environments 
with which FoneBook may be used, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS 
OFFERED.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data 
before relying on it.    The user must assume the entire risk of using the program.    ANY LIABILITY OF 
THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF 
PURCHASE PRICE.



EMail Broadcast
The Email page, allows you to select a file and broadcast it to a group of people or to all people in your 
database. After specifying the users to send it to, the title on the Email you press the send button. This in
turn transfers all the    mail to the microsoft exchange, who handles the connection to which email 
package you are using as your destination. 
You have the choice of a number of different email packages to choose, it all depends on which 
gateways you have installed in the exchange.
Options include Internet, Compuserve, CCMail, MCI mail, MS Network, MS Exchange server, MS Mail 
server, X400, X500, PROFS, SNA Server.



RAS Dialing
This page allows you to connect to the remote system through RAS (Remote Access Services).
To automate the entering of the userid and password you enter the userid after the first “[“ followed by 
either a “/” or a “:” or a “-“, followed by the password for that system.




