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Disclaimer
THIS SOFTWARE AND MANUAL ARE SOLD AS IS AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OF MERCHANT ABILITY OR ANY OTHER WARRANTIES WHETHER 
EXPRESSED OR IMPLIED. BECAUSE OF THE VARIOUS HARDWARE AND SOFTWARE 
ENVIRONMENTS INTO WHICH THIS PROGRAM MAY BE PUT,    NO WARRANTY OF FITNESS    
FOR A PARTICULAR PURPOSE IS OFFERED.      ANY PROGRAM SHOULD BE THOROUGHLY 
TESTED    WITH NON-CRITICAL DATA    BEFORE RELYING ON IT.      THE USER MUST ASSUME    
THE ENTIRE RISK OF USING    THE PROGRAM.      ANY LIABILITY    OF THE SELLER WILL BE 
LIMITED TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.



What is It?
Z & Z Color is named after my two children, Zachary and Zoë.    It is intended for used by children 
ages two to ten but is most appropriate around the pre-K and Kindergarten years.    

As a professional computer programmer and a devoted parent (soon to be a demoted parent as the 
little lady keeps having to nag or drag me away from the computer) I can't help but look at a children's
game without thinking about how I can make it better on a computer.    It can be more fun, more 
educational, and less frustrating.    

It started out as a simple color by number program and gradually evolved over the course of its 
development into something bigger and better.    I hope you and your children enjoy it as much as my 
kids do.    

See the information on How to Color a Drawing for the different ways to use this program.    It teaches
numbers, letters, colors, and at the higher difficulty levels provides a good memory exercise.    



Registration
Z & Z color is a shareware product.    As such, it is provided to you at little or no initial expense for a 
trial period of thirty days.    After the thirty day period if you find that you do not wish to purchase the 
program simply delete it from your hard disk and/or floppies.    If you like the program, thank me by 
sending me a check for $18.    It is not free.    A great deal of effort went into the creation of this 
program.    If you hope to see more programs like it you must support the shareware concept by 
sending in your registration.

Mail your check for $18 ($15 + $3 postage and handling) to:

Jason Balmuth
404 Kosoak Road
Baltimore, MD 21220

Indicate whether you prefer 3 1/2 or 5 1/4 inch disks and I'll send you a copy of the registered version.
Registration also entitles you to three months of support via telephone and the Compuserve computer
service (my ID is 71221,1371).    Also send me any suggestions you might have for improvements and
new features.    If I use your suggestion I'll send you a copy of the next version for free!

You may copy this program and share it with others but you may not sell the software.    Anyone 
wishing to charge people a fee for giving them a copy of Z & Z Color must have the written 
authorization of the author, without which, the distributor is guilty of copyright violation.    To receive 
such authorization print and sign the agreement listed below and send it to me at the address listed 
above.    Include $3 to cover postage and handling for the latest version of Z & Z Color.    For 
distributors already recognized by the Association of Shareware Professionals this authorization is not
necessary.    

TERMS OF DISTRIBUTION OF Z & Z Color

1. The fee charged may not exceed $10, including postage, mailer and any other charges.

2. Your libraries catalog or listing must state that this program is not free, but is copyrighted software 
that is provided to allow the user to evaluate it before paying.

3. The offering and sale of Z & Z Color will be stopped at any time the author so requests.

4. Copies must be made from the disk sent to you with this agreement.    This is required for control 
purposes.    

5.    Problems or complaints about the program will be reported to the author for investigation.    In 
return for a license to charge a fee for the distribution of the program Z & Z Color, I agree to comply 
with the above terms of distribution.

Signed, _____________________________________      ______________
                                                          your signature                                                                                  date



If you have problems...
Z & Z Color underwent quite a bit of testing by myself, my kids, and other Beta testers before it 
reached your hands.    However, I would not want to bet my life that there are no bugs remaining in 
the program.    If you have a registered copy of the program (see Registration for more information) 
and you are the first one to inform me of a problem, I'll fix it and send you a free copy of the next 
version as soon as possible.    If you have an unregistered copy I'm still interested in hearing about 
the problem but you must register in order to get the free copy.

Some common problems and suggested solutions :

Problem : Too slow, needs too much memory 
Solution : Buy a faster machine with more memory and a faster video card.    Just 

kidding.    Stay away from the zoom commands and a magnification other than 100% 
(shown on title bar of window).    Also make sure your display driver is not set for a 
mode with more than 16 colors.    This can be changed via the Windows Setup icon in 
the Main group of the program manager.    If in doubt choose VGA or Super VGA.

Problem : Some menu items are always grayed (disabled).
Solution : Z & Z Color has two modes of operation - coloring pictures and creating 

pictures.    Some menu commands, such as the command to validate a picture 
(located on the edit menu), are exclusive to one mode or the other.    Other menu 
commands, such as the Paste command, depend on other things as well as the 
operating mode of Z & Z Color.    In order for the Paste command to be enabled you 
must be in create mode and there must be a bitmap present on the Windows 
clipboard.    

Problem : Colors filled in on the picture look different than the one on the button that was
selected.

Solution : Some pictures require colors which are not pure but dithered.    Dithered 
means that the color is faked by alternating dots of other colors.    For example, brown 
can be created by alternating maroon and black dots.    When the (zoom) 
magnification is set to 200% on a VGA screen you can start to see the dots for 
dithered colors.    If you shrink the picture down to 50% or 25% the dots are mixed 
together resulting in a color which appears different from the one you used to fill it.    
When and if you restore the picture to 100% the correct color will be visible.

Send as much information as you can gather on any other problems to 

Jason Balmuth
404 Kosoak Road
Baltimore, MD 21220

Compuserve : 71221,1371



How to Color a Drawing
When Z & Z Color first starts up a drawing of the letters in Z & Z Color is shown.    To select another 
drawing use the Open command from the File menu.    

Next select the desired options - numbers, letters, shapes (symbols), colors and beep on wrong via 
menu commands (see the Options menu for more information) or the buttons along the left hand side 
of the window.    Refer to the table below for a brief description of the various ways to configure Z & Z 
Color.    For beginners we recommend using numbers and leaving the beep on wrong off to avoid 
early frustration.    

Select a color by pressing one of the color buttons along the bottom of the window.    Press and 
release the left mouse button anywhere in the drawing to fill in the area around it.    The selected color
spreads out from the point where you clicked the mouse until it reaches a black border or a region of 
any other color.    The color remains selected until another color is chosen.    

Pressing the right mouse button fills an area with white but only if the beep on wrong switch is 
disabled. .

Choose another color required in the drawing and fill in the areas where that number/letter/shape is 
found.    Continue this until all marked areas of the drawing have been colored in.    If the beep on 
wrong switch is enabled (check mark appears in Options menu and button appears depressed) when 
the drawing is completed you will be rewarded with a prize.

If you want to do the same drawing again use the Clear command on the Edit menu to start over 
again.    If you want to try another drawing use the Open command from the File menu.

Marker Options
Numbers Letters Shapes Colors Description Difficulty
On On Number markers, numbered and 

colored buttons Very Easy

On Number markers, numbered 
buttons Easy

On On Letter markers, lettered and 
colored buttons Very Easy

On Letter markers, lettered buttons Easy

On On Shape/symbol markers, shapes 
and colored buttons Easy

On Shape/symbol markers, shapes 
on buttons Medium

On No markers, colored buttons Hard

No markers, plain buttons Very Hard



How to Create a New Drawing
To create a new drawing first you need to find or draw a picture in another application (such as 
Paintbrush, which is included with Windows) and then copy it to the Windows clipboard or save it as a
bitmap file.    

Start up Z & Z Color if it isn't already running and load the picture.    If you copied it to the clipboard 
then use the Paste command from the Edit menu.    If you saved it to a file then use the Open 
command from the File menu.

Make sure you are in create mode - there should be a check mark next to the command in the 
Options menu.    You are now ready to add the number/letter/shape markings to your drawing.

Select a color by pressing one of the color buttons along the bottom of the window.    If the color you 
need is not available, select a color which you do not need and then use the Change Color... 
command from the Edit menu to switch it to the desired color.

Now move the cursor to the area you want to label and then press and release the left mouse button 
to add the marker.    If the location is not satisfactory use the Undo command to remove the last 
marker that you placed or move the cursor close to any existing marker and then press the right 
mouse button to delete it.    Continue adding markers until all areas which should be colored have 
been labeled.

If you have not saved the new drawing yet now is a good time to do it - use the Save As... command 
from the File menu to enter a file name for the drawing.    Validation will be performed automatically 
and the file will not be saved if any errors are found.    Correct any errors and then save the file.

To test the new drawing turn create mode off and then use the Show Completed Picture command 
from the Edit menu to see what the drawing will look like.    To make changes press the Clear button 
(or use the menu command), turn Create mode back on, and then add and/or remove markers and 
change colors as required to make the picture look as good as possible.    Be sure to save the 
drawing when you are finished.

Finding the subject matter for a good looking drawing is more difficult than you might expect as the 
picture should be relatively simple without small areas that are difficult to position the cursor over.    If 
there are just a few small areas you may wish to color them yourself before saving the ZZC file.    This
is also the only way to get a drawing with more than 16 different colors in it.    



File Menu
The Open command is used to select a new drawing.    A dialog box appears to allow for selection of 
either a Z & Z Color file or a bitmap file.    Select a Z & Z Color file for a drawing to color.    Select a 
bitmap file if you wish to create a new Z & Z Color drawing.

The Save command saves the current drawing to its current file.    If you are in create mode the 
default file type is a Z & Z Color file.    If you are working on a drawing, the default file type is a bitmap 
file that can be read in to another application (such as Paintbrush) at a later time. 

Use the Save As command to pop up a dialog for selection/creation of a different file to save the 
current drawing.

Exit closes the Z & Z Color Window.    Do not use this command until you are finished playing with 
this application.

To Print a drawing in its current state select this command from the file menu.    The drawing without 
markers (numbers, shapes, or letters) will be sent to the currently selected printer.    In create mode 
the markers are also sent to the printer.    This gives you a drawing that you can manually color with 
crayons or markers.    If you are informed of insufficient memory try un-checking the Use Print 
Manager checkbox found in the printers part of the Windows control panel. 

The Print Setup command brings up a dialog box that allows you to configure your currently selected
printer as well as to select a different printer (if your computer has access to multiple printers or print 
drivers).



Edit Menu

The Undo command (same as the  button) restores the drawing to its state prior to the last 
change.    For example, if the Beep on Wrong switch is disabled and you fill an area in with the wrong 
color, use this command to correct it.    In create mode the undo command removes the last marking 
(number, letter, or shape) which was added to the drawing.

The Clear command (same as the  button) is used to restore a drawing to its initial (uncolored) state.  
Use this to try the same drawing again.
Show Completed Picture completes the current drawing for you.    If for some reason you can not 
complete the drawing in the normal manner (filling in each area) this command can be used to show you 
what the completed drawing looks like.    Follow this with the clear command (described above) and then 
try to do it the right way.

The Validate command is used in create mode only in order to avoid the situation where a single area
in a drawing contains multiple markings.    Each new drawing which you create must be validated 
before it can be saved as a ZZC file.    Areas which contain multiple markings will be automatically 
corrected but may require you to make a manual correction in order to have the color of your choice.

The default 16 colors used by Z & Z Color are the 16 solid colors that are used by default in most 
VGA displays.    If you need a color for your drawing other than one which is displayed on the color 
buttons simply select the button for a color which you do not need and then use the Change Color... 
command.    A Dialog box appears to assist you in the selection of another color.    

The Reset Colors command restores all 16 colors to the VGA defaults.

The last two commands on the Edit menu both relate to the Windows clipboard.    The Copy 
command copies the current drawing (without numbers, letters, or shapes) to the clipboard so that it 
can be pasted into another application.    The Paste command accomplishes the opposite function; it 
inserts a drawing (referred to as a bitmap) from another application into Z & Z color.    Once a drawing 
has been pasted into Z & Z Color you can then mark areas with the desired colors in create mode.    
Note that the    Paste command is disabled unless Create Mode is active.



View Menu
Commands on the View menu are used to change the magnification of the drawing to allow for easier 
access to small areas and so you can see the whole picture on larger drawings.    

Fit in Window automatically computes the magnification so that the entire drawing fits within the 

window.    Actual Size resets the magnification to 100%.    Zoom In (same as the  button) 
increases the magnification to make the drawing larger.    Zoom Out (same as the 

 button) decreases the magnification to make the drawing smaller.
The minimum magnification is 25%.    The maximum magnification is 200%.    Try to avoid using the 200% 
magnification unless your computer has a lot of available memory.



Options Menu
Create Mode toggles the switch to go between drawing mode and creation mode.    For more 
information on creating drawings refer to the section on creating new drawings .

Beep on Wrong (same as the  button) toggles the switch controlling the beep when the wrong 
color is used to fill an area.    When this switch is off, any color may be used on any area in the 
drawing with the exception of black areas, which are always assumed to be boundaries.    When the 
switch is on, only the designated color may be used to fill in the area containing the current location of
the cursor.

Font... brings up the dialog box to change the font which is used to draw the guiding numbers, letters, or 
shapes.    Note that the font information is saved along with each drawing so that larger drawings can use 
a larger font.    On the other hand, this makes changing the font used for all of the drawings more difficult :
you must open each file, change the font, and then save it again.

If the Numbers switch is enabled (  button is down, check mark appears next to menu item) the 
numbers zero through fifteen are used to indicate which color should be used in each area.

If the Letters switch is enabled (  button is down, check mark appears next to menu item) the letters    
a through P are used to indicate which color should be used in each area.

If the Shapes switch is enabled (  button is down, check mark appears next to menu item) shapes, or 
symbols, are used to indicate which color should be used in each area.

If the Colors switch is enabled (  button is down, check mark appears next to menu item) colors are 
shown on the color buttons (displayed along the bottom of the Z & Z Color Window) in addition to the 
appropriate number, letter, or shape for each button.    
If Numbers, Letters, and Shapes are all disabled and the Colors switch is enabled, nothing will be 
displayed to mark each area but the color buttons at the bottom of the window will contain the color 
associated with each button.    To complete the drawing in this mode you must remember which color 
goes with each area. 

If all four switches are disabled nothing will be displayed to mark each area and the color buttons at 
the bottom of the window will be blank.    This is the most difficult way to complete the drawing as you 
must remember not only which color to use for each area but which button to use to obtain the 
desired color.



Help Menu
Selecting Contents from the Help menu brings you to the title/table of contents page in the Z & Z 
Color online help system.

Using Help displays general information on how to use the Windows Help system.

About Z & Z Color... brings up a brief dialog box tells you the version number of the program, its 
authors, and your registration status, or lack thereof.




