
Microsoft System Information

Microsoft System Information is a basic tool for gathering system configuration information. It is intended primarily to help 
Product Support Services (PSS) engineers determine information that could indicate problems with your system.



File menu commands

The File menu offers the following commands.

Save Saves a listing containing the information for each 
category.

Print Prints a listing containing the information for each 
category.

Run Invokes a dialog box for specifying a program to run.

Exit Quits Microsoft System Information.

Edit menu commands

The Edit menu offers the following commands.

Copy Copies data from the list view to the Clipboard.

Select All Selects all of the items in the list.

View menu commands

The View menu offers the following commands.

Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Refresh Refreshes the list of items for the current category.

Always on Top Toggles the option to have Microsoft System 
Information appear in front of all other windows.

Help menu commands

The Help menu offers the following commands, which provide you assistance with this program. 

Help Topics Opens Help.

About Displays program information, copyright and version 
number for Microsoft System Information.

Save command (File menu)

Use this command to save a listing of all the information for the categories.



Run command (File menu)

Use this command to start another program. This will display a dialog box containing a list of common utilities to choose from. 
You can also type the file specification, or search for the file by clicking the Browse button.



Exit command (File menu)

Use this command to quit this program. You can also use the Close command on the Control menu. 



Copy command (Edit menu)

Use this command to copy selected data onto the Clipboard. 

Copying data to the Clipboard replaces any data previously stored there.



Toolbar command (View menu)

Use this command to display and hide the toolbar, which includes buttons for some of the most common commands. A check 
mark appears next to the command when the toolbar is displayed.



Toolbar

The toolbar is displayed across the top of the window, below the menu bar. The toolbar provides quick mouse access to many 
commands and tools used in Microsoft System Information.

To hide or display the toolbar, choose Toolbar from the View menu (ALT, V, T).



Status Bar command (View menu)

Use this command to display and hide the status bar, which describes the action to be performed by the selected command or 
toolbar button. A check mark appears next to the command when the status bar is displayed.



Status Bar

The status bar appears at the bottom of the main window. To display or hide the status bar, use the Status Bar command on the 
View menu.

This area describes actions of commands as you use the arrow keys to navigate through menus and, similarly, the actions of 
toolbar buttons as you depress them, before releasing them. If after viewing the description of a toolbar button you decide not to 
run the command, move the pointer off the button and then release it.



Help Topics command (Help menu)

Use this command to display Help. From the opening window (Contents or Index), you can jump to step-by-step instructions for 
using Microsoft System Information and various types of reference information. 

When a Help topic is open, you can click the Contents or Index button to return to the Contents or Index.



About command (Help menu)

Use this command to display program information, copyright, and version number of your copy of Microsoft System Information.



Context Help command 

Use the Context Help command to obtain Help on some portion of Microsoft System Information. When you choose the Context 
Help button on the toolbar, the mouse pointer changes to an arrow and question mark. Then click the location in the window, 
such as another toolbar button, that you want information about. 



No Help Available

No Help is available for this area of the window.



No Help Available

No Help is available for this message box.



Print command (File menu)

Use this command to print a listing of all the information for the categories.

Note
If your system is configured for VoiceView modem support, you have the option of sending the information over 
the modem.



Select All command (Edit menu)

Use this command to select all of the items displayed in the list view.



Refresh command (View menu)

Use this command to refresh the list of items for the current category. For example, if the System category is shown, you can use
this command to update some of the statistics, such as available memory.



Cancel Update command (View menu)

Use this command to interrupt Microsoft System Information in the middle of gathering information for the selected category. The
information displayed is incomplete if the data gathering process is interrupted. Select the Refresh command from the view menu
or press F5 to show all the data.



Always on Top command (View menu)

Use this command to make the Microsoft System Information window always remain visible, even if another window has the 
focus.



System Info

Shows information about your computer that is useful when attempting to troubleshoot system problems.

To view information about a specific category, select the category in the left pane. You can sort a column by clicking the column's
heading.

You can copy the data from selected rows in the right-hand pane. Click in the first column of the row(s) you want to copy, click 
the Edit menu, and then click Copy (or press CTRL+C). The data is tab delimited, so you can easily paste it into Microsoft Excel 
worksheets.



System

Lists hardware and system software information.



Items for System Category

Operating system:    The name of the system software on your computer

Windows version:    The version of Windows that is running on your computer

Processor:    The type of CPU (central processing unit)

Total physical memory:    The total amount of installed RAM (random access memory)

Available physical memory:    The amount of free physical RAM (in kilobytes)

USER memory available:    The percent of free resources in the Windows User component

GDI memory available:    The percent of free resources in the Windows Graphic Design Interface (GDI)

Swap file size:    The size of the system file used to implement virtual memory. 

Swap file usage:    The percentage of the Windows swap file that is in use

Swap file setting:    The swap-file configuration (for example, dynamic vs. fixed limit)

Available space on drive <x:>:  The free disk space (in kilobytes) on a specific drive

Windows directory:    The fully qualified path to the main Windows directory

TEMP directory:    The fully qualified path to the system’s temporary directory



Virtual Memory

A memory management technique to allow more programs to be active at the same timeDisk space is used to extend the 
amount of logical memory that programs can access. When a new program is run, infrequently used components or data of other
programs can be moved out of physical memory to a special swap file on disk.



Kilobyte (K)

A measurement of memory or disk space. One kilobyte (K) equals 1024 bytes or characters.



Printing

Displays information about installed printer drivers.



Items for Printing Category
Default printer: The printer that all Windows-based print jobs go to unless otherwise specified

Using print manager spooling?:    Indicates whether the printer output is buffered through the printer manager instead of 
directly going to the printer port

Unidriver (UNIDRV.DLL):    File information for universal printer driver

Gen drv (GENDRV.DLL):    File information for generic library driver

<specific printer>:    Name and file information for each printer that has been installed



System DLL’s

Lists the file name, version number, date stamp, file size, and build number of each DLL in the Windows System directory (for 
example, C:\Windows\System) and determines whether it's loaded in memory. 



Items for System DLL’s category

Each item represents a Dynamic Link Library file in the Windows System directory (typically, C:\Windows\System or C:\Winnt\
System32). The columns displayed are as follows:

Files:    The DLL’s filename

Version:    The numeric version code (for example, 4.0.0.500).
Often given as <major>.<minor>.<revision>.<build>. 

Date:    The date that the DLL was produced (“build” date)

Size:    Size of the file in bytes

Loaded:    Indicates whether    the DLL is active (loaded in memory)

Build No.:    Version code including build identification



Font

Shows information about some third party font engines. 



Font Substitutions

Displays the font substitutions for common fonts that are not installed.



Font Managers

Lists some third party programs that control font size, format, design, and layout.



Proofing

Displays information about your thesaurus, spelling, and grammar checkers.



Registry Settings

Displays proofing tool information found in the Windows registry.



INI Settings

Displays proofing tool information found in the Win.ini file.



File Info

Lists the file name, version number, file date, file size, build number, and fully qualified path of each file associated with your 
proofing tools. This category also determines whether the file is currently loaded in memory.



Graphic Filters

Lists data about your graphics import and export capability.



Registry Settings

Displays graphics filter information found in the Windows registry.



INI Settings

Displays graphics filter information found in the Win.ini file.



File Info

Lists the file name, version number, file date, file size, build number, and fully qualified path of each file associated with your 
graphics filters. This category also determines whether the file is currently loaded in memory.



Text Converters

Lists data about your text import and export capability.



Registry Settings

Displays text converter information found in the Windows registry.



INI Settings

Displays text converter information found in the Win.ini file.



File Info

Lists the file name, version number, file date, file size, build number, and fully qualified path of each file associated with your text 
converters. This category also determines whether the file is currently loaded in memory.



Display

Shows the file name, version date, and size of the current video driver.



Items for Display Category

<Optional Driver Description>

<Driver Filename>:  Version, date, and size in bytes



Applications Running

Displays the module name, process ID number, and bitness of all active programs (.exe files).



Items for Applications Running Category

Each item represents a Windows-based program that is active. The columns displayed are as follows:

Module Name:    The application’s file name, including its directory and path.

Process ID:    The identifier that the operating system uses for the program

16-bit:    Usually indicates whether the program was designed for previous versions of Windows.

Note
Some new utilities are 16-bit for compatibility reasons.



OLE Registration

Lists all the OLE server entries in the Windows registry and Win.ini file.



Registry Settings

Lists all the OLE server entries from the registry.



INI Settings

Lists all the OLE server entries from the Win.ini file.



Active Modules

Displays the module name, version number, file date, file size, bitness, and fully qualified path to all modules (drivers, fonts, 
dynamic link libraries, and executable files) in memory.



Items for Active Modules category

Each item represents an application extension or a system resource that is currently loaded in memory. The columns displayed 
are as follows:

Module Name:    The module’s file name

Version:    The numeric version code (for example, 3.51.0.1057)
Often given as <major>.<minor>.<revision>.<build>.

Date:    The date that the DLL was produced (“build” date)

Size:    Size of the file in bytes

16-bit:    Usually indicates whether the module was designed for previous versions of Windows

Note
Some new module are 16-bit for compatibility reasons.
Path:    The file name, including the full specification of its location



Custom DLLs

Lists the file name, version number, date stamp, file size, and build number of each DLL in a user-specified directory and 
determines whether it's loaded in memory. This category is activated by the /C command-line option, for example:

msinfo32 /c [My DLL’s] c:\mydir    (Be sure to include the square brackets.)



CD-ROM

Displays a wide range of information about your CD-ROM drive(s). In addition to showing the drive and volume identification, this
includes the results of a few performance tests. The tests estimate sustained data transfer rate with the percentage of CPU 
utilization under a simulated workload and check for data transfer integrity.



Disclaimer regarding CD-ROM tests.

The tests incorporated into the CD-ROM category are not meant to convey definitive performance results. They are included to 
provide Microsoft PSS with a rough indication of drive performance, in case this might be causing problems.



Items for CD ROM Category

Each item represents a local CD-ROM drive on your system. The numerous columns displayed are as follows:

Drive:    The logical drive letter assigned to the drive

Volume:    The identifier for the CD currently in the drive

Total Space:    The disk space, in kilobytes, allocated on the current CD

Transfer File:    The file used for testing transfer rate

Transfer Size:    Size of the transfer file in bytes

Data Transfer Rate: Estimated rate for sustained data transfer

CPU Util @ 300KB/s: Estimated drive/driver CPU utilization when accessing data at 300 kilobytes per second (the MPC II 
standard) under a simulated workload

Integrity File:    File used for checking drive data transfer integrity

Integrity Size: Size of the integrity file in bytes

Data Transfer Integrity:    Indicates whether the test file was read successfully

Device:    Operating system hardware identifier for the CD-ROM drive

Description: Manufacturer-specific description, usually indicating model number



Audio

Displays information about multimedia drivers for audio playback and recording. There are three general categories of driver 
shown: low-level drivers designed for specific sound cards; compressor/decompressor (CODEC) drivers handled by the system 
Audio Compression Manager (ACM); and high-level drivers using the system Media Control Interface (MCI).



Items for Audio Category

Each item is for a wave driver on your system. Note that the driver usually has been assigned a unique subcategory in the 
category tree view. This main category shows all the drivers to facilitate comparisons. The following information is shown for 
each driver:

Key:    Unique identifier for the driver

Description:    Text description for the driver, supplied by the driver vendor

Group:    The type of driver, such as wave, MIDI, MCI, or ACM

Driver:    File for the driver executable

Status:    Group-specific status code, which might indicate if the driver is disabled

Version:    The numeric version code (for example, 2.5.0811) for the driver

Date:    The date that the DLL was produced (“build” date)

Size:    Size of the file in bytes

Loaded:    Indicates whether the driver is active (loaded in memory)

Tested OK?:    Indicates whether a test of the driver has been verified by the user 

See the Test command for testing requirements.



Video

Displays information about multimedia drivers for video playback. There are two general categories of driver shown: 
compressor/decompressor (CODEC) drivers handled by the system Installable Compression Manager (ICM); and high-level 
drivers using the system Media Control Interface (MCI). Note that the low-level drivers are part of the display adapter.



Items for Video Category

Each item is for a video driver on your system. Note that the driver usually has been assigned a unique subcategory in the 
category tree view. This main category shows all the drivers to facilitate comparisons. The following information is shown for 
each driver:

Key:    Unique identifier for the driver

Description:    Text description for the driver, supplied by the driver vendor

Group:    The type of driver, such as ICM or MCI

Driver:    File for the driver executable

Status:    Group-specific status code, which might indicate if the driver is disabled

Version:    The numeric version code (for example, 2.5.0811) for the driver

Date:    The date that the DLL was produced (“build” date)

Size:    Size of the file in bytes

Loaded:    Indicates whether the driver is active (loaded in memory)

Tested OK?:    Indicates whether a test of the driver has been verified by the user

See the Test command for testing requirements.



Test Media Driver command (Test menu)

Use this command to test the selected multimedia type with a media sample specified in the program profile. The sample must 
be appropriate for the given driver.

Note
The test command relies heavily on registry profiles for client programs (for example, Microsoft Encarta 96). 
These profiles indicate the samples appropriate for testing the drivers required by the program (usually on the 
client program’s CD). Be aware that without these profiles and supplied samples, most drivers will not be 
testable unless you have alternative samples of the appropriate type.



Cancel Media Test command (Test menu)

Use this command to cancel the ongoing multimedia test, bypassing the confirmation dialog box.

If you just want to proceed to the confirmation, stop the media playback, and close the dialog box.



Locate Media Sample command (Test menu)

Use this command to locate an alternative sample to test the current driver. This displays a standard file browsing dialog box. 
Afterwards, media testing will be initiated with the chosen file.

The chosen sample must represent an appropriate test or an error will be displayed.

Note
Some driver types are rarely used. Thus, you might not have a suitable sample available.



Configure Multimedia command (Test menu)

Use this command to open the Multimedia properties in Control Panel. Using this dialog box, you can configure current 
multimedia drivers.



Appropriate Samples.

To be an appropriate sample, the sample must be of a type specific to the driver. For CODECs, a further requirement is that the 
sample has been compressed in the driver’s main format. For example, to test Microsoft’s ADPCM audio CODEC, a wave file 
(.wav extension) must be available which has been compressed using the MS-ADPCM format. Just any wave file won’t suffice 
because many are encoded using "vanilla" PCM.



Pulse Code Modulation (PCM).

Pulse Code Modulation (PCM) is a simple scheme for encoding analog wave data in digital format. For 8-bit wave files, there are
256 unique levels for representing the analog amplitude. An extension to this, called Adaptive Differential Pulse Code Modulation
(ADPCM), compresses the samples by encoding the difference in the PCM values for consecutive samples. Microsoft ADPCM 
and IMA ADPCM are two of many variations on the ADPCM theme.



Compressor/Decompressor (CODEC)

A compressor/decompressor driver, or CODEC, compresses multimedia data when recording to a disk file and later 
decompresses the data during playback. Multimedia titles use compression to conserve disk space. The savings can be 
significant, because multimedia files usually compress better than typical data files, given their regularity. Even on compact 
discs, compression is important, considering the large number of files that multimedia programs require.

Many sound cards and video adapters don’t support compressed samples, and those that do usually have a limited range. Thus,
CODECs are used as intermediaries between the low-level drivers for the adapter card and the high-level drivers normally used 
for multimedia playback.



Compression

The process of transforming data into a compact form (suitable for long-term storage). This generally involves analyzing data for 
regularities and substituting more space-efficient codes (for example, ‘10000000001’ => ‘10*91’, where * precedes an 
occurrence count).



Bitness

Refers to the distinction between software written for 16 bit operating systems and software written for 32 bit operating systems. 
Some of the data gathered by Microsoft System Information may contain a column labeled ‘bit’ that will contain ‘Yes’ if that item is
determined to be 16 bit or blank if the item is 32 bit or not determined.



Available Physical Memory

This is the amount of free physical memory reported by Windows. It is not uncommon for this number to be very small or even 0 
KB and does not necessarily indicate a problem. Windows system processes may be using more of this memory simply because
it is not being used by other processes or applications. Windows defaults to using your hard disk as memory for applications and 
processes that are inactive and can allocate more memory from the hard disk when needed as long as there is some free space 
on the disk. If you are having memory problems check the Swap file setting, Swap file usage and Available space on drive C: 
settings under the System category.



To copy data

Activate the right-hand pane, click in the first column of the row(s) you want to copy, click the Edit menu, and then click Copy (or 
press CTRL+C).



To sort data

Activate the right-hand pane, and then click the heading of the column you want to sort. A second click toggles the sort order.



To save a report
On the File menu, click Save (or press CTRL+ S).



To print a report
On the File menu, click Print (or press CTRL+ P).



To show available space on network drives

1 Select the System category while holding the SHIFT key down. If you are already in this category, choose the Refresh 
command while holding the SHIFT key down.

2 To enable the display of network drives throughout the session, start Microsoft System Information with the /N command-line 
switch:

MSInfo32 /n

Note
By default, network drive space is not shown, to avoid network delays.



To test an audio driver

1 Select the Audio category to view installed audio drivers. 

2 From the list of installed drivers, click the driver you want to test. If there is a valid default sample to play, the Test button will 
be available. 

3 If the Test button is not available, you need to locate an alternative sample in order to test the driver.

If the Test button is available, click it to play the sample. If you hear the sample, the driver is configured correctly. If you do not 
hear the sample, check the volume setting for your speaker. Make sure your speakers are not set to mute or to a low volume 
setting.

4 If the volume settings are correct, you might need to configure the driver. Click Configure to display a dialog box for 
configuring the driver. 

If you do not know how to configure the driver, contact the manufacturer of your sound card or contact the technical support of
Windows or your computer.



To locate an alternative sample

1 If you need or want a different sample, click Locate to display a Browse dialog box. 

2 Once you find an alternative file, click the file, and then click Open. 

If the sample is of the correct format, the sample will play. If the sample is not correct, an error message appears, instructing 
you to locate another file.



To configure an audio driver

1 To configure an Audio driver, click the installed driver from the Audio category, and then click Configure. This displays the 
Multimedia properties in Control Panel (if you are running Windows 95) or the Drivers dialog box or a mapper dialog box (if 
you are running Windows NT).

2 In Windows 95, select the driver you need to configure, and then click Properties. 

Make sure the device is selected to be used by Windows. If the Settings button is available, click it to check the other settings 
for the device. If the device is a CODEC, changing the priority of the CODEC might enable the device work properly.

If you do not know how to configure the driver, contact the manufacturer of your sound card or contact the technical support of
Windows or your computer.

In Windows NT, click Setup. If there is an auto-configure button, click it to allow the driver to reset its settings.



To copy specific category data

1 Select the specific category you want to copy the information from.    

2 On the Edit menu, click Copy. This copies all the information that appears for that category to the Clipboard so you can paste 
it into a text editor.




