
Windows Media Author
Use Windows Media Author to build image files, audio files, and synchronized script commands into a
single file that can be streamed over a network. The software application creates .asf files that can be 
played locally or streamed from Windows Media Services over any type of network from a local area 
network (LAN) to the Internet.

Network bandwidth and other bottlenecks create limitations for .asf files; for example, an .asf file 
designed for a 100 kilobits per second (Kbps) network cannot be streamed to a user with a 28.8 Kbps
modem. This means that you should know the target network bandwidth when creating an .asf file. 
Once you know this target bandwidth, Windows Media Author makes it easy to build an .asf file.

You design .asf files by placing audio and image files in the timeline and arranging them based on 
when you want the audio to be heard and when the images should appear. Windows Media Author 
creates a diagram of how long it takes for each file to be streamed. Using this diagram, you can see 
whether your files can be built into an .asf file, whether you have attempted to include too much 
image or audio information for the bandwidth (this is displayed as an error), or whether you have 
enough bandwidth for more information. If there are errors or you do not like the layout of the image 
and audio files, use the conversion tools to edit the files. If you like how the audio and image files fit 
together, build and then view your .asf file. 

For additional information on the Advanced Streaming Format (ASF), Windows Media Services, or 
Microsoft Windows Media Player, see the Windows Media Services page at the Microsoft Web site.

Related Topics:

 Project Files
 Advanced Streaming Format (ASF)Overview



Advanced Streaming Format (ASF) Overview
The Advanced Streaming Format (ASF) combines audio, images, video, and script commands into a 
single streamable file format. An .asf file retains all forms of media and synchronization information, 
including any compression information, so that when users play the file over the network they see and
hear the file as the creator intended.

Microsoft Windows, Microsoft Windows NT, Windows Media Services, and any browser that you load,
all come with several audio and video compressors/decompressors (codecs). The .asf creation tools, 
such as Windows Media Author, can detect these codecs on your computer and allow you to use 
them to compress files.    The easiest way to make sure that most users can play your .asf file is to 
use the standard codecs included as part of the Windows Media Services installation. 

For Windows Media Author, the suggested codec to use for compressing images is loss tolerant 
JPEG, and the suggested codecs to use for compressing audio are SIPRO (an ACELP standard for 
voice) and MS Audio (for music). 

Related Topics:

 Predefined Bit Rates
 Overhead in an .asf File



Overhead in an .asf File
When you stream an .asf file, it must accommodate the needs of other applications for network 
bandwidth. One such need is the communication between the Web browser and Web server. This 
overhead is not part of the .asf file, but Windows Media Author must take it into consideration. 
Overhead cannot be deleted or modified. Windows Media Author allows for this overhead when 
representing how audio and image files stream across the bandwidth so you do not have to manually 
compensate for it when creating your .asf files. The allowance for overhead can cause rendering 
errors when using image and audio files that are within the upper limit of the specified bandwidth.

As a rule, approximately 12 percent of the total bandwidth is used for overhead; the rest is for the .asf 
file. For example, if you create an .asf file for streaming at 28.8 Kbps, the .asf file should take up no 
more than 25.3 Kbps. 

Related Topics:

 Predefined Bit Rates
 Advanced Streaming Format (ASF)Overview
 Correcting Errors
 Project Files



Predefined Bit Rates
Choose the bit rate that reflects the size of the smallest network bandwidth that the .asf file can be 
played over. The bit rate you choose influences the size and number of images you can include, as 
well as the size of the audio track. Windows Media Author has predefined these bit rates (each bit 
rate is in kilobits per second, or Kbps):

· 28.8 (for 28.8 modem Internet users)
· 56 (for intranets or ISDN lines)
· Custom (for LANs)
Custom refers to a bit rate that you create.

The two defined bit rates (28.8 and 56) correspond to the types of networks (or modems) that most 
people use.

Note: If you attempt to play an .asf file created for a higher network bit rate than what your network or
modem supports, gaps in the audio track can occur and images may render incompletely or not at all.

Related Topics:

 Create a bit rate 
 Set the project bit rate
 Overhead in an .asf File



Supported Audio and Image Types
Audio files can be any type of .wav file that uses an installed audio compression manager (ACM) 
codec. When you open Windows Media Author, it checks for any installed codecs on your computer 
and adds them to the list of available formats.

Convert all images to either loss tolerant JPEG or JPEG before converting them to ASF format. The 
source images can be any of the following items (represented by file name extension) before 
converting to JPEG format:

· .bmp or .dib (compressed or uncompressed)
· .gif (must be converted to any of the available conversion formats when adding them to the edit 

window)
· .jpg
· .rle
Note: Windows Media Author uses the actual file to determine file type, rather than the file extension.
Some compressed bitmaps may not use the .bmp extension.



Shortcut Menus
Windows Media Author contains two windows that use shortcut menus: edit (window with the timeline)
and content (window with the names of the files). The shortcut menu in the content window helps you 
add and remove files. Because the focus in the edit window is on editing the files so that they can be 
used to create an .asf file, the shortcut menu helps you stack, unstack, animate, and convert.



Project Files
Before you can create an .asf file, you must create a Windows Media Author project (.aep) file. 
Windows Media Author uses the .aep file to keep track of everything used to create an .asf file: the 
location of audio and image files, conversions made to these files, Uniform Resource Locators 
(URLs), bit rate setting, and so on.

Related Topics:

 Create a new project 
 Templates 



Create a new project

1 On the File menu, click New.
2 On the File menu, click Save as.
3 Choose a directory and project name.
Windows Media Author puts the project file in the directory specified. As you add files, Windows 
Media Author copies them to this directory. Only one project can be saved to any single directory.

Related Topics:

 Adding Files to the Project
 Project Properties
 Save a Project



Opening a Project
A project (.aep file) contains all the file information used in building an .asf file. The .aep file has 
references to all of the resources referenced in the project; such as media files script commands, and 
markers. When an .aep file is opened the existence of all of these resource in the project file directory
is verified. If any resources are missing a warning is given. 

It is especially useful to maintain a back up copy of your project directory after publishing an .asf file. 
That is because the only way to change an .asf file, is to open the project from which the .asf file was 
created and publish the .asf file again.

Related Topics:

 Project Files 
 Open a project 
 Create a new project



Open a project
1 On the File menu, click Open.
2 In the Open dialog box, choose a directory and project (.aep file).
3 Click Open.
Tip The four most recently used projects appear at the bottom of the File menu. To open a project 
you have used recently, click its name.

Related Topics:

 Save a Project 
 Adding Files to the Project
 Project Properties



Save a Project

1 On the File menu, click Save or Save As.
2 If you have not named your project yet, enter a name and directory for your project.

All project information is saved into the directory, including all temporary(.tmp) files. 

Related Topics:

 Templates
 Open a Project
 Project Properties



Temporary, or .tmp, files appear in the project directory. Windows Media Author creates these files to 
keep track of conversions of audio and image files, changes made to Windows Media Author settings,
and other editor-specific data. Do not delete or move these files from the directory where Windows 
Media Author puts them.



URLs
Adding Uniform Resource Locators (URLs) to a Windows Media Author project is a way of expanding 
the use of your .asf file. Using Windows Media Author, you can place URLs anywhere in an .asf file. 
Once you build the .asf file, the URLs become a part of the .asf file. When Microsoft Windows Media 
Player plays the part of the .asf file that contains the URL, the player recognizes the script command 
as a URL and passes that URL to the default browser, which then finds the Web page, image, or 
whatever is referenced.

If you want a URL to open in a specific Web page frame, you can specify the name of the frame as 
part of the URL. To specify the name of a Web page frame, Microsoft Windows Media Player should 
be embedded in the Web page. The name of the frame must be one of the other frames on the Web 
page. To add a target frame for the URL launch, append &&framename to the URL when added in 
the dialog box.

Use the Add URL dialog box to place a URL in the project. 

Related Topics:

 Adding a URL to the Project
 Script Commands



Adding a URL to the Project
URLs are considered script commands because they cause an action outside of Windows Media 
Player. Once you create a URL, it appears as a cyan block in the edit window.

 To add a URL to the project file:
1 On the Insert menu, click Add URL.

The Add URL dialog box appears.
2 In the Time box, type the time during the .asf file when you want the URL to appear. This time 

indicates when the URL will be sent to the browser. The URL will not appear instantly; you must 
allow for time delays in network traffic as the items download.

3 In the URL box, type the complete URL address. To add a target frame for the URL launch, append
&&framename to the URL when added in the dialog box. For example, 
http://www.microsoft.com&&topframe.

4 Click OK to add the URL to the edit window.
Script commands do not appear as files in the content window. To edit or open the script command,
right-click the cyan block and click Edit Script or use the Script List command under the Edit 
menu. This provides a list of all the URL commands and other script commands.

Related Topics:

 Script Commands
 URLs



Adding Files to the Project
When you add image and audio files to a project, they appear in the content window. Files in the 
content window are available but cannot be built into an .asf file until they are placed in the edit 
window. 

To add files:
· On the Insert menu, click Insert Media.

Related Topics:

 Supported Audio and Image Types
 URLs
 Assembling an ASF File



Removing Files from the Project
Use the Remove Media command to remove a file from the project file. Removing a file deletes any 
link to that file. If you want to use that file in the .asf file, you must add the file to the project again. 

To remove files:
1 Select the file in the content window.
2 On the Insert menu, click Remove Media.

Related Topics:

 Selecting Multiple Images
 Adding Files to the Project



Assembling an .asf File
Assemble an .asf file by arranging the images and audio in the edit window. 

To add audio or images to the edit window:
· Drag the file icon from the content window into the edit window.

Windows Media Author inserts a color-coded rectangular block (blue for images, green for audio, 
cyan for URLs, purple for captions, yellow for markers, and aqua for custom scripts).

Once you have placed files in the edit window, move them around and convert them as needed. To 
move a file, drag the block forward or backward in the timeline. 

Related Topics:

 Converting Media Files
 Adding Files to the Project
 Edit Window



Using Preview
While you are assembling files in the edit window, you can use the Preview set of commands to play 
the files or simulate playing the files. To use Preview Media, you must have at least one file in the 
edit window.

Preview Media does not test embedded script commands. To test script commands, you can use 
Preview Converted Media or Preview Project.

To use Preview Media:
· On the File menu, point to Preview and then click Media.

The Preview Media dialog box opens and begins playing the audio and rendering the images 
along the timeline, even if files are in error.

To use Preview Converted Media:
· On the File menu, point to Preview and then click Converted Media . You must first publish the 

project and create an .asf file before this command can be executed. This command launches the 
Microsoft Windows Media Player with the ASF created.

To use Preview Project:
· On the File menu, point to Preview and then click Project . You must first publish the project 

and create an .asf file and HTML pages before this command can be executed. This command
launches your default browser with the .asf and HTML files created. 

Related Topics:

 Correcting Errors
 Assembling an ASF File
 Publishing



Publishing
The process of publishing packages all the information in your Windows Media Author project file into 
a series of files, that can be streamed to your audience. You must publish your project at least once, 
before you can preview either your converted media or your project.

You do not need to publish your project after each change. You only need to publish your project 
when you want to preview new media you have converted since the last project or to preview your 
modification. You also need to publish your project a final time, before your project can be streamed 
to your audience.

To use Publish:
1 On the File menu, click Publish.

This displays the Publish dialog box.
2 If you want to generate an .asf file, select the ASF file box.
3 Browse to the folder you want the file to be written to, and enter a name for the file. If the file name 

already exists, Windows Media Author warns that you are going to overwrite an existing file.
4 Set the Window Size. Select either:

· Use Largest. This provides the user the largest default window available.
· Custom. Type the height and width of the window in pixels in the boxes.

5 Determine which browsers you are publishing to, and configure the Internet Explorer and/or 
Netscape group boxes. For each browser you need to check the following boxes and specify a 
path and file name for the HTML files created: 
· The Frame Set Page, which is the master page that holds the player page. 
· The Player Page, which is the page to which your project is streamed with Microsoft Windows 

Media Player. 
6 Select the script templates you need to be streamed along with the .asf file. 
7 Click Finish. 

The files you selected (.asf, HTML, scripts) are generated and written to the directories you 
specified.

Related Topics:

 Script Commands
 Editing Script Commands
 Removing Script Commands



Errors
A red block pattern indicates files that are in error. A file in error attempts to fit too much information in 
a given bandwidth. For example, images may have too high a resolution or too many colors. 



Script Commands
Script commands are typically URLs or Filenames, but they can be any type of script command that 
you embed in the .asf file. Script commands are streamed in the .asf file to Microsoft Windows Media 
Player and are then picked up by event handlers and executed. 

The URL and Filename script commands are distinguished from other script commands because 
Windows Media Player contains the handlers to deal with these two types of script commands. 
Windows Media Player passes URLs to the default browser. Filename script commands can be .asf 
or .asx files or the name of executables. Windows Media Player knows how to handle .asf or .asx 
files. 

If you send other Filename script commands, be sure the computer that receives that script command
contains the proper event handlers. If the receiving Web page or application does not have the correct
event handlers to use the commands, the events are ignored, and the .asf file continues playing.

Script commands provide extensibility to .asf files. Use script commands to invoke URLs or 
additional .asf files. Script commands can also be used to control objects on the client. For complete 
information on what type of script commands you can send, see the Microsoft Windows Media Player 
Software Development Kit (SDK). 

Script commands are actually sent as a table in the header of the .asf file. This means that the more 
script commands sent, the longer it takes for the .asf file to begin rendering.

On the Insert menu, use the Add Captions, Add URL, and Add Custom Script commands to add 
script commands to the .asf file. On the Edit menu, use the Script List command to edit script 
commands in the .asf file. To delete a command, select the command and drag it out of the window.

Related Topics:

 Adding Script Commands
 Editing Script Commands
 Removing Script Commands



Grouping Files
The Group Left command on the Tools menu organizes images to prevent gaps during the 
streaming process. By using this command, all subsequent images will begin to stream when the 
previous image has finished.

For example, if you have two images, one that takes 10 seconds to stream and the other takes 4 
seconds, Group Left rearranges the images so that there is not space between the end of one image
stream to the beginning of the next.

To group images:
1 Select all images you want to group in the edit window.
2 On the Tools menu, click Group Left.



Adding Script Commands
To add script commands to an .asf file:

1 On the Insert menu, click Add Custom Script.
2 In the Add Custom Script dialog box, enter a Time for the command to be carried out, choose a 

Type (pick Filename from the pull-down menu or type one into this box), and specify the command 
in the Parameter box.
The URL command type indicates that you are going to type a URL for the command parameter, 
for example, http://server/file.htm. The Filename command type indicates that you are going to 
enter the path to a file such as an .asf, .asx, or other type of executable file, for example, 
mms://server/file.asf. If you want the script command to open in a frame, following the path, type 
&& and the name of the frame, for example, http://server/image.jpg&&FrameOne. 
If you do not specify URL or Filename as the command type, then anything you enter in the Type 
or Command box is treated as a text command. If you send text commands, be sure that the 
receiving browser has event handlers to handle the text commands. 
For more information, see the Microsoft Windows Media Player Software Development Kit (SDK).

3 Click OK.
The script command is placed in the edit window at the time you specified. Different script 
commands are represented by color coded blocks (cyan for URLs, purple for captions, yellow for 
markers, and aqua for custom scripts). 

Related Topics:

 Script Commands
 Editing Script Commands
 Removing Script Commands



Editing Script Commands
You can easily edit the script commands in the edit window.

To edit script commands:
1 On the Edit menu, click Script List.
2 The Script List dialog box appears.
3 To change properties of a script, select script from the list.
4 Edit the Data Script Type and Start Time boxes accordingly.
5 Click OK to apply the changes.
Repeat this procedure for each script you need to edit.

Related Topics:

 Script Commands
 Adding Script Commands
 Removing Script Commands



Removing Script Commands
To remove script commands:

1 Select the command in the Timeline window. 
2 Drag the command from the Timeline window to remove from the script.

The script command is deleted.
OR
1 Right click the command in the Timeline window. 
2 Choose Delete from the menu or press DELETE.

Related Topics:

 Script Commands
 Adding Script Commands
 Editing Script Commands



Correcting Errors
Errors occur when you attempt to stream more data than can fit in the bandwidth. There are several 
things you can do to resolve errors: 

· Reduce the amount of data that must be transmitted by converting the file.
· Move files along the timeline so that you are not trying to send as much data at one time.
· Remove the files from the edit window by dragging them back to the content window.
You may get an error because you are trying to make several images appear in rapid sequence. Fix 
these errors by stacking the images and setting an animation rate.

Related Topics:

 Stacking Images
 Animating Images
 Converting Media Files
 Building an ASF File
 Using Preview



Building an ASF File
As long as none of the files in the edit window is in error, you can publish (build) the .asf file. Before 
you publish the .asf file, test the file to see how it looks. If you still have errors in your .asf file, 
Windows Media Author will not compile the file. 

To publish an .asf file:
1 On the File menu, click Publish. 
2 From the Publish dialog box, specify which format(s) you would like to publish to.
3 Set the name(s) of the destination file(s).
4 Click Finish.

Related Topics:

 Using Preview
 Correcting Errors
 Playing ASF Files



Playing .asf Files
Windows Media Author uses Microsoft Windows Media Player to play .asf files. 

To play your .asf file from Windows Media Author: 
· On the File menu, point to Preview, then click Converted Media

Windows Media Author calls Windows Media Player, and Windows Media Player begins playing 
the .asf file.

For instructions on streaming .asf files over the Internet or an intranet, see the Windows Media 
Services page on the Microsoft Web site.

Related Topics:

 Building an ASF File



Templates
Templates allow you to copy the timing information from one .asf file to another within the same 
project. For example, if you want to create an .asf file for both 28.8 Kbps and 56 Kbps bit rates, you 
would first create the 56 Kbps version. Once you were satisfied with that version, you could copy all 
the timing information to the 28.8 Kbps version. All the same image positions, animations, and sounds
would appear in the 28.8 Kbps .asf timeline.

Note: When going from a higher bandwidth to a lower one, errors are likely to occur. You might need 
to do further compressing and adjusting to fit the same information into the smaller bandwidth. 

Related Topics:

 Use a template
 Correcting Errors



Use a template

1 On the File menu, click New to create a new project.
2 Start with the highest bit rate you want to compile your .asf file for. Go through the complete 

procedure for creating an .asf file.
3 When you are finished with the first .asf file, change the current bit rate by choosing from Bit Rates

on the toolbar or by clicking Bit Rate on the View menu.
Notice that the edit window is now empty.

4 On the Tools menu, click Template.
5 Click the bit rate of the first .asf file you created and then click OK.
All the samples you assembled in the first .asf file are now in the edit window of the second file. You 
can now work on correcting errors and can compile the .asf file for the new bit rate. Repeat this 
process for as many bit rates as you want.

Related Topics:

 Project Properties



Project Properties
The Project Properties dialog box contains three tabs (General, Project Bit Rates, and Bit Rate 
Properties), which allow you to enter specific types of information about your project. For more 
information about a specific tab, click the tab.



The General Tab
Use the General tab to add Title, Copyright, Author, Description, and Rating information to 
the .asf file. This information is built into the .asf file and can be viewed by the user while the .asf file 
is loaded. Users can view this information during file playback by right-clicking in the Windows Media 
Player window, clicking Properties, and then clicking the Clip tab. The information appears exactly as
you typed it.

Related Topics:

 Enter information in the General tab



Enter information in the General tab

1 On the File menu, click Properties.
2 Click the General tab.
3 Enter the information.



The Project Bit Rates Tab
Use the Project Bit Rates tab to create additional bit rates and to add and remove bit rates from the 
project.

For each bit rate, Windows Media Author does not use all available bandwidth. On average, expect 
Windows Media Author project to leave a 12 buffer in network bandwidth. This buffer can be for a 
variety of things including error correction and network traffic. If you create a custom bit rate, be sure 
to allow for a buffer.

Related Topics:

 Set the project bit rate
 Create a bit rate
 Add a bit rate to a project
 To remove a bit rate from a project



Create a bit rate

1 On the File menu, click Properties.
2 Click the Project Bit Rates tab.
3 Click Custom.

The Custom Bit Rate dialog box appears.
4 Enter a Name, Bit Rate, and Packet Size for the new project bit rate.

If you do not know the packet size, divide the bit rate by 80.
As a rule of thumb, the minimum packet size can be 64 and the maximum can be 65536.

5 Click OK.
This adds the bit rate to the Available list on the Project Bit Rates tab. 

Related Topics:

 Adding a bit rate to a Project
 Set the project bit rate



Add a bit rate to a project

1 On the File menu, click Properties.
2 Click the Project Bit Rates tab.
3 Select a bit rate from the Available list, and click Add to place that bit rate in the Used in Project 

list or double-click the bit rate in the Available list.
4 Click OK.

Related Topics:

 Create a bit rate
 Setting the project bit rate
 To remove a bit rate from a project
 Overhead in an .asf File



Set the project bit rate

On the Edit menu, point to Bit Rate, then click the bit rate you want.

Related Topics:

 Create a bit rate
 Add a bit rate to a project
 To remove a bit rate from a project



To remove a bit rate from a project:

1 On the File menu, click Properties.
2 Click the Project Bit Rates tab.
3 Select a bit rate from the Used in Project list, and click the Remove button to remove it or double-

click the bit rate in the Used in Project list.
4 Click OK.

Related Topics:

 Create a bit rate
 Set the project bit rate
 Add a bit rate to a project



The Bit Rate Properties Tab
Use the Bit Rate Properties tab to set specific properties for the project.

· Bit Rate. Select a bit rate. This is the same setting as the one that appears on the tool bar and the 
Bit Rate option on the Edit menu.

· Output File. Enter a name for the .asf file that you are creating. It is best if you give the .asf file 
an .asf extension.

· Window Size. The Use Largest option forces the Media Player window to be as big as the biggest
image in the project. The Custom option allows you to specify the size of the Microsoft Windows 
Media Player window. If you select Custom, enter a height and width.



Time Range
The yellow bar above the edit window indicates the time range. Tools such as Media Preview operate
only for the time indicated by the time range. To set the time range, drag the ends of the yellow bar to 
correspond to a shortened or lengthened time range. Set a time range when you want to use an 
amount of time less than the whole or you want to add more time to the timeline.

Related Topics:

 Setting Start Time/End Time
 Using Preview



Adjusting the Timeline
It is possible to lengthen or shorten the timeline manually in the Timeline Properties dialog box. The 
start and stop times affect test playback only. They do not affect the published .asf.

To adjust the Timeline:
1 From the Edit menu, click Set Time.
2 In the Set Time dialog box, type new values in the Start Time and Stop Time boxes. This changes

the start and stop times for test playback.
Related Topics:

 Setting Start Time/End Time
 Configuring Timeline Properties



Configuring Timeline Properties
Use the Timeline Properties dialog box to customize how the Timeline is displayed.

To customize the Timeline:
1 On the View menu, click Timeline Properties. 

The Properties dialog box appears.
2 Enter the length of time you want the Timeline to be in the Duration box. 

The duration is entered as HH:MM:SS.T, where HH stands for hours, MM for minutes, SS for 
seconds, and T for tenths of seconds.

3 Select either: 
· Collapsed to place all the same data types (that is, image, audio, markers, scripts) on a single 

line on the Timeline. 
· Expanded to place each data type you add on its own line on the Timeline. 

4 Click OK. 



Setting Start Time/End Time
You can modify the start and end times of your project directly from the edit window. The current time 
range is indicated by the yellow bar above the timeline.

To select a time range:
· Drag the ends of the yellow bar to correspond to a shortened or lengthened time range.
Related Topics:

 Time range
 Adjusting the Timeline



Go To
If your project is longer than two minutes, scrolling to a specific time in the project can be tedious. 
Instead, use the Goto Time command to move directly to a specified time or marker.

To use the Goto Time command:
1 On the Edit menu, click Goto Time. 

The Go To dialog box appears.
2 Enter a time or marker name and then click OK.

The time range in the edit window shifts so that the time or marker specified appears in middle of 
the edit window.

Related Topics:

 Time range
 Adjusting theTimeline



Stacking Images
Stacking images is a way of grouping multiple images so that you can manage multiple images more 
easily, animate images, and remove image errors.

All images in a stack will be part of a blue block. The rendering points for the images do not change 
when they are stacked. 

When you stack images that are in error, Windows Media Author preloads the image information for 
all images in the stack so that the images can be displayed at their specified rendering points. So that
all information can be loaded, Windows Media Author begins loading the image information on the 
Timeline prior to the rendering point.

Note: To stack images, the images must be adjacent on the timeline. There cannot be any space 
between the images in the timeline.

Related Topics:

 To stack images
 Correcting Errors
 Animating Images
 Grouping Files



To stack images:

1 Select the images to be stacked.
2 On the Edit menu, click Stack.

Windows Media Author adjusts the images so that they can be rendered at the specified points.
If a stack of images overlaps another image, either ahead of or behind the stack, you can fix the error 
by adding the image to the stack. Windows Media Author preserves the rendering location of the 
image you add and organizes the image data appropriately.



Unstack images
1 Select the stack of images that you want to unstack. 
2 On the Edit menu, click Unstack.

Windows Media Author returns the images to their previous locations. The images will be in error, 
and their rendering times will remain where they were before stacking.

Related Topics:

 To stack images
 Correcting Errors



Animating Images
The animation option allows you to specify how quickly stacked images are displayed. You must stack
images before animating them. 

When you animate images, keep in mind that Windows Media Author may need a lot of time prior to 
the point of animation to send image data. For this reason, it is a good idea to create your animations 
before you put images in their final positions.

Related Topics:

 To animate images
 To stack images



To animate images:

1 Click a stack of images in the edit window.
2 On the Edit menu, click Animate.
3 Specify a frames-per-second value.
Windows Media Author moves the objects in the stack so that they can be rendered quickly. It places 
an animation as early on the timeline as possible.



Selecting Multiple Images
Select multiple images to stack, move, or remove them from the edit window. When you select 
multiple images, they are only temporarily selected. When you click other images in the edit window, 
you deselect previously selected images.

To select files:
· In the space above the images, press the CTRL key and click the blocks you want to select. 

Related Topics:

 Animating Images
 Stacking Images



Converting Media Files
Because smaller bandwidths can place restrictions on the size of files, Windows Media Author 
provides conversion and editing tools to help you convert your audio and image files to a different 
format, size, colors used, or image quality. The Convert command is sensitive to the type of file 
selected: when you select the Convert command, the appropriate dialog box (Image vs. Audio) 
appears. You can convert the format or adjust the compression algorithm of any image or audio file in 
the edit window.

Related Topics:

 Size Field
 Image Conversion Dialog Box
 Audio Conversion Dialog Box



Colors Field
On the Colors pull-down menu, choose the colors that you want to assign to a selected image. The 
colors available in the list depend on the compression algorithm that you choose. For example, JPEG 
compression allows you to use either 256 colors of gray (8-bit) or 16 million colors (24-bit).



Size Field
The Size field allows you to edit the size (height and width) of a selected image. You make the bit size
of your images smaller by reducing their physical size, but this usually reduces clarity too. 

Note: Reducing the size of images reduces them only as they are streamed across the network. 
When the streamed images are rendered on the Microsoft Windows Media Player, they are stretched 
or shrunk to the size of the Windows Media Player window. If the streamed images are not the same 
size as the Windows Media Player window, the images can appear distorted.



Quality Field
The Quality field allows you to adjust the amount of compression that is used. JPEG is a lossy 
compression, which means that image quality is lost when the image is compressed and then 
decompressed with Microsoft Windows Media Player. The lower you set the quality, the more image 
data is lost.



Image Conversion Dialog Box
With the Image Conversion dialog box, you can convert the source images to either JPEG or Loss-
Tolerant JPEG. The following algorithms come with Windows Media Author:

· Loss-Tolerant JPEG
· JPEG
The Image Conversion dialog box also allows you to adjust the compression, size (height and 
width), number of colors, and quality factor (if available).

Related Topics:

 Convert an image file
 Size Field



Convert an image file

1 Select one or more image files in the edit window.
2 On the File menu, click Convert.

The Image Conversion dialog box appears.
3 Select either JPEG or Loss-Tolerant JPEG.
4 To adjust the size of the image, enter the desired height and width (in pixels).
5 To change the number of colors used, choose from the Colors menu.
6 Adjust the Quality factor.
Related Topics:

 Image Conversion Dialog Box
 Size Field
 Convert an audio file
 Image bar



Audio Conversion Dialog Box
Use the Audio Conversion dialog box to compress an audio file. The Audio Conversion dialog box 
lists the preferred compression formats:

· Internet 28.8 kb/s Voice
· Internet 28.8 kb/s Music
· Internet 56 kb/s Voice
· Internet 56 kb/s Music
Use Other Compression to create a custom audio conversion template. Custom templates let you 
use any of the codecs that exist on the computer. These codecs are listed in the Format pull-down 
menu. Use this dialog box to select the codec used to encode or compress the . Select the sampling 
rate for the audio conversion from the Attributes menu. Only attributes that fit in the current project 
bit rate are shown or enabled.

Related Topics:

 Convert an audio file



Convert an audio file

1 Select the audio file in the edit window.
2 On the Edit menu, click Convert.

The Audio Conversion dialog box appears.
3 Select a new format.

Either click one of the option buttons (preferred formats) or click Other Compression, and use the 
menus to select a format and attribute.

Related Topics:

 Audio Conversion Dialog Box
 Convert an image file
 Image bar



Add a marker

1 On the Insert menu, click Add Marker.
The Add Marker dialog box appears.

2 Enter a name for the marker and a time that the marker points to.
Read the Time field as HH:MM:SS.T where HH stands for hours, MM for minutes, SS for seconds, 
and T for tenths of seconds. After you click OK, the marker appears as a yellow bar in the edit 
window.

Related Topics:

 Markers
 Delete a Marker



Delete a marker
1 Select the marker block in the edit window.
2 Drag it out of the edit window.
OR
1 Right click the marker block in the edit window.
2 Choose Delete from the menu.

Related Topics:

 Markers
 Add a Marker



Markers
A marker is a pointer to a specific time in an .asf file. Markers are not required but they are helpful, 
especially if the .asf file is long. Users can quickly jump forward or backward to points in an .asf file 
using markers. Include as many markers in the .asf file as necessary, but be aware that depending on
where you put a marker, Microsoft Windows Media Player may still need to play a small portion of 
the .asf file to load the necessary data.

Related Topics:

 Add a marker



Content Window
The content window displays the contents of a project (.aep file), that is, the audio and image files that
are used to build the .asf file. Each file in the content window is listed with icons identifying its type. 
Files in the content window are always the original versions. As you begin creating your .asf file, you 
add files to the edit window and then convert those files. The files in the content window are not 
affected by these conversions. 

Quick Reference:
· To add files to your project, click .

· To insert files in your .asf file, drag them from the content window to the edit window.
· To get information about a file, move the mouse pointer over a file; the information is displayed in 
the Image bar. 
· To change the order of files in the content window, drag a file to a new position.
· To add a URL to the project, on the Insert menu click Add URL, and then type a URL.

Related Topics:

 Project Files



Edit Window
Use the edit window to create and/or edit an .asf file. The edit window depicts how files share the 
bandwidth selected for the project. 

The edit window contains a Gantt Bar timeline, which you can use to help you synchronize images or
other events with audio. When you add files to the edit window, they are displayed as blue (image) or 
green (audio) blocks. URLs appear as cyan blocks perpendicular to the timeline. Script commands 
appear as aqua blocks. The yellow bar above the timeline is the time range.

The length of the blocks shows how long it takes a file to finish streaming from the server to the client.

Related Topics:

 Converting Media Files



Image bar
The Image bar is split into two sections that display information about the audio and image files and 
URLs. The upper section displays information about files as they exist in the edit window; the lower 
section displays information about the files in their original state in the content window. Move the 
mouse pointer over a file to get its information. If the mouse pointer is over an image, a thumbnail of 
the image is displayed. 

The Image bar displays:

· File Path: the file name.
· Size: the size (in kilobits) of the object as it exists in the edit window.
· Current codec: for image files, displays the file format (JPG, BMP) and dimensions (with color-bit 

depth). For audio files, displays the file format (MS Audio, Truespeech) and length.
· Source codec: the original codec information of the file.



Zoom In
· On the View menu, click Zoom In.

The timeline in the edit window appears to expand and you see less total time on the timeline.



Zoom Out
· On the View menu, click Zoom Out.

The timeline in the edit window appears to condense and you see more time on the timeline.



Menus: File
The File menu contains the following commands:

· New, which creates a new project.
· Open, which opens an existing project.
· Save, which saves changes to the current project.
· Save As, which saves a project and prompts for a new name or path.
· Preview, which previews the following items:

Media, which plays media using original files.
Converted Media, which plays media using converted files.
Project, which plays project in browser.

· Publish, which creates an ASF file. 
· Properties, which opens the Properties dialog box, where you can change the properties of the 

project. 
· Exit, which exits Windows Media Author.



Menus: Edit
The Edit menu contains the following commands:

· Image List, which edits images in the image list.
· Audio List, which edits audio tracks in the audio list.
· Script List, which edits script commands in the script list.
· Marker List, which edits markers in the marker list.
· Stack, which groups two or more selected objects so that they render at the specified times. 
· Unstack, which separates a stack of objects.
· Animate, which animates the selected stack of images.
· Set Time, which enters a start and end time for the time range.
· Goto Time, which goes to a specific time or marker in the edit window.
· Bit Rate, which specifies the bit rate of the .asf file in the current project. 
· Convert, which converts the media you select.



Menus: Insert
The Insert menu contains the following commands:

· Insert Media, which adds media to your .asf file. 
· Remove Media, which removes media from your .asf file. 
· Add Marker, which adds markers to your .asf file. 
· Add Caption, which adds captions to your .asf file. 
· Add URL, which adds URLs to your .asf file. 
· Add Custom Script, which adds custom scripts to your .asf file. 



Menus: View
The View menu contains the following commands:

· Toolbar, which toggles the toolbar.
· Media Toolbar, which toggles the media toolbar.
· Status Bar, which toggles the status bar.
· Image Bar, which toggles the image bar.
· Gantt Bar, which toggles the Timeline Gantt bar.
· Zoom In, which increases the size of the timeline in the edit window.
· Zoom Out, which decreases the size of the timeline in the edit window.
· File View, which determines how the files are displayed in the edit window. You can select either 

Small Icon, Large Icon, List, or Details.
· Timeline Properties, which sets how the timeline is displayed. 



Menus: Tools
The Tools menu contains the following commands:
· Group Left, which moves selected images toward the left-most image in the current selection, 

removing any gaps between them.
· Template, which opens the Template dialog box. Template contains templates for various bit 

rates. Use templates to add all the data associated with a specific bit rate (such as 28.8) with an 
empty bit rate. This enables you to quickly build your .asf file instead of having to configure all the 
necessary settings.



Menus: Help
The Help menu contains the following commands:

· Help Topics, which displays the contents of this Help file.
· How to Use Help, which starts the Windows Help file about using Windows Help.
· About Microsoft Windows Media Author, which displays the Microsoft Windows Media Author

dialog box.
· About Digital Renaissance, which displays the Digital Renaissance dialog box.




