Programador de tareas

Puede utilizar el Programador de tareas para programar el momento de ejecución de comandos, programas o secuencias de comandos:

  • Antes de utilizar el Programador de tareas, consulte Lista de comprobación.
  • Si necesita Ayuda acerca de determinadas tareas, consulte Cómo.
  • Si desea obtener información general, consulte Conceptos.
  • Si necesita instrucciones para resolver problemas, consulte Solución de problemas.


Lista de comprobación del Programador de tareas

Lista de comprobación

En la siguiente tabla se enumeran las acciones que realizará con más frecuencia con el Programador de tareas. Si desea obtener una lista completa de las instrucciones del Programador de tareas, consulte Cómo.

Paso | Referencia
Antes de programar la ejecución de una tarea debe agregarla. | Programar una nueva tarea
Una vez creadas las tareas programadas puede cambiar la aplicación, el programa o las características de una tarea concreta. | Modificar una tarea programada
Puede quitar las tareas programadas que ya no necesite. | Quitar una tarea programada
Si se inicia una tarea programada mientras está utilizando el equipo, puede detenerla y reiniciarla más tarde. | Detener una tarea programada en ejecución
Puede detener o pausar temporalmente la ejecución de todas las tareas programadas y activarlas de nuevo más tarde. | Detener temporalmente todas las tareas programadas


Cómo...

  • Programar tareas
  • Administrar el Programador de tareas


Programar tareas
  • Iniciar el Programador de tareas
  • Programar una nueva tarea
  • Modificar una tarea programada
  • Quitar una tarea programada
  • Detener una tarea programada que está en ejecución
  • Ejecutar una tarea inmediatamente


Iniciar el Programador de tareas

Para iniciar el Programador de tareas

  • Para iniciar el Programador de tareas, haga doble clic en Mi PC y, después, en Tareas programadas.
  • Haga doble clic en Tareas programadas y después en Agregar tarea programada si desea abrir el Asistente para tareas programadas, que le guiará por el proceso de programar una tarea.


Programar una nueva tarea

Para programar una nueva tarea
  1. Inicie el Programador de tareas
  2. Haga doble clic en Agregar tarea programada.
  3. Siga las instrucciones del asistente para Agregar tarea programada.

Notas

  • Si desea configurar opciones avanzadas para la tarea, active la casilla de verificación Abrir propiedades avanzadas para esta tarea cuando haga clic en Finalizar en la última pantalla del asistente.
  • Si desea que una nueva tarea se repita cada vez que se ejecute, active la casilla de verificación Abrir propiedades avanzadas para esta tarea cuando haga clic en Finalizar en la última pantalla del asistente y, después, haga clic en la ficha Programación y haga clic en Avanzada.
  • Si la aplicación de la tarea necesita algún parámetro, active la casilla de verificación Abrir propiedades avanzadas para esta tarea cuando haga clic en Finalizar en la última pantalla del asistente y, después, haga clic en la ficha Tarea y escríbalos en Ejecutar, después de la ruta de acceso a la tarea.
  • Asegúrese de que la fecha y la hora del equipo son correctas. El Programador de tareas se basa en esta información para saber cuándo debe ejecutar las tareas programadas. Si desea comprobar o cambiar la fecha y la hora, haga doble clic en la hora actual, que aparece en la barra de tareas.


Modificar una tarea programada

Para modificar una tarea programada
  1. Inicie el Programador de tareas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee modificar y seleccione Propiedades.
  3. Elija una o varias de las siguientes opciones:
    • Para cambiar la aplicación que se ejecutará, escriba la ruta de acceso a la nueva aplicación en el cuadro de texto Ejecutar.
    • Para cambiar el programa de la tarea, haga clic en la ficha Programación.
    • Para personalizar la configuración de la tarea, haga clic en la ficha Configuración.

Notas

  • Si cambia la cuenta de usuario o el programa que se utilizarán, deberá proporcionar la contraseña correcta para la cuenta de usuario.
  • Si la aplicación de la tarea necesita utilizar parámetros de línea de comandos, escríbalos en el cuadro de texto Ejecutar, tras la ruta de acceso a la tarea.
  • Si la ruta de acceso a la aplicación de la tarea incluye espacios en blanco, escriba la ruta de acceso entre comillas dobles ("").
  • Asegúrese de que la fecha y la hora del equipo son correctas, ya que el Programador de tareas se basa en esta información para ejecutar las tareas programadas. Si desea comprobar o cambiar esta información, haga doble clic en el indicador de hora, que aparece en la barra de tareas.


Quitar una tarea programada

Para quitar una tarea programada
  1. Inicie el Programador de tareas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee quitar y haga clic en Eliminar.

Notas

  • Al quitar una tarea programada sólo se quita el programa de la lista de tareas programadas. No se quita del disco duro el archivo del programa.
  • También puede quitar una tarea programada mediante la tecla SUPR.


Detener una tarea programada que está en ejecución

Para detener una tarea programada que está en ejecución
  1. Inicie el Programador de tareas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee detener y haga clic en Finalizar tarea.

Notas

  • Si una tarea programada inicia otro programa, este comando sólo detendrá la tarea programada original, no la segunda tarea.
  • Para reiniciar una tarea detenida, haga clic con el botón secundario del mouse (ratón) en ella y, después, haga clic en Ejecutar.


Ejecutar una tarea inmediatamente

Para ejecutar una tarea inmediatamente
  1. Inicie el Programador de tareas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee iniciar y haga clic en Ejecutar.

Notas

  • Si desea detener la tarea, haga clic en Finalizar tarea en el menú Archivo.
  • Si no se ejecutó una tarea programada, haga clic en Ver registro en el menú Avanzadas para examinar el registro.


Administrar el Programador de tareas
  • Ver el registro de las tareas programadas ya finalizadas
  • Ver las tareas programadas en equipos remotos
  • Detener temporalmente todas las tareas programadas
  • Pausar el Programador de tareas
  • Configurar la cuenta de servicios At


Ver un registro de las tareas programadas finalizadas

Para ver un registro de las tareas programadas finalizadas
  1. Inicie el Programador de tareas.
  2. En el menú Avanzadas, haga clic en Ver registro.


Ver las tareas programadas en equipos remotos

Para ver las tareas programadas en equipos remotos
  1. En el escritorio, haga doble clic en Entorno de red.
  2. Haga doble clic en el equipo cuyas tareas programadas desee ver.
  3. Haga clic en Tareas programadas.

Notas

  • Sólo podrá ver las tareas programadas de un equipo remoto que utilice Windows si es un administrador de dicho equipo.
  • Puede modificar las tareas de un equipo remoto que utilice Windows si el equipo tiene instalado software de registro remoto y comparte el recurso x$, donde x es la unidad de disco duro en la que se encuentra la carpeta Tareas programadas. El equipo que ejecute Windows también debe incluir de forma específica su cuenta de usuario entre las que tienen acceso de registro remoto. Para especificar los usuarios que tienen acceso de registro remoto a un equipo con Windows, haga clic en Contraseñas en el Panel de control.


Detener temporalmente todas las tareas programadas

Para detener temporalmente todas las tareas programadas
  1. Inicie el Programador de tareas.

  2. En el menú Avanzadas, haga clic en Pausar Programador de tareas.

Notas

  • Este comando resulta útil si está ejecutando otro programa (como un juego) o instalando software y no desea que las tareas programadas se ejecuten al mismo tiempo.
  • Las tareas que deberían haberse ejecutado mientras el Programador de tareas está en pausa no se ejecutarán hasta la siguiente hora programada.
  • Para reanudar todas las tareas programadas, haga clic en Continuar con Programador de tareas en el menú Avanzadas.


Pausar el Programador de tareas

Para pausar el Programador de tareas
  1. Inicie el Programador de tareas.
  2. En el menú Avanzadas, haga clic en No seguir usando el Programador de tareas.

Nota

  • Al deshabilitar el Programador de tareas, las tareas programadas ya no se ejecutarán y el Programador de tareas no se iniciará automáticamente la próxima vez que inicie Windows.


Configurar la cuenta de servicios AT

Para configurar la cuenta de servicios AT
  1. Inicie el Programador de tareas.
  2. En el menú Avanzadas, haga clic en Cuenta de servicios AT.
  3. Haga clic en Esta cuenta y escriba la cuenta de usuario que utilizará para ejecutar las tareas programadas mediante el comando at.
  4. En los campos Contraseña y Confirmar contraseña, escriba la contraseña correcta para la cuenta.

Notas

  • El servicio AT sólo está disponible en Windows NT.
  • Opcionalmente, puede seleccionar Cuenta del sistema. Si lo hace, el Programador de tareas ejecutará las tareas creadas mediante el comando at con la cuenta LocalSystem, que requiere derechos de administrador.

  • La cuenta de usuario que especifique debe disponer de los permisos necesarios para ejecutar cualquier tarea programada mediante el comando at. Por ejemplo, si programa tareas que sólo puedan ejecutar los administradores, la cuenta de usuario deberá ser una cuenta de administrador.


Conceptos del Programador de tareas

Conceptos

Esta sección proporciona información general acerca del Programador de tareas:

  • Introducción al Programador de tareas
  • Utilizar el Programador de tareas
  • El Programador de tareas y el comando At
  • El Programador de tareas y la seguridad
  • Solución de problemas


Introducción al Programador de tareas

Con el Programador de tareas puede programar tareas (como Desfragmentador de disco) para que se ejecuten cuando mejor le convenga. Programador de tareas se inicia cada vez que se inicia Windows y se ejecuta en segundo plano.

Con Programador de tareas puede:

  • Programar una tarea para que se ejecute diaria, semanal o mensualmente, o en momentos determinados (por ejemplo, al iniciar el sistema).
  • Cambiar una tarea programada.
  • Detener una tarea programada
  • Personalizar la ejecución de una tarea a una hora programada.


Utilizar el Programador de tareas

El sistema operativo Windows instala automáticamente el Programador de tareas. Si desea utilizar el servicio de programación, haga doble clic en la carpeta Tareas programadas de Mi PC.

Para agregar tareas, haga doble clic en Agregar tarea programada, lo que iniciará el Asistente para tarea programada. Puede agregar tareas si arrastra secuencias de comandos, programas o documentos desde el Explorador de Windows o el escritorio hasta la ventana de Tareas programadas.

También puede utilizar el Programador de tareas para modificar, eliminar, pausar o detener las tareas ya programadas, para ver un registro de las tareas programadas ya finalizadas o para ver las tareas programadas en un equipo remoto.

Si desea obtener instrucciones detalladas acerca de la utilización del Programador de tareas, consulte Cómo.

Procedimientos recomendados para el Programador de tareas

En Windows puede utilizar el Programador de tareas para programar la ejecución de cualquier aplicación. Para sacar el máximo partido del Programador de tareas, asegúrese de que la fecha y la hora del equipo son correctas antes de agregar una tarea.


Utilizar Programador de tareas y el comando at

Programador de tareas y el comando At

Además del Programador de tareas, también puede utilizar el comando at para ejecutar automáticamente tareas.

El Programador de tareas y el comando at no son iguales, pero ambos funcionan conjuntamente. Si programa una tarea con el comando at, aparecerá en la lista de tareas de la ventana Programador de tareas.

Puede utilizar el Programador de tareas para modificar las propiedades de una tarea programada con el comando at. Sin embargo, si lo hace, deberá seguir utilizando el Programador de tareas para tener acceso a la tarea. Ya no podrá tener acceso a ella mediante el comando at.

Para especificar la cuenta de usuario que ejecutará las tareas programadas mediante el comando at, haga clic en Tareas programadas en Mi PC y, en el menú Avanzadas, haga clic en Cuenta de servicios AT.

Nota

  • El servicio AT sólo está disponible en Windows NT.


Seguridad del Programador de tareas

El Programador de tareas y la seguridad

Para configurar la seguridad en el Programador de tareas, asigne un nombre de usuario y una contraseña a cada tarea concreta. Una vez configurados, ningún otro usuario podrá cancelar o eliminar la tarea.

Notas

  • Esta característica de seguridad sólo está disponible en Windows NT.
  • Antes de continuar con la programación de la tarea debe escribir un nombre de usuario en el Asistente para tareas programadas. No se necesitan contraseñas.
  • Para cambiar o configurar una nueva contraseña, active la casilla de verificación Abrir propiedades avanzadas para esta tarea cuando haga clic en Finalizar en la última pantalla del asistente.


Solución de problemas del Programador de tareas

Si una tarea programada no se ejecuta en el momento esperado, haga clic con el botón secundario del mouse (ratón) en ella y seleccione Propiedades. En la ficha Tarea, compruebe si la casilla de verificación Habilitada está activada. En la ficha Programación, compruebe si el programa es correcto.

Si la aplicación de una tarea no se ejecuta correctamente, es posible que necesite agregar opciones adicionales a la línea de comandos. Si desea obtener más información acerca de una aplicación y de sus opciones de línea de comandos, intente:

  • Si está disponible, vea la Ayuda en pantalla de la aplicación.

  • En la Interfaz de comandos, escriba: (donde aplicación es el nombre de la aplicación)

    • aplicación /?


Componente de Windows NT no instalado

No se pudo iniciar el programa.

Puede haber varios motivos:

    • Lo quitó un administrador del sistema.
    • El administrador del sistema cambió la directiva asociada al archivo.
    • El programa no está instalado en el equipo.
    • Se eliminó por error.
    • El archivo está dañado

Si hay un administrador del sistema encargado de su equipo, póngase en contacto con él para averiguar por qué no puede iniciar el programa.