Programar tareas para que se ejecuten regularmente

El Programador de tareas es una herramienta que le permite establecer el momento de ejecución de programas (como Desfragmentador de disco) y de otras utilidades para que se ejecuten regularmente cuando le resulte más conveniente. El Programador de tareas se inicia cada vez que inicia Windows y se ejecuta en segundo plano.

También puede abrir el Programador de tareas si hace clic en Inicio, selecciona Programas, Accesorios, Herramientas del sistema y, a continuación, hace clic en Tareas programadas.

Abrir el Programador de tareas le permite:

  • Programar una tarea para que se ejecute diaria, semanal o mensualmente, o en determinados momentos, por ejemplo al iniciar el equipo o cuando éste está inactivo.
  • Desactivar o cambiar la programación de una tarea existente.
  • Personalizar la manera en que se ejecutará una tarea a la hora programada.


Para programar una tarea nueva

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. Haga doble clic en Agregar tarea programada.
  3. Siga las instrucciones del Asistente para nueva tarea programada.

    4. Si desea especificar una configuración avanzada para la tarea (como configurarla para que se ejecute de forma repetida cada vez que se ejecuta) active la casilla de verificación Abrir propiedades avanzadas en la pantalla final del asistente.

Notas

  • Si es necesario especificar algún parámetro para el programa de tarea, active la casilla de verificación Abrir propiedades avanzadas para esta tarea cuando haga clic en Finalizar en la pantalla final del asistente, haga clic primero en Finalizar y, a continuación, en la ficha Tarea y, por último, escriba los parámetros correspondientes en el cuadro Ejecutar, después de la ruta de acceso de la tarea.
  • Si el equipo está encendido se ejecutará una tarea programada, independientemente de si se ha iniciado alguna sesión en Windows o no. Si no desea que se ejecuten las tareas cuando no se ha iniciado ninguna sesión, abra la carpeta Tareas programadas antes de cerrar la sesión, haga clic en el menú Avanzado y, a continuación, haga clic en No seguir usando el Programador de tareas. Para continuar utilizando el Programador de tareas después de volver a iniciar sesión, abra la carpeta Tareas programadas, haga clic en el menú Avanzado y, a continuación, haga clic en Iniciar el uso de Programador de tareas.
  • Asegúrese de que la fecha y hora del sistema especificadas en su PC son exactas. El Programador de tareas se basa en esta información para saber exactamente cuándo debe ejecutar las tareas programadas. Para cambiar la fecha y la hora, haga doble clic en la hora de la barra de tareas.

Temas relacionados


Para modificar una tarea programada

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee modificar y, a continuación, haga clic en Propiedades.
  3. Elija una o varias de las siguientes opciones:
    • Para cambiar el programa que desee ejecutar, en el cuadro Ejecutar, escriba la ruta de acceso de la tarea o haga clic en Examinar.
    • Para cambiar la programación de la tarea, haga clic en la ficha Programación.
    • Para personalizar la configuración de la tarea, haga clic en la ficha Configuración.

Notas

  • Si es necesario especificar parámetros para el programa de la tarea, escríbalos en el cuadro Ejecutar, después de la ruta de acceso de la tarea.
  • Si la ruta de acceso al programa de la tarea incluye espacios, escriba la ruta de acceso completa de la tarea entre comillas dobles (“).


Para quitar una tarea programada

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee quitar y después haga clic en Eliminar.

Nota

  • Al quitar una tarea programada sólo se elimina la tarea de la carpeta Tareas programadas. El programa asociado a la tarea no se quita del equipo.


Para detener una tarea programada que está actualmente en ejecución

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee detener y, a continuación, haga clic en Finalizar tarea.

Notas

  • Si una tarea programada inicia otro programa, este comando detiene sólo la tarea programada original, no la segunda tarea.
  • Para reiniciar una tarea, haga clic con el botón secundario del mouse en la tarea y después haga clic en Ejecutar.
  • Si el equipo está encendido se ejecutará una tarea programada, independientemente de si se ha iniciado alguna sesión en Windows o no. Si no desea que se ejecuten las tareas cuando no se ha iniciado ninguna sesión, abra la carpeta Tareas programadas antes de cerrar la sesión, haga clic en el menú Avanzado y, a continuación, haga clic en No seguir usando el Programador de tareas. Para continuar utilizando el Programador de tareas después de volver a iniciar sesión, abra la carpeta Tareas programadas, haga clic en el menú Avanzado y, a continuación, haga clic en Iniciar el uso de Programador de tareas.


Para ejecutar una tarea inmediatamente

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. Haga clic con el botón secundario del mouse (ratón) en la tarea que desee iniciar y después haga clic en Ejecutar.

Notas

  • Para terminar la tarea, haga clic en el menú Archivo y después haga clic en Finalizar tarea programada.
  • Si una tarea se debió ejecutar pero no se ejecutó, compruebe el registro para ver la causa. En el menú Avanzado, haga clic en Ver registro.


Para ver un registro de las tareas programadas ya realizadas

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. En el menú Avanzado, haga clic en Ver registro.


Para ver tareas programadas en un equipo remoto

  1. Haga doble clic en el icono Mis sitios de red.
  2. Haga doble clic en el equipo donde desee ver las tareas programadas.
  3. Haga doble clic en la carpeta Tareas programadas.

Nota

  • Puede modificar las tareas de un equipo remoto sólo si dicho equipo tiene instalado software de registro remoto y comparte el recurso x$, donde x es el disco duro en el que reside la carpeta Tareas programadas. El equipo también debe indicar específicamente que su cuenta de usuario tiene acceso de registro remoto. Para especificar qué usuarios tienen acceso de registro remoto a un equipo haga doble clic en el icono Contraseñas del Panel de control.


Para desactivar temporalmente todas las tareas programadas

  1. Si no está ya abierta, abra la carpeta Tareas programadas haciendo doble clic en imagen: el icono de programación de tareas en la barra de tareas.
  2. En el menú Avanzado, haga clic en Pausar Programador de tareas.

    Esto es útil si está ejecutando otro programa (como un juego) o instalando software, y no desea que las tareas se ejecuten al mismo tiempo.

Notas

  • Las tareas que debían ejecutarse mientras el Programador de tareas estaba en pausa no se ejecutan hasta la siguiente hora que tengan programada.
  • Para reanudar las programaciones de todas las tareas, en el menú Avanzado haga clic en Continuar con el Programador de tareas.


Para desactivar el Programador de tareas

  1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, después, haga clic en Tareas programadas.
  2. En el menú Avanzado, haga clic en No seguir usando el Programador de tareas.

Nota

  • Al desactivar el Programador de tareas, las tareas programadas no se ejecutarán y el Programador de tareas no se iniciará automáticamente la próxima vez que inicie Windows.


Solución de problemas del Programador de tareas

Si la tarea que ha programado no se ejecuta en el momento esperado, haga clic con el botón secundario del mouse (ratón) en la lista de tareas y después haga clic en Propiedades. En la ficha Tarea, asegúrese de que está activada la casilla de verificación Habilitada. En la ficha Programación, asegúrese de que la programación está establecida correctamente.

Si un programa de tarea no se ejecuta correctamente, puede que necesite proporcionarle argumentos de comando. Para averiguar más acerca de un programa y sus argumentos, intente lo siguiente:

  • Si el programa tiene Ayuda en pantalla, busque en esa Ayuda.
  • Pruebe a escribir lo siguiente en una línea de comandos, donde programa es el nombre del programa.
    programa /?


Para abrir la carpeta Tareas programadas.

  • Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, a continuación, haga clic en Tareas programadas.