
File Menu Commands
Use the scroll bar to see more information.
Open
Opens a hypergraphic.
When you open a hypergraphic, Hotspot Editor places the graphic in a new window. Other 
graphics that are open remain displayed in their own windows.
Related Topics
Creating a Hypergraphic
Opening a Hypergraphic
Close
Closes the current hypergraphic (the one displayed in the active window). If the 
hypergraphic is unsaved, Hotspot Editor lets you save it before closing the hypergraphic.
Save
Saves the current hypergraphic (the one displayed in the active window). 
When you choose Save, the hypergraphic remains open so you can continue working on it.
Save As
Saves a hypergraphic.
When you complete the Save As dialog box, you can do any of the following:
* Name a new hypergraphic.
* Save an existing hypergraphic under a new name.
* Save an existing hypergraphic under its original name.
Exit
Closes any hypergraphics and exits Hotspot Editor.
If any hypergraphic is unsaved, Hotspot Editor lets you save it before exiting.
1, 2, 3, 4
Opens the hypergraphic shown after the number. Lists the last four hypergraphics opened 
or saved.
Related Topics
Opening a Hypergraphic



Edit Menu Commands
Use the scroll bar to see more information.
Undo
Undoes your last edit.
You can undo:
* Changes to hotspots, including changes to attributes, size and position
* Deletions of hotspots (including cuts and deletes)
* Insertions of hotspots
Attributes
Changes hotspot attributes for the selected hotspot. 
Related Topics
Attributes Dialog Box
Changing Hotspot Attributes
Select
Displays a list of hotspots for the hypergraphic and allows you to select a hotspot by 
hotspot ID.
Related Topics
Select Dialog Box
Selecting Hotspots
Delete
Deletes the selected hotspot.
Related Topics
Changing Hotspots
Cut
Moves the selected hotspot to the Clipboard, replacing the previous Clipboard contents.
Related Topics
Changing Hotspots
Copy
Copies the selected hotspot to the Clipboard.
Related Topics
Changing Hotspots
Paste
Pastes the contents of the Clipboard. 
If the Clipboard contains a hotspot, the hotspot is pasted in the top-left corner of the 
hypergraphic. (If a hotspot is selected, the Paste command is unavailable.)
If the Clipboard contains a metafile or bitmap, Hotspot Editor creates a new hypergraphic 
and displays it in a new window.
Related Topics
Creating a Hypergraphic
Changing Hotspots
Preferences
Allows you to specify default hotspot attributes. Hotspot Editor automatically assigns these 
default attributes to new hotspots.



Related Topics
Preferences Dialog Box
Specifying Default Hotspot Attributes



Window Menu Commands
Use the scroll bar to see more information.
Cascade
Arranges windows so they overlap, starting in the upper-left corner of the Hotspot Editor 
window.
The title bar of each window remains visible, making it easy to select any window.
Tile
Arranges the windows side by side, so each window is visible and no windows overlap.
Arrange Icons
Arranges all icons in rows.
1, 2, 3, 4
Selects the window containing the specified hypergraphic.



Help Menu Commands
Use the scroll bar to see more information.
Contents
Displays the Help contents topic.
About
Displays version and copyright information.



Attributes Dialog Box
Changes the attributes for the selected hotspot. Click any control to get more information.

Related Topics
Changing Hotspot Attributes
Edit Menu Commands



Preferences Dialog Box
Changes default attribute settings. Click any control to get more information.

Related Topics
Specifying Default Hotspot Attributes
Edit Menu Commands



Select Dialog Box
Displays a list of hotspots for the hypergraphic. Click any control to get more information.

Related Topics
Selecting Hotspots
Edit Menu Commands



About Hotspot Editor
You use Hotspot Editor to create and edit hypergraphics. A hypergraphic is a bitmap that 
includes one or more hotspots. A hotspot can cover any portion of the bitmap. A bitmap 
can include multiple hotspots that link to Help topics or run Help macros when clicked.
Using Hotspot Editor, you can assign hotspots to a bitmap and assign attributes to each 
hotspot. Each hotspot includes the following attributes:
* Context string
* Link type (jump, pop-up, or macro)
* Visible or invisible hotspot borders
* Hotspot ID
Hotspot Editor saves hypergraphics in a special compressed file format. Hypergraphic files 
generally have a .SHG filename extension.



Using Hypergraphics
To include a hypergraphic in a Help topic, use one of the standard bitmap reference codes 
(bmc, bml, or bmr). The hotspots on the hypergraphic work like standard textual links in an 
RTF file.
Hotspots must reference valid context strings for a Help project. The Help compiler displays
a warning if the hotspot references a nonexistent context string.



File Open
Opens a bitmap or hypergraphic.
When you open a bitmap or hypergraphic, Hotspot Editor places the graphic in a new 
window. Other graphics that are open remain displayed in their own windows.
Related Topics
Creating a Hypergraphic
Opening a Hypergraphic
File Menu Commands



File Close
Closes the current hypergraphic (the one displayed in the active window). If the 
hypergraphic is unsaved, Hotspot Editor lets you save it before closing the hypergraphic.
Related Topics
File Menu Commands



File Save
Saves the current hypergraphic (the one displayed in the active window). 
The hypergraphic remains open so you can continue working on it.
Related Topics
File Menu Commands



File Save As
Saves a hypergraphic.
When you complete the Save As dialog box, you can:
* Name a new hypergraphic.
* Save an existing hypergraphic under a new name.
* Save an existing hypergraphic under its original name.
Related Topics
Creating a Hypergraphic
File Menu Commands



File Exit
Closes any hypergraphics and exits Hotspot Editor.
If any hypergraphic is unsaved, Hotspot Editor lets you save it before exiting.
Related Topics
File Menu Commands



File 1, 2, 3, 4
Opens the graphic shown after the number. Lists the last four graphics opened or saved.
Related Topics
Opening a Hypergraphic
File Menu Commands



Edit Undo
Undoes your last edit.
You can undo:
* Changes to hotspots, including changes to attributes, size and position
* Deletions of hotspots (including cuts and deletes)
* Insertions of hotspots
Related Topics
Selecting Hotspots



Edit Attributes
Changes the attributes for the selected hotspot. Click any control to get more information.

Related Topics
Changing Hotspot Attributes
Edit Menu Commands



Edit Select
Displays a list of hotspots for the hypergraphic. Click any control to get more information.

Related Topics
Selecting Hotspots
Edit Menu Commands



Edit Delete
Deletes the selected hotspot.
Related Topics
Changing Hotspots
Edit Menu Commands



Edit Cut
Moves the selected hotspot to the Clipboard, replacing the previous Clipboard contents.
Related Topics
Changing Hotspots
Edit Menu Commands



Edit Copy
Copies the selected hotspot to the Clipboard, replacing the previous Clipboard contents.
Related Topics
Changing Hotspots
Edit Menu Commands



Edit Paste
Pastes the contents of the Clipboard. 
If the Clipboard contains a hotspot, the hotspot is pasted in the top-left corner of the 
hypergraphic. (If a hotspot is selected, the Paste command is unavailable.)
If the Clipboard contains a metafile or bitmap, Hotspot Editor creates a new hypergraphic 
and displays it in a new window.
Related Topics
Creating a Hypergraphic
Changing Hotspots
Edit Menu Commands



Edit Preferences
Changes default attribute settings. Click any control to get more information.

Related Topics
Specifying Default Hotspot Attributes
Edit Menu Commands



Window Cascade
Arranges windows so they overlap, starting in the upper-left corner of the Hotspot Editor 
window.
The title bar of each window remains visible, making it easy to select any window.
Related Topics
Window Menu Commands



Window Tile
Arranges the windows side by side, so each window is visible and no windows overlap.
Related Topics
Window Menu Commands



Window Arrange Icons
Arranges all icons in rows.
Related Topics
Window Menu Commands



Window 1, 2, 3, 4
Selects the window containing the specified hypergraphic.
Related Topics
Window Menu Commands



Attribute
Specifies a default border style (visible or invisible) for new hotspots.



Context String or Macro
The name and contents of this field depend on the value of the Type field.
Type Value Contents
Jump or Pop-up Specifies a default context string for new hotspots. If you use standard 

context-string prefixes, you can use the prefix as the default context 
string.

Macro Specifies a default macro for new hotspots. When you create a hotspot, 
you can change the macro.



Hotspot ID
Specifies a default hotspot ID for new hotspots. When you create a new hotspot, Hotspot 
Editor appends a sequence number to this name and assigns the resulting ID to the new 
hotspot.



Type
Specifies a default link type (jump, pop-up, macro, or search key) for new hotspots.



Search Key
Specifies default link type search key for new hotspots. The search key link type is use only 
with certain help systems.



Macro
Specifies default link type macro for new hotspots. 



Attribute
Specifies the hotspot border style (visible or invisible).



Bounding Box
Specifies rectangle coordinates for the hotspot.



Context String or Macro
The name and contents of this field depend on the value of the Type field.
Type Value Contents
Jump or Pop-up Context String box. Specifies a context string for the hotspot.
Macro Macro box. Specifies a macro for the hotspot.



Hotspot ID
Specifies an optional hotspot name. The hotspot ID helps you identify the hotspot and is 
displayed in the Select dialog box. The hotspot ID is optional.



Type
Specifies the link type for the hotspot. A hotspot can have a jump link, pop-up link, or 
macro).



Attribute
Specifies the border style (visible or invisible) for the hotspot.



Context String or Macro
Specifies a Help topic context string or Help macro. The name and contents of this field 
depend on the value of the Type field.
Type Value Contents
Jump or Pop-up Context String box. Specifies a context string for the hotspot.
Macro Macro box. Specifies a macro for the hotspot.



Select
Closes the dialog box and selects the hotspot selected in the Hotspots box.



Type
Specifies the link type (jump, pop-up, or macro) of the selected hotspot.



Hotspots
Displays the list of hotspot IDs for the hypergraphic. 
When you select a hotspot ID, the hotspot attributes are displayed.
You can select a hotspot by selecting a hotspot ID and then choosing the Select button.



OK
Closes the dialog box and saves any changes made.



Cancel
Closes the dialog box without saving any changes made.



Context String
Specifies a default context string for new hotspots. If you use standard context-string 
prefixes, you can use the prefix as the default context string. When you create a hotspot, 
you can add the suffix to complete the context string.
Context String is present if Type is jump or pop-up.
Related Topics
Specifying Default Hotspot Attributes
Preferences Dialog Box



Macro
Specifies a default macro for new hotspots. When you create a hotspot, you can change the
macro.
Macro is present if Type is Macro.
Related Topics
Specifying Default Hotspot Attributes
Preferences Dialog Box



Search Key
Specifies default search keys for new hotspots. When you create a hotspot, you can edit 
the search keys.
Search Key is present if Type is Search Key. The search key link type is used only with 
certain help systems.
Related Topics
Specifying Default Hotspot Attributes
Preferences Dialog Box



Type
Specifies a default link type (jump, pop-up, or macro) for new hotspots.
Related Topics
Specifying Default Hotspot Attributes
Preferences Dialog Box



Attribute
Specifies a default border style (visible or invisible) for new hotspots.
Related Topics
Specifying Default Hotspot Attributes
Preferences Dialog Box



Hotspot ID
Specifies a default hotspot name for new hotspots. The hotspot ID can help you identify the
hotspot. Hotspot Editor appends a sequence number to this name and assigns the resulting
ID to the new hotspot.
Related Topics
Specifying Default Hotspot Attributes
Preferences Dialog Box



Context String
Specifies the context string of the Help topic to display when the user clicks the hotspot.
Context String is present if Type is jump or pop-up.
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Macro
Specifies the Help macro to run when the user clicks the hotspot.
Macro is present if Type is Macro.
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Search Keys
Specifies search keywords to associate with the hypergraphic.
Search Key is present if Type is Search Key. Search keys are used only with certain help 
systems.
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Type
Specifies the link type (jump, pop-up, or macro).
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Attribute
Specifies the hotspot border style (visible or invisible).
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Hotspot ID
Specifies an optional hotspot name. The hotspot ID helps you identify the hotspot and is 
displayed in the Select dialog box. 
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Bounding Box
Specifies rectangle coordinates for the hotspot.
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box



Hotspots
Displays the list of hotspot IDs for the hypergraphic. 
When you select a hotspot ID, the hotspot attributes are displayed.
You can select a hotspot by selecting a hotspot ID and then choosing the Select button.
Related Topics
Selecting Hotspots
Select Dialog Box





hotspot
A region of a graphic that is associated with an action. A hotspot has an associated link (a 
jump link, pop-up link, or macro link). When the user selects the hotspot, Help performs the
action. The specific action taken depends on the link type.



hypergraphic
A bitmap that includes one or more hotspots. Hotspots are regions that have an associated 
Help link or macro.



hotspot ID
An optional name for a hotspot. The author can use this name to identify a hotspot within 
the list of hotspots on the Select dialog box.



macro
A procedure for Help to run. A macro can include calls to Help functions and calls to 
functions defined in dynamic-link libraries registered with your Help project.
When the user selects a hotspot associated with a macro, Help runs the macro.



pop-up link
A link to a Help topic. When the user selects a hotspot associated with a pop-up link, Help 
displays a pop-up window containing the Help topic with the specified context string. 



jump link
A link to a Help topic. When the user selects a hotspot associated with a jump link, Help 
replaces the currently displayed topic with the Help topic with the specified context string.   



context string
A unique identifier for a Help topic. Help identifies each Help topic by its context string.



scroll bar
A bar that appears at the right and/or bottom edge of a window whose contents aren't completely visible.
Each scroll bar contains two scroll arrows and a scroll box, which allow you to scroll within the window or
list box.



search key
A search keyword displayed when the user chooses the Search command from Help. You 
can associate search keywords with a hypergraphic by including a hotspot of type search 
key on the hypergraphic.
Only certain help systems use search keywords in hypergraphics.





Creating a Hypergraphic
You can create a hypergraphic in two ways:
* By loading an existing bitmap file (.BMP or .DIB) or metafile (.WMF) and saving it in 

hypergraphic (.SHG) format
* By pasting a bitmap or metafile from the Clipboard and saving it in .SHG format
To load an existing graphic:
1 From the File menu, choose Open.
2 Enter the filename of the bitmap or metafile.
3 Choose OK.

Hotspot Editor opens the bitmap and displays it in a new window.
Related Topics
Opening a Hypergraphic
Creating Hotspots
To paste a bitmap or metafile from the Clipboard:
1 From the Edit menu, choose Paste.

Paste is available only if a valid graphic or hotspot is on the Clipboard.
2 Hotspot Editor displays the hypergraphic in a new window.
Related Topics
File Menu Commands
Opening a Hypergraphic
Creating Hotspots
To save a hypergraphic:
1 From the File menu, choose Save As.
2 Enter a filename for the new hypergraphic.
3 Choose OK.

Hotspot Editor saves the hypergraphic in .SHG format.
Related Topics
File Menu Commands
Creating Hotspots
Opening a Hypergraphic



Opening a Hypergraphic
To open a hypergraphic:
1 From the File menu, choose Open.
2 Enter the filename of the hypergraphic.
3 Choose OK.

Hotspot Editor opens the hypergraphic and displays it in a new window.
Related Topics
Creating a Hypergraphic
To open a hypergraphic that you worked on in a previous session:
* From the File menu, choose the name of the hypergraphic you want to open.



Specifying Default Hotspot Attributes
Hotspot Editor lets you specify default values for hotspot attributes. When you create a new
hotspot, these values are automatically assigned to the new hotspot. After creating a 
hotspot, you can change the attributes.
To assign default hotspot attributes:
1 From the Edit menu, choose Preferences.
2 Enter the default hotspot attributes.
3 Choose OK.
You can specify the following default attributes:
Attribute Description
Context string Specifies a default context string for new hotspots. If your Help project 

uses standard context-string prefixes, you can use the prefix as the default 
context string.

Type Specifies a default link type (jump, pop-up, or macro) for new hotspots.
Attribute Specifies a default border style (visible or invisible) for new hotspots. 
Hotspot ID Specifies a default hotspot ID for new hotspots. When you create a new 

hotspot, Hotspot Editor appends a sequence number to this name.
Related Topics
Preferences Dialog Box
Edit Menu Commands



Creating Hotspots
To create a hotspot:
* Drag across the region for the hotspot.

A selection cursor appears marking the hotspot boundaries.
Related Topics
Changing Hotspot Attributes
Changing Hotspots
To create a hotspot and display hotspot attributes:
* With the right mouse button, drag across the hotspot region.

A selection cursor appears marking the hotspot boundaries. 
When you release the mouse button, the Attributes dialog box appears.

Related Topics
Changing Hotspot Attributes
Changing Hotspots
Attributes Dialog Box
To copy a hotspot:
1 Select the hotspot to copy.
2 Choose Copy from the Edit menu.
3 Select the destination hypergraphic window.
4 Choose Paste from the Edit menu.

The hotspot is pasted in the upper-left corner of the current hypergraphic window.
Related Topics
Changing Hotspots
Selecting Hotspots



Selecting Hotspots
Hotspot Editor displays the attributes of the selected hotspot in the status area at the 
bottom of the main window. You can click on the following status-area hypergraphic to get 
an explanation of the fields:

The border of the selected hotspot includes sizing handles.
To select a hotspot using the mouse:
* Click the hotspot.
If the hotspot is enclosed in another hotspot, you won't be able to select the inside hotspot 
if the outermost hotspot is selected. Remove the selection from the outermost hotspot first 
(click outside the outermost hotspot).
To select a hotspot using the mouse and display the attributes:
* Double-click the hotspot.

Or, with the right mouse button, click the hotspot.
If the hotspot is enclosed in another hotspot, you won't be able to select the inside hotspot 
if the outermost hotspot is selected. Remove the selection from the outermost hotspot first 
(click outside the outermost hotspot).
Related Topics
Changing Hotspot Attributes
Attributes Dialog Box
To select a hotspot using the keyboard:
* Press TAB.

The selection moves to the next hotspot.
To select a hotspot using the Select dialog box:
1 From the Edit menu, choose Select.
2 In the Hotspots box, select a hotspot name.
3 Choose the Select button.
Related Topics
Select Dialog Box



Changing Hotspots
To change the hotspot shape using the mouse:
1 Select the hotspot.

Handles appear on the sides and corners of the hotspot.
2 Drag a side handle to move one side of the rectangle.

Or, drag a corner handle to move two sides of the rectangle. 
Related Topics
Selecting a Hotspot
To move a hotspot using the mouse:
1 Select the hotspot.
2 Drag the center of the hotspot to the desired location. 
Related Topics
Selecting a Hotspot
To change the hotspot shape or position using the keyboard:
1 Select the hotspot.
2 Press ENTER.
3 Change the Bounding Box values on the Attributes dialog box.
4 Choose OK.
Related Topics
Selecting a Hotspot
Attributes Dialog Box
To delete a hotspot:
1 Select the hotspot.
2 From the Edit menu, select Delete.

Or, to move the hotspot to the Clipboard, select Cut from the Edit menu.
Related Topics
Selecting a Hotspot



Changing Hotspot Attributes
Hotspot Editor displays the attributes of the selected hotspot in the status area at the 
bottom of the main window. You can also display the Attributes dialog box for a hotspot; 
this displays the hotspot attributes and allows you to change the attributes.
To change hotspot attributes:
1 Double-click the hotspot.

Or, with the right mouse button, click the hotspot. 
2 Enter the attribute values.
3 Choose OK.
The attributes are as follows:
Attribute Description
Context string Specifies the context string of the linked Help topic. Context string is 

present when Type is Jump or Pop-Up.
Macro Specifies a help macro. Macro is present when Type is Macro.
Type Specifies the hotspot link type (jump, pop-up, or macro).
Attribute Specifies the hotspot border style (visible or invisible).
Hotspot ID Specifies an optional hotspot name. This allows you to identify the 

hotspot and is displayed in the Select dialog box.
Bounding box Specifies rectangle coordinates for the hotspot.
Related Topics
Attributes Dialog Box
Selecting a Hotspot
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Hotspot Editor Keys
Key Function
F1 Displays Help.
ALT+BACKSPACE Undoes last edit.
DEL Deletes the selected hotspot.
SHIFT+DEL Moves the selected hotspot to the Clipboard.
CTRL+INS Copies the selected hotspot to the Clipboard.
SHIFT+INS Inserts the Clipboard contents. 

If the Clipboard contains a graphic, creates a new hypergraphic. 
If the Clipboard contains a hotspot, inserts the hotspot at the upper-left 
corner of the current window.

TAB Selects the next hotspot.
ENTER Displays the Attributes dialog box for the selected hotspot.
SHIFT+F5 Cascades the open windows.
SHIFT+F4 Tiles the open windows.




