XPCompression: Main Page

XPCompression Documentation

1

Generated on Sun Oct 30 01:12:27 2005 for XPCompression by doxygen 1.4.1


XPCompression: File Index

XPCompression File List

Here is a list of all documented files with brief descriptions:
XPCompression.h [code]
Generated on Sun Oct 30 01:12:27 2005 for XPCompression by doxygen 1.4.1


XPCompression: Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
RNReplicaNet::XPCompression
Generated on Sun Oct 30 01:12:27 2005 for XPCompression by doxygen 1.4.1


XPCompression: RNReplicaNet::XPCompression Class Reference

RNReplicaNet::XPCompression

RNReplicaNet::XPCompression Class Reference

#include <XPCompression.h>

List of all members.

Public Member Functions

XPCompression ()
virtual | ~XPCompression ()
int | CalculateMaximumMemory (int size)
bool | Compress (void *source_data, int source_length, void *destination_data, int *destination_length, int level=10)
bool | Decompress (void *source_data, int source_length, void *destination_data, int *destination_length)

Detailed Description

A general purpose lossless compression and decompression class

Constructor & Destructor Documentation

RNReplicaNet::XPCompression::XPCompression ( )

The ctor performs some basic initialisation

virtual RNReplicaNet::XPCompression::~XPCompression ( ) [virtual]

The dtor makes sure everything is tidy

Member Function Documentation

int RNReplicaNet::XPCompression::CalculateMaximumMemory ( int size )

Given an input size calculate the maximum absolute worse case for the compressed output

Parameters:
size the size of the data
Returns:
the worse case output length

bool RNReplicaNet::XPCompression::Compress | ( | void * | source_data,
 |  | int | source_length,
 |  | void * | destination_data,
 |  | int * | destination_length,
 |  | int | level = 10
 | ) |

Compress a block of memory

Parameters:
source_data | the source data
source_length | the source data length in bytes
destination_data | the destination data
destination_length | the pointer to the destination data length in bytes to fill in
level | the compression level to use. 1 is fast and 10 is best but slower. The default for this parameter is 10
Returns:
true is no error else false for an error

bool RNReplicaNet::XPCompression::Decompress | ( | void * | source_data,
 |  | int | source_length,
 |  | void * | destination_data,
 |  | int * | destination_length
 | ) |

Decompress a block of memory

Parameters:
source_data | the source data
source_length | the source data length in bytes
destination_data | the destination data
destination_length | the pointer to the destination data length in bytes to fill in
Returns:
true is no error else false for an error

The documentation for this class was generated from the following file:
  • XPCompression.h
Generated on Sun Oct 30 01:12:28 2005 for XPCompression by doxygen 1.4.1


XPCompression: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

  • CalculateMaximumMemory() : RNReplicaNet::XPCompression
  • Compress() : RNReplicaNet::XPCompression
  • Decompress() : RNReplicaNet::XPCompression
  • XPCompression() : RNReplicaNet::XPCompression
  • ~XPCompression() : RNReplicaNet::XPCompression
Generated on Sun Oct 30 01:12:27 2005 for XPCompression by doxygen 1.4.1


XPCompression: Directory Hierarchy

XPCompression Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • ReplicaNetWork
    • RNXPCompression
      • Inc


XPCompression: C:/Work/ReplicaNetWork/ Directory Reference

ReplicaNetWork

ReplicaNetWork Directory Reference

Directories

directory RNXPCompression


XPCompression: C:/Work/ReplicaNetWork/RNXPCompression/ Directory Reference

RNXPCompression Directory Reference

Directories

directory Inc


XPCompression: C:/Work/ReplicaNetWork/RNXPCompression/Inc/ Directory Reference

Inc Directory Reference

Files

file XPCompression.h [code]


XPCompression: Member List

RNReplicaNet::XPCompression Member List

This is the complete list of members for RNReplicaNet::XPCompression, including all inherited members.

CalculateMaximumMemory(int size) | RNReplicaNet::XPCompression |
Compress(void *source_data, int source_length, void *destination_data, int *destination_length, int level=10) | RNReplicaNet::XPCompression |
Decompress(void *source_data, int source_length, void *destination_data, int *destination_length) | RNReplicaNet::XPCompression |
XPCompression() | RNReplicaNet::XPCompression |
~XPCompression() | RNReplicaNet::XPCompression | [virtual]


XPCompression: Class Members - Functions

  • CalculateMaximumMemory() : RNReplicaNet::XPCompression
  • Compress() : RNReplicaNet::XPCompression
  • Decompress() : RNReplicaNet::XPCompression
  • XPCompression() : RNReplicaNet::XPCompression
  • ~XPCompression() : RNReplicaNet::XPCompression
Generated on Sun Oct 30 01:12:27 2005 for XPCompression by doxygen 1.4.1


XPCompression: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


XPCompression: XPCompression.h Source File

XPCompression.h

00001 /* START_LICENSE_HEADER
00002
00003 Copyright (C) 2000 Martin Piper, original design and program code
00004 Copyright (C) 2001-2005 Replica Software
00005
00006 This program file is copyright (C) Replica Software and can only be used under license.
00007 For more information visit: http://www.replicanet.com/
00008 Or email: info@replicanet.com
00009
00010 END_LICENSE_HEADER */
00011 #ifndef __XPCOMPRESSION_H__
00012 #define __XPCOMPRESSION_H__
00013
00014 namespace RNReplicaNet
00015 {
00016
00017 #define _XPCOMPRESSION_VERSION 5000
00018
00022 class XPCompression
00023 {
00024 public:
00028     XPCompression();
00029
00033     virtual ~XPCompression();
00034
00040     int CalculateMaximumMemory(int size);
00041
00051     bool Compress(void *source_data,int source_length,void *destination_data,int *destination_length,int level = 10);
00052
00061     bool Decompress(void *source_data,int source_length,void *destination_data,int *destination_length);
00062
00063 private:
00064 };
00065
00066 } // namespace RNXPCompression
00067
00068 #endif
Generated on Sun Oct 30 01:12:27 2005 for XPCompression by doxygen 1.4.1