ROLCompiler: RNROLCompiler Index Page

RNROLCompiler Index Page

1

Introduction

RNROLCompiler is a utility to aid in creating the files needed to enable classes to use the ReplicaNet replica object interface.

Using RNROLCompiler

The compiler is called RNROLCompiler.exe and is in the RNROLCompiler\bin directory.

Command line parameters

The compiler takes an input file and two optional output files. If no output files are given then the input ROL filename is used to generate the output CPP and H file names. For example RNROLCompiler.exe <input.rol> <output.cpp> <output.h>
The output cpp and h files can then be included in a project.
Verbose output while compiling can be switched on using the -vx command where 'x' is a number from 0 to 3.
-v0 Turns off verbose output
-v1 Turns on compile time display
-v2 Adds class parsing and compiling status
-v3 Adds what files are being opened and closed

The ROL Language and using it with development tools

The syntax processing of the language is fairly relaxed so that parameters can be included in brackets or not. For example:
 Function AMemberFunction;
and
 Function (AMemberFunction);
are equivalent

The preprocessor commands:

#include "Object.lang"			// This includes the file Object.lang
#includeclass object			// This includes the "object" class
Can be used to include files or class names. It is usually not neccassary to use the include directives since the RNROLCompiler will search for class definitions automatically.

The standard language include files used by the compiler for definitions of certain base types are located in RNROLCompiler\lang. The standard types can be extended and extra comands added by creating extra 'lang' files or by including the definitions in 'rol' files. For example:
In a file called MyDatablock.lang

class MyDatablock : std_datablock
{
    MyDatablock(x)						_MY_REGISTER_MACRO(x);

    SetError(x)							_MY_REGISTER_MACRO_SETERROR(x);

    SetDeltaV1(x)						_MY_REGISTER_MACRO_SETDELTAV1(x);
};

And in an object rol file

object TestExtension
{
    datablock MyDatablock;

    networking
    {
        MyDatablock mPosition.x;
    }
}
The worked examples in the ReplicaNet SDK show how to extend datablocks in more detail.

To use the compiler with MS VC++ you can use custom build rules per file.
Example:
To build _RO_Object.rol and include this in the project use the custom build rule:
..\RNROLCompiler\bin\RNROLCompiler.exe $(InputName).rol $(InputName).cpp $(InputName).h
Or you could use: ..\RNROLCompiler\bin\RNROLCompiler.exe $(InputPath) $(InputName).cpp $(InputName).h
Or even use: ..\RNROLCompiler\bin\RNROLCompiler.exe $(InputPath)
And for the file output box use:
$(InputName).cpp
$(InputName).h
For MS VC++ 6.0 The carriage return between the cpp and h file is important otherwise MSVC will get confused with build dependency and may rebuild the output files unnecessarily.
Note: This assumes the RNROLCompiler directory is one directory 'below' your project build directory.

The tutorial section shows in much greater how to add these build rules to a ReplicaNet project. ROL Files must end with a blank line and a carriage return.

Example scripts

To define a class called 'Test' and tell ReplicaNet that it has three floats in the form of a struct Position
First define our class. This should be defined in a file called "Test.h"
#include "_RO_Test.h"

class Test : _RO_DO_PUBLIC_RO(Test)		// Note that we include the definition for the ReplicaNet class
{
public:
    Test() {};
    virtual ~Test() {};

    struct Position
    {
        float x,y,z;
    };

    Position mPosition;
};

This section should be saved in to a file called "_RO_Test.rol" and compiled with 'RNROLCompiler _RO_Test.rol _RO_Test.cpp _RO_Test.h'

object Test
{
    datablock Predict_Float;

    networking
    {
        Predict_Float mPosition.x;
        {
            SetMaxError(0.5f);
            SetInterpolationFilter(0.1f);
        }
        Predict_Float mPosition.y;
            SetMaxError(2.0f);
        Predict_Float mPosition.z;
    }
}
This will produce a _RO_Test.cpp and _RO_Test.h that can be included in the project<br>
To link in the object in to the ReplicaNet framework then create another file and use the 'application' keyword to include a reference to the class name.
This example should be saved in a file called "_Def_App.rol" and compiled with 'RNROLCompiler _Def_App.rol _Def_App.cpp _Def_App.h'
application
{
    object Test;
}
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
application
Function
NData
NDataAt
networking
object
Predict_Float
std_datablock
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: application Class Reference

application Class Reference

List of all members.

Public Member Functions

object (name)

Detailed Description

This keyword is used to define what C++ classes the ReplicaNet layer uses when running an application. For example:
application
{
    object TestObject1;
    object TestObject2;
}

Member Function Documentation

application::object ( name )

This keyword allows C++ class names that use the ReplicaObject mechanism to be registered with ReplicaNet

Parameters:
name The name of the C++ class to register

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Function Class Reference

Function Class Reference

Inheritance diagram for Function:

[legend]
Collaboration diagram for Function:

[legend]
List of all members.

Public Member Functions

Function (name)

Detailed Description

This datablock handles members functions in C++ classes that need to shared across the network
The class inherits from the std_datablock type. See the ReplicaNet documentation for more details of this datablock type.

Constructor & Destructor Documentation

Function::Function ( name )

The name of the function to share across the network. For example:

        networking
        {
            Function AMemberFunction;
        }

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: NData Class Reference

NData Class Reference

Inheritance diagram for NData:

[legend]
Collaboration diagram for NData:

[legend]
List of all members.

Public Member Functions

NData (memberVariable)
DisableEndianTest ()

Detailed Description

This datablock type handles changes for member variables that contain data types that do not need to have prediction and extrapolation. For example these types could be ints or shorts. See the ReplicaNet documentation for more details of this datablock type.

Constructor & Destructor Documentation

NData::NData ( memberVariable )

Use this keyword to define a member variable that is to be used. For example:

        NData mAnIntMemberVariable

        or

        NData mAnIntMemberVariable
        {
            Reliable();			// Makes the datablock use the reliable method
        }

Member Function Documentation

NData::DisableEndianTest ( )

Use this keyword to disable the endian test for this area of memory. This useful for preserving string data for example.

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: NDataAt Class Reference

NDataAt Class Reference

Inheritance diagram for NDataAt:

[legend]
Collaboration diagram for NDataAt:

[legend]
List of all members.

Public Member Functions

NDataAt (memberVariable)
DisableEndianTest ()

Detailed Description

This datablock type handles changes for array types of member variables that contain data types that do not need to have prediction and extrapolation. For example char[16]. See the ReplicaNet documentation for more details of this datablock type.

Constructor & Destructor Documentation

NDataAt::NDataAt ( memberVariable )

Use this keyword to define a member variable that is to be used. For example:

        NData mAMemberVariable;

        or

        NData mAMemberVariable
        {
            Reliable();			// Makes the datablock use the reliable method
        }

        This would be used from a C++ member variable of the type:
        char mAMemberVariable[16];

Member Function Documentation

NDataAt::DisableEndianTest ( )

Use this keyword to disable the endian test for this area of memory. This useful for preserving string data for example.

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: networking Class Reference

networking Class Reference

Detailed Description

This class defines which elements of the ROL object are used in the networking code which will typically be datablocks and their corresponding variables.
For example:
object ATestClass
{
    datablock NData;

    networking
    {
        NData mSomeData;
    }
}

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: object Class Reference

object Class Reference

List of all members.

Public Member Functions

datablock (name)
datablockcustom (name)
addinclude (name)
extern (...)
ApproveMigration ()
ApproveFault ()
Reliable ()
Certain ()
Unreliable ()
SetLoadBalancing (bool enable)
SetLoadBalancingDefault (bool defaultValue)
SetLoadScore (float load)
SetLoadScoreDefault (float defaultLoad)
SetPropagateToSessionDistance (float distance)
SetPropagateToSessionDistanceDefault (float distance)
RealInclude (char *includeFile)
AddHeaderInclude (char *includeFile)
SetOpaqueType (char *baseClassType)

Detailed Description

The object class defines the object class framework to use. For example if a C++ class looks like this:
class ATestClass
{
    ATestClass() {};
    virtual ~ATestClass() {};
public:
    int mObjectHealth;      // This is going to be shared to all networked objects
};
If the class member variable is to be shared over the network then create a file called _RO_ATestClass.rol containing similar to code this:
object ATestClass
{
    datablock NData;

    networking
    {
        NData mObjectHealth;
    }
}
Then you can compile this file with the RNROLCompiler. The generated C++ files should then be included in your project. The C++ class definition should be changed to look like this:
class ATestClass : _RO_DO_PUBLIC_RO(ATestClass)
{
...
This is so your C++ class inherits from the generated RO class (Replicated Object) which is now aware of the network.
An alternative would be to not use the _RO_DO_PUBLIC_RO() macro and use this format instead:
class ATestClass : public _RO_ATestClass
{
...
Note that the name used in the ROL file for the class has '_RO_' added to the start of the name.

Member Function Documentation

object::AddHeaderInclude ( char * includeFile )

Parameters:
includeFile the filename of the include file for a header file. This command is most useful as a pre-ctor stage command. For example in an ROL file:
object > AddHeaderInclude("ATypeInclude.h") Test
Adds the header file "ATypeInclude.h" to the header file of the compiled ROL output.

object::addinclude ( name )

This keyword add an include file to the ReplicaObject.

Parameters:
name the name of the include file with or without path to add to the object. This then adds the include "xxxx" to the ReplicaObject derived class cpp file where xxxx is the name and optional path of the datablock used.

object::ApproveFault ( )

Makes this object fault tolerant

object::ApproveMigration ( )

Makes this object approve migration requests

object::Certain ( )

Makes the object update use the certain method

object::datablock ( name )

This keyword defines a datablock that is used in the object.

Parameters:
name the name of the datablock used in this object. This then adds the include "RNReplicaNet/Inc/DataBlock_xxxx.h" to the ReplicaObject derived class cpp file where xxxx is the name of the datablock used.

object::datablockcustom ( name )

This keyword defines a custom datablock that is used in the object.

Parameters:
name the name of the datablock used in this object. This then adds the include "DataBlock_xxxx.h" to the ReplicaObject derived class cpp file where xxxx is the name of the datablock used.

object::extern ( ... )

This keyword defined a function prototype used in the C++ class that you want to be able to call across the network.

Parameters:
... The parameter prototype for a function used in a C++ class. For example you would use:
    extern AMemberFunction(int,float);
Which would correspond to a function is a C++ class such as:
    void AMemberFunction(int aParameter,float anotherParameter);

object::RealInclude ( char * includeFile )

Parameters:
includeFile the filename of the include file for the real class. This command is most useful as a pre-ctor stage command. For example in an ROL file:
object > RealInclude("RealTestObjectInclude.h") Test
Creates an object from an object called Test but uses the file name given as the include file for the real class include. Usually the object name is used as a hint for the real object include name.

object::Reliable ( )

Makes the object update use the reliable method

object::SetLoadBalancing ( bool enable )

Enables or disables load balancing for this ReplicaObject.

Parameters:
enable set this to true to enable load balancing. The default is false

object::SetLoadBalancingDefault ( bool defaultValue )

This sets the default value that the load balancing uses. Setting the default value in the object constructor to the same value that is set for the load balancing will result in a smaller data packet being sent.

Parameters:
defaultValue the value that is the default value. The default is false to match the parameter to SetLoadBalancing()

object::SetLoadScore ( float load )

Sets the object load unit score.. The definition of "load" units is left to the user. The default return value is 0.0f

Parameters:
load A "load" score for this object.

object::SetLoadScoreDefault ( float defaultLoad )

This sets the default value that the load balancing score uses. Setting the default value in the object constructor to the same value that is set for the load balancing will result in a smaller data packet being sent.

Parameters:
defaultLoad the value that is the default value. The default is 0.0f to match the parameter to SetLoadScore()

object::SetOpaqueType ( char * baseClassType )

Parameters:
baseClassType the base class of the class object. Instead of using ReplicaObject::SetOpaquePointer() or overriding ReplicaObject::GetOpaquePointer() to pass back an opaque pointer, you can use this method in the ROL file. For example if your game class called MonsterObject inherits from a base class called BaseGameObject you could use SetOpaqueType(BaseGameObject).
As long as the opaque pointer has not been set elsewhere in your code and the GetOpaquePointer() function has not been overridden then when you call ReplicaObject::GetOpaquePointer() the pointer returned will be a valid pointer for this class as if it had been cast to (BaseGameObject *). In effect it is the same as overriding ReplicaObject::GetOpaquePointer() to do { return (BaseGameObject*) ((MonsterObject*) this); };

object::SetPropagateToSessionDistance ( float distance )

This functions sets the distance that an object has to be within for it to be propagated relative to a session observer. If a session has an observer and the CalculateDistanceToObject() result is greater than the value specified then the session will not receive object updates. If a session has no registered observer then the object will always be propagated to that session. The default value for a ReplicaObject is to have this distance set to kReplicaObject_InfiniteDistance, which means that the object will always be propogated to a session. This function can only be used if the ReplicaObject is a master.

Parameters:
distance the distance to set, kReplicaObject_InfiniteDistance is the default value

object::SetPropagateToSessionDistanceDefault ( float distance )

This sets the default value that the propagate distance uses. Setting the default value in the object constructor to the same value that is set for the distance will result in a smaller data packet being sent when an object is published.

Parameters:
distance the value that is the default value. The default is kReplicaObject_InfiniteDistance to match the parameter to SetPropagateToSessionDistance()

object::Unreliable ( )

Makes the object update use the unreliable method

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Predict_Float Class Reference

Predict_Float Class Reference

Inheritance diagram for Predict_Float:

[legend]
Collaboration diagram for Predict_Float:

[legend]
List of all members.

Public Member Functions

Predict_Float (memberVariable)
SetError (float value)
SetMinError (float value)
SetMaxError (float value)
SetMinDistance (float value)
SetMaxDistance (float value)
SetInterpolationFilter (float value)
Quadratic ()
Linear ()

Detailed Description

This datablock type handles changes for member variables that contain float data type that do need to have prediction and extrapolation. See the ReplicaNet documentation for more details of this datablock type.

Constructor & Destructor Documentation

Predict_Float::Predict_Float ( memberVariable )

Use this keyword to define a member variable that is to be used. For example:

        Predict_Float mAFloatMemberVariable
        {
            SetMinError(1.0f);
        }

Member Function Documentation

Predict_Float::Linear ( )

Enable linear distance based extrapolation

Predict_Float::Quadratic ( )

Enable quadratic distance based extrapolation

Predict_Float::SetError ( float value )

Use this keyword to set the minimum and maximum error used by the data block.

Predict_Float::SetInterpolationFilter ( float value )

Use this keyword to set the interpolation filter used by the data block.

Predict_Float::SetMaxDistance ( float value )

Use this keyword to set the maximum distance used by the data block.

Predict_Float::SetMaxError ( float value )

Use this keyword to set the maximum error used by the data block.

Predict_Float::SetMinDistance ( float value )

Use this keyword to set the minimum distance used by the data block.

Predict_Float::SetMinError ( float value )

Use this keyword to set the minimum error used by the data block.

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: std_datablock Class Reference

std_datablock Class Reference

Inheritance diagram for std_datablock:

[legend]
List of all members.

Public Member Functions

Reliable ()
Certain ()
Unreliable ()
Manual ()
Automatic ()
SetUpdateDelayMinimum ()
SetForceSendMaximumUpdates ()
SetForceSendTimeDelay ()

Detailed Description

This ROL class defines the base mechanism used in all other datablocks. See the ReplicaNet documentation for a detailed description of datablocks.

Member Function Documentation

std_datablock::Automatic ( )

Sets the datablock updates to be automatic

std_datablock::Certain ( )

Makes the datablock update use the certain method

std_datablock::Manual ( )

Sets the datablock updates to be manual rather than automatic

std_datablock::Reliable ( )

Makes the datablock update use the reliable method

std_datablock::SetForceSendMaximumUpdates ( )

See DataBlock::SetForceSendMaximumUpdates() in the ReplicaNet documentation for details.

std_datablock::SetForceSendTimeDelay ( )

See DataBlock::SetForceSendTimeDelay() in the ReplicaNet documentation for details.

std_datablock::SetUpdateDelayMinimum ( )

See DataBlock::SetUpdateDelayMinimum() in the ReplicaNet documentation for details.

std_datablock::Unreliable ( )

Makes the datablock update use the unreliable method

The documentation for this class was generated from the following file:
  • ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Hierarchical Index

ROLCompiler Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

  • application
  • networking
  • object
  • std_datablock
    • Function
    • NData
    • NDataAt
    • Predict_Float
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AddHeaderInclude() : object
  • addinclude() : object
  • ApproveFault() : object
  • ApproveMigration() : object
  • Automatic() : std_datablock

- c -

  • Certain() : std_datablock, object

- d -

  • datablock() : object
  • datablockcustom() : object
  • DisableEndianTest() : NDataAt, NData

- e -

  • extern() : object

- f -

  • Function() : Function

- l -

  • Linear() : Predict_Float

- m -

  • Manual() : std_datablock

- n -

  • NData() : NData
  • NDataAt() : NDataAt

- o -

  • object() : application

- p -

  • Predict_Float() : Predict_Float

- q -

  • Quadratic() : Predict_Float

- r -

  • RealInclude() : object
  • Reliable() : std_datablock, object

- s -

  • SetError() : Predict_Float
  • SetForceSendMaximumUpdates() : std_datablock
  • SetForceSendTimeDelay() : std_datablock
  • SetInterpolationFilter() : Predict_Float
  • SetLoadBalancing() : object
  • SetLoadBalancingDefault() : object
  • SetLoadScore() : object
  • SetLoadScoreDefault() : object
  • SetMaxDistance() : Predict_Float
  • SetMaxError() : Predict_Float
  • SetMinDistance() : Predict_Float
  • SetMinError() : Predict_Float
  • SetOpaqueType() : object
  • SetPropagateToSessionDistance() : object
  • SetPropagateToSessionDistanceDefault() : object
  • SetUpdateDelayMinimum() : std_datablock

- u -

  • Unreliable() : std_datablock, object
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Directory Hierarchy

ROLCompiler Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • ReplicaNetWork
    • RNROLCompiler
Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: C:/Work/ReplicaNetWork/ Directory Reference

ReplicaNetWork

ReplicaNetWork Directory Reference

Directories

directory RNROLCompiler
Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: C:/Work/ReplicaNetWork/RNROLCompiler/ Directory Reference

RNROLCompiler Directory Reference

Files

file ROLCompilerDoc.cpp
Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Graphical Class Hierarchy

Go to the textual class hierarchy

Generated on Sun Oct 30 01:12:41 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

application Member List

This is the complete list of members for application, including all inherited members.

object(name) application

Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

Function Member List

This is the complete list of members for Function, including all inherited members.

Automatic() | std_datablock
Certain() | std_datablock
Function(name) | Function
Manual() | std_datablock
Reliable() | std_datablock
SetForceSendMaximumUpdates() | std_datablock
SetForceSendTimeDelay() | std_datablock
SetUpdateDelayMinimum() | std_datablock
Unreliable() | std_datablock

Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

NData Member List

This is the complete list of members for NData, including all inherited members.

Automatic() | std_datablock
Certain() | std_datablock
DisableEndianTest() | NData
Manual() | std_datablock
NData(memberVariable) | NData
Reliable() | std_datablock
SetForceSendMaximumUpdates() | std_datablock
SetForceSendTimeDelay() | std_datablock
SetUpdateDelayMinimum() | std_datablock
Unreliable() | std_datablock

Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

NDataAt Member List

This is the complete list of members for NDataAt, including all inherited members.

Automatic() | std_datablock
Certain() | std_datablock
DisableEndianTest() | NDataAt
Manual() | std_datablock
NDataAt(memberVariable) | NDataAt
Reliable() | std_datablock
SetForceSendMaximumUpdates() | std_datablock
SetForceSendTimeDelay() | std_datablock
SetUpdateDelayMinimum() | std_datablock
Unreliable() | std_datablock

Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

object Member List

This is the complete list of members for object, including all inherited members.

AddHeaderInclude(char *includeFile) | object
addinclude(name) | object
ApproveFault() | object
ApproveMigration() | object
Certain() | object
datablock(name) | object
datablockcustom(name) | object
extern(...) | object
RealInclude(char *includeFile) | object
Reliable() | object
SetLoadBalancing(bool enable) | object
SetLoadBalancingDefault(bool defaultValue) | object
SetLoadScore(float load) | object
SetLoadScoreDefault(float defaultLoad) | object
SetOpaqueType(char *baseClassType) | object
SetPropagateToSessionDistance(float distance) | object
SetPropagateToSessionDistanceDefault(float distance) | object
Unreliable() | object

Generated on Sun Oct 30 01:12:39 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

Predict_Float Member List

This is the complete list of members for Predict_Float, including all inherited members.

Automatic() | std_datablock
Certain() | std_datablock
Linear() | Predict_Float
Manual() | std_datablock
Predict_Float(memberVariable) | Predict_Float
Quadratic() | Predict_Float
Reliable() | std_datablock
SetError(float value) | Predict_Float
SetForceSendMaximumUpdates() | std_datablock
SetForceSendTimeDelay() | std_datablock
SetInterpolationFilter(float value) | Predict_Float
SetMaxDistance(float value) | Predict_Float
SetMaxError(float value) | Predict_Float
SetMinDistance(float value) | Predict_Float
SetMinError(float value) | Predict_Float
SetUpdateDelayMinimum() | std_datablock
Unreliable() | std_datablock

Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Member List

std_datablock Member List

This is the complete list of members for std_datablock, including all inherited members.

Automatic() | std_datablock
Certain() | std_datablock
Manual() | std_datablock
Reliable() | std_datablock
SetForceSendMaximumUpdates() | std_datablock
SetForceSendTimeDelay() | std_datablock
SetUpdateDelayMinimum() | std_datablock
Unreliable() | std_datablock

Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Class Members - Functions

- a -

  • AddHeaderInclude() : object
  • addinclude() : object
  • ApproveFault() : object
  • ApproveMigration() : object
  • Automatic() : std_datablock

- c -

  • Certain() : std_datablock, object

- d -

  • datablock() : object
  • datablockcustom() : object
  • DisableEndianTest() : NDataAt, NData

- e -

  • extern() : object

- f -

  • Function() : Function

- l -

  • Linear() : Predict_Float

- m -

  • Manual() : std_datablock

- n -

  • NData() : NData
  • NDataAt() : NDataAt

- o -

  • object() : application

- p -

  • Predict_Float() : Predict_Float

- q -

  • Quadratic() : Predict_Float

- r -

  • RealInclude() : object
  • Reliable() : std_datablock, object

- s -

  • SetError() : Predict_Float
  • SetForceSendMaximumUpdates() : std_datablock
  • SetForceSendTimeDelay() : std_datablock
  • SetInterpolationFilter() : Predict_Float
  • SetLoadBalancing() : object
  • SetLoadBalancingDefault() : object
  • SetLoadScore() : object
  • SetLoadScoreDefault() : object
  • SetMaxDistance() : Predict_Float
  • SetMaxError() : Predict_Float
  • SetMinDistance() : Predict_Float
  • SetMinError() : Predict_Float
  • SetOpaqueType() : object
  • SetPropagateToSessionDistance() : object
  • SetPropagateToSessionDistanceDefault() : object
  • SetUpdateDelayMinimum() : std_datablock

- u -

  • Unreliable() : std_datablock, object
Generated on Sun Oct 30 01:12:38 2005 for ROLCompiler by doxygen 1.4.1


ROLCompiler: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Sun Oct 30 01:12:40 2005 for ROLCompiler by doxygen 1.4.1