
Introduction to Microangelo Librarian

The Microangelo Librarian provides you with the capability to extract, edit, organize, and store icons
on your system.    You can open a file in Librarian from the Libraries tab in the Browser or from 
Windows Explorer.    Double click on the file or simply drag and drop it into an open Librarian 
window.
Individual icons can be moved or copied by dragging and dropping between Librarian windows to 
create customized icon libraries.    Icons contained in icon libraries and application files can be 
modified in the Studio by double-clicking on the icon in the Librarian window.

Microangelo Librarian Quick Start
Microangelo’s Browser will provide quick access to icons stored in your Windows programs, 
libraries, and resource files.    You may select the file type you would like to open using the Tabs 
found in the Browser.    
Browser Tabs
When you click on these Tabs and navigate through different folders on your machine, the Browser 
will only display the files that contain icons. If you press Open or double click on a file in the Icons 
tab, the file will be opened in a Studio edit session.    Selecting a file in the Libraries tab will open 
the file in the Librarian.
After a Librarian window has been opened, the Browser can be used to drag and drop files onto the 
Librarian.    Using the right mouse button to drag and drop will provide a choice of either opening 
the file or adding the icons in the file(s) to the current Librarian workspace.
Open File Formats
The Librarian has been developed to facilitate managing and editing icons that are contained inside
Icon Resource, Icon Library, Application, and Application Extension files.    These file types are the 
Windows 95 equivalents of the ICO, ICL, EXE, and DLL file extensions used in the old DOS file 
naming convention.
Once the file is open, the Microangelo Librarian can display all images associated with the icons in 
the file.    Icon images can have many different formats.    The image format drop down combo 
control, will tell you the size and number of colors that are currently being displayed.    Select a 
different format, the Librarian will only display icons with that image format.    

Note:
· If an icon does not have an image, the icon will be replaced with a blue square.
· Click with the right mouse button on any image to create an icon resource file. From the pop up 

menu, click Save As ICO.
Viewing Files
To view multiple files, click Browser from the File menu, and repeat the process of opening another
file.    The status bar at the bottom of the window displays: the number of icons within the active 
window, and the number of icons selected.
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Copies the bitmap information for the icon to the windows clipboard.



Deletes all selected icons from the window.



Open an existing image format by selecting it using the Image Format drop down combo control, 
above the open file window.



The status bar at the bottom of the program window displays information and messages that 
provide feedback as you work.    It displays information about tool buttons and menu selections.



The Browser can be accessed from the File menu, of any Microangelo component.



Overview of Icons

Clicking on an icon with the right mouse button will select the icon and display a popup menu with 
a list of actions that can be performed on it.    Selections include Copy to Clipboard and Properties.

A Few Brief Words About Icon Files
The Librarian has been developed to facilitate managing and editing icons that are contained inside
Icon Resource, Icon Library, Application, and Application Extension files.    These file types are the 
Windows 95 equivalents of the ICO, ICL, EXE, and DLL file extensions used in the old DOS file 
naming convention.

Moving Icons in the Same Window

When dragging, the cursor will change to a  whenever it is above an invalid drop area.    Valid 
drop areas are within any open window inside of the Microangelo Librarian. 

Moving Icons into Different Windows
You can add to icons to the library by dragging and dropping files into the window with the right 
mouse button.    A pop up menu will appear with options. 
You can double click on any icon in a library to start editing with the Studio component.    

Note:
· When working with an icon image in an Application or an Application Extension file, the Librarian 

will not allow adding or deleting of images.    These file types can include program code and/or 
other types of resources.    Making any changes to these types of files other than editing the 
existing images could result in the loss of important information.    If you want to create a custom 
library file you should drag the icons into a “New” Librarian workspace and save them in an icon 
library.
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 Copying/Moving Icon Images Into Libraries

1    Open file that contains images.
2    Click Browser from the File menu.
3    Click Libraries Tab.
4    Double click on file to open the library to accept images.
5    Select the icons, by holding down the CTRL key, and click once on each image to be moved..
6    Click on image with the right mouse button, then drag and drop it into the new library.    A pop 

up menu will appear with available options.
7    Click Save from the File menu.
Note:
· If you drag and drop icons with the left mouse button, the images will be moved from one file into 

another.
· While dragging the icon, the cursor will display an image of a paper clip attached to a sheet of 

icons, whenever it is positioned on top of a legal drop area.
· A circle with a slash is displayed when the cursor is over any area that the icon cannot be dropped

on.    Any open window inside the Microangelo Librarian is a valid drop area.    



 
Copying/Moving Icon Images Into New Library

1    Open file that contains images.
2    Click New Window from the File menu.
3    Select the icons, by holding the CTRL key down, and click once on each image.
4 Click on image with the right mouse button, then drag and drop it into the new library.    A pop 

up menu will appear with available options.
5    Click Save As from the File menu.
Note:
· If you drag and drop icons with the left mouse button, the images will be moved from one file into 

another.
· While dragging the icon, the cursor will display an image of a paper clip attached to a sheet of 

icons, whenever it is positioned on top of a legal drop area.    
· A circle with a slash is displayed when the cursor is over any area that the icon cannot be dropped

on.    Any open window inside the Microangelo Librarian is a valid drop area.    



Create Icon Image

1    Click New Icon from the Edit menu.
2    Microangelo Studio will open with a blank grid area to start creating a new icon.
3    Once drawing has been completed, click Update and Exit from the File menu.
Tip:
· If you would like to experiment with the editing of an image, click Update from the File menu.    

This will update the image in the file, but leave the Studio open, so that you may edit the image 
with different color schemes, or shapes, etc.



Create ‘Custom’ Size Icon Image

1    Click New Icon from the Edit menu.
2    Microangelo Studio will open with a blank grid area to start creating a new icon.
3    Click the New Image Format button (far right of toolbar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
4    Once editing has been completed, click Update and Exit from the File menu.
Tip:
· If you would like to experiment with the editing of an image, click Update from the File menu.    

This will update the image in the file, but leave the Studio open, so that you may edit the image 
with different color schemes, or shapes, etc.    



Edit an Icon Resource

1    Click Browser from the File menu.
2    Click the Icons Tab.
3    Double click on the icon image that you would like to edit.
4    Click Save from the File menu.



 
Create Icon Image From Bitmap

1    Click New Icon from the Edit menu.
2 Microangelo Studio will open with a blank grid area to start creating a new icon.
3    Click the New Image Format button (far right of tool bar), and choose the size, and number of 

colors from the different options; or scroll to the Custom... selection and define your own.
4    Click Open Bitmap File from the Edit menu.
5    Browse to the folder which contains the bitmap file.
6    Select the file, and click Open.
7    Click Save As from the File menu to save image as an icon.
Tip:
· You may also convert a BMP file into an icon, by pasting it to the Clipboard, and using the Paste 

Special option on the Edit menu.    However, if your bitmap uses colors that are not available in the
currently active palette, the Studio will substitute the closest color available from the currently 
active palette.    To ensure color integrity, use the Open Bitmap As Image, found on the Edit menu.



 
Open Application Files

1    Click Browser from the File menu.
2    Click Libraries Tab.
3    Browse to the folder which contains the application file.
4    Double click on to open in the Librarian.

Note:
· Double click on any image in the file to start editing with the Studio component.
· When working with an icon image in an Application or an Application Extension file, the Librarian 

will not allow adding or deleting of images.    These file types can include program code and/or 
other types of resources.    Making any changes to these types of files other than editing the 
existing images could result in the loss of important information.    If you want to create a custom 
library file you should drag the icons into a “New” Librarian workspace and save them in an icon 
library.

· If you try to drag and drop an image from Application or an Application Extension file, into a new 
or exisitng file, the Librarian will automatically drop a copy of the image.    You are unable to 
permanently move an image out of these files.    However, you are able to select the image, and 
Save As ICO.



Open Application Extensions

1    Click Browser from the File menu.
2    Click Libraries Tab.
3    Browse to the folder which contains the application extension.
4    Double click on to open in the Librarian.

Note:
· Double click on any image in the file to start editing with the Studio component.
· When working with an icon image in an Application or an Application Extension file, the Librarian 

will not allow adding or deleting of images.    These file types can include program code and/or 
other types of resources.    Making any changes to these types of files other than editing the 
existing images could result in the loss of important information.    If you want to create a custom 
library file you should drag the icons into a “New” Librarian workspace and save them in an icon 
library.

· If you try to drag and drop an image from Application or an Application Extension file, into a new 
or exisitng file, the Librarian will automatically drop a copy of the image.    You are unable to 
permanently move an image out of these files.    However, you are able to select the image, and 
Save As ICO.



Open Icon Resource Files

1    Click Open from the File menu.
2    Move to the folder, where the file is located.
3    Select the file, and click Open.
Tip:
· Double click on image to start editing with Studio component.
· You can edit Icon Resource files directly from the Icons Tab.



Open Icon Libraries

1    Click Browser from the File menu.
2    Move to the folder where the library is located.
3    Double click the library file.    The file will be opened in a new Librarian window.
Tip:
· Double click on image to start editing with Studio component.
· Click with the right mouse button on any image to create an icon resource file. From the pop up 

menu, click Save As ICO.



Delete Icon Images From Library

1    Click Browser from the File menu.
2    Click Libraries Tab.
3    Double click on file, to open.
4    Select the icon images by holding down the CTRL key, and click once on each image.
5    Click Delete Icon From Window from the Edit menu.
6    Click Save from the File menu.
Note:
· When working with an icon image in an Application or an Application Extension file, the Librarian 

will not allow adding or deleting of images.    These file types can include program code and/or 
other types of resources.    Making any changes to these types of files other than editing the 
existing images could result in the loss of important information.    If you want to create a custom 
library file you should drag the icons into a “New” Librarian workspace and save them in an icon 
library.



Save Image as ICO

1    Click with right mouse button on image, in any open library.
2    Click Save As ICO from pop up menu.
3    Save file with an Icon Resource file format.



Using Different File Formats

Click New Window from the File menu to open a new, empty window ready for accepting icons.    
Click Save As from the File menu to save the icons in the active window using the file format of your
choice.    Microangelo Librarian will save files in the following formats:

File Format File Name Comments
Icon Resource *.ICO Can contain only one icon per file.
Icon Library *.ICL,IL,NIL Windows icon library format.    The Librarian can track icon 
titles.
Application *.EXE Icons can be replaced, but not added or deleted.
Application Extension *.DLL Icons can be replaced, but not added or deleted.

Microangelo Librarian will open Icon Archive files (*.ICA), but the file must be saved as an Icon 
Library.

Note:
· When working with an icon image in an Application or an Application Extension file, the Librarian 

will not allow adding or deleting of images.    These file types can include program code and/or 
other types of resources.    Making any changes to these types of files other than editing the 
existing images could result in the loss of important information.    If you want to create a custom 
library file you should drag the icons into a “New” Librarian workspace and save them in an icon 
library.

· If you try to drag and drop an image from Application or an Application Extension file, into a new 
or exisitng file, the Librarian will automatically drop a copy of the image.    You are unable to 
permanently move an image out of these files.    

· The Librarian will not allow you to drag an image from an Application or Application Extension file 
into another Application or Application Extension file.    

· Click with the right mouse button on any image to create an icon resource file. From the pop up 
menu, click Save As ICO.
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