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X-Figure Version 1.50
X-Figure puzzles are similar to crosswords, except that the clues refer to numbers rather 
than to words. Just answer the clues and fill in the grid. At the simplest level this requires 
only straightforward arithmetic. Harder puzzles, however, need some careful deduction to 
get them started.
The program creates each new puzzle from scratch and will almost certainly never 
generate the same one twice. There is always a possible solution, although in some cases 
there may be more than one.
X-Figure is shareware. Please distribute it as widely as possible, using the original .ZIP file 
to keep the component files together. If you use the program regularly then your 
registration will be greatly appreciated and will encourage the author to fix bugs and to add
various improvements - possibly including any suggested by you. In addition, one or two 
features are only available when the program is registered.
This version of X-Figure had no known bugs at the time of release (mid 1995). If you 
discover any problems or have any useful suggestions then please let us know. Where 
possible and relevant, please save puzzles that give rise to bug reports.
X-Figure is distributed and supported by SP Services, who can be contacted via electronic 
mail as sphipps@cix.compulink.co.uk or on Compuserve as 100016,1625.
The author is Alan Saul.



Shareware Registration
For more details, and an order form, please see the document ORDER.WRI that should have
accompanied this software (the file is in Windows Write format).
X-Figure is distributed as shareware. If you use it regularly then please register your 
appreciation and support future development by sending a cheque, payable to SP Services,
for £10 to:
SP Services
PO Box 456
Southampton
SO17 1LP
UK
or telephone/fax (credit cards accepted):
Tel: (01703) 550037 [international +44 1703 550037]
Fax: (01703) 322416 [international +44 1703 322416]
Credit card instructions may also be sent by electronic mail to: 
sphipps@cix.compulink.co.uk or on Compuserve to 100016,1625. We accept Visa, 
Mastercard, American Express and all variants of these. Remember to include the credit 
card start and expiry dates.
When registering, please state the name that you want to appear in the 'About Box' and 
other screens. This should be up to 30 characters in length. The number you will be given 
will only work with these details.
US and Other Non-UK Users
If you register using your credit card then we will debit your account in pounds sterling and 
the credit card company will do any necessary currency conversion. As a special incentive, 
there are no extra shipping costs for non-UK orders! If you really cannot avoid paying in a 
currency other than pounds sterling, please add the equivalent of £6 sterling to the price 
you send to cover part of our currency exchange costs.
What You Will Get
You will be sent a certificate giving a registration code which will allow you to enter your 
personal details (specified with your order) into the program. Having done this all 
references to the fact that you hadn't previously paid for the software will disappear.
You will not normally be sent a disc. If, however, you enclose an additional £5 handling 
charge, you will be sent the latest version of X-Figure and other shareware programs 
(please state disc format).
When you receive the certificate, select the menu options Help, About X-Figure and then 
click on the Register button. Enter the details exactly as they appear on the certificate.
If you upgrade to a later version of X-Figure, simply copy the new files over the existing 
ones. Your registration details will remain intact.
See also Disclaimer and Agreement



Disclaimer and Agreement
Users of X-Figure must accept this disclaimer of warranty. If you do not accept this 
disclaimer, do not use the program.
THE X-FIGURE PROGRAM IS SUPPLIED AS IS. THE AUTHOR DISCLAIMS ALL WARRANTIES, 
EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE WARRANTIES OF 
MERCHANTABILITY AND OF FITNESS FOR ANY PURPOSE. THE AUTHOR ASSUMES NO 
LIABILITY FOR DAMAGES, DIRECT OR CONSEQUENTIAL, WHICH MAY RESULT FROM THE USE 
OF X-FIGURE, EVEN IF THE AUTHOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.
THE LICENCE AGREEMENT AND WARRANTY SHALL BE CONSTRUED, INTERPRETED AND 
GOVERNED BY THE LAWS OF ENGLAND AND WALES. YOU MAY HAVE OTHER RIGHTS WHICH 
VARY FROM ONE STATE TO ANOTHER.
Copyright for this software remains the property of:
Alan Saul
Somerset
United Kingdom
All contact should be made with SP Services in the first instance.



Using the Mouse
Numbers can be entered with the mouse by using the on-screen number pad. If this is not 
visible then you can make it appear by selecting Number Pad from the View menu. If the 
pad obscures your view then you can move it by selecting the bar just above the numbers 
and dragging it around the screen. To alter the layout between the standard keypad shape 
and horizontal and vertical rows of buttons, click in this region with the right mouse button.
To enter a number in the grid select the appropriate square (by clicking on it with the left 
button), and then click on a digit on the number pad.
If a whole clue has been highlighted then the input focus will move to the next digit. 
However, if the selected square intersects with two clues, X-Figure may not know if you are 
answering the across clue or the down clue and will not move the focus.
There are a number of ways to indicate whether you want to enter numbers across or 
down...

Click on one of the direction buttons 
 or 

Click on the text of the clue, rather than in the grid.
Select a square that only belongs to one clue - this will highlight the whole answer. If 

you now select another square in the same answer, that answer will stay selected.
See also: Using the Keyboard, Entering Notes, Entering Guesses, Mouse Buttons



Mouse Buttons
In common with normal Windows practice most mouse actions within X-Figure use the left 
mouse button. Unless otherwise stated, references to 'clicking' mean that the left button 
should be used.
A few actions, however, are performed by clicking or pointing with the right mouse button...

Entering notes from the Number Pad.
Deleting notes or answers using the 

 button on the Number Pad.
Resizing the Number Pad, by right clicking in the drag region.
Hiding clues that are no longer of interest, by clicking on the text of the clue with the 

right button. (To bring one of these clues back into view, select Show Hidden Clues from the 
View menu and right click on it again).



Using the Keyboard
To enter a number in the grid, simply type it in the normal way. Depending on the status of 
Notes Using Keypad on the Edit menu, the keys to the side of the main keyboard may 
have a different effect from those in the top row.
The cursor keys can be used to select a different square. 
If a whole clue has been highlighted then the input focus will move to the next digit as you 
type. However, if the selected square intersects with two clues, X-Figure may not know if 
you are answering the across clue or the down clue and will not move the focus.
In order to indicate in which direction you want to enter numbers...

Use Ctrl + one of the direction keys. 
Select a square that only belongs to one clue. If you then select any square in the 

same clue, the whole clue will remain selected. This is easier to do than to explain - try it.
See also: Using the Mouse, Entering Notes, Entering Guesses 



Verifying Your Answers
There are two ways to verify what you have entered...
Automatic Verification
Enable Verify on the View menu. Now, as you enter numbers in the grid, the text of any 
relevant clues will be highlighted and have  or 
 displayed alongside them. The default highlights are black for undecided, blue for correct, 

and red for incorrect.
Verify may be turned on or off at any time.
It is important to remember that a blue or ticked clue only indicates that you have satisfied 
that particular clue (e.g. entered a square number for the clue `A perfect square'), not that 
you have given the correct answer. The number you have given may yet make the rest of 
the puzzle impossible to complete!
Reveal 
Enable Reveal on the View menu. This will show the known solution to the puzzle (it is 
possible for there to be more than one correct solution). Where you have already supplied 
the correct answer, the grid will be unchanged. Empty squares will have the answer shown.
If you have given an answer which disagrees with the known solution, then the correct 
number will be shown in red (unless you have changed this to something else) with your 
answer displayed in the top right corner of the square.
See also: How Answers are Verified, Change Screen Appearance



An undecided answer is one which has not yet been filled in, or whose clue refers to 
another which has not yet been answered.



A correct answer is one which matches the clue - whether or not it fits in with solution to 
the complete puzzle. See How Answers are Verified for examples of `correct' answers 
that are actually incorrect.



An incorrect answer is one that fails to match the clue.



Creating a New Puzzle
To create a new puzzle, either select New Puzzle from the File menu or make a selection 
from the Puzzle menu.
New Puzzle will create another puzzle of the same size and degree of difficulty as the 
current one. The Puzzle Menu allows you to alter these settings.
See also: Seed Codes



Entering Notes
While solving a cryptic puzzle you will probably want to make notes as you work things out.
These notes can be entered into squares in place of answers. When you then enter an 
answer, it will hide any notes.
Letters and punctuation characters can simply be typed in from the keyboard. Numbers can
be entered in one of several ways...

From the keyboard using Ctrl+Number
From the keyboard using the separate numeric pad. Notes Using Keypad on the Edit 

menu will have to be enabled for this to work, and NumLock should be on.
Using the right mouse button in the Number Pad.

See also: Entering Guesses



Entering Guesses
If you want to try out a train of thought which may turn out to be incorrect, be wary of 
simply entering numbers into the grid as it is easy to lose track of which ones need to be 
removed if the original idea proved wrong. Instead, select Enter Guesses from the Edit 
Menu. Any numbers typed in now will appear in yellow.
Once you have decided whether or not the original guess was correct, select either 
Upgrade Guesses or Remove Guesses 
It isn't a bad idea to have Enter Guesses selected all the time and to upgrade the guesses 
periodically - at times that you are sure that everything entered so far is correct.



Changing the Screen Appearance
The Appearance option on the View menu displays a dialog allowing most of the screen 
attributes to be changed. Some of these (such as the background of the clue boxes) are 
tied to the settings given in the Windows control panel and cannot be altered from within X-
Figure.
Select an item in the list box and the button corresponding to its current appearance will be
depressed. To change it, click on the desired button. 
Rather than have separate foreground and background settings for each item, backgrounds
of the grid squares are items in themselves. It is quite possible to make the foreground and 
background of some things the same, thus rendering them invisible. It is up to you to avoid 
doing this (unless, of course, you particularly want to make something disappear).

This dialog also allows you to change the shape of the number pad, or to remove it from 
the screen entirely. Simply depress the appropriate button (the shape of the number pad 
can also be changed by clicking with the right mouse button in its drag region).



How Answers are Verified
For the purposes of verifying your answers and highlighting clues, your answer is matched 
against the logic of the clue, not the known solution.
For example, consider the clues...
Across
1. A perfect square (2 digits)
2. 1 across times two (2 digits)
Entering any of 01, 04, 09, 16, 25, 36, 49, 64 or 81 will result in 1 across being displayed as 
correct. In fact 01, 04 and 09 are not allowable, since answers never start with zero, and 64
and 81 are clearly impossible since the answer to 2 across would need to have three digits.
Whatever answer you give for 2 across, this will be shown as correct so long as it is twice 
your answer to 1 across. So if you enter 24 for 1 across and 48 for 2 across then X-Figure 
will regard 1 across as incorrect (24 is not a square), but 2 across as correct (48 is twice 24).



Clue and Puzzle Types
Puzzles differ in a number of ways which may be seen by selecting Custom from the Puzzle 
menu. In addition to choosing the size of the grid, different categories of clues may be 
allowed or disallowed. The predefined puzzle types (simple, quick, cryptic and hard) are 
simply samples of those that you can define for yourself.
Clue Categories

Conversion Factors
These provide an easy starting point to the puzzle since they can always be answered 
without looking at any other clues. E.g. Inches in a foot.

Cross References
These link two or more clues, so that the answer to one depends on the answer to another. 
E.g. Two times 1 across.

Miscellaneous
These are clues with more than one possible answer. The correct one will have to be 
determined from looking at other answers that depend on it. E.g. A prime number.
Predefined Types 

Simple
There will always be at least one clue that can be used to get you started. 

Quick
Similar to simple puzzles, but the grid is larger and multiples of ten are avoided. 

Cryptic
These do not have any conversion factor clues. Starting will require a little thought. 

Hard
These select the toughest settings available.
See also: Customising Puzzles, Conversion Factors, Seed Codes 



Customise Level
Selecting Custom from the Puzzle menu gives you the opportunity to create puzzles of the 
type you prefer. Choose from the following... 
Clue Types 
Check or uncheck the boxes to select the types of clue that may be used.
Provided that you allow X-Figure reasonable scope for generating puzzles then it will abide 
by your choices. If, however, you do not select enough clue types then some others may 
have to be used. 
For example, if you choose only metric conversion factors then these will be generated 
along with clues of the type 1 across plus n and possibly some others. On the other hand, a 
puzzle consisting entirely of anagrams is quite reasonable and, if you check just the 
anagrams box, that is what you will get. 
Basically, the rules are that in the Conversion Factor and Number Type groups, clearing a 
check box means that this type of clue will definitely not appear. In the Cross Reference 
group it only makes it less likely. Checking a particular box is never a guarantee that the 
clue type will be used in any particular puzzle, only that it may. 
Grid Size 
X-Figure has a number of pre-defined grid shapes of each size. Select the grid size you 
prefer. 
Times Tables 
This setting is in indication of the multiplication tables that are likely to be used for clues 
such as 1 across times n. It does not affect the choice of conversion factors.    If Hidden 
Multiples is selected then the constant in multiples or divisions may not be given, resulting 
in clues such as Multiple of 1 across.
See also: Conversion Factors 



Conversion Factors
X-Figure knows about the following types of conversion factor... 
Metric 
These are all multiples of ten, such as mm to the cm. 
Non-Metric 
Measures such as inches to the yard. X-Figure knows about certain differences in the UK 
and the US (e.g. US hundredweight = 100lbs; UK hundredweight = 112lbs), and uses the 
international settings in the Control Panel to generate correct questions for the country 
your PC thinks it's in (at least for UK and US).
Time 
'Days in a week' etc. 
Miscellaneous 
These are mostly alternative forms of numbers, such as dozen, rather than true conversion 
factors. 



Printing Options
Having selected either Print or Print Format from the File Menu, you are asked to select how
the printed puzzle should appear. You may choose to print the full puzzle, just the clues, or 
just the grid. If printing the grid then you can leave it empty, containing any answers that 
you have entered so far, or showing the full solution.
Where possible, the whole puzzle is fitted onto a single page. If it does not fit then try 
reducing the grid width or font sizes. If you want the grid and clues on different pages then 
print the two items separately.
Title
If you specify a title then it will be printed at the top of the first page.
Print
Select how much of the puzzle is to be printed...
Empty Grid and Clues The clues and grid, with nothing filled in.
Filled Grid and Clues The clues and grid, with anything you have entered shown.
Empty Grid Only No clues. Nothing is filled in the grid.
Filled Grid Only No clues. Anything you have entered so far is shown in the grid.
Solution Only No clues. The grid contains the correct answers. Clue numbers are 

not printed in the grid (this is similar to the way in which newspapers 
show crossword solutions).

Clues Only Just the clues.
Grid Alignment
The grid may be aligned to the left, right, or centre of the page. If there is space, the clues 
will be placed alongside the grid.
Grid Width
The width (and height) of the grid.
Fonts
Title Used for the title, if given.
Headers 'Across' and 'Down'.
Clues The actual clues.



Menus 
File Menu 
Edit Menu 
View Menu 
Puzzle Menu 



The File Menu 
New Puzzle 
Retrieve... 
Save 
Save As... 
Print...
Print Format...
Print Setup... 
Verify Solution...
Exit 



New Puzzle 
Generate a new puzzle from scratch, at the same level as the current one. 



Retrieve 
Recover a puzzle that was saved earlier 



Save 
Save the current puzzle, along with any answers or notes that you have entered. If you 
have not yet saved this puzzle, you will be prompted for a filename. 



Save As...
You will be asked to supply the name of a file, in which the current puzzle will be saved 
along with all answers or notes that you have entered.



Print...
The puzzle will be sent to your printer. The Print Options dialog is displayed, allowing you 
to select various aspects of the presentation before the printing goes ahead. To see what 
the printed output will look like use Print Format...



Print Format...
This allows you to choose and see how the puzzle will appear on paper, prior to selecting 
Print....



Print Setup...
This allows you to select the printer and printer related settings, such as the paper size and
orientation. The Printer button on the Print Options dialog provides the same options.



Exit
Exit the X-Figure program. Settings such as window position and appearance will be saved -
the current puzzle will not. 



The Edit Menu 
Enter Guesses 
Upgrade Guesses 
Remove Guesses 
Notes Using Keypad 



Enter Guesses 
With this menu option enabled, your answers will be shown differently from normal (usually
in yellow) to indicate that they are currently guesses. These numbers can later be removed 
all one go or converted to firm answers.



Upgrade Guesses 
Convert all current guesses to firm answers.



Remove Guesses 
Delete all guesses from the grid.



Notes Using Keypad
With this enabled, the separate numeric pad on your keyboard can be used to enter notes 
while the numbers on the top row of the keyboard enter answers. Note that NumLock must 
be on, otherwise the numeric keypad provides cursor movement. 



The View Menu
Verify & Reveal
Show Hidden Clues 
Number Pad 
Status Bar 
Appearance... 



Show Hidden Clues 
When you are no longer interested in a particular clue, you may right click on the text to 
hide it. If this menu option is selected, however, hidden clues are displayed, but greyed out.
This allows you to retrieve a hidden clue by clicking on it again with the right button. 



Status Bar 
Use this to toggle the display of the status bar at the bottom of the screen.



Hints
A good strategy, particularly for cryptic puzzles, is to look at each clue in turn and to enter 
notes in the grid about anything you can determine. Eventually notes from different clues 
will combine to yield the contents of a square.

Make notes about anything you know, however trivial, such as that the last digit of a 
multiple of two is even.

Answers never start with zero. This is more a rule than a hint.
Multiples of five are often good clues to get you started.
If the sum of two numbers or the difference between them is known, and also the last

digit of one of the numbers, then the last digit of the other can be determined. For example; 
if 1 across is 2 down plus 16, and its answer is known to end in 3, then 2 down must end in 7.

Where one number is a multiple of another, the number of digits in each number 
provides a useful clue. For example; if 40 times a two digit number gives three digits, then 
the two digit number must be less than 25 (i.e. it starts with 1 or 2), and the product is at 
least 400.

X-Figure never creates an impossible puzzle. Honest!
See also: Tables of Squares and Cubes, Entering Guesses.



One to Four Digit Cubes
-0 -1 -2 -3 -4 -5 -6 -7 -8 -9

0 0 1 8 27 64 125 216 343 512 729
10 1000 1331 1728 2197 2744 3375 4096 4913 5832 6859
20 8000 9261

See also: One to Four Digit Squares



One to Four Digit Squares
-0 -1 -2 -3 -4 -5 -6 -7 -8 -9

0 0 1 4 9 16 25 36 49 64 81
10 100 121 144 169 196 225 256 289 324 361
20 400 441 484 529 576 625 676 729 784 841
30 900 961 1024 1089 1156 1225 1296 1369 1444 1521
40 1600 1681 1764 1849 1936 2025 2116 2209 2304 2401
50 2500 2601 2704 2809 2916 3025 3136 3249 3364 3481
60 3600 3721 3844 3969 4096 4225 4356 4489 4624 4761
70 4900 5041 5184 5329 5476 5625 5776 5929 6084 6241
80 6400 6561 6724 6889 7056 7225 7396 7569 7744 7921
90 8100 8281 8464 8649 8836 9025 9216 9409 9604 9801

See also: One to Four Digit Cubes



Seed Codes
Seed Codes are used to completely identify a given puzzle so that any number of people 
can work on their own copy without having to distribute a file.
For example, a X-Figure puzzle may be printed in a magazine along with its Seed Code. 
Readers with a copy of X-Figure can type in this code to re-create the puzzle and allow 
them to solve it on-screen. The reveal function is disabled in order to prevent cheating.
To Generate a Puzzle From a Seed Code

Select Seed Code from the Puzzle menu.
Type the code into the Existing Puzzle field (you may ignore dashes and spaces and 

type in upper or lower case).
Click on the Re-create button.

To Create New Puzzles Complete With Seed Codes
Select Seed Code from the Puzzle menu and click on the New button (this 

automatically sets Generate Codes). Repeat until you have a puzzle you like.
Save the puzzle using the File menu. Select Seed Code again and note the Current 

Code. Do not re-create the puzzle from the code until you have saved it, or you will not be 
able to Reveal the solution.

All new puzzles created while Generate Codes is checked (the Seed Codes menu 
option will also be checked to reflect this) will have a seed code.

Normally X-Figure injects a high degree of randomness into each new puzzle, ensuring that 
no two are ever likely to be the same. A drawback of seed generated puzzles is that, since 
the codes are limited in length, there must be a limited number of different puzzles 
available (a large number - but finite). A compromise is therefore necessary between 
randomness and the length of the code. Because of this codes are only generated if you 
specify that you want them. If you do not need seed codes then, for the maximum variety 
of puzzles, uncheck Generate Codes in the Seed Codes dialog and click on Close.
See also: Creating Proof of Completion Codes, Verifying Completion Codes.



Creating Proof of Completion Codes
If a puzzle has been generated from a seed code (such as one published in a magazine), 
then when it has been successfully completed a Completion Code will be generated. This 
code may be accepted by the competiton organisers as proof that the puzzle has been 
completed. The code is a 10 or so digit number which should be easier to send in than a 
printed solution and is also easier to verify.
The Completion Code dialog is only displayed when the last digit of the puzzle is correctly 
entered (and for puzzles that were generated from a seed code). If you have already 
completed the puzzle and wish to redisplay the dialog, simply re-enter any digit in the grid 
and it will pop up.
Name or E-mail Address
Each Completion Code is unique both to the puzzle and to the person that completed it, so 
it is not possible simply to find out someone elses code and submit that as your answer. 
You may use any text to identify yourself and 'brand' your code, but your name or E-mail 
address is recommended. Remember that if you do not submit this text to the organisers 
exactly as you entered it when generating the code, then they will not validate your entry.
Completion Code
Once you have entered your name details, click on the Check button to reveal your code. 
If you want to paste the code into a letter or e-mail message, click on Copy to Clipboard 
and then paste the details into your application. The name and number will be embedded 
inside brackets; leave them that way - especially if sending your code by e-mail - since the 
organisers may be using automated tools which rely on this formatting to check the entries.



Verify Completion Codes Dialog
If a puzzle has been solved from a seed code, then the solver will have been given the 
option to create a Completion Code and optionally copy it into another application via the 
clipboard. If is was copied in this way then the name and code will be embedded inside 
angle brackets, for example...
<<NAME:John Smith>>
<<CODE:1234567890>>
Extract the name and number from the delimiters before entering them into this dialog. 
Seed Code
Enter the seed code that was generated when the puzzle was originally created,
Name
The Completion Code must have been submitted along with some identification pertaining 
to the person who completed the puzzle. Enter this exactly as supplied.
Completion Code
This should be a number of up to 10 digits.
Check
Click on this button to see if the code indicates that the puzzle was solved. A status of 
CORRECT or INCORRECT will be displayed.



Verify Solution...
If you have published a puzzle as a competition, for example, and included a seed code for 
entrants to solve it on their PCs, then they can submit their answers in the form of a 
Completion Code. This can only be generated when the puzzle has been answered fully and
correctly, and allows you to verify entrants more readily than checking printed solutions.

Each Completion Code is uniquely generated based on the seed code and a short piece of 
text supplied by the person completing the puzzle - usually their name.
This feature is only available in registered versions of X-Figure.



Verifying Completion Codes
If you have published a puzzle as a competition, for example, and included a seed code for 
entrants to solve it on their PCs, then they can submit their answers in the form of a 
Completion Code. This can only be generated when the puzzle has been answered fully and
correctly, and allows you to verify entrants more readily than checking printed solutions.
Each Completion Code is uniquely generated based on the seed code and a short piece of 
text supplied by the person completing the puzzle - usually their name. To check a 
submitted solution use the Verify Solution option on the File menu (this is only available in 
registered copies of X-Figure).
See also: Creating Proof of Completion Codes




