
A2Z Hangman

This is a version of the classic Hangman game which is designed to help grade school age children improve 
their vocabulary and spelling. It was designed with young children in mind.    It is appropriate for use in a 
classroom or at home. With this version you can:

Use the word list of approximately 300 words included with A2Z Hangman (WORDS.DAT)
Create your own word list
Include definitions to improve vocabulary
Transfer words and definitions from one word list to another
Play the game using the mouse or keyboard

The object of Hangman is to guess all of the letters in a word before the Hangman is drawn. If the letter 
which is guessed is in the word it is shown. If the letter is not in the word, another line is drawn on the 
Hangman. 

Selecting a word list
Starting the game
The game word
Selecting a letter
Hints
Hangman drawing



Game Menu

Use this menu to create a new word list, select an existing word list, enable or disable hints, specify when 
hints are shown, enable or disable keyboard input, or exit.

Create New Word List
Select Word List
Hints
Keyboard Enabled



Edit Menu

Use this menu edit a word list or transfer words from one word list to another.

Edit Word List
Transfer Words



Create New Word List

Select Create New Word List from the file menu to create a new word list. A dialog window will open with two
options. If the Create by entering words option is selected, the Word List Editor will be opened. If the Create 
by transferring words option is selected, the Word Transfer Window will be opened.

Edit Word List
Transfer Words



Restart Game

Starts playing Hangman. This menu item is disabled if there is not a word list loaded. Load a word list using the 
Select Word List option in the Game menu.



Select Word List

Selects and loads a word list file. WORDS.DAT, a list of approximately 300 words, is provided with the A2Z Hangman 
software. You can also create your own word lists using the Edit Word    List option in the Edit Menu. 



Edit Word List

Opens the Word List Editor. The Word List Editor allows you to add, edit and delete words in a word list file. This 
allows students to use A2Z Hangman to learn the vocabulary and spelling words assigned to them by their teacher, 
not just the words which come with A2Z Hangmans WORDS.DAT.



Word List Editor

The Word List Editor allows you to add, edit, and delete words in a word list file. Use the Open command in the File 
menu to select the word list file to edit. You can edit an existing file or create a new file using this command. The 
name of the word list file which is open is located at the top left side of the window.

Definitions are optional, but recommended. Words are limited to 11 characters. Definitions are limited to 120 
characters.

Adding a word:
Select the Add button. Type the word in the box labeled Word. Type a definition for the word in the box labeled 
Definition. (See Definitions for hints about adding definitions.) Click the OK button to add the word to the word list file 
or click the Cancel button to cancel the operation.

Editing a word or definition:
Select a word from the list box or type it in the box at the top of the list box. Select the Edit button. Edit the word or 
definition. (See Definitions for hints about editing definitions.)    Click the OK button to update the selection in the word
list file or click the Cancel button to cancel the operation.

Deleting a word:
Select a word from the list box or type it in the box at the top of the list box. Select the Delete button to delete the 
word from the word list file.



Definitions

Entering definitions with words in the word list files is optional, but recommended. Definitions are displayed when all 
of the letters in a word have been selected or when the Hangman has been drawn. This helps the student learn the 
meanings of the words.

In addition, the definitions are used by the Hint feature, if hints are enabled. The Hint feature searches the definition 
for the game word and replaces it with blank spaces. It shows this as the hint. If you plan to use the Hint feature, 
consider how you write your definitions: 

Examples of definitions which work:

Word: five Definition: I have five toes on each foot.
results in Hint: I have ____ toes on each foot.

Word: tree Definition: Trees are large plants with trunks and many leaves.
results in Hint:    ____s are large plants with trunks and many leaves.

Word: house Definition: a building in which a family lives
results in Hint: a building in which a family lives

Example of a definition which doesnt work:
Word: berry Definition: Berries are small, juicy fruits.
results in Hint: Berries are small, juicy fruits.
Since the plural form is berries (rather than berrys) the Hint feature cant find the word berry and replace it with 
spaces.



Transfer Words

Opens the Word Transfer Window. The Word Transfer Window allows you to transfer words and their definitions from 
one word list file to another. 

This option is especially useful to educators who use the same lists of vocabulary and spelling words from year to 
year. During the first year, add words to the master list every week. In following years, all you need to do is transfer 
that weeks words from the master list (e.g. MASTER.DAT)    to a weekly list (e.g. WEEKLY.DAT). You can create a 
separate word list file for each weeks words if you prefer, but this results in a larger number of files to manage.



Word Transfer Window:

Using the options in the File menu, select a source word list file and a destination word list file. The source file must 
be an existing file. The destination file may be an existing file or a new file. The words in the source file appear in the 
list on the left. The words in the destination file appear in the list on the right.

To transfer a word and definition from the source file to the destination file, select the word in the list on the left. Then 
select the Add button. The word will appear on the list on the right. 

To delete words from the destination file, select the word in the list on the right. Select the Delete button. The word is 
deleted from the destination file list box.



Choosing A Letter

Guess a letter in the game word by pointing to a letter and clicking on it once. If the letter is in the game word, it will 
appear in the game word. Otherwise, a line will be drawn on the Hangman.

 Letters which are available for selection are black. Letters which have already been selected are gray (disabled). All 
of the letters are disabled until a word list is loaded.

If hints are enabled, the Hint button will appear as specified by the When Shown command on the Hints submenu.



Game Word

Each line in the game word box represents a letter in the game word. When a letter is selected, if it is in the game 
word it will appear in the correct position in the game word box.



Hangman Drawing

The Hangman is drawn in the Hangman box. Every time a letter is selected which is not in the game word another 
line will be drawn in the Hangman box. It takes ten lines (or wrong letter guesses) to completely draw the Hangman. 



Hints

Select Hints from the Game Menu to view the Hints submenu.

Select Enable Hints from the Hints submenu to enable the Hint button.    Select it again to disable the Hint Button.

The Hint Button will be shown when the number of guesses specified by the When Shown option on the Hints 
submenu remain. For example if the number for this option is 1and Enable Hints is checked, the Hint Button will be 
shown when the player has one guess remaining. The player can click the Hint button to get a definition of the game 
word. This feature is especially useful for very young players who are having a hard time guessing the words. 

A change made in the When Shown option might be delayed until the next word is loaded.



Keyboard Input

Select Enable Keyboard from the Game Menu to enable using the keyboard to play the game.    Select it again to 
disable using the keyboard 



Registration

To register A2Z Hangman, select How to Register from the Help Menu. 

Payment methods:

Option 1 - Pay by check drawn on US bank
Select    the first option and pay A2ZWare directly using a check drawn on a US bank. After selecting OK a form will 
appear with spaces for name, address, e-mail address, and the name of the person or organization which will be 
using the software. Fill in the appropriate information. Then enter the quantity for the appropriate license type. The 
total for the order is shown at the bottom of the page. Select Continue. A message box appears with the total amount.
Select OK to print the registration form. Send the form, along with a check or money order for the total amount, to the 
address on the form. Because this is the simplest method for A2Zware to process, there is a discount for using this 
registration option.

Option 2 - Alternate payment methods
Those want to pay by a method other than a check drawn on US bank should select the second option. Select OK 
and follow the instructions on the screen. Payments using this method will be sent to Kagi, a processing service 
which handles these alternate payment methods. Kagi will notify A2ZWare when the payment have been processed.

After your payment is received, you will receive a registration code from A2ZWare. Enter this code by selecting Enter 
Registration Code from the Help menu. After your registration code is entered you will not be interrupted by 
shareware reminders anymore. 



License Agreement

A2Z Hangman Copyright © 1996 - 1997 by J. Szatkowski
All rights reserved.

License Agreement
You should carefully read the following terms and conditions before using this software.    This is your license 
agreement unless you have a different written license agreement authorized by A2ZWare. Your use of this software 
indicates your acceptance of this license agreement and warranty.

Unregistered Verision
You may use A2Z Hangman free of charge for 30 days. After that you must register by purchasing a license.

Registered Versions
For an individual license, a single copy of Hangman may be used on one computer. DO NOT purchase an individual 
license for a school. Schools must purchase school licenses.

A school license registers all of the computers at one school. All teachers employed by the school are also licensed to
use the software on their home computers for as long as they are employed by the school. School licenses DO NOT 
cover students. Students must purchase individual licenses.

A district license registers all of the computers at all of the schools in one school district. All teachers employed by the
district are also licensed to use the software on their home computers for as long as they are employed by the district.
District licenses DO NOT cover students. Students must purchase individual licenses.

You may access the registered version of A2Z Hangman through a network, provided that you have obtained 
individual licenses for the software covering all computers that will access the software through the network.    For 
instance, if 3 different computers will access A2Z Hangman on the network, each computer must have its own A2Z 
Hangman license, regardless of whether they use A2Z Hangman at different times or concurrently. For use on four or 
more computers at one location purchase a school license rather than four or more single computer licenses.

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED.
Because of the various hardware and software environments into which A2Z Hangman may be put, NO WARRANTY 
OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.

A2Z Hangman has been tested extensively. However it is not possible to test every possible situation. The user 
assumes the entire risk of using A2Z Hangman.    ANY LIABILITY OF THE SELLER WILL BE LIMITED 
EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE. 



Technical Support

Please contact A2ZWare Technical Support if you have any problems with the software. When contacting Technical 
support, please include the following information:

1. A complete description of the problem
2. Your registration name if registered (Registered to Registration Name    at the top of the screen)
3. The version number of the software. (Select About Hangman from the Help menu)
4. Your Windows version (Windows 3.1, Windows 95, etc.)
5. Your processor type if you know it (486, Pentium, etc.)
6. Any other information which might be important

A2ZWare Technical Support can be contacted in three ways
1. Send e-mail to buildblock@aol.com. 
2. Visit our web site at http://members.aol.com/buildblock/index.htm
3. Send your request and a self-addressed, stamped envelope to the following address:

A2ZWare
Technical Support
11721 Eddie and Park Rd.
St. Louis MO 63126

Technical support requests received via mail which do not include a self-addressed, stamped envelope will NOT 
be processed.




