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Click a word to see its definition.

a

anchor 

applet 

b 

background 

base target 

base URL 



bps 

browser 

c

CGI 

client 

d

dithering 

download 

e

(none)

f

form

frames 

frame layout 

frame set 

frame target 

FTP 

g

GIF 

h

HTML 

hypertext 

i

Internet 

intranet 

image map 

image scaling 

Increase Indent 

Decrease Indent 

ISP 

j

Java 

JavaScript 

JPEG 

k

(none)

l



line break 

link 

local 

local site 

m

(none)

n

(none)

o

(none)

p

publish 

q

(none)

r

remote 

s

server 

t

target

u

upload 

URL 

v

(none)

w

Web page 

Web server 

Web site 

World Wide Web 

x

(none)

y

(none)

z

(none)



anchor

An anchor is a type of link that is used to mark specific locations within a Web page.



applet

An applet is a mini-application, usually created in Java so that it runs on a variety of operating systems.



background

The background of a Web page displays behind all the graphics and text.    A background can be a color, or a tiled graphic.



base target

The frame in which a linked file displays.



base URL

The base URL for a Web page sets the URL upon which all links in the Web page are based.



bps (bits per second)

Bps refers to how fast a modem can transfer data.



browser

A browser is a local application you use to connect to an Internet server. It interprets and displays HTML encoded documents in 
a graphic format.



client

Client refers to an application, usually on a desktop computer, that connects to a server.    Opposite of server.



dithering

If a user's browser or system only supports 256 colors, the image is adjusted automatically by a process called dithering. The 
image displays but its quality is frequently diminished when this happens.



download

To download files is to transfer them from a server to a local machine.    Opposite of upload.



form

A form is a Web page element into which a user inputs data, and then the form processes the input data.



frames

Frames divide parts of a Web page into two or more independent parts.    Each frame displays a separate HTML file.



frame target

A frame target is the frame in which a linked file displays.



FTP (File Transfer Protocol)

The File Transfer Protocol is the common command set that is used to upload and download files from Web sites.



GIF (Graphics Interchange Format)

GIF is a common cross-platform format for Web graphics.



HTML (HyperText Markup Language)

HTML is the primary coding language to create Web pages.    A Web page has HTML tags, which instruct the browser to display 
text in a particular format.



hypertext

Hypertext is text or graphics that contain links to other text or graphics, either in the same or a separate document.



Internet

The Internet is the computer network that connects computers all over the world to each other.



intranet

An intranet is an internal and private computer network, usually for a company or organization.



image map

An image map is a graphic that contains one or more links. 



image scaling

Image scaling proportionally changes an image's height and width.



ISP (Internet Service Provider)

An ISP is a company or organization that allows you to access the Internet via their computers.



Java

Java is a programming language used to develop cross-platform applets and applications.



JavaScript

JavaScript is a scripting language that is used to create dynamic Web pages.



JPEG (Joint Photographic Experts Group)

JPEG is a format for Web page graphics.



line break

A line break is a method of creating a space between lines without applying the previous paragraph's formatting.



link

A link is text or a graphic that has been formatted to include the location of a document or graphic.    When a user clicks a link, 
the new document or graphic displays.



local

Local refers to something that is on your computer, as opposed to being on a server.    Opposite of remote.



local site

Local site refers to the collection of Web files that are located on your computer, as opposed to being on a Web server.    
Opposite of Web site.



publish

To publish is to put your Web files up on a Web server so that others can access them.



remote

Remote refers to something that is on a server, as opposed to being on your computer.    Opposite of local.



server

A server is a computer that is configured (via software and hardware) to provide files to one or more other computers.    Opposite 
of client.



upload

To upload files is to transfer them from your computer to a server.    Opposite of download.



URL (Uniform Resource Locator)

An URL is a specific address used by Web browsing software to locate and access information on the World Wide Web and 
other Web-based computer networks.



Web page

A Web page is a text document that is encoded in HTML, and is the primary means of accessing the World Wide Web.



Web server

A Web server is a type of server that is dedicated to storing and handling Web-based files.



Web site

A Web site is a collection of files that are located on a Web server and available to others to browse.



World Wide Web (WWW)

The World Wide Web is the graphical (as opposed to command-based) interface to the Internet.



CGI (Common Gateway Interface)

CGI is the standard Web protocol for processing information that a user enters via a form.



target

A target is the frame or browser window in which a linked file displays.



Increase Indent
The Increase Indent command adds an indent to a paragraph.



Decrease Indent
The Decrease Indent command removes an indent from a paragraph.



frame layout
A frame layout consists of two or more independent parts, called frames.    Also called frameset.



frame set
A frame set consists of two or more independent parts, called frames.    Also called frame layout.



This is the second document for Vpage 1.0.1 Help, comparable to the “Adding Web page elements” in the Mac HTML file.



 Adding text
{button See Also,AL(`Adding_graphics;Adding_horizontal_lines',0,`',`')}

Adding text to your Visual Page documents is very similar to inserting text using any standard word-processing application. The 
following procedures explain how to insert and format text. 

You can insert text by:

Typing text

Dragging and dropping text

Copying and pasting text 

Importing a plain text file 

You can format text by:

Generating paragraphs and line breaks 

Aligning and indenting paragraphs 

Formatting paragraphs 

Formatting characters 

Creating bulleted lists 

Creating ordered lists 

Creating term and definition lists 



 Typing text
{button See 
Also,AL(`Copying_and_pasting_text_or_graphics;Dragging_and_dropping_text
;Importing_a_plain_text_file;Formatting_paragraphs',0,`',`')}

If you have ever used a word processor to create a text document, you probably know how to type text into a Web page in the 
Visual Page environment. Visual Page supports all the standard text operations.

To insert text by typing:

1 Make sure that you're in Edit mode.    
For information on switching to Edit mode, see Previewing your work.

2 Within the main Edit window, move the text cursor to where you want to insert text.
3 Single-click at the insertion point.
4 Type in your text.    

The text displays on the Web page.



 Dragging and dropping text
{button See 
Also,AL(`Copying_and_pasting_text_or_graphics;Importing_a_plain_text_file;T
yping_text;Formatting_paragraphs',0,`',`')}

Visual Page supports drag-and-drop functionality in many ways. It is an extremely handy way to move text from one location to 
another.    Visual Page also allows you to insert other objects, such as images, from the Windows Explorer into Visual Page.

To insert text by drag-and-drop:

1 Make sure that you're in Edit mode.    
For information on switching to Edit mode, see Previewing your work.

2 Make sure that the files that you want to drag to and from are open.
3 Select the text you wish to move.
4 Click on the selection, and, without releasing the mouse button, move the selection to the new location.
5 Release the mouse button.

The text is now in the new location.

To insert other objects into Visual Page:
1 Make sure that you're in Edit mode.    

For information on switching to Edit mode, see Previewing your work.
2 Locate the object (e.g. image) you want to insert with the Windows Explorer.
3 Press and hold the Control key while dragging the object from Explorer into Visual Page.

When you release the mouse and control key, the Save As dialog box appears.
4 At this point, you can rename the object, or click OK to use the default name.

The object is added to your page.



 Copying and pasting text or graphics
{button See 
Also,AL(`Dragging_and_dropping_text;Importing_a_plain_text_file;Typing_text;
Formatting_paragraphs',0,`',`')}

Visual Page supports the traditional methods of moving and editing text by supporting copy and paste functionality. 

To insert text or graphics by copying and pasting:

1 Make sure that you're in Edit mode. 
For information on switching to Edit mode, see Previewing your work.

2 Make sure that the files that you want to copy to and from are open.
3 Select the text you wish to be copied.
4 From the Edit menu, select Copy (or press Control-C).
5 Position the cursor where you want the copied text to be.
6 From the Edit menu, select Paste (or press Control-V). 

The text is copied into the new location.



 Importing a plain text file
{button See 
Also,AL(`Copying_and_pasting_text_or_graphics;Dragging_and_dropping_text
;Formatting_paragraphs;Typing_text;Using_the_Site_Window',0,`',`')}

This feature allows you to instantly fill your Web page with the text from a text file.

To insert text by importing a plain text file:

1 Make sure that you're in Edit mode.    
For information on switching to Edit mode, see Previewing your work.

2 Position the cursor where you want the text to display.
3 Using the Local Site window, select the plain text file.

For more information see, Opening a Local Site window.
4 Drag the plain text file from your Local Site window and drop it on your Web page. 

The contents of the text file displays on your Web page.



 Generating paragraphs and line breaks
{button See 
Also,AL(`Previewing_your_work;Saving_a_Web_page;Setting_global_preferenc
es;Starting_a_Web_page;Using_HTML',0,`',`')}

Paragraphs and line breaks generate different effects in the display of your Web page. 

Use a line break instead of a standard new paragraph if you want to create a space between lines without applying the previous 
paragraph's formatting. You can also use multiple line breaks to display multiple lines without text, However, a paragraph marker 
cannot generate multiple empty lines in a Web browser because HTML specifications allow only one empty paragraph line.

To generate a new paragraph:
1 Place the insertion point where you want the new paragraph to start.
2 Press the Return key.

Your cursor goes to a new line and Visual Page generates a paragraph tag in the HTML source.

To create a line break:
1 Click where you want the new paragraph to start.
2 Press Shift-Return. 

Visual Page generates a line break (<BR>) tag in the HTML source.

Note: You can set the Return Key to generate either a break or a Paragraph tag in the Output Preferences .



 Aligning and indenting paragraphs
{button See 
Also,AL(`Generating_paragraphs_and_line_breaks;Previewing_your_work;Typi
ng_text',0,`',`')}

You can make paragraphs line up against the left margin, the right margin, or the center of the Web page by setting paragraph 
alignment. You can also format by indenting paragraphs.

To align a paragraph:

1 Click anywhere within the paragraph.

2 Click on one of these three alignment toolbar buttons:  . The choices are left-aligned, center-aligned, and right-
aligned, respectively. You can also choose, from the Format menu, Align Left, Align Right or Align Center.

The paragraph aligns according to the alignment option you choose.

To indent a paragraph:

1 Click anywhere within the paragraph.

2 Click on one of these two indent paragraph toolbar buttons: . The choices are Decrease Indent and Increase 
Indent , respectively. You may also choose Format > Increase Indent or Format > Decrease Indent.

The paragraph indent changes. 



 Formatting paragraphs
{button See 
Also,AL(`Adding_text;Formatting_characters;Generating_paragraphs_and_line
_breaks',0,`',`')}

Apply paragraph formats to make sections of text display differently, such as headings, quotes, and mono-spaced (preformatted)
text. Visual Page supports these paragraph formats:

Normal 

Headings 

Preformatted 

Address 

To apply a format to a paragraph:
1 Click anywhere in a paragraph.
2 Choose a format from the pop-up menu on the toolbar, or from the Format menu. 

Visual Page formats the paragraph accordingly.

Note:    Generally, the look and feel of paragraph formats are ultimately determined by Web browser settings rather than by the 
formats you apply.



 Normal paragraph style
{button See 
Also,AL(`Adding_text;Formatting_characters;Generating_paragraphs_and_line
_breaks;Heading_paragraph_style',0,`',`')}

Normal text is the default style which is applied when you begin a new paragraph on a blank page. (The paragraph you are 
reading now is formatted with the Normal tag.) The text appears flush left in the page window and is displayed in the Visual Page
default font. 

Use the Normal style for most text in a Web page.



 Heading paragraph style
{button See 
Also,AL(`Adding_text;Formatting_characters;Generating_paragraphs_and_line
_breaks;Normal_paragraph_style',0,`',`')}

Heading tags are used to make headlines or titles distinct from the rest of the text in a page. In general, headings are larger than 
the Normal style, and are in a bold type face. 

You may also manually specify the font size of a text block instead of using the Heading style. 

The heading types supported by Visual Page are:



 Preformatted paragraph style
{button See 
Also,AL(`Adding_text;Formatting_characters;Generating_paragraphs_and_line
_breaks;Using_HTML',0,`',`')}

The Preformatted paragraph style is used as a way to maintain text formatting that uses multiple spaces and tabs, such as the 
formatting found in code segments. 

Preformatted paragraphs are displayed in monospaced fonts, such as Courier. You can see an example of a preformatted 
paragraph in the following HTML code sample:



 Address paragraph style
{button See 
Also,AL(`Adding_text;Normal_paragraph_style;Formatting_characters;Generati
ng_paragraphs_and_line_breaks',0,`',`')}

Web page authors typically apply the address style to a paragraph containing a signature address. An example of how it is used 
is shown below:

Send comments to the author:

webmaster@symantec.itools.com

Choosing to include an address is a matter of style. When you include an address, remember to make it an email link.

Note: This tag does NOT create a link to an email address!    To create an email link, see Creating email links.



 Formatting characters
{button See Also,AL(`Adding_text;Formatting_paragraphs;Using_HTML',0,`',`')}

You can format individual characters to make words display differently, rather than affecting a whole paragraph. You can format 
individual characters by changing character styles or character size.

To apply a character style:
1 Select the character:
2 From the Style menu, choose a style, color, or size.    You can also select a style, color, or size by clicking one of the toolbar 

buttons.

Physical character styles include the following standard HTML styles:

The Bold, Italic, and Fixed Width Font styles can be quickly accessed by these toolbar buttons:

Visual Page also supports these Netscape extensions to standard HTML character styles:

How these styles will appear depends on each browser's default settings.



 Changing character size
{button See 
Also,AL(`Adding_text;Formatting_characters;Formatting_paragraphs',0,`',`')}
The size of text in a Web page is relative to the default size setting for each browser. This is why the font sizes in the Size menu 
item (on the Style menu) are relative numbers 1 through 7, instead of the point sizes you see in a word processor, such as 12 or 
14.

Visual Page uses the middle font size (number 4) as the "normal" font size. This is the browser's default display font. The other 
numbers signify either a smaller or larger font than the browser default, with 1 being the smallest font size and 7 the largest font 
size.

To change the size of a character:

n Click Decrease Font Size  or Increase Font Size 

 on the toolbar. You can also choose Size from the Style menu, and then choose a number. 
A checkmark displays next to the selected size.



 Creating bulleted lists
{button See 
Also,AL(`Adding_text;Generating_paragraphs_and_line_breaks;Creating_order
ed_lists;Creating_term_and_description_lists',0,`',`')}

Bulleted lists are useful when you want to make some information easy to see. Visual Page supports bulleted lists and indented 
bulleted lists. 

To create a bulleted list:

1 Select the text you want to change to bulleted list style.
2 From the Format Paragraph drop-down list on the toolbar, select Bullet List. You can also select Format > List > Bullet.

Visual Page indents the text and places a bullet character to the left of the text in the paragraph. 

3 You can apply indentation to the bulleted list by using the Increase Indent  toolbar button to a bulleted paragraph. 
When you apply added indentation to a bulleted paragraph, the look of the bullet changes with the indentation.



 Creating ordered lists
{button See 
Also,AL(`Adding_text;Creating_Bulleted_lists;Generating_paragraphs_and_line
_breaks;Creating_term_and_description_lists',0,`',`')}
When you apply any of the ordered list formats to a paragraph, Visual Page indents the text and places a number or letter to the 
left of the paragraph. 

To create an ordered list:

1 Select the desired text.
2 Select Format > List and choose the desired type of ordered list.

To create a numbered list:
1 Select the desired text.
2 Click the paragraph tag drop-down list on the toolbar, and select the Numbered List tag.



 Creating term and description lists
{button See 
Also,AL(`Adding_text;Creating_Bulleted_lists;Generating_paragraphs_and_line
_breaks;Creating_ordered_lists',0,`',`')}
The term and description formats are designed to be used together in lists of definitions. The format is similar to what you would 
find in a Glossary. 

Applying the Term format to a paragraph places the paragraph text flush left at the left margin. When you press the return key 
after applying a Term format to a paragraph, Visual Page automatically applies the Description format, then indents the text of 
the paragraph.

To create a term and description list:

1 Select the text which you want in the term format.
2 From the paragraph tag drop-down toolbar button select Term.

The selected paragraph displays in the Term format. 
3 Select the text which is to be in the definition format.
4 From the paragraph tag drop-down toolbar button select Definition.
5 Repeat steps 1-4 for the remaining terms and definitions.

Note: You may also select Format > Term or Format > Definition from the menus.



 Adding graphics
{button See 
Also,AL(`Adding_text;Adding_horizontal_lines;Aligning_graphics_and_text;Set
ting_image_attributes',0,`',`')}

You can add graphics to your Web pages by either using drag-and-drop, the Insert Image toolbar button, or copy and paste. 
Graphics must be in BMP, DIB, GIF, or JPEG graphic format before you can insert them into a Web page. Visual Page 
automatically converts .bmp and .dib files into interlaced GIF files when you place them in your Web page. There is a setting in 
the Image Preferences for storing the new GIF files from these conversions. 

To add a graphic by using drag-and-drop:

1 Open the Local Site Window, and navigate to the desired graphic's location.
2 Select desired graphic file, and drag it over to your Web page. 

The image appears full size in your Web page.

You can also drag and drop graphics from another open Web page, as long as the browser supports drag and drop.

To add a graphic by using Insert Image:

1 Place your cursor at the desired location.

2 Click on the Insert Image button ,or choose Image from the Insert menu. 
A standard Open file dialog box opens. 

3 Navigate to the graphic file you want, and click Open. 
The image displays in your Web page.

To add a graphic by using copy and paste:

1 Copy a selected graphic to your clipboard.
2 Paste it into your Web page. 

The image displays in your Web page.

Note: You must either own the graphic image or have the owner’s permission in order to use it in your Web page.



 Aligning graphics and text
{button See 
Also,AL(`Adding_graphics;Aligning_paragraphs;Flowing_text_around_graphic
s;Generating_paragraphs_and_line_breaks;Setting_image_attributes',0,`',`')}

You can align graphics in a variety of ways. Using graphic alignment settings you can also flow text around graphics. You can 
see a good example of how to format images with text in the Visual Page Getting Started tour. 

To align graphics:

1 Use the Graphic Alignment button  on the Visual Page toolbar. You can also choose Graphic Alignment from the Settings
menu.

2 Select the graphic alignment you want.
In general, use the first three options, Top, Bottom, Middle, for small graphics that appear in a line of text, like the image in 
step one. You use the Left and Right alignment options when you want to flow a paragraph of text around a larger graphic.

To flow paragraphs of text around graphics:

1 Select the graphic.
2 Select Left from either the Graphic Alignment toolbar button, or choose Object Alignment from the Format menu.
3 Insert your cursor to the right of the graphic and enter a paragraph or two of text. When the line wraps it returns to the right 

edge of the graphic, until it reaches the bottom of the graphic.

Note: You can add some whitespace around the image by setting the Space Around Image properties in the Image Properties 
dialog box.



 Creating transparent graphics
{button See 
Also,AL(`Adding_graphics;Aligning_graphics_and_text;Setting_image_attribut
es',0,`',`')}

This feature is useful if your Web page has a colored background which is obscured in part by an opaque graphic image. In this 
case, you could use Visual Page to make the image transparent so the background color would show through. Only GIF files can
be made transparent.

To make your image transparent:

1 Open the graphic file. For more information, see Opening a graphic image file.
The graphic displays in the Visual Page's graphic editor.

2 Click the transparency  toolbar button on the Image Tools Toolbar.
3 Click any color in the image and that color is rendered transparent.

When you put the altered graphic in a Web page, you see the Web page's background through the image. 

4 To revert a transparent graphic and thus remove the transparent quality, click the Remove Transparency  toolbar button 
on the Image Tools Toolbar.



 Setting graphic image properties
{button See Also,AL(`Adding_graphics;Setting_preferences',0,`',`')}

Visual Page supports a range of attributes that are contained within any supported graphic. These attributes control the height, 
width, function, alternate text, and spacing around a graphic.

To set a graphic image’s properties:

1 Make sure that you're in Edit mode. 
For information about how to switch to Edit mode, see Previewing your work.

2 Select a graphic in a Web page.
3 From the Edit menu, select Properties, then choose Image Properties.
4 Use the options in the Image Properties dialog box to set the graphic’s attributes. These attributes are described in the table 

below.
5 Click OK. Your graphic’s settings are adjusted accordingly.

Attribute Description

Image The location and filename of the image file.

Width The display width of the image, in pixels.

Visual Page supports image scaling (changing an image's height and width). The width and height indicated in 
the Image Setting dialog box are the dimensions of the image as scaled in the HTML file. The actual dimensions 
of the image are indicated in the Original Width and Original Height fields, as described below.

Height The display height of the image, in pixels.

Original width The width of the source image, in pixels.

Original Height The height of the source image, in pixels.

Horizontal The blank space to the left and right of the image, in pixels. The default setting is zero.

Vertical The blank space to the top and bottom of the image, in pixels. The default setting is zero.

Border The width of the border around an image, in pixels. An image border is black and is similar to a frame around a 
painting. The default setting is zero, which indicates no border.

Image Select this option if the graphic file functions only as an image. This is the default function for graphic files.

Has server map Check this box if the graphic file acts as a server-side image map.

Submit form button Select this option if the graphic file acts as submit button for a form. 

Alternative text If you type in text here, it displays in a user's browser if the image doesn't load properly, or if it can't be displayed 
by a user's browser.

Note: The alternative text option is not for graphic files that function as a form submit button.

Button name (For buttons only) The name of the button. This is NOT the same as the name of the button's source file. A CGI 
script uses this name as an ID.

 Creating image maps
{button See Also,AL(`Adding_graphics;Creating_links_and_anchors',0,`',`')}

Client-side image maps store the coordinates that define the linked areas of an image. These image maps are inserted directly 
into the HTML file. As such, the image map is downloaded to and referenced entirely from the user’s machine (hence the name 
client-side). Visual Page creates these Image maps for you as you use drawing tools to outline and link areas of an image. 



To create a client-side image map:
1 Make sure that you're in Edit mode. For information about how to switch to Edit mode, see Previewing your work.
2 Insert a graphic by clicking the Insert Graphics toolbar button. For information on inserting graphics, see Adding graphics.
3 Right-click on the graphic and select Local Map Tools or select View > Toolbars > Image Tools from the menus.
4 The Image Tools toolbar displays.

5 Create the clickable areas of the image by doing the following:

  Click the rectangle, circle, or polygon Hotspot buttons  on the toolbar.

  Click and drag on the graphic file to create a hotspot area.
  To end creating a polygon hotspot, double-click. To end creating a circle or

   rectangle hotspot, release the mouse button. 
6 Create the URL for each of the clickable areas. 

You can do this by either dragging a file or anchor icon from the Local Site window onto the selected link area, typing the link 
address into the Link field at the bottom of the main edit window, or right-clicking on the desired link location to open the Link 
To dialog box. You may also double-click on the hotspot to open the Link To dialog box.

To move overlapping hotspots:
1 Select a hotspot you want to move forwards or backwards.

2 Click the Front-to-back Order button  on the Image Tools toolbar.
3 Choose Move to Front, Move Forward, Move to Back, or Move Backwards.

The hotspot will change position.

To delete hotspot areas:
Select the hotspot area, and press Delete.

To save your client-side image map:
Select File > Save or press Ctrl+ S. 

To make the shapes easier to see, specify the color of these areas by choosing the desired color from the color menu button.

You may also use the Zoom buttons  to adjust the graphic to the optimal size for outlining links.



 Creating a background
{button See Also,AL(`Setting_Web_page_preferences',0,`',`')}

You can create a colored or tiled background for your Web page.

To create a colored background:

1 In an open Web page document, click on the Page Properties  toolbar button.
2 Choose a color from the Background color well. If you want the background set according to each browser's default settings, 

select Default.

Using a graphic file to tile your Web page background:

1 In an open Web page document, click on the Page Properties  toolbar button.
2 Click the Background Image checkbox. 

An Open File dialog box appears.
3 Navigate to the graphic file you're going to use, then click Open.    

A representation of the tiled graphic appears.
4 Check the appearance of the tile on your Web page by clicking on the Apply button. A graphic may look interesting by itself, 

but may not be appropriate for use as a tiled background.

To remove a background image:
Uncheck the Background Image checkbox.



 Adding horizontal lines
{button See Also,AL(`Adding_graphics;Adding_text',0,`',`')}

Horizontal lines can be useful layout tools which can be used to break up a long Web page. However, they should be used 
sparingly or your Web page will appear to be choppy. Horizontal lines are easy to add in Visual Page and you may even play 
with their appearance by setting their properties. 

To add a horizontal lines:

1 Place your cursor where you want the line to be inserted.

2 Click the Insert Horizontal Line  toolbar button.

To change the properties of a horizontal line:

1 Select a horizontal line by clicking directly on it..
2 Choose Edit > Properties > Line Properties (or press F4). 

The Line Properties dialog box displays.
3 Set the shading, size, and alignment using the dialog box.

Warning:    The Horizontal line alignment property overrides the alignment of the line's paragraph.

For more information see Horizontal line properties .



 Creating links and anchors

Hypertext links, also known as links, are one of the most important parts of a Web page. Links allow you to connect Web pages 
together. 

The following topics tell you more about creating and using links in your Web pages:

Creating links with the Create Link dialog box 

Creating links with the Link Toolbar 

Creating links with the Site Window 

Copying an existing link 

Creating email links 

Creating and linking anchors 

Testing links 

Creating image maps .



 Creating links with the Create Link dialog box
{button See Also,AL(`Adding_text;Testing_links',0,`',`')}

You can create a link to a selected object by using the Create Link dialog box. Using this dialog box, you can either enter the 
URL yourself or browse to locate the file you're linking to so Visual Page will generate the URL. 

To create a link with the Create Link dialog box:

1 Select the object to be linked.

2 Click the Hyperlink button  in the Insert toolbar. The Link dialog box displays.
3 Determine the file to be linked by either typing in the filename or URL of the file, or by clicking Browse and navigating to the 

file you want. 
Your link is created.



 Creating links with the Link Toolbar
{button See Also,AL(`Adding_text;Testing_links',0,`',`')}

The Link Toolbar displays at the bottom of the Visual Page window. It consists of a label and a text field. 

To create a link using the Link Toolbar:

1 Select the object to be linked.
2 At the bottom of the Edit window, select the Link to field in the Link toolbar.

If you do not see the Link to field at the bottom of the Edit window, select Toolbars > Link to make the link field display.
3 Type in the filename or URL in the Link to edit box. 
4 Pressing Return and your link is created.



 Creating links with the Local Site Window
{button See 
Also,AL(`Adding_text;Testing_links;Using_the_Local_Site_Window',0,`',`')}

You can use the Local Site window to drag-and-drop files on selected objects in your Web page to create a link. 

To create a link using the Local Site window:

1 Open a Local Site window for your current project. 
For more information see Opening a Local Site window. 

2 Select the text or graphic image on your Web page that you want to link.
3 Drag the file or anchor you want to link to from the Local Site window and drop it on the selected object. 

The link displays on your Web page.



 Copying an existing link
{button See Also,AL(`Adding_text;Testing_links',0,`',`')}
If you want multiple links to the same place, such as to a home page, you can create the link once and copy and paste the rest of
the links.

To copy an existing link:

1 Select the link you wish to copy.
2 From the Edit menu, choose Copy (or press Control-C).
3 Click where you want the link to be copied to.
4 From the Edit menu, choose Paste (or press Control-V).



 Creating email links
{button See 
Also,AL(`Adding_text;Address_paragraph_style;Testing_links',0,`',`')}

When an email link is clicked on, the browser opens up a pre-addressed email message window.

To create an email link:
1 Create the link text that will display on a Web page. For example:

user@company.com
2 Highlight the link text.
3 Click on the Link to: field and enter the text in the following format:

mailto:user@company.com
4 Replace user with the email address of the person being emailed, and company.com with their Internet address.

Note: The mailto: link is not the same as the <ADDRESS> tag.    For information on the Address tag, see Address paragraph 
style .



 Creating and linking anchors
{button See 
Also,AL(`Creating_links_and_anchors;Testing_links;Using_the_Site_Window',0
,`',`')}

Anchors are used to mark specific locations within a document. Once an anchor is placed in a location, you can create a link to 
that spot.

To add an anchor to a Web page:
1 Click in your Web page where you want to put the anchor.

2 Select on the Insert Anchor  button in the Insert toolbar or select Insert > Anchor. 
The Anchor Properties dialog box displays.

3 Name the anchor, and click OK. 

An anchor icon  appears in your text.
4 Select the object to be linked to the anchor.

5 Click Create Link button  in the Insert toolbar or right Click and select Link to. 
The Link to dialog box appears.

6 Select the anchor from the drop down list box and click OK.
The link to the anchor is displayed next to the object.



 Testing links
{button See Also,AL(`Adding_text;Previewing_your_work',0,`',`')}

You should test your links periodically to make sure they work. It's easy to break links when you're constructing Web pages. 
Since links are really URLs which record the location of a file or anchor, you can break a link by inadvertently changing the name
of a file or of the folders in which the file resides.

To test links in your Web pages, use one of the following methods:
n In Edit Mode, hold down the Control key while clicking over the link. This opens the linked file.
n From the Edit menu, choose Preview in Browser. Your Visual Page document opens in the Web page browser which resides 

on your hard disk. You can then browse your document as you would any Web page.
n From the Edit menu, choose Go To Preview Mode. You can browse and click while still within Visual Page.



 Creating frames
{button See 
Also,AL(`Changing_a_frame_file;Setting_a_frame_s_attributes;Setting_the_fra
me_target;Setting_Web_page_preferences',0,`',`')}

Frames divide the parts of a Web page into two or more independent parts (frames), each displaying a separate HTML file. 

To create a Web page that includes frames:

1 Choose File > New Frame Set or press Ctrl + Shift + N.
Visual Page displays a frame file with two frames of equal size.

2 You may directly add the text, HTML tags, graphics, and plug-ins to each frame, or you may open an existing Web page file in 
a frame. For more information, see Setting the frame source.

3 Save your Web page in a folder dedicated to your collection of Web pages.
For more information, see Saving a Web page with frames.

Additional Frame Set functions include:

Opening a frame in a new window 

Setting a frame's attributes 

Setting the frame target 

Resizing a frame 

Removing a frame 

Splitting frames 

Editing the No Frames settings 



 Resizing a frame
{button See Also,AL(`Creating 
_frames;Setting_a_frame_s_attributes;Starting_a_Web_page',0,`',`')}

Resizing a frame can be done visually on the Web page by dragging frame borders or via the Frame Properties dialog box. 

To resize a frame:

n Use the resize bar  to resize the frame manually.    You can also choose Edit > Properties > Show Frame Properties, and 
enter the desired width in the Width field.

For more information about the Width field, see Setting a frame's attributes .



 Removing a frame
{button See Also,AL(`Creating 
_frames;Setting_a_frame_s_attributes;Starting_a_Web_page',0,`',`')}

If you add too many frames to your Web page you can use the following procedure to remove the selected frame. 

To remove a frame:

1 Open the main frame file.
2 Select the frame file to be removed.
3 Choose Frame > Remove Frame.

Note: Removing a frame doesn’t delete the frame file contained within the frame, only the frame itself.



 Splitting frames
{button See 
Also,AL(`Creating_a_framed_page;Setting_the_frame_target;Starting_a_Web_p
age',0,`',`')}

Visual Page lets you add frames by splitting existing frames into two equal parts, either horizontally or vertically.

To split a frame:
1 Open the main frame file.
2 Select the frame to be split.
3 Choose Frame > Split Frame Vertically or Frame > Split Frame Horizontally. The frame is split.



 Editing the No Frames setting
{button See 
Also,AL(`Adding_text;Creating_a_framed_page;Previewing_your_work;Setting
_a_frame_s_attributes;Starting_a_Web_page',0,`',`')}

The No Frames window lets you specify what content will display when a user's browser doesn't support frames. 

To use the No Frames window:
1 Open the main frame file.
2 Choose Frame > No Frames Page. 

The No Frames page displays.
3 Enter or edit the content of the page.
4 Close the No Frames page.



 Opening a frame in a new window
{button See 
Also,AL(`Creating_a_framed_page;Modifying_frames;Setting_a_frame_s_attrib
utes;Starting_a_Web_page',0,`',`')}

If you have many Web pages which are accessed through the same Web page with frames you may want to navigate your Web 
site in Preview mode. When you see a displayed file that needs editing, opening a frame into a separate window makes it easier 
to edit the Web page.

To open a frame file in a new window:

1 Open the main frame file.
2 Select the frame to be opened in a new window.
3 Choose Frame > Open in New Window. 
The frame file opens in a new window.



 Setting a frame's attributes
{button See 
Also,AL(`Creating_a_framed_page;Modifying_frames;Opening_a_frame_in_its_
own_window;Setting_a_frame_s_attributes;Setting_Web_page_preferences',0,`'
,`')}

Frames have a set of properties you can set. Most of these can be changed as you visually edit the page. The frame properties 
are described below. 

To edit a frame's properties:

1 Choose Edit > Properties > Show Frame Properties. 
2 The Frame Properties dialog displays.
3 Use the options in the Frame Properties dialog box to set the frame’s attributes. 

These attributes are described in the table below.
4 Close the Frame Properties dialog.

Attribute Definition

Source The HTML source file for a frame.

Frame title The frame's name. This is NOT the same as the name of the source file. The frameset file (the 
file that contains the frames within a frame set) uses this name as an ID.

Frame width The width of the selected frame, either as a percentage of the total frame set, or in pixels.

Frameset height The height of the frame set, either as a percentage of the total frame set, or in pixels.

Margin width The width of the selected frame's margin, in pixels.

Margin height The height of the selected frame's margin, in pixels.

Show scrollbar The settings for the frame's scroll bars. Possible choices are Yes, No, and Auto. The default is 
Auto, which makes the scroll bars appear only when the frame extends beyond the length of 
the active window.

Resizable frame Indicates whether or not the selected frame resizes along with the user's browser. The default 
is checked, which indicates that the selected frame will resize



 Setting the base target for a frame
{button See 
Also,AL(`Creating_a_framed_page;Creating_links_and_anchors;Modifying_fra
mes;Opening_a_frame_in_its_own_window;Setting_a_frame_s_attributes;Testi
ng_links',0,`',`')}

Visual Page allows you to select a base target for all the links in a frame. An example of using a base target is to direct all the 
hypertext links in a left-hand frame to appear in the neighboring right-hand frame. 

To set a base target for the links in a frame:

1 Open a frame set, and make sure the frames are already named and saved.
2 Make sure that you're in Edit mode. 

For information about how to switch to Edit mode, see Previewing your work.
3 Click on the frame you are setting as a base target. 
4 Choose Edit > Properties > Page.
5 Click the Select Base Target button. The Base Target dialog displays.
6 Click a frame in the reproduction of your frame set. Set a base target for that frame by selecting one of the Base Target 

options. 
The Base Target options are described below.

7 Click OK to set the base target for the selected frame.
Tip:    To set the base target for additional frames in your frame set, repeat steps 6 and 7 for each frame.

Base Target option Description

Default Makes the linked file display in the same frame as the current frame file. This is the default setting. How 
the default setting performs depends on each browser’s configuration.

New window Makes the linked file display in a new, untitled window.

Same frame Makes the linked file display in the same frame as the current frame file.

Same window Makes the linked file display in the same window as the current frame file.

Parent window Makes the linked file display in the parent window of the current frame file. The parent window is the 
window that was active, then a link opened which caused the current frame file to display.



 Creating tables
{button See Also,AL(`Adding_text',0,`',`')}

Tables can hold all kinds of Web page elements and are useful in formatting and page layout tasks. You can easily create tables 
in Visual Page. 

To create a table in a Web page:

1 Place the cursor where you want the table to display. 

2 Click the Insert Table  toolbar button on the Insert Toolbar or choose Insert > Table > Table. 
The Table Settings dialog box displays. 

3 Set the number of rows and columns for your table.
4 Click OK. 

The new table displays.

You can also perform the following tasks:

Inserting rows 

Inserting columns 

Deleting rows 

Deleting columns 

Changing multiple cells 

Resizing rows, columns and tables 

Spanning rows and columns 

Adding color to tables 

For information on setting the attributes of a table, see Table settings.



 Inserting rows
{button See Also,AL(`Adding_text;Deleting_rows;Table_Properties',0,`',`')}

You can have Visual Page insert a new row either before or after the one in which you placed the insertion point. 

To insert a row after the current row:

1 Place the cursor where you want the row to be inserted.
2 Choose Insert > Table > Row.

The row is inserted.

To insert a row before the current row:
n Choose Insert > Table > Row Before. The row is inserted below the current row.



 Inserting columns
{button See Also,AL(`Adding_text;Deleting_columns;Table_Properties',0,`',`')}

Visual Page allows you to insert a column to the right or left of the column in which you placed the insertion point. 

To insert a column to the right of the current column:

1 Place the cursor where you want the column to be inserted.
2 Choose Insert > Table > Column.

The column is inserted.

To insert a column to the left of the current column:
n Click Insert > Table > Column Before. A column is inserted to the left of the current column.



 Deleting rows
{button See Also,AL(`Adding_text;Inserting_rows;Table_Properties',0,`',`')}

In Visual Page you can designate a row to be deleted. 

To delete a row or rows:

1 Select a row or set of rows to be deleted.
2 Choose Insert > Table > Delete Row

The row(s) are deleted.

Tip:    Click the Delete Row  button in the Insert toolbar. The current row is deleted.



 Deleting columns
{button See Also,AL(`Adding_text;Inserting_columns;Table_Properties',0,`',`')}

Visual Page allows you to delete multiple columns. 

To delete more than one column:

1 Select a column or set of columns to be deleted.
2 Choose Insert > Table > Delete Column

The column(s) are deleted.

Tip:    Click the Delete Column  button in the Insert toolbar. The current column is deleted



 Changing multiple cells
{button See 
Also,AL(`Aligning_paragraphs;Formatting_characters;Formatting_paragraphs;
Table_Properties',0,`',`')}

Visual Page allows selection of multiple adjacent cells. Any selected set of cells may be formatted by applying the following:

Paragraph formatting 

Paragraph alignment

Character formatting 



 Resizing rows, columns, and tables
{button See Also,AL(`Adding_text;Table_Properties',0,`',`')}

You can customize tables by changing the size of rows, columns, or the table.

To resize a row or column:

1 Place the pointer over the border of the row or column you want to resize. 
The pointer changes to a resizing cursor.

2 Click on the row or column's border and drag the mouse until the row or column is the size you want.
3 Release the mouse button. 

The row or column displays at the new size.

To resize a table:

1 Select the table to be resized.
2 Click on the resizing handle (a square box) at the bottom right corner of the table and drag the mouse until the table is the size

you want.
3 Release the mouse button. 

The table displays at the new size.



 Spanning rows and columns
{button See Also,AL(`Adding_text;Table_Properties',0,`',`')}

Sometimes you want a cell in a table to span across multiple rows or columns.

To set a cell to span across multiple rows and/or columns:

1 Click on the cell that you want to enlarge.
2 Choose Properties > Table Properties or press F4. 

The Table Properties dialog displays.
3 Click on the Cells tab.
4 Enter the number of columns that you want the cell to span in the Span across columns field.
5 Enter the number of rows that you want the cell to span in the Span down rows field.
6 The cell now spans across the specified number of rows and columns. An example of a table with a spanned cell is shown 

below:



 Adding color to tables
{button See 
Also,AL(`Adding_text;Creating_a_background;Table_Properties',0,`',`')}

You can use Visual Page to set the background color of a cell or an entire table.

To change a cell's background color:

1 Select one or more cells.
2 Choose Properties > Table Properties or press F4. 

The Table Properties dialog displays.
3 Click the Cells tab.
4 Select the color you want from the Cell background color palette.

If you want to create a custom color, click Custom.

To change a table's background color:

1 Select a table.
2 Choose Properties > Table Properties or press F4. 

The Table Properties dialog displays.
3 Click the Table tab.
4 Select the color you want from the Background color palette.

If you want to create a custom color, click Custom.



 Table Settings dialog box
{button See 
Also,AL(`Creating_tables;Setting_Cell_properties;Setting_Table_properties',0,`',
`')}
This dialog box displays when you insert a table.

Entire table

number of rows

number of columns

space around text

space between cells 

table width

table height

border width

caption placement

background color

For more information about table properties, see Setting Table properties and Setting Cell properties.



Opening a graphic image file
There are several ways to open a graphic image file, including:
n Double-click on the graphic filename in the Local Site window
n Drag the graphic from the Local Site window and drop it on a Web page you're editing or into the main visual Page workspace 

window. 
n Choose File > Open, set the file type to the type of graphic image, navigate to and select the file, and click Open. 



 Configuring the FTP default settings

Visual Page allows you to configure default settings for your Web server, including:

n Server name
n Password
n User ID
n Folder name (directory)

For more information on configuring Visual Page's FTP settings, see Setting FTP Preferences. 



 Connecting to your Web server
{button See Also,AL(`Configuring_the_FTP_default_settings;Setting_global_preferences;IDH_Upload_file',0,`',`')}

Before you may use Visual Page's FTP capabilities you must establish a connection to your Web server.

To establish a connection to your Web server:
1 From the File menu, choose Open FTP Site. 

The Open FTP Site dialog box displays.
2 Enter the host name in the Host field, for example: ftp.yourServer.com.
3 If the server you're accessing requires a user name, enter the user name or log-in ID for your account in the User Name field, 

for example: JQPublic.
4 If the FTP site you're accessing requires a password, enter the password for your account in the Password field.
5 If you want to open to a particular folder on the server, enter it in the Directory field. In most cases, the server defaults to your 

home directory as your destination.
6 Click OK. 

The FTP window displays and Visual Page connects to your FTP site.

Tip:    If you don’t know your user ID or password, or are unable to connect to your Web server, contact your ISP or the technical 
support person for your network.



 Using the FTP window to download files
{button See 
Also,AL(`Setting_global_preferences;IDH_Upload_file;Disconnecting_from_the
_Web',0,`',`')}

You can use the FTP window to download a file from your Web server. For example, this feature is convenient if you are 
archiving an older version of your Web site, or have accidentally deleted a file from your Local site and want to replace it.

To download files from a Web server:

1 If you're not logged onto your Web server, do so now. 
See Connecting to your Web server for more information.

2 In the FTP window, which displays after you are connected, navigate to the folder on your Internet server where you store your
Web files. 

3 Select the file you want to download from the file list on the right side of the FTP window.
4 Click the Download button on the toolbar. It's the first button on the left. 
5 From the resulting dialog box, select the destination folder for the downloaded file on your local disk drive. If you need to 

change drives use the drop-down Drives menu at the bottom of the dialog box. 
6 Before downloading the files, click the Replace Files radio button you want. Your choices are:

Prompt: Asks you if you really want to overwrite a file before it downloads a file which is the same as one already in your local
directory. 
Update: Overwrites automatically if the file is newer than the one being overwritten.
Always: Immediately overwrites files without prompting.
Never: Never overwrites files. 

7 Click Download. 
The file downloads into the destination folder.



 Disconnecting from the Web
{button See 
Also,AL(`IDH_Upload_file;Connecting_to_your_Web_server;Setting_global_pre
ferences;Downloading_files_from_your_Web_server',0,`',`')}

Once you finish uploading and/or downloading your files, you need to disconnect from your Web server. 

To disconnect from your Web server:

n Close the FTP window.



 Deleting remote files
{button See 
Also,AL(`Creating_a_new_remote_folder;Mapping_folders;Renaming_remote_fi
les',0,`',`')}

You can use the FTP facility to delete files which are already published to your Web server or FTP site. 

To delete a file from your Web site:

1 Connect to your Web server. 
If you don't know how to log on to your Web server, see Connecting to your Web server .

2 In the file list on the right side of the FTP window, select the file you want to delete.
3 Click the Delete button on the toolbar. It is the button with an X on it. 

An Alert box displays, asking you to verify the delete.
4 Click Yes to verify the delete and permanently delete the file. Click No if you want to stop the process.



 Renaming remote files
{button See 
Also,AL(`Creating_a_new_remote_folder;Deleting_remote_files;Mapping_folder
s',0,`',`')}

You can rename remote files from within Visual Page by using the FTP window, if you have the server privileges that allow you to
change files on the Web server.

To rename a file from your Web site:

1 Connect to your Web server.
If you don't know how to log on to your Web server, see Connecting to your Web server .

2 In the file list on the right side of the FTP window, select the file you want to rename.
3 Click the Rename button on the toolbar (or press F2). If this button is dimmed, it probably means you don't have the privileges 

necessary to change the file name.
The Rename Remote File dialog box displays. 

4 Enter the new name in the New Name field and click OK. 
If the name doesn't appear in the FTP window, close the file or its parent folder, then open it again. The new name should 
display.



 Creating a remote folder
{button See 
Also,AL(`Deleting_remote_files;Mapping_folders;Renaming_remote_files;Uploa
ding_files_to_your_Web_server',0,`',`')}

You can use the Visual Page FTP window to create a remote folder from within Visual Page.    

To create a remote folder on your Web site:

1 Connect to your Web server. 
If you don't know how to log on to your Web server, see Connecting to your Web server .

2 Press the New Folder button in the FTP window.
3 Enter the folder name in the Folder Name field. 

The new folder is created,.



 Calculating a file's transmission time
{button See 
Also,AL(`Connecting_to_your_Web_server;Setting_global_preferences',0,`',`')}

Visual Page provides tools for determining the amount of time it takes for a Web page to transfer over a modem or other kind of 
Internet connection; given the file's content and the connection speed. If you minimize file transmission time on Web pages, 
users will be more likely to visit your Web site.

To determine the download time for a file:
1 Open the HTML file for which you want to determine the transmission time.
2 From the File menu, select Download Statistics. 

The Download Statistics dialog box displays. It consists of the following elements:

Total Document bar 

Selected Object bar 

Selected Frame bar 

Modem Speed drop-down menu 

Transmission times 

To calculate a time for a different baud rate, select the new rate from the Modem Speed drop-down menu. The recalculated 
transmission time displays in the right-hand side of the window.



 Mapping folders
{button See 
Also,AL(`Connecting_to_your_Web_server;Creating_a_new_remote_folder;Del
eting_remote_files;Renaming_remote_files;Setting_global_preferences',0,`',`')}

You can use Visual Page to map folders in your Local Web site to their remote counterparts. This feature allows you to replace all
references to your Local Site folder (on your desktop computer) with the Web site's remote folder URL. You should map your 
Local Site folders to your Web Site folders before you start creating pages—this will save you having to remap the folders if you 
decide to change folder names later.

Warning:    If you are not very familiar with the differences between remote and local file mapping, do not use this feature.    
Misuse of this feature may result in some or all of your links breaking.

To map your local folder to remote folders:
1 Choose Edit > Preferences. 

The Preferences dialog box displays.
2 Click Folder Mappings tab. 

The Folder Mappings preferences display.
3 Place the cursor in the first empty cell of the Remote column.
4 Type in the full pathname or URL of the remote folder.
5 Press Tab.
6 Type in the name of the local folder you want to map to the remote folder or URL.
7 Repeat steps 3-6 for any additional folders that you want to map.
8 If you want to override the specified local and remote folders, click Revert; otherwise, click OK. 

Your Local Site folders are now mapped to your Web Site folders.



 Creating forms

You can pass user information (such as names and addresses) back to your Web server by using Web page forms. Forms 
contain user interface elements, like radio buttons and text entry fields for data input. These forms then package the information 
by using CGI (Common Gateway Interface) scripts that process the form data and send it to your Web server.

Create forms in your Web pages by:

Inserting form elements 

Inserting multiple forms 

Using CGI scripts 



 Inserting form elements
{button See 
Also,AL(`Inserting_multiple_forms;Using_CGI_scripts;Using_HTML',0,`',`')}

Visual Page supports the standard user interface elements used in forms, such as radio buttons, check boxes, and input fields.

To add a form element to an HTML page:

1 Place the insertion point on the Web page where you want to place a form element.
2 From the Insert menu, choose Form Item.

A list of form elements displays.
3 Select the desired form element.

Visual Page inserts the form element on the visual part of the Web page and places the required <FORM> tag, in the source 
text. This automatically creates the structure for a Web page data-entry form. See Using CGI scripts for information about 
associating a CGI script with your form.    

Tip:  You can also use the Form toolbar to quickly add form elements to your Web page.



 Using CGI scripts 
{button See 
Also,AL(`Inserting_form_elements;Inserting_multiple_forms;Creating_forms',0,
`',`')}

CGI scripts and applications pass information from your Web page forms to your Web server. In most cases, you'll want to use 
an existing CGI script or application with your form. These are often available as freeware or from your ISP.

To access an existing CGI script on your local hard drive:

1 Choose Edit > Properties > Form. 
The Form Properties dialog box displays.

2 Enter the path and name of your CGI script in the Action field.
3 Select the type of method your CGI script uses from the drop-down menu. Your choices are Post or Get.

The Get method sends the user's information as part of the URL. 
The Post method sends the user's information as a separate data stream. 

4 Once you select a CGI script and method type, Visual Page inserts the proper HTML codes for your Web page to interact with 
your designated CGI script.



 Inserting multiple forms
{button See 
Also,AL(`Inserting_form_elements;Using_CGI_scripts;Creating_forms',0,`',`')}

Visual Page allows you to have multiple forms within a single Web page.

To insert multiple forms into a Web page:

1 Place the cursor where you want a new form to be inserted.
2 From the Insert menu, choose Form Item > Extra Form. 

A Form Properties dialog box displays.
3 Enter the path and name of your CGI script in the Action field.
4 Select the type of method your CGI script uses from the drop-down menu. Your choices are either Post or Get.



 Inserting a plugin
{button See Also,AL(`Inserting_a_Java_applet;Using_JavaScript',0,`',`')}

In Visual Page, you can insert plugin programs into your Web pages. Visual Page supports any plugin format that can be 
displayed by a standard browser.

To insert a plugin into your Web page:
1 Place the insertion point on your Web page where you want the plugin to display.

2 Click the Insert Plugin  toolbar button.
3 Navigate to the plugin file that you want to insert.
4 Click OK. 

The plugin is now inserted.
5 You can now modify the parameters of the plugin.



 Modifying the parameters of a plugin
{button See 
Also,AL(`Inserting_a_Java_applet;Modifying_an_applet_s_parameters;Inserting
_a_plug_in',0,`',`')}

Depending upon the plugin, it may be important to set or modify its parameters. You can modify the parameters of a plugin that 
you’ve inserted into your Web page as follows.

To modify the parameters of a plugin:

1 Double-click on the plugin's frame. 
The Plugin Settings dialog box appears.

2 Use the dialog box to specify the location, name, height, width, padding (horizontal or vertical), or custom parameter 
information (if applicable) for the plugin.



 Inserting a Java applet
{button See 
Also,AL(`Inserting_a_plug_in;Using_JavaScript;Using_the_Java_Console',0,`',`'
)}

In Visual Page, you can insert Java applets into your Web pages.

To insert a Java applet:

1 Place the cursor where you want the applet to display.

2 Click the Insert Java Applet  toolbar button.
3 An Open dialog box displays. 
4 Navigate to the applet that you want to insert and select it.
5 Click Open. 

An applet placeholder displays on your Web page and the applet is now inserted.
You can now Preview your work to see your applets running. If needed, you can also modify an applet’s parameters.



 Modifying an applet's parameters
{button See 
Also,AL(`Modifying_the_parameters_of_a_plug_in;Inserting_a_Java_applet;Usi
ng_the_Java_Console',0,`',`')}

Once you’ve inserted an applet into your Web page, you can modify its parameters.

To modify the parameters of an applet:

1 Double-click on the applet's frame. 
The Java Applet Settings dialog box appears.

2 Use the dialog box to specify the location, name, height, width, padding (horizontal or vertical), or custom parameter 
information for the applet. 
For more information, see Setting Java Applet properties .

Note: For information on creating custom parameters, consult the Java documentation for the applet class.



 Using the Java Console
{button See Also,AL(`Inserting_a_Java_applet;Using_JavaScript',0,`',`')}

The Java console is commonly used as the output window for a Java applet. For example, if you are debugging an applet, the 
place that the debugging statements commonly display is in the Java console. The Visual Page Java Console is the same 
console as the one that ships with Sun Microsystem's Java Development Kit (JDK).

To show the Java Console:
n From the View menu, choose Show Java Console. 

The Java Console displays.



 Using JavaScript

You can use JavaScript in your Web pages by:

Embedding JavaScript 

Calling a JavaScript file 

Note: Not all browsers support JavaScript, such as pre-2.0 versions of Netscape Navigator. Check this by consulting the 
documentation of the browsers you plan to support.



 Embedding JavaScript
{button See Also,AL(`Calling_a_JavaScript_file',0,`',`')}

JavaScript code can be embedded directly into a Web page. This cuts down on the overhead of maintaining a separate file for 
the JavaScript code.

To embed JavaScript codes into a Web page:

1 Place your insertion point on the Web page and enter your JavaScript code.
2 Select the block of JavaScript code you entered.
3 Choose JavaScript from the Style menu. 

Visual Page inserts a pair of HTML script tags at the beginning and end of the selected block, in the HTML source text.
4 Once you've entered the requisite JavaScript tags into your HTML file, you can edit the JavaScript codes in Visual Page's 

source editor.

Tip:    You can also enter your JavaScript codes directly into your HTML source file



 Calling a JavaScript file
{button See Also,AL(`Embedding_JavaScript',0,`',`')}

Saving your JavaScript code in separate files and calling them from a Web page as you need them, enables you to reuse 
JavaScript routines.

To call a JavaScript file from within a Web page:

1 From the Insert menu, choose JavaScript file. 
A dialog box displays, listing all of the files with the JavaScript (.js) filename extension.

2 Navigate to the folder containing the JavaScript file you want to use and select it.
3 Click Open. Visual Page displays a JavaScript icon on your Web page, and places a pair of <SCRIPT> tags in the HTML 

source text, using the following format:
<SCRIPT TYPE "JavaScript" SOURCE="symantec.js"></SCRIPT>

Tip: To ensure that Visual Page can recognize your JavaScript files, make sure that they end with a .js filename extension.



Overwrite options
Replace files with same name only if newer
This will only replace files if the source file has the same name as the target file, and the source file is a newer version of the file.

Always overwrite files with same name
This will only overwrite files that have the same name as the source file.

Never overwrite
This won't overwrite the file, regardless of conditions.



Total Document bar
This element in the Download Statistics window displays the transmission time for the file in the active window, at the baud rate 
indicated in the Modem Speed pop-up menu.



Selected Object bar
This element in the Download Statistics window displays the transmission time for the selected object (such as a GIF image), at 
the baud rate indicated in the Modem Speed pop-up menu.    If no object is selected, the displayed transmission time is set to 0 
seconds.



Selected Frame bar
This element in the Download Statistics window displays the transmission time for the selected frame, at the baud rate indicted in
the Modem Speed drop down list box. If no frame is selected, the Selected Frame bar doesn’t appear.



Modem Speed pop-up menu
This element in the Download Statistics menu displays the modem baud rate, also called modem speed.    To determine the 
download statistics for items at a particular baud rate, select the rate in the pop-up menu.



Transmission times
The calculated transmission time are displayed in the right side of the Download Statistics window.



 Starting a Web page
There are three ways to start a Web page in Visual Page:

Creating a new Web page
Opening an existing Web page 
Creating a Web page from a template 



 Creating a new Web page
{button See 
Also,AL(`Creating_a_Web_page_from_a_template;Opening_an_existing_Web_p
age;Saving_a_Web_page',0,`',`')}
There are essentially two kinds of Web pages you may create: a Web page with frames or a Web page without frames. A Web 
page with frames can display the contents of a different Web page in each of its frames. Like a picture holder that has multiple 
frames for displaying multiple pictures simultaneously, a framed Web page can display multiple Web pages simultaneously. A 
Web page without frames simply displays one Web page file. To continue the previous comparison, a Web page without frames 
is like a single picture frame that displays one photograph.

To create a new Web page:
1 From the File menu, select New (or press Control-N).

A new, untitled Web page opens in Edit mode.
2 Add graphics, text, plugins, links, and Java applets directly to your new Web page.
3 Save your Web page in a folder dedicated to your collection of Web pages.

To create a Web page that includes frames:

1 From the File menu, choose New Frame Set. 
Visual Page displays a Web page which is divided into two frames of equal size.

2 You may directly add the text, HTML tags, graphics, and plug-ins to each frame, or you may open an existing Web page file in 
a frame. For more information, see Setting the frame source .

3 Save your Web page in a folder dedicated to your collection of Web pages.



 Setting the frame source
{button See 
Also,AL(`Creating_a_new_Web_page;Creating_a_Web_page_from_a_template;
Saving_a_Web_page',0,`',`')}
A Web page with frames, also known as a frame set, can display multiple Web pages by having a different Web page assigned 
to each frame. You can set a frame to display a particular Web page by using the Set Frame Source menu item to assign a 
particular Web page HTML file    to the selected frame.    

To set the source file for a frame:
1 Make sure a frame is selected in an open Web page.
2 Select Frame > Set Frame Source.

A standard Open file dialog box displays.
3 Navigate to and select the HTML file you want the selected frame to display.
4 Click open.

A Visual Page Frame Save dialog box displays. 
5 Save the changes to the frame. 

If you have not given the frame a name, a Save As dialog box displays.
6 Enter a name for the frame and save it.

Visual Page displays the Web page in the selected frame.



 Starting from an existing Web page
{button See 
Also,AL(`Creating_a_new_Web_page;Creating_a_Web_page_from_a_template;
Saving_a_Web_page',0,`',`')}
The standard Visual Page installation places several professionally-designed templates in your Visual Page directory. You can 
use these pre-existing Web pages as the basis for your own Web pages. Opening a Visual Page template is the same procedure
you will use to open a Web page on which you have previously worked. 

To open an existing Web page:
1 Select Open from the File menu (or press Control-O).
2 Navigate to the directory where the file you want to work on is located.
3 Select the file, and click Open. 

The Web page opens in Edit mode.



 Creating a Web page from a template
{button See 
Also,AL(`Creating_a_new_Web_page;Saving_a_Web_page;Starting_from_an_e
xisting_Web_page',0,`',`')}
The Visual Page templates are provided expressly to provide you a starting place for the creation of your own Web pages. The 
advantage is that instead of beginning with a blank page, you can borrow from the professional design of the template and its 
Web page elements, including the: professional layout, text formatting, special graphic elements, and background. 

To create a Web page from a template:
1 From the File menu, select Open (or press Control-O).
2 Navigate to the Visual Page folder on your hard drive.
3 Locate and open the Web page file, Visual Page.html, in the Templates folder.

The Visual Page Designer's Toolkit home page displays.
4 If Visual Page is not already in Preview mode, switch to Preview mode by choosing View > Preview. 

Make sure you're in Preview Mode by moving the mouse over the buttons on the left side of the Visual Page Designer's Toolkit
home page. When in Preview mode, the mouse displays as a hand with one pointing finger. 

5 Click the Templates button on the Visual Page Designer's Toolkit home page. 
The Templates Web page displays with the text in the Templates button highlighted. 

6 To open a Template Web page, click once on any of the Web page thumbnail sketches appearing at the bottom of the 
Designer's Toolkit home page. 
The Web page you clicked on displays. Continue exploring until you find the Web page you like best.

7 With the template Web page open, choose File > Save As and give the Web page a new name (while keeping the HTML 
filename extension.)
You may now modify this copy of the template Web page and use it as the basis for your own content.



 Saving a Web page
{button See Also,AL(`Setting_global_preferences;Starting_a_Web_page',0,`',`')}
When you save a Web page file and name it, make sure that you preserve the HTML filename extension. All Web page files 
must end with a .html or .htm filename extension. Visual Page's default filename extension is .htm. You can change the 
default filename extension in the Preferences dialog box.

To save a Web page without frames:

1 From the File menu, choose Save or if you want to save a copy of a file with a different name, choose Save As.
2 Navigate to the destination folder for the saved file.
3 Enter the file name.

Visual Page includes the default file extension. 
4 Click Save.

The file is saved to the destination folder. 



 Saving a Web page with frames
{button See 
Also,AL(`Setting_Web_page_properties;Starting_a_Web_page',0,`',`')}
A frame set, or Web page with frames, has more than one HTML Web page file associated with it. The frame set file contains 
information about the Web page that contains the frames. And, each frame displays its own separate HTML file. So, when you 
save a frame set you probably will be prompted to name more than one Web page file. Visual Page's default filename extension 
is .htm. You can change the default filename extension in the Preferences dialog box.

To save a Web page frame set:

1 From the File menu, choose Save Frame Set. 
Or, if you want to save a copy of a frame set file with a different name, choose Save Frame Set As.

2 In the Save or Save As dialog box, navigate to the destination folder for the frame set and select it. 
3 Enter a filename with a .htm or .html extension. 
4 Click the Save button.

If you made changes to any of the frames in your frame set, the Save Frame or Save Frame As dialog box displays. 
5 If asked, enter a name for    the frame file, and click Save. 

If you made changes to other frames, another Save Frame or Save Frame As dialog box displays. 
6 Enter names and click Save until all the changed frame files are saved.



 Setting Web page properties
{button See Also,AL(`Setting_global_preferences;Starting_a_Web_page',0,`',`')}
By setting the properties for a particular Web page, you can specify the following characteristics:

n Title that displays in the title bar of the Browser application.
n Default Web page text color. 
n Background color and/or tiled image which displays beneath all the Web page elements.
n Hypertext link colors, this is where you can set the color for links: active , visited, and normal links.
n A base URLbase_URL which identifies the Web site folder for your Web pages.
n A base target, which is the display window or frame for the links in the Web page. 

In general, these are the properties or characteristics that you want to apply to an entire Web page. You set them for the active 

Web page, by choosing Page Properties from the Edit menu or by pressing the Page Properties  toolbar button.When the 
Page Properties dialog box displays, use it to set these options for your Web page. 

For more information on these options, see Setting page properties.



 Overview of preferences
{button See Also,AL(`Setting_Web_page_properties',0,`',`')}
Visual Page provides a variety of preferences settings that you can use to customize your Web page building environment. If you
choose Preferences from the Edit menu the Preferences dialog box displays. It includes tabs for:

n Setting General Preferences 
n Setting Output Preferences    
n Setting Images Preferences    
n Setting Folder Mappings Preferences    
n Setting FTP Preferences    
n Setting Syntax Color Preferences    



 Previewing your work
{button See 
Also,AL(`Printing_Web_pages;Saving_a_Web_page;Starting_a_Web_page',0,`',`
')}
To see how your Web page will look in a browser, use the Preview Mode. You'll know you're in Preview Mode when the Edit 

Page  toolbar button is active and the Preview Page toolbar button is inactive.

To go to Preview Mode:
n From the Edit menu, choose Preview Page. If instead you see Edit Page, you are already in Preview Mode. 

n You can also click the Preview Page  toolbar button. 



 Printing Web pages
{button See 
Also,AL(`Previewing_your_work;Saving_a_Web_page;Starting_a_Web_page',0,
`',`')}
Using Visual Page, you can print your Web pages as they will appear in a browser . If you want to print out the HTML source, 
make sure that the Source Window is active.

To print a Web page:
1 From the File menu, select Print (or press Control-P). 
2 Select the desired print options. 

Visual Page prints your document.



 Using HTML
Visual Page automatically generates HTML code for you as you create your Web pages in the visual editor. In addition to 
modifying Web content in the edit window, you can edit the HTML for your Web pages in the source editor. 

If you're familiar with HTML, you can work with HTML code by:

Viewing the HTML code 

Adding additional HTML tags 



 Viewing the HTML code
{button See 
Also,AL(`Adding_additional_HTML_tags;Adding_text;Previewing_your_work;Pr
inting_Web_pages',0,`',`')}
You can use the source editor to control the HTML in your Web pages. Using the source editor is similar to using a text editor to 
create HTML, but includes additional features such as automatic coloring of HTML tags.

To view or edit HTML code using the source editor:

Choose View > Source or press Ctrl + Shift + E. You may also click the Edit Source  toolbar button.



 Adding additional HTML tags
{button See 
Also,AL(`Adding_text;Previewing_your_work;Printing_Web_pages;Viewing_the
_HTML_code',0,`',`')}
You can insert HTML tags, including browser-specific tags, while editing your Web pages in the visual editor. 

To insert an HTML tag:
1 While in Edit mode, place the insertion point where you want the HTML tag to go.
2 From the Insert menu, choose HTML Tag.

The HTML tag dialog box displays. 
3 Enter the desired HTML tag into the HTML tag field, without opening and closing brackets (< and >). For example, to insert a 

<STYLE> tag, type STYLE.
4 After clicking OK, Visual Page inserts the tag. If it is a browser-specific tag, Visual Page represents it with a tag marker, as 

shown below:

Tip:    When inserting an HTML tag, make sure to include both the beginning and ending tags, when applicable.



 Using Keyboard Shortcuts in Visual Page
Command Shortcut

File Menu

New Ctrl + N

New Frame Set Ctrl + Shift + N

Open Ctrl + O

Close Ctrl + F4

Save Ctrl + S

Print Ctrl + P

Exit Alt + F4

Edit Menu

Undo Ctrl + Z

Cut Ctrl + X

Copy Ctrl + C

Paste Ctrl + V

Delete Del

Select All Ctrl + A

Link To Ctrl + L

Remove Link Ctrl + R

Spell Check F7

Find/Replace Ctrl + F

Find Next F3

Find Previous Shift + F3

Object Properties F4 

View Menu

Page Ctrl + Shift + P

Source Ctrl + Shift + E

Preview Ctrl + Shift + V

Preview in Browser Ctrl + Shift + B

Style Menu

Plain Ctrl + T

Bold Ctrl + B

Italic Ctrl + I



Increase Size Ctrl + ]

Decrease Size Ctrl + [

Format Menu

Normal Ctrl + K

Heading Alt + 1

Heading Alt + 2

Heading Alt + 3

Heading Alt + 4

Heading Alt + 5

Heading Alt + 6

Increase Indent Tab

Decrease Indent Shift + Tab



This is the F1, context-sensitive Help for Visual Page.



 Using the Visual Page main window

The Visual Page window is the main interface to the Web page editing environment. 

The main window consists of these elements: 

n Menus
n Toolbars
n Visual editor

Other important interface elements include the:

n Source editor 
n Local Site window 



 Using Visual Page menus

The Visual Page menus provide access to all Visual Cafe functionality. Most of the menu items are active only when a Web page
is open. However, most items in the Frame menu are available only when a Web page with frames is open.

These are the standard menus that are always available:

n File    
n Edit      
n View 
n Insert 
n Style
n Format
n Frame
n Window 
n Help



 Estimating download statistics

Use the Download Statistics window to estimate the time needed for your Web page or any of the objects it displays, to 
download over varying modem speeds. 

The Download Statistics window consists of these elements:

n Total document time indicator bar 
n Selected object time indicator bar 
n Modem Speed drop-down menu    

To calculate a time for a different baud rate, select the new rate from the Modem Speed drop-down menu. The recalculated time 
displays next to the appropriate time indicator bar.



 Setting page properties
{button See 
Also,AL(`Creating_a_new_Web_page;Creating_a_Web_page_from_a_template;
Starting_a_Web_page;Starting_from_an_existing_Web_page',0,`',`')}

By using the Page properties button or menu item, you specify options that affect the contents of the active Web page. This 
dialog box also allows you to determine a display target, known as the base target, for the links in the active Web page.

To set page properties:
1 Make sure a Web page is open and active.

2 Choose Edit > Properties > Page or select the Page Properties  toolbar button.
The Page Properties dialog box displays.

3 Set the Page properties according to the following descriptions.

Property Description

Page Title Text displayed in the title bar of the Web page browser when the finished Web 
page is viewed.

Colors:

Background: Color and/or tiled image to be displayed under the objects on your Web page.

Normal text: Default text color for the entire Web page.

Normal links: Color used to indicate linked text. 

Active links: Color that you see immediately after clicking on linked text.

Visited links: text changes to this color to indicate that you have previously visited a link.

URL settings:

Base URL Sets up an absolute (unchanging) path for your Web site folder. Visual Page 
defaults to creating relative URLs instead of "hardcoding" a base Web site 
folder. 

Base target Identifies the target window in which to display the linked files.

Select base 
target

Click to display options for a Web page with frames. 

 About the Local Site window

You can use the Local Site window to speed up the design process, as it allows you to:

n See all the files included in your Local Site 
n Click a file to view its anchors
n Create links by dragging-and dropping elements 
n Display the contents of a file instantly

For more information, see Opening a Local Site window, Viewing files in a Local Site window, and Creating links with the Local 
Site window.





 Opening a Local Site window

You can use the Local Site window in Visual Page to speed your Web page development process. Not only does it provide a 
handy window into the many files that can comprise a Web site, but you can quickly perform many drag-and-drop operations

To open a Local Site window
1 From the File menu, choose Open Local Site.
2 Use the Open Local Site dialog box to browse to and select the folder containing your HTML files. 
3 Click OK. 

The Local Site window for that folder displays. 



 Viewing files in a Local Site window

You can use your Local Site window to instantaneously view Web page files and graphic image files. To do this you simply drag a
file from the open Local Site window and drop it either onto a blank space in the main Visual Page window or on an open Web 
page. 

To see a list of files in a folder in the Local Site Window:
n Click on the plus next to the desired folder.

The folder contents display in an indented list under the folder.

To view a file or graphic image    from the Local Site Window:
n Drag a file from the Local Site window and drop it in on an empty part of the Visual Page main window.

The file displays instantly.

To copy a graphic image from the Local Site Window:
n Drag a graphic image file from the Local Site window and drop it on a Web page.

The image displays instantly in the web page.

To see a list of anchors in a file in the Local Site Window:
n Click on the plus next to a Web page HTML file. (One of these files is in your Visual Page > Tour > Walkthrough folder. )

The plus becomes a minus and a list of the anchor names displays, with anchor symbols next to them.

To open an anchor from the Local Site Window:
n Double-click on an anchor name.

The Web page opens, in Edit mode, to that anchor's location. 

To create links with the Site window:
n See Creating links with the Local Site window.



 Opening an FTP site
{button See Also,AL(`Configuring_the_FTP_default_settings',0,`',`')}

The Open FTP site dialog box contains the four fields described below. See Connecting to your Web server. If you often connect 
to the same site, such as your Internet Web server site, you can set the attributes in the FTP Preferences dialog box. Setting the 
network preferences allows Visual Page to use the attributes in the Open FTP site dialog box. 

Host Enter the name of the host Web server (for example, ftp.yourServer.com).

Directory Key in the name of your destination folder in this field. If you have set the server name in the FTP 
Preferences, this name displays here as your destination. 

User name Enter the user name or ID in this field, if required.

Password If the FTP site you’re accessing requires a password, enter it here.

Note:    If you don’t know your user ID or password, or are unable to connect to your Web server, contact your ISP or the 
technical support person for your network.



 Downloading remote files
{button See Also,AL(`Downloading_files_from_your_Web_server',0,`',`')}

If you know the URL of any FTP or WWW server site, you can use Download Remote File to retrieve a file from that location.

To download remote files from a Web server:
1 Choose File > Download Remote File.
2 Type in the URL of the file you want to download in the Remote file URL field. 
3 Click OK.
4 The Download remote file and save as dialog box displays. 
5 Navigate to the location where you want to save the file.
6 Make sure the file name appears the way you want it.
7 Use the drop-down menu to assign a type to the file.
8 Click Save.



 Creating links using Link To
This is one of the ways to create a link using Visual Page. To use it, you select a Web page object, like a word or graphic, or just 
place the insertion point on the Web page. If you don't select an object, Visual Page creates a link anyway, by inserting the file 
name as linked text into your Web page at the location of the cursor. You can use this dialog box to either directly enter the URL 
for the link or you can browse to locate the file. When you locate the file by browsing, Visual Page constructs the link for you. 

To create links using Link To:
1 Select an object or place the insertion point on the Web page. 
2 Choose Edit > Link To.

The Link dialog box displays.
3 Enter the URL to which you want to link or if you don't know the URL click the Browse button. 
4 A browse file dialog box displays that you can use to locate the file to which you want to link the selected item. Click once on 

the file to select it.
After you click Open in the Browse dialog box, the Link dialog box redisplays with the URL in it. 

5 If the selected file contains anchors, you can create a link to any of the anchors by choosing any of the anchor names from the
Anchor drop-down menu. 

For more information, see Creating links and anchors.



 Finding and replacing text

Visual Page provides the editing utility you need to find and replace text in a Web Page. The Edit menu provide three items 
which you can use, including:

n Find/Replace
n Find Next
n Find Previous

Before you can use the second two items in the above list, you must first choose Find/Replace from the Edit menu. This dialog 
box allows you to find and/or replace text within one Web page. You can use the Find/Replace dialog box to find and replace text
on a word-by-word basis or you can choose the Replace All option to find and replace all occurrences of the selected word. 

To find text within the currently active Web page: 
1. Make sure the insertion point is somewhere in the Web page you want to search. 
2. Choose Edit > Find/Replace.

The Find/Replace dialog box displays. 
3. Enter the text you want to find into the Find what field. 
4. If you want to replace it with new text, type the new text in the Replace field.
5. Though it's optional, you may choose any or all of the search options, which include: 

n Matching with whole words only
n Case sensitivity
n Wraparound searching 

6. After your search options are set, click the appropriate button to initiate any of the following operations: 
n Find, finds the nearest occurrence of the word
n Replace, let's you decide on a word-by-word basis whether to replace the found text
n Replace All, which quickly and automatically finds and replaces all the occurrences in the file. 



 Setting Form properties
Use the Form Properties dialog box to identify the CGI script or application on your hard drive and to change settings for how 
your form operates.

To assign properties for your Web page form:
1. Type in the name and path of the CGI script or application that this form uses in the Action field. 
2. Select the method of performing the action (Post or Get ) from the drop-down Method menu. 
3. Click OK and Visual Page inserts the HTML codes need for interaction between your Web page and the CGI item.



 Setting General preferences
{button See 
Also,AL(`Overview_of_preferences;Setting_Web_page_preferences;Starting_a_
Web_page',0,`',`')}

Use the General tab of the Preferences dialog box to set a group of miscellaneous Visual Page options. If you want to restore 
these preferences to the default settings, click Use Defaults. If you want to change back to the settings that were in place before 
you opened this dialog box, click Revert.

To set general preferences:
1 From the Edit menu, choose Preferences.

The Preferences dialog box displays. 
2 Click General tab.
3 Use the dialog box to select the global preference options you want. 

Show Anchors in the Local Site Window: Displays a plus symbol next to any file containing anchors. This option slows the 
opening of your Local Site window but can be handy.
Show only Web Page and Image Files in Local Site windows open: Limits the files displayed in the Local Site windows to 
nontext files. 
Insert an Invisible Character into New Table Cells: When unchecked this option displays tables with empty cells as invisible
areas
Run Java Applets: Allows you to see your Java applets working in the Preview Mode option - without leaving Visual Page.

4 When you’re finished setting preferences, click OK.



 Setting Output preferences
{button See Also,AL(`Overview_of_preferences',0,`',`')}

Use the Output tab of the Preferences dialog box to set the Visual Page preferences which are described below. If you want to 
restore these preferences to the default settings, click Use Defaults. If you want to change back to the settings that were in place
before you opened this dialog box, click Revert.

To set output preferences:
1 From the Edit menu, choose Preferences.

The Preferences dialog box appears. 
2 Click the Output tab.
3 Use the dialog box to select the output preference options you want.

The preferences are listed below.
4 When you’re finished setting preferences, click OK.

HTML File Extension Allows you to set the default filename extension as either htm or html.
Type of Line Separator Sets the line separator for the platform of your choice; Mac, UNIX, or Windows/DOS.
Return Key Generates Results in either a break or return, each of which is interpreted differently by Web browsers.
META attributes Determines the type of attribute to appear in the HTML source header of your Web pages. 

Check any of the following:
n Identify generator - Visual Page is the HTML generator
n Generate date and time - This can be a handy indication of versions
n Identify author name - Enter the author name here

 Setting Images preferences
{button See Also,AL(`Overview_of_preferences',0,`',`')}

Use the Images tab of the Preferences dialog box to set the Visual Page preferences described below: If you want to restore 
these preferences to the default settings, click Use Defaults. If you want to change back to the settings that were in place before 
you opened this dialog box, click Revert.

To set images preferences:
1 From the Edit menu, choose Preferences.

The Preferences dialog box appears. 
2 Click the Images tab.
3 Use the dialog box to select the Images preference options you want. The preferences are listed below.
4 When you’re finished setting preferences, click OK.

Converted Images Visual Page automatically converts .bmp and .dib files into interlaced GIF files. The following 
options tell Visual Page where to place the new GIF files.

n Always store the new GIF file in same folder as the source document
n Use this image folder

Default Image Map Server Format Visual Page supports server-side image maps if you need to use them. The two Server-Side 
image map formats are either CERN or NSCA. 



 Setting Folder Map preferences
{button See Also,AL(`Overview_of_preferences',0,`',`')}

Visual Page lets you map local folders to their remote counterparts. This feature can save you hours of changing references to 
local folders to their remote folder or URL counterparts. For example, if you have eight Web sites, all of which use the remote 
URL http://www.mysite.com/graphics to store graphics, you can map the URL to the respective graphics folders for your local 
sites, without having to change the links to the URL for all eight Web sites.

Use the Folder Mappings tab of the Preferences dialog box to set the following Visual Page preferences:

n Remote - The URL for the remote folder to which you wish to map your local folder
n Local - The URL for the local folder

Warning:    If you are not very familiar with the differences between remote and local file mapping, do not use this feature. 
Misuse of this feature may result in some or all of your links breaking. If you want to restore these preferences to the default 
settings, click Use Defaults. If you want to change back to the settings that were in place before you opened this dialog box, click
Revert.



 Setting FTP preferences
{button See Also,AL(`Overview_of_preferences',0,`',`')}

These settings are used by the Open FTP site dialog box. You can save yourself the trouble of setting them up every time you 
open the Open FTP site dialog box by setting them here. If you want to restore these preferences to the default settings, click 
Use Defaults. If you want to change back to the settings that were in place before you opened this dialog box, click Revert.

Host Enter the name of the host Web server, for example: ftp.yourServer.com

Directory Enter the name of your destination folder. 

User name If the FTP site you’re accessing requires a user name, enter the user name or ID.

Password If the FTP site you’re accessing requires a password, enter it here.

 Setting Syntax Color preferences

Use the Syntax Color tab of the Preferences dialog box to set text colors for different parts of your HTML source code, as shown 
in the source view of your Web page. The purpose is to make each of these syntax parts easy for you to spot in your code. 
Though it is assumed that you know what these parts of the HTML syntax are you could even use these setting to learn to 
identify the different parts of the HTML code without affecting the presentation of your finished Web page. You can assign a 
different text color to any of the following parts of the HTML code syntax:

n Plain text
n Tags
n Comments
n Attributes
n Values

If you want to restore these preferences to the default settings, click Use Defaults. If you want to change back to the settings that
were in place before you opened this dialog box, click Revert.

Tip:    For more information about what the various parts of the HTML code syntax are used for, consult any of the many HTML 
references in your local bookstore or library. 



 Setting Spacer properties

Spacers are invisible rectangular boxes, (unless selected) , which can be oriented either horizontally or vertically and set to a 
fixed pixel size. Spacers are used to create a fixed amount of empty space in the layout, which can't be changed or reset in the 
Web browser by the viewer of your finished Web page. Use the Spacer properties dialog box to change the following settings for 
spacer items:

n Orientation - horizontal or vertical
n Size - width or height, in pixels



 Setting Image properties

By using the Image properties dialog box you can: 

n Resize your image -this is handy if you have an image you want to use more than once in your Web site and want to optimize 
its size for the different locations

n Adjust the space around an image - this adds a fixed number of pixels of space horizontally or vertically around the image. Or,
you could opt to create a border of space around the whole image. You might want to add space around an object when it is 
embedded in some text or has text flowing around it

n Change the function of your image- besides functioning as inert object, images can be set to work with an image map, so links
can be embedded in the image, or as a Submit button which you would provide on a Web page form to transmit data in 
response to a user's click

n Alternative text - it's a god idea to provide a short caption which browsers that don’t display graphics will display instead of the
graphic



 Setting Java Applet properties

Use the options in the Java Applet Properties dialog box to set an applet’s attributes and modify applet parameters. These 
attributes are described below:

Location Folder containing the applet.

Name Applet's file name.

Width Width of the applet, in pixels.

Height Height of the applet, in pixels.

Horizontal space around Horizontal blank space around the applet.

Vertical space around Vertical blank space around the applet.

Parameters Customized parameters of the applet (if any) and their respective 
values. 

n For more information see Inserting Java applets. For information on creating custom parameters, consult the Java 
documentation for the applet class.



 Setting the base target

Use the Base Target dialog box to select where to display the linked pages of a frame or frameset. This display target Base 
Target is set by default to display Web page links in the same frame as the link. You can set the base target to any of the options 
described following:

Default Linked file displays in the same frame as the current Web page file. 
New window Displays linked file in a new, untitled window
Same frame Displays linked file in the currently selected frame
Same window Displays linked file in the window of the currently displayed Web page
Parent window Linked file displays in the parent window of the current frame file. 
Frame Select frame in the thumbnail sketch of this Web page to display linked files there

To see an example which sets a frame as a base target, using the Base Target dialog box, see the Visual Page Getting Started 
tour. 



 Creating links in a frame set

To create a link in a frame set , type the path to the link in the URL field. If there are anchors in the current document, a drop-
down menu will appear containing a list of those anchors.

You may also set a base target from this dialog box.    For more information on setting a base target, see Setting the Frame 
target.



 Setting Movie properties

Use the Movie properties dialog box to change the following settings for a movie file:

Location Folder containing the movie file.
Name Movie's file name.
Width Width of the movie, in pixels.
Height Height of the movie, in pixels.
Horizontal space around Horizontal blank space around the movie.
Vertical space around Vertical blank space around the movie.

 Setting Anchor properties

This dialog box displays automatically when you create an anchor. If you select some text before creating the anchor, the 
selected text automatically appears as the name of the anchor in the Anchor Properties dialog box. Otherwise, you may enter or 
edit the name for the anchor in the Anchor Properties dialog box. The anchor names you set become part of the URL created 
when you link a Web page object to the anchored location. For more about anchors, see Creating links and anchors.



 Setting Check Box properties

Use the Check Box properties dialog box to change the name and value of a form’s check box. The values you enter here are 
passed to the script associated with the check box, they do not appear on the visible part of the Web page. 

To set the check box properties:
1 Select a check box.
2 Choose Edit > Properties > Object Properties or press F4.

The Check Box Properties dialog box displays. 
3 Set the two fields, Name and Value, as described below.

The properties for check boxes include:

Name Enter an identifier in this field.

Value Checked if you want it to be checked initially.

For more information on creating forms, see Creating forms.



 Setting Frame properties

Use the Frame properties to set the properties which pertain to a selected frame of a frame set. Use the Frame properties dialog 
box to check, assign, or change these values.

To set frame properties:
1 Select the frame whose properties you are setting by clicking once anywhere in the frame.

A heavy black border outlines the frame.
2 Choose Edit > Properties > Show Frame Properties. 

The Frame Properties dialog box displays. 
3 Set the properties as they are described below.

The frame property settings: include the following:

Source Name of the HTML file which you want to display in this frame, 
for instance, HomeTOC.html is an appropriate value. 

Frame title Title for the frame, otherwise Visual Page uses the random 
number shown as the default in this field.

Margin width Width of the margin.

Margin height Height of the margin.

Frameset height This only applies if there are frames below other frames in the 
frameset.

Frameset Border Specifies the thickness of the frameset border.    Set to 0 for 
borderless frames.    Leave it empty to use the default border 
thickness.

Show scrollbars Defaults to automatically showing scrollbars when they're 
needed.

Resizable frame Checked by default, if you don't want people to change the size 
of a frame, uncheck it.

 Setting JavaScript properties

Use the JavaScript properties dialog box to change the name and location of a JavaScript file that is referenced by a Web page.

For more information, see Using JavaScript.



 Setting Plugin properties

Use the Plugin properties dialog box to change the properties for plugin files: 

To set plugin properties:
1 Select a plugin on your Web page.
2 Choose Edit > Properties > Plugin Properties or press F4. 

The Plugin Properties dialog box displays. 

The properties for plugins are as follows:

File location Folder location of the plugin.

Name Plugin file name.

Width Width of the plugin, in pixels.

Height Height of the plugin, in pixels.

Horizontal space 
around

Horizontal blank space around the plugin.

Vertical space around Vertical blank space around the plugin.

Parameters Custom parameter, dependent on the plugin, goes 
here.

For more information on using the plugin properties dialog box, see Inserting a plugin.



 Setting Radio Button properties

Use the Radio button properties dialog box to change the name and value of a form’s radio button. The values you enter here 
are for use in the code for the radio button. They are passed to the script (usually a CGI script) in a name/value pair and do not 
appear on the visible part of the Web page. 

To set radio button properties:
1 Select a radio button on your Web page.
2 Choose Edit > Properties > Radio Button Properties or press F4. 

The Radio Button Properties dialog box displays. 
3 Set the name of each button in a group of radio buttons to be the same. 
4 The values of each radio button in the group should be unique. 

The properties for radio buttons include:

Name Identify a set of radio buttons by giving them all the same name. 

Value Must be unique for each radio button in the group. 

For more information, see Creating forms.



 Setting Horizontal Line properties

The Line Properties dialog box allows you to set the width of the line to an absolute or relative size, an appropriate height, and 
set it to display with 3D shading. In addition, you can choose center, left, or right alignment for it. on the page 

To set horizontal line properties:
1 Select a horizontal line on your Web page by clicking once directly on it.
2 Choose Edit > Properties > Line Properties or press F4. 

The Line Properties dialog box displays. 
3 Set the dimensions, alignment, and shading according to the properties described below. 

The settings for a horizontal line are as follows: 
Width Choose either absolute or percentage from the drop-down menu. When set as 

absolute the width is fixed at a number of pixels. The percentage setting is relative 
to the Web page width. 

Height Number of pixels you set or the default value of 2.

Alignment Can be center, left, or right aligned.

3-dimensional shading 3D is displayed by default unless you uncheck this option.

For more information, see Adding horizontal lines.



 Setting Text Field properties

You can use these settings to give a data input field a name, display width, character limit, and password. You can also set the 
field to be totally hidden and thus exclusively for the author's use. 

To set text field properties:
1 Select a field by clicking directly on it once.
2 Choose Edit > Properties > Text Field Properties or press F4. 

The Text Field Properties dialog box displays. 
3 Set the name, dimensions, and so forth, according to the properties described below. 

Use the Text field properties dialog box to change the following settings:

Name: Enter the name you want passed to the script you use to transmit 
the form data.

Display width Maximum number of characters you want to display.

Maximum length Maximum number of characters your script will accept.

Password: When checked, sets this field to hide the text with asterisks, for 
entering a password.

Hidden: Store information for the author's eyes only in a text field by hiding it 
with this setting.

For more information, see Creating forms.



 Setting Text Area properties

The scrolling text input area is made to hold more text than the text field. Using the Text Area Properties dialog box, you can set 
the number of lines the text area will contain and the maximum number of characters for each line. In addition, you should give 
the text area a name which can be passed back to the script associated with your form for transmitting data. 

To set text area properties:
1 Select a text area by clicking directly on it.
2 Choose Edit > Properties > Text Area Properties or press F4. 

The Text Area Properties dialog box displays. 
3 Set the name and dimensions, according to the properties described below. 

Use the Text Area Properties dialog box to change the following settings:
Name Passed to the script you use to transmit the form data.
Width Maximum width in characters per line
Height Maximum number of lines for the field

For more information see Creating forms.



 Setting List properties

List boxes allow you to present a number of choices in a scrolling box. You can use the List Properties dialog box to set the 
number of visible choices you want to present, to name the list box, and to allow one or multiple choices to be made from it. 

To set List Box properties:
1 Select a text box by clicking on it.
2 Choose Edit > Properties > Text Box For press F4. 

The Text Area Properties dialog box displays. 
3 Set the name, number of visible items, and dimensions according to the properties described below. 

Name Passed to the script you use to 
transmit the form data.

Number of visible 
items

Set to the number of choices you 
require.

Allow multiple 
choices

Defaults to allowing multiple choices to
be made.

For more information see Creating forms.



 Setting Submit Button properties

Use the Submit button properties dialog box to change the programmatic name for the Submit button. To change the visible 
name of the button select the word on the button (while in Edit mode) and type over it. 

For more information see Creating forms.



 Setting Table properties

Table properties apply to either the entire table or selected cells in the table. For that reason, this dialog box has two tabs which 
divide the properties applying to the entire table or cells in the table. See Setting Cell properties.

To edit a table's properties:
1 Select the table by clicking anywhere in it.
2 Choose Properties > Table Properties or press F4. 

The Table Properties dialog displays.
3 Click the Table tab to display the properties for the entire table.

You can easily customize your Web page tables by changing the following settings.

Table Properties:

Rows Number of rows in the table.

Columns Number of columns in the table. 

Space around text Pads each cell so the contents do not bump up against the edge.

Space between cells Sets amount of space between cells throughout the table.

Width Either fixed, in pixels, or set to a percentage of the Web page size.

Height Either fixed, in pixels, or set to a percentage of the Web page size.

Border width Girth of the border surrounding the entire table.

Caption placement Creates a place for a table caption, if desired.

Background color Set the background color for the entire table from this color well.



 Setting Cell properties

Table properties apply to either the entire table or selected cells in the table. For that reason, this dialog box has two tabs which 
divide the properties applying to the entire table or cells in the table. See Setting Table Properties.

To edit a cell’s properties:
1 Select the table by clicking anywhere in it.
2 Choose Properties > Table Properties or press F4. 

The Table Properties dialog displays.
3 Click the Cells tab to display the properties for the selected cells.

Cell properties:

Column width Can be set to fixed pixel size, or as a percentage of the table size.

Row height Can be set to fixed pixel size, or as a percentage of the table size.

Span rows Sets a cell to span (vertically) more than one row.

Span columns Sets a column to span (horizontally) more than one column.

Vertical alignment Aligns the text within a cell to Top, Middle, Bottom, or Default

Header style Turn on if you want a header style applied to the text in this cell.

Line wrap Automatically wraps text within a cell, by default.

Cell color Use this to set the color of the selected, individual cell 

 Uploading files 
{button See 
Also,AL(`Connecting_to_your_Web_server;Downloading_files_from_your_Web
_server;IDH_Preferences_Network',0,`',`')}

Visual Page provides FTP capabilities which allow you to connect to your Internet Service Provider's Web server. This makes it 
easy to upload or "publish" your Web site so that it's available to the public via the Internet. 

There are two types of files that you can upload to the Web:

n A text file (also known as an ASCII file) is the default Web page format for Visual Page, and is the universal standard for HTML
files.

n Binary files are commonly used to contain graphics (such as GIF and JPEG images) and other types of media (such as 
Shockwave and QuickTime movies).

To upload files to your Web site:

1 Log on to your Web server. 
If you don't know how to log on to your Web server, see Connecting to your Web server.

2 Navigate to your Web site (the folder where you store your Web files.)
This is the folder to which you'll upload/publish your Web files.

3 Click the Publish button.
4 Visual Page displays the Publish Files dialog box. It has two windows, one at the top and one below it. The top scrolling list 

includes the files and folders on your local disk drive. The bottom list shows the files you select from the top list, for publishing.
5 To add a file to the publish list (at the bottom of the Publish Files dialog box), select a file in the top list, then click Add. 

Alternatively, you can click the Add All button to add all of the files from your local Web site to the publish list.
6 Before you publish the files, select the Overwrite option that you want to use. 
7 Click Publish. 



Visual Page uploads your local files to your Web site.

Caution:    Be careful which overwrite option you choose! If you select any option other than “Never overwrite,” you may 
inadvertently destroy a Web site file by writing over it. If you’re not sure which option is the best for you, select “Never 
overwrite.”



 Saving a Web page containing frames

A Web page containing frames is known as a frame set. Use the Save Frame Set dialog box to save. Web pages that are frame 
sets.    

To save a frame set
1. Enter the filename with the .htm or .html filename extension
2. Click OK. 

Your page is saved.

For more information on frames, see Creating frames.



 Setting HTML tag properties

Use the HTML tag dialog box to change the HTML tag while still in the visual editor. Type in the tag (not including the brackets 
“<” and “>”), and click OK.

For more information, see Adding additional HTML tags.



 Using the Standard toolbar

Use the Standard toolbar to perform the following functions, at the touch of a button. For more information about using these 
features, click on any of the following topics:

n Creating a new Web page
n Opening an existing Web file
n Saving a Web page
n Opening a Local Site window
n Cutting text or graphics - follows standard Windows interface
n Copying and pasting text or graphics 



 Using the Properties and Views toolbar

This toolbar is divided into two set of buttons. The set on the left of the toolbar, allows you to change the view of the Web page, 
from Edit mode, to Source View mode, to Preview mode. :

n Edit page button
n Edit source
n Preview page button
n Document properties (dialog box)
n Object properties (dialog box)



 Using the Insert toolbar

Use the Insert toolbar to insert any of the following items into a Web page:

n Link
n Horizontal rule
n Image
n Plugin
n Java applet
n Anchor
n Table

Use the Insert toolbar to revise by performing the following functions:

n Insert row
n Insert column
n Delete row
n Delete column



 Using the Format and Style toolbar

Use the Format and Style toolbar to perform the following functions:

n Apply paragraph styles
n Apply bold, italic, and fixed font character styles
n Decrease font size
n Increase font size
n Change font color
n Change font and font group
n Align paragraph to left, center, or right
n Remove or add a paragraph indent
n Align graphics



 Using the Form toolbar

Use the Form toolbar to create a form by adding any of the following form items to a Web page: See the appropriate property 
settings dialog boxes to learn more about customizing these user interface elements. 

To create a form, click on any of the buttons on the Form tools toolbar to insert any of the following form elements:
Check box Can be on or off, checked or not checked.
Radio button These are used in sets so that only one is selected at a time.
Single-line text box A data entry element that holds one line of text, like a name, for example. 
Multi-line text area Scrolling text area; this is useful for allowing the entry of comments, for example.
Drop-down list box Creates a drop-down menu.
List box Allows choices from a scrolling list box.
Submit button Inserts a button which you should set, via a script, to transmit the form data 
Reset button Use this button to programmatically clear all the fields of data

 Using the Link toolbar

Use the Link toolbar to view and edit URL’s in the Link To field.



 Using the Image Tool toolbar

Use the Image Tool toolbar to perform the following functions:

n Draw a rectangular image map
n Draw a circular image map
n Draw a polygon image map
n Change hotspot overlapping
n Change hotspot color
n Change the transparency color
n Turn off transparency
n Interlace images
n Zoom in and out
n Change view size (%)



 Overview of Toolbars
There are seven toolbars in Visual Page. Each toolbar can be docked or used as a floating toolbar except the Link toolbar. 
You can choose a toolbar using one of two methods:

n View > Toolbar
n Right-clicking on the status bar or any empty space between docked toolbars.

Click on the links below for information on each toolbar:
Standard 
Properties/Views 
Insert 
Format/Style 
Form 
Link 
Image Tool 



 About the FTP window

The Visual Page FTP functionality allows you to upload and download files, as well as perform file management tasks for your 
Web site, such as deleting obsolete or unneeded files.

The items below contain additional information about opening and using the FTP window.
Connecting to your Web server 
Configuring the FTP default settings 
Disconnecting from the Web 
Opening the FTP Site 
Deleting remote files 
Renaming remote files 
Creating a remote folder 
Uploading files 
Using the FTP window to download files 



 Other Help resources

This dialog displays because F1 could not locate a help topic.

For help on this topic:
1 Click Help Topics.
2 Use the Contents, Index, or Find tab to perform a search. 

You may also refer to the Visual Page User’s Guide.



Parent window

Last active window before clicking on the link that cases the current framed Web page to display.



Wraparound search

Search automatically continues past the end of the file; stopping at the insertion point. 



Get method

Sends the user's information as part of a URL



Post method

Sends user's data as a data stream that is separate    from the URL.



URL

An acronym for Universal Resource Locator. This is the path which a Web browser uses to locate files identified in links. 



 Working with fonts

Visual Page allows you to use the fonts that are installed on your system to enhance the look of your Web pages.    However, not
all fonts are cross-platform compatible, and may not display correctly on other platforms.

You can work with fonts in three ways in Visual Page by:

Changing fonts
Creating font groups
Assigning font groups



 Changing fonts
{button See Also,AL(`Creating font groups;Assigning font groups',0,`',`')}

You can change the font of selected text in your Web page to any other available font.

To change a font:
1. Highlight the text in your page that you want to change.
2. Click on the Font pull-down menu.

The list of available fonts appear.
3. Select the new font that you want to apply.

The font of the highlighted text changes.



 Creating font groups
{button See Also,AL(`Changing fonts;Assigning font groups',0,`',`')}

Font groups are groups of fonts that usually have some common characteristic to preserve the original design of the Web page.   
Font groups allow the Web browser to substitute fonts from a group of assigned fonts when one or more fonts are not available 
on the client machine.    When no font in a group is available on the client machine, the Web browser uses default fonts available 
on the client machine.

With Visual Page you can create and assign font groups that make your pages look their best across different platforms and 
browsers.

To create a font group:
1. From the Font pull-down menu, select Font Groups.

The Font Groups window opens with the names of default font groups.
2. Click a blank cell in the Group Name column and enter a name for the new font group.
3. Click the Font Names cell and enter font names separated by a comma.
4. Click the OK button when you are finished entering font names.

The font group is added to the Font pull-down menu.
You can also assign a font group on-the-fly. 



 Assigning font groups
{button See Also,AL(`Assigning fonts on-the-fly;Creating font groups;Changing
fonts',0,`',`')}

You can assign font groups in your Web page to allow the Web browser on the client machine to substitute fonts when the 
original font is not available.

To assign a font group:
1 Highlight the text to which you want to apply a font group.
2 From the Font pull-down menu, select a font group.

The selected font group name appears in the pull-down menu and is applied to the highlighted text.



 Using the Spelling Checker
{button See Also,AL(`Editing the Personal Dictionary',0,`',`')}

You can check the spelling in your page at any time by clicking the Spelling Checker icon.    The Spelling Checker checks the 
spelling in the entire page, but does not check spelling of words that you highlight.    The functions available are: 

n Ignore skips the current word and continues spell checking.
n Ignore All skips all instances of this word.
n Add places the current word into the dictionary.
n Change replaces the current word with the word in the Change To window, or to the word that is highlighted in the 

Suggestions window.
n Change All replaces all instances of this word with the word in the Change To window or to the word that is highlighted in the 

Suggestions window.
n Suggestions automatically provides a list of alternatives to the current word.
n Edit Dictionary opens the Personal Dictionary.    In the personal dictionary, you can add, modify, or delete entries.
n Cancel exits the Spelling Checker, but does not cancel any previous spelling changes made with the Spelling Checker.



Font groups

Font groups are groups of fonts that usually have some common characteristic to preserve the original design of the Web page.   
Font groups allow the Web browser to substitute fonts from a group of assigned fonts when one or more fonts are not available 
on the client machine.    When no font in a group is available on the client machine, the Web browser uses default fonts available 
on the client machine.



 Setting Page Default Preferences

Use the Page Defaults tab of the Preferences dialog box to set defaults preferences for every new page you create with Visual 
Page.    If you want to restore these preferences to the default settings, click Use Defaults. If you want to change back to the 
settings that were in place before you opened this dialog box, click Revert.

To set Page Default preferences:
1. From the Edit menu, choose Preferences.

The Preferences dialog box appears. 
2. Click the Page Defaults tab.
3. Use the dialog box to select the page default preferences you want.

The preferences are listed below.
4. When you’re finished setting preferences, click OK.

n Background sets the default background color.
n Normal Text sets the default color for normal text/
n Normal Links sets the default color for normal links/
n Active Links sets the default color for active links.
n Visited Links sets the default color for visited links.
n Background Image You can have each new page use a default image as a background.

To select a default background image:
1 Click the checkbox or click the ellipses.

The Open dialog box appears.
2 Locate the image you want to set as a default background.
3 Click Open.

The selected image appears in the Image Preview window.
4 Click OK to make the image the default background image.



 Editing the Personal Dictionary
{button See Also,AL(`Using the Spelling Checker',0,`',`')}

You can add, delete, or edit entries to the Personal Dictionary.    These features are useful when you are writing text with highly 
specialized vocabulary, such as acronyms and technical terms.

To add entries to the Personal Dictionary:
1. Click the Spell Check icon to open the Spelling Checker.
2. Click the Edit Dictionary button.

The Edit Dictionary window opens.
3. Click the Insert button.    

The Insert text box opens.
4. Type in the word you want to add to the dictionary.
5. Click OK to close the Insert text box.

The new word is added to the dictionary.

To delete entries to the Personal Dictionary:
1. Click the Spell Check icon to open the Spelling Checker.
2. Click the Edit Dictionary button.

The Edit Dictionary window opens.
3. Single click the word you want to delete.
4. Click the Remove button.    

The selected word is deleted from the dictionary.

To edit words in the Personal Dictionary:
1. Click the Spell Check icon to open the Spelling Checker.
2. Click the Edit Dictionary button.

The Edit Dictionary window opens.
3. Single click on the word you want to edit.
4. Click the Edit button.    

The Edit text box opens.
5. Make your correction to the word.
6. Click OK to close the Edit text box.

The modified word is added to the Personal Dictionary.



 Assigning fonts on-the-fly
{button See Also,AL(`fonts',0,`',`')}

You can assign font groups instantly by using Other in the Fonts pull-down menu.    When you use the Other item, a dialog box 
appears and then you type in the names of fonts.    When you apply font groups this way, this particular combination of fonts is 
not saved, and is applicable only to the text you have highlighted.

To assign a font group using the Other menu item:
1. Highlight the text to which you want to apply a font group.
2. From the Font pull-down menu, select Other.

The Other Fonts dialog box appears.
3. Enter a font or list of fonts separated by a comma, for example Arial,Helvetica,Courier.
4. Click OK when you are finished entering font names.

The font group is applied to the highlighted text.




