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The WIG Administrator Program
When you install the WIG for the first time and specify a new workgroup, an executable 
file WIGAdmin.exe will be copied into your Windows directory. This program enables 
you to administer the workgroup gateway postoffice. Run the program by double 
clicking on it from within the Windows Explorer.

When you first enter the Administrator program, you are asked to enter a a password 
and a verification of the same password. Once entered, this will be the password you 
need to get into the WIGAdmin.exe program.

Whenever you subsequently run the WIGAdmin.exe program, you will need to enter this
password into the Enter Password dialog box which appears on running the program.

Using Workgroup administrator program, you can add, edit and delete users and modify
details about your workgroup. When each subsequent user sets up the WIG on their 
system, they will not receive a WIGAdmin.exe program in their Windows directory. 
However, the process of entering their name and mailbox name will automatically add 
them as a user to the WIG postoffice.

The main screen of the Wig Administrator program shows a list of users down the left 
hand side and a details window to the right hand side. Selecting a user from the left 
hand list will display that users details in the details window. The details window 
displays the users name, e-mail address, any forwarding options and the number of 
pending incoming and outgoing mail messages.

Viewing Pending Mail for all users
The Wig Administrator program lets you view pending incoming and outgoing messages
for all users together. You can do this by selecting Pending Messages for all users 
from the View menu (or CTRL+M). This will pop up a list of messages:

You can list all the messages pending for unknown users. Do this by selecting Pending 
Messages for Unknown from the View menu (or CTRL+U).

Event Logging
WIG can log a certain number of events that occur during the process of sending and 



receiving mail. To display the event logging options, select Log Options from the View 
menu.

WIG lets you log events related to sending messages, receiving messages, auto 
responding and forwarding. From the Log Options dialog box, select the logging options
you wish to record and press OK. All users who subsequently log onto MS Exchange 
will use these options and will start logging the events as required.

To view the event log, select Logged Events from the View menu or press CTRL+L. 
The WIG Administrator will show a list of events in date order, always displaying the 
most recent.

This list can be updated by pressing the Recalc button. The list of events may be 
purged at any time by pressing the Purge button.

Adding Users
You can add a new user to the WIG post office either by installing the WIG onto the 
users machine and entering details via the installation program or by pressing the New 
User… button. Pressing this button will pop up the User dialog box.

Enter the name of the user into the Name field. Ensure that the MS Exchange user 
radio button is selected rather than the MS Mail user or virtual mailbox. The MS Mail 
user and MS Mail Gateway selections exist so that 16-bit MS Mail users can connect to 
the Internet. For more information on connecting MS Mail users to the Internet see, 
Using MS Mail with WIG later in this manual.

Virtual Mailboxes
You can create as many virtual mail boxes as you like regardless of the number of 
licenses that you have purchased. A Virtual mailbox is exactly the same as a normal MS
Exchange user mailbox except you cant log in as a virtual mailbox from MS Exchange. 
You can however forward mail sent to a virtual mailbox to a real MS Exchange user 
mailbox.

For example, suppose you were called John and you had an address 
john@company.com and suppose decided that you wanted to set up a mailbox for 
your customers to send enquiries to but ultimately you would be the person to read mail 
coming into this mail box. The solution would be to set up a virtual mailbox called 
enquiries and have all the mail sent to this mailbox forwarded to the MS Exchange 
mailbox john. For more information see Forwarding a Users Mail later in this section.

The Address page lets you specify a mailbox name for the user. Normally, the mailbox 



name, together with the Workgroup address, go towards defining a users e-mail 
address. For example, if the workgroup node name was softalk.demon.co.uk and the 
user Simon Bates has a mailbox name stb then Simon Batess e-mail address will be 
stb@softalk.demon.co.uk.

Users with Domain names
Sometimes, a workgroup will have one or more domain names. The Workgroup Address
drop list in the Address tab lets you choose which domain name will be used to make up
the users e-mail address. For example, Softalk has a node name of 
softalk.demon.co.uk, but has a domain name of softalk.com . If the user Simon Bates 
wanted his e-mail address to be stb@softalk.com rather than stb@softalk.demon.co.uk, 
it would be a case of selecting softalk.com from the Workgroup address drop list.

Individual POP3 Mailboxes
If your workgroup uses POP3 to receive mail (rather than SMTP) from the Internet and 
a particular user has his/her own POP3 mailbox, which is different to the POP3 mailbox 
used by the workgroup then you may enter the details of the users POP3 mailbox in the 
User dialog box. If the address (to the right of the @ sign) is different from the 
workgroup address, then the differing address may be specified in the Address field in 
the User property sheet.. 

Note: If your workgroup has an e-mail account which supports multiple virtual mail 
boxes then the entire organisation can share the same POP3 account in order to send 
and receive mail. If you have a set of single user POP3 mail boxes, then you will need 
to add individual POP3 mail box information as described above.

The POP3 page specifically lets users with individual POP3 mailboxes (see above) to 
enter their POP3 login name and POP3 password.

Forwarding a Users Mail
The Forwarding page lets you forward a particular users mail to another person. This 
person may either be another WIG user, or it may be another e-mail address. The three 
radio buttons let you choose between not forwarding the mail at all, forwarding the mail 
to another WIG user and forwarding the mail to another user-specified address. If you 
select the Forward to user radio button, you can select from a list of WIG users. If you 
select the Keep a copy check box, WIG keeps a copy of the message with the original 
recipient before forwarding the message.

Adding a Signature



A Signature is the text placed at the bottom of all the mail messages that you send. You 
can either supply no signature, in which case you leave the text box blank, or supply 
something along the lines of the example above.

Changing a Users Password
You can change a users password from the User property sheet by selecting the Details
tab and pressing the Change Password button. When you do this a Change Password 
dialog box will appear.

Enter the users current password into the Password field and enter the same password 
into the Verify field.

Editing and Deleting Users
You can edit or delete a user by selecting the user from the list and pressing the Edit 
User… or Delete User… button respectively.

Editing Workgroup Information
You can edit the Workgroup details by selecting Edit Workgroup from the Edit menu. 
Alternatively, you can press CTRL+W. This will pop up a Workgroup property sheet.

Your workgroup name will have already be specified in the setup process.    You may 
change it from the Name page.

The Address page lets you enter the workgroups node name. This is often the same as 
the right hand portion of your e-mail address.    If your company has any Domain names,
then enter these into the Domain names list, by pressing the New button. When you 
press the New button, a Domain dialog box will appear. Enter the new domain name 
and press OK.

The POP3 page lets you enter POP3 information for the workgroup. If you have a POP3
account which supports multiple mailboxes then you would enter the login name and 
password for the account in this page. If the people in your workgroup have individual 
single POP3 accounts then leave these fields blank and ensure that the details are 
entered in each User dialog box. If you do not receive your e-mail using POP3 then 
leave these fields blank.



The Administration page lets you specify the WIG administrator. Select the administrator
from the list of users. If there is no administrator then select No Administrator--.

WIG lets you forward incoming messages which do not match any of the existing virtual 
mailboxes. This will generally be useful for those workgroups who receive their mail 
from their service providers using SMTP rather than POP3.    With SMTP message 
reception, any messages sent to the correct node address will be received. For example
anyone@softalk.demon.co.uk and POSTMASTER@softalk.demon.co.uk and 
stb@softalk.demon.co.uk would are all valid recipients of the softalk.demon.co.uk node 
name. If there were no WIG mailboxes set up for anyone and POSTMASTER, then 
these messages are classed as unknown users Any messages sent to unknown users 
may be forwarded to any WIG user or any other forwarding address.

The Forwarding page lets you forward unknown users mail to another person. This 
person may either be another WIG user, or it may be another e-mail address. The three 
radio buttons let you choose between not forwarding the mail at all, forwarding the mail 
to another WIG user and forwarding the mail to another user-specified address. If you 
select the Forward to user radio button, you can select from a list of WIG users. If you 
select the Keep a copy check box, WIG keeps a copy of the message with the original 
recipient before forwarding the message. It is not recommended to keep a copy of 
unknown users messages.

The License page lets you enter your password and keycode information needed to 
register WIG. When you buy a certain number of users, Softalk will send you a 
password and keycode. Enter this information in the relevant field. Also enter the exact 
number of users that you have purchased. When you press OK, provided that you have 
entered the information correctly, WIG will become registered.

Auto Responders
WIG lets you set up auto responders. An auto responder is a mail box to which people 
can send messages. On receiving the messages, the auto responder mail box will 
automatically reply to the sender with a specific message. The message may either be 
a simple text message or it may be a binary attachment.

To view a list of auto responders set up in WIG, select Responders from the View menu 
in the WIGAdmin.exe program. The list of users will be replaced by a list of responders.

To add a new responder, select New Responder from the Edit/Responder menu 
(alternatively press CTRL+R). A Responder property sheet will appear.

The Address, POP3 and forwarding tabs show similar information to the User dialog 
box. This means that you can set up a responder to use its own POP3 mail box and you
can forward mail sent to the responder on to another user or address. The Responder 



dialog box contains a File tab which lets you specify details about the information the 
responder will mail back to the sender.

Use the browse file to select the file that you want to send. This can either be an ASCII 
text file or a binary file. If it is a text file, you can choose to send the text either as a text 
message, or as an attachment. If it is a binary file then you MUST attach the file rather 
than import the file into the response. If you select the Import file into response radio 
button and you specify a binary file, WIG will flag an error.

Node Names and Domain Names
If you receive your mail using SMTP rather than POP3 then you need to know your 
node name. If you have not registered a domain name then your node address (node 
name) will be the latter part of your e-mail address. For example, if your e-mail address 
is bob@softalk.demon.co.uk, then your node address is softalk.demon.co.uk. If you 
have registered a domain name (e.g. softalk.com), then your e-mail address may be 
bob@softalk.com, however the node address will still remain softalk.demon.co.uk. If 
you are in any doubt as to your node name then contact your Internet provider.

If you have a domain name, then this must be specified in the Address tab of the 
Workgroup dialog box in the WIG Administrator program. Also each user should select 
the relevant domain name in their Address pull down menu in the Address tab of the 
User dialog box in the Workgroup Administrator program. Doing so specifies how their 
address will appear to their recipients.

Setting up MS Mail Users in WIG Admin
Next, you must tell WIG about the MS Mail users. You should do this by adding a user 
(of type MS Mail User) for each and every MS Mail user who wishes to send and 
receive Internet mail. Note that a user license is required for every additional MS Mail 
user. The name of the MS Mail user must match exactly the users full name as specified
in the MS Mail post office. For example if the users name as specified in the MS Mail 
post office is Joe Bloggs, then Joe Bloggs must be specified as the users name in the 
Details tab of the User dialog box for that user.

Note: If the MS Mail users name (as entered in WIGADMIN.EXE) does not exactly 
match the users full name as specified in the MS Mail post office then WIG will not 
succeed in sending on that users Internet mail.

The Address tab of the MS Mail users User dialog box contains the users mailbox name
and Workgroup address information. The mailbox name of the MS Mail user must match
exactly the users mail box name as specified in the MS Mail post office. For example, if 
the users MS Mail address is MS:ACCOUNTS/PLUTO/JOHN then the mailbox name as



specified in the User dialog box must be John.

Note: If the MS Mail users mailbox name (as entered in WIGADMIN.EXE) does not 
exactly match the users mailbox name as specified in the MS Mail post office then WIG 
will not succeed in sending or receiving Internet mail for that user.






