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1.0 What is CATraxx?



CATraxx is a quick, efficient, easy-to-use program for organizing your music collection. 
CATraxx is developed by record collectors for record collectors to ensure that you get all the 
features you need.

With CATraxx you can register and look up information about such things as: 

· artist, album title, format, release date,
· company, label, catalog number, 
· condition, playing time, purchase price and current value, 
· song titles, songwriters, producers, 
· studios, musicians, instruments. 

You can add personal comments for both albums and tracks. Twenty special fields enable 
you to customize your catalog. You can even store a bitmap picture of the album cover.

CATraxx uses a relational database model. This means that you register most information 
only once. For example, an artist's name is included in the catalog the first time you add an 
album by the artist. Later, you simply choose this name from a list. This type of information is 
stored in “lookup” tables which ultimately save time and valuable disk space on your 
computer.

CATraxx lets you work with an unlimited number of databases. This means that you can split 
your collection into different catalogs and organize it to meet your needs. You can also merge
existing databases. CATraxx includes routines for taking and restoring backup of the 
databases you have created.

CATraxx has impressive and powerful search capabilities. You can search for any information
you have entered in a catalog. CATraxx lets you cross reference up to five fields. This is an 
extremely flexible way to search and query data. CATraxx has templates for many types of 
reports which you can generate to examine on the screen or print out.

CATraxx lets you play CDs from your CD-ROM player.

CATraxx comes with a sample database to get you started and a comprehensive context-
sensitive on-line help system. 

2.0 Installing CATraxx
Before you begin the installation process, make sure your system meets the following 
minimum requirements:

· 386-based PC or better
· Microsoft Windows 3.1 or Windows 95
· 4 Mbytes memory (6 Mbytes is recommended)
· 4 Mbytes available space on the hard disk

You can install CATraxx using the diskettes that come with the application or directly from 
your hard disk if all files have been placed in a directory there.

2.1 To install from the diskettes:



1. Insert diskette number 1 into your diskette drive.

2. If you are running Microsoft Windows 3.1, from the Program Manager File menu choose
Run.
If you are running Microsoft Windows 95, from the Start menu choose Run.

3. In the text box, type the path to the installation program, for example A:\SETUP, and 
choose OK.

4. When requested, specify the directory where you want to install CATraxx. Unless you 
specify a different directory the application will be installed in C:\CATRAXX.

5. Choose OK to start the installation process.

2.2 To install from the hard disk:
1. Ensure that all CATraxx installation files are in the same directory, for example C:\

CATTEMP.

2. If you are running Microsoft Windows 3.1, from the Program Manager File menu choose
Run.
If you are running Microsoft Windows 95, from the Start menu choose Run.

3. In the text box, type the name of the drive and directory where the installation files are 
located, then type \SETUP (for example C:\CATTEMP\SETUP) and choose OK.

4. When requested, specify the directory where you want to install CATraxx. Unless you 
specify a different directory the application will be installed in C:\CATRAXX.

5. Choose OK to start the installation process. 

When the installation process is complete you see the CATraxx group and CATraxx icon. 

3.0 Starting CATraxx
Double-click the CATraxx icon. You see the CATraxx main window. 

Note! In CATraxx, the windows you use most often are always available as icons at the 
bottom of the main window. To open a window, double-click the icon. You may also open a 
window by choosing from the Window menu or pressing the menu shortcut (for example 
Ctrl+B to open the Browse window). When you no longer need a window, minimize it.

When you start CATraxx for the first time, you see the Browse window (if you do not see it, 
double-click the Browse icon at the bottom of the main window). The Browse window 
contains the albums from the sample database included with CATraxx (this database is called
SAMPLE.MDB). 

Before you can start cataloging your music, you must create your own database. CATraxx 
enables you to have several databases so you can split your collection in different segments. 
Separate databases can later be merged.



3.1 Creating a database
1. From the File menu choose New. You see the Create New Database dialog box.

2. Select the drive and directory where you want to create the database if it is different from
the CATraxx directory. In general, we recommend that you do not change the directory.

3. In the File Name text box type the name of the database. The name should be one that 
easily reminds you of the information in the database, for example MUSIC or MUSICLIB.
As with other Windows file names, it cannot have more than eight characters. The file 
extension identifying the database, .MDB, is added automatically.

4. Choose OK. 

The database is open and you can now begin adding information to it. You see the name of 
the database in the title bar of the CATraxx window. 

If you want to organize your collection using only one database, then you don’t have to think 
about databases again. CATraxx will always open this database when you start the 
application. If, however, you choose to organize your collection in a way that requires several 
databases, follow the steps above to create as many as you need. To switch from one 
database to another, see the section “Opening a Database”. 

3.2 Opening a database
Whenever you start CATraxx the system will automatically open the last database you 
worked with. If you have more than one database and want to change, follow the steps 
below:

1. From the File menu, choose Open.

2. In the Directories list box, select the drive and directory where the database is located if
it is different from the CATraxx directory.

3. From the list box of database names, select the database you want to open and choose 
OK or double-click the name.

Note! If you do not exit the program by selecting Exit from the File menu (or Close from the 
main window's Control menu), for example if a system error occurs or there is a power-
failure, you may get an error message the next time you try to open the database (probably 
error 3049). If this happens, run a utility called FIX that was installed to the same directory as 
CATraxx.

4.0 Cataloging your music 
collection

If you haven’t already done so, create a database. Otherwise, make certain the database you



want to work with is open (see the section “Starting CATraxx”).

CATraxx stores two basic types of information: 

· Album information, such as title, producer, label, etc. “Album” is a general term that can 
mean a compact disc (CD), a cassette tape, a vinyl (long playing) record, a single 
(45rpm), a digital tape (DAT), and so forth. 

· Track information, such as song, song title, length, musicians, etc. “Track” is a general 
term for any song, movement or work that is contained within an album.

Because most information about an album is common for all tracks on the album, you must 
define the album information before you can catalog details about the individual tracks. 

When you type information, CATraxx can automatically make the first letter in each word 
uppercase. If you want to use this feature:

1. From the File menu choose Preferences.

2. In the Preferences dialog box, choose Data Entry.

3. Ensure that the option Uppercase first character is checked (marked with an X).

4. Choose OK.

4.1 Adding an album
To add a new album to your catalog, choose New from the Album menu. You see the Active 
Album 1 window. Note the following:

· Since adding an album is something you do often, CATraxx makes this window available
to you at any time. The window is always visible and can be minimized and reduced to 
an icon but not closed. 

· CATraxx automatically saves the information the moment you leave the Active Album 
window to choose another command. You can also save the information by choosing 
Save from the Album menu.

· If you want to examine another album, select the album in the Browse window. If it is 
minimized, double-click the Browse icon at the bottom of the main window or press 
Ctrl+B.

Fill in the fields as explained below. Most information you need to enter only once. For 
example, an artist’s name is included in the catalog the first time you add an album by the 
artist. Later, you simply choose this name from a list.

Album title Enter the title of the album. CATraxx can handle up to 75 characters.

Artist The name of the artist that released the album. To catalog the artist:

1. Click the List button (. . . ). You see the Artist Album dialog box.

2. If the artist is registered in the database, the name is already listed. To 
find the artist, either scroll through the list and select the name you want, 
or type the name (or the first characters in the name) in the text box above



the list. Click the Add ( > ) button to move the name to the right-most list 
box.

You can link up to five artists to the same album. If the album is a 
compilation made by several different artists, give the album a general 
name, for example “Various Artists”, and register the individual artist 
information when you add the tracks.

If the artist is not registered in the database, choose New. You see
the New Artist dialog box. Fill in as much of the information as you want. 
You can use the Memo field to add personal comments about the artist. 
When you are ready, choose OK to close the dialog box.

3. Choose OK to close the Artist Album dialog box. You see the name(s) in 
the Artist field in the Active Album 1 window.

Company The company that released the album. Type the name or select it from the 
drop-down list. 

Label Type the label name or select it from the drop-down list.

Distributor The company that distributes the album (if known). Type the name or select it 
from the drop-down list. 

Country The country of origin. Type the name or select it from the drop-down list. 

Condition The physical condition of the album. Select one of the pre-defined descriptions 
from the list or define your own condition as follows: 

1. From the Lookup menu choose Condition.

2. Delete the items you do not need. To do this, select the item you want to 
delete and choose Delete.

3. To add a new description, choose New and complete the information 
requested in the dialog box. 

Category The type of music. You can select one of the pre-defined descriptions from the 
list or define your own category as follows: 

1. From the Lookup menu choose Category. 

2. Delete the items you do not need. To do this, select the item you want to 
delete and choose Delete.

3. To add a new description, choose New and complete the information 
requested in the dialog box. 

Registered The registration date. Today’s date is used automatically but you can change it 
if you want. 

Format The type of album such as LP, CD or Cassette. You can select one of the 
pre-defined descriptions from the list or define your own format as follows: 

1. From the Lookup menu choose Format. 



2. Choose New and complete the information requested in the dialog box. 
You must specify the number of units contained in the set (for example 4 if 
there are four CDs in the box) and the number of sides each unit has (for 
example 1 for CDs, 2 for LPs, etc.).

Released The date the album was released. If you know the day and month, select them 
from the drop-down lists then type the year, for example 1996.

Catalog no. The record company’s catalog number.

Album ID Use this field if you have your own system for identifying albums in your music 
collection.

Playing time The total playing time in minutes and seconds. CATraxx automatically 
calculates the total playing time after you have defined each track on the 
album. You can also calculate the total playing time by choosing Add Up 
Playing Time from the Album menu. If you want to manually enter the playing 
time, you must use the format mmm:ss, where m is minutes and s is seconds; 
for example 053:09.

Purchased The date you purchased the album. If the day, month or year has only one digit 
type a zero ( 0 ) before the numeral; for example, 06.02.97.

Price The purchase price. You can decide, for example, if this refers to the price 
you actually paid for the album or the retail purchase price if it is different.

Value Current value of the album, for example the collector’s value. 

Memo This field is for comments. Maximum length is 10.000 characters.

Special info In addition to the standard fields, you can define up to 13 fields for special 
information. These fields are ready to use, but you may want to change the 
field names to something more specific (the default names are User-defined 1, 
User-defined 2 and so on). To name a special field:

1. At the bottom of the CATraxx window, double-click the icon for Active 
Album 2 (AA2) or press Ctrl+J. You see the Active Album 2 window with 
the 13 fields you can define for albums. There are four text fields 
(maximum 50 characters), three drop-down list fields, and six check-box 
fields.

2. From the File menu choose User-defined Fields. You see the User-
defined Fields dialog box.

3. In the text boxes available, type the titles of the special fields, for example 
'Record store', 'Borrowed by' or 'For sale'. Ensure that the field number 
corresponds to the type of field you want the special category to be. For 
example, the 'For sale' field should be a check box.

4. Choose OK.

Note! None of the user-defined fields are shown in field lists (for example when
you want to search or print a report) before you have told CATraxx that it is in 
use. You do this by choosing Preferences from the File menu and selecting 



the fields you are using in the list box Show fields.

You have now completed the cataloging of this album. CATraxx automatically saves the 
information the moment you leave the Active Album window to choose another command. 
You can also save the information by choosing Save from the Album menu.
You can now:

· start adding detailed information about the tracks on the album (see the section “Adding 
a New Track”).

· add another album

· work with information about an existing album. You choose the album you want to work 
with in the Browse window. To activate this window, double-click the Browse icon or 
press Ctrl+B.

4.2 About lookup tables
CATraxx uses a relational database model. This means that you enter most information only 
once. For example, you enter an artist's name only the first time you add an album by this 
artist. Later you simply choose this name from a list. CATraxx stores the information in 
"lookup tables". The result is that you save time and avoid typing errors. The database 
occupies less space and it is easier to search for exactly the information you want.

The lookup tables can be divided into four groups:

1. Format. You enter format (for example LP, MC or Double CD), items (1 for an ordinary 
album, 2 for a double album and so on), sides (1 for albums with only one side like a CD 
and 2 for albums with two sides like a LP) and what group the format is to be linked to. 
CATraxx uses these format groups when creating the statistics report. Please note that 
an ordinary album and a double album must be separated, for example LP and Double 
LP. However, they can both be linked to the same format group.

2. Artist. You enter the name, whether it is a group or solo artist, country, formed/born and 
disbanded/dead. It is also possible to enter line-up (that is, the members of the group). 
This information can be used when you want to specify musicians that participate on a 
specific track. If you use this feature, you save a lot of time when you add new tracks!

3. Person. You enter the name, country, born and dead. Please note that this table is used 
by the following fields: Mixer, Musician, Producer and Songwriter.

4. Category, Company, Condition, Country, Distributor, Instrument, Label, Studio and 
the five user-defined fields that are linked to lookup tables (User-defined 5, User-
defined 6, User-defined 7, User-defined 16 and User-defined 17). You only enter the 
name of the item, like a country (USA or Norway) or a category (Blues or Rock).

In all lookup tables you may add comments to every item. You can print a report by choosing 
Lookup from the Report menu.

For some of the fields linked to lookup tables you select a value by choosing from a drop-
down list (for example Format and Company) when you edit an album or a track. You can 
also enter the value directly, just like an ordinary text field. If this value is not already in the 
database, CATraxx adds it automatically. You can press Ctrl+W to add a new item, or click 
inside the field with the 'other' (in most cases the right) mouse button to activate a popup 



menu and choose New from this menu. For the rest of the fields, for example Artist and 
Songwriter, you press the button with the three dots, and then select the items in a dialog 
box.

Transferring Lookup Tables

The items in the lookup tables in a database is only accessible from within this database. If 
you work with several databases, you may want to transfer one or more tables from another 
database. You do this by choosing Transfer from the Lookup menu. Specify the database to 
transfer from and select the tables that you want to transfer.

4.3 Editing an album
1. If you do not see the Browse window, open it by double-clicking the Browse icon at the 

bottom of the main window. You may also press Ctrl+B.

2. From the list of registered albums, double-click the album you want to work with. You 
see the Active Album 1 window.

3. Change the information as necessary.

4. If necessary, double-click the Active Album 2 icon (or press Ctrl+J) to edit the special 
info fields.

CATraxx automatically saves the information the moment you leave the Active Album window
to choose another command. You can also save the information by choosing Save from the 
Album menu.

4.4 Deleting albums and compressing your 
database

When you delete albums as explained below, CATraxx will also compress your database to 
save hard disk space.

1. If you do not see the Browse window, open it by double-clicking the Browse icon at the 
bottom of the main window. You may also press Ctrl+B.

2. From the list of registered albums, select the album you want to delete.

3. From the Album menu choose Delete / Active album. You see the word DELETED in 
the status bar. Repeat for the other albums you want to delete (if any).
Note! This only marks the album(s) for deletion. To actually remove the albums from 
your hard disk, you must compress the database as explained in the next step. 

4. From the File menu choose Compress. The system asks if you want to delete the 
album(s). Click Yes.

4.5 Cataloging album covers
CATraxx lets you save and display bitmap pictures your album covers. Bitmap pictures 



occupy a lot of disk space, but you can have CATraxx compress the pictures by choosing 
Preferences from the File menu and checking Misc. - Use compression / Save pictures. 
When using compression, bitmaps may occupy as little as 1/8 of the original size.

To add an album cover to CATraxx:

1. Scan the album cover and save it as a .BMP file or place it on the clipboard.

2. In CATraxx, choose the album from the Browse window.

3. To add an album cover from a .BMP file: From the Edit menu choose Load Cover. 
You see the dialog box Load Cover. Select the bitmap file and choose OK. CATraxx 
opens the Cover window and places the album cover in the window.

To add an album cover from the clipboard: Open the Cover window by double-
clicking the icon at the bottom of the main window. You may also press Ctrl+R. Then 
choose Paste from the Edit menu. CATraxx places the album cover in the window.

To display an album cover:

1. Choose the album from the Browse window.

2. Open the Cover window by double-clicking the icon at the bottom of the main window. 
You may also press Ctrl+R. You see the album cover in the window.

Note! It may take some time to read the picture from the database. Therefore, if you 
want to browse the database quickly, always minimize the Cover window.

To remove an album cover:

Open the Cover window and choose Cut from the Edit menu.

4.6 Adding a track
To add new tracks to the active album, open the Track window by double-clicking on the icon.
You may also press Ctrl+K. Then press the New button. Note the following:

· When you add the first track, you see the dialog box Specify Default Information. Here 
you enter information that is relevant to all tracks (or most of them). This is usually true 
for Artist, Songwriter, Producer, Mixer, Studio, Musician and Instrument. The 
information you enter in this dialog box is automatically added to all new tracks. This way
you can save a lot of time. Please note that this applies only when you choose to add a 
new track (New). If you choose to make a copy of the active track (Copy), CATraxx 
ignores this information.

· You enter information about each track in the Active Track dialog box. The window title 
indicates what album the track is located on (Artist, Album title and Format). The 
tracks position on the album is also shown. With position we mean on what item and 
what side the track is located. If the track is number 2 on side A, (A2) is shown, and if 
the track is number 4 on side B item 2, (2-B4) is shown. The first track you add is always
track 1 on side A. When you are ready to add track 1 on side B (does not apply to CDs!),
choose Change side. Because no other tracks are added to this side, CATraxx asks 
whether you want to add a new track or a copy of the active track. This corresponds to 
the buttons New and Copy. If you have added a track to the wrong position (for example



swapped track 4 and 5), simply choose Change order and select the right track position.

Note! It is extremely important that you specify the right format for the album (including 
items and sides) to be able to add all tracks.

· CATraxx can automatically add musicians and instruments based on the artist(s) 
performing on the track and when the track was recorded. You must then have specified 
line-up (that is, members of the group) for these artists. To specify line-up, choose Artist
from the Lookup menu, select artist, press the Edit button and then press the Line-up 
button. Enter the musicians that have been a members of the group, what instruments 
they played and in what period they were members (as an example, open the sample 
database, SAMPLE.MDB, and check out Throwing Muses). When you want to add 
musicians, press the Automatic button, specify recording year and let CATraxx add the 
relevant musicians and instruments.

· Please note that the persons linked to Songwriter, Producer, Mixer and Musician all 
come from the lookup table Person. As a result you can use standard drag-and-drop 
techniques to transfer names between these lists. Because Songwriter / Producer / 
Mixer and Musician are not shown at the same time, you must drag the pointer over the
title Standard or Musician to make visible the list you want to drop the names on.

· CATraxx can automatically read the track length for all tracks on the album. Add first all 
track (artists, song titles and so on), insert the CD into the CD-ROM player and press the
Read length button.

You may store the following information for each track:

Song title Enter the title of the song. Maximum length is 75 characters.

Artist The name of the artist that performs on the track. To catalog the artist:

1. Click the List button (. . . ). You see the Artist Track dialog box. You can 
link up to five artists to the same track.

2. If the artist is registered in the database, the name is already listed. To 
find the artist, either scroll through the list and select the name you want, 
or type the name (or the first characters in the name) in the text box above
the list. Click the Add ( > ) button to move the name to the right-most list 
box.

If the artist is not registered in the database, choose New. You see
the New Artist dialog box. Fill in as much of the information as you want. 
You can use the Memo field to add personal comments about the artist. 
When you are ready, choose OK to close the dialog box.

3. Choose OK to close the Artist Track dialog box. You see the name(s) in 
the Artist field in the Active Track dialog.

Recorded The year the song was recorded.

Length The length of the track in minutes and seconds. If you have a CD-ROM 
drive (and are adding tracks from a CD!) you do not need to enter this 
manually, simply insert the CD into the CD-ROM drive and press the Read 
length button. CATraxx reads the length of all tracks on the CD. Please note 
that you need to add all tracks (song title, artist and so on) before you press 
this button. If you want to manually enter the length, you must use the format 



mm:ss, where m is minutes and s is seconds; for example 03:43.

Live Check this box if the song is a live recording.

Instrumental Check this box if the song is an instrumental.

Sound Specify whether the recording is in mono or stereo.

Songwriter Specify the songwriter(s). By default you can specify who wrote the music and 
who wrote the lyrics. If you do not want to do this, choose Preferences from 
the File menu and uncheck Data entry - Songwriter - Specify music/lyrics. 
To catalog the songwriter(s):

1. Click the List button (. . . ). You see the Songwriter dialog box.

2. If the person is registered in the database, the name is already listed. 
To find the person, either scroll through the list and select the name you 
want, or type the name (or the first characters in the name) in the text box 
above the list. Click the Add ( > ) button to move the name to the right-
most list box.

If the person is not registered in the database, choose New. You 
see the New Person dialog box. Fill in as much of the information as you 
want. You can use the Memo field to add personal comments about the 
person. When you are ready, choose OK to close the dialog box.

3. Choose OK to close the Songwriter dialog box. You see the name(s) in the
Songwriter field in the Active Track dialog.

Studio Specify the studio(s) where the song was recorded. To catalog the 
studio(s):

1. Click the List button (. . . ). You see the Studio dialog box.

2. If the studio is registered in the database, the name is already listed. To
find the studio, either scroll through the list and select the name you want, 
or type the name (or the first characters in the name) in the text box above
the list. Click the Add ( > ) button to move the name to the right-most list 
box.

If the studio is not registered in the database, choose New. You 
see the New Studio dialog box. You can use the Memo field to add 
personal comments about the studio. When you are ready, choose OK to 
close the dialog box.

3. Choose OK to close the Studio dialog box. You see the name(s) in the 
Studio field in the Active Track dialog.

Producer Specify the producer(s). For more information on how to catalog producer(s), 
see Songwriter.

Mixer Specify the mixer(s). For more information on how to catalog mixer(s), see
Songwriter.

Musician/



Instrument Here you specify the musicians and what instruments they play. CATraxx can 
automatically add musicians and instruments based on the artist(s) performing 
on the track and when the track was recorded. You must then have specified 
line-up (that is, members of the group) for these artists. To specify line-up, 
choose Artist from the Lookup menu, select artist, press the Edit button and 
then press the Line-up button. Enter the persons that have been a member of 
the group, what instruments they played and in what period they were 
members (as an example, open the sample database, SAMPLE.MDB, and 
check out Throwing Muses). When you want to add musicians, press the 
Automatic button, specify recording year and let CATraxx add the relevant 
musicians and instruments. To catalog the musicians:

1. Click the List button (. . . ). You see the Musician dialog box.

2. To catalog a new musician, choose Add. 

3. If the person is registered in the database, the name is already listed. 
To find the person, either scroll through the list and select the name you 
want, or type the name (or the first characters in the name) in the text box 
above the list.

If the person is not registered in the database, choose New. You 
see the New Person dialog box. Fill in as much of the information as you 
want. You can use the Memo field to add personal comments about the 
person. When you are ready, choose OK to close the dialog box.

4. Choose OK to close the Add Musician dialog box. You now need to specify
what instrument(s) the person plays.

5. If the instrument is registered in the database, the name is already 
listed. To find the instrument, either scroll through the list and select the 
instrument you want, or type the name of the instrument (or the first 
characters in the name) in the text box above the list. Click the Add ( > ) 
button to move the instrument to the right-most list box.

If the instrument is not registered in the database, choose New. 
You see the New Instrument dialog box. You can use the Memo field to 
add personal comments about the instrument. When you are ready, 
choose OK to close the dialog box.

6. Choose OK to close the Musician dialog box. You see the 
musicians/instruments in the Musician field in the Active Track dialog.

Memo This field is for comments. Maximum length is 10.000 characters.
Special info In addition to the standard fields, you can define up to 7 fields for special 

information. These fields are ready to use, but you may want to change the 
field names to something more specific (the default names are User-defined 
14, User-defined 15 and so on). There are two text fields (maximum 50 
characters), two drop-down list fields, and three check-box fields. To name a 
special field, choose User-defines fields from the File menu.

4.7 Editing a track
You do not have to do anything special to edit a track, just make the necessary changes. 



Changes you have made is automatically saved when you press one of the buttons. If the 
track you want to edit is not active, select the relevant track in the Track window and press 
the Edit button.

4.8 Deleting a track
When you want to delete a track, select this track in the Track window and press the Delete 
button. Please note that, unlike albums, tracks are deleted immediately!

4.9 Marking albums and tracks
CATraxx uses a system of marking entries (both albums and tracks). Marking and unmarking 
your entries can be useful if you wish to select different entries based on some sort of criteria 
(for example, all albums release by R.E.M.) for a pending action. You may wish to view, edit, 
search among or even print only the entries that have been marked. You can either mark 
entries manually or let CATraxx mark the entries based on a search result.

All new albums and tracks you add to your database is automatically marked. The button that
looks like a "V" on the toolbar indicates whether the album (or track when you have activated
the View Tracks dialog box) is marked or not. You mark/unmark the active entry simply by 
pressing this button. When the entry is marked the button is "in" (pressed), when the entry is 
unmarked the button is "out" (released). You can also press Ctrl+M to 
mark/unmark.

The status bar always shows the number of albums in the database, and how many of these 
that are marked. For example, if you have entered 340 albums and 75 are marked, the status
bar reads 75 / 340. The same is true when you have opened the View Tracks dialog box by 
choosing Tracks from the View menu (200 / 680 means that 200 out of 680 tracks are 
marked).

4.10 Viewing selected albums only 
By default CATraxx shows all albums entered into your database. Use the menu choice 
Subset from the View menu to show only the albums that are marked. This is very useful 
when you want to look at just some of the albums you have entered (for example albums 
released in 1990). This command is also available when you have activated the View Tracks 
dialog box by choosing Tracks from the View menu. For example, you may want to look at 
tracks performed by U2.

4.11 Changing the layout of the Browse window
You can decide which fields should be displayed in the Browse window and in the View 
Tracks dialog box. By default Artist, Album title, Format and Released are displayed for 
albums (Browse window) and Song title, Artist and Album title for tracks (View Tracks 
dialog box).

You may define up to 5 browse layouts yourself for both albums and tracks. Choose Browse 
Layout from the File menu to define your own layout or activate a layout previously defined. 
You can also click inside the Browse window with the 'other' mouse button (usually the right) 
and choose Layout from the popup-menu. Please note that the browse layout for tracks is 



used in the View Tracks dialog box, and not in the Tracks window.

Note! Each database uses separate browse layouts.

4.12 Viewing tracks from different albums 
simultaneously

When you add a new album or look at existing albums, CATraxx displays the tracks in the 
same order as they are located on the album (the Tracks window). Occasionally you may 
want to look at the tracks irrespective of what album they are located on. To do so:

1. Choose Tracks from the View menu. If one or more tracks are marked, CATraxx asks 
you if you want to view only the marked tracks. 

2. You see the View Tracks window. You can now browse the tracks the same way you 
browse the albums. 

To change the browse layout choose Browse Layout from the File menu, and to change the 
sort order choose Change Sort Order from the File menu. To edit the active track simply 
choose Track from the Edit menu. It is not possible to add new tracks or delete existing 
tracks when you view the tracks this way.

If you have searched for tracks and checked Show all, CATraxx will automatically activate 
the View Tracks dialog window.

4.13 Changing the sort order
By default the albums are sorted on Artist, Released and Album title. The tracks are sorted 
on Song tittle. Please note that this sort order is only used in the View Tracks dialog box, 
and not in the Tracks window (see previous section).

You may define up to 5 sort criteria yourself for both albums and tracks. To change the sort 
order, choose Change Sort Order from the File menu or click inside the Browse window with
the 'other' mouse button (usually the right) and choose Change Sort Order from the popup-
menu.

By default the sort order is not automatically updated when you add a new album. You must 
manually update the sort order by choosing Update Sort Order from the File menu or 
pressing Ctrl+F11. If you want CATraxx to automatically update the sort order each time you 
add a new album, choose Preferences from the File menu and check Data entry - 
Sort automatically.

Note! Because it may take some time to update the sort order when you have added a lot of 
albums, you may prefer not to automatically update the sort order. Just add all the new 
albums, and then update the sort order by choosing Update Sort Order from the File menu.

5.0 Looking up information



5.1 How to specify search criteria
CATraxx features very powerful search capabilities. You can search for all information you 
have entered into the database.
There are five different ways to search:

1. Find Album/Track. This is the easiest way to search. Simply fill in the fields you want to 
search in, choose OK, and CATraxx handles the rest!

2. Show Field Values. Specify the field you want to search in with the drop-down list. All 
unique values are then shown in the list box. Select the value you want to search for and
choose OK. The number of occurrences for each value is also shown. This might be 
very useful for statistic purposes.

3. Simple Search. Lets you define a search criterion based on one of the fields. You 
specify field, operator and the value you want to search for.

4. Advanced Search. Lets you define a search criterion based on up to 12 fields. You can 
group the fields in different ways using parenthesis and the logical operators AND/OR. 
The search criteria can be saved to a file for later use.

5. Cross References. The cross reference dialog box lets you cross reference up to 5 
fields. This is an extremely flexible way to search and query data.

In addition, CATraxx has eight "special searches" that give you features not available in the 
other search-commands.

Before you continue, please note that you specify a search criterion this way:

<Field> <Operator> <Value>

<Field> is the field you want to search in and <Value> is the value you want to search for. 
<Operator> is used to compare the value of the field with the value you specified (for 
example contains, less than or between). CATraxx supports the use of wildcards (? and ) in
connection with the operators Contains and Does not contain. A wildcard is a character that
substitutes for and enables a match by any of the characters or set of characters in its place. 
The question mark can be thought of as a special character that means replace me with any 
character you like. The asterisk can be thought of as a special character that means replace 
me with none or more occurrences of any character you like.

Note! CATraxx does not distinguish between upper and lower case characters when 
searching.

It is up to you whether CATraxx should search all albums/tracks, or only the albums/tracks 
that are marked (that is, only search the subset). Use the check box Search subset to 
specify this.

Use the check box Show all to specify whether CATraxx should mark the albums/tracks 
found during the search and show them (activates the View Subset or View Tracks 
command), or just show the first album/track found. If you choose the second alternative, 
choose Show Next from the Search menu to show the next album/track that was found. To 
show all albums/tracks found during the last search, choose Show Result from the Search 
menu.



Check Show albums if you want CATraxx to show what albums the tracks found during the 
search are located on. If you prefer so, the tracks found can be marked and you can later 
choose Tracks from the View menu to view these. Whether the tracks are to be marked or 
not, is specified by choosing Preferences from the File menu and checking Search - Search
tracks, show albums - Mark tracks.

5.2 Find Album/Track
This is the easiest way to search. You can search for both albums and tracks. CATraxx 
includes only the fields you have entered values for. Please note that you need to enter two 
values for some of the fields. For example, if you want to search for albums with a playing 
time between 40 and 60 minutes, you enter 040:00 and 060:00 in the text boxes for playing 
time.

Here is an example that shows you how to find all CDs (please open the sample database, 
SAMPLE.MDB, first):

1. Choose Find/Album from the Search menu.

2. Select CD from the drop-down list Format.

3. Uncheck Search subset. We want to search all albums, no matter whether they are 
marked or not.

4. Uncheck Show all. We want to show one album at first and later choose Show Next 
from the Search menu. This is faster since CATraxx does not need to mark all albums 
that are found.

5. Choose OK to execute the search.

6. CATraxx will now show the number of albums found (if you do not want this, choose 
Preferences from the File menu and uncheck Search - Show number of records 
found). When you choose OK the first album found is shown.

7. Choose Show Next from the Search menu to show the next album that was found.

8. If you want to look at all albums found, choose Show Result from the Search menu.

5.3 Show Field Values
When using this command, you specify the field you want to search in with the drop-down 
list. All unique values are shown in the list box. Select the value you want to search for and 
choose OK. The number of occurrences for each value is also shown. This might be very 
useful for statistical purposes.

Here is an example that shows you how to find all albums released in 1991 (please open the 
sample database, SAMPLE.MDB, first):

1. Choose Show Field Values from the Search menu.

2. Select Released from the drop-down list to the left. CATraxx reads all unique values 
from this field and show the result in the list box. We only want to look at the year (ignore



day and month). Check Only year to do this. The list is now updated and only release 
year is shown.

3. We want to search for albums released in 1991. Select 1991 from the list.

4. Select Is equal to from the right drop-down list.

5. Uncheck Search subset. We want to search all albums, no matter whether they are 
marked or not.

6. Check Show all. We want CATraxx to mark all albums found and then show these (that 
is, show the subset).

7. Choose OK to execute the search.

5.4 Simple Search
This command gives you more control. First specify the field you want to search in and the 
operator to use. Then enter the value you want to search for. You may want to choose Field 
values and select a field value from the list (this is the same list that is shown when you 
choose Show Field Values from the Search menu). 

CATraxx supports use of wildcards (? and ) in connection with the operators Contains and 
Does not contain. A wildcard is a character that substitutes for and enables a match by any 
of the characters or set of characters in its place. The question mark can be thought of as a 
special character that means replace me with any character you like. The asterisk can be 
thought of as a special character that means replace me with none or more occurrences of 
any character you like.

Here is an example that shows you how to find tracks performed by artists with a name that 
begins with "R" (please open the sample database, SAMPLE.MDB, first):

1. Choose Simple Search from the Search menu.

2. Select Artist track from the first drop-down list (this is the field).

3. Select Begins with from the next drop-down list (this is the operator).

4. Enter R as the value to search for.

5. Uncheck Search subset. We want to search all tracks, no matter whether they are 
marked or not.

6. Uncheck Show all. We want to show one track at first and later choose Show Next from
the Search menu. This is faster since CATraxx does not need to mark all tracks that are 
found.

7. Uncheck Show albums. We do not want the search result to be the albums with the 
tracks that are found.

8. Choose OK to execute the search.

9. CATraxx will now show the number of tracks found (if you do not want this, choose 
Preferences from the File menu and uncheck Search - Show number of records 



found). When you choose OK the first track found is shown.

10. Choose Show Next from the Search menu to show the next track that was found.

11. If you want to look at all tracks found, choose Show Result from the Search menu.

5.5 Advanced Search
This search command lets you define a search criterion based on up to 12 fields. You can 
group the fields in different ways. The search criterion can be saved to a file for later use. You
enter information about the sub-criteria you want to include in the query in the same way as 
you do when you use the simple search. For more information, see Simple Search.

As you add new fields to search, they are displayed in the list (each field on a single line). 
Add the logical operator OR by pressing the OR button. Two fields that are placed on two 
lines next to each other are grouped by the logical operator AND. You add parentheses by 
choosing either ( or ).

CATraxx lets you save a search criterion, so that you can use it later. Use the Save, Save as 
and Open buttons to do this.

Here is an example that shows you how to find tracks by R.E.M. on albums released 
between 1988 and 1992 (please open the sample database, SAMPLE.MDB, first):

1. Choose Advanced Search from the Search menu.

2. Press the New button to create a new empty search criterion.

3. Press the Add field button to add the first field.

4. Select Artist track from the first drop-down list (this is the field).

5. Select Is equal to from the next drop-down list (this is the operator).

6. Enter (or select from the list) R.E.M. as the value to search for and choose OK.

7. Press the Add field button to add the second field.

8. Select Released from the first drop-down list (this is the field).

9. Select Between from the next drop-down list (this is the operator).

10. Enter 1988 and 1992 as the values to search for and choose OK.

11. You may want to save this criterion. If so, click Save and enter a file name. Please note 
that all saved search criteria can also be used as a filter in reports.

12. Uncheck Search subset. We want to search all tracks, whether they are marked or not.

13. Check Show all. We want CATraxx to mark all tracks found and then show these (that 
is, show the subset).

14. Uncheck Show albums. We do not want the search result to be the albums with the 
tracks that are found.



15. Choose OK to execute the search.

5.6 Cross References
The cross reference dialog box lets you cross reference up to five fields. This is an extremely 
flexible way to search and query data. The result is shown immediately on the screen. You 
may want to print a report or execute a search based on the cross references.
It is possible to create cross reference based on up to five fields. The dialog box has five list 
boxes that show the result of the cross references. 

Placed right over every list are two drop-down lists. You select field from the left list and 
operator from the right list:

= Is equal to
>= Is greater then or equal to
<= Is less than or equal to

The operator is by default set to =, as this is the most likely choice. 

Please note that in many cases if you want to execute a search based on the cross 
references, you may want to set the operator to >=. This is because CATraxx compares the 
field value with the operator when the search is executed. For example, if you create a cross 
reference between an artist and all tracks with this artist, and you want to search for all these 
tracks, you need to select the first track and then choose the operator >= before the search is
executed. If you do not do this, CATraxx will think you want to search for exactly the track that
is selected in the list (since the operator was set to =).

Here is an example that shows you how to create cross references between Artist album 
and Album title (please open the sample database, SAMPLE.MDB, first):

1. Choose X-Ref from the Search menu.

2. Select Artist album from the drop-down list to the left.

3. Select Album title from the drop-down list over the second list box. All albums released 
by the artist selected in the list to the left are shown.

4. Try to select a different artist and watch CATraxx update the list with album titles.

5. Select U2 in the list to the left. All albums by U2 are shown.

6. To execute a search based on this cross reference, first select the first album shown in 
the second list box (Achtung Baby).

7. Select the operator >= (Is greater then or equal to) from the second operator drop-down 
list.

8. Uncheck Search subset in the Search menu. We want to search all albums, no matter 
whether they are marked or not.

9. Check Show all in the Search menu. We want CATraxx to mark all albums found and 
then show these (that is, show the subset).



10. Choose Execute from the Search menu to execute the search.

5.7 Special Search
CATraxx has eight "special searches" that gives you features not available in the other 
search-commands:

1. Song: More than one version - Searches for songs that you have more than one 
version of. Is based on Song title and, if you want, Songwriter.

2. Artist album - Searches for albums released by either one of or both the artists you 
specify.

3. Artist track - Searches for tracks performed by either one of or both the artists you 
specify. For example, you may want to search for tracks performed by both Neil Young 
and Crazy Horse.

4. Mixer - Searches for tracks mixed by either one of or both the persons you specify.

5. Musician - Searches for tracks where either one of or both the persons you specify play.

6. Producer - Searches for tracks produced by either one of or both the persons you 
specify.

7. Songwriter - Searches for tracks written by either one of or both the persons you 
specify.

8. Studio - Searches for tracks recorded in either one of or both the studios you specify.

6.0 Creating Reports
CATraxx has many different reports that you can customize to suit you needs, including 
reports for discography, insurance, statistics, album cover and various summary reports. All 
reports can be easily viewed or printed.

You can customize most of the reports to a certain extent to suit your needs. All reports can 
be preview, printed or sent to a file. We cannot guarantee that the print preview is 100% 
accurate. It works best with TrueType fonts.

If you want to make changes to the default printer, choose Print Setup from the File menu. 
You see the standard Windows printer setup dialog box where you can view or change your 
computer's current settings for printer, page orientation (landscape or portrait), or paper size. 
Please note that any changes made to Window's default printer will affect all Windows-
applications.

The page setup lets you specify margins and what fonts to use. You can use one font for the 
heading and one for the rest of the report. Default page setup is defined by choosing 
Preferences from the File menu, then selecting Report. Settings you make here are used by
default, but you may override this in the various reports by pressing the Page Setup button. 
In the page setup for each report, you may also specify page numbering and columns.



If you want a test print, that is just the first page (50 lines when printing to a file), check Test 
print. Please note that it is possible to cancel the printing by pressing Ctrl+C.
You can enter a heading that is printed in a different font at the beginning of the first page. In 
the heading you can use the code <date>, which causes CATraxx to insert the current date. 
This is very useful when a report layout is saved.

Use Include to specify which albums or tracks that are printed:

· All
· Subset (that is, albums or tracks that are marked)
· Filter

A filter specifies which albums or tracks are included in the report. The filter is defined exactly
the same way as a search criterion (simple or advanced search). Choose Preferences from 
the File menu, then select Report, Filter to specify if you want to create a simple or 
advanced filter. You may also click on the Filter button with the 'other' mouse button (usually 
the right) and choose this from the popup-menu.

Note! All reports can be canceled by pressing Ctrl+C.

6.1 Cover report
This report prints Artist, Album title and the Cover.

6.2 Discography
This report lists all albums released by the specified artist. The following fields are printed: 
Released, Album title, Company, Label and Catalog number. If you want, the tracks may 
also be included. The report uses all available space on the page (page width minus left and 
right margin). Increase the right margin if you think the report is too "wide".

6.3 Full report
This report provides you with a detailed view of all information entered about an album or 
track. Every record is printed on a separate page. You should always disable the page 
numbering. The report uses all available space on the page (page width minus left and right 
margin). Increase the right margin if you think the report is too "wide".

6.4 Insurance report
This report creates a simple list consisting of Artist, Album title, Album ID, Price and 
Value. CATraxx adds up price and value and prints the total sum at the end of the report. 

6.5 Line report
This report prints one field on each line. You may save the report layout for later use. The 
window title displays the name of the report. You may want to set the number of columns to 2
or 3. Choose Page setup to do this. The following report files were installed in the same 



directory as CATraxx:

· MEMO.LIA (Artist, Album title, Format, Released, Album ID and Memo).
· MEMO.LIT (Artist, Song title, Length, Album title, Album ID and Memo).
· MUSICIAN.LIT (Song title, Artist, Album title, Album ID and Musician).

6.6 List report
This report prints the fields in columns just like the list in the Browse window. Each album or 
track may occupy up to three lines. You may save the report layout for later use. The window 
title displays the name of the report. The following report files were installed in the same 
directory as CATraxx:

· DEFAULT.LSA (Artist, Album title, Format and Released).
· DEFAULT.LST (Artist, Song title and Album title).

6.7 Report lookup table
This report prints the contents of the specified lookup table.

6.8 Statistics report
This report prints the following statistics: number of albums, number of tracks, playing time, 
track length, total price and value in addition to a summary of the format groups.

6.9 Summary report
This report lets you order data into groups based on fields you select. A group value is printed
only when the value has changed. The detail line is printed the same way as the list report. 
You may save the report layout for later use. The window title displays the name of the report.
The following report files were installed in the same directory as CATraxx:

· ARTIST1.SRA (Artist / Album title, Format, Released and Album ID).
· ARTIST2.SRA (Artist / Album title, Format, Released and Album ID + Tracks).
· CATEGORY.SRA (Category / Artist, Album title, Format, Released and Album ID)
· COMPANY.SRA (Company / Artist, Album title, Format, Released and Album ID)
· CONDITI.SRA (Condition / Artist, Album title, Format, Released and Album ID)
· COUNTRY.SRA (Country / Artist, Album title, Format, Released and Album ID)
· FORMAT.SRA (Format / Artist, Album title, Released and Album ID)
· LABEL.SRA (Label / Artist, Album title, Format, Released and Album ID)
· ARTIST.SRT (Artist / Song title, Album title and Album ID).
· MIXER.SRT (Mixer / Artist, Song title, Album title and Album ID).
· MUSICIAN.SRT (Musician / Artist, Song title, Album title and Album ID).
· PRODUCER.SRT (Producer / Artist, Song title, Album title and Album ID).
· SONGWRIT.SRT (Songwriter / Artist, Song title, Album title and Album ID).

7.0 Using the CD Player



CATraxx lets you play CDs with your CD-ROM player. You start the CD Player by choosing 
CD Player from the Album menu. If the CD is linked to the database, CATraxx reads Artist 
and Album title from the album, and Artist, Song title and Songwriter from the current 
track.

CATraxx's CD Player has the following buttons: Start, Pause, Previous track, Next track, 
Stop and Eject (please note that some CD-ROMs do not support this). Check Random to 
play the tracks in random order. Check Repeat to re-start track 1 when the last track has 
finished. Check Introscan to play the first 20 seconds of each track on the CD.

Choose Track order to change, not surprisingly, the track order. This activates a dialog box 
where all tracks are shown in the list the to left. The right list shows the tracks you have 
selected. Please note that if this list is empty, all tracks are accessed in the same order as 
they appear on the CD. Changes to the track order is automatically saved and used next time
the same CD is played. It is not possible to change the track order if the CD is not linked to 
the database.

Choose Information to view the length of all tracks and the total length of the CD.

Note! You link a CD to the active album by choosing Link to CD from the Album menu.

8.0 Creating a backup copy of 
your database

Choose Backup from the File menu to create a backup copy of your database. This backup 
copy can be used if some unusual event occurs which causes your database to become 
corrupt and non-recoverable. (Normally, FIX will be able to restore your database if it 
becomes corrupt.) Please note that if a database is too large to fit onto one diskette, it is 
automatically split in two or more parts. The file on diskette no. 1 is named "dbname".001, 
the file on diskette no. 2 is named "dbname".002 and so on. 

You may restore a backup by choosing Restore from the File menu. Please note that you 
cannot simply copy the necessary file(s) from the diskette(s) to your hard disk. You must use 
CATraxx's internal routines to do this.

If you want CATraxx to compress the database when taking backup, choose Preferences 
from the File menu and check Misc./Use compression - Backup. If you use compression 
the database may occupy as little as ¼ of the original size!

Note! To protect against hard disk failure, you should routinely backup your valuable data 
files. FNProgramvare has no responsibility for any loss of data.

9.0 Splitting and merging 
databases

CATraxx lets you work with an unlimited number of databases. It is possible to split a single 



database in two. The marked albums will be transferred to the other database. These albums
will either be transferred to a new database or to an existing database. You split a database 
by choosing Split from the File menu.

It is also possible to merge two databases into one. All albums from the database you merge 
are transferred. You merge two databases by choosing Merge from the File menu.

10.0 Files Needed to Run CATraxx
CATraxx needs the following files:

In the program directory (the same directory where CATRAXX.EXE is located):

CATRAXX.HLP
CATRAXX.MEM
FIX.EXE

In the SYSTEM directory (usually C:\WINDOWS\SYSTEM):

LHA.DLL
MHRUN400.DLL
MSAES110.DLL
MSAFINX.DLL
MSAJT112.DLL
MSAJT200.DLL
VBDB300.DLL
VBRUN300.DLL
CMDIALOG.VBX
MCI.VBX
MHTIP.VBX
MHCB200.VBX
MHCM200.VBX
MHPFST.VBX
MHPFST.VBX
MHSL200.VBX
MHTAB.VBX
MSMASKED.VBX
MUSCLE.VBX
SSDATA2.VBX
THREED.VBX
VSVIEW.VBX

Several report files were copied to the program directory during installation: MEMO.LIA (line 
report album), MEMO.LIT, MUSICIAN.LIT (line reports track), DEFAULT.LSA (list report 
album), DEFAULT.LST (list report track), ARTIST1.SRA, ARTIST2.SRA, CATEGORY.SRA, 
COMPANY.SRA, CONDITI.SRA, COUNTRY.SRA, FORMAT.SRA, LABEL.SRA (summary 
reports album), ARTIST.SRT, MIXER.SRT, MUSICIAN.SRT, PRODUCER.SRT and 
SONGWRIT.SRT (summary reports track).

A sample database (SAMPLE.MDB) was also copied to the program directory during 
installation. This database contains information about 30 albums. We recommend that you 
open the sample database the first time you run CATraxx. Most examples in the 



documentation are referring to this database.

In addition, CATraxx will automatically create the file CATRAXX.INI in your WINDOWS 
directory (usually C:\WINDOWS). Each database you create has a corresponding ini-file with 
the same name as the database (for example MUSIC.MDB and MUSIC.INI). This ini-file 
contains information about the browse layout and sort order.

11.0 Help and Technical Support
Online help is available at any time by choosing Contents or Search from the CATraxx Help 
menu.

Technical support is available at no charge if you are a registered user. However, support is 
available only by E-mail or regular mail. Sorry, but we cannot provide telephone support at 
this time. Contact us at:

FNProgramvare
Storgt. 22
N-1531 Moss
Norway

or 
E-mail: fredrik.nordbakke@ostfoldnett.no

When reporting problems, the more information you can provide the better our response can 
be. If possible, include the following:

· What version of Microsoft Windows are you running? For example, Windows 3.1, 
Windows for Workgroups, Windows NT or Windows 95.

· What version of CATraxx are you running? You can determine this by choosing About 
CATraxx from the CATraxx Help menu. Include the entire “version line” in your report; 
for example 2.50.00.

· Is the problem reproducible? If so, how?
· If you see a dialog box with an error message when the problem occurs,  if possible 

include the full text of the dialog box, the text in the title bar and the error number. 


