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Create a new Company
 

To create a new Company

1 Choose the Clear button or select Clear from the Record menu. If you are on the Contact tab 
choose the Whole Record button.

2 Choose the Contact tab. Choose the type of company you require - click on the down arrow to 
the right of the Drawer field. This will display a list of possible values from which you can click 
on the one you require.

3 Choose the Company tab. Enter the Code field using up to ten characters.
4 On the left of the screen, enter the remaining fields you require. To move from one field to the 

next, press the TAB key. To move to any field, click on it.
5 On the right of the screen, choose an entry for each category you require - click on the down 

arrow to the right of the field. This will display a list of possible values from which you can click 
on the one you require.

6 Choose the Extras tab and enter the fields you require.
7 Choose the Notes tab and enter the fields you require.
8 Choose the Save button or Save from the Record menu.
9 To enter Contacts for this Company refer to Create a new Contact.
10 Refer to:
Create a new Contact



Create a new Contact
 

To create a new contact

1 Ensure you have selected a Company first. Refer to Create a new Company, Update a 
Company.

2 Choose the Contact tab.
3 Choose the Clear button or Clear from the Record menu. Choose the Contact button.
4 Enter a Contact name. This is the name that will appear on selection lists, etc., so it should easily

identify the person, e.g. Mr Chang, David in Development, or Clare (Sales).
5 Enter the remaining fields you require. To move from one field to the next, press the TAB key. To 

move to any field, click on it.
6 The phone and fax numbers are copied from the Company tab initially but you can type over 

these if you wish.
7 Choose the Save button or Save from the Record menu.
8 If this is the main Contact for the Company, refer to Set Default Contact.
9 Refer to:
Create a new Company
Update a Company
Set Default Contact



Update a Company
 

To update company information

1 Select the Company you require - refer to Find a Company.
2 Choose the tabs and amend the fields you require. To move from one field to the next, press the 

TAB key. To move to any field, click on it.
3 To add a Contact for this Company refer to Create a New Contact
4 To update a Contact for this Company refer to Update a Contact.
5 To create, update or remove a notice refer to Urgent Notice.
6 Choose the Save button or Save from the Record menu.
7 Refer to:
Find a Company
Create a New Contact.
Update a Contact.
Create an Urgent Notice



Find a Company
 

To find a company record

1 Choose the Clear button or select Clear from the Record menu. There are three highlighted key 
fields on which you can search for a company - Code, Company and Postcode.

2 Enter part (starting at the beginning) or all of one of the key fields.
3 Choose the Find button or Find... from the Record menu, or enter <CTRL>F. Either the Company

will be displayed immediately, a List will appear or a message will be shown - no records found.
4 If a List appears, choose the Company you require. If the Company is not on the list, double click

the button in the top left hand corner of the window to close it and go back to step 2, trying 
another code.

5 If the message is shown, choose OK and try another code.



Update a Contact
 

To update contact information

1 Select the Company to which the Contact belongs - refer to Find a Company.
2 Choose the Contact tab.
3 If the Contact you require is the main one for the Company, it will be displayed.
4 If not, choose the down arrow to the right of the Contact field. Choose the Contact you require by

clicking on it.
5 Amend the fields you require. To move from one field to the next, press the TAB key. To move to 

any field, click on it.
6 Choose the Save button or Save from the record menu.
7 If you wish this Contact to become the main one for the Company, refer to Set Default Contact.
8 Refer to:
Find a Company.
Set Default Contact



Set Default Contact
 

To set the default contact for a company

1 Ensure that the Contact you require is displayed in the Contact tab - refer to Update a Contact.
2 Click the small box to the right of the down arrow next to the Contact field. This places an x in the

box and sets this Contact as the default. Any existing default will have the x removed.
3 Refer to:
Update a Contact



Create an Urgent Notice
 

To create an urgent notice

1 Ensure that the Company to which you are giving the Notice is displayed on the Company tab - 
refer to Find a Company.

2 Choose Urgent Notice... from the Action menu.
3 To replace any existing text, choose the Clear button or press the Delete key. To just remove an 

existing notice, ignore the next step.
4 Enter the message to be displayed when a user selects this Company.
5 Choose the OK button.
6 Refer to:
Find a Company



Create a new User
 

To create a new user

1 Choose Security from the Admin menu.
2 Choose Users... from the submenu.
3 Choose the Insert button.
4 Enter the User field using up to ten characters.
5 Enter the remaining fields you require. To move from one field to the next, press the TAB key. To 

move to any field, click on it.
6 To set the user's rights refer to Give Rights to a User.
7 Choose the OK button.
8 Choose the Close button.
9 Refer to:
Give Rights to a User



Give rights to a user
 

To give rights to a user

1 First you must be in Edit User - refer to Update a User.
2 Choose the Insert... button.
3 You can assign a User to one or more Groups. This gives the User all the Rights for each of 

those Groups.    You can also give a User individual Rights.
4 Double click the Groups and Rights you require in the Rights List. (If the Rights List covers the 

user's rights it helps to drag it elsewhere on the screen.)
5 To set Group Rights refer to Give Rights to a Group and Remove Rights from a Group.
6 Close the list by pressing <ESC>.
7 Refer to:
Update a User.
Give Rights to a Group
Remove Rights from a Group



Update a User
 

To update user information

1 Choose Security from the Admin menu.
2 Choose Users... from the submenu.
3 Click on the User you require.
4 Choose the Edit button.
5 Update the fields you require .To move from one field to the next, press the TAB key. To move to 

any field, click on it.
6 To alter the Rights refer to Give Rights to a User and Remove Rights from a User.
7 Choose the OK button.
8 Choose the Close button.
9 Refer to:
Give Rights to a User
Remove Rights from a User.



Remove rights from a user
 

To remove rights from a user

1 First you must be in Edit User - refer to Update a User.
2 Click on the Group or Right you require in the Rights field.
3 Choose the Delete... button.
4 Refer to:
Update a User.



Give rights to a Group
To give rights to a group

1 First you must be in Edit Group - refer to Maintain Groups.
2 Choose the Insert... button.
3 Double click the Rights you require in the Rights List. (If the Rights List covers the user's rights it 

helps to drag it elsewhere on the screen.)
4 Close the list by pressing <ESC>.
5 Refer to:
Maintain Groups



Maintain Groups
To maintain groups to which users can belong

1 Choose Security from the Admin menu.
2 Choose Groups... from the submenu.
3 To add a group, choose the Insert button. Enter a code of up to ten characters in the Group field.
4 To amend a group click on the one you require and choose the Edit button.
5 Enter the Description field.
6 To alter the Rights refer to Give Rights to a Group and Remove Rights from a Group.
7 Choose the OK button.
8 Choose the Close button.
9 Refer to:
Give Rights to a Group
Remove Rights from a Group



Remove Rights From a Group
To remove rights from a group

1 First you must be in Edit Group - refer to Maintain Groups.
2 Click on the Right you require in the Rights field.
3 Choose the Delete... button.
4 Refer to:
Maintain Groups



Create a Todo
 

To create a Todo

1 First you must be entering an Action for a Contact - refer to Create Actions. The fields for a Todo 
are enclosed in the box labelled "Next".

2 Enter a description for the Todo in the comment field.
3 Choose the user to carry out the next action - click on the down arrow to the right of the Assign 

To field. This will display a list of user codes, including yourself, from which you can click on the
one you require.

4 In the same way choose the type of action from the Action field.
5 Specify the date and optionally the time when you wish the next action to be carried out, as 

follows:
6 > Enter the Date field in the form DDMMYYYY, without typing the / characters, e.g. 14021995 for 

14 February 1995.
7 > Enter the Time field in the form HHMMSS, without typing the : characters, e.g. 151130 for 3.11 

and 30 seconds in the afternoon.
8 To send a message to the user's screen shortly before the action is due refer to Set an Alarm.
9 Choose the OK button.
10 Refer to:
Create Actions
Set an Alarm



Create Actions
 

To create an action

1 Ensure that the Company you intend the Action for is displayed in the Company tab - refer to 
Update a Company.

2 Press the F2 key or select Action... from the Action menu.
3 To change the Contact click on the down arrow to the right of the Contact field. This will display a

list of possible names from which you can click on the one you require.
4 Choose the type of Action you require - click on the down arrow to the right of the What field. 

This will display a list of possible codes from which you can click on the one you require.
5 Enter a description of the event in the Comment field.
6 To print an address label if you are sending something in the post, refer to Print Labels.
7 To automatically phone the Contact if you have a modem connected refer to Autodial.
8 To generate the next Action for yourself or another user refer to Create a Todo.
9 To generate tasks and messages for other users in addition to any set up as your defaults in 

Automatic Todos and Automatic Notifications, choose the "people" button then proceed as 
follows:

10 > To add a To Do click the Assign field then choose the Insert... button. This will display the 
User List from which you can double click on the one you require. (If the User List covers the 
Operators it helps to drag it elsewhere on the screen.) Close the window by pressing the 
<ESC> key.

11 > To add a Notification, click the Notify field then continue as in step 10.
12 > Choose the Close button.
13 If you are logging the event after it has occurred, rather than timing it "live", choose the "clock" 

button. Enter the Start and Finish Date and Time fields as follows:
14 > Enter the dates in the form DDMMYYYY, without typing the / characters, e.g. 14021995 for 

14 February 1995.
15 > Enter the times in the form HHMMSS, without typing the : characters, e.g. 151130 for 3.11 

and 30 seconds in the afternoon.
16 > Choose OK.
17 Choose OK.
18 Refer to:
Update a Company
Print Labels
Autodial
Create a To Do.
Automatic Todos
Automatic Notifications



Print Labels
 

To print mailing labels

1 You can print labels from either the Contact tab or the Action screen. Refer to Update a Contact 
and Create Actions.

2 From the Contact tab, ensure that the Contact to print on the Label is displayed. Choose the 
Label button or Label from the Action menu.

3 From the Action screen, choose the type of document you are sending - click on the down arrow 
to the right of the Send field. This will display a list from which you can click on the one you 
require.

4 Refer to:
Update a Contact
Create Actions



Autodial
 

To dial a phone number automatically

1 You can dial phone numbers automatically from either the Contact tab or the Action screen. 
Refer to Update a Contact and Create Actions.

2 From the Contact tab, ensure that the Contact to phone is displayed. Choose the Autodial button 
or Autodial from the Action menu.

3 From the Action screen, choose the "telephone" button.
4 The Contact's number is displayed but you can type over this if necessary.
5 Choose the type of call - click on the down arrow to the right of the Action field. This will display a

list from which you can click on the one you require.
6 Choose the Dial button.
7 Choose the Close button.
8 Refer to:
Update a Contact
Create Actions



Automatic Todos
 

To give someone a Todo automatically

1 Choose Actions... from the Admin menu.
2 This will display the Action Types list from which you can double click on the one you require.
3 Click in the Give Todo box then choose the Insert Op... button. This will display the User List from

which you can double click on the one you require. Close the window by pressing the <ESC> 
key.

4 Choose the OK button.
5 Choose the Close button.



Automatic Notification
 

To notify another operator of an action automatically

1 Choose Actions... from the Admin menu.
2 This will display the Action Types list from which you can double click on the one you require.
3 Click in the Notify box then choose the Insert Op... button. This will display the User List from 

which you can double click on the one you require. Close the window by pressing the <ESC> 
key.

4 Choose the OK button.
5 Choose the Close button.



Set an Alarm
 

To set an alarm

1 First you must be entering a Todo for a Contact - refer to Create a Todo.
2 Click the small box by Set Alarm. This places an x in the box.
3 The default number of minutes before the event is due when the alarm is to be displayed will be 

shown in the Mins Before field. You can type over this if you wish.
4 Refer to:
Create a Todo



Create a Drawer
 

To create a drawer

1 Choose Drawer Maintenance from the Admin menu.
2 Choose the Insert... button.
3 Enter the Code field using up to ten characters.
4 Enter the Name field, usually a longer description.
5 Enter the remaining fields in the Main tab. To move from one field to the next, press the TAB key. 

To move to any field, click on it. The text you enter will be displayed as the tab headings on 
your new Drawer.

6 Choose each tab in turn and enter the fields you require. The text you enter for a field will be 
displayed as the prompt for that field on the Drawer.

7 Note that the Tab 2 fields Ana 1, Ana 2, etc. are analysis fields. Each of these is a category of 
your choosing into which you will place a specific set of values - refer to Analysis Fields. 
Typical analysis fields are Industry Type, Sales Territory and Turnover range.

8 Choose the OK button.
9 Choose the Close button.
10 Refer to:
Analysis Fields



Analysis Fields
 

To set up values for Analysis Fields

1 First you must be creating or amending a Drawer - refer to Drawer Maintenance.
2 Click on the Drawer for which you require Analysis Fields then choose the Analysis... button.
3 Choose the Analysis Field you require - click on the down arrow to the right of the Field Name 

field. This will display a list of possible fields from which you can click on the one you require.
4 Any existing values will be displayed in the box below.
5 To add a new value, choose the Insert button. Enter the Code and Description. Choose the OK 

button.
6 To amend an existing value click on the one you require then choose the Edit button. Enter the 

Description then choose the OK button.
7 To delete an existing value click on the one you require then choose the Delete button.
8 Choose the Close button.
9 Refer to:
Drawer Maintenance.



Drawer Maintenance
 

To create a drawer

1 Choose Drawer Maintenance... from the Admin menu.
2 Choose the Insert... button.
3 Enter the Code field using up to ten characters.
4 Enter the Name field, usually a longer description.
5 Enter the remaining fields in the Main tab. To move from one field to the next, press the TAB key. 

To move to any field, click on it. The text you enter will be displayed as the tab headings on 
your new Drawer.

6 Choose each tab in turn and enter the fields you require. The text you enter for a field will be 
displayed as the prompt for that field on the Drawer.

7 Note that the Tab 2 fields Ana 1, Ana 2, etc. are analysis fields. Each of these is a category of 
your choosing into which you will place a specific set of values - refer to Analysis Fields. 
Typical analysis fields are Industry Type, Sales Territory and Turnover range.

8 Choose the OK button.
9 Choose the Close button.
10 Refer to:
Analysis Fields



Create a Document
 

To create a document

1 To create a document addressed to a Contact ensure that the Contact is displayed in the Contact
tab. Refer to Update a Contact.

2 Choose the Word Processing button or your word processor from the Action menu.
3 Choose a document template from the list by double clicking on the one you require.
4 Enter the Title, Subject and Keyword fields. The Author is yourself initially but you can type over 

this if you wish.
5 To include a description in the Action that will be created enter the Comment field.
6 Choose the OK button.
7 You will now be editing a new document in your particular word processing package.
8 Refer to:
Update a Contact



Retrieve a Document
 

To retrieve a document created through Octopus

1 Ensure that the Company to which the document is addressed is displayed on the Company tab. 
Refer to Update a Company

2 Choose the Actions button or Action List... from the Action menu, or enter <CTRL>A.
3 Click on your document.
4 Choose the Word Processing button or your word processor from the Action menu.
5 After a few moments you will be editing your document.
6 Refer to:
Update a Company



Edit a Document
 

To edit a document created through Octopus

1 Refer to the help screens or manual of your particular Word Processing package.



Print a Document
 

.To print a document created through Octopus

1 Refer to the help screens or manual of your particular Word Processing package.



Use a Todo
 

To use an item on the Todo list

1 If the Todo list is not visible, choose Todo List from the Window menu.
2 Click on the Todo you wish to action. Summary details will be displayed below the list.
3 To see full details double click on the entry.
4 Amend the fields you require.
5 Choose the OK button. This will indicate that the Todo has been done and it will be removed from

the Todo list.



Delete a Contact
 

To delete a contact

1 Ensure that the Contact you wish to delete is displayed in the Contact tab - refer to Update a 
Contact.

2 Choose the Delete button or Delete from the Record menu, or enter <CTRL>D.
3 If you have chosen to delete accidentally you can choose the Cancel button to keep the Contact. 

Otherwise choose the Contact button.
4 Refer to:
Update a Contact



Delete a Company
 

To delete a company

1 Ensure that the Company you wish to delete is displayed in the Company tab - refer to Find a 
Company.

2 Choose the Delete button or Delete from the Record menu, or enter <CTRL>D.
3 If you are on the Contact tab and have chosen to delete accidentally choose the Cancel button to

keep the Company. Otherwise choose the Whole Record button. This will delete the Company 
and all its Contacts.

4 If you are on another tab a message is displayed - Are you sure you want to delete. If you have 
chosen to delete accidentally you can choose the Cancel button to keep the Company. 
Otherwise choose the OK button.

5 Refer to:
Find a Company



Mail Merge
 

To perform mail merge operations

1 It is assumed you know how to run a mail merge in your Word Processor - refer to its manual 
and help screens.

2 Ensure the current Merge File is the one you require by checking on the status bar to the right of 
the time. To change it refer to Merge Information.

3 Choose a Contact to add to the Merge File - refer to Update a Contact.
4 Choose the Merge button or Merge from the Action menu.
5 Repeat steps 3 and 4 for all the Contacts to be mailed.
6 Load your word processor to run the Mail Merge. Create the letter in the word processor and 

take the names and addresses from the file to which you have just been adding Contacts. To 
identify the file and path name refer to Merge Information.

7 Refer to:
Merge Information
Update a Contact



Merge Information
 

To specify name and address files used for mail merges

1 Choose Merge Info... from the Admin menu or enter <CTRL>M.
2 The Merge Info list is displayed showing merge files as messages that will identify Mail Out 

Actions.
3 To set up merge files used choose the Setup... button. The Merge Setup list is displayed, 

showing mail out messages and corresponding file names.
4 To specify a new merge file choose the Insert... button then enter the Description.
5 To specify a file used for an existing mail merge, click on the one you require and choose the 

Edit... button, or double click on the one you require.
6 Enter the Merge File name, including the full path. If you don't know it you can choose the 

Browse... button. This provides the standard Browse window for finding the required file.
7 Choose the OK button.
8 If required enter the Default Merge File including the full path. If you don't know it you can 

choose the Browse... button. This provides the standard Browse window for finding the 
required file.

9 Choose the Close button.
10 Choose the merge file for your next mail merge by clicking on the one you require in the Mail 

out Messages field.
11 Choose the Close button.



Query by Example
 

To perform an ad hoc query

1 You can search on one or more fields in all tabs in any combination.
2 Choose the Query button or Query from the Query menu.
3 For each field you require, click on it and enter part (starting at the beginning) or all of the value 

on which to search. For more complex searches you can include "Wild Cards"    - refer to Using
Wild Cards.

4 Choose the Fire Query button or Query Fire from the Query menu.
5 Either one Company will be displayed immediately, a List will appear of all Companies meeting 

your criteria or a message will be shown - no records found.
6 If a List appears, choose the Company you require. If the Company is not on the list, double click

the button in the top left hand corner of the window to close it and go back to step 2, trying 
different searches.

7 If the message is shown, no companies have met your criteria, so try again from step 2.
8 You can work through the Companies selected by clicking anywhere in the List window to bring it

to the front again.
9 To save your selection criteria, refer to Save Queries.
10 Refer to:
Save Queries
Using Wild Cards



Save Queries
 

To save queries

1 To perform a Query refer to Query by Example.
2 Choose the Query button or Query from the Query menu. Your selection criteria will be 

redisplayed in the appropriate fields.
3 Choose the Save button or Save from the Record menu.
4 Enter a suitable Name that will easily identify the Query.
5 Choose the Query button or Query from the Query menu to exit query mode.
6 Refer to:
Query by Example



Using Wild Cards
To include Wild Cards in queries

1 To specify that at a particular position in a word or number there can be any single character, use
underscore, i.e. _.

2 To specify that at a particular position in a word or number there can be any number of any 
characters (including none), use percent, i.e. %.

3 Examples:

(a) You are looking for a company called Jonathan Smith Ltd or Jonathon Smith Ltd, you don't 
know the spelling: enter Jonath_n in the company field.

(b) You are looking for all companies in postcode area N1: enter N1 ___ in the postcode field. 
By specifying a space and any three characters after N1 you will avoid selecting N10, N11, etc.
as well.

(c) You are looking for a contact named Stephen, Steven or Steve: enter Ste%e% in the 
contact field. (This will allow "v" or "ph" for the first % and "n" or nothing for the second %.) 
Note this would also select Stephanie, Stevie, Steed, etc!

(d) You are looking for all companies in Grosvenor Place, or maybe Grosvener Place, London, 
you don't know the postcode, but you know that the phone numbers must start with 0171: enter
%Grosven_r Place in the first address field and 0171 in the phone field. (This will allow a 
house number before the road name and either spelling, the phone number will eliminate this 
road in any other towns.)



Send EMail
 

To send electronic mail

1 Choose Send EMail from the Action menu.
2 This will take you into your particular EMail package.



Receiving EMail
 

To receive electronic mail

1 Choose Mail Messages from the Action menu.
2 Double click on the message you wish to read.
3 Choose the OK button.
4 Double click on the button in the top left hand corner of the Mail Messages field to close it.



Delete EMail
 

To delete electronic mail

1 Choose Mail Messages from the Action menu.
2 Click on the message you wish to delete.
3 Choose the Delete button. Be quick or it will time out!
4 Double click on the button in the top left hand corner of the Mail Messages field to close it.



Edit Actions
 

To edit an action

1 Ensure that the Company for which the Action took place is displayed in the Company tab - refer 
to Find a Company.

2 Choose the Actions button or Action History... from the Action menu, or enter <CTRL>A.
3 This displays the Action History from which you can double click on the Action you require.
4 Amend the fields you require.
5 Choose the OK button.
6 Refer to:
Find a Company



Delete Actions
 

To delete an action

1 Ensure that the Company for which the Action took place is displayed in the Company tab - refer 
to Update a Company.

2 Choose the Actions button or Action List... from the Action menu, or enter <CTRL>A, to display 
the Action List.

3 Click on the Action you require.
4 Choose the Delete button or Delete from the Record menu, or enter <CTRL>D.
5 A message is displayed - Are you sure you want to delete. If you have chosen to delete 

accidentally you can choose the Cancel button to keep the Action. Otherwise choose the OK 
button.

6 Double click the button in the top left hand corner of the window to close it.
7 Refer to:
Update a Company
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Menu Commands
Select the menu from

File
Edit
Record
Accounts
Action
Query
Admin
Window
Help



File Menu
New Form
Print Preview
Print
Reports
Printer Setup
Exit



Creating a new form
To create a new Company form

1 Choose New Form from the File menu.



Print Preview
To display a report on the screen

1 Choose Print Preview from the File menu.



Printing
To print a report

1 Choose Print from the File menu.



Reports
To locate and run reports

1 Choose Reports... from the File menu.
2 To add a new report, choose the Insert button. Refer to Edit Report Definition.
3 To amend a report's location, click on the report you require and choose the Edit button, or 

double click on the report you require. Refer to Edit Report Definition.
4 To display a report on the screen choose the Preview button.
5 To print a report choose the Print button.
6 To delete a report choose the Delete button.
7 Choose the Close button.
8 Refer to:
Edit Report Definition



Edit Report Definition
To locate a report

1 First you must be adding or amending a report - refer to Reports.
2 Enter the Description field.
3 Enter the report file name in the Filename field including the full path. If you don't know it you can

choose the Browse... button. This provides the standard Browse window for finding the 
required file.

4 Choose a right - click on the down arrow to the right of the Right field. This will display a list of 
possible rights from which you can click on the one you require. To have no rights, choose the 
C button to clear.

5 In the same way choose a Dialogue box, if any.
6 Choose the OK button.
7 Refer to:
Reports



Printer Setup
To select and set up your printer

1 Choose Printer Setup from the File menu.
2 Click on the report type you require in the large box..
3 Choose a printer - click on the down arrow to the right of the Printers field. This will display a list 

of possible printers from which you can click on the one you require.
4 To configure this printer choose the Setup... button. This enters the standard Windows Print 

Setup. Choose the OK button when you have finished setting up.
5 Choose the Change button
6 Choose the OK button.



Exiting Octopus
To exit Octopus

1 Choose Exit from the File menu or double click the button in the top left hand corner of the 
Octopus window.



Edit Menu
Cut
Copy
Paste
Delete



Cut
To remove text for inclusion elsewhere

1 First you must have selected some text to cut. To do this you highlight it.
2 Choose Cut from the Edit menu or enter <CTRL>X.
3 You can now paste the text in either Octopus or some other application. For Octopus refer to 

Paste.
4 Refer to:
Paste



Paste
 

To insert text taken from elsewhere

1 First you must have carried out a Cut or Copy on some text in either Octopus or some other 
application. For Octopus, refer to Cut, Copy.

2 Place the mouse pointer where you wish to insert the text.
3 Choose Paste from the Edit menu or enter <CTRL>V.
4 Refer to:
Cut
Copy



Copy
 

To copy text

1 First you must have selected some text to copy. To do this you highlight it.
2 Choose Copy from the Edit menu or enter <CTRL>C.
3 You can now paste the text in either Octopus or some other application. For Octopus refer to 

Paste.
4 Refer to:
Paste



Delete
 

To delete text

1 First you must have selected some text to delete. To do this you highlight it.
2 Choose Delete from the Edit menu or press <Delete>.
3 To remove text for inclusion elsewhere, refer to Cut.
4 Refer to:
Cut



Record Menu
First
Previous
Next
Last
Find
Clear
Save
Delete



First Record
To access the first company on the current list

1 Choose the First button (|<) or First from the Record menu, or enter <CTRL><Page Up>.



Previous
To access the previous company on the current list

1 Choose the Previous button (<) or Previous from the Record menu, or press <Page Up>.



Next Record
To access the next company on the current list

1 Choose the Next button (>) or Next from the Record menu, or press <Page Down>.



Last Record
To access the last company on the current list

1 Choose the Last button (>|) or Last from the Record menu, or enter <CTRL><Page Down>.



Clear
To clear the Company tab

1 Select the Clear button or Clear from the Record menu.



Save
To save a record you are adding or updating

1 Choose the Save button or Save from the Record menu.



Delete a Company or Contact
To delete a Company or Contact

1 To delete a Company refer to Delete a Company.
2 To delete a Contact refer to Delete a Contact.
3 Refer to:
Delete a Company
Delete a Contact



Accounts Menu
Sales Open Items
Purchase Open Items
Customer Account Record
Supplier Account Record
Create SL Account
Create PL Account
Accounts System
OP Enquiry
OP Entry
Stock Enquiry



Sales Open Items
To enquire on Sales Ledger Transactions

1 Ensure that the Company to enquire on is displayed in the Company tab - refer to Update a 
Company.

2 Choose the Sales Ledger button or Sales Open Items from the Accounts menu, or enter 
<CTRL>S.

3 To vary the display and view invoices refer to Sales Ledger Transactions.
4 To close the Sales Open Items window, double click on the button in the top left hand corner.
5 Refer to:
 Update a Company
Sales Ledger Transactions



Sales Ledger Transactions
To vary the sales transactions display and view invoices

1 The initial display is for Open Items.
2 To view all transactions, click on the button All.
3 To view Open Items in a particular ageing band, click on the Current, 30, 60, 90 or 90+ Days 

button.
4 To view all Open Items again, click on the button Open.
5 To enquire on an invoice or credit note, double click on the entry. Double click on the button in 

the top left hand corner of the window to close it.



Purchase Open Items
To enquire on Purchase Ledger Transactions

1 Ensure that the Company to enquire on is displayed in the Company tab - refer to Update a 
Company.

2 Choose the Purchase Ledger button or Purchase Open Items from the Accounts menu, or enter 
<CTRL>P.

3 To vary the display refer to Purchase Ledger Transactions.
4 To close, double click on the button in the top left hand corner.
5 Refer to:
Update a Company
Purchase Ledger Transactions



Purchase Ledger Transactions
To vary the supplier transaction display

1 The initial display is for Open Items.
2 To view all transactions, click on the button All.
3 To view Open Items in a particular ageing band, click on the Current, 30, 60, 90 or 90+ Days 

button. To view all transactions, click on the button All.
4 To view all Open Items again, click on the button Open.



Customer Account Record
To enquire on the Customer Account

1 Ensure that the Company you require is displayed in the Company tab - refer to Update a 
Company.

2 Choose Customer Account Record from the Accounts menu.
3 You will be taken into the account enquiry of your particular accounting product.
4 To view transactions, choose the Open Items button and refer to Sales Ledger Transactions.
5 Refer to:
Update a Company
Sales Ledger Transactions



Supplier Account Record
To enquire on the Supplier Account

1 Ensure that the Company you require is displayed in the Company tab - refer to Update a 
Company.

2 Choose Supplier Account Record from the Accounts menu.
3 You will be taken into the account enquiry of your particular accounting product.
4 To view transactions, choose the Open Items button and refer to Purchase Ledger Transactions.
5 Refer to:
Update a Company
Purchase Ledger Transactions



Create SL Account
To create a Sales Ledger Account

1 Ensure that the Company to create an account for is displayed in the Company tab - refer to 
Update a Company.

2 Choose Create Sales Ledger Account from the Accounts menu.
3 The account code is the same as the Octopus Company Code initially but you can type over this 

if you wish.
4 Choose the OK button.
5 If the account code already exists choose the OK button. Go back to step 3 and try another code.
6 Once you have entered a unique code, you will be taken into the account entry process of your 

particular accounting product. Wherever possible, information is copied from Octopus.
7 Refer to:
Update a Company



Create PL Account
To create a Purchase Ledger Account

1 Ensure that the Company to create an account for is displayed in the Company tab - refer to 
Update a Company.

2 Choose Create Purchase Ledger Account from the Accounts menu.
3 The account code is the same as the Octopus Company Code initially but you can type over this 

if you wish.
4 Choose the OK button.
5 If the account code already exists choose the OK button. Go back to step 3 and try another code.
6 Once you have entered a unique code, you will be taken into the account entry process of your 

particular accounting product. Wherever possible, information is copied from Octopus.
7 Refer to:
Update a Company



Accounts System
To load your Accounting package

1 Choose the Accounts button or Accounts System from the Accounts menu.



OP Enquiry
To perform a Sales Order Processing enquiry

1 Ensure that the Company to enquire on is displayed in the Company tab - refer to Update a 
Company.

2 Choose OP Enquiry from the Accounts menu or press <F5>.
3 You will be taken into the order enquiry of your particular accounting product.
4 Choose the Close button.
5 Refer to:
Update a Company



OP Entry
To enter a Sales Order

1 Ensure that the Company to enter an order for is displayed in the Company tab - refer to Update 
a Company.

2 Choose OP Entry from the Accounts menu or press <F6>.
3 You will now be in the Order Entry process of your particular accounting package.
4 Refer to:
Update a Company



Stock Enquiry
To perform a Stock Enquiry

1 Choose Stock Enquiry from the Accounts menu or press <F7>.
2 Select the Warehouse by clicking on the ...    button by the Warehouse field. Click on the entry 

you require and choose the Select button, or double click on the entry.
3 Select the Product by product code by clicking on the ... button next to the Product field; or select

it by alpha code by clicking on the ... button next to the Alpha field. Click on the entry you 
require and choose the Select button, or double click on the entry.

4 You will be taken into the stock enquiry of your particular accounting product.
5 Choose the OK button.
6 Choose the Close button.



Action Menu
ToDos
Action History
Actions
Label
Merge
Mail
Autodial
Urgent Notice
Quick Entry
Send EMail
Mail Mesages
Word Processor
Spreadsheet



Todos
To open the Todo List window

1 Choose Todos from the Action menu. If the window is already open this option will be unavailable
- to bring the window to the front choose Todo List from the Window menu.



Action History
To edit an action

1 Ensure that the Company the Action belongs to is displayed in the Company tab - refer to Update
a Company.

2 Choose the Actions button or Action History... from the Action menu, or enter <CTRL>A.
3 This displays the Action History from which you can choose the Action you require.
4 Amend the fields you require.
5 Choose the OK button.
6 Refer to:
Update a Company



Actions
To create an action

1 Ensure that the Company for the Action is displayed in the Company tab - refer to Update a 
Company.

2 Press the F2 key or select Action... from the Action menu.
3 To change the Contact click on the down arrow to the right of the Contact field. This will display a

list of possible names from which you can click on the one you require.
4 Choose the type of Action you require - click on the down arrow to the right of the What field. 

This will display a list of possible codes from which you can click on the one you require.
5 Enter a description of the event in the Comment field.
6 To print an address label if you are sending something in the post, refer to Print Labels.
7 To automatically phone the Contact if you have a modem connected, refer to Autodial.
8 To generate the next Action for yourself or another user, refer to Create a To Do.
9 To generate tasks and messages for other users in addition to any set up as your defaults in 

Automatic Todos and Automatic Notifications, choose the Ops... button then proceed as 
follows:

10 > To add a Todo click the Give Todo field then choose the Insert Op... button. This will display 
the User List from which you can double click on the one you require. Close the window by 
pressing the <ESC> key.

11 > To add a Notification click the Notify field then choose the Insert Op... button. This will display
the User List from which you can double click on the one you require. Close the window by 
pressing the <ESC> key.

12 > Choose the Close button.
13 If you are logging the event after it has occurred, rather than timing it "live", choose the Call 

Time... button. Enter the Start and Finish Date and Time fields as follows:
14 > Enter the dates in the form DDMMYYYY, without typing the / characters, e.g. 14021995 for 

14 February 1995.
15 > Enter the times in the form HHMMSS, without typing the : characters, e.g. 151130 for 3.11 

and 30 seconds in the afternoon.
16 > Choose OK.
17 Choose OK.
18 Refer to:
Update a Company
Print Labels
Autodial
Create a To Do.
Automatic Todos
Automatic Notifications



Mail
To print a mailing label and generate an action for it

1 Ensure that the Contact you require is on the Contact tab - refer to Update a Contact.
2 Choose the Mail Out button or Mail Out from the Action menu.
3 Refer to:
 Update a Contact



Quick Entry
To quickly enter basic Company and Contact details

1 Choose Quick Entry... from the Action menu or press <F4>.
2 Enter any description in the Comments field, this will appear in the Action comments..
3 Enter the Phone, Contact and Company fields.
4 To enter further Action information including Todos, choose the Action... button, otherwise choose

the OK button. Refer to Actions.
5 Refer to:
Actions



Mail Messages
To view mail messages sent to you

1 Choose Mail Messages from the Window menu.
2 If the option is not present, choose Mail Messages from the Action menu.
3 A list of Mail Messages is displayed from which you can double click on the one you require to 

read the whole message.
4 Choose the OK button to return to the list.
5 To return to the main Company window behind, click anywhere on it or choose the Company 

name from the Window menu.



Create a Spreadsheet
 

To create a spreadsheet

1 Choose the Spreadsheet button or your spreadsheet from the Action menu.
2 Choose a document template from the list by double clicking on the one you require.
3 Enter the Title, Subject and Keyword fields. The Author is yourself initially but you can type over 

this if you wish.
4 To include a description in the Action that will be created enter the Comment field.
5 Choose the OK button.
6 You will now be editing a new document in your particular spreadsheet package.
7 Refer to:
Update a Contact



Query Menu
Query
Query Fire
Query Save
Queries



Query
To define an ad hoc Query

1 You can search on one or more fields in all tabs in any combination.
2 Choose the Query button or Query from the Query menu.
3 For each field you require, click on it and enter part (starting at the beginning) or all of the value 

on which to search. For more complex searches you can include "Wild Cards"    - refer to Using
Wild Cards.

4 To run the query refer to Query Fire.
5 To save your selection criteria, refer to Save Queries.
6 Refer to:
Query Fire
Save Queries
Using Wild Cards



Query Fire
To run an ad hoc query

1 First you must have defined a query - refer to Query.
2 Choose the Fire Query button or Query Fire from the Query menu.
3 Either one Company will be displayed immediately, a List will appear of all Companies meeting 

your criteria or a message will be shown - no records found.
4 If a List appears, choose the Company you require. If the Company is not on the list, double click

the button in the top left hand corner of the window to close it and go back to step 1, trying 
different searches.

5 If the message is shown, no companies have met your criteria, so try again from step 1.
6 You can work through the Companies selected by clicking anywhere in the List window to bring it

to the front again.
7 To save your selection criteria, refer to Save Queries.
8 Refer to:
Query
Save Queries



Queries
To run a previously saved query

1 Choose Queries from the Query menu.
2 A list of queries is displayed from which you can double click on the one you require.
3 The screen is cleared and the selection criteria are placed in the appropriate fields. To run the 

query, refer to Query Fire.
4 Refer to:
Query Fire



Admin Menu
Merge Info
Actions
Security
Drawer Maintenance
Change Password
User Options
Toolbar
Status Bar
System Keys



Security
To administer the security of the system

1 To maintain users, refer to Create a New User, Update a User.
2 To maintain groups refer to Maintain Groups.
3 To maintain rights refer to Maintain Rights.
4 Refer to:
Create a New User
Update a User
Maintain Groups
Maintain Rights



Maintain Rights
To maintain rights available to users and groups

1 Choose Security from the Admin menu.
2 Choose Rights... from the submenu.
3 To add a Right, choose the Insert button. Enter a code of up to ten characters in the Right field.
4 To amend a Right click on the one you require and choose the Edit button.
5 Enter the Description field.
6 Choose the OK button.
7 Choose the Close button.



Change Password
To change your password

1 Choose Change Password from the Admin menu.
2 Enter the Old Password and New Password fields.
3 Enter the new password again in the Verify New Password field.
4 Choose the OK button.



User Options
To specify your user options

1 Choose User Options from the Admin menu.
2 To enter general options, choose the User tab and refer to User General Options.
3 To enter word processing options, choose the Wordprocessor tab and refer to Wordprocessor 

Options.
4 To enter spreadsheet options, choose the Spreadsheet tab and refer to Spreadsheet Options
5 To enter communications options, choose the Environment tab and refer to Environment Options.
6 Refer to:
User General Options.
Wordprocessor Options.
Spreadsheet Options
Environment Options.



User General Options
To enter general user options

1 First you must be entering user options and be in the User tab - refer to User Options.
2 Choose the Action you use most often - click on the down arrow to the right of the Default Action 

field. This will display a list of possible Actions from which you can click on the one you require.
3 In the same way, choose the number of days ahead to generate the next action, from the Days 

Ahead field.
4 In the same way, choose the number of minutes before an action is due to display the alarm, 

from the Alarm Mins Before field.
5 Enter the Logfile field including the full path. If you don't know it you can choose the Browse... 

button. This provides the standard Browse window for finding the required file.
6 Enter the Rows, Company List and Contact List fields.
7 Refer to:
User Options



Wordprocessor Options
To enter your word processing options

1 First you must be entering user options and be in the Wordprocessor tab - refer to User Options.
2 Choose your word processor - click on the down arrow to the right of the Word Processor field. 

This will display a list of possible products from which you can click on the one you require.
3 Enter the Exe path field to specify the directory for the word processor programs. If you don't 

know it you can choose the Browse... button. This provides the standard Browse window for 
finding the required path.

4 In the same way enter the Doc path and Template path fields to specify the directories of the 
word processor document and template files respectively.

5 Choose the Action to generate when using the word processor in the same way as for step 2.
6 Refer to:
User Options



Spreadsheet Options
To enter your spreadsheet options

1 First you must be entering user options and be in the Spreadsheet tab - refer to User Options.
2 Choose your spreadsheet - click on the down arrow to the right of the Spreadsheet field. This will

display a list of possible products from which you can click on the one you require.
3 Enter the Exe path field to specify the directory for the spreadsheet programs. If you don't know it

you can choose the Browse... button. This provides the standard Browse window for finding the
required path.

4 In the same way enter the Doc path and Template path fields to specify the directories of the 
spreadsheet document and template files respectively.

5 Choose the Action to generate when using the spreadsheet in the same way as for step 2.
6 Refer to:
User Options



Environment Options
To specify your environment options

1 First you must be entering user options and be in the Environment tab - refer to User Options.
2 Choose your EMail system - click on the down arrow to the right of the Mail Service field. This 

will display a list of possible products from which you can click on the one you require.
3 Enter the Mail Polling field to specify the number of minutes between each check for mail 

received.
4 Choose the port your modem is connected to - click on the down arrow to the right of the Autodial

field. This will display a list of possible ports from which you can click on the one you require.
5 Enter the Reports field to specify the directory for report files. If you don't know it you can choose

the Browse... button. This provides the standard Browse window for finding the required path.
6 Refer to:
User Options



Tool Bar
To toggle the toolbar display on/off

1 Choose Toolbar from the Admin menu.



Status Bar
To toggle the status bar display on/off

1 Choose Status Bar from the Admin menu.



System Keys
To set up the System Keys

1 NOTE: You set up initial values for system keys when you first install Octopus. Thereafter the 
system maintains them and they should not need any more updating, except for setting any 
new ones in upgrades or perhaps for changing descriptions.

2 Choose System Keys from the Admin menu.
3 To amend a system key click on the system key you require and choose the Edit... button, or 

double click on the system key you require.
4 To add a new system key choose the Insert... button. Enter the Code field using up to ten 

alphanumeric characters.
5 Enter the Value and Description fields.
6 Choose the OK button.
7 To finish setting up system keys choose the Close button.



Window Menu
Cascade
Tile Horizontal
Tile Vertical
Arrange Icons
1- 9
More Windows



Cascade
To arrange the windows staggered one on top of another

1 Choose Cascade from the Windows menu.



Tile Horizontal
To arrange the windows separately with horizontal divisions

1 Choose Tile Horizontal from the Window menu.



Tile Vertical
To arrange the windows separately with vertical divisions

1 Choose Tile Vertical from the Window menu.



Arrange Icons
This has no effect within Octopus.



Window Menu Options 1 to 9
To bring a window to the front

1 Choose the window you require from the list numbered from 1 upwards or click anywhere on the 
window if it is visible.



More Windows
To bring the next set of ten windows (if any) onto the window menu

1 Select More Windows from the Window menu.



Help Menu
Index
Using Help
About Octopus



Help Index
To access the help index

1 Select Help Index from the Help menu.



Using Help
To access the Help system

1 Choose Using Help from the Help menu.



About Octopus
To access product and licence information

1 Choose About Octopus from the Help menu.



Keyboard Shortcuts
Navigation

Moving in a form
Switching between Windows
Switching betweens applications

Deleting, copying and pasting

Deleting text
Copying text
Pasting text

Database shortcuts

Finding companies
Moving between companies
Insert, update, delete companies
      insert
      update
      delete
Actions and responses



Moving in a form
 

Keyboard shortcuts for moving in a form

1 <TAB>: Moves to the next field.
2 <SHIFT><TAB>: Moves to the previous field.
3 Click: Moves to the field clicked.
4 <HOME>: Moves to the beginning of the current field.
5 <END>: Moves to the end of the current field.



Switching between Windows
 

To switch between open windows

1 Click anywhere on the window if it is visible.



Switching between applications
 

To switch between active applications

1 Enter <ALT><TAB> repeatedly until the application you require is displayed in the box in the 
centre of the screen, or

2 Enter <CTRL><ESC> to display the Task List. Click on the application you require then choose 
the Switch To button, or double click on the application you require.



Moving between companies
 

To move between companies

1 Click anywhere on the window of the Company you require if it is visible.



Insert, update, delete, companies
 

To insert, update and delete companies

1 To insert a Company refer to Creating a New Form and Create a new Company.
2 To update a Company refer to Update a Company.
3 To delete a Company refer to Delete a Company.
4 Refer to:
Creating a New Form
Update a Company
Delete a Company
Create a new Company



Support

About KAI



About KAI Computer Services Ltd
KAI Computer Services Ltd is a company that has for many years specialised in bespoke 
programming work.
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C
character
click

D
down arrow
drag

F
field

H



highlight

M
menu
modem
mouse

P
path
pointer

S
status bar
submenu

T
tab

W
window
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#
1 to 9

A
About KAI
About Octopus
Accounts Menu
Accounts System
Action Data
Action History
Action Menu
Actions and responses
Actions
Admin Menu
Analysis Fields
Arrange Icons
AutoDial



Automatic Notification
Automatic ToDos

B
Banner

C
Cascade
Change Password
Clear
Contents
Copy
Create a Document
Create a Drawer
Create a new Company
Create a new Contact
Create a new User
Create a Spreadsheet
Create a ToDo
Create Actions
Create an Urgent Notice
Create PL Account
Create SL Account
Creating a new form
Customer Account Record
Cut

D
Data Menu
Delete a Company or Contact
Delete a Company
Delete a Company
Delete a Contact
Delete Actions
Delete EMail
Deleting text in a field
Drawer Maintenance

E
Edit a Document
Edit Actions
Edit Menu
Edit Report Definition
Environment Options
Exiting Octopus

F



File Menu
Find a Company
Find
Finding companies
First Record

G
Give rights to a Group
Give rights to a user
Glossary

H
Help Index
Help Menu

I
Index
INI File Admin
INI File
Insert update    delete companies
Insert

K
Keyboard

L
Label
Last Record

M
Mail Merge
Mail Messages
Mail
Maintain Groups
Maintain Rights
Menus
Merge Information
Merge
More Windows
Moving between companies
Moving in a form

N
Next Record

O
OP Enquiry
OP Entry
Options
Others



P
Paste
Previous Record
Print a Document
Print Labels
Print Preview
Printer Setup
Printing
Purchase Ledger Transactions
Purchase Open Items

Q
Queries
Query by Example
Query Fire
Query Menu
Query Save
Query
Quick Entry

R
Receiving EMail
Record Menu
Reference
Reindex
Remove Rights From a Group
Remove rights from a user
Reports
Retrieve a Document
Rights

S
Sales Ledger Transactions
Sales Open Items
Save Queries
Save
Security
Send EMail
Sending EMail
Set an Alarm
Set Default Contact
Setup Menu
Spreadsheet Options
Status Bar
Stock Enquiry



Supplier Account Record
Support
Switching between applications
Switching between Windows
System Keys

T
Tile Horizontal
Tile Vertical
ToDo
Tool Bar
Topic1
Topic2
Topic3
Topic3
Topic4
Topic5
Topic6
Topic7
Topic8

U
Update a Company
Update a Contact
Update a User
Update
Use a ToDo
User General Options
User Options
Using Help
Using Octopus
Using Wild Cards

V
View EMail
View Menu

W
Window Menu
WinMark INI
Word Processor
Wordprocessor Options



Action (Data Menu)



Actions and responses
 

Actions and responses



Banner



Data Menu
First
Prev
Next
Last
Find
Clear
Insert
Delete
Update
Action List
Action
Query
Query Fire
Query Save
Label
Mail
Merge
AutoDial
Others...







Find



Insert
To insert a Company

1 After entering all the details, choose the Insert button or Insert from the Record menu, or enter 
<CTRL>I.



Update
To update a Company

1 After entering all the details, choose the Update button or Update from the Record menu, or 
enter <CTRL>U.





Query Save



Label



Merge
To add a Contact to a mail merge

1 Ensure the current merge file is the one you require. It is displayed on the status line to the right 
of the time. Refer to Merge Information.

2 Ensure the Contact you require is on the Contact tab - refer to Update a Contact.
3 Choose the Merge button or Merge from the Action menu.
4 Repeat steps 2 and 3 for each Contact to be mailed.
5 To run the mail merge, use your Word Processor. Create the document to send to each Contact 

here. The names and addresses are in the file you have just been adding Contacts to. To 
check its path and name, refer to Merge Information.

6 Refer to:
Merge Information
Update a Contact



Others



Deleting text in a field
 

To delete the text in a field

1 First you must have selected some text to delete. To do this you highlight it.
2 Press <Delete>.



Finding companies
 

To find a company



INI File
Ini file description goes here



INI File Option



Title



Options



Reindex



Rights
To give rights to a user

1 First you must be amending user details - see Edit Users.
2 Choose Security from the Admin menu.
3 Click on the User you require in the Users + Groups list.
4 Find the Right you require in the Rights + Groups list.
5 Drag and Drop the Right into the large box underneath the Users + Groups list.
6 Choose the Close button.



Sending EMail
Sending EMail



Setup Menu
System Keys
Actions
Merge Info
Drawer Maintenance



Title



Title



Title



Title



Title



Title



Title



Title



View EMail
 

To view electronic mail



View Menu
Tool Bar
Status Bar
ToDo's
Queries
Mail Messages
Options



WinMark INI



Word Processor
 



button
labelled rectangle on the screen that you can click to perform a particular operation.



character
anything that you can enter from the keyboard, i.e. an upper or lower case letter, a number or a 
punctuation mark.



click
press a button on a mouse.



down arrow
symbol on the screen or key on the keyboard labelled with an arrow pointing downwards.



drag
move a window with the mouse as follows: 1. Move the pointer over the title bar of the window you wish 
to move. 2. Hold down the mouse button. 3. Move the pointer to take the window to its new position. 4. 
Let go of the mouse button.



field
box on the screen into which you can type information.



highlight
select a piece of text with the mouse as follows. 1. Place the pointer just in front of the required text. 2. 
Hold down the mouse button. 3.    Move the pointer to a position just beyond the end of the text. 4. Let go
of the mouse button.



menu
list of options from which to select a task.



modem
acronym for Modulator Demodulator, a device attached between a computer and a telephone or fax that 
enables the computer to automatically dial a number.



mouse
device attached to a computer by a cable used in conjunction with a keyboard. It has two buttons on top 
and a tracker ball underneath.



path
drive letter and sequence of directories identifying a file's location on a disk.



pointer
arrow on the screen controlled by a mouse.



status bar
bottom line of the screen displaying date, time, messages, etc.



submenu
second menu displayed after selecting a particular entry of another menu.



tab
labelled marker attached to an otherwise hidden page of information to enable its selection.



window
rectangular display area occupying part or all of the screen.






