
About NAL 2.0

Novell* Application Launcher* 2.0 software ("NAL") lets you distribute applications to users' workstations and 
manage those applications as objects in the Novell Directory Services* (NDS*) tree. Users access the applications
that you assign them using the NAL Window and NAL Explorer components. These components, or delivery 
mechanisms, display Application objects as clickable icons in a window or in the Windows** Explorer.

NAL gives you powerful, unparalleled control over applications after they have been distributed to workstations. 
Your users needn't worry about workstation configurations, drives, ports, command-line parameters, application 
source directories, or whether they have the latest upgrade. You, as the administrator, manage such tasks easily 
and centrally from the NetWare* Administrator utility.

Click the following links for answers to frequently asked questions about NAL:

Understanding NAL
What are the major components of NAL?
What is the NDS schema; why does it need to be "extended" to support Application objects?
Can I migrate earlier versions of Application objects to version 2.0?
Can I ensure security of Application objects on the network?
What if users change their login location?
What is NAL.EXE? Why is it called a "wrapper"?
What are the main tasks of distributing applications with NAL?

Creating Application Objects
What is an Application object?
What is an Application Object Template (.AOT) File?
What is a .FIL file?
What is NAL snAppShot?
How do I use NAL snAppShot?
What is an example of using NAL snAppShot?
What is an example of a simple application distribution?
What is an example of a complex application distribution?
How do I create a simple Application object (without a .AOT file)?
How do I create a complex Application object (with a .AOT file)?
Can I export and import Application objects?
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What Are the Major Components of NAL?

Novell* Application Launcher* 2.0 software ("NAL") consists of two administrator components and two user 
components. The following information briefly describes these components.

NAL Snap-In
The NAL Snap-In component is a Windows** DLL that "snaps in" to the NetWare* Administrator utility. NAL Snap-In
makes it possible to create Application objects in Novell Directory Services* (NDS*) trees. Like other objects in an 
NDS tree, Application objects contain their own set of properties. These properties give you a high level of control 
over the Application object after it has been distributed to workstations.

For example, you can run applications one time or run them at a scheduled time. You can create application icons 
that just install software and then disappear from the desktop. If your network is a mixture of Windows platforms 
and workstation configurations, you can filter applications to run only on the workstations that meet your critieria. 
Browse the Help Contents page to discover the many other capabilities of NAL.

In addition to adding the Application object type, NAL Snap-In also adds new property pages to User, Group, 
Organization, and Organizational Unit objects. These property pages enable you associate applications with one 
specific User Object, or with Group, Organization, or Organizational Unit objects. Using the added property pages, 
you can also specify how the application runs users' workstations.

NAL snAppShot
When you install a complex application on a workstation, it is possible that changes are made to the workstation, 
including the Windows** Registry, .INI files, file system files, CONFIG.SYS and AUTOEXEC.BAT files, and any 
other configurations that support the application. Imagine keeping track of all these changes every time you had to
install an application on a user's workstation.

Think of the NAL snAppShot component as a camera that takes two "snapshot" pictures: the workstation's pre-
installation configuration state (before you install an application) and the workstation's post-installation state (after 
you install an application). NAL snAppShot then compares the two snapshots and records any differences in an 
Application Object Template (.AOT) file.

NAL snAppShot also keeps track of all the files that an application Setup program installs to the workstation. 
These files are copied and stored in a series of .FIL files.

You use the information gathered by NAL snAppShot when creating and setting up Application objects in NAL 
Snap-In. Because the .AOT file contains all application installation changes, you can set up Application objects 
with confidence, knowing that they have the same configuration as if you had installed an application locally to a 
workstation. This process greatly simplifies your job and helps to ensure a smooth rollout of applications to users' 
desktops.

NAL Window
NAL Window is the user's workstation component that displays the icons of the Application objects that you set up 
using NAL Snap-In. NAL Window lets users create personal folders (with your permission), refresh applications, 
change views, and get information about folders and applications. Because you centrally manage the application, 
users cannot disturb the drive paths of the application. For more information, click Installing and Running NAL 
Window.

NAL Explorer
NAL Explorer adds a new level of Windows 95** and Windows NT** desktop integration. In addition to using a 
special NAL Explorer window, users also have access to the applications you assign them in the Windows 
Explorer, Start Menu, System Tray, or Deskop. Installing and Running NAL Explorer.

Both NAL Window and NAL Explorer rely on the configurations that you set up in the Launcher Configuration 
property page on the User, Organization, or Organizational Unit object to which you have associated application 
objects. NAL Window and NAL Explorer first look to User's object for configuration information. If that User object is
set to use parent container settings, then NAL Window and NAL Explorer look to the immediate parent 
Organization or Organizational Unit object. If the parent Organization or Organizational Unit is set to use a default 
configuration, then the default configuration is used.
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What Is an Application Object?

An Application object is the key building block of Novell* Application Launcher* 2.0 software ("NAL"). Like other 
objects used in Novell Directory Services* (NDS*) software, an Application object contains certain properties or 
information. The most important information that an Application object carries is

where a network application is physically located on the network and
which users are authorized to use that network application.

Application objects simplify typical administrative tasks such as assigning rights, customizing login scripts, and 
supporting applications. And because you use NetWare* Administrator to create Application objects, you can centrally
administer applications for an entire Organization, Organizational Unit, Group, or User object. By configuring 
executables as Application objects, you can upgrade and control versions of applications on the network more 
effectively.

When you assign an Application object to a User, Group, or Organization, or Organizational Unit object, you make 
the application available to users who are trustees or members of those objects. Using NAL Window or NAL 
Explorer software, users can authenticate to the network anywhere and still access the same applications, 
regardless of the drive mappings and port captures of the local workstation.

When launching the application, you can set up network drive mappings, printer ports, and additional parameters 
to be automatically configured, reducing the need to add mappings in user login scripts to run network 
applications.

Because Application objects configure their required resources when launched, you can reduce maintenance of 
system and user login scripts as well as login execution times.

You can assign application parameters and support contacts to each Application object. The application 
information is available to users on their desktops. Users can send e-mail to support contacts using the contact 
information associated with the application.

Click the following links for answers to frequently asked questions about NAL:

Understanding NAL
What are the major components of NAL?
What is the NDS schema; why does it need to be "extended" to support Application objects?
Can I migrate earlier versions of Application objects to version 2.0?
Can I ensure security of Application objects on the network?
What if users change their login location?
What is NAL.EXE? Why is it called a "wrapper"?
What are the main tasks of distributing applications with NAL?

Creating Application Objects
What is an Application object Template (.AOT) File?
What is a .FIL file?
What is snAppShot?
How do I use NAL snAppShot?
What is an example of a "simple application" distribution?
What is an example of a "complex application" distribution?
How do I create a simple Application object (without a .AOT file)?
How do I create a complex Application object (with a .AOT file)?
Can I export and import Application objects?
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Ensuring Security of Applications through NDS

Using Novell* Application Launcher* 2.0 software ("NAL"), you can assign network Applications objects to User, 
Group, Organization, Organizational Unit object, or any combination of the four. Because access to files and 
directories is handled through Novell Directory Services* (NDS*) file system security, you needn't worry about 
users disturbing application source files.

In addition, NAL Window and NAL Explorer provide security measures of their own. Essentially viewers of 
Application objects, these workstation delivery mechanisms let users create personal folders (with your 
permission) for the applications you have assigned them. Users cannot change the application icon picture or 
caption or disturb the source paths of the application. If they delete important application files or configurations on 
their desktop, you or they can easily redistribute the application (known as an application "refresh").
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What If Users Change Their Login Location?

Because the applications you distribute to workstations using Novell* Application Launcher* 2.0 software ("NAL") 
are connected to Novell* Directory Services* (NDS*) trees, Application objects are associated with a user’s 
network login ID. Therefore, applications follow the user around the network. Regardless of the login location, the 
user always sees the same set of network applications. This ensures that Users who work from multiple locations 
or physical workstations always have a consistent set of network applications.
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Upgrading or Redistributing Application Objects

The applications you distribute using Novell* Application Launcher* 2.0 software ("NAL") are dynamic and can be 
refreshed automatically. This ensures that any changes you make are reflected on users’ workstations. You can 
easily install new applications and migrate users to new versions of applications without visiting each user’s 
workstation. You can upgrade an application by using NAL snAppShot component to gather new Application 
Object Template (.AOT) file information and by modifying the path to the new application executable, which can be
installed anywhere on the network.

For example, suppose that you've installed a new version of a network application. You can quickly move the 
appropriate users to that new version by modifying the properties in the Application object defined in a Novell* 
Directory Services* (NDS*) tree to point to the new version of the application. NAL Window or NAL Explorer then 
update that network application on the appropriate user desktops. The next time a user double-clicks the icon for 
that application, the updated version is launched automatically.

Using the Verify option in NAL Window or NAL Explorer, users can update applications on their own, provided that 
you have given them permission to do so. For more information, read about the Refresh Icons option on the 
Launcher Configuration property page.

See Also
Using Version Stamps to Upgrade Applications
Upgrading Workstations from Windows 3.x to Windows 95
Rolling Back or Reversing an Application Distribution
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Distributing Applications: A Procedural Overview

After you have installed Novell* Application Launcher* Snap-In ("NAL" Snap-In), you must complete several 
general tasks to distribute Application objects to your users' workstations. Click the links for more detailed 
information.

1. If you are using an Application Object Template (.AOT) file to create Application objects, use NAL snAppShot to
discover application installation changes on a representative workstation.

2. Start NetWare* Administrator and log in to the NDS* tree where you create Application objects.

3. Right-click the Organization or Organizational Unit object under which you want to create Application objects.

4. Choose Create > Application and click OK.

5. If you are using a .AOT file that you created in Step 1, click Use Application Object Template (.AOT) File and 
follow the prompts.

OR

If you are not using a .AOT file, fill in the dialog box and follow the prompts.

6. After you have created the Application object, use the Associations property page to assign the Application 
object to User, Group, Organization, or Organizational Unit objects (this is mandatory).

NOTE: Because file system rights are not automatically granted when the Application object is associated to a 
User, Group, Organization, or Organizational Unit object, you must explicitly grant these file system rights. 
Normally, Read and File Scan are required to the SYS:PUBLIC directory where NAL is installed (by default). 
Additional rights may be needed depending on the application you are distributing. For example, if the 
application stores user-specific information on the server, additional rights might be required. You can grant file 
system rights to users by granting rights to the Group, Organization, or Organizational Unit the Application 
object is associated with and to which the User object is a member.

7. Right-click the User, Group, Organization, or Organizational Unit object that is associated with the Application 
object and click Details.

8. Use the User, Organization, or Organizational Unit Launcher Configuration property page to specify settings for
NAL Window or NAL Explorer. By default, applications are set to run in NAL Window.

9. Use the User, Group, Organization, or Organizational Unit object's Applications property page to specify where 
the user sees applications on the workstation.

10. Right-click the Application object and click Details.

11. Use the other property pages to set up any other special configurations (for example, application scheduling, 
Registry changes, setting up icons and shortcuts, and so on) for the Application object.

12. To make use of NAL Window and NAL Explorer, modify the User or Organizational Unit object's login script.
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Migrating Application Objects from 1.0x to 2.0x

Use the Migrate Application Objects dialog box to upgrade version 1.0x Application objects to version 2.0x.

To migrate Application objects from version 1.0 to 2.0

1. Highlight one or more 1.0x Application objects that you want to migrate.

2. Click Tools > Migrate Application Objects.

The area on the left lists the 1.0x Application objects you highlighted in Step 1. The area on the right lists what 
those Application objects are named after they are migrated to 2.0x.

3. Click Remove to remove the currently highlighted Application object from both lists.

4. Click Delete Old Application Object to delete the old Application object after it has been successfully migrated 
to 2.0X. This option is selected by default.

5. Click Migrate Associations to New Objects to maintain User object associations. For example, any users that 
were associated with the old 1.0x Application object is also associated with the new 2.0x Application object. 
This option is selected by default. 

NOTE: Use the Delete Old Application Object and Migrate Associations to New Objects with care. If you decide
to not delete the old Application object yet still associate the new one, the user sees two Application objects 
that are identical. If the user deletes the old Application object and you do not migrate the associations, all of 
the User, Group, Organization and Organizational Unit objects that were associated to the old Application 
object is lost. There is no way to restore these associations except by manually re-associating to the new 
Application object.

6. Use the Customize Object Modifier to specify the text to append on the name of the Application object.

NOTE: The Migrate feature adds "-20" to the end of the new Application object. This modifier is required 
because the new Application object cannot have the same name as the old Application object. This follows the 
NDS* convention that no two objects have the same name in the same Organization or Organizational Unit).
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Example of a Simple Application Distribution

A simple application distribution is one that does not require any modifications on the workstation (such as 
Registry, .INI, CONFIG.SYS and AUTOEXEC.BAT files, and other workstation configurations needed to support 
the application).

NOTE: If you are not sure whether the application you want to distribute is a simple or complex application, 
assume that it is complex.

The Situation
Suppose an IntranetWare* administrator of a company with 100 employees wants to distribute a calculator 
application to the employees who need it. The calculator application requires no special drive mappings, printer 
ports, environment variables, or user configuration files.

The administrator could install the application on each user’s hard disk drive. However, this is a time-intensive 
option, requiring the administrator to install, upgrade, and support the application and computer hardware at each 
user's location.

The administrator could also install the application on an IntranetWare server, making a Group object with the 
users who need access to the application and granting file system rights to the Group object in the directory where
the application is installed. Although the application is now available, no icon appears on the desktop, and Users 
are not aware of the application. The administrator must then communicate how to set up the application or 
physically visit each desktop to set it up.

Problem Summary

1. Even if the calculator icon did appear on users' workstations, the application resides on the network. If the user
is not logged in when the application icon is double-clicked, an error message comes up stating that the path is
invalid. Users might be confused by the error and require support.

2. The user might delete the icon, and then need help from the administrator to restore it.

3. The icon references the executable file (CALC1.EXE) in the \\PRODUCTS\SYS\APPS\CALC\V1.0 directory. To
move or rename the executable, or upgrade to version 2.0 without removing version 1.0, the path must be 
changed at each workstation.

Solution Using NAL
The administrator installs the application on the PRODUCTS server in the SYS\APPS\CALC\V1.0 directory, 
creates a CALC GROUP object, and adds to CALC GROUP users who need the application. Using NetWare* 
Administrator with the Novell* Application Launcher* 2.0 software ("NAL") installed, the administrator creates an 
Application object called CALC1. The CALC1 Application object contains the path to the program file and other 
information, such as command-line parameters, the working directory, and a description of what the application 
does. The administrator associates the CALC1 Application object with CALC GROUP. Using the NAL Window or 
NAL Explorer, the CALC1 application appears on each user's workstation. No setup is required at the user's 
workstation and all future changes to the program, icon, mappings, and so forth are made in the Application object 
residing in the Novell Directory Services* (NDS*) tree. The user can launch the application by double-clicking the 
icon.
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Example of a Complex Application Distribution

A complex application distribution is one that might require modifications on the workstation (such as Registry, .INI,
CONFIG.SYS and AUTOEXEC.BAT files, and other workstation configurations needed to support the application).

The Situation
Suppose an IntranetWare* administrator of a company with 1000 employees wants to distribute a word processing
application to all employees. The application requires special drive mappings, printer ports, environment variables,
and user configuration files. When installed to a workstation, the application's Setup program modifies the 
Windows** Registry, .INI files, and CONFIG.SYS and AUTOEXEC.BAT files.

The administrator could install the application on each user’s hard disk drive. However, this is a time-intensive 
option, requiring the administrator to install, upgrade, and support the application and computer hardware at each 
user's location.

The administrator could also install the word processing application on an IntranetWare server, making a Group 
object with the users who need access to the application and granting file system rights to the Group object in the 
directory where the application is installed. Although the application is now available, no icon appears on the 
desktop, and Users are not aware of the application. The administrator must then communicate how to set up the 
application or physically visit each desktop to set it up.

Problem Summary

1. Even if the calculator icon did appear on users' workstations, the application resides on the network. If the user
is not logged in when the application icon is double-clicked, an error message comes up stating that the path is
invalid. Users might be confused by the error and require support.

2. The user might delete the icon, and then need help from the administrator to restore it.

3. The icon references the executable file (WORD1.EXE) in the \\PRODUCTS\SYS\APPS\WORD\V1.0 directory. 
To move or rename the executable, or upgrade to version 2.0 without removing version 1.0, the path must be 
changed at each workstation.

4. Users run the risk of accidentally deleting important files on the workstation that are necessary to run the 
application. This might require administrator assistance to resolve.

Solution Using NAL
The administrator runs the Novell* Application Launcher* snAppShot component ("NAL" snAppShot) on a 
representative workstation, then installs the word processing application on that workstation. NAL snAppShot 
records all the changes the application's Setup program makes to the workstation and stores this information in an
Application Object Template (.AOT) file. Using NetWare* Administrator with the NAL installed, the administrator 
creates an Application object, importing the .AOT file information as a point of reference. The new word processing
Application object (called WORD1) is now configured to support the application, including source (network) and 
target (workstation) application directories.

The administrator associates the WORD1 application object with all the User, Group, Organization, or 
Organizational Unit objects necessary to distribute the application to the employees. The administrator configures 
User or Organizational Unit object's login script so that NAL Window or NAL Explorer software runs on 
workstations. The WORD1 application then appears on each user's workstation. No setup is required at the user's 
workstation and all future changes to the program, icon, mappings, and so forth are made by you using NetWare 
Administrator in the Novell Directory Services* (NDS*) tree. The user can launch the application by double-clicking
the icon.

 * Novell trademark.    ** Third-party trademark.    For more information, see Trademarks.



Renaming System Folders with Full or Descriptive Names

In the Novell* Application Launcher* Window ("NAL" Window) or NAL Explorer, users access the applications that 
you assign them through System folders. The System folder names are based on the names of the objects to 
which you have associated Application objects in the Novell Directory Services* (NDS*) tree.

For example, suppose you associate the APP1 application object with the ORGANIZATION.ORGANIZATIONAL 
UNIT.GROUP object. Because the name of this associative object might be obscure to users, you can clarify its 
meaning by replacing the NDS object name with a full or descriptive name that is more suited to the object and is 
more recognizable by your users.

NOTE: As users cannot read the full or descriptive name attributes by default, you must explicitly grant them these
rights.These names are read once at start up time and are not updated until after NAL Window or NAL Explorer 
restarts.

To create a descriptive name for a System folder

1. Right-click the User, Group, Organization, or Organizational Unit object to which Application objects are 
associated.

2. Click Details.

3. From the Identification property page, type the descriptive name in the Full Name field (for User objects) or 
Description field (for Group, Organization, or Organizational Unit objects).

NOTE: If you are creating a descriptive name for a User object, edit the Full Name field. If you are creating a 
descriptive name for a Group, Organization, or Organizational Unit object, edit the Description field. If this field 
contains text, the text is used for the descriptive name. If this field is empty, the descriptive name that 
corresponds to the location in the NDS tree is used.
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Rolling Back or Reversing an Application Distribution

When you "roll out" or distribute a complex application using Novell* Application Launcher* 2.0 software ("NAL"), 
changes are made to the targeted workstation. These changes might include text files (such as CONFIG.SYS and 
AUTOEXEC.BAT), Windows** Registry entries, and .INI files. In addition, application files can be copied or deleted
at the target workstation.

If NAL encounters an error during the distribution process, it attempts to "roll back" or reverse all the changes 
made before the error and reset the workstation to the state it was in before the distribution began.

The method NAL uses to roll back changes is simple. First, it creates temporary files and directories to store files 
and other rollback information. If the distribution is successful, those files and directories are deleted. If the 
distribution encounters an error, NAL uses the rollback information to restore the workstation to its original state, 
and then the rollback information is deleted.

NOTE: Currently, NAL cannot roll back changes at a later time, only at the time a distribution error is detected.

In What Order Does NAL Distribute Applications?
Distribution happens in the following order: 

1. Application file copies or deletions

2. Text file modifications 

3. Registry modifications

4. .INI file modifications

What Happens as Applications Are Distributed?
When NAL successfully completes each phase of the distribution, it keeps a record for each distribution phase. If 
an error is encountered, NAL then knows what to do in order to reverse the changes.

For example, suppose that the application files and text file modification phases of the distribution are performed 
successfully. However, NAL encounters an error during the Windows Registry modification phase. This triggers the
Registry module to roll back all its own modifications and also send a message to NAL that an error occurred 
during the distribution process. NAL then uses the previous memory record information to roll back the text file 
modifications and the application file changes. Regardless of success or failure, all rollback information is deleted 
after processing.
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Installing and Running NAL Window

The Novell* Application Launcher* Window ("NAL" Window) is software that runs on users'    workstations and 
displays the applications that you distribute to them using the NAL Snap-In component. Using a User, 
Organization, or Organizational Unit object's Launcher Configuration property page, you can specify to what extent
users can control the options in NAL Window. For example, you can allow or not allow them to create personal 
folders (in which to store the applications you assign to them), refresh icons, or exit NAL Window.

In addition to following the steps below, you also need to enable the App Launcher option on a User, Group, 
Organization, or Organizational Unit object's Applications property page so users can see applications in NAL 
Window. This option is turned on by default.

NOTE: We recommend using NAL Window (NAL.EXE) for workstations running Windows** 3.x. For Windows 95**
and Windows NT** workstations, use NAL Explorer. Do not run NAL Explorer on Windows 3.x workstations.

You can also use NAL Window as a shell program. Click Replacing Program Manager or Explorer with NAL 
Window or NAL Explorer for more information.

To make it possible for users to run NAL Window on their workstations

1. Ensure that NAL.EXE is in a network directory (such as SYS:\PUBLIC) where users have rights and access.

2. Add the following command to the User, Organization, or Organizational Unit object's login script:

#NAL.EXE

The NAL.EXE wrapper runs NAL Window on users' workstations.
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Installing and Running NAL Explorer

The Novell* Application Launcher* Explorer ("NAL" Explorer) is software that runs on users' Windows** 95** or 
Windows NT** 4.0 workstations and displays the applications that you distribute to them using the NAL Snap-In. 
Using a User, Organization, or Organizational Unit object's Launcher Configuration property page, you specify to 
what degree users control the options in NAL Explorer.

NAL Explorer displays application icons in a special NAL Explorer window, Windows Explorer, Start menu, System
Tray, or Desktop. Use the User, Group, Organization, or Organizational Unit object's Applications property page to 
set up the different NAL Explorer access points.

The NALEXPLD.EXE file (installed by default to SYS:\PUBLIC) copies the 
necessary files to the workstation, sets the necessary registry keys, and runs NAL Explorer on users' workstations.
Therefore, running the NAL Explorer is a matter of adding the appropriate command to a User or Organizational 
Unit object's login script.

IMPORTANT: NAL Explorer is a 32-bit application and should not be run under Windows 3.1x or DOS.

To make it possible for users to run the NAL Explorer on their workstations

1. Ensure that NALEXPLD.EXE is in a network directory (such as SYS:\PUBLIC) where users have rights and 
access.

2. Add the following command to the User or Organizational Unit object's login script:

IF OS = "WIN95" THEN
 @\\SERVERNAME\SYS\PUBLIC\NALEXPLD.EXE /S

END
IF OS = "WINNT" THEN

IF OS_VERSION = "V4.00" THEN
  @\\SERVERNAME\SYS\PUBLIC\NALEXPLD.EXE /S

END
END
NOTE: When NAL Explorer starts on the workstation, it displays a message about checking .DLL files. To hide 
this message every time NAL Explorer starts, use the /S startup option in the command-line.

To unload the NAL Explorer

1. Change the /S startup option to a /U in the User or Organizational Unit object's login script. For example:

IF OS = "WIN95" THEN
 @\\SERVERNAME\SYS\PUBLIC\NALEXPLD.EXE /U

END
IF OS = "WINNT" THEN

IF OS_VERSION = "V4.00" THEN
  @\\SERVERNAME\SYS\PUBLIC\NALEXPLD.EXE /U

END
END

Running NAL Explorer on Windows NT 4.0 Workstations
If you are not logged in as the workstation administrator in Windows NT 4.0, NAL Explorer might not load correctly.
If you have a policy that restricts approved shell extensions, you need to use the NALEXP32.ADM file in the 
WinNT directory and Novell Workstation Manager to distribute a policy that adds the product as an approved shell 
extension. You can download Novell Workstation Manager from the Novell Product Support web site at

http://support.novell.com/home/pubbeta

Because Novell Workstation Manager integrates with the Windows NT Client, by extension you install a newer 
version of Windows NT Client when you install Novell Workstation Manager. The Novell Workstation Manager 
Snap-in lets you create Windows NT configuration objects. The location of the NALEXP32.ADM file is stored in the
policy section of a Windows NT configuration object in the NDS* tree. You associate this object to a group of 
Windows NT users that receives the policy changes at login time. NALEXPLD.EXE is then run from the login script
and NAL Explorer runs on the Windows NT workstation.
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Replacing Program Manager or Explorer with NAL Window

By replacing Windows** Program Manager or Explorer with Novell* Application Launcher* Window ("NAL" 
Window), you can restrict users' access to programs.

For example, suppose you are the administrator at a school. Your responsibility is to ensure that students have 
access to applications without letting them change settings on workstations or run different programs. Resourceful 
students might circumvent the restriction of running only NAL applications. We recommend that you use additional 
methods to create the desired restrictions.

The following steps explain how to set up NAL Windows as the shell on workstations running Windows 3.x running
VLM software or Client 32* software, Windows 95** running Client 32, or Windows NT** running Client 32.

NOTE: You can create an Application object that replaces Program Manager or Explorer with NAL Window. To do 
so, record the following changes you make to the workstation using    NAL snAppShot. Then, create an Application 
object based on the .AOT file that is generated.

To run NAL Window as the shell in Windows 3.x with VLM* software

1. Copy the following files (found in the Z:\PUBLIC\NALLIB directory by default) to the WINDOWS\SYSTEM 
directory.

CALWIN16.DLL
NETWIN16.DLL
LOCWIN16.DLL
CLXWIN16.DLL
CLNWIN16.DLL
NCPWIN16.DLL

2. Copy the following files (found in Z:\PUBLIC or subdirectories thereof by default) to the following locations on 
the local drive:

NALW31.EXE C:\NOVELL\NAL
NALRES.DLL C:\NOVELL\NAL\NLS\ENGLISH
NALBMP.DLL C:\NOVELL\NAL\NLS\ENGLISH
NAL.HLP              C:\NOVELL\NAL\NLS\ENGLISH
NWAPP16.DLL C:\WINDOWS\SYSTEM
NALCPY16.EXE C:\WINDOWS

3.      Locate the Windows SYSTEM.INI file and open in a text editor.

4. Find the line in the [boot] section that starts with SHELL= (for example, SHELL=PROGMAN.EXE).

5. Replace the current setting with SHELL=C:\NOVELL\NAL\NALW31.EXE (assuming you copied the NAL 
Window files in C:\NOVELL\NAL).

6. Save the changes to SYSTEM.INI and restart Windows.

To run NAL Window as the shell in Windows 3.1 with Client 32

1.      Copy the following files (found in Z:\PUBLIC or subdirectories thereof by default) to the following locations on 
the local drive:

NALW31.EXE C:\NOVELL\CLIENT32
NALRES.DLL C:\NOVELL\CLIENT32\NLS\ENGLISH
NALBMP.DLL C:\NOVELL\CLIENT32\NLS\ENGLISH
NAL.HLP              C:\NOVELL\CLIENT32\NLS\ENGLISH
NWAPP16.DLL C:\WINDOWS\SYSTEM
NALCPY16.EXE C:\WINDOWS

2.      Locate the Windows SYSTEM.INI file and open in a text editor.

3. Find the line in the [boot] section that starts with SHELL= (for example, SHELL=PROGMAN.EXE).

4. Replace the current setting with SHELL=C:\NOVELL\CLIENT32\NALW31.EXE (assuming you copied the NAL 
Window files in C:\NOVELL\CLIENT32).

5. Save the changes to SYSTEM.INI and restart Windows.



To run NAL Window as the shell in Windows 95 with Client 32

1.      Copy the following files (found in Z:\PUBLIC or subdirectories thereof by default) to the following directory on 
the local drive:

NALWIN32.EXE C:\NOVELL\CLIENT32
NALRES32.DLL C:\NOVELL\CLIENT32\NLS\ENGLISH
NALBMP32.DLL C:\NOVELL\CLIENT32\NLS\ENGLISH
NAL.HLP                        C:\NOVELL\CLIENT32\NLS\ENGLISH
NAL.CNT                      C:\NOVELL\CLIENT32\NLS\ENGLISH
NWAPP32.DLL C:\NOVELL\CLIENT32

2.      Locate the Windows SYSTEM.INI file and open in a text editor.

3. Find the line in the [boot] section that starts with SHELL= (for example, SHELL=EXPLORER.EXE).

4. Replace the current setting with SHELL=C:\NOVELL\CLIENT32\NALWIN32.EXE (assuming you copied the 
NAL Window files in C:\NOVELL\CLIENT32).

5. Save the changes to SYSTEM.INI and restart Windows.

To run NAL Window as the shell in Windows NT 4.0

1. Copy the following files (found in Z:\PUBLIC or subdirectories thereof by default) to this directory on the local 
drive:

NALWIN32.EXE C:\WINNT\SYSTEM32
NALRES32.DLL C:\WINNT\SYSTEM32\NLS\ENGLISH
NALBMP32.DLL C:\WINNT\SYSTEM32\NLS\ENGLISH
NAL.HLP                      C:\WINNT\SYSTEM32\NLS\ENGLISH
NAL.CNT                      C:\WINNT\SYSTEM32\NLS\ENGLISH
NWAPP32.DLL C:\WINNT\SYSTEM32

2.      Run REGEDIT.EXE and locate the following Registry setting:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

3. Replace the SHELL=EXPLORER.EXE with SHELL=C:\WINNT\SYSTEM32\NALWIN32.EXE (assuming you 
placed the NAL Window files in C:\WINNT\SYSTEM32).

4. Exit the Registry editor and restart Windows.

NOTE: Use caution when changing this Registry setting because without the Explorer program in Windows NT 
it is harder to access system programs. We recommend creating an Application object to EXPLORER.EXE 
program for recovery purposes.
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Storing Personal Folder Information in User Objects

As the administrator, you set up System folders for storing and accessing the applications you make available to 
your users. You do this by associating Application objects with User, Group, Organization or Organizational Unit 
objects. The Description names of Group, Organization, and Organizational Unit objects and the Full name of User
objects become the System folder names. If there are no Description or Full names defined, then System folders 
use the NDS* object names.

You can let your users store personal folders in their User object so that when they log in to any workstation they 
can access their personal folders. To do this, you need to have the NetWare* Registration Database that ships 
with IntranetWare* 4.11 software.

Click Renaming System Folders with Descriptive Names for more information.

To store personal folder information in a User object

1. Make sure that your search path contains the location where NetWare Administrator files are stored.

2. Grant rights in the NetWare Registration Database to all users who are storing personal folder information in 
their User object. You need to grant rights to both NRD: Registry Data and NRD: Registry Index.

NOTE: Usually, Users' personal folders and contents are saved when the User exits the NAL Window. 
However, if you save folder information in the Novell* Network Registry* database and Users change their 
Novell Directory Services* (NDS*) tree connections while running the NAL Window, the personal folders and 
contents might be lost. To avoid this, your Users can save the NAL Window settings by holding down the Shift 
key while choosing File > Exit.
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About the NDS Schema

Novell* Application Launcher* 2.0 software ("NAL") introduces a new type of object to Novell Directory Services* 
(NDS*) trees called an Application object. Because your version of NDS likely does not recognize this kind of 
object, NAL must enhance or extend the schema so that the new object type is supported.

The schema is a definition of the types of information stored in the NDS database. This information dictates the 
requirements, limits, and relationships of objects that can be created and found in NDS.

A schema extension needs to occur on each NDS tree that you are using to create Application objects. The 
process of schema extension does not affect other objects or NDS settings and is essentially transparent to you. If
you have write privileges to the root of the tree and the schema has not been modified on that tree, you are 
prompted to modify the tree's schema either when you run the Setup program or when you run NetWare* 
Administrator.

NOTE: If you are logged in to two or more trees, your configuration setting is from the preferred tree. To see which 
tree is the preferred tree in Windows** 3.1, use NetWare User Tools and click the NetWare Connections icon. The 
connection with an asterisk is the preferred tree. To see the preferred tree in Windows 95**, right-click the Network
Neighborhood and click the NetWare Connections icon. The connection with an asterisk is the preferred tree. To 
change the preferred tree, click the tree and select Set Current. NAL supports Directory Map objects, as well as 
aliases to them in the path statement, working directory, and drive mapping strings.

To confirm that the NDS tree supports Application objects

1. Right-click an Organization or Organizational Unit object.

2. Choose Create.

3. Look for the "Application" object type in the list.

If the Application object class is not listed, you might need to reinstall NAL. Be sure you are logged in and have
rights to the [Root] of the NDS tree on which you create Application objects.
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Identifying the Application Object

Use the Identification property page to identify an Application object for distribution.

To identify the application object

1. Right-click the Application object and click Details.

2. Click the Identification button.

3. Change the following Identification properties as needed, and then click OK.

Application Icon Title
The text you type here appears as the caption beneath the application icon in the Novell* Application Launcher* 
Window ("NAL" Window) or NAL Explorer software. The application icon title, which is mandatory, can be different 
than the Application object name (that is, the name that Novell* Directory Services* (NDS*) software uses to 
identify the application) and might contain periods and other special characters. Use the Description property page
for longer descriptions of the application.

Path to Executable File
The path you specify here is to the executable that is run when an Application object icon is double-clicked in the 
NAL Window or NAL Explorer. You can type in the path as a UNC path or a file directory path. Use the Browse 
button to browse the file directory structure to find the executable you want. Refer to the following example syntax 
when mapping a drive:

SERVER\VOLUME:PATH
\\SERVER\VOLUME\PATH
VOLUME_OBJECT_NAME:PATH
DIRECTORY_MAP_OBJECT_NAME:PATH
DRIVELETTER:\PATH

NOTE: If you don't want to run an application (for example, this Application object's purpose might be to just 
update some files on the workstation), use the Install Only option and do not specify a path.

Install Only (No Executable Needed)
Use this option if there isn't an application to run. For example, this Application object's purpose might be to just 
update some files on the workstation. When you select the Install Only option, the software is installed but not run.

Prompt User for Reboot
Using the options in this group box, you can select how a workstation reboot should occur.

If you select Auto Detect (the default setting), and if the NAL Window or NAL Explorer needs to make changes that
cannot occur while Windows** is running (such as replacing open DLLs), it prompts for a reboot.

The Always option prompts the user to reboot every time a distribution takes place.

The Never option does not prompt the user to reboot. In this case, the changes take effect the next time the 
workstation reboots.

Run Once
When an Application object's purpose is to install software to a workstation, it can be confusing to users if the icon 
remains on their workstations after the software has been installed. Use the Run Once option if you want the 
application to run just once and then have its icon disappear so as to not cause confusion.

There are a variety of ways to use Run Once in combination with other object properties. For example, if the 
application is specified as a Force Run on the Applications property page (meaning that the user is not involved, 
the application runs when Windows starts), the application is forced to run one time.

If you selected Run Once and also specified a Version Stamp for this application, the application runs once until 
the next time you change the Version Stamp, whereupon the application runs once one more time.    This latter 
method is useful for upgrading applications.

Distribute Always
This option forces a distribution every time the user runs the application or the application is set for a force run on 



the workstation (using the Applications property page). This option is useful to ensure that certain Registry settings
are present, or that settings are updated every time a user runs an application.

Change Icon 
This option lets you assign an icon to an Application object. The icon you choose appears in the NAL Window or 
NAL Explorer, depending on what you have specified on the Applications property page. If you do not specify an 
icon, a default NAL icon is used.

NOTE: If icon titles do not appear in their entirety, you might need to increase your icon spacing. Do this using 
Windows. After you have adjusted the icon spacing in Windows, exit the NAL Window or NAL Explorer and restart 
for the changes to take effect. You can also use the Description property page for longer descriptions of the 
application.

Version Stamp
The Version Stamp option is simply a text string representing the version of the application. The Version Stamp 
might or might not have anything to do with the actual version of the software; it is simply a tool to help you 
upgrade applications.

For example, suppose you created an application and gave it a version stamp of "4.0." You distribute this 
application and your users run it. Then you realize that you need to change several settings to the application, 
either as a result of reimporting an Application Object Template (.AOT) file or manually changing settings on the 
Registry, .INI Files, Macro, Text Files or Icons/Shortcut property pages. By changing the Version Stamp text to 
something such as "4.1," the changes go into effect the next time the application is run.

If the Run Once option is checked and you change the Version Stamp, the Run Once option causes the 
application to run again once. This is useful when upgrading application software to a new or different version. For 
example, suppose you purchased new application software and want to update an Application object. By changing
the Version Stamp number and selecting the Run Once option, the application runs once after installation even 
though a previous version might have already run once.

GUID (Globally Unique Identification)
NAL uses the GUID to stamp the Windows Registry when tracking information about Application objects. This 
information is displayed for your information only.
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Setting Up the Application Object's Environment

Use the Environment property page to identify the environment that might be required for an Application object.

Some applications require custom configuration parameters to function properly. Before launching the application, 
the Novell* Application Launcher* Window ("NAL" Window) or NAL Explorer software configures the workstation to
properly run the application. The parameters, directories, mappings, and printer ports associated with the 
application automatically execute (mappings and captures don't actually happen until the user launches the 
application). After exiting the application, the application's post-termination script removes any drive mappings or 
port captures it created during execution.

To set up the application's environment

1. Right-click the Application object and click Details.

2. Click the Environment button.

3. Change the following Environment properties as needed, and then click OK.

Command-Line Parameters
Some applications require application-specific parameters to run in a desired mode or view. You can place one or 
more parameters here. See your application's documentation for more information about the types of parameters 
that you can use. You can also run macros that you specify on the Macro and Variable Examples.

Working Directory
This option can be designated for any Application object and might be required by some applications (your 
application's documentation describes the working directories it needs). You can look for the working directory by 
using the Browse button to the right of the Working Directory field.

Run 
This group box sets the application's initial window size. Choose whether you want to run the application in 
Normal, Minimized, or Maximized mode.

Windows NT
If you are setting up a 16-bit application to run on Windows NT**, you need to specify either a shared or separate 
"Windows on Windows" (WOW) session.

To run on Windows NT (a 32-bit operating system), 16-bit applications must run in a Virtual DOS Machine (VDM) 
that emulates Windows** 3.1 functionality. The 16-bit Windows emulator called WOW (for Win16-on-Win32) 
isolates 16-bit application errors from the rest of the 32-bit operating system.

16-bit Windows applications can run in their own separate WOW sessions or they can share a WOW session with 
other 16-bit applications. Sharing a WOW session saves memory and allows applications to use DDE or OLE to 
communicate with other applications in the same WOW session. Running an application in its own separate WOW
session allows for more robust operation because the application is isolated from other 16-bit applications. 
Because some applications do not run properly in a separate WOW session, the default option is to run the 16-bit 
Windows application in a shared WOW session.

Enable Error Logging to File
Specify the path to a file where any errors are logged if the application fails to install or launch. No status is 
tracked here except for errors. Users running this Application object must be given rights to write to this file for this 
option to work correctly.

Clean Up Network Resources 
The process of "cleaning up" means that the license for a particular network connection is removed. This prevents 
users from using a network connection when they don't need it.

If the Clean Up Network Resources option is selected, drive mappings and printer ports associated with the 
applications launched by the NAL Window or NAL Explorer software are cleaned up. If this check box is not 
selected, drive mappings and printer ports established earlier remain in effect.

NOTE: If the resource (a connection, map, or capture) is already in use when NAL Window or NAL Explorer is 
started, NAL Window or NAL Explorer uses it and does not clean it up. Otherwise, the resource is created and 



cleaned up when all other NAL Window or NAL Explorer applications are finished using it. The connection to the 
server containing the resource is removed as well. If the applications that NAL Window or NAL Explorer launched 
are still running when NAL Window or NAL Explorer is terminated, the allocated resources remain intact.

Monitor Module Name
When an application is launched, NAL Window or NAL Explorer monitors the executable of the application. When 
the executable terminates, the process of cleaning up network resources begins.

However, it's possible that the executable filename is actually a "wrapper" that sets up environments, runs other 
executables, and then terminates. If NAL Window or NAL Explorer monitors the wrapper executable, it might 
prematurely start cleaning up network resources before the application has terminated.

Consult your application documentation about whether the application uses a wrapper executable. If it does, find 
out the name of the module that remains running. Type this name (without the extension) in the text box provided.
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Setting Up Drives and Ports

Because the applications that users see in the Novell* Application Launcher* Window ("NAL" Window) or NAL 
Explorer are linked directly to Application objects, users do not need drive mappings established through their 
login scripts.

However, each Application object can map additional drives and capture printers as needed. Use the settings on 
the Drives/Ports property page to set up drive mappings and port captures for printers for an application. Such 
drive mappings and port captures are set up before the NAL Window or NAL Explorer software executes the 
application. If the Clean Up Network Resources option is selected on the Environment property page, the drive 
mappings and port captures that NAL Window or NAL Explorer creates are released when the user exits all 
applications that use the resources.

For example, suppose you are configuring a word processing application that requires a specific mapped drive. 
This application is installed and run from the same drive letter. You choose to map drive W for this application and 
specify W:\APPS\WORD1\WORD1.EXE in the Path to Executable File text box on the Identification property page.
Then, in the Drives/Ports property page, you map drive W: to the server where the application exists. When NAL 
Window or NAL Explorer runs the application, it checks for a mapping of drive W:.    If W: is mapped to the correct 
volume and server, the drive is used. If W: is mapped to some other server or volume, it is not used, and the 
application does not run. If W: is not mapped at all, NAL Window or NAL Explorer maps it. Only in the case where 
NAL Window or NAL Explorer actually maps the drive does it clean up the mapping after the application 
terminates. If several applications use the same drive mapping, then drive mappings aren't cleaned up until the 
last application terminates. See Clean Up Network Resources for more information.

NOTE: The path to executable files, drive mappings, and port captures are stored as strings and not as Novell* 
Directory Services* (NDS*) object names. Therefore, if a subtree is moved, some Application objects might still 
point to the previous, but now invalid, objects.

To change an application's drives and ports

1. Right-click the Application object and click Details.

2. Click the Drives/Ports button.

3. Change the following Drives/Ports properties as needed, and then click OK.

Root
Select this option if you want to treat the path as the root of the drive. For example, if SERVER\VOLUME:DIR1\
DIR2 is the path, the user or application cannot change to a directory that is higher than DIR2. In essence, DIR2 is
the root of the drive. 

Option
Use this option to select the type of drive to map. For example, select S1 to map the path as a search drive. If the 
search drive already exists, it is inserted. Select S16 to map the path as the last search drive. Select Drive to map 
the drive you select using the Drive option.

Drive
Use this option to assign a regular NetWare* drive (next, and A: through Z: are available).

Path
Use this option to map a path.    Click the Browse button, and then use the options to traverse the NDS tree and 
select the directory you want to map.

Example syntax for mapping a drive
SERVER\VOLUME:PATH
\\SERVER\VOLUME\PATH
VOLUME_OBJECT_NAME:PATH
DIRECTORY_MAP_OBJECT_NAME:PATH
DRIVELETTER:\PATH

Port
Use this option to assign the workstation’s printer port to the Application object. Select from nine different ports. 
Your workstation operating system might need to be configured to recognize the port number if it is larger than 3. 



See your operating system documentation for more information.

Printer or Queue
Click the Browse button and then select the InternetWare* queue to which you want to send the application’s print 
jobs. Application objects can access any printers that are available in the system.

Capture Flags
Set the capture options to use when the application is launched by using the Set button. Select Notify, Banner, or 
Form Feed. These options override existing capture settings. Click Setting Up Capture Flags for more information.

Example syntax for capturing a port
SERVER\DS_QUEUE_NAME:
\\SERVER\DS_QUEUE_NAME
DS_QUEUE_NAME
\\\DS_QUEUE_NAME 
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Setting Up Capture Flags

Use the Set Capture Flags dialog box to set the port capture flags of an Application object.

To set capture flags for an Application object

1. Right-click the Application object and click Details.

2. Click the Drives/Ports button.

3. Choose a port and assign it an LPT port and a queue.

4. Click Set.

5. In the Set Capture Flags dialog box, select the Override workstation setting column for the corresponding 
Capture setting you want to override. After you do this, the corresponding Capture setting becomes active.
For example, if you select the Override workstation setting flag for Notify and also select the Capture setting 
check box for Notify, when the user prints a document using that Application object, IntranetWare* software 
displays a Notify alert panel to indicate the completion of the print job, no matter which Capture settings are on 
the user's workstation.
However, if you select the Override workstation setting flag for Notify but do not select the Capture setting 
check box for Notify, when the user prints a document using that Application object, IntranetWare does not 
display a Notify alert panel to indicate the completion of the print job, no matter which Capture settings are on 
the user's workstation.
NOTE: The default capture flags of an Application object are those of the user's workstation.

Override Workstation Setting Options

Notify 
This option overrides the Notify capture flag using the corresponding Capture setting. When selected, the 
Notify capture flag becomes active.

Banner
This option overrides the Banner capture flag using the corresponding Capture setting. When selected, the 
Banner capture flag becomes active.

Form Feed 
This option overrides the Form Feed capture flag using the corresponding Capture setting. When selected, the
Form Feed capture flag becomes active.

Capture Setting Options

Notify
This option toggles the Notify capture flag.

Banner
This option toggles the Banner capture flag.

Form Feed
This option toggles the Form Feed capture flag.
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Describing Applications to Users

Use the Description property page to give your users more complete information than the application icon caption 
allows. Users can right-click an Application object in the Novell* Application Launcher* Window ("NAL" Window) or 
NAL Explorer to see details containing both the descriptive name of the application and the more lengthy 
description that you provide using the Description property page.

For example, suppose you are creating an Application object that installs a word processor to the user’s 
workstation. The description you type, which is longer than the icon's title can contain, might include a description 
and any special instructions you'd like your users to see.

To describe the application to users

1. Right-click the Application object and click Details.

2. Click the Description button.

3. Write a description as needed, and then click OK.
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Setting Up Application Fault Tolerance and Load Balancing

Use the Fault Tolerance property page to make sure your users can access the applications they need even if the 
server containing those applications becomes inaccessible.

Application objects are set up to be accessed from a specific server. If that server is inaccessible, you can set up 
alternative servers from which the application can be accessed. By doing this, you keep the applications running 
with no disruptions in availability to your users. You can use two methods for setting up alternative servers.

Load Balancing lets the Novell* Application Launcher* Window ("NAL" Window) or NAL Explorer software spread 
the user load across multiple Application objects. Ordinarily, you use load balancing when all the servers the 
Application objects use are located in a single site on a local area network. If a particular server goes down, 
rendering that Application object inoperable, the Application object is removed from the list of available 
applications, the list is re-randomized and a server is re-selected.

Fault Tolerance lets the NAL Window or NAL Explorer search the specified servers in the order in which you have 
set them up. If the first server specified is too busy or is not available, NAL Window or NAL Explorer tries each 
server in the order listed until it comes to a server that is available; it accesses the application from that server. 
Ordinarily, you use fault tolerance when the servers are located at various sites throughout a wide area network. 
However, the servers that you are using for fault tolerance must reside in the same NDS* tree.

You can set up your applications to take advantage of both load balancing and fault tolerance. If you do so, NAL 
Window or NAL Explorer first attempts to locate an available server among those designated for load balancing.    
If none of those are available, NAL Window or NAL Explorer then goes in order through the servers listed for fault 
tolerance.

To set up load balancing

1. Right-click the Application object and click Details.

2. Click the Fault Tolerance button.

3. Select the Enable Load Balance check box.

4. Click the Add button (below the Load Balancing text box).
After the Select Object window is displayed, find the next application to launch by using the browser in the 
panel on the right. The applications are contained in the object you created for them. Your current context is 
shown above the browser text box. To change your current context, click the Change Context button below the 
browser text box.
The application now appears in the Load Balancing text box.

To set up fault tolerance

1. Right-click the Application object and click Details.

2. Click the Fault Tolerance button.

3. Select the Enable Fault Tolerance check box.

4. Click the Add button.
After the Select Object window is displayed, find the next application to launch by using the browser in the 
panel on the right. The applications are contained in the object you created for them. Your current context is 
shown above the browser panel. To change your current context, click the Change Context button located 
below the browser text box.
The application now appears in the Fault Tolerance text box.

To delete an application from the Load Balancing or Fault Tolerance lists

1. Right-click the Application object and click Details.

2. Click    the Fault Tolerance button.

3. Select the load balanced--or fault tolerant--enabled application that you want to remove from the list, and then 
click the Delete button.



4. Click OK to save changes.
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Creating Application Scripts

Use the Scripts property page to set up scripts that are executed automatically each time the application is 
launched and closed. Unlike environment parameters, the setup and post-termination scripts can overwrite 
existing drive mappings and printer ports. Startup scripts are executed after the environment is set and before the 
application is launched. Post-termination scripts are executed after the application is closed and before the 
network resources are cleaned up. The Scripts property page uses the same syntax as an IntranetWare* Login 
script. Refer to your IntranetWare documentation for more syntax descriptions and examples.

Examples of what you can do with application scripts
Provide extra mappings beyond those defined on the Drive/Ports property page.
Provide a mapping to override another mapping.
Run other applications.
Log in to other servers or NDS* trees.
Terminate applications under certain circumstances.

To manage application scripts

1. Right-click the Application object and click Details.

2. Click the Scripts button.

3. Type the appropriate commands in either the Run Before Launching or Run After Termination text boxes.
Commands for cleaning up the changes made by the pre-launch script should be placed in the post-termination
script. The post-termination script is run after Novell* Application Launcher* 2.0 software ("NAL") detects that 
the application has terminated. Both scripts follow the login script language syntax and all login script variables 
are allowed (that is, %FULL_NAME, %LOGIN_NAME, <PATH>, and so forth).

Example of two ways to run an application in a script

#calc.exe Run the Calculator application, 
pausing the script processing until 
Calculator returns control.

@calc.exe Run the Calculator application 
concurrently with the remainder of 
the script processing.

NAL scripting does not do the following:

Output anything to the screen
Display errors
Pause

Scripting Commands That Do Not Work with NAL:

CLS
DISPLAY
FDISPLAY
INCLUDE
LASTLOGINTIME
MACHINE=
PAUSE
WRITE
EXIT
NO_DEFAULT
NOSWAP
PCCOMPATIBLE
SCRIPT_SERVER
SET_TIME
SWAP
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Identifying Application Contacts

Use the Contacts property page to add, delete, and list the users who are resources or support contacts for 
specific Application objects. This information is displayed in the properties of each application icon on the user’s 
workstation through the Novell* Application Launcher* Window ("NAL" Window) or NAL Explorer.

The Help information can be tailored so users are directed to the support group at their locations. Designating a 
user support contact helps channel problems to knowledgeable people and alieviate your workload.

A user can find out who is assigned to what application by choosing File > Properties and clicking the Contacts tab
from the NAL Window or NAL Explorer. The user can contact the assigned contact in person, by phone, or by 
using the NAL Window or NAL Explorer to send a e-mail.

To choose or delete a user as a contact

1. Right-click the Application object and click Details.

2. Click the Contacts button.

3. Click Add, choose one or more users from the browser, and then click OK.

Or, to delete a user a contact,

Highlight a user, click Delete to remove the user's designation as a support contact, and then click OK.
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Associating an Application with User, Group, Organizational, or Organizational Unit 
Objects

Use the Associations property page to grant multiple Users, Groups, Organizations, or Organizational Units the 
right to see and use the Application object. If you do not associate applications with these objects, they are not 
available to users in the Novell* Application Launcher* Window ("NAL" Window) or NAL Explorer.

When the association is complete, the object and application contain information about each other. The User, 
Group, Organization, or Organizational Unit object shows which applications it can use, and the application shows 
what other objects can access it. Only direct associations appear. For example, if a user is a member of a Group 
and the Group is associated with an application, viewing the User object does not show the application association
and viewing the application does not show the User association. However, the Group object shows both the User 
and the application associations.

NOTE: Using the Applications property page you can assign User, Group, Organization, or Organizational Unit 
objects to multiple Application objects. For example, if you create several Application objects, you can use the 
Applications property page for a given User object to assign those applications to the User. Furthermore, you can 
specify how applications are displayed on the workstation (that is, through the NAL Window, NAL Explorer, 
Windows Explorer, Start menu, Desktop, and System Tray).

To associate an Application object with User, Group, Organziation, or Organizational Unit objects

1. Right-click the Application object and click Details.

2. Click the Associations button.

3. Click Add, browse and select a User, Group, Organization, or Organizational Unit object, and then click OK.

Or, to remove an association,

Highlight a User, Group, Organization, or Organizational Unit object in the list, and then choose Delete.

NOTE: All applications are displayed in the NAL Window by default. However, using the Applications property 
page, you can expand a user's access to include the NAL Explorer, Windows Explorer, Start menu, Desktop, and 
System Tray (if your users are running the NAL Explorer software for Windows 95** or Windows NT**).
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Writing Application Administrator Notes

Use the Administrator Notes property page to create a section of notes that only you, as the administrator, can 
view and edit.

For example, you might want to remind yourself about some special settings for a particular application. Or, if your 
system is managed by several administrators, you could use the Administrator Notes property page to provide a 
history of application upgrades and file changes.

To write administrator notes for an application

1. Right-click the Application object and click Details.

2. Click the Administrator Notes button.

3. In the space provided, type the note, and then click OK.
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Changing the Windows Registry When the Application Runs

Think of the Registry Settings property page as a working model of the actual Windows** Registry, which lists 
settings and values required to run applications. From the Registry Settings property page you can add, modify, 
and delete and import Registry keys, names, and values as if you were working with the actual Windows Registry. 
You can then specify which of these settings are created or removed in the Windows Registry when the 
application is run.

The easiest way to use the Registry property page is to run the Novell* Application Launcher* snAppShot 
component ("NAL" snAppShot) first. NAL snAppShot compares the configuration settings on a representative 
workstation before and after you install an application on it. These differences are recorded in an Application 
Object Template (.AOT) file. If changes are made to the Windows Registry files during the installation, the changes
are imported to the Registry property page when you create the Application object. Giving you a point of reference,
the .AOT file method takes the guesswork out of knowing which files and settings are required to run an 
application. If you need to upgrade an application and there are new Registry changes, you import a new .AOT file
into the Registry property page.

To change the workstation Windows Registry the next time the application runs

1. Right-click the Application object and click Details.

2. Click the Registry Settings button.

3. Click Import, browse and highlight the Application Object Template (.AOT) file that you created with NAL 
snAppShot, and then click Open.

OR

Highlight a Registry template entry and click Modify to change its name.

OR

Click Add to create a new Registry file template entry.

OR

Highlight a Registry template entry and click Delete to remove it.

4. Browse and highlight an Organization or Organizational Unit in a Registry template entry tree, click Add, and 
then choose Text, Binary, DWORD, or Default. Use the appropriate syntax when creating the entry, and then 
click OK.

OR

Browse and highlight a value in a Registry template entry tree and click Modify to change the value's 
properties.

OR

Browse and highlight a value in a Registry template entry tree and click Delete to remove the value.

5. Browse and highlight a value in a Registry template entry tree, click Create, and then choose Create Always, 
Create If Does Not Exist, or Create If Exists.

OR

Browse and highlight a value in a Registry template entry tree and click Remove to remove the value.
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Creating or Changing .INI Files When the Application Runs

Use the .INI Files property page to create or change the .INI files on the target workstation when the application 
runs.

The easiest way to use the .INI Files property page is to run the Novell* Application Launcher* snAppShot 
component ("NAL" snAppShot) first. NAL snAppShot compares the configuration settings on a representative 
workstation before and after you install an application on it. These differences are recorded in an Application 
Object Template (.AOT) file. If changes are made to .INI files during the installation, the changes are imported to 
the .INI Files property page when you create the Application object. Giving you a point of reference, the .AOT file 
method takes the guesswork out of knowing which files and settings are required to run an application. If you need
to upgrade an application and there are new .INI file changes, you import a new .AOT file into the Text Files 
property page.

To change workstation .INI files the next time the application runs

1. Right-click the Application object and click Details.

2. Click the .INI Files button.

3. Click Import, browse and highlight the Application Object Template (.AOT) file that you created with NAL 
snAppShot, then click Open.

OR

Highlight a .INI file template entry and click Modify File to change its properties.

OR

Click New File to create a new .INI file template entry from scratch.

4. Click Add Section, type the name of the .INI file section you want to add, and then click OK.

OR

Highlight an existing section, click Add Value, and then enter the Value name or Value data.

OR

Highlight an existing section or value, click Modify, and then change the Value name or Value data.

5. Highlight a value under a section, select Create Item, and then choose Create Always, Create If Does Not 
Exist, Create If Exists, or Create Or Add To Existing to define exactly how you want the value to be added.

OR

Highlight the value under a section and click Delete Item to remove the value.
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Changing Application Files When the Application Runs

Use the Application Files property page to make changes to application-related files on the target workstation 
when the application runs.

The easiest way to use the Applications Files property page is to run the Novell* Application Launcher* snAppShot
component ("NAL" snAppShot) first. NAL snAppShot compares the configuration settings on a representative 
workstation before and after you install an application on it. These differences are recorded in an Application 
Object Template (.AOT) file. If files are copied during the installation, the changes are imported to the Application 
Files property page when you create the Application object. Giving you a point of reference, the .AOT file method 
takes the guesswork out of knowing which files and settings are required to run an application. If you need to 
upgrade an application and there are new files to copy, you import a new .AOT file into the Application Files 
property page.

To change workstation application files the next time the application runs

1. Right-click the Application object and click Details.

2. Click the Application Files button.

3. Click Import, browse and highlight the Application Object Template (.AOT) file that you created with NAL 
snAppShot, and then click Open.

OR

Highlight the name of a Application File or Directory template entry and click Modify to change the Source file 
and target file properties.

OR

Click Add to create a new Application File or Directory template entry.

4. Highlight an Application File template entry, select Copy File, and then choose Always Copy, Copy If Does Not 
Exist, Copy If Exists, Copy If Newer, Copy If Newer And Exists, or Request Confirmation.

OR

Highlight an Application File template entry and click Delete File to remove the file.

NOTE: Select the Shared File option to mark a file as a shared file (that is, one that is going to be used by 
more than one application). Files that are usually flagged as shared are Windows* .DLL files (such as 
MFC40.DLL and MFC42.DLL). The NAL snAppShot component detects shared files when it discovers 
application installation changes on a workstation.
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Managing Application Object Macros

Use the Macros property page to manage the macros that are used on other property pages of the Application 
object. You can use macros in the following Application object locations:

Full Path
Command Line
Working Directory
Mapping Path
Capture Port Path
Registry Property Page: Key, Name, Value (String only)
.INI Files Property Page: Group, Name, Value
Application Files Property Page: Source/Target, Directory
Text Files Property Page: Find and Add String
Icons/Shortcuts Property Page: All locations

For example, suppose that you have a complex Application object that uses the %SOURCE_PATH% macro 
throughout numerous property pages. What if the the path that %SOURCE_PATH% points to changes? Rather than 
change each case, you can change the value of %SOURCE_PATH% one time on the Macros property page, and the 
change is reflected on all other property pages where the macro is used.

Click Macro and Variable Examples for more information.

To define and manage macros that are used by other application property pages

1. Right-click the Application object and click Details.

2. Click the Macros button.

3. Click Import, browse and highlight the Application Object Template (.AOT) File that you created with the Novell*
Application Launcher* snAppShot ("NAL" snAppShot) component, and then click Open.

OR

Highlight a Macro template entry and click Modify to edit its name and value. For example, you can change the 
value of the %SOURCE_PATH% to C:\PROGRAM FILES\NETSCAPE macro.

OR

Click Add to create a new Macro template entry. Name the macro and include a value, and then click OK.
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Macro and Variable Examples

A macro is a variable name. The value of a variable is substituted in place of the variable name. If the variable is 
not found, it is not replaced with a value. A macro value is generally a string value. The order in which the following
variables are listed below is also their order of precedence.

For an example of macros in use, click Example of Using NAL snAppShot.

Example
A GroupWise* Application object runs OFWIN.EXE with a command-line parameter:

/@U-@USERNAME@

The USERNAME can be replaced with a macro that uses a user's NDS* Object name (CN):

/@U-@%CN%@

If the NDS Object name is the same as the e-mail login for GroupWise, every user that runs the application has 
the correct USERNAME passed in to GroupWise.

Special Variables
A special variable is one that defines Windows** directories. Typical values are shown in parentheses.

%*WinDir% Windows Directory (c:\windows)

%*WinSysDir% Windows System Directory (c:\windows\system or c:\winnt\
system32 for Windows NT**)

%*WinDisk% Drive Letter (Plus Colon) for Windows Directory (c:)

%*WinSysDisk% Drive Letter (Plus Colon) for Windows System Directory (c:)

%*WinDesktop% Windows Desktop Directory (c:\windows\desktop or c:\winnt\
profiles\<username>\desktop for Windows NT)

%*StartMenu% Windows Start Menu Directory (c:\windows\start menu or c:\winnt\
profiles\<username>\start menu for Windows NT)

%*WinSys16Dir% Windows NT 16-bit System Directory (c:\winnt\system)

%*CommonWinDesktop% Windows NT Common Desktop Directory (c:\winnt\profiles\all 
users\desktop)

%*CommonStartMenu% Windows NT Common Start Menu Directory (c:\winnt\profiles\all 
users\start menu)

%*TempDir% Windows Temporary Directory (c:\windows\temp)

Application Object Macro Variables
An Application object macro variable is one that is defined only for the Macros property page for a particular 
Application object. For example:

%SOURCE_PATH% Location of source files
%TARGET_PATH% Location to copy files

NDS Attribute Variables for Current User
You can add variables that are defined by an attribute in an NDS Object. Usage: %NDSATTRIB%

Examples
%CN% Context Name
%Given Name%Given Name



%Surname% Last Name
%Full Name%  Full Name
%Telephone Number% Telephone
%Home Directory% Home Directory
%Email Address% E-mail Address
%Mailbox ID% Mailbox ID

NOTE: By default, the currently logged-in user is the source NDS object for these attributes.

NDS Attributes From Other Objects
Using the following usage, %.OBJNAME.CONTAINER;NDSATTRIB%, an example might be as follows:

%.UserName.Novell;Description% Description from the UserName.Novell Object

NDS Attributes from Current Application Object
Using the following usage, %*;NDSATTRIB%, examples include

%*;APP:Caption% Application Icon Title
%*;APP:Path% Path to Executable
%*;APP:GUID% GUID
%*;APP:Version String% Version Stamp

Environment Variables
The following are defined by an environment variable:

%NWLANGUAGE%
%TEMP%
%PATH%

NOTE: The value of the variable must not exceed the length of the Application object name; otherwise, the 
variable fails.
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Scheduling Application Run Times

Use the Schedule property page to define when you want a particular application to run or how long you want an 
application's icon to appear in the Novell* Application Launcher* Window ("NAL" Window) or NAL Explorer.

For example, suppose you want users to have access to a particular application for only five days. After that, you 
want to remove the application from their view. Using the settings on the Schedule property page, you can 
automatically remove the icon from users' workstations.

Or, suppose that you want to run a virus detection application on users' workstations at a certain time, and only 
one time. The Schedule property page contains settings that make this possible as well.

To schedule when the application runs

1. Right-click the Application object and click Details.

2. Click the Schedule button.

3. Use the following options to change settings, and then click OK.

By Range
After clicking the Modify button, use this option to select a range of time in which to make the application available.
For example, if you select a start date of 2/2/98 and an end date of 2/5/98 with a start time of 8:00 a.m. and an end
time of 5:00 p.m., the Application object is available from 2/2/98 at 8:00 a.m. until 2/5/98 at 5:00 p.m.

You can also use the By Range option to filter out certain days of the week. For example, you could select a range
that excludes Saturdays and Sundays. This effectively makes the application available on weekdays only.

By Selection
Use this option to select specific dates during which you want the application to be available.    Here, the Start and 
Stop time take on a different meaning. For example, if you select the dates 2/2/98, 3/2/98, 4/2/98, and so on, and 
start and stop times of 8:00 a.m. and 5:00 p.m., this makes the application available from 8:00 a.m. to 5:00 p.m. on
each of the days selected. The application is not available on any other days or at any other time. This could be 
useful in making applications available only on holidays. You select no more than 350 specific dates for this option.

NOTE: When scheduling applications, you can also force them to run at the scheduled time (in addition to merely 
displaying them). Because the Force Run option is available on a per-association basis, you must select it from 
the Applications property page located on a User, Group, Organization or Organizational Unit object. If the 
association is not set up for a Force Run, the application icon is displayed according to the location specified by 
the association.

Spread from Start Time
If an application were to become available at 10:00 a.m., you wouldn't want all users to run the application at the 
same time for fear of bringing down the network because of the load and traffic. The spread option literally 
"spreads out" user access times over the number of minutes specified so they don't all run the application at once.

For example, if the application is scheduled to be available at 10:00 a.m., and the Spread from Start Time is set to 
120 minutes, the application becomes available, on a random basis, between the hours of 10:00 a.m. and 12 
noon. Thus, the demand for the application is spread out over a longer period of time and network traffic is 
minimized. If users access applications after the spread time is expired but before the end time of the Application 
object, they access the application at that time and the spread variable has no effect.

GMT (Greenwich Mean Time)
All application scheduling that you do with the Application property page is based on the workstation's time zone. 
In other words, if your network spans different time zones and you schedule an application to run at 1:00 p.m., it 
runs at 1:00 p.m. in each time zone. However, if you select the GMT check box, workstations run applications 
according to GMT (or Greenwich Mean Time).

For example, suppose you schedule an application to run at 1:00 p.m. and you are in Utah (Mountain Standard 
Time). By selecting the GMT option you, in effect, have really scheduled this application to run at 8:00 p.m. GMT 
time. Timezones are ignored and the the entire network around the world runs this application at the same 
moment.

NOTE: GMT time is not available if you are filtering out days of the week when in the By Range mode.



Setting Up Windows 3.x Clients for Timezones
Windows** 3.x clients do not use a timezone concept. The only way Windows 3.x clients can use a timezone is if it
is set in their environment. You can do this by putting the command

SET TZ=MST7DST

in the AUTOEXEC.BAT or login script. This example sets up the time zone to Mountain Standard Time with the 
option of setting the Daylight Savings Time when Daylight Savings Time is in effect. NAL also looks for the NALTZ 
environment variable. Some applications do not run if you set the TZ environment variable. If no environment 
variable is set, the default time zone is Eastern Standard Time.
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Creating or Changing Text Files When the Application Runs

Use the Text Files property page to change workstation text files (such as CONFIG.SYS and AUTOEXEC.BAT) the
next time the application runs.

For example, suppose that users are experiencing problems due to an incorrect text string found in their 
workstation's CONFIG.SYS file. Rather than visit and change each workstation or run the risk of users incorrectly 
and inconsistently implementing a change, you can set up a Text File template that finds, deletes, modifies, or 
adds text strings to the text file of your choice. The Text File template implements the changes the next time the 
application runs.

The easiest way to use the Text Files property page is to run the Novell* Application Launcher* snAppShot 
component ("NAL" snAppShot) first. NAL snAppShot compares the configuration settings on a representative 
workstation before and after you install an application on it. These differences are recorded in an Application 
Object Template (.AOT) file. If changes are made to text files during the installation, the changes are imported to 
the Text Files property page when you create the Application object. Giving you a point of reference, the .AOT file 
method takes the guesswork out of knowing which files and settings are required to run an application. If you need
to upgrade an application and there are new text file changes, you import a new .AOT file into the Text Files 
property page.

NOTE: It is possible that the text files that you are changing might be in use. Click Changing Workstation Files In 
Use for information about how NAL changes such files.

To change text files on the workstation the next time the application runs

1. Right-click the Application object and click Details.

2. Click the Text Files button.

3. Click Import, browse and highlight the Application Object Template (.AOT) file that you created with NAL 
snAppShot, and then click Open.

OR

Highlight a Text File template entry and click Modify to change its properties. Click Using the Text File Template
Editor for more information.

OR

Click Add to create a new Text File template entry. Click Using the Text File Template Editor for more 
information.
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Changing Workstation Files In Use

When Novell* Application Launcher* 2.0 software ("NAL") distributes applications, it might change workstation text 
files, such as AUTOEXEC.BAT and CONFIG.SYS that are in use. The changes to these files do not take effect 
until after the workstation is rebooted. NAL detects whether such changes are made, and prompts the user with a 
message stating that the workstation must be rebooted before the changes can take place.

Similarly, when application files are copied, the files they are replacing might be in use, and cannot be deleted or 
replaced. NAL handles this situation in several ways, depending on which operating system the workstation is 
currently using (Windows** 3.x, Windows 95**, or Windows NT**).
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Using the Text File Template Editor

Use the Text File Edit dialog box to find, delete, and add text strings to the text file template that is used to change 
text files when related applications are run.

To change a string in a text file template

1. Right-click the Application object and click Details.

2. Click the Text Files button.

3. Double-click the text file you want to modify.

4. Select Find String.

5. Specify whether to find an exact match of the text string or to find any string that contains specific text.

6. Select Modify String, type the new text exactly as it should appear, and then click OK.

To add a string to a text file template

1. Right-click the Application object and click Details.

2. Click the Text Files button.

3. Specify the workstation path and filename of the file you want to modify.

4. Select Add String.

5. Specify whether to add the string at the beginning of the file or at the end of the file.

6. Type the text you want to add, and then click OK.

To delete a string in a text file template

1. Right-click the Application object and click Details.

2. Click the Text Files button.

3. Click Add.

4. In the File Path text box, specify the workstation path and filename of the file you want to modify.

5. Select Find String.

6. Type the string you want to find.

7. Specify whether to find an exact match by selecting Exact Match or to find any string that contains the text you 
typed in Step 6 by selecting Substring Match.

For example, if you type C:\WORDS and select Exact Match, this text and ONLY this text is found.    If, on the 
other hand, you type the text and select Substring Match, any string containing C:\WORDS is found.

8. Select Delete String to delete the text you typed in Step 6, and then click OK.
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Filtering Applications by Workstation Configurations

Use the System Requirements property page as a filter to display application icons only on workstations that meet 
certain criteria that you specify, such as the specific version of an operating system, the amount of RAM, or free 
disk space. If workstations do not meet the criteria you specify, the icons do not appear on that workstation.

For example, suppose you want a word processing application icon to appear only on Windows** 95** 
workstations that have at least 32 MB of RAM, a Pentium** processor, and 500 MB of free disk space on the C: 
drive.    Using the options on the System Requirements property page, you can tailor the requirements in this way.

To display applications on a particular operating system

1. Right-click the Application object and click Details.

2. Click the System Requirements button.

3. As there might be a mixture of platforms on your network, you can select one or more platforms, such as 
Windows 3.x, Windows 95, and Windows NT**.

For example, suppose you want the application to run only Windows NT 4.0 or later workstations. To specify 
this configuration, select Windows NT, and then type 4 in the Major text box and 0 in the Minor text box. If you 
leave the Major and Minor text boxes empty, only the operating system is verified.

4. Click OK.

To display applications on workstations with a minimum set of specifications

1. Right-click the Application object and click Details.

2. Click the System Requirements button.

3. Select the Display Applications on Machines That Have At Least group box.

4. Specify options according to the following information.

Display Applications On Machines That Have At Least
Use the options in this group box if you need further filtering. For example, if the Application object sets up a suite 
of applications, there might be minimum disk space and memory requirements that need to be met.

MB of RAM
This field is valid only for Windows 95 and Windows NT workstations (Windows 3.x is ignored). Use it by 
entering the minimum amount of total installed RAM that the workstation must have to see and run this 
application.

For example, if the application requires 8 MB of RAM (8 x 1024 x 1024 bytes), you enter 8 in this text box. If 
you leave this text box blank, no memory checking is done.

Processor
This field shows the minimum processor needed to run this application. The choices are 386, 486, or Pentium.
For example, if you select 486 and the user has a 386 workstation, the Application object is not displayed on 
the workstation.

NOTE: The Windows 3.x Application Programming Interface does not return values higher than 486. 
Therefore, if Novell* Application Launcher* 2.0 software ("NAL") queries the processor type of a Windows 3.x 
workstation using a Pentium processor, Windows 3.x returns "486." In other words, even if you select the 
Pentium processor type for the Processor option, the application is displayed on 486 workstations running 
Windows 3.x.

Free Disk Space
Use this group box to check three different drives for available disk space. For example, you can check the 
workstation for 20 MB free (20 x 1024 x 1024 bytes) on the Windows Directory drive, 10 MB free on the TEMP 
drive, and 80 MB free on the D: drive. As with the other settings, if you leave these text boxes blank, no checking 
is done for available disk space.

NOTE: If the drives selected for any of the three fields happen to be the same drive, NAL adds those minimum 
requirements together to determine available space. For example, if you specify 20 MB free on the Windows 



Directory drive (which happens to be the C: drive), 10 MB free on the TEMP drive (which is also the C: drive), and 
50 MB free on the D: drive, NAL only shows the Application object as if there were 30 MB available on the C: 
drive, and 50 MB free on the D: drive.
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Associating a User, Group, Organization, or Organizational Unit Object with 
Applications

Use the Applications property page to associate a User, Group, Organization, or Organizational Unit objects to 
multiple Application objects. Compare this property page with an Application object's Associations property page, 
in which you associate (in reverse order) one Application object with multiple User, Group, Organization, or 
Organizational Unit objects. Unless you associate applications using one of these two methods, applications are 
not available to users.

In addition to associating applications with other objects, use the Applications property page to specify where and 
how users access applications on their workstations. For example, you can display application icons in the Novell* 
Application Launcher* Window ("NAL" Window), the NAL Explorer, Windows** Explorer, Start menu, Desktop, and 
System Tray. You can also force applications to launch when Windows starts.

NOTE: The default method of access is "App Launcher," meaning that users see the application in the NAL 
Window and NAL Explorer only.

To specify who sees the application and where the application is displayed on workstations

1. Right-click the User, Group, Organization or Organizational Unit object, and then click Details.

2. Click the Applications button.

3. Click Add, browse and select the Application object, and then click OK. Specify how and where you want the 
application to work by selecting the appropriate check box (see below), and then clicking OK.

Or, to remove the association from the list,

Highlight an existing User, Group, Organization, or Organizational Unit object, and click Delete.

Force Run
This option runs applications immediately when the NAL Window or NAL Explorer starts. You can use this 
option in conjunction with the Run Once option (on the Identification property page) to run an application 
immediately one time. By specifying Run Once and setting an application run schedule (using the Schedule 
property page), you can run the application immediately one time at a given time.

App Launcher
This option displays application icons in the NAL Window and NAL Explorer.

Start Menu
When the NAL Explorer is enabled, this option displays icons on the Windows 95** or Windows NT** Start 
menu under Novell Application Launcher.

Desktop
When the NAL Explorer is enabled, this option displays icons on the Windows 95 or Windows NT desktop area.

System Tray
This option displays icons on the System Tray, an area on the Windows 95 or Windows NT 4.0 Taskbar where 
small icons, representing applications, are placed for easy access. The NAL Explorer can display or remove 
applications on the System Tray at any time.

To view the applications assigned to or inherited by a User, Group, Organization or Organizational Unit 
object

1. Right-click the User, Group, Organization or Organizational Unit object and click Details.

2. Click the Applications button.

OR

Choose Tools > Show Inherited Applications.
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Configuring NAL Window and NAL Explorer

Use the Launcher Configuration property page to specify how users view and work with the Novell* Application 
Launcher* Window ("NAL" Window) and NAL Explorer desktop software. This property page is available for User, 
Organization or Organizational Unit objects only.

NOTE: Except where noted, the settings on this property page apply to both NAL Window and NAL Explorer.

The settings on the Launcher Configuration property page are put in operation in one of three ways:
If you select the Use Current Settings option, NAL Window or NAL Explorer use the settings on the 

Launcher Configuration property page as they are currently defined.
If you select the Use Parent Container Settings option, NAL Window or NAL Explorer use the settings 

included in the user's immediate parent Organization or Organizational Unit object.
If no settings are found (that is, the immediate parent Organization or Organizational Unit object has the Use

Default Setting Launcher Configuration option selected), then NAL Window or NAL Explorer use the default settings 
described below.

NOTE: In a multi-tree environment, the Launcher Configuration settings are read from the default NDS* tree. The 
default NDS tree can be seen in NETWARE.DRV for Windows** 3.x or by right-clicking in the Windows 95** or 
Windows NT** Explorer's Network Neighborhood and selecting IntranetWare Connections.

To specify default settings for NAL Window and NAL Explorer

1. Right-click a User, Organization or Organizational Unit object and click Details.

2. Click the Launcher Configuration button.

3. Define settings using the following information, and then click OK.

Use Default Settings
The Use Default Settings option is available only on Organization or Organizational Unit objects. Selecting this 
option enables the following default settings:

Exit the Launcher (ON)
Log In (ON)
Refresh Icons (ON)
View Folders (ON)
Create Personal Folders (OFF)
Save Window Size and Position (ON)
Enable Timed Refresh (OFF)
Enable Timed Refresh 3600 Seconds (only if Enabled Timed Refresh is selected)
Inherit Container Application 1 Level

Use Parent Container Settings
The Use Parent Container Settings option is available only for User objects. Use it to inherit the Launcher 
Configuration settings from the authenticated User object's immediate parent container (Organization or 
Organizational Unit object). For example, if the USER1 object is a child object of the COMPANY Organization 
object and you select the parent setting, then USER1 receives all Launcher Configuration settings found in the 
COMPANY Organization object.

NOTE: When Use Parent Container Settings is selected, the grayed-out current settings do not necessarily reflect 
the actual values of NAL Window or NAL Explorer.

Use Current Settings
When selected, NAL Window and NAL Explorer use the settings described below.

NOTE: When Use Default Settings is selected, the grayed-out current settings do not necessarily reflect the actual
values of NAL Window or NAL Explorer configuration.

Exit the Launcher
If this setting is ON, the user can exit NAL Window. If this setting is OFF, the user cannot exit NAL Window. 
This option is not available for NAL Explorer.

For example, suppose you are running software at a conference where there are workstations available for 



the attendees of the conference to use. If you do not want users to exit the NAL Window and change settings
on the hard disk drive, you can turn off this option OFF.

Log In
Selecting the Log In option activates the Login option found on the NAL Window's File menu. The user can 
use this option to run the GUI Login software and log in to the network. This option is not available for NAL 
Explorer.

NOTE: When this option is selected, and the user is not logged in, the NAL Window searches for the Login 
executable in the path and if found, displays a Login icon in the NAL Window. If the Login executable cannot 
be found, or if the user is already logged in, the Login option is grayed. Before you select the Log In option, 
ensure that the NAL Window can find the login program (LOGINW31.EXE, LOGINW95.EXE, or 
LOGINWNT.EXE) on the client workstation. Put the appropriate login program in the startup directory, 
working directory, or path.

Refresh Icons
This option enables the user to refresh the NAL Window manually. This displays any Application objects that 
were delivered since NAL Window was last refreshed.

In NAL Window or NAL Explorer, a user can refresh icons by choosing View > Refresh or pressing F5. If the 
Refresh Icons option is ON, users can manually refresh the icons whenever they want. If the Refresh Icons 
option is OFF, NAL Window or NAL Explorer's icons refresh only on startup or at the Timed Refresh interval 
(if it is turned ON). The Refresh Icons option and Timed Refresh options are not connected in any way except
that they both control refresh. One option does not have to be selected for the other to work.

View Folders
The folder view in NAL Window might be confusing to some users. By turning off View Folders, users see 
only the application icons available to them in NAL Window.

NOTE: The associations of the Application object determine System folder names. For example, if a user 
were a member of the .APPLICATIONS.CITY.COMPANY Group, and that Group has applications associated 
with it, the user would see a folder called .APPLICATIONS.CITY.COMPANY containing all its associated 
applications. Click Renaming System Folders with Descriptive Names for more information

Create Personal Folders
If this setting is ON, users can create their own folders and move the icons around in them as they see fit. 
However, the icons must originate from some application associated with the user. A user cannot add a new, 
unassociated Application object using personal folders.

Use caution when offering the option to create personal folders. Users might forget where they have placed 
applications and call you for help. Not allowing personal folders might be a way to exert more strict control 
and thus reduce support calls.

Save Window Size and Position on Local Drive
Saves window size and position settings on a local drive.

For example, suppose you operate a lab at a university. Many users use the workstation but nobody owns it. 
By turning this option OFF, NAL Window is always displayed in the same position for every user. This option 
is available only for NAL Window, not NAL Explorer.

Enable Timed Refresh X Seconds
This option refreshes the application icons automatically without the user having to choose File > Refresh or 
pressing F5 to manually refresh icons. For example, if you the refresh set to 240 seconds, NAL Window or 
NAL Explorer update applications from the network automatically every two hours and might even run some 
applications depending on how you have set them up. The range of values is 0 to 3600 seconds.

A short timed refresh interval is very useful in situations where you want changes to refresh quickly. However,
a short timed refresh interval can cause higher network traffic. The Refresh Icons option and Timed Refresh 
options are not connected in any way except that they both control refresh. One option does not have to be 
selected for the other to work.

Inherit Container Applications X Levels
This option specifies how many parent Organization or Organizational Unit objects up the NDS tree NAL 
Window or NAL Explorer should search for applications.



For example, if a User object's distinguished name (DN) is USER.DEV.CITY.COMPANY and this option is set
to a value of 2, NAL Window or NAL Explorer would look at the Organization or Organizational Unit object's 
DEV and CITY for Application objects but ignore COMPANY. A value of -1 instructs NAL Window or NAL 
Explorer to search all the way up the NDS tree.

Attribute to be Used for E-mail in ‘Contacts’
Specifies the NDS attribute you use to identify users' e-mail addresses. For example, if your e-mail 
addresses are the same as your login names, you can use the common name (CN) attribute.
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Creating or Changing Icons and Shortcuts When the Application Runs

Use the Icons/Shortcuts property page to control the icons of Application objects that appear in Program Manager 
(Windows** 3.x) and Shortcuts in Windows Explorer (Windows 95** and Windows NT** 4.x). The items that 
appear in the Icons/Shortcuts list control the following: Program Group, Program Group Item, and Shortcut.

For example, suppose that your company uses special icons for the applications that users run on their Windows 
95, Windows NT and Windows 3.x workstations. Using the Icons/Shortcuts property page for this Application 
object, you can change the icons for the other applications the next time this application runs.

To change icons and shortcuts the next time the application runs

1. Right-click the Application object and click Details.

2. Click the Icons/Shortcuts button.

3. Click Import, browse and highlight the Application Object Template (.AOT) file that you created with the Novell* 
Application Launcher* component ("NAL" snAppShot), and then click Open.

OR

Click Add to create a new Icon/Shortcut template entry.

For example, select Program Group to display the Windows Program Group dialog box, and specify the name 
of the Program Group that is created in Program Manager when the Application object is run. You can also 
delete a Program Group when the Application object is launched.    See Setting Up a Windows Program 
Manager Group Item or Setting Up a Windows Shortcut for more information.

OR

Highlight an Icon/Shortcut template entry and click Modify to change its properties.

OR

Highlight an Icon/Shortcut template entry and click Delete to remove it.
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Setting Up a Windows Program Manager Group Item

Use the Program Manager Group Item dialog box to define the icon of an item that appears in a Windows** 
Program Group.

To set up a Program Manager Group Item for an Application object

1. Right-click the Application object and click Details.

2. Click the Icons/Shortcuts button.

3. Click Add, and then select Program Group Item.

4. Click Create to add the Program Manager Group Item when the application is launched. If a similar item exists 
and you want to replace it with the one you are creating, select Overwrite Existing Icon.

OR

Click Delete to remove the icon of the Program Group Item when the application is launched.

5. Specify settings for the remaining options as necessary, and then click OK.

Name
Type the name of the Program Manager Group Item icon you want to create.

Target
Specify the path to the file that the Program Group Item icon represents. This is usually the path to an executable.

Program Group
Enter the name of the Program Manager Program Group where this Item is created.

Start In
Specify the working directory of the executable you specified in the Target option. See your Windows 
documentation for more information.

Icon Filename
Specify the name of the file that contains information about the icon. This filename can be the same as the item 
you specified for the Target option. If you don't specify a icon filename, Novell* Application Launcher* ("NAL") uses
the Target filename as the basis of the icon. You can also specify icon collections, such as MORICONS.DLL 
(provided with Windows).

Icon Index
Enter the icon number that is selected from the file specified in the Icon Filename text box. If you don't specify 
anything here (a value of 0), the feature uses the default icon from the file.

Normal
Select Normal if you want to run the application in normal mode.

Minimized
Select Minimized if you want to run the application in minimized mode.

NT Separate Memory
Select this option if you want the application for which you are setting up an Program Group Item to run in its own 
separate memory space when it is launched.
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Setting Up a Windows Explorer Shortcut

Use the Explorer Shortcut dialog box to define the shortcut of an item that appears on a Windows** 95** or 
Windows NT** workstation.

To set up a Windows Explorer shortcut for an Application object

1. Right-click the Application object and click Details.

2. Click the Icons/Shortcuts button.

3. Click Add, and then select Shortcut.

4. Click Create to add the shortcut when the application runs. If a similar Windows Explorer shortcut exists and 
you want to replace it with the one you are creating, select Overwrite Existing Icon.

OR

Click Delete to remove a shortcut when the application runs.

5. Specify settings for the remaining options as necessary, and then click OK.

Name
Type the name of the shortcut you want to create. Most shortcuts are created in the Windows directory under the 
Start Menu folder.

Target
Specify the path to the file that the shortcut represents. This is usually the path to an executable. 

Shortcut Location
Specify the full path of the directory where this shortcut is created. Most shortcuts are created in the Windows 
directory under the Start Menu folder.

Parameters
Specify any command-line parameters that need to be passed to the executable specified in the Target text box.    
See your Windows documentation for more information.

Start In
Specify the working directory of the executable you specified in the Target option. See your Windows 
documentation for more information.

Icon Filename
Specify the name of the file that contains information about the icon used by the shortcut. This filename can be the
same as the item you specified for the Target option. If you don't specify a icon filename, Novell* Application 
Launcher* ("NAL") uses the Target filename as the basis of the icon. You can also specify icon collections, such as
MORICONS.DLL (provided with Windows).

Icon Index
Enter the icon number that is selected from the file specified in the Icon Filename text box. If you don't specify 
anything here (a value of 0), the feature uses the default icon from the file.

Normal
Select Normal to run the application in normal mode.

Minimized
Select Minimized to run the application in minimized mode.

Maximized
Select Maximized to run the application in maximized mode.
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Creating a Simple Application Object (without a .AOT file)

You can create an Application object by naming the Application object and specifying a path to the application's 
executable files. You can also specify additional properties for the application.

NOTE: If you created a .AOT file to create the Application object, you need to use a different set of steps, found 
here.

To create an Application object without a .AOT file

1. Right-click the Organization or Organizational Unit object under which you want to create an Application object.

NOTE: The location of the container object does not matter; however, the container object should be relatively 
close to the users who access the Application objects (usually within the same partition).

2. Choose Create > Application, and then click OK.

3. If you want to set up the Application object's property pages immediately after creating the object, click    Define
Additional Properties.

4. If you want to create another Application object right after you create this one, click Create Another Application 
Object.

5. Click the following topics for information about setting up property pages for the Application object, as desired.

Associating an Application with User, Group, Organization, and Organizational Unit Objects
Associating a User, Group, Organization, or Organizational Unit Object with Applications
Identifying the Application Object
Setting Up the Application's Environment
Setting Up Drives and Ports
Creating Application Scripts
Describing Applications to Users
Identifying Application Contacts
Writing Application Administrator Notes
Filtering Applications by Workstation Configurations
Scheduling Application Run Times
Setting Up Application Fault Tolerance and Load Balancing
Showing a User Object's Inherited Applications
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Creating a Complex Application Object (with a .AOT file)

You can create an Application object using an Application Object Template (.AOT) file. A .AOT file contains a 
record of all changes made to a workstation as a result of running a Setup program, including changes in files and 
configurations. Using a .AOT file greatly simplifies the distribution of applications to users' workstations because 
you don't have to configure and manage each workstation.

You create a .AOT file using the Novell* Application Launcher* snAppShot component ("NAL" snAppShot), which 
is provided with NAL.

To create an Application object using the .AOT and .FIL files that you generated with NAL snAppShot

1. Right-click the Organization or Organizational Unit object under which you want to create an Application object.

NOTE: The location of the container object does not matter; however, the container object should be relatively 
close to the users who access the Application objects (usually within the same partition).

2. Choose Create > Application, and then click OK.

3. Select Use This Wizard with an Application Object Template, and then click Next.

By default, NAL looks in SYS:\PUBLIC\NALLIB\AOTFILES for the .AOT file. Click Accessing .AOT Files in NAL
for more information.

4. If you want to set up the Application object's property pages immediately after creating the object, select Define
Additional Properties.

5. If you want to create another Application object after you create this one, click Create Another Application 
Object.

6. Browse for the .AOT file, select it, click Open, and then click Next.

7. Check (and change, if necessary) the target and source directories of the Application object, and then click 
Next.

8. Review the information about the Application object (click the Back button to make any changes). If the 
information is correct, click Create.

9. Click the following topics for information about setting up property pages for the Application object, as desired.

Associating an Application with User, Group, Organization, and Organizational Unit Objects
Associating a User, Group, Organization, or Organizational Unit Object with Applications
Identifying the Application Object
Setting Up the Application's Environment
Setting Up Drives and Ports
Creating Application Scripts
Describing Applications to Users
Identifying Application Contacts
Writing Application Administrator Notes
Filtering Applications by Workstation Configurations
Scheduling Application Run Times
Setting Up Application Fault Tolerance and Load Balancing
Showing a User Object's Inherited Applications

Property Pages for Complex Application Objects
Managing Application Object Macros
Changing the Windows Registry When the Application Runs
Creating or Changing .INI files When the Application Runs
Changing Application Files When the Application Runs
Creating or Changing Text Files When the Application Runs
Creating or Changing Icons and Shortcuts When the Application Runs
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Showing a User Object's Inherited Applications

Use this option to see the Application objects that have been associated with the User object, including all 
applications either associated with or inherited by the User object. The applications are listed by mode of delivery, 
such as Force Run, Launcher, Desktop, Start Menu, and System Tray. These categories come from the 
Applications property page, which is available for User, Group, Organization, and Organizational Unit objects.

To list the applications that the user sees on the desktop

1. Highlight a User object.

2. Choose Tools > Show Inherited Applications.

3. Expand the User object to view all associated applications.
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Exporting and Importing Application Objects

Use this option to export an Application Object Template (.AOT) file. After it is exported, you can import the .AOT 
file information into other Application objects. 

To export a .AOT file

1. Highlight an Application object.

2. Choose Tools > Export Application Object.

3. Specify a filename using a .AOT file extension, and then click Save.

NOTE: All properties of the Application object are exported except information from the Contacts, Associations, 
Fault Tolerance/Load Balancing, and Administrator Notes property pages.

To import a .AOT file

1. Highlight an Application object.

2. Click a property page that supports .AOT file use (such as the Registry, Text Files, INI Files, or Macros property
page).

3. Click Import, browse for the .AOT file that you exported earlier, then click Open.

NOTE: Only the information that pertains to the property page that you clicked in Step 2 is imported from 
the .AOT file. For example, if you clicked the Registry property page, only Registry information is imported.
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Upgrading Workstations from Windows 3.x to Windows 95
      

Using Novell* Application Launcher* 2.0 software ("NAL") you can upgrade a workstation running Windows** 3.x 
and a VLM* Client to a workstation running Windows 95** and Client 32* for Windows 95.

NOTE: You can download the latest version of Client 32 for Windows 95 at http:\\support.novell.com

Administrator Prerequisites
As the administrator, you need to do the following:

Run Client 32 for Windows 95 or the Novell Client for Windows NT** 4.0.
Log in to a NDS* Tree.
Authenticate to NDS and the server to where you want to set up the file 
Obtain write privileges to the server's SYS:PUBLIC area.
Obtain write privileges to the root of the NDS tree. This is needed only if the tree's schema has not been 

modified to support Application objects.
Obtain object create privileges in the Organization or Organizational Unit object where applications are to be

created.

Workstation Prerequisites
A user's workstation must meet several requirements before it can be upgraded to Windows 95 and Client 32 for 
Windows 95. A workstation must be running the following:

DOS and Windows 3.1x
Program Manager as the desktop in Windows
VLM version 1.21 or later
LOGIN.EXE from the AUTOEXEC.BAT file

In addition, the workstation must:
Log in to an NDS tree
Log in as a Directory Services user (not bindery)
Have preferred tree/server set correctly in NET.CFG
Have preferred context (NAME CONTEXT) set correctly in NET.CFG
Log in to a preferred server or NDS tree with the login line in AUTOEXEC.BAT
Have SYS:PUBLIC in the user's PATH through the Organization or Organizational Unit object's login script. 

Users can map a search drive to \\PREFERRED SERVER\SYS\PUBLIC to ensure that they have access to certain 
files no matter what the current directory is.

Tasks
To upgrade users' desktops using Windows 3.x and a VLM Client to Windows 95 and Client 32, you need to 
perform the following tasks. Click the links for more detailed information:

Install NAL 2.0 (run SETUPNAL.EXE).
Modify the NDS tree's schema
Copy Windows 95 and Client 32 product files to a shared server.
Create an Application object that sets up Windows 95
Create an Application object that sets up Client 32
Associate Application objects
Use ADDICON to add NAL to the Windows 3.x startup group
Run the Windows 95 and Client 32 Application Objects
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Copying the Windows 95 and Client 32 Product Files

After you have installed Novell* Application Launcher* 2.0 software ("NAL") and are ready to create Application 
objects, you need to place Windows** 95 and Client 32* for Windows 95 product files in a network location where 
users have access to them.

NOTE: We recommend copying these product files to a location below SYS:PUBLIC on a server.

To copy the Windows 95 and Client 32 product files

1. Copy Windows 95 to SYS:PUBLIC\CLIENT\OS_WIN95.

You can copy the entire WIN95 directory from the Windows 95 CD. For example:

Type XCOPY D:\WIN95 Z:\PUBLIC\CLIENT\OS_WIN95

where D: is the CD-ROM drive where the Windows 95 CD is loaded and Z: is mapped to the SYS:\PUBLIC 
area.

2. Install Client 32 for Windows 95 to SYS:PUBLIC\CLIENT\WIN95\IBM_ENU (for English).

If Client 32 is already installed, you can update the files to a newer version.
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Creating an Application Object that Sets Up Windows 95

If you have copied the Windows 95** product files, you are ready to create an Application object that users use to 
set up Windows 95 on their workstations.

To create a Windows 95 Setup Application object

1. Right-click the Organization or Organizational Unit object under which you want to create the Application 
object.

NOTE: The location of the container does not matter; however, the container should be relatively close to the 
users who access the Application object (usually within the same partition).

2. Click Create, select Application, and then click OK.

3. Type Microsoft Windows 95 Setup as the object name.

4. Type Z:\PUBLIC\CLIENT\OS_WIN95\SETUP.EXE as the path to the executable.

IMPORTANT: The Windows 95 Setup program accesses files after rebooting and later when installing Client 
32* software. Because Novell* Application Launcher* 2.0 software ("NAL") does not control the second part of 
the installation, Windows 95 goes back to where it originally found the files. If Z: is not mapped, Windows 95 
prompts the user for the location. To avoid this kind of prompting, we recommend using the Z: drive and 
keeping Z: mapped in users' login scripts.

5 Select the Define Additional Properties check box, and then click Create.

6. Choose the System Requirements properties page.

7. Select Windows 3.x only.

8. Click OK to save the changes to the Windows 95 Setup Application object.
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Creating an Application Object that Sets Up Client 32

If you have copied the Client 32* software, you are ready to create an Application object that users use to set up 
Windows** 95** on their desktops.

To create a Client 32 Application object

1. Right-click the same Organization or Organizational Unit object under which you created the Windows 95 
Setup Application object.

2. Click Create, select Application, and then click OK.

3. Type Novell Client 32 for Windows 95 Setup as the object's name.

4. For the path to executable, enter

\\SERVER\VOLUME\PUBLIC\CLIENT\WIN95\IBM_ENU\SETUP.EXE

5. Select the Define Additional Properties check box, and then click Create.

6. Select System Requirements.

7. Select Windows 3.x and Windows 95.

NOTE: When Novell* Application Launcher* Window ("NAL" Window) is run on a workstation that runs 
Windows 95 and VLM* software, the executable (NAL.EXE) runs another executable called NALW31.EXE, 
which is the 16-bit version of NAL Window. Because it is the 16-bit version, it only displays Windows 3.x 
applications. Click NAL.EXE (the Wrapper) for more information.

8. Click OK to save the changes to the Client 32 for Windows 95 Setup Application object.
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Using ADDICON to Add NAL Window to Windows 3.x Startup Group

Use ADDICON, a DOS utility provided with Novell* Application Launcher* 2.0 software ("NAL"), to add a NAL 
Window group item to any Windows** 3.x Program Manager group. You run ADDICON from a DOS command line 
or login script (for example, ADDICON EXE=NAL.EXE).

NOTE: ADDICON creates Program Group items, not Program Groups. Likewise, it works only with Windows 3.x 
Program Manager group files. It does not work with other Windows 3.x desktop replacement tools. For more 
information about this utility (including information about command-line parameters) type ADDICON /H at the 
command line.

See also Creating or Changing Windows Program Manager Group Items When an Application Runs.

To use ADDICON to add NAL.EXE to a user's Windows Startup group

1. Include the following commands in a Organization or Organizational Unit's login script:

IF MEMBER OF "NAL GROUP" THEN
#ADDICON EXE=NAL.EXE
END
This example runs ADDICON if the user who is logging in is a member of "NAL Group." You can add an extra 
IF statement to prevent ADDICON from being run when a GUI login for Windows is present. For example:

IF "%PLATFORM" <> "W95" AND "%PLATFORM" <> "WIN" THEN
IF MEMBER OF "NAL GROUP" THEN
#ADDICON EXE=NAL.EXE
END
END
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Running the Windows 95 and Client 32 Application Objects

Having set up the setup Application objects and made NAL Window or NAL Explorer available to users desktops, 
you are ready to run the Application objects.

To run the Application objects at user's workstations

1. Login to IntranetWare.

NOTE: ADDICON adds NAL.EXE to the startup group if it is not already there.

2. Run Windows 3.x.

3. Double-click the Microsoft Windows 95 Setup icon in NAL Window.

4. Answer all Windows 95 Setup questions appropriately.

NOTE: This step can be automated by the administrator (Click Automating Windows 95 and IntranetWare 
Client 32 for Windows Installations).

5. When the workstation reboots during the Windows 95 Setup, the user must correctly enter his or her 
IntranetWare username and password before the Setup can complete.

NOTE: If a user does not successfully login during this reboot, the Windows 95 Setup does not migrate the 
NAL.EXE icon to the Windows Startup group. Users then need to manually browse SYS:PUBLIC on the server 
and run NAL.EXE on their own. Once Windows 95 Setup completes, NAL Window should appear (there is a 
slight delay when run the first time).

6. Double-click the Novell IntranetWare Client 32 for Windows 95 Setup icon in the Novell Application Window.

7. Answer all questions appropriately.

8. When prompted, click the Reboot Workstation button.

9. When Windows 95 reloads, the Windows login window displays and the user must enter his or her username 
and password.
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Automating Windows 95 and Client 32 for Windows Installations

You can accomplish the installation of Windows 95 and IntranetWare Client 32 for Windows 95 in one step. You do
this by merging the two installations using the MSBATCH.INF option. If a user is running Client 32 for 
DOS/Windows instead of Novell's VLM client when updating, the process is the same.

To pre-answer most or all of the questions asked during the Windows 95 installation, run NETSETUP and 
INFINST to create an MSBATCH.INF file. These utilities are contained on the Windows 95 CD in the \ADMIN\
NETTOOLS\NETSETUP directory.

For more information, search for the topic "server-based setup" in WIN95RK.HLP, which is located in the \ADMIN\
RESKIT directory on the Windows 95 CD.

You can also automate the Client 32 installation. For more information, search for the topics "server-based install," 
"server-based setup," "NETSETUP.EXE file," and "INFINST.EXE file" in the Novell IntranetWare Client 32 Help file 
(SETUPNW.HLP). This Help file is found on the server in SYS:PUBLIC\CLIENT\WIN95\IBM_ENU or in \NOVELL\
CLIENT32 directory after installing Client 32.

* Novell trademark.    ** Third-party trademark.    For more information, see Trademarks.



About NAL.EXE (the Wrapper)

The NAL.EXE executable file, known as a "wrapper" executable, makes it possible to display Application object 
icons on the workstation and perform client tasks to launch the application. The following topics describe in detail 
how this file works and how to customize its functions.

Why Is NAL.EXE Called a Wrapper?
The NAL.EXE file checks the environment and then runs another executable depending on what that environment 
is. When the other executable is running, NAL.EXE terminates. This is why NAL.EXE is considered a wrapper...it 
"wraps" around other executable files.

For example, if NAL.EXE detects that Windows** 3.x is running, it runs NALW31.EXE.    Or, if Windows 95** is 
running, NAL.EXE first checks whether client Virtual Loadable Module* (VLM*) files or Client 32* files are being 
used. If VLM files are running, NAL.EXE runs NALW31.EXE because there is only 16-bit support to the network. If 
Client 32 is running, NAL.EXE runs NALWIN32.EXE. For Windows NT**, NAL.EXE always runs NALWIN32.EXE.

What Is the Benefit of a Wrapper Executable?
A wrapper executable lets you add a single command to a login script without being concerned about the 
environment. For example, if a user moves from one operating system platform to another, the wrapper 
automatically adjusts. This simplifies setup and administration and allows greater flexibility.

We recommend that the workstation always start NAL.EXE rather than directly running one of the launching 
executables. Bypassing the wrapper reduces some of the centralized administration benefits of Novell* Application
Launcher* 2.0 software ("NAL"). In addition, if the workstation cannot properly connect to the network and access 
NAL.EXE from the server, it read NDS* objects or run networked applications.

Updating Files
A wrapper executable also updates appropriate files on the local workstation prior to activating the launcher on the
client. The set of files that NAL.EXE updates on the workstation is located in the NALLIB directory, which is directly
below the directory where NAL.EXE is executed. This directory is typically SYS:PUBLIC\NALLIB when the product
is installed in the default location. Depending on the platform, the wrapper executable updates appropriate files 
needed by the client executable. The local files are updated only when the network copy is newer than the local 
copy. If a copy of NAL.EXE is run from a local drive, it only updates files that belong in the WINDOWS\SYSTEM 
directory.

Executing NAL.EXE from a Login Script
On Windows 3.x and Windows 95, NAL requires the newer versions of the GUI login files to run scripts properly. If 
the newer versions of the files are not present, NAL.EXE does not run scripts when an application is launched. It is
important to note that the GUI login files cannot be updated while the GUI login is running. Therefore, if NAL.EXE 
is run from a login script, none of the GUI login files can be updated using this process. 

If you must update the GUI login files, you can create an Application object that points to NAL.EXE. After the login 
script finishes, the end user can run that application to have the GUI login files updated.
You might label this application "Update Client."

NAL Window Administrative Features
Using the NALINIT.INI file, you can invoke special settings for NAL.EXE.

When run, NAL.EXE looks for NALINIT.INI in the current directory and in the path. If it finds NALINIT.INI, NAL.EXE
looks for settings in the [Init] section. The possible settings are SkipUpdate and SkipLaunch.

If SkipUpdate is set to 1, NAL.EXE does not copy any files. You use SkipUpdate if you do not want NAL to change 
any files on the local workstation and you do want NAL.EXE to always run NALW31.EXE or NALWIN32.EXE from 
the server.

If SkipLaunch is set to 1, NAL.EXE does not run NALW31.EXE or NALWIN32.EXE but performs the update and 
then terminates. You use SkipLaunch if you want NAL.EXE to update GUI login files on a local workstation but not 
start the launcher itself.

NAL.EXE functionality is not affected if the value of a setting is 0 or if the setting is not included in NALINIT.INI. 
Setting both options to 1 at the same time instructs NAL.EXE to perform no function.

The following section does not perform the update before launch:



[Init] 
SkipUpdate=1
SkipLaunch=0

The following section performs the update, but does not launch:

[Init] 
SkipUpdate=0
SkipLaunch=1
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What is UNC?

IntranetWare* software supports the use of Universal Naming Convention (UNC) redirection for path statements in
dialog boxes. UNC lets you 1) use a network resource without setting up a drive mapping to it, 2) run applications 
and programs within Windows** while accessing network volumes and directories, and 3) assign network 
applications, volumes, and directories to icons within Windows.

An example of a valid UNC path is \\SERVER1\SYS\APPS\SOLITAIRE\SOL.EXE\

NOTE: When using UNC paths with Windows 3.1 (and Windows for Workgroups), the SERVER name must be 
less than 11 characters, and the VOLUME name must be less than 7 characters.

* Novell trademark.    ** Third-party trademark.    For more information, see Trademarks.
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What Is NAL snAppShot?

When you install a complex application to a workstation, it is possible that the application's Setup program makes 
changes to the workstation including the Windows** registry, .INI files, file system files, CONFIG.SYS and 
AUTOEXEC.BAT files, and any other configurations that support the application. Imagine keeping track of all these
changes every time you had to install an application on a user's workstation.

Think of the Novell* Application Launcher* snAppShot component ("NAL" snAppShot) as a camera that takes two 
snapshots: the workstation's pre-installation configuration state (before you install an application) and the 
workstation's post-installation state (after you have installed an application). NAL snAppShot then compares the 
two pictures and records any differences in an Application Object Template (.AOT) file.

NAL snAppShot tracks of all the files that an application Setup program installs to the workstation. These files are 
copied and stored in a series of .FIL files.

You use the information gathered by NAL snAppShot when creating and setting up Application objects using 
NetWare* Administrator and the NAL Snap-In component. Because the .AOT file contains all application 
installation changes, you can set up Application objects with confidence, knowing that they will have the same 
configuration as if you had installed an application locally to a workstation. This process greatly simplifies your job 
and helps to ensure a smooth roll out of applications to users' desktops.

IMPORTANT: NAL snAppShot captures only the end result of an installation; it does not capture the "logic" of the 
installation. If the application's Setup program makes choices of which files or settings to install based on existing 
hardware, software, or other settings, those files or settings may not be valid when distributed to other 
workstations. For example, if the application's Setup program installs a particular video driver or modem setting file
to a workstation, these settings may not be valid when transfered to another workstation. To be sure of the impact 
the Application object will have on a workstation, we recommend that you choose a representative workstation 
when running NAL snAppShot and that you review the files and settings that the Application object makes on a 
test workstation before making it widely available to users.

See Also
Example of Using NAL snAppShot
Using NAL snAppShot: A Procedural Overview
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Example of Using NAL snAppShot

Suppose you are going to use the Novell* Application Launcher* snAppshot ("NAL" snAppShot) component to 
discover the changes that Netscape* for Windows** 95** makes on a workstation. The directory you specify for 
placing application files (or source path) is Z:\PUBLIC\AOTFILE\NETSCAPE. You also specify an installation 
directory (or target path) of C:\NETSCAPE where files are copied during the installation.

During the installation process, Netscape copies files to the C:\NETSCAPE and to the C:\WINDOWS directories. 
Netscape also adds Registry settings and places Shortcuts in the Start Menu.

The Netscape installation copies UNINST.EXE to C:\WINDOWS. NAL snAppShot also copies this file to the 
application files directory Z:\PUBLIC\AOTFILE\NETSCAPE (or source path), renaming it "1.FIL." The the real 
name (UNINST.EXE) is recorded in the FILEDEF.TXT file and an entry is made in the Application Object Template 
(.AOT) file to copy %SOURCE_PATH%\1.FIL to %*WINDIR%\UNINST.EXE. Notice that the real pathnames are 
replaced with macro variables (for example, %SOURCE_PATH% equals Z:\PUBLIC\AOTFILE\NETSCAPE). The 
Netscape installation process actually copies the UNINST.EXE file to C:\WINDOWS. Therefore, NAL snAppShot 
substitutes this location with the variable %*WINDIR%. If another Windows 95 workstation uses a different 
Windows directory (for example, C:\WIN95), then the UNINST.EXE file is still copied to the correct location.

The Netscape installation also copies NETSCAPE.EXE to the C:\NETSCAPE directory. NAL snAppShot makes a 
copy of this file, renames it "2.FIL," and stores it in the source path. An entry is made in the .AOT file to copy 
%SOURCE_PATH%\2.FIL to %TARGET_PATH%\NETSCAPE.EXE. Remember that the target path is the one that
you specified earlier (C:\NETSCAPE). Because NETSCAPE.EXE is copied to this directory, %TARGET_PATH% is
substituted.

The Netscape installation adds a value to the Windows Registry. NAL snAppShot adds a corresponding entry to 
the .AOT file, which creates the same value. As the Registry value is added to the .AOT file, it goes through the 
same macro variable replacement process as application files. This is because Registry values, like application 
files, might have pathnames.

NOTE: The following rules are used when macros replace text: Only one replacement per line is allowed and the 
text that is replaced must start at position number one. Check and correct the Registry values once a .AOT file is 
imported into an Application object for any pathnames that are not replaced by macros.

During the Netscape installation, a Shortcut is added to the Start Menu. Most Shortcuts in Windows 95 and 
Windows NT** 4.0 are .LNK files. NAL snAppShot looks inside a Shortcut or .LNK file to get the name, pathname 
and other information. Because Shortcut attributes have pathnames, NAL snAppShot replaces them with macros 
and then makes an entries in the .AOT file. NAL snAppShot supports the following macros:

%*WINDIR%
%*WINSYSDIR%
%*WINSYS16DIR%
%*WINDESKTOP%
%*STARTMENU%
%*COMMONWINDESKTOP%
%*COMMONSTARTMENU%
%TARGET_PATH%.
%SOURCE_PATH%

See the Macros and Variable Examples topic in the NAL Snap-In Help for more information.
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Using NAL snAppShot: A Procedural Overview

The following steps explain how to use the Novell* Application Launcher* snAppShot ("NAL" snAppShot) 
component, including how to compare the pre- and post-installation states of a workstation, how to create 
Application Object Template (.AOT) and .FIL files, and how to make those files available to NetWare* Administrator
using NAL Snap-In.

To use NAL snAppShot and make .AOT and .FIL files available to NAL Snap-In

1. Find a workstation that is representative of the ones on your network to which you will distribute applications.

NOTE 1: Although no two workstations are exactly the same, find a workstation that is configured similarly to 
the other target workstations. The more representative the workstation is, the fewer manual setup procedures 
you need to do during and after distribution.

NOTE 2: Ensure that the application you are going to install is not already installed on the representative 
workstation. If the application is already installed on the workstation, NAL snAppShot cannot accurately record 
changes.

2. For best results, close all other applications on the workstation.

3. Run NAL snAppShot by executing the SNAPSHOT.EXE file from the directory where you installed it; then read 
the introductory screen, and click Next.

4. Add information about the name of the application you are going to install, including a short description, and 
then click Next.

NOTE: The name you provide becomes the Application object name in NAL Snap-In. The description you 
provide becomes the text found beneath the icon that represents the application. You can change the name 
and text from NAL Snap-In.

5. Specify the network directory and filename of the .AOT and the directory for the .FIL files that will be created as
a result of running NAL snAppShot. Also specify the Windows** Drive and Boot Drive. Click Next.

IMPORTANT: If you are going to use NAL snAppShot again to discover the changes of additional application 
installations, we recommend creating unique directories on the network for each application. If you don't use 
unique source directories, .AOT and .FIL files could be overwritten.

6. Specify which files and directories you want to include or exclude during the NAL snAppShot discovery 
process, and then click Next.

For example, because you might not want to record the changes to the Windows 95** Recycle Bin as a result 
of installing an application, you can exclude this directory from the discovery process.

7. If you are ready to take the pre-installation snapshot of the workstation, click Next. 

OR

Click Back to check or change a previous setting.

The pre-installation discovery process records all current files and configurations on the workstation and stores
the information in a hidden file. When NAL snAppShot finishes the pre-installation discovery, it is ready for you 
to run the application's Setup program.

8. Click Run Setup, browse for the application's Setup program, highlight it, and then click Open.

NOTE: Suppose that the location where you installed the application on the "discovery" workstation is different 
than the actual target workstation directory that NAL Snap-In uses to distribute applications on your network. If 
this is the case, you can "redirect" the installation by specifying the target directory on the Install dialog box. 
This causes NAL Snap-In to set up an automated routine that redirects files during the distribution process. To 
redirect installed files to a different target directory when distributing applications, specify the path in the text 
box, and then click Next.

NAL snAppShot performs the post-installation discovery, noting any changes made to the files and 
configurations on the workstation as a result of the application's Setup program. The differences between the 
pre-installation and post-installation workstation states are stored as a .AOT file and a series of .FIL files 
(depending on the number of files included in the installation). These files are placed in the directory locations 
that you specified earlier.



9. The discovery process is complete. Click Exit to close NAL snAppShot.

To create an Application object using the .AOT and .FIL files that you generated

1. Start NetWare* Administrator.

2. Right-click the Organization or Organizational Unit object under which you want to create an Application object 
and click Create. Select Application and then click OK.

3. Select Use This Wizard With An Application Object Template, and then click Next.

By default, NAL Snap-In looks in SYS:\PUBLIC\NALLIB\AOTFILES for the .AOT file. See Accessing .AOT Files
in NAL Snap-In for more information.

4. Browse for the .AOT file, if necessary, and then click Next.

5. Check (and change if necessary) the target and source directories of the Application object, and then click 
Next.

6. Review the information about the Application object, and then click Create.

7. Associate the Application object with a User, Group, Organization, or Organizational Unit object. To associate 
an application, right-click the Application object, click Details, and then click the Associations button. Use this 
property page to assign other objects to the Application object.
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Accessing .AOT Files in NAL Snap-In

After you run Novell* Application Launcher* snAppShot ("NAL" snAppShot) on the representative workstation, you 
need to make Application Object Template (.AOT) files available to NetWare* Administrator using the NAL Snap-
In. Do this by designating a network directory that you can access later when creating and setting up Application 
objects.

By default, NAL Snap-In looks for the .AOT files in SYS:\PUBLIC\NALLIB\AOTFILES. However, you can 
store .AOT files in any directory you want (although we recommend that you designate a unique network directory 
for each time you run NAL snAppShot).

To access .AOT files in NAL Snap-In

1. Place the .AOT files in SYS:\PUBLIC\NALLIB\AOTFILES.

OR

2. Create a .INI file named APPSNAP.INI and place it in the same directory where APPSNP??.DLL is located. The
.INI file should look like this:

[AOTFILES]

path=<PATH>

where <PATH> are the directories where NAL Snap-In looks for .AOT files.
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Naming and Describing the Application

Use the text boxes in the Application Information dialog box to describe the application that you are going to install.
Type the name of the application in the first text box and type a short description in the second text box.

For example, if you are installing Netscape**, type "Netscape" in the first text box and "Netscape 3.0 for 
Windows** 95** and Windows NT**" in the second text box. Or, if you are installing Microsoft** Office, type 
something similar to "Microsoft Office workstation installation" or "Microsoft Office network installation" in the 
second text box.

IMPORTANT: Because Novell* Directory Services* (NDS*) software uses the name you specify for the application 
as the default Application object name, you cannot name the application using a period (.), equals sign (=), or plus 
sign (+). If you do use these characters, NDS will not be able to create the object.
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Specifying Source Directories for .AOT and .FIL Files

Use the text boxes in the Configuration Information dialog box to specify details about how the workstation will be 
configured. 

Template File to Create
Type the complete path and filename of the Application Object Template (.AOT) file that the Novell* Application 
Launcher* snAppShot ("NAL" snAppShot) component creates. As a convenience, NAL Snap-In looks in the default
location SYS:\PUBLIC\NALLIB\AOTFILES for .AOT files.

NOTE: If you don't include the .AOT extension, you will have a harder time finding the file later when importing 
template information into Application objects.

Directory for Application Files
Specify the name of and path to the directory where you want to make a copy of all installed files that are installed 
on the workstation as a result of running the application's Setup program. These files are renamed as .FIL files. 
Application objects use this directory to specify the source directory for copying files from the server to the 
workstation. For convenience, we recommend that you place both the .AOT file and .FIL files in the same network 
directory. This network directory should be different than other directories where you plan to store .AOT and .FIL 
files.

IMPORTANT: If you are going to use NAL snAppShot again to discover the changes of additional application 
installations, we recommend creating unique source directories. If you don't use unique source directories, source 
files could be overwritten.

Windows Drive
The Windows Drive option specifies the drive on which Windows** is installed. In some cases with Windows 3.x, 
this could be a network drive. NAL snAppShot automatically detects the Windows Drive, so you probably don't 
need to change it.

Boot Drive
The Boot Drive option specifies where the AUTOEXEC.BAT and CONFIG.SYS files reside. NAL snAppShot does 
not detect the Boot Drive, so it is important to make sure that the drive specified is correct.
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Including and Excluding Files during the Discovery Process

Often there are files or directories on a workstation that do not require the Novell* Application Launcher* 
snAppShot ("NAL" snAppShot) discovery process. For example, there is no need to discover the changes in the 
Windows** 95** Recycle Bin. By the same token, there could be directories or files that do require evaluation that, 
by default, NAL snAppShot is not aware of.

For special cases such as these, you can use the Include/Exclude dialog box to pinpoint the files, disk drives, and 
directories that you want to include or exclude in the discovery process.

Exclude Files
This text box lists the files to exclude during the snapshot. To remove a file from this list, highlight the filename and
then click Remove. To exclude a file, click Add, highlight the file you want to exclude, and then click Open.

Drives to Include
This text box lists the disk drives to include during the discovery process. To remove a disk drive from this 
discovery inclusion list, highlight the drive letter and then click Remove. To include a disk drive, click Add, highlight 
the disk drive you want to include, and then click Open.

Exclude Directories
This text box lists the directories to exclude during the snapshot. To remove a directory from this list, highlight the 
directory and then click Remove. To exclude a directory, click Add, highlight the directory you want to exclude and 
then click Open.

Text Files to Compare
This text box lists the text files to compare after the pre- and post-installation discovery process. "Text files," in this 
case, means CONFIG.SYS, AUTOEXEC.BAT, .INI and any other text-based configuration file; however, because 
NAL snAppShot scans all .INI files by default, you do not have to specify .INI files in the Text Files to Compare 
option.

To remove a text file from this list, highlight the text file and then click Remove. To add a text file, click Add, 
highlight the text file you want to compare, and then click Open.
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Running the Application's Setup Program

The Run Setup Program dialog box signals that Novell* Application Launcher* snAppShot ("NAL" snAppShot) is 
ready to run the Setup program of the application you are installing.

To run the Setup program

1. Click the Run Setup button, highlight the setup program for the application, and then click Open.

OR

2. In Windows** 95**, click Start    > Run, highlight the Setup program, and then click OK.

OR

Run the Setup program from a menu or a command prompt.

When the Setup program is complete, the post-installation NAL snAppShot discovery process begins.

IMPORTANT: It is possible that the application's Setup program requires the workstation to reboot. Sensing a 
reboot, NAL snAppShot asks you whether you want to discover (or record) changes immediately or wait until after 
the reboot.

If the reboot is part of the Setup program's installation process, let the Setup program reboot the workstation and 
finish setting up the application, then begin the NAL snAppShot post-installation discovery process. When you 
reboot, NAL snAppShot starts when the workstation comes back up, picking up where it left off. You can also close
NAL snAppShot and start it again later; it still picks up where it left off.
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Automating the Target Workstation Installation Directory

Suppose that the location where you installed the application on the representative workstation is different than the
actual target directory that NetWare* Administrator using the Novell* Application Launcher* Snap-In ("NAL Snap-
In") uses to distribute applications.

If this is the case, you can redirect the installation by simply specifying the target directory on the Install Directory 
dialog box. This causes NAL Snap-In to automatically redirects files before the distribution process.

For example, suppose you installed Netscape Navigator** to C:\APPS\NETSCAPE while running NAL snAppShot. 
However, when you distribute the application, you want to install it to C:\PROGRAM FILES\NETSCAPE. To 
automate the process of changing the installation directory, type the path to the directory you want in the text box 
provided.

NAL Snap-In records the C:\PROGRAM\FILES\NETSCAPE location as a macro (%TARGET_PATH%). The 
Source directory that you specified earlier is also entered as a macro (%SOURCE_PATH%), which is used in file 
paths in the Application Files, Registry, .INI, and other property pages in NAL Snap-In.

See Also
Example of Using NAL snAppShot
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What Is an Application Object Template (.AOT) file?

Think of the .AOT file as a "change log" that contains the differences between the pre- and post- application 
installation states of a workstation. NAL snAppShot discovers these differences and records them in the .AOT file. 
You can use this .AOT file later when creating and setting up Application objects using NAL Snap-In for large-scale
distribution.

Specifically, a .AOT file includes the following information:

Registry changes
.INI file changes
Text file changes
A list of files to be copied
Application object name and description

See also What Is a .FIL file?



What Is a .FIL file?

.FIL files represent the application files that are installed on a workstation's hard disk drive.

For example, 3.FIL could represent C:\APPS\NETSCAPE\PROGRAM\NETSCAPE.EXE and would be the same 
size as the executable. In essence, 3.FIL is NETSCAPE.EXE renamed. There is a .FIL file for each file a Setup 
program copies to the hard disk drive. For convenience later when you create Application objects, we recommend 
that you store .FIL files in the same place as the .AOT file.

The FILEDEF.TXT file, which is created in the same directory where the .FIL files are created, lists all the .FIL files 
that are created as a result of using NAL snAppShot.

A list of the .FIL files that need to be copied to run an application is kept in the .AOT file.

See also What is an Application Object Template file?
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What Is NAL Window?

The Novell* Application Launcher* ("NAL" Window) is part of a software delivery process that lets your 
administrator distribute and centrally manage the applications that you see at your workstation in the NAL Window.

By using applications through the NAL Window, you can expect faster resolution to problems that you might 
encounter while using the applications. For example, if drives or ports are not correct, or if your software needs to 
be upgraded, administrators can address the problem far quicker than if they had to come and visit your 
workstation.

Your administrator assigns applications to Users, Groups, Organizations or Organizational Units in Novell 
Directory Services* (NDS*) software. These categories correspond to the folders you see in the NAL Window. For 
example, if your administrator assigns an application to you directly, you can find the application in your User 
folder. If your administrator assigns an application to a Group and you are a member of that Group, you can find 
the application in the corresponding Group folder, and so on. These assignments depend upon on your User 
object's rights and inherited settings in the NDS tree.

To launch an application, double-click its icon in the NAL Window.

As applications become available or are upgraded, you can access them through the NAL Window by choosing 
View > Refresh or pressing F5. Your administrator or your fellow Users might notify you of application upgrades.
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Running Applications from NAL Window

All available applications are presented in the Novell* Application Launcher* ("NAL" Window). If you do not see an 
application that you need to access, it is possible that your User object has not been associated with the with the 
Application object. Contact your administrator for further assistance.

To launch an application, double-click the application icon. If you receive any error messages, contact your 
administrator.

 * Novell trademark.    ** Third-party trademark.    For more information, see Trademarks.



Receiving the Latest Version of an Application

Use the Verify option to update an application on your workstation that your administrator previously distributed 
through the Novell* Application Launcher* ("NAL" Window) software.

For example, when you run an application in the NAL Window for the first time, application files and configuration 
settings are copied or "distributed" to your workstation. Any time after you run the application, the Verify option is 
available. Suppose you accidentally delete some of the files or settings for the application, rendering it inoperable. 
If this happens, use the Verify option to quickly restore the application files and configuration settings.

Administrators might also update the application automatically without your knowledge. For example, if 
administrators want all Users of an application to have the latest upgrade, they could upgrade the version in the 
Application object's definition and redistribute the application. This procedure has no effect on you as the User.

To verify an application

1. Right-click an application.

2. Choose Verify.
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Resizing or Moving NAL Window

You can resize and move the Novell* Application Launcher* ("NAL" Window) if your administrator gives you the 
necessary rights.

You can resize, move, minimize, and maximize the NAL Window in the same way that you would other windows in
Windows** 3.x, Windows 95**, or Windows NT**.

To change the size of the left- or right-hand panes in the NAL Window (made available by choosing View > 
Folders), position the insertion point on the border between the two panes, and then drag the border to the left or 
right.
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Changing the Icon Display in the NAL Window

You can change how application icons are displayed in the Novell* Application Launcher* ("NAL" Window) in the 
following ways.

NOTE: You cannot control the actual icon picture, only the size, order, or details of the icon. Your administrator 
controls the icon picture through the NAL Window.

To refresh icons, choose View > Refresh or press F5 (your administrator controls the automatic refresh rate).

To display large icons, choose View > Large Icons.

To display icons as a list without details, choose View > List.

To display small icons, choose View > Small Icons.

To display details about all the applications in the NAL Window, choose View > Details.
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Creating a Personal Folder

You can create and delete personal folders in the Novell* Application Launcher* ("NAL" Window) if your 
administrator has given you permission to do so. Personal folders let you rearrange applications as you see fit.

To create a personal folder

1. Choose File > New Personal Folder.

2. Enter a name for the folder, and then click OK.

To rearrange applications into a personal folder

1. Click the [All] icon in the left-hand pane of the NAL Window.

NOTE: The left- and right-hand panes of the NAL Window appear by choosing View > Folders.

2. Drag the applications you want from the right-hand window pane into the folder in the left-hand window pane. 
You cannot drag and drop multiple applications.
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Renaming a Personal Folder

You can rename personal folders after you create them.

To rename a personal folder

1. Right-click the folder, and then choose Rename Folder.

2. Type a new name for the folder, and then click OK.
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Viewing Application Descriptions

Your administrator might have provided a description of an application displayed in the Novell* Application 
Launcher* ("NAL" Window).

To view an application description

1. Right-click the application icon.

2. Choose Properties > Description tab.

Tree Name is the name of the Novell Directory Services* (NDS*) tree where the application is located.

NDS Object Name shows where the Application object is located in NDS.
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Viewing Application Contact Information

Your administrator might have assigned a contact person or specialist for an application to help you troubleshoot 
problems.

To view the contacts for an application

1. Right-click the application icon.

2. Choose Properties > Contacts tab.

3. Call the contact if the phone number is available.

4. Click E-mail to send the contact an e-mail message.

NOTE:    The E-mail button is available only if there's an address in the E-mail field and a MAPI-compatible e-mail 
application is installed on your workstation. If you have questions about e-mail, contact your administrator.
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Viewing Folder Information

You can view basic information about an application folder, which is useful when you and your administrator are 
troubleshooting problems.

To view basic information about a folder

1. Right-click a folder.

2. Click Folder Properties.

Type indicates whether the folder is a System folder or Personal folder. A System folder is created by the 
administrator and a Personal folder is created by you.

Name specifies the folder name.
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Viewing System Folder Properties

You can view property information that is specific to System folders.

To view System folder properties

1. Right-click a System folder.

2. Click Folder Properties > System tab.

Tree Name indicates which Novell* Directory Services* (NDS*) tree contains the applications listed in this folder.

NDS Object Name shows which Users, Groups, Organizations, and Organizational Units have rights to the 
applications listed in this folder.

Object Type shows the class of the object selected in the NDS Object Name field. Using this information, you can 
tell if the System folder is based on a User, Group, Organization, or Organizational Unit class object.
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Exiting the NAL Window

To exit the Novell* Application Launcher* ("NAL" Window), choose File > Exit or press Alt+F4. If your administrator 
has set up the NAL Window to run as a shell program, exiting the NAL Window also shuts down Windows**.

NOTE: Your administrator controls your right to exit the NAL Window.

 * Novell trademark.    ** Third-party trademark.    For more information, see Trademarks.
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What Is NAL Explorer?

The Novell* Application Launcher* Explorer ("NAL" Explorer) is part of a software delivery process that lets your 
administrator distribute and centrally manage the applications that you see at your Windows** 95** or Windows 
NT** workstation.

You access the applications your administrator sets up for you through NAL Explorer, which displays application 
icons in a special NAL Explorer window, Windows Explorer and on the Start menu, System Tray, and Desktop. 
You can create personal folders for the applications that have been assigned to you, and drag application icons 
from NAL Explorer window to the Desktop.

By using applications through NAL Explorer, you can expect faster resolution to problems that you might 
encounter while using the applications. For example, if drives or ports are not correct, or if your software needs to 
be upgraded, administrators can address the problem far quicker than if they had to come and visit your 
workstation.

Your administrator assigns applications to User, Group, Organization or Organizational Unit objects in Novell 
Directory Services* (NDS*) software. These categories correspond to the folders you see in NAL Explorer. For 
example, if your administrator assigns an application to you directly, you can find the application in your User 
folder. If your administrator assigns an application to a Group and you are a member of that Group, you can find 
the application in the corresponding Group folder, and so on. These assignments depend on on your User object's
rights and inherited settings in the NDS tree.

As applications become available or are upgraded, you can access them through NAL Explorer by choosing View 
> Refresh or pressing F5. Your administrator or fellow users might notify you of application upgrades.
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What Is the System Tray?

The System Tray is an area on the Windows 95 or Windows NT 4.0 Taskbar where small icons, representing 
applications, are placed for easy access. NAL Explorer can display or remove applications on the System Tray at 
any time.



Running Applications from NAL Explorer

All available applications are presented in the Novell* Application Launcher* Explorer ("NAL" Explorer). If you do 
not see an application that you need to access, it is possible that your User object has not been associated with 
the with the Application object. Contact your administrator for further assistance.

To run applications, double-click their icons in NAL Explorer or the Desktop. Or single click them on the System 
Tray or Start menu. If you receive any error messages, contact your administrator.
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Receiving the Latest Version of an Application

Use the Verify option to update an application on your workstation that your administrator previously distributed 
through the Novell* Application Launcher* Explorer ("NAL" Explorer).

For example, when you run an application in NAL Explorer for the first time, application files and configuration 
settings are copied or "distributed" to your workstation. Any time after you run the application, the Verify option is 
available. Suppose you accidentally delete some of the files or settings for the application, rendering it inoperable. 
If this happens, use the Verify option to quickly restore the application files and configuration settings.

Administrators might also update the application automatically without your knowledge. For example, if 
administrators want all users of an application to have the latest upgrade, they could upgrade the version in the 
Application object's definition and redistribute the application. This procedure has no effect on you as the user.

To verify an application

1. Right-click an application in the NAL Explorer window or in Windows Explorer.

2. Choose Verify.

* Novell trademark.    ** Third-party trademark.    For more information, see Trademarks.



Changing the Icon Display in NAL Explorer

You can change how application icons are displayed in the Novell* Application Launcher* Explorer ("NAL" 
Explorer) in the following ways.

NOTE: You cannot control the actual icon picture, only the size, order, or details of the icon. Your administrator 
controls the icon picture through NAL Explorer.

To refresh icons, choose View > Refresh or press F5 (your administrator controls the automatic refresh rate).

To display large icons, choose View > Large Icons.

To display small icons, choose View > Small Icons.

To display icons as a list without details, choose View > List.

To display icon details, choose View > Details.

To arrange icons, choose View > Arrange Icons > Auto Arrange.

To display details about all the applications in NAL Explorer, choose View > Details.
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Creating a Personal Folder

You can create and delete personal folders in the Novell* Application Launcher* Explorer ("NAL" Explorer) if your 
administrator has given you permission to do so. Personal folders let you rearrange applications as you see fit.

To create a personal folder in NAL Explorer

1. Open the Personal folder.

2. In the Personal window, choose File > New Personal Folder.

A new folder called "New Folder" is created.

3. Right-click the New Folder and choose Rename.

4. Type a new name and press Enter.

To create a personal folder in Windows Explorer

1. Highlight    the Personal folder underneath the NAL Explorer folder.

2. Choose File > New Personal Folder.

A new folder called "New Folder" is created.

3. Right-click the New Folder and choose Rename.

4. Type a new name and press Enter.

To add applications into a personal folder

1. Drag the applications you want from the right-hand window pane into the folder in the left-hand window pane. 
You can drag and drop multiple applications.
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Renaming a Personal Folder

You can rename personal folders after you create them.

To rename a Personal folder

1. Click the Personal folder twice.

2. Type a new name for the folder, and then press Enter.
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Viewing Application Descriptions

Your administrator might have provided a description of an application displayed in the Novell* Application 
Launcher* Explorer ("NAL" Explorer).

To view an application description

1. Right-click the application icon.

2. Choose Properties > Description tab.

Tree Name is the name of the Novell Directory Services* (NDS*) tree where the application is located.

NDS Object Name shows where the Application object is located in NDS.
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Viewing Application Contact Information

Your administrator might have assigned a contact person or specialist for an application to help you troubleshoot 
problems.

To view the contacts for an application

1. Right-click the application icon.

2. Choose Properties > Contacts tab.

3. Highlight the name of the person.

4. Call the contact if the phone number is available.

5. Click E-mail to send the contact an e-mail message.

NOTE:    The E-mail button is available only if there's an address in the E-mail field and a MAPI-compatible e-mail 
application is installed on your workstation. If you have questions about e-mail, contact your administrator.
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Viewing Folder Information

You can view basic information about an application folder, which is useful when you and your administrator are 
troubleshooting problems.

To view basic information about a folder

1. Right-click a folder.

2. Click Folder Properties.

Type indicates whether the folder is a System folder or Personal folder. A System folder is created by the 
administrator and a Personal folder is created by you.

Name specifies the folder name.
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Viewing System Folder Properties

You can view property information that is specific to System folders.

To view System folder properties

1. Right-click a System folder.

2. Click Folder Properties > System tab.

Tree Name indicates which Novell* Directory Services* (NDS*) tree contains the applications listed in this folder.

NDS Object Name shows which User, Group, Organization, and Organizational Unit objects have rights to the 
applications listed in this folder.

Object Type shows the class of the object selected in the NDS Object Name field. Using this information, you can 
tell whether the System folder is based on a User, Group, Organization, or Organizational Unit class object.
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