
                     HP DeskScan II v2.7 Information

This document contains information about HP DeskScan II v2.7 that has been 
updated after the regular documentation was printed.

Topics discussed in this document include: 

* Upgrading from an earlier version of DeskScan
* The DESKSCAN.INI file
* The HPDS23.INI file
* Scanning for ColorSmart printer drivers
* Scaling images scanned with a transparency adapter
* Making sure that TWAIN file versions are correct
* How to install DeskScan II with Norton Desktop 
* DeskScan II and OS/2
* DeskScan II and OLE
* Removing DeskScan II from your computer
* If your Computer has NO Compatible IRQs (Windows 95 Only)

Upgrading from an earlier version of DeskScan

The Setup program for DeskScan II v2.7 automatically upgrades earlier versions of 
DeskScan software. 

Version 2.7 includes an HP ScanJet driver for ASPI- and CAM- compatible SCSI cards.  
This driver is for use ONLY with the HP ScanJet 6100C, 5p, 4c, 4p, 3c, IIcx, IIc, 3p or IIp
scanners.  This driver will not function correctly with the original ScanJet (HP9190A) 
or ScanJet Plus scanners.

If you already have an ASPI or CAM SCSI card, the new driver provides the 
advantages of using one less interface card slot and using less expansion ROM 
memory space.

When you upgrade to Version 2.7, the existing DESKSCAN.INI file is saved as 
DESKSCAN.BAK.  If you have calibrated print paths that you want to save from the 
previous version of DeskScan, you can recover them from the DESKSCAN.BAK file. 
(See the "DESKSCAN.INI file" section below for more information on recovering old 
calibration files.)

The DESKSCAN.INI file

This is the DeskScan II "initialization" file.  It stores DeskScan's default settings and 
any custom settings you specify to DeskScan as you run the program.

This file MUST reside in the DESKSCAN directory (the directory where you installed 
DeskScan II).
  
This file is not intended for modification by any program other than DeskScan.  
However, if you have created custom calibrations for your printers or applications in 
an earlier version of DeskScan, you can copy them to the new DESKSCAN.INI file.

To do this, open the old version (DESKSCAN.BAK) and the new version 



(DESKSCAN.INI) as ASCII files in a text editor.  Copy all the lines under the 
[Calibrations] section in the .BAK file under the [Calibrations] section in the .INI file.  
Don't leave any blank lines after the [Calibrations] line.

If you installed the new version of DeskScan II over the old version, all the calibration 
files will be available.  If you have installed DeskScan II into a new directory, you 
must copy all the file names called out under the [Calibrations] section from the old 
directory to the new.

The HPDS23.INI file
  
This file resides in the WINDOWS directory and is used so that the HP DeskScan II 
TWAIN data source can find the main DeskScan II program file.  It maintains the 
directory name where you installed DeskScan II.

If this file becomes corrupted, DeskScan II displays an error message. To restore the 
file, copy the original version from the DESKSCAN directory to the WINDOWS 
directory.

If you rename the DESKSCAN directory (the directory where you installed DeskScan 
II), run DeskScan II by double-clicking the icon in the DeskScan II Program Manager 
Group BEFORE trying to run DeskScan II through TWAIN.  This will allow DeskScan II 
to update the path in the HPDS23.INI file.

New Scanning Default Gamma 2.2

In order to better support industry standards for gamma correction, the new industry 
standard for gamma correction on personal computers is 2.2, replacing the old 
default of 1.8. Select this calibration file from within the Printer Calibration section of 
the Custom Print Path dialog box; this is also the new ColorSmart default (see below).
This standard (known as sRGB) provides better compatibility with default settings for 
computer monitors and printers.

DeskScan II still provides the ability to define a gamma of 1.8 using the Gamma 1.8 
calibration (formerly Default Gamma 1.8). Use this calibration file if you want 
backward compatibility with all of your old images.

Scanning for ColorSmart printer drivers

DeskScan II includes a special calibration file to help you achieve better colors when 
printing to your color printer using a ColorSmart printer driver.  Select this calibration 
file from within the Printer Calibration section of the Custom Print Path dialog box.

If the colors on your print-out do not closely match the original, try to create a 
custom print path for your printer and select "ColorSmart" in the Printer Calibration 
combo box.
  
If your printer is a 300 dpi device, we suggest that you enter "300" in the "Drawings 
and Halftones" text box and "100" in the "Photos" text box.

If you have a 600 dpi printer, we suggest that you enter "600" in the "Drawings and 
Halftones" text box and "150" in the "Photos" text box.  Remember to name and 
"Add" your new print path before leaving the dialog.



  
For general information about how to create a custom Print Path for your printer that 
can be selected from the "Path" combo box on the DeskScan II front panel, please 
refer to chapter 4 in the DeskScan II User's Guide.

Scaling images scanned with a transparency adapter

The HP ScanJet 6100C, 4c, 3c and IIcx scanners support scanning from a 
transparency adapter (the /T). 

Under some circumstances while scaling an image, minor defects common to all CCD 
scanners may become more noticeable.

If you are confronted with this problem, scan the image at 50, 100, 150, 200, 300, 
400, 600, or 800 dpi.  Then, transform the image to the desired resolution by 
"resampling" it with an image editor such as Corel PHOTO-PAINT or Adobe Photoshop.

This will reduce or remove any CCD-related defects.

Making sure that TWAIN file versions are correct

It is important to the operation of DeskScan II that old versions of the DeskScan 
TWAIN data source files do not attempt to launch DeskScan II.

The best way to do this is to delete old TWAIN data source files from your system, or 
move them to a safe place as specified below.

* To move the old files to a safe place, create a directory in the WINDOWS 
directory called

TWAINOLD.  Copy any file named HPDSxx.DS from the WINDOWS\TWAIN 
directory into

WINDOWS\TWAINOLD.  Then delete the HPDSxx.DS file from the WINDOWS\
TWAIN

directory.

* To delete old versions, look into the WINDOWS\TWAIN directory.  Delete any 
file named

HPDSxx.DS.

NOTE:  If you have an older version of DeskScan II on your system, the default TWAIN
data source will be updated to use the new 32-bit DeskScan.  The older version 
HPDSxx.DS in the WINDOWS\TWAIN directory will be renamed to HPDSxx.OLD.

How to install DeskScan II with Norton Desktop

If you are running MS Windows using the Norton Desktop as the shell, HP 
recommends that you  install DeskScan II using the default directory, C:\DESKSCAN.  
If you intend to install to C:\DESKSCAN, you don't need to read the rest of this 
section.

If you want to install to a different directory, you MUST change the shell to 
PROGMAN.EXE before installing DeskScan II!  (There is a compatibility issue between 



the DESKSCAN II setup and Norton Desktop.) 

Follow these steps to change the shell:

1.  From Windows, run NOTEPAD.EXE and open the SYSTEM.INI file (which is in the \
WINDOWS directory).

2.  In the [boot] section of the SYSTEM.INI file, you will find a line that reads: 
shell=ndw.exe.
Make a copy of this line and insert a ";" (semicolon) as the first character in one of 
the two lines.

3.  Change the second copy to read: shell=progman.exe

4.  Save the file, close NOTEPAD, and restart Windows.

After DeskScan II has been successfully installed, you can switch back to Norton 
Desktop by following these steps:

1.  From Windows, run NOTEPAD.EXE and open the SYSTEM.INI file (which is in the \
WINDOWS directory).

2.  In the [boot] section, find the copy of the line with the semicolon that includes 
"shell=ndw.exe".  Remove the semicolon.

3.  Find the copy of the line you made that includes "shell=progman.exe". Delete it.

4.  Save the file, close NOTEPAD, and restart Windows.

DeskScan II and OS/2

DeskScan II v2.7 is not currently supported under OS/2.  However, call HP's 
Automated Support Access Program at 1-800-333-1917 (or 1-208-344-4809) for 
information allowing use with OS/2.

You can also check the HP Peripherals forum on CompuServe or the Internet to find 
the latest information.  
  
At any CompuServe prompt type,

"Go HPPER"

To connect via the Internet, use either the alias,

ftp-Boi.external.hp.com

or the IP address, 192.6.71.2.  Login as 'anonymous'.  Use your Internet alias as the 
password (e.g. 'yahoo@lab.hp.com').

DesksScan II and OLE

Memory Usage  The use of OLE requires a lot of memory, which may cause problems 
if you don't have enough RAM in your system.  One symptom indicating a memory 



problem is that an application may report that it is unable to find a selected server 
even though the server application is correctly registered.  (Check the registry to 
make sure.)  What is really happening is that there isn't enough memory to load the 
server and the associated system DLLs and the application assumes the failure was 
due to registration problems.

File Size  Extra data is stored with a scanned image when it's embedded in an OLE 
object. The extra data is roughly the size of the image, which may be quite large. If 
file size is a concern, you might prefer using methods other than OLE to store your 
images in documents. Try using TWAIN, paste from the clipboard, files, etc.

Win95  You might encounter problems updating a DeskScan object embedded in a 
WordPad document. You can avoid this problem by using an alternative method to 
embed images in a WordPad document as follows: run DeskScan standalone and save
an image as a .BMP file; save it to the Desktop. An icon representing the image will 
show up on the Desktop. Drag this icon into the WordPad window and drop it into the 
WordPad document. You can double click on the image to edit it. (Note that the image
doesn't have to be saved to the Desktop. You can drag an image icon from any 
directory into a WordPad document.)

Window NT 3.5  The following problem may occur if you're running Client Service for 
NetWare and Windows NT 3.5. Some container applications may lock up if you close 
the container while you have an active embedded DeskScan object. To avoid this 
problem, close the image editor before closing the document that contains the 
embedded image.

Windows NT 3.51  Write may lock up while trying to activate an embedded DeskScan 
object.

Windows NT 4.0  If Paintbrush (not PHOTO-PAINT) is your default image editor, an 
embedded DeskScan object may appear to be corrupted when you create it using 
Insert Object.  The object is not really corrupted.  To fix the object's appearance, 
double-click on the object, make a slight change to it, and it will update correctly.

Corel PHOTO-PAINT  If you've installed the Corel PHOTO-PAINT5 software, you can 
embed Corel PHOTO-PAINT objects directly into your OLE documents by selecting a 
Corel PHOTO-PAINT object in the Insert Object dialog. This starts the Corel server, 
which asks you if you want to scan an image. If you decide to scan, you can use 
DeskScan to scan an image that becomes embedded as a Corel PHOTO-PAINT object. 
This functionality is not supported in Corel PHOTO-PAINT6.  You must select DeskScan
from the Insert Object dialog.  

Removing DeskScan II from your computer

You can run UNINSTAL.EXE to remove the DeskScan II v2.7 from your system.  NOTE: 
Be sure DeskScan II v2.7 is in the same directory where you installed it.  If you have 
moved DeskScan to a different directory or drive, UNINSTAL.EXE will not work 
properly.  To manually uninstall the DeskScan II v2.7 application from your computer 
follow the steps below.

NOTE: If you have other HP ScanJet software installed on your system, you should 
skip the ScanJet Drivers section and go to the DeskScan section.

ScanJet Drivers:



a) Delete the following files in your WINDOWS\SYSTEM directory if they exist:
HPSCNMGR.DLL
HPSCNTST.DLL
HPSJ32.DLL
HPSJ16.DLL

2) Windows95 only:
Delete SCANJET.INF from the WINDOWS\INF directory

Delete the following files in your WINDOWS\SYSTEM directory if they exist:
HPSJCLAS.DLL    
VHPSCAND.VXD
HPSJ1695.DLL
REG32.DLL
HPSJRFSH.VXD

DeskScan II:
1.  Delete the following files from your WINDOWS directory:
HPDS23.INI

2.  Delete the following file from your WINDOWS\TWAIN_32 directory:
HPDS23.DS

3.  Delete all of the files in the directory where DeskScan II v2.7 was installed.

4.  Remove the directory where DeskScan II v2.7 was installed.

5.  From the Windows Program Manager, delete the Program Manager Group where 
DeskScan II v2.7 was installed.  The DeskScan II icons will be removed automatically.

DeskScan II v2.7 has been successfully removed from your computer.

If your Computer has NO Compatible IRQs (Windows 95 Only)

A. If No Compatible IRQs are Available on your Computer

Peripheral devices such as a mouse, keyboard, printer, modem, sound card, and 
floppy drive use IRQs (Interrupt Requests) to communicate with the computer 
system. The limited number of IRQs available in PCs to run these peripheral devices, 
like scanners, is an industry-wide challenge. When a compatible IRQ is not available, 
the HP ScanJet Scanner can be installed using Real Mode Drivers instead of Protected 
Mode Drivers. In most cases, the installation of Real Mode Drivers does not affect 
performance, but occasionally, users report a change in scanning speed.

Normal installation of the HP Scanning Software, on Windows 95, requires an IRQ. If 
the installer is unable to obtain an IRQ that is compatible with the HP ScanJet 
Scanner, the installer reconfigures the HP Scanning Software to run with Real Mode 
Drivers.

If you do not want to install Real Mode Drivers, you may be able to free an IRQ by 
removing another peripheral device from your computer system. In that case, you 
can remove Real Mode Drivers and reinstall your HP ScanJet Scanner using Protected 
Mode Drivers.



B. Changes to the HP Scanner Test

The HP ScanJet Scanners icon no longer appears in the Control Panel window after 
installing Real Mode Drivers.

To start the HP Scanner Test:

* Choose Start > Programs > HP Scanning Software (or directory where you 
installed HP Scanning Software) > HP Scanner Test.
OR
* Choose Start > Programs > HP DeskScan II (or directory where you installed 
HP Scanning Software) > HP Scanner Test.

C. Checking for Real Mode Driver Installation

To determine whether Real Mode Drivers have been installed:

1. Choose Start > Settings > Control Panel.

2. Double-click the System icon.

3. Click on the Device Manager tab.

4. Scroll down the list of devices until you reach HP ScanJet Scanners.

5. If Real Mode Drivers are installed, the scanner entry is:

"HP ScanJet (on SYM53C416) using Real Mode Drivers"

D. If You Prefer to Free A Compatible IRQ

Installing Real Mode Drivers is the easiest way to run your HP ScanJet Scanner when 
no compatible IRQs (Interrupt Requests) are available. The HP ScanJet scanner uses 
one of the following IRQ addresses: 4, 5, 7, 10, 11, 12, or 15.

If you prefer to free one of these compatible IRQs, you may do so by disabling 
another device on your computer. For example, of the two communication ports 
(COM Ports) on your computer, one is needed for a modem, but the second COM Port 
may not be in use. You could disable one of the following devices:

* Modem

* Sound card

* Sound, video, or game controller

NOTE: Once you disable a device, the device is not available for use.

To disable a device:

1. Choose Start > Settings > Control Panel.

2. Double-click System icon.

3. Click on the Device Manager tab.



4. In the Device Manager window, double-click on the device to be disabled.

Steps 5-7 may differ for different versions of Windows 95:

5. Click on the General tab.

6. In the Device Usage area, 

* For Windows 95 Version A: Uncheck the box next to the current configuration. 
(If there is more than one configuration listed in the Device Usage area, uncheck the 
box next to each configuration.)

* For Windows 95 Version B: Check the box next to Disable in this hardware 
profile.

7. Click OK.

8. Close all windows.

9. Restart your computer.

After you uninstall the Real Mode Drivers and disable a device to free a 
compatible IRQ, you must reinstall Protected Mode Drivers from your HP Scanning 
Software.

Continue with Section E, below to remove Real Mode Drivers.

E. Uninstalling Real Mode Drivers

To uninstall Real Mode Drivers:

1. Choose Start > Run.

2. Type sysedit, then press Enter.

A series of overlapping windows appear.

3. Click on the CONFIG.SYS window to bring it to the front.

4. Scroll down the window to find and remove the following lines:

"DEVICE=C:\WINDOWS\SYSTEM\aspi416.sys/OVERRIDE /NO_IRQ_/IO=###"
(where ### is a valid beginning IO Port)

"DEVICE=C:\WINDOWS\SYSTEM\sjiix.sys"

5. From the System Configuration Editor menu, choose File > Save.

6. Choose Start > Settings > Control Panel.

7. Temporarily disable Button Manager by holding down Alt + Ctrl + Delete.  The 
Close Program box appears.  Select HPSJBMGR.  Click End Task.

8. Double-click the System icon.



9. Click the Device Manager tab.

10. Scroll down the list of devices until you reach HP ScanJet Scanners.

11. Remove the line (select the line and click Remove):

"HP ScanJet (on SYM53C416) using Real Mode Drivers"

12. In the Confirm Device Removal window, click OK to remove Real Mode Drivers.

13. Scroll down the list of devices until you reach SCSI Controllers.

14. Remove the line (select the line and click Remove):

"Symbios Logic 53C416 SCSI Adapter (for HP ScanJets)"

15. In the Confirm Device Removal window, click OK.

16. Choose Start > Programs > Windows Explorer.

17. Choose View > Options and select the View tab.

18. Make sure the checkbox for Show all files is checked, then click OK.

19. Delete the files:

\windows\system\aspi416.sys
\windows\system\sjiix.sys

20. Close all windows.

21. Restart your computer.


