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This version of the Live Owners Manual, con-
taining only the introductory chapters, is 
electronically distributed with all demo ver-
sions of Live. The Live Package contains a 
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Welcome to Ableton Live

Welcome and thank you for purchasing Ableton Live!

Live is the result of musicians wanting a better way to perform live, improvisa-
tional music using a computer. A lot of effort has been put into making it intui-
tive and easy to use, yet still capable of helping you create music as complex as 
you want it to be. Live is meant to be an instrument – something that allows truly 
musical expression.

We hope you enjoy using Live in all of your music-making experiences. And we 
welcome your suggestions about how we can make Live better for you. 
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1. Installing and Setting Up Live 

Before you install Live, make sure your computer fulfills 
these minimum requirements:

Macintosh System Requirements

• G3 Macintosh or faster.
• 128 megabytes of RAM or more.
• CD-ROM drive.
• MacOS 8.6 or later.
• 256 color monitor or better, 800 x 600 pixels or 

larger.

PC System Requirements

• 300 MHz CPU or faster.
• 64 megabytes of RAM or more (128 MB recom-

mended).
• CD-ROM drive.
• Windows 95, 98, NT 4.0 or 2000 or later.
• 256 color monitor or better, 800 x 600 pixels or 

larger.
• Windows-compatible sound card, preferably with a 

DirectX or ASIO driver.

To install the Live software, first insert the CD included 
within the Ableton Live package. Refer to the ReadMe file 
on the installation CD for specific instructions.

Copy Protection
 
Live uses what is called challenge-response copy protec-
tion. This ensures that each copy of Live runs on only one 
computer. When the Live software is installed it creates a 
challenge: a unique number that identifies the computer 
you are running Live on. When you first run Live, an Unlock 
dialog box will state the challenge. To unlock the soft-
ware, you have to type a response to this challenge into 
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the response field that is also found on the Unlock dialog. 
To obtain the response from Ableton, you have to submit 
both the challenge and the product serial number, which is 
printed on a sticker that you will find in the Live package. 
This can be done using the Ableton website, or by sending 
an e-mail, or by phoning/faxing/mailing us. Please follow 
the instructions on the unlock dialog.
  
Live will run in “unlock period” for several days until the 
response can be provided. After this period, Live cannot be 
run without the response number.

When you receive the response number from Ableton, 
please write it down. In the manual’s fist pages you will 
find a field for the response number. Under certain circum-
stances, for instance after a disk crash, Live will ask you 
for the response number again.

Setting up Live for Audio and MIDI

When you first install Live, the audio output setting will 
default to SoundManager if you are using a Macintosh, and 
MME/DirectX if you are using a Windows PC. This is a good 
thing because it ensures that Live will be making sound 
as soon as your computer is plugged into your listening 
equipment, but if you have a different sound card, you will 
have to set the Audio preferences.

Click the Audio tab. From the Device Type pop-up menu, 

Audio Preferences tab. 
Open the Preferences 
dialog by selecting Pref-
erences from the Options 
menu in Live. 
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choose the type of driver you would like to use; then, 
choose among the available soundcards from the Output 
Device Pop-Up menu. To learn more about setting the 
Audio preferences, Chapter 5.

If you intend to use a MIDI keyboard or controller, you will 
need to set the MIDI/Sync preferences to tell Live which 
MIDI interface you are using. If you are using a Macintosh, 
you will also have to have OMS 2.3.8 installed and your 
MIDI device selected in your OMS Studio Setup.

Click on the MIDI/Sync tab in the Preferences dialog. 
Select your MIDI interface from the Input Device drop-
down menu.  To learn more about setting the MIDI/Sync 
preferences, see Chapter 5 of this manual.

Now you are ready to get sound out of and MIDI in to 
Live.  

   

The MIDI/Sync Pref-
erences Tab.
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2. Getting Started

Live is the world’s first audio sequencing instrument totally 
geared towards live performance. You can jam with your 
computer. Clips can be launched from the computer key-
board or via a MIDI note and can be processed with a prac-
tically unlimited chain of plug-in effects.

Live also happens to be a sophisticated recording and edit-
ing tool that allows you to capture your improvisations, 
view them as an arrangement, and to refine them to the 
smallest detail.

Live’s time-warping engine automatically compresses or 
expands audio as it is being read from the hard drive. Loops, 
phrases, and entire works can play in sync with a master 
tempo or with external sync-sources. Because Live time-
warps audio without changing the pitch, you can inde-
pendently tune each audio clip, which allows you to use a 
selection of clips that differ not only in tempo but also in 
key. 

For a performance, or Set, you can configure a pool of 
clips as you choose, with loops, one-shot sounds or entire 
pieces. Because Live reads audio directly from the hard 
drive, clips of any length can be used in a Live Set. By set-
ting Warp Markers, you can ensure that even the sloppiest 
recording will play in sync. 

Live comes with a selection of built-in, custom-designed 
effects. You also have access to any compatible VST plug-
ins, giving you maximum flexibility when it comes to pro-
ducing unheard-of sounds in your performance. 
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The Live Interface

Live’s interface is designed to be simple in appearance and 
intuitive in use. It is composed of a number of distinct 
areas, each of which can perform more than one function. 
The main Live window is composed of five areas: 

The Document Area, the central area, shows the current 
Live Set. A Live Set is the performance document you 
create and edit with Live. A Set consists of the Session 
(Session View) and the Arrangement (Arrangement View). 
 

• The Session View is accessed from the Session 
Chooser button. 

 
 
 It contains a user-specified number of tracks. Each 

track functions not only as a pool of audio clips, 
but also like a standard mixer channel. Each track 
has full controls for volume, pan, effect send, and 
input/output routing. 

The Session Chooser.

The Live main window 
showing the Session View.
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• The Arranger View is accessed from the Arranger 
Chooser button.

 

 It allows you to edit the performance you record 
during a Live Set. The Arranger View gives you 
access to a host of non-linear editing tools. See 
Chapter 4 for a detailed description of all arrange-
ment editing options.

The Browser Area, to the left of the Document area, is 
where you will find and organize the folders of clips and 
effects that will make up a Live Set. You can switch the 
browser view between the various browsers listed below:

• The Live Effects browser contains the built-in 
Live effects. 

 

 It is accessed by the Effects Button at the upper 
left of the Browser window.

• The Plug-in Effect browser contains the VST Plug-
ins you can access from within Live. 

 

 You open this browser by clicking the Plug-in 
Effects button at the upper left of the browser 
window. 

• The last three file-shaped buttons in the browser 
view access the Files 1, Files 2, and Files 3  
browsers respectively. You can use these browsers 
to load and organize WAV and AIFF samples into a 
Live Set. 

The Arranger 
Chooser.

The Live Effects 
Chooser.

The Plug-in Effect 
Chooser.
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The Detail Area, at the bottom right portion of the screen, 
gives you additional information on aspects of the Live Set.

• The Clip View allows you to view the audio wave-
form of the clip in detail. You can also edit the 
pitch, loop length, loop offset, and you can change 
or refine the placement of the Warp Markers which 
match the tempo of each loop to the master clock. 
You can access the Clip View by clicking on the 
lower-right tab that displays the small image of a 
waveform, or simply by double-clicking a clip in 
the session or arranger view.

 

• The Track View lets you view and manipulate the 
effects that are inserted on each track. You access 
this view by clicking on the Track View tab at the 
bottom right corner of the window. The tab always 
shows the name of the currently selected track.

 

The Info Area, a square window in the bottom left portion 
of the screen, gives you information about elements of the 
interface as your mouse rolls over it.

The Control Bar contains global controls for tempo and 
clock division, synchronization, tape deck-like transport, 
and system monitoring.

Since you will tend to focus on the Session View during 
a performance, we will talk mainly about this View in the 
quick start guide.

The Clip View Chooser.

The Track View Chooser. 
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Playing a Live Set

Now that you have an idea of how Live’s interface works 
you can start playing, editing, and processing a Live Set.  
The first step in creating a Live Set is to load the clips you 
intend to use into tracks in the Session View. You do this 
by using the Browser View to locate and load clips.

Tracks

When you first open Live, you will see that the Session 
View contains eleven tracks, which appear as vertical col-
umns. The numbered tracks (Track 1, Track 2, etc.) are Clip 
Tracks, for storing and playing clips. The Clip Tracks are the 
only ones that generate audio.

Send Tracks receive signal from the Send controls on each 
Clip Track. They are used to process audio sent from the 
Clip and Send Tracks. 

The Master Track is the default destination for all tracks. It 
controls Live’s main output.   

You can add additional tracks by selecting the Insert Tracks 
command from the Edit menu. Each track consists of the 
mixer portion and the clip column, which is divided hori-
zontally into scenes. A track can have as many scenes as 
you want, each scene holding a clip, but only one clip can 
be triggered at a time for each track.

Essentially, scenes visually organize your clip pool and 
allow for multi-clip triggering options as well. By clicking 
each scene’s play button in the Master Track, you can trig-
ger every clip in that corresponding row (refer to Chapter 4 
for more information on the Session View, Tracks, and 
Scenes).

A running scene
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The mixer component at the bottom of each track has 
familiar controls for volume, pan, and send level.

Loading Clips

In the Browser Area, the Files 1, Files 2, and Files 3 buttons 
are used to open browsers to locate and organize audio 
clips. You can use the different Files browsers to set path-
ways to your audio material. In the top of the file browser 
area, you find three buttons:

•  The leftmost button, shaped like a pair of head-
phones, is for pre-listening to clips. When this 
switch is turned on, clicking on a clip in the brow-
ser will play this clip. If your audio hardware allows 
for more than one stereo output, you can pri-
vately audition clips through headphones, without 
disturbing an ongoing performance. Please refer 
to Chapter 5 to learn about setting audio prefer-
ences.

•  To make the browser go up one step in the direc-
tory hierarchy, click the middle button, which 
shows an arrow pointing up. Repeatedly clicking 
this button will bring the browser to the desktop.

• The right button, an arrow pointing down, makes 
the item that is currently selected in the view the 
new root of the browser, so you do not have to scroll 
through endless lists of unwanted subdirectories.

The Session View’s mixer 
component.
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When you locate the file folder that contains the AIFF or 
WAV audio clips that you want to use, clicking on the folder 
opens it, displaying the contents as individually named 
clips in alphabetical order. You may want to make this 
folder a new root directory by clicking the set root direc-
tory button in the browser view.

To add a clip to the Session, just select a clip from the 
browser and drag it onto a scene slot in one of the tracks. 
Using the Edit menu’s Insert Scene and Insert Track com-
mands, you can add scenes and tracks to suit your needs. 

Playing Clips

Each clip is identified by name once it is loaded into a Clip 
Track. You trigger a clip by clicking on its triangular play 
button, which changes to green to show that it is playing. 

While the clip is playing, each track displays an animated 
pie chart that shows at which point the clip is playing as it 
loops. Turn the loop off by clicking the stop button on the 
track. Triggering a clip starts the clock running, but you 
can also click the Play and Stop buttons on the Control Bar 
transport area to start and stop Live.

By setting the global quantization rate, you can let Live 
automatically correct the timing of each clip trigger (i.e. 
1/8, 1/16, 1/32, etc.). You can change the quantization 
level or turn it off altogether by using the Options menu or 
by the drop-down menu in the Control Bar. As you change 
the tempo at the Control Bar, clips will not only stretch and 
compress to match it, but trigger quantization will keep up 
as well. 

A running clip.
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Editing Clips

You can edit a clip by selecting it and switching to the 
Clip View. In the Clip View you can transpose the clip by 
semitones and cents. You can also select clip color and set 
the Launch mode (see reference guide for more on Launch 
modes). By using the Loop start, end, length, and offset 
controls you can not only change the clip length, but also 
change where the clip starts and which section of the clip 
will loop.

You can also edit the position and number of Warp Markers, 
which allows Live to sync clips of different tempos to the 
master tempo. If you are using clips that have already been 
trimmed into perfect loops, you will not have to change 
the marker positions. See Chapter 4 for more on Warp Mark-
ers.

Using Effects to Process Clips

Clicking on the Live Effects button in the Browser View 
opens the list of Live Effects. Each track can have its own 
unrestrained chain of effects. You can edit a track’s effects 
parameters by switching to the Track View. Effects can be 
dragged and dropped onto the Track View while audio is 
running with no drop-outs or pauses. 

Live Effects in the Track 
View.

The Clip View.
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When a Live Effect is added, its panel opens in the Track 
View. As more effects are added you create a processing 
chain, with audio feeding left to right from one effect to 
the next. You can rearrange the order of a chain of effects 
simply by dragging and dropping them within the Track 
View. Clicking on an effect’s title bar and pressing the 
delete or backspace key on your computer keyboard will 
remove that effect from the processing chain. 

Feel free to experiment with the Live Effects to determine 
the subtleties (or not-so-subtleties) of each one’s process-
ing powers. You can read more about the individual Live 
Effects in Chapter 6.

You can use the Plug-in Effect browser to load any avail-
able VST plug-ins to the processing chain. The original VST 
plug-in panel graphics will be replaced with a Live panel; 
all parameters of the VST plug-in are represented in the 
Live panel and work in the same way. The Edit button in 
the upper left of the effect panel opens a floating window 
that shows the original VST plug-in panel. Changing para-
meters on the floater window has the same effect as chang-
ing them in the Live panel, and vice versa. You can access 
any presets the VST plug-in may have by using the drop-
down menu to the right of the Edit button. You can assign 
any two plug-in parameters to the Live panel X-Y window 
by using the drop-down menus immediately beneath it.    

Recording and Playing Back a Live Set

By now, you should be playing a Live Set: triggering and 
editing clips at will, using the different effects, and gener-
ally making some interesting noise. By using Live’s session 
recording capability, you can also record your performance 
and play it back later, with all of your moves captured as 
part of the recording. 

Start recording by clicking the Record button in the trans-
port area of the Control Bar (the circular button). If Live 
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is stopped, clicking the Record button arms the recording 
capability so that recording begins when you start the Live 
master clock. You can also begin and end recording at any 
point while Live is playing.

When you have finished your recording session, pressing 
Play on the Control Bar will cause Live to play back every-
thing that you just recorded, including any mixer, effect, 
or clip manipulation.

Switch to the Arrange window by clicking the Arranger 
Chooser just below the system monitors, or by selecting 
it from the View menu. You can now see a “classical” 
sequencer view of all the clips that make up your recording. 
Though the clips are in a linear arrangement in the arrange 
view, you can edit them in a nonlinear fashion by using the 
cut, copy, paste, and delete commands from the Edit menu. 
You can learn more about editing and the Arrange View in Chap-
ter 4 of the manual.   

The Control Bar’s Trans-
port Section.
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3. Operating Live

In this Chapter you will learn about the common concepts 
and conventions you will use while running a Live Set. 
Basic commands like changing the values of controllers, 
selecting single or multiple items, and undo and redo will 
be covered in this Chapter. 

The Info View 

The Info View is an important and useful part of the Live 
interface. It makes sense to talk about it first because 
it can tell you many things about the interface while 
Live is running – without you having to open the manual 
(although we recommend that you do open it).  

The Info View gives you information about whatever area 
of the interface the mouse is over. If you cannott remember 
the function of a particular button or view, the Info View 
can tell you what it is and what you can expect it to 
do. 

Changing Views 

Since Live is composed of a number of views, each giving 
you access to different sets of information, you may fre-
quently need to switch between them in the course of a 
Live Set. There are three methods of doing this: Chooser 

The Info View.
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buttons on the screen; menu items, found on the main 
menu bar; hotkeys, or computer key commands.  

Arranger and Session View Choosers
 

One way you can switch between the Session and Arranger 
Views is by clicking one of the striped toggle buttons to 
the right of the Overview and the Master Track. The top-
most, horizontally striped button opens the Arranger View. 
The vertically striped button below this opens the Session 
View.

Track View Chooser

 

To open the Track View in order to edit the effects on a 
track, you can click on the Track View Chooser tab. Each 
track’s Chooser tab is labeled to show at a glance which 
track is selected. The tab also shows a small graphic repre-
sentation of the effects currently loaded in the track.

When several effects are present on a track, the Chooser tab 
expands horizontally to show them. You will also see a block 
rectangular outline that acts as a scroll bar. By grabbing 
it and dragging, you can scroll to see the entire chain of 
effects.        

The Arranger and Session 
Choosers, found in the top 
right corner of the Live 
main screen.

The Track View Chooser 
tab, located in the 
bottom right corner of the 
Live main screen.



Chapter 3

28

Clip View Chooser

To quickly toggle to the Clip View, you can click the Clip 
View Chooser tab. The tab shows a picture of the sample 
being played by the currently selected clip. The picture 
shows not only the sample, but also which part of the 
sample loops. Below, you can see that only the first half of 
the clip is selected to loop.

The rectangular outline represents the part of the sample 
that is visible in the Clip View. As in the Track View tab, the 
rectangle acts as a scroller. By dragging the left and right 
end of the scroller, you can adjust the visible range, and 
also change the zoom level. Dragging the small gray box in 
the center of the rectangle, you can zoom in and out of the 
waveform View. Click and drag up to zoom out; click and 
drag down to zoom in. Please notice you can also zoom and 
scroll by clicking and dragging in the large Sample display. 
See Chapter 4 for more information about navigating in a 
sample.

The Track View Chooser 
serves as a scroll bar 

when a track’s effects do 
not fit on the screen.

The Clip View Chooser tab,
located immediately to 

the left of the Track View 
tab.

 
The Clip View tab showing 
the looping portion of the 

clip.
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Using the View Menu

Besides using the View Choosers to switch between the 
Views, you can also make selections from the View Menu. 
You will find this menu on Live’s main menu bar. From this 
menu you can open and close Views and expand and col-
lapse segments of Views. For example, you can expand the 
In/Out display of the Mixer and collapse the Sends display.

Hotkeys

Hotkeys, or commands accessed by pressing combinations 
of keys on the computer keyboard, are perhaps the quick-
est way to access many features in Live. Efficient use of 
hotkeys can allow you to operate Live with minimal use of 
the mouse, which is extremely helpful in a live performance 
situation.

Please see the electronic documentation for a complete list 
of the hotkeys available in Live.

The View Menu,
accessed from the main 
menu bar.
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Selecting Items

Any control on the interface can be selected by simply click-
ing on it. You can also navigate around the interface screen 
by using combinations of your computer’s arrow keys and 
certain modifier keys. Please see the electronic documenta-
tion for details.

Holding down the Shift key while clicking the arrow keys 
allows you to outline a selection box around multiple Clip 
Slots in the Session View. Use this to conveniently select 
several clips at once without using the mouse.
 
In the Arranger View you can select multiple clips by click-
ing and dragging a box around items with the mouse, using 
what is often called a “rubber band” selection. While hold-
ing down the mouse, you can drag a flexible outline around 
any number of objects, like clips and/or time, to select them 
all. In the Session View, click in an empty slot next to the 
area you wish to grab to start your rubber band selection. 

Changing Values

To change the value of a control, you can simply click on it, 
and while holding the mouse button, drag up to increase 
the value, and down to decrease it. All of Live’s controls 
operate in a vertical direction.

You can also click on a control and use the up and down 
arrow keys on your computer keyboard to incrementally 
change values.

Clicking once at any position on a slider or effect x-y con-
trol will instantly set it to that point, thereby changing 
the value. This can be especially useful when you need to 
quickly set a value near the top or bottom of its range, 
such as turning a mixer channel all the way up or down. 
You should also note that any circular controls that show a 
small, upside down triangle at the top center of their range 
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allow you to quickly set them to their zero point by click-
ing on the triangle. This works with pan controls (setting 
the pan to the center position) and some gain controls, 
among others. Pressing the Delete/Backspace key while the 
control is selected achives the same result.

Assigning MIDI and Key Controllers

Since Live is meant to be played as an instrument, you will 
probably want to use external devices to control its many 
capabilities. You can very easily assign computer keys or 
MIDI controls to any of Live’s parameters.

MIDI Map Mode

Live allows you to assign arbitrary MIDI notes to Session 
View slots and scenes, and arbitrary MIDI controllers to 
mixer and effect controls. Click the MIDI button on the 
control bar or select Edit MIDI Map from the Options menu 
to view and edit the assignments. Any item on the inter-
face that can be controlled by MIDI will be colored in, and 
Live will display the MIDI channel and the note/controller 
number that has been assigned to each item. Select an 
item and play the MIDI key or move the MIDI controller 
that you want to use and it will automatically be assigned. 
Pressing the Delete/Backspace key will discard the assign-
ment for the selected item.

A Live effect in MIDI 
Map mode. Selecting any 
control and sending a 
MIDI controller message 
will make an assignment.
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Key Map Mode

If you want to assign Session View slots or scenes or mixer/
effect switches to keys on the computer keyboard, click 
the Key button on the Control Bar or select Edit Key Map 
from the Options menu. Again, Live’s interface will show 
all available items for key mapping colored in. Click on the 
item you wish to assign and press the corresponding key 
on your computer keyboard.

 

Any MIDI or Key assignments can be changed by selecting 
the assignment and either pressing the Delete/Backspace 
key on your computer keyboard or by simply assigning a 
new controller or key.

Using Undo/Redo

Any action performed in Live can be undone. Live allows 
you to delete actions one-at-a-time from an unlimited 
history of edits, recordings, automations, etc., by simply 
selecting Undo from the Edit menu or by using the Undo 
hotkey (Command/Control Z).
 
If you decide that you liked the action you performed after all, 
selecting the Redo command will reinstate the last undone 
change. This is your Undo safety net, so to speak. The Redo 
command is located below Undo in the Edit menu or you can 
access it with the Redo Hotkey (Command/Control Y).

Session View slots in Key 
Map Mode. Selecting a 
slot and pressing a key 

on the computer keyboard 
will assign that key to the 

slot.

The Edit Menu’s 
Undo and Redo com-

mands.
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Note that every single action you perform on a Live Set is 
stored in the Undo history. The only distinction in using 
the Undo command is when you undo a recording. Even 
though you may have performed a number of parameter 
changes during a recording, the entire recording is treated 
by Live as one Undo step, and will therefore be deleted.       
       
Recording Audio with Live

Audio recording with Live opens a whole new set of possi-
bilities for composition and performance. You can not only 
use Live like any familiar hard disk recording software but 
you can also make your recordings immediately available 
for looping or triggering in a performance situation. It is a 
rather simple process to set Live up to monitor input sig-
nals, set a track and slot to record on, and to start and stop 
recording.

�Selecting a Track for recording

Each track’s Monitor switch can be used to hear signal 
being input to Live. If you have chosen an input from the 
Input/Output menu for the track you wish to record on, 
pressing the track’s Monitor switch will let you hear any 
audio present on that input channel. The input signal will 
be routed through any effects present on the track.

If you want to record Live’s own output, choose Master Out 
as the Input Type. In this case, monitoring would lead to 
feedback and will therefore be disabled. Monitoring is also 
disabled if you have chosen “Live In” as the input type and 
turned the “Monitor Input through Live” option off in the 
Preferences Audio tab.

Activating the Monitor switch on any track will arm that 
channel for recording. A Record button will appear in each 
empty slot in the armed track.
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Starting recording

When a track’s Record mode is engaged, you can begin 
recording in any empty slot by:

• Clicking the slot’s Record button.

• Pressing the return key while the slot is selected.

• Pressing the MIDI key or computer key that is 
assigned to the slot.

Performing one of these actions causes the slot’s Record 
button to flash red until the quantization delay has expired, 
at which point a new, empty clip will appear in the slot.

The new clip’s play button lights red to indicate that 
recording is taking place. During recording, a bar and beat 
count in the track’s status field displays the current length 
of the new clip. Any other active tracks will continue to 
play during the recording process. You can start and stop 
the recording process independently of your other opera-
tions in Live, allowing you to record new clips and imme-
diately use them in your session.

Ending recording

Recording is stopped when:

• You trigger an empty slot in the record track

• You turn the track’s monitor switch off

• You click the track’s stop button

• Global playback is stopped (by pressing the space 
bar or clicking the stop button on the Control Bar)
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• You click the Back-to-Arrangement button in the 
Control Bar

• The new clip starts playback

The new clip can be triggered for playback at any time during 
recording. The new sample will start looping when launched. 
When quantization is activated, incoming audio can be cap-
tured and immediately worked into a performance.  

If recording of a new clip is ended by playback (of itself 
or another clip), the new clip will default to loop mode. If 
playback is ended in any other way, playback mode will set 
to one-shot mode. The playback setting can be changed for 
each new clip at any time − you can find the settings for 
this in the Clip View (see Chapter four).

Ending the recording process by starting a clip in the 
record track (including the newly recorded clip), or by 
clicking the Back-to-Arrangement button, will reset the 
Monitor switch to its off position. If recording is stopped 
by any other means the Monitor switch will remain on.

Handling recorded samples

Live creates 16-bit WAV (PC) and AIFF (Macintosh) sam-
ples. The sampling rate for recorded samples is the same as 
the audio output sampling rate that you set in the Audio 
Preferences tab. 

You can specify the Audio Recording directory for all 
recorded samples in the Preferences dialog’s Misc tab.  
Make sure that you select a directory on a hard drive with 
plenty of space.

To save time and make the recording process more fluid, 
Live automatically creates file names for all of your new 
recordings.  A typical file name created by Live might read 
something like this:  “Sundaysession Guitar Upbeat 12”.
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Each new file name is a compound name. In the case of 
“Sundaysession Guitar Upbeat 12”, Sundaysession is the 
name of the current Live Set, Guitar is the name of the 
track on which the file was recorded, Upbeat is the name 
of the scene into which the file was recorded, and 12 is a 
number appended to differentiate this sample from those 
recorded before it in the same Set, Track, and Scene.

It is a good idea to name your set, tracks and scenes so 
that new sample names make sense when you attempt to 
identify them later. You can rename or move samples at any 
time by accessing them from Windows Explorer (PC)/Finder 
(Macintosh). You can even do this while Live is up by mini-
mizing Live and switching to the Audio Recording Direc-
tory. Upon returning to Live, a dialog will ask you to locate 
the files you’ve moved and/or renamed.

You can use the “Save as Self-Contained” command to copy 
all files referred to by a Live Set into one central location.  
This should be done when you have been recording, renam-
ing, and moving a files. It is a good idea to think of the 
Audio Recording Directory as a temporary storage place for 
all of the new files captured into a Live Set. You can then 
move all pertinent files to their own directory associated 
with your set.

The “Monitor Input Through Live” switch

In order to set up Live to match your recording needs, 
you will have to access the “Monitor Input through Live” 
switch, located in the Preferences dialog Misc tab.  

Set the “Monitor Input through Live” switch to the on 
position if you connect your audio sources directly to the 
audio interface you have selected to use with Live. This 
allows you to listen to audio coming into Live’s inputs. If 
you want to hear the output of your turntable or CD deck 
through Live, for example, set this switch on.
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Set the “Monitor Input through Live” switch to the off 
position if you monitor your audio sources through an out-
board mixing console, or if you have no need to monitor 
audio input. If you are singing, playing an instrument, or 
working with other musicians in a stage or studio environ-
ment, for example, set the switch off.

It is important to keep the factor of sound card latency 
in mind when monitoring signals through Live. Sound 
card hardware latencies can often cause delays significant 
enough to make overdubbing live parts on top of pre-
recorded parts extremely difficult, if not impossible. How-
ever, using a sound card with ASIO drivers may allow you 
to reduce latency to acceptable amounts.

You can adjust the amount of latency generated within Live 
from the Preferences Audio tab. Your hardware and its driv-
ers usually limit the minimum achievable latency, in milli-
seconds. It is a good idea to set Live’s latency preferences 
to their minimum level (before glitching and break-up), 
even if you are not planning on monitoring signals through 
Live’s inputs. The software will respond more quickly to 
your actions when latencies are at their minimum. 

Recording Sessions

You can regard a live musical performance in two ways: 
one is the immediate, “on-the-spot” aspect; the other is 
the performance across time, as captured on tape. As you 
already know, Live allows you to play clips from the Session 
View and tweak mixer and effects parameters as part of a 
truly Live performance. You can also use Live’s Arrangement 
capabilities to turn your performances into complete com-
positions. An understanding of a few basic concepts will 
help you join Live’s two aspects into one inclusive studio 
tool.
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Recording Clips into the Arrangement

When running, Live always plays along a time line. You can 
read (and change) the current position on the time line by 
using the Control Bar’s Arrangement Position Fields. Live 
can record any actions that occur on this time line and 
play them back later. To do this, Live maintains a virtual 
multi-track tape called the Arrangement. The Arranger View 
allows you to view and graphically edit the arrangement of 
clips along the time line, just like many other hard drive-
based audio sequencers.

Recording into the arrangement is as simple as recording 
audio on a tape deck: just click on the Record button in 
the Control Bar’s transport area. As long as record mode is 
activated, all your actions are captured.

Try playing a couple of clips from the Session View with 
the Record button activated, and then flip to the Arranger 
View. You will see that new clips have appeared in the 
Arranger and, if record mode is still active, they grow as 
time passes. The new clips have the same names and colors 
and appear in the same tracks as the clips you triggered 
from the Session View. 

Recording Clips from 
the Session View into the 

Arrangement
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Stop the recording by clicking the Record button on the 
Control Bar once more. You can now listen to what you 
have just recorded by clicking Stop and then Play. While 
playing back the newly recorded clips, flip back to the Ses-
sion View. You will notice that the original Session Clips are 
not running. You can even delete them without affecting 
what you have just recorded.

In fact, the clips in the Session View are completely inde-
pendent from the clips in the Arranger. The clips that 
appear in the Arranger as the result of a recording are 
copies of the original Session Clips. Therefore, the Session 
and the Arrangement can be developed independently.

Returning to the Arrangement

Because each track can only play one clip at a time 
(each track is essentially monophonic), playback from an 
Arrangement Track is temporarily suspended in favor of any 
clips triggered from the Session View. When a clip from 
the Session View is triggered, the Return-to-Arrangement 
button on the Control Bar will light up. This is to remind 
you that what you hear is not what is “on tape”.

You may want to activate the Record button to capture 
the current state, thereby overwriting the last recorded 
Arrangement. Of course, you can undo the recording after-
wards by calling Undo from the Edit menu. By clicking the 
Return-to-Arrangement button, you can return to Arrange-
ment playback at any time. Live will not play any clips from 
the Arrangement until you click the Return-To-Arrangement 
button. You do not have to worry about the clips from the 
Session View occasionally being interrupted by clips from 
the Arrangement.

The Return-To-Arrange-
ment button, found in the 
Control Bar.
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Copying from the Arrangement into the Session View

The path between the Session and Arrangement is a two-
way street. Let us say you have a piece in the Arranger that 
you would like to use as a starting point for a new live 
session.  You can simply copy the clips from the Arrange-
ment to the Session View, by selecting them (the Select 
All command will select an entire arrangement), grabbing 
the clips, and dragging them to the Session View chooser 
button.  The Session View will open and you can drop the 
copied clips anywhere into the Clip Pool. You can also cut 
and paste clips independently.

Live attempts to preserve the structure of the Arrangement 
Clips when copied into the Session View by representing 
changes with new scenes. Moving through the scenes from 
top down, you can reconstruct the original arrangement.  
      
Automating Controls

With Live’s Record mode activated you can record not only 
your clip playing, but also all of your parameter changes. 
Activate Record by clicking the round Record button in 
the transport area of the Control Bar. Clicking this button 
“arms” the Record mode − when you grab a control on 
the Live interface and begin moving it, this movement 
becomes automation data which is stored in the Arrange-
ment. When recording is stopped, a red-cornered outline 
appears around the automated control to show at a glance 
that automation is present.

You can view and edit the automation in the Arranger View. 
Please see Chapter 4 for details.

If you change an automated control when recording is 
disabled, the red outline disappears and the Return-to-
Arrangement button on the Control Bar will light. This 
indicates that the automation has been temporarily deacti-
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vated for this control. Clicking the Return-to-Arrangement 
button will return the control to its recorded state. The 
control will jump back to whatever value its automation 
dictates for that point in the Arrangement.

Use the Delete Automation command from the Edit menu 
to get rid of unwanted automation on any selected control. 
The envelope for this control will be displayed as a flat 
line. 
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