O autorovi

Autorom tohto programu je Andrej Kruták(to som teda ja...). Mám 17 rokov a moje hlavné záujmy sú programovanie, počítače, pasívne (a niekedy aj aktívne) športovanie a ako každý správny chalan aj holky ;-). Doteraz som získal skúsenosti s jazykmi: C/C++ (pomocou týchto dvoch jazykov je napísaný aj UniView :-), Pascal (len kvôli škole, pretože inak nemám rád jeho organizáciu a neefektívnosť), mnohými BASIC-mi (ZXSpectrum, PMD85, ATARI, VisualBasic, QBasic...), HTML a XML. Bývam na Slovensku a som aj Slovák, na čo som zatiaľ hrdý :-). Moja virtuálna adresa je:
e-mail: krutak@www.gym.utcru.sk
WWW: http://www.gym.utcru.sk/andrek/

Pozn.:Chcel by som sa zoznámiť s niekým, kto takisto programuje v C++ WINAPI a chcel by si so mnou svoje skúsenosti vymeniť. Ak sa taký niekto nájde, prosím, nech mi pošle e-mail-ový list a čaká na odpoveď... Inak, som študent gymnázia a v tomto období jeho tretej triedy (logicky)... Napriek tomu, ako vidíte, sa aktívne venujem vývoju niekoľkých aplikácií, zatiaľ sú to všetko nezárobkové aktivity (čo sa vývoja týka). Pre vývoj programov je však potrebné mať výkonný počítač (aby nečakal na preklad programu 2 minúty, keď to môže byť za 5 sekúnd) a dostatok softvéru (prekladače, debugery atď.). No, ako iste viete, všetko niečo stojí, a preto vás prosím o malú finančnú výpomoc (je jedno, v akej výške, ale bol by som vám vďačný keby ste mi posielali buď SK, alebo inú menu tak, aby sa dala zmeniť v banke ;-), poprípade výpomoc vo forme nejakého hardvéru (najlepšie takého, ktorý pôjde zapojiť do PII+/AMD Athlon+ systému) alebo kompletného stroja (4xprocessor Athlon 1,5GHz, 2GB RAM, 80GB disk, GeForce 3 ultra 64MB by sa naozaj zišiel ;-) ale prijmem, samozrejme, aj niečo slabšie, napr. 486 by som využil na testovanie programu na slabších konfiguráciách). Skrátka, každá hmotná, finančná, ale aj psychická pomoc mi príde vhod. Ak sa rozhodnete podporiť ma touto cestou, môžeme sa dohodnúť aj na prípadnej protislužbe, napr. vo forme pravidelnej aktualizácie a pod.
Ak ste sa dopracovali až sem, máte pravdepodobne dobrú trpezlivosť, že ste tento program ešte nevypli :). Dúfam, že vám tento program bude slúžiť. Prehliadaniu a práci zdar!


Úvod do nápovedy

Vitajte v nápovede pre program UniView. Táto nápoveda je, ako ste si dúfam všimli, vytvorená pre čo najpohodlnejšie vyhľadávanie informácií a je určená len pre UniView. Nesmiete ju distribuovať samostatne a okrem toho musíte dodržiavať všetky podmienky stanovené v licencii k tomuto programu. Ak máte problémy s používaním tejto nápovedy, mali by ste si stiahnuť najnovšiu verziu HtmlHelp prehliadača (klienta) z adresy http://msdn.microsoft.com/library/tools/htmlhelp/wkshp/hhupd.exe. Ak máte pripomienky akéhokoľvek druhu, obráťte sa na autora...

Prosím nevšímajte si syntaktické alebo gramatické chyby v tomto dokumente. Veď sami dobre viete, že je pri písaní textu sa sem-tam nejaká tá chyba vyskytne.

Upozornenie: Táto slovenská verzia nápovedy je určená LEN pre program UniView s nastaveným slovenským jazykom. Všetky nadpisy okien, tlačidiel a pod. sú tu uvedené v slovenskom jazyku. Nápoveda pre inú jazykovú mutáciu programu má aj iné názvy tlačidiel atď.


O programe UniView

UniView je rýchly freeware program pre 32-bitový OS Windows(95, 98, 2001, NT), ktorý slúži na prehliadanie, úpravu a konverziu súborov. Ak chcete vedieť zoznam podporovaných formátov, kliknite na tento odkaz. Chcem vás upozorniť, že na prehliadanie niektorých typov súborov je potrebné mať nainštalované kodeky (napr. QuickTime a MPEG súbory). Program je vo vyvoji, preto je možné, že verzia, ktorú práve používate už nie je aktuálna. Novú verziu si môžete stiahnuť napr. z FTP servera SAC (ftp://ftp.sac.sk/pub/pc/sk-made/uniview.zip) alebo z mojej stránky http://www.gym.utcru.sk/andrek/). Okrem toho bude pravdepodobne na väčšine "zrkadiel" servera SAC. Ak vás tento program zaujal, alebo máte s jeho používaním nejaké problémy, kontaktujte ma prosím (e-mailom).


Podporované formáty

UniView podporuje množstvo formátov súborov. V nasledujúcom zozname sa môžete dozvedieť, ktoré možnosti práce so súborom UniView podporuje. Okrem toho môžete tam môžete nájsť aj popis nastavení výsledného formátu, prípadne aj rôzne iné poznámky...
Grafické formáty, Multimediálne formáty, Textové formáty, Ostatné formáty

Grafické formáty

AA - čítanie+zápis
Formát sa hojne používa v emailoch, textových chatoch ale aj na rôznych internetových stránkach. Súbory AA majú čisto textový formát
Na výber máte pri ukladaní filter, ktorý sa použije na prevod grafického súboru do textového formátu, pre EPOX filter si vyberáte aj veľkosť masky (bodu), ktorý sa bude používať.

ATK - čítanie+zápis
-
-

BMP, DIB - čítanie+zápis
Štandardný formát pre výmenu obrázkov na operačných systémoch Wind*ws a OS/2 (aj keď každý používa svoju vlastnú verziu, majú rovnaký pôvod a preto sa označujú ako jeden formát), napriek svojim zjavným nedostatkom (hlavne vo veľkosti výsledného súboru) sa hojne využíva...
Pri ukladaní súboru do BMP formátu si môžete vybrať, či ho chcete uložiť pomocou RLE kompresie (ktorá však funguje iba pri obrázkoch s farebnou hĺbkou 4 alebo 8 BPP). Vo všeobecnosti sa táto kompresia používa málo kvôli svojej nízkej schopnosti zmenšiť veľkosť obrázku, je však odporúčané používať ju. POZOR! RLE kompresia môže v niektorých prípadoch zväčšiť veľkosť výsledného obrázku (najmä pri konverzii z GIF alebo JPG do BMP formátu).

CMU - čítanie+zápis
-
-

DOO - čítanie
-
-

FAC, FACE - čítanie+zápis ako FAC
-
-

G3 - čítanie+zápis
Formát podporujúci iba čiernu a bielu farbu. Používaný niektorými faxmi ako štandardný výstupný digitálny formát...
-

GIF - čítanie
Starší formát, ktorý je i v súčasnosti vďaka podpore animácie používaný na internete. Kvôli licenciovým problémom s firmou Unisys však formát postupne upadá a postupne ho nahradzuje nový formát PNG/MNG spolu s JPG. Osobne vám môžem tieto tri formáty odporučiť...
-

ICL - čítanie
Formát, ktorý je fyzicky zhodný s EXE/DLL/OCX/CPL súbormi s ikonami. Program teda dokáže extrahovať ikonu z takmer každého spustiteľného súboru v OS-Windows...
-

ICO - čítanie+zápis
Formát, ktorý sa používa hlavne v OS Wind*ws (ale aj v iných) na ukladanie ikon rôznych objektov (aplikácie, dokumenty atď.)
Pri ukladaní môžete nastaviť farbu, pomocou ktorej bude uložená informácia o tranparentnosti (musíte však zaškrtnúť aj položku tranparentý obrázok).

ICON - čítanie+zápis
-
-

IMG - čítanie+zápis
Nie príliš rozšírený formát čiernobielych obrázkov (teda ja som sa s ním stretol len raz)
-

BIE,JBG,JBIG - čítanie+zápis ako JBG (potrebný plugin)
Vynikajúci formát pre čiernobiele a sivé obrázky. Používa bezstratovú kompresiu, ktorá v typických prípadoch predstihuje kompresiu CCITT fax 3 aj 4 (ktorá je použitá napr. v TIFF a G3 formáte).
Ak chcete uložiť obrázok v odtieňoch sivej namiesto čiernobieleho, zaškrtnite položku Uložiť obrázok v odtieňoch sivej...

ILBM/LBM/IFF - čítanie
Formát prebraný z Amigy, používa sa aj v produktoch Electronic Arts...
-

JPEG/JPG/JPE - čítanie+zápis
Formát, ktorý slúži na ukadanie obrázkov komprimovaných stratovou kompresiou JPEG (táto kompresia je podporovaná aj TIFF súbormi). Tento formát dosahuje vynikajúce kompresné pomery pre fotografie a rôzne naskenované dokumenty. Neodporúča sa používať ho napr. pre diagramy, pretože pri takomto type obrázkov dochádza k relatívne veľkému skresleniu výsledného obrázku oproti originálu.
Ak súbor uložíte progresívne, pri jeho načítavaní napr. do prehliadača sa v prvej fáze načíta len hrubá mozaika výsledného obrazu, ktorý sa postupne zaostruje načítavaním ďalších častí. Okrem toho väčšinou dochádza aj k úspore veľkosti, preto je odporúčané obrázky ukladať progresívne (aj keď nie všetky prehliadače si dokážu s týmto nastavením poradiť - IE, NN, Mozilla aj Opera by ich mali zvládať bez problémov). Okrem toho môžete nastaviť aj kvalitu obrázku a ďalšie dva nastavena trochu ovplyvňujú veľkosť a kvalitu výsledného obrázku (súboru).

LEAF - čítanie+zápis
-
-

MAC,MACP,MPNT,PAINT,PNTG - čítanie+zápis ako MACP
-
-

MDA,MDP - čítanie+zápis (len MDA)
UniView podporuje MDA aj MDP vo verziách 1.0 aj 1.3, ale dokáže zapísať len MDA vo verzii 1.0 a 1.3
Pri ukladaní si môžete vybrať, ktorá verzia bude použitá na uloženie MDA súboru

MGR - čítanie+zápis
-
-

NGG, NOL, NPM - čítanie+zápos
Formáty NGG/NOL/NPM sú používané mobilnými telefónmi NOKIA ako logo operátora, poprípade ako obrazová SMS správa (alebo nejaký iný obrázok...). Zatiaľ som nemal možnosť osobne vyskúšať, ako sa dá takýto obrázok použiť na mobile, ale podľa určitých zdrojov je to možné pomocou EMI/UCP protokolu cez TCP/IP (otestované v sieťach SwissCom SMSC - Švajčiarsko a IC3S SMSC - Nemecko). Na mobilné telefóny Nokia 3210 a 6210 sa používa ako logo operátora (alebo napr. aj obrázok skupiny) obrázok s rozmermi 72x14 - musí byť čiernobiely (ak nie je, bude prekonvertovaný)...
Pri ukladaní si môžete vybrať, či bude súbor uložený v hexadecimálnej alebo binárnej podobe. Pre formát NOL s HEX môžete nastaviť číslo mobilného operátora (ak nič nenapíšete, použije sa 62F210) a pre NPM nastaviť textovú správu, ktorá bude vložená v obrázku :)

PBM/PGM/PPM/PNM - čítanie+zápis
Formát používaný najmä na Unix a LiNUX systémoch kvôli svojej jednoduchosti a množstvu utilít, ktoré sú pre tieto formáty na spomínaných systémoch k dispozícii. PBM je formát určený pre čierobiele obrázky, PGM pre obrázky v odtieňoch sivej a PPM pre plnofarebné obrázky. PNM môže obsahovať ľubovoľný formát.
Ak súbor uložíte binárne, výrazne sa tak skráti doba načítania aj ukadania súboru a zároveň sa zmenší aj výsledný súbor...

PCX - čítanie+zápis
Formát vyvinutý firmou ZSoft používaný hlavne v OS MS-DOS a jeho klonoch. Dnes už upadá kvôli jeho morálnej aj technickej zaostalosti, používa sa len kvôli spätnej kompatibilite so starším softvérom.
Ak zaškrtnete položku "Kompresia packbits", obrázok bude skomprimovaný (dosahuje dobré výsledky pri neplnofarebných obrázkoch - teda nie na fotografiách a pod.)

PI1 - čítanie+zápis
-
-

PI3 - čítanie+zápis
-
-

PNG - čítanie+zápis
Vynikajúci formát, ktorý bol vyvinutý ako náhrada pre súbory GIF, ktoré majú obmedzené vlastnosti. Okrem iného podporuje nasledovné vlastnosti: farebná hĺbka až do 48BPP (alebo v odtieňoch sivej do 16BPP), alfa kanál, gamma korekcia, kontrola integrity, progresívny mód. Okrem toho nepoužíva kompresiu LZW (ktorá je, ako som spomínal, licencovaná UniSys-om a preto sú s ním problémy...) ale LZ77, ktorá je niekedy aj efektívnejšia a okrem iného sa používa aj v ZIP súboroch - nemá preto význam PNG súbory komprimovať. Okrem toho sa začína rozširovať aj formát MNG, ktorý je založený na PNG ale môže byť, podobne ako GIF, animovaný. PNG formát nie je, napriek nesporným výhodám, vhodné používať na fotografie alebo podobné plnofarebné obrázky - na to je lepšie použiť JPEG formát. Čo sa týka kompatibility s internetovými prehliadačmi, PNG by mali zvládnuť všetky novšie prehliadače (formát PNG bol zavedený cca. od roku 1995)...
Ak súbor uložíte progresívne, môže dojsť k zmenšienu výsledného súboru (ale len pre určité typy obrázkov). Pomocou položky sila kompresie nastavíte, koľko času bude trvať kompresia (obrazne) - čím väčšia sila kompresie, tým dlhšie to bude trvať ale tým menší bude výsledný súbor, aj keď napr. medzi kopresiou 8 a 9 prakticky nie je rozdiel vo výslednej veľkosti. Optimum je zvoliť kompresiu v rozhraní 6-8...

QRT - čítanie+zápis
Formát používaný programom QRT ray-tracer, podporuje len 24 bitovú farebnú hĺbku.
-

RAS, RAST, SR - čítanie+zápis ako RAS
-
Pri ukladaní môžete použiť RLE kompresiu (viď. BMP)

RAW - čítanie+zápis
Všeobecný formát, ktorý môžete používať pre prenos ľubovoľných dát, v tomto prípade obrázkov... Tento formát je používaná v rôznych hrách, kde autori nechcú, aby uživateľ ľubovoľne upravoval grafiku hry, pretože bez toho, aby ste poznali presný formát a polohu obrázku v súbore prakticky nie je možné prezrieť ani zmeniť cieľový súbor...
Offset určuje pozíciu, kde v súbore sa bude ukladať výstupný obrázkok. Nastavenie poradie kanálov určuje poradie jednotlivých farebných položiek obrázku. Položka "prekladanie kanálov" určuje prekladanie položiek vybraného farebného modelu...

RGB/SGI - čítanie+zápis
Formát používaný grafickými stanicami Silicon Graphics pre ukladanie obrázkov (ale používa sa prakticky na každej platforme). Formát sa vyznačuje dobrými technickými vlastnosťami (veď aby aj nie, keď SGI je v grafike "jednotka")...
Pri ukladaní môžete použiť RLE kompresiu (viď. BMP)

RLE, URT - čítanie+zápis ako RLE
-
-

SCR - čítanie
Výstupný formát emulátorov 8-bitového počítača ZX Spectrum, presnejšie povedané obsah "obrazovky" tohto emulátora. Nie je odporúčané asociovať tento formát, nakoľko rovnakú príponu májú aj šetriče obrazoviek...
-

SGI - čítanie+zápis
-
Pri ukladaní môžete použiť RLE kompresiu (viď. BMP)

SIR - čítanie+zápis
-
-

TGA - čítanie+zápis
Formát vyvinutý firmou Truevision nazývaný TARGA. Je pomerne rozšírený a často používaný...
Ak zvolíte RLE kompresiu, môže dôjsť k zmenšeniu dĺžky výsledného súboru. Toto nastavenie funguje iba pri obrázkoch s 8 BPP alebo menším...

TIF,TIFF - čítanie+zápis
TIFF (Tagged Image File Format - značkovaný súborový formát obrázkov) je v súčasnosti jedným z najprepracovanejších a najkomplexnejších formátov, ktoré sú k dispozícii. Vďaka svojej rozšíriteľnosti a kodekovému charakteru sa používa v mnohých programoch a je možné rozširovať ho o rôzne dodatočné informácie (autor, zdroj, copyright, alpha kanál, vodoznak atď.). Tento formát je vhodné používať hlavne pre jeho kompatibilitu s prevažnou väčšinou grafických programoch, na internete je ho už menej (pretože nie je určený na šetrenie miestom, môžu byť súbory v tomto formáte pri zvolení nesprávneho kodeku dosť veľké)
Pomocou položiek v poli "kompresia" si môžete vybrať, ktorý kodek sa použije pri kompresii súboru. Ako ste si mohli všimnúť, aj tu sa nachádza možnosť LZW, ktorá nie je (podobne ako v prípade GIF) odporúčaná. Namiesto nej je dobré používať LZ77 kompresiu (viď PNG), ktorá dosahuje podobné výsledky. Packbits je vhodné použiť pre čiernobiele obrázky, None je žiadna kompresia. JPEG pravdepodobne už netreba vysvetlovať :), snáď iba nastavenia: parameter "kvalita obrázku" určujete stupeň kopresie obrázku. Čím je toto číslo bližšie ku 100%, tým je výsledný obraz kvalitnejší ale veľkosť väčšia a naopak. Ak zaškrtnete možnosť "uložiť vo formáte RGB", dôjde najprv ku konverzii obrázku z YCbCr do RGB farebného modelu. To môže mať za následok väčšiu veľkosť výsledného súboru. Pre LZW exituje jediná voľba: kvalita predpovedania. Čím je tu zadané väčšie číslo, tým lepší je kompresný pomer ale tým dlhší je aj čas kompresie...

WBMP - čítanie+zápis
Relatívne nový formát zavedený W3 konzorciom ako štandardný formát pre WAP stránky (mobilný internet). Podporuje len čiernobiele obrázky.
-

XBM - čítanie+zápis
Formát čiernobielych obrázkov (kurzorov, ikon) na OS Unix a jeho klonoch
Pri ukladaní môžete použiť dve verzie tohto formátu (X10 pre kompatibilitu alebo X11 - novší formát)

XIM - čítanie
Formát obrázkov, ktorý je používaný balíkom Xim toolkit, ktorý je súčasťou grafického prostredia X Window system.
-

XPM - čítanie+zápis
Formát paletovaných (teda neplnofarebných) obrázkov v OS Unix, používaný hlavne ako ikony. Vďaka svojej nebinárnej povahe a syntaxi (ktorá je rovnaká ako má jazyk C/C++) je používaný aj programátormi...
Ak zaškrnete položku "Použiť tabuľku mien...", program sa pokúsi pomenovať jednotlivé farby pomocou mien.

YBM - čítanie+zápis
-
-

YUV - čítanie+zápis
Formát Abekas YUV používa konverziu RGB na YUV (pomer 4:1:1), čo zmenšuje veľkosť výsledného súboru pri skoro rovnakej kvalite - táto konverzia je využívaná napr. aj v MPEG a JPEG kompresii...
-

Textové formáty

RTF - čítanie+zápis
RTF (Rich Text Format) je štandardným formátom, pomocou ktorého sa vymieňajú textové dokumenty obsahujúce rôzne druhy písma (poprípade vložené objekty) medzi rôznymi operačnými systémami. Je to čisto textový formát, preto je výhodné komprimovať ho do archívov...
-

Ostatné formáty sú všetky textového charakteru, čo znamená, že formáty v nich uložené neobsahujú žiadne špeciálne značky a celý text má len jedno písmo.

Multimediálne formáty

WAV, AIF,AIFF,AIFC,RMI,MID,AU - čítanie
Všetky tieto formáty sú čisto hodobné, tzn. nenesú žiadnu obrazovú informáciu
-

ostatné :-) - čítanie
Tieto formáty môžu niesť tak obrazovú ako aj zvukovú informáciu...
-

Ostatné formáty

všetky nespomenuté - čítanie+zápis
Všetky súbory, ktorých formát nie je UniView schopný rozozonať považuje za "obecné" a otvára ich pomocou podprogramu HexView, ktorý je schopný meniť obsah súboru aj pomocou hexadecimálnych hodnôt a tieto súbory potom aj ukadať.
-


Pozdravy

V tejto časti by som chcel pozdraviť nasledovných ľudí: Moju mamu, otca, bratov a všetkých príbuzných a nasledovných mojich známych a priateľov: Ľubo Tulinský, Jano Hýroš, Tomáš Šošovec, Ivan Šamík, Peter Pažítka, Martin Maslo, Eva Nedeľková, Barbora Borovská, Eva Okálová, Július Stančok, Michal Terek, René Kamenský, Filip Kršík, Miro Kendera, Ondrej Novák, Christian Ghisler, Peter Hubinský a všetkých ďalších priateľov.


Prvý pohľad

Keď prvýkrát spustíte program UniView, mal by sa vám naskytnúť približne nasledovný pohľad.

Toto je prázdne okno, ktoré signalizuje, že ste ešte neotvorili žiadny súbor. Autor nápovedy predpokladal, že ak sa vám už podarilo spustiť túto nápovedu, pravdepodobne poznáte základy ovládania windows aplikácií. Preto sa nebudeme zaoberať žiadnymi témami typu: ako mám otvoriť súbor?, ako ukončiť program? atď. Ak máte takéto problémy, určite vám pomôže windows nápoveda alebo nejaká príručka k Windows. Dúfam, že napriek tomuto malému nedostatku nápovedy na UniView nezanevriete. Veď nakoniec, ovládanie programu je viac ako jednoduché, určite to zistíte hneď v nasledujúcich témach alebo po krátkej práci s UniView-om.


Základná obsluha programu

 Okno - nastavenia Okno - o programe Okno - otvoriť súbor Menu programu Stavový riadok Minimalizuje okno Maximalizuje okno Zatvorí okno
Základná obsluha programu

Ešte raz si pozrite, ako UniView vyzerá v základnom stave.

Ako ste si mohli všimnúť, ani v tomto stave nie sú zakázané všetky akcie. Je povolených niekoľko položiek, ktoré môžete použiť. V obrázku sa nachádzajú miesta, na ktoré môžete kliknúť, ak sa o nich chcete dozvedieť viac.


Typy súborov

Po otvorení súboru alebo vytvorení nového sa vám v závislosti od jeho typu zmení prostrediu UniView-u tak, aby ste s ním mohli pracovať čo najproduktívnejšie. Okrem iného to znamená aj to, že sa zmení panel nástrojov, stavový riadok a menu programu. Ak chcete vedieť ako, stačí, ak si to sami vyskúšate v programe.

Čo sa týka panelu s nástrojmi, veľká časť je spoločná pre všetky typy súborov. Okrem iných sú to tlačidlá Otvoriť súbor, Uložiť a Uložiť ako, Tlačidlá pre pohyb adresárom, Tlačidlá pre prácu so schránkou, Nastavenia a O programe.

Ako som spomínal, existuje mnoho typov, ktoré UniView rozoznáva. Sú to:
Textové súbory
Grafické súbory
Multimediálne súbory
Binárne súbory

Upravovať sa dajú všetky typy súborov okrem multimediálnych (to sú napríklad súbory typu AVI, MPG, MOV, QT). Tento typ sa takisto zatiaľ nedá ani ukladať (pomocou pluginu Helpers sa však dá kopírovať :-). Na zdokonalení sa však stále pracuje a je predpoklad, že v budúcnosti bude podporovaná aj táto možnosť...


Binárne súbory

Binárny súbor je ľubovoľný súbor, ktorý obsahuje okrem textu aj rôzne iné dáta. Do tejto skopiny súborov patria okrem iných aj multimediálne a obrázkové súbory. Tie však UniView dokáže odlíšiť a otvoriť v uživateľovi príjemnej forme. Ak nie je schopný zistiť formát súboru, otvorí ho práve v binárnom formáte pomocou programu HexView, ktorý je priamo súčasťou uniview.exe a nie je potrebné inštalovať žiadne dodatočné programy (pluginy). Mnohým uživateľom HexView príliš nepomôže, napriek tomu sa však dá použiť aspoň na zistenie základných informácií o súbore (napríklad UniView nedokáže otvoriť Office súbory typu DOC, XLS atď., ale v binárnom pohľade sa z nich dá vyčítať aspoň časť informácií).

Medzi binárne súbory patria aj spustiteľné súbory typu EXE a COM. Väčšina týchto súborov je chránená autorským právom a je zákázané meniť ich. Najväčšie nebezpečie pri úprave týchto súborov spočíva v tom, že neskúsený uživaťeľ môže úplne zničiť program a ten potom môže poškodiť dáta na jeho počítači. Preto odporúčam nemeniť súbory typov: EXE, COM, DLL, OCX, SYS, CPL, CPX, VXD pomocou binárneho editoru programu UniView, ak presne neviete, čo robíte.

HexView je založený na programe FRHED, ktorý je šírený zdarma. Podrobnejšie informácie môžete získať, ak stlačíte počas práce s HexViewom pravé tlačidlo na myši a potom vyberiete položku 'About HexView'. Táto časť produktu nie je zatiaľ z časových dôvodov preložená do iného jazyka ako je angličtina, ale v budúcnosti určite bude. Je však pravdepodobné, že väčšina uživateľov, ktorí budú túto funkciu produktu využívať ovládajú anglický jazyk na úrovni aspoň postačujúcej pre HexView :-)


Multimediálne súbory

Multimediálne súbory sú súbory, ktoré obsahujú okrem obrazových aj zvukové (a niekedy aj textové) dáta. UniView používa na ich prehrávanie služby Windows MCI rozhrania. V budúcnosti bude podporovať aj ActiveX technológiu prehrávača Windows Media Player-a. Ak máte problémy s prehrávaním súborov typu AVI, MPG alebo WAV, je pravdepodobné, že nemáte nainštalované potrebné kodeky... Pre istotu však ešte môžete skúsiť aj spomínaný MediaPlayer ;-)


Textové súbory

Pod pojmom textové súbory rozumieme súbory, ktoré nesú textové informácie a ich primárnym určením je niesť ich. Okrem toho môžu niektoré súbory niesť aj iné informácie (napr. RTF je schopný niesť aj obrázky a mulitmédiá), ktoré však UniView v súčasnosti nezobrazuje.


Obrázky (grafické súbory)

Obrázky sú súbory, ktoré nesú akúkoľvek grafickú informáciu. UniView rozoznáva mnoho formátov obrázkov, väčšinu z nich je schopný čítať aj zapisovať. Nakoľko asi väčšina z vás vie, čo to obrázok je, budem sa teraz venovať technickým vlastnostiam obrázku, ktoré by mohli pomôcť tvorivejším zefektívniť prácu...

Základnými charakteristikami obrázku v UniView-e sú šírka, výška a farebná hĺbka. Širka (X veľkosť) aj výška (Y veľkosť) sú udávané vždy v pixeloch, tzn. obrazovkových bodoch. Farebná hĺbka určuje maximálny počet farieb, ktoré môže obrázok obsahovať. UniView podporuje farebné hĺbky 1bpp (2 farby), 4bpp (16), 8bpp(256) a 24bpp (16 777 777). Ak načítavaný súbor obsahuje inú farebnú hĺbku, napr. 32bpp, bude skonvertovaný na najbližšiu možnú farebnú hĺbku - vždy na na najvyššiu možnú, aby sa nestratili údaje (teda napr. 2bpp na 4bpp, 32bpp a 16bpp na 24bpp atď.). UniView samozrejme dokáže meniť farebnú hĺbku obrázku smerom nadol aj nahor. Konverzia do 24bpp (Bites Per Pixel - bitov na bod) sa koná automaticky pri vyknávaní niektorých efektov, ktoré potrebujú väčší počet farieb (rozmazanie obrazu, zmena veľkosti).

Obrázok môže pri veľkých rozmeroch zaberať dosť veľa pamäte (napr. obrázok s veľkosťou 5000x5000x24bpp zaberá 71.5 MB. Na takýto obrázok už musíte mať aspoň 192 MB RAM, ak chcete pracovať úplne plynulo (ale malo by stačiť aj 128MB). Preto ak chcete vytvárať "nadrozmerný" obrázok, radšej zatvorte ostatné programy a uložte si prácu, nie je totiž isté, ako dlho windows vydrží pracovať s takým veľkým pamäťovým objektom bez padnutia :-)

Pojmy:
Pixel: bod obrázku, ktorý má určitú farbu
Riadok, scanline: niekoľko pixelov uložených vedľa seba
Stĺpec: niekoľko pixelov uložených pod sebou


Prehľadávanie adresárov

Po otvorení akéhokoľvek súboru môžete začať pomocou tlačidiel ← a → v paneli nástrojov otvárať predchádzajúe alebo ďalšie súbory (môžete použiť aj položky v menu 'súbor'. Zoznam súborov je zoradený podľa kritérií, ktoré zadáte v dialógovom okne nastavenia. Ak máte otvorený multimediálny alebo obrázkový súbor, môžete používať aj tlačidlá medzera a F11 (ďalší) a backspace a F10 (predchádzajúci) (poznámka: tlačidlá F10 a F11 môžete použiť pri hociakom type súboru). V prípade, že ste v okne nastavenia zvolili, že pri prehliadaní chcete vidieť aj textové súbory, môže sa stať, že pri prehliadaní na takýto formát aj narazíte. V tomto prípade vám nebude po otvorení tohto súboru už fungovať medzera a backspace. Musíte použiť tlačidlá F10, F11, tlačidlá v paneli nástrojov alebo ponuku v menu.


Stavový riadok

Stavový riadok je spodná časť okna, ktorá obsahuje základné informácie o stave programu (napr. či je nejaký súbor otvorený, ak áno, jeho poradie v adresári a pod.) a práve otvorenom súbore (veľkosť, rozmery). Pre každý typ súboru má tento riadok trochu inú podobu a obsahuje rôzne informácie, no snažil som sa o to, aby sa z nich dalo čo najľahšie vyčítať informácie aj bez nápovedy.


Programové menu

Základná časť menu programu UniView je nemenná počas celého chodu programu, menia sa len aktivované položky (v závislosti od typu súboru). Nasleduje krátka tabuľka, ktorá obsahuje krátke popisy hlavných častí menu. Po kliknutí na názov časti menu sa vám zobrazí improvizovaná stromová štruktúra menu s popismi významu položiek (poprípade aj dodatočných informácií a odkazov)...
Súbor | vytváranie, otváranie, ukladanie súborov; okrem toho aj ukončenie práce s programami atď.
Úpravy | práca so schránkou (kopírovanie, priliepanie, vystrihovanie), označovanie dokumentu a vrátenie (UNDO) úprav
Text | zmeny v textových dokumentoch
Prehrávač | prehrávanie súborov - zmena mierky, presun aktuálnej pozície
Obrázok | úpravy v obrázkoch, aplikácia efektov, nastavenia nástrojov na úpravu obrázkov
Štart | rôzne utilitky a pluginy, ktoré sa tematicky nedajú zaradiť do inej časti menu
Nápoveda | nápoveda k programu UniView a pluginom, informácie o programe a aktuálnom dokumente


Menu: Súbor

Táto ponuka menu slúži hlavne na prácu so súbormi (ukladanie, otváranie)

Nový
Otvoriť
Uložiť
Uložiť ako
Ďalší súbor
Predchádzajúci súbor
Tlačiť
Celoobrazovkový mód
Nastavenia
Ukončiť program

Nový - vytváranie nových súborov (cez okno nový súbor)
Otvoriť - otváranie existujúcich súborov (cez okno otvoriť súbor)
Uložiť - uloženie aktuálneho súboru (ak ešte nikdy nebol uložený, to isté ako Uložiť ako)
Uložiť ako - uloženie aktuálneho súboru na miesto a vo formáte, ktoré si zvolí sám uživateľ (cez okno Uložiť súbor ako)
Ďalší súbor - otvorí ďalší súbor v adresári
Predchádzajúci súbor - otvorí predchádzajúci súbor v adresári
Tlačiť - vytlačí aktuálny súbor. Prečítajte si toto ak sa chcete dozvedieť viac.
Celoobrazovkový mód - zobrazí aktuálny dokument v celoobrazovkovom režime. Výsledný vzhľad závisí na tom, aké je nastavenie "Jednoduchý celoobrazovkový režim". Ak je možnosť zaškrtnutá, výsledné okno bude tvorené len hlavným editačným oknom. V opačnom prípade bude okno zobrazené ako normálne maximalizované okno s tým rozdielom, že nebude mať titulok...
Nastavenia - spustí dialógové okno Nastavenia
Ukončiť program - ukončí prácu s programom


Menu: Úpravy

Táto ponuka menu slúži na základnú prácu s dokumentom a schránkou...

Vrátiť
Opakovať
Kopírovať
Vystrihnúť
Prilepiť
Vymazať
Vybrať všetko
Maximalizovať okno
Minimalizovať okno

Vrátiť - vráti späť poslednú akciu, ktorú ste vykonali. Táto funkcia je aktívna pri obrázkoch a textoch po tom, čo zmeníte práve otvorený súbor.
Opakovať - zopakuje akciu, ktorú ste vrátili späť príkazom Vrátiť
Kopírovať - skopíruje vybranú časť obrázku/textu/binárneho súboru do schránky
Vystrihnúť - skopíruje vybranú časť obrázku/textu/binárneho súboru do schránky a vymaže túto časť z aktívneho dokumentu
Prilepiť - vloží obsah stránky do aktuálneho dokumentu na misto kde sa nachádza kurzor (text, binárne súbory) alebo aktívny dokument zamení za ten, ktorý sa nachádza v schránke
Vymazať - vymaže vybranú časť (blok) dokumentu
Vybrať všetko - vybere (označí) celý dokument
Maximalizovať okno - maximalizuje okno UniView-u
Minimalizovať okno - minimalizuje okno UniView-u


Menu: Text

Táto ponuka menu slúži na prácu s textovými dokumentmi. Môžte ju vyvolať aj súčastným klávesy SHIFT a pravého tlačidla myši.
Nastaviť písmo
Nastaviť farbu písma
Vlastnosti písma - ponuka
Zarovnať doľava
Zarovnať na stred
Zarovnať doprava
Zväčšiť zarovnanie
Zmenšiť zarovnanie
Nájsť
Nájsť ďalšie
Zameniť
Zalamovať text
Výber - ponuka

Nastaviť písmo - zobrazí štandardné dialógové okno, v ktorom si môžete vybrať písmo pre vybraný blok dokumentu. Ak nemáte vybraný žiadny blok textu, nastaví sa iba aktuálne písmo, ktorým môžete začať písať. Ak zmeníte pozíciu kurzora skôr, ako týmto písmom niečo napíšete, akcia nemá význam (nič sa nestane)...
Nastaviť farbu písma - nastaví farbu písma textu, ktorý je vybraný, ak nie je vybraný žiadny text, platí to isté, ako pre predchádzajúci príkaz
Vlastnosti písma - pomocou položiek v tomto menu môžete nastaviť vlastnosti písma v vybraného bloku textu alebo aktuálneho písma (viď predchádzajúce príkazy). Myslím, že názvy príkazov sú samovysvetlujúce. V prípade položky Len na čítanie dôjde k zakázaniu zmien vybraného textu. Táto funkcia funguje v UniView-ve a nie je zaručené že bude fungovať aj inde. Zrušiť ktorúkoľvek vlastnosť zo skupiny [Tučné, Šikmé, Podčiarknuté, Len na čítanie] môžete opätovným použitím príkazu...
Zarovnať doľava - zarovná aktuálny riadok (ak je označený text, potom všetky riadky, na ktorých sa nachádza označený blok textu) doľava
Zarovnať na stred - zarovná aktuálny riadok (ak je označený text, potom všetky riadky, na ktorých sa nachádza označený blok textu) do stredu - vycentruje ho
Zarovnať doprava - zarovná aktuálny riadok (ak je označený text, potom všetky riadky, na ktorých sa nachádza označený blok textu) doprava
Zväčšiť zarovnanie - zväčší zarovnanie aktuálneho riadoku (ak je označený text, potom všetky riadky, na ktorých sa nachádza označený blok textu)
Zmenšiť zarovnanie - zmenší zarovnanie aktuálneho riadoku (ak je označený text, potom všetky riadky, na ktorých sa nachádza označený blok textu)
Nájsť - nájde v dokumente vybraný text podľa daných kritérií
Nájsť ďalšie - nájde ďalší výskyt zadaného slova v dokumente
Zameniť - zamení vybranú frázu podľa zadaných kritérií za inú
Zalamovať text - zalomí textový dokument tak, aby sa vošiel do okna / zruší zalomenie
Výber - nastaví štýl označovania textu (slová/písmená)


Menu: Prehrávač

Táto ponuka menu slúži na manipuláciu s prehrávanými multimediálnymi súbormi...

Presun na začiatok
Znovuprehranie
Presun na koniec
Prehrať pospiatky
Nastaviť mierku videa

Presun na začiatok - Nastaví aktuálnu pozíciu prehrávača na začiatok súboru
Znovuprehranie - Prehrá aktuálny súbor odzačiaku
Presun na koniec - Presunie aktuálnu pozíciu prehrávača na koniec súboru
Prehrať pospiatky - Prehrá aktuálny súbor pospiatky (smerom od konca) - funguje len pri videách!!!
Nastaviť mierku videa - Nastaví mierku prehrávaného videa (100 je ozajstná veľkosť, 50 polovičná, 200 dvojnásobná atď.)


Menu: Obrázok

Táto ponuka menu slúži na prácu s obrázkami. Je zo všetkých najobsiahlejšia, preto sa ňou budeme zaoberať trochu viac...
Obrázok [image] znamená, že efekt sa dá aplikovať na iba na celý obrázok...

Efekty
 Farby
  Dekolorifikovať
  Zatemniť obrázok
  Izolovať farbu...
  RGB->...
  Negatív
  Odstrániť odtiene sivej
  Odtiene sivej - svietivosť
  Odtiene sivej - suma
  Izolovať RGB/CMYK zložku
  Izolovať HSV/YUV zložku
 Rozmazanie
  Rozmazanie
  Roliate farby
  Rozmazanie pohybom
  Olejomaľba
 Deformácia
  Explózia
  Pixelizovať
  Roztriasť
  Prahový efekt
 Okraje
  Kontrast
  Nájsť okraje
  Vyrazenie do priestoru
  Zväčšiť rozdiely
 Šum
  Mediánový filter
  Šum
 Rôzne
  3D Tlačidlo
  Prekladať
  Vytvoriť gradient
  Uživateľsky definovaný
 Transformácia
  Otočiť vľavo
  Otočiť vpravo
  Otočiť vertikálne
  Zrkadlový obraz

Paleta
 Histogram
 Spočítať počet farieb
 Upraviť paletu
 Exportovať paletu
  Jasc formát
  UniView formát
Pero
Text
Výber
Kvapátko
Zmeniť počet farieb
Zmeniť veľkosť
Zmeniť vlastnosti farieb
Parametre pera
Vybrať farbu pera

Efekty | tu sú všetky štandardné efekty, ktoré môžete aplikovať na obrázok (vo väčšine prípadov aj na jeho časť)
Farby | tu sú všetky efekty pracujúce s farebnými hodnotami obrázku (alebo časti obrázku)
RGB->... | zmení farebné hodnoty obrázku z RGB do zvolého formátu...
Negatív | vytvorí negatív obrázku
Odstrániť odtiene sivej | odstráni sivé odtiene z obrázku a nahradí ich vybranou farbou (užitočné pri OCR programoch)
Odtiene sivej - svietivosť | vytvorí z obrázku kópiu v odtieňoch sivej farby, pričom použije farebnú zložku Lightness z HSL formátu obrázku. Táto funkcia podáva vernejšie výsledky ako tá, ktorá teraz bude nasledovať...
Odtiene sivej - suma | vytvorí z obrázku kópiu v odtieňoch sivej farby, pričom použije priemer z R, G, B častí obrázku
Izolovať RGB/CMYK zložku | Izoluje vybranú zložku farebného modelu obrázku - RGB alebo CMYK - do príslušného farebného kanálu obrázku (R, G, B, C, M, Y alebo K) - všetko samozrejme len na virtuálnej úrovni, obrázok je kvôli jednoduchšej manipulácii stále v RGB formáte.
Izolovať HSV/YUV zložku | Izoluje vybranú zložku farebného modelu obrázku (HSV alebo YUV), pričom vytvorí sivý obrázok reprezentujúci vybraný kanál...
3D Tlačidlo | vytvorí 3D tlačidlo vo vybranej časti obrázku
Dekolorifikovať | Zmenší maximálny počet odtieňov jednej farby (účinná metóda na zmenšovanie počtu farieb)
Explózia | "porozhadzuje" pixely v obrázku tak, že bude vyzerať ako po výbuchu...
Kontrast | pomocou tejto, podľa mojej mienky veľmi užitočnej, funkcie môžete meniť kontrast (rozdiel medzi najsvetlejšími a najtmavšími časťami obrázku). Čím väčšiu hodnotu zadáte, tým bude mať výsledný obrázok väčší kontrast a naopak, čím menšie bude, tým bude kontrast menší.
Mediánový filter | Táto funkcia je určená špeciálne na odstraňovanie šumu z obrázkov pomocou mediánov (aj keď sa dá použiť aj na iné účely) - má však nevýhodu - odstraňuje tenké čiary z obrázku. Pri jeho aplikovaní môžete použiť ako hodnotu číslo v rozsahu 3-33, pričom toto číslo bude zaokrúhlené na najbližší násobok číla 3 (má to svoje dôvody v algoritmoch, tým vás však nechcem zaťažovať).
Nájsť okraje | nájde okraje v obrázku. Čím silnejší je okraj, tým svetlejšia je farba zvýraznenia.
Olejomaľba | vytvorí z obrázku olejomaľbu jeho rozmazaním pomocou väčších či menších plôšok
Otočiť vľavo | otočí obrázok doľava
Otočiť vpravo | otočí obrázok doprava
Otočiť vertikálne | otočí obrázok okolo horizontálnej osi - vrch bude dole a naopak
Zrkadlový obraz | vytvorí zrkadlový obraz obrázku
Pixelizovať | vo vybranej časti obrázku zaštvorcuje obraz tak, že síce bude vidno, aké farby tam sú, ale nebude sa dať rozoznať, čo tam bolo (záleží na nastavení veľkosti štvorcov). Táto funkcia sa zvykne používať napr. pri zahaľovaní tvárí alebo rôznych neželaných oblastí obrázku (nepr. v novinách, televíznych správach atď.)
Prahový efekt | Táto funkcia slúži na zníženie počtu farieb na 2 na základe svetlivosti dvoch bodov. Na nastavenie tohto efektu môžete použiť prah citlivosti a dve farby, ktoré sa použijú na zvýraznenie dvoch rôznych intenzít. Pre popis algoritmu, kliknite sem.
Prekladať | vytvorí vo vybranej časti obrázku čiary (s nastaviteľným smerom a rozostupom), ktoré výrazne pomáhajú napr. pri zväčšovaní obrázok (opticky to potom vyzerá ako bez zväčšenia - pri vhodnej manipulácii samozrejme :-)
Roztriasť | posunie každý riadok doľava alebo doprava o náhodnú hodnotu a potom každý stĺpec hore alebo dole tiež o náhodnú hodnotu. Miesto v obrázku, ktoré nie je obsadeníé žiadnym riadkom ano stĺpcom je vyplnené vybranou farbou.
Rozliate farby | rozmaže obrázok tak, že vyzerá, ako by bol poliaty vodou a tá potom jemne zmyla farby nadol
Rozmazanie | rozmaže obraz tak, že vyzerá ako rozostrený
Rozmazanie pohybom | rozmaže obrázok jeho posúvaním v zadanom uhle toľkokrát a na takú vzdialenosť, ako si zadáte
Šum | pridá do obrázku šum
Vyrazenie do priestoru | vytvorí z obrázku "3D výlysok"
Vytvoriť gradient | vytvorí gradient zvoleného typu (napr. od čiernej do bielej)
Zväčšiť rozdiely | zväčí rozdiely v obrázku (pomôže napr. keď je rozmazaný)
Zatemniť obrázok | zmenší intenzitu svetla v obrázku
Uživateľsky definovaný | Táto funkcia umožňuje uživateľovi definovať vlastný filter podľa jeho želaní - podrobný manuál získate tu.
Paleta | Tu môžete nájsť všetky funkcie, ktoré pracujús paletou obrázkov (niektoré len pre obrázky s BPP menším alebo rovným ako 8)
Histogram | Táto funkcia slúži na prehľad o farbách použitých v obrázku - podrobný popis tu
Spočítať počet farieb | Pomocou tejto funkcie zistíte, koľko obrázok obrahuje farieb
Upraviť paletu | Ak má obrázok 8BPP a menej, môžete zmeniť jednotlivé položky palety pomocou tejto funkcie - v zobrazenom dialógu môžete "dvojklikom" zmeniť vybranú položku na inú farbu...
Exportovať paletu | Ak má obrázok 8BPP a menej, môžete exporovať jeho paletu v jednom z nasledujúcich formátov
Jasc formát | Formát palety používaný programom PaintShop Pro®
UniView formát | Binárny formát palety - prvý byte je (počet farieb-1) (preto môže nadobúdať hodnotu 1 až 256!), potom nasledujú postupne R, G, B hodnoty jednotlivých farieb...
Pero | nastaví aktuálny nástroj pero
Text | nastaví aktuálny nástroj text - funguje len pre 24-bitové obrázky!!!
Výber | nastaví aktuálny nástroj výber
Kvapátko | nastaví aktuálny nástroj kvapátko
Zmeniť počet farieb | pomocou tohto nástroja môžete zmenšiť počet farieb v obrázku (alebo zväčšiť). Viac informácií tu.
Zmeniť veľkosť | touto funkciou môžete zmeniť veľkosť obrázku. Viac informácií tu
Zmeniť vlastnosti farieb | touto funkciou môžete zmeniť vlastnosti farieb v obrázku. Viac informácií tu
Parametre pera | Touto funkciou môžete zmeniť typ, veľkosť a farbu pera.
Vybrať farbu pera | Touto funkciou môžete zmeniť farbu pera.


Menu: Štart

V tejto ponuke môžete nájsť rôzne pomocné programy, ktoré sa nedajú zaradiť do inej časti menu. Pevnou súčasťou programu UniView sú tieto utilitky:
Hromadná konverzia - spustí program na hormadnú konverziu súborov
Prezentácia - spustí program na vytváranie jednoduchých prezentácií založených na zobrazovaní obrázkov
Tvorič náhľadov - spustí program na vytváranie náhľadov
Zachytiť... - spustí program na zachytávanie obrázkov

Ďalšie programy (tzv. pluginy) si môžete stiahnúť z mojej domovskej stránky alebo od rôznych iných programátorov a firiem, ktoré sa venujú vývoju pluginov pre UniView. Prídavné programy si môžete vytvoriť aj sami (ak máte UNIVIEW PLUGIN SDK). Nápoveda k týmto programom je záležitosť ich autora...


Menu: Nápoveda

Táto ponuka slúži na oboznámenie uživateľa so stavom programu a na zobrazenie nápovedy...

Nápoveda
Nápoveda o nápovede
Informácie o pluginoch
Informácie o stave programu
O programe

Nápoveda - Zobrazí túto nápovedu (alebo nápovedu v inej jazykovej mutácii, záleží na nastavení jazyka)
Nápoveda o nápovede - Zobrazí informácie o tom, ako používať nápovedu
Informácie o pluginoch - Zobrazí informácie o pluginoch nainštalovaných v UniViewe
Informácie o stave programu - Zobrazí informácie o stave programu: práve otvorený súbor a jeho vlastnosti, zoznam podporovaných formátov
O programe - Zobrazí okno s informáciami o verzii programu, autorovi atď.


Histogram

Hlavné okno tejto funkcie vyzerá približne takto:

Je rozdelené na dve pomyslené časti: zobrazoavciu a nastavovaciu. V prvej časti môžete vidieť, koľkokrát je tá-ktorá intenzita zložiek R, G, B použitá, v druhej časti si môžete nastaviť spôsob zobrazenia... Ak potrebujete vidieť presné množstvá použitých farieb, stlačte tlačidlo "Používanosť farieb".
V tomto dialógu sa nachádza zoznam všetkých použitých farieb spolu s počtom, koľkokrát boli použité. Množstvo zobraznených farieb je limitované nastavením "Minimálny počet farieb jednej položky" v záložke "Rôzne". Ak má obrázok veľa farieb a vy "slabý" počítač, zvoľte toto číslo dostatočne veľké (napr. 500), inak stačí pre rovnaké množstvo - napr. 10.


Dialógové okno: Nastavenia

Pomocou tohto dialógového okna môžete nastaviť to, ako sa program bude správať pri určitých situáciách, asociácie s rôznymi typmi súborov atď. Okno je "rozdelené" pomocou záložkového systému na viacero logických častí, ktorých zoznam spolu s popismi jednotlivých položiek teraz budú nasledovať...
Základné nastavenia, Asociácie súborov, Multimédiá a text, Prehľadávanie, Rôzne→Import súborov

Základné nastavenia
Jazyk/Language/Sprache | pomocou tejto položky môžete nastaviť jazyk, pomocou ktorého s vami bude UniView komunikovať (táto možnosť sa prejaví až po ukončení dialógu tlačidlom OK). Poznámka: Nastavenie jazyka nemá vplyv na všetky hlásenia programu (napr. chyby pri čítaní PNG, GIF a pod. sa zobrazujú iba v anglickom jazyku)!
Ukázať panel s nástrojmi | Ak je zaškrtnuté, okno bude obsahovať panel nástrojov...
Plochý panel nástrojov | Ak je zaškrtnuté, panel s nástrojmi sa bude správať ako plochý, keď ponad neho prejde kurzor, tlačidlo pod ním sa "zdvihne"... Zmena sa úplne prejaví až po reštarte programu!!!
Ukázať stavový riadok | Ak je zaškrtnuté, okno bude obsahovať stavový riadok...
Uložiť pozíciu okna pri končení programu | Ak je zaškrtnuté, program si pamätá svoju poslednú pozíciu a pri opätovnom spustení sa opäť zobrazí v tejto polohe (pri obrázkoch je to samozrejme zložitejšie, tam sa okno prispôsobuje obrázku...)
Ploché posuvné lišty pri obrázokoch | Ak je zaškrtnuté, obrázky bodú rolovateľné pomocou posuvných líšt, ktoré však, na rozdiel od štandardnej situácie, budú vyzerať plocho.
Okno vždy na vrchu | Ak je zaškrtnuté, okno programu bude vždy viditeľné
Minimalizovať do panelu úloh | Ak je zaškrtnuté, program sa po minimalizácii presunie do panelu úloh (vedľa hodiniek). Späť do normálnej polohy sa dostane po stlačení ľavého tlačidla na ikone...
Opýtať sa na prepísanie súboru | Ak je zaškrtnuté, program sa pri ukladaní súboru na miesto, kde už existuje súbor s rovnakým názvom, pýta, či chcete tento súbor prepísať...
Prepisovať aj súbory označené len na čítanie | Ak je zaškrtnuté, program automaticky zmení atribúty pred uložením súboru tak, aby sa dal súbor ukladať aj na zvolené miesto...
Výstraha ak je pri končení aktívny plugin... | Ak je zaškrtnuté a pri končení programu je aktívny nejaký prídavný program UniView-u, opýta sa, či naozaj chcete program ukončiť (a tak stratiť neuložené dáta z týchto podprogramov).
Jednoduchý celoobrazovkový režim | Ak je zaškrtnuté, po spustení celoobrazovkového režimu bude na obrazovke vidno len okno dokumentu - tzn. nebude vidno menu, panel nástrojov ani stavový riadok. V opačnom prípade ich vidno bude...
Vybrať farbu... | Pomocou týchto dvoch tlačidiel si môžete vybrať farbu pozadia pre daný formát súboru (názvy tlačidiel sú dúfam samovysvetľujúce...)
Vybrať písmo pre textový editor | Po stlačení tlačidla si môžete vybrať písmo, ktoré sa bude používať ako základné pre zobrazovanie čisto textových formátov (formát RTF nie je týmto nastavením ovplyvnený).

Asociácie súborov
S obrázkami, s multimédiami, s ostatnými | V týchto zoznamoch si môžete vybrať formáty, s ktorými sa bude UniView asociovať (tzn. ktoré formáty sa budú spúšťať pomocou tohto programu), zaškrtnutím (tzn. vysvietením väčšinou modrou farbou) prípony formátu...
Vybrať ikonu | Po kliknutí na toto tlačidlo si môžete vybrať ikonu pre skupinu formátov, ktoré sa nachádzajú nad týmto tlačidlom...
Okienko na vstup textu | Tu môžete zadať ďalšie formáty, ktoré budú asociované s UniView-om (použitá bude ikona z posledného zoznamu...)
Ukazovať náhľady ICO súborov | Ak je zaškrtnuté, ikony súborov ICO budú v prieskumníkovi (a vo väčšine z iných súborových manažéroch) zobrazované ak náhľad na skutočný obraz...
Ukazovať náhľady BMP súborov | Ak je zaškrtnuté, ikony súborov BMP budú v prieskumníkovi (a vo väčšine z iných súborových manažéroch) zobrazované ak náhľad na skutočný obraz...
Nastavovať asociácie pri štarte UniViewu | Ak je zaškrtnuté, UniView automaticky asociuje vybrané formáty pri štarte programu (inak iba po spustení tohto dialógu)

Multimédiá a text
Multimédiá |
Automaticky meniť veľkosť filmu podľa veľkosti okna | Ak je zaškrtnuté, veľkosť videa sa bude automaticky prispôsobovať veľkosti okna.
Ukazovať panel prehrávača | Ak je zaškrtnuté, bude zobrazovaný panel prehrávača.
Ukazovať menu | Ak je zaškrtnuté, po stlačení pravého tlačidla na videu sa zobrazí roletové menu
Ukazovať chybové dialógy | Ak je zaškrtnuté, prehrávač bude podávať hlášky, ak sa pri prehrávaní vyskytne chyba
Ukazovať pozíciu | Ak je zaškrtnuté, bude zobrazený posuvník s pozíciou filmu...
Text |
Automaticky zalamovať textové súbory | Ak je zaškrtnuté, text v okne sa bude automaticky zalamovať tak, aby riadok mal veľkosť šírky okna
Vyberať celé slová | Ak je zaškrtnuté, v textových dokumentoch budete môcť vyberať pomocou myši celé slová...
Nikdy nepoužívať RichEdit 2.0 | Ak je zaškrtnuté, nebude možné používať nové vlastnosti rozhrania RichEdit 2.0. Nie je odporúčané zaškrtnúť túto voľbu.
Maximálny počer undo/redo | Táto voľba nastavuje maximálny počet krokov, ktorý sa bude dať vrátiť späť/zopakovať.

Prehľadávanie
Pri pohybe adresárom ukazovať | Vybraté položky určujú, ktoré typy súborov sa budú pri prechádzaní adresárov (pomocou Medzery, Backspace, F10, F11) zobrazovať...
Prehľadávať aj skryté a systémové súbory | Ak je zaškrtnuté, do zoznamu súborov budú pri prehľadávaní adresára zaradené aj skryté a systémové súbory
Zoraďovanie | Tu si môžete vybrať, akým spôsobom budú zoraďované položky pri prehľadávaní adresára.
Považovať za textové súbory | Súbory s príponami zapísanými vo vedľajšom okne budú automaticky otvárané ako textové (ak nebude zistený presný formát) - inak ako binárne súbory.
Zobrazovať detailné popisy chýb | Ak je zaškrtnuté, pre chybe v čítaní súboru bude zobrazený jeho detailný popis (alebo viac popisov)
Rýchlosť rolovania obrázkov | Tu môžete nastaviť rýchlosť rolovania obrázkov kurzorovými šípkami (čím väčšie číslo, tým väčšia rýchlosť)

Rôzne
Otváranie súborov: |
Upozorňovať na nesprávnu príponu súboru | Ak je zaškrtnuté a program zistí zlú príponu súboru (napr. že súbor typu PNG má príponu JPG), informuje o tom používateľa a ponúkne mu možnosť premenovať súbor tak, aby mal správnu príponu...
Ak nie je možné otvoriť... | V prípade povolenia tejto voľby sa súbory, ktoré nemajú formát, aký určil program podľa obsahu, otvoria vo formáte definovanom ich príponou. Tento postup zvýši percento úspešnosti otvárania súborov...
Nastavenia importu súborov | Pomocou tohto tlačidla môžete nastaviť parametre načítania niektorých typov súborov
Ostatné položky: |
Upozorňovať uživateľa pri zatváraní neuloženého súboru | Ak je zaškrtnuté, uživateľ bude upozorňovaný pri zatváraní súboru, ktorý je zmenený ale nie je uložený...
Zatvárať okno po začatí konverzie | Ak je zaškrtnuté, okno hromadnej konverzie bude po začatí konverzie zatvorené - tzn. stratíte možnosť opakovať konverziu - všetky súbory budete musieť zadať odznova...
Minimálny počet farieb jednej položky | Tu musíte zadať číslo, ktoré bude ohraničovať množstvo farieb zobrazené v okne Histogram (až v tom druhom). Viac informácií tu.

Po stlačení tlačidla "Nastavenia importu súborov" v záložke rôzne sa dostanete do dialógového okna, v ktorom môžete nastaviť parametre načítanie niektorých typov súborov. Tu je ich zoznam s popismi možných nastavení...

Import súborov
ASCII art import | V tejto časti môžete nastaviť vlastnosti načítania AA súborov - použitý filter a veľkosť políčok...
RAW/YUV import | Tu sa nastavuje veľkosť RAW/YUV súborov (pretože túto informáciu neobsahujú), offset od ktorého sa má začať čítať súbor, poradie a prekladanosť kanálov pre RAW súbory a prekladanosť YUV súborov.
ICO/ICL | Tu môžete nastaviť, ako budú otvárané ICO/ICL súbory (najlepší je 1. spôsob, pretože ak ikona obsahuje viac obrázkov, môžete si vybrať sami).
LBM (=IFF,ILBM) | Ak chcete, aby bol súbor implicitne identifikovaný ako typ HAM alebo Extra_Halfbrite aj napriek tomu, že tak nie je určené v CAMG sekcii, môžete zaštrnúť prvý prepínač tak, aby jeho nadpis zobrazoval názov jedného z týchto typov. Ak chcete, aby program zistil sám typ súboru, ponechajte ho tak, aby mal nadpis "*". Ak zaškrtnete druhú voľbu (nastaviť farby), program bude upravovať určité druhy 4-bitovej palety na 8-bitovú. V prípade, že chcete preskočit niektoré sekcie súboru, môžete pomocou posledného editačného riadku zadať 4-byteové hlavičky sekcií tvorené veľkými znakmi (napr. PSIM alebo CMAP). Musíte ich oddeľovať práve jednou medzerou!!!


Dialógové okno: Nový súbor

V tomto okne môžete vytvoriť nový súbor podľa vašich želaní (a potom si ho upraviť a uložiť). Máte na výber niekoľko typov súborov, sú to textový súbor, binárny súbor a obrázok. Po vybratí typu súboru si môžete nastaviť aj jeho vlastnosti a potom stlačením tlačidla OK ho môžete vytvoriť. Ak stlačíte tlačidlo zrušiť, žiadny súbor nebude vytvorený.

Varovanie: Súbor, ktorý vytvoríte musíte pred ukončením programu uložiť, inak bude celý jeho obsah stratený. Program sa ale pred skončením pýta, či chcete súbor uložiť...

Typ súboru | Vlastnosť | Popis vlastnosti
Textový súbor | bez nastavení |
Grafický súbor | X | Horizontálna veľkosť obrázku v bodoch
 | Y | Vertikálna veľkosť obrázku v bodoch
 | BPP | Bitová hĺbka obrázku. Štandard je 24, najlepšie je začať s týmto parametrom. Bližšie informácie tu.
Binárny súbor | bez nastavení |


Dialógové okno: O programe

Základným účelom totho dialógového okna je poskytnúť užívateľovi informáciu o verzii programu, domovskej stránke a emailovej adrese autora... Okrem toho sa tu nachádza zoznam použitých knižníc a niekoľko tlačidiel na zobrazenie podrobnejších informácií o stave programu (verzie niektorých knižníc, podporované formáty, aktuálny súbor a jeho vlastnosti, inštalované pluginy atď.)


Dialógové okno: Otvoriť súbor

Toto okno je skoro úplne totožné s oknami, ktoré vám poskytne väčšina programov, ak chcete otvoriť nejaký dokument. Sú tu dva rozdiely oproti ostatným programom: výber filtrov(rozbalovacia lišta v spodnej časti okna). Tu si môžete vybrať z množstva ponúkaných možností. Ak nemôžete nájsť hľadaný súbor, zmeňte si aktuálnu položku na "Všetky súbory (*.*)" (=All files). Ak sa vám ani potom súbor nedarí nájsť, pravdepodobne je označený ako skrytý alebo systémový (alebo sa jedná o DLL súbor) a kvôli nastaveniam systému windows sa takéto súbory u vás nezobrazujú... V prípade že nájdete hľadaný súbor môžete ho otvoriť.
Druhý rozdiel je časť s náhľadom, ktorá obsahuje informácie o obrázku, ktorý je práve vybratý: veľkosť a zmenšený náhľad naň...


Tlač súborov

V súčasnej verzii programu UniView je možné tlačiť textové a grafické súbory. Táto funkcia je len experimentálna a je možné, že sa v budúcich verziách ešte zmení!. Súbor sa dá vytlačiť použitím položky Súbor-Tlačiť.

Tlač textových súborov
Po spustení funkcie sa zobrazí štandardné windows okno, v ktorom si môžete vybrať veľkosť papiera, tlačiareň na ktorej budete tlačiť a iné veci :-) Po potvrdení tlačidlom OK sa zobrazí okno informujúce uživateľa o tom, ktorá strana ktorého súboru sa práve tlačí. Tlačenie sa dá ukončiť tlačidlom "Zrušiť" (vďaka chybe vo Windows ostane úloha v tlačovej fronte, ale nevytlačí sa). Po dokončení tlače sa okno automaticky zatvorí.
Program má bohužiaľ problémy aj s tlačením odstavcov vytvorených klávesou TAB. V ďalšej verzii to bude určite opravené...

Tlač grafických súborov
Po spustení funkcie sa zobrazí štandardné windows okno, v ktorom si môžete vybrať veľkosť papiera, tlačiareň na ktorej budete tlačiť a iné veci. Potom sa ukáže nasledovné okno (v skutočnosti má 2x veľkosť :).

V tomto okno si môžete nastaviť akým spôsobom budú obrázky umiestňované na papier a ich veľkosť. Najprv si opíšeme pravú časť okna - tá určuje, ktorá časť stranu bude využiteľná obrázkom, teda jej okraje. Myslím, že k tomu niet čo dodať. Snáď len to, že jednotky týcho údajov sú zadávané v ponuke Použité jednotky. Jednotky vybraté v tejto ponuke sa použijú aj na políčka vlastná veľkosť.
Hlavnú časť okna tvorí zoznam možných nastavení veľkosti v ľavej časti okna. Môžete si vybrať jeden zo štyroch spôsobov:
  • Najlepšie rozmiestnenie - program automaticky nastaví veľkosť obrázku tak, aby sa presne zmestil do priestoru vyhradeného zadanými okrajmi. Môžte si všimnúť, že program vždy zachová pomer strán obrázku
  • Roztiahnúť na stranu - obrázok je roztiahnutý na maximálnu možnosť veľkosť (podľa okrajov) nehladiac na pomer strán obrázku
  • Mierka - pomocou tejto voľby môžete nastaviť veľkosť obrázku pomocou násobkov jeho pôvodnej veľkosti. Ak sa obrázok so zadanými rozmermi nevôjde do vyhradeného priestoru, prekračujúci rozmer bude automaticky zmenšený (nie však v poli na zadanie rozmerov!!!) a budete o tom upozornení v spodnej časti okna
  • Vlastná veľkosť - tu zadávate priamo veľkosť obrázku v zadaných jednotkách. Čo sa týka prekračovania rozmerov, platia tie isté podmienky ako pre predchádzajúci prípad

Ak máte zašktnutú voľbu "Vycentrovať na strane", obrázok bude vo všetkých prípadoch okrem 2. umiestnený do stredu oblasti určenej okrajmi...
Spodnú časť obrazovky tvoria: náhľad na vyslednú stranu (okraje sú naznačené tenkými čiarami, ktoré sa nevytlačia!) a informácie o tom, ktorý rozmer obrázku prekročil okraje (X je vodorovná, Y zvislá veľkosť) - je to naznačené výkričníkom vedľa označenia osi veľkosti.

Ak už ste všetko potrebné zadali, môžte obrázok vytlačiť - samozrejme pomocou tlačidla "Tlačiť". Zrušiť operáciu môžte ešte stále pomocou tlačidla "Zrušiť". Ak použijete prvú možnosť, operáciu už nie je možné z UniView-u zrušiť, pretože obrázok bude okamžite poslaný na ovládač vybranej tlačiarne. Zrušiť tlač môžete potom napr. vymazaním dokumentu s fronty alebo... ale to už nie je účelom tejto nápovedy :)


Dilógové okno: Uložiť súbor ako

Dialógové okno: Uložiť súbor ako...

Pomocou tohto dialógového okna môžete ukadať súbory, ktoré máte práve otvorené v programe UniView. Je takmer totožný s oknami, ktoré používajú aj ostatné programy... Jediný rozdiel je v tom, že obsahuje jedno tlačidlo navyše: "Voľby". Toto talčidlo slúži na nastavnenie parametrov výsledného súboru. Nastavenia nefungujú u každého formátu, podrobné informácie o možnostiach nastavenia výstupného formátu sa dozviete v časti Podporované formáty.


Uživateľsky definovaný efekt

Uživateľsky definovný efekt

Po spustení tejto funkcie sa vám ukáže približne takéto okno:

Mohli ste si všimnúť pole vstupných polí vo vrchnej časti obrázku, ktoré slúžia na nastavenie "váhy" jednotlivých pixelov. Ďalej sa tu nachádza faktor delenia, ktorý by mal byť pre efekt nemeniaci celkovú svetlosť obrázku rovný súčtu všetkých váh. Nakoniec parameter odchýľka dovoľuje nastaviť výslednú svietivosť výsledného pixelu. A ako to celé funguje? Najlepšie nám poslúži príklad. Máme pole s nasledovnými vlastnosťami:
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 1 | 0 | 0 | 0
0 | 0 | 1 | 2 | 1 | 0 | 0
0 | 0 | 0 | 1 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0

Pole faktor delenia má hodnotu 6 a odchýľka hodnotu 0. Ako sa teraz vypočíta výsledný pixel? Celé to funguje na jednoduchom matricovom princípe, pričom pixel, ktorý je vyznačený hrubým písmom (v dialógu iným okrajom políčka) je ten, čo je vyhodnocovaný. Všetky naokolo sú pixely, ktoré ležia v danej pozícii okolo tohto hlavného. Pre kažkú zložku R, G, B sa postupne celá matrica vyhodnotí násobením každého z pixelov zadaným číslom a nakoniec sa všetko vydelí faktorom delenia a pripočíta sa hodnota odchýľka. Nezabudnite, že ľubovoľná každá z týchto hodnôt môže mať aj zápornú alebo nulovú hodnotu. Ak má faktor delenia hodnotu 0, výsledný súčet nie je delený ničím (to isté ako keby tam bolo číslo 1).
Ak teda chcete vytvoriť napr. efekt, ktorý nebude nič robiť (teda nemá zmysel, ale pre naše potreby sa zíde), vytvoríte ho nasledovne:

0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 1 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0
0 | 0 | 0 | 0 | 0 | 0 | 0

, pričom nastavíte faktor delenia na 1 a odchýľku na 0. Pokiaľ by ste chceli vytvoriť jednoduchú funkciu "rozmazať", použite prvý uvedený príklad... Ďalšie filtre nechám na vás - a pokiaľ by ste "vynašli" nejaký dobrý, dajte mi vedieť!


Zmeniť počet farieb

Pomocou tejto funkcie môžete zmeniť počet možných farieb v obrázku. Hneď po spustení funkcie sa vám ukáže dialóg, v ktorom si môžete tento počet vybrať (a zároveň nastaviť druh a paremetre filtrov).
Pre zmenu počtu farieb na 3 - 256 môžete použiť Floyd-Steinberg zrnenie, ktoré dopomôže k tomu, aby sa obrázok zmenil čo najmenej (čo sa týka celkového výzoru). Ďalšími možnými nastavniami sú položky "Farby porovnať:" a "Farby vyberať ako". Pomocou nastavovania rôznych hodnôť môžete mierne zmeniť výsledný vzhľad obrázku. Odporúčané hodnoty sú "podľa svetlosti" pre prvú položku a "priemer bodov" pre druhú položku.
Ak zmenšujete počet farieb na 2, obrázok bude prevedený na čiernu a bielu. Na prevod môžete použiť niektorý z dostupných filtrov, pričom najúčinnejšie sú Floyd-steinberg a Hilbert (ale v niektorých prípadoch možno radšej použijete iný). Pre Hilbert filter môžete ešte nastaviť jeho detailnosť (čím nižšie číslo, tým lepšie, minimálne 1).

Rada: V prípade, že chcete znížiť farebnú hĺbku na niekoľko farieb (napr. 5) z obrázku, ktorý ich má relatívne veľa, odporúčam vám postupovať po krokoch, ak chcete dosiahnúť dobré výsledky (teda najprv zmenšiť počet farieb na 256, potom na 16 a nakoniec na 5). Taktiež vám odporúčam skúšať viaceré typy filtrov (napríklad, základné filtre "podľa svetlosti" a "priemer bodov" sa hodia na fotografie. Ak chcete kvantovať napríklad diagramy alebo zachytené obrázky obrazovky, môžte skúsiť napr. "normálne" a "stred štvroca" - táto kombinácia mi zaistila prijateľné výsledky...)


Zmeniť veľkosť

Touto funkciou môžete zmeniť veľkosť obrázku na vami zvolenú a za pomoci niektorých filtrov zachovať kvalitu - stačí zvliť ten správny...
Prvým krokom je však výber typu zmeny veľkosti - výber či chcete obrázok iba orezať alebo ho zmenšiť/zväčšiť je iba na vás. Ptom prichádza na rad výber veľkosti - môžete si vybrať zo štyroch prednastavených alebo zadať vlastnú - pokiaľ však máte zaškrtnutú voľbu "zachovať pomer strán", nemôžete ich meniť ľubovoľne - pomer strán X:Y bude stále rovnaký (samozrejme) - to platí aj pre prednastavené voľby!. Posledným krokom pre zmenu veľkosti pomocou typu "zmenšiť/zväčšiť" je výber filtra. Tie sú zoradené podľa kvality (a zároveň náročnosti) vzostupne. Hneď prvý - Windows - je najmenej kvalitný, jeho rýchlosť však vysoko predstihuje ostatné. Naopak, jeden z najkvalitnejších je Lanczos 3, ku ktorému je veľmi podobný Hermite. Každý je však určený na niečo iné, preto odporučam najprv všetky filtre vyskúšať osobne a vybrať si ten, ktorý sa vám hodí najviac...


Zmeniť vlastnosti farieb

Pomocou tejto funkcie môžete zmeniť vlastnosti farieb
- intenzitu zložiek R, G, B
- farebný odtieň
- saturáciu
- svetelnosť
- Gammu

Jednotlivé položku sa postupne upravujú v uvedenom poradí. Výsledky môžete vidieť vo vedľajšom náhľade.


Hromadná konverzia

Táto veľmi užitočná funkcia slúži na zmenu formátu niekoľkých súborov naraz. UniView podporuje okrem tejto základnej možnosti aj zmenu názvu súboru, nastavenie výstupného adresára a aplikáciu efektov pred tým, ako je súbor uložený pod novým formátom. Teraz bude nasledovať podrobný popis ovládania...

Hlavné okno je nápadne podobné s oknom Otvoriť súbor a niektoré jeho prvky majú aj podobnú alebo rovnakú funkciu. Nachádzajú sa tu štandardné prvky - výber súboru, zmena zobrazenia zoznamu súborov, vytváranie adresáru atď. Popis týchto prvkov môžete získať v nápovede Windows. Tlačidlo Otvoriť tu funguje trochu inak ako v štandardnom dialógu - otvorí súbor v programe UniView ale nezatvorí okno s výberom súborov (to je možné využiť napr. ak neviete, ako sa presne súbor volá a chcete sa uistiť). Tlačidlom "Zrušiť" ukončíte dialóg.

Ostatné prvky už nie sú štandardné a slúžia na nastavenie parametrov konverzie. Pre prehľadnosť teraz nasleduje obrázok tohto okna. Informácie o jednotlivých prvkoch sa dozviete po kliknutí na ne... Zoznam súborov na konverziu Vymaže vybrané súbory zo zoznamu Vyprázdni zoznam súborov Výstupný formát Výber vlastností formátu Aplikácia efektov na výstupný obrázok Výstupný adresár Formát názvu výstupného súboru Vybranie adresára pomocou dialógu Zoznam možností výstupného formátu názvu súboru :-) Načíta konfiguráciu hromadnej konverzie z vybraného súboru Uloží aktuálnu konfiguráciu do vybraného súboru Začne konverziu

Zoznam súborov - tento zoznam obsahuje výpis všetkých súborov, ktoré budú konvertované. Súbory môžete pridať do tohto okna pritiahnutím súborov z vedľajšieho zoznamu súborov (štandardného pre dialóg otvoriť súbor) alebo ľubovoľného iného umiestnenia, ktoré podporuje drag&drop funkcionalitu (teda napr. z programov Prieskumník, Windows Commander atď.). Ak chcete z tohto zoznamu vymazať niektoré súbory, jednoducho ich označte a odstránite ich stlačením tlačidla '-', ktoré sa nachádza hneď vedľa. Ak chcete vymazať odstrániť všetky položky, stlačte tlačidlo s nápisom 'X'.
Výstupný formát - V tomto vysúvacom zozname si môžete vybrať formát, v ktorom bude výstupný súbor uložený
Výber vlastností formátu - Po stlačení tlačidla môžete nastavovať vlastnosti všetkých možných výstupných formátov (ako prvé sa zobrazí nastavenie pre vybranú príponu - ale iba ak nejaké nastavenia sú)
Aplikácia efektov - Stlačením tohto tlačidla sa dostanete do dialógového okna, v ktorom si môžete nastaviť efekty, ktoré budú aplikované na jednotlivé súbory pred uložením...
Formát názvu výstupného súboru - Tu si vyberáte (musíte) formát výstupného názvu súboru. Zoznam jednotlivých položiek získate po stlačení tlačidla vedľa. Rada: Ak chcete docieliť, aby sa názvy výstupného súboru tvorili v štýle "pôvodný názov.nová prípona", musíte zadať "?n.?x". Môžete použiť lubovoľný sled znakov (samozrejme iba tých, ktoré sa môžu nachádzať v názve súboru), utilita nahradí iba časti so znakom '?'...
Načítanie konfigurácie - Načíta konfiguráciu uloženú vo vybranom súbore - spolu s ďalšou funkciu sú vhodné pri striedaní rôznych typov konverzií dookola
Uloženie konfigurácie - Uloží konfiguráciu do daného súboru
Konverzia - Začne konverziu. Po spustení sa zobrazí okno s výpisom všetkých akcií, ktoré sa vykonávajú. Konverzia môže byť prerušená tlačidlom "zrušiť", ale budete musieť počkať do uloženia práve konvertovaného súboru (ak je nejaký spracovávaný)...


Prezentácia

Funkcia prezentácia (po anglicky slideshow) je funkcia, pomocou ktorej môžete vytvoriť jednoduchú prezentáciu založenú na zobrazovaní definovanej sady obrázkov v celoobrazovkovom režime. Môžete nastaviť tak poradie obrázkov ako aj spôsob zobrazenia a posúvania sa v zozname. Základné konfiguračné okno je podobné na okno Hromadnej konverzie alebo dialógu Otvoriť súbor.

Najdôležitejšou časťou je zoznam súborov v ľavej hornej časti okna. Súbory do neho môžete pridávať metódou drag&drop (ťahaj a pusti), tak isto ako v okne hromadnej konverzie. Dôležitou vlastnosťou tohto spôsobu je to, že do zoznamu môžete "pretiahnuť" aj konfiguračný TXT súbor (nemusíte teda nutne používať tlačidlo nahrať konfiguráciu)... Tlačidlo s dlhou čiarou (napravo od zoznamu) slúži na odstránenie vybraných súborov zo zoznamu. Pomocou tlačidla "X" vymažete všetky súbory zo zoznamu.

Na zoraďovanie súborov v zozname môžete použiť tlačidlá v skupine "Poradie/Zoraďovanie". Od vrchu slúžia na: Zoradenie podľa mena, zoradenie podľa prípony, zoradenie podľa dátumu poslednej zmeny, zoradenie podľa veľkosti súboru. Pomocou spodného tlačidla (Otočiť poradie) otočíte poradie súborov - prvý bude posledný, posledný prvý atď. Stlačením tlačidla "Rozhádzať" bude vykonané náhodné rozmiestnenie súborov v zozname.

V skupine "Nastavenia" môžete dolaďovať celkový vzhľad prezentácie. Prvou vecou, ktorú musíte nastaviť je štýl presúvania v zozname. Môže to byť buď automatické (pri tomto nastavení musíte zadať aj čas medzi dvomi obrázkami) alebo manuálne (na pohyb musíte stlačiť ľubovoľné tlačidlo na klávesnici alebo myši).
Ďalšie nastavenia sa týkajú ostatných vlastností prezentácie. Po zaškrtnutí prvého prepínača (ukazovať v slučke) budú obrázky zobrazované dookola až do manuálneho prerušenia prezentácie. Druhým prepínačom (neupozorňovať na chyby) zabezpečíte, aby počas prezentácie neboli zobrazované žiadne hlášky programu o chybách. Tretím prepínačom (ukazovať meno súboru) povolíte zobrazovanie mena súboru v ľavom hornom rohu obrazovky. Ak zaškrtnete posledný prepínač (skryť kurzor myši), kurzor myši nebude nad oknom prezentácie viditeľný.

Pomocou tlačidiel uložiť a načítať konfiguráciu môžete ukladať alebo načítavať zoznamy súborov z textových súborov...

Prezentácia sa spúšťa tlačidlom Štart. Prezentáciu môžete kedykoľvek prerušiť tlačidlom ESC alebo kombináciou Alt+Enter (alebo Alt+F4). Toto sa nevzťahuje na proces načítavania súboru, ktorý sa prerušiť nedá...


Tvorič náhľadov

Táto utilitka programu UniView slúži na vytváranie katalógov obrázkov... Jeho použitie je naozaj jednoduché - po spustení sa na obrazovke zobrazí okno s niekoľkými prvkami: Hneď pod titulkom okna sa, ako vo väčšine okien, nachádza menu, z ktorého sú dostupné všetky funkcie utilitky. Pod menu sa nachádzajú 2 okná - jedno je okno obsahujúce stromový výpis všetkých dostupných adresárov (a mechaník - tie sú hneď na prvej úrovni označené ako x:\, kde x je písmeno mechaniky) počítača (aktuálne nepodporuje prácu s počítačmi v sieti :-( ) a druhé, ktoré obsahuje náhľady na súbory, ktoré sa nachádzajú v vybranom adresári. To, akým spôsobom budú náhľady vytvárané sa nastavuje pomocou položky menu Náhľady-nastavenia. Ak chcete vytvoriť HTML katalóg, vyberte si obrázky, ktoré v ňom majú byť a použite Náhľady-Vytvoriť HTML katalóg... Ak chcete vytvoriť obrázkový katalóg, tiež si najprv označte obrázky, ktoré v ňom majú byť a potom spustite Náhľady-Vytvoriť obrázkový katalóg... Na rýchly výber všetkých obrázkov môžete použiť prvok menu Vybrať všetko. Na ukončenie programu použite prvok menu Koniec (alebo Alt+F4 či krížik v titulku okna...).

Nastavenia
V tomto dialógovom okne môžete nastaviť parametre, pomocou ktorých bude program vytvárať náhľady na obrázky a takisto aj niektoré vlastnosti výsledných katalógov. Prvou základnou vlastnosťou, ktorú treba nastaviť je veľkosť náhľadu (zadáva sa v pixeloch). Obe hodnoty, šírka aj výška, môžu nadobúdať hodnoty od 1 do 1024, je však odporúčané nezadávať hodnoty väčšie ako 300, pretože väčšie množstvá veľkých náhľadov rýchlo zapĺňajú pamäť a väčšinou nemajú praktický význam. Takisto je vhodné zadať obe hodnoty rovnaké (napr. 86x86, 100x100 atď.). Ak chcete na náhľadoch dosiahnuť efekt tlačidiel, zaškrtnite voľbu "Vytvárať hrany". Ďalej je potrebné zadať farbu okrajov - ak nezaškrtnete predchádzajúcu voľbu, je odporúčané aby táto farba bola rovnaká ako farba pozadia. Farba pozadia je použitá ako pozadie nielen pre utilitu ale použije sa aj pri vytváraní HTML aj obrázkových katalógov.

HTML katalóg
Keď ste už nastavili všetky vlastnosti, ktoré ste chceli a máte takisto vybrané obrázky, ktoré chcete v katalógu, môžete použiť túto funkciu aby za vás vytvorila HTML katalóg s náhľadmi, ktoré môžete použiť napr. na www stránkach. Základným nastavením je umiestnenie katalógu, zadáva sa iba adresár, pretože katalóg sa bude skladať z viacerých súborov a adresárov (popis na konci odseku). Nemenej dôležité je nastavenie formátu náhľadov, ktoré môže ovplyvniť kompatibilitu s internetovými prehliadačmi a zároveň výrazne zmenšiť/zväčšiť veľkosť výsledného katalógu. Ak plánujete umiestniť katalóg na internet a na kvalite vám príliš nezáleží, použite JPG. Ak vám na kvalite záleží (a takisto chcete katalóg umiestniť na internet), použite formát PNG. Ak chcete náhľady z katalógu ešte použiť v nejakom sofistikovanom grafickom programe, použite formát TIFF alebo PNG. Ak chcete dosiahnúť kvalitnejšie náhľady, zašktrnite voľbu "použiť prevzorkovanie...". Ďalej už iba "kozmeticky updavujete" výsledný katalóg - jeho titulok, maximálny počet stĺpcov v ňom. Takisto si môžete vybrať aj to, či pôvodné súbory budú uvádzané odkazom (a teda katalóg bude použiteľný iba na vašom počítači alebo na počítači s rovnakým umiestnením týchto súborov - nie je vhodné na internet) alebo budú skopírované do výstupného adresára (to síce zaberie viac miesta, ale súbory budú prístupné každému...). Poslednou skupinou vlastností, ktoré treba zadať sú informácie, ktoré budú zobrazené pri každom náhľade - môže to byť pôvodný názov súboru, jeho rozmery a veľkosť (dĺžka) na disku (ktorá je udávaná v bytoch). Po zadaní všetkých potrebných parametrov už nič nebrázni v spustení funkcie pomocou tlačidla "Štart" - stačí chvíľu počkať a katalóg je pripravený na používanie. Pozor! Pri väčšom množstve náhľadov sa môže zdať, že program "zamrzol" - je to síce možné :), ale pravdepodobne mu dlho trvá, kým všetky obrázky spracuje...
PS: Náhľady, budú takej istej veľkosti aké sú v hlavnom okne utility...
Popis výstupu HTML: Hlavný súbor katalógu je _index.html. Je povolené ho akokoľvek meniť ale musíte niekde v kóde uviesť (alebo zachovať) text "UniView" (nemusí byť viditeľný) - pre moju radosť z používanosti programu :-). Vytvorené náhľady sa nachádzajú v adresári _thumbnails_ a skopírované obrázky (ak ste zadali kopírovať) v adresári _images_.

Obrázkový katalóg
Pomocou tejto funkcie môžete vytvoriť jediný obrázok s náhľadmi na viaceré obrázky. Myslím, že všetky (alebo aspoň väčšina) položiek je zrozumiteľná, len dodám pár detailov: Položka "Okraje obrázku" slúži na nastavenia okrajov celého výsledného obrázku. Ak nezaškrtnete položku hlavička alebo päta strany poprípade nezadáte do polí text, nebude tá-ktorá položka vložená do výsledného obrázku... Po spustení funkcie pomocou tlačidla "Štart" sa začne vytváranie obrázku - to môže v niektorých prípadoch trvať dlho (najmä ukladanie do niektorých formátov ako PNG alebo TIFF s kompresiou) - preto prosím počkajte...
PS: Obrázky v tomto type katalógu môžu mať inú veľkosť ako ste zvolili v nastaveniach (záleží od nastavení tejto funkcie - obrázky totiž menia svoju veľkosť dynamicky podľa zostávajúceho voľného miesta - to je ale už algoritmus programu, ktorým vás nechcem zatažovať...).

Technická poznámka: Ak v nemáte v hlavnom programe otvorený žiadny súbor, tvorič náhľadov sa otvorí v štandardnom stave - bez vybraného adresára a bez vytvorených náhľadov. V opačnom prípade sa otvorí adresár, v ktorom na nachádza práve otvorený súbor...


Zachytiť...

Funkcia "Zachytiť" je určená k jedinému účelu - snímaniu časti obrazovky a ukladaniu týchto snímok na presne určené miesto...

Po spustení tejto funkcie sa vám ukáže dialógové okno obsahujúce všetky potrebné nastavenia pre túto funkciu. Je rozdelené na niekoľko častí, ktoré sú popísané v prehľadnej tabuľke.
Časť obrazovky | Tu si môžete vybrať časť obrazovky, ktorú si chcete zachytiť. Môže to byť celá obrazovka, celé okno v popredí alebo obsah okna v popredí (to isté ako celé okno, ale bez titulku okna, menu a posuvných líšt).
Spôsob zachytávania | Tu určujete, akým spôsobom budete riadiť zachytávanie obrazovky. Máto na výber medzi časovým intervalom a stláčaním tlačidla. Ak si vyberiete časový interval, obrazovka bude snímaná každých n sekúnd, podľa vášho výberu. Pri druhej voľbe bude obrazovka zosnímaná vždy po stlačení vybranej kombinácie tlačidiel. Pozn.: Ak je v čase zachytávania ešte stále aktívna predchádzajúca úloha (ukladá sa súbor z predchádzajúceho snímania), snímanie sa nevykoná a budete musieť počkať na jej dokončenie (oznámené krátkym "puknutím speakera"). Toto môže byť nepríjemné hlavne v prípade nastavnia melého časového limitu alebo pri viacnásobnom stlačení kombinácie tlačidiel potrebných na snímanie. V taktomto prípade sa môže stať, že obrazovka bude ešte niekoľkokrát snímaná po požadovanom okamihu (oneskorená reakcia v dôsledku nedostatočného výkonu procesoru...).
Výstup... | V tejto časti okna určujete, kam sa budú zosnímané obrázky ukladať a aký budú mať formát. Ak vybraný adresár nebude existovať, program ho automaticky vytvorí. Výstupný súbor bude mať vybraný formát a jeho meno bude tvorené pomocou "predpony" uniview_, po ktorej bude nasledovať informácia o dátume a čase vzniku súboru. Ak súbor s takýmto menom už existoval a nebol len na čítanie, bude prepísaný! Upozornenie:Adresár musí mať formát "x:\cesta" alebo "x:\cesta\". Pri iných formách zápisu cesty autor neručí za umiestnenie súborov (napr. x:cesta spôsobí, že adresáre budú vytvárané rekurzívne! To nie je chyba programu ale OS, mám to overené...)
Tlačidlá na boku | Stlačením tlačidla "Začať" sa začjne proces snímania obrazovky. Tlačidlom "Zrušiť" ukončíte beh funkcie...

Po spustení snímania tlačidlom "Začať" sa ukáže okno, ktoré vám dovolí kedykoľvek zastaviť ďalšie snímanie obrázkov. Po stlačení tlačidla "zrušiť" v tomto okno bude priebeh snímania zastavený. Ak sa práve v čase stlačenia tlačidla ukladal výstup, beh funkcie bude dokončený po ukončení ukladania.

Pozn.: Nie je zaručené, že program bude schopný zosnímať obsah obrazovky kedykoľvek. Problémy môžu nastať hlavne pri multimediálnych hrách a pri prehrávaní videa niektorými prehrávačmi. V takýchto špecifických prípadoch, keď UniView nie je schopný získať snímku obrazovky, odporúčam obrátiť sa na profesionálne programy (napr. HyperSnap a pod.).


Farby

TÁTO ČASŤ NÁPOVEDY JE URČENÁ HLAVNE PRE POKROČILÝCH POUŽÍVAŤEĽOV GRAFICKÝCH PROGRAMOV

V tejto časti môžete nájsť podrobnejšie informácie o niektorých pojmoch spomenutých v tejto nápovede. Určite nie sú potrebné (a pravdepodobne ani pochopiteľné) pre väčšinu ľudí, ktorí sa nevenujú grafike...

RGB - je farebný model, ktorý sa využíva väčšinou na počítačových monitoroch a vo väčšine grafických programov je základným formátom pre jeho jednoduchosť a ľahké technické zobrazenie na monitoroch (ktoré, ako viete zobrazujú informácie práve pomocou červenej, zelenej a modrej). Farba v tomto formáte má tri položky - Red (červená), Green (zelená) a Blue (modrá). Jednotlivé položky určujú intenzitu danej zložky farieb, pričom výsledná farba sa získa na princípe, ktorý zobrazuje obrázok. Každá položka môže mať hodnotu 0-1, pričom 0 znamená nulovú intenzitu. Na počítačoch, sa tieto hodnoty vo väčšine prípadov zadávajú v celočíselných hodnotách, najčastejšie v rozmedzí 0-255 (je to vlastne 255-násobok predchádzajúceho typu hodnoty). Tento formát používa aj UniView ako základný, preto práca s takýmito obrázkami je najrýchlejšia...
Nákres miešania RGB farieb

CMYK - farebný model používaný hlavne vďaka jeho ľahkej aplikovateľnosti na počítačové tlačiarne (väčšina farebných tlačiarní, ak nie všetky, využíva na "prenos" obrázkov z počítača na papier formát CMYK). Tento farebný formát sa skladá zo 4 hodnôt - Cyan (kyanová), Magenta (magentová), Yellow (žltá) a blacK (čierna). Formát sa dá opísať ako inverzný k modelu RGB, napriek tomu tak vďaka veľkej technickej rozdielnosti monitorov a tlačiarní nie je, pokiaľ sa používajú všetky 4 hodnoty (vysvetlenie ďalej). Ak sú použíté len hodnoty CMY, je situácia jednoduchá, jednotlivé hodnoty možno určiť podľa nasledujúcej tabuľky:
R= | 255-C
G= | 255-M
B= | 255-Y
----- | -----
C= | 255-R
M= | 255-G
Y= | 255-B

V prípade, že sa používajú všetky 4 hodnoty (čo je na väčšine tlačiarní), je situácia zložitejšia a odkazujem tým čitateľa na špecializovanú literatúru, ak sa chce dozvedieť viac ako je v nasledujúcich riadkoch uvedené. Teda aký je rozdiel? Ako príklad použijem tlačiareň. Pri tlači len farbami CMY dochádza pri tlačení čiernej farbe k efektu mokrého papiera, ktorý potom potrebuje relatívne veľa času na vyschnutie, kvoli tomu, že sa na jednotlivé body nanáša plné množstvo všetkých troch farieb. Pre vyriešenie tohto technického problému bol zavedený práve spomínaný farebný model. Ide o jednoduchú fintu - použiť jednu farbu naviac - čiernu (alebo sivú) na zmenšenie množstva použitej farby. Namiesto troch farieb pri tlačení čiernej sa teda použije iba jedna a tak dochádza k úspore času potrebného na tlačenie, nákladov a v neposlednej rade aj k rýchlejšiemu schnutiu papiera. Jediná nevýhoda je nutnosť používať zložitejšie algoritmy na získanie výsledného obrazu...
PS.: Farebný model CMYK sa, ako som už spomenul, používa na tlačiarňach. Tá sa kvalitou zobrazenia nemôže vyrovnať monitoru - nedokáže totiž tlačiť farby bližiace sa k čistej červenej, zelenej a modrej a dochádza teda k degradácii obrazu. Dole môžete vidieť náčrt kombinácie farieb C, M a Y farby. Takto by sa mali namiešať farby po vytlačení - v skutočnosti sa však takéto svetlé farby vytlačiť nedajú. Ak chcete poznať presnú príčinu, odporúčam vám nejakú odbornú publikáciu (napr. Adobe Photoshop 5 - referenčná príručka).
Nákres miešania CMY farieb

HSV, HSL, HSB - postupom času už ľuďom nestačili len počítačové metódy reprezentácie farieb a boli "vynájdené" ďalšie farebné modely, medzi inými HSV (Hue Saturation Value), HSB (Hue Saturation Brightness), a HLS (Hue Lightness Saturation), pričom Hue=odtieň, Saturation=sýtosť, Brightness,Value,Lightness=jas. Všetky modely sú zhodné, majú len rozdielne názvy hodnôt alebo iné poradie. Teraz budem pre príklad používať model HLS. Skladá sa z troch hodnôt. Hue označuje farebný odtieň a udáva sa v stupňoch, teda môže mať hodnotu 0-360°. Na obrázku môžete vidieť ich umiestnenie pri intenzite a jase 50... Ďalšie hodnoty sú intenzita a jas, obe sú z rozmedzia 0-100. Nulová intenzita označuje odtiene sivej, nulový vždy čiernu farbu (nezávisle na predchádzajúcich hodnotách). Čím väčšia je intenzita, tým lepšie poznať farbu. Čím je väčší jas, tým je farba svetlejšia (to je dúfam jasné každému).
Farebná paleta pre H=[0, 360]

YUV, YCbCr, YPbPr, CIE xyz, L*a*b* - Tieto a ďalšie formáty farieb boli vyvinuté špeciálne pre využitie v TV prímačoch (napr. počas prechodu z ČB na farebný signál) a počítačových animácií. Lab model je jeden z najlepších - je totiž celý popísaný matematicky...

Ak sa chcete dozvedieť viac o formátoch farieb, dobrým zdrojom informácií sú rôzne diskusné fóra (comp.graphics, comp.graphics.algorithms) či internetové stránky (http://www.inforamp.net/~poynton/Poynton-color.html alebo zadajte v nejakom lepšom vyhľadávači slová ako: colorspace, color encoding, YUV, RGB a pod.).


Klávesové skratky

Ak ste pokročilý používateľ počítača, určite vám prídu vhod klávesové skratky, ktoré sú tu uvedené - ich používanie totiž môže značne urýchliť vašu prácu s týmto programom...
Pri jednotlivých skratkách sú uvedené malé ikony aby ste vedeli, pri akom type súborov je možné tú-ktorú skratku použiť. Ikona [image] je pre obrázky, [image] pre textové súbory, [image] pre binárne a [image] pre multimediálne. Ak nie je uvedená žiadna ikona, skratka nie je závislá od typu otvoreného súboru...
F1 | Nápoveda
F2 | Nastavenia
F3 | Nájsť ďalšie
F5 | Zachytiť
F11,F10,medzera,backspace | Pohyb v adresári
F12 | Uložiť súbor ako
Alt+Enter | Celoobrazovkový režim (pri obrázkoch a multimédiách stačí Enter)
Alt+F4 | Ukončenie programu
Ctrl+A | Vybrať všetko
Ctrl+B | Tučné písmo
Ctrl+C | Kopírovať
Ctrl+D | Zmeniť počet farieb obrázku
Ctrl+F | Nájsť
Ctrl+G | Nastaviť písmo
Ctrl+H | Zameniť
Ctrl+I | Šikmé (italické) písmo
Ctrl+N | Nový súbor
Ctrl+O | Otvoriť súbor
Ctrl+R | Zmeniť veľkosť obrázku
Ctrl+S | Uložiť súbor
Ctrl+T | Tvorič náhľadov
Ctrl+U | Podčiarknuté písmo
Ctrl+V | Vložiť
Ctrl+X | Vystrihnúť
Ctrl+Z | Späť (vrátiť)
Ctrl+Alt+B | Hromadná konverzia
Ctrl+Alt+C | Zmeniť vlastnosti farieb
Ctrl+Alt+M | Maximalizovať okno
Ctrl+Alt+W | Slideshow (prezentácia)
Ctrl+Alt+Z | Opakovať
Ctrl+Alt+Shift+1 | Pero
Ctrl+Alt+Shift+2 | Text
Ctrl+Alt+Shift+3 | Výber
Ctrl+Alt+Shift+4 | Kvapátko
Ctrl+Alt+F1 | Informácie o stave programu
Ctrl+Shift+C | Vytvorenie tapety z aktuálneho obrázku a jeho vycentrovanie...
Ctrl+Shift+F1 | Informácie o pluginoch
Ctrl+Shift+M | Minimalizovať okno (boss key :-)
Ctrl+Shift+T | Vytvorenie tapety z aktuálneho obrázku a jeho rozmiestnenie ako dlaždice...
Shift+F1 | Informácie o programe

Okrem toho môžete používať aj rôzne iné klávesy...
+/- (na numerickej aj normálnej klávesnici) | Pri obrázkoch slúžia na zväčšovanie a zmenšovanie vizuálnej veľkosti obrázku (nie reálnej!)
Kurzorové šípky | Slúžia na posun v obrázku, texte, binárnom a v multimediálnom režime na posun pozície
Čísla na numerickej klávesnici | Slúžia na jemnejší posun v obrázku
Page up/page down | Pohyb po stránkach hore/dole
Home/End | Pomocou týchto tlačidiel sa v obrázku môžete posúvať po stranách vľavo a v pravo, v texte na začiatok riadku resp. jeho koniec (pri súčasnom držaní Controlu na začiatok resp. koniec dokumentu).


Licencie a iné záležitosti...

LZW | Kompresia LZW (Lempel-Ziv Welch) sa používa okrem iného aj vo formátoch GIF a TIFF s LZW kompresiou. Firma Unisys je vlastníkom patentu na túto kompresiu. Ak teda chcete používať niektorý zo spomenutých formátov, musíte si od firmy Unisys zakúpiť licenciu, za ktorú si firma bežne žiada 5000$. Unisys nikdy nevyužili patent proti bežným používateľom. Petent vyprší v roku 2003. Takisto aj firma IBM vlastní patent na používanie tejto kompresie. Viac informácií na http://www.unisys.com
JBIG | Ak chcete používať formát JBIG, musíte si kúpiť licenciu, pretože JBIG je patentovaný formát (info na http://www.ibm.com, http://www.jpeg.org).
- | Tento program používa niekoľko knižníc, ktorých licencie si môžete prečítať v anglickej nápovede tohto program v tejto istej sekcii...


Otváranie súborov

Po vybraní súboru v okne "otvoriť súbor" alebo po iných úkonoch vedúcich k otvoreniu súboru prebehne zložitý proces rozpoznávania typu súboru podľa jeho obsahu (a teda nie len podľa prípony). To často vedie k otvoreniu súboru aj napriek tomu, že jeho prípona je neznáma ale jeho formát program dokáže spracovať (opačné prípady sú takmer vylúčené). Ak nastane situácia, že súbor inú príponu ako má mať a v nastaveniach ste zaškrtli možnosť "upozorňovať na nesprávnu príponu", budete o tom oboznámení a dostanete ponuku na jeho premenovanie... Je odporúčané zaškrtnúť aj druhú voľbu. Síce to mierne predĺži načítavanie súborov (aj to len vo výnimičných prípadoch) ale získate väčšiu úspešnosť otvárania súborov...


Popis použitých algoritmov

Prahový efekt
Predpokladajme, že sú zadané hodnoty: prah a dve rôzne farby (môžu byť aj rovnaké, ale efekt potom nemá význam). Program pre každý bod obrázku vypočíta svietivosť bodu a porovná s prahom. Ak je hodnota väčšia, priradí spracovávanému bodu hodnotu farby 2, inak (teda ak je svietivosť menšia alebo rovná prahu) hodnotu farby 1.


Použitie myši

V tejto "kapitole" sa môžete dozvedieť o niektorých funkciách myši, ktoré môžete výhodne použiť v UniView-e.

Textové súbory - tu je veľmi výhodná trojtlačidlová myš. Ak stlačíte stredné tlačidlo (a podržíte ho), zobrazí sa vám (ale iba v RichEdit 2.0 móde) obrázok zo šípkami (ak má dokument posuvné lišty) - potom už len stačí posúvať kurzor myši a vy sa môžete pohodlne posúvať v dokumente... Ak máte aj tzv. "roller", na pohyb v dokumente môžete samozrejme použiť aj ten. Po stlačení pravého tlačidla sa vám zobrazí kontextové menu Úpravy. Ak súčasne budete držať klávesu shift, bude to podmenu text. Ďalšia možnosť as tiež týka len ľudí, ktorí vlastnia myš s rollerom. Ak držíte control a súčastne otáčate rollerom, zväčšuje/zmenšuje sa mierka dokumentu, nemení sa však veľkosť písma (ktoré sa dá meniť pomocou položiek v menu textových dokumentov)!

Obrázkové súbory - pomocou pravého tlačidla tu môžete vyvolať kontextové menu Obrázok. Pri súčasnom držaní klávesy shift to bude menu Úpravy. Ak sa chcete pohybovať v obrázku, môžete použíť buď lišty alebo spomínaný "roller". Pri normálnom točení kolieskom sa pohybujete hore/dole. Pri súčasnom stlačení stredného tlačidla (napr. na mojej myške je to práve tento roller) sa pohybujete vľavo a vpravo.

Multimediálne súbory - všetky funkcie myši tu preberá MCI rozhranie. Napr. pravým tlačidlom sa zobrazí kontextové menu...

Binárne súbory - ľavým tlačidlom môžete meniť aktuálnu pozíciu v dokumente alebo vyberať časť dokumentu. Pravým vyvoláte kontextové menu.


Schránka

Schránka je časť pamäte OS Wind*ws vyhradená pre prenos informácií medzi aplikáciami, ktorá dynamicky mení svoju veľkosť s veľkosťou informácií, ktoré sú v nej uložené. Program UniView je schopný pracovať so schránkou, presnejšie s niekoľkými formátmi schránky (áno aj schránka má formáty), ktoré sú uvedené v prehľadnej tabuľke spolu s popisom možností, ktoré vám UniView ponúka...
Text/RTF | prezeranie/úprava/vloženie do schránky
Obrázok | prezeranie/úprava/vloženie do schránky
Multimediálne súbory | bez možností práce s týmto formátom
Neznáme formáty | prezeranie/úprava/vloženie do schránky (všetko pomocou HexView)
Ak má formát možnosť 'prezeranie', program umožňuje prehliadať daný formát vo svojom okne, 'úprava' znamená, že program podporuje úpravu daného formátu a 'vloženie...' do schránky značí, že UniView je schopný vložiť vybranú časť dokumentu do schránky.

Všetky operácie so schránkou sú prístupné z menu 'Úpravy'...


Novinky, zo zákulisia atď.

  • Ak tento program používate dlhšie, určite vám neuniklo, že obsahuje aj tzv. HexView, utilitku, ktorá dovoľuje upravovať akýkoľvek súbor. Jeho jedinou nevýhodou je to, že na otvorenie súboru potrebuje dostatočne veľkú pamäť na to, aby ho otvoril celý. Kvôli tomuto obmedzeniu je na väčšine počítačov nemožné upravovať súbory s veľkosťou napr. 1000MB. Preto chystám novú verziu, ktorá bude zrejme dodávaná ako plugin a nebude schopná upravovať súbory. Jeho výhodou však bude to, že dokáže zobraziť akýkoľvek veľký súbor, pretože ho bude načítavať po kúskoch (teda nie naraz). Aj tento spôsob má niekoľko nedostatkov (napr. pri súboroch na disketách pomalý presun v súbore), napriek tomu sa to môže zísť pri prehliadaní súborov o veľkosti napr. spomínaných 1000 MB. O výsledkoch vás budem včas informovať na domovskej stránke.


Jazykové súbory

Program UniView je možné takmer celý preložiť do ľubovoľného jazyka. Jedinou podmienkou je vytvorenie jazykového súboru s formátom, ktorý je predpísaný. Návod na tvorbu jazykového súboru spolu s aktuálnou šablónou môžete nájsť na mojej domovskej stránke. V prípade, že sa chcete zapojiť do prekladania UniView-u do jazykov, ktoré sa zatiaľ v štandardnej distribúcii nenachádzajú, skontaktujte sa so mnou prosím...


UniView plugin SDK

Je balík súborov (Software Development Kit), ktoré slúžia na vývoj pluginov pre UniView. Celý si ho môžete zdarma stiahnuť na mojom "homesite"-e http://www.gym.utcru.sk/andrek/...


UniView freeware license:

License for 'software' UniView:
If you are using this software, you MUST accept this license
and mustn't violate it! If you will, you may be penalised by several
civil and criminal penalties and you will be then prosecuted to the
maximum extent possible under law in your country!

1. You have right to redistribute this program JUST in original form,
you can't request any payment for this distribution from me or target
user (this doesn't mean resources needed for this activities). You can
use this program in commercial packages. Before redistibuting this
package you should give me a notice...

2. You must NOT change any of parts of this software directly or
indirectly. It is also forbidden to dissasembly software's code.

3. This software can be used and copied on as many computers and
as many times, as you need. It is legal to have more than one copy on
one computer.

4. Author of this program can not be responsible for any damages caused
by this software (it is freeware after all). If you find some 'bug', please
let me know and I'll try to repair it.

5. If you wan't to support developing of this software, please register it.
You don't need it, but it will motivate me in work. You can give me almost
anything: hardware, cash (money ;-), some CDs etc. You will get then
support for this software (for further informations read help file please).

6. All rights are reserved to Andrej Krutak

If you don't accept any of these license rules, you must stop using it and
remove all copies of this software from your computer!