
Open

Click on the File menu, then Open (or use the Open tool on the toolbar.) A dialog allows you to open a file
for use in IrfanView.
 
Use the Look in box to locate the file you want, or type a file name into File Name. Files of type lets you 
limit your choice, showing only the type of file you want (JPG, for instance.) The default is Most IrfanView 
Files (Windows can't display at same time all file types supported by IrfanView).
 
If you check Preview active, a single click on an image filename will display a small version. Another click
brings the file into the viewer. You can also double click the filename.
 
If multiple images are in the file, as with icons, a small dialog box will allow you to choose one. Single 
click the names for a preview. Click accept when you find the one you want.
 
To close without opening a file, click Cancel .  Another way to close is to click the X    in the upper right 
corner.

After the opening, you will see an image or you will get an error message, if the file type is unsupported 
by IrfanView.

If you open a large image, you can use scrollbars to see all parts of the image. Scrolling is possible with 
the arrow keys and with the page up/down, home/end keys. Scrolling is also possible with the right mouse
button: press the right mouse button and move the mouse arround. 

See also:
          Reopen
          Open with external editor



Thumbnails

Open an image from a selected directory in the viewer. Click the File menu, then Thumbnails. A box will 
open and fill with thumbnails of the images in the directory.

Double click any thumbnail to open that image in the viewer. If you change directories by opening another
image, the thumbnail display will show those images.
 
For large images, minimize the thumbnail display. Use the button in the upper right corner of the display 
that looks like an underline ( _ ) character. 
 
To close the display, click exit on the display's menu bar or press ESC.
 
Options, on the display's menu bar allows several settings. 

Select All highlights all the thumbs for saving them as files (below.)

Set thumbnail options lets you control the size and quality of the thumbnails. Click it to open a dialog 
box. The first option is Use Resample instead of Resize for creating thumbnails. Click the check-box 
to have better quality thumbnails displayed. This may take longer for the images to appear. The next 
option is Thumbnail size. Click one of the option buttons to set a size for the thumbnails. The default is 
80 x    80 pixels. The last option is Copy original images to same directory like HTML file. Check the 
box; when you save thumbs as an HTML file, the images themselves will be copied to the directory you 
chose. The thumbnail window can remeber several directories with thumbnails. You can Set the number 
of the MRUDs. If you want to clear the MRUD list, press the Clear MRUDs button.
When done making your choices, click OK to exit. Click Cancel  to exit without making any changes.

Save selected thumbs as an image. Click to have your selected thumbs made into a single image and 
saved.    A dialog lets you choose the directory to save the image in. Images are selected by clicking on 
each thumb, while holding down the CTRL key, or by using the Select All option (see above.)

Save selected thumbs as HTML file. Click to make a page of thumbs that can be used in a web 
browser, or at an internet website. A dialog lets you choose the directory to save the file in. Images are 
selected by clicking on each thumb, while holding down the CTRL key, or by using the Select All option 
(see above.) If you already chose the option Copy original images to same directory like HTML file,    the 
actual images will also be copied to the directory.

Save selected thumbs as single images. Click to have chosen thumbs made into images and saved 
individually. A dialog lets you choose the directory to save them in. Images are selected by clicking on 
each thumb, while holding down the CTRL key, or by using the Select All option (see above.)

Open with external editor. Click to have an alternate viewing or editing program opened, with the image 
connected to the current thumbnail displayed in it. To use this option, you must first set up an external 
editor.



Slideshow

Click on the File menu, select Slideshow. A dialog allows you to select a directory from which the files will
be taken. Use Look in and File name to narrow the search; use Files of type to limit the search to one 
type of file, such as JPG.

Click the file names you want to use. If you have a range of files to choose, click the first. Move the 
mouse to the last file in the group, hold down the Shift key on the keyboard, and click. To choose 
individual files, hold down the Ctrl    key and click each file name with the mouse. Click the Add button. 
Click the Add all    button to select every image in the directory. Remove and Remove all     take files 
back out.

Click the Sort    button to choose a sort order by name, date, size, or extension. Files may be sorted in 
ascending or descending order. To remove a sort, click the No sort option button. Click OK to close the 
dialog. To exit without making changes, click the Cancel    button.

There are several options for slideshow. If there is a check-mark in the box, the option is "on." Unchecked
means "off." Click Loop to cause Slideshow to play continuously. The next option is Suppress errors 
during slideshow. Next is Show image filename; click this to display the name of the image as it 
appears on screen. The final option is Hide mouse cursor; click to make the mouse cursor "invisible" 
while the slideshow is playing.

There are settings for how long each image will be shown; click the option button of your choice. The top 
option plays the next image automatically after a number of seconds; type a number into the box to 
change the timing. The second option will cause the viewer to wait until you touch a key on the keyboard 
or move the mouse before displaying the next image. The third option plays a randomly chosen image 
after the specified time; the fourth plays a random image after you touch a key or the mouse.

Click the Play button to begin the slideshow.

Slideshows can be saved for future use. When you choose the images and begin playing a show, 
IrfanView creates a file named:

          IrfanView_Slideshow.lst

which is placed in the Windows directory on your disk drive. This may be loaded back into the viewer and 
used again. Click Load from TXT file, and a dialog like the Open dialog from the File menu appears. Find
the file you want to use and click Open to load it. Click Save as TXT file, and a dialog like Save As 
appears. Give your slideshow a name, and click Save to have it stored on the disk drive.

Slideshows can be created outside of IrfanView, then loaded once you open the viewer. Use a text editor 
that stores its files as plain text, such as Windows Notepad. The file only contains the name of each 
image to be played in the slideshow, each on a separate line in the file. Each must include the complete 
path where the image will be found on your hard drive. It will look something like this:

          C:\Images\myimage.JPG

Create the file and store it on your disk. When you start IrfanView, open the Slideshow dialog, and use 
the Load from TXT file button to start your show. Shows can also be played from outside the viewer, 
using a Command Line Option.

When you are done click Close. You may also click this before the slideshow starts. Another way to exit is
to click the X in the upper right corner.



How to pause an automatic slideshow? Just press the Pause key. Press the pause key again to restart 
the slideshow.



Batch Conversion

Click on the File menu, select Batch Conversion. A dialog allows you to select a directory from which the
files will be taken. Use Look in,    File name, and Files of type to limit the search.

Select the output directory at bottom right.    If you don't have the full path for this directory, click the 
Browse button to find it. When you have selected a directory with Browse, click the Use dir button.

Use the Advanced Options button to apply many special operations to the images during conversion. 
These options are much like their versions on the Image menu. The options are:

Resize, Change color depth, Horizontal flip, Vertical flip, Rotate left, 
Rotate right, Convert to greyscale, Negative, Sharpen, Gamma 
Correction, Contrast, and Brightness.

Check those you want to use, then click OK. To exit without making any selections, click Cancel.

Select the files you want to convert by clicking their names. For a large range of files: click the first name, 
move the mouse to the last file in the group, hold down the Shift key, and click. To choose individual files, 
hold down the Ctrl    key and click each name.

Click the Add button to add the (selected) files that will be converted. Click the Add all    button to select 
every image in the directory with the extension choosen in Files of type. Remove and Remove all    take 
chosen files back out.

Select the Output Format at bottom left. This works just like Save and Save As. The Options button lets 
you choose various operations to perform, also just like their Save and Save As versions. 

Click the Start button to begin. A box shows the progress of the conversion. If you need to halt, click the 
Stop button. When the process is done, click Exit to close the dialog.

Batch conversion may also be performed from outside IrfanView, using a Command Line Option.

When you are finished converting files, click Cancel    to exit. Another way of exiting is to click the X in the 
upper right corner.



Rename

Click on the File menu, select Rename File. A dialog opens; type in a new name for the file and click OK. 
The filename will be changed, both in the viewer and on the hard drive (or other source.) To exit without 
making a change, click Cancel .
 
While renaming the file, you can also move it to a new location: type in the full path name of the new 
directory, followed by the name of the image. The name will be changed, and the image will be put in the 
new directory (This may also be done without changing the name; just type in the path with the old name).



Move

Click on the File menu, then Move File. The file in the viewer will be moved to another directory on your 
hard drive (or other media.) 

For this function to work, first set up a default directory for Move.

The Move dialog offer 5 different directories as destinations.



Copy (File menu)

Click on the File menu, select Copy File. The file in the viewer will be copied to another directory on your 
hard drive (or other media.)

 For this function to work, first set up a default directory for Copy.

The Copy dialog offer 5 different directories as destinations.
 



Delete (File Menu)

Click on the File menu, select Delete File. The file in the viewer is removed from your hard drive (or other 
source.) Be sure you want this, as the file is immediately removed.

 If you delete a file by accident, just resave the image.
 
There is also a Delete option on the Edit menu: this only removes the file from the viewer (memory), it 
doesn't affect the file on your hard drive.

See also:
            Properties: Copy/MoveDelete options



Save

Click on the File menu, then Save.
 
Allows you to save your file to disk. Use Save in and File name to find the directory where you want the 
file saved.
 
To save the file as a different type, use Save as type. Click the arrow and a list of file types drops down. 
Move the cursor to the one you want and click again. When you save, the file will be converted to this new
type.
 
Clicking the Options button brings up special options for some file types. There are three tabs: 
JPEG/GIF, LWF, and TIFF.
 
Click Save    to send the file to your disk drive. Click Cancel    to exit without saving.
 
Note that Save comes up in the last directory from which you loaded an image; Save As comes up in the 
last directory in which you saved a file.

 
See also:
          Save As



Print

On the File menu, click Print. A dialog appears with options for printing an image. Two previews show how
the image would look printed in Portrait or Landscape orientation.
 
Option buttons select how the image will print. Best Fit puts the image on the page as large as it can, 
without altering the dimensions. Stretch to Page fills the print area, even if it has to re-size one dimension.
 
Scale fits the image on the page. If you click this, two boxes to its right become active. Type in the 
desired change; 1.00 is normal size; 2.00 is twice as large in that dimension. Click Refresh to update the 
previews.
 
Click Center on Page to have the image printed in the center of the paper. 
 
Select options, then click Print. This will bring up the Windows print dialog, from which you finish printing 
as usual. Remember to check the box for Portrait or Landscape orientation.
 
Click Cancel    to exit the Print dialog without printing, or when the job is done.



Select TWAIN Source

Click on the File menu, then Select TWAIN Source. 

Allows you to choose from the scanners, or any other TWAIN compatible device (digital camera, TV card 
etc.), installed on your computer (if more than one is available). 

Click the name of the device you want to use, then the Select button. To exit without making a selection, 
click Cancel .

See also:
          Acquire



Acquire

Click on the File menu, click Acquire. 

The program that runs your scanner, or any other TWAIN compatible device (digital camera, TV card 
etc.), will appear. Follow the steps given in your scanner's manual for scanning an image. 

When finished, the image will be placed into IrfanView.

See also:
          Select TWAIN Source



Exit

There are several ways to exit the program:

On the main window, press the ESC key on your keyboard. The program will close immediately. (If you're 
in any of the menus or dialog boxes, ESC will back out of that window. Press it again to exit.)
 
From the File menu, you can press the E key, to close IrfanView. When using the mouse,    just click the 
EXIT option to close the viewer.
 
Click the logo in the upper left corner of the program window to bring up the standard Windows control 
box. Click the Close option.
 
Click the X    box in the upper right corner of the program window. This will also close the program.
 
Note: IrfanView doesn't ask if you are sure you want to exit - it closes right away. Be sure you've saved 
any work you want to keep.



MRUDs

On the File menu, point the mouse at MRUDs (most recently used directories). A sub-menu appears 
showing the most recently used directories. Click one, and the Open dialog appears, already in the chosen
directory. From there you can open any file in the directory.
 
The MRUDs list can be erased using a button on the Others 1 tab, located in the Properties box, on the 
Options menu.



Reopen

Click on the File menu, select Reopen to bring in, again, the last file you opened.
    
If more than one image is involved, Reopen will let you select from them again.

See also:
          Open
          Open with external editor



Save As

Click on the File menu, select Save As (or use the Save As tool on the toolbar.)
 
Saves your file to disk. Use Save in and File name to find the directory where you want the file saved.
 
To save as a different type, use Save as type. Click the arrow and a list of file types drops down. Move 
the cursor to the one you want and click again. When you save, the file will be converted to this new type. 
 
Clicking the Options button brings up special options for some file types. There are three tabs: 
JPEG/GIF, LWF, and TIFF.
 
Click Save to send the file to your disk drive. To exit without saving, click Cancel.
 
Note that Save As comes up in the last directory in which you saved a file. Save comes up in the last 
directory from which you loaded an image

See also:
          Save



Undo

Click on the Edit menu, select Undo (or use the Undo tool on the toolbar.)
 
"Backs up" from the last action you took. Undo will take back many functions of IrfanView. Only one 
function may be undone; the viewer does not save them up. You can disable this option in Others 1 tab in 
the Properties dialog.
 
Functions supported by Undo are: 3-D Button,    Blur, Brightness,    Color balance,    Contrast, Convert    to
Greyscale,    Crop,    Cut,    Decrease Color Depth,    Edge Detection,    Emboss,    Explosion,    Fine 
Rotation,    Gamma Correction,    Increase Color Depth,    Median Filter,    Negative,    Oil Paint,    Pixelize,    
Resample,    Resize,    Sharpen.



Add Text

Use the left mouse button to outline the area (selection) on the image where you want text to appear. 
Click the Edit menu, then Add Text.    A dialog box will open.

How to make a selection? Just press the left mouse button and move the mouse. You will see the 
selection rectangle. If you click on the image again, the selection rectangle will be deleted and the 
selection is not more active.

In the Text box on the left, type in the text you want to put on the image.
 
Use the Choose Font button to change the size, style, color, etc., of the text. The name of the selected 
font is shown under the Text box.
 
Uncheck the Text is transparent box to choose a background color. The highlighted area will change to 
that color, with the text inside. The small box above the button shows the selected background color.
 
Click the OK button to add the text to your image. To close the dialog without adding any text, click the 
Cancel    button.
 
Add text may be reversed with the Edit menu's    Undo command.



Cut

Use the left mouse button to outline the area (selection), click on the Edit menu, then Cut (or use the Cut 
tool on the toolbar.)

The area inside the outline will be removed from the image. The cut portion is placed on the Windows 
Clipboard, and may be pasted in elsewhere.
 
This action may be reversed with the Edit Menu's Undo command.

See also:
          Paste



Crop

Use the left mouse button to outline the area (selection), click on the Edit menu, then Crop.

The area outside the outline will be thrown away, only the inside will be left.
 
Use this to eliminate unwanted space (usually blank space) from an image. It can also center a badly 
composed photo. 

Use with Resample (Image menu,) to eliminate background "noise", and often have the same sized 
image when you finish.
 
This action may be reversed with the Edit Menu's Undo command.



Copy (Edit menu)

Use the left mouse button to outline the area (selection), click on the Edit menu, select Copy (or use the 
Copy tool on the toolbar.)

The area inside the outline will be placed on the Windows Clipboard, and may be pasted in elsewhere.
 
If you don't select an area with the mouse, the entire image will be copied to the Windows Clipboard.

See also:
          Paste



Paste

Click on the Edit menu, then Paste (or use the Paste tool on the toolbar.) 

If you have an Edit outline around an area of the current image, an image stored on the Windows 
Clipboard will be pasted into your outline. The Clipboard image will be re-sized to fit the outline, and the 
rest of the image will stay as it was. This feature is very useful for editing images or portions of them.

If there is no Edit outline, an image on the Windows Clipboard will replace the entire image in the viewer.

See also:
          Cut
          Copy (Edit menu)



Delete (Edit menu)

Click on the Edit menu, then Delete. 

Removes the entire image from the viewer. This does not affect the image stored on your disk drive.
 
There is also a Delete option on the File menu; this one removes the file from your disk drive completely.



Clear Clipboard

Click on the Edit menu, then Clear Clipboard. 

Removes the contents of the Windows Clipboard. 



File Menu

          The following options are available on the File Menu:

Open
Reopen
Open with external editor
Open in HEX viewer

Thumbnails

Slideshow
Batch Conversion

Rename
Move
Copy File
Delete File

Save
Save As

Print

Select TWAIN Source
Acquire

Exit

MRUDs



Edit Menu

          The following options are available on the Edit Menu:

Undo

Add Text

Cut
Crop

Copy
Paste
Delete

Clear Clipboard



Contacting the Author

The latest edition of IrfanView can be downloaded from the Internet at:

          http://stud1.tuwien.ac.at/~e9227474/

The author of the program, Irfan Skiljan, can be E-mailed at: 

          e9227474@student.tuwien.ac.at

If you want to register the program with him (only $10 US or DM 15)
send your cash payment to: 

          Irfan Skiljan
          Bruendlweg 4
          2752 Woellersdorf
          Austria, Europe

If you have questions, comments, complaints, etc., about this Help file,    
send them to: 

          Steve Clark
          seclar1@geocities.com

or 

          Irfan



IrfanView

IrfanView is a compact, easy to use image viewer. More than that, you can also edit images directly in 
IrfanView, to produce a variety of effects. IrfanView was created by Irfan Skiljan.

Open IrfanView by clicking its icon on the Windows Start Menu or double clicking the icon on your 
desktop.
 
Click on the File menu, then the Open option to get a file for use in the viewer. A dialog box will allow you 
to select the file you want. Click the Preview active box in the Open dialog to see small versions of 
images before opening them.
 
With an image in the viewer, you can manipulate it in a large number of ways. Most functions for changing
an image are in the Edit and Image menus.
 
When you are finished with the image, Save it to your disk. Bring in another image, or Exit IrfanView.

Click on the image below to find out more about that function:



Supported File Formats

These are the file formats supported by the current version of IrfanView:

AIF*,    ANI,    AU*,    AVI,    BMP,    CAM,    CLP,    CPT,    CUR,    DAT*,    DCX,    DIB,    EMF,    EPS,    G3,    
GIF,    ICL,    ICO,    IFF/LBM,    JPG/JPEG,    LWF,    MID,    MOV*,    MPG/MPEG*,    PBM,    PCX,    PGM,    
PhotoCD,    PNG,    PPM,    PSD,    PSP,    RAS/SUN,    RLE,    RMI,    SFW,    SND*,    TGA,    TIFF/TIF,    
WAV,    WMF

*    Microsoft's Active Movie program is required for these formats.



Image Menu

          The following options are available on the Image Menu:

Information

Rotate Left
Rotate Right
Vertical Flip
Horizontal Flip

Resize
Resample

Increase Color Depth
Decrease Color Depth

Convert to Greyscale
Negative
Brightness
Contrast
Color balance
Gamma Correction

Sharpen
Effects

Swap Colors
Edit Palette



Information

Click on the Image menu, then Information (or use the Information tool on the toolbar.) A box opens with 
the following about the image:
 

File name
Compression method (and DPIs if available)
Original size (Width/Height in pixels)
Current size (Width/Height in pixels)
Original colors (color depth, BitsPerPixel)
Current Colors (color depth, BitsPerPixel)
File disk size (in bytes)
Image memory size (in bytes, decompressed)
Current directory index
File date/time
Loaded in (time to load image)

 
Click the OK button when you are done viewing the information.



Rotate Left

Click on the Image menu, then Rotate Left.    The image will turn 90 degrees; the top of the image will 
move towards the left.

See also:
          Rotate Right
          Vertical Flip
          Horizontal Flip
          FineRotation



Rotate Right

Click on the Image menu, then Rotate Right.    The image will turn 90 degrees; the top of the image will 
move towards the right.

See also:
          Rotate Left
          Vertical Flip
          Horizontal Flip
          FineRotation



Vertical Flip

Click on the Image menu, then Vertical Flip. The image will turn upside-down. The left/right orientation 
will stay the same.

see also:
          Horizontal Flip
          Rotate Left
          Rotate Right
          Fine Rotation



Horizontal Flip

Click on the Image menu, then Horizontal Flip. The image will turn side-to-side, as in a mirror.

See also:
          Vertical Flip
          Rotate Left
          Rotate Right
          Fine Rotation



Resize

Click on the Image menu, then Resize. A dialog allows you to choose the new size for the image. 

There are several built in choices, or you can type over the old numbers. The first number is width, the 
second height, both in pixels. Leave the Preserve aspect ratio box checked, type in one number and the
other will be calculated for you.
 
Click OK to resize the image. This action can be reversed by the Edit menu's Undo command.

See also:
          Resample
          Crop



Resample

Click on the Image menu, then select Resample. A dialog allows you to choose the Resample filter to be
used if you are enlarging the image. This is the same dialog box used for resize; the image can be 
Resized directly with Resample.
 
Click OK to resample the image. This action can be reversed by the Edit menu's Undo command.
 
Resampling an image often improves its quality, especially when enlarging it. Enlarging without 
resampling can result in a blurry image.

See also:
          Resize
          Crop



Increase Color Depth

Click on the Image menu, then select Increase Color Depth.    A dialog shows the possible color depths. 
Select one.
 
Click OK to make the change. This action can be reversed by the Edit menu's Undo command.

See also:
          Decrease Color Depth



Decrease Color Depth

Click on the Image menu, then select Decrease Color Depth.    A dialog shows the possible color depths. 
Select one.
 
Click OK to make the change. This action can be reversed by the Edit menu's Undo command.

See also:
          Increase Color Depth



Convert to Greyscale

Click on the Image menu, then select Convert to Greyscale.
 
Greyscale (or grayscale) is actually a color mode, like RGB. It contains more information about the photo 
than Black and White. Converting from color to greyscale will usually give a better effect than from color 
to black and white.
 
This action can be reversed by the Edit menu's Undo command.



Negative

Click on the Image menu, then select Negative. The image is converted to a reversed color version of the
original.
 
This action can be reversed by the Edit menu's Undo command.



Brightness

Click on the Image menu, then Brightness. A dialog appears with a slider control. Move the setting up or 
down, for more or less brightness. You'll see the image change as you move the control. When you are 
satisfied, click OK. To quit without changing the image, click Cancel.
 
With the Contrast option, this can help correct an image that is too light or dark.
 
This action can be reversed by the Edit menu's Undo command.



Contrast

Click on the Image menu, then Contrast.    A dialog appears with a slider control. Move the setting up or 
down, for more or less contrast. You'll see the image change as you move the control. When you are 
satisfied, click OK. To quit without changing the image, click Cancel.
 
With the Brightness option, this can help correct an image that is too light or dark.
 
This action can be reversed by the Edit menu's Undo command.



Color balance

Click on the Image menu, then Color balance.    A dialog appears with three slider controls, one each for 
Red, Green, and Blue. Move the settings up or down, for more or less of each color. You'll see the image 
change as you move the controls. When you are satisfied, click OK. To quit without changing the image, 
click Cancel.
 
An image with a lot of shadows sometimes can be better corrected with Color balance,    than with the 
Brightness / Contrast combination.
 
This action can be reversed by the Edit menu's Undo command.



Gamma Correction

Click on the Image menu, then Gamma Correction.    A dialog appears with a slider control. Move the 
setting up or down, to adjust the intensity of the image. You'll see the image change as you move the 
control. When you are satisfied, click OK. To quit without changes, click Cancel.
 
This action can be reversed by the Edit menu's Undo command.



Sharpen

Click on the Image menu, then Sharpen. The sharpness of the image can be set using Effects setup.
 
This action can be reversed by the Edit menu's Undo command.



Effects

Click on the Image Menu, then point the mouse at Effects to access these options.
 
Note: All of these effects (except Filter Factory) can be used on a smaller portion (selection) of an image, 
as well as the entire image.
 

The Effects possible are:
 
3D Button
Click on the Image Menu, point the mouse at Effects, and click 3D Button. 

Gives the image a beveled edge look, with the center raised. The size of the border can be changed 
using Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Blur
Click on the Image Menu, point the mouse at Effects, and click Blur. 
 
Softens the image, creating a blurry or fuzzy look. The amount of blur can be changed using Effects 
setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Emboss
Click on the Image Menu, point the mouse at Effects, and click Emboss.
 
Turns the background grey and gives the image an engraved appearance.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Oil Paint
Click on the Image Menu, point the mouse at Effects, and click Oil Paint. 
 
Creates a textured effect, such as that seen in an oil painting. The amount of texture can be changed 
using Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Edge Detection
Click on the Image Menu, point the mouse at Effects, and click Edge Detection.
 
Finds the main lines in an image and replaces their color with the opposite color, at the same time most fill
colors are darkened, making them like a background. The image takes on a "painted on velvet" 
appearance. This effect needs a color depth of 256 or less to work properly.
 
This action can be reversed with the Edit menu's Undo command.



 
 
Median Filter
Click on the Image Menu, point the mouse at Effects, and click Median Filter.
 
Causes a group of pixels to have the brightness of the "average" pixel in that group. In most cases, this 
has a "smoothing" effect on the area being filtered. The amount of filter can be changed using Effects 
setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Explosion
Click on the Image Menu, point the mouse at Effects, and click Explosion.
 
Breaks up the image, as if the darker pixels exploded. The amount of Explosion can be changed using 
Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Pixelize
Click on the Image Menu, point the mouse at Effects, and click Pixelize.
 
Breaks the image into a coarse version of itself, as if it were made up of oversized pixels. The amount can
be changed using Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Fine Rotation
Click on the Image Menu, point the mouse at Effects, and click Fine Rotation.
 
Turns the image to the left or right. The degree of rotation can be changed using Effects setup.
 
          See also:  Rotate Left,    Rotate Right.
 
This action can be reversed with the Edit menu's Undo command.

Other menu options:
 
Setup
Click on the Image Menu, then click Setup. Opens a dialog from which you can change many of the 
Effects settings.
 
 
Filter Factory
Click on the Image Menu, then click Filter Factory. Opens a dialog from which you can perform many 
other Effects. 



Swap Colors

Click on the Image menu, then point the mouse at Swap Colors.    A submenu allows you to select one of
the color combinations to change the image.
 
This command operates at the pixel level, changing the color of all, or most, depending on which 
combination you select.

Example: if you choose RGB -> RBG, the pixels that are green will be made blue, and the blue pixels will 
be made green. (In this combination the red pixels stay the same.)

The possible swaps are:

RGB -> RBG
RGB -> BGR
RGB -> BRG
RGB -> GRB
RGB -> GBR



Edit Palette

For images with 256 or fewer colors.

If you have a true color image, you can decrease the color depth in the Image menu.

Click on the Image menu, then Edit Palette. A dialog shows the colors at use in the image. Click any 
color for information about it. Double click to edit the color. Your changes will appear in the image. When 
you are satisfied, click OK to close the dialog.
 
This action can be reversed by the Edit menu's Undo command.



Effects setup

Click on the Image Menu, point the mouse at Effects, then click Setup.    A dialog allows optional settings 
for many of the special effects.

To restore the default settings, click the Default Settings button at the bottom of the dialog.

When you are finished, click OK  to close. To exit without any changes, click Cancel.

The settings are:

Sharpen
Enter a value (1-99) to control how deep the sharpen effect is; higher numbers sharpen the image more; 
the default is 50; higher settings take longer to finish.

Oil Paint
Enter an odd number (3, 5, 7 or 9) to control how coarse the oil paint effect is; higher numbers produce a 
more streaked effect; the default is 3; higher settings take longer to finish.

Explosion
Enter two values to control the mask value for explosion; this sets how coarse the explosion effect will be;
higher numbers produce a more coarse effect; the default is 3 x 3; higher settings take longer to finish.

Fine Rotation
Enter a value to control how far the image is rotated; positive numbers (e.g. 30) rotate the image to the 
right, negative (e.g. -30) rotate the image to the left; higher numbers rotate the image farther; the default 
is 45. If you click the Clear background check-box below, the area where the image was is blanked out, 
then the rotated image is placed over it; otherwise, the rotated image is placed on top of the existing 
image; the default is unchecked (no clear.)

Blur
Enter an odd number, from 3 to 33, to control how coarse the blur effect is; higher numbers produce a 
wider blur; the default is 3; higher settings take longer to finish.

Median Filter
Enter an odd number (3, 5, 7 or 9) to control how coarse the median filter effect is; higher numbers cause 
the pixels to become more alike in brightness (most areas will appear "softer"); the default is 3; higher 
settings take longer to finish.

Pixelize
Enter two values to control the mask value for pixelize; this amount sets how coarse the pixel effect will 
be; higher numbers produce a more coarse effect; the default is 5 x 5; higher settings take longer to 
finish.

3D Button
Enter two values to control the width and height of the border for 3D buttons. The settings are in pixels; 15
is the default.



Filter Factory

Important note: IrfanView can'r read original Photoshop 8BF files, you must use 8BFs created with Filter 
Factory. You can find several such 8BFs under: 

http://www.netins.net/showcase/wolf359/adobepc.htm

Click on the Image Menu, point the mouse at Effects and click Filter Factory. A dialog opens    from which to 
control the filter.

Parameters sliders control the filter: these will cause the filter to act more, or less, on the image. Usually, 
moving the slider to the right increases the action, to the left decreases. Default slider values resets the 
sliders to whatever values were set by the author of the filter. 

Filter Groups help you keep track of them. The display shows the names of all groups available for use. 
You can add groups to the list, or remove them.

Filters displays the names of the filters in the selected group. You can add filters to the list. Click one of 
the names to see that filter. The preview image shows what the image will look like if you apply the filter. 
To use the filter, click Apply to image.    This can be reversed using the Undo button or by the Edit menu's
Undo command.

Add filter makes more filters available. A dialog box    allows you to find the directory in which your filters 
are stored. Click the Use dir button. All of the filter groups in that directory will be added to the list. Click 
Cancel    to exit without changes. Remove filter    removes the selected filter from the list. To remove 
filters in larger numbers, use Remove group, or Remove all groups. Removing a filter does not remove 
it from your hard drive, only from this list.

Filter info displays the filename, filter name, author name, and copyright information for a selected filter. 
When you are done reading the info, click OK.

Thanks to...  shows a message of thanks from Irfan Skiljan for filters provided for use with IrfanView.

When you have finished using the filters, click Exit.



Options Menu

          The following options are available on the Options Menu:

Properties

Stop Animation
Extract all frames

Capture

Video Size
Loop video/music
Play Audio CD
Stop Audio CD

Sort directory files
Set as Wallpaper

Minimize
Always on Top



Properties

Click on the Options Menu, then Properties (or use the Properties    tool on the toolbar.) A dialog allows 
you to change many of the basic functions of IrfanView.

Click one of the tabs to see the properties in that section. They are: 

          JPEG/PCD, Animated GIF, Extensions, Copy/Move/Delete, Viewing, Other Options 1, Other Options
2.



Stop Animation

Click on the Options Menu, then click Stop Animation to perform this action.
 
This is used to "freeze" animated GIFs or animated cursors, ANIs. The motion stops, and the GIF/ANI is 
made a single image. It can be saved as a non-animated image. 

If you want to save all the frames, use Extract all frames.



Extract all frames

Click on the Options Menu, then Extract All Frames. A dialog allows you to select the directory in which 
the frames will be stored. Find the directory you want, then click Use Dir to have the images stored there. 
Click Cancel to abort the change. This option is available for animated GIFs, animated cursors (ANI), AVI,
MPG, and MOV images.
 
The frames from the image are placed into the directory with names like this:
 

imagename_frame_000.bmp
 
where imagename is the name of the original image, and 000 is the number of the frame. The frames are 
stored as bitmap (BMP) files.
 
For mov and mpg images, you are given a chance to change your mind before saving the frames. These 
files can be quite large when extracted.

AVI, MPG, MOV files: 

When you have selected the output directory and clicked OK , another dialog appears: Movie Information.
This lists the Width and Height for each frame, as well as the Bits Per Pixel, total number of Frames, the 
Extract directory (the one you just chose,) and the total Space Required. To continue, click OK. To exit 
without extracting the frames, click Cancel.
 



Capture

Click on the Options Menu, then Capture. A dialog allows you to capture portions of your screen. 

Use the option buttons to capture from your desktop, a window, or a client area (window without 
caption, menu and status bar). The box below the option buttons lets you choose the visible window from 
which to capture. Click one of the windows to select it. Click Start to copy the window to IrfanView. From 
there you can save it, just like any other image.

You can set a delay for capturing, to capture something that isn't yet on the screen, like the result of 
running a program. Click the Use automatic capture box to perform this operation. There are some other
necessary settings:

Enter a value in the box marked: Capture all. The value will be the number of seconds apart the viewer 
will take "snapshots" of the screen. The default is 600 (ten minutes) to prevent automatically taking 
screen shots before you are ready. Set it for some lower figure; 5 or 10 seconds is fine for most captures.

The Save as box lets you choose which image format will be used to store the screens on your disk drive.
Click the arrow and select one of the formats to change from the default JPG. The Options button brings 
up another dialog box with special options for certain file types.

The final setting is Destination directory for images. Type in a directory path, or use the Browse button
to find the directory you want to use.

Click the Start button. The viewer will minimize to the task bar, and the chosen area of the screen will be 
captured as often as your time setting. Perform whatever actions you need to capture, pausing after each 
for the screen to be captured. When you have all the screens you need, click the IrfanView button on the 
task bar to bring the viewer back up. Click Options, then Capture, and uncheck the Use Automatic option
to turn the capture tool off. 

Click Cancel to exit.



Video Size

Click on the Options Menu and point at Video Size. A sub-menu appears with the choices Half size, 
Normal size, and Double size. Click to set video playback to that size. 

This will make small videos larger,    and some large videos don't play clearly and may look better smaller.



Loop video/music

Click on the Options Menu, then Loop Video/Music. This causes video and audio to repeat automatically
each time the end is reached. 

A check mark next to the menu option shows that it is on. Click again to turn it off.



Play Audio CD

Click on the Options Menu, then Play Audio CD.  If there is an audio CD in the CD drive, it will start to 
play.

See also:
          Stop Audio CD



Stop Audio CD

Click on the Options Menu, then Stop Audio CD.    An audio CD that is playing will stop.

See also:
          Play Audio CD



Sort directory files

Click on the Options Menu and point at Sort Directory Files. A sub-menu appears with the choices by 
Name, by Date, by Size, and by Extension. These are available in either ascending or descending 
order. The final choice is No sort. Click your choice.

When you activate any of the options that use the space bar to move forward and backspace to move 
backward through the files, such as Full screen mode, they will be in the order set by your sort option.



Set as Wallpaper

Click on the Options Menu and point at Set as Wallpaper. A sub-menu appears with the choices 
Centered, Tiled,    and Previous wallpaper. Choose one to have the current image made into a 
background for your Windows desktop.
 
Centered  appears as just one image on the center of the screen. Tiled appears as multiple images, 
taking up the whole screen. (The desktop icons are on top of the wallpaper.) Previous wallpaper 
restores the image that was replaced by this operation.



Minimize

Click on the Options Menu, then Minimize to minimize the viewer to the Windows task bar (the 'Boss'-key
;-). 

Click the IrfanView button on the task bar to restore the viewer to use.

Another way to minimize is to click the minimize box in the upper right corner of the viewer window. It 
looks much like the underline ( _ ) character.



Always on Top

Click on the Options Menu, then Always on Top.

IrfanView will always be visible on your screen, even when you open other programs. This can be 
removed by clicking Always on Top again.



View Menu

          The following options are available on the View Menu:

Toolbar

Full screen
Best Fit to desktop

Next File in Directory
Previous File in Directory
First File in Directory
Last File in Directory
Random File in Directory
Refresh
Start/Stop automatic viewing

Zoom In
Zoom Out
Original size

Show HEX view

Multipage TIFF



Toolbar

The toolbar allows quick access to some of the most useful features of IrfanView. 

Turn the toolbar on by using the View Menu, and selecting the Toolbar option. Turn the bar off by again 
clicking on View and Toolbar. There is an image of the Toolbar here.

The toolbar contains:

Open, Save As

Cut selection, Copy, Paste, Undo

Image Information, Zoom In, Zoom Out,
Previous File in Directory, 
Next File in Directory

Previous page
Next page

Directory Count Display

Properties,    About IrfanView



Full screen

Click on the View Menu, then Full screen. The image will be displayed centered on a black background, 
which fills the entire screen. Move through the images in the current directory using the spacebar for the 
next image, and backspace for previous.

To cancel Fullscreen mode,    press the Enter key, or the Esc key.
 
Resizing for Fullscreen mode can be done with resampling, for better results in most cases. Click the 
Options menu, then Properties, then the Viewing tab. Click the check-box next to Use 'Resample' 
function for 'Fit To Desktop' and Fullscreen mode. To turn it off, click again.
 
Other options for Fullscreen mode can be set from the Properties Viewing tab. The first is a set of option
buttons: Show images/movies with the normal size, Fit to screen: large images/movies only, and Fit
to screen: all images/movies. Click the option of your choice.
 
The next option is Hide mouse cursor. If you don't want the cursor onscreen in Fullscreen mode, click 
this. To return the mouse, click again.
 
The final option is Show image filename. Click this to display the filename of the current image during 
Fullscreen mode. Click again to turn off. Click the box below, Show transparent, to have the filename 
appear as a light color against the black background. Uncheck the box for the filename to appear as black
text inside a white box.
 



Best Fit to desktop

Click on the View Menu, then Best Fit to desktop. The image will be resized to fit the screen.
 
This option can be set to automatically fit images larger than the screen to screen size. Click the Options 
menu, then Properties, then the Viewing tab. Finally, click the check-box    Always 'Fit To Desktop' for 
big images. To turn it off, click the check-box again.
 
Resizing for Best Fit to desktop can be done with resampling, for better results. On the Viewing tab 
(see above) click the check-box next to Use 'Resample'    function for 'Fit To Desktop' and Fullscreen 
mode. To turn it off, click the check-box again.

Note: the view option 'Best Fit to desktop' is a static option; the option will be active for all images, the 
menu item is active and clicked. Click on the option again to disable this feature.



Next File in Directory

Click on the View Menu, then click Next File in Directory (or use the Next File tool on the toolbar.) The 
viewer displays the next supported file. 

If the image does not have a vertical scrollbar at its right edge, you can also use the Space or Page 
Down key to move to the next file in the directory.

See also:
          Previous File in Directory
          First File in Directory
          Last File in Directory
          Random File in Directory



Previous File in Directory

Click on the View Menu, then click Previous File in Directory (or use the Previous File tool on the 
toolbar.) The viewer displays the previous supported file, in reverse sequence.

If the image does not have a vertical scrollbar at its right edge, you can use the Backspace or Page Up 
key to move to the previous file in the directory.

See also:
          Next File in Directory
          First File in Directory
          Last File in Directory
          Random File in Directory



First File in Directory

Click on the View Menu, then First File in Directory. The viewer displays the first supported file in the 
current directory.

See also:
          Next File in Directory
          Previous File in Directory
          Last File in Directory
          Random File in Directory



Last File in Directory

Click on the View Menu, then Last File in Directory. The viewer displays the final supported file in the 
current directory.

See also:
          Next File in Directory
          Previous File in Directory
          First File in Directory
          Random File in Directory



Random File in Directory

Click on the View Menu, then Random File in Directory. The viewer displays a random supported file 
from the current directory.

See also:
          Next File in Directory
          Previous File in Directory
          First File in Directory
          Last File in Directory



Refresh

Click on the View Menu, then click Refresh. The image onscreen will be updated. 

If you have an editing outline around an area of the image for, Refresh will remove it.



Zoom In

Click on the View Menu, then Zoom In (or use the Zoom In tool on the toolbar.) Increases size of the 
image. Click again for more increase. 

The amount of each increase can be set using Zoom Factor on the Options menu, Properties dialog, 
Viewing tab. The default is 10% increase per use.



Zoom Out

Click on the View Menu, then Zoom Out (or use the Zoom Out tool on the toolbar.) Decreases size of the 
image. Click again for more decrease. 

The amount of each decrease can be set using Zoom Factor on the Options menu, Properties dialog, 
Viewing tab. The default is 10% decrease per use.



Original size

Click on the View Menu, then Original Size.    Removes Zoom In or Zoom Out, returns image to its normal
size.



Multipage TIFF

Click on the View Menu, point at Multipage TIFF.    A sub-menu opens, with several options. to click. The 
options are:
 
· Next Page
Click Next Page (or use the Next Page tool on the toolbar.) The viewer displays the next page in 
sequence.
 
· Previous Page
Click Previous Page (or use the Previous Page tool on the toolbar.) The viewer displays the previous 
page in reverse sequence.
 
· First Page
Click First Page. The viewer displays the beginning page of the TIFF.
 
· Last Page
Click Last Page. The viewer displays the final page of the TIFF.
 
· Print all pages
Click Print all pages. The Print dialog may be used to send all pages of the TIFF to your printer.
 
· Extract all pages
Click Extract all pages. A dialog allows you to select the directory in which the pages will be stored. Find 
the directory you want, then click Use Dir to store the pages there. Click Cancel to abort.
 
The pages from the TIFF are placed into the directory with names like this:
 
          TIFFname_irfanview_extract_000.bmp
 
where TIFFname is the name of the TIFF and 000 is the number of the page. The pages are stored as 
bitmap (BMP) files.



Help Menu

          The following options are available on the Help Menu:

Help

Thanks

Registration

Info
About IrfanView



Thanks

Click the Help menu and select Thanks.
 
Displays a message of thanks from Irfan Skiljan to all the users of IrfanView.
 
When done viewing the information, click OK.



Registration

Click the Help menu and select Registration. A dialog allows you to enter your name and a registration 
code.
 
Although IrfanView is free for non-commercial use, it’s best to register your copy. The small fee helps the 
author continue developing one of the best viewer on the WWW.
 
When done registering, click OK.



Info

Click the Help menu and select Info. A dialog will explain who is allowed to use IrfanView for free, and 
where to send your registration fee.

 Also explains where to send bug reports, and other messages to the author. Tells you where to find the 
IrfanView website.

When done viewing the information, click OK.



About IrfanView

Click the Help menu and select About    (or use the About    tool on the toolbar.)
 
Gives the current version number of IrfanView, e-mail address for the author, and a photograph of his 
beautiful home town (worth a look, just for that.)
 
When done viewing the information, click on the bar that says "Click."



Help

Click on the Help menu, then Help. This Help file (the one you are reading now) will appear.

The first version of this WinHelp file was written by Steve Clark, changes after IrfanView ver. 3.02 by 
Irfan.

This Help file was created with HelpWriter ver. 4.2.0.

--------------------------------------
Many many thanks Steve! 

                                                                                                                    Irfan

--------------------------------------



Command Line Options

Command line options allow you to set some functions of IrfanView before the viewer is launched. 
 
These command line options are supported in IrfanView:

          /one - force "only one instance"
          /fs - force Full Screen
          /bf - force Best Fit to desktop
          /title=text - set window title to 'text'
          /pos=(x,y) - move the window to x,y
          /convert=filename - convert input file to 'filename'
          /slideshow=txtfile - play slideshow with the files from 'txtfile'
         /thumbs - force thumbnails

 
Note:    Only lower case options are supported (don't type any UPPERCASE    letters.)

Examples:

          i_view32.exe test.bmp /BF = incorrect

          i_view32.exe test.bmp /bf /title=My PIC = correct

Example for conversion:

          i_view32.exe c:\test.bmp /convert=c:\giftest.GIF

Convert file: 'c:\test.bmp' to 'c:\giftest.GIF' without GUI.
Note: supported are all IrfanView Read/Save formats except: AVI, MOV, MPG, WAV, MID, SND,    AU,    
AIF.

Example for slideshow:

          i_view32.exe /slideshow=c:\mypics.txt
 
The file 'c:\mypics.txt' contains, in each line, a name of the image, including the full path.

Example for thumbnails:

          i_view32.exe c:\test\image1.jpg /thumbs

Open 'image1.jpg' and display thumbnails from directory 'c:\test'.



Installation

Setting up IrfanView for use.

For the experienced computer user: 

Download IrfanView, and unzip the files into a directory of your choice. Create a shortcut to the program 
in the Windows start menu, or on your desktop.

 
For the less-experienced computer user:

Download a self-install copy of IrfanView and start the instalation file.
 
Unzipped, the file contains several files. "About.txt" describes the viewer, and gives information about the 
author. "Changes.txt" is a history of versions of the program. "Options.txt" outlines some advanced 
features of the program. "i_view32.exe" is the program that    makes IrfanView work. The two files 
"Irfan.hlp" and "Irfan.cnt" are the Help files for the program.

Shortcuts are the labels you click in the Start Menu, or the icons on your Desktop, that start programs for 
you. You need to create a shortcut to IrfanView. To make one on the Start Menu, click the Start button. 
Move the cursor up to point at Settings. On the sub-menu that appears, click Taskbar. A dialog box opens,
with two tabs. Click the tab that says: Start Menu Programs. In the top half of the box, click the Add 
button. A box called Create Shortcut comes up to put in the name of the program. Click the Browse 
button, and another box opens, to locate your copy of IrfanView. Find it, click it, then click the Open 
button. The box closes, and IrfanView is now selected. Click the Next button. A box comes up called 
Select Program Folder. Browse through to find the folder where you want the shortcut to appear on your 
Start Menu. Click the folder name, then click the Next button below. Finally, a box comes up called Select 
a Title for the Program. Click the Finish button at the bottom of the dialog. Next time you open your Start 
Menu, a clickable label for IrfanView will be in the folder you selected.
 
The easiest way to create a desktop shortcut is to use the viewer, itself. Open IrfanView. Click the 
Options menu, then click Properties. A dialog box opens; click the tab called Others 1. Almost at the 
bottom is a button labeled Create desktop link for IrfanView. Click this, and an icon for the viewer will 
appear on your desktop. Click the OK button to close. Next time you want to use the viewer,    just double 
click the icon.



Save, Options JPEG/GIF

JPEG
The upper half of this tab lets you set a quality level for JPG images. Move the slider control to the 
desired setting. Lower settings take less space, but deliver less quality. Higher settings are better, but 
take more file space. The default setting is 80, which is fine for most images.

Check the greyscale box to save the image as that. Click the Save progressive (like many images from 
internet) box to activate that option. Click either again to remove the choice.

GIF
The bottom half of the dialog has options for GIF images. Click the Save Interlaced (like many images 
from internet) box for that option. Click Save Transparent Color to set a transparency for the GIF. Type a
number in the box below to use that palette entry as the transparent color. For more on this, see Edit 
Palette. If you have a true color image, you must first decrease the color depth to 256 colors to see the 
palette.
 
After setting the options you choose, click OK to close the dialog. To exit without any changes, click 
Cancel. 

The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options LWF
          Save, Options TIFF



Directory Count Display

On the toolbar, shows how many images are in the current directory, and which number is selected. "1/5" 
means the selection is number one out of five images in the directory.
 
To set a custom directory index, type a number into the box. The viewer will open that image.
 
For Multipage TIFF's, this gives the page location and number of pages. "1/5" means page one of five.



Properties, JPEG/PCD

Click on the Options Menu, then Properties. If the JPEG/PCD section is not showing, click its tab at the 
top of the box.
 
The top half lets you select whether to load JPEG images as grayscale, which is faster. Click the check-
box if you want to use this option. Click it again to un-set the option.
 
The bottom half allows you to choose the size at which PhotoCD images are loaded. Click one of the 
option buttons to make your selection.
 
When you are done, click OK. To exit without making any changes, click Cancel.



Properties, Animated GIF

Click on the Options Menu, then Properties. If the Animated GIF section is not showing, click its tab at the 
top of the box.

Option buttons allow choice of several setups for animated GIFs. The default is to show animation. You 
can also choose to show only the first image in the GIF, or to extract all the images into a directory on 
your hard drive. If you choose the last option, be sure to type a directory in which to place the images.

Below the option buttons is a check-box to click if you want to show transparency in non-animated 
GIFs, as well.

When you are done, click OK. To exit without any changes, click Cancel.



Properties, Extensions

Click on the Options Menu, then Properties. If the Extensions section is not showing, click its tab at the 
top of the box.

Here you choose which file types will be automatically associated with IrfanView. Those files will show 
the viewer's icon next to them in directories; double clicking the file name will launch the viewer, with the 
file already loaded. Click any of the check-boxes next to files you want to associate. If you want them all, 
click Select all.  Clear all  removes all associations.

At the bottom of the selections area is a box for entering other file extensions not listed. Click the box, 
then type in the extensions, each separated by a single space.

Below the selections area is a box you can click to Use Thumbnails for loading BMP images. It is 
checked by default. Click it to remove the option.

The Advanced button has some choices for Windows shell operations. Click to access these options: 
Add IrfanView To Send-to Menu, and Add Open-browse to Shell Menu (This option can cause some 
problems with the MS Office toolbar!). Check either or both boxes, then close the dialog, or exit with 
Cancel.

The Set Icon button allows you to choose a different icon for IrfanView. Click the button to see several 
choices; click an icon to choose it. Click OK to finish your choice, or Cancel    to exit without making any 
changes.

When you are done, click OK. To exit without making any changes, click Cancel.



Properties, Copy/Move/Delete

Click on the Options Menu, then Properties. If the Copy/Move/Delete section is not showing, click its tab 
at the top of the box.
 
The first section allows setting a default directory for Copy operations. Type in a directory, or click the 
browse button to select one. If you click the check-box below, IrfanView will ask your permission before 
making any copies.
 
The second section sets a default directory for Move operations. Click the check-box to have IrfanView 
ask permission before moving files.
 
The third section has several check-boxes that refer to delete operations. You may choose to have 
IrfanView ask permission before deleting files, send deleted files to the Windows Recycle Bin, or jump 
to the next file after deleting one. Click any or all of the boxes to select these options.
 
When you are done, click OK . To exit without any changes, click Cancel.



Properties, Viewing

Click on the Options Menu, then Properties. If the Viewing section is not showing, click its tab at the top 
of the box.

The top half of this dialog has several options. The first is View all files in directory. Click this to have 
the viewer display all file extensions supported by IrfanView in each directory. If this is un-checked, you 
can't open next/previuos file with space/backspace or with the toolbar arrows.

The next option sets the Zoom factor for Zoom In and Zoom Out. The default is 10% increase or 
decrease each time you zoom the image. Type a number in the box to change this amount.
 
The next option is Always 'Fit To Desktop' for big images. Click this to have the viewer reduce 
oversized images until they can be seen fully on the screen. Images smaller than the screen will not be 
changed.

The next option is Use 'Resample' function for 'Fit To Desktop' and Fullscreen mode. Click this to 
have the viewer display the best possible version of an image when you put it in Full screen or Best Fit to 
desktop mode.

The next option is Remember the last window position. Click this, and each time you open the viewer, 
it will be positioned on your screen where it was when you last closed it.

The next option is Center window if load new image. Click this, and each time you load a new image in 
the viewer, it will be centered on your desktop.

The bottom half of this tab contains options for the Full screen mode:

The first is a set of option buttons: Show images/movies with the normal size, Fit to screen larger 
images/movies only, and Fit to screen all images/movies. Click your choice. The next option is Hide 
mouse cursor. Click this to prevent the mouse cursor from showing onscreen while the images are 
displayed. The next option is Show image filename. Click this to have the name of each image displayed
onscreen with the image. Below this option is Show transparent. If this is un-checked, the filename will 
appear in a small box.. Check this and the filename will be shown without the box.

When you are done, click OK. To exit without making any changes, click Cancel.



Properties, Others 1

Click on the Options Menu, then Properties. If the Others 1 section is not showing, click its tab at the top 
of the box.
 
Check-boxes allow access to options; click any that you want to select. They are:
 
· Use Undo option:    Unchecking disables this function of the Edit Menu.

· Ask to overwrite for Save and Save As: checking makes the viewer ask permission before it destroys an 
old file in favor of a new one.

· Display Save dialog for File -> Save:    when checked, clicking on Save will bring up the standard 
dialog, through which you can choose a directory in which to save the image. Uncheck the option and 
Save will resave an image in place of the original. Note that this is only for Save; clicking on Save As still 
brings up the dialog box.

· Only 1 Instance of IrfanView: unchecking will allow the viewer to open more than once at the same 
time. Checking the box will prevent more than one instance of the viewer at any time.

· Ask to Rename Incorrect Extension:    while loading a file which has had the name given an incorrect 
extension, IrfanView will ask permission before changing it. If you uncheck this box, the viewer will load 
the file without making any changes.

· Use flat toolbar: when checked, the toolbar appears as a two-dimensional set of icons; when checked, 
the buttons appear as raised, three-dimensional images.

· Don't notify if end/begin of directory is reached:  when you reach the last of the images in a 
directory, IrfanView asks if you want to jump to the first again; checking this option will suppress the 
question, and just go right to the first image. In reverse direction, it will go to the last image.
 
There are also two buttons, for further options:
 
· Clear MRUDs list: clicking this removes all the names from the Most Recently Used Directories list; this 
option may be used at any time.

· Create Desktop Link: places an icon on your Windows desktop that can be double clicked to start the 
viewer.
 
When you are done making selections, click OK. To exit without any changes, click Cancel.

See also:
          Properties, Others 2



Save, Options LWF

LWF
Click one of the option buttons to set a compression level for LWF images. If you select Compression 
Rate or Compress to bytes, type in a value for the option.
 
After setting your options, click OK to close the dialog. To exit without any changes, click Cancel. 
 
The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options JPEG/GIF
          Save, Options TIFF



Save, Options TIFF

TIFF
Click one of the option buttons to set a compression type for TIFFs. The left side is for color images, the 
right may be used for black & white.
 
After setting your options, click OK to close the dialog. To exit without any changes, click Cancel. 
 
The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options JPEG/GIF
          Save, Options LWF



Open with external editor

Click on the File menu, then Open with external editor.    Your chosen "other" viewer/editor will be 
launched, with the image loaded into it (e.g. Adobe Photoshop, Paint Shop Pro etc.).

To use this option, you must first select an external editor.

See also:
          Open
          Reopen



Properties, Others 2

Click on the Options Menu, then Properties. If the Others 2 section is not showing, click its tab at the top 
of the box.

A box allows you to "Set external viewer/editor (for Menu 'File' and Thumbnail window):"    Type in the
location of another graphics viewer or editor, with the full path to where it is on your hard drive. You can 
also click the Browse button to locate the program.    Now when you click the Open with external editor 
option on the File Menu or Thumbnail window, your selected editor will be launched, with the current 
image shown in it.

The next option is Don't change directory index after file renaming: when checked, the current 
directory index will be not changed if you rename a file, otherweise, the index    will be changed to the new
position in the name list.

When you are done making your selection, click OK. To exit without any changes, click Cancel.

See also:
          Properties, Others 1



Start or Stop automatic viewing

Click on the View Menu, then Start/Stop automatic viewing. The window-slideshow will be started, with 
images from the current directory. Click again on this menu to stop the automatic viewing.



Hotkeys

Available shortcuts in IrfanView:

Key: Function:

+ Zoom In                        
 - Zoom Out
A About-Box dialog
CTRL + A Acquire
B Batch Conversion dialog
C Capture dialog
CTRL + C Edit -> Copy
CTRL + SHIFT + C Set as wallpaper - centered
D Edit -> Delete
CTRL + E Effects setup
F Best fit to desktop
CTRL + F Open first file in the directory
G Stop GIF or ANI animation
SHIFT + G Gamma correction
H Horizontal flip
CTRL + H Original size (no zoom)
I Image information
K Filter Factory dialog
L Rotate left
CTRL + L Open last file in the directory
M Minimize IrfanView window (Boss key ;-)
CTRL + M Open random image from the directory
N Show next image in the Overview Photo CD
CTRL + N Show next page in a multipage TIFF
O Open dialog
P Properties dialog
CTRL + P Show previous page in a multipage TIFF
SHIFT + P Print dialog
CTRL + SHIFT + P Set as wallpaper - previuos wallpaper
R Rotate right
CTRL + R Resample dialog
SHIFT + R Reopen file
S Save as - dialog
CTRL + S Save - dialog
T Thumbnails
CTRL + SHIFT + T Set as wallpaper - tiled
U Refresh (display and directory list)
V Vertical flip
CTRL + V Edit -> Paste
F3 Show image in HEX viewer
F1 Help
INSERT Edit -> Paste
W Slideshow dialog
CTRL + W Slideshow with current directory files
CTRL + X Edit -> Cut
CTRL+ Y Edit -> Crop



CTRL+ Z Edit -> Undo                                    
Space Load next file in directory
Backspace Load previous file in directory
CTRL+ Page Down Load next file in directory
CTRL+ Page Up Load previous file in directory
Page Down Load next file in directory (if no vertical scrollbar)
Page Up Load previous file in directory (if no vertical scrollbar)



Uninstall IrfanView

How to uninstall IrfanView:

1. Start IrfanView and go to Properties -> Extensions

2. Unselect all extensions and press OK (The most extensions will be free now, you must start another 
viewer and assotiate your extensions)

3. Close IrfanView (and delete IrfanView folder)



Open in HEX Viewer

Click on the File menu, then Open in HEX viewer. You can open any file in the HEX viewer.
You can see all bytes in HEX and ASCII mode of the opened file.

This option is used by advanced users.

To close without opening a file, click Cancel .  Another way to close is to click the X    in the upper right 
corner.



Show HEX view

Click on the View Menu, then Show HEX view. This option will show you the HEX view of the current 
image.
You can see all bytes in HEX and ASCII mode of the opened file.

This option is used by advanced users.



Glossary

A
AIF
ANI
AU
AVI
B
BMP
C
CAM
capture
check-box
clipboard
CLP
CPT
CUR
D
DAT
DCX
dialog
DIB
DLL
drag
dragging
E
EMF
EPS
EXE
extension
F
fill color
filter
Filter Factory
G
G3
GIF
grayscale
greyscale
I
ICL
ICO
IFF
IFF/LBM
image
interlaced
J
JPEG
JPG
JPG/JPEG



L
landscape
LBM
LWF
M
maximize
MID
minimize
MOV
MPEG
MPG
MPG/MPEG
O
option button
outline
P
PBM
PCD
PCX
PGM
PhotoCD
pixel
PNG
portrait
PPM
progressive
PSD
PSP
R
RAS
RAS/SUN
RLE
RMI
S
SFW
slider control
SND
sub-menu
SUN
T
tabs
task bar
TGA
thumbnail
TIF
TIFF
TIFF/TIF
transparent color
W
WAV
Windows Clipboard
WMF





AIF
Sound file, Audio Interchange Format from Amiga computers.



ANI
Animated Cursor format for Microsoft Windows 95.



AU
Encoded Audio format used by Sun and NeXT machines.



AVI
Audio Video Interleaved: Microsoft's video format for Windows.



BMP
Windows Bitmap: The image format Microsoft created for use in Windows.



CAM
Casio digital camera file.



capture
To store a part of the monitor screen in memory and turn it into an image, which can be saved and 
modified just like any other image. Capture utility programs (such as that in IrfanView) let you choose 
exactly which part of the screen to save.



check-box
A small square box, usually to the left of some text; clicking the box with the mouse makes a mark 
appear, showing it as a selected option. The text identifies what the option is for. Often check-boxes 
appear in groups, to allow multiple selections.



clipboard
An area used by Windows to store various file information for cut/copy/paste operations. For programs 
that support the clipboard (most do,) you can cut or copy from one application, and paste into another. An
example: an image edited pixel-by-pixel in Windows Paint can be copied to the clipboard, then pasted 
into IrfanView, from which it can be saved in a variety of formats. (Paint only saves as bmp.) Each time 
you cut or copy to the clipboard, it replaces whatever was there before.



CLP
Windows clipboard format; used to store various types of files for Windows cut/copy/paste operations.



CPT
CorelDraw Photopaint image, IrfanView can read only older versions, Photopaint 6, 5 etc.



CUR
Cursor Resource file format for Microsoft Windows 95; contains image data for cursors used by Windows 
applications. (Files may contain multiple images, plus a directory.)



DAT
Video CD format; don't confuse this with Windows dat files, which hold information about programs and 
such.



DCX
3D multiple PCX    files format.



dialog
In Windows, a box that appears when you click a menu item or button. The box will contain items from 
which you can select, to more accurately perform a function. For example, a Files dialog allows you to 
browse through the files on your hard drive, choose the one you want, and open it.



DIB
Device Independent Bitmap: another form of BMP, used widely with printers and display devices.



DLL
Dynamic Link Library; under Windows, a file that can contain portions of a program, to make the program 
more useful; it can also hold information to help the main program do its job better; many dll's hold icons 
that can be opened in IrfanView.



drag
Pulling the mouse, usually while holding down one of the buttons. This is used to highlight or outline an 
area, so that some special operation (such as cut or paste) can be performed on the area you select.



dragging
Pulling the mouse, usually while holding down one of the buttons. This is used to highlight or outline an 
area, so that some special operation (such as cut or paste) can be performed on the area you select.



EMF
Enhanced Metafile Format; Microsoft's device-independent graphics format for Windows 95.



EPS
Encapsulated PostScript: mostly used for desktop publishing; uses the Postscript page description 
language; these can be used on both PCs and Macs.
Note: IrfanView can open only EPSs with a TIFF preview image.



EXE
Executable file under DOS and Windows; many exe's contain    icons that can be opened in IrfanView.



extension
The part of a filename that comes after the dot (.) character. In a filename such as "i_view32.exe" the 
"exe" is the extension, and tells us this is an executable file - one that performs a function. (In this case, it 
is the IrfanView program file.) Some common graphics file extensions include .jpg, .gif, and .tif.



fill color
A color used to fill a large area, as opposed to drawing individual lines; if you see a drawn circle and the 
inside area of the circle is yellow, yellow is the fill color.



filter
For images: a small computer program that performs some action on the image, changing it in specific 
ways; filters can be used to smooth or roughen an image, correct or remove the color, and perform many 
other editing functions; most often, filters are used to create special effects.



Filter Factory
A creation tool for image filters. With filters, you can produce an almost endless series of special effects 
from very tiny changes in the image to complete makeovers. There are thousands of such filters 
available;    many can be found    for free on the internet.



G3
Group 3 Facsimile Apparatus format, used for document transmission.



GIF
Graphics Interchange Format: The format created by CompuServe for the faster exchange of graphics 
over modem lines; widely used in Web publishing.



grayscale
Despite the name, grayscale is actually a mode of color; it uses 256 shades of grey to render an image, 
producing a richly varied tonal quality; black and white uses just two colors, black with white spacing to 
render.



greyscale
Despite the name, greyscale is actually a mode of color; it uses 256 shades of grey to render an image, 
producing a richly varied tonal quality; black and white uses just two colors, black with white spacing to 
render.



ICL
Icon Library format, used by many icon editing programs; can contain one or many icons for use in other 
programs.



ICO
Windows    Icon: used by Windows to represent programs and other files.



IFF
Interchange File Format: the image format standard for Amiga computers.



IFF/LBM
Interchange File Format: the image format standard for Amiga computers.



image
The graphics you see on your screen; they can be photographs showing your home town, line drawings 
showing Mickey Mouse, even the undulating, weird backgrounds you see at many WWW websites. They 
can range in size from a single dot on your screen (so small it is difficult to see,) to huge objects that go 
off the screen in all directions, causing you to scroll the screen back and forth, up and down, to see them.



interlaced
In terms of some image types, such as gif: an image which builds up on the screen, showing the full 
image, but of low quality, then gradually building until the full quality image is visible. This allows the user 
to see some of the image as it builds. This is much the same as Progressive.



JPEG
Joint Photographic Experts Group: 24-bit support and fine compression make this format another 
standard for publishing on the Web.



JPG
Joint Photographic Experts Group: 24-bit support and fine compression make this format another 
standard for publishing on the Web.



JPG/JPEG
Joint Photographic Experts Group: 24-bit support and fine compression make this format another 
standard for publishing on the Web.



landscape
In reference to printers, printing an image so that it is faced with one long edge of the paper nearest you, 
as most landscape paintings would be faced. The other standard facing is Portrait.



LBM
Interchange File Format: the image format standard for Amiga computers.



LWF
LuRaWave Format: wavelet compression image format from LuRaTech GmbH, Germany. Format 
enhanced to improve on JPG, with better quality and more control options. IrfanView is the first viewer 
with LWF support.

Note: IrfanView can't save images larger than 640x480 as LWF.



maximize
To "blow up" a program window so that it fills the entire screen. This is useful if the information in the 
program does not fully display at a smaller screen size.



MID
Musical Instrument Digital Interface (MIDI): a file created with a set of standard formats to instruct 
electronic musical instruments how to play; with a MIDI player (such as IrfanView,) you can play a basic 
version of the song through the computer's speakers.



minimize
To remove a program, such as IrfanView, from the screen and have it appear as a button on the task bar 
at bottom of the screen. Click the button to restore the program to the screen.



MOV
Quick Time Movie format; Apple Computer's format for movie and other time-based data file storage.
Note: IrfanView uses the MS Active Movie for MOV playing. Active Movie can't play all MOVs, especially 
many QuickTime-created MOVs.



MPEG
Moving Pictures Experts Group: a standard for full-motion video; provides 352x240 resolution, 30 frames 
per second, and CD-quality sound; also used to compress audio without video.



MPG
Moving Pictures Experts Group: a standard for full-motion video; provides 352x240 resolution, 30 frames 
per second, and CD-quality sound; also used to compress audio without video.



MPG/MPEG
Moving Pictures Experts Group: a standard for full-motion video; provides 352x240 resolution, 30 frames 
per second, and CD-quality sound; also used to compress audio without video.



option button
A small circle, usually to the left of some text; clicking the circle with the mouse makes a mark appear, 
showing it as a selected option. The text identifies what the option is for. Option buttons appear in groups,
to allow a single selection from many choices; clicking one automatically "unclicks" all the others. 
Sometimes these groups are known as radio buttons, for their similarity to selecting a station on a radio.



outline
Highlighting an area you want to work on.

Put the mouse cursor at one corner of the area you want to outline. Press the left button, and hold it. Drag
the mouse across and down (or up,)    to the opposite corner of the area you want outlined. A border 
appears as you drag the mouse. Release the button when you are done dragging.
 
This technique is used in such operations as cropping, and adding text to an image. If the buttons on your
mouse are reversed, use the right button as described above.



PBM
Portable Bitmap File format; mostly used to convert between various types of bitmap images.



PCD
Digital images from Kodak, presented as "slides" on a CD-ROM. IrfanView can open the Overview-PCD 
files too!



PCX
PC Paintbrush format from ZSoft Corporation. These images are used by many word-processing and 
desktop publishing programs.



PGM
Portable Greymap File format; mostly used to convert between various types of greymap images.



PhotoCD
Digital images from Kodak, presented as "slides" on a CD-ROM. IrfanView can open the Overview-PCD 
files too!



pixel
Picture element: One dot in an image. It is the smallest (practical) element used to make up a picture.



PNG
Portable Network Graphics: A format that combines the best qualities of gifs and jpgs; used for Web 
publishing.



portrait
In reference to printers, printing an image so that it is faced with one short edge of the paper nearest you,
as most portrait paintings would be faced. The other standard facing is Landscape.



PPM
Portable Pixelmap format; mostly used to convert between various types of color images.



progressive
In terms of some image types, such as jpg: an image which builds up on the screen, showing the full 
image, but of low quality, then gradually building until the full quality image is visible. This allows the user 
to see some of the image as it builds. This is much the same as Interlaced.



PSD
PhotoShop Software Development file, used for development with Adobe Photoshop and related 
software.
Note: IrfanView (and other viewers too) can't correct display some PSD files, especially CMYK PSDs.



PSP
Paint Shop Pro file format, from Jasc Software; special graphics format that can describe a multi-layered 
image in complete detail.
Note: IrfanView will display only the first layer (if many) in a PSP image.



RAS
Sun Raster: The native bitmap file format for Sun Microsystems    workstations.



RAS/SUN
Sun Raster: The native bitmap file format for Sun Microsystems    workstations.



RLE
Run Length Encoded image format (Utah); device-independent means of storing multi-level raster 
images.



RMI
MIDI file (MIDI sequence.)    See also: MID.



SFW
Seattle Film Works format.



slider control
A control used in Windows to set a value for something. An example: in IrfanView, click on the Image 
menu, then select Brightness. A dialog opens with a slider control that allows you to set the value of 
brightness you want. In the Brightness control, the value starts at zero, and you can move the slider down
to -255 (less bright,) or up to +255 (more bright.) Click on one of the arrows to move the setting slowly. 
Click the area between the arrows to move the settings more rapidly. Put the mouse directly on the 
control bar (the box that starts at the zero setting,) press the left mouse button and hold it, and drag the 
bar to change the settings very rapidly. Most slider controls are similar.



SND
Sun-workstation sound file, similar to AU.



sub-menu
On a Windows menu, an extra menu that "pops up" when you point the mouse at one of the menu 
choices. This sub-menu gives further control over the choice. An example: on the Image menu, point the 
mouse at Effects; a sub-menu will appear to let you choose which effect to perform.



SUN
Sun Raster: The native bitmap file format for Sun Microsystems    workstations.



tabs
Small extensions at the top of a dialog box; they look like tabs on a file folder; clicking one changes to a 
different section of the dialog, allowing access to other options.



task bar
The area of Windows along the bottom of the screen. This displays various information about Windows' 
status, such as the clock in the lower right corner. Also shown in the bar are the buttons representing 
open programs, such as IrfanView. If you minimize a program, you remove it from the screen, but leave it 
active. Only its button shows, until you click the button to restore it.



TGA
Truevision Advanced Raster Graphics Adapter (TARGA): Format by Truevision, Inc, used to support 
image capturing; used with a series of high-resolution graphics adaptors released under the TARGA 
name.



thumbnail
A small version of a larger image. Thumbnails are used as "stand-ins" for images where space is a 
problem. Example: pages on the WWW often use thumbnails to represent images stored at the website. 
The thumbnails take a fraction of the time to load that the large images would take. Usually, the thumbnail
is linked to the large image, so that a click on it will load the full-sized version.



TIF
Tagged Image File Format: a widely used raster format, jointly supported by Microsoft and Aldus; used 
mostly in desktop publishing; can be viewed on both Macs and PCs; this is the format used by most fax 
machines.



TIFF
Tagged Image File Format: a widely used raster format, jointly supported by Microsoft and Aldus; used 
mostly in desktop publishing; can be viewed on both Macs and PCs; this is the format used by most fax 
machines.



TIFF/TIF
Tagged Image File Format: a widely used raster format, jointly supported by Microsoft and Aldus; used 
mostly in desktop publishing; can be viewed on both Macs and PCs; this is the format used by most fax 
machines.



transparent color
One color in an image that does not show onscreen. This is most often used to allow an image 
background to be invisible against other colors. An example would be a company logo used on an 
internet web page; a transparent background color would allow it to be placed directly over other images 
on the page, and all will still be visible.



WAV
Windows audio file; they take up a lot of space, but can serve as a go-between for converting between 
some of the other sound formats.



Windows Clipboard
An area used by Windows to store various file information for cut/copy/paste operations. For programs 
that support the clipboard (most do,) you can cut or copy from one application, and paste into another. An
example: an image edited pixel-by-pixel in Windows Paint can be copied to the clipboard, then pasted 
into IrfanView, from which it can be saved in a variety of formats. (Paint only saves as bmp.) Each time 
you cut or copy to the clipboard, it replaces whatever was there before.



WMF
Windows MetaFile format; Microsoft graphics file, more compact and portable than bmp images.






