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NOTE: Always backup any files you are about to delete.



 Overview
Link Check enables the user to view the links between an executable file and the modules 
it requires to run on the system. Furthermore, the program allows the user to view version 
information on these modules for identification purposes.

Link Check has a built-in scanner to identify modules on the hard disk which are apparently
not called by any executable. This enables the user to backup those files and remove them 
from the disk to free up some valuable disk space.

VERY IMPORTANT: Always backup any files you are about to delete.

The program evolved from two basic needs, namely to identify which modules needed to be 
backed up with a particular executable as well as identifying the modules that were likely 
candidates for deletion upon the removal of the executable.

Link Check also comes in handy when a program cannot run bacause some of the modules 
it requires are not present on the system. Link Check shows what those missing modules 
are.

This shareware version of Link Check supports 16-bit Windows executables only. Please 
click on Registered Version details for more information on what you'll receive if you decide 
to register with Link Check.



 System Requirements
Link Check requires Windows 3.1 or later or Windows for Workgroups 3.11.

This package consists of the following files:

1) WLCHECK.EXE Program itself 
2) WLCHECK.HLP Help file
3) CTL3DV2.DLL Optional, 3D effects in dialogs



 Menu Options

Please select one of the following:

File:
Open executable
Exit

Options:
Find unused modules
Expand selected module
Expand all modules
Key

View:
Toolbar
Status Bar

Window:
Cascade
Tile
Arrange icons
Close all

Help:
Contents
Search for Help on
How to Use Help
How to Register
About Link Check



 Module Window

To open a module window, please use the File menu option followed by the Open 
executable option or click on the short cut on the toolbar.

This window shows all of the modules that the selected file (indicated by the  symbol) is 
linked to. These modules are required to be present in your system for the executable to run.

If a  symbol appears next to a module name, then that component cannot be found in the
system.Link Check verifies the presence of a module by searching the directory of the 
executable (current directory) followed by the Windows System directory and then finally 
goes through all the directories listed in your PATH statement as set in your 
AUTOEXEC.BAT file to find the component. Note, however, that some programs use their 
own directory structure to locate their modules. Neither the system nor Link Check would 
pick these up.

If the text color of the module name appears in black, then that module is required to be on 
the system for that executable to run. If the text color appears in red, then a reference to 
that module exists in the executable. This does not necessarily mean that the module is 
required by the executable at all times but that it loads it upon request.

If you double-click (or press the Enter key) on any of the modules listed, a brief description 
of the module is shown including what the component actually is as well as version 
information.

You can also select Expand selected module or Expand all modules from the Options menu 
to display another module window showing all the modules that one is linked to.

For more information on the symbols used in the Module Window, please click on Key 
Window.



 Key Window

To open the key window, please use the Options menu option followed by the Key option or
click on the short cut on the toolbar.

This window shows the symbols and their meaning as used by the Module window.

Each different type of module is represented by a different color. The last two items in the 
key window are the explanations of the different text colors. If the text color of the module 
name appears in black, then that module is required to be on the system for that 
executable to run. If the text color appears in red, then a reference to that module exists in 
the executable. This does not necessarily mean that the module is required by the 
executable at all times but that it loads it upon request.



 DLL Scanner Window

To open the DLL scanner window, please use the Options menu option followed by the Find
unused modules option or click on the short cut on the toolbar.

Use this window to scan your hard disk for a list of possibly unused Dynamic Link Libraries 
(.DLLs).

To start the scan, click on the Scan pushbutton (in the above image, as the scanner is in full 
flow, the Stop pushbutton is in place of the Scan pushbutton). During scanning, you can 
select a module from the list and click on the Details pushbutton to view information about 
the file.

To stop or cancel the scan, click on the Stop pushbutton.

When the scanner has finished scanning the whole of your disk, the Save pushbutton 
becomes enabled and you can save the list to any ASCII or text file.

NOTE: During scanning, ALL of your .DLLs are listed. During the latter part of the scan, the 
scanner removes (from the list, not the disk) the .DLLs that have valid links. The ones 
remaining have no executable files calling them.

VERY IMPORTANT: Always backup any files that you're about to delete. This list is NOT 
always 100% accurate.



 File: Open executable
Click on this menu option to open an executable file or click on the short cut on the toolbar.

A new Module Window is created listing all of the components required by the executable to 
run.



 File: Exit
Click on this menu option to exit Link Check or click on the short cut on the toolbar.



 Options: Expand selected module
Click on this menu option to expand the selected module or click on the short cut on the 
toolbar.

A new Module Window is created listing all of the components required by it to run.



 Options: Expand all modules
Click on this menu option to expand all the modules listed in a Module Window. 
Alternatively, click on the short cut on the toolbar.



 Options: Key
Click on this menu option to show the Key Window. Alternatively, click on the short cut on 
the toolbar.

This window explains the symbols used in the Module Window.



 Options: Find unused modules
Click on this menu option to show the DLL Scanner Window or click on the short cut on the 
toolbar.



Window: Cascade
Arranges open windows in an overlapping pattern so that the title bar of each window is 
visible.



View: Toolbar
Shows and hides the toolbar.



 Toolbar
The toolbar contains the following short cuts:

 Open Executable

 Find Unused Modules

 Expand Selected Modules

 Expand All Modules

 Key Window

 Exit Program

 Help Contents



View: Status Bar
Shows and hides the Status Bar.



Window: Tile
Arranges open windows side by side so that all windows are visible.



Window: Arrange icons
Arranges all icons into rows.



Window: Close all
Closes all open windows.



Help: Contents
This menu item shows the Contents page of the help file.



Help: Search for Help on
This menu item shows the Search dialog box for the help file.



Help: How to Use Help
This menu item shows how to use Help.



Help: About Link Check
Use this dialog box to view the copyright information for this program. You may also review 
the license agreement as well as the order form for this program.



Order Form
Link Check 1.10 Order Form/Invoice

Print this form by using the File menu option followed by Print Topic menu option at the 
top of this page. Send this order form and a cheque payable to Karri Software Limited to:

Karri Software Limited
10 Regency Close,
Woodville Gardens,
Ealing,
London W5 2LP,
England.

Payments must be in English pounds (sterling) for the time being, or you can send 
international postal money orders in English pounds. Prices include shipping and 
handling fees.

3.5 inch diskettes will be sent unless 5.25 inch diskettes are requested.

Please send me ____ copies of Link Check 1.10

   at 11 pounds sterling in the UK each       =  _______

or at 13 pounds sterling outside the UK each  =  _______

UK residents please add 17.5% VAT             =  _______

Total (in English pounds sterling)            =  _______
Ship to:
Name:            _______________________________________

Company:         _______________________________________

Address:         _______________________________________

                 _______________________________________

Postcode/Zip:    _______________________________________

Country:         _______________________________________

Telephone:       _______________________________________

Electronic Mail: _______________________________________

Comments:



 Registered Version Details
Link Check is shareware and not available for free. You are allowed a 21-day evaluation 
period free of charge for this program and then you should either register it with the author 
or remove it from your disk(s). Should you use it after the 21-day evaluation period, you are 
violating US and international copyright laws and treaties.

To register this program, please click on How to Register/Order.

As a registered user of Link Check, you will receive the following benefits:

1. Technical support over the telephone and Email
2. Free updates for minor improvements
3. Information on other programs/utilities as they become available.
4. Other interesting offers that will appear to registered users only.

The registered version will also support 32-bit file formats, delete and backup facilities. 
Registered users can also suggest features they'd like to see incorporated into Link Check. 
Any of these features implemented will result in free upgrades for the suggester for the rest 
of the life of the program.

Technical support is not restricted to Link Check; with the discretion of the authors, other 
areas of technical support will also be supplied free of charge for the time being.



 Copyright and License Agreement
Link Check 1.10 (Shareware Version) 
Copyright (C) Karri Software Limited 1994-1995

The above is from now on known as SOFTWARE.

You should read this section carefully before using this SOFTWARE. By using this SOFTWARE
you are agreeing to the terms and conditions of this license agreement.

This SOFTWARE is shareware and not available for free. You are hereby granted a license for 
a 21-day evaluation period free of charge for this SOFTWARE. After the evaluation period has
passed you must either register the SOFTWARE with Karri Software Limited or remove it 
from your disk(s). Should you use the SOFTWARE after the 21-day evaluation period, you are
violating US and International copyright laws and treaties.

You are hereby granted a license to make as many copies of the SOFTWARE as you wish, and
distribute it to anyone as long as the SOFTWARE is distributed in its entirety and without any
modifications what so ever. Bulletin Board Systems are allowed to add a small file describing
the BBS with the SOFTWARE.

You are prohibited from charging or requesting donations from this SOFTWARE in any form. 
You are also prohibited in distributing the SOFTWARE as part of other products (commercial 
or otherwise) without prior written permission from Karri Software Limited. Only Disk 
Vendors approved by the Association of Shareware Professionals are permitted to 
redistribute the SOFTWARE, subject to the conditions in this license agreement, without prior
written permission. 

You may not rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer or
transfer the licensed SOFTWARE except as provided in this agreement. Any such 
unauthorised use shall terminate this license immediately. 

All rights not expressly granted here are reserved to Karri Software Limited. 

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" WITHOUT WARRANTY OF 
ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

THE USER MUST ASSUME THE FULL RISK OF USING THIS SOFTWARE.

ANY LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT 
OR REFUND OF THE PURCHASE PRICE.



Trademarks
Windows, Windows 3.1 and Windows for Workgroups 3.11 are registered trademarks of 
Microsoft Corporation.
OS/2 is a registered trademark of International Business Machines Corporation.






