
Running Personal Address Book

After you install the Personal Address Book 4.0 on your computer go to Start->Programs
and click on the Personal Address Book icon. When you execute PAB for the first time, an empty
data file called data.pab will be automatically created. If you're upgrading from a previous 
version of PAB (versions 1.6 - 3.0), you will be asked if you want to convert you old data file to 
a new format. It's recommended that you do. You can reverse that process later (see: Saving 
Found Records). If you're upgrading from a version prior to 1.6, your data file will be converted 
to a new format and your old data will be saved in the data.pab.orig file (see also: Loading 
Files). 

When the main window gets displayed you can start entering addresses by clicking on the
Add button. After you're done, you can press the  (asterisk) flat button on the main window 
(just above the address display area) to view all records in the database. 

To uninstall Personal Address Book 4.0 go to the Control Panel, double click on the 
"Add/Remove Programs" icon, select "Personal Address Book 4.0" from the list of installed 
programs and click on the "Add/Remove" button to start the uninstallation process.      





Adding/Editing Records

Adding New Records

From the main menu choose Function->Add.... A new dialog box will open up with 
several edit boxes where you will enter your data. The edit boxes are grouped by Name & 
Address, Phone(s), E-mail & WWW, Note and Location/Category. The edit boxes are self 
explanatory, however some of them are worth mentioning here. 

PHONE(S) - There are 3 edit boxes where you can enter phone numbers. To the right of 
the edit boxes there are 4 checkboxes that correspond to 5 categories: 2nd line, fax, cell phone, 
pager. The fifth (or rather the first) category is the main line which is assumed if you don't check
any of the checkboxes. Initially the checkboxes are disabled but when you get to the point where 
you're ready to enter a phone number, the checkboxes will be enabled. At this point, you will 
notice a little red arrow pointing to the edit box that the phone number is being entered into. 
After you enter a phone number you may want to mark it (for example as fax), then the arrow 
will show you what phone number the current checkbox selection corresponds to. 

LOCATION - When you write down someone's address it might be their home or work 
or school address. You have to have means of identifying the location of the addresses and/or 
phone numbers. There are 5 options to choose from initially: Home, School, Office, Work (not 
everyone works in an office), Other. If you select the "Other" option, the edit box below will be 
automatically enabled and you will be able to type in your own specific location that you want to
assign to the record.

You can add, edit and remove items from the list box to suit your needs by right clicking 
on the list box and choosing an appropriate menu item. You may also set the order of the items in
the list box by selecting an item and dragging it to its new spot. 

One other feature of this list box is that you can toggle its name between Location and 
Category (see: Settings). I've been asked by various PAB users to add this feature to facilitate 
better address categorization and organization.

When you're done entering the address just click Save (or press SHIFT & ENTER) to 
save the record in the database. Make sure that at least one of the search fields (Note, First 
Name, Last Name, Address, E-mail, WWW Address, Phone Number) contain data. If you leave all
of these fields blank the program won't let you save the data. It needs to have some way of 
searching for the record(s) later. 

    
Editing Existing Records 

From the main menu choose Function->Edit.... If you don't have a record displayed 
already, you will be prompted to choose whether you want to add a new record or cancel the 
operation. If you click YES refer to the Adding New Records section above. Otherwise you will
get the same dialog widow as in the above section, but the relevant fields will be filled with data. 





Searching for Addresses

First, in the box labeled Search/Sort by select the field you want to perform the search 
on (e.g. First Name, Last Name etc.). The Last Name is chosen for you by default. Next, click on 
the checkboxes below to narrow the search criteria. 

·    Starts With: Looks for records that start with the same sequence of characters as the 
string in the Search For edit box. Checking this checkbox automatically disables the Match 
Whole Field checkbox.

·    Case Sensitive: Checking this box forces a case sensitive search. 
·    Match Whole Field: Looks for records whose field(s) contain the exact copy of the 

string in the Search For edit box. Checking this box automatically disables the Starts With 
checkbox. 

Finally go to the box labeled Search For and type the string that you want to search for 
and click on the Find button.

You can use the flat buttons (also called the speed buttons) to perform quick searches. 
Pressing one of those buttons is equivalent to typing the button's letter in the Search For edit 
box and clicking on the Find button. For example, if you want to display all the records in the 
database you can type *    in the Search For box and hit the Find button or just click on the  
speed button.

If a record is found, it will be displayed in a white rectangular area right beneath flat 
buttons. Unless PAB is in the Additive Search mode (see: Other Features & Options), the results 
of previous searches will disappear. Only the newly found records will be displayed. You can 
resize the main window if all contents of the address record can't fit in the display area. If there is
more than one record found, then you can view the other records by pressing the navigation 
buttons with >, <, >>, << signs or the arrow keys on the computer keyboard (see: Keyboard 
Shortcuts). The number next to these buttons is the counter. It shows how many records were 
found and which record you're viewing. For example, 3/7 means that your looking at the third 
record out of 7 that were found. 



Additive Search Mode - a mode in which consecutive searches do not overwrite the results of 
previous searches but append results to the list of currently found records. If you find that you 
need to clear the current list of found records click the Clear All button.





Using Wild Cards

The following are symbols that allow you to perform wild card searches. This feature is 
useful when doing some cleaning up. When you enter these in the Search For edit box in the 
Main Window the results will be as follows: 

* - Finds all records in the database. 
? - Finds only the records that contain data in the field(s) that you specify in the 

Search/Sort By combo box. If used when searching on more than just one record (e.g. Phone 
(any field)) then the search will yield all the records that have data in all of the searched fields.

! - Finds only the records that DO NOT contain data in the field that you specify in the 
Search/Sort By combo box. If used when searching on more than just one record (e.g. Address 
(any field)) then the search will yield all the records that DO NOT have data in any of the 
searched fields. 





Using the Record Browser & the Note Browser

Using the Record Browser

Choosing Options->Record Browser menu item displays a floating list box with all the 
currently found records. The fields shown in the list box (by default) are Last Name followed by 
a comma and the First Name. You can change the display field(s) in the settings. Using the 
Record Browser is just a convenient way of scanning through a batch of records. Another way of 
displaying the Record browser is to click on the counter flat button, provided that at least 1 
record has already been found and currently displayed.

You can perform certain operations while in the Record Browser window. If you just 
want to look at the contents of the record, simply select the record from the list, using the mouse 
or the keyboard arrow buttons, and it will be displayed in the display area of the main window. 
You can edit a record by double clicking on it or pressing ENTER after making a selection. You 
can also right click on the Record Browser and a popup menu will let you choose the action that 
you want to perform.

If PAB is in the Multiple Selection mode you can select several records at a time. The 
currently displayed address will be grayed in the Main Window and a small rectangular box 
(above the right top corner of the Display Area) will appear, indicating how many records are 
selected. At this point you can perform batch Delete and/or Hide functions.

Using the Note Browser

If the (...) symbol gets displayed in the Note field it means that it contains more 
information that could be displayed. You can double click on the Note label or the Note field to 
invoke the Note browser and view all the information. In version 4.0, you can leave the Note 
Browser open while you perform other searches.



Multiple Selection Mode - allows for selection of more than 1 record in the Record Browser.





Sorting Records

When you start the program, or after you press the Clear All button, the Sort checkbox 
gets displayed underneath the Search/Sort By dropdown box. If you check the checkbox, then 
when you perform a search the data will be sorted in alphabetical order by the field that you just 
selected. The checkbox then becomes a Sort button. When the button is in the disabled state it 
indicates that the data currently displayed is sorted. If you choose another field from the 
Search/Sort By dropdown box the Sort button becomes enabled allowing you to sort the data by
that field. When you sort records you may sometimes come across records whose sorting field 
contains no data. A standard sorting algorithm would put these records in front of the records 
whose sort field contains data. I found that to be impractical here and implemented an algorithm 
that puts the empty sort field records at the end of the list. 





Printing

Personal Address Book 4.0 allows you to print Address Books and Envelopes with 
address information. 

·      Printing Envelopes
·      Printing Address Books 



Printing Envelopes

Under Function->Print choose Print Envelope menu item. A window resembling an 
envelope will appear with    several buttons and edit boxes. 

·    the To: edit box is for the address of a person or place that the envelope is going to be 
mailed to. If you do not have any addresses currently displayed in the database you'll need to 
enter the information yourself otherwise the currently displayed record will appear in this box. 
You can also scroll to a desired record using the navigation buttons "<" & ">".

·    the From: edit box is for the return address. You'll need to enter it yourself unless you 
specify a default return address in the settings section. A checkbox directly underneath it 
indicates whether the return address is to be printed on the envelope or not. NOTE: This 
checkbox appears only if the return address is entered in the From: box. 

·    the Font button displays a dialog that allows you to specify the kind of font you want 
to use. 

·    the Envelope button displays a standard page setup window. Generally this window 
will allow you to choose the printer you want to print to, paper type, size and orientation, etc. But
keep in mind that these options are dependent upon the printer and the printer driver that you 
currently have set up on your system. 

·    the Print button prints the information from the To: and optionally the From: edit 
boxes to the printer. 

·    the Help button brings up this help window. 
·    the Close button closes the Print Envelope dialog. 



Address Book - a set of addresses to be printed



Printing Address Books

Under Function->Print choose the Print Address Book menu item. A small window will 
appear with several last minute printing options. Note that if you don't have any address(es) 
currently displayed the Print Address Book menu option is disabled. 

·    the Print Page Markers checkbox allows you to print the page beginning and the 
page ending markers in the upper right corner of a page. The markers content depends on the 
field that the records were sorted by. Suppose that you found all the people that start with the 
letter S and you sorted them    by last name. The markers on each page of the printout will 
indicate the last name of the first person on the page and the last name of the last person on that 
same page. For example: if the last name of the first person on the page is Shue and the last name
of the last person on the page is Smith then the markers will print "Shue - Smith" for that 
particular page. 

·    the Page Numbers checkbox allows numbering of the printout pages. 
·    the Print To File checkbox enables you to direct the address book printout to a file 

rather than the printer.
·    the Location edit box is where you can enter the location of the file you want to print 

to. You can use the browse button [...] to select that location with the Open File dialog.
·    the Include Field Names checkbox will print out the field name before printing the 

contents of each field.
·    the Include Title checkbox will print out the title at the top of the printout.
·    the Append checkbox determines whether the printout will be appended to an already 

existing file or if that file will be overwritten with new addresses.
·    the Font button displays a dialog that allows you to specify the kind of font you want 

to use. 
·    the Page Setup button displays a standard page setup window. Generally this window 

will allow you to choose the printer you want to print to, paper type, size and orientation, etc. But
keep in mind that these options are dependent upon the printer and the printer driver that you 
currently have set up on your system. 

·    the Print button prints the information from the To: and optionally the From: edit 
boxes to the printer. 

·    the Help button brings up this help window. 
·    the Close button closes the print window. 

Personal Address Book 4.0 allows you to print only the fields that you explicitly select. 
Checking the Allow Selecting Fields for Printing checkbox in the Settings will enable a white 
arrow flat button near the top right corner of the window. Clicking on it will display or hide the 
fields checklist.



By default all fields are selected for printing



- Show field selection checklist
 - Hide field selection checklist



Fields Checklist - a control where you can select specific fields to be printed





Loading Files

Personal Address Book 4.0 allows you to load and view different files. Under File->Load 
New... you can select a new file to be loaded into the application. The file has to be in one of the 
PAB's formats in order to be properly loaded. After you load a file into PAB the previously 
loaded file gets saved and closed and you will be able to view only the addresses contained 
within the newly loaded file. Refer to section on importing data if you want to combine contents 
of two files.

The menu item File->Load Main allows you to quickly load the file that you designated 
as the Main Data File in the Settings.



Main Data File - a file designated as the main database file in the settings of the Personal 
Address Book under the Data File tab. Data.pab is the default main data file.



PAB distinguishes between 3 file formats for loading purposes:
·    PAB ver. 1.0 & 1.5 (obsolete - always converted to the newest format)
·    PAB ver. 1.6, 2.0 & 3.0 (optionally converted to the newest format)
·    PAB ver. 4.0





Importing Files

Choosing File->Import... menu item displays the Import dialog. The dialog contains 
several controls which specify the import file's formatting criteria:

1. PAB Format allows you to import files from older and/or current versions of Personal 
Address Book.

2. Delimited Format allows to import ASCII files whose fields are comma or tab 
delimited. Optionally the fields may    be wrapped around by another character. Most often that 
character is a double quotation mark.





Saving Found Records

Choosing File->Save As... menu item will display the Save As dialog. The dialog 
contains several controls which specify the format in which you can to save the currently 
displayed records. If you're saving records to an already existing file you have an option to 
append the records to the file, by checking the Append checkbox, or overwrite the file with new 
data.

The Tab Delimited format allows you to save PAB's data into a file where the data fields 
are delimited by the ASCII TAB character. This format is very useful if you want to export data 
into other database aplication formats.





Transferring Addresses to Other Applications

Cut & Paste

When an address is displayed in the white display area, you can extract any or all the 
information you can see there. Just highlight the fields of information you need and right click on
the white display area. A popup menu will allow you to choose Copy and the highlighted 
components will be copied to the Windows clipboard. At this point you can use any word editor 
and paste it there. If you want all the displayed info, just right click on the display area, choose 
Select All (w/o separators) or Select All (w/ Separators), then choose Copy and again you can 
paste it in your favorite word processor.

Export Plug-in

In order to be able to export data from PAB you need to download a free copy of the 
Export plug-in for PAB. It is not included with the installation version to minimize the 
installation file size and at the same time minimize the download time of the application. You can
find your free copy at the Personal Address Book Web Page at: 
http://www.geocities.com/SiliconValley/Chip/2719/AddrBook.html 
This plug-in does not work on some Windows 98 systems.

NOTE: Unless you install the plug-in the options below do not show up in the File Menu.
When you choose File->Export you'll get a popup menu with options to export data. DBF

File, Excel Spread Sheet, and Lotus 1-2-3 Spread Sheet menu items export PAB data to files 
in these particular formats. You can later use the corresponding applications that use these file 
formats to manipulate the data in any way you want.





Dialing Phone Numbers

When you choose Address->Dial option from the menu a dialog box will appear with 
several pre-dialing options. Depending on how many phone numbers there are entered for the 
currently displayed record they will show up in the three edit boxes. At this point, you can revise 
the phone numbers and press the appropriate Dial button to start dialing. If there aren't any phone
numbers in the currently displayed record then the dial dialog will have only one edit box and 
one dial button enabled. You can enter a number you wish to call into the edit box and press dial 
to start dialing. Note that the Add/Edit dialog (where you enter data) does not put any restrictions
on the phone number format. PAB will do its best to display it in some readable manner. If you 
find that the numbers you wish to dial are shown incorrectly you can always edit it before dialing
and/or adjust dialing settings in the Settings section. The bottom line is that all the numbers 
(characters in some cases) that are shown in the edit box (and are not comments) will be dialed. 
Any punctuation relevant when dialing phone numbers will also be dialed. 

If you have a record that contains more than 3 phone numbers and thus you "sacrificed" a
different field to enter the fourth phone number, you can highlight that number then right click 
on the display area and choose the Dial option. This will ignore any other phone numbers that 
might have been entered into the current record and will display only the highlighted number in 
the dial dialog. 

·    Local/Long Distance controls are used for toggling between displaying only the first 
7 digits of the number and the full number with the area code. Note that it only applies if you use
the canonical phone number format (+1(999) 999-9999). 

·    Convert Characters to Digits checkbox is displayed only if you check the Interpret 
characters as digits checkbox in settings. It is used to convert character based numbers (e.g.. 
999-9-NUMBER) to their digit equivalents (999-9-686227). 

·    Dial for Outside Line checkbox can be used if you need to dial a number to get the 
outside line. You need to supply the outside line number in the settings before you can use this 
control. 

·    International Phone Call checkbox is used when you want to place international 
phone calls. You need to supply the prefix number in the settings before you can use this control. 

Since there are not any restrictions on how you should enter a phone number into the 
database, Personal Address Book will try to decipher it for itself (and for you too). By default 
PAB assumes that phone numbers are in a format similar to the canonical format (i.e.+1    (999) 
999-9999). The +1 should not be entered when adding/editing records. Instead it should be 
specified in the dialing section of the Settings dialog. You also have an option not to use the 
canonical format at all. The bottom line is that PAB will dial any dialable digit (or character) as 
long as it is not a comment. 



Dialing Comment - the text in the phone number field that is wrapped around by the square 
brackets, e.g. [this is a comment]



Common Dialing Punctuation:
* - same as pressing the * on the phone dial
# - same as pressing the # on the phone dial
, - pauses dialing for about 2 seconds





E-Mailing & Web Browsing

E-Mailing

You can use Personal Address Book to start your system's E-mail Client and/or Web 
Browser. When you choose Address->Write E-Mail menu item, your system's default E-mail 
program will be launched and any information entered in the E-mail field of the currently 
displayed record will be placed in the TO: section of the e-mail message. If you have an e-mail 
address entered in a field other than the e-mail field you can highlight it, right click on the 
display area of PAB and choose Write E-mail. The E-mail field contents will be ignored and the 
highlighted address will be displayed in the TO: section of the e-mail message. 

WWW Browsing

You can use Personal Address Book to open Web Pages using a Web Browser. When you 
choose Address->Browse WWW menu item, your system's default Browser will be launched and
any information entered in the WWW field of the currently displayed record will be used to 
locate the desired web page. You can use protocols such as HTTP (default), FTP, TELNET, 
NEWS. If you have a web page address (URL) entered in a field other than WWW, you can 
highlight that URL, right click on the display area of PAB and choose Browse WWW. The 
WWW field's contents will be ignored and the highlighted text will be used to locate the web 
page. If you want to use a protocol different than HTTP then you need to explicitly specify it in 
the URL (e.g. ftp://ftp.anonymous.com).





Other Features and Options

·      Keyboard Shortcuts 

·      Customization of the Main Window 

·      Rebuilding Database 



Keyboard Shortcuts

Main Window 

Insert Key - add a new record
Delete Key - delete selected record(s)

Home Key - takes you to the first record of the address list
Arrow Up Key - same as Home key

End Key - takes you to the last record of address list
Arrow Down Key - same as End key

Page Up Key - skips to the previous record in the address list
Arrow Left Key - same as Page Up key

Page Down Key - skips to the next record in the address list
Arrow Right Key - same as Page Down key

Record Browser

Enter Key - allows user to edit the current record
Shift-E - same as Enter
Shift-A - allows user to add a new record
Shift-D - allows user to delete the currently selected record(s)
Shift-H - allows user to hide the currently selected record(s)
Shift-C - closes the Record Browser
Shift-X - exits the Personal Address Book application



Customization of the Main Window

In Personal Address Book 4.0 you can resize the main window to fit your needs and to 
display the addresses correctly using different fonts (see Settings). The Options menu allows the 
user to further customize the look of PAB's main window. 

·    The Option->Record Browser allows you to display/hide the record browser window.
·    The Options->Address Display Splitter allows the user to adjust the width of the field 

names display area. This menu item toggles the show/hide attributes of the splitter.
·    The Options->Function Buttons menu item toggles the show/hide attributes of the 

function buttons panel 
·    See section on Rebuilding Database to read about the Options->Rebuild Database 

menu item.
·    See section on Settings to read about Options->Settings menu item.



Field Names Display Area - the area containing field names, to the left of the main address 
display



Function Buttons Panel - panel with PAB's basic function buttons: Add, Edit, Delete, Hide, 
Help & Exit



Rebuilding Database

 The Options->Rebuild Database menu item lets you reload the data from the backup file 
in case there are problems with loading or reading the current data file. The backup file name is 
the same as your data file name but it has the *.BAK extention instead of the *.PAB extension. 
The backup file gets saved when you exit the application (or load a new file) if a change has 
been made to its corresponding data file.



A Change to a data file occurs when an Add, Edit or Delete operation is perfomed.





Settings Dialog

The Options->Settings menu item invokes the Settings tabbed dialog where you can 
customize certain features of the program. 

There are 6 tabs to choose from: 
·      Main Window 
·      Dialing 
·      Printing 
·      Data File 
·      Record Browser 
·      General 



Main Window Tab (Settings)

The Main Window tab allows you to customize features of the main window. 
·    The Search/Sort Defaults box is used for setting up the initial look of the controls in 

the main window at startup.    
·    Display Alignment lets you choose how you want the records to be aligned in the 

display area.
·    When the Search all records at startup is checked all records in the address book 

will be displayed every time you open PAB.
·    When the Perform additive searches checkbox is checked, found records get 

appended to the already existing address list. The first record of the set of newly found addresses 
gets displayed in the main window. 

·    The Show the "Hide" button checkbox toggles the show/hide attributes of    the Hide
button in the Function Buttons Panel. The Hide button removes record(s) from the found list 
without actually deleting them from the database. 

·    When the Don't display the 'Note' field information checkbox is checked, any 
information entered in the Note field will not be displayed. 



Dialing Tab (Settings)

The Dialing tab allows you to customize the dialing dialog features. The top group of 
controls consists of 2 checkboxes. When the Interpret Characters as Digits checkbox is 
checked, any character (A-Z, a-z) in a phone number that is not a comment (anything inside 
square brackets []) will be interpreted as a corresponding digit on the phone dial. You will then 
be able to convert the character(s) contained in phone numbers into digits and back. If the 
checkbox is unchecked then any characters in the phone number will be ignored.                                

When the Display Characters As Digits checkbox is checked, Personal Address Book 
automatically converts all character(s) contained in phone numbers into digits. 

The middle group consists of 3 edit boxes and 2 button-like checkboxes. You can input 
the International Prefix, the Outside Line Number and the Long Distance Prefix in the 
provided edit boxes. Pressing the Use at startup button-like checkboxes causes the equivalent 
checkboxes in the dial dialog to be checked each time the dialing window is opened. 

The bottom group lets you customize in what format you want the phone number to be 
displayed. The default is the canonical-like format (1+ (999) 999-9999). The radio buttons let 
you choose whether to display the entire phone number or just the local number. If you check 
Don't use the Canonical Format you can customize how you want the phone number to be 
grouped by selecting a number in the updown control. See Dialing Phone Numbers for more 
information. 



______ _____ _____
|          | ABC | DEF |
|    1    |    2    |    3    |
|-----------------|
| GHI | JKL | MNO |
|    4    |    5    |    6    |
|-----------------|
| PRS | TUV |WXYZ |
|    7    |    8    |    9    |
|-----------------|
|    *    |    0    |    #    | 
|_____|_____|_____|
                                    



Printing Tab (Settings)

The Printing tab allows the user to set default values for printing controls. The big edit 
box is for the return address to be printed on an envelope, provided that the checkbox below is 
unchecked. The bottom controls let you choose the defaults for printing the address books. The 
radio buttons let you toggle between printing all found records or just the currently displayed 
record. The checkboxes set the defaults for printing page numbers and/or page markers. You can 
also specify the default title for address book printouts by entering it in the edit box at the 
bottom. The bottom Allow Selecting Fields for Printing checkbox allows you to control what 
fields you want to print when printing address books. 



Data File Tab (Settings)

As the name suggests, the Data File tab allows users to customize some of the settings 
regarding the data files. The Main Data File group box lets you select the    main data file for the
application. By default data.pab is selected for you.

Checking the Display current data file name in the main window title bar checkbox 
allows to indicate to the user the currently used file.

Don't update the PAB 1.6-3.0 format to PAB 4.0 format allows for maintaining 
compatibility with older versions of PAB. If the above checkbox is not checked the user gets 
prompted whether or not to convert to the new format when loading older files. Checking the 
Don't prompt for conversion to new format will prevent the prompt from appearing.

When you use more than one file to store information in, you can set PAB to remember 
the last used file between sessions by checking the Remember the last used data file between 
sessions checkbox. The location of the currently used data file will appear on the bottom. 



Record Browser Tab (Settings)
                                                                                      

The Record Browser tab of the Settings dialog allows users to customize some of the 
Record Browser features.

The Display Fields group box allows for selecting fields and in what order they should 
appear in the Record Browser.

Checking the Display only the first field in the Record Browser checkbox will display 
only the field that you indicated as the first field.

Checking the Allow selecting multiple records checkbox enables the user to select more
than one record in the Record Browser.

Checking the Stay on top checkbox causes the Record Browser window to always be 
visible (not covered by other PAB's widows) whenever the Personal Address Book application is 
selected among all other possible applications that may be open and/or running.

Checking the Show records browser at startup allows you to display the Record 
Browser at startup. 

NOTE:
On slower machines ( < 100 MHz) the record browser may affect PAB's performance, 

especially when the Allow selecting multiple records checkbox is checked. In those cases it is 
recommended that you don't keep the record browser opened at all times.



General Tab (Settings)

The General tab allows users to customize general settings for Personal Address Book 
application.

The Font Defaults group box allows users to choose display & printout default fonts by 
pressing on the corresponding Select button. 

In the After Import group box you can choose how records are to be displayed after an 
import of data has been performed.

Checking the After adding a new address, display it in the Main Window checkbox 
will show the newly added record when you press OK in the Data Input/Edit dialog (see 
Adding/Editing Records).

You can prevent the keyboard arrow keys (Up,Down,Left,Right) from being the 
navigation keys in the main window (not in the Record Browser) by checking the Prevent the 
Keyboard "arrow" keys from record navigation checkbox. 

You can change the Location field to Category field by checking the Change the name 
of the 'Location' field to 'Category' checkbox. Many users reported to me that they didn't find 
use for the Location field but would like to have an additional field with record category info.

The Use HTML Help checkbox can be used with the Windows 98 HTML help system. 
You can download it from the PAB's web page.

The Use PAB's e-mail plug-in to send electronic mail checkbox works only if you 
install the email plug-in (see: Performance & Implementation Issues), also available on PAB's 
web page.





Frequently Asked Questions

This section contains some frequently asked questions asked by users of previous 
versions of PAB and some potential questions/problems users may have about Personal Address 
Book 4.0

·    What happens to my addresses when I'm upgrading from an older version of PAB? 
·    Where is the help file? 
·    How can I retrieve a record that I just deleted? 
·    PAB won't dial phone numbers even though the Phone Dialer program is installed. 
·    PAB won't dial 1 before the area code if the area code is the same as mine.
·    How do I display the address I just added? 
·    How do I display records I just imported into PAB? 
·    How do I select what fields to print? 
·    Where can I get the latest version of Personal Address Book? 

Other questions and/or comments send to: fsware@geocities.com 



What happens to my addresses when I'm upgrading from previous versions of Personal 
Address Book?

It is recommended that you uninstall the older version of PAB and install the current 
version into the same directory. The default directory is C:\Program Files\Pab. The 
uninstallation program does not remove the data files from the disk. So, if you installed the 
current version of PAB into the same location as the previous version, all addresses should 
appear in the current version. Otherwise you need to copy the data file called data.pab from the 
old location to the new one.



Where is the Help file?

The help file for the Personal Address Book 4.0 is called addrbook.hlp and resides in the
same directory as the main application's executable (addrbook.exe). The TEXT help is no longer
provided. The HTML help file (for Windows 98) is available only on PAB's web page: 
http://www.geocities.com/SiliconValley/Chip/2719/AddrBook.html 



How can I retrieve a record that I just deleted?

If you haven't closed Personal Address Book since you deleted the record, DO NOT 
EXIT OUT OF THE PERSONAL ADDRESS BOOK. Choose Options->Rebuild Database to 
restore the lost info.

If you have closed the Personal Address Book after the unfortunate deletion then unless 
you have backups of files on your system the record in question is irretrievable. 



PAB won't dial phone numbers even though the Phone Dialer program is installed

In the Phone Dialer program, go to Tools and choose Connect Using... from the menu. 
Make sure that the Use Phone Dialer to Handle Voice Call Requests from other Programs 
checkbox is checked. Click the OK button, exit out of the Phone Dialer and try dialing using 
PAB. 



PAB won't dial 1 before the area code if the area code is the same as mine

At first, I thought it was a bug in the PAB's code, but it turns out that Windows Telephony
System makes it happen. To get around this problem you have to go to the Control Panel, double
click on the Modems icon. In the Modems Properties dialog click on the Dialing Properties 
button. Now in the Area Code edit box enter some dummy 3 digit number and click OK. 
Note that this change will affect your system globally so you may want to keep this in mind, in 
particular when sending faxes. 



How do I display the address I just added?

In the PAB's Settings dialog click the General tab. Make sure that the After adding a 
new address, display it in the Main Window checkbox is checked. Now every time you add a 
new address it will get displayed in the main window.



How do I display records I just imported into PAB?

In the PAB's Settings dialog click the General tab. Now choose one of the options 
provided in the After Import group box.



How do I select what fields to print?

In the PAB's Settings dialog click the Printing tab. Now check the Allow selecting 
fields for printing checkbox. This will enable you to display a field selection check list in the 
Print Address Books dialog where you can check off the fields you want printed.



Where can I get the latest version of Personal Address Book?

http://www.geocities.com/SiliconValley/Chip/2719/AddrBook.html 





Performance and Implementation Issues

The Personal Address Book versions 1.0 - 2.0 were written in C++ using Borland C++ 
compiler with OWL 5.0. Versions 3.0 & 4.0 were written using Borland C++ Builder 3.0 with 
VCL. All versions should run on any 32 bit MS Windows platform. In version < 3.x the records 
are stored on a disk in the file called data.pab and in the backup.pab. PAB 4.0 uses data.pab as
the default data file however PAB 4.0 allows users to store its data in more than one file. The 
backup file now has the same name as the data file but it has the *.BAK extension. If you're 
upgrading from a previous version of PAB the backup.pab gets renamed to backup.old, and the
new backup file gets named data.bak.    

I recommend that you run PAB 4.0 on a Pentium machine with at least 16 Mb of RAM. 
However, when I tested the program on a 486/50 with 16 Mb RAM,    2000 records were in the 
database and    PAB still performed (in my opinion) with tolerable speed.

There are two plug-ins available for use with the Personal Address Book 4.0, the Export 
plug-in & the Send Email plug-in. The Export plug-in can be used for exporting PAB's data 
directly into file formats: DBF, Lotus 1-2-3, Excel. I found that it does not work on some 
Windows 98 systems. The Send Email plug-in can be used to send email, in case you don't have 
an email client on your system already or it's not properly installed or you just don't wish to use it
with PAB. This plug-in can only send email, it cannot receive it. It can be used as a stand alone 
application.

You can download both plug-ins (free of charge) from:
http://www.geocities.com/SiliconValley/Chip/2719/AddrBook.html 





Credits & Copyrights

I'd like thank my wife Danielle for editing this help file and making it more readable 
(also for putting up with me and my procrastination of house chores while I wrote this program).

I would also like to extend my thanks to all the people who sent me comments and 
suggestions about previous versions of Personal Address Book. It has been a tremendous help 
while trying to improve the program. 

This program is freeware. Feel free to use, copy and/or distribute this software freely as 
long as it's free of charge. 

If you encounter any bugs, errors or if you just have comments do not hesitate to report 
them to: 
    Rafal Szukala 
    fsware@geocities.com 



Freeware - Copyrighted software given away for free by the author. Although it is available for 
free, the author retains the copyright, which means that you cannot do anything with it that is not 
expressly allowed by the author.
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