
About AVGuard/9x
The AntiVir Personal Edition with the resident scanner AVGuard has been developed especially for home 
users. It is completely free of charge for private use and can be obtained from the following Internet URL: 
http://www.free-av.com.

AntiVir 6 Professional
If you need support of network drives or if you need any more functionality, we recommend the 
enhanced version of AntiVir: AntiVir 6 Professional. 

Currently there are the following AntiVir products available:

DOS, Windows 3.1x, Windows 9x, Windows Me, Windows NT, Windows 2000, Windows XP, OS/2, 
Linux (i386), FreeBSD (i386), OpenBSD (i386) Novell NetWare, Windows 2000 Server, Exchange 
Server, Exchange Workstation, Outlook, Eudora Mail Client and MS Mail. 

More information about these products is available from one of the address below or from the 
Internet:

H+BEDV Datentechnik GmbH Internet: http://www.hbedv.com
Lindauer Strasse 21 Email: info@hbedv.com
88069 Tettnang Phone: +49 (0) 7542 - 500 0
Germany Fax +49 (0) 7542 - 525 10

About AVGuard/9x
This dialog box displays some information about the AVGuard for Windows 9x VxD and the control 
program.

Version Information
The first line displays the version and the creation date of the AVGuard/9x Control Program. The 
current version of the AntiVir search engine is displayed in the second line. The third line contains 
the version of the currently used virus definition file.

Hotline
Technical support is available via Internet only.

Technical inquiries via Phone/Fax/Letter and e-mail can not be answered!

In order to facilitate your inquiries to the technical support, we have created an Internet Support 
Forum for you.

You find the AntiVir Support Forum on the internet at: http://www.free-av.de/forum.

You will find the frequently asked questions about AntiVir Personal Edition and you will have the 
possibility to submit technical questions to all other forum members and our moderators. Additionally,
you can discuss with other users of AntiVir and share your own experiences and hints.

Additional Product Information
This section contains the information how to contact us if you need information or assistance 
concerning our AntiVir Professional products.



Activate AVGuard
If you click this item, AVGuard will be activated. 

This means that the resident guard will check every file depending on the settings. To protect your system
against viruses and unwanted programs you should have the AVGuard activated. This option is disabled if
the AVGuard already is activated!



AntiVir Professional
Besides the AntiVir Personal Edition, H+BEDV Datentechnik GmbH offers the AntiVir 6 Professional 
Edition. This package provides a much enhanced functionality and a flexible and cheap licensing, 
especially in multi-user environments.

Additional Features:
Support of network drives.
Support of network messages and warnings.
Support of search profiles.
Scanning of single and multiple directories.
Scanning of user-defined archives.
Explicit scanning of boot records.
Intranet-Update-Wizard. This is a tool to distribute the software in your network.
Start of external programs depending on the search results.
Scheduler.
Password protection for the configuration.
CRC option.
Enhances configuration possibilities for the scan- and repair engine.
The email scanner for MS Mail, Qualcomm Eudora, MS Outlook and MS Exchange Client are 

included. 

Currently there are the following AntiVir products available:

DOS, Windows 3.1x, Windows 9x, Windows Me, Windows NT, Windows 2000, Windows XP, OS/2, Linux 
(i386), FreeBSD (i386), OpenBSD (i386) Novell NetWare, Windows 2000 Server, Exchange Server, 
Exchange Workstation, Outlook, Eudora Mail Client and MS Mail. 

Information about these products is available at:
H+BEDV Datentechnik GmbH Internet: http://www.hbedv.com
Lindauer Strasse 21 Email: info@hbedv.com
88069 Tettnang Phone: +49 (0) 7542 - 500 0
Germany Fax: +49 (0) 7542 - 525 10



Configuration
This menu displays a property sheet to configure the AVGuard for Windows 9x. 

The button  has the same effect. 

The property sheet contains the following property tabs:

Scanner All settings used by the scanner.
Action Actions to perform if a virus or unwanted program has been found.
Heuristic Settings for the AntiVir macro virus heuristic.
Report Report file settings



Contents
These help pages are currently available in AVGuard for Windows 9x Personal Edition:

About AVGuard
Activate AVGuard
AntiVir Professional
Configuration
Deactivate AVGuard
Demo Version
Edit File Extension
Exit And Close
Exit And Minimize
File Action
File Extensions
Files To Scan
Main Window
Property Tab Action
Property Tab Heuristic
Property Tab Report
Property Tab Scanner
The File Menu
The Help Menu
The Options Menu
Trouble Shooting
Virus Infection
VxD-Status



Deactivate AVGuard
If you click this item, the AVGuard will be deactivated. This means that the resident guard will no longer 
check any files for viruses and unwanted programs. Handle with care since concerning files may not 
longer be detected! This option will be disabled if the AVGuard already is deactivated.



Demo Version
Demo-Version

If you don't have a valid license key file, AVGuard/9x Personal Edition will run in the restricted demo 
mode. This means that it will only scan files on the volume C: of your computer.



Edit File Extension
You can enter a new file extension in this dialog box. The maximum length of a new extension is 6 
characters. 

{button OK,}

The current extension will be inserted into the list of file extensions.

{button Cancel,}

The current extension will be thrown away and not inserted into the file extension list.

{button Help,}

Displays this help screen.



Exit And Close
To completely exit and close the Control Program you have to click this item. The program will be 
completely closed. A restart is only possible using the icon in the AntiVir/9x program folder.



Exit And Minimize

or use the button  

Click this item if you would like to exit the Control Program but don't want to close it. It will be minimized 
and you can see its icon placed in the system tray. A double click on the small icon in the system tray will 
enlarge it for further use. When minimized, the AVGuard Control Program does not consume any CPU 
cycles. 



File Action
In this box, you will see the currently selected action to be performed by AVGuard/9x in 
case of an detection.

Repair File
AVGuard/9x will try to repair the reported file. If a repair is not possible, the action set with Action if 
file not repaired will be taken.

Please note that the following actions will only be performed if the concerning file is unable to be 
repaired.

Delete File
The concerning file will be deleted. It is not possible to restore the file anymore.

Move File
The concerning file will be moved to the quarantine directory set in the filed Quarantine Directory. 
The files in this directory can be repaired later on or you can send us such files for further 
investigations if needed.

Rename File
The concerning file will be renamed to *.VIR. Any direct shell shortcut to the file will be disabled. You 
can re-rename and repair the file later on.

Notify Only
AVGuard/9x will deny access to an concerning file. If enabled, only an entry will be written to the 
logfile.



File Extensions
The file extensions used by AVGuard/9x when "Program Files Only" is enabled are stored in this list.

You can edit the list as follows:

{button OK,}

This closes and saves the current list

{button Cancel,}

The changes made are cancelled.

{button Insert,JI(`',`HELP_EDIT_EXTENSION')}

Opens a window to edit and insert a new file extension.

{button Delete,}

This deletes the currently marked item in the list.

{button Default,}

This sets the list to the default file extensions as shipped by H+BEDV Datentechnik GmbH.

{button Help,}

Displays this help screen



Files To Scan
Files to scan
AVGuard/9x can use a filter in order to limit the number of files to be scanned. Since the filename 
extension in PCs normally also indicates the type of file in question, AVGuard/9x is equipped with a filter 
which limits the data to be scanned to files with a specified extension.

All Files

If this option is selected, all files are automatically scanned for viruses and unwanted programs.

Use file extension list

In this case, only files with a file extension included in the list are scanned for viruses and unwanted 
programs.

{button File extensions,JI(`',`HELP_FILE_EXTENSIONS')}

Displays the list of file extensions for the user to edit.



Main Window
The main window of AntiVir Guard for Windows (Personal Edition) consists of 3 main areas: the menu 
bar, the tool bar and the display area for statistical data. More detailed statistical data and additional 
configuration options are available with our professional version, AntiVir 6 Professional.

Menu Options
File
Options
Help

Configuration
VxD-Status: This displays the current status of the AVGuard/9x VxD. 
File Action: This field displays the action taken if an concerning file has been found and the user

notification has been disabled.
Last File: The name of the last file scanned by AVGuard/9x.
File To Scan: All files or only files with a specific file extension.
Notify User: Notify the user when an detection occurs or take the action automatically.

Statistics
In these fields that current statistics of the Guard will be displayed. Note that - from performance reasons 
- these fields will be updated only twice a second.

File Count: The number of files scanned.
Last Detection: The name of the last virus or unwanted program found.
Detections: The number of viruses and unwanted programs found.
Repaired Files: The number of successfully repaired files.
Moved Files: The number of files successfully moved to the quarantine directory.
Deleted Files: The number of successfully deleted files.



Property Tab Action
This sheet configures how AVGuard/9x shall react if a virus or unwanted program has been detected.

Action If File Not Repaired
When AVGuard/9x discovers a virus or unwanted program, it will display a text mode dialog to let the user
selects the action to be taken. If the file could be repaired and the auto-repair mode is enabled, the user 
can select to repair the file. If this repair fails, the action selected in this group box will be taken. If the user
selects another option in the displayed dialog box, the selected action will be taken. 

Delete file
The concerning file will be deleted but can be restored using appropriate tools.

Move to quarantine directory
The concerning file will be moved to the Quarantine Directory entered in the appropriate field. Note 
that only the Administrator should have access rights to this directory!

Rename file to *.VIR
The concerning file will be renamed to *.VIR, ... It can no longer be accessed using the shell.

Ignore File

The concerning is merely entered in the report file if activated.

Quarantine Directory
If a file is to be moved to the Quarantine Directory, AVGuard/9x will move it to the directory specified 
in this field.



Property Tab Heuristic
This property tab contains the settings for the AntiVir virus heuristic. 

Macro virus heuristic
AntiVir contains a very powerful macro virus heuristic, which is able to detect even unknown viruses, 
worms and trojans. This is done by analyzing the macro virus code and searching for typical virus actions 
and code fragments. If a macro fits into this pattern, it will be marked as suspicious.

If a repair is disabled, suspicious documents will be reported only. This means that AntiVir will not try to 
repair them. If repair is enabled, all macros are deleted.

Win32 file heuristic
AntiVir contains a very powerful heuristic for Windows executables, which may detect even unknown
viruses, worms and trojans. If activated, you can decide which level of detection capabilities AntiVir 
should use.

Detection level low

With this setting, AntiVir false positives are minimized, 

Detection level medium

This is the default setting.

Detection level high

Using this level, AntiVir detects almost all unknown viruses. There might be some false positives, 
however.



Property Tab Report
AVGuard/9x has a very powerful reporting function included. It is able to give the administrator a complete
report of what's going on with your machine.

Report file

Reporting enabled
If selected, AVGuard will activate the reporting feature. A default report file name will be inserted to 
the edit field for the logfile name. 

Name of logfile
This is the name and the path of the report file to write. Each entry will be added to this file.



Property Tab Scanner
These settings are used to configure the scanner of AVGuard/9x.

Files to Scan
AVGuard/9x can be configured to use a filter to exclude some files that are normally not hosts for viruses 
and unwanted programs. This can improve the system performance depending on you environment.

All Files
If selected, all files accessed in the specified device mode will be scanned automatically.

Use file extension list
Only files with a file extension that matches an extension in the file extension list will be scanned.

{button File extensions,JI(`',`HELP_FILE_EXTENSIONS')}
Opens a window with a list of file extensions used by the scanner.

Drives
At least with the AntiVir Professional Edition AVGuard may monitor network and local drives differently. 
The Personal Edition only supports local drives.

Reported files

Repair automatically
You have to activate this option in order to be able to repair reported files. AVGuard uses a special 
mode to search for viruses and unwanted programs if this option has been activated. Using this 
mode, AVGuard is able to collect information weather the file may be repaired or not. This option is 
required to be able to repair files. 

NOTE: This option has to be activated too, if you would like to have the repair option enabled that is 
shown in a dialog box displayed when an reported file has been detected.

System shutdown

Warn if floppy in drive A:
A lot of today's viruses still replicate via the boot sector of a floppy disk. If your BIOS startup option is
still A:/C: and you leave a possibly infected floppy disk in your drive A:, the next system startup may 
cause you computer to be infected with a boot sector virus. To avoid this, AVGuard checks the drive 
A: for an inserted floppy disk at system shutdown if this option is enabled. This will minimize the risk 
of becoming infected with such a virus or unwanted program.



The File Menu
This menu contains the following sub menus:

Activate AVGuard

Select this function to activate the scan for viruses and unwanted programs in AVGuard/9x.

Deactivate AVGuard

Select this function to deactivate the scan for viruses and unwanted programs in AVGuard/9x.

Start AntiVir Main Program

This is a shortcut to start the AntiVir Main Program (on-demand scanner) easily.
This menu option is an easy way of starting the AntiVir main program from AVGuard/9x, e.g. in order 
to carry out a scan on the entire C:\ drive.

Start Internet Update

The internet updater can now also be started via this menu option. This improves user-friendliness, 
as you no longer have to load the main program whenever you want to start the updater. This menu 
option is only selectable provided the internet updater is already installed and activated.

Exit and Minimize or  button

Select this entry if you wish to exit the AVGuard/9x control program without closing it completely. 

Exit and Close

Select this entry if you wish to exit the control program and close it completely.



The Help Menu
In this menu, you will find information on AVGuard/9x and how to operate it.

Help (F1) or  button

Opens the context-sensitive help system (these pages). 

Using Context Sensitive Help

This tells you how to use the context-sensitive help system.

Help Index

Displays a page containing cross-references to all available help pages.

About AVGuard/9x

This menu option opens a window containing further information on AVGuard/9x together with our 
addresses.



The Options Menu
This menu contains the following entry:

Configuration or button 

Select this to configure the AVGuard/9x.



Trouble Shooting
If AVGuard/9x Personal Edition does not work properly or if you have any problems with AVGuard/9x or if 
you have an detection which you are not able to manage yourself, please check the following:

Please check if the VxD is active. The small red umbrella in the system tray must be opened. 
Please activate the VxD if necessary by clicking the item "Activate AVGuard" in the "File" menu.

Check the settings of the group Files To Scan. If "Use file extension list" is selected, you should 
have a look into the file extension list. Please set it to default values if needed. 

To be able to repair a file, it is important that the option Repair automatically is enabled.
It is strongly recommended that you do not use resident virus guards from other vendors besides 

AVGuard. Multiple virus guards lead to an instable system in most cases.

More information can be found in the file README.TXT in the program directory of AntiVir or in the 
internet at www.free-av.com.

AntiVir Support Forum
In order to facilitate your inquiries to the technical support, we have created the AntiVir Support Forum for 
you.

You find the AntiVir Support Forum on the internet at: http://www.free-av.de/forum.

You will find the frequently asked questions about AntiVir Personal Edition and you will have the possibility
to submit technical questions to all other forum members and our moderators. Additionally, you can 
discuss with other users of AntiVir and share your own experiences and hints.

To enable us to help you efficiently, please add the following information to your request:

Version information of virus definition file, serach engine and program.
The version information of your operating system and the possibly installed service packs.
Installed software packages, e.g. antivirus applications from other vendors.
The exact (!) messages displayed by the application or shown in the logfile.

Technical inquiries via Phone/Fax/Letter and e-mail can not be answered!



Virus Infection
This provides a brief introduction to the steps to take if AVGuard/9x finds a virus, for example. Please note
that there are some limits to the functionality of the AntiVir Personal Edition. Should you require antivirus 
software for other platforms or an extended range of functions, we would recommend the version AntiVir 
6 Professional.

If AVGuard/9x detected a virus ...

1. Don't panic and beware calm!

AVGuard/9x has done all the important jobs automatically if it is configured correctly. If you tried to 
access or to start an infected file, it will be disinfected or moved or the access to this file will be 
denied. After successful disinfection, you can work with that file as usual. If disinfection is not 
possible, the file will be normally moved to the quarantine directory and you'll get a warning.

2. Follow the antivirus instructions step by step, don't rush the things!

Now, it is important to check your complete workstation and all possibly infected floppy disks for 
viruses. It would be a good choice to let AntiVir/9x do this job since it has already been installed on 
your system. Please try to disinfect all infected files and boot records on your hard disk and all floppy
disks. Ask your dealer or call H+BEDV if you need any assistance. Possibly it would be a good idea 
to activate the automatic repair option inside AVGuard/9x. If AntiVir/9x or AVGuard/9x is not able to 
disinfect the file, please send us a copy for further analysis. We will provide you with a solution as 
fast as possible. At least, try to investigate where the virus did come from. Check your anti-virus 
strategy if needed to beware of further infections.

3. Inform your colleagues, your boss and your business partners!

It is not a very pleasant job, however information is very important in such cases. Especially, if the 
virus has been imported from outside your site. Please inform your colleagues, your boss or your 
security manager about the infection!

4. Unknown new viruses and suspicious files

Please send new unknown viruses and suspicious files in an encrypted archive as an email 
attachment to virus@free-av.com. Please don't forget to mention the password and a short virus/file 
description.



VxD-Status
This field displays the current status of the AVGuard for 9x Service. 

Active
means that the VxD is up and scanning for viruses and unwanted programs in the background. 
However, since AVGuard uses the options you've selected, some files may not be scanned. 

Deactivated
that the AVGuard VxD does not scan for viruses and unwanted programs on your computer.




