
Contents For DingDang Help
About The Program

How To...
Setup File DINGDANG.INI In Window Directory
Input English
Input Chinese By Pin1 Yin1 Method
Input Chinese By Que1 Wei4 Method
Input Chinese By Cang1 Jie2 Method
Use Traditional Characters (Fan2 Ti3 Zi4)
Print Documentation
Format Documentation
Editing Text
Contact The Author

Commands
File Menu Commands
Edit Menu Commands
Input Menu Commands
Font Menu Commands
Format Menu Commands



About the Program ...
DingDang for Window is a Chinese word processor designed to run under MS 
Window version 3.1 or later.  The file size is currently limited to 60K, or 
about 28,000 Chinese characters.  It uses standard GB coded ASCII text format.
It can write Chinese, Japanese, Russian as well as English.

The shareware version is distributed with 2 16x16 bitmap fonts: simplified and
complex.  The regular version includes additional 5 24x24 fonts: song4, kai3, 
fang3 song4, hei1 and fan2.  Text can be scaled to any sizes.

The program prints through the standard Window printer driver so it can print 
on any printer that Window 3.1 supports. It can exchange text with other 
programs with cut and paste.  It can exchange Chinese text with another 
program (or another instance of DDWIN.EXE) which also support standard GB 
coding.

It supports several input methods.  Pinyin input is popular for short text.  
Cangjie is fast when you do a lot of Chinese text editing.  Quewei input is 
handy when you need to find the GB code of a character.



Shareware version
Shareware version of DingDang Chinese word processor has the following 
restrictions:

1. You will see this screen in help window instead of main window when you 
start the program.

2. File will not be saved if it is larger than 2400 bytes.

Now you may double click the upper left box to close the help window or choose
to read the following topics:

Main help index
Contact the author



File Menu Commands
New

Opens a new document with file name "untitled.gb". You should use Save As 
option to save the file with a different file name.

Open

Opens an existing GB coded file or create a new file. If a file is larger than
60K in size, only the first 60K will be read into the editing buffer.

Save

Saves changes to the document you have been working on. When you choose Save, 
the document remains open so you can continue working on it. Save will be 
grayed if you have not made any change to the document.

Save As

Saves a new or existing document. You can name a new document or save an 
existing document under a new name. The original document remains unchanged. 
When you choose Save As, the document remains open so you can continue working
on it.

Print

Prints one copy of the document. Since texts are printed as graphic images, it
is slow. Please be patient.

Print Setup

Selects a printer and sets printing options such as printer orientation, 
printing quality etc.. The available options depend on the type of the printer
selected.

Exit

Closes the document you have been working on and quits the program. You will 
be asked to save your file before quitting if you have made any changes to the
file.



Edit Menu Commands
Cut

Deletes text from a document and places it onto the Clipboard, replacing the 
previous Clipboard contents.

Copy

Copies text from a document onto the Clipboard, leaving the original intact 
and replacing the previous Clipboard contents.

Paste

Pastes a copy of the Clipboard contents at the insertion point or replaces 
selected text in a document.

Delete

Deletes selected text from a document, but does not place the text onto the 
Clipboard. Punctuation Delete when you want to delete text from the current 
document but you have text on the Clipboard that you want to keep.



Input Menu Commands
Tips: I found it convenient to resize the main window wide but short (less 
than 5 liens in height) when editing text.  And move the input dialog window 
below the main window so that they don't overlap.

PinYin

Activate pinyin dialog box so Chinese characters can be typed by pinyin 
method.  Pinyin input is easy, but slow.  It also requires that you are 
familiar with the pronunciation of the character.

QueWei

Activate quewei dialog box so Chinese characters can be typed by quewei 
method.  This is not really an input method since most people can't remember 
quewei codes.  Best for typing punctuation, Japanese characters and graphics 
characters.

CangJie

Activate cangjie dialog box so Chinese characters can be typed by cangjie 
method.  Cangjie input is very fast and efficient.  It does need you to learn 
some basic rules before you can comfortably use it.

Please read the file CANGJIE.GB for more information. You should also print 
the file CJB.PCX with Window Paintbrush program.

Find Cangjie code from pinyin / GB code.



Font Menu Commands
Pure Chinese

If this menu item is checked, then English letters will be translated to their
corresponding Chinese characters, except that '.' and '`', which will be 
translated to period (jue4 huao4) and duen4 huao4 respectively.

Fonts...

Each entry in [font] section in the profile DINGDANG.INI will be appeared as a
menu item. 24x24 fonts will be grayed since they are used for printing only. 
You can choose any of the 16x16 Chinese character fonts you want by clipping 
the mouse button on the item.



Format Menu Commands
Page control codes are embedded into documents inside a pair of delimited 
char.  The default character is '~'.  The delimited character can not be used 
in document text (you can still use the Chinese version of '~').  If you want 
all characters available, then you can use a non-printable character such as 
127 (delete) as the delimited character.  See setup file DINGDANG.INI.

Page Control

Check this item to reveal page control codes in the document. When this item 
is checked, you will be able to type page control codes directly from keyboard
if the delimited character is printable.  Make sure that all control codes are
properly enclosed inside the delimited character.

Add Control

A dialog box will appear so you can add page control code to the document. 
This is only way, (and safer way) to add control codes to document when the 
delimited character is non-printable.

Edit Control

The next page control code will be shown in dialog box. You can change or 
delete this code.



Find cangjie code from pinyin / GB code
If you can't finger out the cangjie code of the character, but you can type 
the character by using pinyin / quewei method, you can do the following: First
show the character by using pinyin / quewei dialog box respectively.  Now open
cangjie dialog box.  The cangjie code of the character will be shown in the 
edit box.



Setup file DINGDANG.INI in window directory
If you do not have a file DINGDANG.INI in your window directory (normally C:\
WINDOWS), DingDang will make one for you as the following:

[dd]
left margin=100
right margin=100
top margin=100
bottom margin=100
char skip=0
baseline skip=58
paragraph skip=0
char width=32
char height=36
pure Chinese=0
delimited char=126

[font]
Song16=song16.fon
Fan16=fan16.fon

You can edit this file with any DOS editor such as EDIT or DDWIN. For example,
if your font file path is d:\font\fan16.fon, then you may use the following as
the first line in font section:

[font]
FanTi16=d:\font\fan16.fon
JieTi16=d:\font\song16.fon
SONG24=d:\font\song24.fon
FAN24=d:\font\fan24.fon

The general syntax under [dd] section is: String=Number, where String must be 
exactly typed as the above and number is an integer. Baseline skip is distance
between two line so that it should be larger than char height. Use 0=no 1=yes 
for pure Chinese. If you use '~' (code 126) character, you can set delimited 
char=127. See Format Menu Command.

The general syntax under [font] section is: FontName=Path, where FontName must
end with either "16" or "24" and path is any valid DOS path name.



Input English
English letters can be typed directly from the keyboard.

When "pure Chinese" menu item under menu "Font" is checked, the Chinese 
character version of the English letters will be printed.

DingDang can edit normal DOS text file such as DINGDANG.INI or AUTOEXEC.BAT 
when "pure Chinese" mode is off.



Input Chinese by pin yin method
1. Open / activate pinyin dialog box.
2. Type the pinyin followed by a number 1-5 indicating the toneExample 1, 

da4 (big), da is pinyin, 4 is the tone (di4 si4 sheng1). Example 2, de5 
(of), de is pinyin, 5 is the tone (qing1 sheng1).

3. All characters match the above pinyin will be listed.  Now you may 
choose the correct character by typing the letter immediately above it 
or click mouse button on it.

4. Press return.

You may search pinyin by using the scroll bar.



Input Chinese by que wei method
1. Open / activate quewei dialog box.
2. Type the two letters representing the que1.
3. All characters in this que will be listed. Now you may choose the 

correct character by typing the wei4 or click mouse button on it.

You may search quewei by using the scroll bar.



Input Chinese by cang jie method
1. Open / activate cangjie dialog box.
2. Type cang jie codes of the character.
3. You may need to type a space character if the cang jie code is less than

5 letters.
4. Press return if you see the character appeared on top left of the dialog

box.

Find Cangjie code from pinyin / GB code.



Using the traditional characters
The default font is song16.fon which is the simplified character set (jian3 
ti3 zi4). If you like to use traditional / complex character set (fan2 ti3 
zi4), just put the fanti font file as the first line in the [font] section in 
file DINGDANG.INI.

See Setup file DINGDANG.INI in window directory.



Printing Documents
Do the following only if you are not sure that your printer is setup 
correctly:

1 From the File menu, choose Print Setup.
2 Select the correct printer and change any options as appropriate, and 

then choose the OK button.

To printer the document:

1 From the File menu, choose Print.
2 Change any options if needed, then choose the OK button.

You can change the default page format information in file DINGDANG.INI.  Also
see Format Document.



Format Documents
You can change the following default page format settings in file DINGDANG.INI
under section [dd]:

left margin = 100 (10 millimeters)
right margin = 100
top margin = 100
bottom margin = 100
baseline skip = 54

 character skip = 0
paragraph skip = 0
character width = 32
character height = 36

Additional format statements can be inserted into document.  See Format Menu 
Commands for more information.  The followings are list of format statements:

Syntax Description
Ffontname change font to fontname, see next line
FKAI24 to 24x24 KAI
ML#   set left margin
MR# set right margin
MT# set top margin
MB# set bottom margin
OL#   distance of two lines
OC#   space added to character
OP#   space added to end of paragraph
OZ# # Chinese character width, height
OX#   relative horizontal move
OY#   relative vertical move
OM# # absolute position

The units used is 1/10 of a millimeter.  The fonts name like "Fan16" or 
"KAI24" must be listed under [font] in file dingdang.ini and the font files 
must exist. The page controls can be grouped like ~FSONG24 OZ48 48 OL60~, 
assuming '~' is the delimited character.



Editing Text
Press BACKSPACE to delete the character to the left of the insertion point. 
Press DEL to delete the character to the right of the insertion point. Press 
and hold the mouse button to select text. 

To delete more than one character:

1 Select the text you want to delete.
2 Choose Delete from the Edit menu. Or choose Cut from the Edit menu to 

place the text on to the Clipboard.

To copy text:

1 Select the text you want to copy.
2 Choose Copy from the Edit menu.
3 Move the mouse pointer to the place you want to insert the copy.
4 Choose Paste from the Edit menu.

To move text:

1 Select the text you want to move.
2 Choose Cut from the Edit menu.
3 Move the mouse pointer to the place you want to insert the text.
4 Choose Paste from the Edit menu.



Contact the author
If you have questions, you can write to:

Yijun Ding
12640 Southridge Drive 
Little Rock, AR 72212
USA

Internet e-mail can be sent to: xxye@ualr.edu

If you like the program, please register by sending $40 (shipping included) to
the above address.  You will get the followings (files marked with a * are not
included in the shareware version):

*DDWIN.EXE   Standard version.
 DDWIN.HLP   On line help documentation.
 DINGDANG.INI Ddwin initial sample file.
 PINYIN.GB   Pinyin code reference.
 CANGJIE.GB  Cangjie input documentation.
 CJB.PCX     Cangjie table (paintbrush format).
*FONTEDIT.EXE Create or edit characters.
 SONG16.FON  Song ti 16x16 bitmap fonts.
 FAN16.FON   Fan ti (traditional) 16x16 bitmap fonts.
*SONG24.FON  Song ti 24x24 fonts.
*KAI24.FON   Fai ti 24x24 fonts.
*HEI24.FON   Hei ti 24x24 fonts.
*FANG24.FON  Fang song ti 24x24 fonts.
*FAN24.FON   Fan ti (traditional) 24x24 fonts.
 READ.ME     Brief introduction.
 PRINTTST.GB Printer test file.




