WinDirStat

WinDirStat - Verzeichnisstatistik

Copyright (c) 2003-2004 Bernhard Seifert. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled "GNU Free Documentation License".

(Windows Directory Statistics.) Zeigt an, wo all der Plattenplatz geblieben ist, und hilft aufzuräumen.

Sie kennen das Problem: Die Festplatte ist fast voll, und man weiß nicht, wo eigentlich die großen Dateien liegen, die den ganzen Platz belegen. Sie können ja in Unter-Unterverzeichnissen versteckt sein. Dies mit Hilfe des Windows-Explorers herauszubekommen, ist ermüdend: Man müsste im Verzeichnisbaum immer wieder Verzeichnisse und Unterverzeichnisse aufklappen und zuklappen oder die "Eigenschaften" der Verzeichnisse betrachten, wobei immer nur die Größe eines Teilbaums gezählt wird. Es ist schwierig, sich auf diese Weise ein Bild von der Festplattenbelegung zu machen. Hier hilft WinDirStat.

Beim Start öffnet WinDirStat den Laufwerksauswahl-Dialog. Bestätigen Sie diesen mit OK.

Dann liest WinDirStat einmal den gesamten Verzeichnisbaum ein, was je nach Festplattengröße ein paar Minuten dauern kann, und stellt ihn dann in drei praktischen Ansichten dar:

WinDirStat
Verzeichnisliste Typenliste
Baumkarte

Die Ansichten sind miteinander gekoppelt.

Die Festplatten können mithilfe verschiedener Aktionen aufgeräumt werden.

Die Ansichten und die benutzerdefinierten Aktionen können nach den persönlichen Bedürfnissen konfiguriert werden.

Sortierung

Zeichenerklärung

Häufig gestellte Fragen

Obergrenzen

Deinstallation

GNU Free Documentation License


Was ist ein Verzeichnisbaum?

Bei den meisten Computer-Betriebssystemen, so auch in Microsoft Windows, sind die Daten auf der Festplatte hierarchisch organisiert.

Einerseits gibt es die Dateien, die eine gewisse Größe haben und die Nutzdaten enthalten. Jede Datei hat einen Namen. Unter Microsoft Windows gibt die "Dateinamenserweiterung" Aufschluss über den Typ der Datei. Die Erweiterung ".exe" z.B. deutet an, dass es sich bei der Datei um ein Programm handelt. Die Erweiterung ".doc" deutet auf ein WinWord-Dokument hin, ".jpg" ist ein Foto, usw. Unsinnigerweise blendet der Microsoft-Windows-Explorer allerdings standardmäßig diese Dateinamenserweiterungen aus. Im Optionen-Menü des Windows Explorers können Sie dieses Verhalten ändern.

Andererseits gibt es die Verzeichnisse. Der Windows-Explorer und auch WinDirStat stellen die Verzeichnisse als gelbe Aktenmappen dar. Auch Verzeichnisse haben einen Namen, normalerweise aber ohne Dateinamenserweiterung. Verzeichnisse dienen nur dazu, Dateien und andere Verzeichnisse ("Unterverzeichnisse") zu enthalten. Dadurch, dass Verzeichnisse Unterverzeichnisse enthalten können und diese wiederum Unterverzeichnisse, entsteht auf der Festplatte eine hierarchische Struktur.

Statt "hierarchische Struktur" sagt man auch einfach Baumstruktur. Denn auch ein Baum ist ja hierarchisch aufgebaut: Der Stamm verzweigt sich in Äste, die Äste verzweigen sich in Unteräste, Zweige und schließlich die Blätter. Im Dateisystem entspricht das sogenannte Wurzelverzeichnis dem Stamm, die Verzeichnisse entsprechen den Ästen, und die Dateien entsprechen den Blättern.

Aus diesem Grund spricht man beim Dateisystem eines Computers von einem "Verzeichnisbaum".

Im Unterschied zu den meisten wirklichen Bäumen tragen auf der Festplatte auch der Stamm und die Äste bereits Blätter. Und, ebenfalls im Unterschied zu wirklichen Bäumen: die Dateien sind die eigentlich voluminösen Einheiten (deren Größe sich in Megabytes oder Gigabytes bemisst), die eigentlichen Verzeichnisse sind dagegen vernachlässigbar klein. Übrigens stellt man sich abstrakte Bäume normalerweise umgedreht vor: die Wurzel oben und die Äste und Blätter unten.

Sägt man von einem Baum einen Ast ab und steckt ihn in die Erde, so wird er selbst zu einem kleinen Baum (na ja, er sieht jedenfalls so aus): Jeder Ast ist zusammen mit seinen Unterästen und Blättern selbst ein Baum, ein Teilbaum.

Gern wird auch die Stammbaum-Metapher verwendet: Die Unterverzeichnisse und Dateien eines Verzeichnisses heißen Kind-Elemente dieses Verzeichnisses. Und ein Verzeichnis, in dem ein Unterverzeichnis bzw. eine Datei liegt, heißt das Eltern-Element dieses Unterverzeichnisses bzw. der Datei. Das Wurzelverzeichnis ist der Urahn aller Elemente des Verzeichnisbaums.

Ein Pfad wie "C:\dokumente\briefe\entwürfe\liebesbrief.doc" deutet an, dass sich auf der Festplatte C: im Wurzelverzeichnis "C:\" ein Verzeichnis "dokumente" befindet, darunter das Unterverzeichnis "briefe", darunter das Unterverzeichnis "entwürfe" und darin eine Datei "liebesbrief.doc". Der Pfad ist also eine präzise Darstellung des Weges von der Wurzel bis zum Blatt.


Verzeichnisliste

Die Verzeichnisliste gleicht der Baum-Ansicht des Windows-Explorers mit dem Unterschied, dass sie Verzeichnisse und Dateien absteigend nach Größe sortiert darstellt. Oben sehen Sie die Verzeichnisse und Dateien, die am meisten Platz verbrauchen. Klappen Sie ein Verzeichnis auf, so werden dessen Unterverzeichnisse wiederum nach Größe sortiert angezeigt, und so weiter.

Spalten

  • Name. Diese Spalte zeigt die Namen der Dateien und Verzeichnisse an und ihre Baumstruktur.
  • Größe. Für Dateien steht in dieser Spalte die Größe der Datei, in Bytes. Für Verzeichnisse steht hier die Größe des Teilbaums, d.h. die Summe der Größen aller Unterverzeichnisse und Dateien.
  • Teilbaum-Anteil. Diese Spalte zeigt, wie sich die Größe eines Teilbaums aus den Größen der Unterelemente zusammensetzt. Die Angaben sind immer nur innerhalb einer Ebene vergleichbar und beziehen sich auf das aufgeklappte Elternelement.
    [Während des Einlesens zeigt diese Spalte entweder den Pacman oder die Anzahl der noch auszuführenden Leseaufträge für diesen Teilbaum.]
  • Anteil. Dieselbe Angabe wie "Teilbaum-Anteil", in Prozent.
    [Während des Einlesens kann diese Spalte optional die bisher für den Teilbaum aufgewendete Zeit anzeigen.]
  • Dateien. Anzahl der Dateien im Teilbaum.
  • Verzeichnisse. Anzahl der Unterverzeichnisse im Teilbaum.
  • Einträge. Anzahl der Einträge im Teilbaum. Summe aus "Dateien" und "Verzeichnisse".
  • Letzte Änderung. Datum der letzten im Teilbaum erfolgten Änderung.
  • Attribute. Datei-/Verzeichnisattribute. R = schreibgeschützt (read-only), H = versteckt (hidden), S = System, A = archivierbar, C = komprimiert (compressed), E = verschlüsselt (encrypted).

Bedienung

In der Spalte "Name" können Verzeichnisse mit einem Mausklick auf die kleinen Kästchen mit + und - wie im Windows-Explorer auf- und zugeklappt werden. Mit einem Klick auf einen Namen markieren Sie ein Element. Danach können Sie mit den Pfeiltasten im Baum navigieren.

In der Baumkarte wird das jeweils markierte Element durch eine Umrahmung hervorgehoben.

Markieren Sie eine Datei, so zeigt die Typenliste automatisch deren Typ an.

Die Sortierung kann per Mausklick auf die Spaltenüberschrift geändert werden.


Typenliste

Die Typenliste enthält sämtliche im Verzeichnisbaum vorkommenden Dateitypen (Dateinamenserweiterungen). Für jeden Dateityp wird die Summe der Dateigrößen in der Spalte "Bytes" angezeigt. Die Typenliste ist standardmäßig absteigend nach dieser Spalte sortiert. Oben stehen also diejenigen Dateitypen, die auf der Festplatte zusammengenommen den meisten Platz einnehmen.

Den 12 Dateitypen, die am meisten Platz belegen, sind 12 Farben zugeordnet, allen anderen die Farbe Grau. In dieser Farbe werden die Dateien in der Baumkarte dargestellt.

Spalten

  • Dateityp. Symbol und Dateinamenserweiterung.
  • Farbe. Die Farbe, in der dieser Typ in der Baumkarte dargestellt ist.
  • Beschreibung. Beschreibung des Dateityps. Entspricht der Beschreibung, wie sie der Windows-Explorer unter Extras->Ordneroptionen->Dateitypen anzeigt.
  • Bytes. Gesamt-Volumen des Dateityps im Verzeichnisbaum. Summe der Größen aller Dateien dieses Typs.
  • % Bytes. Dieselbe Angabe als Prozent-Anteil bezogen auf die gesamte Baumgröße.
  • Dateien. Anzahl der Dateien dieses Typs im Verzeichnisbaum.

Bedienung

Klicken Sie auf eine Dateinamenserweiterung: Die Baumkarte hebt alle Dateien dieses Typs hervor.


Baumkarte

Baumkarte (engl. Treemap)

Die Baumkarte zeigt auf einen Blick den gesamten Inhalt des Verzeichnisbaums.

Sie stellt jede Datei dabei als ein farbiges Rechteck dar, dessen Fläche der Größe der Datei entspricht.

Die Rechtecke sind so angeordnet, dass Verzeichnisse wiederum Rechtecke bilden, die alle ihre Dateien und Unterverzeichnisse enthalten. Die Fläche dieser Rechtecke entspricht also der Größe der Teilbäume.

Die Farbe eines Rechtecks deutet den Typ der Datei an, wie in der Typenliste angegeben.

Der Kisseneffekt verdeutlicht dabei zusätzlich die Verzeichnisstruktur.

Bedienung

Sie erkennen mühelos die großen Rechtecke, d.h. die großen Dateien, auch wenn diese weit unten im Verzeichnisbaum in Unterverzeichnissen versteckt sind. Klicken Sie darauf: In der Verzeichnisliste klappt der Pfad zu dieser Datei auf, und Sie können Ort, Namen und Attribute der Datei ablesen, sowie - wenn Sie wollen - eine Aktion auf sie anwenden, z.B. die Datei löschen.

Navigieren Sie in der Verzeichnisliste: die jeweilige Markierung wird in der Baumkarte durch einen farbigen Rahmen hervorgehoben. Gewinnen Sie so einen Eindruck von den Größenverhältnissen: Wie groß ist z.B. C:\windows verglichen mit C:\programme?

Benutzen Sie zum Navigieren auch die Kontextmenü-Optionen "Zum Elternelement" und "Zurück zum Kindelement".

Zoomen. Die Option "Hineinzoomen" vergrößert die Baumkarte, so dass ein Teilbaum in voller Größe dargestellt wird. Sie machen quasi einen Schritt auf das markierte Element zu. Die Verzeichnisliste zeigt die Wurzel dieses Teilbaums durch eine blaue Umrahmung an. Mit "Herauszoomen" treten Sie wieder zurück und das Elternelement wird wieder dargestellt.


Kopplung der Ansichten

Die eigentliche Stärke von WinDirStat besteht darin, dass die drei Ansichten, Verzeichnisliste, Typenliste und Baumkarte, miteinander gekoppelt sind.

Verzeichnisliste -> Baumkarte

Wird ein Element (Verzeichnis oder Datei) in der Verzeichnisliste markiert, so zeigt auch die Baumkarte dieses Element an, indem sie es durch einen farbigen Rahmen hervorhebt. So können Sie insbesondere die Größe von Verzeichnissen beurteilen.

Baumkarte -> Verzeichnisliste

Wenn Sie in die Baumkarte klicken, so treffen Sie mit der Maus ja immer eine Datei (ein farbiges Rechteck). Daraufhin klappt, falls nötig, die Verzeichnisliste entsprechend auf und markiert diese Datei. So können Sie, indem Sie z.B. auf ein großes Rechteck klicken, Pfad und Attribute der entsprechenden großen Datei in der Verzeichnisliste ablesen.

Die Markierung in der Verzeichnisliste und der Baumkarte stimmt aufgrund der gegenseitigen Kopplung also immer überein.

Verzeichnisliste+Baumkarte -> Typenliste

Wird in der Verzeichnisliste (bzw. in der Baumkarte) eine Datei markiert, so zeigt die Typenliste den Dateityp (die Dateinamenserweiterung) an. Der Dateityp wird markiert und in den sichtbaren Bereich gescrollt. So können Sie die Beschreibung und die Statistik zu diesem Typ ablesen.

Typenliste -> Baumkarte

Markieren Sie in der Typenliste einen Dateityp, so hebt die Baumkarte sämtliche Dateien dieses Typs hervor.


Laufwerksauswahl-Dialog

Hier können Sie bestimmen, welche Laufwerke in die Statistik aufgenommen werden sollen.

Sie haben die Möglichkeit, eines oder mehrere Laufwerke aus der Liste auszusuchen oder ein Verzeichnis auszuwählen.

Die Liste zeigt alle vorhandenen Laufwerke (Festplatten, eingelegte Floppy Disks oder CDs, Netzlaufwerke) an.

Spalten

  • Name. Name und Laufwerksbuchstabe des Laufwerks.
  • Gesamt. Kapazität des Laufwerks.
  • Frei. Freier Platz auf dem Laufwerk.
  • Belegt/Gesamt Anteil der Belegung bezogen auf die Kapazität.
  • Belegt/Gesamt Dasselbe in Prozent.

Bedienung

Der Dialog hat drei "Radioknöpfe".

  • Alle lokalen Laufwerke. Dies ist die Voreinstellung. Liest alle lokalen Laufwerke, d.h. alle Laufwerke, die keine Netzlaufwerke sind. Laufwerke, die mit SUBST erstellt wurden, werden ebenfalls ausgeschlossen (nur NT und höher).
  • Einzelne Laufwerke. Hier können Sie explizit eine Menge von Laufwerken auswählen.
  • Ein Verzeichnis. Hier können Sie ein Verzeichnis oder einen UNC-Pfad auswählen.
Klicken Sie auf OK, um mit dem Einlesen zu beginnen.

Die Auswahl ist persistent, d.h. beim nächsten Öffnen des Dialogs erscheint wieder dieselbe Auswahl, die Sie zuletzt vorgenommen hatten.


Aktionen

Auf ein markiertes Element können verschiedene Aufräumaktionen angewendet werden. Die Aktionen sind erreichbar über das Hauptmenü, die Symbolleiste, die Kontextmenüs und über Tastatur-Shortcuts.

Markierung aktualisieren

Es kann sein, dass ein Element außerhalb von WinDirStat gelöscht oder verändert wurde. "Aktualisieren" bewirkt, dass WinDirStat das Element neu einliest, so dass die Anzeige in WinDirStat wieder mit den tatsächlichen Verhältnissen auf der Festplatte übereinstimmt.

Pfad kopieren

Kopiert den Pfad des markierten Elements in die Zwischenablage.

Öffnen

Öffnet die markierte Datei. Achtung: im Falle einer ausführbaren Datei (.exe) heißt dies, dass das Programm gestartet wird.

Explorer hier starten

Startet den Windows-Explorer so, dass er das markierte Element anzeigt.

DOS-Prompt hier starten

Startet die Kommandozeile im markierten Verzeichnis.

Löschen (in den Papierkorb)

Verschiebt das markierte Element in den Papierkorb. Danach werden das Element und die Papierkorb-Verzeichnisse aktualisiert.

Löschen (irreversibel)

Löscht das markierte Element endgültig. Danach wird das Element aktualisiert. Löschen Sie bitte nur Dateien und Verzeichnisse, von denen Sie wissen, dass weder Sie noch das Betriebssystem sie brauchen!

Eigenschaften

Öffnet den 'Eigenschaften'-Dialog für die markierte Datei.

E-Mail an den Eigentümer senden

Erstellt einen textuellen Report über das markierte Verzeichnis zwecks E-Mail-Versand an den Eigentümer. Ist gedacht für von mehreren Leuten benutzte Netz-Laufwerke. Der Report enthält genau die Zeilen, die die Verzeichnisliste gerade unter dem markierten Verzeichnis anzeigt, im selben "Klappstatus" und in derselben Sortierung.

Benutzerdefinierte Aktionen

Neben diesen eingebauten Aktionen können Sie eigene Aktionen frei definieren.


Benutzerdefinierte Aktionen

Dieser Punkt ist für Experten.

Hier können Sie bis zu 10 Aktionen selbst definieren. Die Aktionen werden als Kommandozeile spezifiziert.

Selektieren Sie in der Liste einen Eintrag und setzen Sie ihn auf "Freigegeben". Vergeben Sie einen Titel, der Titel erscheint in den Menüs.

Formulieren Sie eine Kommandozeile. Benutzen Sie die "MSDOS-Eingabeaufforderung" (Windows 9x, command.com) bzw. die "Eingabeaufforderung" (NT, cmd.exe), um Hilfe zu möglichen Kommandos abzufragen und die Kommandozeile auszuprobieren.

Beispiele

  • dir /b > dir.txt
    Dateinamen in die Textdatei dir.txt schreiben.
  • del *.bak
    Alle *.bak-Dateien im aktuellen Verzeichnis löschen.
  • del /s *.bak *.tmp
    Alle *.bak- und *.tmp-Dateien in allen Unterverzeichnissen löschen (rekursiv).
  • C:\programme\windirstat.exe "%p"
    Ein zweites WinDirStat aufrufen mit dem Pfad des aktuellen Verzeichnisses.

Beispiele (nur NT und höher)

  • echo %n & pause
    Namen des aktuellen Verzeichnisses ausgeben.
  • cd & pause
    Aktuellen Pfad ausgeben und auf Tastendruck warten.
  • cd .. && myzip "%n"
    Aktuelles Verzeichnis komprimieren (mit dem hypothetischen Tool myzip).

Die Bedeutung der Platzhalter %p, %n, %sp, %sn ist im Dialog angegeben. Vergessen Sie nicht, sie ggf. in Anführungszeichen einzuschließen.

Aufbau der Kommandozeile

Angenommen, Sie geben die Kommandozeile

xyz
ein. WinDirStat versucht dann, folgenden Prozess zu starten:
%COMSPEC% /c xyz

Weitere Optionen

Geben Sie an, auf welche Elemente die Aktion anwendbar sein soll. Vorsicht bei UNC-Pfaden: ein Command-Prompt kann keinen UNC-Pfad als Arbeitsverzeichnis haben.

Geben Sie an, ob die Aktion rekursiv auf alle Unterverzeichnisse angewendet werden soll (depth first).

Die restlichen Optionen müssten klar sein.


Konfiguration

Allgemein

Dateisystemgrenzen überschreiten (nur NT und höher). Unter NTFS können Volumes in Verzeichnisse eingehängt werden. Standardmäßig stoppt WinDirStat mit dem Einlesen an diesen Punkten, zeigt also nur die Belegung jeweils einer Festplatte an. Hier können Sie dieses Verhalten ändern. (Mountpoints auf UNC-Laufwerken werden nicht erkannt.)

Symbolischen Verzeichnislinks folgen (außer Volume Mount Points) (nur NT und höher). Unter NTFS können Zielverzeichnisse in ein anderes Verzeichnis eingepfropft werden (Junction Points). (Sie brauchen ein Produkt wie z.B. awxlink, downloadbar von http://www.arniworld.de/, um Junction points anzulegen.) Standardmäßig stoppt WinDirStat mit dem Einlesen an diesen Punkten. Hier können Sie dieses Verhalten ändern.

Listenstil. Diese Optionen, Raster und Streifen, gelten für alle Listen in WinDirStat.

Sprache. In dieser Combobox werden neben der eingebauten Sprache Englisch diejenigen Sprachen angeboten, für die eine entsprechende wdsrxxxx.dll existiert. Die Einstellung wird erst beim nächsten Start von WinDirStat wirksam.

Verzeichnisliste

Zwei Optionen, die steuern, was die Spalten 'Teilbaum-Anteil' und 'Anteil' während des Einlesens anzeigen. Farben für die Teilbaum-Anteil-Darstellung.

Baumkarte

Quadratierungsstil, Parameter für den Kisseneffekt, Gitternetzlinien, Farbe des Markierungsrahmens.

Aktionen

Hier werden die benutzerdefinierten Aktionen konfiguriert.

Report

Administratoren können hier die E-Mail-Report-Funktion ihren Bedürfnissen anpassen.


Sortierung

Sämtliche Listen in WinDirStat können Sie nach Belieben sortieren. Die aktuelle Sortierung wird durch die Zeichen < und > in den Spaltenüberschriften angedeutet. < bedeutet aufsteigende Sortierung, > bedeutet absteigende Sortierung.

Durch einen Mausklick auf eine Spaltenüberschrift setzen Sie die gewünschte Sortierung.

Eigentlich werden sogar zwei Spalten zur Sortierung herangezogen. Erstens diejenige, auf die Sie zuletzt geklickt haben, und zweitens - wenn die Elemente bezüglich dieser Spalte gleich sind - diejenige, nach der zuvor sortiert wurde.

Beachten Sie, dass die Sortierung in der Verzeichnisliste natürlich die Baumstruktur respektiert: Sortiert wird dort immer nur innerhalb derselben Hierarchieebene.

Bemerkung

Die Breite der Spalten und ihre Reihenfolge können per Drag 'n Drop eingestellt werden. Die Spaltenbreiten und -reihenfolgen sind persistent, d.h. werden beim Programmstart automatisch wieder so hergestellt, wie Sie sie zuletzt eingestellt hatten.


Zeichenerklärung

<Dateien>

Jedes Verzeichnis in der Verzeichnisliste hat im allgemeinen ein Pseudo-Unterverzeichnis <Dateien>. Dort sind alle einfachen Dateien des Verzeichnisses zusammengefasst. Also die Dateien, die direkt im Verzeichnis, nicht in Unterverzeichnissen, liegen. Dies hat den Vorteil, dass die Verzeichnisliste aufgeräumter und dass die Statistik aussagekräftiger ist. So können Sie nämlich ablesen, welchen Platz die in einem Verzeichnis (nicht in Unterverzeichnissen) liegenden Dateien zusammen einnehmen.

Der <Dateien>-Pseudoeintrag entfällt, wenn es nur eine Datei im Verzeichnis gibt, oder wenn das Verzeichnis keine Unterverzeichnisse hat.

<Freier Platz>

Wenn Sie im Optionen-Menü "Freien Platz anzeigen" aktiviert haben, hat jedes Laufwerk einen <Freier Platz>-Eintrag. Die Größe dieses Eintrags entspricht der Menge des auf dem Laufwerk noch zur Verfügung stehenden freien Platzes. In der Baumkarte hat dieser Eintrag eine dunkelgraue Farbe. Durch den <Freier Platz>-Eintrag bekommt man einen Eindruck von der Relation zwischen ingesamt belegtem und noch freien Plattenplatz. Diese Angabe entspricht der Angabe "Freier Speicher" im Windows-Explorer-Eigenschaften-Dialog für das Laufwerk.

<Unbekannt>

Wenn Sie im Optionen-Menü "Unbekannten Platz anzeigen" aktiviert haben, hat jedes Laufwerk einen <Unbekannt>-Eintrag. Damit hat es folgende Bewandtnis. Einerseits kennt WinDirStat die Gesamtkapazität des Laufwerks und den freien Plattenplatz. (Diese Werte entsprechen den Angaben im Windows-Explorer-Eigenschaften-Dialog für das Laufwerk.) Andererseits hat WinDirStat die Größen aller Dateien ermittelt und summiert. <Unbekannt> ist nun die Differenz Gesamtkapazität minus freier Platz minus ermittelte Summe. Dieser Rest kann aus mehreren Gründen größer als Null sein. Z.B. kann es Verzeichnisse (z.B. "System Volume Information") geben, die man nicht auslesen darf. Deren Größe fließt also in die von WinDirStat ermittelte Summe nicht mit ein. In der Baumkarte hat der <Unbekannt>-Eintrag eine leuchtend gelbe Farbe.

< (in Spaltenüberschriften)

deutet an, dass die Liste nach dieser Spalte aufsteigend sortiert ist.

> (in Spaltenüberschriften)

deutet an, dass die Liste nach dieser Spalte absteigend sortiert ist.


Häufig gestellte Fragen

Gibt die Baumkarte die Belegung der Harddisk-Sektoren wieder?

Nein. Die Baumkartenansicht hat nichts zu tun mit den Harddisk-Sektoren. Die Verteilung der Dateien auf Sektoren ist eine ganz andere. Im allgemeinen sind große Dateien weit über die Harddisk verstreut. Die Baumkarte hingegen stellt jede Datei als ein Rechteck dar.

Werden für die Leseaufträge Threads gestartet?

Nein. WinDirStat ist - abgesehen von der Aboutbox, die in einem eigenen Thread läuft und von den Abfragen im Laufwerksauswahldialog - single-threaded. Alle Arbeit geschieht in OnIdle().

Was hat es mit dem Eintrag <Dateien> auf sich?

Siehe Zeichenerklärung.

Was bedeutet das >-Zeichen vor den Spaltenüberschriften?

Die >- und <-Zeichen in den Spaltenüberschriften deuten die aktuelle Sortierung an.

Auf meinem XP zeigt WinDirStat mehr als 1 GB <Unbekannt> an. Ist das normal?

Ja. XP speichert ziemlich oft ziemlich große 'Systemwiederherstellungspunkte' unter C:\System Volume Information, verweigert aber den Zugriff darauf.

Wozu ist die Datei wdsr0407.dll da?

Diese Datei enthält die deutsche Übersetzung von WinDirStat. 0407 ist die Kennziffer für "Deutsch - Deutschland". Wenn diese Datei fehlt, dann ist WinDirStat nur in der (eingebauten) Sprache Englisch verfügbar.

Die Größenangaben in KB und MB scheinen etwas zu klein zu sein.

WinDirStat hält sich an die im Computerwesen übliche Konvention, dass "Kilo"
            nicht für 1000 steht sondern für 1024. Es gilt also:
1 KB = 1024 Bytes
1 MB = 1024 KB = 1.048.576 Bytes
1 GB = 1024 MB = 1.048.576 KB = 1.073.741.824 Bytes.


Obergrenzen

Zum Einlesen aufgewendete Zeit | 2^32 ms (= 49 Tage)
Anzahl direkte Unterelemente eines Verzeichnisses | 2^31 (= 2.147.483.648)
Dateigröße, Baumgröße | 2^63 (= 8.388.608 TB)
Gesamtzahl Elemente | 2^63
Anzahl gleichzeitige Leseaufträge | 2^63


Deinstallation

  • Das Verzeichnis C:\programme\windirstat löschen
  • Die Verknüpfungen zu WinDirStat löschen
  • Für Experten: HKCU\Software\seifert\windirstat löschen.


GNU Free Documentation License

Version 1.2, November 2002

Copyright (C) 2000,2001,2002  Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document "free" in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The "Document", below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as "you". You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A "Modified Version" of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

A "Secondary Section" is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document's overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A "Transparent" copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, "Title Page" means the text near the most prominent appearance of the work's title, preceding the beginning of the body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as "Acknowledgements", "Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when you modify the Document means that it remains a section "Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document's license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

  • A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.
  • B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.
  • C. State on the Title page the name of the publisher of the Modified Version, as the publisher.
  • D. Preserve all the copyright notices of the Document.
  • E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.
  • F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.
  • G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document's license notice.
  • H. Include an unaltered copy of this License.
  • I. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled "History" in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.
  • J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the "History" section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.
  • K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.
  • L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.
  • M. Delete any section Entitled "Endorsements". Such a section may not be included in the Modified Version.
  • N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title with any Invariant Section.
  • O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version's license notice. These titles must be distinct from any other section titles.

You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of your Modified Version by various parties--for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original documents, forming one section Entitled "History"; likewise combine any sections Entitled "Acknowledgements", and any sections Entitled "Dedications". You must delete all sections Entitled "Endorsements."

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the copyright resulting from the compilation is not used to limit the legal rights of the compilation's users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License "or any later version" applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation.

How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices just after the title page:

Copyright (c)  YEAR  YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
or any later version published by the Free Software Foundation;
with no Invariant Sections, no Front-Cover Texts, and no Back-Cover
Texts.  A copy of the license is included in the section entitled "GNU
Free Documentation License".

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the "with...Texts." line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software license, such as the GNU General Public License, to permit their use in free software.