DiskCleaner, obecně

Nástroj "DiskCleaner"

Jak spustit DiskCleaner

Pokud chcete spustit DiskCleaner, máte několik možností:
  • pomocí menu Nástroje -> DiskCleaner (F8).
  • pomocí funkční klávesy F8.
  • z panelu nástrojů klepnutím na ikonku DiskCleaneru (disk s koštětem).

Co je DiskCleaner

DiskCleaner je nástroj pro udržení vašeho disku bez nepotřebných souborů. Pomocí toho nástroje velice snadno z disku odstraníte odpadky, dvojníky či dočasné soubory internetu.

Hledání odpadků patři ke stěžejní práci DiskCleaneru a velice účinně maže opravdu nepotřebné soubory. Nově vylepšené hledání dvojníků nyní umožňuje hledat stejné soubory také dle jejich obsahu, což přináší téměř stoprocentní výsledky bez chybných identifikací dvojníků. DiskCleaner navíc nabízí možnost prohlédnout si nejdelší soubory na disku a rychle mazat obsah dočasných souborů internetu.

Seznam kapitol pro DiskCleaner

  • Hlavní panel DiskCleaneru
  • Hledání odpadků
  • Hledání velkých souborů
  • Hledání dvojníků


DiskCleaner, popis hlavního panelu

DiskCleaner, hlavní panel

Hlavní panel DiskCleaneru je startovní místo pro všechny jeho funkce a možnosti.

Druhy testů

Pomocí čtyř záložek (karet) můžete vybrat jednu z funkcí, kterou bude DiskCleaner provádět. Máte na výběr tyto možnosti:
  • Odpadky - hledání přebytečných souborů. Přebytečné soubory jsou dočasné soubory aplikací, jejich záložní kopie a ostatní soubory umístěné v odkládacích složkách. Tyto soubory nesou duplicitní nebo zcela zbytečnou informaci a je tedy zcela bezpečné tyto sobory z disku odstranit a uvolnit tak místo. Soubory jsou identifikovány dle svých specifických přípon. DiskCleaner samozřejmě má v základu definovány typické přípony pro tyto soubory, ale nabízí samozřejmě uživateli možnost tyto definice jakkoliv pozměnit či definovat nové.
  • Velké soubory - nalezení souborů, které svou velikostí splňují některý ze zadaných parametrů. Na výběr máte tři druhy hledání velkých souborů.
  • Dvojníci - hledání duplicitních (tedy opakujících se) souborů na vašem disku. Podle zadaných kriterií hledá DiskCleaner soubory, které se volitelně shodují ve jméně, délce, datumu poslední změny souboru a nově také dle jejich obsahu.
  • Internet - snadné a rychlé zjištění velikosti místa, které zabírají dočasné soubory internetu prohlížeče Internet Explorer. Stejně snadně a rychle tyto soubory navíc i odstraníte a uvolníte tak místo na disku.

Výběr umístění pro test

Pro první tři druhy testů (odpadky, velké soubory a dvojníci) určujete umístění, která se budou prohledávat. Panel se seznamem těchto umístění se nachází v levé části a pomocí tlačítek a editačního pole můžete libovolně tento seznam sestavit. Seznam je pro uvedené tři testy společný. Před spuštěním testu můžete pomocí políček výběru (zatržítek) upřesnit, která umístění se použijí a která se budou ignorovat.

Správa seznamu

Při vytváření seznamu umístění nejste nijak omezeni, jeho obsah můžete spravovat pomocí těchto tlačítek:
  • Přidat... - tlačítko vyvolá dialog, ve kterém nalistujete požadované umístění (včetně síťových jednotek, výměnných zařízení i síťových cest). Doplňující funkce tohoto tlačítka najdete v rozbalovacím seznamu napravo vedle tlačítka.
  • Odstranit - toto tlačítko odebere ze seznamu aktuálně vybraný řádek. Pokud chcete odstranit veškeré záznamy, využijte rozbalovací seznam napravo vedle tlačítka.
  • Ukaž vybranou - zobrazí v samostatném okně celou cestu vybraného záznamu. Tuto funkci využijte v případě, že se výpis umístění nevleze do šířky panelu a není tak kompletně čitelný.
  • Přidat vlastní - toto tlačítko se stane aktivním v případě, že napíšete ručně vlastní cestu do editačního pole nalevo od tlačítka. Pokud zadáte neplatnou cestu, DiskCleaner Vás na toto upozorní, ale bránit vám v jejím vložení nebude.

Poznámka

Před samotným testem DiskCleaner vyhodnotí vámi vybraný seznam umístění a automaticky se nebude zabývat neplatnými cestami.


DiskCleaner, odpadky

Hledání odpadků je stěžejní práce DiskCleaneru.

Co jsou to odpadky?

Za odpadky můžeme považovat ty soubory, které nesou duplicitní nebo nepotřebnou informaci. Jedná se o různé záložní a dočasné (pracovní) soubory aplikací.

Jak vznikají odpadky

Při práci na počítači vznikají odpadky, aniž byste o tom věděli. Některé programy (aplikace) si vytváří soubory, které používají jako dočasné úložiště pro svá pracovní data. Tyto soubory by měl správně program po svém ukončení odstranit. Samozřejmě ne vždy se tomu tak podaří a tak se tyto soubory pomalu ale jistě hromadí a plní Váš disk aniž by obsahovaly smysluplná data. Některé programy si navíc vytváří zálohy datových souborů pro případ jejich obnovy, ale ne vždy jsou tyto zálohy využívány.

Samozřejmě že platí - co uživatel, to jiné prostředí a tím i jiné odpadky. Je to logické, protože každý uživatel pracuje s jiným druhem aplikací. DiskCleaner proto nabízí plnou kontrolu nad definicí toho, co se bude považovat za odpadky a co nikoliv. V základní instalaci jsou definovány základní masky souborů, které odpovídají nejčastějším typům odpadků a mohou je tak využít téměř všichni uživatelé a v budoucnu si pouze doplnit své změny.

Jak DiskCleaner určuje odpadky

Odpadky se určují podle masky souboru. Maska souboru je dána tzv. hvězdičkovou konvencí, která používá speciální znaky (hvězdičku a otazník) pro nahrazení určitých znaků. Maska souboru se použije na jméno souboru a pokud si odpovídají, je výsledek zahrnut do výsledku hledání.

Nastavení parametrů hledání odpadků

Pokud zvolíte kartu hledání odpadků, zobrazí se na pravé straně ovládací panel, na kterém můžete nastavit volby pro hledání odpadků:
  • Definované masky - šest skupin masek, které můžete vybrat a tím je aktivovat pro hledání. Každá skupina je zobrazena pod svým jménem a pokud nad ní zůstanete chvíli myší, zobrazí se podrobněji její obsah.
  • Speciální volby - zde můžete určit, zda bude DiskCleaner prohledávat také odkládací a další adresáře a nebo soubory s nulovou délkou.

Poznámka

Upravit masky souborů a definovat vlastní odkládací adresáře můžete pomocí tlačítka Definice vlastních adresářů a masek souborů.


DiskCleaner, velké soubory

Hledání velkých souborů má pro uživatele spíše informativní charakter. Umožňuje zobrazit soubory, které splňuji co se týče jejich velikosti zadané parametry.

Pozor:

V drtivé většině případů jsou nalezené soubory běžně používané a nejsou určeny ke smazání! Mezi výsledky naleznete např. různé multimediální soubory (videa, muziku), ale může se jednat i o některé kritické systémové soubory. Tato funkce slouží spíše pro informaci!

Možnosti hledání

Na výběr máme možnost vybrat jeden ze tří způsobů hledání velkých souborů:
  • Najít soubory větší než X MB a Y kB - prohledá všechny soubory na vybraných umístěních a do výsledného seznamu zahrne ty soubory, které budou větší nebo rovny zadaným kritériím.
  • Najdi X největších souborů - prohledá všechny soubory na vybraných umístěních a do seznamu zahrne X nejdelších souborů.
  • Najít a zobrazit všechny soubory řazeny dle délky - prohledá všechny soubory na vybraných umístěních a seřadí je ve výsledném seznamu dle délky. Pozn.: do seznamu nebudou zařazeny krátké soubory. Hranice krátkých souborů se nastavuje v Konfiguraci DiskCleaneru.


DiskCleaner, dvojníci

Tento nástroj Vám umožní pohodlně najít stejné soubory, které se na Vašem disku vyskytují vícekrát a možná tak zabírají zcela zbytečně místo. Díky filtru souborů můžete určit pouze vybrané skupiny souborů, které chcete hledat (např. multimedia, dokumenty apod.). Tyto skupiny navíc můžete různě kombinovat. Od verze 5.1 umožňuje DiskCleaner porovnávat soubory také dle jejich skutečného obsahu (s využitím výpočtů CRC-32).

Poznámka

Hledání dle obsahu souborů pomocí CRC-32 dokáže vyloučit chybné identifikace dvojníků, kteří se shodují v základních parametrech (název, délka, datum změny), ale přesto nejsou obsahově shodné. Funkce pracuje tak, že čte veškerý obsah souboru a z jeho dat počítá tzv. kód CRC-32, tedy 32-bitový kontrolní součet. Přesnost této metody je zde bohužel vykoupena větší časovou náročností, která se projeví především u dlouhých souborů.

Na panelu možností máte na výběr dvě karty - parametry hledání a filtr souborů.

Parametry hledání

Za dvojníky se budou považovat ty soubory, které se budou shodovat ve všech vybraných parametrech. Na výběr máte:

Hledat soubory se stejnými vlastnostmi

  • Jméno souboru - pokud zvolíte tuto volbu, můžete ještě případné dvojníky se stejným jménem rozlišit:
    • Rozlišovat VELKÁ/malá písmena - i přes to, že ve Windows nebere ohled na velikost písmen ve jméně souboru, můžete DiskCleaner hledat včetně rozlišení velkých a malých písmen ve jménech souborů.
    • Délka souboru - v potaz se bude brát také shodná délka souborů.
    • Datum poslední změny souboru - soubory musí mít stejný datum poslední úpravy.
  • Obsah souboru (CRC32 standard) - pokud zapnete tuto možnost, bude DiskCleaner počítat z každého souboru jeho kontrolní součet dle standardu CRC-32 a za dvojníky bude považovat soubory se shodným CRC-32.

Všimněte si

Dvojníky nemusíte hledat vůbec podle shodnosti jejich názvů! Pokud aktivujete pouze volbu pro hledání dle obsahu souboru, bude DiskCleaner hledat soubory které jsou stejně dlouhé a obsahově mají stejný CRC-32 součet. Tím můžete nalézt i dvojníky, kteří se skrývají pod různými jmény!

Umístění dvojníků

Zde určíte, zda mohou být dvojníci umístěni různě na libovolných diskových jednotkách, nebo zda se dvojníci budou hledat pouze na stejné jednotce.

Filtr souborů

Zde můžete omezit záběr DiskCleaneru pouze na vybranou skupinu (vybrané skupiny) souborů (podobně jako u hledání odpadků).
  • Všechny soubory - do hledání budou zahrnuty všechny soubory.
  • Pouze vybrané skupiny - omezí hledání pouze na vybrané skupiny. Vyberte kombinaci skupin kterou chcete pro hledání použít. Skupiny můžete také libovolně upravit pomocí tlačítka Definice skupin pro hledání....

Poznámka

Doporučuji hledat dvojníky se zapnutým filtrem. Zamezíte tak zobrazení např. systémových souborů nebo knihoven programů, které někdy bývají duplicitně umístěni na více místech.


DiskCleaner, internet

Na této kartě můžete zjistit velikost místa, které zabírají dočasné soubory internetu prohlížeče Internet Explorer. Také tyto soubory můžete velice jednoduše smazat. Vše se ovládá pomocí dvou tlačítek a několika přepínačů pro volby.

Tlačítko Získat/přepočítat hodnoty zobrazí aktuální čísla obsazeného místa. Pokud chcete cache vyčistit, vyberte v pravé části panelu Položky ke smazání a stiskem tlačítka Smazat vybrané položky vyčistěte disk od vybraných položek.

Pokud chcete detailněji pracovat s obsahem internetové cache, můžete přímo z tohoto místa spustit InternetCache Cleaner.

Poznámka

DiskCleaner nedokáže korektně odstranit položky historie navštívených stránek. Proč tomu tak je se dozvíte v kapitole Historie v Internet Exploreru a práce s ní.


DiskCleaner, definice vlastních skupin a adresářů

DiskCleaner samozřejmě nabízí možnost zcela libovolně upravit parametry hledaných odpadků. Omezeni jste pouze počtem šesti skupin, do kterých můžete rozložit libovolné množství masek souborů. Dále můžete definovat vlastní adresáře pro kompletní vyčištění a také můžete určit adresáře, které se budou ignorovat.

Možnosti nastavení jsou rozděleny do tří karet (záložek):

  • Skupiny
  • Adresáře
  • Ignorované adresáře

Skupiny

Zde se definují skupiny souborů, které se považují za odpadky. V horní části vidíte názvy šesti skupin mezi kterými můžete vybírat pomocí přepínacích tlačítek. Ve spodní části pak máte zobrazeny parametry právě vybrané skupiny, které můžete změnit.

Vlastnosti vybrané skupiny

  • Název - zde napište libovolný název popisující tuto skupinu.
  • Maska souborů - zde zadejte masky souborů, které bude DiskCleaner považovat za odpadky. Jednotlivé položky od sebe oddělte středníkem.
  • Mimo soubory - zde zadejte masky souborů, které chcete vyloučit. Většinou se zadávají konkrétní soubory, které sice splňují zadaná kritéria masky pro hledání ale nechceme je do výsledků hledání odpadků zahrnout.

Poznámka

Pro pohodlnou úpravu seznamů s položkami oddělenými středníkem můžete použít editor, který vyvoláte po stisku tlačítka "..." (sestavit).

Adresáře

Zde můžete zvolit speciální adresáře a definovat vlastní, ve kterých bude DiskCleaner veškeré soubory považovat za odpadky.
  • Odkládacím adresáři systému - v systému Windows je určen jeden adresář, který se používá výhradně jako odkládací prostor pro dočasné soubory. Z toho vyplývá, že veškeré soubory v tomto adresáři mohou být smazány a doporučuje se tento adresář pravidelně čistit. Pozn.: Plnou cestu odkládacího adresáře (temp) systému vidíte pod touto volbou.
  • Odpadkové koše - tato volba je momentálně zakázána a bude k dispozici v příštích verzích.
  • Vlastní adresáře - zde můžete určit vlastní adresáře.Použijte tlačítka napravo pro editaci seznamu.

Upozornění

Několikrát to bylo již zmíněno, ale raději ještě jednou - veškeré soubory v adresářích zde určených se budou považovat za odpadky! Na tyto adresáře se již neaplikují definované masky! Navíc hledání souborů probíhá také ve všech podadresářích.

Ignorované adresáře

Zde přidejte do seznamu ty adresáře, které chcete z jakéhokoliv hledání odpadků vynechat. Ignorovat se budou také veškeré podadresáře. Jako příklad můžeme uvést plochu systému Windows apod.


Nastavení

Konfigurace DiskCheckeruXP

DiskCheckerXP nabízí širokou škálu konfiguračních možností. Dialog konfigurace vyvoláte stisknutím tlačítka na hlavním panelu nástrojů nebo pomocí menu Nastavení - Konfigurovat. Dialog konfigurace je rozdělen do těchto karet:

  • Obecné
  • Kontrola disku
  • Defragmentace disku
  • Zobrazení
  • Detailní informace
  • DiskCleaner
  • InternetCache Cleaner


Nastavení, záložka obecné

Konfigurace DiskCheckeruXP - záložka "Obecné"

Tato záložka konfiguruje obecné vlastnosti DiskCheckeruXP.

Kontrola a defragmentace

Ovlivňuje základní chování DiskCheckeruXP během kontroly či defragmentace disků.
  • Čekat na dokončení kontroly a defragmentace (doporučeno) - určuje, jestli bude DiskCheckerXP po spuštění aplikace kontroly nebo defragmentace čekat na jejich ukončení. Pokud tuto volbu zapnete, budete mít navíc možnost zvolit operaci, která se po ukončení běhu spuštěného nástroje provede.
  • Implicitní akce pro konec - určuje operaci, kterou bude DiskCheckerXP doplňovat jako implicitní při čekání na spuštěný nástroj. Volbu můžete samozřejmě před dokončením nástroje ručně změnit - tato volba určuje pouze výchozí stav. Na výběr z akcí jsou tyto možnosti - Bez akce (návrat zpět), Odhlásit uživatele, Vypnout Windows, Restartovat Windows.
  • Vynutit konec spuštěných nástrojů bez čekání - tuto volbu zapněte pouze tehdy, máte-li problémy s odhlášením, restartováním nebo vypnutím počítače po ukončení běhu nástroje pro kontrolu nebo defragmentace disku. Pokud je volba aktivní, dojde k násilnému ukončení všech spuštěných aplikací bez čekání na jejich odezvu, čímž dojde většinou k úspěšnému provedení akce, ale může tak dojít k nežádoucí ztrátě neuložených dat ve spuštěných aplikacích.
  • Průběh integrovaných nástrojů bez zásahu uživatele - určuje, že testy pomocí integrovaných nástrojů pro kontrolu a defragmentaci budou probíhat bez výzev k uživateli. Platí pouze pro integrované nástroje ScanDisk a Defrag!
  • Minimalizovat DiskCheckerXP v průběhu kontroly a defragmentace - pokud aktivujete tuto volbu, dojde k minimalizaci okna DiskCheckeru v době průběhu kontroly nebo defragmentace. Lze použít pouze zároveň spolu s možností čekat na dokončení kontroly a defragmentace.

Dvojklik myší na hlavním panelu způsobí

Určuje, co se stane v případě "poklepání" myší na panelu disků.

Další nastavení

Nastavení ostatních, především systémových vlastností.
  • Automaticky obnovovat informace - zapněte tuto volbu, pokud chcete, aby DiskCheckerXP automaticky po zvoleném intervalu zjišťoval aktuální stav informací, které shromažďuje.
  • Umožnit pouze jednu běžící instanci DiskCheckeru ve Windows - pokud si nepřejete mít spuštěných více oken DiskCheckeruXP, zapněte tuto volbu. Při pokusu o opětovné spuštění dojde pouze k vyzvednutí již spuštěného DiskCheckeruXP na popředí.
  • Spouštět DiskChecker při startu Windows - pokud využíváte některé z automatizovaných funkcí DiskCheckeru, je vhodné zapnout tuto volbu, aby došlo k automatickému spuštění DiskCheckeru při startu Windows.
  • Potvrzovat ukončení DiskCheckeru - dotáže se před ukončením aplikace, zda jste si ukončením opravdu jisti.

Použít font

Může vybrat písmo, které DiskCheckerXP použije pro zobrazení textů na svých dialozích. Při volbě postupujte s velikostí písma od nejmenších hodnot (8) po vyšší. Mohlo by totiž dojít k zobrazení příliš velkých písmen a tím k přetečení některých zobrazovaných informací za rohy aplikace!


Nastavení, záložka ScanDisk

Konfigurace DiskCheckeruXP - záložka "Kontrola disku"

Umožňuje nakonfigurovat nástroje, které bude využívat DiskCheckerXP pro kontrolu disků. Možnosti voleb jsou jak pro integrovaný nástroj (nástroj dodávaný se systémem Windows - ScanDisk), tak i pro externí aplikace třetích stran. Definice externích nástrojů vyžaduje znalost jejich parametrů, které podporují z příkazové řádky (command-line). Čím více parametrů z příkazové řádky podporuje externí nástroj, tím lépe jej můžete pomocí DiskCheckeruXP ovládat.

Poznámka

DiskCheckerXP nemá vlastní jádro pro kontrolu či defragmentaci disků, pouze využívá nástroje dodávané běžně se systémem Windows nebo aplikace třetích stran. Bohužel, Windows NT, 200x či XP Professional neobsahují nástroj jako mají Windows9x, Millenium či XP Home Edition pro kontrolu disků (známý též jako ScanDisk). DiskCheckerXP tedy není schopen pracovat s kontrolou disků pokud nedefinujete externí nástroj. Od verze 5.1 je ale již schopen v systémech Windows 200x a XP spouštět nástroj pro defragmentaci disků (v konzole snap-in).

Možnosti pro "Integrovaný v systému (Windows 95/98/Me) [scandisk])"

V této sekci můžete doladit chování integrovaného ScanDisku v systému Windows. Jak je uvedeno v závorce, DiskCheckerXP je schopen pracovat pouze s aplikací scandisk.exe dodávanou se systémy Windows 9x/Me/XP Home edition. Pro ostatní verze Windows (NT/2000/2003/XP Professional) je nutné využít aplikace třetích stran, jako jsou například Norton SystemWorks apod. Systémy založené na technologii NT obsahují sice řádkovou utilitu chkdsk.exe, jejíž využití pomocí DiskCheckeruXP je sice možné, ale v praxi nepoužitelné.

Parametry integrovaného nástroje

  • Chyby pouze hlásit, neopravovat je na disku - určuje, že bude scandisk pracovat v režimu pouze pro čtení, to znamená, že pouze zjistí případné chyby na disku, ale nebude je opravovat.
  • Automaticky opravovat chyby (test bez přerušení) - říká scandisku, aby případné chyby, na které během testu narazí, automaticky opravoval bez výzvy k uživateli.
  • Zobrazit konečné výsledky testu - určuje, zda scandisk po skončení testu zobrazí dialog s výsledky. Pokud ne, dojde k jeho automatickému ukončení ihned po konci testu.

Možnosti pro "Definovaný uživatelem"

Konfiguruje externí nástroj třetí strany.

Parametry externího nástroje

  • Cesta k aplikaci - do tohoto pole se zadává cesta včetně spustitelného souboru aplikace, která se má použít jako kontrolní nástroj disků. Pomocí tlačítka "..." můžete program snadno nalistovat pomocí dialogu.
  • Parametry - určuje parametr (parametry), které se předají aplikaci vždy.
  • Parametr pro kontrolu všech jednotek - zde zadejte parametr (parametry), který řekne externímu nástroji, aby otestoval všechny jednotky přítomné v systému (pokud tento parametr podporuje).
  • Navíc přidej písmena všech místních jednotek - pokud nástroj nepodporuje speciální parametr pro test všech jednotek, je možné nasimulovat tento stav předáním všech místních jednotek. O toto předání se postará DiskCheckerXP v případě, že zatrhnete tuto volbu.
  • Pozn.: poslední dvě volby se využívají v přídě volby kontroly všech jednotek (z menu nebo na panelu nástrojů). Pokud testujete pouze vybrané jednotky, tyto parametry se nepředávají. Parametry mezi sebou oddělujte mezerou. Pro přesné informace o parametrech externího nástroje je nutné prostudovat jeho manuál nebo nápovědu.


Nastavení, záložka defragmentace

Konfigurace DiskCheckeruXP - záložka "Defragmentace disku"

Umožňuje nakonfigurovat nástroje, které bude využívat DiskCheckerXP pro defragmentaci disků. Možnosti voleb jsou jak pro integrovaný nástroj (nástroj dodávaný se systémem Windows - Defrag), tak i pro externí aplikace třetích stran. Definice externích nástrojů vyžaduje znalost jejich parametrů, které podporují z příkazové řádky (command-line). Čím více parametrů z příkazové řádky podporuje externí nástroj, tím lépe jej můžete pomocí DiskCheckeruXP ovládat.

Poznámka

DiskCheckerXP nemá vlastní jádro pro kontrolu či defragmentaci disků, pouze využívá nástroje dodávané běžně se systémem Windows nebo aplikace třetích stran. Bohužel, Windows NT, 200x či XP Professional neobsahují nástroj jako mají Windows9x, Millenium či XP Home Edition pro kontrolu disků (známý též jako ScanDisk). DiskCheckerXP tedy není schopen pracovat s kontrolou disků pokud nedefinujete externí nástroj. Od verze 5.1 je ale již schopen v systémech Windows 200x a XP spouštět nástroj pro defragmentaci disků (v konzole snap-in).

Možnosti pro "Integrovaný v systému (Windows 95/98/Me) [defrag])"

Pokud máte systém Windows 9x/Me/XP Home, můžete využít interního nástroje pro defragmentaci. Jeho chování můžete doladit v této sekci.

Co defragmentovat

  • Soubory i volné místo (=úplná defragmentace) - první možnost se doporučuje, pokud chcete provést důkladnou defragmentaci. Provede kompletní uspořádání disků tak, aby byly data souborů v souvislém bloku a volné místo bude v souvislém bloku za nimi. Tato volba je doporučena. Podrobnější popis defragmentace viz níže.
  • Pouze soubory - uspořádá data souborů tak, aby byly jednotlivé soubory v souvislých blocích a mohli tak být rychle čteny bez toho, aniž by musely hlavy disků běhat z jednoho konce na druhý. Nebere však ohled na volné místo, které mezi těmito soubory po defragmentaci vznikne. Do těchto volných "děr" se poté zapisují data nových souborů, které se dle svých různých délek rozkládají do různých volných míst a tím okamžitě po defragmentaci touto volbou dochází k nové fragmentaci díky novým souborům.
  • Pouze volné místo - uspořádá volné místo tak, aby bylo v souvislém bloku. Tím dojde ke zmírnění defragmentace nových souborů. Staré soubory ale zůstávají fragmentovány v původním stavu, k výraznému zvýšení výkonu po této operaci proto nedojde.

Při defragmentaci zobrazit

  • Pouze informační panel s průběhem - zobrazí malé okno s procentním ukazatelem průběhu defragmentace jednoho disku.
  • Podrobnou mapu defragmentace - zobrazí barevnou mapu, která znázorňuje graficky rozmístění dat souborů a uživatel může v reálném čase sledovat, jak dochází k přesunu jednotlivých bloků dat a tím k defragmentaci.

Možnosti pro "Definovaný uživatelem"

Konfiguruje externí nástroj třetí strany.

Parametry externího nástroje

  • Cesta k aplikaci - do tohoto pole se zadává cesta včetně spustitelného souboru aplikace, která se má použít jako nástroj defragmentace disků. Pomocí tlačítka "..." můžete program snadno nalistovat pomocí dialogu.
  • Parametry - určuje parametr (parametry), které se předají aplikaci vždy.
  • Parametr pro kontrolu všech jednotek - zde zadejte parametr (parametry), který řekne externímu nástroji, aby defragmentoval všechny jednotky přítomné v systému (pokud tento parametr podporuje).
  • Navíc přidej písmena všech místních jednotek - pokud nástroj nepodporuje speciální parametr pro defragmentaci všech jednotek, je možné nasimulovat tento stav předáním všech místních jednotek. O toto předání se postará DiskCheckerXP v případě, že zatrhnete tuto volbu.
  • Pozn.: poslední dvě volby se využívají v přídě volby defragmentace všech jednotek (z menu nebo na panelu nástrojů). Pokud defragmentujete pouze vybrané jednotky, tyto parametry se nepředávají. Parametry mezi sebou oddělujte mezerou. Pro přesné informace o parametrech externího nástroje je nutné prostudovat jeho manuál nebo nápovědu.


Nastavení, záložka Zobrazení

Konfigurace DiskCheckeruXP - záložka "Zobrazení"

Nastavuje způsob zobrazení DiskCheckeruXP v systému.

Zobrazovat DiskCheckerXP v

Určuje, kde se bude zobrazovat identifikace spuštěného DiskCheckeruXP. Na výběr máte tyto tři možnosti:
  • pruhu správce úloh (klasické zobrazení) - standardně se bude zobrazovat tlačítko s názvem DiskCheckeruXP v pruhu správce úloh, to je v panelu s tlačítkem Start.
  • políčku s časovým údajem - oblast známá také jako system tray. Většinou zobrazuje aplikace, které běží v systému Windows neustále - to proto, aby nezabíraly zbytečně místo ve standardní oblasti správce úloh. Jedná se o místo vedle systémových hodin, kde je aplikace vyobrazena jako malá ikonka. Pokud na tuto ikonku poklepete levým tlačítkem myši, dojde k přenesení DiskCheckeruXP na popředí. Další volby naleznete v případě, že použijete na ikonku pravé tlačítko myši.
  • obou dvou (pruh správce i políčko s časem) - kombinuje obě předešlé možnosti.

Zobrazit ikonky pro rychlý test a defragmentaci

Pokud často využíváte možnosti kontroly nebo defragmentace disku, nabízí Vám DiskCheckerXP možnost zobrazení dalších dvou ikonek v oblasti system tray (oblast se systémovým časem) pro tyto operace. Vyberte si, zda chcete využívat kontrolu, defragmentaci nebo oboje, tím dojde k zobrazení vybraných ikonek. Pokud chcete, aby se ikonky zobrazovali pouze v případě, že minimalizujete DiskCheckerXP, zvolte možnost tyto ikonky zobrazuj pouze pokud jsi minimalizovaný.

Pokud tuto volbu aktivujete, můžete využít možnosti rychlé kontroly a defragmentace pomocí pravého tlačítka na zobrazených ikonkách. Poklepáním na vybranou ikonku provede akci, která je v nabídce pravého tlačítka zobrazena tučně.

Další nastavení

  • Při minimalizaci se přesuň do políčka s časovým údajem - volba šetří místo na panelu správce úloh v případě, že DiskCheckerXP minimalizujete. V tom případě zmizí tlačítko z panelu správce úloh a zobrazí se ikonka v system tray. Jakmile ale DiskCheckerXP znovu přenesete do popředí, vrátí se tlačítko zpět na panel a ikonka ze system tray zmizne.
  • Při spuštění při startu se zobraz v políčku s časem - pokud si aktivujete volbu automatického spouštění DiskCheckeruXP zároveň při startu Windows (viz. nastavení - záložka "obecné") a aktivujete tuto volbu, zobrazí se po startu Windows DiskCheckerXP v oblasti system tray bez ohledu na nastavení zobrazení. V okamžiku prvního přesunu aplikace do popředí dojde k zobrazení dle platného nastavení a to již bude platit do příštího startu Windows.


Nastavení, záložka detailní informace

Konfigurace DiskCheckeruXP - záložka "Detailní informace"

Nastavuje možnosti pro zobrazení detailních informací vybraného (vybraných) disků a zobrazení informací o zvukovém CD (AudioCD).

Souhrnné informace - do celkové kapacity počítat

Detailní informace poskytují souhrnné informace (v pořadí třetí záložka), tedy počty jednotek a součty jejich volného, využitého a celkem volného místa. Tato záložka konfigurace definuje, jaké jednotky se do výpočtů budou brát v potaz. Pokud zvolíte první možnost - vybrané jednotky na panelu, bude ve výpočtech pracováno s právě vybranými jednotkami na hlavním panelu. Pokud ale zvolíte některou z voleb druhu jednotek (pevné disky, výměnné disky, síťové jednotky, jednotky CD-ROM), nebude brán zřetel na hlavní panel, ale do výpočtu se zahrnou všechny jednotky v systému, které odpovídají vybraným typům.

Informace pro CD Audio

DiskCheckerXP je schopen načíst informace ze souboru systému Windows cdplayer.ini, který obsahuje informace o zvukových CD. Konkrétně obsahuje informace o interpretu, názvu alba a seznam jednotlivých stop na CD. Pokud aktivujete volbu načítat informace ze souboru cdplayer.ini, bude se DiskCheckerXP snažit v případě, že bude v mechanice CD-ROM vloženo hudební CD, najít v soboru cdplayer.ini odpovídající záznam. Podle zadaného formátu zobrazení jmenovky CD poté zobrazí získané informace (konkrétně na druhé záložce).

Jmenovka disku

  • Je pouze pro čtení - Detailní informace umožňují také změnit jednoduše jmenovku vybraného disku. Pokud si přejte tomuto zabránit, povolte tuto volbu. Nebude poté možné provést změnu názvu jednotky.


Nastavení, záložka DiskCleaner

Konfigurace DiskCheckeruXP - záložka "DiskCleaner"

Tato záložka upravuje chování nástroje DiskCleaner.

Mazání souborů

Tyto volby upravují, jak se DiskCleaner chová při mazání souborů.
  • Atributy souborů "pouze pro čtení" odstranit při mazání - určuje, že se před smazáním souboru pokusí nastavit DiskCleaner atributy souboru na výchozí hodnotu. Pokud má soubor aktivní atribut pouze pro čtení, nedovolí systém Windows jeho smazání. Tato volba se přenáší vždy do prostředí výsledků hledání DiskCleaneru, proto můžete volbu přímo před mazáním ještě změnit.
  • soubory, které nelze smazat, automaticky přeskočit - pokud se nepodaří DiskCleaneru smazat některý z vybraných souborů, upozorní na tuto skutečnost uživatele informačním oknem, ve kterém se může rozhodnout, jak dál. Pokud chcete tomuto zabránit (urychlení), použijte tuto volbu. Soubory, které se nepodaří smazat, zůstanou ve výsledcích hledání. Pozn.: Pokud DiskCleaner zobrazí informaci o tom, že se nepodařilo soubor smazat, může uživatel zatrhnout volbu použít tuto volbu i pro ostatní, která zabezpečí průchod přes další chyby stejného druhu bez dalších výzev k uživateli.
  • potvrzovat smazání každého souboru zvlášť - umožní zobrazení výzvy k potvrzení smazání každého souboru.

Výsledky hledání

Po každém hledání je zobrazen dialog s výsledky hledání. Volby v této sekci dolaďují chování tohoto okna.

Velké soubory

  • Při hledání všech souborů a jejich následném řazení podle velikosti nebrat ohled na soubory menší jak - pokud využijete DiskCleaner ke hledání velkých souborů s funkcí Vyhledat všechny soubory a seřadit je podle velikosti, nebude DiskCleaner do výsledného seznamu zahrnovat soubory, které jsou menší než zadaná hodnota. Doporučuje se nechat tuto hodnotu minimálně na několika desítkách kB, protože souborů, které jsou menší jak těchto pár kB jsou spousty a výsledný seznam by pak obsahoval i desítky tisíc záznamů.

Barevné rozlišení

Umožňuje nastavit barevné rozlišení některých prvků výsledků hledání.
  • Podklad sudé skupiny dvojníků - nastavte barvu, která se použije na pozadí u každé sudé skupiny dvojníků.

    Poznámka:

    Ve výsledném seznamu hledání dvojníků se nachází pohromadě ty soubory, které se shodovaly v zadaných kritériích a tvoří tak skupiny. Díky barevnému rozlišení každé sudé skupiny dvojníků dochází opticky k zvýraznění těch položek, které patří k sobě a zároveň k jasnému rozdělení jednotlivých skupin.

  • Podklad pro neodebrané záznamy - tuto barvu využije DiskCleaner pro zbarvení podkladu těch položek, které se nepodaří odstranit při mazání. Pozn.: Tato volba není brána v ohled při práci s dvojníky souborů.


Nastavení, záložka InternetCache Cleaner

Konfigurace DiskCheckeruXP - "InternetCache Cleaner"

Tato záložka poskytuje nastavení jednoho z nástrojů DiskCheckeruXP - InternetCache Cleaneru, tedy nástroje pro práci s dočasnou pamětí prohlížeče internetových stránek Internet Exploreru.

Čištění při startu

  • Smazat historii navštívených stránek při startu Windows - zajistí, že DiskCheckerXP při spouštění systému Windows smaže historii navštívených stránek prohlížeče Internet Explorer. Toto je zatím jediný účinný způsob, jak smazat historii pomocí DiskCheckeruXP. Pokud chcete vědět více proč, přečtěte si Historie v Internet Exploreru a práce s ní.


Hlavní strana nápovědy

DiskCheckerXP 5 - nápověda

Vítejte v on-line nápovědě k aplikaci DiskCheckerXP.

Jelikož se jedná zatím o rozpracovanou verzi této nápovědy, může se stát, že některé informace zde uvedené budou nekompletní nebo budou některé úseky zcela chybět.


DiskCleaner, maska souboru

Co je to maska souboru?

Maska souboru je vyjádřena hvězdičkovou konvencí (v anlgičtině termín známý jako wildcards). Hvězdičková konvence využívá znaků hvězdičky (*) a otazníku (?) pro nahrazení některých nebo všech znaků ve jméně a příponě souboru.

Pravidla pro hvězdičkovou konvenci:

  • Otazník (?) nahrazuje libovolný jeden znak.
  • Hvězdička (*) nahrazuje libovolný počet znaků (včteně žádného).

Pár příkladů

Nejlépe se určitě vše objasníme na pár jednoduchých příkladech. Představte si, že máte tyto čtyři soubory Zpráva.doc, Zpráva1.doc, Zpráva2_pepa.doc a Změna2_pepa.doc. Pomocí těchto masek souborů můžete vybrat např. tyto skupiny:
  • Zpráva?.doc - otazník na 7 pozici zaručí, ze se vyberou soubory Zprava1.doc, Zpráva2_pepa.doc, protože zastupuje jakýkoliv znak na tomto místě. První soubor Zpráva.doc se nevybere, protože nemá 7 pozici a otazník zastupuje právě jeden znak.
  • Zpráva*.doc - vybere první tři soubory Zpráva.doc, Zpráva1.doc a Zpráva2_pepa.doc, protože hvězdička nahrazuje libovolný počet znaků včetně žádného.
  • Z*.* - vybere všechny soubory, protože všechny začínají na písmeno Z. Hvězdička v příponě souboru určuje, že se bude brát libovolná přípona.

Další používané příklady jsou například tyto:

  • *.* - vybere všechny soubory.
  • test.* - vybere všechny soubory se jménem "test" a libovolnou příponou.
  • *.txt - vybere všechny soubory, které mají příponu "txt".
  • ???.d* - vybere soubory, které mají název souboru dlouhý přesně tři znaky a mají příponu souboru "d" nebo začínající na "d".
  • test.?d?* - vybere soubory, které se jmenují "test" a mají příponu dlouhou minimálně tři znaky, ve které je na druhém místě znak "d".


Mr.Pear's DiskCheckerXP 5 (help)

Historie v Internet Exploreru a práce s ní

Úvodem

Internet Explorer - prohlížeč webových stránek jistě není potřeba představovat. V dnešní době jej využívá drtivá většina uživatelů internetu a tak se stal nedílnou součástí jejich života. DiskCheckerXP od verze 5.0 v sobě nese také nástroj InternetCachce Cleaner, který dává možnost uživateli pracovat mimo jiné s historií navštívených stránek tohoto prohlížeče. Funkce má však jistá omezení - proč a jak se obcházejí, to je téma této kapitoly.

Co je to historie navštívených stránek?

Jak brouzdáte po internetu, nebo v nových systémech Windows také po svém lokálním počítači, tak Internet Explorer zaznamenává adresu každé navštívené stránky a ukládá ji do historie navštívených stránek pro pozdější vyvolání. V počítači Vám tak vzniká podrobná stopa o tom, kdo, kdy, kde a co pomocí prohlížeče zobrazil. Konkrétně při brouzdání po internetu se jedná o adresy a soubory webových serverů, na lokálním počítači názvy souborů včetně jejich plných cest. Panel s historií jednoduše vyvoláte v prohlížeči pomocí nabídky menu Zobrazit -> panel aplikace Explorer -> Historie (Ctrl+H). Podle nastavení prohlížeče uvidíte zpětně až několik týdnů, kde jste všude po internetu a po svém počítači brouzdali.

Jak se historie zbavit?

Jak bylo řečeno, každý uživatel má ve svém profilu uloženo podrobně kde, kdy a co prohlížel. Pokud nechcete tyto informace shromažďovat, nebo chcete jejich shromažďovaní omezit, pak máte na výběr několik možností:
  • změnit nastavení Internet Exploreru - v nastavení Internet Exploreru (menu Nástroje -> možnosti -> záložka Obecné) můžete upravit počet dní, po které zpětně bude IE zachovávat historii stránek.
  • smazat historii z nastavení Internet Exploreru - dialog nastavení IE umožňuje také pohodlně smazat historii navštívených stránek. Je to nejrychlejší cesta k odstranění záznamů konkrétního uživatele.
  • použít např. DiskCheckerXP a jeho InternetCache Cleaner - funkce InternetCache Cleaneru umožňují jednoduše smazat obsah historie při každém spuštění systému Windows (přesně ihned po přihlášení konkrétního uživatele). Více o této volbě viz.Konfigurace - záložka "InternetCache Cleaner".

Proč neumí InternetCache Cleaner smazat historii při běhu Windows?

Ano, InternetCache Cleaner není schopen smazat vybrané záznamy historie. Umí pouze odstranit veškerou historii při startu systému Windows (během přihlášení uživatele). I když v jeho prostředí vyberete historii, smažete ji, tak v prostředí Internet Exploreru stále bude. I přes to, že při novém načtení InternetCache Cleanerem se v seznamu nezobrazí.

Proč?

Tak nad tímto otazníkem stojí hlava nejednomu programátorovi. I přes to, že Microsoft poskytuje informace, jak historii programově odstranit, uvedené funkce pracují jen částečně. Částečně proto, že pro aplikaci samotnou se po provedení tváří historie jako odstraněná, ale Internet Explorer dál hrdě historii drží. Důvod pro toto jsou "záhadné" soubory index.dat (umístěné v každém profilu uživatele), které obsahují veškeré záznamy z historie. To poněkud přehnané slůvko "záhadné" proto, že systém Windows má tyto soubory neustále uzamčené pro sebe a neumožňuje do nich jakýkoliv zásah z jiné aplikace a nelze je samozřejmě ani smazat. A jedině smazání těchto soborů stoprocentně zametete stopy po historii v Internet Exploreru.

A tím se dostáváme k tomu, jak je InternetCache Cleaner schopen odstranit veškerou historii - smazáním souborů s historií. Jak ale už víme, to je možné provést pouze před tím, než si je systém Windows uzamkne pro svou potřebu. Ten správný okamžik je v průběhu přihlášení uživatele a proto nabízí InternetCache Cleaner možnost smazat při každém přihlášení uživatele veškeré jeho soubory historie (index.dat). Po dokončení přihlášení systém Windows znovu tyto soubory vytvoří, soubory jsou však prázdné a neobsahují žádné stopy předešlé historie.

Pokud chcete tuto volbu využít a mít tak jistotu, že bude vždy při startu systému historie vymazána, podívejte se na Konfigurace - záložka "InternetCache Cleaner".