
Introduction To MultiView
Multiview was written to view up to four different AVI files without the need to run multiple 
instances of Microsoft's Media Player. You can also use MultiView to listen to WAVE and MIDI
files!

Although MultiView has been designed to be easy to use, the following Help topics are 
available:

System Requirements
Defining MultiView As Your Default Windows' AVI Movie Viewer
Defining MultiView As Your Default Windows WAVE Audio Player
The MultiView Main Window
The MultiView Menu
The MultiView Control Box
Opening an AVI File
Playing an AVI File
Setting The AVI File Playback Speed
Looping an AVI Movie
Capturing Video
Selecting the Active Window
Using the Zoom Command
Playing a movie in Full Screen mode
Copying A Frame To The Windows' Clipboard
Using the Volume control
Using the Restart Command
Playing a Movie Backwards
Changing the Background Color
The MultiView AudioView Screen
The MultiView AudioView Menu
Opening a WAVE or MIDI File
Playing a WAVE or MIDI File
Editing WAVE and MIDI Files
Looping a WAVE or MIDI File
Changing the MultiView AudioView Light Scheme
Using the Volume Control
Shortcut Keys
Custom AVI Files
About the Author



System Requirments
MultiView requires that the following software is installed on your PC:

Microsoft Visual Basic Runtime Module v3.0 (VBRUN300.DLL)
Microsoft Video For Windows Runtime
AVI files (necessary to have something to view!)

The hardware requirements are the same as for Video For Windows.

In order to hear sound from AVI files, or to use MultiView AudioView, you must have sound 
hardware installed, or you can use a Windows PC Speaker driver.
If you do not have sound drivers loaded, MultiView AudioView will be disabled.

MultiView is optimized for use with 160 x 120 movies. It will decrease the size of any 
movies that are larger than that.



The MultiView AudioView Screen
The MultiView AudioView screen is comprised of a menu, a title panel that will display the 
current file name, a slider to control the current position of the sound file, an elasped time 
display, volume control buttons, and an optional row of "lights".

    



The MultiView Main Window
The MultiView Main Windows is composed of four viewing windows.

These windows are referred to in the Windows menu selection as Upper Left, Upper Right, 
Lower Left, and Lower Right. On the Control Box these are referred to    as 1,2,3, and 4. The 
currently active window is indicated by a darker shadow. If the Control Box is visible you 
can also determine the active window by checking which of the numbers on the Control Box
is darker than the rest. The Window menu item will also show the active window by having 
a check mark next to the name of the window.

Note: If you exit MultiView while in the Single View mode, MultiView will automatically start
in SingleView mode. The same applies to Zoom mode.

An optional Control Box is available by selecting Preferences from the menu, then clicking 
on Control Box.

    



The MultiView AudioView Menu
The MultiView AudioView menu has five options. Choose the Menu item for more info.

File
Open
Close
Exit

Edit
Edit Current File
Select Sound Editor

Action
Play
Stop
Position To Start
Position To End

Preferences
Loop
Lights
MultiView
Volume

Help 
Help
About



The MultiView AudioView Light Scheme
Just for the heck of it, MultiView AudioView can show a row of "lights" to enhance your 
sound file listening pleasure.
From the Preferences Menu, choose Lights, then choose one of the schemes, or choose Off 
to disable the lights altogether.



The MultiView Menu
The MultiView menu has six options. Choose the Menu item for more info.

File
Open
Close
Capture - available if MultiView Capture is installed
Exit

Edit
Copy
Edit Current File
Select AVI Editor

Action
Play
Stop
Position To Start
Position To End
Restart
Reverse
Advance Frame
Back One Frame
Go To Frame

Preferences
Background Color
Control Box
Full Screen
Hide Menu
Loop
AudioView
Single View
Set Speed
Volume
Zoom

Window
Upper Right
Upper Left
Lower Left
Lower Right

Help 
Help
About



Opening A WAVE or MIDI File
There are many ways of selecting a sound file to be opened for use in MultiView.

The most obvious way is by selecting File from the MultiView menu bar, then choosing the 
Open... option. The Open File dialogue is then displayed. When the file is selected the 
sound file is opened.

The last ten AVI, WAVE and MIDI files that have been opened within MultiView will also 
appear on the File Menu. Click once on a file name and that file will open, if it still exists. If 
you choose to open an AVI file then the MultiView video viewer will then be enabled.

Close the file by selecting Close from the File menu.



Opening an AVI file
There are many ways of selecting an AVI file to be opened for use in MultiView.

The most obvious way is by selecting File from the MultiView menu bar, then choosing the 
Open... option. The Open File dialogue is then displayed. When the file is selected the AVI 
file is opened into the currently selected window. This method is also used if you have the 
Control Box displayed, and the Open button is clicked.

You may also bring up the Open AVI File dialogue by double clicking the window you would 
like to open the file into. 

The last ten AVI files that have been opened within MultiView will also appear on the File 
Menu. Click once on a file name and that file will open, if it still exists. If you choose to open
a WAVE or MIDI file then MultiView AudioView will then be enabled.

Close the file by setting it's window to active, then either select Close from the File menu, 
or click on Close from the Control Bar.



Playing A Sound File
You can start playing an open sound file by either selecting the Action Menu, then clicking 
on Play, or simply click on the arrow to the left of the slider control. Stop the file from 
playing by choosing Stop on the Action Menu, or click on the square next to the slider 
control.



Playing An AVI File
Once an AVI file has been opened into a MultiView window, you may choose to play this 
movie.

Choose Action from the MultiView menu and then select Play. This will start the movie 
playing in the active window. The frame number will be displayed on the title bar.

You may also play an open movie by clicking on the play button located directly under the 
viewing window.

If the Control Box is visible, click on the Play button to start playing the movie in the active 
window.

Choosing Stop from either the Action menu or the Control Box, or by pressing the square 
Stop icon under the active movie window, will cancel the playing of the movie. 

Unless you have selected otherwise, the playback speed will be the same as the speed at 
which the AVI was made. You may check this by looking at the Set Speed menu item under 
the Preferences Menu.



The MultiView Control Box

The MultiView Control Box is visible if you have selected Control Box from the Preferences 
menu. Depending on the setting of the Hide Menu option from the Preferences Menu, the 
MultiView Menu may disappear when the Control Box is visible.

The Control Box gives you easy access to many menu items. As with the menu, the Action 
buttons (i.e. Play, Stop) pertain to the currently active window. The four buttons that 
represent the windows will indicate the active window if the number is bolder than the rest

The red bar in the middle of the Control Box is a volume control. Clicking from left to right 
raises the volume..

Toclose the MultiView Control Box you can double click on the Window Control Box (the 
square on the upper left hand corner of the title bar), or select Close from the Windows 
Control Box Menu. If you have not chosen to activate the Hide Menu option you also have 
the option to click on the Control Box option on the Preferences menu.

The MultiView Control Box may also be minimized, giving you easy access for making the 
Control Box visible again by doulbe clicking on the Control Box icon.



Restart
The Restart command, available from the Action menu and from the Control Box, will reset 
the current position of the active movie to the beginning and then start playing. This is the 
equivalent of using the Start command , then using the Play command.



Position To Start
The Position To Start option on the Action menu, and the Start button on the Control Box 
positions the active movie to the beginning in the stopped position. You can also use the 
scroll bar under the window to postition the movie.



Position To End
Selecting the Position To End option from the Action menu, or clicking on the End button 
from the Control Box will position the active movie to the last frame in the movie. This 
comes in handy if you want to view the movie in reverse. You can also use the scroll bar 
under the window to position the movie.



Reverse
Selecting Reverse from either the Action menu or from the Control Box will start playing the
active movie backwards.



Zoom
The Zoom option from the Preferences menu, or the Zoom On/Off button on the Control Box
will double the size of the active window.

This makes the active window the only visible window, however you can still change 
windows and view these in the Zoomed view.



The Window Menu
The Window menu give you a selection of the four Main MultiView Windows. The active 
window will have a check next to it. If an AVI file is open in a window, the file name will be 
ther in place of the positional name (Upper Left, Upper Right, etc.).

You can also select the window to become active my choosing it's number from the Control 
Box, or by clicking once in the window.



Preferences Menu
The Preferences Menu allows you to select these three options:

Background Color
Changes MultiView from metallic to black, and vice versa.

Control Box
When selected the Control Box will be visible. Select again to hide the Control Box. When 
enabled this option will be checked.

Full Screen
Full-screen mode enables playback on a black background. If the image is zoomed, it can 
take up the full screen size.

Hide Menu
Determines whether the MultiView Menu is hidden when the Control Box is visible. 

Loop
This option causes a movie to run in a continuous loop

AudioView
Changes the interface over to the MultiView AudioView sound file player.

Single View
Changes MultiView from a four-window viewer to a single window viewer.

Set Speed
Adjusts the playback rate.

Volume
Selecting this will drop down a list of numbers from 0 to 9. Selecting 9 will give you full 
volume. Zero will disable the volume.

Zoom
When the option is checked, the Zoom feature is enabled. Selecting this again will turn off 
the Zoom feature.



Volume
TheVolume option can be selected by clicking    on the Preferences Menu, or 

For MultiView only:
by clicking on the red bar on the Control Box.

For MultiView AudioView only:
by clicking on the numbered buttons on the bottom of the MultiView AudioView screen.

The volume may be lowered and raised by selecting a number from 0 to 9, where 9 is the 
loudest.

Note: This volume control does not control the master control for your sound card. When 
viewing AVI files or playing WAVE files the volume control controls the WAVE portion of your
sound card. For MIDI files, it controls only the MIDI portion of your sound card.

You must preset the master volume on your sound card prior to using MultiView.



Action Menu
If a sound file is currently open, the Action Menu will be enabled. Otherwise this menu item 
is greyed out.

These commands are available when the Action menu is enabled:

Play
Start playing the sound file.

Stop
Halt playing the sound file.

Position To Start
Position the sound file to the beginning.

Position To End
Position the sound file to the end.



Action Menu
If the active window contains an open AVI file, the Action Menu will be enabled. Otherwise 
this menu item is greyed out.

These commands are available when the Action menu is enabled:

Play
Start playing the movie in the active window.

Stop
Halt the movie in the active window.

Position To Start
Position the active window's movie to frame 0.

Position To End
Position the active window's movie to the last frame.

Restart
Play the movie in the active window from the beginning.

Reverse
Play the movie in the active window backwards.

Advance One Frame
Step ahead one frame

Back One Frame
Step back one frame

Go To Frame
Allows setting the position of the movie by entering a frame number



File Menu
The File Menu gives you these options:

Open...
Open an AVI file into the active window.

Close
Close the AVI file in the active window.

Capture
Visible if the MultiView Capture program is installed.

Exit
End the MultiView program.

The last ten AVI files that have been used by MultiView will also appear on the File Menu. 
Click on any file name to open that file. If the file no longer exists, you will be notified of 
this.



Exit
The Exit command, selected either from the File menu or, for MultiView only, from the 
Control Box, ends the MultiView program.



Active Window
The Active Window can be determined by the checked item on the Window menu list, by a 
darker shading around the window, or, if the Control Box is visible, a darkened number on 
the Window selection buttons. Select the window to become active by using the Window 
menu, clicking once on the window, or clicking on a number on the Control Box.



Open File Dialogue
The Open File Dialogue allows you to select an AVI, WAVE, or MIDI file to open in the active 
window, or in the case of sound files, in MultiView AudioView.

Highlight the file name and click OK, or double click the file name, to open the file.



About
MultiView was orignally written by Robert Reinstein in 1994. 

Robert is a Microsoft Windows Certified Professional.

The future development of MultiView depends on your vote!

See the About option on the Help menu for more details.



Help Menu
The Help menu gives you these choices:

Help - view this Help file

About - information about MultiView and it's author



VBRUN300.DLL is the runtime DLL for Microsoft's Visual Basic version 3.0.

This program was written using the Visual Basic Professional Edition.



Microsoft Video For Windows Runtime is available from most commercial bulletin board 
systems, such as CompuServe, and on Microsoft's own BBS.



Advance Frame
When in the paused (Stop) position, this menu item, or Control Box button, will step the 
movie    in the active window ahead one frame. You can also use the scroll bar under the 
window to step frames.

In the Control Box click on the >> button.



Back One Frame
When in the paused (Stop) position, this menu item, or Control Box button, will step the 
movie    in the active window back one frame. You can also use the scroll bar under the 
window to step frames.

In the Control Box, click on the << button.



Loop
Enables movies or sound files to loop (restart after reaching the end).

Turning on this option will automatically restart a movie or sound file if the Position To End 
command is used.

MultiView only:
This option is also available by clicking on  in the Control Box.

Turn off looping by clicking on  in the Control Box.



Select Editor
This menu option will display a dialogue box which lets you choose a file editor of choice to 
use with the Edit Current File option.



Edit Current File
This option is enabled only if you have already chosen a file editor using the Select 
Sound/AVI Editor menu option. Clicking on this option closes MultiView, but starts the editor
of choice with the file from the cureent file loaded and ready for editing.

MultiView only:
This is also available by clicking on Edit button in the Control Box.



Capture
This option will be enabled if you have a video capture board installed, and you have 
installed the MultiView Capture program into your MultiView directory.

The MultiView Capture program is a full featured video capture program that allows you to 
quickly review what you have captured, and also allows you to exit the program and either 
edit the captured video, or return to MultiView.



Full Screen
This enables full-screen playback. In Zoom mode, a 160x120 AVI file will fill the entire 
screen.

This option is also available in the Control Box by clicking on the monitor button.



Background Color
This changes the MultiView window from the metallic color to a black background, and vice 
versa.



Scroll Bars
The scroll bars located under each window that contains an open AVI file can be used to 
postion the movie. By clicking on either arrow you can step by one frame in either 
direction. Clicking between the button and the arrows step the movie by 10 frames. 
Clicking and dragging the button can take you anywhere within the movie (try it).

Note that the scroll bar is only active for frame positioning if the movie is in STOP mode. 
Otherwise the button will display the current position of the movie.



Shortcut Keys
MultiView uses the following shortcut keys to allow you total control without a mouse!

Ctrl+O File Open
Ctrl+F12 File Close
Ctrl+X Exit MultiView
Ctrl+C Copy Frame
Ctrl+P Play
Ctrl+S Stop
Ctrl+T Position To Start
Ctrl+E Position To End
Ctrl+M Toggle between MultiView and MultiView AudioView
Ctrl+L Restart
Ctrl+R Reverse
Ctrl+A Advance One Frame
Ctrl+Q Back One Frame
Ctrl+G Go To Frame
Del Change Background Color
Ctrl+B Control Box Toggle
Ctrl+Y Full Screen
Ctrl+I Hide Menu Toggle
Ctrl+F8 Loop Toggle
Ctrl+V Single View Toggle
Ctrl+Z Zoom Toggle
Shift+Del Select Editor
Ctrl+F1 Upper Left Window
Ctrl+F2 Upper Right Window
Ctrl+F3 Lower Left Window
Ctrl+F4 Lower Right Window
Ctrl+H Help

 



Custom AVI Files
If you would like to transfer some of your favorite home movies to AVI format, I am offering 
a service to do just that. Send an NTSC VHS or NTSC 8mm videotape cued to the proper 
section, and I will transfer 15 seconds of video to an AVI file for the price of $15 ($10 for 
registered users of MultiView). A diskette will be sent to you with the AVI file. For an 
additional $2 I will return your videotape.

If you wish to order your custom AVI file, be sure to enclose a good description of the 
segment you would like transfered (for instance, "child squirts grown-up in the face with 
water gun"). Please cue the tape as accurately as possible. 

The AVI file will be 160x120 at 15fps.
This offer is good for the U.S. only.

Send orders to:

Robert Reinstein
20 Singingwood Drive
Holbrook, New York 11741



After passing several examinations, a designation of Microsoft Certified Professional For 
Microsoft Windows Version 3.1 Administration.



Single View
Enabling Single View allows you to use MultiView as a standard AVI viewer. This will display 
one AVI file in the center of the MultiView window.

You can still switch from file to file, as this option acts just like the Zoom option, without 
enlarging the size of the AVI file display area.

If you exit MultiView while in Single View mode, the next time you start MultiView it will still 
be in Single View mode.

Single View mode is also available by clicking on  in the Control Box.

Turn off Single View mode by clicking on  in the Control Box.



Copying A Frame To The Windows' Clipboard
When viewing an AVI movie, you may select the Edit Menu, then choose Copy.
The current frame will be copied to the clipboard. If you are using Zoom view, then the 
zoomed image will appeat on the clipboard.

You may also click on the Copy button in the Control Box to achieve the same results.



Setting The Frame Number
Besides using the scroll bar, and the Position To End and Position To Start commands, you 
may choose from the Action menu the Go To Frame... option.

 This will display an entry field for you to enter the frame number you would like to skip to.

You may also click on the GoTo button in the Control Box.



Edit Menu
The MultiView Edit menu contains these options:

MultiView only:

Copy
Copy the current frame to the Windows' Clipboard

MultiView and MultiView AudioView:

Edit Current File
Load the current file into a selected editor
Note: The current file is first closed, and then loaded into the editor

Select Sound/AVI Editor
Choose the program to be used with the Edit Current File selection



Using MultiView As Your Default WAVE or MIDI Player
MultiView is capable of functioning as your default WAVE and MIDI sound file player.

There are two methods of enabling this.

For the first method you must edit your WIN.INI file. Look for the section [Extensions] and 
find the line that    starts with WAV=. This will read something like:

WAV= mplayer.exe ^.wav

Change the line, or if you cannot find this line, add the line:

WAV=C:\MULTIVU\MULTIVU.EXE ^.WAV

For MIDI files. look for 

MID=mplayer.exe ^.mid

and change the line to:

MID=C:\MULTIVU\MULTIVU.EXE ^.mid

Substitute your MultiView directory for C:\MULTIVU if you have it installed in a different 
path.

The second method requires that you open the Windows' File Manager. Click on the File 
menu, then choose Associate...

Next, in the Files With Extensions field, enter WAV or MID. Then, click on the Browse... 
button and navigate to the directory where your MultiView executable, MULTIVU.EXE is 
located. Double-click on MULTIVU.EXE, and then choose OK. The association is now 
complete. Repeat this for the other extension if you wish.



Using MultiView As Your Default AVI Player
MultiView is capable of functioning as your default AVI movie file player.

There are two methods of enabling this.

For the first method you must edit your WIN.INI file. Look for the section [Extensions] and 
find the line that    starts with AVI=. This will read something like:

 AVI= mplayer.exe ^.avi

Change the line, or if you cannot find this line, add the line:

AVI=C:\MULTIVU\MULTIVU.EXE ^.AVI

Substitute your MultiView directory for C:\MULTIVU if you have it installed in a different 
path.

The second method requires that you open the Windows' File Manager. Click on the File 
menu, then choose Associate...

Next, in the Files With Extensions field, enter AVI. Then, click on the Browse... button and 
navigate to the directory where your MultiView executable, MULTIVU.EXE is located. 
Double-click on MULTIVU.EXE, and then choose OK. The association is now complete.



Set Speed
You can adjust the playback speed of AVI files using this option, found on the Preferences 
Menu.
You can also adjust the speed by using the Plus (+) and Minus (-) buttons on the Control 
Box.

The choices are:

1x - normal speed
2x - double speed
1/2x - half speed
1/4x - quarter speed
1/5x - one-fifth speed
1/10x - one-tenth speed

Changing the speed will affect all MultiView windows.



Hide Menu
This option, available from the Preferences Menu, determines whether the MultiView Menu 
will be visible when the MultiView Control Box is visible.

If this option is checked, the MultiView Menu will disappear when the Control Box item from 
the Preferences Menu is selected. The MultiView Menu will re-appear when the Control Box 
is closed.

If this option is left unchecked then the MultiView Menu will still be available when the 
Control Box is visible.



The MultiView AudioView Preferences Menu
Preferences Menu

The Preferences Menu allows you to select these three options:

Loop
This option causes a movie to run in a continuous loop

MultiView
Changes the interface over to the MultiView AVI file player.

Lights
This item provides you with a choice of light schemes, or the ability to disable the lights.

Volume
Selecting this will drop down a list of numbers from 0 to 9. Selecting 9 will give you full 
volume. Zero will disable the volume.




