
WYSI-Help Composer Tutorial - Facts about California

In this tutorial you will create a hypertext file covering three major cities in California. All
the components needed are included; your task is to put the hypertext file together using
WYSI-Help Composer.

Part 1 of the tutorial will guide you through the basic features of WYSI-Help Composer.
In Part 2 you will be introduced to more advanced features. If you are new to WYSI-Help
Composer, Part 1 of this tutorial will take about half an hour. If you have been using an
earlier  version  of  WYSI-Help,  Part  1  should  not  take  more  than  ten  minutes.  We
recommend you complete Part 1 since it forms the basis for Part 2.

Part 1 Basic Features of WYSI-Help Composer

1. Open WYSI-Help Composer

Double click on the WYSI-Help Composer Icon in the Program Manager to launch the
WYSI-Help Composer. 

2. Open a File

From the WYSI-Help Composer File menu, choose Open.

Select  TUTOR.DHF from the list of available files and click  OK. This file is a partially
developed Facts about California hypertext file. It includes text, some hypertext links and
bitmaps.

3. Create a Hypertext Link

When TUTOR.DHF opens, double click on  San Francisco in the Topics list to edit the
topic about San Francisco. (If  the topic San Francisco is not visible, use the scroll bar
on the right of the topics list to browse through the topics.)

The topic text for San Francisco now appears in the editing window. Scroll down to the
last paragraph of the topic.

In  the  editing  box and  select  the  words  Golden Gate Bridge in  the  last  paragraph.
Golden Gate Bridge will now be highlighted.

From  the  Link  menu,  choose  Hypertext... to  create  a  hypertext  link.  WYSI-Help
Composer will automatically create a new topic called Golden Gate Bridge.

Click on the  Edit button in the  Hypertext... dialog box to edit the topic about Golden
Gate. Move your cursor into the editing window and type “The Golden Gate bridge is 8981
feet long and the bridge’s towers are 746 feet high.” 

You’ve  finished  creating  the  hypertext  link.  Now,  when  the  user  clicks  on  the  word
Golden Gate in the compiled help file,  the topic you just created about Golden Gate
bridge will open. If you would like to use a pop-up link instead of a hypertext link, choose
Pop-up instead of Hypertext... from the Link menu. 
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Note: The topic you have just edited will remain on the screen.  You will see the results
of the link you just made later on in the tutorial.  For now, continue on with the tutorial.

4. Creating and Inserting a HotSpot Picture

From the  Edit  menu, choose  Edit Hypergraphic.  This will launch Microsoft’s HotSpot
Editor.  The HotSpot Editor is used to add hot zones to pictures. When the user moves
over a hot  zone in  the help file,  the cursor  changes into a hand and if  clicked,  the
associated help topic will open.

In the HotSpot Editor, choose Open from the File menu. Select USA-CAD.BMP from the
list of available files. This will open a map of California.

After the map is loaded, locate San Francisco (you may use the scroll bar), and draw a
box over the word San Francisco. To do this, position the cursor just to the left of the
word San Francisco and press the left  mouse button. Keeping the left mouse button
pressed down, move your mouse diagonally across the word San Francisco. Size the
box  so  it  covers  the  word  San  Francisco.  The  box  will  be  a  hot  zone  in  the  help
application. 

Now double click on the hot zone box to link it to an existing help topic in the WYSI-Help
Composer. Double clicking on the hot zone box will open the Attributes dialog box and
WYSI-Help Composer’s list of available topics.

Double click on the word San Francisco in the list of available topics. This will move the
topic name,  SAN FRANCISCO, into the  Context String text box. The hot zone is now
linked to the topic: San Francisco.

Click OK to return to the main window of the HotSpot Editor.

Use the same method to create hot zones for Los Angeles, and link this hot zone to LOS
ANGELES  topic.

After you have linked all three cities, choose  Save As... from the HotSpot Editor  File
menu and save your hypergraphic as USA-CAD.SHG.

From the HotSpot Editor File menu, choose Exit to quit the HotSpot Editor and to return
to the WYSI-Help Composer.

In the WYSI-Help Composer, double click on topic:  Main_index,  which appears in the
Topics list. You will now edit the main index of your help file. Place your cursor in the
editing window below the underlined text “California, the Golden State”. This is where
the hypergraphic will be inserted.

From the  Insert menu, choose  Hypergraphic... and select  USA-CAD.SHG. Click  OK
and the hypergraphic created earlier will  appear in the WYSI-Help Composer editing
window.
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5. Using the Spell Check

Your help file is almost ready. However, before compiling the help file you should do a
spell check.

Choose Spell Check... from the File menu.

If the spell checker finds incorrectly spelled words, it will suggest a replacement. You can
either ignore or replace the suggested words using the Ignore and Replace buttons in
the dialog box. If the spell checker does not recognize a word, you can add it to your
personal dictionary by using the Add button. If you want to quit the spell check, click on
Done.

After the spell checker has completed checking your current topic, a dialog box appears
asking if you want to continue the spell check. Click on All Topics to check all topics of
your help file. After the spell check is complete, click  OK to return to the WYSI-Help
Composer main window.

6. Compiling the Help file

Before the help file can be used, it has to be compiled using Microsoft’s Help Compiler.

Choose Save from the File menu.

Click OK to convert the file to RTF-format (Rich Text Format). This step is necessary to
compile the help file.

Another dialog box appears asking if you want to convert the file into HLP format. Click
OK and the file will be compiled. The compilation takes place in a DOS window and
takes a while to do.

After the compilation is completed, press any key to return to the WYSI-Help Composer
main window. 

Note:  A message  accompanied  by  a  beep  will  be  displayed  advising  you  that  the
compile process is completed.  Please ignore the hourglass displayed. 

From the File menu, choose Execute Help File to see what your help file looks like.

Congratulations! You have now completed the first part of this tutorial.

Part 2 The Advanced Features of the WYSI-Help Composer 

Part  2  of  the  tutorial  will  guide  you  through  the  advanced  features  of  WYSI-Help
Composer. Going through the Part 2 will take about 30 - 60 minutes.
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1. Importing an Existing Text Document

What to do when you need to import your old help files or text from another document?
No problem. Save your old help file, text or hypertext file in .RTF-format and use WYSI-
Help  Composer’s  automatic  RTF-file  import  feature.  RTF  (Rich  Text  Format)  is  a
standard text file type, supported by most word processors. For example, if you have a
Word  for  Windows  text  or  hypertext  document,  you  can  import  it  into  WYSI-Help
Composer. First save it as an RTF file in Word for Windows. Then import it into WYSI-
Help Composer. To import your WYSI-Help files (created in earlier versions of WYSI-
Help), we recommend you import them as RTF-files.

In  this  part  of  the  tutorial  you  will  import  CALHIST.RTF to  WYSI-Help  Composer.
CALHIST.RTF is a three page text document about the history of California. The goal is
to create different topics for each chapter of the document. (If you wish, you can open
the CALHIST.RTF document with your word processor before importing it.)

From the WYSI-Help Composer File menu, choose New to create a new help file. From
the File menu, choose Open.

Click on the  List Files of Type menu in the  Open dialog box and select the RTF file
type. 

After selecting the RTF file type, choose CALHIST.RTF from the list of available files and
click OK. The Document Import dialog box appears with choices for importing RTF-files.
On the right  is a list  of  the all  the styles used in the document.  Styles are used to
delineate chapters and sections in a document. Similarly, these same styles can be used
to delineate topics in a Help File. 

To select the Style of titles, double click on Times New Roman Bold 14. A double arrow
will appear to the left of the chosen style. Now, click on Titles in the Select View box to
get a listing of the actual titles of the chapters in the original .RTF document. Five titles
will be displayed, starting with Juan Rodriguez Cabrillo....

Double click on Juan Rodriguez Cabrillo... to select it to be imported and then click on
Expand to Level to select all the available topic titles. The text contained in the Juan
Rodriguez  Cabrillo... chapter  will  be  imported  into  the  Juan Rodriguez  Cabrillo...
topic,  the text contained in the Spanish Coastal Expeditions chapter will be imported
into Spanish Coastal Expeditions and so on.

Click on Import. When a dialog box appears asking if you want to save conversion rules
click No unless you want to use the same conversion rules later on. When the import is
complete, the new topics will be displayed in the Topics list.

Save your help file as CALHIST.DHF. There is no need to convert to RTF or HLP.
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2. Importing Topics: The next step is to import the new topics from the CALHIST.DHF
file into  TUTOR.DHF.

From the File menu, choose Open and select the TUTOR.DHF file. Click OK to open it.

Now choose Import Topics from the Topic menu. When the Open dialog box appears,
choose  CALHIST.DHF and  click  on  OK.  When  the  Topics  to  Import dialog  box
appears, select the San Francisco and SF weather from the list on the left by holding
down the Ctrl key and clicking on the topics.  

After you have chosen all the topics to import, click on Import. This will import the topics
to the TUTOR.DHF file.

Save the changes now but do not convert the file to RTF or HLP format when prompted. 

3. Automatic Link Generation

Now we  will  look  at  one  of  WYSI-Help  Composer’s  major  features,  Automatic  Link
Generation. This feature scans your help file for specific text contained in a Reference
list,  and automatically creates hypertext links for that text.  In our tutorial, we want all
occurrences of the words “Mexico” and “Mexican” to be linked to the topic Mexican and
Russian Settlers. 

First, you need to activate Automatic Generation in the Link Menu.  This menu item is
activated when a check mark appears next to it. In the  Link menu, select  Automatic
Generation to make the check mark appear.

Now you will add the reference words, Mexico and Mexican, to the reference list of a
particular topic.

Select the topic Mexican and Russian Settlers in the Topics list and double click on it.
This makes it the current topic.

From the  Link Menu,  select the  Edit Auto Links... menu item. The  Edit Automatic
Links dialog box appears,  with the cursor in the Link Text box.  Type in Mexico and
click on the Add button.

Place the cursor in the Link Text box again, highlight  Mexico and replace it by typing
Mexican.  Click the Add button again. 

Below the Link Box is a list of all of the reference words associated with the target topic
Mexican and Russian Settlers.  Click OK.
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Select  Regenerate links from the  Link menu.  In  the dialog box that  opens,  all  the
reference words will be highlighted.  To save time by not regenerating all of the lists, use
the scroll bar to locate  Mexico and  Mexican. Highlight these two words by clicking on
one,  then  pressing  the  Ctrl  key  while  clicking  on  the  other.  Click  on  the  Ask  for
confirmation box, to switch off the confirmation. Now click  OK.  After the links have
been regenerated, click OK in the dialog box.

You can now preview the help file, using the Preview Mode available in the File menu,
to see the new links you have created.  Using the hypertext links in the help file, move
from topic to topic to see that every instance of the text Mexico and Mexican is now a
hypertext link.

4. Modifying the Layout of your Help File

Making your help files look good is very easy with the WYSI-Help Composer. You can
easily  size  windows,  set  colors  and  add  secondary  windows.  This  is  done  with  the
Project Editor. The  Project Editor edits the project file (.HPJ-file) which controls the
parameters of the Help compiler when you compile your help file. In this next section we
will modify the layout of our help file.

Resizing the help window:  You will now resize the Main help window with the Project
Editor.

From the File menu, choose Project Editor. The Project Editor dialog box opens with
settings for your project file.

Click on the Modify button in the Windows area of the Project Editor dialog box. When
the Window Information dialog box opens, click on the Size Window... button and drag
the corners of the sample window that appears. Size the window to about half the size of
your screen and move it to the left side of your screen.

When you are satisfied with the size of the help window, click OK to return to the Project
Editor.

Secondary Window

The Project Editor also allows you to create secondary windows.

Click  on the  Add... button  in  the  Windows area  to  add  a  secondary  window.   The
secondary window will appear in your help file when the user calls it. The default name
for  this  window is  SEC1.   This  is  the name that  will  be  used to call  the secondary
window, so don’t change it.

In the Window Information dialog box, type “Weather” in the Title box. Later you will
link the weather information to the secondary window. Now size the secondary window
as above. Make the secondary window wide and short and move it to the upper right
corner of your screen.

When you are satisfied with the size of the secondary window, click OK to return to the
Project Editor.

6



Modify Colors

You can select colors for your Main and secondary help windows.

Choose the window you wish to modify in the Windows area and click Modify.

Select the colors in the  Window Information dialog box. Click on the  Fixed Region
parameter box.  This box sets the color for the possible non-scrolling region, and the
Background parameter sets the color for the help window. When you are satisfied with
the color selections, click OK.

You are finished with the Project Editor.  Click OK to close the Project Editor dialog box.

In addition  to the  Project  Editor,  WYSI-Help  Composer  supports  functions  that  are
related to the format of your help file.

Modify Style

This function lets you change the default text style for all your topics.

Enter some text into the editing window and select. This allows WYSI-Help Composer to
automatically  recognize which style of  text  you want to modify throughout  the whole
document.

Next, choose Modify Style... from the Format menu. When the Modify Style dialog box
opens, click on Modify.

In the  Font  dialog box, choose the font attributes and the color you want to use. For
example System 10 Bold works nicely in a help file.

When you are  satisfied  with the font  style,  click  on  OK to  return  to  the WYSI-Help
Composer main window.

Non-Scrolling Region

WYSI-Help Composer also allows you to add a non-scrolling region to your topics by
using  the  Non-Scrolling  Region command  in  the  Topic menu.  You  can  do  this
automatically when creating new topics by checking the Non-Scrolling Region box in
the Create a New Topic dialog box.

Choose  Non-Scrolling Region command from the  Topic menu.  In the Non-Scrolling
Region dialog box, enter the number of paragraphs you wish to have in the non-scrolling
region.  Click on OK.  The current topic now has a non-scrolling region.

Extended Link 

In addition to hypertext and pop-up links, WYSI-Help Composer allows you to link your
help file to external programs, sound, macros, other help files and secondary windows.
We will now link the San Francisco weather to the secondary window created earlier.
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Select the San Francisco topic by double clicking on San Francisco in the Topics list.
When the San Francisco topic is open, scroll down until you see the small picture of the
sun. Select the picture by double clicking on it and choose  Extended Link... from the
Link menu.

When the Extended Link dialog box opens, choose SEC1 from the Target Window list.
SEC1 is the default name for the first secondary window.

Click on Find Topics to see the list of available topics in your help file. Choose the SF
weather topic by clicking on it and then click  OK to return to the main window of the
WYSI-Help Composer.

5. Using Macros

Macros are functions that  can be invoked from a help file.   These functions can be
invoked when a user clicks on some text or graphics, when a specific topic is entered, or
when the help file is opened.  Instruction in the details of Macros is beyond the scope of
this  example.   To  learn  more  about  using  macros,  refer  to  the  Microsoft  Software
Developers Kit or other software developers tools.  

In this tutorial, we will write an Exit routine. This routine creates a button that the user
can click to exit the help file.  It combines two macros entered in the Help Project File
(.HPJ).  Macros in the Help Project Files are called file macros.

From the File menu, select File Macros....

In  the  Help  Macro  Definition dialog  box,  scroll  down  the  Macro  List until  the
CreateButton macro appears.  Select the CreateButton macro and click on the Add to
current definition button. 

The  parameters  for  the  macros  are  displayed  on  the  box  beside  the list.   Add  the
parameters by placing the cursor in the  Current definition editing field containing the
macro  until  it  looks  exactly  like:   CreateButton(“exit”,”Exit”,”EXIT()”).   The  first
parameter,  “exit”, is an internal ID and can be ignored,  “Exit” is the caption on the
button and “EXIT()” is the macro that is invoked when the button is pressed. At this
point, click OK.

6. Testing Your Help File

The final step in this tutorial is to compile and test your help file. Save and compile your
help file by choosing Save from File menu. Click Yes to convert to RTF and to HLP.

When the compile process is completed, choose Execute Help File from the File menu.
When  the  help  file  opens,  click  on  San  Francisco to  open  the  topic  about  San
Francisco. Scroll down and click on the picture of the sun. A secondary window should
open.  Check out your automatic links Mexico and Mexican.  Also test the Exit  Macro
located on the top of your help file.

Congratulations! You have now completed the second part of the WYSI-
Help Composer tutorial.
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