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Introduction

FTP Explorer has a new home!! FTPx now has its own home page – http://www.ftpx.com.    Come and 
see the newest helpful hints and tips, download the latest version (at a much improved speed), talk 
with other users, subscribe to the mailing list, submit a suggestion, or just admire the cool graphics.    

Welcome to one of the most versatile, and powerful, yet easy to use FTP 
programs available today!    FTP Explorer is a 32-bit FTP application that is 
extremely simple to operate, and makes moving files between the Internet and 
your computer as simple as local file manipulation.    Several features of FTP 
Explorer make it stand head and shoulders above most other FTP programs 
that are currently available.    At a glance, some of these advanced features are:  

Download or upload files to one or more servers while browsing and selecting files to 
transfer on another.    That's right!, FTP Explorer handles all file transfer requests in 
the background, so you don't have to wait while files copy to continue browsing the 
current server – you can even connect to a different server, and the program will 
automatically log off of the original server once the requested transfer has completed.  

Can't connect?    Not to worry.    FTP Explorer will automatically retry if the connection 
attempt fails.    You can configure the number of times it should try to connect, and the 
time delay between connection attempts.

Support for resuming interrupted file transfers.    FTP Explorer attempts to resume a 
file transfer if it detects a file with the same name in the current download directory.    
This can save you time and connection costs for those troublesome connections.    
(Note:    not all ftp servers support this option.)

No more searching through that index file for the entry you're looking for.    FTP 
Explorer can automatically download and display the proper description of each file 
with the file that it describes.    As an option, the program will automatically download 
the index file on the server and display the file descriptions next to the appropriate files
while you browse.    Several standard index file formats are currently supported.    

The new Transfer Manager allows you to ascertain the details of download or upload 
requests at a glance.    The source, destination, and status of each request is detailed 
in the Transfer Manager window to keep you apprised of multiple connections, and 
make it easy to see which files have been transferred.    

Create file or directory FTP shortcuts on your desktop to launch FTP Explorer and 
automatically connect to your most commonly visited FTP sites.

Like icons?    Like descriptions?    No problem.    FTP Explorer    uses the Windows 95 
style list boxes for displaying the contents of remote servers.    Toggle between large 
icons, small icons, lists, or full descriptions of the files you are browsing.    Its intelligent
tree view learns the directory structure as it goes.    



Windows 95 style right-click menus keep options at your fingertips.    The most 
commonly used options are only a mouse click away.    Menu options change based 
on the type of file or directory that is highlighted.    

Intelligent Command Queue enables background completion of each command, so 
you don't have to wait on directory listings!.    Once connected to a server, FTP 
Explorer maintains a list of commands to carry out which makes listing files and 
searching the server much faster.    Select the directories that you want to browse as 
soon as you connect, and FTP Explorer    will go to work downloading the directory 
information and listing its contents in the background while you continue to browse.    
As each directory listing is completed, its color changes to let you know you can view 
it without any delay.    

This thing caches it all!    Each connection is cached in memory, so moving back one 
or more directory takes a fraction of the time that is necessary with most FTP 
programs.    It also has an option to cache entire sites so that you may peruse the site 
off-line, then automatically connect when a download or upload us initiated.    

The Quick Connect option lets you immediately connect to a site without having to go 
through the usual song-and-dance of adding a site to the profile list.    

Support for fpArchie is also included with FTP Explorer.    

Full Drag and Drop support.    Simply drag one or more files – or complete directory 
structures -- onto the FTP Explorer's file view area to transfer them to the location of 
the server that is currently connected.    Receiving files is also as simple as dragging 
one or more files (or directories) onto your desktop, or any other folder.    

Shareware Notice

This product is free for any individual to use as a personal entertainment or utility.    Any other use of 
this program, including business or corporate use is strictly prohibited unless a proper license has been
issued to the company or individual.    For licensing information and ordering instructions, see the 
Ordering Information section.



Getting Started
This section will discuss the steps necessary to install and configure the FTP Explorer for use on your 
system.    For more detailed information on making connections, see the section of this help file that 
discusses the    Connection Dialog.    

System Requirements
FTP Explorer must run on a machine that is configured for TCP/IP network communication or Internet 
access. Access can be gained through Winsock and the use of any dial-up provider, a Remote Access 
Server (RAS), or a direct connection via a local area network that supports TCP/IP (provided there is a 
FTP server on the network).    This table displays the minimum and suggested requirements for FTP 
Explorer.    

Installation
The installation of FTP Explorer takes place by unzipping the distributed files, and running the setup 
program (setup.exe) from either Windows Explorer, the Run option from the Start Menu, or the 
command prompt.    If upgrading, make sure that FTP Explorer is not running prior to launching the 
setup program, or the installation will fail.    Once setup is launched, it will prompt for a location to install
the program.    If this is an upgrade, setup will determine the existing directory location of the program 
and load it as the default path for installation.    If the default directory is satisfactory, choose the Next 
button to begin copying the files for the installation.    When all files have been copied, the setup options
screen will appear and prompt for the installation of shortcuts on the desktop and in the start menu, in 
addition to asking to make FTP Explorer the default FTP application.    Select or remove any of the 
options that you desire, and press the Next button to continue.    The setup program will make the 
desired changes, then prompt to reboot the system (if any of the registry enhancements were chosen 
from the setup options screen).    

After the system restarts, launch FTP Explorer.    If this is an upgrade, your existing profiles should 
appear in the Connection Dialog.    If this is the first time to run the application, you will be prompted to 
load the default FTP server profiles.    Press OK to load the profiles, or No to leave the server profile 



area blank.    FTP Explorer will then be ready to use.    

Initial Configuration

Before running FTP Explorer, your machine must first be configured for TCP/IP use.    Chances are 
that this will not be a problem for most users, since currently this program is only available on the 
Internet or subscription services connected to the Internet.    In short, before you launch FTP Explorer, 
do the same things that you would do prior to launching your WWW browser like starting the Winsock, 
connecting to a RAS server or dial-up access provider, or whatever else may be necessary in your 
case.    Once your machine is properly configured for Internet access, launch the program to start the 
configuration procedure.    

If you are running FTP Explorer for the first time, you may wish to view or change the default user 
settings from within the Option Configuration Dialog.    Settings to control the programs performance, 
and user customization are available from within this dialog.    Open the dialog by choosing the 
"Options…" item from within the View Menu.    

By default, the Connection Dialog appears every time the program launches (this feature can be 
disabled in the General Options Settings dialog).    This dialog contains a listing of each server 
configured for connection with FTP Explorer.    Before any file transfers can take place between your 
machine and the desired server, the server's information must be entered in the Connection Dialog.    

Where To Go From Here

Here are a few areas to browse if you need more information on program configuration, or learning the 
interface characteristics of FTP Explorer:    

Menu Options
Tool Bar Options
Connection Dialog
Option Configuration Dialog
Ordering Information
How To…



Menu Options

Select any of the following menu captions for further information on each of the menu choices.

File Menu
Edit Menu
View Menu
Tools Menu
Window Menu
Help Menu



Tool Bar Options

Up One Level 

This option moves up one directory level, and is only available if a connection is active, and the current 
directory is not at the root level.

Go To… 

This button functions in the same manner as the Go To option from the Tools Menu.    Use it to enter a 
path and move directly to the folder or directory specified rather than using the mouse to navigate 
through the server's directory structure.    

Refresh

Use this option to reload the file listing of the current directory.    This option is only available if a 
connection is active.    You may also refresh the current directory by using the Context Menu in the File 
View Area, or by choosing the Refresh option from the View Menu

Connect

Use the connect button to open the Connection Dialog and make a new connection to a FTP server.    If
a server is currently attached, connecting to a new server will disconnect from the existing server, and 
allow you to browse exclusively the new connection.    However, any file transfer requests from or to the
current connection that have been added to the Transfer Manager will be downloaded or uploaded 
from the existing connection while you connect and browse the new connection.    

Disconnect

Use this button to disconnect from the current server and clear the Tree or "All Folders" and List or 
"Contents of " windows.    Disconnecting from a server will not halt any file transfer requests that have 
been added to the Transfer Manager, or initiated on the current server.    

Cancel

The Cancel button is only active during connection attempts are being carried out by FTP Explorer.    
Pressing this button will cancel any connection attempts in progress.    

Quick Connect

Like its counterpart in the Tools Menu, the Quick Connect button allows the user to open a dialog to 
enter the URL to a server without entering all of the server profile information in the Connection 
Dialog. .    This is especially convenient for pasting URL’s from other applications.    Quick Connect will 
attempt to make an anonymous connection to the specified server on the default port (21).    If the 
server does not accept anonymous logins, or connections on the default port, the quick connect will 
fail, and a server profile must be made in the connection dialog.    Syntax for the quick connect is as 



follows:    

ftp://ftp.whatever.com/subdir1/subdir2/etc/filename

If the URL includes a filename, enable the “Download File” option to instruct the program to download 
the file (the option will only be visible when there is no “/” character at the end of the URL).

Download To…

Selecting this option will save the currently highlighted file to a name of your choice.    It will queue a 
transfer request with the Transfer Manager, which will initiate the download of the file from the server, 
and save it in the directory and as the file name that you choose.    This option differs from the 
"Download" option in that you will be prompted for a local directory and file name to which to save the 
file.    This option is only available when a connection is active and one or more files are selected within
the List View or File View area.    

File Download

This button will queue a transfer request to download the selected file(s) from the server to the default 
download directory (see the Option Configuration Dialog for more information on download path 
options)

File Upload

This button will prompt for one or more files, then queue a transfer request to upload those file(s) from 
the host to the current directory of the server.    

File Delete

This button will queue a command to delete the currently highlighted file(s) provided that your account 
on the server to which the program is connected permits the deletion.    The command will be 
completed once all commands queued prior to it have been completed.    

File Properties

Displays the Properties Dialog to show the properties of the currently selected file.    This button is only 
available if a connection to a server is open, and a file on the server is selected.    

The next four options control how FTP Explorer displays the directory listing of files contained on the 
on the remote server.      See the View Menu for more details on the available display options.    

Large Icon View

Small Icon View

List View



Detail View

ASCII Transfer Mode

Like the ASCII option in the Tools Menu, if this option is selected, all transfers to or from the remote 
server will be made in ASCII format.    This is necessary for ASCII text files on some servers, but cannot
be used for the transfer of binary executables, or files other than those composed strictly of ASCII text. 
You can specify the file types that should always be transferred with ASCII mode in the File Types tab 
of the Options Dialog.    

Binary Transfer Mode

The Binary option makes FTP Explorer treat all transfers to and from the remote server in a binary 
format, which is necessary for binary executables, or very generally, for files that are not composed 
strictly of ASCII text.    This feature can be toggled from within the Tools Menu also.    You can specify 
the file types that should always be transferred with ASCII mode in the File Types tab of the Options 
Dialog.    By adding ASCII file types in this dialog, all other files can be transferred in Binary mode 
without problems.    

Show FTP Log

Enable this option to display the FTP Log on the lower portion of the screen.    The log displays a listing
of all commands sent to the remote server(s), and can be useful for debugging, trouble shooting, or 
simply to satisfy your curiosity about the FTP connection between your machine and the server(s) to 
which it is connected.    



Connection Dialog

This dialog contains fields for all necessary information to make a connection to a remote server with 
FTP Explorer.    The program comes with several default options for immediate use, but the process of 
making connections of your own is relatively simple with the proper information.    The process of 
creating connections is explained in detail below, but a quick look at the Option Configuration Dialog 
may be necessary at some point to clarify the "Anonymous" and "Attempts / Retry Delay" options.    

Profile Name
The text displayed in this field can either be the profile name that is selected in the list on the left side 
of the dialog, or it can be text that has just been entered.    Click on an entry in the list to choose the 
profile and automatically display the related connection information for it.    Any relevant data previously
configured in the connection dialog for each server will be displayed after its selection from the list.    

To edit an existing Profile Name, simply select the profile to edit from the list, then move the cursor to 
the point in the profile name that you wish to change, and make the desired changes.    Any changes 
will automatically be saved unless the “Cancel” button is chosen.        Use the Save button to retain any
changes if you intend to close the dialog using the “Cancel” option.    All standard Windows edit options
including Copy, Cut, and Paste are available when editing this field.    Profile Name entries can contain 
spaces, and other characters, but must be smaller than 25 characters in length.

Host Address
The Host Address field contains the location of the FTP server to which the FTP Explorer is to connect
when this Profile Name is selected.    In the example above, the location is described by its DNS entry.  
The location may also be specified by its IP address.

Port
The Port option is set to 21 by default, but may be changed for any profile at any time.    Most servers 
accept ftp connection requests on port 21, but there are those that do not for security, or other reasons.
Change the port number by clearing the default entry, and typing the new port number.    You can use 
the Save button to save any changes, or simply select a different Profile from the list to update the 



setting.    You must use the “Save” button to retain any changes if you close the dialog with the 
“Cancel” button.    

Use PASV Mode
PASV mode is useful for certain types of firewalls that do not allow FTP servers to initiate data 
connections back to the connected client.    

Use Firewall
If this option is selected, the firewall configuration parameters from the Firewall tab of the Options 
Dialog will be used when initiating a connection to this profile.    

Login
The login name that is required by the selected server to access your FTP account goes in this field.    
If you do not have an account with the selected server, and it accepts anonymous FTP requests, enter 
“anonymous” in this field, or enable the Anonymous option (explained below).

Password
Enter the password in this field that is required by the server to access your FTP account.    The 
password entered here will not be legible for security purposes.    If the connection to a server is 
refused, it is a good idea to re-enter the password to make sure it wasn't entered incorrectly.    If you 
are configuring a profile for a server that requires an anonymous login, you can enable the Anonymous
option to automate the entry of the password.    See the Anonymous option for more details.

Initial Path
Enter the path on the server that you wish to start in when using the current profile.    This feature 
makes it quick and easy to automate the navigation to a commonly visited directory on the server.    For
example:    In the example above, when the connection is made to ftpx.com, the directory in which the 
first listing will be made is the "/pub/ftpx/" directory.    If the Initial path field does not contain a value, the
root directory will be the default listing.    FTP Explorer provides a handy feature that can “Remember” 
any directory that you specify, and add it to the initial path section of the server profile.    See the 
“Remember” feature described in the Tools Menu for more details.    

Attempts and Retry Delay
Use these options to allow FTP Explorer to automatically retry the connection if the initial attempt fails. 
The "Attempts" field contains the maximum number of attempts that the program will try before 
returning an error.    The "Retry Delay" option instructs the program how long to wait between 
connection attempts.    

Note:    If the value contained in the "Retry Delay" field is larger than the connection time-out 
value of your Winsock configuration, the delay will not be effective, although the “Attempts” 
value will be.    The value of the "Retry Delay" field is only effective if the value is smaller than 
the Winsock time-out value.    

Download Path
Use this field to enter a default path for all downloads from this server.    If you do not enter a path in 
this field, the default download path will be used for all download operations (not download - to 



operations).    Use the Browse button to locate the chosen directory.    

Description
Enter a description for the server in this field.    An entry in this field is not required for any profile.    

Options and Command Buttons

The Anonymous Option
Use this option to fill in the Login and Password fields with "Anonymous" and the value contained in the
Email Address field on the General tab of the Option Configuration Dialog (an email address is 
customary for anonymous connections).    

The Add Button
Use this button to create a new server profile.    All of the information necessary for the connection must
be added to the new profile before a connection can be made to the server.    

The Save Button
The Save button is provided for those instances when you want to change a profile, then “Cancel” the 
dialog (useful when you are connected and want to stay that way).    If you “Connect” or change to a 
different profile, changes are saved automatically.

The Shortcut Button
Use the Shortcut button to create an Internet shortcut to the selected server on the desktop of your 
machine.    When a shortcut is opened on the desktop, FTP Explorer will automatically launch and 
attempt to connect to the server addressed in the shortcut profile.    

The Remove Button
The Remove button deletes the current profile from the system registry and the profile list of the 
program.    There is no "Undo" command for removal of profiles, so care should be taken when 
removing a profile.    

Cache data between sessions
If this feature is enabled, FTP Explorer will save all directory information about the site on the local 
machine, so you can disconnect and browse the site locally.    FTP Explorer will automatically re-
connect to carry out any user-initiated file transfers.    This allows users on pay-per-hour connections to 
save considerable time perusing directory structures on-line.    The cached data for each profile is kept 
in a file called ~profile name~.DAT which is located in the program directory.    These files can be 
deleted as necessary with no ill effects.    After a profile’s cached data has been deleted, you must 
connect to the server to create a new .DAT file for the profile before you can browse the site off-line.    



View Window

The "Tree View" or view window displays the directory structure of the currently connected server.    
The window is blank unless FTP Explorer is connected to a server, or a server's cached directory 
information is displayed.    Navigating through the server's various folders or directories is 
accomplished by clicking individual folders with the mouse.    As the example below displays, the folder 
icons change depending on their status.    Here are the general guidelines that explain the individual 
icons displayed in the Tree View:    

If a directory has been chosen, and its contents displayed in 
the File View Area, the folder will be represented by a yellow 
icon.

The current folder is represented by an open folder icon.

Folders that have not been listed are gray in color. 

Folders that are being refreshed are green. These folders turn 
yellow once FTP Explorer finishes downloading the content 
listing from the server.

Folders with a "+" symbol next to the folder name mean that 
there are sub-directories beneath the folder. 

Conversely, a "-" symbol next to a folder icon means that there 
are no further directories beneath, although there may be files 
in the directory.

Non-viewed (gray) directories will not have the "+", or "-" symbols next to their icons since the program 
has not attempted to display the contents of the folders, and it is only during the listing process that 
FTP Explorer determines the contents of each folder. 

FTP Explorer handles all user commands intelligently by placing each command in a virtual "queue".    
The individual commands in this command queue are then carried out sequentially until all have been 
completed.    This feature allows the user to select or "flag" several directories at the same time, and 
continue to upload or download files while the program completes downloading the file listings of the 
chosen directories.    This speeds the navigation of servers by downloading only the directories that the 
user selects without disabling the user interface, or restricting the navigation functionality of the program 
while displaying the contents of those directories.    

Using The Keyboard To Navigate



For users more accustomed to keyboard navigation, FTP Explorer has been designed to make every 
feature available via the keyboard.    The tree view area of the main screen can be fully exploited with 
the Tab, Page-Up, Page Down, and various Arrow keys.    Use the up and down arrow keys to select 
individual directories to display.    Enlarge or collapse directory trees with the right and left arrow keys 
respectively.    Press the tab key to move from the tree view to the File View Area.    



File View Area

The File View or "List View" area of the program is located on the right side of the main program 
screen.    If a server connection is active, it displays the contents of the currently highlighted directory in
the "Tree View" or View Window portion of the main screen.    

View and Sorting Options
The files contained within the selected directory will be displayed in one of four ways depending on the 
chosen display option on the tool bar, or View Menu.    The display option may be changed at any time 
by selecting the desired option from the tool bar, view menu, or by right clicking the mouse in the File 
View area and choosing the appropriate "View" option from the Context Menu.    

Similar to the view options, you may sort the items displayed in the File View Area by choosing a sort 
method from the View Menu, or by using the Context Menu to select the sort method.    If you choose 
the “Details” sort option, you may also sort the contents of this area by clicking on the column 
headings.    Additionally, clicking them more than once will toggle the sort order between ascending and
descending.    



FTP Status Log

The FTP Status Log area is visible by default.    It displays the complete history of information that FTP 
Explorer transmits or receives, including commands, login data, and server announcements.    Every 
command that the program is given via the user interface is interpreted, converted, then carried out.    
The FTP Status Log displays the information that is passed between the program and any remote 
servers to which the program attaches during the session.    The contents of the log can be useful for 
troubleshooting purposes, or informative for those users that enjoy seeing what the program is actually 
doing.    Each time the program closes, the contents of the log are discarded, and may not be retrieved 
again.    It is possible, however, to retain the contents of the log and place the data in a file for future 
reference (see the File Menu for details).    

For those that do not wish to view the log, or simply need more desktop space, it can be removed from 
the screen by disabling the FTP Log option in the View Menu.    

As you become more familiar with FTP commands, you may want to send the server a command 
directly.    You may accomplish this by selecting the Quote option from the Tools Menu.    



The Status Bar

The Status Bar will always keep you apprised of FTP Explorer’s actions.    The left-most portion of the 
status bar displays short informative statements and descriptions of the program’s activities during its 
various connection, or file transfer operations.    

Perhaps the most useful feature of the Status Bar is the numeric indicator that displays how much data 
is being transferred between the local machine and the server.    This indicator becomes active for 
downloads or uploads that are not performed in the background (see Transfer Options for more 
information on background file transfers).    The value displayed here at any given time is the amount of
data that has been transferred to or from the computer during the current operation.    



Option Configuration Dialog
The Option Configuration Dialog contains four "tabs" that house the various default program options.    
These tabs are:    

The General Options Tab… which contains basic items like email address, and enabling sound among 
other basic options.

The Paths Tab… Default path locations for downloaded, and temporary files.

The Connection Tab… Options like prompting for passwords and connection retry attempts.

The Transfers Tab… Background transfer and quick view options.

The Firewall Tab… Firewall configuration options.    

The File Types Tab… Specify files to be handled as ASCII, and assign Index file names.



Ordering Information

FTP Explorer is shareware and is free for all to evaluate over a 30 day trial period beginning on the 
day of installation.    At the end of the 30 day trial period, any business or corporate use of the product 
must be licensed by the author.    If a license is not obtained, by the last day of the evaluation period, 
FTP Explorer and all associated files must be removed from the computer(s) on which it is installed.    
Students, educational institutions, or individuals using FTP Explorer for educational purposes, or 
personal entertainment have the permission of the author to use the program free of charge so long as 
it is not manipulated, decompiled, changed in any way, or separated from any of its distributed files.    If 
FTP Explorer is used for business purposes at any time, the company or individual must obtain a 
license from the author.    

Those that are entitled to use FTP Explorer without charge as described above are still encouraged to 
register the program, to support continued development and maintenance of the program.    

A single user license for FTP Explorer    is $30.    Multi-user or site license information can be obtained 
by contacting achavis@ftpx.com.

Fill out the Yes I Need This Software form and fax or mail it to receive the appropriate number of 
software licenses.    



File Open Error
This error occurs if a viewer or application is not associated with a file and it is selected to open.    



View Menu

The View Menu contains several features 
that allow the user to manipulate the 
appearance of the program on the desktop.   
When active, the first three options in the 
menu have check marks next to them.    The 
view options give the user several choices 
relating to how the files will appear within the
file or List View area of the program.    A 
small dot will appear next to the chosen 
option, as Details does in this example.

FTP Log
This option toggles the lower portion of the program in and out of view.    The FTP Log displays the 
actual commands that are transmitted between the local machine and the server to which it is 
attached.    This information can be useful for troubleshooting connection problems that may otherwise 
be untraceable.    If the information isn't useful to you, simply disable this option.    Additionally, the data 
contained in the FTP Log can be saved to a file from within the File Menu, or by right-clicking within the
actual log. 

Toolbar
The Toolbar option toggles the display of the button bar or tool bar on the program screen.    In some 
instances it may be necessary, or simply preferred to remove the tool buttons, so this feature was 
implemented.    Further information on the Tool Bar is contained in that section of the help file.    

Status Bar
Toggle the display of the status bar with this option.    The status bar displays error, and program status 
information as well as counting the amount of data transferred between the local machine and the 
server (for non-background transfers only).

Large Icons
The Large Icons option makes all files and directories within the List View area of the main screen be 
represented by the large version of either their own icon, or the default icon for the file type.    

Small Icons
As you might have guessed, same as Large Icons, except smaller.    

List
The list view is much like the Small Icons view except it is oriented vertically, as opposed to the 
horizontal orientation of the latter.    



Details
The Details option is probably the most informative of the four display options.    It consists of a list view
of the files, while simultaneously showing the complete properties for each file.    The Details view 
displays so much information, that if the program is not sized large enough, it may be necessary to 
scroll the list to the right, or resize the display panes to display all of the available information on the 
files.    See the section concerning the Window Menu for more information on sizing the screen panes.   

Arrange Icons
The Arrange Icons option opens a sub-
menu to allow the user to arrange the 
files/directories in the View Window in a 
variety of ways. The available options 
appear to the left.    ASCII sort order is the
sort method, so regardless of the sort 
choice, numeric and special characters 
will appear before letters.    

Note:    While using the “Details” display option, you can select the sort method by clicking on 
the column name at the top of the file listing.    Clicking it twice will sort the selections in 
descending order rather than ascending order.

Refresh
Use the Refresh option to update the file or directory listing of the current connection.    

Options
The Options alternative will display the Option Configuration Dialog so that the user can view or alter 
the default settings.    



Edit Menu

Use the options within this menu to aid in the selection of multiple file.    Each of the options is 
described in further detail below.

Select All Ctrl+A
Use this option to select all files in the current directory of the current server connection.    

Invert Selection
This option will reverse the selected files in the current directory of the current server connection.    This
eases the process of file selection if there are more files that you want to select than not.    Select the 
files that you don't want, then use this option to invert the selection.    Now all files that were not 
selected before will be, and vice-versa.    



Window Menu

The Window Menu controls options to 
customize the layout and look of FTP 
Explorer, and to allow keyboard access to 
the individual panes of the program.    These
options are explained below.

Tree
Use the Tree option to switch to the Tree View, or leftmost pane of the main screen.    

List
Use the List option to move the cursor to the List View or File View pane of the main screen.    

FTP Log

Use the FTP Log option to move to the FTP Status Log pane of the main screen.    

Transfer Manager
This option will display the Transfer Manager so that you may check the progress of any transfers in 
progress, or determine the outcome of completed or aborted transfers.    

Vertical Split
Use this option to change the size of the Tree View and List View panes of the main screen.    Any 
changes made will be written to the system registry so the next time the program runs, the changes will
be retained.    

Horizontal Split 
Use this option to change the size of the FTP Status Log on the main screen.    Any changes made will 
be written to the system registry so the next time the program runs, the changes will be retained.    



Properties Dialog

The Properties Dialog displays key information concerning the currently selected file or folder.    File 
name, size, description, associated application, location, date, owner, group, and permissions are 
displayed (depending on the type of server on which the file resides).    The information contained in 
this dialog is also available within the List View pane of the main screen if the "Details" view option has 
been selected on the View Menu.    If more than one file is selected, the properties for the file that was 
selected last will be displayed in the properties dialog.



File Menu

The File Menu options 
allow keyboard access to 
all commands available for 
any file or directory that 
may be encountered while 
using the program.    
Program control options 
like Exit are also contained
in the File Menu.    

New Window
This option will launch 
another instance of FTP 
Explorer.    

Open
The Open option is available if a connection is active, and a file is highlighted.    Choose the Open 
option to download the file, and open it with its associated application.    If no application is associated 
with the file, an error will pop up detailing that is the case.    Make 

Mouse Shortcut:  Right click on the file you want to open and    select this option from the Context 
Menu.

Quick View
The Quick View option is for use with files that are supported by a quick view driver for Windows 95™.  
Several vendors have made viewers available for their file formats, and it is a fair probability that more 
vendors will follow in their steps.    The Quick View option will retrieve the highlighted file, and attempt 
to display its contents within the quick viewer.    This option is only available if a connection is active, 
and a file is currently selected.    

Mouse Shortcut:    Right click on the file you want to use quick view with and select this option from 
the Context Menu.    

Create Shortcut
This option is only available when a server connection is active, and a directory on the server is 
highlighted in either the Tree View or File View areas of the program.    When this option is selected, it 
will create a shortcut to the server on the desktop.    This shortcut will automatically launch FTP 
Explorer and attempt to connect to the server with this directory as its initial path.    Shortcuts can also 
be created on the desktop from within the Connection Dialog.    

Download
This option is only available if a connection is active.    Choose this option to queue a transfer request 
for the selected file(s) or directory(ies).    The chosen files will be downloaded to the default download 
directory.    This option differs from Download To… since the user is not prompted for a location or new 
file name for the incoming file(s).    If a file exists in the default download directory with the same name, 
one of two things will happen:    



1. You will be prompted to overwrite the file if it is the same size or larger than the file to be 
downloaded.    

2. You will be prompted to resume the transmission of the chosen file if the local copy is smaller, or 
has an older date than the file chosen for download.    The resume feature is not supported by all 
FTP servers, so do not take for granted that the download of a file can be resumed on every 
server.    

Transfer requests are handled by the Transfer Manager, and may take place after the connection to the
existing server is closed, thus allowing the user to continue to browse and download or upload files on 
other FTP servers, rather than wait on file transfers.    

Mouse Shortcut:  Right click on the file you want to download and select this option from the Context 
Menu.

Upload
Choose this option to select one or more files on your local machine and submit a transfer request to 
copy these files to the current directory on the active server.    You may also drag and drop files onto 
the File View or List View area of the program to queue a transfer request to copy the selected files to 
the active server.    

Transfer requests are handled by the Transfer Manager, and may take place after the connection to the
existing server is closed, thus allowing the user to continue to browse and request or download files 
from other FTP sites, rather than wait on file transfers.    

This option is only available if a connection is active.    

Download To:…
Use the Download To:…option to initiate a transfer request to download one or more files to the 
directory and file name(s) of your choice.    You will be prompted for the file name(s) and location(s).    
Download To:… differs from Download since the user will be prompted for a file name and the location 
before the download takes place.    Additionally, if a file with the same name already exists in the 
directory that you choose for the download, you will be prompted to overwrite, or to resume the transfer
as explained in the Download section above.    

Transfer requests are handled by the Transfer Manager, and may take place after the connection to the
existing server is closed, thus allowing the user to continue to browse and request or download files 
from other FTP sites, rather than wait on file transfers.    

A connection must be active, and one or more files must be selected before this option is available.    

Mouse Shortcut:    Right click on the file(s) you want to save and select this option from the Context 
Menu.    

Save Log As
Use the Save Log As command to place the entire contents of the FTP Log into a file for future 
reference.    Additionally, sections of the FTP Log may be captured, and placed on the clipboard by 



using the Copy option from the Edit Menu.    See the section on the View Menu for more information on 
capturing text from within the FTP Log.    

New
Use the New option to create a new folder in the directory that is being displayed in the File View Area. 
Your user permissions must include the right to create directories, or the action will fail.    

Mouse Shortcut:    While FTP Explorer is displaying the directory in which you want to create the new 
folder, right click in the File View Area, and select this option from the Context Menu.

Delete
Delete will delete the selected file providing your login grants you permission to delete files on the 
server to which FTP Explorer is attached.    

Mouse Shortcut:    Right click on the file you want to delete and select this option from the Context 
Menu.    

Rename
Rename will prompt for a new name for the file that is currently selected.    The new name will replace 
the old, providing your login grants you permission to rename files on the server to which FTP 
Explorer is attached.    

Mouse Shortcut:    Right click on the file you want to rename and select this option from the Context 
Menu.    

Numbered options
The numbered options displayed in this menu are the last four connections that were established.    
Select any of the items in the list to connect to the chosen site.    

Properties
Use this option to display the properties of the currently selected file.    The option will not be available if
an active connection is not open, and a file is not selected.    The items listed in the properties dialog 
may also be listed within the file view or List View area of the program if the List View area is 
configured to display "Details".    

Exit
Choose the Exit option to close the FTP Explorer program.    Any settings that may have been altered 
during the current session will automatically be saved when the program closes.    



Help Menu

The Help Menu contains choices to 
display this help file, and display 
important program copyright information.

Help Topics
Open this help file to the contents page.    Help is available at any time by pressing the F1 key.    "Tool 
Tips" are also available for buttons on the tool bar by hovering over the button in question for more 
than 1 second.    Tool Tips can be toggled on or off from within the Option Configuration Dialog (View 
Menu, Options selection).    

About FTP Explorer…
The program "About" box is displayed after choosing this selection.    It contains copyright and version 
information about FTP Explorer.    



Tools Menu

The Tools Menu contains options to aid in 
special transfer or connection circumstances 
while allowing access to several unique 
features of the program.

Find
This option currently supports fpArchie searches for files on the Internet.    The option will not operate 
properly unless the fpArchie program is installed on the system.    This program can usually be 
obtained at:
http://www.euronet.nl/~petert/fpware/When installed properly, FTP Explorer will launch fpArchie, and 
allow you to search the Internet for specific files of interest.    You may then use FTP Explorer to 
navigate to the sites that contain those files.    

Connect
Use this option to open the Connection Dialog and either attach to a server, or edit a connection profile.
The Connect option may be activated by the Tool Bar button with the same name.    

Quick Connect

Disconnect
The Disconnect option is only available if a server is currently attached.    Choosing this option will 
break the connection from the server, although any pending transfer requests that involve the server 
will still be carried out in the background.    See the Transfer Manager for more information.

Cancel
Use this option to cancel any connection attempts in progress.    There is also a cancel button on the 
Tool Bar.    



Quote
The Quote command allows you to enter commands directly to the FTP server.  The available 
commands vary depending on the type of server, and can usually be determined by logging on to the 
server with the command line FTP client and using the "remotehelp" command.  FTP Explorer does 
nothing other than forward the keyed command directly to the server.

Go To…

This option allows the user a means to directly enter a directory on the connected server.    This feature is 
particularly useful on large or busy FTP sites.    If you know the exact directory that you wish to open, but 
navigating through the directory structure takes too long, simply enter the path to the directory that you 
want to enter, and press the OK button.    FTP Explorer will jump directly to the chosen directory, and 
display its contents.    The directory tree will automatically check the directory structure, and if all is 
correct, will display the contents of the chosen directory.

Remember
The Remember option is only available if a server connection is active.    It places the current directory 
in the Initial Path field of the connection profile for the server.    This will make FTP Explorer 
automatically start in the current directory the next time the server profile is chosen from the 
Connection Dialog.    

ASCII
Like the ASCII option on the Tool Bar, if this option is selected, all transfers to or from the remote 
server will be made in ASCII format.    This is necessary for ASCII text files on some servers, but cannot
be used for the transfer of binary executables, or files other than those composed strictly of ASCII text. 
You can specify file types that are always treated as ASCII in the File Types tab of the Options dialog.    

Binary
The Binary option makes FTP Explorer treat all transfers to and from the remote server in a binary 
format, which is necessary for binary executables, or very generally, for files that are not composed 
strictly of ASCII text.    This feature can be toggled from the Tool Bar also.    

Import…
The Import feature allows for the import of existing profile settings from popular FTP programs.    Profile
settings from, WS_FTP, and Cute FTP are supported at this time.    To import the existing profiles, first 
choose the Import option, then select the type of file that FTP Explorer is to search for from the "Files 
of type" list.    The available options are currently:



WS_FTP (ws_ftp.ini)

CuteFTP (tree.dat)

After choosing the type of file to import, select the file that contains the profile settings, (both types of 
files are contained in the directory with their respective FTP program) and press the "Open" button to 
start the import process.    The import process is speedy, and should take no more than 10 seconds 
unless importing several dozen entries.    FTP Explorer will notify you with a message upon the 
successful import of the profile entries.    

Note:    You can only import one file at a time.    If you have profiles from more than one file or 
program, you must import the files separately.    



Transfer Manager

The Transfer Manager maintains a record of each transfer request, and displays a summary of each of 
the requests during the current session.    Both downloads and uploads are summarized within the 
Transfer Manager, and can be differentiated by the “From” and “To” fields.    Completed transfers can be 
identified by the blue icon, and the "Complete” value in the Status field.    Active transfers are shown by a 
yellow Icon, and the "Active" entry in the Status field.    Pending transactions have gray icons and a 
"Pending" entry in the Status field.    Transfers that have encountered errors have red icons, and display 
"Error" in the Status field.    Finally, transfers that have been canceled by the user will appear with black 
icons and will be accompanied by the text “Canceled” in the Status field.    

A transfer request can be added to the Transfer Manager at any time, and from any server.    Requests 
that are not from the current connection will be handled in the background via a separate connection to
the proper server.    This allows the user to "queue" transfers to or from a server, then disconnect, and 
attach to another and continue browsing or making additional transfer requests while the requests to 
the first server complete in the background.    Depending on the “Transfer Queued Items” setting in the 
Transfer Option Dialog, transfer requests are handled either in a linear fashion I.E. – first in first out, or 
simultaneously. 

The Transfer Manager is not a stand-alone program, but if it is running, and transfers are in progress, 
you can close FTP Explorer and it will remain open to aid in the completion of    the remaining 
transfers.    Once the transfers are complete, the transfer manager along with the transfer dialog(s) will 
close, and the program will completely unload itself from memory.    

Note:    Downloads that result in errors can be resubmitted via the Context Menu, or Transmit 
Menu.    If the server supports the resume function, the download can continue with little or no 
lost time since FTP Explorer will not have to transfer what has already been downloaded.    

Transfer Manager Menu Options

Transfer Menu

The Transfer Menu contains options that allow you to either cancel pending or active transmissions, 
and to resubmit a transmission that has already taken place, whether it was successful, canceled, or 
encountered errors.    To use these options, simply select one or more items from the Transfer 
Manager, then click on the option of your choice. 



Edit Menu

The Edit menu in the    Transfer Manager makes it easier to make multiple selections if there are more 
than a few that you wish to select from the list.    As it says, the Select All option will select every 
transfer from the list.    Use the Invert Selection option to reverse the selection of the transfers in the 
list.    For example, if you wanted to select all but three items in the a list that contains twenty items, 
simply select the three that you do not want, then choose the Invert Selection option to de-select the 
three, and select the remaining seventeen.    

Transfer Manager Context Menu

The Transfer Manager menu options are also available from the Transfer Manager’s context menu.    
To use the context menu, make your selections, then right click on one of the selected transmissions to
bring up the menu.    Select the choice that you desire from the menu to carry out the task for the 
selected transfers.



Context Menu
The context menus offer quick right-click options that speed the selection of commonly used 
commands.    Depending on the selection, and the properties available for that item, the contents of the
context menu will change to allow the commands that are specific for the selected item.      There are 
specific menus for files, directories, links, and also a default menu when nothing is explicitly selected.    
Regardless of the option, every command contained in any of the context menus is also available from 
within one of the Menu Options, or via the Tool Bar options.    There is also a Context Menu available in
the Transfer Manager that is not described here.    The available menus and the explanation of the 
circumstances that make the options available are described next.        

Default 
Menu

The default context menu is always available -- whether a connection is active or not -- by using the 
right mouse button in the File View Area of the program.    If a connection is active, right-click on a 
blank section of the File View Area, and not on a file or directory to activate this menu.    The options 
available within the default menu allow easy access to the file display and sort options, as well as the 
option to reload or refresh the current directory, and create a new directory. 

View 
Option

 Use the View option change the appearance of the files and folders in the File View Area.    These 
options are also available from the View Menu .    Complete descriptions of the choices are located in 
that section of the help text. 

Arrange
Icons 
Option

The “Arrange” options allow you to sort the files and directories in the File View Area by any one of 
several methods.    These options are also available from within the View Menu.    Complete 
descriptions of the choices can be found under that topic.    
Note:    If the selected view method is “Details”, you can also sort the files and directories in the
File View Area by clicking on the column headers.    Additionally, Clicking them twice will toggle 
the sort order from ascending to descending

New 
Option

The New option allows you to create a new folder in the current directory.    This option is only available
if a connection to a server is active.    Your user permissions must also allow the creation of directories, 
or the command will fail.    The same command can also be found in either the Tool Bar, or the File 
Menu.    



Refresh 
Option

Use the Refresh option to update the directory listing for the current directory.    This option is also 
available from both the Tool Bar, the View Menu.    

Folder or 
Directory 
Context 
Menu

The context menu available when a directory is selected is shown to the left.    These options allow 
quick downloads, and creation of shortcuts, along with several other features that are explicitly 
available to directories.    To enable this menu, a connection must be active, and a directory must be 
visible in the File View Area.    Hover over the desired directory, then use the right mouse button to pop 
up the menu.    With the exception of the Explore option, each of the features in this menu are also 
available in the File Menu.    The options are fully described in that section of the help file.    The Explore
option simply opens the chosen directory, and displays its contents in the File View Area.    
NOTE:    You may also “Explore” or open the chosen directory by double-clicking it in the File 
View Area, or clicking on it once from within the View Window, or List View Area.    

File 
Context
Menu

The context menu available when a file is selected appears to the left.    This menu is very similar to the
directory-specific context menu since it has many of the same options.    Additional choices include the 
options to Open, and Quick View the selected file or files.    The Quick View option will only operate 
properly if the Quick View software is installed on the machine running FTP Explorer (open Windows 
Help, from the Start Menu, and search for the key words “Quick View” for details on installing the 
feature) .    Common choices permit the download of files, and the renaming or deletion of the selected 
files (access rights permitting).    Each of these options are available in the File Menu, and are 
completely described in that section of the help file.    

Link 
Context 
Menu

The file specific and folder specific Link context menus are identical to their parent category context 
menus other than the added Treat Link as …option in the Link context menus.    FTP Explorer does not
search for the target of links that it encounters, so occasionally a link may be listed as a folder when it 
is actually a file or vice versa.    This option permits the user to manually toggle the item’s properties to 
that of a file or directory depending on its existing properties.    See the file and directory sections 
above for the explanation of the other options in the Link menus.    





Transfer Request
Any command initiated by the user to upload, save, or download one or more files to or from the 
remote server.    Transfer requests are carried out one at a time until all are complete.    There can be 
queued transfer requests from more than one server waiting to be carried out, and FTP Explorer will 
retain or make the necessary connections to carry out the requests.    



Default Download Directory
Configurable within the Option Configuration Dialog, the directory in which all incoming files that were 
requested by the "download" command will be placed unless a download path is specified by the user 
or in the connection dialog for the current profile.    



General Options
The General configuration 
options tab contains some of 
the globally active choices 
available within the program.    
All of the features on this tab 
are not required for standard 
program operation, but can 
make commonly repeated or 
tedious tasks more transparent
and generally easier to use.    

Email Address
Enter your email address in the
space provided to automate 
the anonymous login process.   
Whatever information is 
contained in the Email Address
field will automatically be 
placed in the Password field of 
the Connection Dialog when 
the Anonymous login feature 
has been selected.    

Highlight Last Log Entry
This feature will optionally highlight the last entry in the FTP Status Log making the text easier to view 
and follow.    If the check mark appears next to the option, it is active. To enable or disable the feature, 
click the option with the mouse, or press Alt+H, to move to the item, then press the space bar to toggle 
its value.

Enable Sound
This option will enable the default system sound upon connect, and successful download or upload of 
a file or files.    The default error sound will be used to alert you to possible problems with the program. 
To enable or disable the feature, click the option with the mouse, or press Alt+S, to move to the item, 
then press the space bar to toggle its value.

Save window size and position between sessions
This feature directs FTP Explorer to remember the position of each of the panes within the program, 
and the main program location on the desktop, from session to session.    To enable or disable the 
feature, click the option with the mouse, or press Alt+S, to move to the item, then press the space bar 
to toggle its value.    

Include description bar for right and left panes
This option will add or remove the text descriptions of the View Window or "Tree View and the "List 
View" or File View Area panes





Path Options
The default path locations for the 
program can be changed from 
within this tab of the Options 
Configuration Dialog.    

Default Download 
Folder 

This field specifies the default 
directory on your machine that the 
“Save As” dialog will open when 
files are selected for download.    

Folder for 
Temporary Files 

This field points to the location 
where FTP Explorer    places any 
temporary files that it creates, or 
uses.    All files utilized by the 
program that are contained in this 
directory at the time the application 
closes are deleted if the next option 
is enabled.

Clean up temporary directory on shutdown
This option will allow FTP Explorer to delete the files it uses during each session.    It will also delete 
the files downloaded for the "Open" and "Quick View" options.    Clear the option if you wish to maintain
the files in the temporary directory.    

Verify before deleting temporary files
With this option enabled, the program will prompt you before it deletes any of the temporary files that it 
creates or uses during the FTP session.    Use care when disabling this option, as all files in the 
specified temporary directory, whether placed there by FTP Explorer or otherwise, will be deleted 
without notice when the program exits.    

When uploading short filenames
This feature allows FTP Explorer to automatically convert file names if that is desired.    The default for 
this feature is the "Upload filename as is" option, which will upload the files exactly as they are named 
(no case change).    The other two options will convert the file to either lower or upper case depending 
on the selection.    



Connection Options

Show connect…
When enabled, this option will 
automatically display the 
connection dialog at program 
startup.    

Prompt for 
password…

If no password is specified in a 
connection profile, FTP 
Explorer will prompt for the 
password before every 
connection if this option is 
enabled.    This feature was 
added for security reasons.    If 
a password is saved in the 
profile, the value of this option 
does not have any effect.    

Hide files and folders that start with a period
Self explanatory – any files or folders on any connected server that begin with a "."will not be displayed
in either the Tree or List views of the program.    Some servers, by default, do not list files that begin 
with a period.    To view files that begin with a period on these servers, the server must be configured 
appropriately.    

Send keepalive to prevent time-outs
If this option is enabled, FTP Explorer will send commands periodically to prevent the connection from 
timing out due to inactivity.    Take care when using this option if you are charged a per-hour rate for 
your Internet connection.    FTP Explorer will maintain the connection indefinitely when this option is 
selected.    

Default Connection Retry Settings
This group of options allow FTP Explorer to attempt to connect the number of times specified if the 
connection is refused.    The “Timeout attempt after … seconds” field puts a time limit on each 
connection attempt.    The period between connection attempts can be specified in the “Wait… 
seconds…” field.    If the program cannot connect in the number of tries specified, it will write an 
explanation to the FTP Log and stop trying. 



Transfer Options

Autoload File 
Descriptions..

Select this option to 
automatically download file 
descriptions (if available) and
display each file’s description
next to its file name in the 
"List View" or File View Area 
pane.    

..If index file is 
smaller than… 
kilobytes

Use this field to set the 
maximum size of index files 
that the autoload file 
descriptions feature will 
attempt to retrieve and 
display.

Warn on Open or Quick View…
Enabling this option will tell FTP Explorer to send an alert if an attempt is made to "Open" or "Quick 
View" a file that is larger than the value contained in the "..If item is larger than … kilobytes" field. 

Show dialog for items larger than …. kilobytes
This option will automatically display a dialog to ask if you want to download the file instead of "quick 
view" it if the size of the file is greater than the amount in kilobytes entered in this field.    The idea 
behind this feature is that when you are downloading small files, it can take longer to display the 
connection dialog than it does to download the file.    The difference between the “quick-view” 
download versus a standard download is that “quick view” files will be placed in the FTP Explorer 
temporary directory, and may not be saved after the program closes (depending on the setting in the 
Paths tab of the Options Dialog.    Downloaded files will not be deleted.    If you do not want to see this 
dialog, simply put a large value in the field provided.    

Background transfer items larger than … kilobytes
The value placed in this field qualifies the smallest file that will be downloaded in a background thread. 
Files larger than this value will automatically be downloaded in the background, allowing the user to 
continue to browse the current FTP server.    Since downloads are handled in the background by the 
Transfer Manager, the user can actually disconnect from the current server, connect to another, and 
FTP Explorer will continue to download the queued transfer requests.    If this feature is enabled, FTP 
Explorer will attempt to make a separate connection to the host.    Background transfer hinges on 
whether or not the host accepts the additional connection.    If the host does not accept multiple 
connections, or if it has no more connections available, the background file transfer feature will not 



operate properly.    FTP Explorer will notify you if the feature cannot perform as it should.    

Transfer Queued Items
If background file transfers have been enabled, the files that are selected to be transferred can either 
be handled one at a time, or simultaneously depending on the value of this setting.    If you are on a 
slow connection, or do not have a great deal of bandwidth, it is suggested that you use the sequential 
option.    For those who have faster connections, the simultaneous transfer option is extremely useful.    
The maximum number of individual connections can be assigned in the “Limit to maximum of … 
connections” field.    If this field is not enabled, there will be no limit of background connections, only 
bandwidth restrictions.    



How To...

Create a server profile
Download a file from a server
Quick-View a file
Upload a file to a server
Specify the default download directory
Import profile settings from CuteFTP, or WS_FTP
Load alternate language resources



More Information On FTP Explorer

Obtaining FTP Explorer Updates

The latest release of FTP Explorer will always be available at the following sites:    

The FTP Explorer Home Site (U.S.)

http://www.ftpx.com
ftp://ftp.ftpx.com/pub/ftpx/ftpx.zip

Obtaining Alternate Language Modules
Additional language module for FTP Explorer are under development, and can be obtained from the 
“Download It” page of the FTP Explorer web site, or in the /pub/lang directory of the FTP Explorer 
FTP site.    Complete URLs for both are given below.    
ftp://ftp.ftpx.com/pub/lang/
or:
http://www.ftpx.com/

Join The FTP Explorer Mailing List…

if you want to learn more about FTP Explorer, and discuss the program with other users.    Complete 
instructions are on the FTP Explorer     home page  .    There are two lists from which to choose.    The first
is strictly an announcement list that will notify you when updates are available.    The second list is a 
discussion list that you can monitor to find out about problems, work-arounds, or just discuss your 
experiences with other users.    There is no need to join both lists.    If you join the discussion list, you 
will receive both the announcements and general discussion mail.    

Removing Yourself From The Mailing List:    

If for some reason you decide that you don't want to be on either of the mailing lists, visit the FTP 
Explorer   home page  , go to the mailing list page, and fill out the form with the appropriate information.   
Make sure you choose the “Unsubscribe” option.    

IRC Chat Channel

There is an IRC channel monitored by fellow FTP Explorer enthusiasts available at EFnet. 
(irc.ais.net:6665)    Look for group #ftpx.    Feel free to join in and discuss FTP Explorer online.

No, none of those categories covered it!

Anything else about FTP Explorer that isn't covered in this help file can probably be found on the FTP 
Explorer home page:



http://www.ftpx.com

or by contacting Alan Chavis, 



Yes I Need This Software

Online registration via the FTP Explorer SSL site is now available!    Read On! 

Print this form and either fax or mail it with the appropriate payment amount the address printed below 
to receive your software license(s). 

Company - User Name ________________________      Phone _____________________

Address ________________________________________________________________

City _______________________________________      State ______________________

Zip / Postal Code __________      Country __________      Email address_______________

Where did you hear about FTP Explorer? _____________________________________

Card type (Visa, MC, Amer. Exp.)    ____________      Expiration Date_________________

Card Number_________________________      Name on Card______________________

Signature_______________________________________________________________

Multiple license discounts are available for orders of 10 or more.    Site licenses are also negotiable.    
Contact Alan Chavis for more information.

Mail checks payable to:

FTP Explorer
PO Box 20574

Oklahoma City, OK    
73156-0574

Or you may fax this completed form with your credit card order to:    405-348-4753;
Or you may submit your Visa, Mastercard, or American Express credit card orders at the Secure   FTP   
Explorer   Website   (https://www.ftpx.com/cgi-bin/ftpxreg.dll)



Firewall Options

Use PASV Mode
PASV mode is supported as a firewall option.    This feature simply reverses the connection between host 
and server, thus allowing many users that reside behind firewalls to use this program.    PASV mode ftp is 
what most of the browsers like Netscape, and Microsoft use to initiate ftp transfers.    

Use Firewall
If your system resides behind a firewall that limits or restricts FTP access, enable this option and fill in 
the appropriate information for the firewall in use at your location.    Most firewalls require a host name 
and port number (the default port for FTP connections is 21), along with a user ID, and password.    
There are differences in the methods used by firewalls to permit user activity.    The “Firewall Type” box
permits you to select the command required by your firewall when initiating an FTP session from FTP 
Explorer.    If your firewall requires the “User”, or “Open” command (upper or lower case sensitive), 
simply click the appropriate option to enable it.    



File Types

The “Use these filenames as description files:” feature allows you to add to the automatically detected 
index file listing of the program.    FTP Explorer will look for any of the files contained in this list to load 
as the description file for the connected server.    If you connect to a server that has an index file, but 
the file descriptions do not load, simply add the name of the index file to this list, and refresh the listing 
(Context Menu or Tools Menu).    As long as the index file conforms to the “filename – description” 
method of listing its entries, FTP Explorer will recognize the format, and display the descriptions 
properly.    To add an index file to the list, simply type it in the space provided (case sensitive), and 
press the upper Add button.    

Prior to transferring any files, FTP Explorer compares the extension of the filename (if it exists) with 
the extensions in the “Always use ASCII mode for files with these extensions:” list.    If it encounters a 
match, it will automatically switch to ASCII mode before processing the file.    This feature is a 
convenience for transferring files that must be handled in ASCII format.    To add an extension to the 
list, type it in the field provided, then press the lower Add button.    It will appear in the list once it has 
been processed successfully.    



How to create a server profile
1.    Press the Connect button on the Tool Bar or 

choose Connect from within the Tools Menu.

2.    Press the Add button on the Connection Dialog.

3.    Enter a name for the profile.

4.    Enter the host address for the server (can be 
either the DNS entry, or its IP address.    Do not 
put any path information in this field.    It should 
contain the server’s address only.    

5.    Enter the port number on which the server 
accepts FTP requests (the default is 21). 
 

6.    Enable PASV mode if your computer is behind a 
firewall which does not allow external FTP 
connections (see Firewall Options for more 
details).    

7.    Enable the firewall option if your system is 
located behind a firewall.    The settings from the 
Firewall tab of the Options Dialog will be used if 
this option is enabled.

8.    Either type your user name, or check the 
Anonymous option (if an anonymous login is 
used, skip to step number 10).

9.    Enter the corresponding password for the user 
name.    The characters of the password will 
appear as asterisk (*) symbols unless you chose
the anonymous login option in the previous step.

10.    Type the path in which you want to begin. -- This
step is optional.    

11.    Make sure there is a value of at least 1 in the 
attempts field.

12.    If you entered more than 1 attempt in the 
previous step, enter the amount of time the 
program should wait between connection 
attempts here.    

13.    Type in a path for all download to be placed for 
this profile (only used for the download option, 
not the download-to or quick view options – see 



the File Menu for further details).    

13.    Press the Connect button to establish the 
connection to the server.    

Any errors or problems will be reported in the FTP Status Log.    Several of the options listed above 
have default values that can be changed from within the Option Configuration Dialog.    



How to download a file from a server

1.    Connect to a server using a valid server profile or the Quick Connect option.

2.    Navigate through the server’s directories to locate the file that you desire.    Be sure to make use of 
FTP Explorer’s Auto-loading index file feature (Options Dialog)

3.    Select a file by clicking on it.    If more than one file is to be selected, you can “rope” the desired 
files with the mouse if they are adjacent to one another, or you can hold down the Ctrl key on the 
keyboard while clicking individual files to make multiple selections.

4.    Either press the Download button, or use the context menu (right click on a selected file) to choose 
the download option.    The file(s) will be placed in the download directory specified in the server 
profile.    If you want to specify the local directory to place the files, choose the “Download To” option 
instead of the download option.    You will then be prompted for a location for each file that is 
downloaded. 

You can also Drag the selected files from the File View Area onto your desktop, or any other folder to 
begin the download.

Several user-configurable options dealing with the way files are transferred, including background file 
transfers, and simultaneous transfers, can be changed within the Options Configuration Dialog.    



How to quick-view a file

1.    Select the file to quick view on the remote server.    Only those file extensions that have Quick-View 
drivers will display properly.    If there is not a Quick-View driver for the specified file type, FTP 
Explorer will not be able to launch the proper viewer to display the file.

2.    Use the Context Menu (right-click on the file you want to quick-view) to choose the Quick View 
option

3.    After viewing the file, if you decide to keep it, there is no need to download the file again.    FTP 
Explorer keeps all of the files that it quick-views in its temporary directory (configurable from the 
Paths tab of the Option Configuration Dialog).

Note:    If you have chosen the option in the Path Options dialog that clears the temporary 
directory at startup, the files that you quick view will be deleted the next time FTP Explorer 
starts.    Make sure to move any files out of the temporary directory that you intend to keep 
for future use.      



How to upload a file to a server

1.    Connect to the server to which you intend to upload the file(s).    See the How to create a server 
profile section if you do not have a profile    configured.

2.    Choose one or more files to upload from within the Upload dialog.    Select more than one file by 
holding down the Ctrl key on the keyboard, and clicking the files with your mouse.    you can also 
select the files to upload by simply dragging the files onto the File View Area of the screen.    The 
files will be uploaded to the current directory on the server as long as your user account has the 
appropriate clearance to copy files into the selected directory.



How to specify the default download directory

1.    Open the Option Configuration Dialog by selecting Options from the View Menu.

2.    Click on the “Paths” tab.

3.    Fill in the appropriate path information in the “Default Download Folder” field.    Use the Browse 
button if you need to search for, or create a new directory.

4.    Press the OK button to save the change.



How to import profile settings

1.    Select the Import option from the Tools Menu.

2.    Locate the file that you wish to import.    Only one file can be imported at a time.    WS_FTP profiles 
are contained in the file named WS_FTP.INI in the windows directory, and CuteFTP profiles are 
contained in the file named tree.dat which is located in the application directory.

3.    Press the Open button to begin the import procedure. Once the import is complete, a message box 
will appear stating that X entries were imported successfully.



How to load alternate language resources

1.    Retain the desired language module from the FTP Explorer   download page  

2.    Unzip the resource file into the same directory as the executable, and restart FTP Explorer.



Command Line Options

FTP Explorer can be launched from the command line, or from within other programs as long as the 
syntax for the desired connection meets a few simple requirements.

The syntax to launch and connect to an existing profile is:    

ftpx //profile_name!/initial_path

The initial path information is optional, but if included must be separated from the profile name with an 
exclamation point.    

The program will also accept standard FTP URLs from the command line such as:    

ftp://ftp.server.com/path_info/filename

The path information and filename are optional parameters, but if included, the connection will change 
to the path listed, and attempt to download the file.    




