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Install Options - Startup Defaults
You can change the following startup paths or keep the default values.

Fields

Startup Path for Bookshelves and Books 
Specify the path that contains your books and bookshelves. When you start Library 
Reader for Windows, it looks in this path for books and bookshelves.

Specify the full path name, including the drive name. You can list more than one 
path.    Separate paths with semicolons (;), and do not place blank spaces between 
the paths. For example:

 C:\BOOKS;D:\BOOKS;J:\SHELVES 

The default value is the drive and directory that contains the Library Reader for 
Windows product softcopy documentation.    If you also have READ/DOS installed, 
the paths containing your READ/DOS books and bookshelves are also used as part 
of the default path.

Startup Path for Notes 
Specify the path where electronic book notes are stored. You can type in any drive 
and directory that you have write-access to.    If you type a subdirectory that does 
not exist, Library Reader for Windows asks you if you want to create that 
subdirectory.

The default value is the drive and directory that contains the Library Reader for 
Windows program files.    You can safely store notes in the directory containing the 
program files because the notes are not disturbed when you apply maintenance 
updates to Library Reader for Windows.

Note: If you are installing to access Library Reader for Windows from a local area 
network (LAN), the default path is specified by you or your LAN 
administrator.

To change the startup paths at a later time, choose Startup Defaults from the Options 
menu on the Library Reader for Windows menu bar.

Buttons

OK Accepts changes and closes the window

Reset Restores the values in the fields to the default values

Help Displays help for the window



EJRIN001
Explanation:    Library Reader for Windows is unable to run the REGEDIT command.    
Library Reader for Windows uses the REGEDIT command to enable the association of books 
with Library Reader for Windows for Microsoft Windows File Manager or Print Manager.

Response:    You can do one or more of the following:

· If you do not plan to associate books and bookshelves with Library Reader for Windows, 
you can ignore this message.

· To determine the cause of the problem, record the return code and message number, 
and contact your support personnel.

· If you can manually run the REGEDIT command, then you can manually enable Library 
Reader for Windows for file association.

To manually enable Library Reader for Windows for file association, do the following:

1. From the File menu of the Program Manager window, choose Run.

2. Type REGEDIT in the Command Line text box.

3. Choose the OK button.

4. In the dialog box that appears, choose Add File Type from the Edit menu.

5. To enable for association of books, do the following in the Add File Type dialog box:

a. In the Identifier text box, type LRBook.
b. In the File Type text box, type BookManager Library Reader Book.
c. In the Action box, select Open.
d. In the Command text box, type READIBM.EXE /b %1.
e. In the Action box, select Print.
f. In the Command text box, type READIBM.EXE /p %1.
g. Choose the OK button.

6. To enable for association of bookshelves, choose Add File Type from the Edit menu 
again.

7. In the Add File Type dialog box, do the following:

a. In the Identifier text box, type LRBookshelf.
b. In the File Type text box, type BookManager Library Reader Bookshelf.
c. In the Action box, select Open.
d. In the Command text box, type READIBM.EXE /s %1.
e. Choose the OK button.

To associate a book or bookshelf with Library Reader for Windows, do the following:

1. Run File Manager.
2. From the File Manager window, select either a .BOO or .BKS file.
3. From the File menu, choose Associate.
4. In the dialog box that appears, select BookManager Library Reader Book (for .BOO 



files) or BookManager Library Reader Bookshelf (for .BKS files).
5. Choose the OK button.



EJRIN002
Explanation:    Library Reader for Windows is unable to find the registration file.    The 
registration file should be in the same directory as the EJRIL5.EXE file.    Because the 
registration file was not found, book and bookshelf files cannot be associated with Library 
Reader for Windows.

Response:    You can do one or more of the following:

· If you do not plan to associate books and bookshelves with Library Reader for Windows, 
you can ignore this message.

· To determine the cause of the problem, record the return code and message number, 
and contact your support personnel.

· Reinstall Library Reader for Windows.

· Manually enable Library Reader for Windows for file association.

To manually enable Library Reader for Windows for file association, do the following:

1. From the File menu of the Program Manager window, choose Run.

2. Type REGEDIT in the Command Line text box.

3. Choose the OK button.

4. In the dialog box that appears, choose Add File Type from the Edit menu.

5. To enable for association of books, do the following in the Add File Type dialog box:

a. In the Identifier text box, type LRBook.
b. In the File Type text box, type BookManager Library Reader Book.
c. In the Action box, select Open.
d. In the Command text box, type READIBM.EXE /b %1.
e. In the Action box, select Print.
f. In the Command text box, type READIBM.EXE /p %1.
g. Choose the OK button.

6. To enable for association of bookshelves, choose Add File Type from the Edit menu 
again.

7. In the Add File Type dialog box, do the following:

a. In the Identifier text box, type LRBookshelf.
b. In the File Type text box, type BookManager Library Reader Bookshelf.
c. In the Action box, select Open.
d. In the Command text box, type READIBM.EXE /s %1.
e. Choose the OK button.

To associate a book or bookshelf with Library Reader for Windows, do the following:

1. Run File Manager.
2. From the File Manager window, select either a .BOO or .BKS file.



3. From the File menu, choose Associate.
4. In the dialog box that appears, select BookManager Library Reader Book (for .BOO 

files) or BookManager Library Reader Bookshelf (for .BKS files).
5. Choose the OK button.



EJRIN003
Explanation:    Library Reader for Windows is unable to determine if you are installing 
Library Reader for Windows interactively.    This could be due to one of the following reasons:

· There is insufficient memory.
· The Software Installer for Windows application is not installed on this computer.
· The Software Installer application is not running on this computer.

Library Reader for Windows will assume that you are installing interactively and will provide 
dialogs for you to respond to.

Response:    If you want to install interactively, ensure that the Software Installer 
application is correctly installed on your computer and that you start EPFINSTS.EXE.

If you still encounter problems or if you want to install Library Reader for Windows without 
user interaction (non-interactively), record the return code and message number, and 
contact your support personnel.



EJRIN004
Explanation:    Library Reader for Windows detected that you are not running a file locking 
program, such as SHARE.EXE, on your system.    You cannot read existing note files if you do 
not run a file locking program.

Response:    Update your AUTOEXEC.BAT file to include the appropriate file locking 
program. If you are running on a local area network (LAN), contact your LAN administrator to
determine the file locking program to use.



The line at the bottom of the application window that indicates the status of the window and 
the application.    It often reminds you to do things like press F1 for help.



NT is a trademark of Microsoft Corporation.



Microsoft is a trademark of Microsoft Corporation.



Windows is a trademark of Microsoft Corporation.



Use the minus sign that is in the numeric key pad to the right of your keyboard.    If you 
cannot use the numeric key pad, then use the key combination Ctrl+Shift+- from the 
keyboard instead of Ctrl+-.



Use the drag operation to move an item on the screen to another place on the screen.    For 
example, you can drag an entire window, the scroll bar, or the split bar.

To drag:

· Press and hold down the mouse button 1.
· Move the mouse while continuing to hold the mouse button until you have reached your 

destination.
· Release the mouse button.



The text that does not reflow when a window is resized is considered nonreflowable text.    
Nonreflowable text is found in tables, figures, example text, syntax diagrams, and right-
justified text.



The split bar divides the Book window into two parts. The book topics are listed in the 
window on the right. The text itself is on the left. You can drag the split bar in either direction
to adjust the size of the two parts.



Removing a book from a bookshelf does not delete the book from your system.    Only the 
bookshelf entry for that book is deleted. The actual book file remains on your system.    If you
want, you can add the book back to the bookshelf.



A bookshelf is a set of books. A bookshelf does not actually contain books, but simply lists 
them. Therefore, removing a book from a bookshelf does not delete the book; it merely 
removes its name.



A fuzzy search looks for all occurrences of your search word in any form that shares the 
same language root.    For example, if you search for color, it will also find colors, coloring,
and colorful.



An exact search looks for all occurrences of your search word exactly as you enter it.    You 
can choose to make it case-sensitive and also match the capitalization exactly, or you can 
choose not to consider the capitalization.



A bookshelf search index increases the speed with which you can perform a multiple-book 
search on a bookshelf.    A bookshelf search index is created for a specific bookshelf and 
contains all the words in the books that are in the bookshelf when the search index is 
created.

You can create a bookshelf search index using either BookManager BUILD/MVS or 
BookManager BUILD/VM.    Because Library Reader for Windows cannot create bookshelf 
search indexes, you must either use prebuilt bookshelves that you acquire from IBM or other
sources, or build a bookshelf search index using BookManager BUILD/MVS or BookManager 
BUILD/VM.    Library Reader for Windows provides a bookshelf search index for the prebuilt 
bookshelf that contains Library Reader for Windows documentation.



The character used to substitute for unknown or unspecified characters or words in a search 
word or phrase.    An asterisk (*) is an example of a wildcard character. If you search for 
color* you could find colorful, colors, coloring.    A question mark (?) used as a wildcard 
represents only one letter.    In this case, you would only find colors.



Boolean operators (and, or, butnot) are used between words or phrases to make your search 
more precise.



The color refiner box shows shades of colors available to you on your system.    Select 
shades by dragging the cursor to an area of color that you want and clicking mouse button 
1. Use the keyboard to adjust the number for hue and saturation.



Portrait is the way we typically print text; the paper is taller than it is wide.



With Landscape orientation, the text is printed sideways on the page; the paper is wider 
than it is tall.



A picture that is displayed in the topic text rather than in a separate window.



The name of a book or bookshelf is not the same as the title of the book or bookshelf.    The 
name of a book or bookshelf is one of the following:

· The file name of the book or bookshelf
· An 8-character name that is assigned to the book or bookshelf when the book or 

bookshelf is created.



When you associate a file with an application, you automatically start the application when 
you open the file. Associating book or bookshelf files (any file with a file extension of .BOO or
.BKS) with Library Reader for Windows enables you to:

· Open that book or bookshelf directly from Microsoft Windows File Manager

· Open and print that book by dragging it from Windows File Manager to Windows Print 
Manager.




