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Welcome to Build-o-Rama
There are two main parts to this program: The Windows application that provides 

most of the interface, and an OS/2 server that does most of the work. The OS/2 server 
(BILDRAMA.EXE) is started automatically when the Windows program (BUILDER.EXE) is 
started, unless it is already running. The OS/2 program creates a file called FLAGFILE.DAT to 
tell the Windows program that it is up and running; if you experience problems with 
connecting the two programs, try finding and deleting this file.

After the Windows program finds that the OS/2 program is running, it connects to it 
using DDE.

IMPORTANT:    This will only work if the Windows program is running in a WinOS/2 
session that has shared DDE included in the settings.

After connecting to the OS/2 side, the program automatically hooks the messages 
from Microsoft Visual C++ for the menu and toolbar items that start builds. (Compiling a 
single file is not supported in this version).

ALSO IMPORTANT: Build-o-Rama must be running in the same WinOS/2 session as 
Visual C++ for this to work. The easiest way to assure this is to add BUILDER.EXE to your 
Tools menu in Visual C++, providing whatever directory you put these files in as the working
directory.

So, to get things going:
1) Start up Visual C++
2) Start Build-o-Rama for WinOS/2 from the Tools menu.
3) If the server was not already running, wait until you see the status-bar message 

The build hooks are turned on. If the server was running, builds should be enabled on 
startup.

At that point, you should be able to build a project using the Visual C++ build and 
build all commands.

When you use the toolbar buttons or menus in Visual C++, Build-o-Rama checks the 
titlebar of Visual C++ for the name of the makefile to use, and then tries to find it in the 
current directory for Visual C++. If that doesnt work, it then tries to use the Visual C++ 
Project menu to determine the current makefile. If that project information is not correct, 
then Build-o-Rama will check to see if the Build Report (*.BLD) file currently active includes a
valid makefile and directory.

If all of that fails, Build-o-Rama displays a dialog asking for the correct makefile and 
directory.

Once you input this information, then the build should be able to be started. If you 
save the build report for this project and open it again, Build-o-Rama can use the path 
information you entered for future builds.

If you start a build using the toolbar or Builds menu of Build-o-Rama, however, the 
program looks first at the makefile and directory defined for the active Build Report, before  
looking at the Visual C++ information. This way, you can open an old Build Report and start 
a build without opening the project in Visual C++.



What happens

When you start a build, Build-o-Rama will create an hidden object for a VDM that it 
runs the compiler in, with a minimum of    8MB as the    DPMI_MEMORY_LIMIT. You can 
increase this by using the Project Setupdialog BEFORE a build is started; this setting can be 
saved as part of the *.BLD file.

The object is then opened minimized, and the compiler output is piped to the OS/2 
server, which parses the output and sends it by DDE to the Windows side, which displays it.

Some limits

Visual C++ does not know that a build has been done, so the next time you try to 
start the debugger, it may ask you if you want to build affected files. Just say no.

The current    version of Build-o-Rama does NOT close out the OS/2 server when the 
Windows program is shut down. The server will refuse to start another instance of itself if the
Windows program is started again. If the server refuses to start, you may need to shut down 
the WinOS/2 session that was using it and start a new one.

If you experience problems in a given session, try closing out Build-o-Rama and 
shutting down the WinOS/2 session it is running in, including Visual C++, closing down the 
server, and restarting everything. Sometimes you may end up with a phantom WinOS/2 
session that will eventually pop up a box asking about    a lost    DDE connection, at which 
point you can close the session out.

One known problem is if Build-o-Rama for WinOS/2 is shut down and then restarted, it
will not properly communicate with Visual C++ until Visual C++ itself is shut down and 
restarted.

The server
The OS/2 server doesnt have very many commands, but it does allow you to do 

several things:
1) If you restore its window after a build, you will see a listing of    the detailed output 

from the compiler. This may be useful if you are getting unusual error messages. You can 
also save it all to a file.

2) There is also a Stop builds command. This is not the best way to stop a build: 
instead, try switching to the OS2BILD.BAT session from the OS/2 Window List, and then 
issuing a Control C. The Stop command may leave the server in an unusable state; we hope 
to improve this command in the next release.



File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Exit Exits Build-o-Rama .



Build menu commands

The Builds menu offers the following commands:

Enabled Toggles on and off the connection to the OS/2 server and the hooks 
that connect Microsoft Visual C++s menus to the Build-o-Rama 
applications. The build hooks are turned on automatically on startup; 
turning them off may improve performance of Windows applications 
running in the same session if no builds are being done. Toggling this 
option off and then on again may fix some problems with getting a 
build started

Build Starts a build of the current project, the same as the similar menu in 
Visual C++. This will only work if a build has been done previously 
from the Visual C++ toolbar or menus, or the correct directory and 
makefile name have been entered through the Project Setup dialog.

Build All Starts a complete rebuild of the current project. This is equivalent to a
/A on the command line.



Project menu commands

The Project menu offers the following commands:

Setup Displays the Project Setup dialog box, which allows the user to change
or supply the project directory, makefile name, and DPMI Memory 
settings for the current project.



Edit menu commands

The Edit menu offers the following commands:

Copy Copies the currently selected build report line to the clipboard.
Copy All Copies all of the build report to the clipboard. 
Clear All... Deletes the build report, but does not delete the project setup information, such as 

the DPMI Memory Limit, project directory and makefile name



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Next Error Goes to the source file line associated with the next error 
on the build report

Previous 
Error

Goes to the source file line for the previous error

OS/2 Server menu commands

The View menu offers the following commands:

Minimize Minimizes the OS/2 server program, Build-o-Rama/2 (It 
starts out minimized)

Restore Restores the window of the OS/2 server, and shifts the 
focus to that window.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new build report in Build-o-Rama . You do not need to open a 
new report for each build, but you may want to create a new report for each project, so that 
the DPMI memory limit and directory information can be stored for each project from session
to session.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing build report in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.  
See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
The default file extension for build reports is *.bld

Drives
Select the drive in which Build-o-Rama    stores the file that you want to open. 

Directories
Select the directory in which Build-o-Rama    stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document.    Before closing an 
untitled document, Build-o-Rama    displays the Save As dialog box and suggests that you 
name and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, Build-o-Rama    displays the Save As dialog box so 
you can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    Build-o-Rama    displays the 
Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters.    Build-o-Rama    adds 
the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your Build-o-Rama    session.    You can also use the Close 
command on the application Control menu.    Build-o-Rama    prompts you to save documents
with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Copy command (Edit menu)

Use this command to copy the selected line from the listbox (the build report) to the 
clipboard.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Copy All command (Edit menu)

Use this command to copy the all of the build report to the clipboard.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Keys: CTRL+A



Clear    All command (Edit menu)

Use this command to erase all information on the build report. This command will not 
change the makefile path information, so it can be used to reuse an old build report or to get
rid of old error information on a project being built again.

Shortcuts
Keys: ALT+DEL



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Build-o-Rama , such as File Open.    A check mark appears next 
to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Build-o-Rama ,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    Build-o-Rama    displays the Open dialog box, in which 
you can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, Build-o-Rama    displays the Save As dialog box.

Print the active document.

Copy the selection to the clipboard.

    Build the active project

 Rebuild all of the active project



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
Messages about the status of the build will also appear. A check mark appears next to the 
menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Build-o-Rama    window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

Also, messages appear here on the status of the build in progress. The message Server 
Ready indicates that the build is complete, and the OS/2 program is ready to do another 
build.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple document windows to display different parts or views of a document at 
the same time.    If you change the contents in one window, all other windows containing the 
same document reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



1, 2, ... command (Window menu)

Build-o-Rama    displays a list of currently open document windows at the bottom of the 
Window menu.    A check mark appears in front of the document name of the active window.  
Choose a document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Build-o-Rama    and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Build-
o-Rama .



Context Help command 

Use the Context Help command to obtain help on some portion of Build-o-Rama .    When you
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the Build-o-Rama    window, such as another 
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.

The outer set of scroll bars moves the list box and buttons around in the formview. The inner
set are used for scrolling the listbox that displays the build report.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Build-o-Rama    window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    Build-o-Rama    
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    Build-o-Rama    
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the Build-o-Rama window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Project Setup dialog

The Project Setup dialog allows you to enter the directory, makefile name, and the amount 
of DPMI Memory OS/2 should allocate to the project. The directory and makefile name fields 
will be blank if no build has been done while this build report document was active; if a build
has been done, they will be filled in with the information as pulled from Microsoft Visual C+
+s window.

The DMPI Memory limit can be adjusted from a minimum of 8 MB (about the minimum for 
the compiler to function) to the maximum allowed by OS/2: 512 MB. Increasing the memory 
limit from 8 may be necessary for larger projects, and may also improve build speed if the 
computer has more physical RAM. Setting the limit higher may take more memory away 
from other tasks, however, and cause the swapfile to grow.

The best setting will vary with the amount of physical RAM, the size of the project, and the 
need to run other processes at the same time.



Clear All command (Edit menu)

The Clear All command removes all entries from the build report, after prompting the user to
make sure. The project directory, makefile and memory settings are not affected by this 
command, so it can be used to clear out old error information from a build report without 
affecting project settings.

If there is a very large amount of entries in the build report, it may be necessary to clear the 
report before doing another build (the Windows list box is limited in storage capacity).



Cannot find makefile path

Build-o-Rama was unable to find the working directory for this makefile. If you want to enter 
the correct project information, press Yes. Press No to cancel the build.



The Build Report Window

Build-o-Rama uses a list box to display the results of the compiler and other build tools as 
they are run in an OS/2 Virtual DOS Machine. The display is similar to that generated by 
Visual C++ itself during a DOS-Windows compile session.

Double-clicking on a line in the list box that includes an error or warning will open the 
appropriate file in the Visual C++ editor, if Visual C++ is running. The Next Error button will 
find the next error in the list and call up that file; the Previous Error button does the same 
thing, but moving up the list.

The Help on Error button will call up a Windows help topic on the error or warning in the 
selected line of the list box. NOTE: for this to work properly, the help file path entries in 
Visual C++ must be correct..



Build command (Builds menu)

This command will build the project whose Build Report is active. If there is no makefile 
specified yet for the project, the makefile open in Visual C++ will be used. If there is no 
project with valid makefile and directory information open, the user will be prompted for    a 
makefile name and directory.

Shortcuts
Toolbar:

Keys: Shift+F8



Build All command (Builds menu)

This command will rebuild the project whose Build Report is active. If there is no makefile 
specified yet for the project, the makefile open in Visual C++ will be used. If there is no 
project with valid makefile and directory information open, the user will be prompted for    a 
makefile name and directory.

Shortcuts
Toolbar:

Keys: ALT+F8



Restore (Server menu)

This command calls up the BILDRAMA server to the OS/2 Desktop. BILDRAMA normally runs 
minimized, but you can restore its window to view and save the full output from the NMAKE 
session.

Shortcut

Keys: ALT+R





Minimize (Server menu)

This menu item minimizes the OS/2 server if its window is open on the OS/2 desktop. 
Normally, the server can run minimized.

Shortcut
Keys: ALT+M



Enabled    toggle (Builds menu)

This menu item turns on and off the link between Visual C++ and Build-o-Rama. When 
Enabled is checked, menu and toolbar commands from Visual C++ to build a project are 
captured by Build-o-Rama and executed using NMAKE. When it is not checked, the Visual C+
+ commands are not captured. You may want to turn Enabled off if you are using a tool such
as Spy to capture messages while debugging an application, or for better WinOS/2 
performance if you are not building a project.

Shortcut
Keys: ALT+E



Setup (Project menu)

Displays the Project Setup dialog box, which allows the user to change or supply the project 
directory, makefile name, and DPMI Memory settings for the current project. Changes will 
apply to the open Build Report window.

Shortcut
Keys: ALT+S



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>

    




