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Welcome to StockTray

STOCKTRAY - STOCK QUOTE TRACKER AND PORTFOLIO MANAGER

(C) EmTec Innovative Software, 1999

What is StockTray
StockTray is a program that obtains stock quotes from free sources on the internet and displays them in a
compact form on your desktop.    You can use it to monitor stock prices that you are interested in and even
monitor the value of your portfolio in real time.
StockTray allows timed updating of stock quotes (the times and frequency of the updates are 
customizable) and will notify you if the price of a stock moves above or below a predefined target price.
It also supports charts: If you request a chart it will start your web browser and display the chart from the 
internet source that you selected to provide the data.
By organizing the data in user configurable sections you can maintain a watchlist, multiple portfolios, or 
other kind of organization you prefer, eg. current stocks, sold stocks, stocks sold last year, etc.
Good places to learn more about this program are: 

o First Steps/Common tasks/Menu Highly Recommended! 
o Configuring the program 

o Program's limiations 

o Tips/Questions/Problems 

o Ordering StockTray 

o Support and Bug-Reports 

o Author-Contact 

 



First Steps/Common tasks/Item Menu

The first task is to create new entries in the list of shares you are interested in monitoring.    You can put 
these into one predefined section or you can go to the section dialog and add sections of your own 
choice.    For example, you could create a section for your portfolio and a watchlist for other stocks you 
wish to monitor.    Additionally, you could add a section to monitor shares you have sold.    You can select 
individually or for each section which columns (eg. current price, high, low, value of investment, etc.) will 
be visible.

Adding Items and Selecting a Data Source
To add an item select 'Add Item' from the Item menu or from the menu that pops up if you click the 
right mouse button in the list area of the main window. Enter a name for the item to add and select a
type then select a data source from the list.    Each source represents a website on the internet 
where stock quotes can be obtained.    As you scroll through the list a short description of each data 
source will be displayed.    Next to the description is a button which will give you additional 
information about this data source. There is also a button that will start your web browser and show 
you which web page the data source is based.    After you have selected a data source, enter a 
ticker symbol or WKN (German stock id number) the site uses to look up the quote(s).    You may 
then use the button next to that field to view the result page (i.e. the same web page from which 
StockTray will try to read the figures) in your browser. This is useful to see if the site provides quotes
for the security you are interested in.

Working with Sections and Data Columns
Each StockTray section can display different columns (see Description of Data Columns) depending
on your needs.    Eg. you will or will not want to see the current stock price and the prices at which 
you bought or sold a stocks, depending on if you own a stock or if you just watch it.
Usually you will create a section for stocks to watch (with a lot of current information like price, 
change, change % etc), another one for stocks you currently own (eg. with current price, price 
bought) and yet another one for stocks sold (which would not show the current price, but which 
would show the price at which the stock was sold).
You can add, remove and configure sections in the Edit->Sections entry of the main menu (see 
Section List). 

Timing Updates
You can also select if you want timed updates at preset intervals. (see timer dialog).    If you have a 
dedicated internet connection or if you configured StockTray to use a dial up networking entry to dial
out, a timer allows you to update stock quotes periodically (providing everything from updates every 
minute to once a year).

Manual Updates
If you do not want to update the quotes automatically you can mark one or more items (more items 
can be marked, by holding down the Ctrl or Shift key while selecting items with the mouse) and use 
Refresh from the right mouse button menu.    It is also possible to refresh the section currently 
visible or all sections (these functions are also available from the context menu and from the 
toolbar).

Charts
If a data source provides charts, intraday charts, or company profiles, the right mouse button menu 
for all items which are based on this data source will have corresponding menu entries.    If you 
select one of these menu entries, StockTray will use your web browser to show the corresponding 
information.



 



Command line options

When starting the program you can provide the following parameters in the command line: 

/LANG:<code>
Force the program to start in a given language.    Supported language codes are GER for German 
and ENGL for English.
Example: STOCKTRAY /LANG:GER 

/MIN
Start the program with the window minimized. 

 
Alternately, you can specify command line options in Unix style, eg. 
STOCKTRAY -min -lang ger 



Configuration

Topics in this section: 

o Program options 

o Creating and changing items 

 



Program Options

The program's options are subdivided into three topics: 

o General 

o Internet 

o Alert Action 

o Alert Popup 

 



Options -- General

Window always on top
If this option is enabled, StockTray will always stay on top of all other windows on your desktop. 

Automatically adjust width of columns
If this field is checked StockTray will resize the width of columns after every data update to fit the 
new data. 

Data sources to offer
StockTray will not offer data sources that provide data for these markets if you uncheck one or more
of the markets listed here (eg. U.S. users will probably want to uncheck the 'German market' 
setting).    However, this setting does not affect foreign securities -- ie. disabling the 'German market'
will still give you quotes for German securities (ex: SAP) if they are listed on the NYSE or Nasdaq 
and if their quotes are provided by an U.S. data source.
The 'General' checkmark refers to data sources which are not related to a specific market, such as 
lists of stock indexes or currencies. 

 



Options -- Internet

Permanent/dial-up internet connection
Here you select what kind of internet connection you have.    If permanent connection is selected, 
StockTray will assume that it can always access world wide web pages whenever it needs to.
If you select a dial up connection, StockTray will check if the connection is already active before it 
tries to get stock quotes.    If the dial up entry is not active, StockTray will dial out, obtain stock 
quotes and will then immediately disconnect the dial up entry again. 

Get HTML data via proxy
If your internet provider requires you to access the internet through a proxy server, check this option
and enter the proxy's host name or address and the proxy port into the dialog (separate both by a 
colon, eg. proxy.nowhe.re:8080).    If you are not sure about this please ask your internet provider or 
check the Connection or Network/Proxy setting in your Web browser or simply press the Find Proxy 
Setting button in this dialog.
MS Internet Explorer 4.x: Select Properties from Internet Explorers' desktop icon and check the 
Connection setting.
Netscape 4.xSelect Edit -> Preferences -> Advanced -> Proxies. Then check if proxies are enabled 
and if they are, use the View button to see the address and port for the HTTP proxy. 

 



Options -- Alert Action

An item can be set to alert the user every time it is updated and/or every time the price/value rises above 
or falls below a certain target price.
This configuration section allows you to define what happens for update alerts and high/low alerts.
For price updates you can show a message box or a temporary popup window (which is defined in the 
next section).
For high/low alerts you can show a message box and/or change the icon for the item to indicate the 
alerted state.



Options -- Alert Popup

The notification window is one of StockTray's alert options (Note: the text will also be used for the 
Message-Box alert).    It is a window that looks a bit like a Window tooltip and displays a text when the 
data in an item has been updated.    Here you can configure the appearance of this window (font, color, 
position).
The text is an arbitrary message (which will be used for all items) and can contain placeholders for the 
actual data from the item.
If you want the text to be shown in multiple lines use Ctrl+Enter in the text field to start a new line.    The 
placeholders which can be used in the message text are: 

Name Description 
$label The name of the item 
$data The items current price (or value) 

A typical text for an popup window is: 
New Quote!
$label: $data



Creating and changing data items

The item definition is done in up to three steps: 

o General 

o Alert 

 



Edit Item -- General

Name
Enter a name for your item.    The name will be shown in the list and when referencing the item. 

Section
This setting determines in which of StockTray's section the item will be shown. 

Type
An item type.    The type will determine the icon that will be shown in the list. 

Data Source
A source which StockTray will obtain the quotes from.    The sources are basically web pages which 
StockTray will retrieve and analyze. See Data Sources for more information about this. 

More Info
This field will show a short description of the selected data source. If you scroll through the list of 
data sources, this field will be updated immediately. 

Show Page
This button will start your web browser to show the web page where this data source is based.    
This allows you to explore the site and to check to see if it offers the information you need, search 
for a ticker symbol, etc. 

Symbol/Ticker/WKN
Here you enter the value used by the data source to identify your quote.    U.S. data sources 
normally use the ticker symbol, German data sources use a WKN (which is a 6-digit numerical 
identifier for all securities used in Germany).    If you do not know the ticker symbol or WKN you can 
press the Show Page button since most data source web sites have search options.    Some data 
sources (especially German sources) also allow you to select the stock exchange from where a list 
of quotes may be obtained. 

Try
If you entered a ticker symbol/WKN you can use the try button to see if the data source offers the 
quote you are looking for.    Your web browser will start and shows the page that StockTray will 
analyze to obtain the figures for your entry.    Using this button can be useful if you do not get data 
for your value and wish to find out why. 

Timed Update
Here you can select which of the predefined timers, if any, (see timer setup should be used to 
update an item automatically. 

Bought/Sold
The buy/sell section of the item setup is used if you actually own (or owned) the securities the item 
refers to. 

Amt
Amount of shares/warrants/etc. bought. 

Date
Date of purchase/sale in your local date format (depending on your Regional Settings in the 
Windows Control Panel).    Please enter day, month and year.    In Germany this will be 
DD.MM.YYYY, in the U.S. you will use MM/DD/YYYY (unless you configured your system to 
use a different format). 

Price/Item
Price per item in the currency used by the data source which was selected for this item (see 
general item settings). 



Fee
Broker fees and commission for the transaction. 

 

 



Edit Item -- Alerts

Report all changes
If you enable this option every time this item is updated from the data source, StockTray will perform
the alert action defined in the program options.    This way you can keep StockTray in the 
background, while still seeing updated stock prices for items of special interest whenever StockTray 
updates them. 

Alert if price is higher/lower than
If you are not interested in displaying every updated quote but would rather be notified whenever the
items price reaches a certain limit you can define an upper and/or lower limit here.    The action to 
perform when one of the limits is reached is configured in the alert action section of StockTray's 
options menu.
IMPORTANT! Please be aware that this feature is not intended to be used to determine the actual 
purchase or sale.    The reason for this is described in Program's Limitations. An actual purchase or 
sale should ALWAYS be triggered by placing an order ordering through your broker. 

 



Managing Sections

Topics: 

o Section List 

o Section Properties 

 



The Section List

This dialog allows you to manage the sections used to organize your data items. (You can move data 
items between sections by editing them and by changing their section setting;    this is also possible with 
multiple items.)
To add a new section type the name in the field in the lower left corner of the dialog and press the Add 
button.    To change the order of sections or to delete one, mark an entry in the list and press the 
corresponding button.    The Edit button    brings you to the dialog which lets you define the section 
properties (ie. the columns shown in each section).



Section Properties

The section properties dialog allows you to configure the appearance of a section.    You can select the 
data columns displayed in a section (eg. it makes no sense to show buy/sell information in a section that 
is intended to watch securities which you do not yet own) and if the section should show an extra line with
totals.
At the bottom the two lists in the dialog have buttons with arrows which allow you to move a selected 
entry from one list to another.    Additionally, the list of columns to use has two buttons which move an 
entry up and down within the list (in order to configure the order in which the columns appear).
See also: Description of Data Columns 



Managing Timers

Topics: 

o Timer List 

o Timer Properties 

 



Timer List

Timers are used to automatically update items at preset times.    A timer is like an alarm clock that will go 
off at certain predefined times and trigger the update of data items associated with that timer (i.e. which 
have the timer name in their configuration).
An example is to have a timer called Currency-Timer that goes off every night and triggers the update of 
all Currency related data items (after the final fixing).
A new timer is added by entering a name in the field in the lower left corner of the dialog and by pressing 
Add.    Exisiting timers can be modified, renamed or deleted by selecting them in the list and by clicking 
the corresponding button.
For details about how a timer entry is configured, see Setting a Timer. 



Timer Properties

A StockTray timer can tigger updates at a certain time or multiple times a day, either periodically (eg. 
every hour) or irregularly (eg. 12AM and 6PM every Monday through Friday).
To better understand the concept, imagine a timer to be a pattern that does or does not match the five 
elements of a certain time (month, day of month, weekday, hour, minute).    The timer goes off (i.e. 
updates the data items) if all five properties match the current time.    If a property is set to *, it is not 
relevant to your requirement and is ignored.
Here are a few examples: Hour 1; Minute 0; Day *; Month *; Weekday * :    01:00 AM every day.
Hour 6,10,14; Minute 0; Day *; Month *; Weekday Mon, Tue, Wed, Thu, Fri : 6:00 AM, 10:00 AM, 02:00 
PM every Monday through Friday.
Hour 6,14; Minute 0,30; Day 1; Month *; Weekday Mon : 6:00 AM, 6:30 AM, 2:00 PM, 02:30 PM on the 
first of every month, but only if it is a Monday.
Hour 6, Minute 0; Day *; Month 4,6,8; Weekday Monday : 6:00 AM on every day that is a Monday but only
in April, June and August



Miscellaneous Functions

o Editing Multiple Items 

o Item Split 

o Section Export 

o Section Import 

 



Editing Multiple Items

If you mark multiple items and select edit with the right mouse button menu a dialog is displayed allowing 
you to change one or more of the following settings: Section, Data Source, Timer.    This can be used to 
move a list of items into another section or to change the data source for a group of items in one step.
Select which of the settings you want to update in the selected items and then set the values.    Pressing 
OK will modify the values for all selected items.



Item Split

To split a lot into two parts (eg. because you want to sell only a part of the lot) you select an amount to 
split from the item and press OK.    After that, you will find two items with the same properties but with 
modified amount fields in the list.



Section Export

You can export all items in a section to a file for import either in another StockTray (see StockTray import) 
or for import in a spreadsheet program or database that supports CSV format. This feature can be used to
swap stock lists with other users or to allow you to do your own calculations based on StockTray's data.
When exporting for another StockTray, you can suggest a section name under which it will later be 
imported and a description which will be shown before importing the list.    It is recommended to use a file 
extension of '.stk' for the new file (this is the default when importing a section into StockTray).    Please 
note that the exported file will have empty buy/sell and alert information but it will include the column list 
used for the section.
For export in CSV format, you can select to export just the data or to put the column names in the first 
record. The exported file will have the fields separated by semicolons and the the field delimiter will be a 
double quote.    This format can be imported to Microsoft Excel or similar programs by selecting CSV as 
the file type in the program's File Open dialog.



Section Import

If you have a file with exported StockTray items (eg. from a friend who created a list of interesting stocks 
to watch), you can import it into a new section in your copy of StockTray.    Simply select the Import 
function from the menu and select a file to import.
StockTray will show a window with a short description for the file and a recommended section name.    
You can modify the section name which must be a new one.    It is also possible to select a timer setting 
for all imported items.    After you press OK a new section with all the columns that were used in the 
export will appear in your StockTray list.    You can move the items to another section by marking some or 
all of the items with the mouse and selecting the edit function from the menu.



Sources/Columns

o Data Sources 

o Data Columns 

 



Internet Sources for Stock Quotes

StockTray's stock quotes are retrieved from free sources on the internet (like www.quicken.com, 
www.quote.com, www.comdirect.de, etc.) by simulating user input on these pages and analyzing the 
results.
Currently there is not an ideal free source of quotes on the internet so StockTray offers a list of sources 
from which to choose. Some may have fasters servers, others might offer the complete list of data and yet
others will provide charts and company profiles.
Information about each source is shown in the section where the data sources are selected to help you 
find the best source of data. You will probably find your preferred source by trial and error.    
Tip: Make a few copies of a stock you are interested in and use a different data source for each copy and 
compare how fast they update and how the information displayed.
At present there are data sources for the German and the U.S. stock market and over time (and with the 
help of other users) we hope to expand the number of data sources and the markets covered.    If you are 
only interested in one of the markets you can configure the type of sources to offer in the program options
(in the Edit menu).



List of Data Columns

The table below is a list of columns that can be added to a section.    Data for a column will be displayed if
the data source supports it and if it's applicable (eg. there will be no buy price if an item in the section was
not bought).    Please be aware that most data sources support only a subset of information (eg. not all 
offer ask/bid information). 
Column Description 
Amt (Buy) The amount of shares bought. 
Ask The price someone is currently willing to pay for the item. 
Bid The price for which someone is currently willing to sell the item. 
Change Price difference in percent compared to the day before. 
Currency Currency in which prices are listed. 
Date Date of quote. 
Date (Buy) Date when item was bought. 
Date (Sell) Date when item was sold. 
Diff per Share Price difference per share between current price and price bought. 
Fee (Buy) Fees/commission etc. charged when item was bought. 
Fee (Sell) Fees/commission etc. charged when item was sold. 
Gain/Loss% Total profit/loss (including fees) in percent from buying and selling the item. 
Gross Gain/Loss Profit/loss (excluding fees) from buying and selling the item. 
High Highest price today. 
52W-High Highest price during the last year. 
Kassa A special price used in the German market for trading small packets of shares. 
Low Lowest price today. 
52W-Low Lowet price last year. 
Market Market or StockExchange from where the price was obtained. 
Name The name you gave the item. 
Net Gain/Loss Total profit/loss (including fees) from buying and selling the item. 
Price Current price on market. 
Price (Buy) Price for which you bought the item. 
Price (Sell) Price for which you sold the item. 
Source Short identifier for the data source used to obtain the quote. 
Symbol Symbol to identify the security (normally the ticker symbol). 
Time Time of day when quote was obtained. 
Value (Buy) Number of shares multiplied price for which you bought. 
Value (Current) Number of shares multiplied with current market price. 
Value (Sell) Number of shares multiplied price for which you sold. 
Volume Amount of shares traded today. 
Yesterday Price for which item was traded on the day before. 



Other Topics

o Tips/Questions/Problems 

o Program Limitations 

o Ordering StockTray 

o Reporting Ideas, Problems and Bugs 

o About StockTray 

 



Tips/Questions/Problems

Where can I get updates?
Please start your web browser and go to http://www.emtec.com 

How do I order?
Please checkout the Order Form in the Help menu and/or check Ordering StockTray topic in this 
help file. 

How can I start StockTray minimized?
Edit the properties shortcut which you are using to start StockTray and add /min to the command 
line, e.g. c:files.exe /min. 

How can I add columns or sections?
Just go the Edit->Sections menu.    To change the columns in a section, select the edit function 
there. 

How can I show totals?
Go the Edit->Sections menu, select the section for which you want to show totals and edit it.    Then 
check the 'show totals' checkmark. 

How can I print my portfolio?
Use File->Export and export the section in CSV format.    Then load the CSV file into MS Excel or 
another Spreadsheet or database. A built in print function will be added in a later version. 

How can I move items between sections?
Mark the items with the mouse (multiple items can be marked by holding down the Ctrl or Shift key 
while marking them) and either select Move or select Edit from the Menu.    Then check the 'Modify 
section setting' option and select the new section for the items. 

What does <N/A> mean?
<N/A> means 'not available'.    This text is shown in a column if a data source does not provide the 
value (eg. bid/ask data) or if data from a source could not be obtained (because the web site was 
down or does not provide information for the stock you are looking for). 

I get something like <Error-Message> instead of a price?
StockTray uses scripts to obtain data from the source web pages.    These scripts rely on the way 
these web pages are designed. If the provider of the data changes the web pages, web-address or 
layout, these scripts will fail.      Please try another data source and check EmTec's web pages for 
updated data sources (if an update is unavailable, please report the problem to EmTec). 

I configured a section to show totals, but the totals remains emtpy?
Totals are only calculated for some of the columns (mainly those who deal with buy/sell value).    
Maybe your section does not show any of the columns for which totals can be calculated. 

Can I create my own data sources?
You can, and you should.    In fact creating your own data sources is considered a vital feature of 
StockTray.    The sources are stored in *.SRC files in the StockTray SOURCES directory. A 
document describing the data sources is included in every version of StockTray.    Please also look 
at EmTec's InfoTray product for a description of the scripting language and please feel free to 
contact EmTec if you have questions regarding entries in the source definition files.    Please see 
Data Sources for more information about data sources. 

I want to backup my data files
All configuration data is stored in the following files: items.inf, timers.inf, sections.inf, stocktray.cfg.    
All these files are plain text. 

I think I found a bug



See Support and Bug-Reports. 

How can I uninstall StockTray?
Please open the Windows Control-Panel and double click 'Add/Remove Programs'. Then select 
StockTray and click on 'Add/Remove'. 

 



Program's Limiations

As described in Data Sources Stocktray is using free internet services to obtain stock quotes.    Basically 
all these web sites have huge legal statements, disclaiming all liability from and kind of loss or damage 
caused by using the quotes obtained from there and giving no warranty whatsoever.    Also, all these sites 
only offer delayed stock quotes (usually with a delay of 15 to 20 minutes).
Additionaly there can be unexpected problems with the site's server or with your internet connection. And 
last but not least, StockTray heavily relies on the site's page layout; this means that StockTray will report 
incorrect results (or none at all) if the layout changes.
In other words: nobody can guarantee that the data you see in StockTray will be correct.
Never make sales or purchase decisions based on StockTray data alone. 



Ordering StockTray

If you want to order StockTray, please select the Order-Form item from the Help menu or start the 
separate Order application from the StockTray program group.    There you will find all neccesary 
information regarding pricing and payment.
When ordering StockTray, you will receive a license code which turn off the evaluation mode of your 
installed copy of moony.    This license code will work for the current version of StockTray and for all 
versions with the same major version number (e.g. all 1.xx versions).    The idea behind this license 
scheme is to provide users with free bug fixes and minor improvements (like additional configurability and 
improved user interface). However, at some point, EmTec will probably make a new release with major 
improvements and a new major version number.    In this case registered users will be offered upgrades at
a reduced price.

When ordering you can choose from the following options: 

StockTray License
A code to license the program for one machine/user (see important information below). 

Diskette
A 3.5'' disk with the latest StockTray version available. 

 
Important: The display of stock quotes StockTray is based on so called data sources.    These depend on
the layout and technical aspects of the web sites that provide free stock quotes via world wide web.    The 
set of data sources that comes with this software is intended as a starting point for the user to use and to 
evenutally develop his/her own.
Hence it can not be guaranteed that updated versions of the data sources (to reflect changes in the 
underlying web services) can or will be provided with program updates. 
Please see also Author-Contact and How to get support/report bugs. 



Reporting Ideas, Problems and Bugs

If you have questions about ordering/paying the program, please go to Ordering StockTray.

Of course there are no bugs in this program (you probably know the saying "It's not a bug, it's a feature), 
so here is how you ask questions, how to tell us about your ideas or how to report "undesired features" ;-)
First of all, please check out the help text related to your problem (e.g. for a certain option) and also 
browse through Common Questions, to see if the problem is known and if an answer is already provided 
there.
If this does not help, please contact us via email and provide a good description of the problem.    To solve
a problem it is essential for us to be able to reproduce it, so please try out different situations or settings 
(e.g. an problem might only occur the first time after the program was started, or only if a certain feature is
enabled or while there is a lunar eclipse).    Generally, try to figure out what's going wrong and provide as 
many details as possible. 
The email address is stocktray@emtec.com 



About StockTray

STOCKTRAY - Stock Quote Ticker and Portfolio Manager 

All concepts and programming done by Markus Schmidt

StockTray is (C) Copyright 1999 by

    EmTec Innovative Software
    Markus Schmidt
    Waagstr. 4
    90762 Fuerth
    - Germany -

    m.schmidt@emtec.com
    +49 911 7406856
    +49 911 7406857 (fax)

Please see also Ordering StockTray and How to get support/report bugs. 




