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Welcome to Fish!

In today’s hectic world, computers are too often associated with stress, pressure and problems. If it isn’t 
the graphics for the report your boss needed to have done last week, it’s the reservations you made six 
months ago getting eaten by some faceless computer just minutes before you arrive. Here at Tom & Ed’s 
Bogus Software we think the computer’s potential to create a soothing atmosphere is being vastly 
underused.

For this reason, we have created Fish! to bring peace and harmony to your computer. As you work, your 
aquatic friends swim behind your windows to offer their support. At any time, you can take a break and 
enjoy their company.

In addition to making your computer a more pleasant place to work, Fish! will actually help to reduce the 
risk of screen burn-in. If you leave your computer unattended for long periods of time, images left on the 
screen can become burnt into the screen phosphors, leaving a ghost of the image permanently visible on 
your screen. To prevent this, Fish! will cover your screen with the background of your choosing, leaving 
only your aquatic companions to entertain you.



About Bogus

Tom & Ed's Bogus Software was founded in 1988 to accomplish a simple goal: to put "A Fish 
on Every Desktop." Win Fish brings our efforts to the world of Microsoft Windows 3.0. As 
Bogus enters the 90's we hope to give you, our users, "Fish Animation at Your Fingertips."

The roots of Bogus Software extend back even further. Several friends established a tradition
of releasing toys, games and utilities under the Bogus Software name. Several have since 
gone on to be published and sold commercially. Fish! was initially released as a shareware 
program with no real thought of profit. When it started generating mail and reviews in 
magazines, Tom & Ed's Bogus Software was formed to improve and market Fish!. It is a real 
company, pays taxes and everything. When asked how we expect to build credibility with a 
name like Bogus, we explain we're not out to build credibility, we're out to build incredibility.

Of course all of this could not have been accomplished by just two guys, even two guys as 
bogus as Tom & Ed. We'd like to thank the following bogus supporters:

Wes Boyd
Bruce Burkhalter

Kathy Conley
Cathy Joyce

Peter Rinearson
Suzanne Stefanac



Fish Artists!

We are very pleased to be able to ship you fish species other than what Tom and Ed were able to 
create. This collection shows off the capabilities of fish much better than the little stick-figure man Ed 
created or the mutant tang Tom worked on for days.

Darrell Aldrich
CLASSIC cturtle, stingray, whale

Jill Chan (Jill's fish are copyright 1991 by Alki Software Corporation and used here with their 
permission)

MISC alkiperc
PLANES alkichut, alkispin, alkibaln, alkirip
SPACE alkiastr, alkicomt, erth2010, alkicap, alkiurns
TROPICAL alkiperc, alkirain

Kathy Conley
BTRFLIES tortois, emperor, swllwtl, agrias, whtkite, flower
FRESH koi, inazuma
MISC bonsai, koala
SKY firework
SPACE earth
TROPICAL parrot, seahorse, tigrbrb, fairy, lionfish, chromis, newfish

Ed Fries
CLASSIC angel, bigfish, black, lilred, meenie
TROPICAL edfish

David Hairston
CLASSIC mermaid

Cathy Joyce
TROPICAL clown, tang, flame, copper

Dave Leahy
TROPICAL Jimmy

Barry Linnett
CLASSIC diver, jelly, octopus

Hans Spiller
CARS 250gto, cobra, lambo, porsche, porschec, tbird, mg-td
MISC tardis
SPACE projectile, rocket (both based on Kathy Conley fish)



Using the Fish Menu

Click on the desktop and the Fish! main menu will appear. Select an item from the menu to perform the 
specified action.

If you have checked "Double Click for Menu" from the Preferences Dialog, then you'll have to double-click
on the desktop to bring up the Fish! menu.

The items in the Fish! Menu are:

Edit Fish Brings up the Fish Editor.

Preferences Brings up the Preferences Dialog

Screen Saver Brings up the Screen Saver    Dialog

About Displays scintillating information about Fish!

Switch To Brings up the Windows Task List.

Exit Removes Fish! from your system. (You can run FISH.EXE to restart it).



Fish Editor
Use the Fish Editor to customize existing fish s  pecies   or create your own. See Creating New Fish and 
Editing Fish for hints on how to get started.

The Fish Editor Window

The fish editor window contains various items used to edit a fish. The largest feature is the edit area 
which shows an enlarged version of the current frame; it is used for drawing and editing the fish graphic. 
The color palette to the right of the edit area is used to select the current drawing color. The upper right 
corner of the window contains the fish preview area which shows how the fish will appear when 
animated on the screen. Finally, the lower right corner shows the two fish frames. Use this frame 
selector to pick which frame appears in the edit area.

File Menu

New Creates a new, blank fish s  pecies  .

Open Opens an existing fish s  pecies  from the file you specify.

Save Saves the current species to its file.

Save As Saves the current species to the file you specify.

Exit Exits the Fish Editor.

Edit Menu

The Edit Menu contains commands which affect the current selection. The Selection tool from the Tools 
menu is used to change the current selection. If you have not made an explicit selection, the whole frame 
is automatically used.

Undo Reverses the action of the most recent edit operation.

Cut Copies the current selection to the Clipboard and then clears the contents of the current 
selection.

Copy Copies the current selection to the Clipboard.

Paste Replaces the current selection with the contents of the clipboard. This can be used to copy 
on fish frame to the other, move a portion of the frame to a new location, or shrink or stretch a 
portion of the fish. Pasting with a single pixel selected will paste in the contents of the clipboard, 
without stretching or shrinking, with the upper left corner at the selected pixel.

Clear Clears the contents of the current selection.

Flip Horizontal Reverses the contents of the current selection from left to right.

Flip Vertical Reverses the contents of the current selection from top to bottom.

Tools Menu

Draw Turns the mouse into a pencil. Use this to draw in the current color.

Select Turns the mouse into a selection tool (a crosshair). Use this to select an area of the fish 
for the various Edit menu operations.



Fill Turns the mouse into a fill tool (a gas pump). To fill a shape with the current color, click in the 
shape's interior with the fill tool.

Options Menu

Motion... Brings up the Fish Motion Dialog.

Enabled Indicates whether the current fish species is enabled. A fish species is enabled if there is
a checkmark on the left side of the menu item. Fish species which are not enabled will not be 
used to create fish. This makes it possible to temporarily hide a fish species from the tank without 
deleting or moving the fish species file. See Creating a Fish Tank.

Rare Indicates how frequently the current fish species will appear. A fish species with a 
checkmark by this menu item will be shown much less frequently than other species. See 
Creating a Fish Tank.



Fish Motion Dialog

Use the Fish Motion dialog to determine how your fish moves. Fish may move horizontally, vertically or 
diagonally. Horizontal fish may move to the left, to the right or both. Further, they may be constrained to 
stay near the top of the screen, near the bottom of the screen, or in the middle of the screen. Vertical fish 
can move up, down or both and can be constrained the left, right or middle portion of the screen. Diagonal
fish may wiggle up the screen or squirm down.



Preferences Dialog

Number O' Fish

Set the number of fish to be displayed on your monitor. You should have enough fish that you can enjoy 
their presence, but remember that too many fish crowded into a small tank can slow their motion and 
create stress for the fish.

Desktop Fish!

Check this box if you want fish to swim on the desktop. This makes it possible to enjoy Fish! while your 
are working with your Windows applications.

Screen Saver Fish!

Check this box to enable the Screen Saver function of Fish! Bring up the Screen Saver Dialog from the 
Fish Menu to customize the screen saver.

Double Click for Menu

If you check this box, the Fish Menu will come up when you double click on the desktop. If this item is 
not checked, a single click on the desktop will cause the Fish Menu to appear.

Background

You can set the color of the screen-saving aquarium to Black, White or Desktop. Black is the best color 
for preserving your monitor since the phosphors are turned off when showing black. White is also good 
because all of the phosphors are turned on at the same intensity to show white. Finally, you can have 
your desktop pattern fill the screen behind the fish. If you are concerned about your desktop pattern 
becoming burned into your screen, you can change it periodically. This also keeps your fish (and you) 
from becoming bored with their environment.

Fish Directory...

When Fish! is stocking your computer aquarium, it looks for fish species in the directory you specify. By 
putting different kinds of fish species in different directories you can change the appearance of your 
aquarium simply by changing where Fish! looks. To change the directory Fish! uses, click on the "Fish 
Directory..." button and use the handy browser to pick your new fish directory.

Note that whenever you open a fish file in the editor, the fish directory is automatically changed to the 
directory containing that file. Fish! will restock your aquarium when you exit the editor.



Using the Screen Saver

Fish! can act as a Screen Saver to help prolong the life of your computer's monitor. Objects which are 
displayed on the screen for long periods of time can become "burned into" the phosphors in the monitor, 
leaving a faint image behind. To help prevent this, Fish! can replace the image on the screen with a 
constantly changing aquatic display when you leave your machine unattended.

To use the screen saver function of Fish!, bring up the Preferences Dialog dialog from the Fish Menu. 
Check the box "Screen Saver". (To disable the screen saver, uncheck this box.)

Setting Screen Saver Options

To set various screen saver options, such as delay time and password, choose "Screen Saver" from the 
Fish Menu.



Screen Saver Dialog

Sleep Now

Fish! will activate the screen saver immediately when you move your mouse into the "Sleep Now" corner.
The screen saver will stay up until you move the mouse out of that corner. You can change the "Sleep 
Now" corner by clicking in the corner you want in the "Sleep Now" mini-screen of the Screen Saver dialog.

Sleep Never

Fish! will refrain from activating the screen saver when you move the mouse into the "Sleep Never" 
corner. The screen saver will not come up as long as your mouse is in that corner. You can change the 
"Sleep Never" corner by clicking in the corner you want in the "Sleep Never" mini-screen of the Screen 
Saver dialog.

Sleep After...

You can set the amount of time Fish! will let your machine set idle before turning on the screen saver. If 
the screen saver seems to kick in every time you pause working, you may start to feel pressured. Since 
Fish! is supposed to help you relax while working, increase the Sleep After time if this happens. If the 
screen saver doesn't save your screen between tasks, you may want to decrease the Sleep After time.

Password

To prevent others from using your computer when you are away from your desk, enter a password. Once 
the screen saver kicks in, you will have to type in your password to get out of screen saver mode.

If you have specified a password, your machine will appear to get stuck in screen saver mode. To return 
to Windows, simply type in your password. No dialog will appear; if you make a mistake, simply start over.
Once you have typed in the correct word or phrase, Fish! will exit screen saver mode and return control 
to you.

If you forget your password, you can reboot your machine to regain conrol and enter a new password in 
the Screen Saver dialog before the screen saver locks your machine again.

To disable the password protection feature, delete the text in the Password field of the Screen Saver 
dialog.



Creating New Fish

To create a new fish, bring up the Fish Menu and choose "Edit Fish...". The Fish Editor will then appear. 
You are now ready to use the drawing tools from the Tools menu to create a new fish. When you are 
done, choose "Save" from the file menu.

If you already have a fish showing in the editor, choose "New" from the "File" menu to begin a new fish.

Some Fishy Hints...

You probably want to first draw a rough outline of your fish. You will see what you have drawn flash in the 
fish preview area in the upper right corner of the editor window. Since the second frame of you fish is 
initially blank, your fish will appear to blink in and out of existence. To get rid of the blinking, select "Copy" 
from the "Edit" menu, select the second (currently blank) frame in the lower right hand portion of the editor
window and then select "Paste" from the "Edit" menu.

You will probably want to refine your initial sketch and give your fish life by making its fins, eyes, mouth or 
other bodily parts move. To do this, you may want to finish the first frame, then copy it to the second 
frame and alter it slightly. Alternatively, you may want to work on the two frames together. The former 
method works well for fish that move only slightly and the latter method works well for fish which change 
dramatically between the two frames.

As with any work you do on a computer, be sure to save your fish often. If your computer loses power, 
you will lose any work you have done since the last time you saved your fish. The first time you choose 
"Save" from the "File" menu, you will be asked to specify a directory and file name for your fish file.

You may want to edit your fish in several sessions; see the Editing Fish topic for instructions on how to 
edit an existing fish. See also the Fish Editor.topic for detailed infomation on using the Fish Editor 
commands.



Editing Fish

To edit an existing fish, bring up the Fish Menu and choose "Edit Fish...". The Fish Editor will then appear.
From the "File" menu choose "Open...". You can then enter the path to the directory containing the fish file
you wish to edit. Once the correct directory is selected, the fish files in that directory can be previewed by 
selecting each fish's file name. Once the fish file you wish to edit has been selected, press the "Open" 
button.

The fish you selected will now appear in the editor. The first frame of the animated fish will appear in the 
magnified edit area. Both graphic frames appear in the frame selector in the lower right corner of the 
window. To change to the other frame of the animation, click on it in the frame selector. The newly 
selected frame will then appear in the magnified edit area. The fish preview, in the upper right corner of 
the window, shows both fish frames drawn alternately to show what the fish will look like when animated 
on the desktop.

You can edit the graphic in the frame you selected by picking a color from the color palette and drawing in
the magnified edit area with the mouse. Drawing with "Clear" from the color palette will cause the desktop
pattern or color to show through that portion on the graphic frame. A "New" fish starts out being 
completely Clear.

The "Tools" menu lets you select from 3 tools: the "Draw" tool (a pencil), the "Select" tool (a crosshair), or 
the "Fill" tool (a gas pump). The drawing tool lets you draw in the selected color. The select tools lets you 
copy and paste portions of the fish graphic. The fill tool lets you fill in enclosed areas with the color you 
choose.

Once you are satisfied with your fish, choose "Save" from the "File" menu. If you don't want to change the
fish file you originally opened, choose "Save As..." from the "File" menu and supply a new name or 
directory location for your altered fish. If you created a "New" fish you will be asked to supply a name and 
directory for your new fish file when you choose "Save" or "Save As..."

To reverse all or part of your fish, use the "Select" tool to pick the area you want to reverse, then choose 
"Flip Horizontally" or "Flip Vertically". If you have the "Draw" or "Fill" tools selected, the Flip commands will
flip the entire fish.

More Fish Options...

The "Options" menu lets you customize how, when and where your fish appers. Select "Motion" to bring 
up the Motion Dialog which lets you change the way your fish moves. If your fish has a checkmark next to
the "Enabled" menu item, it can be used when Fish! is stocking your aquarium. If the fish species is 
enabled, checking the "Rare" menu item will make it appear less frequently than other fish species in that 
directory. (Selecting a checkmark menu item will add or remove the check.)

See the Fish Editor topic for more information about the commands available from the Fish Editor.



Creating A Fish Tank

A Fish Tank is a collection of fish species files, "*.FSH" files, in a DOS directory. The current fish directory 
is set in the Preferences Dialog.

When Fish! fills your desktop aquarium, it selects fish from the species in the current fish directory. 
Whenever a fish swims off of the screen, it is replaced with a new fish chosen at random. Only fish which 
are "Enabled" will be used. Fish which are "Rare" will be chosen much less frequently than others in the 
same directory. You can set these attributes in the Fish Editor.

If it seems that a particular fish never appears, it might not be "Enabled" or it might be "Rare". Also, there 
may be too many fish in the current directory for all of the fish to appear regularly. In that case, disable 
some of the fish or move some of the fish files out of that directory.

As you create and acquire new fish species files, you will probably want to group them into different 
directories. To create a new directory, use either the Windows File Manager or DOS commands. You can 
then move fish files into that directory, again with either the File Manager or DOS commands. See the 
Windows help or your DOS manual for more infomation.



Fish Species

A fish species specifies the graphic images to be used when displaying the fish, and also motion 
characteristics which determine how and where fish of that species move. Each fish consists of two 
images which are drawn alternately to give a two-frame animation which can be used to create a 
swimming motion. Fish species are stored in .FSH files.



Desktop

The area of your computer screen behind all of your application windows. If you have an application 
maximized, then the desktop is hidden.



Double Click

To click twice quickly in the same spot. The Windows Control Panel lets you set adjust what "quickly" 
means.



 


