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The Index contains a list of all Help topics available for the Help Example. For information on 
how to use Help, press F1 or choose Using Help from the Help menu.



File Menu

The File menu currently only allows you to clear the Wbar work area of any barcodes 
and to exit the program. Future versions will allow you to save a barcode to a file and to 
print directly to the printer.

For more information, select the File menu command name.

New
Exit



Edit Menu
The Edit menu allows you to copy a bitmap barcode to the clipboard, paste a copied 

bitmap barcode into the Wbar work area, and to clear the work area of any barcodes.

For more information, select the Edit menu command name.

Copy
Paste
Clear



Action Menu
The Action menu allows you to toggle between Barcode mode and Select mode.

For mode information, select the Action menu command name.

Barcode
Select



Type Menu
The Type menu allows you to change various aspects of bitmap barcodes, and to 

toggle the Autometa feature on or off.

For more information, select the Type menu command name.

Color
Monochrome
Autometa



Special Menu
The Special menu allows you to select which barcode dialog box to use when creating

a barcode. You can choose between Default, Bookland, and FIM barcodes.

For more information, select the Special menu command name.

Default
Bookland
FIM



Glossary
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metafile
select tool
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Code 128



Copying to the clipboard
You can copy a barcode to the clipboard in one of two ways. You can select an area of

the screen to be copied, or you can merely use the autometa feature. To select an area of 
the screen, choose the select tool from the Action menu. The cursor will take on the shape of
a crosshair. Position the crosshair to the upper left corner of the area you wish to select, 
press and hold the left mouse button, and drag a box to the lower right corner of the area 
you wish to select.    At this point you can release the left mouse button. You should now 
have a single line box surrounding the area or barcode you selected. To copy the selected 
region to the clipboard you click on the Copy command from the Edit menu. This will copy 
the barcode to the clipboard in either a color or monochrome bitmap form, depending on 
which bitmap form you have chosen on the Type menu.

In the Autometa mode, once you have produced a barcode on the screen, a metafile 
representation of the barcode will automatically be placed to the clipboard.



Producing a barcode

When WBAR is first loaded, the About Wbar Dialog Box appears if you have an unregistered 
copy of Wbar, otherwise you are presented by blank window. The cursor takes on the shape of a barcode 
while in the workspace of the WBAR window. To make a barcode, you simply position the cursor in the 
window where you want to place the barcode and click the left button on your mouse. A dialog box will 
appear allowing you to toggle various options, select what type of barcode to produce and to input the 
barcode data. After all this is done, clicking on OK will produce the desired barcode on the display. If you 
have the AutoMeta mode ON then a metafile of the barcode is copied to the clipboard. If you wish to copy
a bitmap representation of the barcode to the clipboard, you then choose the Action Select command and
select an area of the screen or barcode to copy to the clipboard. 

For more information on copying to the clipboard click HERE



Exiting

You can exit Wbar in one of three ways. You can choose the File Exit command from 
the Wbar menu. Click on the Control-menu box in the upper-left corner of the window and 
choose Close from the menu, or merely double-click on the Control-menu box.



File New Command
The New command on the File menu clears the WBAR work area of any barcodes. It 

does not clear anything that may have been copied to the clipboard. This command provides
the same function as the Edit Clear command.



File Exit Command
The Exit command on the File menu closes the WBAR window and exits the 

application. Any data left in the windows clipboard will remain.



Edit Copy Command
The Copy command on the Edit menu copies the area selected using the select tool, 

to the clipboard in bitmap format. 



Edit Paste Command

The Paste command on the Edit menu is used to paste a bitmap barcode to the upper
left corner of the WBAR window. Useful if you need to know what the clipboard data looks 
like without leaving WBAR. You could just leave a copy of the Windows Clipboard viewer 
running along with WBAR to achieve the same effect.



Edit Clear Command

The Clear command on the Edit menu clears the WBAR work area of any barcodes. It 
does not clear anything that may have been copied to the clipboard. This command provides
the same function as the File New command.



Action Barcode Command

The Barcode command on the Action menu selects the barcode tool. This tools is 
represented by a cursor in the shape of a barcode. With this cursor visible, a click of the left 
mouse button will bring up a dialog box requesting various barcode info. Upon completing 
the dialog box, a barcode will be displayed in the position that the mouse was first clicked.



Action Select Command
The Select command on the Action menu selects the select tool. This tool is 

represented by a cursor in the shape of a crosshair. With the select tool, you can draw a box 
around an area of the screen in order to copy the boxed in area to the clipboard. To draw a 
box with the select tool, postion the crosshair cursor to the upper left corner of the area you 
wish to select. Press the left mouse button and with the button depressed, drag the box to 
the lower right corner of the area you wish to select and release the left mouse button. 



Type Color Command

When the Color option is checkmarked, any copies to the clipboard will be in a color 
bitmap format. Useful for applications that can accept only color bitmaps. Selecting the 
Color option will uncheck the Monochrome option.



Type Monochrome Command

When the Monochrome option is checkmarked, any copies to the clipboard will be in a
monochrome bitmap format. Useful for applications that can accept only monochrome 
bitmaps. Selecting the Monochrome option will uncheck the Color option.



Type Autometa Command

When the Autometa option is checkmarked, any barcodes produced in the WBAR 
window will be automatically copied to the clipboard in the Windows Metafileformat. Very 
useful to produce barcodes of exact size regardless of the type of display resolution. Also the
best way to paste barcodes into Corel Draw 2.0 and produce POSTNET barcodes suitable for 
printing on envelopes.

Note: Metafiles pasted into other applications may not look correct on the display, but 
should print correctly.



Special Default Command

With the default option checked, the default barcode dialog box will be used to
input various barcode options.    With the dialog box you can choose among the following 
barcodes.

UPC-A
UPC-E
3 of 9
Interleaved 2 of 5
POSTNET
EAN 13
EAN 8
Codabar
Code 128

Note: UPC-E is currently not supported but will be in the near future. 



Special Bookland Command

With the Bookland option checked, the Bookland EAN barcode dialog box will be used 
to input various barcode options such as ISBN number and book price. Bookland EAN 
barcodes are typically found on or in most books sold today.



Special FIM command

With the FIM option checked, the FIM barcode dialog box will be used to input various 
barcode options.    With the dialog box you can choose among the following barcodes.

FIM A - Courtesy Reply Mail with POSTNET
FIM B - Business Reply, Penalty or Franked Mail without POSTNET
FIM C - Business Reply, Penalty or Franked Mail with POSTNET
FIM D - OCR Readable Mail without POSTNET (usually used on courtesy reply window envelopes)



The clipboard is a storage area for information copied or cut from any Windows application. 
This information can be text, graphic image, or screen capture.



A bitmap is an array of bits where one or more bits corresponds to each pixel ,or dot, on the 
display screen. Thus a bitmap is a complete digital representation of a picture, where each 
pixel in the image corresponds to one or more bits in the bitmap. A bitmap can exist in 
memory or be stored on a disk as a file.



A dialog box is an additional window in an application usually requesting additional 
information. This information can be in the form of push buttons, check boxes, and text entry
fields.



A metafile stores pictorial information as a series of Graphic Device Interface (GDI) calls, 
such as MoveTo, Rectangle, and LineTo. A metafile is thus a description of a picture rather 
than a digital representation of it. A metafile can exist in memory or be stored on a disk as a 
file.



The select tool is a crosshair cursor used to select, or box an area to be copied to the 
clipboard.



UPC-A
Universal Product Code version A. Commonly used in the supermarket industry since 

1973. UPC is a coding system as well as a symbology, used to identify a product and its 
manufacturer. UPC-A is a fixed length numeric barcode which encodes 12 digits.

0    04560    17100    8

The first digit is the indeustry code. For example, 0 is grocery and 3 is 
pharmaceutical. Digits 2 thru 6 specify the manufacturers product number. Digits 7 thru 11 
contain the manufacturer ID number. The remaining 12th digit is a check digit calculated 
from the preceding digits.



UPC-E
Currently not available in this version of WBAR.



Interleaved 2 of 5

A variable length, high density code containing the digits 0 thru 9. Because of the nature of coding
Interleaved 2 of 5, data contained in the barcode must be an even amount of digits.



3 of 9

An alphanumeric code consisting of the upper case letters "A" thru "Z", the digits "0" thru "9", and 
the characters "-", "+", ".", "$", "/", "%" and the space character. It is of a variable length and can contain 
up to 100 charcters in this version of Wbar.



POSTNET
The POSTNET bar code was developed by the Postal Service to provide a system of 

encoding Zip Code information on letter mail, which can be read reliably by relatively 
inexpensive bar code sorters. The code is made up of binary elements printed in the lower 
right corner of the mail peice as tall and short bars representing the Zip Code or Zip+4 code.

The location of the complete Zip+4 is very presice. The baseline of the code should 
be 1/4" (+/- 1/16") from the bottom edge of the mail piece. The start (left-most) bar should 
lie between 3 1/4" and 4" from the right edge of the mail piece. 



Codabar
Codabar is commonly used in libraries, blood banks and air parcel express 

applications. It comprises 16 characters, the numbers "0" through "9" and the characters 
"$", ":", "/", ".", "+", and "-". There are four different start/stop codes "A", "B", "C", "D". In 
this version of Wbar only the start/stop sequence "AsomedataB" will be recognised and 
displayed correctly. 

Example:
"A$12345B"



EAN 13
European Article Numbering barcode 13 digit. Simular to the UPC-A barcode in height,

width and number of bars. It does however allow a 13th digit to be encoded into the 
barcode. The entire code comprises 12 user digits plus an EAN checkdigit. Keep in mind that 
EAN scanners can read EAN and UPC barcodes, but a UPC scanner might not be able to read 
an EAN barcode.



EAN 8
European Article Numbering barcode 8 digit. Same characteristics as the UPC-A 

barcode, but is smaller and allows only 7 user digits and an EAN check digit.



FIM (Facing Identification Marks)

Facing Identification Mark patterns are typically used on reply mail envelopes and cards to further help 
the Postal Service in sorting mail. Currently there are four different patterns made up of a 9-position 
bar/no-bar pattern. There are position requirements for FIM patterns. Obtain Postal publication #25 for 
details.

FIM A - Courtesy Reply Mail with POSTNET
FIM B - Business Reply, Penalty or Franked Mail without POSTNET
FIM C - Business Reply, Penalty or Franked Mail with POSTNET
FIM D - OCR Readable Mail without POSTNET (usually used on courtesy reply window envelopes)



Code 128
Code 128 was introduced in 1981 as a very high density alphanumeric symbology. It 

is a variable length, continuous code employing multiple element widths. Code 128 has 3 
different character sets. In this version of WBAR, only character set B is used. Character set 
B contains the full ASCII set of printable characters.


