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Overview
Visual Forms for Windows is an interactive Form designer for the Windows 

programming enviornment.    A Form, in this context, refers to the portion of a viewed or 
printed document that is static, or does not change at runtime.    Both Visual Basic and a 
number of other Windows development environments use the term Form in other contexts, 
including the screen display, dialog boxes, etc.    A Visual Forms for Windows Form is 
created at design time (as its appearance being static, is known), with no programming.    It
is a fast, efficient way to develop the static portion of your output; and, since the forms are 
stored as Windows MetaFiles, makes your code small, efficient, and easier to maintain.

Visual Forms for Windows can also help you design the runtime (or data) portion of 
your output.    If you are using PrintWorks to display or print your document, you can use 
Visual Forms for Windows to create a Data Template that will be automatically filled in with 
formatted text at runtime.    Design your Form once in Visual Forms for Windows, and you 
can display it on any monitor and print it on any printer with no programming.    In addition, 
it uses Windows API commands, store in a MetaFile to produce the image.    This is many 
times faster than using controls, and helps conserve resources.

The Visual Forms for Windows interface works similarly to Visual Basic's form 
designer and Visual C++'s App Studio.    However, instead of adding controls to create text, 
line, graphics and data fields, you add graphical Objects.    These Objects are converted to 
API commands when you generate a MetaFile.    Otherwise, creating Forms is very much like
Visual Basic and Visual C++'s App Studio.

Creating a Visual Forms for Windows Form involves the following steps:

1.    Create a new Form
2.    Add various graphics and text Objects
3.    Create a MetaFile

Creating a Form is as simple as selecting New from the File Menu, picking a file 
name, and specifying the page size and units.    All Visual Forms for Windows dimensions 
are in inches or centimeters, based on the full size printed page.    To add Objects to your 
Form, click on the toolbar or use the Tools Menu to select a tool for the Object Type you 
want.    A Properties Window is available for you to customize each Object.    When the Form 
is complete, use the File Menu to create a MetaFile, and the Form is ready for inclusion in 
your application - with no programming.

Creating a Data Template is equally simple.    Create Text Objects setting the Replace
Property to indicate the Object is a data field.    From the File Menu create a Data Template 
file, and you're done.    To make development of Data Templates easy, a number or options 
are available for displaying and/or printing the data fields while working on the Form.



Moving Objects
Objects can be moved, or re-positioned in several ways:

1.    Dragging selected objects with the mouse 
2.    Changing the values of X Pos and Y Pos in the Properties Window
3.    Using the cursor keys to move one pixel at a time
4.    Using the Alignment Tools

The Focus Object may be moved by dragging the cursor when it is inside the 
bounding rectangle (indicated as a green cross hatch).    The cursor takes the shape of a 
four-pointed arrow, indicating you can drag the object.    When you drag the Focus Object, 
other Selected Objects are moved in relation to it.    Visual Forms for Windows will not allow 
an object to placed partially (or, completely) off the page.

You may move the Selected Objects using the cursor keys (up, down, left and right). 
Each time you press a cursor key, the Object(s) move 1 pixel (1 / 300th of an inch).    At 
some zoom levels, there may be no apparent movement on the screen because 1 screen 
pixel may represent several pixels.    Keep an eye on the Properties Window, which will be 
updated with every move.



Re-Sizing Objects
Objects can be re-sized, or stretched in several ways:

1.    Dragging selected objects with the mouse 
2.    Changing the values of Width and Height in the Properties Window
3.    Using the shift+cursor keys to stretch on pixel at a time

Objects can be stretched horizontally (Width Property) and/or vertically (Height 
Property), with the exception of a Bitmap Object that does not have the Allow Re-Size 
Property checked.    A Horizontal Line Object cannot be stretched vertically because it has 
no Height Property; and, a Vertical Line Object cannot be stretched horizontally because it 
has no Width Property.

To stretch Selected Objects using the mouse, the cursor has to be placed in a 
stretch zone, which are the right side of the focus rectangle for horizontal stretching; and, 
the bottom of the focus rectangle for vertical stretching.    Hold the left mouse button down,
and drag the focus rectangle to stretch the Object(s).

You may also stretch Selected Objects using the shift key and cursor keys.    These 
keys cause the following actions:

Shift + Left Increases Width Property 1 pixel
Shift + Right Decreases Width Property 1 pixel
Shift + Up Decreases Height Property 1 pixel
Shift + Down Increases Height Property 1 pixel

Keep in mind that the height of the focus rectangle for Text Objects represents the 
line spacing for successive lines of text, not the height of the characters.



Keyboard Keys
In addition to the standard keyboard combinations for menus and other controls, 

Visual Forms for Windows implements the following shortcut keys:

Enter toggles between Properties Window and main window (displays 
Properties Window if it is hidden)

Ctrl+Enter hides the Properties Window

Left Moves Selected Object(s) 1 pixel to the left
Right Moves Selected Object(s) 1 pixel to the right
Up Moves Selected Object(s) 1 pixel up
Down Moves Selected Object(s) 1 pixel down

Shift + Left Increases Width Property of Selected Object(s) 1 pixel
Shift + Right Decreases Width Property Selected Object(s) 1 pixel
Shift + Up Decreases Height Property Selected Object(s) 1 pixel
Shift + Down Increases Height Property Selected Object(s) 1 pixel



Files
Visual Forms for Windows deals with five types of files:

1.    Project Files
2.    Data Template Files
3.    Font Lists
4.    Bitmap Files
5.    MetaFiles

A Project File (usually with VFW extension), is a proprietary file format used only by 
Visual Forms for Windows.    It contains all the information about a particular Form.    This file
is never distributed with your application.    

A Data Template File is a special version of a Project File, that contains only 
information about the Text Objects that have been defined as data fields.    This file must be
distributed with your application to instruct PrintWorks how to fill in runtime data.

A Font List is a proprietary file format containing specifications about all the fonts in 
your Form.    It is loaded into Visual Forms for Windows when the Form is loaded.    It is 
distributed with your application only if you have defined a Data Template for use with 
PrintWorks.    Otherwise, it is not needed.

Bitmap Files are standard Windows device independent bitmaps (usually having the 
DIB or BMP extension).    To display a Bitmap Object in Visual Forms for Windows, the source
bitmap file must be in the Windows device independent format.    Bitmap Files do not have 
to be distributed with your application because they are included in the MetaFile 
representing the Form.

Visual Forms for Windows generates a Windows MetaFile and/or Aldus Placeable 
MetaFile for your Form.    This is a device independent format that can be used in any 
Windows application supporting MetaFiles.    The MetaFile contains the actual image of your 
Form and must be distributed with your application.    (Note:    It is possible to create a 
"blank" Form, for the purpose of creating only a Data Template.    In this case, you would not
need to distribute a MetaFile).



Fonts

Visual Forms for Windows uses TrueType fonts to render all Text Objects (including 
data fields).    In order to simplify the management of many potential typefaces and font 
characteristics, Font Lists are used.    Each Form is associated with one Font List, that 
contains the specifications for all the fonts used in the Form.    Every font used in the Form 
must be included in the Font List; however, not every font in the Font List need be used.    In
addition, a Font List may be used for one or many different Forms.

Use Font Manager to create and edit Font Lists.    You may change the characteristics
of a font at any time.    When you do, all Text Objects that use that font will be updated 
immediately.    Be careful about editing fonts in Font Lists that are used for more than one 
Form, so that you don't inadvertently change the appearance of another Form.    It is 
recommended that if you wish to use one Font List for more than one Form, you do it for 
related Forms.

When your Form is distributed, in MetaFile format, the Font List is not required 
because all the font specifications are included in the MetaFile.    If you are using the Data 
Template feature of Visual Forms for Windows with PrintWorks, the Font List is required.

When building Font Lists, consider the availability of the fonts you choose with 
likelyhood the same fonts will be present on the machines of those using your application.   
If a specified font is not present, Windows makes a substitution, based on the closest match
of existing fonts.    This can produce undesirable results.    It is best to use commonly 
available fonts; or, obtain a license to distribute the fonts you use.    As an alternative, you 
could specify specific third party fonts that are required to use your application.    It is 
recommended you print your Form from a machine having limited fonts installed to observe
the results.



Data Templates
Data Templates are an extremely powerful feature of Visual Forms for Windows.    It 

allows you to visually decide where runtime data will be placed on your Form (to fill it in), 
and what the font characteristics will be (this is why the Font List must be distributed).    In 
order to use the Data Template capability, you must have PrintWorks, a custom control 
distributed by Bytech Business Systems, Inc.    PrintWorks contains properties for easily 
filling in the data portion of your form with properly formatted text, without any 
programming.

Creating a Data Template is very easy and involves the following steps:

1.    Add a Text Object to your Form
2.    Click the Styles button on the Properties Window
3.    Check the "Replace text at runtime (data field)" check box
4.    Save the Data Template by selecting the "Create Data Template File" item from 

the File Menu

A Data Field is simply a Text Object with the Data Field style set.    The Data 
Template file is a list of these Data Fields.    Specifying a Text Object as a Data Field means 
that it won't appear as part of the Form (and is not a part of the MetaFile).    Therefore, you 
must distribute both the Data Template file and the Font List so PrintWorks can properly 
add the data to the Form at runtime.



File Menu
The File Menu contains items for managing Visual Forms files (except for Font Lists), 

printing and exiting.    Font List files are managed from the Fonts Menu.

Select a File Menu item for Help.



Edit Menu
The Edit Menu contains tools for manipulating specific properties of one or more 

Objects, copying and deleting Objects, and editing the page layout.

Select an Edit Menu item for Help.



View Menu
The View Menu is used for configuring Visual Forms main window and for controlling 

the Zoom Level of the current form.

Select a View Menu item for Help.



Tools Menu
The Tools Menu and corresponding toolbar buttons allow you to select an Object 

Type to add to your Form.    Also, the Pick Tool can be chosen to Select Objects.

Select a Tools Menu item for Help.



Filters Menu
The Filters Menu allows you to designate an Object Type for selection.    When a 

particular filter is chosen, only Objects of that type may be Selected.

Select a Filters Menu item for Help.



Fonts Menu
The Fonts Menu contains items for creating and managing Font Lists.

Select a Fonts Menu item for Help.



Alignment Tools
The Alignment Tools are used to re-position one or more Objects.    If only one Object

is selected (i.e. the Focus Object), then only the Align Center tool is available.    If more than
one Object is selected, they may be centered with the Align Center tool, or aligned with the
Focus Object.



Align Menu
The Align Menu contains tools for aligning one or more objects.    Only the Align 

Center menu item (or toolbar button) is useful for a single Selected Object (i.e. the Focus 
Object).    The other alignment tools require more than one object, and the Selected Objects
are aligned relative the Focus Object.

Select an Align Menu item for Help.



Help Menu
The Help Menu launches Visual Forms Help, or displays the Visual Forms About Box.

Select a Help Menu item for Help.



New File
The New item in the File Menu creates a new Visual Forms Form.    Enter a name for 

the file (usually with a VFW extension).    A VFW File containing a blank form will be created. 
Next, the Page Layout dialog box will appear.    Enter the dimensions of the page and the 
units (inches or centimeters).



Open File
The Open item in the File Menu loads a VFW File for an existing form, allowing you 

to edit, view or print.



Save File
The Save item in the File Menu saves the current Form as a VFW File.    It works in 

conjunction with the Edit Restore to allow restoring your Form to the last saved version.    
While you are designing a Form, save it often.    You may even wish to use Save As at 
certain points, particular when major portions are complete.



Save File As
The Save As item in the File Menu makes a copy of the current Form (typically a 

VFW File) with a new file name.



Print
The Print item in the File Menu invokes the Windows print dialog box for printing.    

The Form will be printed along with the Data Fields, depending on the Field Display Options 
selected.    The Print menu item prints directly from Visual Forms for Windows.    To display 
or print the form from other applications, create a MetaFile from the File Menu.



Print Setup
The Print Setup item in the File Menu invokes the Windows print setup dialog box so 

you can change printers or printing options.



Field Display Options
The Field Display Options dialog box contains options for displaying or printing Data 

Fields while working in Visual Forms for Windows.    The options include what text, if any, is 
displayed; and, whether the field is grayed and/or has a border.    Click on the options in the
graphic for more detail on each option.



Sequence Number Data Field Option
When Sequence Number Data Field Option is selected, the numerical number 

representing Data Field is displayed or printed.    This is useful if you are filling the data in 
the fields by referencing the sequential number.    Data Fields are numbered in the order 
they are created, beginning with 1.    If a Data Field is deleted, the remaining fields are re-
numbered accordingly.    



Blank Data Field Option
The Blank Data Field Option causes no text to be displayed or printed in the Data 

Field.



Shade Data Field Option
The Shade Data Field Option fills the Data Field with a gray shading.    Only the first 

line of the Data Field is shaded; and, the height of the field represents the spacing between
successive lines.



Outline Data Field Option
If the Outline Data Field Option is selected, a red border is drawn around the Data 

Field.    Only the first line of the field has a border; and, the height of the Data Field 
represents the spacing between successive lines.



I.D. Name Data Field Option
If the Name Data Field Option is selected, the I.D. name of the Data Field is 

displayed or printed.    This is useful if you are filling the data in the fields by referencing the
I.D.



Sample Text Data Field Option
If the Sample Text Data Field Option is selected, the text entered in the Properties 

Window is displayed or printed.    This option is useful to simulate an actual filled in Form.



Create Windows MetaFile
Create Windows MetaFile generates an image of your Form in standard Windows 

metafile format.    Use this metafile to display or print your Form in your application, or any 
other application that supports Windows metafiles.    If your application requires an Aldus 
Placeable MetaFile format, use the Create Placeable MetaFile menu item instead.



Create Placeable MetaFile
Create Placeable MetaFile generates an image of your Form in Aldus Placeable 

Metafile format.    Use this metafile to display or print your Form in your application, or any 
other application that supports Aldus placeable metafiles.    If your application requires a 
standard Windows MetaFile format, use the Create Windows MetaFile menu item instead.



Create Data Template File
Create Data Template File generates a special file that is used by PrintWorks to fill in

the Data Fields in your Form.    This file must be distributed with your application if you are 
using PrintWorks to automatically fill in Data Fields.



Exit
The Exit menu item terminates the program.



Restore
Restore changes the Form back to the last saved version.



Cut
Cut is used to delete Objects from your Form.    It applies to all Selected Objects.    It 

is recommended that you save your Form prior to using this function.



Copy
The Copy function makes a copy of the Selected Objects at a new location on the 

Form.    A dialog box will appear for you to enter the horizontal and vertical offsets for the 
copied Objects.



Apply Color
Apply Color applies the Current Color to all Selected Objects.    To change the 

Current Color, select the Color item from the Edit Menu.



Apply Line Weight
Apply Line Weight applies the Current Line Weight to all Diagonal, Vertical, and 

Horizontal Line Objects and Rectangle Objects.    To change the Current Line Weight, enter 
the new value directly in the toolbar edit box, or select the Line Weight item from the Edit 
Menu.



Apply Font
Apply Font applies the Current Font to any selected Text Objects.    To change the 

Current Font, select from the toolbar list box, or select the Font Manager item from the 
Fonts Menu and make your selection in the Font Manager dialog box.



Page Layout
The Page Layout dialog box allows you to define the size and units of your Form.    

For many Forms, the size will be 8.5 inches by 11.0 inches, representing a standard page in
portrait orientation.    If your Form is designed for landscape orientation, the width and 
height should be reversed (i.e. 11.0 inches by 8.5 inches).    This way, your Form will always
be readable on the screen.    If you are using PrintWorks to print your Form, the page will 
automatically be rotated.    If you are using other software to print, make sure your printer is
set to print in landscape orientation.    If you wish to display and/or print a landscape Form 
in portrait orientation (long side vertical), you must set it up as a portrait Form and rotate 
all your Objects accordingly.

If you are using metric units, select centimeters from the Measuring Units group.    
The height and width will automatically be converted to centimeters.    You may then edit 
the height and width, if necessary.



Line Weight
The Line Weight item sets the Current Line Weight, which is used to set the Line 

Weight Property of line and rectangle objects. The L ine Weight is the thickness of lines and 
rectangle borders, in pixels.    A pixel is based on 300 dots per inch (standard laser printer 
resolution), so each pixel represents 1 / 300th of an inch.



Color
The Color item in the Edit Menu sets the Current Color.    All Objects that are created 

have their Color Property set to the Current Color when they are created.



Toolbar On/Off
The Toolbar On/Off item in the View Menu toggles the toolbar on (visible) or off 

(hidden).



Status Bar On/Off
The Status Bar On/Off item in the View Menu toggles the status bar on (visible) or 

off (hidden).



Properties Window On/Off
The Properties Window On/Off item in the View Menu, and the toolbar button, 

displays (on) or hides (off) the Properties Window.



View Full Scale
The View Full Scale item (and toolbar button) displays the Form on the screen at full 

resolution; that is, one pixel on the screen represents one pixel at 300 dots per inch 
(standard laser printer resolution).



View Page
The View Page item (and toolbar button) displays the Form in full page mode, where

the entire Form is displayed.



Zoom In
The Zoom In item (and toolbar button) enlarges the view of the Form for detailed 

work.    The maximum Zoom Level is twice the Full Scale resolution, or 600 dots per inch.



Zoom Out
The Zoom Out item (and toolbar button) reduces the size of the Form for more 

general work.    The minimum Zoom Level is the same scale as View Page (i.e. where the 
entire page is visible).



Display Grid
The Display Grid item toggles the background grid on or off.    If you are doing a lot 

of scrolling, you may want to turn the grid off to allow faster scrolling.



Refresh Screen
The Refresh Screen item is used to force a re-draw of the Form and the bounding 

rectangles of Selected Objects.    Use this function if the screen should become corrupted 
for any reason.



Pick Tool
The Pick Tool allows you to "pick" or Select an Object.    You may select one or more 

Objects by enclosing them within a rectangle created by dragging the pick tool (holding 
down the left mouse button and moving the mouse).    Only objects that are fully enclosed 
by the dragged rectangle will be selected.    You may select an individual object by clicking 
the left mouse button.    The nearest object to the cursor will be selected.    You may also 
choose a filter from the Filters Menu, so that only one Object Type is available for selection.

Objects that have been selected have a bounding rectangle; a green, cross-hatched 
rectangle for the Focus Object, and a gray, solid rectangle for others.    Selected objects 
may be moved, re-sized, copied, deleted, or have their Font, Line Weight, or Color 
properties changed.    The Focus Object may also be edited in the Properties Window.



Text Tool
The Text Tool is used to add a new Text Object to the Form.



Diagonal Line Tool
The Diagonal Line Tool is used to add a new Diagonal Line Object to the Form.



Vertical Line Tool
The Vertical Line Tool is used to add a new Vertical Line Object to the Form.



Horizontal Line Tool
The Horizontal Line Tool is used to add a new Horizontal Line Object to the Form.



Rectangle Tool
The Rectangle Tool is used to add a new Rectangle Object to the Form.



Bitmap Tool
The Bitmap Tool is used to add a new Bitmap Object to the Form.    



All Objects Filter
The All Objects Filter allows selection of all Object Types when using the Pick Tool.



Text Filter
The Text Filter allows selection of only Text Objects when using the Pick Tool.



Diagonal Line Filter
The Diagonal Line Filter allows selection of only Diagonal Line Objects when using 

the Pick Tool.



Vertical Line Filter
The Vertical Line Filter allows selection of only Vertical Line Objects when using the 

Pick Tool.



Horizontal Line Filter
The Horizontal Line Filter allows selection of only Horizontal Line Objects when using

the Pick Tool.



Rectangle Filter
The Rectangle Filter allows selection of only Rectangle Objects when using the Pick 

Tool.



Bitmap Filter
The Bitmap Filter allows selection of only Bitmap Objects when using the Pick Tool.



Font Manager
The Font Manager dialog box is used to add, delete, and edit fonts in the Font List, 

and is shown below:

The file name for the Font List is displayed in the dialog caption bar.    The Current 
Font is displayed in the drop-down list box following the caption "Current Font I.D.".    This is 
the font that is affected by any changes you make in the Font Properties group; or, if you 
click the Delete Font button.    

You can select any of the fonts in the list by clicking the arrow on the list box to 
display the Font List.    The name or I.D. of a font in the list cannot be changed.    If you must 
change the name of a font, do the following: (1) add a new font to the list with the same 
characteristics but with the new name; (2) ReMap all Text Objects using the original font to 
the new one; and (3) delete the original font if you don't need it.

All of the characteristics of a font that may be edited are in the Font Properties 
group (see below).    All of the properties except Point Size require only a selection; so, it is 
impossible to specify a non-valid value.    Point Size requires you enter a value, which may 
contain a decimal portion.    In Visual Forms for Windows, Point Size is the standard 
typography definition - one point = 1 / 72 of an inch; so there are 72 points in an inch.    The
Point Size refers to a character cell (a rectangular area that encloses all characters in the 
font), so the actual height of any character will be less than the Point Size converted to 
inches.    This definition ensures that the font will be the correct height when it is printed.    
When viewed on the screen as part of a Form, the font will be scaled appropriately to 
compensate for the screen's resolution.    This definition may be different than that used by 
other Windows software that base Point Size on how the font will appear on the screen.

A Font List can only include TrueType fonts.    All the TrueType fonts that have been 



installed with your version of Windows are listed in the Typeface drop-down list box.    If you 
intend to distribute your Form, or use it on another computer, make sure all the fonts you 
specify in your Font List are installed.    Any fonts that are not installed will be replaced with 
a substitute by Windows, using a closest match strategy.    It is possible the substituted font 
may affect the formatting of text and the appearance of your Form.    Try to use fonts you 
know exist on computers that will use the Form, or distribute the fonts (this may require a 
license), or require customers to acquire them.



Re-Map Font
Fonts can be easily re-mapped using the Re-Map Font item from the Fonts Menu.    

Re-mapping a font takes all Text Objects that use a particular font in the Font List, and 
assigns a different font from the Font List to those Text Objects.    Simply indicate which font
you wish to have replaced in the left list box (see below), and which font you wish to 
replace it with in the right list box.    Press Ok to apply the change. Pressing Cancel will 
cancel the operation.



Create New Font List
Create New Font List creates an empty Font List.    You then add the fonts you want 

to be in the new list using Font Manager.    It is best to use Create New Font List when there 
are no Text Objects in the current Form (i.e. create a new blank Form first) to avoid getting 
a message that some fonts were not found.    If you wish to create a new Font List for an 
existing Form that has Text Objects, use Save Font List As to make a clone, and then delete 
the fonts you don't need.



Open Font List
Open Font Lists loads an existing Font List and associates it with the current Form.    

If the Font List is different than a previously used Font List, the appearance of the Form will 
be updated accordingly.    Keep in mind that if you change the characteristics of a font in a 
Font List, all Forms that are associated with that Font List will appear differently.



Save Font List As
Save Font List As makes a copy of the current Font List and saves it with a new 

name.    This is useful for creating similar, but different Font Lists.    



Align Left
Align Left aligns the left side of all Selected Objects with the left side of the Focus 

Object.    The position of the Focus Object is not changed.



Align Center
Align Center centers all Selected Objects including the Focus Object, horizontally on 

the page.



Align Right
Align Right aligns the right side of all Selected Objects with the right side of the 

Focus Object.    The position of the Focus Object is not changed.



Align Top
Align Top aligns the top of all Selected Objects with the top of the Focus Object.    

The position of the Focus Object is not changed.



Align Bottom
Align Bottom aligns the bottom of all Selected Objects with the bottom of the Focus 

Object.    The position of the Focus Object is not changed.



Visual Forms Help
The Visual Forms Help item in the Help Menu launches Visual Forms for Windows 

help.



About Visual Forms
The About Visual Forms item in the Help Menu displays a dialog box with copyright 

information.



Current Font
The Current Font is displayed in the drop-down list box on the toolbar to the left of 

the Apply Font toolbar button.    It indicates the font that will be used to create subsequent 
Text Objects; or that will be applied to Selected Objects by clicking the Apply Font toolbar 
button.    The Current Font can be changed by making a new selection from the drop-down 
list box; or, by selecting the Font Manager item from the Fonts Menu.



Current Line Weight
The Current Line Weight is displayed on the toolbar to the left of the Apply Line 

Weight toolbar button.    It indicates the Line Weight, in pixels, that will be used to create 
subsequent Objects; or that will be applied to Selected Objects by clicking the Apply Line 
Weight toolbar button.



Current Color
The Current Color is displayed on the toolbar to the left of the Apply Color toolbar 

button.    It indicates the color that will be used to create subsequent Objects; or that will be
applied to Selected Objects by clicking the Apply Color toolbar button.



Select Font
The Select Font drop down list box on the toolbar allows you to select a font from 

the Font List.    The selected font is applied to any new Text Objects that are created.    Also, 
any selected Text Objects can be changed to the selected font by clicking the Apply Font 
toolbar button.    A font can also be selected by clicking the Font Manager toolbar button, or
by selecting the Font Manager item from the Fonts Menu.



Selected Object
An Object is selected if it has a rectangular border around it.    There are two types 

of borders: (1) a green, cross-hatched border for the Focus Object; and, (2) a gray border 
for all other objects.    At least one Object (the Focus Object) is always selected.    Selected 
Objects can be: re-positioned as a group; aligned to the Focus Object using the Alignment 
Tools; have their Color, Font, and Line Weight Properties changed as a group; deleted; and, 
copied.



Focus Object
Whenever a Form contains at least one object, there is a Focus Object.    The object 

that has the focus is surrounded by a green, cross-hatched rectangular border. The Focus 
Object is also Selected.    A Form can have a number of objects that are Selected, but only 
one, the Focus Object, has the focus.    Objects that are selected, but do not have the focus,
have a gray rectangular border.

The Focus Object has two important attributes, in addition to its properties: (1) it is 
the Object that the Properties Window refers to; and, (2) it is the Object which other 
selected Objects are aligned to with the Alignment Tools.

The Focus Object can be changed using the tab and shift + tab keys.    If the tab key 
is pressed, the next Object becomes the Focus Object.    If the shift + tab key is pressed, the
previous Object become the Focus Object.    If only one Object (the Focus Object) is 
selected, the tab and shift + tab keys will allow you to change the focus to any Object on 
your form.    If more than one Object are selected, you can only change the focus to another
Selected Object.    If a filter has been selected from the Filters Menu, only objects of that 
type may be selected.



Font List
A Font List is a file containing a list of TrueType fonts that are used to draw Text 

Objects for one or more Forms.    Each entry in the Font List contains all the attributes of a 
particular font, which provides an easy method for managing the appearance of Text 
Objects.    A Font List may be used for any number of forms; and not every font in the list 
need be used.



Zoom Level
The Zoom Level defines the amount of detail visible in the current form.    As you 

Zoom In, more detail becomes visible over a smaller portion of the page.    As you Zoom 
Out, more of the page is visible, but less detail.



Object Type
A form is comprised of a collection of Objects, of which there are six types:

1.    Text (including data fields)
2.    Diagonal Line
3.    Vertical Line
4.    Horizontal Line
5.    Rectangle (which includes fills and hatching patterns)
6.    Bitmaps

These Objects may be thought of as building blocks, from which very complex forms
can be created.    Each of the Object types has a set of Properties (such as color or size) that
control its appearance.



Text Object
A Text Object consists of from one character to several paragraphs of text.    It has 

two basic forms: (1) static; and, (2) data.    The difference relates to when the text is 
actually drawn; otherwise, they are identical.    Static text is part of the Form, and never 
changes.    It is included in the MetaFile you create, and therefore, is always displayed or 
printed.    Data is text that is added at runtime, because it is dependent on the application 
and may change.    It requires PrintWorks VBX, which automatically fills in the data from 
within your application.    

Text is formatted in fields - a rectangular area on the Form that contains the text.    A
field is defined by its reference point (X Pos Property and Y Pos Property), and its Width 
Property.    The reference point is the left edge of the text field at the character baseline (a 
character "sits" on its baseline).    The Y Pos field name changes to "Baseline" in the 
Properties Window to indicate that a Text Object has the Focus.    The height of the field is 
the height of one line or, the line spacing.    Although a Text Object may have more than 
one line, only the first line is considered as the field.    The text may be formatted within the
field by setting the Alignment Property.

Text is formatted in paragraphs, if there is more than one line.    You can start a new 
paragraph, or force a linefeed, by pressing Ctrl+Enter in the text edit box in the Properties 
Window.    You can also use Ctrl+Enter to format multiple lines of text as centered or right 
justified.

All text is displayed in a particular font from the Form's Font List.    When a Text 
Object is created (by selecting the Text item from the Tools Menu or clicking the Text Tool 
toolbar button), a new Text Object is located in the upper left corner of the screen.    You 
then position the object where you want it and set its Properties.    The Text Object initially 
has the Current Font as its Font Property, and "Text" as its Text Property.

One Text Object can be used to print a single character (such as the check mark in 
the Available Properties grid in the Properties topic), or many paragraphs.    You can always 
change the Font Property to another font, or use the Font Manager to change the 
characteristics of the font being used.    Keep in mind that changing a font's characteristics 
affects all Text Objects that use the font.



Diagonal Line Object
A Diagonal Line Object is a straight solid line between two points.    It is created by 

selecting the Diagonal Line item from the Tools Menu, or clicking the Diagonal Line Tool 
from the toolbar.    Use the drawing pencil that appears when the tool is selected to draw 
the line.    Press and hold the left mouse button where you want the line to start, and drag 
the line with the mouse to where you want the line to end.    If the line is not exactly where 
you want it, use the mouse to re-position or re-size it; or, use the cursor keys, or the 
Properties Window.



Vertical Line Object
A Vertical Line Object is a straight solid vertical line between two points.    It is 

created by selecting the Vertical Line item from the Tools Menu, or clicking the Vertical Line 
Tool from the toolbar.    Use the drawing pencil that appears when the tool is selected to 
draw the line.    Press and hold the left mouse button where you want the line to start, and 
drag the line with the mouse to where you want the line to end.    You can move the drawing
pencil out of the way (moving it left or right) and the line will remain vertical.    This can 
help improve your vision, for precise positioning.    If the line is not exactly where you want 
it, use the mouse to re-position or re-size it; or, use the cursor keys, or the Properties 
Window.



Horizontal Line Object
A Horizontal Line Object is a straight solid horizontal line between two points.    It is 

created by selecting the Horizontal Line item from the Tools Menu, or clicking the Horizontal
Line Tool from the toolbar.    Use the drawing pencil that appears when the tool is selected 
to draw the line.    Press and hold the left mouse button where you want the line to start, 
and drag the line with the mouse to where you want the line to end.    You can move the 
drawing pencil out of the way (moving it up or down) and the line will remain horizontal.    
This can help improve your vision, for precise positioning.    If the line is not exactly where 
you want it, use the mouse to re-position or re-size it; or, use the cursor keys, or the 
Properties Window.



Rectangle Object
A Rectangle Object may be used to create boxes, fills, and hatching patterns.    It is 

created by selecting the Rectangle item from the Tools Menu, or clicking the Rectangle Tool 
from the toolbar.    Use the drawing pencil to draw the Rectangle.    Press and hold the left 
mouse button at one corner of the Rectangle, and drag the Rectangle with the mouse to 
the opposite corner.    If the Rectangle is not exactly where you want it, use the mouse to 
re-position or re-size it; or, use the cursor keys, or the Properties Window.

Use the Style Properties to customize the appearance of your rectangle.    Keep in 
mind the following points when designing Rectangles:

1.    The Color Property for the Rectangle itself and its fill (if any) are the same

2.    If a Solid Fill is used, it will cover any objects in the background

3.    All filled Rectangles are drawn as opaque (background does not show through 
white space) because of known problems with some printer drivers correctly rendering fills 
in transparent background mode.    Un-filled Rectangles are simply drawn as boxes.    If you 
are using filled Rectangles, put them behind other objects you want to be visible by 
drawing them first.



Bitmap Object
A Bitmap Object allows you to add graphics to your Form.    It is created by selected 

the Bitmap item from the Tools Menu, or clicking the Bitmap Tool toolbar button.    A dialog 
box appears requesting the name of the bitmap file to add to your Form.    The bitmap must
be a Windows device independent bitmap (usually a DIB or BMP extension).    Windows has 
another bitmap format which is device dependent and is intended to be used internally.    It 
is possible for some software to save device dependent bitmaps to files; however, this 
format is not supported.

After selecting the bitmap file you want, position it on the Form.    The Bitmap Object
may be displayed as either transparent (background shows through white space) or opaque
(white space remains white), depending on the Opaque Property.    If the ReSize Property is 
set, the Bitmap Object may be scaled (or, stretched) to any size you like.    Otherwise, it 
retains its native size.    When it is first added to the Form, it is displayed at its native size.

Monochrome Bitmap Objects may have a Color Property.    When the Bitmap Object 
is created, the Color Property is the Current Color.    For color bitmaps, the Color Property 
does not apply, and is ignored.



VFW File
A VFW File is a Visual Forms for Windows project file, and usually has the extension 

VFW.    It contains all the information about the form you have designed, including Page 
Layout, Objects and their Properties, and the appropriate Font List.    A VFW file is in a 
proprietary format, and is not compatible with other software.    To create a file containing 
an image of your form for use in other software, or with PrintWorks, select Create Windows 
MetaFile, or Create Placeable MetaFile from the File Menu.



Repeat Property
The Repeat Property, which is displayed in the Properties Window, specifies how 

many additional times an Object is drawn, or repeated.    For most Objects, this value is zero
and the Object is drawn only once.    When an Object is to be repeated, the X Offset and Y 
Offset values are specified in the Properties Window, to indicate the position offset of 
successive repeated Objects.    For example, if you wished to draw five horizontal lines, one 
inch apart, you would enter the following values:

Repeats = 4
X Offset = 0
Y Offset = 1.0

All other Properties of the repeated Object (except location) are the same.    This 
feature is useful for building grids, a series of check boxes, etc.



Properties
Properties are the attributes of a particular Object, such as its location, size, and 

color.    Each type of Object has its own set of properties that are used to fully define it.    In 
addition, all Objects have a Repeat Property, that determines how many times it is drawn.

The Properties for an Object can be edited in the Properties Window.    The Properties
Window always displays the properties of the Focus Object.    The most common properties 
are displayed in the Properties Window:    Other properties are called Style Properties, and 
require clicking the "Style" button in the Properties Window.    This displays a custom style 
properties window for the particular Object Type.

There are a number of Properties available; however, not each Object Type has all of
the available properties.    The chart below (which was created in Visual Forms for Windows)
lists the Object Types and the available properties.    The check mark indicates that a 
particular Property is available for the Object Type.    Click on the Property for a description 
of that Property.    Click on the Object Type for a description of that Object.



X Pos Property
The X Pos Property is the horizontal coordinate (in inches or centimeters) of the 

reference point of the Object, which fixes its position    on the Form.    X Pos is measured 
from the physical left edge of the page.    The position of the reference point relative to 
each Object Type is as follows:

Text: The left edge of the text field at the character baseline (a character "sits" on 
its baseline)

Diagonal Line:    The upper left corner of a rectangle that bounds the line

Vertical Line:    The top end of the line

Horizontal Line:    The left end of the line

Rectangle:    The upper left corner of the rectangle

Bitmap:    The upper left corner of the bitmap



Y Pos Property
The Y Pos Property is the vertical coordinate (in inches or centimeters) of the 

reference point of the Object, which fixes its position on the Form.    Y Pos is measured from 
the physical top edge of the page.    The position of the reference point relative to each 
Object Type is as follows:

Text: The left edge of the text field at the character baseline (a character "sits" on 
its baseline)

Diagonal Line:    The upper left corner of a rectangle that bounds the line

Vertical Line:    The top end of the line

Horizontal Line:    The left end of the line

Rectangle:    The upper left corner of the rectangle

Bitmap:    The upper left corner of the bitmap



Width Property
The Width Property describes the width of an Object.    Only the Vertical Line Object 

has no Width Property.    Its thickness is described by the Line Weight Property.



Height Property
The Height Property describes the height of an Object.    Only the Horizontal Line 

Object has no Height Property.    Its thickness is described by the Line Weight Property.



Color Property
The Color Property is the color of the Object.    For a Rectangle Object, both the fill 

color and outline color are the same.    The Color Property applies to the foreground (black) 
pixels of a monochrome Bitmap Object; but, has no effect on a color Bitmap Object.



Text Property
The Text Property is the actual text in a Text Object field.    If the Text Object has the 

Replace Property set, it becomes a Data Field no text will be placed in the created MetaFile, 
since this text will be added at runtime.



Font Property
The Font Property determines which font in a Font List is used to draw a Text Object.



Alignment Property
The Alignment Property determines how the text in a Text Object field is formatted.   

The following formatting options are available:

Left Justified:    Text is drawn flush left to the left side of the field (i.e. at X Pos)

Right Justified:    Text is drawn flush right to the right side of the field (i.e. at X Pos + 
Width)

Centered:    Text is centered in the field

Fully Justified:    Text is drawn both flush left and flush right (see above)

Decimal Aligned:    Text is aligned with the first decimal point encountered at the left
edge of the field.    All text prior to the decimal point (typically numbers) will 
be drawn to the left of the field.



Indent Property
The Indent Property describes how far to indent the first line of text in each 

paragraph of a Text Object.    



Replace Property
The Replace Property specifies that the Text Object is a Data Field and its text will be

drawn at runtime.    In order to use this property, you must print or preview your form at 
runtime using PrintWorks VBX.    This Text Object will be left blank when a MetaFile is 
created, even though you may display sample text within Visual Forms for Windows.



Line Weight Property
The Line Weight Property describes the thickness of a line in pixels.    A pixel is 1 / 

300th of an inch (standard laser printer resolution).    If a Line Weight of zero is set, a one 
pixel width line will be drawn.



Fill Style Property
The Fill Style Property describes the type of fill for a Rectangle Object.    The 

following styles are available:

No Fill:    The rectangle appears as a box.

Solid Fill:    The rectangle is filled solid with the Color.

Horizontal Hatch:    The rectangle is filled with a horizontal hatching pattern.

Vertical Hatch:    The rectangle is filled with a verticall hatching pattern.

Diagonal Hatch 1:    The rectangle is filled with a diagonal hatching pattern.

Diagonal Hatch 2:    The rectangle is filled with a diagonal hatching pattern, 
rotated 90 degrees.

Cross Hatch:    The rectangle is filled with a hatching pattern that is a 
combination of vertical and horizontal.

Diagonal Cross Hatch:    The rectangle is filled with a hatching pattern that 
is a combination of the two diagonal hatching patterns.



Allow Re-Size Property
The Allow Re-Size Property permits scaling or "stretching" a Bitmap Object.    If this 

property is not set, the Bitmap Object will be displayed in its native resolution.



Opaque Property
The Opaque Property, when set, causes a Bitmap Object to block out the 

background.    When this property is not set, the background will show through and white 
space in the Bitmap Object.



Objects
A form is comprised of a collection of Objects, of which there are six types:

1.    Text (including data fields)
2.    Diagonal Line
3.    Vertical Line
4.    Horizontal Line
5.    Rectangle (which includes fills and hatching patterns)
6.    Bitmaps

These Objects may be thought of as building blocks, from which very complex forms
can be created.    Each of the object types has a set of Properties (such as color or size) that
control its appearance.    Through manipulation of the Object's Properties, you can create a 
wide range of Form designs.



PrintWorks
PrintWorks is a Windows Custom Control (VBX) distributed by Bytech Business 

Systems, Inc.    It makes displaying and printing Forms and runtime data very easy.    It 
allows merging of runtime data with data fields specified in Visual Forms for Windows; and, 
contains a comprehensive library for dynamically adding text and graphics.

Although Visual Forms for Windows and PrintWorks can both function as 
independent products, maximum efficiency is achieved when they are used together.    If 
you are using the data field capabilities of Visual Forms for Windows, PrintWorks is required.



MetaFile
A MetaFile is a standard Windows file format containing graphics commands, so it 

represents a graphic image of a page, or portion of a page.    The MetaFile may be displayed
and/or printed from any Windows program that supports metafiles.    When a Visual Forms 
for Windows Form is complete, you create a MetaFile so it can be used in your application.    
The PrintWorks VBX can be used to easily manage displaying and printing of your forms.

A non-standard Windows MetaFile, usually called an "Aldus Placeable Metafile" or 
"Placeable Metafile", is used by some software.    Visual Forms for Windows allows you to 
create a "Placeable Metafile" from the File Menu.



Template File
A Template File contains the information for adding runtime data to your Form.    The

information it contains includes: the size and position of the data fields; the characteristics 
of the font to use for displaying the data; the font color; and formatting instructions.    The 
Template File depends on the Font List associated with the Form.    If you are using data 
templates, you must include the appropriate Font List with your application.



Form
A Form is the finished product of Visual Forms for Windows.    It has a broader 

meaning than some uses of the word in that it can be any kind of document: a business 
form; a graphic such as a logo; a letterhead; a base sheet for graphs and plots; a form 
letter; and almost anything else.    Be aware that some Windows development platforms, 
such as Visual Basic, use the word form in a different context - to mean a screen display or 
dialog box.

A Visual Forms for Windows Form is a Windows MetaFile, and as such can be easily 
displayed and printed.    Typically, the portion of your output that is static (does not change 
at runtime) is included with the Form, so you do not have to do any programming to create 
it.    Dynamic output (created at runtime) is then merged with the form (filling it in) to 
create the final product.

Since a Form is used as a MetaFile, it cannot contain data fields, or their definitions.  
This information is saved in a special file called a data Template File (or TF File), which is 
created from the File Menu.



Data Field
A Data Field is a Text Object that has the Replace Property set.    When this is true, 

the Text Object is not considered part of the Form, but a field that will be filled in at 
runtime.    In order to fill the field at runtime, the PrintWorks custom control is required.    A 
collection of Data Fields is called a Data Template.
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