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cdrLabel is a shareware utility for the creation of labels to be placed in CD-ROM and CD-Recordable 
jewel cases.    It can generate many different kinds of labels, containing directory information, images, 
fonts, and more.    Organize your entire CD collection with it!

Check out ZipLabel if you have a Zip drive and like the kind of labels 
cdrLabel creates:

http://www.geocities.com/CapeCanaveral/6552/ziplabel.html
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Getting Started
It's as easy as 1…2…3 to make your first label using cdrLabel!

1. If you haven't already selected your CD drive using the File->Select CDROM Drive menu, do 
that now.

2. Insert the disk you want to catalog.

3. Double-click the on-screen label or press the  button, and you've got a basic label, like this one:

Wasn't that easy?    Now that you've scanned your CD into the label, you can have fun adding pictures 
and text, changing the fonts and colors, or just printing and admiring it!



Let's add an image to your label, it's also as easy as 1…2…3!

1. Click the  toolbar button.
2. Select the image (either BMP or JPEG format) from the file dialog.
3. Click-and-drag to move the image to it's final position:

Once your label is perfect, print it by using the  toolbar button.    Cut it out, put it in your CD's jewel 
case, and show off to your friends.
This is just a tiny sample of cdrLabel's capabilities.    Explore on your own or use this help file to get more 
information about additional cool features.



What's New 
cdrLabel was initially released September 1997, as a derivative of ZipLabel.    Since then it has undergone
an incredible amount of work to become to the program you see today.

Changes in this release of cdrLabel (April 15, 1998)…

Version 3.0:
· May now edit all pages of a booklet label
· Multi-line strings, with more formatting options
· Graphical directory browser and file editor
· Store printer and page setup between runs
· Automated, customizable comment line
· Space between labels for people with shaky hands
· Icons for all saved files with double-click opening
· Registered users get to customize their initials on-the-fly
· Ergonomic changes to interface, tweaks to menu tree
· This help file!

Changes in previous version (January 9, 1998)…

Version 2.0:
· Booklet labels, create ultra-fat catalogs!
· Audio CD support
· Opposable spine option
· Crop marks to make it easier to cut
· Customizable borders
· Printer setup dialog, can choose non-default printer and get WYSIWYG
· Can place label anywhere on printouts
· Very small font sizes supported
· Up to 7 columns now available
· Spine can be custom aligned



License
cdrLabel is shareware, (c) 1997-8 by Earle F. Philhower, III.    All rights reserved.    I make no warranties as
to it's correctness or functionality.    Use it at your own risk.

You may use cdrLabel free of charge only for a 30 day evaluation period. After that, you must either 
register your copy by paying a small license fee, or stop using it.

I encourage and grant license for anyone to copy and distribute unregistered version of this program, 
provided that:

· Copies contain all files of original distribution in unmodified state.
· No fee is charged other than a nominal duplication and handling fee.
· Software is clearly identified as shareware.



Shareware Registration
cdrLabel is shareware, the standard software try-before-you-buy.    If cdrLabel is of use to you after the 
initial evaluation period, a $15.00 registration fee is requested.    If cdrLabel isn't useful to you, or you find 
some important features lacking, feel free to email me at earle@geocities.com.    I listen to all comments.

What Will You Get For Registration?
· A registration code that can be entered into the Registration dialog.    This code will remove the 

random nag screen on printouts, as well as allow you to customize the initials.
· Registration will be good for all future releases of cdrLabel.
· Addition to the mailing list for new releases and betas.    Your contact information will not be 

distributed to any other parties.    I hate spam worse than you do, believe me!
· A warm, fuzzy feeling for supporting the shareware concept.

How Do You Register?
Registrations are now being processed through the Kagi (http://www.kagi.com) online service, which 
allows both check and credit card payment.    It should also decrease the turnaround time for registration 
codes to a matter of days or hours.

Before May 1, 1998, the easiest way to register is to select the "Order Form…" item in the Help menu, 
and follow the program's prompts to email your payment information.    If, for some reason cdrLabel 
cannot find the executable "REGCL.EXE", you will have to execute it from the Explorer or File Manager 
yourself.

After May 1, 1998, an "Online Registration…" option will appear in the Help menu.    If you'd rather register
via your Web browser, you may use this option to connect to the Kagi server automatically.    Please note 
that this obviously requires an internet connection.    If you're unwired you can always use the "Order 
Form…" option and snail mail your registration.

You can bring the online registration form up in your web browser by using the following URL:

http://order.kagi.com/?4VG



Installation
There are two ways to install cdrLabel:

1. Use the included Setup program, which will make program groups and allow you to use the Uninstall 
program, or

2. Just copy the executable file to any convenient directory.

If there are any problems with the setup program, just perform option (2) and send me some email 
(earle@geocities.com).

WINDOWS 3.1 ONLY:    Under Windows 3.1 you NEED to have Win32s v1.30c installed, if you don't 
already have it check out the following URL to get it:

http://support.microsoft.com/support/kb/articles/Q122/2/35.asp



Templates
A template is a small text file created by cdrLabel that contains all formatting information for a label.    It 
allows you to add and delete files from a disk while preserving the label's appearance between runs of 
cdrLabel.    If you're going to be updating the contents of a disk frequently they can save you lots of time.   
It's most useful for CD-RWs and Packet-CDs, which are updated frequently.    If you are scanning a label 
that isn't going to change often, just save it normally.

Templates store the following information:
· General format, including font and colors
· Images and Strings
· Directories displayed/hidden

This is enough information for cdrLabel to create a new label when files are added or removed.    Best of 
all, these files won't take up much disk space (normally under 5Kb)!

Using Templates
It's easy and fast to start using templates for your disks:

1. First, select the File->Use Templates.    This will make cdrLabel search for a hidden file, 
"CDRLABEL.CLT", on each disk it scans and read it's formatting.

2. Now, insert your CD and read it in.    Set the font, directory tree, and the images you want and select 
File->Write Template.    Save it in the root directory of your CD-RW or Packet-CD.

3. The next time cdrLabel reads in the CD with your saved template, it will automatically format it the 
way you specified.

I use templates on all my disks, and it's saved me countless hours of tweaking!



Adding Images
cdrLabel can import .BMP (Windows Bitmap) and .JPG (JPEG) files into your labels. Simply select Body-
>Insert Image or the  toolbar button and you're on your way.    Labels can either be underneath 
the label text, or above the text. Text will automatically flow around any images above it.
To select an image in your label, left-click on it.    Click-and-drag to move the label around.    Right-click to 
bring up a menu of options to delete, center, or change the image's position relative to the text.    Above 
Label makes the text flow around the image, while On Label and Below Label place an image without text
wrapping.
Use the little size-blocks to change an image's size, or use the Image popup-menu's scaling options.

HINT: If you are having trouble dragging a tiny image, hold down the SHIFT key while you click the left 
button.    This turns off the size-blocks and always drags an image.

HINT: To setup a photo as your label's background, perform the following steps.    (Remember, with a 
dark image it's easiest to see white text, and with a light image it's easiest to see dark text):

1. Image->Insert Image
2. Image->Scale->Size To Body
3. Image->Below Label

Bitmaps of greater than 72dpi are supported automatically, so you can scan an image in at a higher 
resolution than the screen supports, yet still print out at the higher resolution.    This is especially useful for
line art, where 72dpi conversion can cause excessive jaggies.



Working With Labels
cdrLabel supports two different label formats:    single, and booklet.    Both allow you to specify the order in
which file listings will appear.    Select a label format by using the File->Label Format menu.

You may zoom in or out of the label by using the  toolbar button.
Booklet Labels
If you've got a CD with too many files to fit on the front and back of a label, you can create a booklet label 
that will allow you to catalog all files on your CD.    Select File->Label Format-
>(No) Text On Back and you're almost done!

Catalog the disk as normal, and modify the pages to suit your liking.    Use the  buttons in the 
toolbar, or the PgUp/PgDn keys to navigate between your label's pages.    You can place images and 
strings anywhere, on any page.

When you print out your booklet, it's easy to fasten them together into a booklet.    Cut out the individual 
pages, arrange them in the proper order, and staple them together.    Three staples spaced equally along 
the left edge are all that's needed.



Printer Setup
Set your printer and output options with the printer setup dialog.    Bring it up via the File-
>Printer Setup menu:

· Select a Default Printer:    cdrLabel interrogates the currently selected printer to determine the size of 
fonts, graphics capabilities, and more.    To print to a non-default printer use this button to select it 
from the list.

· Toggle Crop Marks:    Crop marks are 1 inch lines along the edge of the sheet indicating where cuts 
need to be made.    These are especially handy for use with paper    cutters.    These marks only 
appear on the printed output.

· Space Multiple Labels On The Page:    If you have trouble cutting out labels with a shared edge, use 
this option to give you a small gap between multiple labels per page.

· Select a Border Style:    Use this popup to determine how cdrLabel should outline your labels.    If you 
are using a paper cutter, you can turn off the border and turn on crop marks for a neat, borderless 
label.

· Position: Specify the upper-left-hand corner of printouts yourself using these boxes, making it easy to 
use different paper sizes and perforated templates.    When the Default checkbox is checked, the 
labels will be placed in the approximate center of the page.



Menu Items
Here are the menus that are available through the menu bar.    You can also right-click on any screen item
to bring up it's popup menu.

File
Select CDROM Drive

Chooses the drive letter associated with your CD drive.    Does not actually read in a disk!

Window Scaling
If cdrLabel's window appears too small or large, you can adjust it's scaling from this menu.    This 
scaling does not affect printed output, only the on-screen display.

Label Format
Choose how you'd like them formatted from this menu.    Different options specify whether to begin 
file listings on the back or front cover, and whether or not to create a booklet instead of a single 
cover.

Directory Levels
cdrLabel only scans down the number of directories you specify here. 
Scan Directories Only
When checked, cdrLabel will only read in the names of directories and not files. Use this mode 
when you have lots of directories that you want to see, but don't care about the files in those 
directories.

Use Template Files
When checked, cdrLabel automatically formats your label according to the template file stored 
on the CD.    If the disk doesn't have a template file, no action is taken.    See Templates for 
more information.

Load…
Read a saved label from disk.

Save
Save the currently edited label to disk under the last file name entered.

Save As…
Prompt for a new name to save the current label to disk.

Read Template File
Read in the formatting information stored in a CD's template file.    See Templates for more 
information.

Write Template File
Save only the formatting information from the current label to disk as a template. See Templates for
more information.

Reset To Defaults
Set all font, color, and formatting options to sane defaults.

Printer Setup
Specify printout options.    See Printer Setup for more details.

Print
Print displayed label.

Exit
Quits cdrLabel.

Body
Display File Sizes

Show or hide the file sizes for the current label.



Display Extensions
Show or hide extensions from the files present in the current label.

Display Comment
Show or hide disk comment, the single line of text at the bottom of the label summarizing free 
space, scan date, etc.

Columns
Selects the number of columns of files to display.
No Columns

Do not display files on the current label.
Lined

Check to draw a thin line under each file name.

Sorting
Sort the files in the current label by name, extension, or size, and either ascending or descending 
order.

Set Fonts And Color
Select the font and color for files, folders, and other label elements.    See Fonts and Colors for 
more information.

Background Color
Select the background color for the label body.    Note that this color will be printed by your printer, 
and may consume a lot of ink.

Read CDROM
Scan a disk into the currently selected label.    If "Use Templates" is selected in the File menu, also 
reads template and applies formatting and images.

Edit Files and Folders
Modify the contents of the label by adding, removing, or moving files.    See Files And Folders for 
more information.

Edit Label Comment
Modify the comment displayed at the bottom of the label.    See Comment Editor for details.

Choose Subdirectories
Select the directories to display or hide.    See Subdirectory Selector for more information.

Clear Label
Removes images, text, and files from the current label.

Zoom
Zoom in or out of the current label.

Spine
Edit Spine Text

Modify the text printed on the label spine.

Spine Font
Choose the font of the spine text.

Spine Color
Choose the foreground color of the spine text.

Alignment
Select the justification used for the spine text.

Background Color
Choose the background color for the spine.

Display "CDR 650"
Insert the cdr 650 logo box on the spine.



Color cdr Logo
When the cdr 650 logo box is displayed, color the 650 box in blue.

Customize Initials
Registered users may modify the cdr portion of the cdr 650 logo box to their initials.

Image
Insert Image

Place a JPEG(.JPG) or Windows Bitmap(.BMP) on the label.

Copy
Duplicate the currently selected image.

Delete
Remove the currently selected image.

Above Label
Have file listing flow around image border.    No file names are overwritten by the image in this 
mode.

On Label
Simply draw the image on the label, do not flow the file names around it.    File names may be 
obscured by the image.

Below Label
Draw the image under the label, with file names appearing on top of the image.    Especially useful 
for background bitmaps.

Center Horizontally
Center the image left-to-right in the label.

Center Vertically
Center the image top-to-bottom in the label.

Scale
25%-200%

Stretch the image to a percentage of it's original size.
Size To Body

Stretch the image to fill the body of the label, leaving the spine empty.
Size To Label

Stretch the image to fill the entire label, spine and all.
Maximum Aspect

Make the image as large as possible while preserving it's aspect ratio.

String
Insert String

Place a text string on the label.    See String Editor for more details.

Copy
Duplicate the currently selected image.

Delete
Remove the currently selected image.

Modify Text
Modify the selected string's text, font and color using the String Editor.

Font...
Choose a new font for the current string.

Foreground Color
Choose a new foreground color for the current string.



Background Color
Choose a new background color for the selected string.
Transparent

When selected, do not draw a background color for the string.    Useful when overlaying text on 
images.

Automatically Size
Adjust the bounding box of the currently selected string automagically.

Orientation
Rotate the string 0, 90, 180, or 270 degrees.

Alignment
Select the alignment of the string within it's bounding box.

Above Label
Have file listing flow around image border.    No file names are overwritten by the image in this 
mode.

On Label
Simply draw the image on the label, do not flow the file names around it.    File names may be 
obscured by the image.

Below Label
Draw the image under the label, with file names appearing on top of the image.    Especially useful 
for background bitmaps.

Center Horizontally
Center the image left-to-right in the label.

Center Vertically
Center the image top-to-bottom in the label.

Help
About cdrLabel

Give information about program and author.

cdrLabel Help Contents
Displays the help file, for when you're really stuck!

Check for New Version
Starts your web browser and loads the update information web page.

Order Form
Runs registration program to allow you to register via email, WWW, or postal mail.

Enter Registration Codes
Enter the codes returned with your registration.    Once completed allow customization of the spine 
initials.



Using the Printed Label
Cut out the label, it should be pretty obvious where to cut and where to fold.    Insert the label into your 
jewel case.    Admire just how cool it looks, and then go make some more!

If you've printed out a booklet label, cut out all the pages in the booklet, and use three staples along the 
left-hand side to secure them together.    If you're adventurous you can glue the sheets together instead of
stapling them, but this requires some practice to get right.

If you have access to a paper cutter you can add crop marks to the printed output to make it easier for 
you to cut.

Try using some colored, heavy-bond copier paper.    Packs of 5 colors can be bought at any office supply 
store, and make it very easy to classify your disks (i.e. RED for backups, GREEN for games, etc.)! 



Special Thanks
Thanks to the beta testers who tested the program with their own strange computer configurations.

The JPEG decoding routines are taken from JPEG-6a sources, and they'd like me to say: "this software is
based in part on the work of the Independent JPEG Group."    These guys make no warranty as to their 
JPEG decoder, and neither do I!

Greg Kochaniak is the author of the registration utility Kagi uses, and he's kind enough to give it away to 
all of us authors.

Thanks to all the registered users for their feedback and support.    Keep the suggestions    and bug 
reports coming in!



Bug Reports
If cdrLabel crashes on you, or doesn't print out correctly on your printer I'd like to hear about it.    Please 
make sure to include the following information to speed things up:
· Operating System
· Printer Type, Language(PCL, GDI, PS), Connection(network, local, etc)
· Series of operations to cause failure (if it's repeatable)

Just saying "cdrLabel crashed on me!" is about as useful as saying "My car's broken" to a mechanic over 
the phone. 



Future Directions
· Free rotation of images and text?
· In-place editing of strings, selecting of directories?
· Importing file icons?
· User suggestions, of course



How Do I…

How do I make a label as fast as possible, with the least fuss?
Use this program!    Just double-click on the label and the program will scan your disk.

The program isn't displaying anything after a period (.).    How do I change this?
You've got the Show Extensions menu option unchecked, and the program is hiding them.    
Check the Body->Show Extensions item.

How do I make the program scan my entire disk and not just the root directory?
Use the File->Directory Levels option and select how many levels you want to scan.    Be 
aware that scanning disks with many levels can take a long time.

How do I add a background picture of my baby/dog/girlfriend to my label?
Use the Add Image button in the toolbar, select a .BMP or .JPG of your tiny/furry/cute friend.    
You'll see the picture appear in the center of the label.    Now, right-click on the image and select 
Scale->Size To Body or Scale->Size To Label option.    The image will now fill your 
label.    Finally, put it under the text by right-clicking on the image once again, and using the 
Below Label option.

I have a LOT of files.    How can I catalog them all?
You've got several options:
· Use a booklet label, these may have many pages
· Increase the number of columns, possibly turning off extensions or file sizes
· Change the font for directories and folders to something smaller
· Hide directories you don't need to see

The program keeps reading my hard drive!    How can I make it scan my CD instead?
Use the File->Select Drive option.

How do I move a tiny image or string?
Hold down the SHIFT key when you're working with a block that's very small to tell the program 
you want to move the image or string, not resize it.

How do I make rotated text print properly on my Brother Laser printer?
Your printer's driver doesn't handle rotated text properly.    Tell it to let Windows to handle rotated 
fonts by checking the Download TrueType Fonts as Graphics from the printer's control panel.

How do I make certain types of files stand out?
Use the Fonts and Colors window to add pizzazz to special file types by changing their fonts or 
colors.    For example, you could make all your source files (.C, .H) green and all your executables
(.EXE, .DLL) blue.

How do I move the label's position on the printed page?
Use the File->Print Setup menu, and uncheck the Default Position box and enter X and Y 
offsets for the upper-left-hand corner of the label.

How do I thank you for this neat program?
Email me with suggestions for additions or improvements, and register. 

 



Subdirectory Selector
cdrLabel allows you to choose which directories it shows and which it hides with the Subdirectory 

Selector.    Bring it up by using the Body->Choose Subdirectories menu option or the  toolbar 
button.

· Double-click on a directory to open or close it.
· Closed directories contents are not shown.
· Use the Open All button to open up every folder
· Use the Close All to close every folder.

Note: If you want to actually delete folders, and files, use the Files and Folders Editor.



Files and Folders Editor
cdrLabel contains a graphical file and folder editor window.    Bring it up by using the Body-
>Edit Files and Folders menu or the  toolbar button.

The window is divided into two sections, a graphical tree representation of every file and folder displayed 
on your label; and a column of action buttons.

· Double-clicking on a directory will open or close it.
· Select a file with the mouse and use the Move Up and Move Down buttons to change it's position in 

the list.      Note, however, that you can only rearrange a file in it's own directory.
· Remove files you don't want to see on your label by the Delete button.    This will only change your 

label, and will NOT delete the file from your disk.
· Click where you'd like to insert a file and select the Add button to insert a new file.

Double-clicking on a file, or selecting the Change button will bring up an editor window allowing you to 
change it.

· The name and size sections of this new dialog are self explanatory.
· The comment section is the 8-character string that normally contains a text representation of a file's 

size.    (i.e. a file of 12,612 bytes has a comment of 12K).
· Use the Align combo-box to change an item's alignment in the column of files.



Comment Editor
Each label contains a single-line comment that may be hidden or shown.    This comment normally 
contains information about the disk free space and scan date, but is completely customizable.    Double 
click the comment text, use the Body->Edit Label Comment menu to bring up the editor.

There are three sections to this dialog, the editor where you can type a new comment, a line below that 
which shows how the entered comment will appear, and a series of macro buttons.

To set the label to a default comment, click the Default Data button.    This will give a handy summary of 
disk space free and used, as well as last scan date for your disks.    If you're scanning music CDs, click 
the Default Audio button which gives information useful for audio CDs.

These macro buttons are very powerful, and may be used to automatically customize each label with your
own comment line.

Comment Macros
The buttons on the bottom of the dialog insert macros, strings that will be replaced with calculated values 
automagically by the program.    Examine the comment in the shown dialog:

%spacefree% free, %spaceused% used    (%shortdate%)

And the sample line:

107.1M free, 386.8M used (4/12/98)

Note how the %spacefree% was replaced with the space free on the disk.    Here's what the macro 
buttons do:

Name Description Sample
Short Date Shorthand date (1/23/98)
Long Date Longhand date Monday, January 23, 1998
Space Free Space available on disk 10.3M
Space Used Space used by files on disk 87.9M
Files Number of files scanned from disk 185
Folders Number of directories scanned 32
% Free Percentage of disk empty 20.4%
% Used Percentage of disk used by files 82.0%

Adding Strings
cdrLabel allows the insertion of multiple-line strings anywhere on the label.    Up to 1,000 characters per 
string are allowed, and every feature of the string can be customized.    Bring up the string editor by 

double-clicking on a string, or create a new string via the String->Insert String menu or  
toolbar button.



Note: Whenever you make a change to a string you can immediately see how it looks on your label by 
clicking the Apply button.    You can also click the Apply button in any font or color pickers that 
appear from this window.

The largest part of this window consists of an area for entering the text of your string.    Type or paste up 
to 1,000 characters into this box.

Customize your string's appearance by using the other controls in this window.

· The two popup boxes, Horizontal and Vertical, control the alignment of your string within it's bounding 
box.

· Change the string's font, color, and background with the buttons along the bottom.
· Rotate the string in 90 degree increments with the orientation popup menu.

To have the program automagically size the string to fit all text without cutting any off, check the Auto Size
checkbox.    Unchecking this box will allow you to stretch the string's bounding box manually.

The Default button copies the current spine font and color to the string.



Fonts and Colors
cdrLabel supports customizing file display on a per-extension basis, through the use of the Fonts and 
Colors window. Use this window to change the fonts of files you want to stand out.    For example, a 
programmer could make all .C files green, all .CPP files blue, and all .JAVA files red.    Bring this window 

up by using the Body->Set Fonts and Colors menu or the  toolbar button.

The first four items in this list are fixed as Files, Folders, Comment, and Spine.
· Customize the fonts and colors used for all files and folders with the first two items, the comment line 

with the third, and the spine with the fourth.

Add additional file extensions by typing their extension in the edit box and clicking the Add button. 
· The extension will be added to the list, with it's font and color the same as normal files. 
· Use the color picker window to select a new color.
· Or, select the newly added extension and click the Font button to change it's font.

The Copy from Files or Copy from Folders duplicates the standard file or folder color and font into the 
currently selected extension.



ZipLabel
ZipLabel is a utility for creating labels for Zip disks.    It has the same easy interface as cdrLabel, but adds 
special features just for Zips.

You can download your copy of ZipLabel from the following web page, or from any large shareware 
archive.

http://www.geocities.com/CapeCanaveral/6552/ziplabel.html



Audio CD Support
cdrLabel can automagically catalog audio (music) CDs.    Unfortunately, music CDs do not have their 
song names digitally encoded on the disk, so you'll still have to enter the track names by hand in the "Edit
Files and Folders" dialog.    The individual tracks will be read as "Track x", and the comment will be the 
track's running length in mm:ss form.

Under Windows 3.1 it is only possible to catalog audio CDs present in the first CDROM drive, cdaudio, 
detected by the multimedia system.    All other versions of Windows do not have this limitation.

NOTE: For best results when cataloging Audio CDs, make sure cdrLabel's sorting mode is "Name" and 
"Ascending."

HINT: When cataloging music CDs the String capability is very handy for adding CD title and band 
information.    Use a BIG font for the front title!




